check-circle-line exclamation-circle-line close-line

VMware Tools 10.3.0 Release Notes

Updated on: 23 JUL 2018

VMware Tools | 12 JUL 2018 | Build 8931395

Check for additions and updates to these release notes.

What's in the Release Notes

The release notes cover the following topics:

What's New

  • VMware Tools 10.3.0 supports the following guest operating systems:
    • windows.iso supports Windows Vista and later. 
      • VMware Tools 10.3.0 depends on and ships Microsoft Visual C++ 2017 Redistributable version 14.0. While preparing the system for VMware Tools 10.3.0 installation, Microsoft Visual C++ 2017 Redistributable is installed on the system as a prerequisite. Installing or upgrading to VMware Tools 10.3.0 is not supported for Windows versions that do not meet the prerequisites and customers should continue to use VMware Tools 10.2.x or older until they can patch or update Windows OS to meet the prerequisites for VMware Tools 10.3.0. 
      • Windows OS level prerequisites
        • Windows Server 2016
        • Windows 10
        • Windows Server 2012 R2
        • Windows 8.1
        • Windows Server 2012
        • Windows 8
        • Windows Server 2008 R2 Service Pack 1 (SP1)
        • Windows 7 SP1
        • Windows Server 2008 Service Pack 2 (SP2)
        • Windows Vista SP2
        • Windows Server 2012 R2 with Microsoft update KB2919355
        • Windows 8.1 with Microsoft update  KB2919355
    • linux.iso supports Linux guest operating systems Red Hat Enterprise Linux (RHEL) 5 and later, SUSE Linux Enterprise Server (SLES) 11 and later, Ubuntu 10.04 and later. It also supports other distributions with glibc versions 2.5 and later.
    • darwin.iso supports Mac OS X versions 10.11 and later.
    • solaris.iso supports Solaris versions.
  • Integration of VMware AppDefense with VMware Tools: VMware Tools installation includes the VMware AppDefense, a security management, and monitoring solution. This data center security solution is based on application control, detection, and response. For more information, see the VMware Tools User Guide.
  • Changes in the OpenGL driver: OpenGL driver has been updated for bug fixes and performance improvements
    • Vertex buffer object (VBO) optimization
    • Display list drawing optimization
  • Changes in the VMXNET3 driver: Receive data ring support for the Windows VMXNET3 driver.
  • VMware Tools lifecycle using driver update from Windows Update server: This integration will allow you to update the PVSCSI driver during a Windows update. This feature supports PVSCSI for Windows Server 2016 only.
  • Shared folders: FUSE-based Shared Folders client which is used as a replacement for the kernel mode client supports Linux distributions with kernel version 3.10 and later.
  • VMware Tools user space compiler upgrade: Compiler for VMware Tools 10.3.0 for Windows has been upgraded to Microsoft Visual Studio 2015.
  • Resolved Issues: This release of VMware Tools resolves few issues which are documented in the Resolved Issues section of this release notes.

Earlier Releases of VMware Tools

  • For earlier releases of VMware Tools, see the VMware Tools Documentation page.

Before You Begin

Important note about upgrading to VMware Tools 10.3.0

Installing or upgrading to VMware Tools 10.3.0 is not supported for Windows versions that do not meet the prerequisites. Users are recommended to use VMware Tools 10.2.x or older until Windows OS is updated to meet the prerequisites for VMware Tools 10.3.0.

NOTE: VMware Tools 10.3.0 for Windows installs Microsoft Visual C++ 2017 Redistributable version 14.0 on the system which might need a system restart. Windows users are highly recommended to plan for a system restart before installing or upgrading to VMware Tools 10.3.0.

VMware Tools ISO images are frozen for some end of life guest operating systems. Some ISO images are not included with ESXi in the tools-light VIB. For more details, see the VMware Tools Documentation page. All VMware Tools ISO images are available for download from http://my.vmware.com.

VMware Tools for Windows: 32-bit and 64-bit installer executable (.exe) files are available for download. These files are provided for easier access and installation of VMware Tools in Windows guest operating systems.

When a newer version of vmtoolspkg VIB is installed, VMware Tools status might not change. This limitation is observed in vSphere 5.5.x and update releases. To work around, power off and power on the VM or reboot the host.

Important note about upgrading to ESXi 5.5 Update 3b or later

Resolution on incompatibility and general guidelines: While upgrading ESXi hosts to ESXi 5.5 Update 3b or ESXi 6.0 Update 1 or later, and using older versions of Horizon View Agent, refer to the knowledge base articles:

Internationalization

VMware Tools 10.3.0 is available in the following languages:

  • English
  • French
  • German
  • Spanish
  • Italian
  • Japanese
  • Korean
  • Simplified Chinese
  • Traditional Chinese

Product Support Notice

The Windows pre-Vista iso image for VMWare Tools is no longer packaged with ESXi. The Windows pre-Vista iso image is available for download by users who require it. For download information, see the Product Download page.

Compatibility Notes

  • Starting with VMware Tools version 10.2.0, Perl script-based VMware Tools installation for FreeBSD has been discontinued. FreeBSD systems are supported only through the open-vm-tools packages directly available from FreeBSD package repositories. FreeBSD packages for open-vm-tools 10.1.0 and later are available from FreeBSD package repositories.

Guest Operating System Customization Support

The Guest OS Customization Support Matrix provides details about the guest operating systems supported for customization.

Installation and Upgrades for this release

VMware Tools can be downloaded from the Product Download page.

VMware Tools Operating System Specific Packages can be downloaded from http://packages.vmware.com/tools/releases/index.html. For more information on installing OSPs, see the VMware Tools Installation Guide for Operating System Specific Packages for ESXi versions 5.x and 6.x.

The steps to install VMware Tools vary depending on your VMware product and the guest operating system you have installed. For general steps to install VMware Tools in most VMware products, see General VMware Tools installation instructions (1014294).To set up productLocker to point to the shared datastore, see KB 2004018.

For specific instructions to install, upgrade, and configure VMware Tools, see the VMware Tools Documentation page.

Windows guest drivers installed by VMware Tools

VMware Tools 10.3.0 supports the following driver versions on a Windows Guest Operating System.

Drivers VMware Tools 10.3.0
Hardware Drivers
vmci

9.8.6.0

vsock

9.8.12.0

pvscsi

1.3.10.0

wddm

8.16.1.0

xpdm

12.1.8.0

vmxnet3

1.8.3.0

vmxnet2

2.2.0.0

vmmouse

12.5.7.0

vmusbmouse

12.5.7.0

vmaudio

5.10.0.3506

efifw 1.0.0.0
vmaudio

5.10.0.3506

Software Drivers
vmrawdsk.sys

1.1.1.0

vmmemctl.sys

7.4.2.0

vmhgfs.sys

11.0.34.0

vsepflt.sys

10.3.0.0

vnetflt.sys

10.2.5.0 (For Kernel-Mode Code Signing, Windows Vista and Windows 2008)

vnetWFP.sys 

10.3.0.0 

glgxi.sys
1.2.1.0
(Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, and Windows Server 2016)

Resolved Issues

  • Repair option is removed from the Control Panel of VMware Tools installer.

    Repair option is replaced with Change option in the Control Panel of VMware Tools installer.

    This issue is resolved in this release.

  • Process ID of a discontinued VMware Tools service might get reused immediately by the system.

    On Linux and UNIX like operating systems, the process id (PID) of a stopped VMware Tools service might get reused immediately by the system. As a result, the new process might get aborted by the VMware Tools service init script. 

    If this occurs during a system shutdown, the fallacious 'kill' operation of the other process with the same (reused) PID might affect the orderly shutdown of another system service.

    This issue is resolved in this release.

  • The VMware Tools process might take a long time and consume 100% CPU of a core in a Linux OS with many IPv6 routes

    Prior to VMware Tools 10.3.0, gathering network adapter information in a Linux guest OS with many IPv6 routes was a time-consuming process with 100% use of the CPU of a core. The exported data contained only a maximum of 100 routes. IPv4 routes took precedence over IPv6, leading to data loss in reporting IPv6 routes. If there were more than 100 IPv4 routes, IPv6 routes were not reported.

    This performance issue has been resolved in this release. The default routes gathering behavior can be overridden by configuring the values in the /etc/vmware-tools/tools.conf file:

    [guestinfo]
    max-ipv4-routes=0
    max-ipv6-routes=0


    Note: If they are not manually set or an invalid value (over 100 or less than 0) is set, 'max-ipv4-routes' and 'max-ipv6-routes' is set to 100 by default. It can be set to 0 to disable the data collection.

    This issue is resolved in this release.

  • Installation of the libvmtools package might fail the installation of VMware Tools

    When the package "libvmtools0" is installed in SUSE Linux 12 and open-vm-tools is not installed, the VMware Tools installer fails. This is set to prevent an incomplete installation. Users have to uninstall both open-vm-tools and libvmtools0 to install VMware Tools.

    This issue is resolved in this release.

Known Issues

  • AppDefense driver glxgi logs an error in the event viewer.

    AppDefense driver glxgi logs an error in the event viewer similar to the following:

    "The glxgi service failed to start due to the following error: A device attached to the system is not functioning."

    The events are observed when,

    • Guest Integrity is disabled
    • AppDefense driver glxgi attempts to start after installation.

    Workaround: None. These events do not impact the system and are safe to ignore.

  • VMware Tools is incompatible with additional LSA protection

    The Windows OS component Local Security Authority (LSA), which includes the Local Security Authority Server Service (LSASS) process, validates users for local and remote sign-ins and enforces local security policies. 
    The Windows operating system provides additional protection for the LSA to prevent security attacks. When this feature is enabled, any LSA plugin must be signed with the file signing service for Local Security Authority (LSA). VMware Tools installs an LSA plugin called vmwsu_v1_0.dllwhich is not signed in the required manner and fails to load when RunAsPPL is enabled in LSA configuration. An error message similar to the following is displayed.

    ******************************************************************
    * This break indicates this binary is not signed correctly: \Device\HarddiskVolume4\Windows\System32\VMWSU_V1_0.DLL

    * and does not meet the system policy.

    * The binary was attempted to be loaded in the process: \Device\HarddiskVolume4\Windows\System32\lsass.exe

    * This is not a failure in CI, but a problem with the failing binary.

    * Please contact the binary owner for getting the binary correctly signed.

    ******************************************************************

    Workaround: None.

  • VMware Tools package fails to complete the installation.

    While installing VMware Tools by running the setup command, a dialog box appears which displays a progress bar. This dialog box displays the progress of the installation of the VC 2017 redistributable package which is used by VMware Tools. The VC 2017 redistributable package installation does not complete, preventing the launch of the general VMware Tools installation dialog box.

    The VMware Tools installation logs can be found in the temporary folder in the path similar to the following:

     %temp%\vminst.log and %temp%\vmmsi.log

    The issue is observed with Windows Vista Service Pack 2 operating system which has Microsoft Document Explorer 2008 package installed when VMware Tools installs the Microsoft VC 2017 redistributable package.

    Workaround: To install VMware Tools, 

    1. Uninstall the Microsoft Document Explorer 2008 package from the Windows Vista Service Pack 2 operating system. 
    2. Install or upgrade VMware Tools by running the setup again.
  • Event Viewer driver warnings generated by VMware Tools boot start drivers glxgi, pvscsi, vsepflt, and vsock. 

    When you have a secure boot VM with Microsoft Hyper-V and virtualization-based security enabled with Device Guard and Code Integrity policy set to enforced, then drivers, glxgi, pvscsi, vsepflt, and vsock might generate the event log warnings similar to the following.

    Log Name:      Microsoft-Windows-CodeIntegrity/Operational
    Source:        Microsoft-Windows-CodeIntegrity

    Operational Log:

    Warnings 

    Event ID:      3083    
    Level:         Warning

    Description:
    Code Integrity determined kernel module system32\DRIVERS\vsock.sys that did not meet the WHQL requirements is loaded into the system.
    Check with the publisher to see if a WHQL compliant kernel module is available. 

    Workaround: None. These warnings are safe to ignore. The drivers load and operate in the normal manner.

  • Drag functionality fails to work in Ubuntu

    Drag functionality fails to work in Ubuntu 16.04.4 32-bit virtual machine installed using easy install. Also, failure of copy and paste functionality is observed in the same system.

    Workaround:

    • Add the modprobe.blacklist=vmwgfx linux kernel boot option.
    • To gain access to larger resolutions, remove svga.guestBackedPrimaryAware = "TRUE" option from the VMX file,
  • Applications fail to start after upgrading to VMware Tools 10.3.0.

    During installation or post-installation of VMware Tools, the application fails with an error:
    The program can't start because msvcr71.dll is missing from your computer

    You might see similar messages with DLLs ending with  mfc71.dll, 90.dll after upgrading to VMware Tools 10.3.0

    This issue may occur when failed third-party applications did not add a dependency reference count on these DLLs at installation time.

    Workaround:

    In both cases, the Visual C++ runtime installers can be run before or after upgrading.

  • Shared Folders mount is unavailable on Linux VM

    If the Shared Folders feature is enabled on a Linux VM while it is powered off, shared folders mount is not available on restart.

    Workaround: If the VM is powered on, disable and enable the Shared Folders feature from the interface.

    For resolving the issue permanently, edit /etc/fstab and add an entry to mount the Shared Folders automatically on boot.

    For example, add the line:

    vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

  • The knowledge base article link that is displayed to the user on the dialog box is not clickable.

    Installing or upgrading of VMware Tools to 10.3.0 fails on Windows if operating system pre-requisites are not met, or the VMware Tools dependency on Microsoft VC runtime package cannot upgrade without a system reboot. A dialog box is displayed to the user which specifies the URL to a knowledge base article. This article cannot be accessed by clicking the link directly.

    Workaround: Copy and paste the URL text to a browser and navigate to the article.

  • Installing or upgrading to VMware Tools 10.3.0 might take longer and Windows OS might need a restart.

    Installation process might appear to be in progress and displays a message similar to the following:
    "Preparing 'VMware Tools' for installation..."

    During this process, the user might be prompted to restart the operating system. 

    Workaround: For more information, see KB 55798.