Updated on: 23 SEP 2021

VMware Tools | 23 SEP 2021 | Build 18557794

Check back for additions and updates to these release notes.

What's in the Release Notes

The release notes cover the following topics:

What's New

  • For issues resolved in this release, see Resolved Issues section.
  • libxml2 version is updated to 2.9.12.
  • openssl version is updated to 1.1.1l.

Earlier Releases of VMware Tools

  • For earlier releases of VMware Tools, see the VMware Tools Documentation page.

Before You Begin

  • VMware Tools 11.3.5 supports the following guest operating systems:
    • windows.iso supports Windows 7 SP1 or Windows Server 2008 R2 SP1 and later. 
      • The Microsoft Visual C++ Redistributable package is a prerequisite for installing VMware Tools for Windows 11.3.5 and ships with the VMware Tools 11.3.5 download package. While preparing a Windows guest for installation, VMware Tools runs the Microsoft Visual C++ Redistributable Package installer which checks for the presence of a more recent version on the guest. If the guest has a more recent version already present, the package does not install.
        For a 32-bit Windows guest, the prerequisite version is Microsoft Visual C++ 2015-2019 Redistributable (x86) version 14.28.29913.0.
        For a 64-bit Windows guest, the prerequisite versions are Microsoft Visual C++ 2015-2019 Redistributable (x86) version 14.28.29913.0 and Microsoft Visual C++ 2015-2019 Redistributable (x64) version 14.28.29913.0.
      • Installing or upgrading to VMware Tools 11.3.5 is not supported for Windows versions that do not meet the prerequisite. Customers should continue to use VMware Tools 10.2.x or older until they can patch or update their Windows OS to meet the prerequisites for VMware Tools 11.3.5. Refer to Microsoft's update KB2977003 for latest supported Visual C++ downloads.
      • Windows OS level prerequisites
        • Windows Server 2019
        • Windows Server 2016
        • Windows 10
        • Windows Server 2012 R2 with Microsoft's update KB2919355
        • Windows 8.1 with Microsoft's update  KB2919355
        • Windows Server 2012 
        • Windows 8
        • Windows Server 2008 R2 Service Pack 1 (SP1) with Microsoft's update KB4474419.
        • Windows 7 Service Pack 1 (SP1) with Microsoft's update KB4474419.
    • darwin.iso supports Mac OS X versions 10.11 and later.
    • For details on linux.iso, refer to VMware Tools 10.3.23 Release Notes.
    • For details on solaris.iso, refer to VMware Tools 10.3.10 Release Notes.
  • VMware Tools ISO images are frozen for some end of life guest operating systems. Some ISO images are not included with ESXi in the tools-light VIB. For more details, see the VMware Tools Documentation page. All VMware Tools ISO images are available for download from http://my.vmware.com.
  • VMware Tools for Windows: 32-bit and 64-bit installer executable (.exe) files are available for download. These files are provided for easier access and installation of VMware Tools in Windows guest operating systems.

Important note about upgrading to ESXi 6.5 or later

Resolution on incompatibility and general guidelines: While upgrading ESXi hosts to ESXi 6.5 or later, and using older versions of Horizon View Agent, refer to the knowledge base articles:

Internationalization

VMware Tools 11.3.5 is available in the following languages:

  • English
  • French
  • German
  • Spanish
  • Italian
  • Japanese
  • Korean
  • Simplified Chinese
  • Traditional Chinese

Product Support Notice

  • The Windows pre-Vista iso image for VMWare Tools is no longer packaged with ESXi. The Windows pre-Vista iso image is available for download by users who require it. For download information, see the Product Download page.

End of Feature Support Notice

  • After VMware Tools 11.3.5 version, the subsequent releases will no longer support the "VMXNET 2 (Enhanced)" Network Adapter by providing the VMXNet NIC Driver.
    For users who have configured a virtual machine with the "VMXNET 2 (Enhanced)" adapter running Windows Server 2008 R2 version of windows, switching to the VMXNET3 Network adapter is recommended.
  • The Balloon driver has been removed from MacOS VMware Tools 11.1.0.
  • The tar tools (linux.iso) and OSPs shipped with VMware Tools 10.3.x release will continue to be supported. However, releases after VMware Tools 10.3.5 will only include critical and security fixes. No new feature support will be provided in these types of VMware Tools (tar tools and OSP's). It is recommended that customers use open-vm-tools for those operating systems that support open-vm-tools. For more information on different types of VMware Tools, see https://blogs.vmware.com/vsphere/2016/02/understanding-the-three-types-of-vm-tools.html

Compatibility Notes

  • Starting with VMware Tools version 10.2.0, Perl script-based VMware Tools installation for FreeBSD has been discontinued. FreeBSD systems are supported only through the open-vm-tools packages directly available from FreeBSD package repositories. FreeBSD packages for open-vm-tools 10.1.0 and later are available from FreeBSD package repositories.

Guest Operating System Customization Support

The Guest OS Customization Support Matrix provides details about the guest operating systems supported for customization.

Interoperability Matrix

The VMware Product Interoperability Matrix provides details about the compatibility of current and earlier versions of VMware Products.

Installation and Upgrades for this release

VMware Tools can be downloaded from the Product Download page.

The steps to install VMware Tools vary depending on your VMware product and the guest operating system you have installed. For general steps to install VMware Tools in most VMware products, see General VMware Tools installation instructions (1014294).To set up productLocker to point to the shared datastore, see KB 2004018.

This release provides packages to upgrade VMware Tools 11.2.5 or later deployments using GuestStore.

For specific instructions to install, upgrade, and configure VMware Tools, see the VMware Tools Documentation page.

Windows guest drivers installed by VMware Tools

VMware Tools 11.3.5 supports the following driver versions on a Windows Guest Operating System:

Drivers VMware Tools 11.3.5
Hardware Drivers
efifwfromhost.bin

1.0.0.0

pvscsi.sys

For Windows 7 and Windows Server 2008 Release 2:  1.3.15.0

For Windows 8, Windows 8.1, Windows 10, Windows Server 2012, Windows Server 2012 Release 2, Windows Server 2016, and Windows Server 2019:  1.3.17.0

vmaudio.sys

5.10.0.3506

vmci.sys

9.8.16.0

vmmouse.sys

12.5.10.0

vmusbmouse.sys

12.5.10.0

vmxnet.sys

2.2.0.0

vmxnet3.sys

1.9.2.0

vm3dmp.sys

8.17.03.0005

Software Drivers
giappdef.sys

2.3.1.0

glgxi.sys

2.3.0.0

vmhgfs.sys

11.0.42.0

vmmemctl.sys

7.5.5.0

vmrawdsk.sys

1.1.5.0

vnetWFP.sys

11.3.0.0

vsepflt.sys

11.3.5.0

vsock.sys

9.8.17.0

Security DLL
vmwsu.dll

2.5.0.0

Resolved Issues

  • VMware Tools installer can fail when a VMware Tools upgrade overlaps with the Windows system updates.

    In a Windows VM, if a VMware Tools upgrade overlaps with an in-progress Windows system update that required a system reboot on restart of a VM, it causes some VMware kernel drivers not to upgrade and fail with Windows system error (0x800f0246). As a result of this error, VMware Tools installer rolls back the upgrade, and removes VMware Tools along with upgraded VMware kernel drivers from the guest.

    This issue is fixed in this release.

    The VMware Tools 11.3.5 and later installer handles this system error condition by displaying a message to the end-user, then allows the install to proceed.  
    After upgrade completion, including any system restart, run the VMware Tools installer and select the repair option to replace any drivers that failed to upgrade.
    For further details, go to https://kb.vmware.com/s/article/83949.

  • Applications do not run after upgrading to VMware Tools 11.0.0.

    Applications may not run correctly when unable to query the graphics memory size from the registry. This can occur in rare cases when an application either requests the AdapterRAM information from WMI or directly from the Windows registry.

    This issue is fixed in this release.

Known Issues

The known issues are grouped as follows.

VMware Tools Issues
  • VMware Tools upgrade failed with error code 1072 (The specified service has been marked for deletion.)

    When upgrading VMware Tools to a new version, if the previous version's VMware Tools service is not deleted completely, this incomplete service removal causes installing the new VMware Tools version service to fail and leads to a fatal error for the upgrade.

    When detecting an incomplete service removal to prevent VMware Tools upgrade from failing catastrophically every time, the new service creation will pause and retry to see if the condition clears. The VMware Tools installer will pause for up to 2 1/2 minutes. After this, a fatal error will occur. If the condition clears, the upgrade creates the new service and continues.

    For more information, see https://kb.vmware.com/s/article/84269.

    Workaround:

    Retry installing VMware Tools.

  • After upgrading to a new version VMware Tools with an installer parameter to remove the NetworkIntrospection feature, the old version of the vnetflt or vnetWFP driver service continues to run.

    After the upgrade, the NetworkIntrospection feature is not present in the system's VMware Tools MSI database, but the feature's vnetflt or vnetWFP driver service still exists.

    Workaround:

    Refer to KB 78016

    Note: Future tools upgrade from version 11.1.0 to a newer tools version will not have the issue.

  • VMware Tools upgrade fails on Windows 7 SP1 and Windows Server 2008 R2 SP1 without SHA-2 code signing support.

    Microsoft has changed Windows driver signing to use the SHA-2 algorithm exclusively starting December 3, 2019. Legacy Windows systems without SHA-2 code signing support fail driver signature verification.

    Workaround:

    Refer to KB 78708.

  • AppDefense driver glxgi logs an error in the event viewer.

    AppDefense driver glxgi logs an error in the event viewer similar to the following:

    "The glxgi service failed to start due to the following error: A device attached to the system is not functioning."

    The events are observed when Guest Integrity is disabled.

    Workaround:

    These events do not impact the system and are safe to ignore.

  • Installing or upgrading versions earlier than VMware Tools 10.3.0 to VMware Tools 11.1.x might take longer and Windows OS might need a restart.

    Installation process might appear to be in progress and displays a message similar to the following:
    "Preparing 'VMware Tools' for installation..."

    During this process, the user might be prompted to restart the operating system. 

    For more information, see KB 55798.

VMware Tools Issues in VMware Workstation or Fusion
  • Shared Folders mount is unavailable on Linux VM.

    If the Shared Folders feature is enabled on a Linux VM while it is powered off, the shared folders mount is not available on restart.

    Note: This issue is applicable to VMware Tools running on Workstation and Fusion.

    Workaround:

    If the VM is powered on, disable and enable the Shared Folders feature from the interface. For resolving the issue permanently, edit /etc/fstab and add an entry to mount the Shared Folders automatically on boot.

    For example, add the line:

    vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

  • Drag functionality fails to work in Ubuntu.

    Drag functionality fails to work in Ubuntu 16.04.4 32-bit virtual machines installed using Easy Install. Also, failure of the copy and paste functionality is observed in the same systems.

    Note: This issue is applicable to VMware Tools running on Workstation and Fusion.

    Workaround:

    • Add the modprobe.blacklist=vmwgfx linux kernel boot option.
    • To gain access to larger resolutions, remove svga.guestBackedPrimaryAware = "TRUE" option from the VMX file.
VMware Tools Issue in VMware Horizon
  • WDDM driver fails on Windows Update installation when Horizon Agent is installed on W8/8.1/WS2008R2.

    When Horizon Agent is installed on W8/8.1/WS2008R2, the WDDM driver fails on Windows Update installation.

    The WDDM driver will be made available through Windows Update service, when the driver publication process completes.

check-circle-line exclamation-circle-line close-line
Scroll to top icon