A mismatch between the configurations of the Citrix server farm and Workspace ONE Access might cause the launch of Citrix-published resources to fail.

Problem

Launching a Citrix-published resource fails as the browser displays 500 Internal Server Error.

Cause

A 500 error occurs when the Citrix server farm information provided in the Workspace ONE Access console does not match the Citrix server configuration.

Solution

  1. Note the settings of the transport type, port number, and SSL relay port number of each server farm integrated with your Workspace ONE Access deployment.
  2. Log in to the Workspace ONE Access console.
  3. Select the Catalog > Virtual Apps Collections tab.
  4. Click the Citrix virtual apps collection, then click Edit.
  5. In the Edit Citrix XenApp Collection wizard, click Server Farm in the left pane, then click the server farm to edit.
  6. Under Launch Preference, Web Interface SDK, change the Transport Type, Port, and SSL Relay Port settings to match the settings in your Citrix server configuration.
  7. Click Save.
  8. Repeat these steps to modify the settings for each server farm.