Use this information to troubleshoot the Horizon 7 or Horizon 6 configuration in Workspace ONE Access.

Users Unable to Launch Horizon Applications or Desktops

Users are unable to launch Horizon 7 or Horizon 6 applications or desktops from the Workspace ONE Access catalog.

Problem

Users are unable to launch Horizon 7 or Horizon 6 applications or desktops from the VMware Workspace ONE Access user portal and the following error appears in the user interface:

Error launching resource. Please contact your IT Administrator.

Cause

This error might occur if the SAML metadata on the Horizon Connection Server instances expired after the last sync.

Solution

  1. In the Workspace ONE Access console, click the Catalog > Virtual Apps Collections tab.
  2. Select the Horizon virtual apps collection and click Sync to sync Horizon resources to VMware Workspace ONE Access again.