Citrix resource sync fails if the Limited Visibility Group setting is selected and if it does not contain any AD users or groups.

Problem

In XenDesktop and XenApp 7.9 and later, if the Limited Visibility Group setting is selected and if it does not contain any users or groups, sync to Workspace ONE Access fails.

Cause

If set, the Limited Visibility Group must contain users or groups.

Solution

  1. Find the actual name of the application by running the following PowerShell command:
    asnp citrix*

    Get-brokerapplication-browsername nameOfCitrixPublishedResource

    In the application detail that is displayed, look for the name of the application.

  2. In Citrix Studio, find the application with that name, edit the Limited Visibility property, and add users and groups to the list.