Citrix entitlements do not appear in Workspace ONE Access.

Problem

Entitlements to an application or delivery group are set on the Citrix server but they do not appear in Workspace ONE Access.

Cause

Users and groups that are entitled to the application or delivery group might not be synced to Workspace ONE Access.

Solution

Ensure that the users and groups are synced to Workspace ONE Access.
  1. Log in to the Citrix Management Console and locate the application that does not have any entitlements.
  2. Make a note of the Active Directory users and groups that have permissions to launch the application in the Citrix Management Console.
  3. Log in to the Workspace ONE Access console, navigate to the Accounts > Users and Accounts > User Groups pages, and verify that the users and groups appear in the lists.
  4. If the users and groups exist in Workspace ONE Access, sync Citrix resources again from the Resources > Virtual Apps Collections page.
    Note: The users and groups must exist in Workspace ONE Access before you sync Citrix resources. If they do not exist, the sync runs but entitlements are not updated.
  5. If the users and groups do not exist in Workspace ONE Access, perform these actions.
    1. Check where the users and groups exist in Active Directory (using Active Directory Users and Computers Snap-in).
    2. In the Workspace ONE Access console, update the AD Sync DNs for the users and groups in the directory's Sync Settings pages.
    3. When the users and groups appear in the Workspace ONE Access console, sync Citrix resources again.

    When sync completes, the entitlements appear in Workspace ONE Access.