Users are unable to launch applications from the Workspace ONE portal or the wrong authentication method is applied in a load-balanced environment.

Problem

In a load-balanced environment, problems such as the following might occur:
  • Users are unable to launch applications from the Workspace ONE portal after they log in.
  • The wrong authentication method is presented to users for step-up authentication.

Cause

These problems can occur if access policies are determined incorrectly. The client IP address determines which access policy is applied during login and during application launch. In a load-balanced environment, VMware Identity Manager uses the X-Forwarded-For header to determine the client IP address. In some cases, an error might occur.

Solution

Set the service.numberOfLoadBalancers property in the runtime-config.properties file in each of the nodes in your VMware Identity Manager cluster. The property specifies the number of load balancers fronting the VMware Identity Manager instances.

Note: Setting this property is optional.
  1. Log in to the VMware Identity Manager appliance.
  2. Edit the /usr/local/horizon/conf/runtime-config.properties file and add the following property:

    service.numberOfLoadBalancers numberOfLBs

    where numberOfLBs is the number of load balancers fronting the VMware Identity Manager instances.

  3. Restart the workspace appliance.

    service horizon-workspace restart