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Product Provisioning 1
Workspace ONE UEM powered by AirWatch enables you to create and deliver products, which contain 
device profiles, applications, and platform-specific installation instructions and conditions. These products 
follow a set of rules, schedules, and dependencies as guidelines for ensuring your devices remain up-to-
date with the content they need.

Product provisioning encompasses the use of a relay server, which is an FTP(S) server designed to work 
as a go-between for devices and the UEM console. Create these servers for each store or warehouse to 
store content to distribute to your devices.

Another product provisioning feature is the staging methods of enrollment. Depending on the device type, 
you can perform device staging that quickly enrolls a device and downloads the Workspace ONE 
Intelligent Hub, Wi-Fi profile, and any other important content. The methods of staging a device vary by 
platform.

As this guide focuses on the functionality provided by product provisioning, it does not contain all the 
features and functionality that Workspace ONE UEM offers for managing devices of any specific platform.

Visit docs.vmware.com and search for the Platform Guide of your choice. For more information on 
general MDM and UEM console functionality, see the Managing Devices Documentation and Console 
Basics Documentation available on docs.vmware.com.

This chapter includes the following topics:

n Supported Devices, OS, and Agents, Product Provisioning

Supported Devices, OS, and Agents, Product Provisioning
The product provisioning functionality in Workspace ONE UEM powered by AirWatch supports different 
devices and operating systems. The available functionality changes based on the supported rugged 
device.

Workspace ONE UEM supports product provisioning for devices with the following operating systems.

Android
n Android Legacy devices running Android 4.1 (Jelly Bean) and later with Workspace ONE Intelligent 

Hub.

n Zebra devices running Android 4.4 (Kit Kat) and later.
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n Android Enterprise Work Managed devices running Workspace ONE Intelligent Hub.

macOS
n macOS 10.7 Lion+ devices:

n MacBook Pro

n MacBook Air

n Mac Mini

n iMac

n Mac Pro

QNX Devices
n QNX 6.5 devices.

Windows Desktop, Windows 7, and Windows Rugged
n Windows CE 5, 6, and 7.

n Windows Mobile 5.x/6.1/6.5 (Professional and Standard).

n Windows Embedded 6.5.

n Motorola and Zebra Windows Rugged devices require the Rapid Deployment Client v2.0+.

n Windows 7 (32 bit and 64 bit).

n Windows 10 devices with Workspace ONE Intelligent Hub installed.
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Relay Servers 2
Relay servers act as a content distribution node that provides more bandwidth and data use control in 
Workspace ONE UEM powered by AirWatch. Relay servers act as a proxy between the Workspace ONE 
UEM server and the rugged device for product provisioning.

Source Server Versus Relay Server
A source server is the original location of the data, usually a database, or content repository. After the 
data is downloaded from the source server to the UEM console, it is then transferred to the relay server. 
The data is then downloaded from the relay server to devices.

Relay Server Basics
The relay server acts as an FTP/Explicit FTPS/SFTP server that distributes products to the device for 
download and installation. You can distribute to all devices without consuming all the bandwidth to the 
main/central MDM server. There are two ways the files are sent from the Workspace ONE UEM console, 
Push and Pull.

n Push Relay Servers.

This method is typically used in on-premises deployments. The UEM console pushes content and 
applications contained in the product or staging to the relay server. SaaS customers interested in 
push relay servers must configure a public DNS to make the relay server available, and allows the 
Workspace ONE UEM server to open the required connection to send the files.

n Pull Relay Servers.

Typically used in SaaS deployments, a pull service is installed on the relay server and monitors the 
UEM console for files to be downloaded. When it finds some, it downloads content and applications 
(whether provisioned or staged) to the FTP home directory through an outbound connection. This 
option is ideal because the pull service itself opens the HTTPS connection to the UEM console, 
making the need for a public connection unnecessary.

FTP and FTPS servers must be compliant with RFC 959 and RFC 2228 set by the Internet Engineering 
Task Force.
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Relay servers are required for Motorola Rapid Deployment Barcode Enrollment, supported by Android 
and Windows Rugged. Otherwise, relay servers are optional but useful for pushing products to 
downloaded applications and content – as opposed to downloading directly from the server that hosts the 
Workspace ONE UEM console.

Relay servers also add redundancy through the fallback feature. If a device's relay server is down, the 
device falls back to the next relay server in the hierarchy system until it finds a working server or connects 
to the Workspace ONE UEM console server.

If you are not using a relay server, the device downloads applications and content directly from the UEM 
console server.

Relay Server and Job Status Updates
Relay servers greatly enhance the performance in a product provisioning environment, however, they 
complicate the task of reporting the status of a job. For more information, see Product Job Statuses.

Relay Server List View
Navigate to Devices > Provisioning > Relay Servers > List View to see all the push and pull relay 
servers in your environment. After creating a relay server, refresh the relay server list view to get the 
status of the connection.

The Source Server and Relay Server statuses are defined as follows:

Indicator Source Server Relay Server

Last retrieval from server succeeded. Last file sync with server succeeded.

Retrieval from a server is in progress. File sync with a server is in progress.

Last retrieval failed. Last file sync failed.

Once the check mark displays for both source server and relay server, the product components are 
available to distribute to the end-user device.

Product Provisioning
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Advanced Info
You can access the Advanced Info action for more detailed information pertaining to the server. This 
action can be found in the More Actions options drop-down available after selecting a relay server. The 
Advanced Info action displays the Queued Count of files, the Last Error Code displayed, and the Last 
Error Description.

This chapter includes the following topics:

n Configure a Relay Server

n Batch Import Relay Servers

n Pull Service Based Relay Server Configuration

n View Remote Files on Relay Server

Configure a Relay Server
Configure a relay server for product provisioning by selecting an FTP, Explicit FTPS, Implicit FTPS (Pull 
only), SFTP file server, or HTTPS protocol and integrating it with Workspace ONE UEM powered by 
AirWatch.

Important   If you use the pull service to create a pull-based relay server, you must give the home 
directory full SYSTEM access. This configuration means the pull service stores and removes files from 
the directory.

Client-server applications such as Workspace ONE UEM use the transport layer security (TLS) 
cryptographic protocol to communicate across a network. Three transfer protocols support TLS. The file 
transfer protocol (FTP), the file transfer protocol over SSL (FTPS), and the SSH file transfer protocol 
(SFTP).

These file transfer protocols only secure those parts of the process where data is in transit between the 
client and the server. Because of this limitation, use an OS-level disk encryption. There are several 
operating system-specific tools available (for example BitLocker for Windows, GnuPG for Linux).

Product Provisioning
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Prerequisites

Only Android supports Implicit FTPS relay servers instead of Explicit FTPS relay servers and only in a pull 
configuration. Workspace ONE UEM console is not compatible with Implicit FTPS Push Relay Servers.

n An FTP, Explicit FTPS, Implicit FTPS in Pull configuration (Android only), or SFTP server.

n Pull service bandwidth needs and minimum hardware requirements are negligible when 
compared to pushing products to devices. Such needs are entirely dependent upon 1) the 
number of products you are pushing, 2) how often they are pushed, and 3) the size of the 
products in MBs.

n When assessing hardware and bandwidth needs for FTP servers, consider following general 
guidelines and adjust their specifications as your needs change.

n General FTP Server Guidelines: 2 GHz x86 or x64 processor and 4 GB RAM.

n You must create an FTP user with a home directory. This user must have read/write/delete 
permissions for both the directory and the files used in the relay server. This FTP user must have a 
user name and password for authentication.

n Workspace ONE UEM supports SFTP servers, however, the supported staging clients, Stage Now 
(Android), and Rapid Deployment, do not support SFTP servers for use with barcode staging.

n If selecting an HTTPS protocol (pull configuration only), you must configure the HTTPS endpoint 
using the web server configuration tool of choice (for example, IIS). The root directory you opt in the 
web server config must be the same as the Pull Local Directory of the relay server.

n FTP and FTPS servers must be compliant with RFC 959 and RFC 2228 set by the Internet 
Engineering Task Force.

Procedure

1 Navigate to Devices > Provisioning > Relay Servers > List View and select Add, followed by Add 
Relay Server.

2 Complete all applicable settings in the tabs that are displayed.

Table 2-1. General Tab

Setting Description

Name Enter a name for the relay server.

Description Enter a description for the relay server.

Product Provisioning
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Table 2-1. General Tab (continued)

Setting Description

Relay Server Type Select either Push or Pull as the relay server method.

Push – This method is typically used in on-premises deployments. The UEM console pushes content 
and applications contained in the product or staging to the relay server.

Pull – This method is typically used in SaaS deployments. A web-based application stored in the relay 
server pulls content and applications contained in the product or staging from the UEM console through 
an outbound connection.

For more information on installing a pull server, see Pull Service Based Relay Server Configuration.

Restrict Content 
Delivery Window

Limits content delivery to a specific time window. Provide a Start Time and End Time to restrict the 
delivery of content.

The start time and end time of the restriction window is based on Coordinated Universal Time (UTC), 
which the system obtains by converting the console server time into Greenwich Mean Time (GMT).

Set the system time on the console server accurately to ensure that your content is delivered on time.

Table 2-2. Assignment Tab

Setting Description

Managed By Select the organization group that manages the relay server.

Android and Windows Rugged Only: If you want to use the FTPS server for Barcode Enrollment only 
and not for Product Provisioning, remove all assigned organization groups under the Production Server 
section.

Staging Server 
Assigned Organization 
Groups

Assign the organization groups that use the relay server as a staging server.

A staging server only works for the staging process involving the supported staging clients, Stage Now 
(Android), and Rapid Deployment.

Production Server 
Assigned Organization 
Groups

Assign the organization groups that use the relay server as a production server.

A production server works with any device with the proper Workspace ONE Intelligent Hub installed on 
it.

Table 2-3. Device Connection Tab

Setting Description

Protocol The information the device uses to authenticate with the FTP server when downloading applications and 
content.

Select between FTP, Explicit FTPS, Implicit FTPS in Pull configuration (Android only), SFTP, or 
HTTPS (Pull only) as the Protocol for the relay server.

Only Android supports Implicit FTPS relay servers instead of Explicit FTPS relay servers and only in a 
pull configuration.

If using Explicit FTPS, your Explicit FTPS server must have a valid SSL certificate. Configure the SSL 
certificate on the Explicit FTPS server.

If selecting an HTTPS protocol, you must configure the HTTPS endpoint using the web server 
configuration tool of choice (for example, IIS).

Hostname Enter the name of the server that hosts the device connection.

Port Select the port established for your server.

Important   The ports you configure when you create your FTP, Explicit FTPS, Implicit FTPS (Android 
only), or SFTP server must be the same ports you enter when creating a relay server in the Workspace 
ONE UEM console.

Product Provisioning
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Table 2-3. Device Connection Tab (continued)

Setting Description

User Enter the server user name.

Domain-based user names are supported, accepted formats for domain users are username@domain and 
domain\username.

Password Enter the server password.

Path Enter the path for the server.

This path must match the home directory path of the ftp user. For example, if the ftp user's home 
directory is c:\ftp\home\jdoe, the path entered into this text box must be c:\ftp\home\jdoe.

Passive Mode Enable forces the client to establish both the data and command channels.

Verify Server This setting is only visible when Protocol is set to FTPS.

Enable ensures that the connection is trusted and there are no SSL errors.

If left deselected, then the certificate used to encrypt the data can be untrusted and data can still be 
sent.

3 For a push server, select the Console Connection tab and finish the settings.

The Console Connection tab contains information that the UEM console uses to authenticate with the 
FTP(S) server when pushing applications and content. The settings are typically identical to the 
Device Connection tab. Select the Copy Values From Device Connection button to save yourself 
from having to enter values from the Device Connection tab manually.

a Press the Test Connection button to test your Console Connection to the push server.

Each step of the connection is tested and the results are displayed to help with troubleshooting 
connection issues.

b Press the Export button on the Test Relay Server Connection page to export the data from the 
test as an XLSX or CSV (comma-separated values) file.

4 For a Pull server selection made in the General tab, select the Pull Connection tab and complete 
the settings.

Settings Descriptions

Pull Local Directory. Enter the local directory path for the server.

The directory you enter here must be the same as the root directory you opt when 
configuring an HTTPS endpoint on the webserver. For example, if you have 
configured an HTTPS endpoint and selected c:\rootfolder as your root directory in 
IIS, then you must use c:\rootfolder for your Pull Local Directory.

Pull Discovery Text. Enter the IP addresses or the MAC addresses of the server. Separate each 
address with commas.

IP addresses use periods as normal but MAC addresses do not use any 
punctuation in this form.

Pull Frequency. Enter the frequency in minutes that the pull server should review the UEM console 
for changes in the product.

 
5 Select Save.
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Batch Import Relay Servers
The Batch Import feature of Workspace ONE UEM powered by AirWatch loads relay servers into your 
product provisioning solution in bulk, saving you time if you have many to add. The Batch Import screen 
serves two purposes, 1) download a blank relay server batch file template and 2) import a completed 
template.

Download a blank relay server batch file template, fill it out, then upload the completed template by taking 
the following steps.

Procedure

1 Navigate to Devices > Provisioning > Relay Servers > List View then select Add and Batch 
Import.

The Batch Import screen displays.

2 Select the Show Server Function Codes and Show Relay Server Types links to see the codes that 
you need as you fill in the relay server batch import template.

3 Select the Download template link and save the template to your device.

4 Open the template with MS Excel or your favorite text editor.

The template features two sample entries. These entries allow you to see what kinds of values and 
their formats the system expects to find in each column heading when you import your completed 
template.

5 You must associate the relay server users with an organization group (GroupID).

The columns that feature an asterisk are required.

6 Remove the sample entries before you save your completed template.

7 Save the template in CSV format.

8 Return to the Workspace ONE UEM console and navigate once again to Devices > Provisioning > 
Relay Servers > List View then select Add and Batch Import.

9 Enter a Batch Name.

10 Enter a Batch Description.

11 Select Choose File to upload the completed Batch File.

Batch files must be in CSV format.

12 Select Import to upload the file and begin the batch import process.

All the relay servers in the correctly filled out template are now available to host product content in 
Workspace ONE UEM.

Product Provisioning
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Pull Service Based Relay Server Configuration
Pull service-based relay servers periodically contact the Workspace ONE UEM powered by AirWatch to 
monitor for new products, profiles, files, actions, and applications provisioned to devices under the pull 
relay servers purview. Configure a pull server to provision content to devices without excessive bandwidth 
use.

The server creates an outbound https connection on port 443 to the UEM console and periodically polls 
for changes or additions. If the server finds changes or additions, then it downloads the new content onto 
the server before pushing it to its devices.

Pull service is preferred when using a NAT firewall or SaaS environments over on-premises hybrid 
environments. The reason is that SaaS customers typically do not want the service to tie up bandwidth 
when content is delivered from Workspace ONE UEM to the store server.

Note   The IP configured in the pull connection / pull discovery must be an internal IP address for the 
server. The service does not configure correctly if an external IP or NAT IP address is used.

Pull Relay Server Security
Client-server applications such as Workspace ONE UEM use the transport layer security (TLS) 
cryptographic protocol to communicate across a network. TLS is supported by the file transfer protocol 
(FTP), file transfer protocol over SSL (FTPS), and SSH file transfer protocol (SFTP).

These file transfer protocols only secure those parts of the process where data is in transit between the 
client and the server. Because of this limitation, use an OS-level disk encryption. There are several 
operating system-specific tools available (for example BitLocker for Windows, GnuPG for Linux).

To create a pull relay server, you must first have an FTP, Explicit FTPS, or SFTP server to function as the 
relay server. FTP and FTPS servers must be compliant with RFC 959 and RFC 2228 set by the Internet 
Engineering Task Force.

Important   The ports you configure when you create your FTP, Explicit FTPS, Implicit FTPS (Android 
only), or SFTP server must be the same ports you enter when creating a relay server in the Workspace 
ONE UEM console.

The process covers the installation of one server at a time. For a bulk installation, you must use a third-
party application. Workspace ONE UEM supports importing servers in bulk through the Batch Import 
option. See Batch Import Relay Servers for more information.

Configure .NET Core Pull Relay Server, PS v2.0
You can configure a pull service v2.0 relay server based on Microsoft's .NET Core, the open source, 
cross-platform successor to their .NET Framework.

Prerequisites

The .NET Core based pull service is built using .Net core 2.1. For more information, see https://
dotnet.microsoft.com/.
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Table 2-4. Hardware Requirements

Component Requirement

Server 1

CPUs 2 (2.0 GHz Intel Processor)

Memory 4 GB

Storage* 25 GB

* Required storage size for the .NET Core server must scale with the collective size of the files and 
applications you plan to host. A file is not deleted from the relay server until the associated File Action 
component is deleted from the console.

Also, this .NET Core machine serves as the FTP server as well so the CPU and memory specifications 
might need to change to accommodate this load.

Table 2-5. Network Requirements

Component Requirement

Outbound Traffic to Content Pull Port 443

Protocol for Outbound Traffic to Content Pull HTTPS

On the client side, the pull service can use any dynamically assigned port, with no limitations, to connect 
to content pull on the server side.

At the current time, .NET Core does not support HTTPS proxies.

Table 2-6. Software Requirements

Component Requirement

Operating System Windows 64 bit or RHEL7 64 bit or

CentOS7 64 bit** or Ubuntu 18.04 64 bit**

Product Provisioning
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Procedure

1 Visit https://my.workspaceone.com/products/Pull-Service and download the .NET Core Pull Relay 
Server for Windows or Linux installer.

a Note: The Linux pull service installer has a hard-coded installation path of "/OPT/". You must 
configure this directory with sufficient write permissions and the top-most privileges. You must 
also have sufficient write permissions for the directory where the pull service is configured to 
download the contents.

b Linux Silent Installation Option: You have the option of running the Linux installation without 
being prompted. The following is an example of the code you might use to install silently the pull 
relay server for Linux with an NTLM proxy, basic authentication, and custom discovery text.

sudo ./VmwarePullserviceinstaller.bin -i silent -DPULL_SERVICE_CERT_PASSWORD=Test@1234 -

DOUTBOUND_PROXY=1 -DOUTBOUND_PROXY_HOST=192.168.1.100 -DOUTBOUND_PROXY_PORT=808 -

DOUTBOUND_PROXY_CREDENTIALS=1 -DOUTBOUND_PROXY_NTLM_AUTH=0 -DOUTBOUND_PROXY_DOMAIN= -

DOUTBOUND_PROXY_USERNAME=john -DOUTBOUND_PROXY_PASSWORD=hello@1234 -DIS_DISCOVERY_TEXT=1 -

DDISCOVERY_TEXT=og1

2 On-premises customers using older versions of the console can enable the 
PullServiceInstallerFeatureFlag. Contact VMware Support for assistance in updating the database 
with this feature flag.

3 In Workspace ONE UEM, navigate to Groups & Settings > All Settings > System > Enterprise 
Integration > Pull Service Installers and select the Download Configuration button.

The Download pull service configuration screen displays.

4 Enter and confirm the Certificate password you want to use for the pull service certificate and select 
Download to save the ZIP file. Save the ZIP file to the same directory as the pull service installer you 
downloaded in step 1.

5 Extract the contents of the ZIP file to the directory in which you saved it.

The ZIP file contains the pull service installer CONFIG file which is a file you require to run the 
installer. You should have the Windows EXE (or Linux BIN) Pull Service Installer file plus the CONFIG 
file extracted from the ZIP file together in the same directory. If you are installing the Linux variant, 
you might also have one of the NTLM enablers from step 2.

6 Run the Pull Service Installer, supplying the password you entered in step 4 when prompted. 
Continue with the remainder of the installation.

Product Provisioning
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7 ** If you are installing the Linux version and you want to configure an NTLM proxy authentication, the 
"gss-ntlmssp" package must be installed. Select the download link that corresponds to your Linux 
flavor and install it now.

Option Description

CentOS For CentOS, download the following RPM file.

https://centos.pkgs.org/7/epel-x86_64/gssntlmssp-0.7.0-1.el7.x86_64.rpm.html

Ubuntu For Ubuntu, download the following DEB file.

https://packages.ubuntu.com/bionic/amd64/gss-ntlmssp/download
 

Using the .NET Core Pull Service
You can fine-tune the way your .NET Core pull server works by heeding these tips and to adjust the 
appsettings.json file.

Best Practices

n Do not run multiple instances of pull service (old or new versions) on the same machine.

n Once the pull service is installed, avoid selecting the Regenerate button on the Pull Service Installers 
settings page. Regenerating the certificate after the pull service is running breaks communication 
between the Workspace ONE UEM console and the pull service client. If you must regenerate the 
certificate, then you must rerun the pull service installer.

n On-premises customers must generate and download the PSinstaller.config file directly from Global 
OG and not from Customer OG. This configuration enables an easy relay server move from OG 1 to 
OG 2 without having to reinstall the pull service every time. For more information, see Move an 
Existing Pull Relay Server from One Organization Group to Another.

Starting and Stopping the Pull Service

n Start/stop service on CentOS and RHEL.

/etc/init.d/awpullservice {start|stop|status|restart)

n Start the pull service.

service awpullservice start

n Stop the pull service.

service awpullservice stop

n Displays status of the pull service.

service awpullservice status

n Restarts the pull service.

service awpullservice restart
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n Start/stop service on Ubuntu. Run this SH file, which is located in the pull-service/bin folder.

n Start the pull service.

sh start.sh

n Stop the pull service.

sh stop.sh

n Start/stop service on Windows.

n Navigate to Run > services.msc, locate the Airwatch Pull Service, and select start, stop, or 
restart.

Appsettings.json Tweaks

The appsettings.json file settings presented here are the default values which you can change to modify 
the server's default behavior. The appsettings.json file is located in the pull service\Bin folder.

If the "discoveryText" value is set as null in the appsettings.json, then the pull service assembles and 
posts a default discovery text. This discovery text is composed of the merging of the pull server's IP 
address and Mac address in place of the null value.

The pull service must be manually restarted each time you change values in appsettings.json to apply the 
new settings.

n "performSystemTaskIntervalMin": "720" (in minutes), the interval when the pull service logs are sent 
to the content pull endpoint. For more information, see Enable Pull Service Logging.

n "clientPostTimeOut": "240" (in minutes), the amount of time the connection remains active before 
timing out. This time frame can increase as the size of your files increase to avoid connection 
timeouts.

n "waitTimeOnFailure": "300" (in seconds), the amount of time you allow the pull service to rediscover 
the relay server if there is a connection error.

n "logMaxEntries": "10000", the maximum number of log entries in a single log file.

n "maxLogFiles": "5", the maximum number of logs generated.

n "maxLogFileSize": "2000000" (in bytes), the maximum size a log file is allowed to get.

n "enableConsoleLog": "false", for developmental purposes. Enable to activate the console log.

n "proxyBypassOnLocal": "false", enable/disable the bypass proxy server for local addresses.

Migrating to the .NET Core Pull Service
You can migrate the use of the legacy pull service to a .NET Core pull service by heeding the following 
tips and taking the following steps.
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The .NET Core pull service installer does not support an automatic migration with custom discovery text. 
When you reinstall the same version of the PS or upgrade the PS to a new version, the custom discovery 
text value is different each time. For this reason, make a note of the complete discovery text value under 
appsettings.json ("discoveryText") or from the Undiscovered Pull Relay servers page on the console after 
a fresh installation for the first time (for example: a6af8505-3d0c-4490-
ab02-14db2fa3a80c_PSmachine1). Saving the discovery text value is useful for when you accidentally 
uninstall the pull service or when you must move the relay server from one OG to another or from one 
server to another.

Migration Without Custom Discovery Text

Follow this task when you do not want to use custom discovery text after migration and you want to 
continue using the same default discovery text. The default discovery text is the pull server's IP address 
plus Mac address.

1. Uninstall the legacy Java pull service or .NET Framework pull service from your Linux or Windows 
machine. Alternatively, you can just run the latest version of the pull service installer for an upgrade.

2. Run the new pull service installer or upgrade installer.

3. Do not enable the custom discovery text option when prompted by the installer and complete the 
installation.

Migration with Custom Discovery Text

Follow this task when your pull service becomes corrupted or the installed files/folders have been 
accidentally deleted. You want to reinstall the pull service onto the existing server, which has been 
configured with the custom discovery text that your corrupted/deleted pull service used.

Linux

1. Uninstall the existing PS from the Linux machine or upgrade to the latest version by running the new 
installer.

2. After installation is complete, navigate to the Bin folder of the Linux machine, edit the "discoveryText" 
entry in appsettings.json with the original discovery text value.

3. Restart the pull service. The server resumes functioning as it did before, using the exact same 
discovery text. The already queued items and new items are served to the same directory path as before.

Windows

Note   By default, the Windows installer features an option to modify the settings in appsettings.json 
directly.

1. Uninstall the existing PS from the Windows machine or upgrade to the latest version by running the 
new installer.

2. Update the "discoveryText" entry in appsettings.json with the original discovery text value.

3. Restart the pull service. The server resumes functioning as it did before. The already queued items and 
new items are served to the same directory path as before.
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Enable Pull Service Logging
You can enable the collection of pull service logs by taking the following steps.

Adjust how often the pull service logs are sent to the content pull endpoint by editing the number of 
minutes configured for the "performSystemTaskIntervalMin" setting in the appsettings.json file. This file is 
located in the pull service machine's \Bin folder.

Procedure

1 Navigate to Devices > Provisioning > Relay Servers > List View.

2 Select the radio button above the Edit icon on the relevant Pull Server.

3 Select the More Actions button and select Pull Logging.

4 Enable the Collect Log File check box, enter the Start Date and End Date, then select Save.

Pull service logging is enabled for the time period entered.

What to do next

Completed logs can be found on the console server machine in x:\Airwatch\Logs\ContentPull\RSid\, 
replacing 'x' for the actual drive letter of your environment.

Create a Windows-Based Pull Relay Server, PS v1.0
You can configure a pull service v1.0 relay server using a Windows FTP, Explicit FTPS, or SFTP server 
for use with product provisioning and staging.

Prerequisites

Before you begin, ensure that you have the following.

n An FTP, Explicit FTPS, or SFTP server. Workspace ONE UEM does not support Implicit FTPS 
Windows-based relay servers.

n Microsoft's .NET Framework must be installed on Windows-based servers.

n The pull relay server requires outbound network access on https 443 to the Workspace ONE UEM 
console.

n Each server requires disk storage of 2 MB for the pull server installer and hard disk space for all the 
content pulled to the server.

Procedure

1 Configure an FTP, Explicit FTPS, or SFTP server.

You must create an FTP user with read/write/delete permissions for both the directory and the files 
used in the relay server. This FTP user must have a user name and password for authentication. 
Note the home directory of the user for use in configuring the pull service.

2 Navigate to Groups & Settings > All Settings > System > Enterprise Integration > Pull Service 
Installers.
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3 Download the Windows Pull Service Installer and the Configuration file onto the server using your 
preferred server management system.

4 Open the XML config file and update the IP Address with your console server FQDN.

<PullConfiguration>

   <libraryPath>C:\<FTP_Home_Dir>\</libraryPath>

   <endPointAddress>https://<Console_Server_URL>/contentpull /</endPointAddress>

</PullConfiguration>

5 Run the WindowsPullServiceInstaller.exe. DotNet is installed before the MSI is extracted.

6 Navigate to Devices > Provisioning > Relay Servers > Undiscovered Pull Relay Servers.

If you have configured the FTP, Explicit FTPS, or SFTP server correctly, it provides feedback to this 
effect. If you do not see your server displayed, review your configuration settings.

7 Configure the relay server as a pull relay server in the UEM console.

See Configure a Relay Server for more details.

8 If you are using the silent install from the command prompt, use the following commands.

a WindowsPullServiceInstaller.exe /s /v"/qn/"

b To include log: WindowsPullServiceInstaller.exe /s /v"/qn" /l WindowsPullServiceInstaller.txt”

The installer looks for the PullserviceInstaller.config file in the installer execution directory. If the file is 
missing, the installer prompts you to let you know the file is missing.

Create a Linux-Based Pull Relay Server, PS v1.0
Configure a pull service v1.0 relay server using a Linux FTP, Explicit FTPS, or SFTP server for use with 
product provisioning and staging. The pull service must be installed before you integrate the server with 
the Workspace ONE UEM console.

Prerequisites

n An FTP, Explicit FTPS, Implicit FTPS in Pull configuration (Android only), or SFTP server. Only 
Android supports Implicit FTPS relay servers.

n Linux-based servers must run either CentOS or SLES 11 SP3.

n Java 8+ must be installed on Linux-based servers.

n The pull relay server requires outbound network access on https 443 to the Workspace ONE UEM 
console

n Each server requires disk storage of 2 MB for the pull server installer and hard disk space for all the 
content pulled to the server.
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Procedure

1 Configure an FTP, Explicit FTPS, or SFTP server. You must create an FTP user with read/write/delete 
permissions for both the directory and the files used in the relay server. Note the home directory of 
the user for use in configuring the pull service.

This FTP user must have a user name and password for authentication.

2 Navigate to Groups & Settings > All Settings > System > Enterprise Integration > Pull Service 
Installers.

3 Download the Linux Pull Service Installer and the Configuration file onto the server using your 
preferred server management system.

4 Open the XML config file and update the IP Address with your console server FQDN.

cn274.awmdm.com

<PullConfiguration>

<libraryPath>C:\AirWatch\PullService\</libraryPath>

<endPointAddress>https://[endpoint URL]/contentpull /</endPointAddress>

</PullConfiguration>

5 In the command prompt, enter the command.

sudo ./LinuxPullServerInstaller.bin

Alternatively, enter the following command to install silently.

sudo ./LinuxPullServerInstaller.bin -I silent

6 Follow the instructions prompted by the installer, including the optional configuration of a proxy server.

a If you want to use a proxy server, supply the host, port, and authentication information when 
prompted.

7 Navigate to Devices > Provisioning > Relay Servers > Undiscovered Pull Relay Servers.

If you have configured the FTP, Explicit FTPS, or SFTP server correctly, it provides feedback to this 
effect. If you do not see your server displayed, review your configuration settings.

8 Configure the relay server as a pull relay server in the UEM console.

See Configure a Relay Server for more details.

The installer looks for the PullserviceInstaller.config file in the installer execution directory. If the file is 
missing, the installer prompts you that the file is missing.

Move an Existing Pull Relay Server from One Organization Group 
to Another
You can move an existing pull relay server installed with the Windows or new Linux installer by taking the 
following steps.
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Prerequisites

If you have a .NET Core pull service in an on-premises environment, you must generate and download 
the PullServiceInstaller.config file directly from Global OG (not from a Customer OG). This configuration 
allows you to move the relay server from OG 1 to OG 2 easily without reinstalling the pull service.

If you have a regular .NET Framework pull service or Java pull service installed, then use the following 
steps to move your relay server from on OG to another.

Procedure

1 Delete the existing pull relay server from the original OG on the console. Once it is deleted, the pull 
discovery text that belongs to the pull service starts appearing on the undiscovered pull discovery 
page at Global OG.

2 Navigate to Devices > Provisioning > Relay Servers > Undiscovered Pull Relay Servers and 
locate the server by searching for your IP address (only available for on-premises).

3 Copy the pull discovery text that includes the IP address of your selected server.

4 Create a relay server in the new OG and activate it. After activating the relay server in the new OG, 
the pull service discovery text listed in the Undiscovered Pull Relay Servers page disappears.

Move an Existing Pull Service from One Relay Server to Another 
Relay Server
You can move the pull service from one relay server to another relay server by taking the following steps.

Such an action is advisable for when you must install the pull service onto a server with upgraded 
hardware and your pull service runs with custom discovery text. The old relay server was configured with 
this custom discovery text and as a consequence, the new relay server must also be configured with the 
same custom discovery text.

Procedure

1 On the old relay server, locate the appsettings.json file and find the custom "discoveryText" value 
including the GUID. Select and copy this string to the clipboard with Ctrl-C.

2 Uninstall the pull service from the old relay server manually.

3 Using the latest version of the PS installer, install the pull service onto the new relay server.

4 From the Workspace ONE UEM console, update the FTP server details of the new relay server, 
located in the Device Connection tab.

5 In the Pull Connection tab, paste the custom discovery text you copied in step 1 in the Pull 
Discovery Text text box with Ctrl-V.

The custom discovery text is now copied from the old machine to the new machine.

6 Save and activate the relay server from the UEM console.

7 Restart the pull service.
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The new pull service, using the original custom discovery text, is configured on the new relay server. The 
new machine serves any existing pending or new content and the device selects content from the new 
relay server through FTP.

Configuring Session Persistence of a Load Balancer for Multiple 
Pull Relay Servers
You can configure a load balancer for multiple pull relay servers (both legacy and DotNetCore) by setting 
session persistence.

Relay servers process requests for content. When the number of requests exceed what a single server 
can handle, the solution is multiple relay servers. A load balancer can be used to distribute the load 
across multiple pull relay servers, for both legacy and DotNetCore pull services.

You must configure the load balancer with session persistence, ensuring that the same relay server 
receives each endpoint call per content request. If session persistence is not configured on the load 
balancer, subsequent requests that are routed to another relay server can result in a File-Not-Found error.

The following endpoints are called from the pull service to retrieve content.

n GetNextManifest, retrieves the file metadata which the client must download.

n GetFileInfoEx, retrieves the file-hash which is used to determine whether the file is already 
downloaded.

n GetFileData, downloads the actual content.

Resolution
Since the file is downloaded locally to the server where Content-pull is running, you must configure the 
Load Balancer to have session persistence (IP based) to route all three endpoints to the same relay 
server.

View Remote Files on Relay Server
Workspace ONE UEM powered by AirWatch lets you view files sent to a relay server for product 
provisioning to devices through the Remote File Viewer.

Procedure

1 Navigate to Devices > Provisioning > Relay Servers > List View.

2 Select the server you are interested in viewing by clicking the radio button to the left of the Active 
indicator, above the Edit pencil icon.

3 Select the More Actions button.
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4 Select Remote File List and open the Remote File List for your selected relay server.
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Device Staging 3
Workspace ONE UEM powered by AirWatch lets you stage a device quickly to enroll and prepare it for 
production use. A staging package connects a device to a Wi-Fi connection, installs the Workspace ONE 
Intelligent Hub, and enrolls the device without end-user input.

Staging Basics
The Rugged Enrollment Configuration Wizard simplifies creating staging packages. With the wizard, 
everything you need for a staging package is created in a step-by-step process.

Staging packages are created as part of the product provisioning process. You can include profiles, 
applications, and files/actions as part of the staging package depending on the device platform.

You have several methods for enrolling a rugged device through staging. Barcode Enrollment creates a 
staging package associated with a barcode that you scan to stage the device. The Stage Now client is 
exclusive to Android devices with Zebra MX version 7.1+ under Android Nougat and later. Sideloading 
packages are transferred to a device instead of being scanned or downloaded.

This chapter includes the following topics:

n Stage Devices With the Enrollment Configuration Wizard

n Stage Devices With a Manually Created Staging Package

n Add a Manifest to Your Staging Package

n Wi-Fi Profiles for Staging

n Barcode Staging

n Sideload Staging Packages

n AirWatch CAB Creator, WinRugg

n Android Device Enrollment With the Workspace ONE Intelligent Hub

n Enroll Zebra Devices with Stage Now Barcode, Android

n Enroll Honeywell Devices with Staging Barcode, Android

n How Do You Configure a Zebra Work Managed Device with Stage Now, Relay Servers, and CICO 
Launcher
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Stage Devices With the Enrollment Configuration Wizard
Simplify rugged device enrollment in Workspace ONE UEM powered by AirWatch through the Enrollment 
Configuration wizard. This wizard helps you complete each step in creating a staging package for your 
Android and Windows Rugged devices.

Procedure

1 Navigate to Devices > Lifecycle > Staging and select the Configure Enrollment button.

2 Select the device platform you want.

3 Select the staging enrollment type.

The settings you must configure change based on the enrollment type selected.

n Generate a QR Code with the Enrollment Configuration Wizard, Android (Android only) – Create 
a QR Code to scan with your Android Work Managed devices to quickly stage the device. The 
wizard simplifies the configuration process.

n Generate a Barcode Staging Package with the Enrollment Configuration Wizard – Create a 
barcode to scan with your Zebra rugged devices to quickly stage the device. The wizard simplifies 
the barcode configuration process.

n Generate a Sideload Staging Package with the Enrollment Configuration Wizard, Android and 
Windows Rugged – Create a sideload staging package to download and install onto a device to 
automatically configure and enroll the rugged device.

n Enroll with Web Enrollment, Windows Rugged (Windows Rugged only) – Create a staging 
package to download and install from a web URL onto a device to automatically configure and 
enroll the rugged device.

4 Select Configure.

Generate a QR Code with the Enrollment Configuration Wizard, 
Android
After selecting QR Code enrollment in the Enrollment Configuration wizard, create a QR Code to scan 
with your Android 7.0 or later devices to stage the device quickly. The wizard simplifies the staging 
configuration process.

Procedure

1 After taking note of the prerequisites, select Configure to begin.
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2 You can connect the device to Wi-Fi before enrollment by enabling the Wi-Fi toggle. This enabling 
action displays the following options.

Setting Description

SSID Enter the Service Set Identifier, more commonly known as the name of the Wi-Fi 
Network.

Password Enter the Wi-Fi password for the entered SSID.
 

3 Select Next.

4 Select the Workspace ONE Intelligent Hub to push to devices during staging. The default selection is 
Use latest Workspace ONE Intelligent Hub.

If you do not have an Workspace ONE Intelligent Hub added, select Hosted on an external URL and 
enter the address in the URL text box to point to an externally hosted Workspace ONE Intelligent Hub 
Package.

5 Select Next.

6 Set the Enrollment Details settings. To use a token-based authentication, leave both commands 
disabled.

Setting Description

Organization Group Enable and select the organization group the QR Code staging package uses.

User name Enable and configure login credentials. Enter the Workspace ONE UEM account 
user name.

Password Enter the corresponding password.
 

7 Select Next.

8 The Summary page allows you to Download File of the PDF. You can also View PDF to see a 
preview of your QR Code Format selections.

Generate a Barcode Staging Package with the Enrollment 
Configuration Wizard
After selecting Barcode enrollment in the Enrollment Configuration Wizard, create a barcode to scan with 
your rugged devices to stage the device quickly. The wizard simplifies the staging configuration process.

Procedure

1 After taking note of the prerequisites, select Configure to begin.

2 Stage the devices by selecting the Relay Server.

a If you do not have a relay server created, select Add Relay Server.

The list of relay servers populates from any relay servers created for the organization group or the 
parent organization groups.

3 Select Next.
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4 Select a Wi-Fi Profile that devices use to connect to the relay server and download the Workspace 
ONE Intelligent Hub.

a If you do not have a Wi-Fi profile created, select Add Wi-Fi profile.

You cannot create a Wi-Fi profile through the wizard that uses a certificate authentication. The Wi-Fi 
profile created is used for staging and remains on the device after enrollment.

5 Select Next.

6 Select the Workspace ONE Intelligent Hub to push to devices during staging.

a If you do not have an Workspace ONE Intelligent Hub added, select Add Workspace ONE 
Intelligent Hub to upload a Workspace ONE Intelligent Hub Package if necessary.

b Download the latest version of the Workspace ONE Intelligent Hub.

c Contact your Account Manager or Workspace ONE UEM Support for access.

7 Select Next.

8 Enter the Stage User credentials.

Settings Descriptions

Name Enter the name of the staging package.

Description Enter a description of the staging package.

Owned By Select the organization group that owns the staging package.

Enrollment User Enter the user name of the user.

If you do not have a user, select Add User.
The user must be a basic user account. Do not use staging users or multi-user 
staging.

Password Android only. Enter the password of the user.
 

9 Select Next.

10 Set the Barcode settings.

Setting Description

Organization Group Select the organization group the staging package uses.

Universal Barcode Enable to create a universal barcode enrollment so devices can be enrolled without 
automatically assigning an organization group.

Android Only Note: With this setting enabled, the Workspace ONE Intelligent Hub 
prompts you to enter an organization group after beginning the staging process. If 
you are enrolling devices into Android (Legacy) with this barcode, take care to 
select an OG that is configured for Android (Legacy) enrollment.

Require Password. Create an alphanumeric password (maximum 99 characters) used to unlock the 
staging package encryption on the end-user device immediately after enrollment.

Barcode Format Select the barcode format for the devices you want to enroll.
 

11 Select Save.
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What to do next

Navigate to the Summary page and you can Download File of the PDF.

You can also View PDF to see a preview of your Barcode Format selections.

Android Only Note: If you want to make a barcode for Android devices using the options you have 
selected above, you must close the Enrollment Wizard and proceed to the Generate a Barcode Staging 
Package step.

Generate a Sideload Staging Package with the Enrollment 
Configuration Wizard, Android and Windows Rugged
You can create a sideload staging package to configure and enroll the Android (only legacy devices 
supported) or Windows Rugged device. The wizard simplifies the staging configuration process.

After selecting Sideload enrollment in the Stage Devices With the Enrollment Configuration Wizard, 
create a sideload staging package using the wizard.

Procedure

1 Select a Wi-Fi profile that devices use to connect to the relay server and download the Workspace 
ONE Intelligent Hub.

a If you do not have a Wi-Fi profile created, select Create Wi-Fi profile.

You cannot create a Wi-Fi profile that uses certificate authentication through the wizard. The Wi-
Fi profile created is used for staging and remains on the device after enrollment.

2 Select Next.

3 Select the Workspace ONE Intelligent Hub to push to devices during staging.

a If you do not have an Workspace ONE Intelligent Hub added, select Add Workspace ONE 
Intelligent Hub to upload a Workspace ONE Intelligent Hub Package if necessary.

b Download the latest version of the Workspace ONE Intelligent Hub.

c Contact your Account Manager or Workspace ONE UEM Support for access.

4 Select Next.

5 Enter the Stage User credentials.

Settings Descriptions

Name Enter the name of the staging package.

Description Enter a description of the staging package.

Owned By Select the organization group that owns the staging package.

Enrollment User Enter the user name of the user.

The user must be a basic user account. Do not use staging users or multi-user 
staging.

Password Enter the password of the user.
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6 Select Next.

7 Enter the Sideload settings.

Settings Descriptions

OG Select the organization group the staging package uses.

Universal You can create a universal enrollment so devices can be enrolled without 
automatically assigning an organization group.

This option allows you to enroll devices without needing a Sideload enrollment for 
each organization group. The Hub prompts you to enter an organization group after 
the staging process begins.

 

Enroll with Web Enrollment, Windows Rugged
After selecting Web enrollment in the Rugged Enrollment Configuration wizard, create a staging package 
to enroll devices by sending end users to a URL to enroll. The wizard simplifies the staging configuration 
process.

Procedure

1 Select Configure Hub to configure the Workspace ONE Intelligent Hub for web enrollment.

The default file path to the Workspace ONE Intelligent Hub CAB file displays.

2 If you want to use a different CAB, select Disable and then select the CAB file you want to use. 
Select the CAB file for both Windows Mobile, Windows CE, and Windows x86 CE devices.

a To upload your own CAB file, select Add Application.

3 Select Next.

4 Send end users to the enrollment URL to begin enrollment.

The enrollment URL is configured on the Site URLS page.

Stage Devices With a Manually Created Staging Package
Workspace ONE UEM powered by AirWatch lets you manually stage your devices to connect to Wi-Fi, 
download the Workspace ONE Intelligent Hub, and enroll automatically with a Staging Package. This 
method does not use the Rugged Enrollment wizard.

Procedure

1 Navigate to Devices > Lifecycle > Staging and select the Add Staging button.

2 Select the Platform for which you want to create a staging configuration.

The Staging Add screen displays.
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3 Complete the required text boxes on the General tab.

Settings Description

Name Enter the name of the staging configuration.

Description Enter the description of the staging configuration.

Owned By Select the organization group under which the staging package applies.

Enrollment User Enter the user name of the enrollment user.

You can search for and select an existing user by clicking the magnifying glass 
icon. You can also add a user by selecting Add User at the bottom of the drop-
down menu.

Password Enter the password for the enrollment user.

You have the option of keeping the password redacted or displaying it as written.

Hub Select an existing Workspace ONE Intelligent Hub package from the drop-down 
listing which is downloaded during staging.

You can also add the Workspace ONE Intelligent Hub package by selecting Add 
Workspace ONE Intelligent Hub at the bottom of the drop-down menu.

These agents are uploaded as the Workspace ONE Intelligent Hub Package. See 
Upload the Workspace ONE Intelligent Hub APF File, Upgrade File-Action for more 
information.

 
4 Select Save.

What to do next

Proceed to the Add a Manifest to Your Staging Package task.

Add a Manifest to Your Staging Package
After finishing the General tab of the staging package in Workspace ONE UEM powered by AirWatch, 
you can add a Manifest of advanced product components including additional content, commands, and 
components like applications, profiles, Files/Actions, and Event Actions.

A manifest is a list of ordered steps taken during staging. The manifest can be added by navigating to 

Devices > Lifecycle > Staging. Either select the edit icon ( ) to the left of an existing staging package 
in the listing and proceed to step 1 below or create a new staging package by selecting the Add Staging 
button. Select the platform then proceed to the Manifest tab.

Prerequisites

If you plan to add Applications, Profiles, Files/Actions or Event Actions, you must create these 
components before adding them to the manifest. Create these components by navigating to Devices > 
Provisioning > Components.

Procedure

1 After finishing the General tab of the Staging window, continue to the Manifest tab.
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2 Select the Add button.

The Add Manifest screen displays.

3 Select the Action(s) To Perform during staging.

Action(s) to Perform 
Drop-Down Menu Settings

Install Profile In the Profile text box, select the profile to install during the staging configuration. This component 
must be made before adding it to the manifest.

Uninstall Profile In the Profile text box, select the profile to remove during the staging configuration.

Install Application 
(Android Only)

In the Application text box, select the App to install during the staging configuration. This 
component must be made before adding it to the manifest.

Uninstall Application 
(Android Only)

In the Application text box, select the App to remove during the staging configuration.

Install Files/Actions In the Files/Actions text box, select the Files/Actions component to install during the staging 
configuration. This component must be made before adding it to the manifest.

Uninstall Files/
Actions

In the Files/Actions text box, select the Files/Actions component to remove during the staging 
configuration.

Reboot (Android Only) Reboots the device during the staging configuration. This action works best as the last step of the 
manifest.

Warm Boot/Cold Boot 
(WinRugg Only)

Warm Boot reboots the device during the staging configuration. This action works best as the last 
step of the manifest.

Cold Boot shuts down the device, forcing a restart by the end user. This action works best as the 
last step of the manifest.

Install Event Action 
(Android and WinRugg 
Only)

In the Event Action text box, select the Event Action component to install during the staging 
configuration. This component must be made before adding it to the manifest.

Uninstall Event Action 
(Android and WinRugg 
Only)

In the Event Action text box, select the Event Action component to remove during the staging 
configuration.

4 Android and Windows Rugged only - Enable or disable Persistent through enterprise reset. 
Enable to keep the profile, application, files/actions, or event action on the device after an enterprise 
reset. For more information, see Product Persistence, Android, and WinRugg.

5 When finished with the single Manifest action, select Save.

6 Select Add again to add additional Manifest actions. You can adjust the order of manifest steps using 
the up and down arrows in the Manifest list view. You can also edit or delete a manifest step.

7 When you are finished adding actions, select Save.

What to do next

View the newly created staging profile in the List View. Take additional actions on the profile from the 
menus on the right.

n Edit your configuration.
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n Copy your profile.

n Android and Windows Rugged only: Select Barcode and finish the text boxes on the Generate 
Barcode subpage.

Wi-Fi Profiles for Staging
Your staging configuration must include a Wi-Fi profile or the device cannot receive content. This profile 
connects the device to the relay server and downloads the Workspace ONE Intelligent Hub which is 
required for Workspace ONE UEM powered by AirWatch.

A Wi-Fi profile is either a staging or production profile. The staging Wi-Fi profile is created under the 
Products section and connects the device to the relay server so the device can receive the staging 
configuration. The production Wi-Fi profile is a normal Wi-Fi profile used at the device's daily use 
locations.

To create a Wi-Fi profile, navigate to the General settings of the profile. Set the Profile Scope of the Wi-
Fi profile:

n Staging Wi-Fi Profile – Connects a device to the Wi-Fi used specifically for staging.

n Production Wi-Fi Profile – Connects a device to the Wi-Fi network for everyday use. Production Wi-
Fi profiles are under Device > Profiles > List View > Add. You must use auto deployment and 
publish the profile before staging a device with it.

Barcode Staging
You can create a barcode with Workspace ONE UEM powered by AirWatch and use it to auto-enroll your 
Motorola and Zebra rugged devices. Barcode Staging reduces the process to a simple barcode scan 
which configures the device with a staging package.

You can also create universal barcode staging which does not automatically assign an organization group 
while enrolling the device. This generic barcode allows you to create one staging enrollment for all 
devices and assign the device to an organization group later, as needed.

Barcode enrollment is only available on devices running the Rapid Deployment Client or Zebra's Stage 
Now client. The Rapid Deployment client supports FTP and FTPS relay servers. Zebra's Stage Now client 
supports FTP, FTPS, and HTTPS relay servers.

Use the Rugged Enrollment wizard to simplify the creation of barcode staging packages. The wizard 
enables you to create all the necessary components of a staging package in one place. For more 
information, see Stage Devices With the Enrollment Configuration Wizard.

Barcode enrollment is only supported on the following devices.

Android
n Zebra Rugged devices with MX running Android Marshmallow and earlier (Rapid Deployment 

barcodes only).
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n Zebra Rugged devices with MX version 7.1 or later running Android Nougat (Stage Now barcodes 
only).

n Zebra Rugged devices with Android Hub version 8.2 or later (Stage Now barcodes only).

You can create barcodes to enroll Honeywell Android rugged devices in the Workspace ONE UEM 
console by using the EZconfig utility for Android legacy devices only.

Windows Rugged with Rapid Deployment
n MC45

n MC55

n MC65/67

n MC75

n MC3090

n MC3190

n MC9090

n MC9190

n MC92N0

Generate a Barcode Staging Package
Create a barcode to scan with your Zebra or Honeywell rugged devices to stage the device quickly.

Prerequisites

You must create a staging package before you generate a barcode that uses it. See Stage Devices With 
a Manually Created Staging Package.

The staging user for the staging package must be a basic user account. Do not use staging users or 
multi-user staging.

Procedure

1 Navigate to Devices > Lifecycle > Staging.

2 Select the radio button to the left of the name of the staging package.

A new row of buttons displays under the Add Staging and Configure Enrollment buttons.

3 Select the Barcode or Stage Now Barcode or Honeywell Barcode button.

Product Provisioning

VMware, Inc. 36



4 Select the Staging Options.

Settings Descriptions

Organization Group Select the organization group the staging package uses.

Universal Barcode Enable to create a universal barcode enrollment so devices can be enrolled without 
automatically assigning an organization group.

Android Only Note: With this setting enabled, the Workspace ONE Intelligent Hub 
prompts you to enter an organization group after beginning the staging process. If 
you are enrolling devices into Work-Managed Mode with this barcode, take care to 
select an OG that is configured with Android EMM Registration settings.

Enabling this box repopulates the Staging Relay Server and Staging Profile with 
applicable options.

Staging Relay Server Select the staging relay server that hosts the staging content.

Staging Profile Select the staging Wi-Fi profile and apply it to the enrolled device.

Require Password. Enable to create an alphanumeric passphrase (maximum 99 characters) to be 
used to unlock the staging package encryption on the end-user device.

Device Owner Mode Android Only. Enable to enroll the device into Android Work Managed mode. This 
option can only be enabled when the Universal Barcode option is enabled.

 
5 Select the Barcode Format options. Android Only Note: Android admins can enter the optional 

Barcode Instructions to be included on the barcode PDF output page.

6 Select View PDF.

This option generates a preview of the barcode PDF output page for end users to scan.

7 Save the PDF file.

Sideload Staging Packages
Workspace ONE UEM powered by AirWatch lets you create a sideload staging package to download and 
install onto your rugged devices to begin the auto-enrollment process. Sideload staging simplifies 
enrollment by combining all the required components into one package.

Android Only Note: sideload staging packages are only supported by Android legacy devices.

You can also create universal barcode staging to stage devices with a generic barcode that does not 
automatically assign an organization group when enrolling the device. This allows you to create one 
staging enrollment for all devices and assign the device to an organization group as needed.

Simplify creating a barcode staging package by using the Rugged Enrollment wizard. The wizard allows 
you to create all the necessary components of a staging package in one place. For more information, see 
Stage Devices With the Enrollment Configuration Wizard.

You can use the Sideload Staging Utility for Windows Rugged devices to sideload a staging package 
easily. The utility simplifies the process of installing a sideloading package onto the device with simple 
step-by-step instructions.
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Generate a Sideload Staging Package with the Configuration 
Wizard
After selecting Sideload as the staging enrollment type in the Enrollment Configuration wizard, create a 
sideload staging package to download and install onto a device to configure and enroll the rugged device 
automatically.

Prerequisites

You must create a staging package before you create a sideload staging package. See Stage Devices 
With a Manually Created Staging Package.

The staging user for the staging package must be a basic user account. Do not use staging users or 
multi-user staging.

Procedure

1 Navigate to Devices > Lifecycle > Staging.

2 Select a previous staging package that you want to create a sideloaded staging package for. Select 
the More option and select Staging Side Load from the drop-down.

3 Select the Organization Group to which this staging applies.

4 (Optional for Android and Windows Rugged, not supported for QNX) Enable Universal Barcode to 
enable a universal enrollment so devices can be enrolled without automatically assigning an 
organization group.

This allows you to enroll devices without needing a Sideload enrollment for each organization group.

The Hub will prompt you to enter an organization group after beginning the staging process.

5 Select Download to start downloading the zip file of the staging sideload.

Install a Sideload Staging Package, Android
After creating a sideload staging package and downloading it, install it onto the Android device to begin 
the enrollment process.

If you want to preconfigure a Wi-Fi connection into the staging cab file, then use the advanced staging 
feature (Manifest tab on the staging profile) and add a step for installing a production Wi-Fi profile. If this 
step is not done, then the Wi-Fi profile must be manually configured on the device (preferably before 
running the staging cab).

Procedure

1 Download and install the Android Debug Bridge to the computer you want to use for staging devices.

2 Unzip the downloaded Sideload Staging ZIP file.
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3 Depending upon the version of the OS that your device is running, you might need to download an 
updated stage.bat file from my Workspace ONE ™ Resource Portal.

a Visit https://my.workspaceone.com.

b Search for "VMware AirWatch Stage.bat for Zebra Sideload Staging" and download this file.

c Verify that this stage.bat file is in the root folder of the unzipped Sideload Staging ZIP file.

4 Establish a USB debug connection to the Android device.

USB debugging must be enabled on the Android device. This setting is located in the device system 
settings under Developer Options.

5 Start the stage.bat file from the root folder of the unzipped Sideload Staging ZIP file.

The stage.bat file copies files to the device and then uses intents to start the auto-enrollment process.

The Workspace ONE UEM auto-enrollment screen displays on the device and shows progress.

When auto-enrollment is complete, the Workspace ONE Intelligent Hub displays the main details 
screen.

This script installs the MX Service and Hub then applies the Wi-Fi profile you defined in the staging 
manifest and any other manifest items. Once the Wi-Fi connects, the device auto-enrolls into Workspace 
ONE UEM.

Install a Sideload Staging Package, WinRugg
After creating a sideload staging package and downloading it, install it onto the Windows Rugged device 
to begin the enrollment process.

You can also use the Sideload Staging Utility for Windows Rugged devices to simplify the sideload 
staging process. See Use the Sideload Staging Utility, WinRugg.

Important   If you want to preconfigure your Wi-Fi connection into the staging cab file, then use the 
advanced staging feature (Manifest tab on the staging profile) and add a step for installing a production 
Wi-Fi profile. If this step is not done, then the Wi-Fi profile must be manually set up on the device 
(preferably before running the staging cab).

Procedure

1 Unzip the file and connect your device to the staging machine through USB once the download is 
complete.

2 Manually create "\Program Files\AirWatch\Staging" directory on your device. You must add both the 
AirWatch and staging directories.

3 Copy the content of the unzipped staging file to the directory you created.

The staging file contains several directory folders.

4 Open the "\Program Files\AirWatch\Staging\agent" directory and manually run the Workspace ONE 
Intelligent Hub cab file.
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The cab file installs the Workspace ONE Intelligent Hub, then the enrollment process completes and the 
Workspace ONE Intelligent Hub enrolls the device, assuming the device has network connectivity.

Enroll Honeywell Devices with Sideload Staging, Android
Enroll your Honeywell Android devices using a sideload staging package. Sideload staging configures 
your Honeywell Android devices to download the Workspace ONE Intelligent Hub and enroll 
automatically.

Prerequisites

n You must create a staging package before you create a sideload staging package. See Stage 
Devices With a Manually Created Staging Package.

n Download the staging package and unzip the file to access the credentials.bin file.

n Download the latest Hub APK available on Workspace ONE UEM Resources. Contact your 
Workspace ONE UEM account manager for access to the APK.

n Download the latest Honeywell APK available on Workspace ONE UEM Resources. Contact your 
Workspace ONE UEM account manager for access to the APK.

n Download and install the Android Debug Bridge (ADB).

Procedure

1 Create a folder containing the following.

n Latest Workspace ONE Intelligent Hub for Android APK.

n Latest Honeywell APK.

n Credentials.bin from the staging package.

2 Open a text editor such as Notepad. Copy the following chunk of text and paste it into the blank 
notepad.

adb push credentials.bin /sdcard/credentials.bin

adb install HoneywellService.apk

adb shell am start -a android.intent.action.MAIN -n 

com.airwatch.admin.honeywell/.HoneywellActivity

adb install Hub.apk

adb shell am start -a android.intent.action.MAIN -n com.airwatch.androidagent/

com.airwatch.agent.ui.activity.SplashActivity -e hideui true

adb shell pm grant com.airwatch.androidagent android.permission.READ_EXTERNAL_STORAGE

adb shell am broadcast -a com.airwatch.agent.action.IMPORT_CREDENTIAL_XML -e file /sdcard/

credentials.bin --user 0

adb shell am broadcast -a com.airwatch.agent.action.AUTO_ENROLL --user 0

a Change the filenames and storage locations as needed.

3 Save the file as autoenroll_Honeywell.bat in the same directory as the other files.

4 Connect a Honeywell Android device to your PC using an ADB connection. Ensure that the device is 
connected to Wi-Fi.
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5 Run the autoenroll_Honeywell.bat file.

Create Sideload Staging Bundle with Platform OEM Service
You can set up a Sideload Staging bundle for devices using the Generic OEM Service. This procedure is 
not supportive of Advanced Staging.

Procedure

1 Get the enrollment credentials.

a Create a Staging bundle in the console.

b Download the Sideload Staging Package.

c Unzip the Sideload Staging Package file and copy the 'credentials.bin' file inside the enrollment 
folder. Save this file for later.

2 Collect the necessary files for the device.

a Get the latest Hub APK.

b Get the OEM Service APK for your device.

For more information, see Platform OEM Service, Android Provisioning.

c Get the credentials.bin from the preceding step.

d Place all these files in a folder on your PC.

3 Create your auto-enroll BAT file.

a Using a text editor, add the following lines (change the filenames and storage locations based on 
your own configuration).

adb push credentials.bin /sdcard/credentials.bin

  adb install OEMService.apk

  adb shell am start -a android.intent.action.MAIN -n com.airwatch.admin.awoem.[OEM_NAME]/

com.airwatch.admin.awoem.PlatformOEMActivity -e hideui true

*If you are using POEM v3.2 or higher, use this intent instead:

  adb shell am start -a com.airwatch.START_AIRWATCH_SERVICE

adb install Agent.apk

  adb shell am start -a android.intent.action.MAIN -n com.airwatch.androidagent/

com.airwatch.agent.ui.activity.SplashActivity -e hideui true

  adb shell am broadcast -a com.airwatch.agent.action.IMPORT_CREDENTIAL_XML -e file /sdcard/

credentials.bin --user 0

  adb shell am broadcast -a com.airwatch.agent.action.AUTO_ENROLL --user 0

b Save the file as autoenroll_OEM.bat in the same directory as the other files.

*On Mac, it must be an SH file and run in Terminal.
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4 Auto-enroll the device.

a Connect the device to Wi-Fi.

b Connect the device to the PC through an ADB connection.

c Run the autoenroll_OEM.bat file.

Use the Sideload Staging Utility, WinRugg
You can easily sideload your Windows Rugged device through the AirWatch Sideload Staging Utility. The 
utility simplifies the process of installing a sideloading package onto the device with simple step-by-step 
instructions.

Procedure

1 Download the "VMware AirWatch Windows Mobile/CE Side loader Utility" from the 
myWorkspaceONE ™ documentation repository.

The download URL is https://resources.workspaceone.com/view/dpzpbh2cvvnztcc9nkv3/en.

2 Install the utility after the download completes.

3 Start the AirWatch Side loader Utility after the installation finishes.

4 Connect the device to your computer.

The Choose Side Staging and Stage File to Device buttons become available for use after the 
utility detects the device connection.
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5 Select Choose Side Staging and select the ZIP file you want to stage to a device.

6 Select Stage File to Device and begin staging the device.

The ZIP file unzips, folders and directories are created, and the CAB file installs.

Uninstall a Sideload Staging Package, WinRugg
Use the Sideload Staging Utility for Windows Rugged to uninstall a sideload staging package from a 
device.

Procedure

1 Start the Sideload Staging Utility.

2 Connect the device to your computer.

3 Once the Sideload Staging Utility detects connection with the device that has existing staging, select 
any of the following options.

Setting Description

Uninstall Hub. Select to remove the Workspace ONE Intelligent Hub for Windows Rugged from 
the device.

Remove Persistence. Select to remove any products marked for persistence through Enterprise Reset.

Remove Registry Key. Select to remove all registry key entries for the staging.
 

Selecting the uninstall options displays a status message when the action completes.
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AirWatch CAB Creator, WinRugg
The AirWatch Cab Creator for Windows Rugged allows you to create custom CAB files for use on 
Windows Rugged devices in Workspace ONE UEM powered by AirWatch. These custom CAB files 
consist of files and applications you add from your computer.

Simplify the install process combining all the files and applications you want on your Windows Rugged 
device into a custom CAB file. You can also import other CAB files into your own custom CAB file.

This feature allows you to create one custom CAB file that contains all the CAB files you want to install on 
a device. You can also use the AirWatch Cab Creator to edit any existing CAB file on your PC. The 
AirWatch Cab Creator also supports importing files that are converted to the CAB file format upon saving.
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Create a Custom CAB, WinRugg
Simplify installation of files onto your Windows Rugged devices by creating custom CAB files using the 
AirWatch Cab Creator for Windows Rugged. These custom CABs can contain your business files or the 
files necessary to upgrade your Windows Rugged devices.

Prerequisites

To use the AirWatch Cab Creator for Windows Rugged, you must meet the following requirements.

n A Windows device running Windows 7+

n .NET Framework 4.5

Procedure

1 Download the "AirWatch Cab Creator" for Windows Rugged from the MyWorkspaceONE portal.

2 Unzip the file to your preferred directory.
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3 Double-click CabBuilder.exe to start the app.

4 Navigate to a file on your Local Drive you want to add to the custom CAB file. You can select a 
different drive by selecting Select Drive.

5 Enter an Application Name. This text box is the name of the CAB file after installation.

Remember the name for use in Uninstall Manifest items.

6 Select the file and drag it to the Device Drive pane.

To create a folder on the device drive, right-click the root drive and select Add Folder.

7 Repeat Step 5 for each file or application you want to add to the custom CAB file.

8 (Optional) Add an existing CAB file to your custom CAB file by selecting Import a CAB File.
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9 Select Build a CAB File to save the CAB file and select a name for the file.

10 Select Save to create a custom CAB file.

Android Device Enrollment With the Workspace ONE 
Intelligent Hub
The Workspace ONE Intelligent Hub application facilitates enrollment and allows for real-time 
management and access to device information. The enrollment process secures a connection between 
Android devices and your Workspace ONE UEM powered by AirWatch environment.

Android devices also support using the Workspace ONE Intelligent Hub for enrollment purposes. 
Consider using the Product Provisioning system to enroll devices through staging packages as the 
Workspace ONE Intelligent Hub enrollment method does not support some Product Provisioning 
functionality.

n WifiConfig cannot configure Fusion settings for Motorola devices. You must push the WifiConfig.apk 
as an internal application after enrollment to configure the settings. Extract the WifiConfig.apk from a 
sideload staging bundle inside the Workspace ONE Intelligent Hub folder of a device and upload it to 
the Workspace ONE UEM console as an internal application.

n Product Persistence does not support the Workspace ONE Intelligent Hub enrollment method. 
Products marked for persistence still download to the device but an Enterprise Reset removes all 
products. Persisted products do not automatically reinstall following an Enterprise Reset when the 
device reboots.

n Android Work Managed enrollment is supported provided Zebra's Stage Now staging client is used.

For additional enrollment considerations and details about configuring enrollment options including 
enforcing enrollment restrictions, see the Device Enrollment topic in Managing Devices documentation.
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Enroll Zebra Devices with Stage Now Barcode, Android
You can enroll Zebra Android devices with a Stage Now barcode straight from the console for Workspace 
ONE UEM powered by AirWatch. The Stage Now staging client is Zebra's Android solution for staging 
Zebra devices and preparing them for production use.

Workspace ONE UEM supports Stage Now given the following conditions and limitations.

For more information on Zebra Mobility, see Zebra Mobility Extensions (MX) and Full MX Feature Matrix.

If you plan to enroll Zebra devices in Work-Managed Device Mode with a Stage Now barcode, take the 
following steps.

Prerequisites

n Zebra devices must be running Android Nougat with MX version 7.1 or later.

n Zebra devices running Android Marshmallow and below must continue to use Rapid Deployment 
as the default staging client.

n You must have Android Hub version 8.2 or later uploaded to the console as the Workspace ONE 
Intelligent Hub Package.

n Relay Servers

n Stage Now supports only FTP Relay Servers set to passive mode. FTP Relay servers in active 
mode are not supported and do not function with the Stage Now client.

n HTTPS endpoints for the relay server are supported so long as they are configured using the web 
server of your choice (for example IIS). You must also select the HTTPS protocol when you 
Configure a Relay Server.

n Ensure the Stage Now URL setting, found in Groups & Settings > All Settings > System > 
Advanced > Site URLs, is set to the appropriate URL.

n If your on premises environment is configuring your own Stage Now server, then place your 
custom URL in this text box.

n If your on premises environment is not configuring your own Stage Now server, then you simply 
must open your networks to allow access to the URL listed here.

n SaaS environments do not need to change this text box.

n There must be no Google account present on the device while attempting Stage Now enrollment in 
Work-Managed Mode.

Procedure

1 Use the Organization Group selector to select the OG you want to configure for your Android devices.

2 Navigate to Groups & Settings > All Settings > Devices & Users > Android > Android EMM 
Registration and select the Enrollment Restrictions tab.
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3 Complete the following settings.

Setting Description

Current Setting Select Override and affect changes to the OG you selected in step 1.

Define the enrollment method for this 
organization group.

This setting determines how this OG treats Android (Legacy) devices. Select from 
among the following settings.

Always use Android – This setting enables the Device Owner Mode slider on the 
Generate Stage Now Barcode screen and makes it uneditable. This setting forces 
all Android (Legacy) devices that enroll in this OG to be in Device Owner Mode (or 
Work Managed Device Mode).

Always use Android (Legacy) – This setting disables the Device Owner Mode 
slider from the Generate Stage Now Barcode screen and makes it uneditable. 
This setting forces all Android (Legacy) devices that enroll in this OG to be in 
Device Admin Mode.

Define Assignment Groups that use Android – This setting enables the Device 
Owner Mode slider on the Generate Stage Now Barcode screen and makes it 
editable, allowing you the choice of enrolling Android devices in Device Owner 
Mode (Work Managed Device Mode) or enrolling them in Device Admin Mode. 
Select the Smart Groups you have assigned to the Zebra devices you want to 
enroll using these settings.

 
4 Direct your end user to take the following steps after they take possession of the newly enrolled 

device.

a Start the device from a "factory settings" state.

b Ensure that there is no Google account on the device.

c Proceed through the Setup Wizard or scan the "skip setup wizard" barcode provided by Zebra.

d Open the Stage Now application.

e Scan the barcode.

The device is enrolled into Work-Managed mode automatically.

What to do next

You can optionally continue to the next step of making a Stage Now barcode by proceeding to the next 
step, Generate a Barcode Staging Package with the Enrollment Configuration Wizard.

Zebra Stage Now Special Characters, Android
While configuring relay servers for Zebra device enrollment using StageNow barcodes, you are not 
allowed to use certain characters for the login password.

Password Restrictions
Customers who have any special characters in the Relay Server > Device Connection for staging 
configuration experience issues while enrolling Zebra devices with a StageNow barcode.

Do not use any of the following characters in the FTP/FTPS password.

“@” | “/” | “\” | “:” | “;” | “,” | “?” | “$” | “&” | “=” | “+” | "!"

Product Provisioning

VMware, Inc. 49



Domain User Names
You can authenticate onto StageNow relay servers using a domain user name. For more information, see 
the Table 2-3. Device Connection Tab of the Configure a Relay Server topic.

Enroll Honeywell Devices with Staging Barcode, Android
You can enroll Honeywell Android devices with a staging barcode straight from the console for 
Workspace ONE UEM powered by AirWatch. The Honeywell Enterprise Provisioner is Honeywell's 
Android solution for staging devices and preparing them for production use.

n Ensure the Honeywell Enterprise Provisioner URL setting, found in Groups & Settings > All 
Settings > System > Advanced > Site URLs, is set to the appropriate URL.

n If your on premises environment is configuring your own Honeywell Enterprise Provisioner server, 
then place your custom URL in this text box.

n If your on premises environment is not configuring your own Honeywell Enterprise Provisioner 
server, then you must open your networks to allow access to the URL listed here.

n SaaS environments do not need to change this text box.

n Protocols supported: FTP, FTPS, HTTPS

n Advanced Staging Manifest is not currently supported.

Prerequisites

If you plan to enroll Honeywell devices with a staging barcode, take the following steps.

Procedure

1 Use the Organization Group selector to select the OG you want to configure for your Android devices.

2 Navigate to Groups & Settings > All Settings > Devices & Users > Android > Android EMM 
Registration and select the Enrollment Restrictions tab.
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3 Complete the following settings.

Setting Description

Current Setting Select Override and affect changes to the OG you selected in step 1.

Define the enrollment method for this 
organization group.

This setting determines how this OG treats Android (Legacy) devices. Select from 
among the following settings.

Always use Android – This setting enables the Device Owner Mode slider on the 
Generate Honeywell Barcode screen and makes it uneditable. This setting forces 
all Android (Legacy) devices that enroll in this OG to be in Device Owner Mode (or 
Work Managed Device Mode).

Always use Android (Legacy) – This setting disables the Device Owner Mode 
slider from the Generate Honeywell Barcode screen and makes it uneditable. 
This setting forces all Android (Legacy) devices that enroll in this OG to be in 
Device Admin Mode.

Define Assignment Groups that use Android – This setting enables the Device 
Owner Mode slider on the Generate Honeywell Barcode screen and makes it 
editable, allowing you the choice of enrolling Android devices in Device Owner 
Mode (Work Managed Device Mode) or enrolling them in Device Admin Mode. 
Select the Smart Groups you have assigned to the Honeywell devices you want to 
enroll using these settings.

 
4 Direct your end user to take the following steps after they take possession of the newly enrolled 

device.

a Start the device from a "factory settings" state.

b Ensure that there is no Google account on the device.

c Proceed through the Setup Wizard.

d Open the Enterprise Provisioner or the EZ Config application.

e Scan the barcode.

The device is enrolled automatically.

What to do next

You can optionally continue to the next step of making a Honeywell barcode by proceeding to the next 
step, Generate a Barcode Staging Package with the Enrollment Configuration Wizard.

How Do You Configure a Zebra Work Managed Device 
with Stage Now, Relay Servers, and CICO Launcher
Workspace ONE UEM powered by AirWatch lets you provision a Zebra Rugged device with a Stage Now 
barcode that installs a host of useful configs including a Wi-Fi profile, Relay Server connectivity, and a 
Check-in/Check-out launcher.
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Use Case: You want to provision a Zebra device with a way to check the device in and out making it 
suitable for multi-user use. These devices also need a relay server to host provisioned content, a Wi-Fi 
profile to connect it to the network, and a Stage Now barcode to deliver it all. This use case represents a 
"one-stop" provisioning solution for Zebra Android devices.

Prerequisites

n The Zebra device must begin in a factory reset state with Android 7.0 (Nougat) or later and MX 
version 7.1 or later.

n The Zebra device must also have VMware Workspace ONE Intelligent Hub version 8.2 or later.

Note   Devices without these minimum specifications will not be included in this Stage Now barcode load 
out.

Procedure

1 Create a staging-based relay server. This is the server that hosts all the staging content.

a Navigate to Devices > Provisioning > Relay Servers > List View.

b Select Add > Add Relay Server.

c Configure the relay server options per your preferences and specifications. For the purpose of 
this use case, select the Assignment tab and in the Staging Server section, select one or more 
organization groups that manage your Zebra devices.

d Save the Staging Relay Server.

2 Create a production-based relay server. This is the server that hosts all the content to be used on a 
day-to-day basis after the conclusion of this use case.

a While still in the Relay Servers List View, select Add > Add Relay Server.

b Configure the relay server options per your preferences and specifications. For the purpose of 
this use case, select the Assignment tab and in the Production Server section, select the same 
organization groups you selected for the Staging Relay Server in the previous step.

c Save the Production Relay Server.

3 Create the CICO Launcher profile. The launcher is the component that facilitates the check-in / 
check-out process.

a Navigate to Devices > Provisioning > Components > Profiles and select Add Profile > 
Android.

b For Profile Scope, set the drop-down menu to Production.

c Select the Launcher payload from the list to the far-left of the window.

d Select the Configure button and select the app options for the launcher per your preferences.

e Select Settings, include an Administrative Passcode, then select Close.
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f Save the Launcher configuration.

g Select Save again to save the new Android Provisioning Profile.

4 Create a Wi-Fi profile. This profile ensures that the Zebra device has Wi-Fi connectivity, which is 
important.

a While still at Devices > Provisioning > Components > Profiles from the previous step, select 
Add Profile > Android.

b For Profile Scope, set the drop-down menu to Staging.

c Select the Wi-Fi payload from the list at the far-left of the window.

d Select the Configure button and complete the Wi-Fi connection details. Make certain to select a 
Wi-Fi password that complies with the minimum length and complexity rules for passcodes.

e Save the Wi-Fi Profile.

5 Create a smart group that contains all the Zebra devices you want to target for this use case. This 
smart group is how the CICO Launcher profile gets installed on your Zebra device fleet.

a Navigate to Groups & Settings > Groups > Assignment Groups and select the Add Smart 
Group button.

b Name the smart group something like "Zebra Devices CICO Launcher".

c Under Organization Group, select the OG that manages your Zebra devices.

d Under Platform and Operating System, select Android Greater Than or Equal To Android 
7.0.0.

e Under Enterprise OEM Version, select Motorola/Zebra Greater Than or Equal To Zebra 
Mobility Extensions Version 7.1.

f Save the smart group.

6 Create a product, include the CICO launcher, and assign it to the smart group.

a Navigate to Devices > Provisioning > Product List View and select the Add Product button.

b Select the Android platform.

c Enter the Name of the product and under Managed By, select the OG that manages your Zebra 
devices.

d Under Smart Groups, select the smart group you made in the previous step from the drop-down 
menu.

e Select the Manifest tab and then select the Add button.

f Under Actions to Perform, select Install Profile.

g Under Profile, select the CICO Launcher Profile you made in step 3.

h Save the product.
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7 Configure an Android Staging Profile.

a Navigate to Devices > Lifecycle > Staging > List View and select Add Staging > Android.

b Complete all required options on the General tab.

n Owned By - Select the organization group that manages your Zebra devices.

n Enrollment User - You must select a device user who is configured as a staging multi-user. 
You can edit an existing user to be a staging multi-user by taking the following steps.

a Navigate to Accounts > Users > List View.

b Select the Edit icon ( ) to the left of the user you want to change.

c Select the Advanced tab and in the Staging section, Enable Device Staging and then 
enable Multi User Devices.

d Save the edit.

n Hub - Select version 8.2 or later of the Workspace ONE Intelligent Hub app.

c Save the Staging Profile.

8 Configure the Stage Now barcode.

a Navigate to Devices > Lifecycle > Staging > List View and locate the Android Staging Profile 
you made earlier.

b Select the radio button to the left of the Android Staging Profile. Some new buttons display under 
the main buttons.

c Select the Stage Now Barcode button. The Generate Stage Now Barcode screen displays.

d Under Staging Relay Server, select the staging-based relay server you made earlier.

e Under Staging Profile, select the Wi-Fi profile you made earlier.

f Select Save to save the barcode as a PDF file.

9 Ensure that the Stage Now URL setting is configured correctly, found in Groups & Settings > All 
Settings > System > Advanced > Site URLs. If you are operating in a SaaS environment, you can 
skip this step.

n If your on-premises environment is configuring its own Stage Now server, then enter that custom 
URL in this text box.

n If your on-premises environment is not configuring its own Stage Now server, then you must open 
your networks to allow access to the URL listed here.
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10 Distribute the Zebra device and the PDF produced in a previous step to the staging individual and 
direct them to scan the following Zebra Skip Setup Barcode which runs the Stage Now application.

a
Figure 3-1. Zebra Skip Setup Barcode

11 Stage Now makes the request to scan a barcode.

12 Scan the Stage Now Barcode provided in PDF saved in an earlier step.

Scanning the Stage Now Barcode triggers the following actions.

n MDM information is obtained.

n The Wi-Fi profile is downloaded and assigned.

n A connection is made to the Staging Relay Server, enabling the device to pull the Staging Profile.

n The Staging Profile contains the Workspace ONE Intelligent Hub app, ZebraMXService.apk, and 
credentials.bin file.

n The device installs the Workspace ONE Intelligent Hub app. The Hub opens and interprets the 
credentials.bin file, which in turn triggers the derived user information to be sent to the device 
services server for authentication and authorization.

n Device services validates the credentials.

n The Workspace ONE Intelligent Hub calls Google EMM registration service to obtain an 
Enterprise ID.

n Google responds with a masked Gmail account linked to the Enterprise and a token for 
authentication. This response allows the Workspace ONE Intelligent Hub app to continue 
enrolling.

13 Accept the privacy information and any other prompts presented by the Workspace ONE Intelligent 
Hub. For more information about Workspace ONE Mobile Applications Privacy, see https://
kb.vmware.com/s/article/2960318.

The Zebra device enrolls into Workspace ONE UEM and the Workspace ONE Intelligent Hub app 
sends intents to the device to install additional products assigned in the UEM console including the 
CICO Launcher configured earlier.

14 The Zebra device downloads products from the Production Relay Server.
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15 The VMware Launcher prompts the end user to log in. The device end user takes possession of the 
device by entering their enterprise credentials (AD/LDAP/Basic) and organization group as required.

n VMware Launcher receives the credentials and passes off the authentication to the Workspace ONE 
Intelligent Hub app.

n The Workspace ONE Intelligent Hub app sends the user information to device services which 
validates the credentials.

n The Workspace ONE Intelligent Hub directs the VMware Launcher to load the configured layout and 
also directs the device to pull down any other products that are assigned to the end user. It pulls 
these products from the Production Relay Server, configured earlier.

n The device works with Google EMM to install any public applications that are assigned to the device.

What to do next

The device is successfully checked out and the end user can use the device in its full capacity.
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Products 4
Think of products as an ordered installation of device profiles, applications, and files/actions to be pushed 
to devices based on the conditions you create. Products are the main feature of the Product Provisioning 
system in Workspace ONE UEM powered by AirWatch.

Important   You must upload the content of the product before a product can be created.

Product Basics
After products are created and activated, they are pushed to the device based on the conditions set. 
Conditions determine when a product is downloaded and when it is installed. Content and Application 
(Android only) provisioning by products can be pushed to devices through optional relay servers.

Products are pushed to devices that by way of smart group assignments. These groups control which 
devices get which product based on how the group is created. You can also use Assignment Rules to 
target your products to devices.

Note   Windows Rugged Only: In addition, you can ensure the product you provision from the console 
or from an API call is the exact same product that gets received by the Windows Rugged device. This 
product verification is built into the provisioning process. If the product status is Compliant, then the 
product on the device matches the product provisioned. If validation discovers a mismatch, the console 
pushes the content to the device again to ensure compliance between the product and the device. In this 
way, the product ensures that your devices remain up-to-date.

This chapter includes the following topics:

n Create a Product

n Product Provisioning Profiles

n Product Verification

n Product Persistence, Android, and WinRugg

n Product Push Automatic Retry

n Application Provisioning, Android

n Product Conditions

n Event Actions, Android and WinRugg
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n Files-Actions for Products

n Product Sets

n Custom Attributes

Create a Product
After creating the content you want to push to devices in Workspace ONE UEM powered by AirWatch, 
you can put all that content, including the apps, the files, and all the installation rules, in a product to be 
provisioned. Creation of the product also defines the order in which content is installed.

Prerequisites

To edit a product, the product must be deactivated in the list view first.

Procedure

1 Navigate to Devices > Provisioning > Product List View > Add Product.

2 Select the Platform you want to create a staging configuration for.

3 Complete the General text boxes.

Setting Description

Name Enter a name for the product. The name cannot be longer than 255 characters.

Description Enter a short description for the product.

Managed By Select the organization group that can edit the product.

Assigned Smart 
Groups

Enter the smart groups the product provisions.

4 Select Add Rules and use Assignment Rules to control which devices receive the product.

Application rules can be applied to unmanaged applications installed on the device. Because the 
Workspace ONE UEM console does not manage ALL applications, these rules are available for 
certain system applications and third-party applications.

Setting Description

Add Rule Select to create a rule for product provisioning. Displays the Attribute/Application, Operator, and 
Value drop-down menus.

Add Application Rule 
(Android Only)

Android Only: Select to create an application rule for product provisioning. This rule allows you to 
require applications to have specific versions install on the device for the rule to pass. Displays the 
Attribute/Application, Operator, and Value drop-down menus.

Add Logical Operator Select to display a drop-down menu of logical operators such as AND, OR, NOT, and parentheses. 
Allows for more complex rules.

Attribute/Application The custom attribute or application used to designate which devices receive the product. Custom 
attributes are created separately.

Android Only: Only internal applications display in the drop-down menu. You can use Enter Manually 
to enter the package ID of any application that must be present on the device.

For more information, see Custom Attributes.
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Setting Description

Operator This operator compares the Attribute to the Value to determine if the device qualifies for the product.

Note   There is a limitation on the less than (<) and greater than (>) operators. This limitation includes 
"less than or equal to" and "greater than or equal to" variants. These operators are mathematical in 
nature, which means they are effective at comparing numbers including integers. They cannot be used 
to compare non-numeric text strings. And while it is common for software versions to be represented 
with numbers indicating a graded versioning system (for example, 6.14.2), such representations are not 
numbers because they have more than one decimal point. These representations are actually text 
strings. Therefore, any assignment rule that compares software version numbers with multiple decimal 
points using greater than or less than operators (and their variants) can result in an error message.

Value The value of the custom attribute. All values from all applicable devices are listed here for the Attribute 
selected for the rule.

5 Select Save and add the Assignment Rule to the product.

6 Select the Manifest tab.

7 Select Add and select the Action(s) To Perform for the Manifest.

Action(s) to Perform 
Drop-Down Menu Settings

Install Profile In the Profile text box, select the profile to install during the staging configuration. This component 
must be made before adding it to the manifest.

Uninstall Profile In the Profile text box, select the profile to remove during the staging configuration.

Install Application 
(Android Only)

In the Application text box, select the App to install during the staging configuration. This 
component must be made before adding it to the manifest.

Uninstall Application 
(Android Only)

In the Application text box, select the App to remove during the staging configuration.

Install Files/Actions In the Files/Actions text box, select the Files/Actions component to install during the staging 
configuration. This component must be made before adding it to the manifest.

Uninstall Files/
Actions

In the Files/Actions text box, select the Files/Actions component to remove during the staging 
configuration.

Reboot (Android Only) Reboots the device during the staging configuration. This action works best as the last step of the 
manifest.

Warm Boot/Cold Boot 
(WinRugg Only)

Warm Boot reboots the device during the staging configuration. This action works best as the last 
step of the manifest.

Cold Boot shuts down the device, forcing a restart by the end user. This action works best as the 
last step of the manifest.

Install Event Action 
(Android and WinRugg 
Only)

In the Event Action text box, select the Event Action component to install during the staging 
configuration. This component must be made before adding it to the manifest.

Uninstall Event Action 
(Android and WinRugg 
Only)

In the Event Action text box, select the Event Action component to remove during the staging 
configuration.
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8 Android and Windows Rugged only - Enable or disable Persistent through enterprise reset. 
Enable to keep the profile, application, files/actions, or event action on the device after an enterprise 
reset. For more information, see Product Persistence, Android, and WinRugg.

9 When finished with the single Manifest action, select Save.

10 Select Add again to add additional Manifest actions. You can adjust the order of manifest steps using 
the up and down arrows in the Manifest list view. You can also edit or delete a manifest step.

11 When you are finished adding actions, select Save.

12 Select the Conditions tab if you want to use conditions with your product.

These conditions are optional and are not required to create and use a product.

13 Select Add and select either Download Conditions, Install Conditions, or both.

n A Download Condition determines when a product is downloaded but not installed on a device.

n An Install Condition determines when a product is installed on a device.

14 Select the Deployment tab if you want to control the time and date that products are activated and 
deactivated.

This tab is optional and is not required to create and use a product.

Setting Description

Activation Date Enter the time when a product automatically activates for device job processing.

If the activation date is defined and the product is saved, the product stays inactive until the activation 
date is met according to the Workspace ONE UEM server time. The policy engine wakes up and 
automatically activates the product. You can manually activate products with activation dates 
beforehand. Manually activating a product overrides the activation date.

Deactivation Date Enter the time when a product automatically deactivates from current and new device job processing.

If the deactivation date is defined and the product is saved and currently active, it stays active until the 
deactivation date is met according to the Workspace ONE UEM server time. The policy engine wakes 
up and automatically deactivates the product. You can manually deactivate products with deactivation 
dates beforehand. Manually deactivating a product overrides the deactivation date.

A deactivation date cannot be set earlier than the activation date.

Pause/Resume Enable to ensure that an interrupted product provisioning due to Wi-Fi connectivity issues is retried in 
the following manner.

The Workspace ONE Intelligent Hub makes 5 attempts to contact the relay server to download the 
product. If the download fails or Wi-Fi connectivity fails, then the Hub makes 5 attempts to connect to 
the Device Services URL by way of HTTPS (configure this setting at Groups & Settings > All Settings 
> Admin > Content Delivery Settings > File Sources Include HTTPS set to enabled). If the product is 
still unavailable, then the job is moved to a Paused state.

After a while, the Hub changes the job state to Started and makes another 5 attempts to connect to the 
relay server and another 5 attempts on the Device Services (provided the option is enabled).

It repeats this process for a maximum 24 hours after the first connection failure. If, after this 24-hour 
period, the download is still not complete, the job is set to Failed.

Product Type Determine if a product is Required or Elective.

A required product provisions to assigned devices when deployment settings are met. An elective 
product is only provisioned when it is manually activated on the Device Details View of a provisioned 
device.
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Setting Description

Deployment Mode Select from the following how the product is to be deployed.

Relay Server with Workspace ONE Server as Backup – The default deployment mode. The device 
attempts to receive the product from the relay server initially, making 5 separate attempts, then falling 
back to device services as a secondary source.

Relay Server Only – The device attempts to receive the product from the relay server only. In a 
scenario where the relay server is not configured or deactivated, the fallback source is device services.

Auto Retry Enables the automatic retry of a product push when it detects a push failure rate of up to 5%, making a 
maximum of three retries per device. For details, see Product Push Automatic Retry.

15 Select the Dependencies tab if you want to set the product to only provision devices that have other 
products provisioned as well.

a Select Add and add a dependent product.

You can add as many dependent products as you want.

16 Select to deploy the product immediately by selecting Activate or wait to deploy later and select 
Save.

Product Provisioning Profiles
Workspace ONE UEM powered by AirWatch allows you to create profiles for your rugged devices. The 
profiles created for rugged devices are installed or uninstalled as part of a product. Unlike device profiles 
created for MDM deployments, product provisioning profiles have different rules governing editing and 
deleting.

Profiles created under Products are different than those created through Workspace ONE UEM. This 
section lists the differences between profiles created for normal device use and those created for use in 
product provisioning.

Profile Creation and General Settings
Profiles for use with product provisioning must be created by navigating to Devices > Provisioning > 
Components > Profiles and select Add Profile.

While creating these product provisioning profiles, the general tab will be different than the normal general 
tab for profiles.

Note   Assignment of profiles happens at the product level and not at the profile level as it is in 
smartphone profiles.

Saving Product Provisioning Profiles
After configuring your product provisioning profile, select Save instead of Save & Publish.

Profiles names cannot be longer than 255 characters.
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Update Profiles
When you edit an existing profile, the version number increases. After saving the edits, Workspace ONE 
UEM runs a check on all active products to find any that contain the newly edited profile.

If any active products contain the profile, a warning prompt displays listing all active products affected by 
the edited profile. You can then select to Activate or Deactivate a product using the profile.

Delete a Product Provisioning Profile
You can delete an unwanted or unused product provisioning profile provided it is not attached to a 
product. Workspace ONE UEM monitors attempts to delete a profile against the list of active products.

Prerequisites

Before you can delete a product provisioning profile, you must detach it from all products.

Procedure

1 Select the Profile listed in the Warning prompt.

2 Select Edit.

3 Remove the profile from the product.

4 Select Save.

5 Repeat these steps for all products containing the profile.

6 After the profile detaches from all products, you can delete the profile.

If a profile is part of an active product, a warning prompt displays listing any product that uses the profile.

Product Verification
Workspace ONE UEM powered by AirWatch lets you ensure the product you provision from the console 
or from an API call is the exact same product that gets received by the device. This product verification is 
built into the product provisioning process.

Verification happens on the device Hub side but both the device end user and the administrator on the 
console side is made aware of the product's status.

Product Persistence, Android, and WinRugg
Workspace ONE UEM powered by AirWatch lets you direct profiles, files-actions, and applications to 
remain on a device even after an enterprise reset. Content marked to persist following an enterprise reset 
reinstalls following the device restart after the Workspace ONE Intelligent Hub installs.

The help desk benefits the most from Product Persistence since it reinstalls required products and 
applications even after an enterprise reset.
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Supported Devices
n Product Persistence for Windows Rugged only applies to Motorola, Honeywell, Psion, Pideon, and 

Intermec devices running Windows Mobile.

n Product Persistence for Android only applies to legacy Motorola, Zebra, and Honeywell devices.

How Persistence Works
n A device must contain a staging configuration so that the Workspace ONE Intelligent Hub and 

enrollment reinstall following the enterprise reset. Staging configurations persist on a device.

n Set to persist any profiles, files-actions, or applications that you want to remain on the device after the 
enterprise reset.

n The device resets when the Enterprise Reset command is sent (see Chapter 5 Product 
Management). After resetting, the restore process begins.

n The Workspace ONE Intelligent Hub for the device reinstalls during the restore process.

n After the Workspace ONE Intelligent Hub is installed, any persisted profiles, such as Wi-Fi, reinstall.

n Any persisted files-actions or applications are reinstalled.

Product Push Automatic Retry
In the product provisioning system of Workspace ONE UEM powered by AirWatch, when a device fails to 
process a provisioned product for whatever reason, the product push is automatically retried up to three 
times per device.

This feature helps to minimize the amount of force reprocessing you must request. Enable this feature 
when you make a new product by navigating to Devices > Provisioning > Product List View and select 
the Add Product button followed by the platform selection. The Auto Retry check box is in the 
Deployment tab.

Automatic Retry Trigger
The automatic retry trigger audits each product job by making a rolling calculation of the product push 
failure rate. If the amount of failed product pushes is 5% or less, then an automatic retry is triggered. At 
this stage, individual devices are sampled and if the auto retry fails again, then another retry is attempted. 
This retry happens a maximum of three times per device.

If the amount of failed pushes is greater than 5% (or the rolling calculation increases to greater than 5%), 
then automatic retry is not triggered or the retry stops.

Manual Force Reprocess
You can monitor for product push failures by navigating to Devices > Provisioning > Product 
Dashboard.

For details on how to request a Force Reprocess, see Products List View.
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Application Provisioning, Android
Product provisioning in Workspace ONE UEM powered by AirWatch allows you to upload applications to 
the console for distribution as part of a product. Through product provisioning, you can upgrade 
applications and remove them remotely.

Silent install of applications is supported on Android Work Managed devices and on Android Legacy 
devices with an OEM service application.

Note   Smart group assignment happens on the Product level and not on the Application level.

Upload an Application to Provision, Android
Applications added through product provisioning use the rules and restrictions of the product to manage 
the installation. Add applications that you want installed onto devices as part of a product.

Procedure

1 Navigate to Devices > Provisioning > Components > Applications and select Add Application.

2 Enter who the application is Managed By.

3 Select Upload and browse for the Application File.

4 Select Choose File and add a local file or select Link to enter a link.

5 Select Save and finish uploading the application.

The uploader reviews the version of the application you have selected and compares it to the 
applications that have already been uploaded. If it finds a match, it prevents you from uploading it 
again.

6 Select Continue and add the application to the Product Provisioning application list.

Add New Application Versions to Provision, Android
You can add a version of an already uploaded application. This action enables you to push the newest 
version of an application to end users using the existing products you have already created.

Procedure

1 Navigate to Devices > Provisioning > Components > Applications and select More.

2 Select the Add Version option from the drop-down menu.

3 Upload the new version of the application as described in Upload an Application to Provision, 
Android.

4 Select Save.

5 Navigate to Devices > Provisioning > Product List View and find the product that contains the 
application you want to update. If necessary, use the filters to narrow your search.
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6 Select the radio button to the left of the product name.

This radio button selection displays some action buttons at the top of the List View.

7 Select the Edit action button.

The Edit product screen displays.

8 In the Manifest tab, find the Install Application Action Type that contains the application you want to 
update and select the small blue pencil icon to the right of the Description column.

The Edit Manifest screen displays.

9 In the Application text box, delete the application name.

This action causes the drop-down menu to appear which now displays all versions of all applications 
in your entire Applications library.

10 Select the new version of the application that you uploaded earlier.

11 Select the Save button.

The Edit product screen now shows the Manifest that includes the new version of the application.

12 Select the Activate button.

This action pushes the new version of the application to the devices provisioned with this product.

Delete Applications from Provisioning, Android
Remove unwanted applications from your products. The Workspace ONE UEM console monitors any 
attempt to delete an application against the list of active products.

Prerequisites

Before you can delete an application, it must be detached from all products.

Procedure

1 Navigate to Devices > Provisioning > Applications.

2 Locate the Application you want to delete from the List View.

3 Select the down arrow button to the far-right of the row belonging to the application.

4 Select Delete.

5 The Restricted Action screen display. Restricted Action is a security feature designed to prevent 
accidental application deletions. Enter your four-digit security PIN and proceed with the deletion.

6 If the application you selected is part of a product, then you are not allowed to delete it until the 
application is detached from the product. A green warning prompt appears. At the bottom of the 
warning prompt, lists all the products to which the selected application belongs. Take note of these 
products.

7 Navigate to Devices > Provisioning > Product List View.

8 Select the Product listed in the warning prompt.

Product Provisioning

VMware, Inc. 65



9 Select the Edit button. The Edit Product screen displays.

10 Switch to the Manifest tab.

11 Select the delete button (x) and detach the application from the product. You are prompted to confirm.

12 Select Save.

13 Repeat steps 8–12 for all products containing the application.

What to do next

After the application detaches from all products, you can delete the application by returning to complete 
steps 1–5.

Product Conditions
Product provisioning in Workspace ONE UEM powered by AirWatch allows for conditions to be placed on 
products. A condition determines when the product or OS upgrade package can be downloaded and 
installed. Conditions are reviewed when a product is pushed to a device.

Your device fleet is not always readily available for maintenance. You might have devices in different time 
zones or countries. Some devices may be away from a reliable hotspot. Also, you cannot always ensure 
that a device is not in use when you push a product. For all these reasons and many more, you can use 
conditions to delay the download and installation of products.

These conditions defer the product download or installation until the device meets the criteria of the 
assigned condition. You can set products to download only based on battery life, power adapters, user 
confirmation, and other criteria. The available conditions for your products vary based on the device 
platform.

When you edit a condition, be aware that the changes can filter down to active Products or Event-Actions 
that are a part of active Products. For more information, see Effects of Editing an Event-Action or 
Condition.

Copy or Delete Conditions in List View
You can view all conditions in a list view. You can also edit and delete conditions from the list view.

Prerequisites

Before you can delete a condition, you might have to detach it from one or more products. For more 
information, see Detach a Condition from a Product.

Procedure

1 Navigate to Devices > Provisioning > Components > Conditions.

2 Select the pencil icon ( ) to the left of the name of the condition and open the Edit Condition 
screen.
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3 Select the radio button to the far left of the condition and display the Copy and Delete buttons, 
offering more actions.

Create a Condition
You can set products to download and install on your device only when certain conditions are met. Create 
a condition and determine when a product downloads and installs onto your devices.

Procedure

1 Navigate to Devices > Provisioning > Components > Conditions and select the Add Condition 
button.

2 Select the Platform you want to create a condition for.

3 Complete the Create Condition Type settings.

Settings Description

Name Enter a name for the condition. The name cannot be longer than 255 characters.

Description Enter a description for the condition.

Condition Select from the drop-down menu of platform-specific conditions. The type of 
condition affects the parameters on the Details tab to follow. For more information, 
see Conditions Defined.

Managed By Select the organization group that manages the condition.
 

4 Select Next.

5 Complete the Details settings based on the condition type selected.

6 Select Finish.

Conditions Defined
You can learn how each condition works and which platforms support which conditions.

Platform-Specific Conditions

Select a condition to be taken to its definition. The File condition has two versions, one for Windows 
Rugged and QNX, the other for Android. Select the check marks for File to be taken to the platform-
specific definition.

Windows 7 Windows

Condition Android macOS QNX & Desktop Rugged

Adapter     ✓

Adapter Time ✓ ✓  ✓ ✓

Battery Threshold ✓    ✓

Confirm ✓ ✓   ✓

Connectivity State     ✓
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File –––> File (2)  File (1)  File (1)

Memory Threshold     ✓

Power ✓   ✓ ✓

Recurring Schedule ✓

Schedule ✓   ✓  

SD Encryption ✓   ✓  

Time ✓  ✓  ✓

Adapter

Supported Platform: Windows Rugged – This condition type tests to see which, if any, Network 
Adapters are connected. This condition can be relevant if network connectivity is a scarce or expensive 
resource and certain operations are limited to use over certain Network Adapters or prohibited from use 
over certain Network Adapters.

Settings Descriptions

What would you like to 
do with the adapters?

Select to use the adapters you define or exclude them.

n Only use these adapters to connect.

n Exclude these adapters from connecting.

Adapter 1 Select to select an adapter from the list or enter the adapter by name.

n Select From List.

n Enter name.

Select adapter. Select the network adapter from the drop-down menu.

Specify Adapter. Use or exclude the adapter you enter here.

Adapter 2/Adapter 3 Use or exclude additional adapters you enter here.

Adapter Time

Supported Platforms: Android, macOS, All Windows – This condition type tests for various 
combinations of constraints related to Network Adapters including local date, time, and frequency on the 
device.

Settings Description

Specify scenario #1? Set to Specify this scenario to begin configuring the condition scenario.

Up to 5 scenarios can be entered, each with their own constraint choices.

Each Scenario is an OR statement and each option inside a Scenario is an AND statement. For 
example, a device monitors whether Scenario #1 OR Scenario #2 is true. If Scenario #1 is true, it 
reviews if all the constraints listed are true because they are AND statements.

Scenario description Enter a description for the adapter time scenario.
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Settings Description

Constrain Network 
Adapters?.

Set to Constrain based on the Best Connected Network Adapter and configure the following.

n Specify any Included or Excluded Network Adapters.

n Either Select Network Adapter Class from a drop-down list or Type in a Network Adapter 
Name.

n Up to five network adapters can be selected in the Adapter selection method? setting.

n For each adapter you want to include/exclude, Select a Network Adapter Class drop-down 
menu and entering a specific Adapter name.

If you want to skip this kind of constraint, then select Don't constrain based on the Best Connected 
Network Adapter. Then you can proceed with defining another kind of constraint.

Constrain days of 
week?.

For each day of the week, select whether it is included or excluded.

Constrain months?. For each month, select whether it is included or excluded.

Constrain days of 
month?.

Enter a Start day of month? and an End day of month?.

Constrain years?. Enter a Start year? and an Last year?.

Constrain time of 
day?.

Enter the Start hour?, Start minute?, End hour?, and End minute?.

Set frequency limit?. Ranges from Every 15 Minutes to Every 1 Week.

Set frequency limit?. Ranges from Every 15 Minutes to Every 1 Week.

Set frequency limit is a mandatory setting. The Adapter Time condition will not function correctly 
without it.

Note   ActiveSync and VPN Network Adapters are not supported under the Android platform.

Battery Threshold

Supported Platforms: Android and Windows Rugged – This condition type tests the device to see 
what level battery charge remains. You can test for charge levels under a defined threshold or over a 
defined threshold.

Settings Description

Battery Level Select between Less than or Equal To, Greater Than or Equal To, and Between to define a range of 
charge levels.

Battery Percentage Enter a percentage between 1 and 100. When Between is selected, you must enter a range comprised 
of two percentage levels.

Connectivity State

Supported Platform: Windows Rugged – This condition tests the device for the type of connection and 
the length of time it has been connected.
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Settings Description

the device is 
connected to.

Select between Wi-Fi and Cellular.

the device is 
continuously.

Two selections must be made.

First, select whether to test if the device has been Connected or Disconnected.

Next, select the length of time it has been in such a state.

Confirm

Supported Platforms: Android, macOS, Windows Rugged – This condition type prompts the end user 
to determine whether the condition is met. This prompt is customizable so you can control what displays 
on the prompt.

Table 4-1. Message to Be Displayed (Confirm)

Settings Description

First line prompt Enter a header of the prompt.

Second line prompt Enter the body of the prompt.

Enter the subheading of the prompt (macOS Only).

Third line prompt If you enable a countdown, you can enter a countdown phrase into this setting.

For example, "You have %count% seconds to comply" where %count% is the countdown.

Enter the body of the prompt into the Third Line Prompt (Mac OSX Only).

Allow users to cancel 
actions?

Select Yes if you want to give users a chance to opt out of the action upon which this condition is 
placed.

Select No and obligate users to accept the action.
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Table 4-2. Delay (Confirm)

Settings Description

Delay (seconds) Delay for a specified time or until the end user makes a selection.

If you enter a non-zero value, the prompt waits for that value worth of seconds. Then if the end user 
does not make a selection in the time allowed, the condition is automatically considered not met.

If a value of zero is entered, then the prompt displays indefinitely until the user makes a selection.

Enable countdown? Select Yes and allow the delay time to be “counted” down on the device so the end user knows how 
much time is remaining to make a selection.

Select No and hide the delay countdown.

Table 4-3. Defer Action (Confirm)

Settings Description

Defer time. The minimum time after the condition is not met before the end user is prompted again to determine the 
state of this condition.

If a non-zero value is entered, the end user is not prompted again for at least this number of seconds.

If a value of zero is entered, then the end user might be prompted again when the next execution of the 
Check-In command.

Maximum number of 
defers

The maximum number of times the condition is not met.

After the condition is not met this number of times, it is either met or failed, depending on the setting of 
the next feature.

If a value of zero is entered, then the condition is met or failed on the first time.

Action after maximum 
defers.

Select the action to trigger after the maximum number of defers is met.

n Fail Condition.

n Display Cancel Button.

n Pass Condition.

File (1)

Supported Platforms: QNX and Windows Rugged – This condition type tests the device to see if a file 
is present or not. You can set the condition to test if the file is on the device, and if it is, test true. You can 
also set the condition to test true if a file is not on the device. Finally, you can set the condition to create a 
flag file and save it on the device for use with third-party programs.

Settings Description

Specify Flag File Set to Specify Flag File to enable the use of a flag file for use with third-party programs.

Specify Flag File 
Location

Enter a location path for the flag file.

Specify Flag File 
Contents

Enter the content you want in the flag file.

Specify Scenario #1 Set to Specify this scenario to enable testing a file's existence on the device.

Test File Enter the name of the test file the condition tests.

Test Type Test whether the File Exists or the File Does Not Exist.

Remove File Either Remove File or Do Not Remove File when the test finishes.
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File (2)

Supported Platform: Android – This iteration of the file condition is specific to Android, but it still tests 
the device to see if a file is present or not. You can set the condition to test if the file is on the device, and 
if it is, test true. Alternatively, if a file is not on the device, you can also set the condition to test true.

Settings Description

File Name Enter the name of the file the system searches for, including device path. The system searches for this 
file before it downloads or installs product components.

Condition Met When Select whether the system downloads or installs based on the existence of the file (File Found) or 
nonexistence of the file (File Not Found).

Frequency Select how often the system searches for this file.

Duration Select how long this condition performs the action.

After Duration 
Exceeded

Select how to proceed after the condition duration period elapses.

Memory Threshold

Supported Platform: Windows Rugged – This condition type tests the device for the level of system 
memory that is available.

Settings Description

Available memory is 
less than

Enter a percentage of available memory such that your action only runs if the device has less than the 
indicated amount.

Power

Supported Platforms: Android and All Windows – This condition type tests how a device is being 
powered, including whether the device is plugged in or has a full battery level. Use a Power condition 
type to prompt users to place the device into the cradle or to insert a charged replacement battery. If your 
testing needs are particular, the Battery Threshold condition (Android and Windows Rugged only) offers 
more granular battery tests than Power offers.

Table 4-4. Message to Be Displayed (Power)

Settings Description

First line prompt Enter a header for the prompt.

Second line prompt Enter the body of the prompt.

Third line prompt If you enable a countdown, you can enter a countdown phrase into the Third line prompt text box.

For example, "You have %count% seconds to comply" where %count% is the countdown clock.

Table 4-5. Condition (Power)

Settings Description

Required power level Enter the required power level for the condition to test true.

n A/C.

n A/C or Full Battery.
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Table 4-6. Delay (Power)

Settings Description

Delay (seconds). Use this to delay for a specified time or until the end user makes a selection.

If you enter a non-zero value, the prompt waits for that value worth of seconds. If the end user does not 
make a selection in the time allowed, the condition is automatically considered not met.

If a value of zero is entered, then the prompt displays indefinitely until the end user makes a selection.

Enable countdown? This allows delay time to be “counted” down on the device so the end user knows how much time is 
remaining for the user to make a selection.

Recurring Schedule

Supported Platform: Android – Rather than set an event action to begin based on a specific device 
condition, you can simply assign it to a recurring schedule.

Settings Description

Scheduled Interval Select from Hourly, Daily, and Weekly as the basis for the recurrence.

Number of hours / 
days / weeks between 
events

Enter the number of hours, days, or weeks between events.

For example, if you want an event action to run every other Wednesday, then select Weekly, enter 2 in 
this text box, then select Wednesday as the Day of event occurrence.

After the product with this condition is activated, the recurring schedule begins as soon as is 
administratively possible. Continuing the above example, the recurring schedule begins the first 
Wednesday after you activate the product that uses this condition.

Table 4-7. Days of Event Occurrence (Weekly Only), Recurring Schedule

Settings Description

Sunday through 
Saturday

Select Yes for each day you want the event action to start.

Table 4-8. Start and End Time (Daily and Weekly Only), Recurring Schedule

Settings Description

Start Time. Enter the time of day the event action starts.

End Time. Many things can delay an event action from starting such as the device being offline or a previous event 
still in progress. When the device is ready, you can allow the event action to always start or set an end 
time at which point the device waits until the next start time.

Enter the time of day the event action stops making start attempts until the next scheduled start time.

Disable end time. Select Yes to disable end time. This option causes the device to make continued attempts to start the 
event action until it succeeds.

Schedule

Supported Platforms: Android, Windows 7, and Windows Desktop – This condition type tests the 
device date and time against a specific date/time entered. When the date/time is met, the condition 
passes and allows the download.

Product Provisioning

VMware, Inc. 73



Settings Description

Date Select the specific date from the drop-down calendar.

Time Select the specific hour and minute from the drop-down menu.

SD Encryption

Supported Platforms: Android, Windows 7, and Windows Desktop – This condition type tests 
whether the device's SD card is encrypted or not encrypted. This condition can be relevant if you must 
wait for the SD card to be encrypted before downloading a file.

Settings Description

SD card is Select Encrypted or Unencrypted and limit the product based on the state of the SD card encryption.

Time

Supported Platforms: Android, QNX, and Windows Rugged – This condition type tests the local date 
and time on a device.

Table 4-9. First Time Slot (Time)

Settings Description

Select the month, day 
and yearStartFinish.

Select Month, Day, and Year for both Start and Finish.

Select hour and 
minuteStartFinish.

Select Hour and Minute for Start and Finish.

Table 4-10. Second Time Slot (Time)

Settings Description

Enable time check 2?. Select Yes to display a second set of options identical to the First Time Slot.

Table 4-11. Third Time Slot (Time)

Settings Description

Enable time check 3?. Select Yes to display a third set of options identical to the First Time Slot.

Detach a Condition from a Product
Remove unwanted conditions from your product. The Workspace ONE UEM console checks any attempt 
to delete a condition against the list of active products.

To delete a condition, it must be detached from all products as detailed below.

Procedure

1 Select the Product listed in the Warning prompt.

2 Select Edit.

3 Remove the condition from the product.
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4 Select Save.

5 Repeat the steps above for all products containing the condition.

6 Once the condition detaches from all products, you can delete the condition. For more information, 
see Copy or Delete Conditions in List View.

If a condition is part of an active product, a warning prompt appears listing any product that uses the 
condition.

Event Actions, Android and WinRugg
In product provisioning for Workspace ONE UEM powered by AirWatch, there are Event Actions, or rules 
you make to trigger an action when an event occurs. The 'event' occurs followed by the prescribed 
'action'. The Event Actions wizard guides you through creating the conditions and actions together.

In cases where you want to perform a device action only when certain conditions are met, event actions 
allow you to control the timing of these actions. For example, your devices might need new files download 
to them but only until the device is not in use. A device event can wait until the device is connected to its 
charger before installing files. In another example, you can set a connectivity condition to wait for the 
device to connect to Wi-Fi before sending in a device check-in.

Event actions act as a device-based "if-this-then-that" configuration which controls the recurrence of 
actions on a device. A product only processes once on a device. Event actions, however, process any 
time the conditions are met.

Push event actions to devices as a component of a product. When you edit an Event-Action, the changes 
can filter down to Active Products. For more information, see Effects of Editing an Event-Action or 
Condition.

Create an Event Action, Android and WinRugg
You can create event actions that run on a device when certain conditions are met.

Procedure

1 Navigate to Devices > Provisioning > Components > Event Actions and select the Add Event 
Action button.

The Add Event Action wizard displays.

2 Select your device platform.

The available conditions and available actions for the platform display.

3 Select Next.
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4 Complete the Details settings and select Next when complete.

Settings Descriptions

Name Enter a name for the event action. The name cannot be longer than 255 
characters.

Description Enter a short description for the event action.

Managed By Select the organization group that can edit the event action.
 

5 Select a Condition that triggers the device action.

Table 4-12. Event-Action Conditions by Platform

Condition
Andr
oid

WinR
ugg Description

AC Power ✓ Detects when the device is connected to an AC adapter.

Adapter ✓ Detects network adapters, enabling you to select which to allow/disallow.

Battery 
Threshold

✓ ✓ Detects battery charge, enabling you to direct the device as it reaches prescribed battery 
levels.

Connectivity ✓ Detects connectivity, enabling you to take action when certain requirements are met.

Memory ✓ Detects memory levels, enabling you to take actions when it reaches certain levels.

Recurring 
Schedule

✓ Enables you to schedule your actions on a recurring basis.

Time ✓ Enables you to schedule your actions to take place on certain dates, days of the week, and 
within time-slots.

You can select a previously created condition from the drop-down menu or create a new one.

a To create a condition, select Create Condition from the drop-down menu.

b Select Next when complete.

For more information, see Create a Condition.

6 Complete the required option (Android only) Minimum Time Between Actions (hours) which limits 
the number of times the action is run when triggered by the prescribed event.

This option is not available when Recurring Schedule is included in the selected conditions.

You can select zero hours for this option but only for AC Power conditions.
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7 Select an Action to perform. The actions available depend on the device platform.

Table 4-13. Event-Action Actions by Platform

Action
Andr
oid

WinR
ugg Description

Apply Custom 
Settings.

✓ Apply custom, OEM-specific device settings based on the selected XML file, which must be 
delivered to the device through a separate File/Action.

If the file entered in the File Path text box is not found, then the Event Action does not run. 
However, the Event Action remains active, making attempts to run the custom setting XML 
file each time the condition is met.

Supported Devices:

n Android MSI devices with the Android Hub v7.1+

n Upload the ZIP file created by MSI.

n Android Zebra devices with the Android Hub v7.2+

n Upload the XML configuration file created by the Zebra Stage Now program.

Copy Files ✓ Copy files from one location to another on the WinRugg device.

Create Folder. ✓ Create a folder on the WinRugg device.

Delete Files. ✓ Delete folders from the WinRugg device.

Device Check-in ✓ Command the Workspace ONE Intelligent Hub to check in the WinRugg device for updates.

Download Files. ✓ ✓ You can download a file from the selected File Server source path onto the selected 
Destination folder of your Android or Windows Rugged device.

For details, see Configure Download and Upload Actions for Event Actions, Android.

Install ✓ Install files on the Windows Rugged device. You must use the Run manifest action to install 
files or applications by using command lines. Supports the following file types:

.reg, .cab, and .xml

Launcher Logout ✓ Checks-in the device, making it ready for another end user.

Move Files ✓ Move files from one location to another on the WinRugg device.

Reboot ✓ Restart the Android device.

Remove Folder. ✓ Remove a folder from the WinRugg device.

Rename File. ✓ Rename a file on the WinRugg device.

Rename Folder. ✓ Rename a folder located in the WinRugg device.

Run ✓ Run command lines and arguments on the WinRugg device.

If you want to install executable files (EXE), then you must use the Run manifest action on 
Windows Rugged devices. This is accomplished using command lines. The Run command 
must use the syntax of "\[full file path]". For example, \program files\program.exe.

Run Intent. ✓ Run command lines and arguments on the Android device. See RunIntent Action, File-Action 
Android for more information.

Send Sample 
Data.

✓ Send the WinRugg device data sample to the UEM console.

Terminate ✓ End a process or application running on the WinRugg device.
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Table 4-13. Event-Action Actions by Platform (continued)

Action
Andr
oid

WinR
ugg Description

Uninstall ✓ Uninstall a program or application on the WinRugg device. You must enter the application 
name.

The application name must match the name that appears in the Uninstall menu in the Control 
Panel.

Note   The Uninstall Manifest is for deleting files when a product is removed. If you remove a 
product from a device, any files installed remain on the device until uninstalled using an 
Uninstall Manifest.

Upload Files ✓ You can upload a file from a source file path on your Android device to the selected File 
Server destination folder.

For details, see Configure Download and Upload Actions for Event Actions, Android.

Warm Boot ✓ Restart the WinRugg device.

8 Select Update to add the action to the event action. You can add additional actions to the event 
action. Select Next.

9 Review the Summary and select Save.

What to do next

To push event actions to devices, add them as a component to a product. For more information, see 
Create a Product.

Configure Download and Upload Actions for Event Actions, 
Android
You must select a previously configured file server when you make Download Files or Upload Files the 
action of your Event Action. Making such a selection provides a source and destination for these files.

If you have not yet configured a file server for this purpose, see Add a File Server for Event Actions, 
Android.

You can only see these options in the Actions tab of the Add Event Action screen, and only when you 
select as your action either Download Files or Upload Files.

Procedure

1 Complete the following options to configure the Download Files or Upload Files action.

Setting Description

Select Action This option is pre-populated with either Download Files or Upload Files.

File Server Select from the list of Existing file servers you have configured previously. If no file 
servers are configured, select the Create New button followed by New File Server 
to add a file server and consult Add a File Server for Event Actions, Android.
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Setting Description

Source For Download Files, the source is a file on the file server. Enter the path on the file 
server where the file can be found.

For Upload Files, the source is a file on your device. Enter the directory or file path 
on your device where the file can be found.

Destination For Download Files, the destination is your device. Enter the directory or file path 
on your device where the file is going.

For Upload Files, the destination is the file server. Enter the path on the file server 
where the file is going.

Folder Naming This option is available only when Upload Files is the Select Action.

When multiple Upload Files actions use the same destination folder, there is a risk 
that identically named files might overwrite each other.

To reduce this risk, files can be uploaded into dynamically generated child folders 
for each assigned device. You can use a lookup value to give identically named 
files a unique folder name. When you review the uploaded files on the file server, 
the folder name identifies the user or device from which it came.

Select one or more of the following lookup values to make the destination folder 
name unique.

n DeviceAssetNumber

n DeviceUid

n DeviceFriendlyName

n User name

n UserEmailAddress

For more information, see Chapter 7 Lookup Values. You can also perform a 
search on docs.vmware.com.

 
2 Select the Update button to save your configuration.

File Servers for Event Actions, Android
You can configure a file server as a staging and provisioning component. This file server component is in 
support of the Upload File and Download File actions in Event Actions.

You can coordinate this file server with an organization group and content gateway in Workspace ONE 
UEM console.

Add a File Server for Event Actions, Android
File servers are used as the source or destination of a download files or upload files event action.

Procedure

1 Navigate to Devices > Provisioning > Components > File Servers and then select Add File 
Server.
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2 Complete all applicable settings in the tabs that are displayed.

Setting Description

Name Enter a name for the file server.

Link Enter the path of the source or destination of files.

For example, \\home\NetworkFileShare

Organization Group Enter the organization group you want to coordinate with for the File Server.

Content Gateway Select the content gateway that is reachable from this resource. Only the Unified 
Access Gateway (UAG) version is supported.

The selection of a content gateway is required.

User name Enter the user name that is recognized by the file server.

Password Enter the password that accompanies the user name.

Test Connection Status Select the Test Connection button to test whether the file server can be connected 
to with the user name and password entered.

 

Files-Actions for Products
In product provisioning for Workspace ONE UEM powered by AirWatch, a file-action is the combination of 
the files you want on a device plus the actions you want performed on the device with the file. You assign 
a file-action to a product. The product is then assigned to the device using Smart Group assignment.

You can install, configure, and upgrade devices by assigning Files-Actions to a product. The Files-Actions 
component also contains ways to manage the file system of a device.

View the files-actions in the Files-Actions List View.

Windows Windows Windows

Actions Android macOS QNX 7 Desktop Rugged

Copy Files. ✓ ✓ ✓ ✓ ✓ ✓

Create Folder. ✓ ✓ ✓ ✓ ✓ ✓

Delete Files. ✓ ✓ ✓ ✓ ✓ ✓

Execute Script.  ✓     

Install  ✓ ✓ ✓ ✓ ✓

Move Files. ✓ ✓ ✓ ✓ ✓ ✓

Remove Folders. ✓ ✓ ✓ ✓ ✓ ✓

Rename File. ✓ ✓ ✓ ✓ ✓ ✓

Run.  ✓ ✓ ✓ ✓ ✓

Run Intent. ✓      

Reboot ✓      

Terminate.   ✓ ✓ ✓ ✓

Uninstall.  ✓  ✓ ✓ ✓
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Warm Boot      ✓

OS Upgrade ✓      

Workspace ONE 
Intelligent Hub 

Upgrade.

✓      

Create a Files-Actions Component
You can install, configure, and upgrade devices by assigning files/actions to a product. The files/actions 
component also contains ways to manage the file system of a device.

Note   Windows Rugged and Windows Desktop: Windows Unified Agent is a 32-bit application, so 
when trying to run scripts in a 64-bit machine, proper redirections must be used to get access to the 64-bit 
folder or the registry hive.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions and select Add Files/Actions.

2 Select the device Platform for which you want to make the files/actions.

3 Complete the General text boxes.

Settings Descriptions

Name Enter a name for the files/actions. The name cannot be longer than 255 characters.

Description Enter a short description for the files/actions.

Version The UEM console pre-populates this setting.

Platform Read-only setting displays the selected platform.

Managed By Select the organization group that can edit the files/actions.
 

4 Select the Files tab.

5 Select Add Files.

The Add Files window displays.

6 Select Choose Files and browse for a file or multiple files to upload.

There is a 2 GB limit on uploads.

Note   Windows Rugged devices can use files/actions to install XML onto a device. For more 
information, see Create an XML Provisioning File, Android, Win7, WinRugg.

Android and Windows Rugged devices can use the File-Action function to upgrade the OS of the 
device remotely. For more information, see Create an OS Upgrade File-Action, Android and Create 
an OS Upgrade File-Action, WinRugg.
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7 Select Save and upload the files.

Once the files upload, the file grouping screen opens. File groups allow you to assign different 
download paths and settings to different groups of files you have uploaded to a single file/action.

8 Select uploaded files and select Add to move the files into a new file group.

9 Define the Download Path the device uses to store the file group in a specific device folder.

If the download path entered does not exist, the folder structure is created as part of the installation.

Note   Windows Rugged devices can Store OS Update Files on Relay Server to ensure that files 
used to update the OS remain available on the relay server.

10 Select Save.

You can repeat the previous steps for as many files as you want.

11 Select the Manifest tab.

If you have at least one file uploaded, Actions are not required.

12 Add actions to the Install Manifest or the Uninstall Manifest if needed.

The uninstall manifest only runs when the Uninstall action is added to the product. If nothing is added 
to the Uninstall Manifest, uninstalling the file/action results in no effect.

Select the platform for which you are making a File-Action.

Option Description

Android Files-Actions Manifest Options for Android

macOS Files-Actions Manifest Options for macOS

QNX Files-Actions Manifest Options for QNX

Windows 7 Files-Actions Manifest Options for Windows 7

Windows Desktop Files-Actions Manifest Options for Windows Desktop

Windows Rugged Files-Actions Manifest Options for WinRugg
 

Files-Actions Manifest Options for Android
You must select all the desired Android options for your Files-Actions product component.
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Procedure

1 Add the Manifest Actions for your Android File-Action.

Settings Descriptions

Workspace ONE Intelligent Hub 
Upgrade

Install the new Workspace ONE Intelligent Hub to the device. Before using this file/
action, see Upload the Workspace ONE Intelligent Hub APF File, Upgrade File-
Action for more information.

Apply Custom Settings Apply custom, OEM-specific device settings based on the selected XML file. You 
must upload the custom XML or ZIP file as part of the file/action.

Supported Devices:

n Android Motorola Solutions devices with the Android Hub v7.1+

n Upload the ZIP file created by MSI.

n Android Zebra devices with the Android Hub v7.2+ and Zebra's MX Service 
App installed on the device.

n Create your XML configuration file using Zebra Stage Now.

n Upload the XML configuration file and select it from the drop-down menu.

n After pushing the product containing an Apply Custom Setting file/action, 
the status information reports in the Job Log. If an error occurs, the failed 
response XML is reported in the Job Log. For more information, see 
Product Job Statuses.

Copy Files Copy files from one location to another on the device.

Create Folder Create a new folder on the device.

Delete Files Delete folders from the device.

Install Unmanaged Application Install an unmanaged .APK file. Workspace ONE UEM does not add the app to the 
managed app list. Enterprise wipes or unenrollment do not remove the app from 
the device. You must use the Uninstall Unmanaged Application file/action. Consider 
adding Uninstall Unmanaged Application to the uninstall manifest of any product 
including the Install Unmanaged Application file/action.

Move Files Move files from one location to another on the device.

OS Upgrade Install a new OS upgrade and the relevant Workspace ONE Intelligent Hub. For 
more information on this option, see Create an OS Upgrade File-Action, Android.

Reboot Restart the device.

Remove Folder Remove a folder from the device.

Rename File Rename a file on the device.

Rename Folder Rename a folder located in the device.

Run Intent Run command lines and arguments on the device. See RunIntent Action, File-
Action Android for more information.

Uninstall Unmanaged Application Uninstall an unmanaged application. Enter the package ID of the app.
 

2 When finished adding actions to the Manifest, select Save.
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What to do next

Path Variables – For all file management-related actions listed above (copy files, create folder, delete 
files, move files, remove folder, rename file, and rename folder), you have the option of inserting a path 
variable for both source and target, as applicable. The use of these variables in your Files/Actions path 
means you do not need to account for the randomly generated OEM-specific path definitions in the 
creation of your Files/Actions.

$internal$ – Use this variable at the beginning of your path to indicate your source/target path to be read 
from/written to the internal storage space. Supports read and write actions. For example: /$internal$/
agreement/license.txt addresses the file license.txt in the agreement folder on the device's 
internal storage space.

Note   $internal$ does not work with all Files/Actions.

$external$ – Use this variable at the beginning of your path to indicate your source path to be from the 
external memory card storage, which the device must feature. External storage supports read-only 
access so any usage must involve a memory card that has been properly formatted and furnished with 
the correct files in the correct locations. For example: /$external$/sdcard/license.txt reads the file 
license.txt from the sdcard folder found on the device's external memory card storage.

Files-Actions Manifest Options for macOS
You must select all the desired macOS options for your Files-Actions product component.

Procedure

1 Add the Manifest Actions for your macOS File-Action.

Settings Descriptions

Execute Script Runs the selected script on the device. This command supports .sh and .scpt files.

You must enter the script file path and name. Select Execute as Root to run the 
script as the Root user. If you do not enable this option, the script runs as the user 
currently logged in.

Install Install files on the device. This is accomplished using command lines. Supports the 
following file types.

macOS
DMG, PKG, or APP (zipped)

If the DMG file contains an APP file, Workspace ONE UEM moves the APP file to 
the /Applications folder. If the DMG contains a PKG or MPKG file, extract the file 
from the DMG and push the PKG or MPKG directly.

Workspace ONE UEM supports installing and managing .app files as internal 
applications which provide additional control for removing apps upon unenrollment.
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Settings Descriptions

Run Use the manifest to run an application. This is accomplished using command lines. 
The Run command must use the syntax of "\[full file path]". For example, \program 
files\program.exe.

You must select the context of the command. Select whether the command runs at 
the system level, the user level, or the admin account level.

For Windows Rugged devices, Workspace ONE UEM supports 3 file types, EXE, 
AWS, and LNK. The EXE is the app itself while AWS is the AirWatch supported 
scripting language. LNK files support an inferred execution based on the file 
extension. For example, if a DOC file is run, the device would use whatever app is 
associated with DOC files.

Note   With macOS devices, you can run any root command that you normally use 
within Terminal. The Workspace ONE Intelligent Hub automatically appends sudo 
before running any command.

Uninstall Uninstall a program or application on the device. You must enter the application 
name.

Note   The Uninstall Manifest is for deleting files when a product is removed. If you 
remove a product from a device, any files installed remain on the device until 
uninstalled using an Uninstall Manifest.

 
2 When finished adding actions to the Manifest, select Save.

Files-Actions Manifest Options for QNX
You must select all the desired QNX options for your Files-Actions product component.

Procedure

1 Add the Manifest Actions for your QNX File-Action.

Settings Descriptions

Copy Files Copy files from one location to another on the device.

Create Folder Create a new folder on the device.

Delete Files Delete folders from the device.

Install Install files on the device. This is accomplished using command lines.

Move Files Move files from one location to another on the device.

Remove Folder Remove a folder from the device.

Rename File Rename a file on the device.

Rename Folder Rename a folder located in the device.
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Settings Descriptions

Run Use the manifest to run an application. This is accomplished using command lines. 
The Run command must use the syntax of "\[full file path]". For example, \program 
files\program.exe.

You must select the context of the command. Select whether the command runs at 
the system level, the user level, or the admin account level.

For Windows Rugged devices, Workspace ONE UEM supports 3 file types, EXE, 
AWS, and LNK. The EXE is the app itself while AWS is the AirWatch supported 
scripting language. LNK files support an inferred execution based on the file 
extension. For example, if a DOC file is run, the device would use whatever app is 
associated with DOC files.

Terminate End a process or application running on the device.
 

2 When finished adding actions to the Manifest, select Save.

Files-Actions Manifest Options for Windows 7
You must select all the desired Windows 7 options for your Files-Actions product component.

Procedure

1 Add the Manifest Actions for your Windows 7 File-Action.

Settings Descriptions

Copy Files Copy files from one location to another on the device.

Create Folder Create a new folder on the device.

Delete Files Delete folders from the device.

Install Install files on the device. This is accomplished using command lines. Supports the 
following file types.

CAB, MSI, REG, and XML. CAB and MSI files contain the app itself while REG and 
XML files are for modifying the registry settings.

Move Files Move files from one location to another on the device.

Remove Folder Remove a folder from the device.

Rename File Rename a file on the device.

Rename Folder Rename a folder located in the device.

Run Use the manifest to run an application. This is accomplished using command lines. 
The Run command must use the syntax of "\[full file path]". For example, \program 
files\program.exe.

You must select the context of the command. Select whether the command runs at 
the system level, the user level, or the admin account level.
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Settings Descriptions

Terminate End a process or application running on the device.

Uninstall Uninstall a program or application on the device. You must enter the application 
name.

The application name must match the name that appears in the Uninstall menu in 
the Control Panel.

Note   The Uninstall Manifest is for deleting files when a product is removed. If you 
remove a product from a device, any files installed remain on the device until 
uninstalled using an Uninstall Manifest.

 
2 When finished adding actions to the Manifest, select Save.

Files-Actions Manifest Options for Windows Desktop
You must select all the desired Windows Desktop options for your Files-Actions product component.

Procedure

1 Add the Manifest Actions for your Windows Desktop File-Action.

Settings Descriptions

Copy Files Copy files from one location to another on the device.

Create Folder Create a new folder on the device.

Delete Files Delete folders from the device.

Install Install files on the device. This is accomplished using command lines. Supports the 
following file types.

CAB, MSI, REG, and XML. CAB and MSI files contain the app itself while REG and 
XML files are for modifying the registry settings.

REG files require batch files and PowerShell commands.

Move Files Move files from one location to another on the device.

Remove Folder Remove a folder from the device.

Rename File Rename a file on the device.

Rename Folder Rename a folder located in the device.

Run Use the manifest to run an application. This is accomplished using command lines. 
The Run command must use the syntax of "\[full file path]". For example, \program 
files\program.exe.

You must select the context of the command. Select whether the command runs at 
the system level, the user level, or the admin account level.
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Settings Descriptions

Terminate End a process or application running on the device.

Uninstall Uninstall a program or application on the device. You must enter the application 
name.

The application name must match the name that appears in the Uninstall menu in 
the Control Panel.

Note   The Uninstall Manifest is for deleting files when a product is removed. If you 
remove a product from a device, any files installed remain on the device until 
uninstalled using an Uninstall Manifest.

 
2 When finished adding actions to the Manifest, select Save.

Files-Actions Manifest Options for WinRugg
You must select all the desired Windows Rugged options for your Files-Actions product component.

Procedure

1 Add the Manifest Actions for your Windows Rugged File-Action.

Settings Descriptions

Workspace ONE Intelligent Hub 
Upgrade

Install the new Workspace ONE Intelligent Hub to the device. Before using this file/
action, see Upload the Workspace ONE Intelligent Hub APF File, Upgrade File-
Action for more information.

Copy Files Copy files from one location to another on the device.

Create Folder Create a new folder on the device.

Files Delete folders from the device.

Install Install files on the device. This is accomplished using command lines. Supports the 
following file types.

CAB, REG, and XML. CAB files contain the app itself while REG and XML files are 
for modifying the registry settings.

Consider using the Workspace ONE UEM CAB Creator to create CAB files that 
combine multiple files into one CAB file.

Move Files Move files from one location to another on the device.

Remove Folder Remove a folder from the device.

Rename File Rename a file on the device.

Rename Folder Rename a folder located in the device.
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Settings Descriptions

Run Use the manifest to run an application. This is accomplished using command lines. 
The Run command must use the syntax of "\[full file path]". For example, \program 
files\program.exe.

You must select the context of the command. Select whether the command runs at 
the system level, the user level, or the admin account level.

For Windows Rugged devices, Workspace ONE UEM supports 3 file types, EXE, 
AWS, and LNK. The EXE is the app itself while AWS is the AirWatch supported 
scripting language. LNK files support an inferred execution based on the file 
extension. For example, if a DOC file is run, the device would use whatever app is 
associated with DOC files.

Note   With macOS devices, you can run any root command that you normally use 
within Terminal. The Workspace ONE Intelligent Hub automatically appends sudo 
before running any command.

Terminate End a process or application running on the device.

Uninstall Uninstall a program or application on the device. You must enter the application 
name.

WD W7 The application name must match the name that appears in the Uninstall 
menu in the Control Panel.

Note   The Uninstall Manifest is for deleting files when a product is removed. If you 
remove a product from a device, any files installed remain on the device until 
uninstalled using an Uninstall Manifest.

Warm Boot Restart the device.
 

2 For each manifest action, select a Critical option. If the critical 'success' or 'error' options are 
selected, then the action is skipped if the condition is not met.

Option Condition

Continue on Error Execute this manifest action only if the previous action fails.

Continue Execute this manifest action regardless of the outcome of the previous action.

Continue on Success Execute this manifest action only if the previous action succeeds. If the previous 
action is skipped, then this manifest action is also skipped.

 
3 When finished adding actions to the Manifest, select Save.

Editing Files-Actions
You can edit existing Files-Actions to keep products and devices up-to-date.

When you edit any existing files/actions, the version number increases. After saving the edits, Workspace 
ONE UEM runs a check against all active products to find any that contain the newly edited files/actions.

If any active products contain the files/actions, a warning prompt displays listing all active products 
affected by the edited files/actions. You can then Activate or Deactivate a product using the files/actions.
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Delete Files-Actions
Workspace ONE UEM checks any attempt to delete files-actions against the list of active products. To 
delete files-actions, it must be detached from all products.

Procedure

1 Select the Files/Actions listed in the Warning prompt.

2 Select Edit.

3 Remove the files-actions from the product.

4 Select Save.

5 Repeat for all products containing the files-actions.

6 After the files-actions detach from all products, you can delete the files-actions.

If the files-actions is part of an active product, a warning prompt displays listing any product that uses the 
files/actions.

Import Motorola Packages in Files-Actions, Android and WinRugg
You can import MSP (Motorola Services Platform) packages, which can be unpacked into proper files/
actions for use in products.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions and select Add.

2 Select the Platform you want to create a staging configuration for.

3 Select Import Package.

4 Select Upload to add an APF file.

Once the file is uploaded, the required text boxes are auto-completed.

5 Select Save.

Create an XML Provisioning File, Android, Win7, WinRugg
XML provisioning allows you to download a custom-designed XML file to a device in a provisioning 
product. After the file is downloaded, it runs an install command to extract the settings from the XML file 
and install them on the device.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions and select Add Files/Actions.

2 Select your platform.

3 Enter the required settings on the General tab, then select the Files tab and upload the desired XML 
file and enter the destination path on the device.

4 Select the Manifest tab and Add an Install Action for the XML file.
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5 Select Save.

6 Navigate to Devices > Provisioning > Products List View, and select Add Product.

7 Select your platform.

8 Enter the General information.

9 Select the Manifest tab.

10 Select Install Files/Actions and select the files and actions just created.

11 Save and Activate the product.

The product downloads to all assigned devices and the XML file successfully installs.

Example

Windows Rugged

The following is a sample of an XML file which updates a registry setting that can be installed on a device 
through product provisioning.

XML Provisioning is for Windows Mobile devices only and not Windows CE devices.

<?xml version="1.0"?>

<wap-provisioningdoc name="desiredDocName /V_1">

<characteristic type="com.windowspc.getregistryinfo.managed">

<reg_value value_name="KeyName"

<!–- (i.e. CommonFilesDir) --

key_name="RegistryPath"

<!-- (i.e.Software\Wow6432Node\Microsoft\Windows\CurrentVersion) --

custom_attribute_name="AttributeName"/>

<reg_value value_name="Keyname ..." key_name="Path\...."

custom_attribute_name="AttributeName2"/>

</characteristic>

</wap-provisioningdoc>

Windows 7

<?xml version="1.0"?>

<wap-provisioningdoc>

<characteristic type="com.airwatch.getregistryinfo.winpc">

<reg_value value_name="KeyName"

<!–- (i.e. CommonFilesDir) --

key_name="RegistryPath"

<!–- (i.e. Software\Wow6432Node\Microsoft\Windows\CurrentVersion)" --

custom_attribute_name="AttributeName"/>

<reg_value value_name="Keyname ..." key_name="Path\...."

custom_attribute_name="AttributeName2"/>

</characteristic>

</wap-provisioningdoc>
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Android

<?xml version="1.0"?>

<attributes>

<attribute name="attribute 1" value="value 1"/>

<attribute name="attribute 2" value="value 2"/>

<attribute name="attribute 3" value="value 3"/>

</attributes>

Workspace ONE Intelligent Hub Upgrading a File-Action
When you upgrade your devices, you can seed the Workspace ONE Intelligent Hub in the Workspace 
ONE UEM console for use in products. The file-action Workspace ONE Intelligent Hub Upgrade then 
grabs the list of seeded APF files when creating a manifest action for products.

Use this option to enroll devices with older Hub versions installed. You can enroll the devices then 
upgrade the device to the new Hub version you want to use.

When using this upgrade option, be alert for failed upgrades. A failed upgrade can cause the product to 
push repeatedly as the console recognizes the older Hub version. This failed upgrade can tax the network 
and result in excessive battery use. If the upgrade fails, deactivate the product and look over the 
configuration to ensure that the settings are correct.

Note   The Hub Packages screen is only accessible in Customer type organization groups.

Upload the Workspace ONE Intelligent Hub APF File, Upgrade File-Action
The Hub Package can be uploaded only in specific organization group types, for example, in organization 
groups of type ‘Customer’. Upload the Workspace ONE Intelligent Hub Package to the topmost 
organization group level. You can find the file specific to your OEM located in Workspace ONE UEM 
Resources.

Procedure

1 Navigate to Devices > Provisioning > Components > Hub Packages and select Add Workspace 
ONE Intelligent Hub. Make sure that you are using the top-level organization group.

2 Select the platform for which you are adding the Workspace ONE Intelligent Hub package.

The Add Workspace ONE Intelligent Hub screen displays.

3 Select the Upload button next to the Application File setting.

4 Select Choose File and browse for the APF file of the Workspace ONE Intelligent Hub version you 
want to upload.

5 Select the APF file and select Open to select the file.

6 Select Save and close the upload dialog box.

With the uploading of the APF file, the settings are populated with data automatically.
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7 Make any desired edits to File Name, Package Name, and Version for the Workspace ONE 
Intelligent Hub.

8 Select Save and upload the APF file to the UEM console.

RunIntent Action, File-Action Android
The runIntent action starts an Android intent that facilitates late runtime binding between the code in 
different applications. Use these intents to accomplish actions on your Android devices.

The most significant use of runIntent is the launching of activities, where it can be thought of as the glue 
between activities. It is a passive data structure holding an abstract description of an action to be 
performed. The runIntent action supports both explicit and implicit intents.

Depending on the arguments used, the Workspace ONE Intelligent Hub uses either of the following to 
start the specified intent.

n android.content.Context.startActivity(Intent intent)

n android.content.Context.sendBroadcast(Intent intent) to run the specified intent.

RunIntent Syntax

The argument syntax changes depending on whether explicit or implicit mode is specified.

mode=explicit, broadcast=[true|false] , action=< action>, package=<package>, class=<class> [, 

data=<data>][, extraString=<stringname>=<string value>[,...]][, extraInt=<int name>=<int value>[,…]]

mode=implicit, broadcast=[true|false] , action=<action> [,category=<category>][, uri=<uri>] [, 

data=<data>] [, extraString=<string name>=<string value>[,...]][, extraInt=<int name>=<int value>[,…]]

Argument Explanation

mode=[explicit|implicit] Specifies whether the intent is explicit or implicit.

broadcast=[true|false] Specifies whether the intent to be launched using startActivity() or sendBroadcast().

action=<action> Specifies the Android action string for the intent. An example of an Android action string is 
android.intent.action.MAIN.

package=<package > Specifies the Android package name of the java class to be explicitly run. Android package names 
are generally of the format com.mycompany.myapplication.

class=<class> Specifies the java class in the specified package that is to be explicitly launched.

uri=<uri> Specifies the URI that is to be passed with the implicitly launched intent.

category =<category> Specifies the Android category string that is to be passed with the implicitly launched intent. An 
example of an Android category string is android.intent.category.DEFAULT

data=<data> Specifies the value of the Android data parameter that is to be passed with the explicitly or implicitly 
launched intent.
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extraString=<string 
name>=<string value>

Specifies the name of an extra string parameter that is to be passed with the explicitly or implicitly 
launched intent. string value specifies the value of the extra string. The extraString argument can be 
used multiple times to specify additional extra string name/values.

extraInt=<int name>=<int 
value>

Specifies the name of an extra int parameter that is to be passed with the explicitly or implicitly 
launched intent. int value specifies the value of the extra int. The extraInt argument can be used 
multiple times to specify additional extra int name/values.

The following table indicates which arguments are required, optional, or not applicable for the explicit and 
implicit modes.

mode Explicit Implicit

broadcast required required

action required required

package required n/a

class required n/a

uri n/a optional

category n/a optional

data optional optional

extraString optional optional

extraInt optional optional

Example RunIntent

mode=explicit,broadcast=false,action=android.intent.action.MAIN,package=com.examples.myappl,class=com.

examples.myappl.MainActivity

APK File Installation

You can use a runIntent action on an APK file on the device's local storage which installs an application 
on the device.

RunIntent Syntax for APK File Installation

mode=implicit,broadcast=false,action=com.airwatch.android.provisioning.INSTALL_APKS_FROM_FOLDER,packag

e=com.airwatch.androidagent,extraString=path=/storage/emulated/Download

n You must customize the path in the highlighted portion to account for your specific file and folder 
structure.

n You can specify an individual APK file in this path on the runIntent which installs an application on the 
device.

n You can also specify a folder in the path of the runIntent, which runs all APK files found in that folder.

n Applications installed on a device using APK files by way of a runIntent are unmanaged.

n You can also use a path variable in the runIntent to represent the device's internal or external storage.
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Path Variable Use in RunIntent for APK Installation

$internal$ – Use this variable at the beginning of your path to indicate your source/target path to be read 
from/written to the internal storage space. Supports read and write actions. For example: /$internal$/
agreement/license.txt addresses the file license.txt in the agreement folder on the device's 
internal storage space.

Note   $internal$ does not work with all Files/Actions.

$external$ – Use this variable at the beginning of your path to indicate your source path to be from the 
external memory card storage, which the device must feature. External storage supports read-only 
access so any usage must involve a memory card that has been properly formatted and furnished with 
the correct files in the correct locations. For example: /$external$/sdcard/license.txt reads the file 
license.txt from the sdcard folder found on the device's external memory card storage.

Upgrade the OS, File-Action for Android
You can upgrade the OS of your Android devices remotely using product provisioning. This process 
allows you to keep your entire device fleet up-to-date without needing to have the devices shipped back 
to you.

After an Android device receives an Android OS Upgrade file/action, the device processes the command 
in the following order.

Prerequisites

n Support includes Zebra devices using the Zebra MX Service and any OEM supporting the Platform 
OEM Service v3.0 or later. For more information about the Platform OEM Service, see the VMware 
Workspace ONE UEM Android Platform Guide topics titled Android OEM Services and Platform 
OEM Service Overview.

n Note   Before updating your Motorola device to a new Zebra OS, you must have the Workspace ONE 
Intelligent Hub for Android v5.1.4+ installed and the 1.9 MX service.

Procedure

1 The device receives the product which you can verify on the device by navigating to Hub > Products.

2 Download all the files including the OS update zip which you can verify in the Product logs found on 
the device in Hub > Products > Product Name.

3 Once the downloads complete on a Zebra device, the Workspace ONE Intelligent Hub backs up its 
data and any installed managed applications to the device enterprise folder which is persistent.

4 The Hub then reboots the device into recovery mode to install the update.

5 Device then applies the OS update.

6 Once complete, the device reboots.

After reboot, the Workspace ONE Intelligent Hub validates that the OS update is successful before 
reporting that the job completed successfully.
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What to do next

If the OS update fails, you can investigate the reasons why by using the Workspace ONE UEM console to 
navigate to Devices > Provisioning > Product Dashboard. Select the failed product in Recent Product 
Status that contains the OS upgrade. In the View Devices screen, select the magnifying glass icon to 
view history, then select the magnifying glass icon again to view the Job Log.

Create an OS Upgrade File-Action, Android
Upgrade Android devices remotely with the OS Upgrade File-Action. Add the file-action to a product to 
update your devices without a need for a manual OS update.

Prerequisites

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions and select the Add Files/
Actions button.

2 Select the Android platform.

3 Complete the General text boxes.

a Enter a Name.

b Enter a Description.

c View the pre-populated Version number of the file-action.

d View and confirm the Platform for the file-action.

e Enter who the files-actions are Managed By.

4 Select the Files tab.

5 Select the Add Files button and upload the extracted OS update files.

For Zebra devices, upload the following files and specify the path as either /data/tmp/ to store the file 
on the data partition, or as a known internal path to store it on the internal storage. For other devices, 
specify a known internal storage path on the device, such as /sdcard/.

n OS Update ZIP file – This file can be a major or minor OS upgrade file. The file can also be an 
enterprise reset package.

n [optional] Workspace ONE Intelligent Hub update package (APF) – This optional file can be 
specified to update the Workspace ONE Intelligent Hub before initiating the actual OS update. 
Workspace ONE UEM can provide this APK.

6 Select the Manifest tab and select Add Action under the Install Manifest.

7 Add OS Upgrade command to the manifest and select the corresponding OS upgrade file that was 
uploaded earlier.

Your Manifest tab looks similar to the following.
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8 Select Save.

What to do next

After creating an OS Upgrade file/action, create a product to push the upgrade to your devices. See 
Create a Product for more information.

Note   Before installing an OS Update, the device checks the battery level. If the level is below a 
threshold, the product fails. This failure displays in the log.

Upgrade the OS, File-Action for WinRugg
Using the Windows OS Upgrade file/action, upgrade your Motorola and Zebra Windows Rugged devices 
remotely. By creating a product containing the OS Upgrade file/action, you can upgrade all your devices 
without having them shipped back to you.

Prerequisites

For Windows Rugged devices, all OS upgrade files are restricted access files and require a valid user 
account with Motorola to log in with a valid device serial number. The OS upgrade files are specific to 
both device model and OS version. The Workspace ONE ™ UEM OS upgrade process uses the APF 
files and requires the administrator to first install the MSP Package Builder utility.

This utility is required to extract the contents of the APF file into individual components that are then 
pushed to the device and used to upgrade the OS.

Important   The Windows Rugged OS Upgrade method requires the Workspace ONE Intelligent Hub 
v5.3+ for Windows Rugged devices.

To use the Windows Rugged OS Upgrade, you must have the following:

n The MSP Package Builder utility installed on your computer.
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n A Motorola user account to download the OS Upgrade.

n The serial number for the device you want to upgrade.

n The OS update utility included with the extracted APF files. This file can be downloaded from the 
Zebra support website.

n A relay server configured to deliver the product to the device.

Procedure

1 Extract Required OS Update Files, File-Action for WinRugg

2 Create an OS Upgrade File-Action, WinRugg

3 Create a Product

OS Upgrade Resources for WinRugg
The Windows Rugged OS Upgrade file/action might require Run command arguments to process the 
action on the device. You can also change the device registry settings.

The Windows Rugged OS Upgrade file/action might require Run command arguments to process the 
action on the device. You can also change the device registry settings.

Check Device Registry Settings

If at any point an error occurs, review the device registry settings. The 5.x Hub has been designed to 
update these settings based on the Workspace ONE ™ UEM console configuration settings. The relay 
server settings are a part of the job XML and are applied during provisioning just before processing the 
job.

If the OS Update process does not complete successfully, the following settings are monitored as part as 
any troubleshooting effort.

HKEY_LOCAL_MACHINE\SOFTWARE\AIRBEAM\  

IGNORESERVER string “1”

SERVERRIP string [Enter the Server URL or IP Address]

FTPUSER string [Enter the FTPs user name]

FTPPASSWORD string [Enter the FTPs password] - THIS FIELD MUST BE ENCRYPTED

TFTP string "0"

PASSIVEMODE string "1"

FTPPORT string "21"

FTPS string "0" or "1"

VERIFYSERVER string "0"

SOFTKEY1 number "123"

SOFTKEY2 number "124"

ENTERKEY number "13"
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Run Command Argument Information

-d option describes the Workspace ONE UEM relay server folder path containing files required to update 
the device. It uses the following format (with forward slashes and double quotes): "[path of your relay 
server]/PFILES/[file action name]_version/"

-y option describes the maximum number of retry attempts while the –z option describes the retry delay.

-q is the folder on the device that is used to download the files from the FTP server when updating 
Windows Mobile. This location is typically “\Temp” or “\Storage Card”. In CE updates, the files are 
downloaded one at a time into memory so the parameter is not used in that case.

-p is the OSUpdate project name. The project name can be whatever the user wants it to be but is usually 
something to indicate what the update package contains. This name must be the same as the Motorola 
APF file. The project (APF) must be named so it can identify the target device, OS type, and so forth.

For the Workspace ONE UEM process, this name is the same as whatever you call the dummy APD file 
(which can be an empty text file).

n If your command line contained –p”WT41N0”, you must have a WT41N0.APD file put down to the 
device before applying the update. This is only needed for CE devices.

n For Windows Mobile devices –p”MC9190WM65” is required by the command-line parsing, but in 
effect is not used.

Extract Required OS Update Files, File-Action for WinRugg
Before you can create an OS Upgrade file/action, you must extract the required files from the APF files. 
These files are extracted using the MSP Package Builder Utility.

Procedure

1 Start the MSP Package Builder Utility.

2 Navigate to File > Open Project and select the appropriate APF file and open it in MSP Package 
Builder.

3 Navigate to Tools > Convert Project to open the Convert to Project dialog box.

4 Complete the following text boxes.

n Name – Enter the name for the OS Upgrade project.

n Extract FilesTo – Enter the location the files should be saved to or select the Browse button to 
select the location.

5 Select OK to close the Convert to Project dialog box.

6 Select Command from the left window pane.

7 Select Install and copy the install command from the bottom right window pane.

Consider copy-pasting this install command to a file (Notepad, Word, and so on) so you can access it 
later while creating the File/Action for the OS Upgrade.
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Create an OS Upgrade File-Action, WinRugg
Once you extract the OS upgrade files from the APF file, create an OS Upgrade file-action. If you must 
update the device registry, create a separate files-actions for the Registry Edit file and list that Files-Action 
first in the product manifest.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions and select the Add Files/
Actions button.

2 Select the Windows Rugged platform.

3 Complete the General text boxes.

a Enter a Name.

b Enter a Description.

c View the pre-populated Version number of the file-action.

d View and confirm the Platform for the file-action.

e Enter who the files-actions are Managed By.

4 Select the Files tab and select Add Files.

5 Select Choose Files and upload the extracted OS update files.

6 Specify the Download Path\[directory]\[full file name]

7 Enable Store OS Update Files on Relay Server to ensure that OS Update files remain on the Relay 
Server until needed by the OSUpdate utility.
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8 Select Save and add the file and return to the Files tab.

9 Select Add Files and add additional files.

10 Upload the OS Update Utility EXE and the "package.TXT" manifest file.

Windows Mobile devices always use a file named "osupdMagneto.exe." For Windows CE devices, 
the filename varies with the device.

Windows CE devices also require a package .APD. The contents of this file are not important and can 
be a simple text format file containing something benign. It can even be empty.

11 Specify separate Download Paths for both the OS Update Utility and the package .TXT manifest file.

The Download Path for the OS Update utility and the package.TXT manifest file must be: "\Windows
\".

The Windows CE .APD file must be placed in: "\Application\AirBeam\PKG."

Important   Do not select Relay Server Only. These files must be delivered directly to the device.

12 (Optional) Create a files/actions to download and install the REG file to the device.

This step is only necessary if the registry settings are not already correctly updated on the device.

Download the REG file to the '\Temp' directory specifying the full filename. On the manifest tab, add 
an Install action type and specify the directory location and the filename of the REG file to be run on 
the device.

13 Once all the files have been uploaded, select the Manifest tab and select Add Action to add Install 
Actions.

14 Select the Run action in the Action Types text box.

15 Copy the Install Command from the MSP Package Builder utility and paste it into the Command Line 
and Arguments to Run.

You must edit the syntax of the Install Command to match Workspace ONE ™ UEM run syntax:

n Windows Mobile

n You must use double quotes around "\windows\osupdMagento" and add the .exe to the end 
of osupdMagento.

n -d"myserverpath" must be updated in the following format: "[path of your relay server]/
PFILES/[file action name]_version/". If the directory on the relay server that you are using for 
OS Update is /Motorola/OSUpdateFiles, the name of the OS Update file/action is "OSUpdate" 
and the "OSUpdate" file/action is on version 5, then the -d argument might look like: -d"/
Motorola/OSUpdateFiles/PFILES/OSUpdate_5/".

• The full run command syntax with all the arguments looks like the following.

\windows\osupdMagneto.exe" -p"MC9190WM65" -o -y5 -z10 -q"\temp\" -d"/Motorola/

OSUpdateFiles/PFILES/OSUpdate_5/

Product Provisioning

VMware, Inc. 101



n Windows CE

n You must use double quotes around "\windows\ [OS Update Utility filename]" and add 
the .exe to the end of the filename.

n -d"myserverpath" must be updated in the following format: "[path of your relay server]/
PFILES/[file action name]_version/". If the directory on the relay server that you are using for 
OS Update is /Motorola/OSUpdateFiles, the name of the OS Update file/action is "OSUpdate" 
and the "OSUpdate" file/action is on version 5, then the -d argument might look like: -d"/
Motorola/OSUpdateFiles/PFILES/OSUpdate_5/".

• The full run command syntax with all the arguments looks like the following.

\windows\[OS Update filename].exe" -p"WT41N0" -o -y5 -z10 -d"/Motorola/OSUpdateFiles/

PFILES/OSUpdate_5/

16 Select Save.

17 Add the OS Upgrade file/action to a product and assign the product to all applicable devices.

Once the device receives the product, the OS Update process initiates. A notification screen displays 
when the upgrade is complete.

Product Sets
Occasionally there are conflicting products provisioned to devices due to similar grouping in smart groups 
and custom attributes in Workspace ONE UEM powered by AirWatch. Product Sets allow you to group 
conflicting products and rank the products based on business needs.

Product Sets Basics
Product sets contain multiple products that you want to keep mutually exclusive. Product sets are useful 
for situations where the products contained inside the product set are meant only for specific devices 
within the parameters set by the rules engine using custom attributes.

The products in the product set follow a hierarchy based on ranking according to business needs. From a 
given product set, a device receives only one product that applies to the device. This product is the 
highest ranked among devices that meet the smart group and custom attribute rules criteria. After a 
device receives a product from a product set, the device will not receive any other products from the set 
unless the rank of a subsequent product is elevated or a new product is created in the set with a higher 
rank.

Important   A product must exist as either a standalone product or as part of a product set. The product 
set ensures the integrity of mutual exclusivity of products for a given device.

Create a Product Set
Create a product set to control the delivery of multiple products so a device receives only the specific 
product that applies to the device based on your business rules.
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Procedure

1 Navigate to Devices > Provisioning > Product Sets and select the Add Product Set button.

2 Select the platform for which you want to create the product set.

3 Complete the General text boxes.

Settings Descriptions

Name Enter a name for the product sets. The name cannot be longer than 255 
characters.

Description Enter a short description for the product sets.

Managed By Select the organization group that can edit the product sets.
 

4 Select the Products tab.

5 Select Add to add products to the product set.

6 Create a product including manifest items, conditions, and deployment settings.

See Create a Product for more information on creating a product. Ensure that you use the rules 
engine to create custom attribute-based rules for each product so the policy engine can properly 
assign the products.

7 Use the Up and Down arrows to adjust product ranking based on business needs.

8 Set products to Active if needed.

9 Select Save to create the product set.

Add a Product to a Product Set
You can add a product to an existing product set. This action requires following specific rules due to the 
complicated relationship between products and business rules.

A new product in a product set is added with the lowest ranking in the set by default. If the new product 
should be a higher rank, you must edit the ranking. See Change the Product Ranking in a Product Set for 
more information on what happens when product ranks are adjusted.

Procedure

1 Navigate to Devices > Provisioning > Product Sets.

2 Find the product set you want to add a product to and select the Edit icon ( ).

3 Select the Products tab.

4 Select Add Product.

5 Manually adjust the product rank as needed according to your business needs.

6 Select Save to add the product to the product set.
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Any modifications made during the edit of a product set do not take effect until you save the product set. 
Once saved, the product set enters the policy engine for evaluation.

Remove a Product from a Product Set
Remove a product from an existing product set. This action requires following specific rules due to the 
complicated relation between products and business rules.

Removing a product from a product set raises the rank of all products previously ranked below the 
removed product by one. If multiple products are removed, the remaining products are adjusted by one 
rank for each product removed. See Change the Product Ranking in a Product Set for more information 
on what happens when product ranks are adjusted.

Any modifications made during the edit of a product set do not take effect until you save the product set.

Procedure

1 Navigate to Devices > Provisioning > Product Sets.

2 Find the product set you want to add a product to and select the Edit icon ( ).

3 Select the Products tab.

4 Select the check box for each product you want to remove from the product set.

5 Select the Delete button to remove the products.

6 Manually adjust the product rank as needed according to your business needs.

7 Select Save to add the product to the product set.

Once saved, the product set enters the policy engine for evaluation.

Activate and Deactivate Products in a Product Set
When you activate or deactivate a product in a product set, you must be aware of and prepare for 
possible consequences.

Procedure

1 Navigate to Devices > Provisioning > Product Sets and select the pencil icon ( ) to the left of the 
Product Set name in the listing.

The Edit Product Set screen displays.

2 Select the Products tab.

The full list of products in the product set displays including the green and red traffic light toggles. 
Products with a green light are active, products with a red light are inactive.

3 Select the traffic light toggle and switch between activated (green) and deactivated (red) products.

n Deactivating a product in a product set sends a removal command to all devices with that product, 
and the next highest ranked product is installed.
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n Activating a product in a product set might trigger other products to be removed on devices, and the 
newly activated product to be installed.

Viewing Product Sets in Device Details
Product Sets display on individual device detail pages to show the status of the products' deployments to 
the device. The products listed that are part of a product set display the product set they pertain to and 
the deployment status of the products.

The Products tab displays all the products in a product set that is assigned to a device. The status of the 
products in relation to the device is displayed as well. Not all the displayed products from a product set 
are applicable for the device viewed.

To see the product sets in the Device Details, navigate to Devices > List View and select the device you 
want to view. Then select the More option and select Products.

n Product Set – Displays the product set that contains the product. Select the product set to view the 
product set details.

n Status – Displays the status of the product. For products in a product set, the appropriate product 
deployed to the device is labeled as Compliant. The other products contained in the product set 
eligible for deployment but are not deployed to the device are labeled as Outranked. Any product 
that is not eligible to be deployed to the device is labeled as Not Applicable.

Change the Product Ranking in a Product Set
Product set ranking controls which product of a product set is sent to a device. Since the ranking is the 
key feature of product sets, changes in ranking cause a series of reactions in the product set.

The following are examples of rank changes and what happens to the product, product set, and devices 
as a result.
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Table 4-16. Rank Changes

Reason for Edit Effect of Edit

To add a product. The new product is set at the lowest rank. You must manually change the rank of the new product 
as needed.

Changing rank of existing 
products

Increasing the rank (selecting Up arrow) of a product decreases the rank of all subsequent products 
by one.

Decreasing the rank (selecting Down arrow) of a product increases the rank of previously lower-
ranked products.

After you complete the rank changes and save the product, the product set enters the policy engine 
for evaluation. The engine assesses the custom attribute for each device against the new device 
rankings.

If you reorder the Products priority within a Product Set, then the Products are reassigned based on 
the new priority order. As a result, the Workspace ONE UEM console sends removal commands for 
all devices affected by the reorder and assign Products based on the new order.

After editing product ranking, only the products affected by the new ranking receive removal and 
install commands. Products outside the change in ranking are not affected.

Removing a Product Removing a product increases the rank of all products previously ranked below the deleted product 
by one. If multiple products were removed, the ranking increases by one for each product removed.

All products that preceded the deleted product's rank remain unchanged.

Any products that had the removed product installed receives a new product based on the new 
rankings.

Procedure

1 Navigate to Devices > Provisioning > Product Sets.

2 Find the product set you want to add a product to and select the Edit icon ( ).

3 Select the Products tab.

4 Manually adjust the product rank as needed according to your business needs.

5 Select Save and apply the rank changes.

Custom Attributes
Custom attributes enable you to extract specific values from a managed device and return it to the 
Workspace ONE UEM powered by AirWatch. You can also assign the attribute value for device lookup 
values.

Note   Custom attributes (and the rules generator) are only configurable and useable at Customer-level 
organization groups.
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Custom Attributes Database
Custom attributes are stored either as XML files on the device or in the custom attribute database on the 
Workspace ONE UEM console server. When using the database, custom attributes are sent as samples 
to Workspace ONE UEM periodically for asset tracking of key/value pairs. If a record in the device 
database is configured with 'Create Attribute' = TRUE, then the Workspace ONE Intelligent Hub 
automatically retrieves the Name and Value sent with the custom attributes sample. The key/value pair 
displays in the Device Details page for the device in the Custom Attributes tab.

Note   Custom Attribute values cannot return the following special characters: / \ " * : ; < > ? |. If a script 
returns a value which contains these characters, the value is not reported on the console. Trim these 
characters from the script's output.

Create Custom Attributes
Create a custom attribute and values to push to devices in Workspace ONE UEM powered by AirWatch. 
These attributes and values control how product rules work. Custom Attributes also function as lookup 
values for certain devices.

Procedure

1 Navigate to Devices > Provisioning > Custom Attributes > List View.

2 Select Add and then select Add Attribute.

3 Under the Settings tab, enter an Attribute Name.

4 Enter the optional Description of what the attribute identifies.

5 Enter the name of the Application that gathers the attribute.

6 Select Collect Value for Rule Generator to make the values of the attribute available in the drop-
down menu of the rule generator.

7 Select Use in Rule Generator if you want to use the attribute in the rule generator.

8 Select Persist to prevent the removal of the custom attribute from the Workspace ONE UEM console 
unless an Admin or an API call explicitly removes it.

Otherwise, the attribute is removed as normal. If you delete a custom attribute reported from a device 
to the UEM console, a persisted custom attribute remains in the UEM console. Custom attribute 
persistence is only available to Android and Windows Rugged devices.

9 Select Use as Lookup Value to use the custom attribute as a lookup value anywhere in the UEM 
console.

You can use custom attributes as part of a device friendly name to simplify device naming.

10 Select the Values tab.

11 Select Add Value to add values to the custom attribute and then select Save.
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Create a Custom Attributes Profile, macOS
Write a command or script and report it as a custom attribute using the Workspace ONE Intelligent Hub 
for macOS v.2.3 or later. Select when to run the command or script on hourly intervals or during an event.

Custom Attributes can also be used in Assignment Rules for Products.

Procedure

1 Navigate to Devices > Profiles & Resources > Profiles and select Add then Add Profile. Select 
Apple macOS, and then select Device Profile, because this profile is only applicable to the entire 
device.

2 Scroll down the menu bar on the left and select Custom Attributes followed by Configure.

3 Enter the Attribute Name.

4 Enter the Script/Command to run. Expand the text box as needed.

5 Select an Execution Interval and allow for scheduling to report either in hours or as an event occurs.

6 Use the + and - buttons at the bottom of the payload to create multiple scripts.

7 Select Save & Publish when you are finished to push the profile to devices.

Note   Custom Attribute values cannot return the following special characters: / \ " * : ; < > ? |. If a 
script returns a value which contains these characters, the value is not reported on the console. Trim 
these characters from the script's output.

Custom Attributes Importing
The custom attribute batch import feature in Workspace ONE UEM powered by AirWatch allows you to 
load custom attributes and corresponding values into the system in bulk. In the templates provided, each 
column corresponds to one custom attribute and each row corresponds to their different parameters.

With the templates, you can import custom attributes in different ways and with different information.

Caution   The syntax of the first column of each template must be replicated exactly. Failure to use the 
proper syntax can cause database issues and result in loss of data.

Template Types
n Custom Attributes Template – Allows you to define a custom attribute and its settings.

n Custom Attribute Values Template – Allows you to define the values of predefined custom attributes.
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n Device Custom Attribute Values – Allows you to define the values of predefined custom attributes for 
individual devices based on the cross reference (Xref) value. The Xref values determine the individual 
devices receiving the value for each custom attribute.

a DeviceID (Workspace ONE UEM assigned DeviceID when the device enrolls)

b Serial Number

c UDID

d MAC Address

e IMEI Number

Save the file as a .csv before you import it.

Assign Organization Groups Using Custom Attributes
Configure rules that control how devices are assigned to organization groups following enrollment in 
Workspace ONE UEM powered by AirWatch. You are limited to one custom attribute assignment rule per 
organization group.

Procedure

1 Ensure that you are currently in a customer type organization group.

2 Navigate to Groups & Settings > All Settings > Devices & Users > General > Advanced.

3 Set Device Assignment Rules to Enabled.

4 Set the Type to Organization Group by Custom Attribute.

5 Select Save.

6 Navigate to Devices > Provisioning > Custom Attributes > List View > Add > Add Attribute and 
create a custom attribute if you have not already done so.

See Create Custom Attributes for more information.

7 Navigate to Devices > Provisioning > Custom Attributes > Custom Attributes Assignment 
Rules > Add Rule.

8 Select the Organization Group to which the rule assigns devices.
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9 Select Add Rule to configure the logic of the rule.

Setting Description

Attribute/
Application

This custom attribute determines device assignment.

Operator This operator compares the Attribute to the Value to determine if the device qualifies for the product.

When using more than one Operator in a rule, you must include a Logical Operator between each Operator.

Note   There is a limitation on the less than (<) and greater than (>) operators. This limitation includes "less than 
or equal to" and "greater than or equal to" variants. These operators are mathematical in nature, which means 
they are effective at comparing numbers including integers. They cannot be used to compare non-numeric text 
strings. And while it is common for software versions to be represented with numbers indicating a graded 
versioning system (for example, 6.14.2), such representations are not numbers because they have more than 
one decimal point. These representations are actually text strings. Therefore, any assignment rule that 
compares software version numbers with multiple decimal points using greater than or less than operators (and 
their variants) can result in an error message.

Value All values from all applicable devices are listed here for the Attribute selected for the rule.

Add Logical 
Operator

Select to display a drop-down menu of logical operators such as AND, OR, NOT, and parentheses. Allows for 
more complex rules.

10 Select Save after configuring the logic of the rule.

When a device enrolls with an assigned attribute, the rule assigns the device to the configured 
organization group.

Custom Attributes, Android
XML provisioning can collect custom attributes based on your Android device details. You can use custom 
attributes for product provisioning's more advanced functionality.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions > Add and select Android as 
your platform.

2 Create an XML provisioning file.

See Create an XML Provisioning File, Android, Win7, WinRugg. The manifest must include an action 
to download the XML file to the Zebra device location /enterprise/usr/attributes.

For non-Zebra Android devices, the XML file location is /sdcard/Android/data/
com.airwatch.androidagent/files/attributes/.

Upon receiving the XML file, the Workspace ONE Intelligent Hub for Android creates a custom attributes 
output file.

During the next check-in with AirWatch, the Workspace ONE Intelligent Hub sends the output file to the 
Workspace ONE UEM console.
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Once the XML file installs, the custom attributes requested in the file exported to the console. These 
values display in the console in the Device Details page under custom attributes. The Device Details 
page enables you to view the name of the attribute and the values returned from each device. These 
values can be used to create product assignment rules using the Custom Rules system.

Example

Android

<?xml version="1.0"?>

<attributes>

    <attribute name="attribute 1" value="value 1"/>

    <attribute name="attribute 2" value="value 2"/>

    <attribute name="attribute 3" value="value 3"/>

</attributes>

What to do next

You can also view existing custom attributes for all devices at a particular organization group and 
manually create custom attributes directly in the console. Navigate to Devices > Provisioning > Custom 
Attributes > List View. Any custom attribute created in this manner automatically associates with a 
device and its respective custom attribute value that is successfully transmitted to the console.

Custom Attributes, macOS
You can use custom attributes to unlock product provisioning's more advanced functionality for your 
macOS device.

Procedure

1 Navigate to Devices > Profiles & Resources > Profiles and select Add. Select Apple macOS, and 
then select Device Profile, because this profile is only applicable to the entire device.
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2 Create a Custom Attributes profile.

For more information, see Create a Custom Attributes Profile, macOS.

The script included in the profile runs on the device to gather the values for each attribute.

Example: Key-Value Pair Examples
The following is an example of commands you can use for creating, removing, or modifying key-value 
pairs. Use these commands to dynamically change the values for a custom attribute on the device.

Add a Key-Value Pair.

/usr/libexec/PlistBuddy -c "Add :ASSET_ID string '1'" "/Library/Application Support/AirWatch/Data/

CustomAttributes /CustomAttributes.plist"

Delete a Key-Value Pair.

/usr/libexec/PlistBuddy -c "Delete :ASSET_TAG" "/Library/Application Support/AirWatch/Data/

CustomAttributes/ CustomAttributes.plist"

Modify a Key-Value Pair.

/usr/libexec/PlistBuddy -c "Set :ASSET_ID '2'" "/Library/Application Support/AirWatch/Data/

CustomAttributes/ CustomAttributes.plist"

What to do next

You can view existing custom attributes for all devices at a particular organization group and manually 
create custom attributes directly in the console.

Navigate to Devices > Provisioning > Custom Attributes > List View. Any custom attribute created in 
this manner automatically associates with a device and its respective custom attribute value that is 
successfully transmitted to the console.

Custom Attributes, Win7
XML provisioning can collect custom attributes based on your Win7 device details. You can use custom 
attributes to unlock product provisioning's more advanced functionality.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions > Add and select Windows 7 
as your platform.

2 Create an XML product.

For more information, see Create an XML Provisioning File, Android, Win7, WinRugg. The manifest 
must include an action to download the XML file to {installation path}\AirWatch\AgentUI\Cache
\Profiles.
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Upon receiving the XML file, the Workspace ONE Intelligent Hub for Windows 7 creates a custom 
attributes output file. During the next check-in with Workspace ONE ™ UEM, the Workspace ONE 
Intelligent Hub sends the output file to the UEM console.

Once the XML file installs, the custom attributes requested in the file exported to the UEM console. These 
values display in the console in the Device Details page under Custom Attributes. The Device Details 
page enables you to view the name of the attribute and the values returned from each device. These 
values can be used to create product assignment rules using the Custom Rules system.

Upon enrollment, the Workspace ONE Intelligent Hub for PC automatically generates the Device Model 
and Serial Number attributes.

Example: Syncing Registry Settings
To synchronize the registry settings on a Windows 7 device with the console, which is likely the most 
common use of custom attributes for Windows 7 devices, you must create a custom XML file.

This sample XML file pulls information from the registry on a device:

<xml version="1.0">

<wap-provisioningdoc name="desiredDocName /V_1">

    <characteristic type="com.windowspc.getregistryinfo.managed">

        <reg_value value_name="KeyName(i.e. CommonFilesDir)"

        key_name="RegistryPath(i.e.Software\Wow6432Node\Microsoft\Windows\

        CurrentVersion)"custom_attribute_name="AttributeName"/>

        <reg_value value_name="Keyname ..." key_name="Path\...."

        custom_attribute_name="AttributeName2"/>

    </characteristic>

</wap-provisioningdoc>

It must be in the previous format for the XML file to get correctly parsed and the registry settings to be 
outputted to a key value pair that can be exported back to the UEM console.

In this example, the registry key path is “HKEY_LOCAL_MACHINE\Ident” for two of the values and within 
that key path it is reading the values of “Username” and “OrigName”. The ‘custom_attribute_name’ 
parameter is simply the name of the custom attribute that displays in the console and corresponds to the 
value read from the device.
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What to do next

You can also view existing custom attributes for all devices at a particular organization group and 
manually create custom attributes directly in the console. Navigate to Devices > Provisioning > Custom 
Attributes > List View. Any custom attribute created in this manner automatically associates with a 
device and its respective custom attribute value that is successfully transmitted to the console.

Custom Attributes, WinDesk
XML provisioning can collect custom attributes based on your Windows Desktop device details. You can 
use custom attributes to unlock product provisioning's more advanced functionality.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions > Add and select Windows > 
Windows Desktop as your platform.

2 Complete the steps to create an XML product as mentioned in Create an XML Provisioning File. 
Upload the XML file and specify the download path as {installation path}\AirWatch\AgentUI\Cache
\Profiles.

Upon receiving the XML file, the Workspace ONE Intelligent Hub creates a custom attributes output file. 
During the next check-in with Workspace ONE ™ UEM, the Workspace ONE Intelligent Hub sends the 
output file to the UEM console.

Once the XML file installs, the custom attributes requested in the file are reported to the UEM console. 
These values display in the console in the Device Details page under custom attributes. This page allows 
you to view the name of the attribute and the values returned from each device. These values can be 
used to create product assignment rules using the Custom Rules system.

Note   Note: Custom Attributes support the HKLM registry hive only.

Example: Fetching Registry Settings
A common use of custom attributes for Windows devices is to fetch registry settings with the UEM 
console. To do this, you must create a custom XML file and deploy it using a custom settings policy 
targeted to the AirWatch Unified Agent. Here is an example of the format of an XML file that can pull 
information from the registry on a device.
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Windows 10 Example

<xml version="1.0">

<wap-provisioningdoc name="System Info /V_1">

     <characteristic type="com.windowspc.getregistryinfo.managed">

          <reg_value custom_attribute_name="Hostname"

          key_name="SYSTEM\CurrentControlSet\Control\ComputerName\ActiveComputerName"

          value_name="ComputerName"/>

     </characteristic>

</wap-provisioningdoc>

The custom payload must be in the above format. When the correct syntax is used, the XML is parsed 
and the registry settings are outputted to a key value pair that are exported back to the Workspace ONE 
UEM console.

In the above example, the registry key name or path is “Computer\HKEY_LOCAL_MACHINE\SYSTEM
\CurrentControlSet\Control\ComputerName\ActiveComputerName” and the value_name is 
“ComputerName”. The data corresponding to this value name is retrieved and stored in the console with 
the label specified under the ‘custom_attribute_name’ parameter which is “Hostname” in the examples.

The final output of this configuration stores the computer name of the device in the Workspace ONE 
database with a key Hostname and a data value retrieved from the device. For example, Hostname -> 
JSMITH-PC01. This data can be viewed in the Custom Attributes tab on the Device Details view.

What to do next

You can also view existing custom attributes for all devices at a particular organization group and 
manually create custom attributes directly in the console. Navigate to Devices > Provisioning > Custom 
Attributes > List View. Any custom attribute created in this manner automatically associates with a 
device and its respective custom attribute value that is successfully transmitted to the console.

Custom Attributes, WinRugg
XML provisioning can collect custom attributes based on device details for your Windows Rugged device. 
You can use custom attributes to unlock product provisioning's more advanced functionality.

Procedure

1 Navigate to Devices > Provisioning > Components > Files/Actions, then select the Add Files/
Actions button, and then select Windows Rugged as your platform.

2 Create an XML product.

For more information, see Create an XML Provisioning File, Android, Win7, WinRugg. The manifest 
includes an action to download the XML file to \Program Files\Airwatch\Cache\Profiles.

Upon receiving the XML file, the Workspace ONE Intelligent Hub for Windows Rugged creates a custom 
attributes output file. During the next check-in with Workspace ONE UEM, the Workspace ONE Intelligent 
Hub sends the output file to the Workspace ONE UEM console.
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Once the XML file installs, the custom attributes requested in the file are reported to the UEM console. 
These values display in the UEM console on the Device Details page under custom attributes. The 
Device Details page enables you to view the name of the attribute and the values returned from each 
device. These values can be used to create product assignment rules using the Custom Rules system.

Example

Syncing Registry Settings

To synchronize the registry settings on a Windows Rugged device with the console, which is likely the 
most common use of custom attributes for Windows Rugged devices, you must create a custom XML file. 
Below is an example of the format of an XML file that can pull information from the registry on a device:

<?xml version="1.0"?>-<wap-provisioningdoc allowRemoval="True" name="GetTypicalRegValues/V_1" 

id="5a63204f-848c-42d5-9c14-4ca070743920">

    -<characteristic uuid="f49a9cb5-48e9-47cd-84cc-ef122dcb5d50" 

type="com.airwatch.getregistryinfo.winmo">

        <reg_value value_name="Username"

          key_name="HKEY_LOCAL_MACHINE\Ident"

          custom_attribute_name="HKLM_Ident_Username"/>

        <reg_value value_name="OrigName"

          key_name="HKEY_LOCAL_MACHINE\Ident"

          custom_attribute_name="HKLM_Ident_OrigName"/>

        <reg_value value_name="BootCount"

          key_name="HKEY_LOCAL_MACHINE\Comm"

          custom_attribute_name="HKLM_Comm_BootCount"/>

        <reg_value value_name="DeviceIdAlgorithm"

          key_name="HKEY_LOCAL_MACHINE\Software\AirWatch"

          custom_attribute_name="Software_AirWatch_DeviceIdAlgorithm"/>

    </characteristic></wap-provisioningdoc>
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It must be in the previous format for the XML file to get correctly parsed and the registry settings to be 
outputted to a key value pair that can be exported back to the UEM console. In this example, the registry 
key path is “HKEY_LOCAL_MACHINE\Ident” for two of the values and within that key path it is reading 
the values of “user name” and “OrigName”. The ‘custom_attribute_name’ parameter is simply the name of 
the custom attribute that displays in the console and corresponds to the value read from the device.

Using Third-Party Applications to Create Custom Attributes

If you want to create custom attributes using a third-party application, you need that application to export 
an XML file with a key value pair to the Program Files\AirWatch\Cache\CustomAttributes directory on 
the device. Once an XML file with a key value pair is present in this directory, it is parsed by the 
Workspace ONE Intelligent Hub and included in the next interrogator sample. The XML key/value pair 
must be in the following format.

<?xml version="1.0"?>-<attributes>

    <attribute name="HKLM_Ident_Username" value="guest"/>

    <attribute name="HKLM_Ident_OrigName" value="Pocket_PC"/>

    <attribute name="HKLM_Comm_BootCount" value="1"/>

    <attribute name="Software_AirWatch_DeviceIdAlgorithm" value="3"/>

    <attribute name="HKLM_SoftwareAW_SerialNo" value="13233521403231"/>

</attributes>

‘Attribute name’ is the name of the attribute in the console while ‘value’ is the corresponding value that is 
associated with that attribute.

What to do next

You can also view existing custom attributes for all devices at a particular organization group and 
manually create custom attributes directly in the UEM console. Navigate to Devices > Provisioning > 
Custom Attributes > List View. Any custom attribute created in this manner automatically associates 
with a device and its respective custom attribute value that is successfully transmitted to the UEM 
console.
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Product Management 5
Manage products using the product provisioning management functionality built into Workspace ONE 
UEM powered by AirWatch. Product management uses the Products Dashboard, Products List View, and 
Device Details View to manage how devices use products.

Rugged devices have different device actions and options than consumer devices. Some actions, such as 
Remote Management, require additional configuration before using with devices. Products must be 
deactivated before most device actions work. You must also disable any components before using device 
actions.

XML Provisioning
For Android, Win7, and WinRugg Only, XML provisioning allows you to download a custom-designed 
XML file to a device in a provisioning product. After the file is downloaded, it runs an install command to 
extract the settings from the XML file and install them on the device. For more information, see Create an 
XML Provisioning File, Android, Win7, WinRugg.

This chapter includes the following topics:

n Products Dashboard

n Products List View

n Effects of Editing an Event-Action or Condition

n View Information About Products in Device Details

n Product Job Statuses

Products Dashboard
Workspace ONE UEM powered by AirWatch lets you view and manage products to provision from the 
Products Dashboard. Navigate to Devices > Provisioning > Products Dashboard.

The dashboard provides an easy method of viewing the status of your products and the devices they 
provision. The charts of information allow you to examine specific products or devices so you can remain 
informed about your device fleet.
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Recent Product Status
This chart displays the 10 most recently created products and the status for each product. You can select 
any section of the bar graph to view the devices to which that product status applies.

n Compliant – The product installed on the device and the inventory data of the product reported by the 
device matches the requirements of the product.

n For Windows Rugged Only: The product also passes a file hash validation, ensuring the 
product on the device is the exact same product provisioned by the console or API call.

n In Progress – The product has been sent to the device and is pending a compliance check based on 
inventory.

n n For Windows Rugged Only: The compliance check also factors in file hash data to be received 
from the device.

n Must Push – The product deployment type is set to elective. The admin on the console side must 
initiate product installation.

n Dependent – The product depends on another product installation before installing onto devices.

n Failed – The product reached maximum attempts to install on the device and is no longer attempting 
to install.

Filters

You can filter the Recent Product Status chart to refer to specific device platforms that support product 

provisioning. To filter your results, select the Menu icon ( ) in the top right corner. Select the platforms 
you want to filter by.

Product Compliance
The Product Compliance chart shows the total percentage of each compliance status. The number 
displayed in each status is the total number of product statuses reported from each device.

Filters

You can filter the Product Compliance chart to display specific device platforms that support product 
provisioning and the total percentage of each compliance status for a specific products.
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To filter your results, select the Menu icon ( ) in the top right corner. Select either the platform or the 
product by which you want to filter.

Top Job Compliance
This chart displays a ratio of total job count to the number of devices to which the product is provisioned. 
This ratio gives you information on what products are having issues running.

For example, if the number shown is a 3, then you know that an average of 3 jobs per device happens for 
this product. If you select the bar for each product, the View Devices screen displays with all devices 
currently assigned the product. You can then determine which jobs are failing and the reason for those 
failures.

Filters

You can filter the Total Job Compliance chart to refer to specific device platforms that support product 

provisioning. To filter your results, select the menu icon ( ) in the top right corner. Select the platforms 
you want to filter by.

Product Breakdown
This section shows you the breakdown of your products. The first chart shows the breakdown of products 
by platform. Selecting a platform displays the Products List View filtered by that product. This 
arrangement allows you to see the products available for each platform quickly.

The second chart displays the percentage of your products that are active vs. inactive and a total number 
of products. Selecting a chart displays the Products List View page filtered by the status of the product.
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Products List View
The Product List view in Workspace ONE UEM powered by AirWatch allows you to view, edit, copy, 
reprocess, and delete products and view the devices on which your products are provisioned.

Navigate to Devices > Provisioning > Product List View. Listed here are all the available products for 
the current organization group. The products can be sorted using the columns.

n Platform sorts by the device platform.

n Managed By sorts by the organization group the product is assigned to.

n A/D sorts by if the product uses activation/deactivation dates or manual.

n Compliant, In Progress, Failed, and Total Assigned sort by the status of the product on devices.

View the details and settings of the product by selecting a product by name. The View Product screen 
displays the general settings, manifest items, conditions, deployment settings, and product dependencies 
for the product. You can also select the number links in the Compliant, In Progress, Failed, Has 
Dependency, Must Push, Offline, and Total columns, allowing you to see device details as they pertain 
to these product provisioning statuses.

Select the edit radio button to the left of each product name and you have access to the following actions.

n You can Deactivate a product, making it no longer accessible. Deactivating the product also clears all 
pending provisioning commands.

n Select the Edit button to edit a product. You can only edit products after they are deactivated. Edit 
displays the Product Wizard allowing you to change any part of a product.

n Select the View Devices button to view all devices to which the product provisions. A quick summary 
of information on each device allows you to see which devices are at specific statuses. Select a 
device Friendly Name to open the Device Details Page for that device.

More Actions
n You can view the Activation Log for the selected product, which displays detailed information about 

the product including date of activation and the name of the admin who initiated the activation.
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n You can make a Copy of a product. If one of your products has detailed and intricate parameters, you 
can save time programming them from the beginning by making a copy of an existing product. You 
can then, for example, change the application in the manifest of the copy, and as a result, make an 
entirely new product that shares the same detailed parameters.

n You can attempt to fix non-compliant products and push the product to the device again by selecting 
the Reprocess button.

n The Force Reprocess action resends Products to all assigned devices regardless of compliance 
status. The devices fully download and install every component of the Product manifest, even if it 
exists on the device already. You can perform this action on multiple products simultaneously.

n Select the Relay Server Status button to see the status of the relay server associated with the 
product. Only active products have the Relay Server Status button. You can also view history from 
the View Devices page to see the past and future products pushed to the device based on Product 
sync.

n The Inherited Products option displays all inherited products a child organization group receives 
from the parent organization groups. As products are provisioned based on smart groups and not 
organization groups, your devices can receive products from a parent organization group.

Effects of Editing an Event-Action or Condition
When you edit an Event-Action or Condition in Workspace ONE UEM powered by AirWatch, you are 
given the chance to activate or deactivate the product that depends upon it but only under certain 
circumstances.

Note   Problems with the active product can arise when you change its components like Event-Actions or 
Conditions. To mitigate the likelihood of problems affecting the product, consider deactivating the product 
before making changes, then reactivate the product after.

Editing an Event-Action
When you edit an Event-Action, only those Event-Actions that are currently a component of an Active 
Product can you affect the product to which the Event-Action belongs.

To edit the Event-Action, take the following steps.

1 Navigate to Devices > Provisioning > Components > Event Actions.

2 Locate the Event-Action you want to edit and select the edit icon ( ) to the left of the listing.

3 Proceed through the Platform, Details, Conditions and Actions tabs, making edits per your 
preferences.

4 On the Summary tab, select Save.

n If no Warning screen displays, then the Event-Action is not a current component of an active 
product.
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n If a Warning screen displays with an Active Product name, then you must Activate or 
Deactivate the product shown.

Selecting Activate means that the product is effectively re-provisioned and distributed as an active job.

Selecting Deactivate resets the status of the product as inactive.

Editing a Condition
When you edit a condition, the only time you can affect a product is when that condition is...

n ...a direct component of that Active Product.

OR

n ...used in an Event-Action that is a component in that Active Product.

To edit the Condition, take the following steps.

1 Navigate to Devices > Provisioning > Components > Conditions.

2 Locate the Condition you want to edit and select the edit icon ( ) to the left of the listing.

3 Proceed through the Type and Details tabs, making edits per your preferences.

4 On the Details tab, select Save when you are finished making changes.

n If no Warning screen displays, then the Condition is not a current component of an active 
product.

n If a Warning screen displays with an Active Product name, then you must Activate or 
Deactivate the product shown.

Selecting Activate means that the product is effectively reprovisioned and distributed as an active job.

Selecting Deactivate resets the status of the product as inactive.

View Information About Products in Device Details
You can use the Device Details View in Workspace ONE UEM powered by AirWatch to see the products, 
files/actions, apps, and profiles pushed to a device.

Products
To view the products on a device, navigate to Devices > List View > Select a device > More > 
Products.

Any product that fails to push to devices can be reprocessed by selecting the Reprocess button next to 
the failed product.
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Product Sets
Product Sets display on individual device detail pages to show the status of the products' deployments to 
the device. The products listed that are part of a product set display the product set they pertain to and 
the deployment status of the products.

The following text boxes display relevant product set information.

n Product Set – Displays the product set that contains the product. Select the product set to view the 
product set details.

n Status – Displays the status of the product. For products in a product set, the appropriate product 
deployed to the device is labeled as Compliant. The other products contained in the product set that 
are eligible for deployment but are not deployed to the device are labeled as Outranked. Any product 
that is not eligible for deployment to the device is labeled as Not Applicable.

Files/Actions
Navigate to Devices > List View > Select a device > More > Files/Actions to access the files/actions 
on the device.

Applications
For Android devices only, navigate to Devices > Details View > Apps to access the Applications on the 
device.

Profiles
For Windows Rugged devices, Windows Desktop devices, QNX devices, and Android devices only, 
navigate to Devices > Details View > Additional Options > Profiles to access the Profiles on the 
device.

Product Job Statuses
Product provisioning works by interpreting each item in a product as a different task or Job that the UEM 
server handles. As a product is pushed to a device, Workspace ONE UEM powered by AirWatch updates 
the status of each job to display any errors or issues that are in process.

Product Job Logs
You can view more detail about product jobs by viewing the job logs.

Navigate to Devices > List View and select the friendly name of a device that has been provisioned with 
a product. Next, select the More tab, select Products, then select the magnifying glass icon to the right of 
the Last Job Status column. This action displays the Jobs screen which provides access to the contents 
of the Job logs.

The Job logs provide a detailed history of events that have elapsed for the device in question as it 
pertains to the assigned product. This history includes timestamps, progress, error messages, and pause/
resume history.
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Each job follows a workflow and the statuses reflect the position in the process.

Job Status Description

*Queued The job is created but not yet started.

Delivered Job initially delivered to device database.

Paused Job was previously started but a failure occurred. Jobs resume before other jobs are 
processed.

Download Pending. The download remains in a pending state until download conditions are met.

Downloaded The job downloaded to the device.

Install pending. The install is pending until install conditions are met.

Installed The job installed on the device.

Deferred Job download conditions not yet met.

Waiting Job is processing on the device but the status of the job is not confirmed.

Completed / Failed Job processing complete. Complete means that the process was a success. Failed means 
that the process failed.

Canceled Job canceled while deferred or waiting.

Orphaned Job being processed by device is incomplete when job is reprocessed. Job automatically 
restarts when able.

Deleted The job was canceled by the user on the device.

Note   * If one or more relay servers are part of your product provisioning environment, you might see 
extended periods in which "Queued" is the official job status. While each relay server added to the 
processing chain serves to enhance greatly the performance of a busy provisioning environment, they 
also tend to delay the reporting of a conclusive product status.

You can use the following methods to troubleshoot and investigate a job status where relay servers are 
involved.
n Check Relay Server Advanced Info - Navigate to Devices > Provisioning > Relay Servers > List 

View and select the radio button to the left of the relay server name. Select the More Actions button 
that appears and lastly, select Advanced Info. This displays the Relay Server Advanced 
Information screen, where you can verify a product's Queued Count. Device commands for 
products are not sent to devices until any recently created product stops being reported in this text 
box. Once you see a zero value in this text box, then device commands can be sent.

n Check Relay Server Status. - Navigate to Devices > Provisioning > Product List View and select 
the radio button to the left of the product you want to research. Select the More Actions button and 
lastly, select Relay Server Status. You can monitor the specific status of the relay server by pointing 
your cursor over the displayed Relay Server icon.
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Job Log Detail Level
You can set the amount of detail captured in the Job Log for Android and Windows Rugged devices only 
by navigating to Groups & Settings > All Settings > Devices & Users > Android or Windows > 
Windows Rugged then continue on to Hub Settings then scroll down to the Product Provisioning 
section and select the Job Log Level you prefer.

You can also Target a Device Log Level for Troubleshooting Purposes, Android and WinRugg.

Configure the Collection of Job Logs for Specific Devices
You can target individual devices to collect their provisioning job logs.

Procedure

1 Navigate to Groups & Settings > All Settings > Admin > Diagnostics > Logging.

2 Select the Enabled slider for each component and Scheduled Services for which you want to collect 
data.

3 Scroll down to the Targeted Logging section, Enable the Targeted Logging slider, and complete the 
settings.

Setting Description

Organization Groups Select the organization groups where the devices reside.

Device IDs Enter the device IDs for which you want to enable targeted logging. Use commas 
to separate multiple device IDs.

File Storage Impersonation Enabled Enable if you are using a file storage server to store these targeted logs and enter 
the appropriate authentication credentials.

File Path Enter the path and filename of the LOG file where you want the data saved.

File Storage Impersonation User 
Name

This option appears only when File Storage Impersonation Enabled is selected.

Enter the user name of the storage server where you targeted logs are saved.

File Storage Impersonation Password This option appears only when File Storage Impersonation Enabled is selected.

Enter the corresponding password of the user name of the storage server where 
you targeted logs are saved.

Test Connection (button) This button tests various possible scenarios which the logging process uses and 
makes sure it is working as expected.

 
4 Save to apply Targeted Logging.

What to do next

For Android and Windows Rugged only, you can target an individual device for troubleshooting purposes. 
See Target a Device Log Level for Troubleshooting Purposes, Android and WinRugg.

Define How Much Data to Collect, Product Job Log
You can define the length of time job log data is collected. Define this timescale by taking the following 
steps.
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Procedure

1 Navigate to Groups & Settings > All Settings > Admin > Data Purging.

2 Locate the purge module named DevicePolicyJobPurge and select the pencil icon ( ) to open the 
Data Purging screen.

3 Complete the Purge older than (days) setting with the length of time in days that you want to keep 
job log data.

4 Select Save.

Job logs older than the selected number of days are purged from the Workspace ONE UEM console.

Target a Device Log Level for Troubleshooting Purposes, Android 
and WinRugg
You can target an individual device and temporarily change its logging level for troubleshooting purposes.

Procedure

1 Navigate to Devices > List View, locate the device you want to troubleshoot and select the device-
friendly name to display the Device Details.

2 Click the More tab and select Targeted Logging.

3 Select Create New Log and select the length of time you want the log to capture data.

4 Select Start to begin the logging.
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Device Management 6
You can manage devices you have provisioned products onto using the tools and features included with 
Workspace ONE UEM powered by AirWatch, such as Device Details, Enterprise Reset, Advanced 
Remote Management, and much more.

The features presented in the topics that follow are specific to devices associated with product 
provisioning, including Windows Rugged, QNX, and others. For information about device management or 
the Workspace ONE UEM Console in general, see VMware Workspace ONE Managing Devices and 
VMware Workspace ONE Console Basics, each available on docs.vmware.com.

This chapter includes the following topics:

n Device Details Page, QNX

n Device Details Page, WinRugg

n Windows Desktop Device Details Page

n Device Details Page, Win7

n Configure Settings, QNX

n Enterprise Reset a Rugged Device, Android and WinRugg

n Enable AirWatch Cloud Messaging, Android Rugged

n Workspace ONE Assist

n Platform OEM Service, Android Provisioning

n Batch (BAT) File Guidelines, Win7 and WinDesk

Device Details Page, QNX
The Device Details page for QNX in Workspace ONE UEM powered by AirWatch displays detailed device 
information for QNX devices and lets you quickly access user and device management actions.

You can access the Device Details page by selecting a device's Friendly Name from the Device Search 
page. You can also use one of the available Dashboards or any of the available search tools with the 
Workspace ONE ™ UEM console.
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From the Device Details page, you can access specific device information broken into different menu 
tabs. Each menu tab contains related device information depending on your Workspace ONE UEM 
deployment.

Performing Remote Actions
The More drop-down on the Device Details page enables you to perform remote actions over-the-air to 
the selected device.

The actions listed below vary depending on factors such as device platform, UEM console settings, and 
enrollment status.

n Add Tag – Assign a customizable tag to a device, which can be used to identify a special device in 
your fleet.

n Change Organization Group – Change the device's home organization group to another existing 
OG. Includes an option to select a static or dynamic OG.

n If you want to change the organization group for multiple devices at a time, you must select 
devices for the bulk action using the Block selection method (using the shift-key) instead of the 
Global check box (next to the Last Seen column heading in the device list view).

n Delete Device – Delete and unenroll a device from the console. Sends the enterprise wipe command 
to the device that gets wiped on the next check-in and marks the device as Delete In Progress on 
the console. If the wipe protection is turned off on the device, the issued command immediately 
performs an enterprise wipe and removes the device representation in the console.

n Edit Device – Edit device information such as Friendly Name, Asset Number, Device Ownership, 
Device Group Device Category.

n Enterprise Wipe – Enterprise Wipe a device to unenroll and remove all managed enterprise 
resources including applications and profiles. This action cannot be undone and re-enrollment is 
required before Workspace ONE UEM can manage this device again. This device action includes 
options to prevent future re-enrollment and a Note Description text box for you to add information 
about the action.

n Enterprise Wipe is not supported for cloud domain-joined devices.

n Remote Management – Take control of a supported device remotely using this action, which starts a 
console application that enables you to perform support and troubleshoot on the device. Android 
devices require Remote Control Service to be installed on the device.

n Send Message – Send a message to the user of the selected device. Select between Email, Push 
Notification (through AirWatch Cloud Messaging), and SMS.

Device Details Page, WinRugg
Use the Device Details page in Workspace ONE UEM powered by AirWatch to track detailed Windows 
Rugged device information and quickly access user and device management actions. You can access 
Device Details by selecting a Friendly Name from the Device List View, using one of the Dashboards, or 
with any of the search tools.
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From the Device Details page, you can access specific device information broken into different menu 
tabs. Each menu tab contains related device information depending on your Workspace ONE UEM 
deployment.

Remote Actions
The More drop-down on the Device Details page enables you to perform remote actions over the air to 
the selected device.
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The actions vary depending on factors such as the device platform, UEM console settings, and 
enrollment status:

n Add Tag – Assign a customizable tag to a device, which can be used to identify a special device in 
your fleet.

n Apps (Query) – Send an MDM query command to the device to return a list of installed applications.

n Certificates (Query) – Send an MDM query command to the device to return a list of installed 
certificates.

n Change Organization Group – Change the device's home organization group to another existing 
OG. Includes an option to select a static or dynamic OG.

n If you want to change the organization group for multiple devices at a time, you must select 
devices for the bulk action using the Block selection method (using the shift-key) instead of the 
Global check box (next to the Last Seen column heading in the device list view).

n Clear Passcode (Device) – Clear the device passcode. To be used in situations where the user has 
forgotten their device's passcode.

n Delete Device – Delete and unenroll a device from the console. Sends the enterprise wipe command 
to the device that gets wiped on the next check-in and marks the device as Delete In Progress on 
the console. If the wipe protection is turned off on the device, the issued command immediately 
performs an enterprise wipe and removes the device representation in the console.

n Device Information (Query) – Send an MDM query command to the device to return information on 
the device such as friendly name, platform, model, organization group, operating system version, and 
ownership status.

n Device Wipe – Send an MDM command to wipe a device clear of all data and operating system. This 
action cannot be undone.

n Edit Device – Edit device information such as Friendly Name, Asset Number, Device Ownership, 
Device Group Device Category.

n Enterprise Reset – Enterprise Reset a device to factory settings, keeping only the Workspace ONE 
UEM enrollment.

n Windows Desktop Only: Enterprise Reset restores a device to a Ready to Work state when a 
device is corrupted or has malfunctioning applications. It reinstalls the Windows OS while 
preserving user data, user accounts, and managed applications. The device will resync auto-
deployed enterprise settings, policies, and applications after resync while remaining managed by 
Workspace ONE.

n Enterprise Wipe – Enterprise Wipe a device to unenroll and remove all managed enterprise 
resources including applications and profiles. This action cannot be undone and re-enrollment is 
required before Workspace ONE UEM can manage this device again. This device action includes 
options to prevent future re-enrollment and a Note Description text box for you to add information 
about the action.

n Enterprise Wipe is not supported for cloud domain-joined devices.
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n File Manager – Start a File Manager within the UEM console that enables you to view remotely a 
device's content, add folders, conduct searches, and upload files.

n Provision Now – Provision products to a device. Provisioning is the ability to create an ordered 
installation of files, actions, profiles, and applications into a single product that can be pushed to 
devices.

n Query All – Send a query command to the device to return a list of installed applications (including 
Workspace ONE Intelligent Hub, where applicable), books, certificates, device information, profiles, 
and security measures.

n Registry Manager – Start a Registry Manager within the UEM console that enables you to view 
remotely a device's OS registry, add keys, conduct searches and add properties.

n Remote Control – Take control of a supported device remotely using this action, which starts a 
console application that enables you to perform support and troubleshooting on the device. Android 
devices require Remote Control Service to be installed on the device.

n Remote Management – Take control of a supported device remotely using this action, which starts a 
console application that enables you to perform support and troubleshoot on the device. Android 
devices require Remote Control Service to be installed on the device.

n Request Device Check-In – Request that the selected device check itself in to the UEM console. 
This action updates the Last Seen column status.

n Restart Workspace ONE Intelligent Hub – Restart the Workspace ONE Intelligent Hub. This option 
is used during troubleshooting for when the enrollment process or submodule installation process is 
interrupted.

n Send Message – Send a message to the user of the selected device. Select between Email, Push 
Notification (through AirWatch Cloud Messaging), and SMS.

n Start/Stop AWCM – Start/Stop the Cloud Messaging service for the selected device. VMware 
AirWatch Cloud Messaging (AWCM) streamlines the delivery of messages and commands from the 
Admin Console. The AWCM eliminates the need for end users to access the public Internet or use 
consumer accounts such as Google IDs.

n Task Manager – Run a Task Manager within the UEM console that enables you to view remotely a 
device's currently running tasks, including task Name, Process ID, and applicable Actions you can 
take.

n View Manifest – View the device's Package Manifest in XML format from the UEM console. The 
manifest on Windows Rugged devices lists metadata for widgets and applications.

n Warm Boot – Initiate a restart of the operating system without performing a power-on self-test 
(POST).

n Workspace ONE Intelligent Hub Query – Send a query command to the Workspace ONE Intelligent 
Hub on the device to ensure it has been installed and is functioning normally.
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Windows Desktop Device Details Page
Use the Device Details page in Workspace ONE UEM powered by AirWatch to track detailed device 
information for Windows Desktop devices and quickly access user and device management actions.

You can access Device Details by selecting a Friendly Name from the Device List View, using one of the 
Dashboards, or with any of the search tools.

From the Device Details page, you can access specific device information broken into different menu 
tabs. Each menu tab contains related device information depending on your Workspace ONE UEM 
deployment.

Windows Notification Service Details
You can see the status of device communication with the Windows Notification Service(WNS) from the 
Network tab of the Device Details page. The WNS supports sending your devices notifications. If a device 
is not currently online, the service caches the notifications until the device connects again.

The WNS statuses include the following:

n WNS Server Status - displays the state of your WNS server.

n Last WNS Renewal Request - The date and time of last attempt made to renew the Windows 
Notification Services (WNS) connection with the device. This connection allows Workspace ONE 
UEM to query and push policies to the device in real time (Networking, Battery Sense, and Data 
Sense conditions permitting). For more information on WNS, please refer to https://
docs.microsoft.com/en-us/windows/client-management/mdm/push-notification-windows-mdm.

n Next WNS Get Request: - The date and time of the next scheduled attempt to renew the connection 
between WNS and the device.

n WNS Channel URI - The WNS communication endpoint that devices and Workspace ONE UEM use. 
This endpoint uses the following format: https://*.notify.windows.com/?token=_{TOKEN}

Remote Actions
The More Actions drop-down on the Device Details page enables you to perform remote actions over 
the air to the selected device.

The actions vary depending on factors such as the device platform, Workspace ONE UEM console 
settings, and enrollment status:

n Add Tag – Assign a customizable tag to a device, which can be used to identify a special device in 
your fleet.

n Apps (Query) – Send an MDM query command to the device to return a list of installed applications.
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The Apps (Query) action requires an active enrolled user login.

n View BIOS Password – View the BIOS password for the device that was auto-generated by the 
Workspace ONE UEM console. You see the Last Password Applied and the Last Password 
Submitted.

n Force BIOS Password Reset – Force the device to reset the BIOS password to a new auto-
generated password.

n Certificates (Query) – Send an MDM query command to the device to return a list of installed 
certificates.

The Certificates (Query) requires an active enrolled user login.

n Change Organization Group – Change the device's home organization group to another existing 
OG. Includes an option to select a static or dynamic OG.

n If you want to change the organization group for multiple devices at a time, you must select 
devices for the bulk action using the Block selection method (using the shift-key) instead of the 
Global check box (next to the Last Seen column heading in the device list view).

n Request Device Log – Request the debug log for the selected device, after which you can view the 
log by selecting the More tab and selecting Attachments > Documents. You cannot view the log 
within the Workspace ONE UEM console. The log is delivered as a ZIP file that can be used to 
troubleshoot and provide support.

When you request a log, you can select to receive the logs from the System or the Hub. System 
provides system-level logs. Hub provides logs from the multiple agents running on the device.
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Android Only: you can retrieve detailed logs from corporate-owned Android devices and view them 
in the console to resolve issues on the device quickly.

n Delete Device – Delete and unenroll a device from the console. Sends the enterprise wipe command 
to the device that gets wiped on the next check-in and marks the device as Delete In Progress on 
the console. If the wipe protection is turned off on the device, the issued command immediately 
performs an enterprise wipe and removes the device representation in the console.

n Device Information (Query) – Send an MDM query command to the device to return information on 
the device such as friendly name, platform, model, organization group, operating system version, and 
ownership status.

n Device Wipe – Send an MDM command to wipe a device clear of all data and operating system. This 
action cannot be undone.

n Edit Device – Edit device information such as Friendly Name, Asset Number, Device Ownership, 
Device Group Device Category.

n Enterprise Wipe – Enterprise Wipe a device to unenroll and remove all managed enterprise 
resources including applications and profiles. This action cannot be undone and re-enrollment is 
required before Workspace ONE UEM can manage this device again. This device action includes 
options to prevent future re-enrollment and a Note Description text box for you to add information 
about the action.

n Enterprise Wipe is not supported for cloud domain-joined devices.

n Enterprise Reset – Enterprise Reset a device to factory settings, keeping only the Workspace ONE 
UEM enrollment.

n Windows Desktop Only: Enterprise Reset restores a device to a Ready to Work state when a 
device is corrupted or has malfunctioning applications. It reinstalls the Windows OS while 
preserving user data, user accounts, and managed applications. The device will resync auto-
deployed enterprise settings, policies, and applications after resync while remaining managed by 
Workspace ONE.

n Lock Device – Send an MDM command to lock a selected device, rendering it unusable until it is 
unlocked.
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Important   When locking a device, an enrolled user must be signed into the device for the command to 
process. The lock command locks the device and any user signed in must reauthenticate with Windows. 
If an enrolled user is signed-in to the device, a lock device command locks the device. If an enrolled user 
is not signed in, the lock device command is not processed.

n Query All – Send a query command to the device to return a list of installed applications (including 
Workspace ONE Intelligent Hub, where applicable), books, certificates, device information, profiles, 
and security measures.

n Reboot Device – Reboot a device remotely, reproducing the effect of powering it off and on again.

n Remote Management – Take control of a supported device remotely using this action, which starts a 
console application that enables you to perform support and troubleshoot on the device. Android 
devices require Remote Control Service to be installed on the device.

n Security (Query) – Send an MDM query command to the device to return the list of active security 
measures (device manager, encryption, passcode, certificates, and so on).

n Send Message – Send a message to the user of the selected device. Select between Email, Push 
Notification (through AirWatch Cloud Messaging), and SMS.

Device Details Page, Win7
Use the Device Details page in Workspace ONE UEM powered by AirWatch to track detailed device 
information for Windows 7 devices and quickly access user and device management actions.

You can access Device Details by selecting a Friendly Name from the Device List View, using one of the 
Dashboards, or with any of the search tools.

From the Device Details page, you can access specific device information broken into different menu 
tabs. Each menu tab contains related device information depending on your Workspace ONE UEM 
deployment.

Remote Actions
The More drop-down on the Device Details page enables you to perform remote actions over the air to 
the selected device.
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The actions vary depending on factors such as the device platform, Workspace ONE UEM console 
settings, and enrollment status:

n Add Tag – Assign a customizable tag to a device, which can be used to identify a special device in 
your fleet.

n Change Organization Group – Change the device's home organization group to another existing 
OG. Includes an option to select a static or dynamic OG.

n If you want to change the organization group for multiple devices at a time, you must select 
devices for the bulk action using the Block selection method (using the shift-key) instead of the 
Global check box (next to the Last Seen column heading in the device list view).

n Delete Device – Delete and unenroll a device from the console. Sends the enterprise wipe command 
to the device that gets wiped on the next check-in and marks the device as Delete In Progress on 
the console. If the wipe protection is turned off on the device, the issued command immediately 
performs an enterprise wipe and removes the device representation in the console.

n Edit Device – Edit device information such as Friendly Name, Asset Number, Device Ownership, 
Device Group Device Category.

n Enterprise Wipe – Enterprise Wipe a device to unenroll and remove all managed enterprise 
resources including applications and profiles. This action cannot be undone and re-enrollment is 
required before Workspace ONE UEM can manage this device again. This device action includes 
options to prevent future re-enrollment and a Note Description text box for you to add information 
about the action.

n Enterprise Wipe is not supported for cloud domain-joined devices.

n Lock Device – Send an MDM command to lock a selected device, rendering it unusable until it is 
unlocked.

n Query All – Send a query command to the device to return a list of installed applications (including 
Workspace ONE Intelligent Hub, where applicable), books, certificates, device information, profiles, 
and security measures.

n Remote Management – Take control of a supported device remotely using this action, which starts a 
console application that enables you to perform support and troubleshoot on the device. Android 
devices require Remote Control Service to be installed on the device.

n Send Message – Send a message to the user of the selected device. Select between Email, Push 
Notification (through AirWatch Cloud Messaging), and SMS.

Configure Settings, QNX
Workspace ONE UEM powered by AirWatch, together with the Workspace ONE Intelligent Hub app, 
manage all the special settings that QNX devices have. You can change these settings when you need 
the Hub to meet certain business needs.
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Procedure

u Edit the Workspace ONE Intelligent Hub Settings by navigating to Groups & Settings > All Settings 
> Devices & Users > QNX > Hub Settings.

Setting Description

Device ID Algorithm Set the unique device identification algorithm used on the device.

Heartbeat Interval 
(min)

Set the time (in minutes) the Workspace ONE Intelligent Hub waits before checking-in with the 
Workspace ONE UEM console.

Data Sample Interval 
(min)

Set the time (in minutes) the Workspace ONE Intelligent Hub waits to collect data from the device.

Data Transmit Time 
Interval (min)

Set the time (in minutes) the Workspace ONE Intelligent Hub waits to send data to the UEM console.

What to do next

For information about initiating a remote management session for troubleshooting purposes, see 
Workspace ONE Assist.

QNX devices use the Workspace ONE Intelligent Hub to deliver Job notifications for products provisioned 
to the device. Notifications for jobs that are completed display on the device side through the Workspace 
ONE Intelligent Hub for QNX devices.

AWTrigger Commands, QNX
AWTrigger allows third-party applications to interact with the Workspace ONE Intelligent Hub for QNX.

The applications interact in two ways. The first interaction is the ability to enable/disable the process of 
products using the fast track. This setting allows you to evaluate products regardless of any conditions 
enabled for the product. For example, you can install all products available for a device immediately 
instead of waiting for conditions or dependencies.

The second interaction ability allows you to evaluate all device readiness and detached conditions 
immediately. This interaction circumvents the normal check-in interval for the Workspace ONE Intelligent 
Hub and monitors all conditions at that moment as opposed to waiting for the normal interval.

This appendix lists the commands available for use while using the Workspace ONE ™ UEM Installation 
Directory Command-Line entries.

AWTrigger –installnow true
This command processes all the jobs that have already reached the device (and also all the jobs that 
reach the device after this command has been successfully run) to be processed with immediate effect by 
disabling all conditions.

AWTrigger –installnow false
This command disables the installnow functionality. All the jobs that reach the device after this command 
has been run, will be processed normally (by evaluating conditions).
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AWTrigger –condition true
This command causes all the deferred jobs on the device to be reevaluated again with immediate effect to 
see if the condition specified (in each job) has been met or not. Useful in the case of file conditions.

For example, suppose that a job has been pushed onto the device which has a file condition associated 
with it and the file condition specifies to monitor the presence of a test file. If the test file is missing on the 
device, AWApplicationManager creates a flag file. Hub defers this job by 5 minutes. After 5 minutes, the 
AWApplicationManager will again check for the presence of the test file). If the application creates a test 
file after 2 minutes (of deferring the job) and if the technician does not want to wait for another 3 minutes 
for the job to be processed, he can run this command and the job will be immediately evaluated. This 
command causes ALL the deferred jobs to be evaluated with immediate effect.

AWTrigger –h
This prints the usage of the utility into the respective log file.

AWTrigger -migrateca true
This migrates your XML custom attribute files to the new custom attribute database.

In order for the new text boxes to be present in a custom attribute XML file created from a profile, the 
UEM console version must be at least 8.1, and the Workspace ONE Intelligent Hub version must be at 
least 5.4.66.98.

For clean migration of custom attribute data from XML files to the database, Workspace ONE UEM 
recommends repushing any profiles that are already installed on any devices so that the new text boxes 
are present.

Migrate from XML to CA Database, AWTriggers
You can migrate information in XML format to the custom attribute database by taking the following steps.

Procedure

1 Repush existing profiles to update XML files with data for all profile text boxes.

2 Update configuration file "~/airwatch/General-Config.cfg" to use DB_BASED_CA.

[CustomAttributes] Type = DB_BASED_CA

3 Run command for custom attribute migration utility.

~/airwatch/AWTrigger -migrateca true

4 Check Status.

~/airwatch/AWStatusFinder -migrateca

Migrating from AirWatch 8 XML to CA Database, AWTriggers
Workspace ONE UEM recommends re-pushing the custom attribute profile from the UEM console after 
upgrading to AirWatch v8.1.
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If you choose to migrate to a CA Database without pushing the updated profile, the following decisions 
are made by the migration process.

n Importing Application values.

n If an Application value does exist for a custom attribute record in an XML file, then the existing 
value is used as the value for application when the record is inserted into the database.

n If an Application value does not exist for an attribute record in an XML file, then the File Name is 
used as the Application value when the record is inserted into the database.

n Importing Attribute Name values.

n The name of the custom attribute record in the XML element is imported as the name of the 
custom attribute database record.

n Importing value.

n The value of the custom attribute record in the XML element is imported as the value of the 
custom attribute database record.

n Importing is_dynamic values.

n If an is_dyanmic value does exist for a custom attribute record in an XML file, then the existing 
values are imported as the is_dynamic value for the database record.

n If an is_dyanmic value does not exist for a custom attribute record in an XML file, then the 
is_dynamic value is set to "True" for the database record.

n Importing Permission values:

n If a Permission value does exist for a custom attribute record in an XML file, then the existing 
value is imported as the Permission value for the database record.

n If a Permission value does not exist for a custom attribute record in an XML file, then the 
Permission value is set to "read/write" for the database record.

n Importing sync.

n If a Sync value does exist for a custom attribute record in an XML file, then the existing value is 
imported as the Sync value for the database record.

n If a Sync value does not exist for a custom attribute record in an XML file, then the Sync value is 
set to "True" for the database record.

Enterprise Reset a Rugged Device, Android and WinRugg
Workspace ONE UEM powered by AirWatch lets you "Enterprise Reset" a device, which is a process that 
is similar to an enterprise wipe, but with one important difference. Profiles and files/actions set to persist 
on a device are not removed and automatically reinstall on a device following the first reboot after an 
enterprise reset.
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Enterprise Reset is only available for Windows Rugged Devices and Android legacy Motorola, Zebra, and 
Honeywell devices.

Note   Enterprise Reset cannot run on devices with low battery levels. If you attempt an Enterprise Reset 
on a device with low battery level, a warning displays alerting to you about potential issues with the 
Enterprise Reset. On Android devices, the Enterprise Reset command is held until the device reaches 
sufficient battery level. Once the device is charged, the Reset occurs automatically.

Note   Honeywell Work Managed devices do not currently support the Enterprise Reset action.

Note   Zebra Work Managed devices have special requirements for applying an Enterprise Reset.
n Zebra device must have Workspace ONE Intelligent Hub 1909 or later installed.

n Zebra devices must have Android 7.0 (Nougat) or later installed.

n Zebra devices must have MX 4.5.0.3 or later installed.

n Zebra device must be enrolled as Work Managed device with a Stage Now barcode using the Device 
Owner (DO) APF file.

n Zebra device must be connected to Wi-Fi before launching the Workspace ONE Intelligent Hub, 
otherwise enrollment is blocked. Admin must ensure a Wi-Fi profile is pushed with the persist option 
enabled before initiating the Enterprise Reset.

n Once the Enterprise Reset has finished, the device re-registers itself as Android Enterprise when the 
Workspace ONE Intelligent Hub is run for the first time.

n If the registered Android Enterprise account is Laforge, the device end user can skip the gmail 
account registration.

n If the registered Android Enterprise account is G Suite, the device end user must provide the 
previously registered account to finish the device wizard setup.

n Agent Upgrades

n Persisted profiles, Event/Actions, and Files-Actions pushed to Hubs earlier than 1908 are 
retained after an Enterprise Reset but applications must be reinstalled. These applications persist 
after subsequent resets.

n Persisted profiles, Event/Actions, Files-Actions, and Applications pushed to Hubs version 1908 
and later are retained after an Enterprise Reset.

Prerequisites

Once you have complied with the above prerequisites, take the following steps to run an Enterprise 
Reset.

Procedure

1 Navigate to Devices > List View and select a device you want to Enterprise Reset.

2 On the Device Details View, select the More Actions button.
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3 Select Enterprise Reset, located under Management section.

If you do not see the Enterprise Reset option for the selected device, then the device might not be 
eligible for this device action. Please see the list of prerequisites for details.

4 Enter your Security Pin in the Restrict Action prompt to perform the Enterprise Reset.

Enable AirWatch Cloud Messaging, Android Rugged
AirWatch Cloud Messaging (AWCM) provides an internal communication solution for the entire 
Workspace ONE UEM powered by AirWatch solution as a comprehensive replacement for Google Cloud 
Messaging (GCM).

AWCM provides real-time device management status and command pushes for:

n Devices that cannot be configured with a Google Account.

n Devices restricted to internal network communication.

n Devices without public Internet access.

Enable AWCM
Enable AWCM by navigating to Devices > Device Settings > Android > Hub Settings > AirWatch 
Cloud Messaging.

Select Enabled on Use AWCM Instead of C2DM to enable AWCM. Selecting this option locks the 
deployment type to Always Running so that the system and device have a constant and ongoing line of 
communication. You can also leave the Use AWCM Instead of C2DM check box deselected and decide 
to make the deployment type Always Running or Manual, with an associated timeout value.

Workspace ONE Assist
Workspace ONE Assist, previously named Advanced Remote Management (ARM), allows you to connect 
remotely to end-user devices so you can help with troubleshooting and maintenance. The Assist Server 
facilitates communication between the Workspace ONE UEM powered by AirWatch and the "host" device.

For more information, see VMware Workspace ONE Assist Documentation on docs.vmware.com.

Platform OEM Service, Android Provisioning
The Platform OEM (POEM) Service is an extra application that allows the console for Workspace ONE 
UEM powered by AirWatch to provide extended management capabilities to Android legacy devices only.

After you enroll, the Workspace ONE UEM console automatically detects if the device can take 
advantage of additional device capabilities, and deploys an Original Equipment Manufacturer (OEM) 
specific service application to your Android. The OEM Service app is a plug-in app that is only installed 
and used with Workspace ONE Intelligent Hub enrollment.
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It allows for additional MDM capabilities that only pertain to a specific OEM device. All these APKs are 
available through AirWatch Resources by request. There are a few service applications that we publish to 
the Google Play Store (see list below).

Here is a sample of supported features and available OEMs for the Platform OEM Service.

POEM Service Features
n Silent App installation, uninstallation, and updates

n Silent Device Administrator Activation on start

n Date/Time configuration (date format, time format, time zone, server time, SNTP, HTTP URL, or Auto)

n Toggle Bluetooth on/off with the Disable Bluetooth restriction.

n Disable installation from unknown sources on 5.0 Lollipop and above.

n Device Reboot

POEM Service Versions
n Bluebird

n Kube

n Getac

n Honeywell

n HP

n Intermec

n Lenovo

n Mediawave

n Panasonic

n Sonim

n Zebra CC5000

POEM Service Version Available on the Google Play Store
n Samsung

n Sony

n LG

n Huawei

n Zebra

n Honeywell
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Batch (BAT) File Guidelines, Win7 and WinDesk
For product provisioning in Workspace ONE UEM powered by AirWatch, Windows 7 and Windows 
Desktop devices can be configured using batch (BAT) files. While writing and running these batch files, 
there are best practices you should follow.

Accounting for Path
Windows Unified Agent is a 32-bit application, so when trying to run scripts in a 64-bit machine, proper 
redirections must be used to get access to the 64-bit folder or the registry hive.

There are two %windir%\System32 directories on a Windows x64 system.

n %windir%\System32 directory is for 64-bit applications. This directory contains a 64-bit cmd.exe.

n %windir%\SysWOW64 directory is for 32-bit applications. This directory contains a 32-bit cmd.exe.

Since Workspace ONE Intelligent Hub is a 32-bit application, it can access %windir%\System32 for 
running 64-bit applications by using %windir%\Sysnative in path.

Admin must use %windir%\Sysnative in script to access any 64-bit applications.

For example,

%windir%\Sysnative\manage-bde -on c: -skiphardwaretest

n manage-bde is a 64-bit application and it can be accessed only by providing proper path %windir%
\Sysnative.

n Certutil is part of both folders (32-bit and 64-bit), so no need to give %windir%\Sysnative in the script.

Writing Scripts for Registry
Since Windows Unified Agent is a 32-bit application, it always creates a record or performs any action on 
WOW6432 Node.

On 64-bit Windows, HKLM\Software\Wow6432Node contains values used by 32-bit applications running on 
the 64-bit system.

32-bit applications do not create records in HKLM\Software directly.

To write explicitly to a 64-bit hive, add the /reg:64 modifier to the end of your REG ADD command in 
scripts to create a record in the HKLM\Software registry path.

For example, REG ADD HKLM\Software\MyApp /reg:64

General Instructions
n Running scripts in admin context when Standard User is logged in performs actions for Admin User.

For example,

Running a script in User context installs a certificate for a standard user in the Current user store.

Running a script in Admin context installs a certificate for an Admin in the Current user store.

Product Provisioning

VMware, Inc. 144



n The path must be quoted while passing arguments to batch files.

For example,

"C:\Passing_Argument.bat" Hello World

n The BAT file extension must always be included in the file path. Omitting this extension causes a file 
not found error and the script fails to run.

n You must always have file action as run while deploying batch files.
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Lookup Values 7
A lookup value is a variable that represents a particular data element of a device, user, or admin account 
in Workspace ONE UEM powered by AirWatch and Workspace ONE Express. Lookup values can be 
invaluable in completing a process or a form.

In several different text boxes in the Workspace ONE UEM console and Workspace ONE Express, you 
can add lookup values in place of manually entered or static values. In most cases, lookup values 
function as a stand-in for a piece of information you do not know or do not have access to.

For example, the Add Device screen is used to add a device to your fleet. One of the text boxes on this 
screen that can be completed with lookup values is the Expected Friendly Name.

The friendly name represents the device on many different screens in the UEM console including the 
Device List View and the Details View. And while you can manually enter a static friendly name when 
you add a device, you can instead use lookup values to standardize the friendly name and make it a 
valuable identifier.

A common friendly name format can be constructed with the following lookup values.

{EnrollmentUser} {DeviceModel} {DeviceOperatingSystem} {DeviceSerialNumberLastFour}

If you enter this string in the Expected Friendly Name text box, it produces a friendly name that appears 
this way on the Device List View.

jsmith iPad iOS GHKD

This friendly name instantly provides you with at least three useful pieces of information. And with the last 
four digits of the device serial number at the end, the friendly name is almost sure to be unique.

Data Overhead
When used, lookup values do not add to the device's memory with an extra load. Lookup values are a 
construct of the console itself, not something that is transferred to the device.

Static Strings Versus Lookup Values
Lookup values cannot be applied once a static string has been entered in a text box.
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For example, assume that you have 100 devices to enroll. You add the first 50 devices using a manually 
entered static string for Expected Friendly Name. For the next 50 devices, you opt to use a lookup value 
for Expected Friendly Name instead. Those 100 devices, half with static friendly names and the other 
half with lookup values, can coexist perfectly well. There is no issue with mixing and matching static 
strings and lookup values.

However, you cannot return to the first 50 devices and replace the static string-friendly name with a 
lookup value.
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