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Workspace ONE UEM Device 
Management for Windows 
Desktop Devices 1
Workspace ONE UEM powered by AirWatch provides you with a robust set of mobility management 
solutions for enrolling, securing, configuring, and managing your Windows 10 device deployment. Learn 
more about how Workspace ONE UEM enables your Windows 10 device management.

Through the Workspace ONE UEM console, you have several tools and features for managing the entire 
lifecycle of corporate and employee-owned devices. You can also enable end users to perform tasks 
themselves, for example, through the Self-Service Portal and user self-enrollment, which saves you vital 
time and resources.

Workspace ONE UEM allows you to enroll both corporate and employee-owned devices to configure and 
secure your enterprise data and content. By using of our device profiles, you can properly configure and 
secure your Windows devices. Detect compromised devices and remove their access to corporate 
resources using the compliance engine.

Enrolling your devices into Workspace ONE UEM allows you to secure and configure devices to meet 
your needs.

This chapter includes the following topics:

n Workspace ONE UEM Enrollment Requirements for Windows Desktop Devices

n What Windows 10 Versions are Supported?

Workspace ONE UEM Enrollment Requirements for 
Windows Desktop Devices
Before enrolling your Windows Desktop devices, you must meet the requirements. These requirements 
include important information you need to give to your end users before they can enroll.

Requirements
n Active Environment – Your active Workspace ONE UEM environment and your access to the 

Workspace ONE UEM Console.

n Appropriate Admin Permissions – A type of permission that allows you to create profiles, 
determine policies, and manage devices within the UEM Console.

n Enrollment URL – This URL is unique to your enrollment environment and takes you directly to the 
enrollment screen. For example, mdm.example.com.
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n Group ID – This Group ID associates your device with your corporate role and is defined in the UEM 
Console.

n Device Root Certificate - You must configure the Device Root Certificate in the System settings 
before enrolling devices. To configure the certificate, navigate to Groups & Settings > All Settings > 
System > Advanced > Device Root Certificate.

Important   If your enrollment server is behind a proxy, you must configure the Windows service 
WINHTTP to be proxy-aware when configuring your network settings.

What Windows 10 Versions are Supported?
Workspace ONE UEM powered by AirWatch supports enrolling and managing Windows 10 devices. The 
level of support depends on the OS version and device architecture.

Platforms and Devices Supported
Workspace ONE UEM supports devices running the following operating systems:

n Windows 10 Pro

n Windows 10 Enterprise

n Windows 10 Education

n Windows 10 Home

n Windows 10 S

Workspace ONE Intelligent Hub does not support Windows ARM Snapdragon or Hololens devices. These 
devices must use native MDM functionality.

Important: To see the OS version each update branch supports, see Microsoft's documentation on 
Windows 10 release information: https://technet.microsoft.com/en-us/windows/release-info.aspx.

Windows 10 Version Matrix
Compare the MDM functionality available in each version of the Windows 10 OS. Workspace ONE UEM 
supports all versions of Windows 10 OS and the functions they support.

The different editions of Windows 10 (Home, Professional, Enterprise, and Education) have different 
functionality. Windows 10 Home edition does not support the advanced functionality available to the 
Windows 10 OS. Consider using Enterprise or Education editions for the most functionality.

Feature
Windows 10 OS 
Home

Windows 10 OS 
Professional

Windows 10 OS 
Enterprise

Windows 10 OS 
Education

Native Client Enrollment ✓ ✓ ✓ ✓

Agent Based Enrollment ✓ ✓ ✓ ✓

Requires a Windows Account ID     

Windows Desktop Device Management
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Feature
Windows 10 OS 
Home

Windows 10 OS 
Professional

Windows 10 OS 
Enterprise

Windows 10 OS 
Education

Force EULA/Terms of Use 
Acceptance

✓ ✓ ✓ ✓

Support for Option Prompts during 
Enrollment

✓ ✓ ✓ ✓

Active Directory/ LDAP ✓ ✓ ✓ ✓

Cloud Domain Join Enrollment  ✓ ✓ ✓

Out of Box Experience Enrollment  ✓ ✓ ✓

Bulk Provisioning Enrollment  ✓ ✓ ✓

Device Staging ✓ ✓ ✓ ✓

SMS     

Email Messages  ✓ ✓ ✓

Password Policy ✓ ✓ ✓ ✓

Enterprise Wipe ✓ ✓ ✓ ✓

Full Device Wipe ✓ ✓ ✓ ✓

Email & Exchange ActiveSync ✓ ✓ ✓ ✓

Wi-Fi ✓ ✓ ✓ ✓

VPN ✓ ✓ ✓ ✓

Certificate Management ✓ ✓ ✓ ✓

Device Restrictions and Settings ✓ ✓ ✓ ✓

Windows Hello ✓ ✓ ✓ ✓

Personalization ✓ ✓

Encryption ✓3 ✓ ✓ ✓

Application Control (AppLocker)   ✓ ✓

Health Attestation ✓ ✓ ✓ ✓

Windows Update for Business  ✓ ✓ ✓

Assigned Access   ✓ ✓

Application Management  ✓ ✓ ✓

Workspace ONE Content ✓ ✓ ✓ ✓

Asset Tracking  ✓ ✓ ✓

Device Status  ✓ ✓ ✓

IP Address     

Location ✓ ✓ ✓ ✓

Network  ✓ ✓ ✓

Send Support Message (Email and 
SMS only)

 ✓ ✓ ✓
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1 – Enterprise also includes IoT Enterprise and Long-Term Servicing Branch (LTSB). LTSB is a separate 
Windows 10 Enterprise image with many native apps, including Microsoft Edge, Cortana, and the 
Microsoft Store, removed. Some Workspace ONE UEM functionality which leverage these features will 
not be supported.

2 – Microsoft Passport requires TPM 1.2 or 2.0 hardware based protection of credentials or keys; if no 
TPM exists or is configured, credentials and keys protection will be OS-based.

3 – Device encryption for home does not include BitLocker encryption.

4 – Can be downloaded from the Microsoft Store only. Windows 10 Home does not support pushing 
internal apps.

5 – Requires the Workspace ONE Intelligent Hub downloaded from the Microsoft Store.

Windows Desktop Device Management
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Enrolling Windows 10 Devices 
into Workspace ONE UEM 2
Workspace ONE UEM supports several different methods to enroll your Windows 10 devices. Learn 
which enrollment workflow best services your needs based on your Workspace ONE UEM deployment, 
enterprise integrations, and device operating system.

Enrollment Basics
Before enrolling devices, ensure that you have the required enrollment information. See Workspace ONE 
UEM Enrollment Requirements for Windows Desktop Devices for more information.

Simplify your end-user enrollments by setting up the Windows Auto-Discovery Services (WADS) in your 
Workspace ONE UEM environment. WADS supports an on-premises solution and cloud-based WADS.

The enrollment methods use either the native MDM functionality of the Windows operating system, 
Workspace ONE Intelligent Hub for Windows, or Azure AD integration.

If you want to use Workspace ONE UEM to manage Windows devices managed by SCCM, you must 
download the VMware AirWatch SCCM Integration Client. Use this client to enroll SCCM-managed 
devices into Workspace ONE UEM.

Workspace ONE Intelligent Hub for Windows Enrollment
The simplest enrollment workflow uses Workspace ONE Intelligent Hub for Windows to enroll devices. 
End users simply download Workspace ONE Intelligent Hub from awagent.com and follow the prompts to 
enroll.

Consider using Workspace ONE Intelligent Hub for the Windows Enrollment workflow. Workspace ONE 
UEM supports additional enrollment flows that meet specific use cases.

Azure AD Integration Enrollment
Through integration with Microsoft Azure Active Directory, Windows devices automatically enroll into 
Workspace ONE UEM with minimal end-user interaction. Azure AD integration enrollment simplifies 
enrollment for both end users and admins. Azure AD integration enrollment supports three different 
enrollment flows: Join Azure AD, Out of Box Experience enrollment, and Office 365 enrollment. All 
methods require configuring Azure AD integration with Workspace ONE UEM.
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Before you can enroll your devices using Azure AD integration, you must configure Workspace ONE UEM 
and Azure AD.

Native MDM Enrollment
Workspace ONE UEM supports enrolling Windows Desktop devices using the native MDM enrollment 
workflow. The name of the native MDM solution varies based on the version of Windows. This enrollment 
flow changes based on the version of Windows and if you use WADS.

Only users with local admin permissions on the device can enroll a device into Workspace ONE UEM and 
enable MDM.

Device Staging
If you want to configure device management on a Windows 10 device before shipping it to your end user, 
consider using Windows Desktop device staging. This enrollment workflow allows you to enroll a device 
through Workspace ONE Intelligent Hub, install device-level profiles, and then ship the device to end 
users. The two methods of device staging are manual installation and command-line installation. Manual 
installation requires devices to be domain-joined to an Azure AD integration. Command-line installation 
works for all Windows 10 devices.

Windows Desktop Auto-Enrollment
Workspace ONE UEM supports the auto-enrollment of specific Windows Desktop devices purchased 
from Dell. Auto-enrollment simplifies the enrollment process by automatically enrolling registered devices 
following the Out-of-Box-Experience.

Windows 10 Provisioning Service by VMware AirWatch only applies to select Dell Enterprise devices with 
the correct Windows 10 image. The auto-enrollment functionality must be purchased as part of the 
purchase order from Dell.

Bulk Provisioning and Enrollment
Bulk provisioning creates a pre-configured package that stages Windows 10 devices and enrolls them 
into Workspace ONE UEM. Bulk provisioning requires downloading the Microsoft Assessment and 
Development Kit and installing the Imaging and Configuration Designer tool. This tool creates the 
provisioning packages used to image devices.

With the bulk provisioning workflow, you can include Workspace ONE UEM settings in the provisioning 
package so that provisioned devices automatically enroll during the initial Out of Box Experience.

This chapter includes the following topics:

n Workspace ONE Intelligent Hub for Windows 10 Enrollment

n Native MDM Enrollment for Windows Desktop

n Windows 10 Device Staging Enrollment

Windows Desktop Device Management
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n Windows 10 Provisioning Service by VMware AirWatch for Dell Windows 10 Devices

n Workspace ONE UEM and Azure AD Integration

n Bulk Provisioning and Enrollment for Windows 10 Devices

Workspace ONE Intelligent Hub for Windows 10 
Enrollment
Workspace ONE Intelligent Hub provides a single resource for enrollment and facilitates communication 
between the device and the Workspace ONE UEM console Use Workspace ONE Intelligent Hub to 
simplify enrollment and enable full MDM functionality.

Consider using Workspace ONE Intelligent Hub for Windows to enroll your Windows Desktop devices as 
it provides the simplest enrollment flow for users. If you have Workspace ONE configured, downloading 
Workspace ONE Intelligent Hub from https://getwsone.com/ also downloads the Workspace ONE app. 
When you finish enrolling with Workspace ONE Intelligent Hub, the Workspace ONE app auto-launches 
and configures based on your Workspace ONE UEMWorkspace ONE UEM deployment.

The Workspace ONE Intelligent Hub provides extra functionality to your Windows Desktop devices 
including location services.

You can simplify enrollment for your end users by using Windows Auto-Discovery. Windows Auto-
Discovery enables end users to enter their email address to fill in the text boxes automatically with their 
enrollment credentials.

AirWatch Cloud Messaging
AirWatch Cloud Messaging (AWCM) enables real-time policy and command delivery to Workspace ONE 
Intelligent Hub. Without AWCM, Workspace ONE Intelligent Hub only receives policy and command 
delivery during its normal check-in intervals set in the Workspace ONE UEM console. Consider using 
AWCM for real-time policy and command delivery to Windows Desktop devices.

Enroll with the VMware Workspace ONE Intelligent Hub
Use Workspace ONE Intelligent Hub to enroll your Windows 10 devices. Workspace ONE Intelligent Hub 
provides a simplified enrollment flow for end users that is quick and easy enrollment.

Procedure

1 On the Windows Desktop device, navigate to https://getwsone.com.

2 Install Workspace ONE Intelligent Hub. When the installation is finished, start Workspace ONE 
Intelligent Hub.

3 Enter the email address and select Next.

Windows Desktop Device Management
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4 If you are not using Windows Auto-Discovery, complete the following settings:

a Enter the Server URL and select Next.

b Enter the Group ID and select Next.

c Enter the Username and Password.

5 Accept the terms of use.

6 Select Done.

7 Open Workspace ONE Intelligent Huband complete the enrollment.

Native MDM Enrollment for Windows Desktop
Windows Desktop enrollment methods all use the Work Access native MDM Client. Use the native MDM 
enrollment to enroll both corporate owned and BYOD devices through the same enrollment flow.

Work Access first processes an Azure AD work flow for domains connected to Office 365 or Azure AD 
when you select Connect and does not automatically complete the enrollment workflow. If you use Office 
365 or Azure AD without a premium license, consider using the Workspace ONE Intelligent Hub to enroll 
Windows 10 devices instead of native MDM enrollment. To complete the enrollment workflow using native 
MDM enrollment, select Connect twice. If you have an Azure AD premium license, you can enabled 
Require Management in your Azure instance to have native MDM enrollment complete the enrollment 
flow after the Azure work flow. You can use native MDM enrollment without issue if you do not use Office 
365 or Azure AD.

Only users who have local admin permissions on the device can enroll a device into Workspace ONE 
UEM and enable MDM. Domain Admin permissions do not work for enrolling a device. To enroll a device 
with a standard user, you must use Bulk Provisioning for Windows 10 devices.

By using the Windows Auto-Discovery Service, you simplify enrollment for your end user by reducing the 
necessary interaction during enrollment. Using the Windows Auto-Discovery Service requires you to 
follow the steps outlined in the VMware AirWatch Windows Auto-Discovery Service Installation 
Guide.

Devices joined to a domain can enroll using the native Workplace enrollment. The email address entered 
in the settings is auto-populated with the Active Directory UPN attribute. If the end user wants to use a 
different email address, they must download the optional update.

Enroll Through Work Access With Windows Auto Discovery
Work Access is the native MDM enrollment method for Windows 10 devices. Enrolling through Work 
Access and using Windows Auto Discovery provides a quick and easy enrollment flow for end users.

Windows Desktop Device Management
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Prerequisites

Registering your domain in Workspace ONE UEM removes the need to enter the Group ID during 
enrollment.

Note   Consider using the Workspace ONE Intelligent Hub for Windows to enroll your Windows 10 
devices instead of using native MDM enrollment. The native MDM enrollment flow does not enroll devices 
into MDM if you use Office 365 or Azure AD on the same domain.

Procedure

1 Navigate on the device to Settings > Accounts > Work Access and select Enroll in to device 
management.

2 Enter the user name you provided to your end user into the Email text box, followed by the domain 
for the environment in the format Username@domain.com (such as jdoe1@acme.com). Select 
Continue.

3 Enter the Group ID and select Next.

4 Enter your username and password and select Next.

These credentials may be your directory services credentials or dedicated credentials specific to your 
Workspace ONE UEM environment.

Windows Desktop Device Management
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5 (Optional) Review the End User License Agreement and select Accept to agree to the terms of use.

This step is optional and only displays if enabled in the Workspace ONE UEM Console.

6 (Optional) Select Yes to save sign-in info.

The device then attempts to connect to Workspace ONE UEM. If it connects successfully, a briefcase 
icon displays with Workspace ONE UEM written next to it. This icon shows your successful 
connection to Workspace ONE UEM. 

Enroll Through Work Access Without Windows Auto Discovery
Work Access is the native MDM enrollment method for Windows 10 devices. Enrolling through Work 
Access without WADS requires manually entering end-user credentials.

Prerequisites

Note   Consider using the Workspace ONE Intelligent Hub for Windows to enroll your Windows 10 
devices instead of using native MDM enrollment. The native MDM enrollment flow does not enroll devices 
into MDM if you use Office 365 or Azure AD on the same domain.

Windows Desktop Device Management
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Procedure

1 Navigate on the device to Settings > Accounts > Work Access and select Enroll in to device 
management.

2 Enter the user name you provided to your end user into the Email text box, followed by the domain 
for the environment in the format Username@domain.com (such as jdoe1@acme.com).

3 Enter server address as follows: <DeviceServicesURL>/DeviceServices/Discovery.aws. Do not 
include 'https://' in the URL.

ds156.awmdm.com/deviceservices/discovery.aws.

4 Select Continue.

5 Enter the Group ID and select Next.

6 Enter your username and password and select Next.

These credentials may be your directory services credentials, or dedicated credentials specific to your 
Workspace ONE UEM environment.

7 (Optional) Review the End-User License Agreement and select Accept to agree to the terms of use.

This step is optional and only displays if you choose to enable it.

Windows Desktop Device Management
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8 (Optional) Select Yes to save sign-in info.

The device then attempts to connect to Workspace ONE UEM. If it connects successfully, a briefcase 
icon displays with Workspace ONE UEM written next to it. This icon shows your successful 
connection to Workspace ONE UEM.

Windows 10 Device Staging Enrollment
With device staging, you can configure your Windows 10 devices for device management by Workspace 
ONE UEM before you send the devices to your end users. Learn how to enroll and configure your devices 
with Workspace ONE Intelligent Hub on behalf of your end users.

Device staging enrollment enables you to enroll your Windows 10 device into Workspace ONE UEM. This 
enrollment requires the Workspace ONE Intelligent Hub to start. After the device enrolls, any assigned 
device-level profiles download to the device. Once the device is fully enrolled and configured, you can 
ship the device to your end users. When the end user signs in to the device, the Workspace ONE 
Intelligent Hub updates the device record in the Workspace ONE UEM console. Workspace ONE UEM 
reassigns the device to the end user and pushes any user-level profiles to the device.

The two staging methods are:

n Manual Installation – Download and install the Workspace ONE Intelligent Hub and enter enrollment 
credentials. This method requires devices to be domain-joined before enrollment.
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n Command Line Installation – Download the Workspace ONE Intelligent Hub and then install and 
enroll the device using the command line.

The enrollment completes by either updating the UEM console device registry when a user enrolls into a 
domain-joined device or by comparing the enrolled user name against a list of previously registers serial 
numbers.

Bulk Import Device Serial Numbers
Import device serial numbers for use with device staging to quickly add devices to the Workspace ONE 
UEM Console. The bulk import requires a CSV file with all the serial numbers to import.

Procedure

1 Navigate to Accounts > Users > List View or Devices > Lifecycle > Enrollment Status.

a Select Add and then Batch Import to display the Batch Import screen.

2 Complete each of the required options. Batch Name, Batch Description, and Batch Type.

3 Within the Batch File (.csv) option is a list of task-based templates you can use to load users and 
their devices in bulk.

4 Select the appropriate download template and save the comma-separated values (CSV) file to 
somewhere accessible.

5 Locate the saved CSV file, open it with Excel, and enter all the relevant information for each of the 
devices that you want to import. Each template is pre-populated with sample entries demonstrating 
the type of information (and its format) intended to be placed in each column.

Fields in the CSV file denoted with an asterisk (*) are required.

6 Save the completed template as a CSV file. In the UEM console, select the Choose File button from 
the Batch Import screen, navigate to the path where you saved the completed CSV file and select it.

7 Select Save to complete registration for all listed users and corresponding devices.

Enroll through Command Line Staging
Simplify enrollment for end users by staging your Windows Desktop devices using the Windows 
Command Line. This enrollment method enrolls the device and downloads device-level profiles base on 
the user credentials entered.

Important   Do not change the name of the AirWatchAgent.msi file as this breaks the staging command. 
Also, Do not use bulk serial number import if you want to use command-line staging.

Note   This product should not be used to silently install Workspace ONE Intelligent Hub for Windows on 
BYOD devices. If you silently install onto BYOD devices, you are solely responsible for providing any 
necessary notices to your device end users regarding your use of silent installation and the data collected 
from the silently installed apps, obtaining any legally required consents from your device end users, and 
otherwise complying with all applicable laws.
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Procedure

1 Navigate to https://getwsone.com/ to download Workspace ONE Intelligent Hub for Windows.

Only download Workspace ONE Intelligent Hub. Do not start the executable or select Run as that 
initiates a standard enrollment process and defeats the purpose of silent enrollment. If necessary, 
move Workspace ONE Intelligent Hub from the download folder to a local or network drive folder.

2 Open a command line or create a BAT file and enter all the necessary paths, parameters, and values 
using information shown in Silent Enrollment Parameters and Values.

3 Run the command. For examples of syntax, see Silent Enrollment Parameters and Values.

After the command runs, the device enrolls into Workspace ONE UEM. If the device is domain-joined, 
Workspace ONE Intelligent Hub updates the Workspace ONE UEM Console device registry with the 
correct user.

Enroll through Manual Device Staging
Simplify enrollment for end users by staging your Windows 10 devices using the Workspace ONE 
Intelligent Hub. This enrollment method enrolls the device and downloads device-level profiles so the end 
user must only log in to the device to begin using it.

Prerequisites

These devices must be joined to a domain.

Procedure

1 Navigate to www.awagent.com to download the Workspace ONE Intelligent Hub Installer.

2 Start the installer once the download completes.

3 Select Run to begin the installation.

4 Select Email if you have AirWatch Auto-Discovery enabled, otherwise select Server Detail.

5 Complete the settings required based on the authentication type selected:

a Enter the email address to auto-fill the server details screen. Select Next and the details are 
entered.

b Enter the Server Name and Group ID if you are not using AirWatch Auto-Discovery to complete 
the settings. Select Next.

6 Enter the staging Username and Password and select Next.

7 Complete any optional screens.
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8 Select Finish to complete the enrollment.

Once the Workspace ONE Intelligent Hub detects a staging user, the Workspace ONE Intelligent Hub 
listener runs and listens for the next Windows login. When the end user logs into the device, the 
Workspace ONE Intelligent Hublistener reads the user UPN and email from the device registry. This 
information is sent to the Workspace ONE UEM Console and the device registry is updated to 
register the device to the user.

Silent Enrollment Parameters and Values
Silent enrollment requires command-line entries or a BAT file to control how the Workspace ONE 
Intelligent Hubdownloads and installs onto the device.

Note   This product should not be used to silently install Workspace ONE Intelligent Hub for Windows on 
BYOD devices. If you silently install onto BYOD devices, you are solely responsible for providing any 
necessary notices to your device end users regarding your use of silent installation and the data collected 
from the silently installed apps, obtaining any legally required consents from your device end users, and 
otherwise complying with all applicable laws.

The following table lists all the possible enrollment parameters you can enter into a command line or into 
a BAT file, and the respective values for each parameter. If you are Enrolling on Behalf of Others, ensure 
you use the EOBO parameters.

Enrollment Parameters Values to Add to Parameter

All MSI parameters These parameters control the behavior of installation of the application. The behavior description 
for some of them :

n /quiet - Completely silent

n /q - Controls the UI levels for installation

n /passive - minimal controls for the user to guide the application

n /L - log levels and log paths

For more information, see https://docs.microsoft.com/en-us/windows/win32/msi/command-line-
options

ENROLL Select 'Y' to enroll.

Select 'N' for image only.

The agent will try to enroll in silent mode only if this parameter is set to 'Y'.

IMAGE This flag takes priority over everything, if this flag is set to 'Y', the agent will be put into image 
mode.

Select 'Y' for image.

Select 'N' for enrollment.

SERVER Enter the enrollment URL.

LGName Enter organization group name.

USERNAME Enter the user name for the user you are enrolling or the staging user name if staging the device on 
the behalf of a user.

PASSWORD Enter the password for the user you are enrolling or the staging user password if staging the device 
on the behalf of a user.

ASSIGNTOLOGGEDINUSER Select 'Y' to assign the device to the logged in domain user.
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Enrollment Parameters Values to Add to Parameter

STAGEUSERNAME EOBO Workflow Only: Enter user name for the enrolling user.

SECURITYTYPE EOBO Workflow Only: Needed if user account is added to Workspace ONE UEM console during 
enrollment process:

n Select 'D' for Directory.

n Select 'B' for Basic User type.

STAGEEMAILUSRNAME* EOBO Workflow Only: Enter the email user name for the user you are enrolling.

STAGEPASSWORD EOBO Workflow Only: Enter the password for the user you are enrolling.

STAGEEMAIL* EOBO Workflow Only: Enter the email address for the user you are enrolling.

DEVICEOWNERSHIPTYPE* Select 'CD' for Corporate Dedicated.

Select 'CS' for Corporate Shared.

Select 'EO' for Employee Owned.

Select 'N' for None.

INSTALLDIR* Enter the directory path if you want to change installation path.

Note   Note: If this parameter is not present, the Workspace ONE Intelligent Hub uses the default 
path: C:\Program Files (x86)\AirWatch.

DOWNLOADWSBUNDLE This parameter controls the download of the Workspace ONE application during enrollment.

Select 'Y', to download the Workspace ONE app installer during the installation of Workspace ONE 
Intelligent HubIf you enroll a device using Workspace ONE Intelligent Hub, installing Workspace 
ONE is not optional.

If you do not set DOWNLOADWSBUNDLE to 'Y', the Workspace ONE app installer does not 
download regardless of the ui-level used.

Items denoted with an asterisk (*) are optional.

Examples of Silent Enrollment
Below are examples of various use cases using enrollment parameters and the values that you can enter 
into a command line or use to create a BAT file. Initiating any one of these examples silently enrolls the 
Windows device without prompting the user to select any of the acknowledgment buttons.

Agent Install for Image Only Without Enrollment
The following is an example of installing the Workspace ONE Intelligent Hub for image only without 
enrollment using minimum parameters required for image only.

AirwatchAgent.msi /quiet ENROLL=N IMAGE=Y

Basic User Enrollment
The following is an example of using minimum parameters required for basic enrollment only:

AirwatchAgent.msi /quiet ENROLL=YIMAGE=n SERVER=companyURL.com LGName=locationgroupid 
USERNAME=TestUsr PASSWORD=test

Workspace ONE Intelligent Hub Installed Elsewhere
The following is an example of the AirwatchAgent.msi located in a different location:
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C:\AirwatchAgent.msi /quiet ENROLL=Y IMAGE=n SERVER=companyURL.com 
LGName=locationgroupid USERNAME=TestUsr PASSWORD=test

Installation Directory and Workspace ONE Intelligent Hub on Network Drive
The following is an example of the installation directory parameter with the Workspace ONE Intelligent 
Hub on a network drive.

Important   Add extra quotes for the INSTALLDIR parameter when there is space within the parameter.

Q:\AirwatchAgent.msi /quiet INSTALLDIR=\"E:\Install Win32\" ENROLL=Y IMAGE=n 
SERVER=companyURL.com LGName=locationgroupid USERNAME=TestUsr PASSWORD=test

All Available Parameters and Values
The following is an example of the syntax using all available parameters and values shown in the 
previous table.

<AirwatchAgent.msi>/quiet INSTALLDIR=\"<Directory Path>" ENROLL=<Y/N>IMAGE=<Y/
N>SERVER=<CompanyURL>LGNAME=<Location Group 
ID>USERNAME=<Username>PASSWORD=<Username Password>STAGEUSERNAME=<Stager 
Username>SECURITYTYPE=<D/B>STAGEEMAILUSRNAME=<User 
Enrolling>STAGEPASSWORD=<Password for User Enrolling>STAGEEMAIL=<Email Address for User 
Enrolling>DEVICEOWNERSHIPTYPE<CD/CS/EO/N>ASSIGNTOLOGGEDINUSER=<Y/N>

Windows 10 Provisioning Service by VMware AirWatch for 
Dell Windows 10 Devices
You can auto-enroll your Windows 10 devices you buy from Dell intoWorkspace ONE UEM before they 
leave the factory. Learn how to simplify the enrollment process by automatically enrolling registered 
devices following the Out-of-Box-Experience.

Windows 10 Provisioning Service by VMware AirWatch only applies to select Dell devices with the correct 
Windows 10 image. The auto-enrollment functionality must be purchased as part of the purchase order 
from Dell. Windows 10 Provisioning Service by VMware AirWatch only supports Windows 10 Pro, 
Enterprise, and Education SKUs for Cloud Provisioning.

Windows 10 Provisioning Service by VMware AirWatch matches registered devices with users and 
automatically enrolls the device following the Out-of-Box-Experience. When the end user signs in to the 
device, the provisioning agent on the device receives the profiles and apps assigned to the device and 
user. This functionality works similar to the Apple Device Enrollment Program.

When you purchase your Dell devices, Dell supplies Workspace ONE UEM with the device details of the 
purchased devices. To use auto-enrollment, you must register the serial numbers for all the devices 
purchased from Dell. Workspace ONE UEM matches the serial number to the ones provides by dell for 
use with AirWatch Auto-Discovery.

You must register the devices with a user account before sending the devices to end users.

Windows Desktop Device Management

VMware, Inc. 22



For a seamless enrollment experience, consider configuring the External Access Token authentication 
method for VMware Identity Manager. The External Access Token authentication enables Workspace 
ONE UEM to open automatically and deliver apps to the device. When the feature is enabled, Workspace 
ONE UEM automatically authenticates and provides the user with the first-launch experience that shows 
the application and policy installation progress.

Important   "Devices enrolled through Windows 10 Provisioning Service by VMware AirWatch will not 
automatically re-enroll during a factory reset. The Windows 10 Provisioning Service by VMware AirWatch 
only works for the first time enrollment.

Configure Windows 10 Provisioning
Configure Windows 10 Provisioning Service by VMware AirWatch to enroll Dell Windows Desktop devices 
automatically. Auto-enrollment compares registered device serial numbers against a list provided by Dell 
to enroll devices as part of the Out-of-Box-Experience.

Prerequisites

Purchase Windows 10 Provisioning Service by VMware AirWatch as part of your purchase order from 
Dell.

Procedure

1 Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Desktop 
> Auto Enrollment.

2 Configure the Auto Enrollment settings:

Settings Description

Auto Enrollment Select Enable to use Windows 10 Provisioning Service by VMware AirWatch.

Sync Interval Select the amount of time between sync attempts between the Workspace ONE 
Intelligent Hub and the Workspace ONE UEM Console.

Enforce Policies Before Log In Select Enable to enforce the device policies before the user logs in to the device.

Maximum Time Before Log In Select the maximum number of minutes that may pass before a user logs in after 
completing the Out-of-Box-Experience.

 
3 Select Save.
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4 Register the device serial numbers with Workspace ONE UEM. Only required for On-premises 
customers, this step is completed for SaaS customers. Validate that device registration records exisit, 
if not complete the following steps. There are three workflows for registering devices:

a Navigate to Accounts > Users > Add > Add User and add the user account. When you are 
done adding the user, select Save and Add Device. Then complete the Add Device settings. You 
must set the Platform to Windows Desktop.

b Navigate to Accounts > Users > Add > Batch Import. Download and complete the CSV 
template for User and/or Device. Upload the CSV and select Import. You must enter Windows 
Desktop as the Device Platform when completing the template. You must set the Platform to 
Windows Desktop.

c Navigate to Devices Lifecycle > Enrollment Status > Add > Register Device. You must set the 
Platform to Windows Desktop.

Workspace ONE UEM and Azure AD Integration
Through integration with Microsoft Azure Active Directory, you can automatically enroll your Windows 10 
devices into Workspace ONE UEM with minimal end-user interaction. Learn how Azure AD integration 
simplifies enrolling your Windows 10 devices.

Before you can enroll your devices using Azure AD Integration, you must configure Workspace ONE UEM 
and Azure AD. The configuration requires entering information into your Azure AD and Workspace ONE 
UEM deployments to facilitate communication.

Azure AD integration enrollment supports three different enrollment flows: Join Azure AD, Out of Box 
Experience enrollment, and Office 365 enrollment. All methods require configuring Azure AD integration 
with Workspace ONE UEM.

Important   Enrollment through Azure AD integration requires Windows 10 and Azure Active Directory 
Premium License.

Configure Workspace ONE UEM to use Azure AD as an Identity 
Service
Before you can use Azure AD to enroll your Windows devices, you must configure Workspace ONE UEM 
to use Azure AD as an Identity Service. Enabling Azure AD is a two-step process which requires the 
MDM-enrollment details to be added to Azure.

Prerequisites

You must have a Premium Azure AD P1 or P2 subscription to integrate Azure AD with Workspace ONE 
UEM. Azure AD integration with Workspace ONE UEM must be configured at the tenant where Active 
Directory (such as LDAP) is configured.

Important   If you are setting the Current Setting to Override on the Directory Services system settings 
page, the LDAP settings must be configured and saved before enabling Azure AD for Identity Services.
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Procedure

1 Navigate to Groups & Settings > All Settings > System > Enterprise Integration > Directory 
Services.

2 Enable Use Azure AD for Identity Services under Advanced settings. After you enable the, take 
note of the MDM Enrollment and MDM Terms of Use URLs as they are needed when configuring the 
Azure directory.

3 Log in to the Azure Management Portal with your Microsoft account or organizational account.

4 Select your directory and navigate to the Mobility (MDM and MAM) tab. This tab was formerly the 
Applications tab.

5 Select Add Application and select the AirWatch by VMware application.

You can use the default URLs if the user scope is set to none. If needed, you can also use 
placeholder URLs.

6 Leave the AirWatch by VMware application on the default settings. Change the MDM user scope to 
None.

7 Select Add Application again and select the On Premises MDM application. You can rename the 
application when you add it.

8 Configure the on-premises MDM application by entering the MDM Enrollment URL and MDM Terms 
of Use URLs from the Workspace ONE UEM console.

9 Select On-premises MDM application settings > Manifest. In the Manifest section, add the 
Console URL under the IdentifierURIs.

10 Set MDM user scope to All to apply these settings to all users.

You can also limit the OOBE enrollment to selected Azure AD groups by selecting Some and adding 
the preferred groups.

11 Select Save to continue.

12 Navigate to the Properties tab and find the Azure Directory ID. This setting was formerly called the 
Tenant ID.

13 Select User Account Details in the top right corner. The Azure Tenant Name is the name of your 
Azure Directory. You can find the name under the Domain tab.

14 Return to the Workspace ONE UEM console and select Use Azure AD for Identity Services to 
configure Azure AD Integration.

15 Enter the Azure Directory ID as the Tenant Identifier. Enter the default domain as your Azure 
Directory Tenant Name.

16 Select Save to finish the process.
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Enroll a Device With Azure AD
Enroll devices with Azure AD integration to enroll a device into the correct organization group in 
Workspace ONE UEM automatically. Devices enrolled through Azure AD join completely, meaning all 
users on the device join the domain.

This enrollment flow is for devices not already joined to Azure AD. For more information on enrolling an 
Azure AD managed device, see Enroll an Azure AD Managed Device into Workspace ONE UEM.

Procedure

1 Navigate on the Windows 10 device to Settings > Accounts > Access Work or School. Select 
Continue.

2 Enter your Email Address. Select Next.

3 Ensure that the Workspace ONE UEM welcome page displays. Select Continue.

4 Select Accept if terms of use are enabled.

5 Select Join to confirm that you want to enroll in Workspace ONE UEM.

6 Select Finish to complete joining your device to Workspace ONE UEM. Your device now downloads 
the applicable policies and profiles.

Enroll an Azure AD Managed Device into Workspace ONE UEM
Devices that are joined to Azure AD use a different enrollment flow than devices enrolling through Azure 
AD integration. Use this enrollment flow to enroll a device that is already joined to Azure AD into 
Workspace ONE UEM.

Prerequisites

n Windows 10 OS build 14393.82 and above.

n KB update KB3176934 installed.

n No MDM applications installed under your Azure AD management portal.

n Azure AD account configured on the device.

Procedure

1 On the device, navigate to Settings > Accounts > Access work or school and select Enroll only 
in device management.

You may also enroll through the Workspace ONE Intelligent Hub for Windows.

2 Complete the enrollment process. You must enter an email address with a different domain than your 
Azure AD account.

a If you are using Windows Auto-Discovery, see Enroll Through Work Access With Windows Auto 
Discovery.

b If you are not using Windows Auto-Discovery, see Enroll Through Work Access With Windows 
Auto Discovery.
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3 Navigate to Settings > Accounts > Access work or school and ensure there is an Azure AD 
account and a Workspace ONE UEM MDM account added.

Enroll Through Out of Box Experience
Out of Box Experience (OOBE) enrollment automatically enrolls a device into the correct organization 
group as part of the initial setup and configuration of a Windows 10 device.

Important   The OOBE enrollment flow does not support Enterprise Wipe. If you perform an enterprise 
wipe, users cannot log into the device as connection to Azure AD has been broken. You must create a 
local admin account before sending an Enterprise Wipe or you will be locked out of the device and forced 
to reset the device.

Prerequisites

The OOBE process can take some time to complete on end-user devices. Consider enabling the 
progress display for the install status. This display allows end users to know where they are in the 
process. To enable the display, navigate to Groups & Settings > All Settings > General > Enrollment > 
Optional Prompt.
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Procedure

1 Power on the device and follow the steps to configure Windows until you reach the Choose how 
you'll connect screen.

2 Select Join Azure AD. Select Continue.

3 Enter your Azure AD/Workspace ONE UEM email address as the Work or school account.

4 Enter your Password. Select Sign In.

Windows Desktop Device Management

VMware, Inc. 29



5 Ensure that the Welcome to AirWatch screen displays. Select Continue.

6 Select Accept if terms of use are enabled.

7 Select Join to confirm that you want to enroll in Workspace ONE UEM.

8 Select Finish to complete joining your device to Workspace ONE UEM. Your device now downloads 
the applicable policies and profiles.

Enroll Through Office 365 Apps
If your organization uses Office 365 and Azure AD integration, end users can enroll their devices the first 
time they open an Office 365 app.

Procedure

1 Select Add a Work Account the first time you open an Office 365 application.

2 Enter your Email Address and Password. Select Sign In.

3 Ensure that the Workspace ONE UEMwelcome page displays. Select Continue.

4 Select Accept if terms of use are enabled.

5 Select Join to confirm that you want to enroll in Workspace ONE UEM.

6 Select Finish to complete joining your device to Workspace ONE UEM. Your device now downloads 
the applicable policies and profiles.
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Bulk Provisioning and Enrollment for Windows 10 Devices
Bulk provisioning lets you create a pre-configured package that stages Windows 10 devices and enrolls 
them into Workspace ONE UEM. Learn how to use bulk provisioning to quickly enroll and configured 
multiple devices with a standard user account.

This enrollment flow is the only way to enroll a device with a standard user account. Admin permissions 
are still required run the pre-configured package. Bulk provisioning only supports single user standard 
staging.

To use bulk provisioning, download the Microsoft Assessment and Development Kit and installing the 
Imaging and Configuration Designer (ICD) tool. The ICD creates provisioning packages used to image 
devices. As part of these provisioning packages, you can include Workspace ONE UEM configuration 
settings so that provisioned devices are automatically enrolled into Workspace ONE UEM during the 
initial Out of Box Experience (OOBE).

To map the devices to the correct end user automatically, register the devices per user or using a bulk 
import before creating the provisioning package.

Enroll With Bulk Provisioning
The Microsoft Imaging and Configuration Designer tool allows you to create a provisioning package to 
enroll multiple Windows 10 devices into Workspace ONE UEM quickly and easily. Once the package is 
installed, the device automatically enrolls into Workspace ONE UEM.

Procedure

1 Download the Microsoft Assessment and Deployment Kit for Windows 10 and install the Windows 
Imaging and Configuration Designer tool (ICD).

2 Start the Windows ICD and select New Provisioning Package.

3 Enter a Project Name and select the settings to view and configure.

The typical choice is the Common to all Windows desktop editions option.

4 (Optional) Import a provisioning package if you want to create a provisioning package based on the 
settings of a previous package.

5 Navigate to Runtime Settings > Workplace > Enrollments.

6 In the Workspace ONE UEM console, navigate to Groups & Settings > All Settings > Devices & 
Users > Windows > Windows Desktop > Staging and Provisioning.

When you navigate to this settings page, a staging user is created and URLs pertaining to the created 
staging user display. You can create your own staging user for use with bulk provisioning but the 
settings displayed on this settings page do not apply to any created users.

7 Copy the UPN and paste it into the UPN text box of the ICD.

Windows Desktop Device Management

VMware, Inc. 31



8 Select the down arrow next to Enrollments in the Available Customizations window.

9 Configure the following settings:

a Select AuthPolicy and select the value displayed in the UEM console.

b Select DiscoveryServiceFullURL and copy the URL displayed in the UEM console.

c Select EnrollmentServiceFullURL and copy the URL displayed in the UEM console.

d Select PolicyServiceFullURL and copy the URL displayed in the UEM console.

e Select Secret and copy the value displayed in the UEM console.

10 Select File > Save to save the project.

11 Select Export > Provisioning Package to create a package for use with bulk provisioning then 
select Next.

12 Save the Encryption password for later use if you choose to encrypt the package and then select 
Next.

13 Save the package to a USB drive for transfer to each device you want to provision. You can also 
email the package to the device.

14 Select Build to create the package.
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What to do next

Next you must install the bulk provisioning package. For more information, see Install Bulk Provisioning 
Packages.

Install Bulk Provisioning Packages
After you create the provisioning packages using the Microsoft Imaging and Configuration Designer, you 
must install the provisioning package onto the end-user devices.

Procedure

1 On the device you want to provision, navigate to Settings > Accounts > Work Access and select 
Add or remove a package for work or school. If the package was emailed, start the package from 
your mail client.

2 Select Add a package and select the Removable Media choice as the method to add the package.

3 Select the correct package from the list provided.

If you added the device to the user account in the Workspace ONE UEM Console before 
provisioning, the device is assigned upon enrollment.
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Workspace ONE UEM Profiles for 
Windows 3
Profiles are the primary means to configure your Windows 10 devices to connect to Wi-Fi, use a VPN, 
restrict access to settings, and more. Learn how to configure profiles so your Windows Desktop devices 
remain secure and configured to your preferred settings.

Overview
You can think of profiles as the settings and rules that, when combined with compliance policies, help you 
enforce corporate rules and procedures. They contain the settings, configurations, and restrictions that 
you want to enforce on devices.

A profile consists of the general profile settings and a specific payload. Profiles work best when they 
contain only a single payload.

Windows Desktop profiles apply to a device at either the user level or the device level. When creating 
Windows Desktop profiles, you select the level the profile applies to. Some profiles can only be applied to 
the user level or device level. Workspace ONE UEM runs commands that apply to the device context 
even if the device has no active enrolled user login. User-specific profiles require an active enrolled user 
login.

Baselines
Maintaining the best configurations to keep your devices secure can be a challenge. Workspace ONE 
UEM curates the best practices as Baselines. This feature allows you to simply the process by applying 
industry-recommended settings and configurations. With Baselines, you only need to select a smart 
group and a baseline and your devices remain up-to-date with industry favorites such as Microsoft 
Baselines or CIS Benchmarks. For more information on Baselines, see Chapter 4 Using Baselines.

This chapter includes the following topics:

n Configure a Passcode Profile for Windows 10 Devices

n Configure a Wi-Fi Profile for Windows 10 Devices

n Per-App VPN for Windows 10 Devices Using the VPN Profile

n Workspace ONE UEM Credentials Profile for Windows 10 Devices

n Configure a Restrictions Payload for Windows 10 Devices
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n Windows Defender Exploit Guard Profile for Windows 10 Devices

n Workspace ONE UEM Data Protection Profile for Windows 10 Devices

n Windows Hello Profile (Windows Desktop)

n Configure a Firewall (Legacy) Profile (Windows Desktop)

n Configure a Firewall Profile (Windows Desktop)

n Configure a Single App Mode Profile (Windows Desktop)

n Configure an Antivirus Profile (Windows Desktop)

n Encryption Profile (Windows Desktop)

n Configure a Windows Updates Profile (Windows Desktop)

n Create a Proxy Profile (Windows Desktop)

n Configure a Web Clips Profile (Windows Desktop)

n Exchange ActiveSync Profile (Windows Desktop)

n SCEP Profile (Windows Desktop)

n Application Control Profile (Windows Desktop)

n Configure an Exchange Web Services Profile (Windows Desktop)

n Create a Windows Licensing Profile (Windows Desktop)

n Configure a BIOS Profile (Windows Desktop)

n Configure the OEM Updates Profile (Windows Desktop)

n Configure a Kiosk Profile (Windows Desktop)

n Configure a Personalization Profile (Windows Desktop)

n Peer Distribution with Workspace ONE

n Use Custom Settings (Windows Desktop)

Configure a Passcode Profile for Windows 10 Devices
Use a Passcode profile to protect your Windows 10 devices by requiring a passcode each time they 
return from an idle state. Learn how a Passcode profile with Workspace ONE UEM ensures that all your 
sensitive corporate information on managed devices remains protected.

Passcodes set using this profile only take effect if the passcode is stricter than existing passcodes. For 
example, if the existing Microsoft Account passcode requires stricter settings than the Passcode payload 
requirements, the device continues to use the Microsoft Account passcode.

Important   The Passcode payload does not apply to domain-joined devices.
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Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Passcode profile.

6 Configure the Passcode settings:

Settings Descriptions

Password Complexity Set to Simple or Complex to your preferred level of password difficulty.

Require Alphanumeric Enable to require the passcode to be an alphanumeric passcode.

Minimum Password Length Enter the minimum number of characters a Password must contain.

Maximum Password Age (days) Enter the maximum number of days that may elapse before the end user is 
required to change the Password.

Minimum Password Age (days) Enter the minimum number of days that must elapse before the end user is 
required to change the Password.

Device Lock Timeout (in Minutes) Enter the number of minutes before the device automatically locks and requires a 
passcode re-entry.

Maximum Number of Failed Attempts Enter the maximum number of attempts the end user may enter before the device 
is restarted.

Password History (occurrences) Enter the number of occurrences a password is remembered.

If the end user reuses a password within the number of recorded occurrences, they 
cannot reuse that password.

For example, if you set the history to 12, an end user cannot reuse the past 12 
passwords.

Expire Password Enable to expire the existing password on the device and require a new password 
to be created.

Requires Workspace ONE Intelligent Hub to be installed on the device.

Password Expiration (days) Configure the number of days that a password is valid for before expiring.

Reversible Encryption for Password 
Storage

Enable to set the operating system to store passwords using reversible encryption.

Storing passwords using reversible encryption is essentially the same as storing 
plain text versions of the passwords.

For this reason, do not enable this policy unless application requirements outweigh 
the need to protect password information.

Use Protection Agent for Windows 10 
Devices

Enable to use the Workspace ONE Intelligent Hub to enforce Password profile 
settings instead of the native DM functionality. Enable this settings if you have 
issues using the native DM functionality.

 
7 Select Save & Publish when you are finished to push the profile to your devices.
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Configure a Wi-Fi Profile for Windows 10 Devices
Create a Wi-Fi profile through Workspace ONE UEM to connect your devices to hidden, encrypted, or 
password-protected corporate networks. Learn how Wi-Fi profiles are useful for end users who need 
access to multiple networks or for configuring devices to connect automatically to the appropriate wireless 
network.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Wi-Fi profile.

6 Configure the General settings:

Settings Descriptions

Service Set Identifier Enter an identifier for the name (SSID) of the desired Wi-Fi network.

The network SSID cannot contain spaces.

Hidden Network Enable this option if the network uses a hidden SSID.

Auto-Join Enable this option to set the device to join the network automatically.

Security Type Use the drop-down menu to select the security type (for example, WPA2 Personal) 
for the Wi-Fi network.

Encryption Use the drop-down menu to select the encryption type used.

Displays based on the Security Type.

Password Enter the password required to join the Wi-Fi network for networks with static 
passwords.

Select the Show Characters check box to disable hidden characters within the text 
box.

Displays based on the Security Type.

Proxy Enable this option to configure proxy settings for the Wi-Fi connection.

URL Enter the URL for the proxy.

Port Enter the port for the proxy.

Protocols Select the type of protocols to use:

Certificate: PEAP-MsChapv2

EAP-TTLS: Custom

This section displays when the Security Type is set to WPA Enterprise or WPA2 
Enterprise.
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Settings Descriptions

Inner Identity Select the method of authentication through EAP-TTLS:

n Username/Password
n Certificate
This section displays when the Protocols option is set to EAP-TTLS or PEAP-
MsChapv2.

Require Crypto Binding Enable this option to require cryptographic binding on both authentications.

This limits man-in-the-middle attacks.

Use Windows Log On Credentials Enable this option to use the Windows login credentials are the user name/
password to authenticate.

Displays when Username/Password is set as the Inner Identity.

Identity Certificate Select an Identity Certificate, which you can configure using the Credentials 
payload. See Workspace ONE UEM Credentials Profile for Windows 10 Devices 
for more information.

Displays when Certificate is set as the Inner Identity.

Trusted Certificates Select Add to add Trusted Certificates to the Wi-Fi profile.

This section displays when the Security Type is set to WPA Enterprise or WPA2 
Enterprise.

Allow Trust Exceptions Enable to allow trust decisions to be made by the user through a dialog box.
 

7 Select Save & Publish when you are finished to push the profile to devices.

Per-App VPN for Windows 10 Devices Using the VPN 
Profile
Workspace ONE UEM VPN profiles support configuring Per-App VPN settings for Windows 10 devices. 
Learn how to configure your VPN profile to use the specific traffic rules and logic to enable Per-App VPN 
access.

Per-App VPN
Per-app VPN lets you configure VPN traffic rules based on specific applications. When configured, the 
VPN connects automatically when a specified app starts and sends the application traffic through the 
VPN connection but not traffic from other applications. With this flexibility, you can ensure that your data 
remains secure while not limiting device access to the Internet at large.

Each rule group under the Per-App VPN Rules section uses the logical OR operator. So if the traffic 
matches any of the configured policies, it is allowed through the VPN.
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The applications for which Per-app VPN traffic rules apply can be legacy Windows applications such as 
EXE files or modern apps downloaded from the Microsoft Store. By setting specific applications to start 
and use the VPN connection, only the traffic from those apps uses the VPN and not all device traffic. This 
logic allows you to keep corporate data secure while reducing the bandwidth sent through your VPN.

To help you reduce VPN bandwidth constraint, you can set DNS routing rules for the Per-app VPN 
connection. These routing rules limit the amount of traffic sent through the VPN to only that traffic that 
matches the rules. The logic rules use the AND operator. If you set an IP Address, Port, and IP Protocol, 
the traffic much match each of these filters to pass through the VPN.

Per-app VPN allows you to configure detailed control over your VPN connections on an app by app basis.

Configure a VPN Profile for Windows 10 Devices
Workspace ONE UEM supports configuring device VPN settings so your end users can remotely and 
securely access your organizations internal network. Learn how the VPN profile provides detailed VPN 
settings control including specific VPN provider settings and Per-App VPN access.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select User Profile or Device Profile.

4 Configure the profile General settings.

5 Select the VPN profile.
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6 Configure the Connection Info settings:

Settings Descriptions

Connection Name Enter the name of the VPN connection.

Connection Type Select the type of VPN connection:

Server Enter the VPN server hostname or IP Address.

Port Enter the port the VPN server uses.

Advanced Connection Settings Enable to configure advanced routing rules for device VPN connection.

Routing Addresses Select Add to enter the IP Addresses and Subnet Prefix Size of the VPN server.

You may add more routing addresses as needed.

DNS Routing Rules Select Add to enter the Domain Name that governs when to use the VPN. Enter 
the DNS Servers and Web Proxy Servers to use for each specific domain.

Routing Policy Choose either to Force All Traffic Through VPN or Allow Direct Access to 
External Resources.

n Force All Traffic Through VPN (Force Tunnel): For this traffic rule, all IP traffic 
must go through the VPN Interface only.

n Allow Direct Access to External Resources (Split Tunnel): For this traffic 
filter rule, only the traffic meant for the VPN interface (as determined by the 
networking stack) goes over the interface. Internet traffic can continue to go 
over the other interfaces.

Proxy Select Auto Detect to detect automatically any proxy servers used by the VPN. 
Select Manual to configure the proxy server.

Server Enter the IP Address for the proxy server.

Displays when Proxy is set to Manual.

Proxy Server Config URL Enter the URL for the proxy server configuration settings.

Displays when Proxy is set to Manual.

Bypass proxy for local Enable to bypass the proxy server when the device detects it is on the local 
network.

Protocol Select the authentication protocol for the VPN:

n EAP – Allows for various authentication methods

n Machine Certificate – Detects a client certificate in the device certificate store 
to use for authentication.

EAP Type Select the type of EAP authentication:

n EAP-TLS – Smart Card or client certificate authentication

n EAP-MSCHAPv2 – User name and Password

n EAP-TTLS

n PEAP

n Custom Configuration – Allows all EAP configurations

Displays only if Protocol is set to EAP.

Credential Type Select Use Certificate to use a client certificate. Select Use Smart Card to use a 
Smart Card to authenticate.

Displays when EAP Type is set to EAP-TLS.

Windows Desktop Device Management

VMware, Inc. 40



Settings Descriptions

Simple Certificate Selection Enable to simplify the list of certificates from which the user selects. The 
certificates display by the most recent certificated issued for each entity.

Displays when EAP Type is set to EAP-TLS.

Use Windows Log On Credentials Enable to use the same credentials as the Windows device.

Displays when EAP Type is set to EAP-MSCHAPv2.

Identity Privacy Enter the value to send servers before the client authenticates the server identity.

Displays when EAP Type is set to EAP-TTLS.

Inner Authentication Method Select the authentication method for inner identity authentication.

Displays when EAP Type is set to EAP-TTLS.

Enable Fast Reconnect Enable to reduce the delay in time between an authentication request by a client 
and the response from the server.

Displays when EAP Type is set to PEAP.

Enable Identity Privacy Enable to protect the user identity until the client authenticates with the server.

Per-app VPN Rules Select Add to add traffic rules for specific Legacy and Modern applications. For 
more information on Per-app VPN, see Per-App VPN for Windows 10 Devices 
Using the VPN Profile

Application ID First select whether the app is a Store App or a Desktop App. Then enter the 
application file path for Desktop apps or package family name for Store Apps to 
specify the app the traffic rules apply to.

n File Path example: %ProgramFiles%/ Internet Explorer/iexplore.exe

n Package Family Name example: 
AirWatchLLC.AirWatchMDMAgent_htcwkw4rx2gx4

The PFN Lookup allows you to search for the application PFN by selecting the 
Search icon. A display window opens allowing you to select the app you want to 
configure Per-app VPN rules to govern. The PFN is then autopopulated.

VPN On Demand Enable to have the VPN connection automatically connect when the application is 
launched.

Routing Policy Select the routing policy for the app.

n Allow Direct Access to External Resources allows for both VPN traffic and 
traffic through the local network connection.

n Force All Traffic Through VPN forces all traffic through the VPN.

DNS Routing Rules Enable to add DNS routing rules for the app traffic.

Select Add to add Filter Types and Filter Values for the routing rules. Only traffic 
from the specified app that matches these rules can be sent through the VPN.

n IP Address: A list of comma-separated values specifying remote IP address 
ranges to allow.

n Ports: A list of comma-separated values specifying remote port ranges to 
allow. For example, 100–120, 200, 300–320. Ports are only valid when the 
protocol is set to TCP or UDP.

n IP Protocol: Numeric value from 0-255 representing the IP protocol to allow. 
For example, TCP = 6 and UDP = 17.

For more information on how these filters and policies function and the logic used, 
see Per-App VPN for Windows 10 Devices Using the VPN Profile.
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Settings Descriptions

Device Wide VPN Rules Select Add to add traffic rules for the entire device.

Select Add to add Filter Typesand Filter Values for the routing rules. Only traffic 
that matches these rules can be sent through the VPN.

n IP Address: A list of comma-separated values specifying remote IP address 
ranges to allow.

n Ports: A list of comma-separated values specifying remote port ranges to 
allow. For example, 100–120, 200, 300–320. Ports are only valid when the 
protocol is set to TCP or UDP.

n IP Protocol: Numeric value from 0–255 representing the IP protocol to allow. 
For example, TCP = 6 and UDP = 17. For a list of the numeric value of all 
protocols, see https://www.iana.org/assignments/protocol-numbers/protocol-
numbers.xhtml.

Remember Credentials Enable to remember the end user login credentials.

Always On Enable to force the VPN connection to be always on.

VPN Lockdown Enable to force the VPN to always be on, never disconnect, disable any network 
access if the VPN is not connected, and prevent other VPN profiles from 
connecting on the device.

A VPN profile with VPN Lockdown enabled must be deleted before you push a new 
VPN profile to the device.

This feature only displays if the profile is set to Device context.

Bypass for Local Enable to bypass the VPN connection for local intranet traffic.

Trusted Network Detection Enter, separated by commas, trusted network addresses. The VPN does not 
connect when a trusted network connection is detected.

Domain Select Add New Domain to add domains to resolve through the VMware Tunnel 
server.

Any domains added resolve though the VMware Tunnel server regardless of the 
app originating the traffic. For example, vmware.com will resolve through the 
VMware Tunnel server if you use the whitelisted Chrome or the non-whitelisted 
Edge apps.

This option only displays when you create the VPN profile as a user profile.
 

7 Select Save & Publish when you are finished to push the profile to devices.

Workspace ONE UEM Credentials Profile for Windows 10 
Devices
A Credentials profile allows you to push Root, Intermediate, and Client certificates to your Windows 10 
devices to support any Public Key Infrastructure (PKI) and certificate authentication use case. The profile 
pushes configured credentials to the proper credentials store on the Windows Desktop device. Learn how 
to configure a credentials profile to enable authentication for your Windows 10 devices.
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Even with strong passcodes and other restrictions, your infrastructure remains vulnerable to brute force, 
dictionary attacks, and employee error. For greater security, you can implement digital certificates to 
protect corporate assets. To use certificates in this way, you must first configure a Credentials payload 
with a certificate authority, and then configure your Wi-Fi and VPN payloads. Each of these payloads has 
settings for associating the certificate authority defined in the Credentials payload.

The Credentials profile also allows you to push S/MIME certificates to devices. These certificates are 
uploaded under each user account and controlled by the Credentials profile.

Configure a Credentials Profile for Windows 10 Devices
A Credentials profile pushes certificates to devices for use in authentication. With Workspace ONE UEM, 
you can configure credentials for personal, intermediate, trusted root, trusted publisher, and trusted 
people certificate stores. Learn how to configure a credentials profile to enable authentication for your 
Windows 10 devices.

Even with strong passcodes and other restrictions, your infrastructure remains vulnerable to brute force, 
dictionary attacks, and employee error. For greater security, you can implement digital certificates to 
protect corporate assets. To use certificates in this way, you must first configure a credentials payload 
with a certificate authority, and then configure your Wi-Fi and VPN payloads. Each of these payloads has 
settings for associating the certificate authority defined in the credentials payload.

The credentials profile also allows you to push S/MIME certificates to devices. These certificates are 
uploaded under each user account and controlled by the credentials profile.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select User Profile or Device Profile.

4 Configure the profile General settings.

5 Select the Credentials payload and configure the following settings:

Settings Descriptions

Credential Source Select the credential source as either an Upload, a Defined Certificate Authority, 
or User Certificate
The remaining payload options are source-dependent.

n If you select Upload, you must upload a new certificate.

n If you select Defined Certificate Authority, you must choose a predefined 
certificate authority and Template.

n If you select User Certificate, you must select how the S/MIME certificate is 
used.

Upload Select to navigate to the desired credential certificate file and upload it to the 
Workspace ONE UEM console.

This setting displays when Upload is selected as the Credential Source.
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Settings Descriptions

Certificate Authority Use the drop-down menu to select a predefined certificate authority.

This setting displays when Defined Certificate Authority is selected as the 
Credential Source.

Certificate Template Use the drop-down menu to select a predefined certificate template specific to the 
selected certificate authority.

This setting displays when Defined Certificate Authority is selected as the 
Credential Source.

Export Private Key Select Allow to let end users export certificates using Windows Certificate 
Manager.

Select Don't Allow to prohibit end users from exporting certificates.

Key Location Select the location for the certificate private key:

n TPM If Present – Select to store the private key on a Trusted Platform Module 
if one is present on the device, otherwise store it in the OS.

n TPM Required – Select to store the private key on a Trusted Platform Module. 
If a TPM is not present, the certificate does not install and an error displays on 
the device.

n Software – Select to store the private key in the device OS.

n Passport – Select to save the private key within the Microsoft Passport. This 
option requires the Azure AD integration.

Certificate Store Select the appropriate certificate store for the credential to reside in on the device:

n Personal – Select to store personal certificates. Personal certificates require 
the Workspace ONE Intelligent Hub on the device or using the SCEP payload.

n Intermediate – Select to store certificates from Intermediate Certificate 
Authorities.

n Trusted Root – Select to store certificates from Trusted Certificate Authorities 
and root certificates from your organization and Microsoft.

n Trusted Publisher – Select to store certificates from Trusted Certificates 
Authorities trusted by software restriction policies.

n Trusted People – Select to store certificates from trusted people or end 
entities that are explicitly trusted. Often these certificates are self-signed 
certificates or certificates explicitly trusted in an application such as Microsoft 
Outlook.

Store Location Select User or Machine to define where the certificate is located.

S/MIME Select whether the S/MIME certificate is for encryption or signing.

This option only displays if Credential Source is set to User Certificate.
 

6 Select Save & Publish to push the profile to devices.

Configure a Restrictions Payload for Windows 10 Devices
Use the Restrictions profile to disable end-user access to device features to ensure that your Windows 10 
devices are not tampered with. Learn how to control what settings and options end users can use or 
change with the Workspace ONE UEM restrictions profile.

The Windows version and edition you use change what restrictions apply to a device.
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Procedure

1 Navigate to Devices > Profiles > List View and select Add.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Restrictions profile.

6 Configure the Administration settings:

Settings Description

Allow Manual MDM Unenrollment Allow the end user to unenroll from Workspace ONE UEM manually through the 
Workplace/Work Access enrollment.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Runtime Configuration Hub to Install 
Provisioning Packages

Enable to allow the use of provisioning packages to enroll devices into Workspace 
ONE UEM (bulk provisioning).

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Location Select how location services run on the device.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Runtime Configuration Agent to 
Remove Provisioning Packages

Enable to allow the removal of provisioning packages.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Send Diagnostic and Usage 
Telemetry Data

Select the level of of telemetry data to send to Microsoft .

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Require Microsoft Account for MDM Enable to require a Microsoft Account for devices to receive policies or 
applications.

Require of Microsoft Account for 
Modern Applications

Enable to require a Microsoft Account for devices to download and install Windows 
Apps.

Provisioning Packages Must Have a 
Certificate Signed by a Device 
Trusted Authority

Enable to require a trusted certificate for all provisioning packages (bulk 
provisioning).

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow User to Change Auto Play 
Settings

Allow the user to change what program is used for Auto Play of file types.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow User to Change Data Sense 
Settings

Allow the user to change the Data Sense settings to restrict data use on the 
device.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.
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Settings Description

Date/Time Allow the user to change the Date/Time settings.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Language Allow the user to change the language settings.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow User to Change Power and 
Sleep Settings

Allow the user to change the Power and Sleep settings.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Region Allow the user to change the region.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow User to Change Sign-In 
Options

Allow the user to change the Sign-In Options.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

VPN Allow the user to change the VPN settings.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow User to Change Workplace 
Settings

Allow the user to change Workplace settings and change how MDM functions on 
the device.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow the User to Change Account 
Settings

Allow the user to change Account settings.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Bluetooth Allow the use of Bluetooth on the device.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Device Bluetooth Advertising Allow the device to broadcast Bluetooth Advertisements.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Bluetooth-enabled devices can 
discovery the device

Allow Bluetooth discovery of the device by other Bluetooth devices.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Camera Allow access the camera function of the device.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Cortana Allow access to the Cortana application.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.
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Settings Description

Device Discovery UX on the Lock 
Screen

Allow the device discovery UX on the lock screen to discover projectors and other 
displays.

When enabled, the Win+P and Win+K shortcuts do not work.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

IME Logging Enable to allow the user to turn on and off the logging for incorrect conversions 
and saving of auto-tuning result to a file and history-based predictive input.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

IME Network Access Enable to allow the user to turn on the Open Extended Dictionary to integrate 
Internet searches to provide input suggestions that do not exist in a devices local 
dictionary.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Smart Screen Enable to allow the end user to use the Microsoft SmartScreen feature, which is a 
form of security requesting the end user to draw shapes on an image to unlock the 
device. This option also allows end users to use PINs as their passcode.

Note   After you disable function, you cannot reenable it through Workspace ONE 
UEM MDM. To reenable it, you must factory reset the device.

The restriction does not apply to Windows 10 Home edition devices.

Search to Leverage Location 
Information

Allow the search to use the device location information.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Storage Card Enable to allow the use of an SD card and the device USB ports.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Windows Sync Settings Allow user to sync Windows settings across devices.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Windows Tips Allow Windows Tips on the device to help the user.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

User Account Control Setting Select the level of notification sent to end users when a change to the operating 
system requires device admin permission.

Allow Non-Microsoft Store Trusted 
Applications

Allows the downloading and installation of applications not trusted by the Microsoft 
Store.

This restriction applies to all Windows 10 devices.

App Store Auto Updates Enable to allow apps downloaded from the Microsoft Store to update automatically 
when new versions are available.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.
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Settings Description

Allow Developer Unlock Allows the use of the Developer Unlock setting for sideloading applications onto 
devices.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow DVR & Game Broadcasting Enable to allow the recording and broadcasting of games on the device.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Allow Share Data Among Multiple 
Users of the Same App

Allows sharing of data between multiple users of an app.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Restrict App Data to System Volume Restricts app data to the same volume as the OS instead of secondary volumes or 
removable media.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Restrict Installation of Applications to 
System Drive

Restricts the installation of apps to the system drive instead of secondary drives or 
removable media.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Auto Connect to Wi-Fi Hotspots Enable to allow the device to connect to Wi-Fi hotspots automatically using the Wi-
Fi Sense functionality.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Cellular Data On Roaming Enable to allow cellular data use while roaming.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Internet Sharing Enable to allow Internet sharing between devices.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Data Usage on Roaming Enable to allow end users to transmit and receive data while roaming.

This restriction applies to all Windows devices.

VPN Over Cellular Allow the use of a VPN over cellular data connections.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

VPN Roaming Over Cellular Allow the use of a VPN while on roaming cellular data connections.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Auto fill Allow the use of Auto fill to complete user information.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Cookies Allow the use of cookies.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.
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Settings Description

Do Not Track Allow the use of Do Not Track requests.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Password Manager Allow the use of a password manager.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Pop-ups Allow pop-up browser windows.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Search Suggestions in Address Bar Allow search suggestions to appear in address bar.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Smart Screen Allow the use of the SmartScreen malicious site and content filter.

This restriction applies to Windows 10 devices only and is not supported for 
Windows 10 Home edition devices.

Send Intranet Traffic to Internet 
Explorer

Allow intranet traffic to use Internet Explorer.

This restriction applies to all Windows 10 devices.

Enterprise Site List URL Enter the URL for an enterprise site list.

This restriction applies to all Windows 10 devices.
 

7 Select Save & Publish when you are finished to push the profile to devices.

Windows Defender Exploit Guard Profile for Windows 10 
Devices
Protect your Windows 10 devices from exploits and malware with the Windows Defender Exploit Guard 
profile. Workspace ONE UEM uses these settings to protect your devices from exploits, reduce attack 
surfaces, control folder access, and protect your network connections.

Windows Defender Exploit Guard
Various malware and exploits use vulnerabilities in your Windows 10 devices to gain access to your 
network and devices. Workspace ONE UEM uses the Windows Defender Exploit Guard profile to protect 
your devices from these bad actors. The profile uses the Windows Defender Exploit Guard settings native 
to Windows 10. The profile contains four different methods of protection. These methods cover different 
vulnerabilities and attack vectors.

Exploit Protection
Exploit protection automatically applies exploit mitigations to both the operating system and apps. These 
mitigations also work with third-party antivirus and Windows Defender antivirus. In the Windows Defender 
Exploit Guard profile, you configure these settings by uploading a configuration XML file. This file must be 
created using the Windows Security App or PowerShell.
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Attack Surface Reduction
Attack surface reduction rules help prevent the typical actions malware use to infect devices. These rules 
target actions such as:

n Executable files and scripts used in Office apps or web mail that try to download or run files

n Obfuscated or otherwise suspicious scripts

n Actions that apps do not usually use

Attack surface reduction rules require Windows Defender Real Time Protection enabled.

Controlled Folder Access
Controlled folder access helps protect your valuable data from malicious apps and threats including 
ransomware. When enabled, Windows Defender Antivirus reviews all apps (.EXE, .SCR, .DLL, and so 
on). Windows Defender then determines if the app is malicious or safe. If the app is marked as malicious 
or suspicious, then Windows prevents the app from changing files in protected folders.

Protected folders include common system folders. You can add you own folders to Controlled Folder 
Access. Most known and trusted apps can access protected folders. If you want an internal or unknown 
app to access protected folders, you must add the app file path when creating the profile.

Controlled folder access requires Windows Defender Real Time Protection enabled.

Network Protection
Network protection helps protect users and data from phishing scams and malicious websites. These 
settings prevent users from using any app to access dangerous domains that might host phishing attacks, 
exploits, or malware.

Network protection requires Windows Defender Real Time Protection enabled.

Additional Information
For more information on the specific exploit protections and settings configured, see https://
docs.microsoft.com/en-us/sccm/protect/deploy-use/create-deploy-exploit-guard-policy.

Create a Defender Exploit Guard Profile for Windows 10 Devices
Create a Defender Exploit Guard profile through Workspace ONE UEM to protect your Windows 10 
devices against exploits and malware. Learn how to use the profile to configure the Windows Defender 
Exploit Guard settings on your Windows 10 devices.

When you create rules and settings for Attack Surface Reduction, Controlled Folder Access, and 
Network Protection, you must select Enabled, Disabled, or Audit. These options change how the rule or 
setting functions.

n Enabled - Configures Windows Defender to block exploits for that method. For example, if you set 
Controlled Folder Access to Enabled, Windows Defender will block exploits from accessing the 
protected folders.
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n Disabled - Doe not configured the policy for Windows Defender.

n Audit - Configured Windows Defender to block the exploits the same as Enabled, but also logs the 
event in the event viewer.

Prerequisites

To use the Exploit Protection settings in this profile, you must create a configuration XML file using 
Windows Security App or PowerShell on an individual device before creating the profile.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Defender Exploit Guard payload.

6 Upload Exploit Protection Settings configuration XML file.

These settings automatically apply exploit mitigation techniques to both the operating system and 
individual apps. You must create the XML file using the Windows Security App or PowerShell on an 
individual device.

7 Configure the Attack Surface Reduction settings. These rules help prevent the typical actions 
malware uses to infect devices with malicious code. Select Add to add additional rules.

The description of each rule describes what apps or file types the rule applies to. Attack surface 
reduction rules require Windows Defender Real-Time Protection enabled.

8 Configure the Controlled Folder Access settings. Set Controlled Folder Access to Enabled to use 
these settings. When enabled, the setting protects several folders by default. To see the list, point to 
over the ? icon.

a Add additional folders to protect by selecting Add New and enter the folder file path.

b Add applications that can access protected folders by selecting Add New and entering the 
application file path. Most known and trusted apps can access the folders by default. Use this 
setting to add internal or unknown apps to access protected folders.

These settings automatically protect your data from malware and exploits. Controlled folder access 
requires Windows Defender Real-Time Protection enabled.

9 Configure the Network Protection settings. Set Network Protection to Enabled to use these settings.

These settings protect users and data from phishing scams and malicious websites. Network 
protection requires Windows Defender Real-Time Protection enabled.

10 Select Save and Publish when you are finished to push the profile to devices.
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Workspace ONE UEM Data Protection Profile for 
Windows 10 Devices
The Data Protection profile configures rules to control how enterprise applications access data from 
multiple sources in your organization. Learn how using the data protection profile ensures that your data 
is only accessible by secured, approved applications.

With personal and work data on the same device, accidental data disclosure is possible through services 
that your organization does not control. With the Data Protection payload, Workspace ONE UEM controls 
how your enterprise data moves between applications to limit leakage with a minimal impact on end 
users. Workspace ONE UEM uses the Microsoft Windows Information Protection (WIP) feature to protect 
your Windows 10 devices.

Data Protection works by whitelisting enterprise applications to give them permission to access enterprise 
data from protected networks. If end users move data to non-enterprise applications, you can act based 
on the selected enforcement policies.

WIP treats data as either unencrypted personal data or corporate data to protect and encrypt. 
Applications whitelisted for Data Protection fall into four different types. These types determine how the 
app interacts with protected data.

n Enlightened Apps – These apps fully support WIP functionality. Enlightened apps can access both 
personal and corporate data without issues. If data is created with an enlightened app, you can save 
the data as unencrypted personal data or encrypted corporate data. You can restrict users from 
saving personal data with enlightened apps using the Data Protection profile.

n Allowed – These apps support WIP-encrypted data. Allowed apps can access both corporate and 
personal data but the apps save any accessed data as encrypted corporate data. Allowed apps save 
personal data as encrypted corporate data that cannot be accessed outside of WIP-approved apps. 
Consider slowly whitelisting allowed apps on a case-by-case basis to prevent issues accessing data. 
Reach out to software providers for information on WIP approval.

n Exempt – You determine which apps are exempt from WIP policy enforcement when you create the 
Data Protection profile. Exempt any apps that do not support WIP-encrypted data. If an app does not 
support WIP-encryption, the apps break when attempting to access encrypted corporate data. No 
WIP policies apply to exempt apps. Exempt apps can access unencrypted personal data and 
encrypted corporate data. Because exempt apps access corporate data without WIP policy 
enforcement, use caution when whitelisting exempt apps. Exempt apps create gaps in data protection 
and leak corporate data.

n Not Allowed – These apps are not whitelisted or exempted from WIP policies and cannot access 
encrypted corporate data. Not allowed apps can still access personal data on a WIP-protected 
device.

Important   The Data Protection profile requires Windows Information Protection (WIP). This feature 
requires the Windows Anniversary Update. Consider testing this profile before deploying to production.
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Configure a Data Protection Profile (Windows Desktop)
Create the Data Protection (Preview) profile to use the Microsoft Windows Information Protection feature 
to limit user and application access to your organizational data to approved networks and applications. 
You can set detailed controls over data protection.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and choose Windows Desktop as the platform.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Data Protection payload.

6 Configure the Enterprise Data Protection settings:

Settings Descriptions

Add Select to add enterprise applications to the enterprise allowed list.

Applications added here are trusted to use enterprise data.

App Type Select whether the application is a traditional desktop application or a Microsoft 
Store app.

You can also select an application publisher for desktop applications or store apps. 
Selecting a publisher whitelists all apps from the publisher.

Name Enter the app name. If the app is a Microsoft Store app, select the Search icon ( ) 
to search for the app Package Family Name (PFN).

Identifier Enter the file path for a desktop application or the package family name for a store 
app.

Exempt Select the check box if the app does not support full data protection but still needs 
access to enterprise data. Enabling this option exempts the app from data 
protection restrictions. These apps are often legacy apps not yet updated for data 
protection support.

Creating exemptions creates gaps in data protection. Only create exemptions when 
necessary.

Primary Domain Enter the primary domain that your enterprise data uses.

Data from protected networks is accessible by enterprise applications only. 
Attempting to access a protected network from an application not on the enterprise 
allowed list results in enforcement policy action.

Enter domains in lowercase characters only.

Enterprise Protected Domain Names Enter a list of domains (other than your primary domain) used by the enterprise for 
its user identities. Separate the domains with the vertical bar character (|).

Enter domains in lowercase characters only.

Enterprise IP Ranges Enter the enterprise IP ranges that define the Windows 10 devices in the enterprise 
network.

Data that comes from the devices in range are considered part of the enterprise 
and are protected. These locations are considered a safe destination for enterprise 
data sharing.
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Settings Descriptions

Enterprise Network Domain Names Enter the list of domains that are the boundaries of the enterprise network.

Data from a listed domain that is sent to a device is considered enterprise data and 
is protected. These locations are considered a safe destination for enterprise data 
sharing.

Enterprise Proxy Servers Enter the list of proxy server that the enterprise can use for corporate resources.

Enterprise Cloud Resources Enter the list of enterprise resource domains hosted in the cloud that need to be 
protected by routing through the enterprise network through a proxy server (on port 
80).

If Windows cannot determine whether to allow an app to connect to a network 
resource, it will automatically block the connection. If you want Windows to default 
to allow the connections, add the /*AppCompat*/ string to the setting. For example:

www.air-watch.com | /*AppCompat*/

Only add the /*AppCompat*/ string once to change the default setting.

Application Data Protection Level Set the level of protection and the actions taken to protect enterprise data.

Show EDP Icons Enable to display an EDP icon( ) in the Web browser, file explorer, and app 
icons when accessing protected data. The icon also displays in enterprise-only app 
tiles on the Start menu.

Revoke on Unenroll Enable to revoke Data Protection keys from a device when the device unenrolls 
from Workspace ONE UEM.

User Decryption Enable to allow users to select how data is saved using an enlightened app. They 
can select Save as Corporate or Save as Personal.
If this option is not enabled, all data saved using an enlightened app will save as 
corporate data and encrypt using the corporate encryption.

Direct Memory Access Enable to allow users direct access to device memory.

Data Recovery Certificate Upload the special Encrypting File System certificate to use for file recovery if your 
encryption key is lost or damaged. For more information, see Create an Encrypting 
File System Certificate (Windows Desktop).

 
7 Select Save & Publish to push the profile to devices.

Create an Encrypting File System Certificate (Windows Desktop)
The Data Protection profile encrypts enterprise data and restricts access to approved devices. Create an 
EFS certificate to encrypt your enterprise data protected by a Data Protection profile.

Procedure

1 On a computer without an EFS certificate, open a command prompt (with admin rights) and navigate 
to the certificate store you where you want to store the certificate.

2 Run the command:cipher /r:<EFSRA>

The value of <EFSRA> is the name of the .cer and .pfx files that you want to create.

3 When prompted, enter the password to help protect your new .pfx file.
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4 The .cer and .pfx files are created in the certificate store you selected.

5 Upload your .cer certificate to devices as part of a Data Protection profile. For more information, see 
Configure a Data Protection Profile (Windows Desktop).

Windows Hello Profile (Windows Desktop)
Windows Hello provides a secure alternative to using passwords for security. The Windows Hello profile 
configures Windows Hello for Business for your Windows Desktop devices so end users can access your 
data without sending a password.

Protecting devices and accounts with a user name and password creates potential security exploits. 
Users can forget a password or share it with non-employees, putting your corporate data at risk. Using 
Windows Hello, Windows 10 devices securely authenticate the user to applications, Web sites, and 
networks on the behalf of the user without sending a password. The user does not need to remember 
passwords, and man-in-the-middle attacks are less likely to compromise your security.

Windows Hello requires users to verify possession of a Windows 10 device before it authenticates with 
either a PIN or Windows Hello biometric verification. After authentication through Windows Hello, the 
device gains instant access to Web sites, applications, and networks.

Important   Windows Hello for Business requires Azure AD integration to work.

Create a Windows Hello Profile (Windows Desktop)
Create a Windows Hello profile to configure Windows Hello for Business for your Windows Desktop 
devices so end users can access your applications, websites, and networks without entering a password.

Important   Windows Hello profiles only apply to devices enrolled through Azure AD integration.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Windows Hello profile and configure the settings:

Settings Descriptions

Biometric Gesture Enable to allow end users to use the device biometric readers.

TPM Set to Require to disable Passport use without a Trusted Protection Module 
installed on the device.

Minimum PIN Length Enter the minimum number of digits a PIN must contain.

Maximum PIN Length Enter the maximum number of digits a PIN can contain.

Digits Set the permissions level for using digits in the PIN.
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Settings Descriptions

Upper Case Letters Set the permissions level for using upper case letters in the PIN.

Lower Case Letters Set the permissions level for using lower case letters in the PIN.

Special Characters >Set the permissions level for using special characters (! " # $ % & ' ( ) * + , - . / : ; 
< = > ? @ [ \ ] ^ _ ` { | } ~) in the PIN.

 
6 Select Save & Publish to push the profile to devices.

Configure a Firewall (Legacy) Profile (Windows Desktop)
The Firewall (Legacy) profile for Windows Desktop devices allows you to configure the Windows Firewall 
settings for devices. Consider using the new Firewall profile for Windows Desktop as the new profile uses 
new Windows features.

Prerequisites

Important   The Firewall profile requires the Workspace ONE Intelligent Hub to be installed on the device.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Firewall (Legacy) payload.

6 Enable Use Windows Recommended Settings to use the Windows Recommended Settings and 
disable all other options available in this profile. The settings will automatically change to the 
recommended settings and you cannot change them.

7 Configure the Private Networksettings:

Settings Description

Firewall Enable to use the firewall when the device is connected to private network 
connections.

Block All Incoming Connections, 
Including Those on the List of 
Allowed Apps

Enable to block all incoming connections. This setting allows outbound 
connections.

Notify User when Windows Firewall 
Blocks a New App

Enable to allow notifications to display when the Windows Firewall blocks a new 
app.
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8 Configure the Public Network settings:

Settings Description

Firewall Enable to use the firewall when the device is connected to private network 
connections.

Block All Incoming Connections, 
Including Those on the List of 
Allowed Apps

Enable to block all incoming connections. This setting allows outbound 
connections.

Notify User when Windows Firewall 
Blocks a New App

Enable to allow notifications to display when the Windows Firewall blocks a new 
app.

 
9 Select Save and Publish when you are finished to push the profile to devices.

Configure a Firewall Profile (Windows Desktop)
Create a Firewall profile to configure the native Windows Desktop firewall settings. This profile uses more 
advanced functionality than the Firewall (Legacy) profile.

Workspace ONE UEM whitelists the OMA-DM agent automatically to ensure the Workspace ONE UEM 
console can always communicate with devices.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Firewall payload.

6 Configure the Global settings.

Setting Description

Stateful FTP Set how the firewall handles FTP traffic.

If you select Enable, the firewall tracks all FTP traffic. If you select Disable, the 
firewall does not inspect FTP traffic.

Security Association Idle Time Select Configured and set the maximum amount of time (in seconds) the device 
waits before deleting idle security associations.

Security associations are an agreement between two peers or endpoints. These 
agreements contain all the information required to securely exchange data.

Preshared Key Encoding Select the type of encoding used for the preshared key.

IPSec Exemptions Select the IPSec exemptions to use.

Certification Revocation List 
Verification

Select how to enforce the certificate revocation list verification.
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Setting Description

Opportunity Match Auth Set Per KM Select how key modules ignore authentication suites. Enabling this option forces 
key modules to ignore only the authentication suites they do not support. Disabling 
this option forces key modules to ignore the entire authentication set if they do not 
support all the authentication suites in the set.

Enable Packet Queue Select how packet queuing works on the device. This setting allows you to ensure 
proper scaling.

 
7 Configure how the firewall behaves when connected to Domain, Private, and Public networks.

Setting Description

Firewall Set to Enable to enforce policy settings on the network traffic. If disabled, the 
device allows all network traffic, regardless of other policy settings.

Outbound Action Select the default action the firewall takes on outbound connections.

If you set this setting to Block, the firewall blocks all outbound traffic unless 
explicitly specified otherwise.

Inbound Action. Select the default action the firewall takes on inbound connections.

If you set this setting to Block, the firewall blocks all inbound traffic unless explicitly 
specified otherwise.

Unicast Responses to Multicast or 
Broadcast Network Traffic

Set the behavior for the responses to multicast or broadcast network traffic.

If you disable this option, the firewall blocks all responses to multicast or broadcast 
network traffic.

Notify User When Windows Firewall 
Blocks a New App

Set the notification behavior for the firewall.

If you select Enable, the firewall may send notifications to the user when it blocks 
a new app. If you select Disable, the firewall does not send any notifications.

Stealth Mode To set the device in stealth mode, select Enable.

Stealth mode helps prevent bad actors from gaining information about network 
devices and services. When enabled, stealth mode blocks outgoing ICMP 
unreachable and TCP reset messages from ports without an app actively listening 
on that port.

Allow IPSec Network Traffic in Stealth 
Mode

Set how the firewall handles unsolicited traffic secured by IPSec.

If you select Enable, the firewall allows unsolicited network traffic secure by IPSec.

This setting only applies when you enable Stealth Mode.

Local Firewall Rules Set how the firewall interacts with local firewall rules.

If you select Enable, the firewall follows local rules. If you select Disable, the 
firewall ignores local rules and does not enforce them.

Local Connection Rules Set how the firewall interacts with local security connection rules.

If you select Enable, the firewall follows local rules. If you select Disable, the 
firewall ignores local rules and does not enforce them, regardless of the schema 
and connection security versions.
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Setting Description

Global Port Firewall Rules Set how the firewall interacts with global port firewall rules.

If you select Enable, the firewall follows the global port firewall rules. If you select 
Disable, the firewall ignores the rules and does not enforce them.

Authorized Application Rules Set how the firewall interacts with local authorized application rules.

If you select Enable, the firewall follows local rules. If you select Disable, the 
firewall ignores local rules and does not enforce them.

 
8 To configure you own firewall rules, select Add Firewall Rule. After adding a rule, configure the 

settings as needed. You can add as many rules as you need.

9 When finished, select Save And Publish to push the profile to devices.

Configure a Single App Mode Profile (Windows Desktop)
The Single App Mode profile allows you to limit access on the device to a single application. With Single 
App Mode, the device is locked into a single application until the payload is removed. The policy enables 
after a device reboot.

Prerequisites

Single App Mode has some restrictions and limitations.

n Windows Universal or Modern apps only. Single App Mode does not support legacy .msi or .exe 
applications.

n Users must be local standard users only. They cannot be a domain user, admin user, Microsoft 
account, or guest. The Standard User must be a Local User. Domain Accounts are not supported.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop

3 Select User Profile.

4 Configure the profile General settings.

5 Select the Single App Mode Profile.

6 Configure the Single App Mode settings:

Settings Descriptions

Application Name Enter the application friendly name.

For Windows apps, the friendly name is the Package Name or Package ID.

Run a PowerShell command to get the friendly name of the app installed on the 
device. The command "Get-AppxPackage" returns the application friendly name as 
"name."
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7 After configuring a Single App Mode profile, you must set up Single App Mode on the device.

a After receiving the Single App Mode profile on the device, reboot the device to begin.

b Once the device restarts, you are prompted to sign into the device with the Standard User 
account.

Once signed in, the policy launches and Single App Mode is ready for use.

If you must sign out of Single App Mode, press the Windows key 5X fast to launch the login screen to 
log in to a different user.

Configure an Antivirus Profile (Windows Desktop)
Create an Antivirus profile to configure the native Windows Defender antivirus on Windows Desktop 
devices. Windows Defender configured for all your devices ensures that your end users are protected as 
they use the device.

Important   This profile only configures native Windows Defender and not other third-party antivirus 
appliances.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Antivirus Profile.

6 Configure the Antivirus settings:

Settings Descriptions

Real Time Monitoring Enable to configure Windows Defender to monitor the device in real time.

Full Scan Enable to schedule when a full system scan runs. Select the time interval (in hours) 
between scans.

Quick Scan Enable to schedule when a quick system scan runs. Select the time interval (in 
hours) between scans.

Exclusions Select the file paths or processes to exclude from the Windows Defender scans.

Select Add New to add an exception.
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Settings Descriptions

Threat Default Action (Low, Moderate, 
High, Severe threats)

Set the default action for the different threat levels found during scans.

n Clean – Select to clean the issues with the threat.

n Quarantine – Select to separate the threat into a quarantine folder.

n Remove – Select to remove the threat from your system.

n Allow – Select to let the threat stay.

n User Defined – Select to let the user decide what to do with the threat.

n No Action – Select to take no action with the threat.

n Block – Select to block the threat from accessing the device.

Scan Avg CPU Load Factor Set the maximum average percentage of CPU Windows Defender can use during 
scans.

UI Lockdown Enable to lock down completely the UI so end users cannot change settings.

Catchup Full Scan Enable to allow run a full scan that was interrupted or missed previously.

A catch-up scan is a scan that is initiated because a regularly scheduled scan was 
missed. Usually these scheduled scans are missed because the computer was 
turned off at the scheduled time.

Catchup Quick Scan Enable to allow run a quick scan that was interrupted or missed previously.

A catch-up scan is a scan that is initiated because a regularly scheduled scan was 
missed. Usually these scheduled scans are missed because the computer was 
turned off at the scheduled time.

Behavior Monitoring Enable to set the virus scanner to send an activity log to Microsoft.

Intrusion Prevention System Enable to configure the network protection against exploitation of known 
vulnerabilities.

This option enables Windows Defender to monitor the connections continuously 
and identify potentially malicious behavior patterns. In this respect, the software 
behaves like a classic virus scanner, except that instead of scanning files it now 
scans network traffic.

Scan Email Enable to allow Windows Defender to scan emails.

Scan Mapped Network Drives Enable to allow Windows Defender to scan network drives mapped to devices.

Scan Archives Enable to allow Windows Defender to run a full scan archived folders.

Scan Removable Drives Enable to allow Windows Defender to scan any removable drives attached to the 
device.

Remove Quarantined Files After Set how long files are quarantined before being removed.
 

7 Select Save & Publish.

Encryption Profile (Windows Desktop)
Secure your organization data on Windows Desktop devices with the Encryption profile. The Encryption 
profile sets the native BitLocker encryption policy on your Windows Desktop devices to ensure data 
remains secure.

BitLocker encryption is only available on Windows 8 Enterprise and Pro and Windows 10 Enterprise, 
Education, and Pro devices.
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Because laptops and tablets are mobile devices by design, they risk your organization data being lost or 
stolen. By enforcing an encryption policy through Workspace ONE UEM, you can protect data on the hard 
drive. BitLocker is the native Windows encryption and Dell Data Protection | Encryption is a third-party 
encryption solution from Dell. With the Encryption profile enabled, Workspace ONE Intelligent Hub 
continually checks the encryption status of the device. If Workspace ONE Intelligent Hub finds that the 
device is not encrypted, it automatically encrypts the device.

If you decide to encrypt with BitLocker, a recovery key created during encryption is stored in the 
Workspace ONE UEM console and in the Self-Service Portal.

The Encryption profile requires Workspace ONE Intelligent Hub to be installed on the device.

Note   The Encryption profile does not configure or enable Dell Data Protection | Encryption. The status of 
the encryption is reported to the Workspace ONE UEM console and Self-Service Portal, but the 
encryption must be configured manually on the device.

Caution   Windows 10 does not support devices without a pre-boot onscreen keyboard. Without a 
keyboard, you cannot enter the start up pin necessary to unlock the hard drive and start Windows on the 
device. Pushing this profile to devices without a pre-boot onscreen keyboard breaks your device.

BitLocker Functionality
The Encryption profile uses advanced BitLocker functionality to control authentication and deployment of 
BitLocker encryption.

BitLocker uses the Trusted Platform Module (TPM) on devices to store the recovery password on the 
device to decrypt hard drives connected to the motherboard. If the drive is removed from the 
motherboard, the drive does not decrypt. For enhanced authentication, you can enable an encryption PIN 
to confirm user authentication. You can also require a password for devices as a fallback for when the 
TPM is not available.

Deployment Behavior
The Windows-native BitLocker encryption secures data on Windows Desktop devices. Deploying the 
encryption profile requires more actions from the end user.

If the Encryption profile is pushed to an encrypted device and the current encryption settings match the 
profile settings, Workspace ONE Intelligent Hub adds a new recovery key and sends it to the Workspace 
ONE UEM console. This new recovery key is also stored in an encrypted database on the device. With 
this feature, if a user or an admin attempts to decrypt the device, the Encryption profile re-encrypts the 
device with the new recovery key. The encryption is enforced even if the device is offline.

If the existing encryption does not meet the authentication settings of the Encryption profile, the existing 
protectors are removed and new protectors are applied that meet the Encryption profile settings.

If the existing encryption method does not match the Encryption profile, Workspace ONE UEM leaves the 
existing method in place and does not override it. This functionality also applies if you add a new version 
of the Encryption profile to a device managed by an existing Encryption profile. The existing encryption 
method is not changed.
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Encryption Status
If BitLocker is enabled and in use, you can see status reports about the encryption status in the following 
areas:

n Workspace ONE UEM Dashboard

n Device Details displays recovery key information.

n BitLocker protection displays as enabled.

n Workspace ONE UEM Self-Service Portal

n Self-Service Portal displays that the recovery key is stored, but not the recovery key details.

n BitLocker protection displays as enabled.

Removal Behavior
If the profile is removed from the Workspace ONE UEM console, Workspace ONE UEM no longer 
enforces the encryption and the device automatically decrypts. Enterprise wiping or manually uninstalling 
Workspace ONE Intelligent Hub from the Control Panel disables BitLocker encryption.

When you create the Encryption profile, you can choose to enable the Keep System Encrypted at All 
Times option. This setting ensures that the device remains encrypted even if the profile is removed, the 
device is wiped, or communication with Workspace ONE UEM ends.

If the end user decides to unenroll during the BitLocker encryption process, the encryption process 
continues unless it is turned off manually from the Control Panel.

Configure an Encryption Profile (Windows Desktop)
Create an Encryption profile to secure your data on Windows Desktop devices using the native BitLocker 
encryption.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Encryption profile and configure the settings:

Settings Descriptions

Encrypted Volume Use the drop-down menu to select the type of encryption as follows:

n Complete Hard Disk – Encrypts the entire hard disk on the device, including 
the System Partition where the OS is installed.

n System Partition – Encrypts a partition or drive in the same location Windows is 
installed and from which it boots.

Encryption Method Select the encryption method for the device.
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Settings Descriptions

Only encrypt used space during initial 
encryption

Enable to limit the BitLocker encryption to only the used space on the drive at the 
time of encryption.

Recovery Key URL Enter the URL to display on the lock screen directing end users to get the recovery 
key.

Consider entering the Self Service Portal URL as Workspace ONE UEM hosts the 
recovery key there.

Force Encryption Enable to force encryption on the device. This enforcement means that the device 
immediately re-encrypts if BitLocker is manually disabled.

Consider disabling this setting to prevent issues during upgrades or Enterprise 
Wipes.

Keep System Encrypted at All Times Enable this option to keep the device encrypted at all times. Use this option to 
ensure that device wipes, profile removals, or break in communication with 
Workspace ONE UEM does not decrypt the device.

If this you enable this setting and wipe a device, you can only access the recovery 
from the Workspace ONE UEM console for 30 days. After 30 days, the system may 
be unrecoverable.

Authentication Mode Select the method for authenticating access to a BitLocker encrypted device.

n TPM — Uses the devices Trusted Platform Module. Requires a TPM on the 
device.

n Password — Uses a password to authenticate.

Enforce Encryption PIN on Login Select the check box to require users to enter a PIN to unlock the device. This 
option locks out the OS start up and auto-resume from suspend or hibernate until 
the user enters the correct PIN.

Use Password if TPM Not present Select the check box to use a password as a fallback to decrypt the device if the 
TPM is unavailable.

If this settings is not enabled, any devices without a TPM do not encrypt.

Suspend BitLocker until TPM is 
initialized

Select this option to postpone encryption on the device until TPM is initialized on 
the machine. Use this option for enrollments that require encryption before TPM 
initializes such as OOBE.

Minimum Password Length Select the minimum number of characters a password must be.

Displays if the Authentication Mode is set to Password or if Use Password if 
TPM Not Available is enabled.

Create Static BitLocker Password Select the check box if a static recovery key is enabled.

BitLocker Recovery Password Select the Generate icon ( ) to generate a new recovery key.

Rotation Period Enter the number of days until the recovery key rotates.

Grace Period Enter the number of days after rotation that the previous recovery key still works.

Enable BitLocker Suspend Select the check box to enable BitLocker Suspension. This functionality suspends 
BitLocker encryption during a specified time period. Use this feature to suspend 
BitLocker when updates are scheduled so devices can reboot without requiring end 
users to enter the Encryption PIN or password.
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Settings Descriptions

Suspend BitLocker Type Select the type of suspension.

n Schedule — Select to enter the specific time period that BitLocker suspends. 
Then set the schedule repeat to daily or weekly.

n Custom — Select to enter the day and time to begin and end BitLocker 
suspension.

BitLocker Suspend Start Time Enter the time to start BitLocker suspension.

BitLocker Suspend End Time Enter the time to end BitLocker suspension.

Scheduled Repeat Type Set whether the scheduled suspension repeats daily or weekly. If you select 
weekly, select the days of the week to repeat the schedule.

 
6 Select Save & Publish when you are finished to push the profile to devices.

Configure a Windows Updates Profile (Windows Desktop)
Create a Windows Updates profile to manage the Windows Updates settings for Windows Desktop 
devices. The profile ensures that all your devices are up-to-date, which improves device and network 
security.

Prerequisites

To use advanced settings, the Windows Update profile requires the Workspace ONE Intelligent Hub to be 
installed on the device.

Important: To see the OS version each update branch supports, see Microsoft's documentation on 
Windows 10 release information: https://technet.microsoft.com/en-us/windows/release-info.aspx.

To enforce a Windows Update profile:

Procedure

1 Navigate to Devices > Profiles > List View and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Windows Updates profile.
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6 Configure the Windows Updates settings:

Settings Descriptions

Windows Update Source Select the source for Windows Updates:

n Microsoft Update Service– Select to use the default Microsoft Update Server.

n Corporate WSUS – Select to use a corporate server and enter the WSUS 
Server URL and WSUS Group.

The device must contact the WSUS at least once for this setting to take effect.

Selecting Corporate WSUS as a source allows your IT Admin to view updates 
installed and device status of devices in the WSUS Group.

Update Branch Select the update branch to follow for updates.

n Semi-Annual Channel

n Windows Insider Branch - Slow

n Windows Insider Branch - Fast

n Release Windows Insider Build

Insider Builds Allow the download of Windows Insider builds of Windows 10.

Defer Feature Updates Period in Days Select the number of days to delay feature updates before installing the updates on 
the device.

The maximum number of days you can defer an update changed in Windows 10 
version 1703. Devices running a version before 1703 can only defer for 180 days. 
Devices running a version after 1703 can defer up to 365 days.

If you defer an update for longer than 180 days and push the profile to a device 
running Windows 10 before the1703 update, the profile fails to install on the device.

Pause Feature Updates Enable to pause all feature updates for 60 days or until disabled. This setting 
overrides the Defer Feature Updates Period in Days setting.

Use this option to delay an update that causes issues that can normally install 
following your deferral settings.

Defer Quality Updates Period In Days Select the number of days to delay quality updates before installing the updates on 
the device.

Pause Quality Updates Enable to pause all quality updates for 60 days or until disabled. This setting 
overrides the Defer Quality Updates Period in Days setting.

Use this option to delay an update that causes issues that can normally install 
following your deferral settings.

Enable Settings for Previous 
Windows versions

Select to enable deferral settings for previous versions of Windows. The settings 
include:

n Defer New Features (months)
n Defer New Updates (weeks)
n Pause Deferrals
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Settings Descriptions

Automatic Updates Set how updates from the selected Update Branch are handled:

n Install updates automatically.

n Install Updates but let the user schedule the computer.

n Install updates automatically and restart at specified time.

n Install updates automatically and prevent user from modifying the control panel 
settings.

n Check for updates but let the user choose whether to download and install 
them.

n Never check for updates.

Active Hours Maximum (Hours) Enter the maximum number of active hours that prevent the system from rebooting 
due to updates.

Active Hours Start Time Enter the start time for active hours.

Set the active hours to prevent the system from rebooting during these hours.

Active Hours End Time Displays the end time for active hours

This time is determined by the Active Hours Start Time and the Active Hours 
Maximum.

Auto Restart Deadlines Set the maximum number of days that can pass after installing a Quality or Feature 
Update before a system reboot is mandatory.

Auto-Restart Notification (Minutes) Set the number of minutes before an auto-restart that a warning displays.

Auto-Restart Required Notification Set how an auto-restart notification must be dismissed.

n Auto Dismissal - Automatically dismissed

n User Dismissal - Requires the user to close the notification.

Engaged Restart Deadline Engaged Restarts allow to manage when the device reboots after installing a 
Quality or Feature update during Active Hours. Use this option to set the number of 
days a user can engage a reboot before a reboot is automatically scheduled 
outside of active hours.

Engaged Restart Snooze Schedule Enter the number of days a user can snooze an Engaged Restart. After the snooze 
period passes, a reboot time is scheduled outside active hours.

Scheduled Auto-Restart Warning 
(Hours)

Set the number of hours before a scheduled auto-restart to warn users.

Scheduled Auto-Restart Warning 
(Minutes)

Set the number of minutes before a scheduled auto-restart to warn users.

Allow Public Updates Allow updates from the public Windows Update service.

Not allowing this service can cause issues with the Microsoft Store.

Allow Microsoft Updates Allow updates from Microsoft Update.

Update Scan Frequency (Hours) Set the number of hours between scans for updates.

Dual Scan Enable to use Windows Update as your primary update source while using 
Windows Server update Services to provide all other content.

Exclude Windows Update Drivers 
from Quality Updates

Enable to prevent driver updates from automatically installing on devices during 
Quality Updates.

Install Signed Updates from 3rd Party 
Entities

Allow the installation of updates from approved third parties.
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Settings Descriptions

Mobile Operator App Download Limit Select whether to ignore any Mobile Operator download limits for downloading 
apps and their updates over a cellular network.

Mobile Operator Update Download 
Limit

Select whether to ignore any Mobile Operator download limits for downloading OS 
updates over a cellular network.

Require Update Approval Enable to require updates to have approval before downloading to the device.

Enable to require admins explicitly approve updates before downloading to the 
device. This approval is either through Update Groups or individual update 
approval.

This option requires you to accept any required EULA on behalf of your end users 
before the update pushes to devices. If a EULA must be accepted, a dialog box 
opens displaying the EULA.

To approve updates, navigate to Lifecycle > Windows Updates. For more 
information, see Approve Windows Updates.

Auto-Approved Updates Enable this option to set update groups that are automatically approved for 
download on end-user devices.

This option requires you to accept any required EULA on behalf of your end users 
before the update pushes to devices. If a EULA must be accepted, a dialog box 
opens displaying the EULA.

When you enable this option, the update groups display so you can set which 
groups automatically update. Set these groups to Allowed to approve the updates 
for download to assigned devices automatically.

n Feature Updates

n Application

n Connectors

n Critical

n Definition

n Developer Kit

n Drivers

n Feature Pack

n Guidance

n Security

n Service Pack

n Tool Updates

n Update Rollups

n General

Peer-to-Peer Updates Allow the use of peer-to-peer downloading of updates.

Allowed Peer-to-Peer Method Select the method of peer-to-peer connection you want to allow.

Limit Peer Usage to Member with the 
Same Group ID

Limit peer-to-peer downloading to devices within the same organization group.

VPN Peer Caching Enable to allow devices to participate in Peer Caching while connected to a VPN.

Minimum Battery Required for Peer 
Uploads (%)

Select the minimum battery charge percentage that a device must have before it 
can participate in peer-to-peer uploading.

Maximum Allowed Cache Size Enter the maximum catch size that delivery optimization can use. This value is a 
percantage of disk size.
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Settings Descriptions

Maximum cache size that delivery 
optimization can utilize (%)

Enter the percentage of the cache that delivery optimization can use.

Maximum time each file is held in the 
delivery optimization cache (seconds)

Set the number of seconds a file is held in the delivery optimization cache before 
being pushed to devices.

The optimization cache keeps updates available on other peers that the device can 
reach for quicker downloading of updates.

Minimum Disk Size for Device to Use 
Peer Caching

Enter the minimum disk size (in GB) that the device must have to use Peer 
Caching

Minimum RAM for Device to Use Peer 
Caching

Enter the minimum RAM size (in GB) that the device must have to use Peer 
Caching.

Minimum Content File Size That Can 
Use Peer Caching

Enter the minimum file size content must be to use Peer Caching.

Drive Location Used for Peer Caching Enter the file location to use for Peer Caching.

Maximum upload bandwidth that a 
device will use across all concurrent 
upload activity (KB/second

Enter the maximum upload bandwidth in KB/second that a device uses when 
sending updates to peers.

Maximum Download Bandwidth that a 
Device Will Use (KB/second)

Enter the maximum download bandwidth in KB/second that a device uses when 
downloading updates from peers.

Maximum Download Bandwidth as a 
Percentage of Total Available (%)

Enter the maximum download bandwidth percentage (of the total bandwidth 
available) used for downloading updates from Peer Caching.

Minimum QoS for Backgrund 
Downloads (KB/second)

Enter the minimum quality of service (or speed) in KB/secondfor background 
downloads.

Monthly Upload Data Cap (GB) Enter the maximum amount of data (in GB) that a device can upload per month.
 

7 Select Save & Publish to push the profile to devices.

Lifecycle Updates List View
Workspace ONE UEM supports reviewing and approving OS and OEM updates for Windows 10 devices 
and OS updates for specific Android updates. The Updates console page lists all updates available for 
Windows 10 devices enrolled in the current Organization Group.

Windows Updates
From this tab, you can approve updates and assign the updates to the specific smart groups as meets 
your business needs. This tab displays all updates with their published date, platform, classification, and 
assigned group. Only the updates available for the Windows 10 devices enrolled in the current 
Organization Group display. If you do not have any Windows 10 devices enrolled in the OG, no updates 
display.

Selecting the update name displays a window with detailed information, a link to the Microsoft KB page 
for the update, and the status of update installation.

For more information on approving an update, see Approve Windows Updates.

Windows Desktop Device Management

VMware, Inc. 69



The update installation status shows the deployment of the update across your devices. See the status of 
the update deployment by selecting View.

Status Descriptions

Assigned The update is approved and assigned to the device

Approved The approved update is successfully assigned to the device.

Available The update is available on the device for installation

Pending Installation The installation is approved and available but not yet installed.

Pending Reboot Installation is paused until the device reboots.

Installed The update successfully installed

Failed The updated failed to install.

OEM Updates
From this tab, you can see all OEM updates deployed to your Windows Desktop devices. You can order 
the list view by name, level, type, and device category. You can also filter the displayed updates with 
filters including audio drivers, chipset drivers, BIOS updates, and more.

See the installation status of the update deployment by selecting the update name.

Fore more information on pushing OEM updates to devices, see Configure the OEM Updates Profile 
(Windows Desktop)

Approve Windows Updates
Review and approve Windows Updates for installation on your Windows 10 devices. This feature allows 
you to ensure your devices remain up-to-date while controlling the distribution of updates to meet your 
business needs.

Prerequisites

You must publish a Windows Update profile with Require Update Approval enabled.

Procedure

1 Navigate to Lifecycle > Updates > Windows.

2 Select the check box on the left of the update. Select the Assign button.

3 Enter the smart groups to which the update applies.

4 Select Add.

What to do next

For more information on the Windows Updates console page, see Lifecycle Updates List View.
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Create a Proxy Profile (Windows Desktop)
Create a Proxy profile to configure a proxy server for your Windows Desktop devices. These settings do 
not apply to VPN connections.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Proxy profile and configure the settings:

Settings Description

Automatically Detect Settings Enable to have the system automatically try to find the path to a proxy auto-config 
(PAC) script.

Use Setup Script Enable to enter the file path to the PAC script.

Script Address Enter the file path to the PAC script.

This option displays when Use Setup Script is enabled.

Use Proxy Server Enable to use a static proxy server for Ethernet and Wi-Fi connections. This proxy 
server is used for all protocols. These settings do not apply to VPN connections.

Address to Proxy Server Enter the proxy server address. The address must follow the format: 
<server>[“:”<port>].

Exceptions Enter any addresses that should not use the proxy server. The system will not user 
the proxy server for these addresses. Separate enteries with a semicolon (;).

User Proxy for Local (Intranet) 
Addresses

Enable to use the proxy server for local (intranet) addresses.

 
6 Select Save And Publish.

Configure a Web Clips Profile (Windows Desktop)
A Web Clips Profile allows you to push URLs on to end-user devices for easy access to important Web 
sites.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select User Profile.

4 Configure the profile General settings.

5 Select the Web Clips profile.
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6 Configure the Web Clips settings, including:

Settings Description

Label Enter a description for the Web clip.

URL Enter the target URL for the Web clip.

Show in App Catalog Enable to show the Web clip in the app catalog.
 

7 Select Save & Publish when you are finished to push the profile to devices.

Exchange ActiveSync Profile (Windows Desktop)
The Exchange ActiveSync profiles enable you to configure your Windows Desktop devices to access your 
Exchange ActiveSync server for email and calendar use.

Use certificates signed by a trusted third-party certificate authority (CA). Mistakes in your certificates 
expose your otherwise secure connections to potential man-in-the-middle attacks. Such attacks degrade 
the confidentiality and integrity of data transmitted between product components, and might allow 
attackers to intercept or alter data in transit. See Configure a Credentials Profile for Windows 10 Devices 
for more information.

The Exchange ActiveSync profile supports the native mail client for Windows Desktop. The configuration 
changes based on which mail client you use.

Removing Profile or Enterprise Wiping
If the profile is removed using the remove profile command, compliance policies, or through an enterprise 
wipe, all email data is deleted, including:

n User account/login information.

n Email message data.

n Contacts and calendar information.

n Attachments that were saved to the internal application storage.

Username and Password
If you have email user names that are different than user email addresses, you can use the 
{EmailUserName} text box, which corresponds to the email user names imported during directory service 
integration. Even if your user user names are the same as their email addresses, use the 
{EmailUserName} text box, because it uses email addresses imported through the directory service 
integration.
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Configure an Exchange ActiveSync Profile (Windows Desktop)
Create an Exchange ActiveSync profile to give Windows Desktop devices access to your Exchange 
ActiveSync server for email and calendar use.

Note   Workspace ONE UEM does not support Outlook 2016 for Exchange ActiveSync profiles.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and choose Windows Desktop as the platform.

3 Select User Profile.

4 Configure the profile General settings.

5 Select the Exchange ActiveSync payload.

6 Configure the Exchange ActiveSync settings:

Settings Descriptions

Mail Client Select the Mail Client that the EAS profile configures.

Workspace ONE UEM supports the Native Mail Client.

Account Name Enter the name for the Exchange ActiveSync account.

Exchange ActiveSync Host Enter the URL or IP Address for the server hosting the EAS server.

Use SSL Enable to send all communications through the Secure Socket Layer.

Domain Enter the email domain.

The profile supports lookup values for inserting enrollment user login information. 
For more information, see the Username and Password section at the bottom of 
the page.

Username Enter the email user name.

Email Address Enter the email address. This text box is a required setting.

Password Enter the email password.

Identity Certificate Select the certificate for the EAS payload.See Configure a Credentials Profile for 
Windows 10 Devices for more information.

Next Sync Interval (Min) Select the frequency, in minutes, that the device syncs with the EAS server.

Past Days of Mail to Sync Select how many days of past emails sync to the device.

Diagnostic Logging Enable to log information for troubleshooting purposes.

Require Data Protection Under Lock Enable to require data to be protected when the device is locked.

Allow Email Sync Enable to allow the syncing of email messages.

Allow Contacts Sync Enable to allow the syncing of contacts.

Allow Calendar Sync Enable to allow the syncing of calendar events.
 

7 Select Save to keep the profile in the Workspace ONE UEM console or Save & Publish to push the 
profile to the devices.
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SCEP Profile (Windows Desktop)
Simple Certificate Enrollment Protocol (SCEP) profiles enable you to install certificates onto devices 
silently without interaction from the end user.

Even with strong passcodes and other restrictions, your infrastructure remains vulnerable to brute force, 
dictionary attacks, and employee error. For greater security, you can implement digital certificates to 
protect corporate assets. To use SCEP to install these certificates to devices silently, you must first define 
a certificate authority, then configure a SCEP payload alongside your EAS, Wi-Fi, or VPN payload. Each 
of these payloads has settings for associating the certificate authority defined in the SCEP payload.

To push certificates to devices, configure a SCEP payload as part of the profiles you created for EAS, Wi-
Fi, and VPN settings.

Configure a SCEP Profile (Windows Desktop)
A SCEP profile silently installs certificates onto devices for use with device authentication.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select User Profile or Device Profile.

4 Configure the profile General settings.

5 Select the SCEP profile.

6 Configure the SCEP settings, including:

Settings Descriptions

Credential Source This drop-down menu is always set to defined certificate authority.

Certificate Authority Select the certificate authority you want to use.

Certificate Template Select the template available for the certificate.

Issuer Enter the issuer of the certificate. The issuer can be found in the subject line of the 
certificate.

Key Location Select the location for the certificate private key:

n TPM If Present – Select to store the private key on a Trusted Platform Module 
if one is present on the device, otherwise store it in the OS.

n TPM Required – Select to store the private key on a Trusted Platform Module. 
If a TPM is not present, the certificate does not install and an error displays on 
the device.

n Software – Select to store the private key in the device OS.

n Passport – Select to save the private key within the Microsoft Passport. This 
option requires the Azure AD integration.

Container Name Specify the Passport for Work (now called ‘Windows Hello for Business’) container 
name. This setting displays when you set Key Location to Passport.
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7 Configure the Wi-Fi, VPN, or EAS profile.

8 Select Save & Publish when you are finished to push the profile to devices.

Application Control Profile (Windows Desktop)
Limit which applications can be installed onto Windows Desktop devices with the Application Control 
profile. Limiting application installs protects your data from malicious apps and prevents end users from 
accessing unwanted apps on corporate devices.

To allow or prevent installation of applications on devices, you can enable Application Control to whitelist 
and blacklist specific applications. While the compliance engine monitors devices for whitelisted and 
blacklisted apps, Application Control prevents users from even attempting to add or remove applications. 
For example, prevent a certain game application from ever installing on a device, or allow only specific 
apps whitelisted to be installed on a device. Blacklisted apps installed on the device before the 
Application Control payload is pushed to the device are disabled after the profile is pushed.

The Application Control profile helps reduce the cost of device management by preventing user from 
running prohibited apps that cause issues. Preventing apps from causing issues reduces the number of 
calls your support staff must answer.

Configure an Application Control Profile (Windows Desktop)
Enable Application Control to whitelist and blacklist specific applications to allow or prevent use of 
applications on devices. Application Control uses Microsoft AppLocker configurations to enforce app 
control on Windows 10 devices.

Important  
n Create policies using Audit Only mode first. After verifying with the Audit Only version on a test 

device, create an Enforce mode version for use with your devices. Failing to test policies before 
general use may result in your devices becoming unusable.

n Create default rules and any other desired rules for your organization to reduce chances of locking 
the default configurations or breaking devices after reboot. For more information on creating rules, 
see the Microsoft TechNet article on AppLocker.

Prerequisites

To configure an XML configuration file, you must configure the AppLocker settings on a device and export 
the file for use with the profile.

The Application Control profile requires Windows 10 Enterprise or Education.

Procedure

1 On the configuration device, start the Local Security Policy editor.

Windows Desktop Device Management

VMware, Inc. 75



2 Navigate to Application Control Policies > AppLocker and select Configure Rule Enforcement.

3 Enable Executable Rules, Windows Installer Rules, and Script Rules enforcement by selecting 
Enforce Rules.

4 Create Executable Rules, Windows Installer Rules, and Script Rules by selecting the folder on 
the right then right-clicking the folder and selecting Create New Rule.

Remember to create Default Rules to reduce chances of locking the default configuration or breaking 
the device.

5 After creating all the rules you want, right-click AppLocker and select Export Policy and save the 
XML configuration file.

6 Navigate in the Workspace ONE UEM console to Devices > Profiles > List View > Add and select 
Add Profile.

7 Select Windows and then select Windows Desktop.

8 Select Device Profile.

9 Configure the profile General settings.

10 Select the Application Control payload.

11 Select Import Sample Device Configuration and select Upload to add your Policy Configuration 
File.

12 Select Save & Publish.
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Configure an Exchange Web Services Profile (Windows 
Desktop)
Create an Exchange Web Services profile to allow end users to access corporate email infrastructures 
and Microsoft Outlook accounts from their devices.

Prerequisites

Important   During first-time configuration, the device must have access to the Internal Exchange Server.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select User Profile.

4 Configure the profile General settings.

5 Select the Exchange Web Services profile and configure the settings:

Settings Descriptions

Domain Enter the name of the email domain to which the end user belongs.

Email Server Enter the name of the Exchange server.

Email Address Enter the address for the email account.
 

6 Select Save & Publish when you are finished to push the profile to devices.

Removing an Exchange Web Services profile removes all Outlook accounts from the device.

Create a Windows Licensing Profile (Windows Desktop)
Configure a Windows Licensing profile to provide your Windows 10 devices with a Windows 10 Enterprise 
or Windows 10 Education license key. Use this profile to upgrade devices that do not come with Windows 
10 Enterprise.

Important   This upgrade cannot be reversed. If you publish this profile to BYOD devices, you cannot 
remove the licensing through MDM. Windows 10 can only upgrade following a specific upgrade path:
n Windows 10 Enterprise to Windows 10 Education

n Windows 10 Home to Windows 10 Education

n Windows 10 Pro to Windows 10 Education

n Windows 10 Pro to Windows 10 Enterprise

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.
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2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Windows Licensing profile and configure the following settings:

Settings Descriptions

Windows Edition Select either Enterprise or Education edition.

Please Enter valid License Key Enter the license key for the edition of Windows that you are using.
 

6 Select Save & Publish to push the profile to devices.

Configure a BIOS Profile (Windows Desktop)
Configure BIOS settings for select Dell enterprise devices with the BIOS profile. This profile requires 
integration with Dell Command | Monitor.

Support for the BIOS profile settings varies by Dell Enterprise device. Workspace ONE UEM only pushes 
the settings a device supports. If you push this profile to devices, Workspace ONE UEM automatically 
pushes the Dell Command | Monitor app to the devices.

For more information on supported devices, see Chapter 9 Dell Command | Monitor Integration.

Prerequisites

If you want to use the configuration package feature, you must push the Dell Command | Configure app to 
devices. For more information, see Chapter 8 Dell Command | Configure Integration.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the BIOS payload and configure the following settings:

Settings Descriptions

BIOS Password Enter the password used to unlock the BIOS of the device.

This field is required.

TPM Chip Select Enable to enable the device Trusted Platform Module chip.

Boot Mode Select whether the device boots in BIOS or UEFI mode.

Boot Mode Protection Select Enable to prevent issues with the OS installed on the device from booting. 
This protection prevents a change in Boot Mode on a device with an installed OS.
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Settings Descriptions

Secure Boot Select Enable to use Secure Boot settings on the device. You cannot disable 
Secure Boot with DCM. If your devices already use Secure Boot, you must 
manually disable the settings on the device.

Secure Boot requires Boot Mode to be set to UEFI and Legacy Option ROMS to 
be set to Disable.

Legacy Option ROMS Select Enable to allow the use of legacy option ROMS during the boot process.

CPU Virtualization Select Enable to allow hardware virtualization support.

Virtualization IO Select Enable to allow input/output virtualization.

Trusted Execution Select Enable to allow the device to use the TPM chip, CPU Virtualization, and 
Virtualization IO for trust decisions.

Trust Execution requires the TPM Chip, CPU Virtualization, and Virtualization IO 
settings to be set to Enabled.

Wireless LAN Select Enable to allow use of the device wireless LAN functionality.

Cellular Radio Select Enable to allow use of the device cellular radio functionality.

Bluetooth Select Enable to allow use of the device Bluetooth functionality.

GPS Select Enable to allow use of the device GPS functionality.

SMART Reporting Select Enable to use SMART monitoring of the device storage solutions.

Primary Battery Charge Select the charging rules for the device:

n Standard Charge - Consider using this option for users who switch between 
battery power and an external power source. This option fully charges the 
battery at a standard rate. Charge time varies by device model.

n Express Charge - Consider using this option for users who need the battery 
charged over a short time period. Dell’s fast charging technology allows a 
completely discharged battery to typically charge to 80% in about 1 hour when 
the computer is turned off and to 100% in approximately 2 hours. Charge time 
may be longer with the computer turned on.

n AC Charge - Consider using this option for users who primarily operate their 
system while plugged in to an external power source. This setting may extend 
your battery’s lifespan by lowering the charge threshold.

n Auto Charge - Consider using this option for users who want to set the option 
and not change it. This option lets the system adaptively optimize your battery 
settings based on your typical battery usage pattern.

n Custom Charge - Consider using this option for advanced users that desire 
greater control over when their battery starts and stops charging.

These rules control when the battery starts and stops charging. If you select 
Custom Charge, you can manually set the charge percentage to start and stop 
charging the battery.

Primary Battery Custom Charge Start 
Limit

Set the battery charge percentage that must be reached before the device starts 
charging the battery.

Primary Battery Custom Charge Stop 
Limit

Set the battery charge percentage that must be reached before the device stops 
charging the battery.

Peak Shift Select Enable to use peak shift to control when a device uses battery charge or AC 
current. Peak shift allows you to use battery power instead of AC current during 
specified times.

To set the schedule for Peak Shift, select the calendar icon.
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Settings Descriptions

Peak Shift Scheduling The three parameters for peak shift scheduling control when a device uses battery 
or AC current and when the device charges the battery.

n Peak Shift Start – Set the start time for Peak Shift when devices switch to 
battery power.

n Peak Shift End – Set the end time for Peak Shift when devices switch to AC 
current.

n Peak Shift Charge Start – Set the start time for Peak Shift Charge when the 
devices charge the batteries while using AC current.

Peak Shift Battery Threshold Set the battery charge percentage that must be reached before devices switch 
back to AC current from battery power.

The Peak Shift Charge Start setting controls the time when devices charge the 
batteries after switching to AC current.

System Properties Select Add System Properties to add a custom system property. Select the button 
again to add additional properties.

These properties are advanced options. Consider reviewing Dell documentation 
before using these settings.

System Properties override any pre-defined settings configured in the profile.

Class Enter a class and select it from the drop-down menu.

Displays after selecting Add System Properties.

System Property Enter a system property and select it from the drop-down menu.

Displays after selecting Add System Properties.

BIOS Attributes Select Add BIOS Attribute to add a custom BIOS attribute. Select the button 
again to add additional attributes.

These attributes are advanced options. Consider reviewing Dell documentation 
before using these settings.

BIOS Attributes override any pre-defined settings configured in the profile.

BIOS Attribute Enter a BIOS attribute and select it from the drop-down menu.

Displays after selecting Add BIOS Attribute.

Value Select a value for the BIOS attribute. If a value is not supplied, the BIOS Attribute is 
read only.

Displays after selecting Add BIOS Attribute.

Configuration Package Select Upload to add a Dell Command | Configure configuration package. 
Uploading a package allows you to configure multiple Dell devices with a single 
configuration.

Configuration packages override any custom system properties or attributes.

If you whitelist the file extensions allowed, you must add the CCTK file extension to 
the whitelist. Navigate to Groups & Settings > All Settings > Content > 
Advanced > File Extensions to add the file extension.

 
6 Select Save & Publish.

Configure the OEM Updates Profile (Windows Desktop)
Configure OEM Update settings for select Dell enterprise devices with the OEM Updates profile. This 
profile requires integration with Dell Command | Update.
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Support for the OEM Update profile settings varies by Dell Enterprise device. Workspace ONE UEM only 
pushes the settings a device supports.

For more information on supported devices, see Chapter 10 Dell Command | Update Overview.

Note   The OEM Updates profile only supports Dell Command | Update v2.4.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the OEM Updates payload and configure the following settings:

Settings Description

Check for Updates Select the interval used to check for updates.

Day of the Week Select the day of the week to check for updates.

Only displays when Check for Updates is set to Weekly.

Day of the Month Select the day of the month to check for updates.

Only displays when Check for Updates is set to Monthly.

Time Select the time of day to check for updates.

Update Behavior Select the actions to take when checking for updates.

n Select Scan Notify to scan for updates and notify the user that updates are 
available.

n Select Scan Download Notify to scan for updates, download any available, 
and notify the user that updates are available for installation.

n Select Scan Notify Apply Reboot to scan for updates, download any 
available, install the updates, and reboot the device.

Reboot Delay Select the amount of time the device delays rebooting after downloading updates.

Urgent Updates Select Enable to apply Urgent Updates to the device.

Recommended Updates Select Enable to apply Recommended Updates to the device.

Optional Updates Select Enable to apply Optional Updates to the device.

Hardware Drivers Select Enable to apply hardware driver updates provided by the OEM to the 
device.

Application Software Select Enable to apply application software updates provided by the OEM to the 
device.

BIOS Updates Select Enable to apply BIOS updates provided by the OEM to the device.

Consider disabling any BIOS passwords if you want to use the OEM Update profile 
to manage BIOS updates. Some BIOS updates prompt users to enter the 
BIOS password.

Firmware Updates Select Enable to apply firmware updates provided by the OEM to the device.

Utility Software Select Enable to apply utility software updates provided by the OEM to the device.
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Settings Description

Other Select Enable to apply other updates provided by the OEM to the device.

Audio Select Enable to apply audio device updates provided by the OEM to the device.

Chipset Select Enable to apply chipset device updates provided by the OEM to the device.

Input Select Enable to apply input device updates provided by the OEM to the device.

Network Select Enable to apply network device updates provided by the OEM to the device.

Storage Select Enable to apply storage device updates provided by the OEM to the device.

Video Select Enable to apply video device updates provided by the OEM to the device.

Others Select Enable to apply other device updates provided by the OEM to the device.
 

6 Select Save & Publish.

Configure a Kiosk Profile (Windows Desktop)
Configure a Kiosk profile to turn your Windows Desktop device into multi-app kiosk device. This profile 
allows you to configure the apps that display in the device start menu.

You can upload your own custom XML to configure the Kiosk profile or create your kiosk as part of the 
profile. This profile does not support domain accounts or domain groups. The user is a built-in user 
account created by Windows.

n Supported Apps

n .EXE apps

• MSI and ZIP files require you to add the file path.

n Built-In apps

• Select built-in apps are automatically added to the designer. These apps include:

• News

• Microsoft Edge

• Weather

• Alarms & Clock

• Sticky Notes

• Maps

• Calculator and Photos.

Procedure

1 Navigate to Devices > Profiles > List View > Add and select Add Profile.

2 Select Windows and then select Windows Desktop.

3 Select Device Profile.
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4 Configure the profile General settings.

You must add an assignment before configuring the Kiosk profile.

5 Select the Kiosk profile.

6 If you have your custom XML already, select Upload Kiosk XML and complete the settings.

Settings Description

Assign Access Configuration XML Select Upload and add your Assigned Access Configuration XML. You can also 
paste your XML into the text box.

For more information, see https://docs.microsoft.com/en-us/windows/client-
management/mdm/assignedaccess-csp.

 
7 If you do not have any custom XML, select Create Your Kiosk and configure the app layout.

This layout is the device Start Menu in a grid. The apps that display on the left are the apps assigned 
to the assignment group you selected. Some apps have a gear icon with a red dot in the top-right 
corner. This icon displays for apps that require additional settings when added to the kiosk layout. 
After you configure the settings, the red dot disappears but the icon remains. You can select the 
arrow icon to change the size of the apps. For classic desktop apps, you can only select Small or 
Medium. 
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For applications that require additional support applications, the Kiosk profile supports adding these 
support applications using the Additional Settings option. For example, the VMware Horizon client 
requires up to four support applications to run in Kiosk mode. Add these additional support 
applications when you configure the primary kiosk application by adding the additional Application 
Executable Paths.

8 Drag all the apps you want to add to the start menu to the center. You can create up to four groups for 
your apps. These groups combine your apps into sections on the start menu.

9 Once you have added all the apps and groups you want, select Save.

10 On the Kiosk profile screen, select Save & Publish.

The profile does not install onto the device until all apps included in the profile are installed. Once the 
device receives the profile, the device restarts and runs in Kiosk mode. If you remove the profile from 
the device, the device disables Kiosk mode, restarts, and removes the Kiosk user.

Configure a Personalization Profile (Windows Desktop)
Configure a Personalization profile for Windows Desktop devices to configure the Windows 
Personalization settings. These settings include the desktop background and the start menu settings.

The options in this profile are all optional. Consider only configuring the settings you need to meet your 
Personalization requirements.

This profile does not create a multi-app kiosk device like the Kiosk profile. If you want to create a kiosk 
device, see Configure a Kiosk Profile (Windows Desktop).

Procedure

1 Navigate to Devices > Profiles & Resources and select Add.

2 Select Windows and then select Windows Desktop.
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3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Personalization profile.

6 Configure the Images settings:

Settings Descriptions

Desktop Image Select Upload to add an image to use as the desktop background.

Lock Screen Image Select Upload to add an image to use as the lock screen background.
 

7 Upload a start layout XML. This XML file overrides the default start menu layout and prevents users 
from changing the layout. You can configure the layout of tiles, the number of groups, and the apps in 
each group. You must create this XML yourself. For more information on creating a start layout XML, 
see https://docs.microsoft.com/en-us/windows/configuration/customize-and-export-start-layout.

8 Configure the Start Menu Policies settings. These settings allow you to control which shortcuts are 
allowed in the start menu. You can also choose to Hide or Show certain options such as the Shut 
Down option or the App List.

9 Select Save & Publish.

What to do next

Peer Distribution with Workspace ONE
Workspace ONE peer distribution uses the native Windows BranchCache feature that is built into the 
Windows operating system. This feature provides an alternative peer-to-peer technology for customers to 
use instead of Adaptiva.

Configure peer distribution on your Windows 10 devices with the Peer Distribution Windows Desktop 
Profile. Peer distribution supports Distributed, Hosted and Local BranchCache modes along with their 
configuration settings; disk space percentage and max cache age.

Configure a Peer Distribution Profile (Windows Desktop)
Peer distribution with Workspace ONE allows you to deploy your Windows apps to enterprise networks. 
This profile uses the native Windows BranchCache functionality built into the the Windows operating 
system.

Prerequisites

Before you can use the Peer Distribution profile for peer-to-peer distribution, you must meet the peer 
distribution with Workspace ONE requirements. For more information, see Requirements for Workspace 
ONE Peer Distribution.

Procedure

1 Navigate to Devices > Profiles & Resources and select Add.
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2 Select Windows and then select Windows Desktop.

3 Select Device Profile.

4 Configure the profile General settings.

5 Select the Peer Distribution profile and select Configure.

You must have File Storage configured before you can create a Peer Distribution profile. For more 
information, seeRequirements for Workspace ONE Peer Distribution.

6 Select the Workspace ONE Peer Distribution Mode you want to use.

Setting Description

Distributed Select this option to have your devices download apps from peers in a local 
subnet.

Hosted Select this option to have your devices to download apps from a hosted cache 
server.

Local Select this option to have your devices to download apps from local device caching 
only.

Disabled Select this option to disable peer distribution.
 

7 Configure the Cache settings:

Setting Description

Maximum Cache Age (days) Enter the maximum number of days that peer distribution items should remain in 
the cache before the device purges the items.

Percentage of Disk Space Used for 
BranchCache

Enter the amount of local disk space the device should allow peer distribution to 
use.

 
8 If you set the distribution mode to Hosted, configure the Hosted Cache Servers settings. You must 

add at least one hosted cache server for devices to download and upload content to and from.

9 Select Save & Publish.

Use Custom Settings (Windows Desktop)
The Custom Settings payload provides a way to use Windows Desktop functionality that Workspace ONE 
UEM does not currently support through its native payloads. If you want to use the new features, you can 
use the Custom Settings payload and XML code to enable or disable certain settings manually.

Prerequisites

You must write your own SyncML code for Windows Desktop profiles. Microsoft publishes a Configuration 
Service Provider reference site available on their website. To simplify creating the SyncML code, visit 
VMware Policy Builder.
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Example code:

  <Replace>

    <CmdID>2</CmdID>

      <Item>

        <Target>

          <LocURI>./Device/Vendor/MSFT/AssignedAccess/KioskModeApp</LocURI>

        </Target>

        <Meta>

          <Format xmlns="syncml:metinf">chr</Format>

        </Meta>

        <Data>{"Account":"standard","AUMID":"AirWatchLLC.AirWatchBrowser_htcwkw4rx2gx4!App"}</Data>

      </Item>

  </Replace>

Procedure

1 Navigate to VMware Policy Builder.

2 Select the Configuration Service Providers policy you want to use to create your custom profile.

3 Select Configure.

4 On the Configure page, configure the policy settings to meet your business needs.

5 Select the command verb to use with the policy: Add, Delete, Remove, or Replace.

6 Select the Copy button.

7 In the Workspace ONE UEM console, Navigate to Devices > Profiles & Resources and select Add.

8 Select Windows and then select Windows Desktop.

9 Select User Profile or Device Profile.

10 Configure the profile General settings.

11 Select the Custom Settings payload and select Configure.

12 Select a Target for the custom profile.

Most use cases use OMA-DM as the Target. Use Workspace ONE Intelligent Hub when you are 
customizing an BitLocker profile or looking to Prevent Users from Disabling the AirWatch Service.

13 Select Make Commands Atomic as long as your SyncML uses the Add, Delete, or Replace 
commands. If your code uses Exec, do not select Make Commands Atomic.

14 Paste the XML you copied in the Install Settings text box. The XML code you paste must contain the 
complete block of code, from <Add> to </Add> or whatever command your SyncML code uses Do not 
include anything before or after these tags..
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15 Add the removal code to the Delete Settings text box. The removal code must contain <replace> </
replace> or <delete> </delete>.

This code enables Workspace ONE UEM functionality such as Remove Profile and Deactivate 
Profile. Without the removal code, you cannot remove the profile from the devices besides pushing a 
second Custom Settings profile. For more information, see https://docs.microsoft.com/en-us/windows/
client-management/mdm/configuration-service-provider-reference.

16 Select Save and Publish.

Prevent Users from Disabling the AirWatch Service
Use a Custom Settings profile to prevent end users from disabling the AirWatch Service on their Windows 
10 devices. Preventing end users from disabling the AirWatch Service ensures that the Workspace ONE 
Intelligent Hub runs regular check-ins with the Workspace ONE UEM consoleand receives the latest 
policy updates.

Procedure

1 Create a Custom Settings profile. For more information, see Use Custom Settings (Windows 
Desktop).

2 Set the Target to Protection Agent.

3 Copy the following code and paste it into the Custom Settings text box:

          <wap-provisioningdoc id="c14e8e45-792c-4ec3-88e1-be121d8c33dc" name="customprofile">

            <characteristic type="com.airwatch.winrt.awservicelockdown" 

uuid="7957d046-7765-4422-9e39-6fd5eef38174">

              <parm name="LockDownAwService" value="True"/> 

            </characteristic>

          </wap-provisioningdoc>

        

4 Select Save & Publish.

If you want to remove the restriction from end user devices, you must push a separate profile using 
the following code:

          <wap-provisioningdoc id="c14e8e45-792c-4ec3-88e1-be121d8c33dc" name="customprofile"> 

            <characteristic type="com.airwatch.winrt.awservicelockdown" 

uuid="7957d046-7765-4422-9e39-6fd5eef38174">

              <parm name="LockDownAwService" value="False"/> 

            </characteristic> 

          </wap-provisioningdoc>

          

Windows Desktop Device Management

VMware, Inc. 88

https://docs.microsoft.com/en-us/windows/client-management/mdm/configuration-service-provider-reference
https://docs.microsoft.com/en-us/windows/client-management/mdm/configuration-service-provider-reference


Using Baselines 4
Keep your Windows Desktop devices secure with Baselines. Workspace ONE UEM curates industry-
recommended settings into one configuration to simplify securing your devices.

Keeping your devices configured to best practices is a time-consuming process. With Baselines, you can 
keep all your devices secure with industry-recommended settings and configurations. Workspace ONE 
UEM curates these best practices into configurations called Baselines. These configurations significantly 
reduce the time it takes to set up and configure Windows devices.

Baselines uses a cloud-based micro service that handles the policy catalog. If you are an on-premises 
customer, ensure that your environment can communicate with the micro-service. For more information, 
see the Workspace ONE UEM Recommended Architecture documentation.

To ensure that Baselines use only the best settings and configurations, CIS certifies VMware to provide 
industry favorites such as CIS Benchmarks for Windows 10. Baselines are based on the Windows OS 
version of your devices. You can change the OS version of the baseline later when editing. During 
configuration, you can choose which baseline to use and customize any of the baseline policies. You can 
also add any additional policies you need as part of the configuration process. These policies are the 
Microsoft ADMX policies.

If you have an existing Group Policy Object (GPO) backup file, you can create a custom baseline with 
those policies. You add additional policies to your existing GPO when creating a custom baseline.

After enrolling a device into Workspace ONE UEM, you can add the device to a Smart Group and assign 
a baseline to the group. The device receives and applies all the settings and configurations in the 
baseline after a device restart. The device checks for the baseline configurations upon publishing the 
baseline and at the defined check-in intervals. When you push a baseline to a device, Workspace ONE 
UEM stores a snapshot of the device settings. You can limit the assignment of the baseline using the 
Exclusions tab of the Assignment dialog. You can designate smart groups to exclude from assignment.

You can manage your baselines from the Baselines list view. From here, you can edit and delete existing 
baselines. If you delete a baseline that was pushed to devices, the device settings revert to before the 
baseline was published based on the snapshot stored by Workspace ONE UEM.

You can see which baselines are applied to a device in the Device Details page.

Ensure that your device follow the baselines with the baseline compliance status. Viewed from the 
Baseline Details page, the baseline compliance status shows when devices are compliant, intermediate, 
non-compliant, or not available. Baseline compliance status only applies to baselines created using the 
UI. You cannot see the compliance status for custom baselines created using ZIP packages. Intermediate 
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devices are 85% to 99% compliant. Use this information to see when your devices drop out of 
compliance. The not available status means that the Workspace ONE UEM console does not have a 
compliance sample for the device. You can force a sample by simply opening the baseline and publishing 
it again.

This chapter includes the following topics:

n Create a Baseline

Create a Baseline
Create a baseline that configures your devices to industry-recommended settings and configurations. 
Workspace ONE UEM curates Baselines based on industry favorites including CIS Benchmarks and 
Microsoft's Windows 10 security baselines.

Prerequisites

Baselines require that devices are enrolled in Workspace ONE UEM and have the Workspace ONE 
Intelligent Hub installed.

If you are publishing a custom baseline, you must add the LGPO.exe to all devices that you want to 
assign a baseline to. You must install the EXE at C:\ProgramData\Airwatch\LGPO\LGPO.exe. If you 
are using the CIS Benchmark or Windows 10 Security baselines, you do not need to add this file.

Procedure

1 Navigate to Devices > Profiles & Resources > Baselines and select New

2 Enter a Baseline Name, Description, and select the smart group the baseline is Managed By. Then 
select Next.

3 Select a baseline:

Setting Description

CIS Windows 10 Benchmarks This baseline applies the configuration settings recommended by CIS Benchmarks.

Select the OS version and benchmark level to apply.

Windows 10 Security Baseline This baseline applies the configuration settings recommended by Microsoft.

Select the OS version and benchmark level to apply.

Custom Baseline Upload a ZIP file with a GPO backup. You must create this baseline outside of 
Workspace ONE UEM. The backup must be less than 5 MB with at least one GPO 
folder.

 
4 Select Next.

5 Customize the baseline as needed. You can change any of the existing ADMX policies configured in 
the baseline.

When creating a custom baseline from a GPO baseline, you cannot customize the existing ADMX 
policies.
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Ensure you use SIDs when creating User Rights ADMX policies. For more information, see https://
support.microsoft.com/en-us/help/243330/well-known-security-identifiers-in-windows-operating-
systems.

6 Select Next.

7 Add any additional policies to the baseline. These policies come from Microsoft ADMX files. Search 
for any policy to add and configure the policy.

8 Select Next.

9 Review the summary and select Save & Assign. The summary includes any customized or added 
policies.

10 During assignment, enter the smart group containing the Windows 10 devices you want to assign the 
baseline to. You can redefine which devices get the baseline using the Exclusions tab. Enter the 
smart groups you want to exclude from assignment.

Exclusions override assignment. If a device is in an excluded smart group, that device does not 
receive the baseline. If that device already had the baseline from a previous assignment, the baseline 
is removed from the device.

Results

Workspace ONE UEM assigns the baseline to all devices in the smart group (besides those devices in 
excluded smart groups).

What to do next

You must restart the device for the baseline to take effect.
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Compliance Policies 5
The compliance engine is an automated tool by Workspace ONE UEM powered by AirWatch that ensures 
all devices abide by your policies. These policies can include basic security settings such as requiring a 
passcode and having a minimum device lock period.

For certain platforms, you can also decide to set and enforce certain precautions. These precautions 
include setting password strength, blacklisting certain apps, and requiring device check-in intervals to 
ensure that devices are safe and in-contact with Workspace ONE UEM. Once devices are determined to 
be out of compliance, the compliance engine warns users to address compliance errors to prevent 
disciplinary action on the device. For example, the compliance engine can trigger a message to notify the 
user that their device is out of compliance.

In addition, devices not in compliance cannot have device profiles assigned to it and cannot have apps 
installed on the device. If corrections are not made in the amount of time specified, the device loses 
access to certain content and functions that you define. The available compliance policies and actions 
vary by platform.

For more information about compliance policies, including which policies and actions are supported for a 
particular platform, see the Managing Devices documentation on docs.vmware.com.

This chapter includes the following topics:

n Dell BIOS Verification for Workspace ONE UEM

n Compromised Device Detection with Health Attestation

Dell BIOS Verification for Workspace ONE UEM
Ensure that your Dell Windows Desktop devices remain secure with Dell BIOS Verification. This service 
analyses the BIOS of your Dell devices and reports the status to Workspace ONE UEM so you can act 
against any compromised devices.

VMware, Inc. 92

https://docs.vmware.com


Benefits of Dell BIOS Verification
The BIOS is an integral part in maintaining the overall device health and security. Modern computer 
systems rely on BIOS firmware to initialize hardware during the boot process and for runtime services that 
support the operating system and applications. This privileged position within the device architecture 
makes unauthorized modification of the BIOS firmware a significant threat. The Dell BIOS Verification 
service provides secure BIOS validation using a secure signed response model. The status of the secure 
validation helps you act on compromised devices with the compliance policy engine.

Prepare Your Devices for Dell BIOS Verification
To use Dell BIOS Verification on your Windows Desktop devices, you must install the Dell BIOS 
Verification service on the device. You must download the latest client from Dell (https://www.dell.com/
support/home/us/en/04/product-support/product/bios-verification/drivers). Consider using Software 
Distribution to install the client on your Dell Windows Desktop devices.

Dell BIOS Verification Statuses
After you install the client onto your devices, you can see the reported status in the Device Details page. 
The statuses are as follows:

n Pass - The Dell BIOS Verification client is installed on the device and the device is secure.

n Fail - The Dell BIOS Verification client is installed and one of the following issues is present:

n The Pre-Check event returns a fail result. This result happens when the client detects an invalid 
binary signature.

n The BIOS Utility event returns a fail result for the validation test.

n The BIOS Server Processing event returns a fail result for an invalid signature, invalid exit code, 
or the payload status is out of sync.

n Warning - The Dell BIOS Verification is installed and the client detects an issue. The device might not 
be secured and you should investigate the issue. Causes for a Warning status might include:

n No network connection

n Invalid command-line argument

n Application is running with insufficient privileges.

n Internal errors in the client

n Server responds with an error.

n Driver issues with the client

n Unknown results in the BIOS verification

n If you see a gray warning icon, the Dell BIOS Verification client is not installed on the device.
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Compromised Device Detection with Health Attestation
Health Attestation scans devices during startup for failures in device integrity. Use Health Attestation to 
detect compromised Windows Desktop devices while managed under Workspace ONE UEM powered by 
AirWatch.

In both BYOD and Corporate-Owned device deployments, it is important to know that devices are healthy 
when accessing corporate resources. The Windows Health Attestation Service accesses device boot 
information from the cloud through secure communications. This information is measured and checked 
against related data points to ensure that the device booted up as intended and is not victim to security 
vulnerabilities or threat. Measurements include Secure Boot, Code Integrity, BitLocker, and Boot 
Manager.

Workspace ONE UEM enables you to configure the Windows Health Attestation service to ensure device 
compliance. If any of the enabled checks fail, the Workspace ONE UEM compliance policy engine applies 
security measures based on the configured compliance policy. This functionality allows you to keep your 
enterprise data secure from compromised devices. Since Workspace ONE UEM pulls the necessary 
information from the device hardware and not the OS, compromised devices are detected even when the 
OS kernel is compromised.

Configure the Health Attestation for Windows Desktop 
Compliance Policies
Keep your devices secured by using Windows Health Attestation Service for compromised device 
detection. This service allows Workspace ONE UEM to check the device integrity during startup and take 
corrective actions.

Procedure

1 Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Desktop 
> Windows Health Attestation.

2 (Optional) Select Use Custom Server if you are using a custom on-premises server running Health 
Attestation. Enter the Server URL.

3 Configure the Health Attestation settings:

Table 5-1. Compromised Status Definition

Settings Descriptions

Use Custom Server Select to configure a custom server for Health Attestation.

This option requires a server running Windows Server 2016 or newer.

Enabling this option displays the Server URL field.

Server URL Enter the URL for your custom Health Attestation server.

Secure Boot Disabled Enable to flag compromised device status when Secure Boot is disabled on the device.

Secure Boot forces the system to boot to a factory trusted state. When Secure Boot is enabled, the core 
components used to boot the machine must have the correct cryptographic signatures that the OEM 
trusts. The UEFI firmware verifies the trust before it allows the machine to start. Secure boot prevents 
the startup if any it detects any tampered files.
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Table 5-1. Compromised Status Definition (continued)

Settings Descriptions

Attestation Identity 
Key (AIK) Not Present

Enable to flag compromised device status when the AIK is not present on the device.

Attestation Identity Key (AIK) is present on a device, it indicates that the device has an endorsement key 
(EK) certificate. It can be trusted more than a device that does not have an EK certificate.

Data Execution 
Prevention (DEP) 
Policy Disabled

Enable to flag compromised device status when the DEP is disabled on the device.

The Data Execution Prevention (DEP) Policy is a memory protection feature built into the system level of 
the OS. The policy prevents running code from data pages such as the default heap, stacks, and 
memory pools. DEP is enforced by both hardware and software.

BitLocker Disabled Enable to flag compromised device status when BitLocker encryption is disabled on the device.

Code Integrity Check 
Disabled

Enable to flag compromised device status when the code integrity check is disabled on the device.

Code integrity is a feature that validates the integrity of a driver or system file each time it is loaded into 
memory. Code integrity checks for unsigned drivers or system files before they load into the kernel. The 
check also scans for users with administrative privileges running system files modified by malicious 
software.

Early Launch Anti-
Malware Disabled

Enable to flag compromised device status when the early launch anti-malware is disabled on the device.

Early launch anti-malware (ELAM) provides protection for the computers in your network when they start 
up and before third-party drivers initialize.

Code Integrity Version 
Check

Enable to flag compromised device status when the code integrity version check fails.

Boot Manager Version 
Check

Enable to flag compromised device status when the boot manager version check fails.

Boot App Security 
Version Number Check

Enable to flag compromised device status when the boot app security version number does not meet 
the entered number.

Boot Manager Security 
Version Number Check

Enable to flag compromised device status when the boot manager security version number does not 
meet the entered number.

Advanced Settings Enable to configure advance settings in the Software Version Identifiers section.

4 Select Save.
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Windows Desktop Application 
Overview 6
You can use Workspace ONE UEM applications in addition to Workspace ONE UEM MDM features to 
further secure devices and configure them with added functionality.

Use the VMware Content Locker to safeguard corporate content on mobile devices and deploy the 
VMware Browser to enable secure Web browsing for your end users. Download the Workspace ONE 
Intelligent Hub for Windows to monitor your devices on a more granular level.

Deploying Win32 apps to Windows Desktop devices requires the Workspace ONE Intelligent Hub to be 
present on the device.

Important   All public applications deployed to Windows Desktop devices are unmanaged applications. 
Unmanaged apps cannot be pushed to devices (end users must download the app themselves) nor can 
unmanaged apps be removed from devices through Enterprise Wipe.

This chapter includes the following topics:

n VMware Workspace ONE for Windows Desktop

n Configure the Workspace ONE Intelligent Hub for Windows Devices

VMware Workspace ONE for Windows Desktop
When the Workspace ONE application is installed on devices, users can sign in to Workspace ONE to 
securely access a catalog of applications that your organization enabled for them. When the application is 
configured with single sign-on, users do not need to reenter their sign-in credentials when they launch the 
app.

The Workspace ONE user interface works similarly on phones, tablets, and desktops. Workspace ONE 
opens to a Launcher page that displays resources that have been pushed to Workspace ONE. Users can 
tap or click to search, add, and update apps; right-click on an app to remove it from the page, and go to 
the Catalog page to add entitled resources.

If an app requires device enrollment, Workspace ONE uses adaptive management to start the enrollment 
process for the end user. For more information on Workspace ONE, see Setting up the VMware 
Workspace ONE Application on Devices available on the VMware Identity Manager Documentation 
Center (https://docs.vmware.com).
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Configure the Workspace ONE Intelligent Hub for 
Windows Devices
The Workspace ONE Intelligent Hub for Windows devices is pre-configured with AirWatch. Change these 
settings when you need the Workspace ONE Intelligent Hub to meet certain business needs.

Procedure

u Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Desktop 
> Intelligent Hub Settings to edit the Workspace ONE Intelligent Hub Settings:

a Configure the Workspace ONE Intelligent Hub settings so that the Workspace ONE Intelligent 
Hub transmits the desired data to the AirWatch Console:

Settings Descriptions

Data Sample Interval (min Defines the intervals at which the Workspace ONE Intelligent Hub takes 
samples of data.

 
b Configure the MDM Settings settings to ensure prompt communication between the device and 

the AirWatch Console.

Settings Descriptions

MDM Channel Security Set the app-layer security between the device and the Workspace ONE UEM 
console.

 
c Configure the Remote Management settings to enable communication between the Workspace 

ONE Intelligent Hub and the Remote Management Server.

Setting Description

Download Remote 
Control Cab

Select this link to download the cabinet (CAB) installer file for Workspace ONE UEM Remote 
Management.

Seek Permission Enable Seek Permission if you want to prompt the end user to accept or decline the remote 
management request from the admin.

n Enter a Seek Permission Message that the end user sees when a remote request is sent.

n Enter the Yes Caption message for the accept button the end user sees on the Seek Permission 
request.

n Enter the No Caption message for the decline button the end user sees on the Seek Permission 
request.

What to do next

You can prevent end users from disabling the AirWatch Service on their device using a custom XML 
profile. For more information, see Prevent Users from Disabling the AirWatch Service.
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Creating Sensors for Windows 
Desktop Devices 7
Windows Desktop devices contain multiple attributes such as hardware, OS, certificates, patches, apps, 
and more. Track these attributes in the Workspace ONE UEM console with the Sensors feature.

Devices have a huge number of attributes associated with them. This number increases when you start 
tracking the different apps, OS versions, patches, and other continually changing variables. It can be 
difficult to track all of these attributes to ensure your devices meet your needs.

Workspace ONE UEM tracks a limited number of device attributes by default. With Sensors, you can 
track the specific device attributes you want. For example, you can create a sensor that track the driver 
details for a mouse driver, the warranty information for the OS, and the registry value for your internal 
apps. Sensors allows you to track all of these across your devices. Another use case for Sensors involves 
creating a sensor that reports a "Retired Date" so you can keep track of devices that are no longer 
managed by your server.

Taking the tracking functionality to the next logical step, Workspace ONE UEM integrates Sensors with 
smart groups so you can provision apps, profiles, baselines, and more to your devices based on specific 
attributes. With a compliance policy, you can enforce actions when a device attriubute changes value.

When configuring Sensors, you can control when the device reports the sensor data back to the 
Workspace ONE UEM console with triggers. These triggers can be a scheduled time based on the 
Windows Sample Schedule or specific device events such as login/logout, startup, or switching users.

The value of each sensor is determined by the PowerShell script you create. For examples of what scripts 
you can create, see PowerShell Script Examples for Sensors.

This chapter includes the following topics:

n PowerShell Script Examples for Sensors

n Create a Sensor for Windows Desktop Devices

PowerShell Script Examples for Sensors
When you create a sensor, you must upload a PowerShell script or enter the PowerShell commands in 
the text box provided during configuration. These commands return the values for the sensor attributes.
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PowerShell Script Examples
The following examples contain the settings and code needed. You can also visit https://
code.vmware.com/samples?id=4930 for more Sensors samples.

Note   Any sensor that returns a date-time data type value uses the ISO format.

n Check remaining battery

n Value Type: integer

n Execution Context: User

$battery_remain=(Get-WmiObject win32_battery).estimatedChargeRemaining |

Measure-Object -Average | Select-Object -ExpandProperty Averageecho $battery_remain

n Get Serial Number

n Value Type: String

n Execution Context: User

$os=Get-WmiObject Win32_bios -ComputerName $env:computername -ea silentlycontinue

echo $os.SerialNumber

n Get system date

n Value Type: DateTime

n Execution Context: User

$date_current = get-Date -format s -DisplayHint Date

echo $date_current

n Check if TPM is enabled

n Value Type: Boolean

n Execution Context: Administrator

$obj = get-tpm

echo $obj.TpmReady

n Check if TPM is locked

n Value Type: Boolean

n Execution Context: Administrator

$obj = get-tpm

echo $obj.LockedOut

n Get TPM Locked Out Heal Time

n Value Type: String
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n Execution Context: Administrator

$tpm=get-tpm

echo $tpm.LockoutHealTime

n Check if SMBIOS is present

n Value Type: Boolean

n Execution Context: User

$os = Get-WmiObject Win32_bios -ComputerName $env:computername -ea silentlycontinue

echo $os.SMBIOSPresent

n Check SMBIOS BIOSVersion

n Value Type: Boolean

n Execution Context: User

$os = Get-WmiObject Win32_bios -ComputerName $env:computername -ea silentlycontinue

echo $os.SMBIOSBIOSVersion

n Get BIOS version

n Value Type: String

n Execution Context: User

$os = Get-WmiObject Win32_bios -ComputerName $env:computername -ea silentlycontinue

echo $os.Version

n Get BIOS status

n Value Type: String

n Execution Context: User

$os = Get-WmiObject Win32_bios -ComputerName $env:computername -ea silentlycontinue

echo $os.Status

n Get average CPU usage (%)

n Value Type: Integer

n Execution Context: User

cpu_usage= Get-WmiObject win32_processor | Select-Object -ExpandProperty LoadPercentage

echo $cpu_usage

n Get average memory usage

n Value Type: Integer
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n Execution Context: User

$os = Get-WmiObject win32_OperatingSystem

$used_memory = $os.totalvisiblememorysize - $os.freephysicalmemory

echo $used_memory

n Get average virtual memory usage

n Value Type: Integer

n Execution Context: User

$os = Get-WmiObject win32_OperatingSystem

$used_memory = $os.totalvirtualmemorysize - $os.freevirtualmemory

echo $used_memory

n Get average network usage

n Value Type: Integer

n Execution Context: User

$Total_bytes=Get-WmiObject -class Win32_PerfFormattedData_Tcpip_NetworkInterface

|Measure-Object -property BytesTotalPersec -Average |Select-Object -ExpandProperty Average

echo ([System.Math]::Round($Total_bytes))

n Get average memory usage for a process

n Value Type: String

n Execution Context: User

$PM = get-process chrome |Measure-object -property PM -Average|Select-Object -ExpandProperty 

Average

$NPM = get-process chrome |Measure-object -property NPM -Average|Select-Object -

ExpandProperty Average

echo [System.Math]::Round(($PM+$NPM)/1KB)

n Check if a process is running or not

n Value Type: Boolean

n Execution Context: User

 $chrome = Get-Process chrome -ea SilentlyContinue

            if($chrome){

                echo $true

                }

            else{

                echo $false

                }

n Check if Secure Boot is enabled

n Value Type: Boolean
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n Execution Context: Administrator

try { $bios=Confirm-SecureBootUEFI }

catch { $false }

echo $bios

n Active Network Interface

n Value Type: String

n Execution Context: User

$properties = @(‘Name’,’InterfaceDescription’)

$physical_adapter = get-netadapter -physical | where status -eq "up" 

|select-object -Property $properties

echo $physical_adapter

n Check the PowerShell version

n Value Type: String

n Execution Context: User

$x = $PSVersionTable.PSVersion

echo "$($x.Major).$($x.Minor).$($x.Build).$($x.Revision)"

n Check Battery max capacity

n Value Type: Integer

n Execution Context: User

$max_capacity = (Get-WmiObject -Class "BatteryFullChargedCapacity" -Namespace "ROOT

\WMI").FullChargedCapacity | Measure-Object -Sum | 

Select-Object -ExpandProperty Sum

echo $max_capacity

n Check Battery Charging Status

n Value Type: String

n Execution Context: User

$charge_status = (Get-CimInstance win32_battery).batterystatus

$charging = @(2,6,7,8,9)

if($charging -contains $charge_status[0] -or $charging -contains $charge_status[1] )

{

                echo "Charging"

                }else{  

                echo "Not Charging"

}

n Active Power Management Profile

n Value Type: String
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n Execution Context: Administrator

$plan = Get-WmiObject -Class win32_powerplan -Namespace root\cimv2\power 

-Filter "isActive='true'" 

echo $plan

n Check if Wireless is present

n Value Type: Boolean

n Execution Context: User

$wireless = Get-WmiObject -class Win32_NetworkAdapter -filter "netconnectionid like 'Wi-Fi%'"

    if($wireless){echo $true}

    else {echo $false}

n Get Java version

n Value Type: String

n Execution Context: User

$java_ver = cmd.exe /c "java -version" '2>&1'

echo $java_ver

Create a Sensor for Windows Desktop Devices
Create a sensor to track specific device attributes such as remaining battery, OS version, average CPU 
usage, and more. You can use these sensors with smart groups to provision profiles or create compliance 
policies.

Sensors use PowerShell scripts to gather attribute values. You must create these scripts yourself either 
before creating a sensor or during configuration in the scripting window. Each script should contain only 
one sensor. If a script returns multiple values, VMware Workspace ONE Intelligencereads only the first 
value as the response from the script. If a script returns a null value, VMware Workspace ONE 
Intelligence does not report the sensor.

Prerequisites

You must opt into VMware Workspace ONE Intelligence before using Sensors.

Procedure

1 Navigate to Devices > Provisioning > Custom Attributes > Sensors.

2 Select New > Windows.
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3 Configure the Sensor settings:

Setting Description

Name Enter a name for the sensor. The name must start with a lowercase letter followed 
by alpha-numeric characters and underscores. The name must be between 2-255 
characters.

Description Enter a description for the sensor.

Value Type Select the sensor value type. You can choose between:

n String
n Integar
n Boolean
n Date Time

Triggers Select the trigger for the sensor reporting the device attribute value.

If you select Schedule, the device reports the value to the Workspace ONE UEM 
consolebased on the Windows Sample Schedule.

If you select Event, you can choose a device event to trigger when to record the 
value. The triggers include:

n Login
n Logout
n Startup
n User Switch

 
4 Select Next.

5 Select the Execution Context. This setting controls whether the script executes on a user or system 
context.

6 Select the Execution Architecture. This settings controls whether the script executes on a device 
based on the architecture. You can limit the script to execute on 32-bit devices or 64-bit devices only 
or to automatically run the script based on the device architecture. You can also force the script to 
execute as 32-bit regardless of the device.

7 Upload a Script/Command or write your own in the text box provided.

Results

The sensor is created and appears in the Sensors list view.

What to do next

After creating a sensor, assign the sensor to a smart group by selecting the Assign button on the 
Sensors list view.
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Dell Command | Configure 
Integration 8
Integrate Workspace ONE UEM with Dell Command | Configure to configure device BIOS settings. This 
integration enables the full functionality of the BIOS profile for Windows Desktop devices.

Basics
Integrating with Dell Command | Configure to enhance the device management of Dell enterprise devices. 
If you want to use the configuration packages feature of the BIOS profile, you must add this integration to 
your environment.

Supported Devices
n Dell OptiPlex™ desktop devices

n Dell Precision Workstation™ desktop and laptop devices

n Dell Latitude™ laptop devices

Add Dell Command | Configure to Workspace ONE UEM
To integrate Dell Command | Configure with Workspace ONE UEM, add the program as an internal 
Win32 application in the Workspace ONE UEM. For more information, see Add Dell Command | 
Configure to Workspace ONE UEM.

BIOS Profile
Configure certain BIOS settings on Dell enterprise devices using a BIOS profile. The settings allow you to 
control hardware virtulization and BIOS security. For more information, see Configure a BIOS Profile 
(Windows Desktop).

This chapter includes the following topics:

n Add Dell Command | Configure to Workspace ONE UEM
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Add Dell Command | Configure to Workspace ONE UEM
Add Dell Command | Configure to the Workspace ONE UEM console to enhance management of your 
Dell enterprise devices. If you want to use the configuration packages feature of the BIOS profile, you 
must add this integration to your environment.

Prerequisites

You must enable Software Distribution to push Dell Command | Configure to your devices.

Procedure

1 Navigate to https://www.dell.com/support/article/us/en/04/sln311302/dell-command-configure?
lang=en and download the latest version of Dell Command | Configure.

2 Open the EXE and select Extract. Save the extracted files into a folder.

3 Navigate to the folder and find the MSI file.

4 In the UEM console, add the extracted MSI file as an internal application. Make sure to set the 
Supported Processor Architecture to 32-bit or 64-bit based on the device OS.

5 In the Deployment Options tab, set the Admin Privileges to Yes.

6 Add an assignment of the application to your Dell enterprise devices.

Results

The application downloads and installs on assigned devices and you can now push BIOS profiles to the 
device.
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Dell Command | Monitor 
Integration 9
Integrate Workspace ONE UEM with Dell Command | Monitor to enhance the information Workspace 
ONE UEM collects from enrolled Dell enterprise devices. This integration also allows you to configure 
device BIOS settings.

Basics
Integrating with Dell Command | Monitor to enhance the device management of Dell enterprise devices. 
With this integration, Workspace ONE UEM reports the device battery health status and certain BIOS 
settings.

Supported Devices
n Dell OptiPlex™ desktop devices

n Dell Precision Workstation™ desktop and laptop devices

n Dell Latitude™ laptop devices

BIOS Profile
Configure certain BIOS settings on Dell enterprise devices using a BIOS profile. The settings allow you to 
control hardware virtulization and BIOS security. For more information, see Configure a BIOS Profile 
(Windows Desktop).

Battery Health Status
The overall health of a battery affects the lifespan of a device. With Dell Command | Monitor, monitor the 
health of your Dell enterprise device batteries. This health does not show the current charge of the battery 
but reports status of the ability to hold a charge, time to charge to full, and other factors as a percentage. 
According to Dell, any battery with a status under 25% should be replaced.
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Dell Command | Update 
Overview 10
Dell Command | Update is a client-side management software and part of the Dell Client Command Suite. 
The software enables updating firmware, drivers, and applications for supported Dell devices.

Basics
Integrate with Dell Command | Update to enhance the update management of Dell enterprise devices. 
With this integration, Workspace ONE UEM supports remotely updating firmware, drivers, and other 
applications. You can control when and what types of updates deploy to devices.

Supported Devices
n Dell OptiPlex™ desktop devices

n Dell Precision Workstation™ desktop and laptop devices

n Dell Latitude™ laptop devices

Add Dell Command | Update to Workspace ONE UEM
To integrate Dell Command | Update with Workspace ONE UEM, add the application as an internal Win32 
application in the Workspace ONE UEM Console. For more information, see Add Dell Command | Update 
to Workspace ONE UEM.

Configure the OEM Updates Profile
Configure the OEM Updates profile to enabled Dell Command | Update on end-user devices. For more 
information, see Configure the OEM Updates Profile (Windows Desktop).

This chapter includes the following topics:

n Add Dell Command | Update to Workspace ONE UEM
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Add Dell Command | Update to Workspace ONE UEM
To enhance management of your Dell enterprise devices, add the Dell Command | Update to the 
Workspace ONE UEM Console. The OEM Update profile requires this application before pushing to 
devices.

Prerequisites

You must enable Software Distribution to push Dell Command | Update to your devices.

Procedure

1 Navigate to http://en.community.dell.com/techcenter/enterprise-client/w/wiki/7534.dell-command-
update and download the latest version of Dell Command | Update.

2 In the UEM Console, add the EXE file as an internal application. Make sure to set the Supported 
Processor Architecture to 32-bit or 64-bit based on the device OS.

3 In the Deployment Options tab, set the Admin Privileges to Yes.

4 Add an assignment of the application to your Dell enterprise devices.

Results

The application downloads and installs on assigned devices and you can now push OEM Update profiles 
to the device.
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Windows Desktop Device 
Management 11
After your devices are enrolled and configured, manage the devices using the Workspace ONE ™ 
UEM console. The management tools and functions enable you to keep an eye on your devices and 
remotely perform administrative functions.

You can manage all your devices from the UEM console. The Dashboard is a searchable, customizable 
view that you can use to filter and find specific devices. This feature makes it easier to perform 
administrative functions on a particular set of devices. The Device List View displays all the devices 
currently enrolled in your Workspace ONE UEM environment and their status. The Device Details page 
provides device-specific information such as profiles, apps, Workspace ONE Intelligent Hub version and 
which version of any applicable OEM service currently installed on the device. You can also perform 
remote actions on the device from the Device Details page that are platform-specific.

This chapter includes the following topics:

n Device Dashboard

n Device List View

n Windows Desktop Device Details Page

n Workspace ONE Assist

n Manage Your Microsoft HoloLens Devices

n Product Provisioning Overview

Device Dashboard
As devices are enrolled, you can manage them from the Device Dashboard in Workspace ONE UEM 
powered by AirWatch.

The Device Dashboard provides a high-level view of your entire fleet and allows you to act on individual 
devices quickly.

You can view graphical representations of relevant device information for your fleet, such as device 
ownership type, compliance statistics, and platform and OS breakdowns. You can access each set of 
devices in the presented categories by selecting any of the available data views from the Device 
Dashboard.
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From the List View, you can take administrative action: send messages, lock devices, delete devices, 
and change groups associated with the device.

n Security – View the top causes of security issues in your device fleet. Selecting any of the doughnut 
charts displays a filtered Device List view comprised of devices affected by the selected security 
issue. If supported by the platform, you can configure a compliance policy to act on these devices.

n Compromised – The number and percentage of compromised devices (jailbroken or rooted) in 
your deployment.

n No Passcode – The number and percentage of devices without a passcode configured for 
security.

n Not Encrypted – The number and percentage of devices that are not encrypted for security. This 
reported figure excludes Android SD Card encryption. Only those Android devices lacking disc 
encryption are reported in the donut graph.

Ownership – View the total number of devices in each ownership category. Selecting any of the bar 
graph segments displays a filtered Device List view comprised of devices affected by the selected 
ownership type.

n Last Seen Overview/Breakdown – View the number and percentage of devices that have recently 
communicated with the Workspace ONE UEM MDM server. For example, if several devices have not 
been seen in over 30 days, select the corresponding bar graph to display only those devices. You can 
then select all these filtered devices and send them a message requesting that they check in.

n Platforms – View the total number of devices in each device platform category. Selecting any of the 
graphs displays a filtered Device List view comprised of devices under the selected platform.

n Enrollment – View the total number of devices in each enrollment category. Selecting any of the 
graphs displays a filtered Device List view comprised of devices with the selected enrollment status.

n Operating System Breakdown – View devices in your fleet based on operating system. There are 
separate charts for each supported OS. Selecting any of the graphs displays a filtered Device List 
view comprised of devices running the selected OS version.

Device List View
Use the Device List View in Workspace ONE UEM powered by AirWatch to see a full listing of devices in 
the currently selected organization group.
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The Last Seen column displays an indicator showing the number of minutes elapsed since the device 
has checked-in. The indicator is red or green, depending on how long the device is inactive. The default 
value is 480 minutes (8 hours) but you can customize this by navigating to Groups & Settings > All 
Settings > Devices & Users > General > Advanced and change the Device Inactivity Timeout (min) 
value.

Select a device-friendly name in the General Info column at any time to open the details page for that 
device. A Friendly Name is the label you assign to a device to help you differentiate devices of the same 
make and model.

Sort by columns and configure information filters to review activity based on specific information. For 
example, sort by the Compliance Status column to view only devices that are currently out-of-
compliance and target only those devices. Search all devices for a friendly name or user name to isolate 
one device or user.

Customize Device List View Layout
Display the full listing of visible columns in the Device List view by selecting the Layout button and select 
the Custom option. This view enables you to display or hide Device List columns per your preferences.

There is also an option to apply your customized column view to all administrators at or below the current 
organization group (OG). For instance, you can hide 'Asset Number' from the Device List views of the 
current OG and of all the OGs underneath.

Once all your customizations are complete, select the Accept button to save your column preferences 
and apply this new column view. You can return to the Layout button settings at any time to tweak your 
column display preferences.
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Some notable device list view custom layout columns include the following.

n SSID (Service Set Identifier or Wi-Fi network name)

n Wi-Fi MAC Address

n Wi-Fi IP Address

n Public IP Address

Search in Device List View
You can search for a single device for quick access to its information and take remote action on the 
device.

To run a search, navigate to Devices > List View, select the Search List bar and enter a user name, 
device-friendly name, or other device-identifying element. This action initiates a search across all devices, 
using your search parameter, within the current organization group and all child groups.

Windows Desktop Device Details Page
Use the Device Details page to track detailed device information for Windows Desktop devices and 
quickly access user and device management actions.

You can access Device Details by selecting a Friendly Name from the Device List View, using one of the 
Dashboards, or with any of the search tools.

From the Device Details page, you can access specific device information broken into different menu 
tabs. Each menu tab contains related device information depending on your Workspace ONE UEM 
deployment.

Windows Notification Service Details
You can see the status of device communication with the Windows Notification Service(WNS) from the 
Network tab of the Device Details page. The WNS supports sending your devices notifications. If a device 
is not currently online, the service caches the notifications until the device connects again.

The WNS statuses include the following:

n WNS Server Status - displays the state of your WNS server.

n Last WNS Renewal Request - The date and time of last attempt made to renew the Windows 
Notification Services (WNS) connection with the device. This connection allows Workspace ONE 
UEM to query and push policies to the device in real time (Networking, Battery Sense, and Data 
Sense conditions permitting). For more information on WNS, please refer to https://
docs.microsoft.com/en-us/windows/client-management/mdm/push-notification-windows-mdm.

n Next WNS Get Request: - The date and time of the next scheduled attempt to renew the connection 
between WNS and the device.

n WNS Channel URI - The WNS communication endpoint that devices and Workspace ONE UEM use. 
This endpoint uses the following format: https://*.notify.windows.com/?token=_{TOKEN}
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Remote Actions
The More Actions drop-down on the Device Details page enables you to perform remote actions over 
the air to the selected device.

The actions vary depending on factors such as the device platform, Workspace ONE UEM console 
settings, and enrollment status:

n Add Tag – Assign a customizable tag to a device, which can be used to identify a special device in 
your fleet.

n Apps (Query) – Send an MDM query command to the device to return a list of installed applications.

The Apps (Query) action requires an active enrolled user login.

n Certificates (Query) – Send an MDM query command to the device to return a list of installed 
certificates.

The Certificates (Query) requires an active enrolled user login.

n Change Organization Group – Change the device's home organization group to another existing 
OG. Includes an option to select a static or dynamic OG.

n If you want to change the organization group for multiple devices at a time, you must select 
devices for the bulk action using the Block selection method (using the shift-key) instead of the 
Global check box (next to the Last Seen column heading in the device list view).

n Request Device Log – Request the debug log for the selected device, after which you can view the 
log by selecting the More tab and selecting Attachments > Documents. You cannot view the log 
within the Workspace ONE UEM console. The log is delivered as a ZIP file that can be used to 
troubleshoot and provide support.

When you request a log, you can select to receive the logs from the System or the Hub. System 
provides system-level logs. Hub provides logs from the multiple agents running on the device.

Android Only: you can retrieve detailed logs from corporate-owned Android devices and view them 
in the console to resolve issues on the device quickly.

n Delete Device – Delete and unenroll a device from the console. Sends the enterprise wipe command 
to the device that gets wiped on the next check-in and marks the device as Delete In Progress on 
the console. If the wipe protection is turned off on the device, the issued command immediately 
performs an enterprise wipe and removes the device representation in the console.

n Device Information (Query) – Send an MDM query command to the device to return information on 
the device such as friendly name, platform, model, organization group, operating system version, and 
ownership status.

n Device Wipe – Send an MDM command to wipe a device clear of all data and operating system. This 
action cannot be undone.

n For Windows Desktop Devices, you can select the type of device wipe.

• Wipe - This option wipes the device of all content.
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• Wipe Protected - This option is similar a normal device wipe but the device end user cannot 
circumvent the action. The Wipe Protected command keeps trying to reset the device until it 
is successful. In some device configurations, this command can leave the device unable to 
start.
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• Wipe and Persist Provisioning Data - This option wipes the device but specifies that 
provisioning data be backed up to a persistent location. After the wipe runs, the provisioning 
data is restored and applied to the device. The provisioning folder is saved. You can find the 
folder by navigating on the device to %ProgramData%\Microsoft\Provisioning.

n Edit Device – Edit device information such as Friendly Name, Asset Number, Device Ownership, 
Device Group Device Category.

n Enterprise Wipe – Enterprise Wipe a device to unenroll and remove all managed enterprise 
resources including applications and profiles. This action cannot be undone and re-enrollment is 
required before Workspace ONE UEM can manage this device again. This device action includes 
options to prevent future re-enrollment and a Note Description text box for you to add information 
about the action.

n Enterprise Wipe is not supported for cloud domain-joined devices.

n Enterprise Reset – Enterprise Reset a device to factory settings, keeping only the Workspace ONE 
UEM enrollment.

n Windows Desktop Only: Enterprise Reset restores a device to a Ready to Work state when a 
device is corrupted or has malfunctioning applications. It reinstalls the Windows OS while 
preserving user data, user accounts, and managed applications. The device will resync auto-
deployed enterprise settings, policies, and applications after resync while remaining managed by 
Workspace ONE.

n Lock Device – Send an MDM command to lock a selected device, rendering it unusable until it is 
unlocked.

Important   When locking a device, an enrolled user must be signed into the device for the command to 
process. The lock command locks the device and any user signed in must reauthenticate with Windows. 
If an enrolled user is signed-in to the device, a lock device command locks the device. If an enrolled user 
is not signed in, the lock device command is not processed.

n Query All – Send a query command to the device to return a list of installed applications (including 
Workspace ONE Intelligent Hub, where applicable), books, certificates, device information, profiles, 
and security measures.

n Reboot Device – Reboot a device remotely, reproducing the effect of powering it off and on again.

n Remote Management – Take control of a supported device remotely using this action, which starts a 
console application that enables you to perform support and troubleshoot on the device. Android 
devices require Remote Control Service to be installed on the device.

n Security (Query) – Send an MDM query command to the device to return the list of active security 
measures (device manager, encryption, passcode, certificates, and so on).

n Send Message – Send a message to the user of the selected device. Select between Email, Push 
Notification (through AirWatch Cloud Messaging), and SMS.
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Workspace ONE Assist
Workspace ONE Assist, previously named Advanced Remote Management (ARM), allows you to connect 
remotely to end-user devices so you can help with troubleshooting and maintenance. The Assist Server 
facilitates communication between the Workspace ONE UEM powered by AirWatch and the "host" device.

For more information, see VMware Workspace ONE Assist Documentation on docs.vmware.com.

Manage Your Microsoft HoloLens Devices
Workspace ONE UEM supports enrolling and managing Microsoft HoloLens devices. You must use the 
native enrollment and management functionality to manage your Windows HoloLens devices.

Prepare Your HoloLens Devices for Workspace ONE UEM 
Management
Before you can manage your HoloLens devices using Workspace ONE UEM, you must apply the 
Licensing XML file to the devices. If you are using HoloLens 1 devices, you must apply the file before 
enrolling. For more information on applying licensing, see https://docs.microsoft.com/en-us/hololens/
hololens1-upgrade-enterprise. This step is not required for HoloLens 2 devices.

Enroll Your HoloLens Devices
You can enroll your Microsoft HoloLens devices into Workspace ONE UEM using native management 
functionality. You must use native Windows 10 enrollment methods as HoloLens devices do not support 
Workspace ONE Intelligent Hub functionality. For more information, see Native MDM Enrollment for 
Windows Desktop.

Manage Your HoloLens Devices
After enrolling, you can apply supported profiles to your HoloLens devices using Workspace ONE UEM. 
For a list of the supported CSP, see https://docs.microsoft.com/en-us/windows/client-management/mdm/
configuration-service-provider-reference#hololens.

Product Provisioning Overview
Product provisioning enables you to create, through Workspace ONE ™ UEM, products containing 
profiles, applications, files/actions, and event actions (depending on the platform you use). These 
products follow a set of rules, schedules, and dependencies as guidelines for ensuring your devices 
remain up-to-date with the content they need.

Product provisioning also encompasses the use of relay servers. These servers are FTP(S) servers 
designed to work as a go-between for devices and the UEM console. Create these servers for each store 
or warehouse to store product content for distribution to your devices.

For more information, see Product Provisioning documentation.
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