If you are having problems with the Reports feature, consider troubleshooting your problem before calling support. These troubleshooting steps address the most common problems with the Reports feature in Workspace ONE UEM powered by AirWatch.
Problem
Reports do not initiate.
Cause
The background processing service is not running.
Solution
Follow the instructions in Enable Background Processing Service.
Problem
Errors occasionally occur during report processing.
Cause
Various causes.
Solution
Refer to the following logs.
- Web Console Logs – For troubleshooting purpose, refer to the web console logs when any console error occurs. These logs can be referred for both new and existing reports. Logs can be found here:
\AirWatch\Logs\WebConsole\WebConsoleLog.txt
- Detailed error logs about new reports – Refer to logs found here:
\AirWatch\Logs\Services\BackgroundProcessorServiceLogFile.txt
- Detailed error logs about old reports – Refer to the reports server logs found here:
\Microsoft SQL Server\MSRS12.ABC\Reporting Services\LogFiles
Problem
Reports fail to generate.
Cause
The size of the report exceeds the maximum size allowed of 4 GB.
Solution
Try to limit the size of the report by following the suggestions in Generate Reports.