If you are having problems with the Reports feature, consider troubleshooting your problem before calling support. These troubleshooting steps address the most common problems encountered in the Reports feature in Workspace ONE UEM.

Problem

Reports do not initiate.

Cause

The background processing service is not running.

Solution

Follow the instructions in the section below, entitled Enable Background Processing Service.

Problem

Errors occasionally occur during report processing.

Cause

Various causes.

Solution

Refer to the following logs.
  • Web Console Logs – For troubleshooting purpose, refer to the web console logs when any console error occurs. Refer to these logs for both new and existing reports. Logs can be found here:
    \AirWatch\Logs\WebConsole\WebConsoleLog.txt
  • Detailed error logs about new reports – Refer to logs found here:
    \AirWatch\Logs\Services\BackgroundProcessorServiceLogFile.txt
  • Detailed error logs about old reports – Refer to the reports server logs found here:
    \Microsoft SQL Server\MSRS12.ABC\Reporting Services\LogFiles

Problem

Reports fail to generate.

Cause

The size of the report exceeds the maximum size allowed of 4 GB.

Solution

Try to limit the size of the report by following the suggestions in Generate Reports.

Enable Background Processing Service

Workspace ONE UEM Reports require the background processing service running on the console server. The installation process enables this process but if it is not running, you must enable it to use Workspace ONE UEM Reports.

Each console server requires the background processing service. Each server processes reports and writes them to their respective queue before sending them to the database, file storage, or reports storage.

  1. Press Windows key + R on the console server box.
  2. Run the command "services.msc".

    This partial screenshot shows the Run dialog box that displays when you invoke the Windows-R keyboard combo. This lets you run programs by name.

    A screen displays listing all services running on the Console Server box.

  3. Locate Airwatch Background Processor Service and select Properties.

    This screenshot shows the Services app with the Airwatch Background Processor Service highlighted.

    A screen displays showing if the service status.

  4. Make sure that status of this service is Running. If status is Stopped, ensure to Start the service.

    This screenshot shows the Properties of the Airwatch Background Processor Service, showing that it is running and the Stop button is enabled.

    This screenshot shows the Properties of the Airwatch Background Processor Service, showing that it is not running, the Stop button is deactivated and the Start button is enabled.