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Introduction to the Windows Rugged Platform
Workspace ONE UEM provides you with a robust set ofmobility management solutions for enrolling, securing,
configuring, and managing yourWindows Rugged deployment. Through the UEM console, you have several tools and
features for managing the entire lifecycle of corporate and employee-owned devices.

Windows Mobile and Windows CE devices and their operating systems are proven performers in rugged environments
like warehouses, courier services, and healthcare facilities. These devices represent most mobile devices in these
environments and can perform many functions such as sales, inventory, scanners, and more. With theWorkspace ONE
UEM solution, you can manage these devices and integrate them with your other mobile platforms, which give you a
central location for mobile devicemanagement.

Windows Rugged Requirements
Before reading this guide, gather and prepare the requirements Workspace ONE UEM requires for Windows Rugged
devices.

Platforms Supported

l Windows CE 5, 6, and 7

l Windows Mobile 5.x

l Windows Mobile 6.1

l Windows Mobile 6.5 (Professional and Standard)

l Windows Embedded 6.5

Agents and Versions Supported

Workspace ONE UEM recommends using the 5.X.X version of the AirWatch Agent for Windows Rugged. Workspace ONE
UEM no longer supports bug reports, code changes, or new enhancements for previous version of the AirWatch Agent
for Windows Rugged.

Chapter 1: Overview
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Product Provisioning Overview
Product provisioning enables you to create, through Workspace ONE UEM, products containing profiles, applications,
and files/actions (depending on the platform you use). These products follow a set of rules, schedules, and dependencies
as guidelines for ensuring your devices remain up-to-date with the content they need.

Product provisioning also encompasses the use of relay servers. These servers are FTP(S) servers designed to work as a
go-between for devices and the UEM console. Create these servers for each store or warehouse to store product content
for distribution to your devices.

Another product provisioning feature is the staging methods of enrollment. Depending on the device type, you can
perform device staging that quickly enrolls a device and downloads the AirWatch Agent, Wi-Fi profile, and any other
important content. Themethods of staging a device vary by platform.

Chapter 2: Product Provisioning for Windows Rugged Devices
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Windows Rugged Enrollment
Enroll Windows Rugged devices into Workspace ONE UEM to access internal content and features using Web enrollment.
Web enrollment directs the user to an enrollment URL to complete enrollment and download the AirWatch Agent.

Device enrollment is required for all Windows Rugged devices you want managed by Workspace ONE UEM.

If you use the Product Provisioning functionality, you can enroll your Windows Rugged devices through additional
enrollment methods. These additional methods, including sideload staging, require product provisioning.

Enrollment Basics

TheWindows Rugged platform covers Windows CE and Windows Mobile devices. For more information on the
supported devices, seeWindows Rugged Requirements on page 5

Windows Rugged enrollment uses either the web enrollment method or the Product Provisioning staging functionality.

Web Enrollment

The web enrollment method for Windows Rugged devices taks end users to enter enrollment credentials into the web
browser on the device. For more information, see Enroll Windows Rugged Devices Through Web Enrollment on page 9.

To unenroll Windows Rugged devices, you must perform an EnterpriseWipe in the UEM console followed by manually
uninstalling the AirWatch Agent. For more information, see Unenroll Windows Rugged Devices on page 10.

AirWatch Cab Creator

The AirWatch Cab Creator for Windows Rugged allows you to create custom CAB files for use on Windows Rugged
devices. These custom CAB files consist of any files or applications you add from your computer. Simplify the install
process combining all the files and applications you want on yourWindows Rugged device into a custom CAB file. For
more information, see Create a Custom CAB on page 11.

Enroll Windows Rugged Devices Through Web Enrollment
Simplify device enrollment with Web enrollment instead of downloading the AirWatch Agent manually. Send end users to
a URL to enroll their devices into Workspace ONE UEM.

1. Go to the enrollment URL using the native browser on the device.

2. Enter the applicableWorkspace ONE UEM solution information in theGroup ID, Username, and Password text
boxes.

3. Optionally, select theDevice Ownership type (Employee Owned, Corporate-Dedicated, or Corporate-Shared) and
select Enroll.

4. Accept the Terms of Use if this option is configured.

5. Select Accept to download the AirWatch Agent to the device.

6. Select Continue to complete the enrollment.

Chapter 3: Windows Rugged Device Enrollment
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Unenroll Windows Rugged Devices
When it is time to unenroll a device fromWorkspace ONE UEM, ensure that you choose the best method for your
situation. Unenroll devices using enterprise wipe from the UEM console or remove the AirWatch Agent from the end-user
device.

Enterprise Wipe

Enterprise wipe allows you to clear corporate data, applications, and profiles from a device without removing personal
data. This action allows you to unenroll an employee-owned device without clearing the personal data.

To perform an enterprise wipe from the UEM console:

1. Navigate to Devices > List View and select theWindows Rugged device you want to unenroll.

2. From the Device Detail page, select theMore option.

3. Select the Enterprise Wipe option underManagement.

4. Enter your Admin PIN to confirm the EnterpriseWipe.

The device undergoes an enterprise wipe to remove corporate data and unenroll the device fromWorkspace ONE UEM.

You can also perform an enterprise wipe from the device through the AirWatch Agent. To perform a device-side
enterprise wipe:

1. On the device, open the AW Diagnostics app.

2. Navigate to the Advanced tab.

3. Select Enterprise Wipe.

The device removes corporate data and unenrolls fromWorkspace ONE UEM.

Uninstalling the AirWatch Agent

You can also unenroll a device fromWorkspace ONE UEM by uninstalling the AW Core Agent CAB. To unenroll by
uninstalling the AirWatch Agent:

1. On the device, navigate to Settings > Remove Programs.

2. Find the AW Core Agent CAB and uninstall the application.

While the device removes corporate data, the device remains enrolled with Workspace ONE UEM. This uninstall method
is not the preferred method.

AirWatch Cab Creator for Windows Rugged
The AirWatch Cab Creator for Windows Rugged allows you to create custom CAB files for use on Windows Rugged
devices. These custom CAB files consist of any files or applications you add from your computer.

Simplify the install process combining all the files and applications you want on yourWindows Rugged device into a
custom CAB file. You can import CAB files into your own custom CAB file. This feature allows you to create one custom
CAB file that contains all the CAB files you must install on a device. You can also use the AirWatch Cab Creator to edit any

Chapter 3: Windows Rugged Device Enrollment
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existing CAB file on your PC. The AirWatch Cab Creator also supports importing files that you can then convert to CAB file
upon saving.

Create a Custom CAB
Simplify installation of files onto yourWindows Rugged devices by creating custom CAB files using the AirWatch Cab
Creator for Windows Rugged. These custom CABS can contain your business files or the files necessary to upgrade your
Windows Rugged devices.

Requirements

To use the AirWatch Cab Creator for Windows Rugged, you must meet the following requirements:

l AWindows device running Windows 7+

l .NET Framework 4.5

To create a custom CAB file:

1. Download the "AirWatch Cab Creator" for Windows Rugged from themyAirWatch documentation repository.

2. Unzip the file to your preferred directory.

Chapter 3: Windows Rugged Device Enrollment
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3. Double-click CabBuilder.exe to start the app.

4. Navigate to a file on your Local Drive you want to add to the custom CAB file. You can select a different drive by
selecting Select Drive.

5. Enter an Application Name. This text box is the name of the CAB file after installation.

Remember the name for use in Uninstall Manifest items.

6. Select the file and drag it to theDevice Drive pane.

To create a folder on the device drive, right-click the root drive and select Add Folder.

7. Repeat Step 5 for each file or application you want to add to the custom CAB file.

8. (Optional) Add an existing CAB file to your custom CAB file by selecting Import a CAB File.

9. Select Build a CAB File to save the CAB file and select a name for the file.

Chapter 3: Windows Rugged Device Enrollment
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10. Select Save to create a custom CAB file.

Chapter 3: Windows Rugged Device Enrollment
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Windows Rugged Profiles Overview
Profiles are the primary means to manage devices. Configure profiles so yourWindows Rugged devices remain secure
and configured to your settings.

Overview

You can think of profiles as the settings and rules that, when combined with compliance policies, help you enforce
corporate rules and procedures. They contain the settings, configurations, and restrictions that you want to enforce on
devices.

The individual settings you configure, such as the settings for Wi-Fi, VPN, and passcodes, are payloads. Consider
associating only one payload per profile. Createmultiple profiles for the different settings you want to establish.

Device Access

Some device profiles configure the settings for accessing aWindows Phone device. Use these profiles to ensure that
access to a device is limited only to authorized users.

Some examples of device access profiles include:

l Secure a device with a Passcode profile. For more information, see Create a Passcode Profile (Windows Rugged) on
page 17.

l Configure the device launcher and layout. For more information, see Launcher Profile (Windows Rugged) on page 28.

Device Security

Ensure that yourWindows Phone devices remain secure through device profiles. These profiles configure the native
Windows security features or configure corporate security settings on a device through Workspace ONE UEM.

Some examples of device security profiles include:

l Use aWi-Fi profile to connect enrolled devices to your corporateWi-Fi without sending the network credentials to
users. For more information, see DynamicWi-Fi Profiles (Windows Rugged) on page 18.

l Ensure access to internal resources for your devices with the VPN profile. For more information, see Create a VPN
Profile (Windows Rugged) on page 34.

Device Configuration

Configure the various settings of your Windows Phone devices with the configuration profiles. These profiles configure
the device settings to meet your business needs.

Some examples of device configuration profiles include:

l Set up an Exchange account on a device with an Exchange ActiveSync profile. For more information, see Configure an
Exchange ActiveSync Profile (Windows Rugged) on page 25.

l Configure the device time zone. For more information, see Create a Time Zone Profile (Windows Rugged) on page 37.

Profiles and Product Provisioning

Chapter 4: Windows Rugged Device Profiles
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Create a Passcode Profile (Windows Rugged)
Deploy a Passcode payload to require users to protect their devices with passcodes each time they return from an idle
state. This action ensures that all sensitive corporate information on managed devices remains protected.

Important: Passcode payloads apply only to Windows Rugged devices and not Windows CE devices.

To enforce a Passcode profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Passcode profile.

5. Configure the Passcode settings:

Settings Descriptions

Maximum Passcode Age Requires users to renew passcodes at selected intervals.

Passcode Sets a specific passcode for the device.

Maximum Passcode Length Sets themaximum number of characters a passcodemay be.

Minimum Passcode Length Sets theminimum number of characters a passcodemust be.

Minimum Number of Upper Case
Letter

Sets theminimum number of upper case letters a passcodemust
contain.

Minimum Number of Lower Case
Letter

Sets theminimum number of lower case letters a passcodemust
contain.

Minimum Number of Numerical Digits Sets theminimum number of numerical digits a passcodemust contain.

Grace period for device lock Specifies a period of inactivity before locking a device.

Maximum Number of Failed Attempts Sets a limit on failed passcode attempts before wiping a device.

6. Select Save & Publish to push the profile to devices.

Create a Restrictions Profile (Windows Rugged)
Deploy a Restrictions payload to restrict the options end users have on devices. Restrictions allow you to ensure that
your device is secure by controlling what an end user can use to save and store data.

Important: You can use a Restriction payload only on Windows Rugged devices and not on Windows CE devices.

To enforce a Restrictions profile:

Chapter 4: Windows Rugged Device Profiles
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1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Restrictions profile.

5. Configure the Restriction settings:

Settings Descriptions

Allow Camera Enable to allow access to the camera application.

Allow External Storage Enable to allow use of external storagememory.

Remove Encryption on External Storage Enable to allow the removal of encryption on external storage.

Enable On-Device Encryption Enable to allow encryption on the device.

Allow Bluetooth Enable to allow the use of Bluetooth.

6. Select Save & Publishwhen you are finished to push the profile to devices.

Dynamic Wi-Fi Profiles (Windows Rugged)
Using custom attributes, you can create dynamicWi-Fi profiles that allow you to configure deviceWi-Fi settings across
smart groups and OGs without creating multiple profiles. The custom attributes can use device-side values or override
device values with a specific value.

This feature works best when managing many different Wi-Fi networks across your mobile fleet. When updating the
access credentials for all your Wi-Fi networks, import a batch of custom attributes (using the .csv batch import process).
Using the Device Custom Attribute Values template, you can upload specific values to individual devices. This process
allows you to update the credentials across your mobile fleet quickly without having to create hundreds of different Wi-Fi
profiles.

DynamicWi-Fi profiles allow you to specify certain text boxes in the profile as a dynamic value. For example, the Service
Set Identifier can be set to a dynamic value so devices can use their own value as opposed to one service set identifier
per profile. If you have devices in one OG that use different Wi-Fi credentials, use dynamicWi-Fi profiles to create one
profile that configures the different settings required.

To use a custom attribute in yourWi-Fi Profile, enable the check box next to a text box. Enabling the text box allows you
to select the custom attribute, enter a default value, and set the default value to override device values for the attribute.

For more information on custom attributes and instructions for creating them, see Custom Attributes Overview on page
51.

Configure a Wi-Fi Profile (Windows Rugged)
Create aWi-Fi profile to connect devices to hidden, encrypted, or password-protected corporate networks. Wi-Fi profiles
are useful for end users who need access to multiple networks or for configuring devices to connect automatically to the
appropriate wireless network.

Chapter 4: Windows Rugged Device Profiles
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Important: Zero Wireless Config is not available for Windows CE devices except Psion CE devices. You can provision
Wi-Fi profiles using Zero Wireless Config to Psion CE devices only but not any other Windows CE devices.

To configure aWi-Fi profile, follow the steps detailed below:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select theWi-Fi profile.

5. Configure theWi-Fi settings:

Settings Descriptions

Network Adapter
Type

Select the adapter type.

l Standard Microsoft (Zero Wireless Config).

l Motorola Fusion – For more information, see Configure a Motorola Fusion Wi-Fi Profile
(Windows Rugged) on page 20.

l Honeywell DeviceScope – Network Adapter Type for Honeywell devices.

Service Set
Identifier

Enter an identifier that is associated with the name (SSID) of the desired Wi-Fi network.

Wi-Fi Meta
Network

Choose whether you are connecting through a proxy withWork or connecting directly to the
Internet.

RFBand Honeywell Network Adapter Type only.

IP Addressing
Mode

Select the type of IP Addressing mode used.

Operating Mode Select the type of operating mode used.

Security Type Select your Wi-Fi security type.

The type selected determines which additional fields display

Authentication
Type

Select the Authentication type to be used with enterprise applications.

Encryption Select the encryption type for traffic over theWi-Fi connection.

Pre Shared Key Enter the Pre Shared Key for yourWi-Fi.

Displays when Security type is set toWPA Personal orWPA2 Personal.

Domain Name Enter the Domain name for your certificates.

Displays when Security type is set toWPA Enterprise orWPA2 Enterprise.

Chapter 4: Windows Rugged Device Profiles
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Settings Descriptions

Username Enter the username for the domain.

Displays when Security type is set toWPA Enterprise orWPA2 Enterprise.

Password Enter the password used for the domain.

Displays when Security type is set toWPA Enterprise orWPA2 Enterprise.

Identity
Certificate

Select the certificate used to identify the end user to the server.

Server Certificate Select the certificate used to identify the server to the end user.

6. Select Save & Publish to push the profile to devices.

Configure a Motorola Fusion Wi-Fi Profile (Windows Rugged)
TheWindows Rugged Wi-Fi profile allows you to specify the network adapter to support theMotorola Fusion type of
network adapter. These settings allow you to control when and howoften the device connects to Wi-Fi.

The settings differ based on theMotorola adapter type selected.

Note: The settings that follow are based on the specific Motorola adapter type selected.

To configure a Motorola Fusion Wi-Fi profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select theWi-Fi profile.

5. Configure theWi-Fi settings:

Settings Descriptions

Network Adapter Type Set to Motorola Fusion. For other adapter types, see Configure aWi-
Fi Profile (Windows Rugged) on page 18.

Motorola Adapter Type These options change the text boxes available. Text boxes that are
tied to a specific Motorola adapter type are noted.

l WLANFusionPublic-specific settings on page 20

l WLANFusion3xPublic on page 22

l WLANFusionX2Public on page 23

WLANFusionPublic-specific settings

Set Fusion Options Set to Yes to list extra network options.

Chapter 4: Windows Rugged Device Profiles

20

VMware AirWatchWindows Rugged Platform Guide | v.2018.05 | May 2018

Copyright©2018 VMware, Inc. All rights reserved.



Settings Descriptions

Enable 80211d Set to Change to enable 802.11d wireless specification for operation in
extra regulatory domains.

Change Regulatory Country Code Set to Change to choose the Country Code for the device.

Set RFBand Set to Change to specify the RF Band for the device.

Enable Auto Time Config Set to Change to enable automatic time configuration.

Set FAPI Access Password Set to Change to choose a FAPI access code.

Set FAPI Access Code Enter the FAPI Access Code you want for the device.

Set Profile Configuration Set to Yes to set the profile settings.

Service Set Identifier remotely and securely

Profile Country Code Enter the country code to use with the profile.

Wi-Fi Meta Network Choose whether you are connecting through a proxy withWork or
connecting directly to the Internet.

IP Addressing Mode Choose to useDHCP or Static IP Addressing. If you choose Static,
enter the settings for your static IP address.

Disable all other Profiles Set to Yes to disable all other Wi-Fi profiles on the device.

Operating Mode Select the operating mode.

Transmit Power Level Choose the transmit power level.

Power Level Select the balance of power use.

Security Type Choose the encryption type for the network connection.

Authentication Type Choose an authentication type to be used with enterprise
applications. Additional text boxes display depending on the type
chosen.

The FAST authentication types (EAP-FAST-MSCHAPV2, EAP-FAST-TLS,
and EAP-FAST-GTC) add the following additional text boxes:

l Auto PAC Refreshing

l Auto PAC Provisioning

l PACFile Name

l PACFile Password

l Use GTC Token

Encryption Select the encryption type used for theWi-Fi connection

Pre Shared Key Enter the Pre Shared Key used for theWi-Fi Connection.

Change CCKM Setting Select change to change the CCKM Mode.

Chapter 4: Windows Rugged Device Profiles
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Settings Descriptions

Domain Name Enter the domain name used in authentication.

Username Enter the user name used for authentication.

Password Enter the password used for authentication.

Identity Certificate Set to Other and enter the certificate name used for authentication.

Server Certificate Set to Other and enter the certificate name used for authentication.

WLANFusion3xPublic

Set Fusion Options Set to Yes to list extra network options.

Enable 80211d Set to Change to enable 802.11d wireless specification for operation in
additional regulatory domains.

Change Regulatory Country Code Set to Change to choose the Country Code for the device.

Set RFBand Set to Change to specify the RF Band for the device.

Enable Auto Time Config Set to Change to enable automatic time configuration.

Set FAPI Access Password Set to Change to choose a FAPI access code.

Set FAPI Access Code Enter the FAPI Access Code for the device.

Set WLAN Management Mode Set to Change to configure theWLANManagement Mode settings.

WLAN Management Mode Select either theWireless Zero Config or Fusion Management State
modes.

Set Profile Configuration Set to Yes to set the profile settings.

Handle Error By Choose to Ignore Error or Stop On Error.

Set Current Management Mode Option Set to Change to configure themanagement mode.

Apply Profile Regardless of Device's
Current Management Mode
Configuration

Enable to apply theWi-Fi profile regardless of current management
mode.

Service Set Identifier Enter the identification of the wireless network the device connects
with.

Profile Country Code Enter the country code to use with the profile.

Wi-Fi Meta Network Choose whether you are connecting through a proxy withWork or
connecting directly to the Internet.

IP Addressing Mode Choose to useDHCP or Static IP Addressing. If you choose Static,
enter the settings for your static IP address.

Disable all other Profiles Set to Yes to disable all other Wi-Fi profiles on the device.

Chapter 4: Windows Rugged Device Profiles
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Settings Descriptions

Operating Mode Select the operating mode.

Transmit Power
Level

Choose the transmit power level.

Adhoc Channel Select the Ad Hoc channel the devices use.

Encryption
Select the encryption type for theWi-Fi
network.

Pre Share Key
Enter the Pre Shared Key used for the
network.

Transmit Power Level Choose the transmit power level.

Power Level Select the balance of power use.

Security Type Choose the encryption type for the network connection.

Pre Shared Key Enter the Pre Shared Key used for theWi-Fi Connection.

Change CCKM Setting Select change to change the CCKM Mode.

Domain Name Enter the domain name used in authentication.

Username Enter the user name used for authentication.

Password Enter the password used for authentication.

Identity Certificate Set to Other and enter the certificate name used for authentication.

Server Certificate Set to Other and enter the certificate name used for authentication.

WLANFusionX2Public

Enable 80211d Set to Change to enable 802.11d wireless specification for operation in
additional regulatory domains.

Set RFBand Set to Change to specify the RF Band for the device.

Enable Auto Time Config Set to Change to enable automatic time configuration.

Set FAPI Access Password Set to Change to choose a FAPI access code.

Enable IPv6 Set to Change to enable IPv6 settings.

Set WLAN Management Mode Set to Change to configure theWLANManagement Mode settings.

WLAN Management Mode Select either theWireless Zero Config or Fusion Management State
modes.

Enable FIPS Mode Set to Change to enable FIPS mode.

Change PreAuth Enable PreAuth to allow access points to authorize devices before
they officially switchover to the new access point.

Reset Fusion Options Set to Reset to reset the device's Fusion options when pushing this
profile to the device.

Chapter 4: Windows Rugged Device Profiles
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Settings Descriptions

Reset Fusion Data Store Set to Reset to reset the Fusion data store on a device.

Set Profile Configuration Set to Yes to set the profile settings.

Handle Error By Choose to Ignore Error or Stop On Error.

Service Set Identifier Enter the identification of the wireless network the device connects
with.

Profile Country Code Enter the country code to use with the profile.

Wi-Fi Meta Network Choose whether you are connecting through a proxy withWork or
connecting directly to the Internet.

IP Addressing Mode Choose to useDHCP or Static IP Addressing. If you choose Static,
enter the settings for your static IP address.

Disable all other Profiles Set to Yes to disable all other Wi-Fi profiles on the device.

Operating Mode Select the operating mode.

Transmit Power
Level

Choose the transmit power level.

Adhoc Channel Select the Ad Hoc channel the devices use.

Encryption
Select the encryption type for theWi-Fi
network.

Pre Share Key
Enter the Pre Shared Key used for the
network.

Transmit Power Level Choose the transmit power level.

Power Level Select the balance of power use.

Security Type Choose the encryption type for the network connection.

Pre Shared Key Enter the Pre Shared Key used for theWi-Fi Connection.

Change CCKM Setting Select change to change the CCKM Mode.

Domain Name Enter the domain name used in authentication.

Username Enter the user name used for authentication.

Password Enter the password used for authentication.

6. After setting theMotorola adapter type specific settings, select Save & Publish to push the profiles to devices.

Exchange ActiveSync Profiles (Windows Rugged)
The Exchange ActiveSync profiles enable you to configure yourWindows Rugged devices to access your Exchange
ActiveSync server for email and calendar use.

Strongly consider only using certificates signed by a trusted third-party certificate authority (CA). Mistakes in your
certificates expose your otherwise secure connections to potential man-in-the-middle attacks. Such attacks degrade the
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confidentiality and integrity of data transmitted between product components, and might allow attackers to intercept or
alter data in transit.

The Exchange ActiveSync profile supports the nativemail client and AirWatch Inbox for Windows Desktop. The
configuration changes based on which mail client you use.

Important: You can use an EAS payload only on Windows Mobile devices and not on Windows CE devices.

Configure an Exchange ActiveSync Profile (Windows Rugged)
Create an Exchange ActiveSync profile to giveWindows Phone devices access to your Exchange ActiveSync server for
email and calendar use.

To configure Exchange ActiveSync payloads:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Exchange ActiveSync profile.
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5. Configure the Exchange ActiveSync settings:

Settings Descriptions

Domain Enter the domain for the Exchange account.

You may use Lookup values to create dynamic profiles.

Exchange ActiveSync Host Enter the hostname or IP address for the Exchange ActiveSync server.

User Enter the user name for the Exchange account.

You may use Lookup values to create dynamic profiles.

Settings

Use SSL Enable to send all communications through the Secure Socket Layer.

Max Body Truncation Select themaximum amount an email body is truncated in bytes.

Past Days of Calendar to
Sync

Enter the number of days of Calendar events to download when the account syncs
for the first time on the device.

Past Days of Mail to Sync Enter the number of days of emails to download when the account syncs for the first
time on the device.

Max HTML Truncation Select the level of truncation for HTML emails.

Max Email Truncation Select themaximum amount an email is truncated in bytes.

Max Email File Attachment
Size (MB)

Select themax size (in MB) that a file may be when attached.

Allow Sync When Roaming Enable to allow the email client to sync when the device is roaming.

Restrictions

Allow Calendar Sync Enable to allow the syncing of calendars.

Allow Contacts Sync Enable to allow the syncing of contacts.

Allow Tasks Enable to allow the syncing of tasks.

Allows Text Messages Enable to allow the syncing of text messages.

Allow Email Sync Allow the syncing of email. Disabling this setting removes access to email through
Exchange Active Sync.

Peak Days and Schedule

Sunday Enable to allow schedule of syncing on Sundays.

Monday Enable to allow schedule of syncing on Mondays.

Tuesday Enable to allow schedule of syncing on Tuesdays.

Wednesday Enable to allow schedule of syncing on Wednesdays.

Thursday Enable to allow schedule of syncing on Thursdays.

Friday Enable to allow schedule of syncing on Fridays.
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Settings Descriptions

Saturday Enable to allow schedule of syncing on Saturdays.

Peak Start Time Select the start time of the peak time period.

Peak End Time Select the end time of the peak time period.

Sync Schedule Peak Select what level of syncing happens during the peak time period.

Sync Schedule Off Peak Select what level of syncing happens outside the peak time period.

6. Select Save & Publish to push the profile to devices.

Credentials Profile (Windows Rugged)
A Credentials profile allows you to push Root, Intermediate, and Client certificates to support any Public Key
Infrastructure (PKI) and certificate authentication use case. The profile pushes configured credentials to the proper
credentials store on theWindows Rugged device.

Even with strong passcodes and other restrictions, your infrastructure remains vulnerable to brute force, dictionary
attacks, and employee error. For greater security, you can implement digital certificates to protect corporate assets. To
use certificates in this way, you must first configure a Credentials payload with a certificate authority, and then configure
yourWi-Fi and VPN payloads. Each of these payloads has settings for associating the certificate authority defined in the
Credentials payload.

Create a Credentials Profile (Windows Rugged)
A Credentials profile pushes certificates to devices for use in authentication. With Workspace ONE UEM, you can
configure credentials for intermediate, trusted root, trusted publisher, and trusted people certificate stores.

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Credentials profile.
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5. Configure the Credentials settings:

Settings Description

Credential
Source

Use the drop-down menu to select either Upload or Defined Certificate Authority.

Credential
Name

Enter a name for the credentials certificate. Displays if the Credential Source is Upload.

Certificate Select Upload, navigate to the desired credential certificate file and select Save.

Displays if the Credential Source is Upload.

Certificate
Authority

Use the drop-down menu to select a predefined certificate authority.

Displays if the Credential Source is Define Certificate Authority.

Certificate
Template

Use the drop-down menu to select a predefined certificate template specific to the selected
certificate authority.

Displays if the Credential Source is Define Certificate Authority.

Store
Location

Use the drop-down menu to choose to save the certificate on the specific user account level or on
the Computer Store for all users of a computer.

Certificate
Store

Select the certificate store folder location from the drop-down list.

l Trusted Root Certification Authorities

l Trusted Publishers

l Untrusted Certificates

l Trusted People

6. Select Save & Publish to push the profile to devices.

Launcher Profile (Windows Rugged)
TheWorkspace ONE UEM App Launcher restricts user access to a list of allowed applications and native features on the
device. Use the App Launcher to control the apps available to end users and the layout of the device home screen.

The Launcher profile enables you to customize the look and layout of theWindows Rugged device home screen. You can
configure the launcher profile to start when the device starts to limit end-user access to the entire device. To limit end-
user access to the correct apps on a shared device, you can set the launcher profile to display based on the user group of
the end user. This functionality allows you to tailor the launcher to the role of the end user using a shared device.

Customize the launcher to display different settings and apps based on the layout you want. To manage the device, the
launcher profile includes different tools for admins to troubleshoot the device.

Create a Launcher Profile (Windows Rugged)
Configure theWorkspace ONE UEM App Launcher profile to customize the layout and apps of a Windows Rugged device
using the App Launcher. This customization allows you to control end-user access to the device settings and applications
based on the roles of the user.
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To configure a Launcher profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Launcher profile.

5. Enter a Title for the launcher profile. You can use the supported Workspace ONE UEM Lookup Values. Select ( ) for
a list of all Workspace ONE UEM supported Lookup Values.

6. Define an Administrative Passcode for setting configurations on the device.

7. Define theUser Category of the end user if Shared Devices are enabled in theWindows Rugged Agent Settings page.
The user category ties end users to specific Launcher profiles allowing you to tailor Launcher layout and configuration
to individual end users. Consider creating user groups based on the end user's role.

8. Configure the remaining options:

Settings Descriptions

Allowed Applications

Application Name Specifies the application name that displays in the
Workspace ONE UEM App Launcher.

File Path to Exe Defines the file path of the application and includes the
executable file.

Arguments (Optional) Enter any command-line arguments to run the
application.

Hide Masks the application on the device.

Start Up Options Select the condition that triggers the launcher starting.

Delayed Launch Select the time (in seconds) that the launcher is delayed
from starting following device boot.

This setting requires Start Up Options to be set to
Delayed Start.

Console Application Defines the application as not having a user interface or
as a background process.

Tools Menu Lists applications on the Tools menu for the App
Launcher.

Background Application Select if the application requires no user interaction and
you want it to run in the background.

Disable App Close Removes the close button from the application
preventing the user from closing the app. Select this
option only for dedicated use applications.
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Settings Descriptions

Enable Home Button Allows you to minimize a whitelisted application and
return to themain App Launcher page while keeping the
current session active for that app.

If you want to return to theminimized app, select the
icon on the App Launcher screen.

Application Icon Path Defines the path to the location of the application icon
that resides on the device. If the desired icon does not
reside on the device, then you can upload an image.

Upload Icon Allows you to upload an image (icon) that can be
associated to an application by entering the path in the
Application Icon Path text box.

Settings

View Time Displays the time for application processes.

Disable Active Sync Disables the use of the Exchange ActiveSync protocol for
application transactions.

Disable Keyboard Disables the use of the device keyboard to perform
application processes.

View IP Address Displays the device's IP address within application
processes.

Enable Native Taskbar* Uses the default taskbar for that device instead of the
custom launcher taskbar.

View Connection Status Displays the connection status of the device.

Show Message Notification Displays a message indicator for unviewed messages
from a third-party application.

Display Organization Group Displays the Organization Group of the signed-in user.

View Wi-Fi Signal Displays the strength of theWi-Fi signal.

View Cell Signal Displays the strength of the cell signal.

View Battery Icon Displays the amount of power remaining in the battery.

View Volume Displays the level the volume is set to on the device.

Display Missed Call Notification Displays a notification when an incoming call was not
answered/missed.

Display SMS/Text Notification Displays a notification when the device received a text
message.

*When selected, these settings are disabled except for View Time, Disable Active Sync, Disable Keyboard, and
View IP Address. These exceptions exist because the native taskbar only displays the icons/settings that are
available to that device.
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Settings Descriptions

Tools

These settings allow the user to customize and manage the contents of the Tools Menu on the Launcher. You can
select any combination of the following options to make those options available to the user on the Tools Menu. A
second option is to whitelist the application under the Allowed Application section by selecting the Tools Menu
option next to that application. A third option is to configure apps directly on a device, provided the configure
option is enabled.

Restart AW Agent Allows the user to restart the AirWatch Service on the
device.

Restart AWCM Allows the user to restart the AWCM Service on the
device.

Start AW Diagnostics Allows the user to open and access the AirWatch
Diagnostics utility.

Start App Manager Allows the user to open and access the Application
Manager utility.

The Launcher is capable ofmultiple profile support.
Profiles that are active and meet the assignment criteria
for that device.

Multiple profile support requires AirWatch Agent
version 4.0.0.13 or higher.

Configure Allows the user to configure all areas of the Launcher
directly on the device, including Allowed Applications,
Settings, and Tools Menu.

View/Layout

Select Launcher View/Layout Style Select the format for the view/layout.

l Grid – Traditional grid layout of applications.

l List – List of applications with a small thumbnail of
the app icon.

l Plain List – List of applications with no thumbnail of
app icon.

l None – No preset view/layout. End users can select
the view/layout they want. If you select a
view/layout other than None, end users cannot
change the view/layout.

Wallpaper

Enable Wallpaper Enable to set a wallpaper for the Launcher. You must
select a Landscape and Portraitmode image.

9. Select Save & Publish.
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Important:Wallpapers cannot exceed 640x480 or bemore than 20 KB. Images larger than 20 KB cannot display.

Update the Launcher Profile from the Windows Rugged Device
You may need to change the applications included in theWorkspace ONE UEM App Launcher. This action requires admin
credentials to perform.

To make Admin configurations in theWorkspace ONE UEM App Launcher:

1. Open theWorkspace ONE UEM App Launcher application on the device.

2. Enter the Admin passcode in the Password text box and select Accept.

3. Select the option to Import, Export, or Add applications from and to the list.

4. Select Add to add an application and complete the following options on the Add Application screen:

l Application Location – Defines the file path of the application or select the Browse option.

l Application Name – Defines the name of the application to display in theWorkspace ONE UEM App Launcher.

l Arguments – Defines command-line arguments to run the application.

l Launch On Start – Starts the application when theWorkspace ONE UEM App Launcher is started.

l Hide from User –Masks the application in the user interface.

l Console Application – Defines the application as not having a user interface or as a background process.

5. Select Save.
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Configure Shared Device Launcher Profiles (Windows Rugged)
Workspace ONE UEM allows you to configure Launcher profiles to support multiple end users sharing a single device. Use
this feature to customize the Launcher for individual users and their different applications to meet their individual roles.

Important: You must enroll the device into the Parent organization group for the Launcher profiles for various User
Categories to push to the device.

To configure the Launcher profile for shared devices:

1. Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged > Agent Settings.

2. Select Enable Shared Device Mode.

3. Navigate to Accounts > Users > User Settings > Categories > Add and enter the Name and Description. Consider
creating the User Categories based on the various roles end users have that require different applications on the
device. For example, basic users require different applications than a shift supervisor or manager. To accommodate
this requirement, create different User Categories for the basic user, shift supervisor, and manager.

4. Navigate to Accounts > Users > List View and Add new user or Edit an existing one.

5. Enable Show Advanced User Details and select the applicable Category based on the role of the user.

6. Create and configure a Launcher Profile. Select the applicableUser Category based on the role of the user for this
specific Launcher profile.
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7. Configured more Launcher profiles for each end-user role. For more information, see Create a Launcher Profile
(Windows Rugged) on page 28

End users must enter their credentials and their group ID. To remove the need to enter the group ID, navigate to Settings
> All Settings > Devices & Users > General > Shared Device and set theGroup Assignment Mode to Fixed Organization
Group.

Create a VPN Profile (Windows Rugged)
Create a VPN Profile to deploy corporate VPN settings directly to managed devices. This profile enables end users to
access corporate infrastructure remotely and securely.

Important: You can use a VPN profile only on Windows Rugged devices, but not on Windows CE devices.

To enforce a VPN profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the VPN profile.

5. Configure the VPN settings:

Settings Descriptions

Connection
Type

Defines the connection for the VPN.

Both of these types rely on the encryption protocol to be passed within the tunnel because they
do not inherently have their own encryption methods.

l PPTP – Point-to-Point Tunneling Protocol.

l IPSec/L2TP – Layer 2 Tunneling Protocol.

Connection
Name

Enter the connection name.

Server Enter the hostname of IP address of the VPN server.

Username Enter the user name for the VPN.

You can use lookup values to use the device-specific value.

Domain Enter the domain for the VPN.

You can use lookup values to use the device-specific value.
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Settings Descriptions

Authentication Defines the authentication for the VPN.

l Certificate – Use this option to deploy certificate-based authentication for your VPN
connections.

You must choose this option if you select the Connection Type IPSec/L2TP

l Pre Shared Key – Use the PSK option when you have a shared secret that device users use to
access the VPN.

This authentication type often uses symmetric key algorithms for security.

Shared Secret Enter the shared secret for the connection.

Displays when Authentication is set to Pre Shared Key.

6. Select Save & Publish to push the profile to devices.

Create a Time Sync Profile (Windows Rugged)
Deploy Time Sync payloads to synchronize the system time on Windows Rugged devices with time servers to ensure that
the device fleet runs on the same clock. This profile is useful for global networks with devices in numerous time zones.

To configure a Time Sync profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Time Sync profile.
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5. Configure the Time Sync settings:

Settings Descriptions

Time Sync
Method

Select the preferred method of time sync.

l Time Server – Select to use a Network Time Protocol server with which to sync devices
such as pool.ntp.org.

l HTTP – Select to enter a URL. This URL can be any URL. For example, you can use
www.google.com.

l SNTP – Select to enter a Simple Network Time Protocol such as time.nist.gov.

l Console – Select to sync the device with the UEM console.

Primary Time
Server

Enter the URL of the time server with which the device syncs.

Port Enter the port the device uses to sync with the secondary server.

Secondary Server Enter an optional secondary server the device can use if the primary is unavailable.

Displays when Time Server is selected as the Time Sync Method.

Port Enter the port the device uses to sync.

Displays when Time Server is selected as the Time Sync Method.

Sync Time Every Enter the number ofminutes, hours, or days.

6. Select Save & Publish.

Create a Shortcut Profile (Windows Rugged)
Create a Shortcut profile to push custom icons associated with URLS. These icons provide your end users with the
shortcuts to Web sites they need.

You can add as many icons as needed to a shortcut payload. Upload the icon image file into theWorkspace ONE UEM
console.

To configure a shortcut profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Shortcuts profile.

5. Configure the Shortcuts settings:

Settings Descriptions

Label Enter the name associated to the icon that displays on the user's device.
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Settings Descriptions

URL Enter the URL for theWeb site in which the user is advanced to when user taps on the icon.

Icon Upload the image file that displays on the user's device that is associated to the URL.

6. Select Save & Publish to push the profile to devices.

Create a Time Zone Profile (Windows Rugged)
Create a Time Zone profile to configure yourWindows Rugged device time zone settings. This profile eliminates having to
remote control into the end user's device to set the time zonemanually.

After pushing the profile, the device displays the time zone, and all device activity is time stamped based on that time
zone regardless of the actual device location.

To configure Time Zone profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Time Zone payload, select the Time Zone Setup drop-down, and select Set Time Zone Manually.

5. Select the Time Zone drop-down and select the appropriate time zone from the list.

Create a Custom Attribute Payload
Workspace ONE UEM allows you to create and deploy custom attributes that collect and compare custom-made values
from device. Custom attributes are used to manage devices using attributes assigned to or gathered from the devices.

These attributes can be collected or created by third-party applications for use with the UEM console. By using custom
attributes, you can ensure that only the devices whose attribute values match the ones you set are selected.

Custom attributes are used by the rules generator of product provisioning to provision products to specific devices.
Ensure your devices are provided the correct values to prevent incorrect products from being provisioned to them. See
Custom Attributes Overview on page 51 for more information.

To configure a Custom Attributes payload, take the following steps.

1. Navigate to Devices > Products > Profiles > List View and select Add and then select the device platform.

2. Configure the profile's General settings.

3. Select the Custom Attribute profile.

4. Select Add to configure the custom attribute(s) you want to use.

Settings Descriptions

Application Select the application (grouping of custom attributes) that contain the attribute(s) you want to
configure.
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Settings Descriptions

Custom
Attributes

Select the specific custom attribute(s) for the profile to configure.

Value Enter the custom attribute value to assign to the device.

Is Dynamic Enable to allow the custom attribute's value to change and be changed based on permissions.

If checked, this will look up the custom attribute value for an individual device when the command is
queued instead of using the default value specified in the payload. If no value is found, the device's
default value is used.

Permission Set the permission of the custom attribute.

l Read/Write allows the applications to change the attribute value.

l Read Only restricts applications from changing the value.

Sync Enable to push the attribute value back to the UEM console to be displayed in the Device Details
page.

You may add additional attributes as necessary.

5. Select Save & Publish to push the profile to devices.

Create a Proxy Profile (Windows Rugged)
Create a proxy profile to set specific proxy settings for devices. Use a proxy to add a layer of security to yourWindows
Rugged devices.

To configure a Proxy profile:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select the Proxy profile.

5. Configure the profile settings:

Settings Descriptions

Proxy Type SelectManual to configure the specific settings or Auto to use the settings of a Proxy URL.

Proxy Server Enter the proxy server URL.

Proxy Server Port Enter the port used to communicate with the proxy server.

Proxy Username Enter the user name credential for the proxy server.

Proxy Password Enter the password credential for the proxy server.

Proxy URL Enter the URL for the auto proxy settings.

6. Select Save & Publish to push the profile to devices.
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Create a GPRS Profile (Windows Rugged)
The General Packet Radio Service (GPRS) allows mobile data on 2G and 3G cellular communication system for GSM
devices. The GPRS payload allows you to configure and control how the device uses GPRS.

To configure a GPRS payload:

1. Navigate to Devices > Profiles > List View > Add and select Add Profile.

2. SelectWindows Rugged.

3. Configure the profile's General settings.

4. Select theGPRS profile.
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5. Configure the GPRS settings:

Settings Descriptions

General

Enabled Select to enable GPRS management.

Connection Name Enter the GPRS connection name.

Destination Select whether the GPRS connection is to the Internet or aWork intranet.

GPRS Info Access Point
Name

Enter the APN the devicemust connect to. The APNmust follow the correct format:

<network identifier>.mnc<MNC>.mcc<MCC>.gprs

Username Enter the user name for connecting to the network.

Password Enter the password for connecting to the network.

Domain Enter the network domain.

Advanced

Advanced Enable to configure advanced options.

Specific Name Servers Enable to enter specific name servers to use.

Country Code Enter the network country code.

Area Code Enter the device area code.

Use Country and Area
Codes

Enable to use Country and Area codes.

Phone Enter the device phone number.

Device Name Enter the device name for use in phone books.

Device Type Select the RAS device type.

Use Software
Compression

Allows for faster connection speeds on low-bandwidth networks by compressing the
phone book entries.

Use IP Header
Compression

Allows for faster connection speeds on low-bandwidth networks by compressing the IP
Header.

Specific IP Address Enable to connect to a specific IP Address.

Read Only Enable to restrict the device to reading data only.

Authentication Type Select the type of authentication the network uses.

6. Select Save & Publish.
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Compliance Policy Overview
The compliance engine is an automated tool by Workspace ONE UEM that ensures all devices abide by your policies.
These policies may include basic security settings such as requiring a passcode and having a minimum device lock period.
For certain platforms, you may also decide to set and enforce certain precautions. These precautions include setting
password strength, blacklisting certain apps, and requiring device check-in intervals to ensure that devices are safe and
in-contact with Workspace ONE UEM.

Once devices are determined to be out of compliance, the compliance engine warns users to address compliance errors
to prevent disciplinary action on the device. For example, the compliance engine can trigger a message to notify the user
that their device is out of compliance.

In addition, devices not in compliance cannot have device profiles assigned to it and cannot have apps installed on the
device. If corrections are not made in the amount of time specified, the device loses access to certain content and
functions that you define. The available compliance policies and actions vary by platform.

For more information about compliance policies, including which policies and actions are supported for a particular
platform, refer to the VMware AirWatch Mobile Device Management Guide, available on docs.vmware.com.
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Configure the AirWatch Agent for Windows Rugged
The AirWatch Agent for Windows Rugged devices is pre-configured with Workspace ONE UEM. Change these settings
when you need the AirWatch Agent to meet certain business needs.

Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged > Agent Settings.

Upgrade the Agent

When a new version of the AirWatch Agent releases, upgrade your devices remotely and easily. With product
provisioning, devices receive the AirWatch Agent CAB file and install it based on directions. For more information, see the
Product Provisioning Guide for Windows Rugged available on Workspace ONE UEM Resources.

If you are using a legacy AirWatch Agent older than version 5.2.x, you must use the legacy Over-the-Air Migration
method. For more information, see https://support.air-watch.com/articles/115001664548.

Device-side Scripting

The AirWatch AWScript component allows you to configure yourWindows Rugged devices through device-side scripting.
The script file uses a dialect of BASIC as its core scripting language and adds Workspace ONE UEM specific extensions on
top.

For more information on the AWscript and it's capabilities, see https://support.air-
watch.com/articles/115001664528

General

Setting Description

Device ID
Algorithm

Set the unique device identification algorithm used on the device.

l Device ID Algorithm 3 – Agent uses the OS-provided API to generate the UDID.

l Device ID Algorithm 5 – Along with the OS-provided API, the agent uses the MAC ID of the device to generate the UDID.

l Device ID Algorithm 6 – Together with the OS-provided API and the MAC ID of the device, the agent also uses the serial
number of the device to generate the UDID.

Heartbeat
Interval
(min)

Set the time (in minutes) the agent waits before checking in with theWorkspace ONE UEM console.

Data Sample
Interval
(min)

Set the time (in minutes) the agent waits to collect data from the device.

Data
Transmit
Time
Interval
(min)

Set the time (in minutes) the agent waits to send data collected from the device to the UEM console.
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Setting Description

Check-In on
Condition
(Event)

Enable to limit the agent to check-in or beacon to the UEM console only when certain conditions (Wi-Fi
connection, AC Power, or NW Adapter) aremet. This helps reduce bandwidth issues as devices typically
meet the condition when they are stored for after hours.

Shared Devices

Setting Description

Enable Shared
Device Mode

Select this check box to enable shared device functionality. For more information, see the
Windows Rugged Launcher Profile Overview.

Notifications

Setting Description

Enable Agent Installation Complete
Notification

Select this check box to enable or disable notifications for Agent installation
completion.

Enable Product Install Status
Notification

Select this check box to enable or disable notifications through the Agent for
product installation completion.

Location

Setting Description

Collect
Location
Data

Enable to allow the agent to determine the device location based on a device's Wi-Fi network. When
available, the agent will report the location to theWorkspace ONE UEM console using the Data Transmit
Interval.

Application List

Setting Description

Applications Poll
Interval (min)

Set the time interval (in minutes) at which the applications list for each device will refresh on
theWorkspace ONE UEM console.

Certificate List

Setting Description

Certificate Poll Interval
(min)

Set the time interval at which the certificate list for each device will refresh on theWorkspace
ONE UEM console.

Proxy

Setting Description

Proxy Configuration Enable to allow the configuration of a proxy settings.
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Application Manager Package Scheduler

These settings are for the legacy AirWatch Agent v3.3.

Use the APPLICATION MANAGER PACKAGE SCHEDULER to define a schedule for devices with the AirWatch Agent v3.3+
to retrieve products provisioned on schedule.

Setting Description

Add Select to create schedules for provisioning products using Products (Legacy).

Application Manager
Scheduler

Select the hour the product begins to push to devices.

Randomization Window
(min)

Select the amount of time the product is pushed over. The order of devices is
randomized.

Sideloading Cab

Setting Description

Request Enrollment
Cab

Enable to create a side loading cab to quickly enroll devices.

Platform Select the operating system for the cab file.

Enrollment User Select a user for the cab file to use during enrollment. The cab file can be used on multiple devices
regardless of the user selected.

Enrollment User
Password

Enter the password for the user for enrolling with the cab file.

Show Characters Select to show password characters.

Power On Password

Use the Power On Password option to control system BIOS password options to secure the device from unauthorized
users when they turn on the device.

Important: Power On Password is only for Athena and requires the Power On Password CAB, which is a separate CAB
component. You can perform a similar function through the AirWatch Agent by pushing down a "Passcode" profile.

To configure the Power On Password option:

1. Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged.

2. Enable Power On Password and set the options, including:

l Path to App Update – Enter the path to the AppUpdate.exe file so that this loader can check for updates, install
the updates and load and run the applications it updates.

l Intermec Reboot Exe – Enter the path to the Reboot.exe file on Intermec devices used to warm boot the device.

3. Select Save.
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Advanced Settings

Use these options to update applications on Windows Rugged devices and to reset devices.

1. Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged.

2. Select Advanced and set the options, including:

l Force Password Expiration – Forces the password to expire so that the user must change the password.

l View Power On Password – Enables the user to see the password they enter.

3. Select Save.

Windows Rugged Device Logging with the AirWatch Agent v5.X+
All device log settings are configured through the log_config.cfg file located in the "\Program Files\AirWatch" directory.
When this file is opened up and viewed in Notepad, it appears with the following text and options:

[*]
trace_level=5
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

[aw_setup]
trace_level=5
max_file_size_kb=256
files_to_keep=2
log_file_path=\
use_local_time=false

[awregisterdevice.exe]
trace_level=3
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

[awapplyprofile.exe]
trace_level=5
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

[awremotecontrol.exe]
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trace_level=1
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

The first setting group that appears under the asterisk is the default configuration settings for all logs available on the
device.

Trace levels vary from 1 to 5. A level of 1 provides themost basic and least amount of information. Developers use Level 5
for debugging purposes since it provides all available messaging. There is a tradeoff between the trace level and the log
size. A higher trace level increases the size of the log files due to messaging increase. The trace level that is set in the
default section applies to all log files on a device.

You can keep the default log level low and still increase the log level for the four options below the default log level.
Specify the log level for each of the options if you choose to use a different trace level than the default level.

The logs available on a device vary based on what is configured and the OEM of the device. The following log files are
generally available on Windows Rugged devices:

l aw_setup – Provides logging information relating to the AWMasterSetup utility. The AWMasterSetup utility initiates
the agent install and uninstall process on a device. This log file is the only log file that is not located in the "\Program
Files\AirWatch" directory. The log is instead located in the root of the file system.

l awacmclient – Provides logging information relating to the AWCM client on the device.

l awapplicationmanager – Provides logging information relating to product provisioning.

l awprocesscommands – Provides logging information relating to the execution ofMDM commands and installation
of profiles.

l AWService – Provides information about the AWService.exe component, which is responsible for managing beacon
and interrogator samples.

l awapplyprofile – Relates to installation of the agent settings XML file which occurs during the enrollment process.

l awregisterdevice – Provides information about the registering of the device that occurs during the enrollment
process.

l awapplauncher – Provides information about the Application Launcher executable. This log only applies to devices
using the App Launcher.

l fusionwlansetup – Provides information about configuring and setting up the Fusion Wi-Fi driver on Motorola
devices.

General Process for Configuring Log Files

1. Transfer the log file to your PC using the file manager utility in device details or through remotemanagement.

2. Open the log file using a basic text editor such as Notepad.

3. Edit the desired trace level to the needed value.
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4. Save the log file.

5. Transfer the log file back to the "Program Files\AirWatch" directory on the devices. Consider first deleting the old
log_config.cfg file on the device.

6. Restart the AWService on the device once it has the updated log_config.cfg file. Use the Restart AirWatch Agent or
theWarm Boot device actions available in the UEM console.

7. Once the AWService restarts, the new logging configuration takes effect.
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Custom Attributes Overview
Custom attributes enable administrators to extract specific values from a managed device and return it to theWorkspace
ONE UEM console. You can also assign the attribute value to devices for use in product provisioning or device lookup
values.

These attributes allow you to take advantage of the rules generator when creating products using Product Provisioning.

Note: Custom attributes (and the rules generator) are only configurable and useable at Customer-level organization
groups.

Custom Attributes Database

Custom attributes are stored either as XML files on the device or in the custom attribute database on theWorkspace
ONE UEM console server. When using the database, custom attributes are sent as samples to Workspace ONE UEM
periodically for asset tracking of key/value pairs. If a record in the device database is configured with 'Create Attribute' =
TRUE, then the AirWatch Agent automatically retrieves the Name and Value sent with the custom attributes sample. The
key/value pair displays in the Device Details page for the device in the Custom Attributes tab.

Create Custom Attributes

Create a custom attribute and values to push to devices. You create the attributes and values associated with them. For
more information, see Create Custom Attributes on page 51.

Importing Custom Attributes

The custom attribute batch import feature allows you to load custom attributes and corresponding values into the
system in bulk. In the templates provided, each column corresponds to one custom attribute and each row corresponds
to different parameters of custom attribute. For more information, see Custom Attributes Importing on page 52.

Platform-Specific Custom Attributes Provisioning

You can push custom attributes to a device using XML provisioning for use with advanced product provisioning
functionality. Themethod for pushing the XML varies based on the device platform.

Create Custom Attributes
Create a custom attribute and values to push to devices. These attributes and values control how product rules work and
function as lookup values for certain devices.

1. Navigate to Devices > Staging & Provisioning > Custom Attributes > List View.

2. Select Add and then select Add Attribute.

3. Under the Settings tab, enter an Attribute Name.

4. Enter the optionalDescription of what the attribute identifies.

5. Enter the name of the Application that gathers the attribute.
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6. Select Collect Value for Rule Generator to make the values of the attribute available in the drop-down menu of the
rule generator.

7. Select Use in Rule Generator if you want to use the attribute in the rule generator.

8. Select Persist to prevent the removal of the custom attribute from theWorkspace ONE UEM console unless an
Admin or an API call explicitly removes it. Otherwise, the attribute is removed as normal.

If you delete a custom attribute reported from a device to the UEM console, a persisted custom attribute remains in
the UEM console.

Custom attribute persistence is only available to Android and Windows Rugged devices.

9. Select Use as Lookup Value to use the custom attribute as a lookup value anywhere in the UEM console.

For example, you can use custom attributes as part of a device friendly name to simplify device naming.

10. Select the Values tab.

11. Select Add Value to add values to the custom attribute and then select Save.

Custom Attributes Importing
The custom attribute batch import feature allows you to load custom attributes and corresponding values into the
system in bulk. In the templates provided, each column corresponds to one custom attribute and each row corresponds
to different parameters of custom attribute.

With the templates, you can import custom attributes in different ways and with different information.

Caution: The syntax of the first column of each templatemust be replicated exactly. Failure to use proper syntax can
cause database issues and result in loss of data.

Template Types

l Custom Attributes Template – Allows you to define a custom attribute and its settings.

l Custom Attribute Values Template – Allows you to define the values of predefined custom attributes.

l Device Custom Attribute Values – Allows you to define the values of predefined custom attributes for individual
devices based on the cross reference (Xref) value. The Xref values determine the individual devices receiving the value
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for each custom attribute.

o 1 – DeviceID (Workspace ONE UEM assigned DeviceID when the device enrolls)

o 2 – Serial Number

o 3 – UDID

o 4 –MAC Address

o 5 – IMEI Number

Save the file as a .csv before you import it.

Windows Rugged Custom Attributes
Use XML provisioning to collect custom attributes based on device details. Custom attributes enable you to use
advanced product provisioning functionality.

Implementation

To begin collecting custom attributes, follow the steps detailed below:

1. Navigate to Devices > Staging & Provisioning > Components > Files/Actions and select the Add Files/Actions
button, then selectWindows Rugged as your platform.

2. Create an XML product. For more information, see Create an XML Provisioning File on page 55. Themanifest should
include an action to download the XML file to \Program Files\Airwatch\Cache\Profiles.

Upon receiving the XML file, the AirWatch Agent for Windows Rugged creates a custom attributes output file. During the
next check-in with Workspace ONE UEM, the agent sends the output file to the UEM console.

Once the XML file installs, the custom attributes requested in the file are reported to the UEM console. These values
display in the UEM console on the Device Details page under custom attributes. The Device Details page enables you to
view the name of the attribute as well as the values returned from each device. These values can be used to create
product assignment rules using the Custom Rules system.
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You may also view existing custom attributes for all devices at a particular organization group as well as manually create
custom attributes directly in the UEM console. Navigate to Devices > Staging & Provisioning > Custom Attributes > List
View to see these custom attributes listed. Any custom attribute created in this manner automatically associates with a
device and its respective custom attribute value that is successfully transmitted to the UEM console.

Syncing Registry Settings

In order to synchronize the registry settings on aWindows Rugged device with the console, which is likely themost
common use of custom attributes for Windows Rugged devices, you need to create a custom XML file. Below is an
example of the format of an XML file that can pull information from the registry on a device:

<?xmlversion="1.0"?>

-<wap-provisioningdocallowRemoval="True"name="GetTypicalRegValues/V_1"id="5a63204f-848c-42d5-9c14-
4ca070743920">

-<characteristicuuid="f49a9cb5-48e9-47cd-84cc-ef122dcb5d50"
type="com.airwatch.getregistryinfo.winmo">

<reg_valuevalue_name="Username"key_name="HKEY_LOCAL_MACHINE\Ident"custom_
attribute_name="HKLM_Ident_Username"/>

<reg_valuevalue_name="OrigName"key_name="HKEY_LOCAL_MACHINE\Ident"custom_
attribute_name="HKLM_Ident_OrigName"/>

<reg_valuevalue_name="BootCount"key_name="HKEY_LOCAL_MACHINE\Comm"custom_
attribute_name="HKLM_Comm_BootCount"/>

<reg_valuevalue_name="DeviceIdAlgorithm"key_name="HKEY_LOCAL_
MACHINE\Software\AirWatch"custom_attribute_name="Software_AirWatch_DeviceIdAlgorithm"/>

</characteristic>
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</wap-provisioningdoc>

It must be in the previous format for the XML file to get correctly parsed and the registry settings to be outputted to a
key value pair that can be exported back to the UEM console. In this example, the registry key path is “HKEY_LOCAL_
MACHINE\Ident” for two of the values and within that key path it is reading the values of “Username” and “OrigName”.
The ‘custom_attribute_name’ parameter is simply the name of the custom attribute that displays in the console and
corresponds to the value read from the device.

Using Third-Party Applications to Create Custom Attributes

If you want to create custom attributes using a third party application, you need that application to export an XML file
with a key value pair to the Program Files\AirWatch\Cache\CustomAttributes directory on the device. Once an XML file
with a key value pair is present in this directory it is parsed by the agent and included in the next interrogator sample. The
XML key/value pair should be in the following format:

<?xmlversion="1.0"?>

-<attributes>

<attributename="HKLM_Ident_Username"value="guest"/>

<attributename="HKLM_Ident_OrigName"value="Pocket_PC"/>

<attributename="HKLM_Comm_BootCount"value="1"/>

<attributename="Software_AirWatch_DeviceIdAlgorithm"value="3"/>

<attributename="HKLM_SoftwareAW_SerialNo"value="13233521403231"/>

</attributes>

‘Attribute name’ is the name of the attribute in the console while ‘value’ is the corresponding value that is associated
with that attribute.

Create an XML Provisioning File
XML provisioning allows you to download a custom-designed XML file to a device in a provisioning product. After the file
is downloaded, it executes an install command to extract the settings from the XML file and install them on the device.

1. Navigate to Devices > Staging & Provisioning > Components > Files/Actions and select Add Files/Actions.

2. Select your platform.

3. Enter the required settings on theGeneral tab, then select the Files tab and upload the desired XML file and enter
the destination path on the device.

4. Select theManifest tab and Add an Install Action for the XML file.

5. Select Save.
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6. Navigate to Devices > Staging & Provisioning > Products List View, and select Add Product.

7. Select your platform.

8. Enter theGeneral information.

9. Select theManifest tab.

10. Select Install Files/Actions and choose the files and actions just created.

11. Save and Activate the product.

The product downloads to all assigned devices and the XML file should successfully install.

XML Provisioning is for Windows Mobile devices only and not Windows CE.
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Windows Rugged Device Management Overview
After your devices are enrolled and configured, manage the devices using theWorkspace ONE UEM console. The
management tools and functions enable you to keep an eye on your devices and remotely perform administrative
functions.

You can manage all your devices from the UEM console. The Dashboard is a searchable, customizable view that you can
use to filter and find specific devices. This featuremakes it easier to perform administrative functions on a particular set
of devices. The Device List View displays all the devices currently enrolled in yourWorkspace ONE UEM environment and
their status. TheDevice Details page provides device-specific information such as profiles, apps, AirWatch Agent version
and which version of any applicable OEM service currently installed on the device. You can also perform remote actions
on the device from the Device Details page that are platform-specific.

Device Dashboard
As devices are enrolled, you can manage them from theWorkspace ONE UEM Device Dashboard. TheDevice Dashboard
provides a high-level view of your entire fleet and allows you to act on individual devices quickly.

You can view graphical representations of relevant device information for your fleet, such as device ownership type,
compliance statistics, and platform and OS breakdowns. You can access each set of devices in the presented categories
by selecting any of the available data views from theDevice Dashboard.

From the List View, you can take administrative action: send messages, lock devices, delete devices, and change groups
associated with the device.

Device List View
Select Devices > List View to see a full listing of all devices.

The Last Seen column displays an indicator showing the number ofminutes elapsed since the device has checked-in.

Select a device in theGeneral Info column at any time to open the details page for that device.

Sort by columns and configure information filters to review device activity based on specific information. For example,
sort by the Compliance Status column to view only devices that are currently out-of-compliance and target only those
devices. Search all devices for a friendly name or user name to isolate one device or user.

Customize Device List View Layout

Display the full listing of visible columns in theDevice List view by selecting the Layout button and choose the Custom
option. This view enables you to display or hide Device List columns per your preferences.

There is also an option to apply your customized column view to all administrators. For instance, you can hide 'Asset
Number' from theDevice List.

Once all your customizations are complete, select the Accept button to save your column preferences and apply this new
column view. You may return to the Layout button settings at any time to tweak your column display preferences.

Search in Device List View

You can search for a single device for quick access to its information and take remote action on the device.
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To run a search, navigate to Devices > List View, select the Search List bar and enter a user name, device friendly name,
or other device-identifying element. This action initiates a search across all devices, using your search parameter.

Windows Rugged Device Details Page
Use the Device Details page to track detailed device information and quickly access user and devicemanagement actions.

You can access Device Details by selecting a device Friendly Name from the Device List View, using one of the Dashboards,
or with any of the search tools.

From the Device Details page, you can access specific device information broken into different menu tabs. Each menu tab
contains related device information depending on yourWorkspace ONE UEM deployment.

Remote Actions

TheMore drop-down on the Device Details page enables you to perform remote actions over the air to the selected
device.

The actions vary depending on factors such as the device platform, UEM console settings, and enrollment status:

l Add Tag – Assign a customizable tag to a device, which can be used to identify a special device in your fleet.

l AirWatch Agent (Query) – Send a query command to the device's AirWatch Agent to ensure it has been installed and
is functioning normally.

l App Remote View – Take a series of screenshots of an installed application and send them to the Remote View
screen in the UEM console. You may choose the number of screenshots and the length of the gap, in seconds,
between the screenshots.

l Apps (Query) – Send a query command to the device to return a list of installed apps.

l Certificates (Query) – Send a query command to the device to return a list of installed certificates.

l Change Organization Group – Change the device's home organization group to another pre-existing OG. Includes an
option to select a static or dynamic OG.

l Clear Passcode (Device) – Clear the device passcode. To be used in situations where the user has forgotten their
device's passcode.

l Delete Device – Delete and unenroll a device from the UEM console. This action does not remove any data from the
device itself, only its representation in the console.

l Device Information (Query) – Send a query command to the device to return basic information on the device such
as friendly name, platform, model, organization group, operating system version and ownership status.

l Device Wipe –Wipe a device clear of all data, including email, profiles and MDM capabilities and the device returns
to a factory default state. This includes all personal user information if applicable. This action cannot be undone.

l Edit Device – Edit device information such as Friendly Name, Asset Number, Device Ownership, Device Group and
Device Category.

l Enterprise Reset – Enterprise Reset a device to factory settings, keeping only theWorkspace ONE UEM enrollment.
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l Enterprise Wipe – EnterpriseWipe a device to unenroll and remove all managed enterprise resources including
applications and profiles. This action cannot be undone and re-enrollment will be required for Workspace ONE UEM
to manage this device again. Includes options to prevent future re-enrollment and a Note Description field for you to
add any noteworthy details about the action.

o EnterpriseWipe is not supported for cloud domain-joined devices.

l File Manager – Launch a FileManager within the UEM console that enables you to remotely view a device's content,
add folders, conduct searches and upload files.

l Provision Now – Provision products to a device. Provisioning is the ability to create an ordered installation of files,
actions, profiles and applications into a single product that can be pushed to devices.

l Query All – Send a query command to the device to return a list of installed apps (including AirWatch Agent, where
applicable), books, certificates, device information, profiles and security measures.

l Registry Manager – Launch a Registry Manager within the UEM console that enables you to remotely view a device's
OS registry, add keys, conduct searches and add properties.

l Remote Control – Take control of a supported device remotely using this action, which launches a console
application that enables you to perform support and troubleshooting on the device.

l Remote Management – Take control of a supported device remotely using this action, which launches a console
application that enables you to perform support and troubleshoot on the device.

l Request Device Check-In – Request that the selected device check itself in to the UEM console. This action updates
the Last Seen column status.

l Restart AirWatch Agent – Restart the AirWatch Agent. To be used during troubleshooting for when the enrollment
process or submodule installation process is interrupted.

l Send Message – Send a message to the user of the selected device. Choose between Email, Push Notification and
SMS.

l Start/Stop AWCM – Start/Stop the Cloud Messaging service for the selected device. VMware AirWatch Cloud
Messaging (AWCM) streamlines the delivery ofmessages and commands from the Admin Console by eliminating the
need for end users to access the public Internet or utilize consumer accounts, such as Google IDs.

l Task Manager – Launch a Task Manager within the UEM console that enables you to remotely view a device's
currently-running tasks, including task Name, Process ID and applicable Actions you may take.

l View Manifest – View the device's Package Manifest in XML format from the UEM console. Themanifest on
Windows Rugged devices lists metadata for widgets and apps.

l Warm Boot – Initiate a restart of the operating system without performing a power-on self-test (POST).

Advanced Remote Management
Advanced RemoteManagement (ARM) allows you to remotely connect to end-user devices so you can assist in
troubleshooting and maintenance. ARM requires your computer and the end user device to connect to the Remote
Management Server to facilitate communication between theWorkspace ONE UEM console and the end user device.
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For more information on installing, configuring, and using Advanced RemoteManagement, please see the VMware
Workspace ONE UEM Advanced Remote Management Guide, available on docs.vmware.com.
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