Advanced Remote Management Link Does Not Display in Workspace ONE ™ UEM

Problem

ARM link does not display in the More Actions drop-down menu as seen in Device Details View OR device is not shown in the Device List View.

Possible Cause

Registration failed or ARM agent might not have been deployed properly. ARM Agent might have not been installed on the device properly or registration to ARM Server has failed.

Solution

Attempt to re-register the device. Update Resource portal to ensure that ARM agent may be properly downloaded and installed on device. A Workspace ONE UEM administrator must re-register the device.

 

Registration Check Returns Failed

Problem

Device does not register with Workspace ONE UEM or the ARM portal.

Possible cause

P7b file missing root/intermediate certificates in certificate chain. In MMC (Microsoft Management Console) certificate console when opening the certificate, the certificate path is missing and certificate status displays: the issue of this certificate could not be found.

Solution

Reinstall the certificate including intermediate and root certificate. Reinstall all the certificates for this client and ensure that the root certificate is placed into the root certificate folder and the intermediate certificate is placed in intermediate certificate folders in MMC certificate console.

 

Error Message, 'Registration Failed: Server Not Found'

Problem

Device does not register with Workspace ONE UEM or the ARM portal.

Possible cause

ARM Site URL capital and lower-case letters. In Advanced Remote Management tool versions 4.4.2.6291 and prior, the URL for remote management server is CAPS sensitive. In the example shown below, the URL utilizes upper-case and lower-case letters ‘https://rmSTAGE01.awmdm.com’

Solution

Remove upper case characters from the Advanced Remote Management site URL. Check the ARM site configuration. You need to ensure that the URL has all lower-case letters. In the example above, the URL should be ‘https://rmstage01.awmdm.com’.

 

Possible cause

Firewall is ON but misconfigured. If the firewall is incorrectly configured on the Advanced Remote Management Server, it might be preventing device registrations from being received.

Solution

Turn off firewall or set up exceptions. When the firewall is on and it is not correctly configured, it might be preventing device registrations. Devices register with the Anchor web service, usually hosted on port 443 on the ARM server. If this port is blocked on the firewall, registrations are jeopardized. Turn off the firewall and see if registrations succeed. If they do, check the exceptions to ensure that the Anchor web service on port 443 or other port defined for this service is in the list of exceptions.