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Chapter 1:
Introduction to the Windows Rugged
Platform
Workspace ONE ™ UEM provides you with a robust set of mobility management solutions for enrolling, securing,
configuring, and managing your Windows Rugged deployment. Through the UEM console, you have several tools and
features for managing the entire lifecycle of corporate and employee-owned devices.
Windows Mobile and Windows CE devices and their operating systems are proven performers in rugged environments
like warehouses, courier services, and healthcare facilities. These devices represent most mobile devices in these
environments and can perform many functions such as sales, inventory, scanners, and more. With the Workspace ONE
UEM solution, you can manage these devices and integrate them with your other mobile platforms, which give you a
central location for mobile device management.

Windows Rugged Requirements
Before reading this guide, gather and prepare the requirements Workspace ONE ™ UEM requires for Windows Rugged
devices.

Platforms Supported
l

Windows CE 5, 6, and 7.

l

Windows Mobile 5.x.

l

Windows Mobile 6.1.

l

Windows Mobile 6.5 (Professional and Standard).

l

Windows Embedded 6.5.

Agents and Versions Supported
Workspace ONE UEM recommends using the version 5.X.X of the AirWatch Agent for Windows Rugged. Workspace ONE
UEM no longer supports bug reports, code changes, or new enhancements for previous versions of the AirWatch Agent
for Windows Rugged.
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Chapter 2:
Product Provisioning
Product provisioning enables you to create, through Workspace ONE ™ UEM, products containing profiles, applications,
files/actions, and event actions (depending on the platform you use). These products follow a set of rules, schedules, and
dependencies as guidelines for ensuring your devices remain up-to-date with the content they need.
Product provisioning also encompasses the use of relay servers. These servers are FTP(S) servers designed to work as a
go-between for devices and the UEM console. Create these servers for each store or warehouse to store product content
for distribution to your devices.
Another product provisioning feature is the staging methods of enrollment. Depending on the device type, you can
perform device staging that quickly enrolls a device and downloads the AirWatch Agent, Wi-Fi profile, and any other
important content. The methods of staging a device vary by platform.
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Chapter 3:
Windows Rugged Enrollment
Enroll Windows Rugged devices into Workspace ONE ™ UEM to access internal content and features using Web
enrollment. Web enrollment directs the user to an enrollment URL to complete enrollment and download the AirWatch
Agent.
Device enrollment is required for all Windows Rugged devices you want managed by Workspace ONE UEM.
If you use the Product Provisioning functionality, you can enroll your Windows Rugged devices through additional
enrollment methods. These additional methods, including sideload staging, require product provisioning.

Enrollment Basics
The Windows Rugged platform covers Windows CE and Windows Mobile devices. For more information on the
supported devices, see Windows Rugged Requirements on page 5
Windows Rugged enrollment uses either the web enrollment method or the Product Provisioning staging functionality.

Web Enrollment
The web enrollment method for Windows Rugged devices asks end users to enter enrollment credentials into the web
browser on the device. For more information, see Enroll Windows Rugged Devices Through Web Enrollment on page 8.
To unenroll Windows Rugged devices, you must perform an Enterprise Wipe in the UEM console followed by manually
uninstalling the AirWatch Agent. For more information, see Unenroll Windows Rugged Devices on page 8.

AirWatch Cab Creator
The AirWatch Cab Creator for Windows Rugged allows you to create custom CAB files for use on Windows Rugged
devices. These custom CAB files consist of any files or applications you add from your computer. Simplify the install
process combining all the files and applications you want on your Windows Rugged device into a custom CAB file. For
more information, see Create a Custom CAB on page 10.
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Enroll Windows Rugged Devices Through Web Enrollment
Simplify device enrollment with Web enrollment instead of downloading the AirWatch Agent manually. Send end users to
a URL to enroll their devices into Workspace ONE ™ UEM.
1. Go to the enrollment URL using the native browser on the device.
2. Enter the applicable Workspace ONE UEM solution information in the Group ID, Username, and Password text
boxes.
3. Optionally, select the Device Ownership type (Employee Owned, Corporate-Dedicated, or Corporate-Shared) and
select Enroll.
4. Accept the Terms of Use if this option is configured.
5. Select Accept to download the AirWatch Agent to the device.
6. Select Continue to complete the enrollment.

Unenroll Windows Rugged Devices
When it is time to unenroll a device from Workspace ONE ™ UEM, ensure that you select the best method for your
situation. Unenroll devices using enterprise wipe from the UEM console or remove the AirWatch Agent from the end-user
device.

Enterprise Wipe
Enterprise wipe enables you to clear corporate data, applications, and profiles from a device without removing personal
data. This action enables you to unenroll an employee-owned device without clearing the personal data.
To perform an enterprise wipe from the UEM console, take the following steps.
1. Navigate to Devices > List View and select the Windows Rugged device you want to unenroll.
2. From the Device Detail page, select the More option.
3. Select the Enterprise Wipe option under Management.
4. Enter your Admin PIN to confirm the Enterprise Wipe.
The device undergoes an enterprise wipe to remove corporate data and unenroll the device from Workspace ONE UEM.
You can also perform an enterprise wipe from the device through the AirWatch Agent. To perform a device-side
enterprise wipe:
1. On the device, open the AW Diagnostics app.
2. Navigate to the Advanced tab.
3. Select Enterprise Wipe.
The device removes corporate data and unenrolls from Workspace ONE UEM.
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Uninstalling the AirWatch Agent
You can also unenroll a device from Workspace ONE UEM by uninstalling the AW Core Agent CAB. To unenroll by
uninstalling the AirWatch Agent:
1. On the device, navigate to Settings > Remove Programs.
2. Find the AW Core Agent CAB and uninstall the application.
While the device removes corporate data, the device remains enrolled with Workspace ONE UEM. This uninstall method
is not the preferred method.

AirWatch Cab Creator for Windows Rugged
The AirWatch Cab Creator for Windows Rugged allows you to create custom CAB files for use on Windows Rugged
devices. These custom CAB files consist of any files or applications you add from your computer.
Simplify the install process combining all the files and applications you want on your Windows Rugged device into a
custom CAB file. You can import CAB files into your own custom CAB file.
This feature allows you to create one custom CAB file that contains all the CAB files you must install on a device. You can
also use the AirWatch Cab Creator to edit any existing CAB file on your PC. The AirWatch Cab Creator also supports
importing files that you can then convert to CAB file upon saving.
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Create a Custom CAB
Simplify installation of files onto your Windows Rugged devices by creating custom CAB files using the AirWatch Cab
Creator for Windows Rugged. These custom CABS can contain your business files or the files necessary to upgrade your
Windows Rugged devices.
Requirements
To use the AirWatch Cab Creator for Windows Rugged, you must meet the following requirements:
l

A Windows device running Windows 7+

l

.NET Framework 4.5

To create a custom CAB file:
1. Download the "AirWatch Cab Creator" for Windows Rugged from the my Workspace ONE documentation
repository.
2. Unzip the file to your preferred directory.
3. Double-click CabBuilder.exe to start the app.

4. Navigate to a file on your Local Drive you want to add to the custom CAB file. You can select a different drive by
selecting Select Drive.
5. Enter an Application Name. This text box is the name of the CAB file after installation.
Remember the name for use in Uninstall Manifest items.
6. Select the file and drag it to the Device Drive pane.
To create a folder on the device drive, right-click the root drive and select Add Folder.
7. Repeat Step 5 for each file or application you want to add to the custom CAB file.
8. (Optional) Add an existing CAB file to your custom CAB file by selecting Import a CAB File.
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9. Select Build a CAB File to save the CAB file and select a name for the file.

10. Select Save to create a custom CAB file.
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Chapter 4:
Windows Rugged Profiles
Profiles are the primary means to manage devices. Configure profiles so your Windows Rugged devices remain secure
and configured to your settings.

Overview
You can think of profiles as the settings and rules that, when combined with compliance policies, help you enforce
corporate rules and procedures. They contain the settings, configurations, and restrictions that you want to enforce on
devices.
The individual settings you configure, such as the settings for Wi-Fi, VPN, and passcodes, are payloads. Consider
associating only one payload per profile. Create multiple profiles for the different settings you want to establish.

Device Access
Some device profiles configure the settings for accessing a Windows Phone device. Use these profiles to ensure that
access to a device is limited only to authorized users.
Some examples of device access profiles include:
l

l

Secure a device with a Passcode profile. For more information, see Create a Passcode Profile (Windows Rugged) on
page 13.
Configure the device launcher and layout. For more information, see Launcher Profile (Windows Rugged) on page 24.

Device Security
Ensure that your Windows Phone devices remain secure through device profiles. These profiles configure the native
Windows security features or configure corporate security settings on a device through Workspace ONE ™ UEM.
Some examples of device security profiles include:
l

Use a Wi-Fi profile to connect enrolled devices to your corporate Wi-Fi without sending the network credentials to
users. For more information, see Dynamic Wi-Fi Profiles (Windows Rugged) on page 14.
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l

Ensure access to internal resources for your devices with the VPN profile. For more information, see Create a VPN
Profile (Windows Rugged) on page 29.

Device Configuration
Configure the various settings of your Windows Phone devices with the configuration profiles. These profiles configure
the device settings to meet your business needs.
Some examples of device configuration profiles include:
l

l

Set up an Exchange account on a device with an Exchange ActiveSync profile. For more information, see Configure an
Exchange ActiveSync Profile (Windows Rugged) on page 21.
Configure the device time zone. For more information, see Create a Time Zone Profile (Windows Rugged) on page 32.

Profiles and Product Provisioning
Create a Passcode Profile (Windows Rugged)
Deploy a Passcode payload to require users to protect their devices with passcodes each time they return from an idle
state. This action ensures that all sensitive corporate information on managed devices remains protected.
Important: Passcode payloads apply only to Windows Rugged devices and not Windows CE devices.
To enforce a Passcode profile:
1. Navigate to Devices > Profiles > List View > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Passcode profile.
5. Configure the Passcode settings:
Settings

Descriptions

Maximum Passcode Age

Requires users to renew passcodes at selected intervals.

Passcode

Sets a specific passcode for the device.

Maximum Passcode Length

Sets the maximum number of characters for your passcode.

Minimum Passcode Length

Sets the minimum number of characters for your passcode.

Minimum Number of Upper Case
Letter

Sets the minimum number of upper case letters a passcode must
contain.
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Settings

Descriptions

Minimum Number of Lower Case
Letter

Sets the minimum number of lower case letters a passcode must
contain.

Minimum Number of Numerical Digits Sets the minimum number of numerical digits a passcode must contain.
Grace period for device lock

Specifies a period of inactivity before locking a device.

Maximum Number of Failed Attempts

Sets a limit on failed passcode attempts before wiping a device.

6. Select Save & Publish to push the profile to devices.

Create a Restrictions Profile (Windows Rugged)
Deploy a Restrictions payload to restrict the options end users have on devices. Restrictions allow you to ensure that
your device is secure by controlling what an end user can use to save and store data.
Important: You can use a Restriction payload only on Windows Rugged devices and not on Windows CE devices.
To enforce a Restrictions profile:
1. Navigate to Devices > Profiles > List View > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Restrictions profile.
5. Configure the Restriction settings.
Settings

Descriptions

Allow Camera

Enable to allow access to the camera application.

Allow External Storage

Enable to allow use of external storage memory.

Remove Encryption on External Storage Enable to allow the removal of encryption on external storage.
Enable On-Device Encryption

Enable to allow encryption on the device.

Allow Bluetooth

Enable to allow the use of Bluetooth.

6. Select Save & Publish when you are finished to push the profile to devices.

Dynamic Wi-Fi Profiles (Windows Rugged)
Using custom attributes, you can create dynamic Wi-Fi profiles that allow you to configure device Wi-Fi settings across
smart groups and OGs without creating multiple profiles. The custom attributes can use device-side values or override
device values with a specific value.
This feature works best when managing many different Wi-Fi networks across your mobile fleet. When updating the
access credentials for all your Wi-Fi networks, import a batch of custom attributes (using the .csv batch import process).
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Using the Device Custom Attribute Values template, you can upload specific values to individual devices. This process
allows you to update the credentials across your mobile fleet quickly without having to create hundreds of different Wi-Fi
profiles.
Dynamic Wi-Fi profiles allow you to specify certain text boxes in the profile as a dynamic value. For example, the Service
Set Identifier can be set to a dynamic value so devices can use their own value as opposed to one service set identifier
per profile. If you have devices in one OG that use different Wi-Fi credentials, use dynamic Wi-Fi profiles to create one
profile that configures the different settings required.
To use a custom attribute in your Wi-Fi Profile, enable the check box next to a text box. Enabling the text box allows you
to select the custom attribute, enter a default value, and set the default value to override device values for the attribute.
For more information on custom attributes and instructions for creating them, see Custom Attributes on page 43.

Configure a Wi-Fi Profile (Windows Rugged)
Create a Wi-Fi profile to connect devices to hidden, encrypted, or password-protected corporate networks. Wi-Fi profiles
are useful for end users who need access to multiple networks or for configuring devices to connect automatically to the
appropriate wireless network.
Important: Zero Wireless Config is not available for Windows CE devices except Psion CE devices. You can provision
Wi-Fi profiles using Zero Wireless Config to Psion CE devices only but not any other Windows CE devices.
To configure a Wi-Fi profile, take the following steps.
1. Navigate to Devices > Profiles > List View > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Wi-Fi profile.
5. Configure the Wi-Fi settings:
Settings

Descriptions

Network Adapter Select the adapter type.
Type
l Standard Microsoft (Zero Wireless Config).
l

l

Motorola Fusion – For more information, see Configure a Motorola Fusion Wi-Fi Profile
(Windows Rugged) on page 16.
Honeywell DeviceScope – Network Adapter Type for Honeywell devices.

Service Set
Identifier

Enter an identifier that is associated with the name (SSID) of the desired Wi-Fi network.

Wi-Fi Meta
Network

Select whether you are connecting through a proxy with Work or connecting directly to the
Internet.

RFBand

Honeywell Network Adapter Type only.
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Settings

Descriptions

IP Addressing
Mode

Select the type of IP Addressing mode used.

Operating Mode

Select the type of operating mode used.

Security Type

Select your Wi-Fi security type.
The type selected determines which additional text boxes display.

Authentication
Type

Select the Authentication type to be used with enterprise applications.

Encryption

Select the encryption type for traffic over the Wi-Fi connection.

Pre Shared Key

Enter the Pre Shared Key for your Wi-Fi.
Displays when Security type is set to WPA Personal or WPA2 Personal.

Domain Name

Enter the Domain name for your certificates.
Displays when Security type is set to WPA Enterprise or WPA2 Enterprise.

Username

Enter the user name for the domain.
Displays when Security type is set to WPA Enterprise or WPA2 Enterprise.

Password

Enter the password used for the domain.
Displays when Security type is set to WPA Enterprise or WPA2 Enterprise.

Identity
Certificate

Select the certificate used to identify the end user to the server.

Server Certificate Select the certificate used to identify the server to the end user.
6. Select Save & Publish to push the profile to devices.

Configure a Motorola Fusion Wi-Fi Profile (Windows Rugged)
The Windows Rugged Wi-Fi profile allows you to specify the network adapter to support the Motorola Fusion type of
network adapter. These settings allow you to control when and how often the device connects to Wi-Fi.
The settings differ based on the Motorola adapter type selected.
Note: The settings that follow are based on the specific Motorola adapter type selected.
To configure a Motorola Fusion Wi-Fi profile:
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
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4. Select the Wi-Fi profile and click the Configure button.
5. Configure the Wi-Fi settings.
Settings

Descriptions

Network Adapter Type

Set to Motorola Fusion. For other adapter types, see Configure a Wi-Fi
Profile (Windows Rugged) on page 15.

Motorola Adapter Type

These options change the text boxes available. Text boxes that are tied to a
specific Motorola adapter type are noted.
l

WLANFusionPublic-specific settings on page 17

l

WLANFusion3xPublic on page 18

l

WLANFusionX2Public on page 19

WLANFusionPublic-specific settings
Set Fusion Options

Set to Yes to list extra network options.

Enable 80211d

Set to Change to enable 802.11d wireless specification for operation in extra
regulatory domains.

Change Regulatory Country Code

Set to Change to select the Country Code for the device.

Set RFBand

Set to Change to specify the RF Band for the device.

Enable Auto Time Config

Set to Change to enable automatic time configuration.

Set FAPI Access Password

Set to Change to select a FAPI access code.

Set FAPI Access Code

Enter the FAPI Access Code you want for the device.

Set Profile Configuration

Set to Yes to set the profile settings.

Service Set Identifier

Identifies the wireless network to be connected. This text box includes an
option to set its value dynamically with custom attributes. You can also use
lookup values.

Profile Country Code

Enter the country code to use with the profile.

Wi-Fi Meta Network

Select whether you are connecting through a proxy with Work or
connecting directly to the Internet.

IP Addressing Mode

Select to use DHCP or Static IP Addressing. If you select Static, enter the
settings for your static IP address.

Disable all other Profiles

Set to Yes to disable all other Wi-Fi profiles on the device.

Operating Mode

Select the operating mode.

Transmit Power Level

Select the transmit power level.

Power Level

Select the balance of power use.

Security Type

Select the encryption type for the network connection.
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Settings

Descriptions

Authentication Type

Select an authentication type to be used with enterprise applications.
Additional text boxes display depending on the type selected.
The FAST authentication types (EAP-FAST-MSCHAPV2, EAP-FAST-TLS, and
EAP-FAST-GTC) add the following additional text boxes:
l

Auto PAC Refreshing

l

Auto PAC Provisioning

l

PACFile Name

l

PACFile Password

l

Use GTC Token

Encryption

Select the encryption type used for the Wi-Fi connection.

Pre Shared Key

Enter the Pre Shared Key used for the Wi-Fi Connection.

Change CCKM Setting

Enable to change the CCKM Mode.

Domain Name

Enter the domain name used in authentication.

Username

Enter the user name used for authentication.

Password

Enter the password used for authentication.

Identity Certificate

Set to Other and enter the certificate name used for authentication.

Server Certificate

Set to Other and enter the certificate name used for authentication.
WLANFusion3xPublic

Set Fusion Options

Set to Yes to list extra network options.

Enable 80211d

Set to Change to enable 802.11d wireless specification for operation in
additional regulatory domains.

Change Regulatory Country Code

Set to Change to choose the Country Code for the device.

Set RFBand

Set to Change to specify the RF Band for the device.

Enable Auto Time Config

Set to Change to enable automatic time configuration.

Set FAPI Access Password

Set to Change to choose a FAPI access code.

Set FAPI Access Code

Enter the FAPI Access Code for the device.

Set WLAN Management Mode

Set to Change to configure the WLAN Management Mode settings.

WLAN Management Mode

Select either the Wireless Zero Config or Fusion Management State
modes.

Set Profile Configuration

Set to Yes to set the profile settings.

Handle Error By

Choose to Ignore Error or Stop On Error.
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Settings

Descriptions

Set Current Management Mode
Option

Set to Change to configure the management mode.

Apply Profile Regardless of Device's Enable to apply the Wi-Fi profile regardless of current management mode.
Current Management Mode
Configuration
Service Set Identifier

Enter the identification of the wireless network the device connects with.

Profile Country Code

Enter the country code to use with the profile.

Wi-Fi Meta Network

Select whether you are connecting through a proxy with Work or
connecting directly to the Internet.

IP Addressing Mode

Select to use DHCP or Static IP Addressing. If you select Static, enter the
settings for your static IP address.

Disable all other Profiles

Set to Yes to disable all other Wi-Fi profiles on the device.

Operating Mode

Select the operating mode.
Transmit Power Level Select the transmit power level.
Adhoc Channel

Select the Ad Hoc channel the devices use.

Encryption

Select the encryption type for the Wi-Fi network.

Pre Share Key

Enter the Pre Shared Key used for the network.

Transmit Power Level

Select the transmit power level.

Power Level

Select the balance of power use.

Security Type

Select the encryption type for the network connection.

Pre Shared Key

Enter the Pre Shared Key used for the Wi-Fi Connection.

Change CCKM Setting

Enable to change the CCKM Mode.

Domain Name

Enter the domain name used in authentication.

Username

Enter the user name used for authentication.

Password

Enter the password used for authentication.

Identity Certificate

Set to Other and enter the certificate name used for authentication.

Server Certificate

Set to Other and enter the certificate name used for authentication.
WLANFusionX2Public

Enable 80211d

Set to Change to enable 802.11d wireless specification for operation in
additional regulatory domains.

Set RFBand

Set to Change to specify the RF Band for the device.

Enable Auto Time Config

Set to Change to enable automatic time configuration.

Set FAPI Access Password

Set to Change to select an FAPI access code.
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Settings

Descriptions

Enable IPv6

Set to Change to enable IPv6 settings.

Set WLAN Management Mode

Set to Change to configure the WLAN Management Mode settings.

WLAN Management Mode

Select either the Wireless Zero Config or Fusion Management State
modes.

Enable FIPS Mode

Set to Change to enable FIPS mode.

Change PreAuth

Enable PreAuth to allow access points to authorize devices before they
officially switchover to the new access point.

Reset Fusion Options

Set to Reset to reset the device's Fusion options when pushing this profile
to the device.

Reset Fusion Data Store

Set to Reset to reset the Fusion data store on a device.

Set Profile Configuration

Set to Yes to set the profile settings.

Handle Error By

Select to Ignore Error or Stop On Error.

Service Set Identifier

Enter the identification of the wireless network the device connects with.

Profile Country Code

Enter the country code to use with the profile.

Wi-Fi Meta Network

Select whether you are connecting through a proxy with Work or
connecting directly to the Internet.

IP Addressing Mode

Select to use DHCP or Static IP Addressing. If you choose Static, enter the
settings for your static IP address.

Disable all other Profiles

Set to Yes to disable all other Wi-Fi profiles on the device.

Operating Mode

Select the operating mode.
Transmit Power Level Choose the transmit power level.
Adhoc Channel

Select the Ad Hoc channel the devices use.

Encryption

Select the encryption type for the Wi-Fi network.

Pre Share Key

Enter the Pre Shared Key used for the network.

Transmit Power Level

Select the transmit power level.

Power Level

Select the balance of power use.

Security Type

Select the encryption type for the network connection.

Pre Shared Key

Enter the Pre Shared Key used for the Wi-Fi Connection.

Change CCKM Setting

Enable to change the CCKM Mode.

Domain Name

Enter the domain name used in authentication.

Username

Enter the user name used for authentication.

Password

Enter the password used for authentication.

6. After setting the Motorola adapter type specific settings, select Save & Publish to push the profiles to devices.
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Exchange ActiveSync Profiles (Windows Rugged)
The Exchange ActiveSync profiles enable you to configure your Windows Rugged devices to access your Exchange
ActiveSync server for email and calendar use.
Strongly consider only using certificates signed by a trusted third-party certificate authority (CA). Mistakes in your
certificates expose your otherwise secure connections to potential man-in-the-middle attacks. Such attacks degrade the
confidentiality and integrity of data transmitted between product components, and might allow attackers to intercept or
alter data in transit.
The Exchange ActiveSync profile supports the native mail client and AirWatch Inbox for Windows Desktop. The
configuration changes based on which mail client you use.
Important: You can use an EAS payload only on Windows Mobile devices and not on Windows CE devices.

Configure an Exchange ActiveSync Profile (Windows Rugged)
Create an Exchange ActiveSync profile to give Windows Phone devices access to your Exchange ActiveSync server for
email and calendar use.
To configure Exchange ActiveSync payloads, take the following steps.
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Exchange ActiveSync profile and click the Configure button.
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5. Configure the Exchange ActiveSync settings.
Settings

Descriptions

Domain

Enter the domain for the Exchange account.
You can use lookup values to create dynamic profiles.

Exchange ActiveSync Host

Enter the hostname or IP address for the Exchange ActiveSync server.

User

Enter the user name for the Exchange account.
You can use lookup values to create dynamic profiles.
Settings

Use SSL

Enable to send all communications through the Secure Socket Layer.

Max Body Truncation

Select the maximum amount an email body is truncated in bytes.

Past Days of Calendar to
Sync

Enter the number of days of Calendar events to download when the account syncs
for the first time on the device.

Past Days of Mail to Sync

Enter the number of days of emails to download when the account syncs for the first
time on the device.

Max HTML Truncation

Select the level of truncation for HTML emails.

Max Email Truncation

Select the maximum amount an email is truncated in bytes.

Max Email File Attachment Select the max size (in MB) that a file can be when attached.
Size (MB)
Allow Sync When Roaming Enable to allow the email client to sync when the device is roaming.
Restrictions
Allow Calendar Sync

Enable to allow the syncing of calendars.

Allow Contacts Sync

Enable to allow the syncing of contacts.

Allow Tasks

Enable to allow the syncing of tasks.

Allows Text Messages

Enable to allow the syncing of text messages.

Allow Email Sync

Allow the syncing of email. Disabling this setting removes access to email through
Exchange Active Sync.
Peak Days and Schedule

Sunday

Enable to allow schedule of syncing on Sundays.

Monday

Enable to allow schedule of syncing on Mondays.

Tuesday

Enable to allow schedule of syncing on Tuesdays.

Wednesday

Enable to allow schedule of syncing on Wednesdays.

Thursday

Enable to allow schedule of syncing on Thursdays.

Friday

Enable to allow schedule of syncing on Fridays.
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Settings

Descriptions

Saturday

Enable to allow schedule of syncing on Saturdays.

Peak Start Time

Select the start time of the peak time period.

Peak End Time

Select the end time of the peak time period.

Sync Schedule Peak

Select what level of syncing happens during the peak time period.

Sync Schedule Off Peak

Select what level of syncing happens outside the peak time period.

6. Select Save & Publish to push the profile to devices.

Credentials Profile (Windows Rugged)
A Credentials profile allows you to push Root, Intermediate, and Client certificates to support any Public Key
Infrastructure (PKI) and certificate authentication use case. The profile pushes configured credentials to the proper
credentials store on the Windows Rugged device.
Even with strong passcodes and other restrictions, your infrastructure remains vulnerable to brute force, dictionary
attacks, and employee error. For greater security, you can implement digital certificates to protect corporate assets. To
use certificates in this way, you must first configure a Credentials payload with a certificate authority, and then configure
your Wi-Fi and VPN payloads. Each of these payloads has settings for associating the certificate authority defined in the
Credentials payload.

Create a Credentials Profile (Windows Rugged)
A Credentials profile pushes certificates to devices for use in authentication. With Workspace ONE ™ UEM, you can
configure credentials for intermediate, trusted root, trusted publisher, and trusted people certificate stores.
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Credentials profile and click the Configure button.
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5. Configure the Credentials settings.
Settings

Description

Credential
Source

Use the drop-down menu to select either Upload or Defined Certificate Authority.

Credential
Name

Enter a name for the credentials certificate. Displays if the Credential Source is Upload.

Certificate

Select Upload, navigate to the desired credential certificate file, and select Save.
Displays if the Credential Source is Upload.

Certificate
Authority

Use the drop-down menu to select a predefined certificate authority.

Certificate
Template

Use the drop-down menu to select a predefined certificate template specific to the selected
certificate authority.

Displays if the Credential Source is Define Certificate Authority.

Displays if the Credential Source is Define Certificate Authority.
Store
Location

Use the drop-down menu to select to save the certificate on the specific user account level or on
the Computer Store for all users of a computer.

Certificate
Store

Select the certificate store folder location from the drop-down menu.
l

Trusted Root Certification Authorities

l

Trusted Publishers

l

Untrusted Certificates

l

Trusted People

6. Select Save & Publish to push the profile to devices.

Launcher Profile (Windows Rugged)
The Workspace ONE ™ UEM App Launcher restricts user access to a list of allowed applications and native features on the
device. Use the App Launcher to control the apps available to end users and the layout of the device home screen.
The Launcher profile enables you to customize the look and layout of the Windows Rugged device home screen. You can
configure the launcher profile to start when the device starts to limit end-user access to the entire device. To limit enduser access to the correct apps on a shared device, you can set the launcher profile to display based on the user group of
the end user. This functionality allows you to tailor the launcher to the role of the end user using a shared device.
Customize the launcher to display different settings and apps based on the layout you want. To manage the device, the
launcher profile includes different tools for admins to troubleshoot the device.

Create a Launcher Profile (Windows Rugged)
Configure the Workspace ONE ™ UEM App Launcher profile to customize the layout and apps of a Windows Rugged
device using the App Launcher. This customization allows you to control end-user access to the device settings and
applications based on the roles of the user.
To configure a Launcher profile:
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1. Navigate to Devices > Profiles & Resources> Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Launcher profile and click the Configure button.
5. Enter a Title for the launcher profile. You can use the supported Workspace ONE UEM Lookup Values. Select ( ) for
a list of all Workspace ONE UEM supported Lookup Values.
6. Define an Administrative Passcode for setting configurations on the device.
7. Define the User Category of the end user if Shared Devices are enabled in the Windows Rugged Agent Settings page.
The user category ties end users to specific Launcher profiles allowing you to tailor Launcher layout and configuration
to individual end users. Consider creating user groups based on the end user's role.
8. Configure the remaining options:
Settings

Descriptions
Allowed Applications

Application Name

Specifies the application name that displays in the Workspace ONE
UEM App Launcher.

File Path to Exe

Defines the file path of the application and includes the executable file.

Arguments (Optional)

Enter any command-line arguments to run the application.

Hide

Masks the application on the device.

Start Up Options

Select the condition that triggers the launcher starting.

Delayed Launch

Select the time (in seconds) that the launcher is delayed from starting
following device boot.
This setting requires Start Up Options to be set to Delayed Start.

Console Application

Defines the application as not having a user interface or as a
background process.

Tools Menu

Lists applications on the Tools menu for the App Launcher.

Background Application

Select if the application requires no user interaction and you want it to
run in the background.

Disable App Close

Removes the close button from the application preventing the user
from closing the app. Select this option only for dedicated use
applications.

Enable Home Button

Allows you to minimize a whitelisted application and return to the
main App Launcher page while keeping the current session active for
that app.
If you want to return to the minimized app, select the icon on the App
Launcher screen.
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Settings

Descriptions

Application Icon Path

Defines the path to the location of the application icon that resides on
the device. If the desired icon does not reside on the device, then you
can upload an image.

Upload Icon

Allows you to upload an image (icon) that can be associated to an
application by entering the path in the Application Icon Path text box.
Settings

View Time

Displays the time for application processes.

Disable Active Sync

Disables the use of the Exchange ActiveSync protocol for application
transactions.

Disable Keyboard

Disables the use of the device keyboard to perform application
processes.

View IP Address

Displays the device's IP address within application processes.

Enable Native Taskbar*

Uses the default taskbar for that device instead of the custom launcher
taskbar.

View Connection Status

Displays the connection status of the device.

Show Message Notification

Displays a message indicator for unviewed messages from a thirdparty application.

Display Organization Group

Displays the Organization Group of the signed-in user.

View Wi-Fi Signal

Displays the strength of the Wi-Fi signal.

View Cell Signal

Displays the strength of the cell signal.

View Battery Icon

Displays the amount of power remaining in the battery.

View Volume

Displays the level the volume is set to on the device.

Display Missed Call Notification

Displays a notification when an incoming call was not
answered/missed.

Display SMS/Text Notification

Displays a notification when the device received a text message.

*When selected, these settings are disabled except for View Time, Disable Active Sync, Disable Keyboard,
and View IP Address. These exceptions exist because the native taskbar only displays the icons/settings
that are available to that device.
Tools
These settings allow the user to customize and manage the contents of the Tools Menu on the Launcher.
You can select any combination of the following options to make those options available to the user on the
Tools Menu. A second option is to whitelist the application under the Allowed Application section by
selecting the Tools Menu option next to that application. A third option is to configure apps directly on a
device, provided the configure option is enabled.
Restart AW Agent

Allows the user to restart the AirWatch Service on the device.
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Settings

Descriptions

Restart AWCM

Allows the user to restart the AWCM Service on the device.

Start AW Diagnostics

Allows the user to open and access the AirWatch Diagnostics utility.

Start App Manager

Allows the user to open and access the Application Manager utility.
The Launcher is capable of multiple profile support. Profiles that are
active and meet the assignment criteria for that device.
Multiple profile support requires AirWatch Agent version 4.0.0.13 or
higher.

Configure

Allows the user to configure all areas of the Launcher directly on the
device, including Allowed Applications, Settings, and Tools Menu.
View/Layout

Select Launcher View/Layout Style Select the format for the view/layout.
l

Grid – Traditional grid layout of applications.

l

List – List of applications with a small thumbnail of the app icon.

l

Plain List – List of applications with no thumbnail of app icon.

l

None – No preset view/layout. End users can select the
view/layout they want. If you select a view/layout other than
None, end users cannot change the view/layout.
Wallpaper

Enable Wallpaper

Enable to set a wallpaper for the Launcher. You must select a
Landscape and Portrait mode image.

9. Select Save & Publish.
Important: Wallpapers cannot exceed 640x480 or be more than 20 KB. Images larger than 20 KB cannot display.

Update the Launcher Profile from the Windows Rugged Device
You might need to change the applications included in the Workspace ONE ™ UEM App Launcher. This action requires
admin credentials to perform.
To make Admin configurations in the Workspace ONE UEM App Launcher:
1. Open the Workspace ONE UEM App Launcher application on the device.
2. Enter the Admin passcode in the Password text box and select Accept.
3. Select the option to Import, Export, or Add applications from and to the list.
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4. Select Add to add an application and complete the following options on the Add Application screen:
l

Application Location – Defines the file path of the application or select the Browse option.

l

Application Name – Defines the name of the application to display in the Workspace ONE UEM App Launcher.

l

Arguments – Defines command-line arguments to run the application.

l

Launch On Start – Starts the application when the Workspace ONE UEM App Launcher is started.

l

Hide from User – Masks the application in the user interface.

l

Console Application – Defines the application as not having a user interface or as a background process.

5. Select Save.

Configure Shared Device Launcher Profiles (Windows Rugged)
Workspace ONE ™ UEM allows you to configure Launcher profiles to support multiple end users sharing a single device.
Use this feature to customize the Launcher for individual users and their different applications to meet their individual
roles.
Important: You must enroll the device into the Parent organization group for the Launcher profiles for various User
Categories to push to the device.
To configure the Launcher profile for shared devices:
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1. Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged > Agent Settings.
2. Select Enable Shared Device Mode.
3. Navigate to Accounts > Users > User Settings > Categories > Add and enter the Name and Description. Consider
creating the User Categories based on the various roles end users have that require different applications on the
device. For example, basic users require different applications than a shift supervisor or manager. To accommodate
this requirement, create different User Categories for the basic user, shift supervisor, and manager.
4. Navigate to Accounts > Users > List View and Add new user or Edit an existing one.
5. Enable Show Advanced User Details and select the applicable Category based on the role of the user.
6. Create and configure a Launcher Profile. Select the applicable User Category based on the role of the user for this
specific Launcher profile.
7. Configured more Launcher profiles for each end-user role. For more information, see Create a Launcher Profile
(Windows Rugged) on page 24
End users must enter their credentials and their group ID. To remove the need to enter the group ID, navigate to Settings
> All Settings > Devices & Users > General > Shared Device and set the Group Assignment Mode to Fixed Organization
Group.

Create a VPN Profile (Windows Rugged)
Create a VPN Profile to deploy corporate VPN settings directly to managed devices. This profile enables end users to
access corporate infrastructure remotely and securely.
Important: You can use a VPN profile only on Windows Rugged devices, but not on Windows CE devices.
To enforce a VPN profile:
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the VPN profile and click the Configure button.
5. Configure the VPN settings.
Settings

Descriptions

Connection
Type

Defines the connection for the VPN.
Both of these types rely on the encryption protocol to be passed within the tunnel because they
do not inherently have their own encryption methods.
l

PPTP – Point-to-Point Tunneling Protocol.

l

IPSec/L2TP – Layer 2 Tunneling Protocol.
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Settings

Descriptions

Connection
Name

Enter the connection name.

Server

Enter the hostname of IP address of the VPN server.

Username

Enter the user name for the VPN.
You can use lookup values to use the device-specific value.

Domain

Enter the domain for the VPN.
You can use lookup values to use the device-specific value.

Authentication Defines the authentication for the VPN.
l

Certificate – Use this option to deploy certificate-based authentication for your VPN
connections.
You must select this option if you select the Connection Type IPSec/L2TP

l

Pre Shared Key – Use the PSK option when you have a shared secret that device users use to
access the VPN.
This authentication type often uses symmetric key algorithms for security.

Shared Secret

Enter the shared secret for the connection.
Displays when Authentication is set to Pre Shared Key.

6. Select Save & Publish to push the profile to devices.

Create a Time Sync Profile (Windows Rugged)
Deploy Time Sync payloads to synchronize the system time on Windows Rugged devices with time servers to ensure that
the device fleet runs on the same clock. This profile is useful for global networks with devices in numerous time zones.
To configure a Time Sync profile:
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Time Sync profile and click the Configure button.
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5. Configure the Time Sync settings:
Settings

Descriptions

Time Sync
Method

Select the preferred method of time sync.
l

l

Time Server – Select to use a Network Time Protocol server with which to sync devices
such as pool.ntp.org.
HTTP – Select to enter a URL. This URL can be any URL. For example, you can use
www.google.com.

l

SNTP – Select to enter a Simple Network Time Protocol such as time.nist.gov.

l

Console – Select to sync the device with the UEM console.

Primary Time
Server

Enter the URL of the time server with which the device syncs.

Port

Enter the port the device uses to sync with the secondary server.

Secondary Server Enter an optional secondary server the device can use if the primary is unavailable.
Displays when Time Server is selected as the Time Sync Method.
Port

Enter the port the device uses to sync.
Displays when Time Server is selected as the Time Sync Method.

Sync Time Every

Enter the number of minutes, hours, or days.

6. Select Save & Publish.

Create a Shortcut Profile (Windows Rugged)
Create a Shortcut profile to push custom icons associated with URLS. These icons provide your end users with the
shortcuts to websites they need.
You can add as many icons as needed to a shortcut payload. Upload the icon image file into the Workspace ONE UEM
console.
To configure a shortcut profile, take the following steps.
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Shortcuts profile and click the Configure button.
5. Configure the Shortcuts settings.
Settings Descriptions
Label

Enter the name associated to the icon that displays on the user's device.
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Settings Descriptions
URL

Enter the URL for the website in which the user is advanced to when the user taps on the icon.

Icon

Upload the image file that displays on the user's device that is associated to the URL.

6. Select Save & Publish to push the profile to devices.

Create a Time Zone Profile (Windows Rugged)
Create a Time Zone profile to configure your Windows Rugged device time zone settings. This profile eliminates having to
remote control into the end user's device to set the time zone manually.
After pushing the profile, the device displays the time zone, and all device activity is time stamped based on that time
zone regardless of the actual device location.
To configure Time Zone profile, take the following steps.
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Time Zone payload, select the Time Zone Setup drop-down, and select Set Time Zone Manually.
5. Select the Time Zone drop-down and select the appropriate time zone from the list.

Create a Custom Attribute Payload
Workspace ONE ™ UEM allows you to create and deploy custom attributes that collect and compare custom-made
values from device. Custom attributes are used to manage devices using attributes assigned to or gathered from the
devices.
These attributes can be collected or created by third-party applications for use with the UEM console. By using custom
attributes, you can ensure that only the devices whose attribute values match the ones you set are selected.
Custom attributes are used by the rules generator of product provisioning to provision products to specific devices.
Ensure that your devices are provided the correct values to prevent incorrect products from being provisioned to them.
See Custom Attributes on page 43 for more information.
To configure a Custom Attributes payload, take the following steps.
1. Navigate to Devices > Products > Profiles > List View and select Add and then select the device platform.
2. Configure the profile's General settings.
3. Select the Custom Attribute profile.
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4. Select Add to configure the custom attributes you want to use.
Settings

Descriptions

Application Select the application (grouping of custom attributes) that contain the attributes you want to
configure.
Custom
Attributes

Select the specific custom attributes for the profile to configure.

Value

Enter the custom attribute value to assign to the device.

Is Dynamic Enable to allow the custom attribute's value to change and be changed based on permissions.
If selected, this looks up the custom attribute value for an individual device when the command is
queued instead of using the default value specified in the payload. If no value is found, the device's
default value is used.
Permission Set the permission of the custom attribute.

Sync

l

Read/Write allows the applications to change the attribute value.

l

Read Only restricts applications from changing the value.

Enable to push the attribute value back to the UEM console to be displayed in the Device Details
page.

You can add additional attributes as necessary.
5. Select Save & Publish to push the profile to devices.

Create a Proxy Profile (Windows Rugged)
Create a proxy profile to set specific proxy settings for devices. Use a proxy to add a layer of security to your Windows
Rugged devices.
To configure a Proxy profile, take the following steps.
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the Proxy profile and click the Configure button.
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5. Configure the profile settings.
Settings

Descriptions

Proxy Type

Select Manual to configure the specific settings or Auto to use the settings of a Proxy URL.

Proxy Server

Enter the proxy server URL.

Proxy Server Port Enter the port used to communicate with the proxy server.
Proxy Username

Enter the user name credential for the proxy server.

Proxy Password

Enter the password credential for the proxy server.

Proxy URL

Enter the URL for the auto proxy settings.

6. Select Save & Publish to push the profile to devices.

Create a GPRS Profile (Windows Rugged)
The General Packet Radio Service (GPRS) allows mobile data on 2G and 3G cellular communication system for GSM
devices. The GPRS payload allows you to configure and control how the device uses GPRS.
To configure a GPRS payload, take the following steps.
1. Navigate to Devices > Profiles & Resources > Profiles > Add and select Add Profile.
2. Select Windows Rugged.
3. Configure the profile's General settings.
4. Select the GPRS profile and click the Configure button.
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5. Configure the GPRS settings.
Settings

Descriptions
General

Enabled

Select to enable GPRS management.

Connection Name

Enter the GPRS connection name.

Destination

Select whether the GPRS connection is to the Internet or a Work intranet.

GPRS Info Access Point
Name

Enter the APN the device must connect to. The APN must follow the correct format:

User name

Enter the user name for connecting to the network.

Password

Enter the password for connecting to the network.

Domain

Enter the network domain.

<network identifier>.mnc<MNC>.mcc<MCC>.gprs

Advanced
Advanced

Enable to configure advanced options.

Specific Name Servers

Enable to enter specific name servers to use.

Country Code

Enter the network country code.

Area Code

Enter the device area code.

Use Country and Area
Codes

Enable to use Country and Area codes.

Phone

Enter the device phone number.

Device Name

Enter the device name for use in phone books.

Device Type

Select the RAS device type.

Use Software
Compression

Allows for faster connection speeds on low-bandwidth networks by compressing the
phone book entries.

Use IP Header
Compression

Allows for faster connection speeds on low-bandwidth networks by compressing the IP
Header.

Specific IP Address

Enable to connect to a specific IP Address.

Read Only

Enable to restrict the device to reading data only.

Authentication Type

Select the type of authentication the network uses.

6. Select Save & Publish.
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The compliance engine is an automated tool by Workspace ONE ™ UEM that ensures all devices abide by your policies.
These policies can include basic security settings such as requiring a passcode and having a minimum device lock period.
For certain platforms, you can also decide to set and enforce certain precautions. These precautions include setting
password strength, blacklisting certain apps, and requiring device check-in intervals to ensure that devices are safe and
in-contact with Workspace ONE UEM.
Once devices are determined to be out of compliance, the compliance engine warns users to address compliance errors
to prevent disciplinary action on the device. For example, the compliance engine can trigger a message to notify the user
that their device is out of compliance.
In addition, devices not in compliance cannot have device profiles assigned to it and cannot have apps installed on the
device. If corrections are not made in the amount of time specified, the device loses access to certain content and
functions that you define. The available compliance policies and actions vary by platform.
For more information about compliance policies, including which policies and actions are supported for a particular
platform, refer to the VMware AirWatch Mobile Device Management Guide, available on docs.vmware.com.
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The AirWatch Agent for Windows Rugged devices is pre-configured with Workspace ONE ™ UEM. Change these settings
when you need the AirWatch Agent to meet certain business needs.
Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged > Agent Settings.

Upgrade the Agent
When a new version of the AirWatch Agent releases, upgrade your devices remotely and easily. With product
provisioning, devices receive the AirWatch Agent CAB file and install it based on directions. For more information, see the
Product Provisioning Guide for Windows Rugged available on Workspace ONE UEM Resources.
If you are using a legacy AirWatch Agent older than version 5.2.x, you must use the legacy Over-the-Air Migration
method. For more information, see https://support.air-watch.com/articles/115001664548.

Device-Side Scripting
The AirWatch AWScript component allows you to configure your Windows Rugged devices through device-side scripting.
The script file uses a dialect of BASIC as its core scripting language and adds Workspace ONE UEM-specific extensions on
top.
For more information on the AWscript and its capabilities, see https://support.airwatch.com/articles/115001664528
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General
Setting

Description

Device ID
Algorithm

Set the unique device identification algorithm used on the device.
l

Device ID Algorithm 3 – Agent uses the OS-provided API to generate the UDID.

l

Device ID Algorithm 5 – Along with the OS-provided API, the agent uses the MAC ID of the device to generate the UDID.

l

Heartbeat
Interval
(min)

Device ID Algorithm 6 – Together with the OS-provided API and the MAC ID of the device, the agent also uses the serial
number of the device to generate the UDID.

Set the time (in minutes) the agent waits before checking in with the Workspace ONE UEM console.

Data Sample Set the time (in minutes) the agent waits to collect data from the device.
Interval
(min)
Data
Transmit
Time
Interval
(min)

Set the time (in minutes) the agent waits to send data collected from the device to the UEM console.

Check-In on
Condition
(Event)

Enable to limit the agent to check-in or beacon to the UEM console only when certain conditions (Wi-Fi
connection, AC Power, or NW Adapter) are met. This helps reduce bandwidth issues as devices typically
meet the condition when they are stored for after hours.

Shared Devices
Setting

Description

Enable Shared
Device Mode

Select this check box to enable shared device functionality. For more information, see the
Windows Rugged Launcher Profile Overview.

Notifications
Setting

Description

Enable Agent Installation Complete Select this check box to enable or disable notifications for Agent installation
Notification
completion.
Enable Product Install Status
Notification

Select this check box to enable or disable notifications through the Agent for
product installation completion.
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Location
Setting

Description

Collect
Location
Data

Enable to allow the agent to determine the device location based on a device's Wi-Fi network. When
available, the agent will report the location to the Workspace ONE UEM console using the Data Transmit
Interval.

Application List
Setting

Description

Applications Poll
Interval (min)

Set the time interval (in minutes) at which the applications list for each device will refresh on
the Workspace ONE UEM console.

Certificate List
Setting

Description

Certificate Poll Interval
(min)

Set the time interval at which the certificate list for each device will refresh on the Workspace
ONE UEM console.

Proxy
Setting

Description

Proxy Configuration Enable to allow the configuration of a proxy settings.

Application Manager Package Scheduler
These settings are for the legacy AirWatch Agent v3.3.
Use the APPLICATION MANAGER PACKAGE SCHEDULER to define a schedule for devices with the AirWatch Agent v3.3+
to retrieve products provisioned on schedule.
Setting

Description

Add

Select to create schedules for provisioning products using Products (Legacy).

Application Manager
Scheduler

Select the hour the product begins to push to devices.

Randomization Window
(min)

Select the amount of time the product is pushed over. The order of devices is
randomized.
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Sideloading Cab
Setting

Description

Request Enrollment Enable to create a side loading cab to quickly enroll devices.
Cab
Platform

Select the operating system for the cab file.

Enrollment User

Select a user for the cab file to use during enrollment. The cab file can be used on multiple devices
regardless of the user selected.

Enrollment User
Password

Enter the password for the user for enrolling with the cab file.

Show Characters

Select to show password characters.

Power on Password
Use the Power On Password option to control system BIOS password options to secure the device from unauthorized
users when they turn on the device.
Important: Power On Password is only for Athena and requires the Power On Password CAB, which is a separate CAB
component. You can perform a similar function through the AirWatch Agent by pushing down a "Passcode" profile.
To configure the Power On Password option:
1. Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged.
2. Enable Power On Password and set the options, including:
l

l

Path to App Update – Enter the path to the AppUpdate.exe file so that this loader can check for updates, install
the updates and load and run the applications it updates.
Intermec Reboot Exe – Enter the path to the Reboot.exe file on Intermec devices used to warm boot the device.

3. Select Save.

Advanced Settings
Use these options to update applications on Windows Rugged devices and to reset devices.
1. Navigate to Groups & Settings > All Settings > Devices & Users > Windows > Windows Rugged.
2. Select Advanced and set the options, including:
l

Force Password Expiration – Forces the password to expire so that the user must change the password.

l

View Power On Password – Enables the user to see the password they enter.

3. Select Save.
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Windows Rugged Device Logging with the AirWatch Agent v5.X+
All device log settings are configured through the log_config.cfg file located in the "\Program Files\AirWatch" directory.
When this file is opened up and viewed in Notepad, it appears with the following text and options.

[*]
trace_level=5
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

[aw_setup]
trace_level=5
max_file_size_kb=256
files_to_keep=2
log_file_path=\
use_local_time=false

[awregisterdevice.exe]
trace_level=3
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

[awapplyprofile.exe]
trace_level=5
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

[awremotecontrol.exe]
trace_level=1
max_file_size_kb=256
files_to_keep=2
log_file_path=\Program Files\AirWatch\Logs
use_local_time=false

The first setting group that appears under the asterisk is the default configuration settings for all logs available on the
device.
Trace levels vary from 1 to 5. A level of 1 provides the most basic and least amount of information. Developers use Level 5
for debugging purposes since it provides all available messaging. There is a tradeoff between the trace level and the log
size. A higher trace level increases the size of the log files due to messaging increase. The trace level that is set in the
default section applies to all log files on a device.
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You can keep the default log level low and still increase the log level for the four options below the default log level.
Specify the log level for each of the options if you select to use a different trace level than the default level.
The logs available on a device vary based on what is configured and the OEM of the device. The following log files are
generally available on Windows Rugged devices:
l

aw_setup – Provides logging information relating to the AWMasterSetup utility. The AWMasterSetup utility initiates
the agent install and uninstall process on a device. This log file is the only log file that is not located in the "\Program
Files\AirWatch" directory. The log is instead located in the root of the file system.

l

awacmclient – Provides logging information relating to the AWCM client on the device.

l

awapplicationmanager – Provides logging information relating to product provisioning.

l

l

l

l

l

l

awprocesscommands – Provides logging information relating to the execution of MDM commands and installation
of profiles.
AWService – Provides information about the AWService.exe component, which is responsible for managing beacon
and interrogator samples.
awapplyprofile – Relates to installation of the agent settings XML file which occurs during the enrollment process.
awregisterdevice – Provides information about the registering of the device that occurs during the enrollment
process.
awapplauncher – Provides information about the Application Launcher executable. This log only applies to devices
using the App Launcher.
fusionwlansetup – Provides information about configuring and setting up the Fusion Wi-Fi driver on Motorola
devices.

General Process for Configuring Log Files
1. Transfer the log file to your PC using the file manager utility in device details or through remote management.
2. Open the log file using a basic text editor such as Notepad.
3. Edit the desired trace level to the needed value.
4. Save the log file.
5. Transfer the log file back to the "Program Files\AirWatch" directory on the devices. Consider first deleting the old
log_config.cfg file on the device.
6. Restart the AWService on the device once it has the updated log_config.cfg file. Use the Restart AirWatch Agent or
the Warm Boot device actions available in the UEM console.
7. Once the AWService restarts, the new logging configuration takes effect.
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Custom attributes enable administrators to extract specific values from a managed device and return it to the Workspace
ONE UEM console. You can also assign the attribute value to devices for use in product provisioning or device lookup
values.
These attributes allow you to take advantage of the rules generator when creating products using Product Provisioning.
Note: Custom attributes (and the rules generator) are only configurable and useable at Customer-level organization
groups.

Custom Attributes Database
Custom attributes are stored either as XML files on the device or in the custom attribute database on the Workspace
ONE ™ UEM console server. When using the database, custom attributes are sent as samples to Workspace ONE UEM
periodically for asset tracking of key/value pairs. If a record in the device database is configured with 'Create Attribute' =
TRUE, then the AirWatch Agent automatically retrieves the Name and Value sent with the custom attributes sample. The
key/value pair displays in the Device Details page for the device in the Custom Attributes tab.

Create Custom Attributes
Create a custom attribute and values to push to devices. You create the attributes and values associated with them. For
more information, see Create Custom Attributes on page 44.

Importing Custom Attributes
The custom attribute batch import feature allows you to load custom attributes and corresponding values into the
system in bulk. In the templates provided, each column corresponds to one custom attribute and each row corresponds
to their different parameters. For more information, see Custom Attributes Importing on page 44.
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Platform-Specific Custom Attributes Provisioning
You can push custom attributes to a device using XML provisioning for use with advanced product provisioning
functionality. The method for pushing the XML varies based on the device platform.

Create Custom Attributes
Create a custom attribute and values to push to devices. These attributes and values control how product rules work and
function as lookup values for certain devices.
1. Navigate to Devices > Staging & Provisioning > Custom Attributes > List View.
2. Select Add and then select Add Attribute.
3. Under the Settings tab, enter an Attribute Name.
4. Enter the optional Description of what the attribute identifies.
5. Enter the name of the Application that gathers the attribute.
6. Select Collect Value for Rule Generator to make the values of the attribute available in the drop-down menu of the
rule generator.
7. Select Use in Rule Generator if you want to use the attribute in the rule generator.
8. Select Persist to prevent the removal of the custom attribute from the Workspace ONE ™ UEM console unless an
Admin or an API call explicitly removes it. Otherwise, the attribute is removed as normal.
If you delete a custom attribute reported from a device to the UEM console, a persisted custom attribute remains in
the UEM console.
Custom attribute persistence is only available to Android and Windows Rugged devices.
9. Select Use as Lookup Value to use the custom attribute as a lookup value anywhere in the UEM console.
For example, you can use custom attributes as part of a device friendly name to simplify device naming.
10. Select the Values tab.
11. Select Add Value to add values to the custom attribute and then select Save.

Custom Attributes Importing
The custom attribute batch import feature allows you to load custom attributes and corresponding values into the
system in bulk. In the templates provided, each column corresponds to one custom attribute and each row corresponds
to their different parameters.
With the templates, you can import custom attributes in different ways and with different information.
Caution: The syntax of the first column of each template must be replicated exactly. Failure to use the proper syntax
can cause database issues and result in loss of data.
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Template Types
l

Custom Attributes Template – Allows you to define a custom attribute and its settings.

l

Custom Attribute Values Template – Allows you to define the values of predefined custom attributes.

l

Device Custom Attribute Values – Allows you to define the values of predefined custom attributes for individual
devices based on the cross reference (Xref) value. The Xref values determine the individual devices receiving the value
for each custom attribute.

1. DeviceID (Workspace ONE ™ UEM assigned DeviceID when the device enrolls)
2. Serial Number
3. UDID
4. MAC Address
5. IMEI Number
Save the file as a .csv before you import it.

Windows Rugged Custom Attributes
Use XML provisioning to collect custom attributes based on device details. Custom attributes enable you to use
advanced product provisioning functionality.

Implementation
To begin collecting custom attributes, take the following steps.
1. Navigate to Devices > Staging & Provisioning > Components > Files/Actions, then select the Add Files/Actions
button, and then select Windows Rugged as your platform.
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2. Create an XML product. For more information, see Create an XML Provisioning File on page 47. The manifest includes
an action to download the XML file to \Program Files\Airwatch\Cache\Profiles.
Upon receiving the XML file, the AirWatch Agent for Windows Rugged creates a custom attributes output file. During the
next check-in with AirWatch, the agent sends the output file to the Workspace ONE ™ UEM console.
Once the XML file installs, the custom attributes requested in the file are reported to the UEM console. These values
display in the UEM console on the Device Details page under custom attributes. The Device Details page enables you to
view the name of the attribute and the values returned from each device. These values can be used to create product
assignment rules using the Custom Rules system.

You can also view existing custom attributes for all devices at a particular organization group and manually create custom
attributes directly in the UEM console. Navigate to Devices > Staging & Provisioning > Custom Attributes > List View to
see these custom attributes listed. Any custom attribute created in this manner automatically associates with a device
and its respective custom attribute value that is successfully transmitted to the UEM console.

Syncing Registry Settings
To synchronize the registry settings on a Windows Rugged device with the console, which is likely the most common use
of custom attributes for Windows Rugged devices, you must create a custom XML file. Below is an example of the format
of an XML file that can pull information from the registry on a device:
<?xmlversion="1.0"?>
-<wap-provisioningdocallowRemoval="True"name="GetTypicalRegValues/V_1"id="5a63204f-848c-42d5-9c14-4ca070743920">
-<characteristicuuid="f49a9cb5-48e9-47cd-84cc-ef122dcb5d50"type="com.airwatch.getregistryinfo.winmo">
<reg_valuevalue_name="Username"key_name="HKEY_LOCAL_MACHINE\Ident"custom_attribute_name="HKLM_Ident_Username"/>
<reg_valuevalue_name="OrigName"key_name="HKEY_LOCAL_MACHINE\Ident"custom_attribute_name="HKLM_Ident_OrigName"/>
<reg_valuevalue_name="BootCount"key_name="HKEY_LOCAL_MACHINE\Comm"custom_attribute_name="HKLM_Comm_
BootCount"/>
<reg_valuevalue_name="DeviceIdAlgorithm"key_name="HKEY_LOCAL_MACHINE\Software\AirWatch"custom_attribute_
name="Software_AirWatch_DeviceIdAlgorithm"/>
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</characteristic>
</wap-provisioningdoc>
It must be in the previous format for the XML file to get correctly parsed and the registry settings to be outputted to a
key value pair that can be exported back to the UEM console. In this example, the registry key path is “HKEY_LOCAL_
MACHINE\Ident” for two of the values and within that key path it is reading the values of “user name” and “OrigName”.
The ‘custom_attribute_name’ parameter is simply the name of the custom attribute that displays in the console and
corresponds to the value read from the device.

Using Third-Party Applications to Create Custom Attributes
If you want to create custom attributes using a third-party application, you need that application to export an XML file
with a key value pair to the Program Files\AirWatch\Cache\CustomAttributes directory on the device. Once an XML file
with a key value pair is present in this directory, it is parsed by the agent and included in the next interrogator sample.
The XML key/value pair must be in the following format.
<?xmlversion="1.0"?>
-<attributes>
<attributename="HKLM_Ident_Username"value="guest"/>
<attributename="HKLM_Ident_OrigName"value="Pocket_PC"/>
<attributename="HKLM_Comm_BootCount"value="1"/>
<attributename="Software_AirWatch_DeviceIdAlgorithm"value="3"/>
<attributename="HKLM_SoftwareAW_SerialNo"value="13233521403231"/>
</attributes>
‘Attribute name’ is the name of the attribute in the console while ‘value’ is the corresponding value that is associated
with that attribute.

Create an XML Provisioning File
XML provisioning allows you to download a custom-designed XML file to a device in a provisioning product. After the file
is downloaded, it runs an install command to extract the settings from the XML file and install them on the device.
1. Navigate to Devices > Staging & Provisioning > Components > Files/Actions and select Add Files/Actions.
2. Select your platform.
3. Enter the required settings on the General tab, then select the Files tab and upload the desired XML file and enter
the destination path on the device.
4. Select the Manifest tab and Add an Install Action for the XML file.
5. Select Save.
6. Navigate to Devices > Staging & Provisioning > Products List View, and select Add Product.
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7. Select your platform.
8. Enter the General information.
9. Select the Manifest tab.
10. Select Install Files/Actions and select the files and actions just created.
11. Save and Activate the product.
The product downloads to all assigned devices and the XML file successfully installs.
XML Provisioning is for Windows Mobile devices only and not Windows CE.
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After your devices are enrolled and configured, manage the devices using the Workspace ONE ™ UEM console. The
management tools and functions enable you to keep an eye on your devices and remotely perform administrative
functions.
You can manage all your devices from the UEM console. The Dashboard is a searchable, customizable view that you can
use to filter and find specific devices. This feature makes it easier to perform administrative functions on a particular set
of devices. The Device List View displays all the devices currently enrolled in your Workspace ONE UEM environment and
their status. The Device Details page provides device-specific information such as profiles, apps, AirWatch Agent version
and which version of any applicable OEM service currently installed on the device. You can also perform remote actions
on the device from the Device Details page that are platform-specific.

Device Dashboard
As devices are enrolled, you can manage them from the Workspace ONE ™ UEM Device Dashboard. The Device
Dashboard provides a high-level view of your entire fleet and allows you to act on individual devices quickly.
You can view graphical representations of relevant device information for your fleet, such as device ownership type,
compliance statistics, and platform and OS breakdowns. You can access each set of devices in the presented categories
by selecting any of the available data views from the Device Dashboard.
From the List View, you can take administrative action: send messages, lock devices, delete devices, and change groups
associated with the device.

Device List View
Select Devices > List View to see a full listing of all devices.
The Last Seen column displays an indicator showing the number of minutes elapsed since the device has checked-in.
Select a device in the General Info column at any time to open the details page for that device.
Sort by columns and configure information filters to review device activity based on specific information. For example,
sort by the Compliance Status column to view only devices that are currently out-of-compliance and target only those
devices. Search all devices for a friendly name or user name to isolate one device or user.
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Customize Device List View Layout
Display the full listing of visible columns in the Device List view by selecting the Layout button and select the Custom
option. This view enables you to display or hide Device List columns per your preferences.
There is also an option to apply your customized column view to all administrators. For instance, you can hide 'Asset
Number' from the Device List.
Once all your customizations are complete, select the Accept button to save your column preferences and apply this new
column view. You can return to the Layout button settings at any time to tweak your column display preferences.

Search in Device List View
You can search for a single device for quick access to its information and take remote action on the device.
To run a search, navigate to Devices > List View, select the Search List bar and enter a user name, device friendly name,
or other device-identifying element. This action initiates a search across all devices, using your search parameter.

Windows Rugged Device Details Page
Use the Device Details page to track detailed device information and quickly access user and device management actions.
You can access Device Details by selecting a device Friendly Name from the Device List View, using one of the Dashboards,
or with any of the search tools.
From the Device Details page, you can access specific device information broken into different menu tabs. Each menu tab
contains related device information depending on your Workspace ONE ™ UEM deployment.

Remote Actions
The More drop-down on the Device Details page enables you to perform remote actions over the air to the selected
device.
The actions vary depending on factors such as the device platform, UEM console settings, and enrollment status:
l

l

l

Add Tag – Assign a customizable tag to a device, which can be used to identify a special device in your fleet.
AirWatch Agent (Query) – Send a query command to the device's AirWatch Agent to ensure it has been installed and
is functioning normally.
App Remote View – Take a series of screenshots of an installed application and send them to the Remote View
screen in the UEM console. You may choose the number of screenshots and the length of the gap, in seconds,
between the screenshots.

l

Apps (Query) – Send an MDM query command to the device to return a list of installed apps.

l

Certificates (Query) – Send an MDM query command to the device to return a list of installed certificates.

l

l

Change Organization Group – Change the device's home organization group to another pre-existing OG. Includes an
option to select a static or dynamic OG.
Clear Passcode (Device) – Clear the device passcode. To be used in situations where the user has forgotten their
device's passcode.
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l

l

l

l

l

l

Delete Device – Delete and unenroll a device from the UEM console. This action performs an Enterprise Wipe and
remove its representation in the UEM console.
Device Information (Query) – Send an MDM query command to the device to return basic information on the
device such as friendly name, platform, model, organization group, operating system version and ownership status.
Device Wipe – Send an MDM command to wipe a device clear of all data and operating system. This puts the device
in a state where recovery partition will be needed to reinstall the OS. This action cannot be undone.
Edit Device – Edit device information such as Friendly Name, Asset Number, Device Ownership, Device Group and
Device Category.
Enterprise Reset – Enterprise Reset a device to factory settings, keeping only the Workspace ONE UEM enrollment.
Enterprise Wipe – Enterprise Wipe a device to unenroll and remove all managed enterprise resources including
applications and profiles. This action cannot be undone and re-enrollment will be required for Workspace ONE UEM
to manage this device again. Includes options to prevent future re-enrollment and a Note Description field for you to
add any noteworthy details about the action.
o

l

l

l

l

l

l

l

l

l

l

l

Enterprise Wipe is not supported for cloud domain-joined devices.

File Manager – Launch a File Manager within the UEM console that enables you to remotely view a device's content,
add folders, conduct searches and upload files.
Provision Now – Provision products to a device. Provisioning is the ability to create an ordered installation of files,
actions, profiles and applications into a single product that can be pushed to devices.
Query All – Send a query command to the device to return a list of installed apps (including AirWatch Agent, where
applicable), books, certificates, device information, profiles and security measures.
Registry Manager – Launch a Registry Manager within the UEM console that enables you to remotely view a device's
OS registry, add keys, conduct searches and add properties.
Remote Control – Take control of a supported device remotely using this action, which launches a console
application that enables you to perform support and troubleshooting on the device.
Remote Management – Take control of a supported device remotely using this action, which launches a console
application that enables you to perform support and troubleshoot on the device.
Request Device Check-In – Request that the selected device check itself in to the UEM console. This action updates
the Last Seen column status.
Restart AirWatch Agent – Restart the AirWatch Agent. To be used during troubleshooting for when the enrollment
process or submodule installation process is interrupted.
Send Message – Send a message to the user of the selected device. Choose between Email, Push Notification
(through AirWatch Cloud Messaging), and SMS.
Start/Stop AWCM – Start/Stop the Cloud Messaging service for the selected device. VMware AirWatch Cloud
Messaging (AWCM) streamlines the delivery of messages and commands from the Admin Console by eliminating the
need for end users to access the public Internet or utilize consumer accounts, such as Google IDs.
Task Manager – Launch a Task Manager within the UEM console that enables you to remotely view a device's
currently-running tasks, including task Name, Process ID and applicable Actions you may take.
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l

l

View Manifest – View the device's Package Manifest in XML format from the UEM console. The manifest on
Windows Rugged devices lists metadata for widgets and apps.
Warm Boot – Initiate a restart of the operating system without performing a power-on self-test (POST).

Advanced Remote Management
Advanced Remote Management (ARM) allows you to connect remotely to end-user devices so you can help with
troubleshooting and maintenance. ARM requires your computer and the end-user device to connect to the Remote
Management Server to facilitate communication between the Workspace ONE UEM console and the end-user device.
For more information on installing, configuring, and using Advanced Remote Management, see the VMware Workspace
ONE UEM Advanced Remote Management Guide, available on docs.vmware.com.
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