Occasionally you need to troubleshoot your Workspace ONE AirLift deployment. Issues can arise with the communication between services, transitions to modern management, and other areas.

When you are troubleshooting Workspace ONE AirLift, you should first look for the Workspace ONE AirLift log file. You can find the logs at C:\ProgramData\VMware\VMware AirLift\Logs\. You can also use the Support bundle feature in Workspace ONE AirLift to gather the logs, SQL data, and environment information automatically to expedite the troubleshooting process.

Profiles Created Using Workspace ONE AirLift Fail to Install on End-User Devices

Workspace ONE AirLift policies exported into profiles in Workspace ONE UEM occasionally fail to install on end-user devices.

Problem

Exported Policies occasionally fail to install on the end-user devices.

Cause

After exporting policies to Workspace ONE UEM to create profiles, the profiles sometimes fail to install on end-user devices.

Solution

  1. In the Workspace ONE UEM console, navigate to the profile that failed to install.
  2. Edit the profile.
  3. Create a new version of the profile.
  4. Unselect Make Commands Atomic.
  5. Select Save and Publish this new version.

ADMX policies fail to display in the policies page in Workspace ONE AirLift

ADMX policies sometimes fail to display in Workspace ONE AirLift.

Problem

ADMX policies sometimes fail to display in Workspace ONE AirLift.

Cause

This issue could be related to a Microsoft Known issue releated to ADMX and ADML language files. For more information, see https://support.microsoft.com/en-au/help/2688272/wrong-error-message-for-missing-adml-files.

Solution

Ensure you have the ADML language files for any ADMX files you use.