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Certificate Authority Integrations

Certificates help protect your infrastructure from brute force attacks, dictionary attacks, and
employee error. If you use certificates, integrate your certificate authority with VMware
Workspace ONE® UEM powered by AirWatch for increased stability, security, and authentication.
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Compare Microsoft Certificate
Authority Models

Find out what Microsoft certificate authority (CA) models Workspace ONE UEM supports. View
a high-level comparison of each CA type and consider which configuration might work best for
your deployment.

= Available Microsoft Certificate Authority Models
m  Comparison Matrix by Protocol

m  Workspace ONE UEM Directly to CA

m  Device to CA with UEM as Delegate

m Workspace ONE UEM SCEP Proxy Between Device and CA

Available Microsoft Certificate Authority Models

Workspace ONE UEM offers several deployment options for Microsoft certificate authorities.

m Workspace ONE UEM to the CA- This model uses the DCOM protocol. Workspace ONE UEM
communicates directly with the Microsoft CA or through the AirWatch Cloud Connector to
the CA.

= Mobile Devices to the CA - This model uses the NDES (a Microsoft proprietary version
of SCEP) or SCEP protocol. Workspace ONE UEM only delegates certificate transactions
between the device and the Microsoft CA.

m Workspace ONE UEM SCEP Proxy - This model uses the NDES or SCEP protocol. Workspace
ONE UEM is the proxy that sends certificate transactions between the device and the CA
endpoint. The NDES/SCEP endpoint is not exposed to the Internet.

VMware, Inc.
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Comparison Matrix by Protocol

Considerations

Key Benefit

Devices Supported

Architecture

Key Pair Generation

Ports

Certificate Template

Certificate Renewal

Certificate Revocation

VMware, Inc.

DCOM Protocol:
Workspace ONE UEM to
CA

You can automate

the certificate lifecycle
management (certificate
revocation and renewal).

Android
iOS
Windows 10

macOS

Workspace ONE UEM
servers must have DCOM
access to the CA.

CA server handles the key
pair generation.

DCOM Port 135: Microsoft
DCOM Service Control
Manager

DCOM Ports 1025-5000:
Default ports for DCOM
processes but you can
configure the port range to
any non-standard ports.

Supports multiple
templates.

For example, a single CA
supports Wi-Fi, VPN, and
email certificates.

Automatic renewal
available.

Supported

NDES/SCEP Protocol:
Workspace ONE UEM as
Delegate

Each device generates and
has its own key pair.

Android
iOS
Windows 10

macOS

NDES/SCEP server must be
externally available to the
Internet.

Device handles the key pair
generation.

HTTP/HTTPS 443 or 80

Single template per
instance.

For example, Wi-Fi, VPN,
and email certificates
require three separate
templates.

SCEP - Requires manual
renewal by profile repush.

NDES - Automatic renewal
available.

Not supported

NDES/SCEP Protocol:
Workspace ONE UEM
SCEP Proxy

The NDES/SCEP endpoint
is not exposed to the

Internet.

®  Android

m iOS

m  Windows 10
B macOS

Workspace ONE UEM must
be able to reach the NDES/
SCEP server.

Device handles the key pair
generation.

HTTP/HTTPS 443 or 80

Single template per
instance.

For example, Wi-Fi, VPN,
and email certificates
require three separate
templates.

SCEP - Requires manual
renewal by profile repush.

NDES - Automatic renewal
available.

Not supported
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Workspace ONE UEM Directly to CA
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Direct CA integration with Workspace ONE UEM over DCOM provides functionality for mobile
certificate management. With direct CA integration, unlike with regular SCEP, there are no
exposed endpoints of your Public Key Infrastructure (PKIl) left open and vulnerable to attack.
Plus, it offers additional features such as the ability to issue multiple certificate templates and
revoke certificates from the CA by including them in a Certificate Revocation List (CRL).

For on-premises, Workspace ONE UEM can directly communicate to your CA within the internal
network. For SaaS, you can use the AirWatch Cloud Connector to securely connect Workspace
ONE UEM to your CA.

1 The device enrolls with Workspace ONE UEM.

2 Workspace ONE UEM sends a request to the CA to issue a certificate for the enrolled device
using domain credentials.

3 The CAissues a certificate for the enrolled device.
4 The CA sends the device's certificate to Workspace ONE UEM.

5 Workspace ONE UEM generates a configuration profile for the enrolled device and attaches
the certificate to the profile.

6 Workspace ONE UEM sends the configuration profile and the certificate to the enrolled
device.

VMware, Inc.
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Device to CA with UEM as Delegate

Workspace ONE UEM can act as a delegate between the device and the CA, sending certificate
transactions between the device and the CA over NDES/SCEP. This integration with NDES/SCEP
and the device positions Workspace ONE UEM to never come in contact with the device
certificate. Workspace ONE UEM only acts as a delegate so that the device receives its certificate
from the CA.

Mobiles l'_zevice ° 8

Workspace ONE UEM Server

O o=
L

A |

A
5

U
~ ™

!

e

ﬂ CA (Ext or Int)

This is the typical NDES/SCEP configuration currently found in most existing implementations that
include Wi-Fi access points, routers, and other network equipment. In this scenario, Workspace
ONE UEM is not given the responsibility of managing the device certificate. Also, the token is
transmitted to the device over the Internet so there is an added risk that an unauthorized person
can intercept the certificate.

1
2

The device enrolls with Workspace ONE UEM.
Workspace ONE UEM sends informaton using NDES/SCEP to the device.

The NDES/SCEP server authorizes approval and sends Workspace ONE UEM a token for the
enrolled device.

Workspace ONE UEM notifies the enrolled device about the approval, the token, and server
information.

The enrolled device communicates directly with the NDES/SCEP server because it has
approval.

The NDES/SCEP server requests that the CA generates a certificate for the enrolled device.
The CA generates a certificate and returns it to the NDES/SCEP server.

The NDES/SCEP service sends the certificate to the device.

VMware, Inc. 8
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Workspace ONE UEM SCEP Proxy Between Device and CA

If you do not want to expose your NDES/SCEP endpoints to external devices, you can use the
Workspace ONE UEM SCEP Proxy. The SCEP Proxy allows Workspace ONE UEM to act as an
intermediary between the NDES/SCEP server and the device. It forwards and returns requests
and responses between the two components. Workspace ONE UEM does not have the NDES/
SCEP server's private key, so it cannot parse requests from devices.
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For on-premises, Workspace ONE UEM can proxy to a CA on the same or different domains. For
SaaSs, use the AirWatch Cloud Connector to securely connect Workspace ONE UEM to your CA.
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The device enrolls with Workspace ONE UEM.

Workspace ONE UEM sends information to the NDES/SCEP server to request that the CA
issue a certificate to the enrolled device.

The NDES/SCEP service requests that the CA generate a certificate for the enrolled device.
The CA generates a certificate and sends it to the NDES/SCEP service.
The NDES/SCEP server receives the certificate and sends it to Workspace ONE UEM.

Workspace ONE UEM generates a configuration profile for the enrolled device and attaches
the certificate to the profile.

Workspace ONE UEM sends the configuration profile and the certificate to the enrolled
device.

VMware, Inc.



AD CS Via DCOM

Install and setup the Microsoft certificate authority (CA) for direct integration with Workspace
ONE UEM over the DCOM protocol.

For Workspace ONE UEM to use a certificate in a profile used to authenticate a user, an
enterprise CA must be set up in the domain. Additionally, the CA must be joined to the same

domain as AirWatch Cloud Connector to successfully manage certificates within Workspace ONE

UEM.

There are several methods for Workspace ONE UEM to retrieve a certificate from the CA. Each

method requires the basic installation and configuration described in this documentation. Sample

CA Configurations are shown below.

m On Premises - All Workspace ONE UEM application servers are internal. The console, Device
Services, and CA must be in the same domain.AirWatch Cloud Connector is not installed.

_________________________________________________________

console/Device Services

X Internet X : DMZ : ! Internal !
1 1 1 11 1
1 1 1 11 1
1 I I 1
I ‘ I—; L - :[nunn] !
! 1 1 oLz :
: Workspace ONE UEM Internal CA
1 1
1 1
1 1

_________________________________________________________

m On Premises - Device Services is located in the DMZ. CA and Workspace ONE UEM servers
are internal. The console, Device Services, and CA must be in the same domain. AirWatch
Cloud Connector is not installed.

______________________________________________________________

UEM console

i Internet ! DMz . Internal !
1 LI | LI 1
1 11 — L 1
1 I I 1
1 1
! D—> L1 > © |« — > < e :
1 — o !
: [ 1 = L1 —— — :
1 Device Services Internal CA Workspace ONE 1
1 1
1 1
1 1

m  On Premises - Devices Services, AirWatch Cloud Connector, Workspace ONE UEM servers,
and CA are internal.

VMware, Inc.
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Internet

LB

Device Services

Internal
— ACC —
B oo E
CACALc3 E=
= o

Internal CA
"DG‘GD"

Workspace ONE
UEM console

___________________________________________

m On Premises - Device Services is located in the DMZ. AirWatch Cloud Connector , Workspace
ONE UEM servers, and CA are internal.

Internet

________________________________

m  SaaS - Workspace ONE UEM as SaaS. AirWatch Cloud Connector and CA are internal. The

EACACAE]

Hglk

[DDDU

Workspace ONE
UEM console

ACC and CA must be in the same domain.

____________________

1 Internet (| DMZ [ Internal !
1 LI | | 1
1 1 [} 1
1 11 |} 1
1 LI | |} 1
1 [GGDG LI | |} 1
1 I I 1

1
: Workspace ONE <% I T <~ - - I T | <F 1
! UEM SaaS Server T T 1 :
I S o o I
1 1 | 1
1 LI | [ 1
1 1 [} 1
1 LI | [ 1
e, P b b e e e e e e .
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Prerequisites

Requirement Description

Software Windows Server 2008 R2 SP1, Windows Server 2012,
Windows Server 2012 R2, or Windows Server 2016
Consider using the Enterprise version of Windows server
for 50 or more users.

Network The Workspace ONE UEM console server, VMware
AirWatch Cloud Connector(ACC) server if you are using
ACC, must be able to communicate to the Microsoft CA
over all configured DCOM ports.
m  Port 135: Microsoft DCOM Service Control Manager.
m  Ports 1025 - 5000: Default ports DCOM processes.
m Ports 49152 - 65535: Dynamic Ports.

This port range can be configured to be any number
of non-standard ports depending on your DCOM
implementation. However, these ports are used by
default.

Other m  Server must be a member of the same domain as the
Workspace ONE UEM application server to install the
Enterprise CA.

m Administrative access to the server.

VMware, Inc.
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Procedure

1 Install the Micrsoft CA role.

a Addthe ADCS role.

1

5
6

Click the Server Manager icon next to the Start button to open the Server Manager
window.

Click Roles and choose Add Role.

Select the Active Directory Certificate Services check box under Server Roles and
then select Next.

Select the Certification Authority check box and then select Next.
Select Enterprise and then select Next.

Select Root CA and then select Next.

b Define CA private key settings.

1
2

Select Create a new private key and then select Next.
Select your preferred Key character length (for example 4096).

Select your preferred algorithm (for example SHA256) from the Select the hash
algorithm for signing certificates issued by the CA and then select Next.

Click Common name for this CA and enter the name of the CA or use the default CA
displayed and then select Next. Make note of the name of the CA server. You need to
enter this information in Workspace ONE UEM when setting up access to the CA.

Select the desired length of time under Set the validity period for the certificate
generated for this CA and then select Next. The length of time you select is the
validity period for the CA, not the certificate. However, when the validity for the CA
expires, so does the certificate.

¢ Configure the ADCS certificate database.

1

VMware, Inc.

Click Next to accept the default information in the Configure Certificate Database
screen.

Click Next to accept the Confirm Installation Selections screen.

Click Install. The installation begins. After the installation completes, the Installation
Results window displays. Select to Close.
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2 Configure the Microsoft CA.

a Add a Service Account to the CA.

1

Launch the Certification Authority Console from the Administrative Tools in Windows.

2 In the left pane, select (+) to expand the CA directory.

3 Right-click the name of the CA and select Properties. The CA Properties dialog box
displays.

4 Click the Security tab.

5 Click Add. The Select Users, Computers, Service Accounts, or Groups dialog box
displays.

6 Click within the Enter the object names to select field and type the name of the
service account (e.g., Ima Service).

7 Click OK. The CA Properties dialog box displays.

8 Select the service account you added in the previous step (e.g., Ima Service) from the
Group or user names list.

9 Select the Read, the Issue and Manage Certificates, and the Request Certificates
checkboxes to assign permissions to the service account.

10 Click OK.

b Configure the CA if you're using Subject Alternative Name (SAN) in Certificates.

1

VMware, Inc.

Open a command prompt from the Windows Desktop and enter the following in the
order they appear. These commands configure the CA to allow the use of the Subject
Alternative Name (SAN) in a certificate.

certutil -setreg policy\EditFlags +EDITF ATTRIBUTESUBJECTALTNAME2

net stop certsvc

net start certsvc
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c Add a Certificate Template to the CA in the CA (certsrv) window.

1
2

In the left pane, select (+) to expand the CA directory.

Right-click the Certificate Template folder and select Manage. The Certificate
Templates Console window displays.

Select the desired template (e.g., User) under Template Display Name, and right-click
Duplicate Template. The Duplicate Template dialog box displays.

Workspace ONE UEM will use the duplicate certificate template. The template you

choose depends on the function being configured in Workspace ONE UEM. For Wi-Fi,
VPN, or Exchange Active Sync (EAS) client authentication select User template.

Certificate Templates Console i | EI|1|

File Acton ‘View Help

I EIEEN

5] Certificate Templates {us8dc0 LUSE | Template Display Name =

| Minimun + | | Actions

£ ca Exchange Bl | Certficate Templates (us... 4
E CEP Encryption Window
H certRenewal Window More Actions 4
E Code Signing Window
E Computer Window _
[ Cross Certification Authority Window More Actions 4
@ Directory Email Replication Window
@ Router (Offline request) Window
E Smartcard Logon Window
E Smartcard User Window
E Suberdinate Certification Authority Window
E Trust List Signing Window
E User Sign Duplicate Templats Window
] web Serve All Tasks Window
] workstatic e Windov—

<| | el —— o

|Using this template as a base, creates a template that st i 3 Enterprise CAz |

Select the Windows Server that represents the oldest enterprise version being used

within the domain to ensure backward compatibility of the certificate that was issued.

Duplicate Template i

You can create certificate templates with advanced properties, However,
not all Windows CAs support all certificate template properties.Select the
version of Windows Server {minimum supported CAs) for the duplicate

certificate template,

™ Windows Server 2003 Enterprise

* \Windows Server 2008 Enterprise

Learn more about Certificate Template Versions.

X

5 Click OK. The Properties of New Template dialog box displays.

VMware, Inc.
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d Configure the Certficate Template properties.

1
2

Click the General tab.

Type the name of the template displayed to users in the Template display name field.
The Template name field auto-fills with the template display name without spaces.

You may use this default value or enter a new template name if desired. The template
name may not contain spaces. Make note of the template name. You will need to
enter this information inWorkspace ONE UEM.

You will enter the Template name you just configured with no spaces in the
Workspace ONE UEM console in the Issuing Template field within the Configuring
the Certificate Template screen.

Select the desired length of time for the certificate to be active from the Validity
period entry field/drop-down menu.

You should choose a length of time that is less than the time you chose for the CA
(step 1.b.v.). By doing this the certificate will expire before the CA.

Click Apply.
Click the Request Handling tab.

Select the appropriate client authentication method from thePurpose: drop-down
menu. This selection might be based on the application of the certificate being issued,
although for general purpose client authentication, select Signature and Encryption.

Click Apply.
Select the Subject Name tab.

Select Supply in the request. If Supply in the request is not selected, the certificate
will be generated to the service account instead of the desired end user.

e Enable the template for CA.

1

o o1 b~ W

VMware, Inc.

Click the Extensions tab.

Select Application Policies from the Extensions included in this template: field. This
allows you to add client authentication.

Click Edit. The Edit Application Policies Extension dialog box displays.
Click Add. The Add Application Policy dialog box displays.
Select Client Authentication from the Application policies: field.

Click OK. The Properties of New Template dialog box displays.
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f  Provide the AD Service Account permissions to request a certificate.

1
2

6
7

Click the Security tab.

Click Add. The Select Users, Computers, Service Accounts or Groups dialog box
displays. This allows you to add the service account configured in Active Directory to
request a certificate.

Enter the name of the service account (e.g., Ima Service) in the Enter the object
names to select field.

Click OK. The Properties of New Template dialog box displays.

Select the service account you created in the previous step (e.g., Ima Service) from
the Group or user names: field.

Select the Enroll checkbox under Permissions for CertTemplate ServiceAccount.

ClickOK.

g Enable the Certificate Template in the CA.

1

2
3
4

VMware, Inc.

Navigate to the Certificate Authority Console.
Click (+) to expand the CA directory.
Click Certificate Templates folder.

Right-click and select New > Certificate Template to Issue. The Enable Certificates
Templates dialog box displays.

Select the name of the certificate template (for example, Mobile User) that you
previously created in Creating a Name for the Certificate Template.

Click OK.
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3 Configure the CA and the certificate template in Workspace ONE UEM so that Workspace
ONE UEM can retrieve a certificate from a CA.

a Configure the CA.

1

6

Login to the Workspace ONE UEM console as a user with Workspace ONE UEM
Administrator privileges, at minimum.

Navigate to System > Enterprise Integration > Certificate Authorities.
Click Add.

Select Microsoft ADCS from the Authority Type drop-down menu. You need to select
this option prior to populating other fields in the dialog so applicable fields and
options display.

Enter the following details about the CA in the remaining fields.

m  Enter a name for the CA in the Certificate Authority field. This is how the CA will
be displayed within the Workspace ONE UEM console.

m  Enter a brief Description for the new CA.

m  Select ADCS radio button in the Protocol section. If you select SCEP, note that
there are different fields and selections available not covered by this whitepaper.

m  Enter the host name of the CA server in the Server Hostname field.

m  Enter the actual CA Name in the Authority Name field. This is the name of the
CA to which the ADCS endpoint is connected. This can be found by launching the
Certification Authority application on the CA server.

m  Select the radio button that reflects the type of service account in the
Authentication section. Service Account causes the device user to enter
credentials. Self-Service Portal authenticates the device without the user having
to enter their credentials.

m  Enter the Admin Username and Password. This is the username and password
of the ADCS Admin Account (step 2.f). This admin has sufficient access to allow
Workspace ONE UEM to request and issue certificates.

Click Save.

b Configure the certificate template.

1
2
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Select the Request Templates tab.
Click Add.
Complete the certificate template information.

m  Enter a friendly name for the new Request Template. This name is used by the
Workspace ONE UEM console.

m  Enter a brief Description for the new certificate template.
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Select the Certificate Authority that was just created from the certificate authority
drop-down menu.

Enter the name of the Issuing Template (e.g., MobileUser) that you configured
in Configuring Certificate Template Properties in the Template name field. Make
sure you enter the name with no spaces.

Enter the Subject Name or Distinguished Name (DN) for the template. The text
entered in this field is the “Subject” of the certificate, which can be used by the
network administrator to determine who or what device received the certificate.

A typical entry in this field is “CN={EnrolimentUser}” or “CN={DeviceUid}” where
the {} fields are Workspace ONE UEM lookup values.

Select the private key length from the Private Key Length drop-down menu.

This is typically 2048 and should match the setting on the certificate template that
is being used by DCOM.

Select the Private Key Type using the applicable checkbox.

This should match the setting on the certificate template that is being used by
DCOM.

Under SAN Type, select Add to include one or more Subject Alternate Names
with the template. This is used for additional unique certificate identification. In
most cases, this needs to match the certificate template on the server. Use
the drop-down menu to select the SAN Type and enter the subject alternate
name in the corresponding data entry field. Each field supports lookup values.
Email Address, User Principal Name, and DNS Name are supported by ADCS
Templates by default.

Select the checkbox for Security Identifier to include the AD SID in the certificate
SAN.

Select the Automatic Certificate Renewal checkbox to have certificates using this
template automatically renewed prior to their expiration date. If enabled, specify
the Auto Renewal Period in days and make sure the assignment type is set to
Auto.

Select the Enable Certificate Revocation checkbox to have certificates
automatically revoked when applicable devices are unenrolled or deleted, or if
the applicable profile is removed.
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Note If you are making use of the Enable Certificate Revocation feature, navigate
to Devices & Users > General > Advanced and set the number of hours in the
Certificate Revocation Grace Period field. This is the amount of time in hours after
the discovery that a required certificate is missing from a device that the system
will wait before actually revoking the certificate. Given the vagaries of wireless
technology and network bandwidth performance, this field is designed to prevent
false negatives or times when a certificate is falsely identified as not existing on a
device.

Select the Publish Private Key checkbox to publish the private key to the
specified web service endpoint (Directory Services or custom web service).

Publishing Private Key is only applicable when using Lotus Domino.

Click Add to the right of Eku Attributes to insert an object identifier (OID) that
represents any additional extended key usages that may be required. You may
add multiple Eku Attributes to fit your needs.

Select the Force Key Generation on Device checkbox to generate public and
private key pair on the device which improves CA performance and security.

4  Click Save.

VMware, Inc.
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NDES for SCEP

Install and set up the Microsoft certificate authority (CA) over the NDES for SCEP protocol for
integration with Workspace ONE UEM.

In order for Workspace ONE UEM to use a certificate in a profile, which is used to authenticate
a user, an enterprise certificate authority does not need to be set up in the same domain as the
Workspace ONE UEM server.

There are several methods for Workspace ONE UEM to retrieve a certificate from the certificate
authority. Each method requires the basic installation and configuration described in this
documentation. See sample CA Configurations for Workspace ONE UEM SaaS environments.
Configurations differ in on-premises environments.

s Workspace ONE UEM to NDES/SCEP and then to Certificate Authority

: SaaS : ' External " DMZ " Internal
1 Environment 1 1 " "
! ! : Workspace One :: ::
X ' : UEM to NDES/ " " NDES/MSCEP/
1 1 ! MSCEP/SCEP III III SCEP to CA using N
! ! ' using https/port 443 http/port 443
| <--:-®+ ------------- L0 - > e < - P ------ - - - >
1
. Workspace One | ] LU npesmscers U —
' UEMSaaS ! : :: SCEP Server :: Certifice
' Server ' ! " " Serve
:_ ___________ : 1 1 [}
m  Workspace ONE UEM to AirWatch Cloud Connector, then to NDES/SCEP, and then to
Certificate Authority
£ $aaS DMZ ! Internal NDES/MSCEP/
nvironment

N, SCEP to CA using
http/port 443
€------ - .

Certificate Server

- _'E°E= . - . ACC to NDES/MSCEP/
1 SCEP using http/port 443
1

I
t
A

! 1 1
Workspace One | ' : ACC :
UEM Saas ' Workspace One | | Server  t------- o€ - ------ :
Server 1 UEM to ACC using ' ]
1 https/port 443 ' ' NDES/MSCEP/
: ' ' SCEP Server

VMware, Inc. 21
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m On-premises DS and NDES in the DMZ with Internal Workspace ONE UEM and CA

' External ! ! DMZ ; : Internal
1 1 1 1 1
! ! RS J'=0=T_1 CEHE EE g T=C=T"L €
1 1 1 1 1
1 1 1 1, Device Services | 1 I 1+ Workspace One !
: «-1TT%}-+- v Tt UEM console |
. * - I F = ro-= I == I
1 1 | | 11 [ | | | [ [
1 1 11 11 1 I
1 1 |L——).EOE=(--J 1 1 n_-_-) r
1 1 1 1 1
1 1 1 NDES 1 1
1 1 1 1 1
1 1 1 1 1
m On-premises with All Servers Internal and SCEP Proxy
. External | , DMZ | X Internal
1 1 1 1 1
! ! L e - - - - > - -
! ! ; : : — . ' Workspace One ACC
' ' T11° T 11 ! UEM console/
: - I R I . Device Services
: : 1 17,
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1

If you do not want to expose your SCEP endpoints to external devices, you can use the SCEP
Proxy. This feature, Enable Proxy, is an advanced feature when you configure the CA in the
Workspace ONE UEM console. The SCEP Proxy allows Workspace ONE UEM to act as an
intermediary between the SCEP server and the device. It forwards and returns requests and
responses between the two components. Workspace ONE UEM does not have the SCEP server's
private key, so it cannot parse requests from devices.
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Request SCEP Device

Challenge

SCEP payload with ° Generates
Challenge and URL CSR

-

SCEP Challenge N Generates
Response e Local
e - Certificate
»~
GetCACert
< e CSR
GetCACert

N CA
Certificate

N CA N CA
Certificate Certificate

N Encrypted
O
; PKCS #10
Workspace ONE GetCACaps (optional) ( )
SCEP UEM Devi <
Server . .eV|ce - 0 ) Local
Get CACaps (optional) SELES Certificate
@ List of supported

operations by CA

Signed Message

@ PKI Message
PKlOperation

List of supported
operations by CA

Y

Local
Certificate

PKlOperation

PKIMessage

PKIMessage

Y

User
Certificate

Traffic flows in the following sequence.

1 Workspace ONE UEM Device Services (where the SCEP Proxy is located) requests a SCEP
challenge from the CA's SCEP server.

2 The CA responds with a SCEP challenge phrase.
3 Device Services builds the SCEP payload and sends it to the device.

The payload contains the SCEP challenge phrase, the SCEP URL, and other attributes (for

example, Subject Name, Key Usage, and SAN). The SCEP URL has the SCEP enrollment token

that is associated with the CA and certificate template.

4 The device receives the SCEP payload and it generates a certificate signing request (CSR)
based on all the attributes in the payload.

5 The device generates a local certificate with a private key.

6 The device sends a GetCacCert request to the Workspace ONE UEM SCEP Proxy.
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10

n
12
13

14

15

16

17

18
19

The Workspace ONE UEM SCEP Proxy resolves the GUID to the CA's SCEP endpoint and
forwards the request to the respective SCEP endpoint.

The CA responds with a CA certificate to the Workspace ONE UEM SCEP Proxy.
The Workspace ONE UEM SCEP Proxy forwards the CA certificate to the device.

The CA certificate encrypts the CSR the device generated. The local device certificate signs
the encrypted CSR to build a signed message.

Optionally, the device sends a GetCaCaps request to the Workspace ONE UEM SCEP Proxy.
The Workspace ONE UEM SCEP Proxy forwards the request to the CA's SCEP endpoint.

If the CA supports the GetCacaps request, the CA returns a list of all the supported operations
to the Workspace ONE UEM SCEP Proxy.

The Workspace ONE UEM SCEP Proxy forwards the list of supported operations to the
device.

The device sends a PKIOperation request to the Workspace ONE UEM SCEP Proxy.
The request includes the generated signed message.

The Workspace ONE UEM SCEP Proxy validates that the SCEP enroliment token is compliant
and enrolled with Workspace ONE UEM. If the validation is successful, it forwards the request
to the CA SCEP endpoint.

If the PKIOperation is valid, the CA responds with PKIMessage that contains the user
certificate.

The Workspace ONE UEM SCEP Proxy sends the response to the device.

The CA certificate signs the PKIMessage, it decrypts it using the local device certificate, and it
installs the user certificate on the device.

Prerequisites

Meet the list requirements to configure the protocol.

NDES is available in the Enterprise version of Microsoft Server 2008, 2008 R2, and 2012 or
2016 Standard and Enterprise.

A Certificate Authority (CA) installed, configured, and made available to the NDES/SCEP/
MSCEP server.

m  You can install the CA and NDES for SCEP on the same server or on different servers. If
you do put them both on the same server, complete the CA installation first and restart
the server before installing NDES for SCEP.

You need certificate templates during NDES for SCEP setup and service certificate renewal:

m  Exchange Enrollment Agent (Offline request)
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m  CEP Encryption

Note It is possible for all the following accounts to be the same account. However, using
a single account has security concerns.

Connection Requirements

The SCEP endpoint must be accessible from the device in order for certificate enrollment to
finish.

m  The exception to this requirement is when you use the Enable Proxy menu item in the
Certificate Authority - Add/Edit page for non-generic, SCEP protocol use.

An Admin Account must exist in the domain. This account is used to install the NDES/SCEP/
MSCEP role service and must meet the following requirements.

= Member of the Local Administrators group (Standalone Installation)
= Member of the Domain Admins group (Enterprise)
m  ‘Enroll’ permissions on the NDES for SCEP service certificate templates (Enterprise).

A Service Account must exist. It is used by the NDES for SCEP application pool and must
meet the following requirements.

m Member of the local IS_USRS group. If this setting is not configured, role installation fails.
m  ‘Request’ permission on the configured CA.
m  ‘Read’ and ‘Enroll’ permissions on configured device certificate templates.

m A Service Principal Name (SPN) must be added by using: SetSpn -a HTTP/<ComputerName>

<AccountName>.
<ComputerName> IS the name of the computer where NDES for SCEP is installed.

<AccountName> is the computer account name when NetworkService is used, or the domain
user account when a custom application pool identity is configured.

The Device Administrator account used to request password challenges from NDES for SCEP
must meet the following requirements.

m  ‘Enroll’ permissions on all configured device certificate templates (Enterprise).

= Member of the Local Administrator group (standalone).
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Procedure

1 Install the Microsoft CA role.

a Addthe ADCS role.

1

2
3
4
5
6
7
8

Click the Server Manager icon next to Start to open the Server Manager window.
Click Roles in the left pane.

Click Add Role in the right pane. An Add Roles Wizard window displays.

Under Server Roles, select the Active Directory Certificate Services check box.
Click Next.

Select the Certification Authority check box and then select Next.

Select Enterprise and then select Next.

Select Root CA and then select Next.

b Define CA private key settings.

1
2

Select Create a new private key and then select Next.
Select your preferred Key character length (for example 4096).

Select your preferred algorithm (for example SHA256) from the Select the hash
algorithm for signing certificates issued by the CA and then select Next.

Click Common name for this CA and enter the name of the CA or use the default CA
displayed and then select Next.

Note the name of the CA server. You must enter this information in Workspace ONE
UEM when setting up access to the CA.

Select the desired length of time under Set the validity period for the certificate
generated for this CA and then select Next.

The length of time you select is the validity period for the CA, not the certificate.
However, when the validity for the CA expires, so does the certificate.

c Configure the ADCS certificate database.

1

4

Click Next to accept the default information in the Configure Certificate Database
screen.

Click Next to accept the Confirm Installation Selections screen.

Click Install. The installation begins. After the installation completes, the Installation
Results window displays.

Click Close.

2 Set permissions for the NDES/SCEP Admin Account.

a Run the Certification Authority Console from the Administrative Tools in Windows.

b Right-click the server name and select Properties.
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j

Select the Security tab.

Click Add. The Select Users, Computers, Service Accounts, or Groups dialog box
displays.

Click within the Enter the object names to select text box and type the name of the SCEP
Admin Account.

Click OK. The CA Properties dialog box displays.

Select the SCEP Admin Account from the Group or user names list.
Select the Manage CA permission Allow check box.

Select the Request Certificates permission Allow check box.

Click OK.

3 Set the Read and Enroll permissions on the certificate template for the NDES/SCEP Service
Account and the Device Administrator.

a

j

Run the Certificate Templates Console by running certtmpl.msc from the Windows
Desktop.

Right-click the required template and select Properties. The example here is ‘MobileUser’
from the CA Setup Document.

Select the Security tab.

Click Add. The Select Users, Computers, Service Accounts, or Groups dialog box
displays.

Click within the Enter the object names to select text box and type the name of the
Service Account.

Click OK. The Properties dialog box displays.
Select the Service Account from the Group or user names: list.
Select the Read permission Allow check box.
Select the Enroll permission Allow check box.

Click OK.

4 Install the NDES/SCEP role.

a

b

Run the Server Manager on the server to be used as the NDES/SCEP/MSCEP server.
Select Roles.

Click Add Roles. The Add Roles Wizard displays.

Click Next. The Select Server Roles dialog box displays.

Select Active Directory Certificate Services.

Click Next. The Select Role Services dialog box displays.
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Clear the Certification Authority check box.

Select Network Device Enrollment Service (or SCEP).

Click Next.

Click Select User. The user selected MUST be in the local IS_USRS Group.

Enter the Username and Password for the account NDES/SCEP Admin Account.

Click Next. The Specify CA for Network Device Enrollment Service (or SCEP) dialog box
displays.

Select CA Name.

Click Browse.

Select the CA in the Select Certification Authority dialog box.

Click OK.

In the Specify Registration Authority dialog box, select Next.

In the Configure Cryptography for Registration Authority dialog box, select Next.

Navigate through any additional required services or roles and then select Install and
Next.

5 Specify the NDES/SCEP template.

NDES/SCEP uses one template from the certificate authority. This template is specified in the
registry and must be edited using Registry Editor.

a

b

Run the Registry Editor by running regedit.exe from the Windows Desktop.

Navigate to HKEY LOCAL MACHINE\SOFTWARE\Microsoft\Cryptography\MSCEP (or NDES/
SCEP).

Right-click the General Purpose Template and select Modify.

Replace the value 1pPsECIntermediateOffline with the template name being used.

6 Registry Editor

2 ). Mcrosolt o] | rame | Type | Data
s NETFramework. b/ (Def k) REG_SZ (valon ot set)
5 e Adtive Setup 25 EncryptionTemplaste REG_SZ PSECIRermediateOffine
s x 1 JIe PSECintermmduateOffiee
PSECRermadiateOffire

T g ]
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e Close the Registry Editor.
f Restart Internet Information Services by opening a command prompt and running iisreset.
6 Configure lIS to allow for large query strings.

When the device requests a certificate from NDES/SCEP, it sends a string of over 2700
characters as part of the request. This string is larger than the default size for query
strings and results in a 404.15 error. The default query string length must be increased to
accommodate this large string.

a Open acommand prompt from the Windows Desktop.

b Enter c:\windows\system32\inetsrv\appcmd.exe
set config -section:system.webServer/security/requestFiltering /

requestLimits.maxQueryString:"3072" /commit:apphost.
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7 Configure the CA and the certificate template in Workspace ONE UEM so that Workspace
ONE UEM can retrieve a certificate from a CA.

a Configure the CA.

1
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Log in to the Workspace ONE UEM console as a user with Workspace ONE UEM
admin privileges, at minimum.

Navigate to System > Enterprise Integration > Certificate Authorities.

Click Add.

Enter details about the CA:

Select ‘Microsoft ADCS’ from the Authority Type drop-down menu. Configure this
setting first, because dependent settings appear.

Enter the Name and Description of the new certificate authority.
Select the Protocol: ADCS or SCEP.

Select the Version: NDES 2008/2012 or SCEP 2003.

Enter the URL of the CA server in the SCEP URL text box.

Select the Challenge Type that reflects whether a challenge phrase is required for
authentication.

m If you want basic authentication, select Static and enter an authentication
phrase consisting of a singular key or password that is used to authenticate
the device with the certificate enrollment URL.

m  To enable a new challenge to be generated for every SCEP enrollment
request, select Dynamic.

Enter the Challenge Username/Challenge Password. This user-name and
password combination is used to authenticate the device making the request.

For additional security, upload a certificate under Challenge Client Certificate for
Workspace ONE UEM to present when fetching the dynamic challenge from the
SCEP endpoint.

Finish the SCEP Challenge URL text box with a URL in the following format:
http://host/certsrv/mscep admin/.

Advanced Options

m  Enter the SCEP Challenge Length, which represents the number of characters
in the challenge password.

m  Enter the Retry Timeout, which is the time the system waits between retries.
m  For Windows 10 devices, this should be a non-zero value.

m  Enter the Max Retries When Pending, which is the maximum number of retries
the system allows while the authority is pending.
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= With Enable Proxy selected, Workspace ONE UEM acts as a proxy between
the device and the SCEP endpoint defined in the CA configuration.

Click Test Connection. If you select Save before Test Connection, a “Test is
unsuccessful” error displays.

5 Click Save.

b Configure the certificate template.

1 Click the Request Templates tab.

2 Click Add.

3 Enter the following details about the template in the remaining text boxes:
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Enter the template Name and Description.

Select the certificate authority that was created from the Certificate Authority
drop-down box.

Enter the distinguished name in the Subject Name text box. The text entered
in this text box becomes the Subject of the certificate, which lets the network
administrator determine which devices receive the certificate.

A typical entry in this text box is “CN={EnrollmentUser}” or “CN={DeviceUid}”
where the {} text boxes are Workspace ONE UEM lookup values.

If you select Automatic Certificate Renewal for the certificate, CN=sceprenew-
{GUID} get's automatically added in backend. CA needs to issue certs with
retaining this attribute.

Select the private key length from the Private Key Length drop-down menu.

This value is typically 2048 matches the setting on the certificate template that is
being used by NDES/SCEP.

Select the applicable Private Key Type.

This value can be Signing, Encryption, or both, and the value matches the
certificate template being used by NDES/SCEP.

You can optionally select any of the following:

m If Workspace ONE UEM renews the certificate when it expires, select
Automatic Certificate Renewal and make sure the assignment is set to
Auto. Enter the number of days before expiration that Workspace ONE UEM
automatically reissues a certificate to the device in the Auto Renewal Period
(days) text box .

m  Select Publish Private Key if the certificate is published to Active Directory
or any other customer web service. Then select the proper destination by
selecting the appropriate Private Key Destination, either Directory Services or
a Custom Web Service.
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m Click Add to the right of Eku Attributes to insert an object identifier (OID) that
represents any additional extended key usages that might be required. You
can add multiple Eku Attributes to fit your needs.

m  The EKU Attribute is required for Windows 10 devices.

m  Select Force Key Generation On Device to generate a public and private key
pair on the device itself. This setting improves CA performance and security.

4 Click Save.
8 Confirm and test the installation and the configuration.

Testing of the installation and configuration can be performed by browsing to the NDES/
SCEP webpage, entering the service account credentials, and confirming the presence of a
challenge.

a Open a web browser and navigate to http://<servername>/certsvr/mscep admin/ where
<servername> is the name of the server running NDES/SCEP. If confirmation and testing
are being run from the NDES/SCEP server, the <servername> can be “localhost”.

b Enter the NDES/SCEP Service Account user name and password if prompted.

1 This is a basic authentication prompt which is used to make GetChallenge for NDES.
Basic Authentication needs to be added to IIS to support this authentication.

¢ The webpage shows a thumbprint and a password if configured properly. If a problem
exists with either the authentication of the Service Account or the template, an error
displays.
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What to do next
Review some tips and troubleshooting steps for the integration.

= When configuring the certificate password settings, use the default setting (dynamic
password mode).

= Although Workspace ONE UEM supports the use of the registry setting for Single Password
mode, consider not using it. The “Single Password” mode sets a static challenge password all
devices can use which can expose security vulnerabilities.

m If the NDES/SCEP challenge cache is full, (an issue which can arise when publishing a profile,
for example), edit the cache value by:

a Run regedit.exe to edit the PasswordMax value.

b The PasswordMax value is at:
HKEY LOCAL MACHINE\Software\Microsoft\Cryptography\MsCEP (or NDES/SCEP) within
the registry.

¢ Increase the PasswordMax value to a number greater than the default value of 5.

m If youreceive a Password Not Present error when installing the SCEP Profile to a device,
confirm that the challenge response length setting in the Workspace ONE UEM console
matches the length setting associated with the certificate.
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Integrate your Exchange ActiveSync (EAS) and Active Directory Certificate Services (AD CS)
with Workspace ONE UEM to pass email to managed devices using certificates for authenticated

access.

This diagram shows how certificate authentication is handled from the point where the user
device enrolls into Workspace ONE UEM to when the user begins to receive email.

e
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Prerequisites

Meet these requirements including setting up a certificate authority server, enabling Microsoft
Exchange with ActiveSync, and selecting the option to install Client Certificate Mapping
Authentication.

m  Set up an enterprise certificate authority server for Microsoft as opposed to a standalone
certificate authority. A standalone certificate authority does not allow for the configuration
and customization of templates.

Important Certificate Authorities can be set up on servers running a variety of operating
systems. However, not all operating systems support all features or design requirements,

and creating an optimal design requires careful planning and lab testing before you deploy a

client access server like AD CS in a production environment.

= Microsoft Exchange with ActiveSync enabled.

m Install Client Certificate Mapping Authentication on the Internet Information Services (IIS) on
the Exchange ActiveSync server.

Procedure

1 Set up a trust relationship between Active Directory and the Certificate Authority (CA), which

is EAS with ADCS.
a On the Certificate Authority server, select Start > Run.

b Type MMC in the dialog box and press Enter to launch the Microsoft Management
Console (MMCQ).

c Click File > Add/Remove Snap-ins from the MMC main menu.

d Select Enterprise PKI from the list of Available snap-ins and then select Add.
e Click OK.

f  Right-click Enterprise PKI and select Manage AD Containers.

g Select the NT AuthCertificates tab and verify the Certificate Authority is listed. If not,
select Add to add the Certificate Authority to the group.

h Click OK.
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2 Set permissions on Microsoft Exchange server.
a Configure the certificate authentication.
1 On the Exchange server, select Start > Run.

2 Type inetmgr in the dialog box to run Internet Information Services (lIS).

3 Select the server in the Connections pane.
4 Under IIS, double-click the Authentication icon.
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5 Select Active Directory Client Certificate Authentication and then select Enable.

b Set up the configuration editor.

1 Select + to expand Site and then Default website to display all available configuration
editors.

a If you are using MS Server 2008 R2 or later, the Configuration Editor
icon appears; Select Microsoft-Server-ActiveSync and double-click on the
Configuration Editor icon. Skip steps 1b & 1c, and go directly to step 2.

b If you are using Exchange servers older than 2008 R2, be familiar with the use of
appcmd.exe and run it from the command prompt.

¢ Open acommand prompt by selecting Start > Run. Type cmd in the dialog box and
select OK. In the command prompt, type the following command:
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appcmd.exe set config
"Microsoft-Server-ActiveSync" -section:system.webServer/
security/authentication/clientCertificateMappingAuthentication /

enabled:"True" /commit:apphost

If you performed this step, then skip the remaining steps and advance to Setting
up Secure Socket Layer (SSL).
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2 Navigate to system.webserver > security > authentication in the Section drop-down

menu.

3 Select clientCertificateMappingAuthentication.
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4 Select True from the drop-down menu on the Enabled option.
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c If you only use certificate authentication, configure Secure Socket Layer (SSL).

1 Select Microsoft-Server-ActiveSync, and then double-click the SSL Settings icon.
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2 Select Accept if other types of authentication are allowed. If only certificate
authentication is allowed, then select the Require SSL check box and then select
Required.

d Increase the value of the memory size parameter uploadReadAheadSize from 48 KB to
10 MB to account for an increased amount of data.

1 Open acommand prompt by selecting Start > Run.
2 Type cmd in the dialog box and select OK.

3 Enter the following commands:

C:\Windows\System32\inetsrv\appcmd.exe set config -section:system.webServer/
serverRuntime /uploadReadAheadSize:"10485760" /commit:apphost

C:\Windows\System32\inetsrv\appcmd.exe set config "Default
Website" -section:system.webServer/serverRuntime /uploadReadAheadSize:"10485760" /
commit :apphost

If the name of the site has been changed in IIS, then replace pefault Website with the
new name in the second command.

4 Perform an IIS reset by entering the following command:

iisreset
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3 Configure the CA and the certificate template in Workspace ONE UEM.

a Configure the CA.

1

5

Log in to the Workspace ONE UEM console as a user with Workspace ONE UEM
admin privileges.

Navigate to Groups & Settings > Configurations > Certificate Authorities
Click Add.

Enter details about the CA.

Option Description

Name Enter any name that helps identify the CA.
Authority Type Microsoft ADCS

Protocol ADCS

Server Hostname Enter the URL for the server in the format https://

{servername}/certsrv/adcs/.

The URL can also have HTTP but it must include the
trailing /.

Authority Name Enter the name of the certificate authority that the
AD CS endpoint is connected to. This can be found
by launching the Certification Authority application
on the certificate authority server.

Authentication Service Account

User name Enter the user name of the AD CS Admin Account
with sufficient access to allow Workspace ONE UEM
to request and issue certificates.

Password Enter the password of the AD CS Admin Account
with sufficient access to allow Workspace ONE UEM
to request and issue certificates.

Click Save.

b Configure the certificate template.

1
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Navigate to Groups & Settings > Configurations > Certificate Authorities > Request
Templates tab.

Click Add.

Enter the following details about the template in the remaining fields.

Option Description

Name Enter a name that helps identify the certificate
template.

Certificate Authority Select the AD CS certificate authority created
earlier.
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Option

Subject Name

Private Key Length

Private Key Type

SAN Type

Automatic Certificate Renewal

Enable Certificate Revocation

Publish Private Key

Force Key Generation on Device

4 Click Save.

Description

Enter text that is the Subject of the certificate. The
network admin can use it to determine who or what
device received the certificate.

A typical entry in this field is CN=WorkspaceONEUEM.
{EnrollmentUser} or CN={DeviceUid} where
the {} fields are Workspace ONE UEM lookup values.

This length is typically 2048 and should match the
setting on the certificate template that is being used
by AD CS.

Select Signing and Encryption.

Include one or more Subject Alternate Names
(SANSs) with the template.

This is used for additional unique certificate
identification. In most cases, this needs to match
the certificate template on the server. Use the drop-
down menu to select the SAN Type and enter the
subject alternate name in the corresponding data
entry field. Each field supports lookup values.

Enabled

Has certificates using this template automatically
renewed prior to their expiration date. If enabled,
specify the Auto Renewal Period in days and make
sure the assignment type is set to Auto.

Select the check box to have certificates
automatically revoked when applicable devices are
unenrolled or deleted, or if the applicable profile is
removed.

Enable this option for Lotus Domino configurations.

Generates a public and private key pair on iOS
devices, improving performance and security.

4 Create and deploy a Workspace ONE UEM profile that pushes the Exchange Server settings
to the device. This profile contains the information necessary for the device to connect to
Exchange and the certificate that the device uses to authenticate.

a

b

Navigate to Devices > Profiles > List View.

Click Add.

Click the applicable device platform to launch the Add a New Profile dialog.

Configure the General settings for the profile. The General settings determine how the
profile is deployed, who receives it, and other overall settings.

Select Credentials from the profile options at left and then select Configure.

Select Define Certificate Authority from the Credential Source drop-down menu.
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g Select the certificate authority you created previously from the Certificate Authority
drop-down menu.

h Select the certificate template you created previously from the Certificate Template
drop-down menu.

i Select Exchange ActiveSync from the profile options at left and then select Configure.

j  Configure the Exchange ActiveSync.

1

Enter an account name in the Account Name field. This is the name that displays
on the device to indicate which email account is active so it should be accurately
descriptive.

Enter the Exchange ActiveSync host in the Exchange Active Sync Host data entry
field. This is the actual endpoint of the mail server.

Do not include http:// or https:// at the beginning or /Microsoft-server-activesync at
the end.

Ensure the Use SSL check box is selected. Authentication using certificates fails over
a non-SSL connection.

Deselect the Use S/MIME check box if enabled by default.
The Domain data entry field should contain the email domain for the user account.

The Username data entry field should contain the email address of the user when on
the device.

The Email Address text box should contain the email address of the user when on the
device

Domain, Username, and Email Address can be obtained using Lookup Values which
will retrieve the text stored in the applicable field of the User Profile.

Select the credential you created previously from the Payload Certificate drop-down
menu.

k Click Save or select Save and Publish to publish this profile to a device.
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EAS with NDES-MSCEP

Integrate the Microsoft Exchange Client Access Server (CAS) and Workspace ONE UEM to
allow a device to connect to Microsoft Exchange ActiveSync (EAS) using a certificate for
authentication.

Prerequisites

m  Set up a certificate authority server and configure it. Ensure that the CA is an Enterprise
CA as opposed to a Stand Alone CA. The Stand Alone version does not allow for the
configuration and customization of templates.

Note A Network Device Enrollment Service, also referred to as MSCEP server setup. NDES is
only available in the Enterprise version of Microsoft Server 2008 and 2008 R2.

= Enable Microsoft Exchange with ActiveSync.

m  Cofigure Internet Information Services (lIS) on the EAS server with the option Client
Certificate Mapping Authentication installed.

Procedure

1 Set up a trust between active directory and the certificate authority, eas with NDES-MSCEP.

a

b

On the Certificate Authority server, select Start > Run.

Type MMC in the dialog box and press Enter to launch the Microsoft Management
Console (MMCQC).

Click File > Add/Remove Snap-in... from the MMC main menu.

Select Enterprise PKI from the list of available snap-ins and then select Add.
Click OK.

Right-click Enterprise PKI and select Manage AD Containers.

Select the NT AuthCertificates tab and verify the Certificate Authority is listed. If not,
select Add to add the Certificate Authority to the group.

Click OK.
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2 Set permissions on Microsoft Exchange server.
a Update certificate authentication on Exchange.
1 On the Exchange server, select Start > Run.
2 Type inetmgr in the dialog box to run Internet Information Services (1IS).
3 Select the server in the Connections pane.
4

Under IS, double-click the Authentication icon.
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5 Select Active Directory Client Certificate Authentication and then select Enable.

b Update the configuration editor.

1 Select + to expand Site and then Default website to display all available configuration
editors.

2 If you are using MS Server 2008 R2 or later, the Configuration Editor icon appears.

Select Microsoft-Server-ActiveSync and double-click on the Configuration Editor
icon.
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If you are using Exchange servers older than 2008 R2, be familiar with the use of
appcmd.exe and run it from the command prompt.If you are using Exchange servers
older than 2008 R2, be familiar with the use of appcmd.exe and run it from the
command prompt.

Open a command prompt by selecting Start > Run. Type cmd

in the dialog box and select OK. In the command prompt,

type the following command. appcmd.exe set config "Microsoft-
Server—-ActiveSync" -section:system.webServer/security/authentication/

clientCertificateMappingAuthentication /enabled:"True" /commit:apphost
You can skip to the secure socket layer step.

Navigate to system.webserver > security > authentication in the Section drop-down
menu.

Select clientCertificateMappingAuthentication.
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5 Select True from the drop-down menu on the Enabled option.
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c Set up secure socket layer.

If only certificate authentication is being used, then you must configure Secure Socket
Layer (SSL).

1 Select Microsoft-Server-ActiveSync, and then double-click the SSL Settings icon.
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2 Select Accept if other types of authentication are allowed. If only certificate
authentication is allowed, then select the Require SSL check box and then select
Required.

d Adjust uploadReadAheadSize memory size.

Since certificate-based authentication uses a larger amount of data during the
authentication process, you must increase the value of the uploadReadAheadSize from
48 KB to 10 MB to account for the increased amount of data.

1 Open acommand prompt by selecting Start > Run.
2 Type emd in the dialog box and select OK.

3 If the name of the site has been changed in IS, then replace pefault Website with the
new name in the second command.

4 Perform an IIS reset by entering iisreset.
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3 Configure certificate authority and template in Workspace ONE UEM.

a Configure the certificate authority (CA).

1

2
3
4
5
6

8

Open the Workspace ONE UEM console.

Login as a user with a minimum of Workspace ONE UEM administrator privileges.
Navigate to Devices > Certificates > Certificate Authorities.

On the Certificate Authorities tab, select Add.

Select Generic SCEP from the Authority Type drop-down menu.

Complete the following options.

Setting Description

Name Enter the name of the CA to which the NDES/SCEP/
MSCEP endpoint is connected. Find the name by
launching the Certification Authority application on
the CA server.

SCEP URL Enter the URL of the CA server.

Challenge Type The Static item requires you to enter an
authentication phrase consisting of a key or
password used to authenticate the device with the
certificate enrollment URL.

Click Test Connection.
If you select Save prior to Test Connection, a Test is unsuccessful error displays.

Select Save.

b Configure the request template.

1
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Navigate to Devices > Certificates > Certificate Authorities and select the Request
Templates tab.

Select Add and complete the settings.

Setting Description

Name Enter any name that helps to identify this template.
Certificate Authority Select the CA you configured earlier in this process.
Subject Name Enter the Distinguished Name (DN) for the template.

The text entered in this field is the “Subject” of

the certificate. The network admin can use the

DN to determine who or what device received the
certificate.

A typical entry in this field is CN=WorkspaceONEUEM.
{EnrollmentUser}” or “CN={DeviceUid}. The {}
fields are Workspace ONE UEM lookup values.
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Setting

Private Key Length

Private Key Type

SAN Type > Add

Automatic Certificate Renewal

Publish Private Key

3 Save your settings.

Description

This entry is often 2048 and matches the setting
on the certificate template that NDES/SCEP/MSCEP
use.

This entry matches the setting on the certificate
template that NDES/SCEP/MSCEP use.

Include one or more Subject Alternate Names (SAN)
with the template. SANs are used for additional
unique certificate identification. In most cases, this
needs to match the certificate template on the
server.

Use the drop-down menu to select the SAN

Type and enter the subject alternate name in the
corresponding data entry field. Each field supports
lookup values.

Set certificates using this template to automatically
renew prior to their expiration date. Specify the
Auto Renewal Period in days and make sure the
Assignment type is set to Auto.

Publishes the private key to the specified web
service endpoint (Directory Services or custom web
service).

4 Create and deploy the Workspace ONE UEM profile that pushes the Exchange Server

settings to the device.

This profile contains the information necessary for the device to connect to Exchange, as well
as the certificate that the device uses to authenticate.

a Inthe Workspace ONE UEM console, navigate to Devices > Profiles & Resources >

Profiles > Add > Add Profile.

b Select the applicable device platform to launch the Add a New Profile dialog.

¢ Configure the General settings for the profile.

The General settings determine how the profile is deployed and who receives it as well as

other overall settings.

d Select Credentials from the profile options at left and then select Configure.

Setting
Credential Source
Certificate Authority

Certificate Template
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Description
Select Define Certificate Authority.
Select the certificate authority you created previously.

Select the certificate template you created previously.
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e Select Exchange ActiveSync from the profile options at left and then select Configure.

Setting

Account Name

Exchange ActiveSync Host

Use SSL

Use S/MIE

Domain

Email Address

Payload Certificate

Description

Enter a name that helps identify this payload. This
name displays on the device to indicate which
email account is active so it should be accurately
descriptive.

Enter the actual endpoint of the mail server.

Do notinclude http:// or https:// at the beginning
and do not include /Microsoft-server-activesync
at the end.

Select this option.

Authentication using certificates fails over a non-SSL
connection.

Unselect this option.

Enter the email domain for the user account.

You can use Lookup Values that retrieve the text
stored in the applicable field of the User Profile.

Enter the email address of the user when on the
device.

You can use Lookup Values that retrieve the text
stored in the applicable field of the User Profile.

Select the credential you created previously.

f  Select Save or select Save and Publish to publish this profile to a device.

What to do next

Review some tips and troubleshooting steps for the integration.

m  You can confirm that the certificate is operational by pushing a profile to the device and
testing whether or not the device is able to connect and sync to the configured Exchange
ActiveSync endpoint. If the device does not connect and shows a message indicating the
certificate cannot be authenticated or the account cannot connect to Exchange ActiveSync,

then there is a problem in the configuration.

m  Ensure a certificate is being issued by the certificate authority to the device.

a Launch the certification authority application on the certificate authority server and

browse to the issued certificates section.

b Locate the last certificate issued and verify it shows a subject matching the subject
created when the certificate was generated in the Workspace ONE UEM console.

If there is no certificate, then there is an issue with the certificate authority, client access
server (e.g., ADCS), or the Workspace ONE UEM connection to client access server.

¢ Ensure the permissions of the client access server (e.g., ADCS) Admin Account is applied
correctly to the certificate authority and the certificate template.
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d Ensure the account information is entered correctly in the Workspace ONE UEM
configuration.

m If the certificate is being issued, ensure that it is in the profile and on the device.
a Navigate to Devices > Profiles > List View.

b Click to the right of the applicable Exchange ActiveSync profile to launch the Actions
menu and select View XML.
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¢ On the device, access the list of installed profiles.
d View details for the applicable profile and ensure the certificate is present.

e Confirm that the certificate contains the Subject Alternative Name (or SAN) section and
within that section there is an Email and Principal name with the appropriate data. If
this section is not in the certificate, then either the template is incorrect or the certificate
authority has not been configured to accept SAN. Refer to the section on configuring the
certificate authority.

f  Confirm the certificate contains the Client Authentication in the Enhanced Key Usage
section. If not present, then the template is not configured correctly.

m [f the certificate is on the device and contains the correct information, then the problem
is most likely with the security settings on the Exchange ActiveSync server. Confirm the
address of the Exchange ActiveSync server is entered correctly in the Workspace ONE UEM
profile and that all security settings have been adjusted to allow certificate authentication on
the Exchange ActiveSync server.

A reliable test is to manually configure a single device to connect to the Exchange ActiveSync
server using certificate authentication. This should work outside of Workspace ONE UEM and
until this works properly, Workspace ONE UEM will not be able to configure a device to
connect to Exchange ActiveSync with a certificate.
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Configure Workspace ONE UEM so that managed Apple and select Android devices can connect
to an enterprise network through Cisco AnyConnect using a certificate for authentication.

Certificate authentication is handled from the point where the user's device enrolls into
Workspace ONE UEM to when the user has VPN access to the protected enterprise network.

1

After the device enrolls, Workspace ONE UEM sends the device a profile that contains the
user's identity certificate and Cisco AnyConnect configuration settings.

When the device uses VPN, the device sends the identity certificate to ASA's VPN endpoint
for authentication.

ASA verifies that the device identity certificate came from the same CA as its own identity
certificate and both were signed with the CA's certificate.

Optionally, if CRL Checking is enabled, the ASA regularly receives, parses, and caches the
CA's CRL to validate the device identity certificate has not been revoked.

ASA grants the device VPN access. The device can now securely access internal enterprise
resources.
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The following tasks must be completed before configuring certificate integration.

m  Set up an external CA server. The CA must be an external Enterprise CA as opposed to
a standalone CA. Standalone CAs do not allow for the configuration and customization of

templates.

m  For AnyConnect VPN, you must have a Cisco Adaptive Security Appliance (ASA) connected

to your network.

Procedure

1 Disable the local CA on the ASA firewall for AnyConnect.

Disabling the local CA ensures that certificates are authenticated against the external CA.

a Login to the Cisco Adaptive Security Device Manager (ASDM) to configure your ASA

firewall.

b Navigate to Configuration > Remote Access VPN > Certificate Management > Local

Certificate Authority > CA Server.
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Enterprise Network with VPN Access
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c Select Disable.
d Select OK.

Configuration > Remote Access VPN > Certificate Management > Local Certificate Authority > CA Server
Configure the Local Certificate Authority. To make configuration changes after it has been configured for the first time, disable the Local Certificate Authority.

() Enable @) Disable
2 Configure the ASA firewall and AnyConnect clients with a signed identity certificate.

a Create a CSR on the ASA firewall and send it to the external CA. The ASA needs an
Identity Certificate signed by the external CA. For assistance, follow Cisco’s instructions
for Generating a CSR on the ASA firewall.

After you complete all the steps, a *CER file (for example, cert_client_id.cer) downloads
to your local machine that was obtained from the external CA.

b Download the certificate from the external CA and install it on the ASA firewall to
authenticate that the external CA is a trusted source. For assistance, follow Cisco’s
instructions on how to install the external CA’s certificate.

¢ Install the Identity Certificate that you previously downloaded from the external CA.

This certificate is used to verify that the Identity Certificate users authenticate with the
same parameters and are coming from the same external CA as the Identity Certificate
on the ASA firewall. For assistance, follow Cisco’s instructions on how to install ASA’s
Identity Certificate. After completing these steps, the Identity Certificate that the external
CA created is now installed on your ASA firewall.

d Configure the VPN settings on the ASA. To begin, you must enable AnyConnect access
on the appropriate VPN interface. Follow instructions on the Cisco website on how to
enable the AnyConnect client access to the ASA.
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e Specify the group policy that is applied to AnyConnect clients and devices that connect

to SSL VPN through the ASA firewall. Follow instructions on the Cisco website on how to

create a SSL VPN Group Policy that is used by the ASA firewall.

f  Set up the connection profile and tunnel group to define the connection parameters of
the SSL VPN session used by AnyConnect clients. For assistance, follow instructions on
the Cisco Web site.

While creating a connection profile and tunnel group on the ASA for SSL VPN clients, a
screen similar to the image here appears so that you can configure the PublicCertVPN
SSL VPN Connection Profile. When this screen appears, make sure that you select
Certificate instead of AAA authentication.

Edit SSL VPN Connection Profile: PublicCert o
o E Basic) Mame: PublicCertyPM
[+-Advanced
Aliases: PublicCertvPM
Authentication
Method: (7) AAA (@) Certificate () Both
AAA Server Group: iLDCAL -
Use LOCAL if Server Group fails
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3 Automate the deployment process of Identity Certificates and VPN settings to each device in
Workspace ONE UEM console.

Integrate Workspace ONE UEM with the external CA so that Workspace ONE UEM can
request and deploy Identity Certificates. Configure the CA and then the request template in
Workspace ONE UEM console.

a Configure the certificate authority (CA).
1 Login to the Workspace ONE UEM console as an Administrator.

2 Navigate to Devices > Certificates > Certificate Authorities > Certificate Authorities
tab.

3 Select Add and complete the menu items.

Setting Description
Authority Type Microsoft AD CS
Protocol AD CS

If you select SCEP, then there are different text
boxes and selections available not covered by this
documentation.

Server Hostname Enter the host name of the CA server.

Authority Name Enter the actual CA name.

This value is the name of the CA to which the AD CS
endpoint is connected. This value can be found by
launching the Certification Authority application on
the CA server.

Authentication Service Account causes the device user to enter
credentials. Self-Service Portal authenticates the
device without the user having to enter their
credentials.

User name This value is the user name of the AD CS
Admin Account which has sufficient access to
allow Workspace ONE UEM to request and issue
certificates.

Password This value is the password of the AD CS
Admin Account which has sufficient access to
allow Workspace ONE UEM to request and issue
certificates.

Additional Options None
4  Select Save. Next,
b Configure the request template.

Enter information about the Identity Certificate template that Workspace ONE UEM
deploys to devices for VPN certificate authentication.

1 Navigate to Devices > Certificates > Certificate Authorities and select the Request
Template tab.
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2 Select Add.

3 Complete the certificate template information.

Setting

Certificate Authority

Subject Name

Private Key Length

Private Key Type

SAN Type

Automatic Certificate Renewal

Enable Certificate Revocation

Publish Private Key

4 Select Save.
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Description

Select the certificate authority that was created
from the certificate authority drop-down menu.

Enter the Subject Name or Distinguished Name (DN)
for the template.

The text entered in this text box is the Subject of
the certificate, which a network administrator can
use to determine who or what device received the
certificate.

A typical entry in this text box is
CN=WorkspaceONEUEM. {EnrollmentUser} or
CN={DeviceUid} where the {} entries are
Workspace ONE UEM lookup values.

This value is typically 2048 but must match the
certificate template used by the external CA.

Select the types that match the certificate template
used by the external CA.

Include one or more Subject Alternate Names with
the template. This value is used for extra unique
certificate identification. Usually, this value needs to
match the certificate template on the server.

Use the drop-down menu to select the SAN
Type and enter the subject alternate name in the
corresponding data entry text box. Each text box
supports lookup values.

Has certificates using this template automatically
renewed before their expiration date. If enabled,
specify the Auto Renewal Period in days and make
sure the assignment type is set to Auto.

Has certificates automatically revoked when
applicable devices are unenrolled or deleted, or if
the applicable profile is removed.

Select to publish the private key to the specified
Web service endpoint (directory services or custom
Web service).
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4 Deploy a device profile from Workspace ONE UEM console with AnyConnect VPN and
Certificate payloads to devices.

This device profile deploys an Identity Certificate and AnyConnect VPN settings to configure

all assigned devices.

a
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Navigate to Devices > Profiles > List View from the Workspace ONE UEM console main
menu.

Select Add.
Select the applicable device platform to open the Add a New Profile screen.

Configure the General settings for the profile. The General settings determine how the
profile is deployed and who receives it and other overall settings.

Select Credentials from the profile options at left and then select Configure.
Select Defined Certificate Authority from the Credential Source drop-down menu.

Select the external CA created previously from the Certificate Authority drop-down
menu.

Select the certificate template created previously from the Certificate Template drop-
down menu.

Select VPN from the profile options at left and then select Configure.

Credentials profile settings must be configured before the VPN profile settings because
the VPN configuration refers to the Credential that was created in the previous step.
Also, some of the configuration settings described here are not applicable to all device
platforms.
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k

Configure the following VPN profile settings.

Setting Description

Connection Type Cisco AnyConnect

Connection Name Enter a name that helps identify this specific VPN.

Server Enter the URL that users connect to for establishing their VPN
connection.

Account If your VPN has been configured to apply user credentials in addition to a

certificate for authentication, then specify an account to pass to the VPN
endpoint. To pass Workspace ONE UEM User Account names to the VPN
endpoint, use the {EnrollmentUser} lookup value.

Send All Traffic To send all device traffic through the VPN connections, select this check
box.

Alternatively, only traffic destined for the internal enterprise network

uses the VPN connection, and public traffic continues to use 3G or other
external connections to communicate.

User Authentication Certificate
Group Name AnyConnect VPN group name used to establish the connection.
Identity Certificate Select the credential configured for the certificate.

Select Save or Save & Publish to push the profile to a device.

5 Deploy the AnyConnect app to devices managed in Workspace ONE UEM console.

This deployment can be completed manually, by asking each device user to download the
application from the App Store, or you can use Workspace ONE UEM to prompt each user to
install the Cisco AnyConnect app.

a

b

Navigate to Apps & Books > Applications > Native.

Select the Public tab.

Select Add Application.

Ensure that the correct organization group is displayed in the Managed By text box.
Select the appropriate platform from the Platform drop-down menu.

Enter Cisco AnyConnect in the Name text box.

Select Next.

Locate Cisco AnyConnect in the Search window.

Cisco Legacy AnyConnect represents all versions up to 4.0.05069 and that Cisco
AnyConnect represents all versions afterward. Ensure you select the correct version for
your needs by clicking the appropriate Select button.

All required configuration settings populate automatically in the Add Application window.
Specify any additional parameters.

Select Save & Publish.
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What to do next

Review some tips and troubleshooting steps to help with the integration.

VMware, Inc.

You can confirm that the VPN certificate is operational by pushing a profile to the device.
Then, test whether or not the device can connect and sync to the configured ASA firewall.

If the device is not connecting, it may show a message that the certificate cannot be
authenticated or the account cannot connect to the ASA firewall. In this case, there is a
problem in the configuration.

Make sure that a certificate is issued by the external CA to the device by checking the
following information:

Go to the external CA’s server, start the certification authority application, and browse to
the “issued certificates” section.

Find the last certificate that was issued. Ensure it has a subject that matches the one
created in the certificate template section earlier in this documentation.

If there is no certificate, then there is an issue with the external CA, client access server
(for example, ADCS), or with the Workspace ONE UEM connection to the client access
server.

Check that the permissions of the client access server (for example, ADCS) Admin
Account are applied correctly to the external CA and the template on the external CA.

Check that the account information is entered correctly in the Workspace ONE UEM
configuration.

If the certificate is being issued, make sure that it is in the Profile payload and on the device.

Navigate to Devices > Profiles > List View. In the Device Profiles screen for the user’s
device, select Actions and then, select </ > View XML to view the profile XML. There is
certificate information that appears as a large section of text in the payload.

On the device, go to the profiles list, select details, and see if the certificate is present.

If the certificate is on the device and contains the correct information, then the problem is
most likely with the security settings on the ASA firewall.

Confirm that the address of the VPN endpoint is correct in the Workspace ONE UEM
profile. Also confirm that all the security settings have been adjusted for allowing certificate
authentication on the firewall.

A good test to run is to configure a single device to connect to AnyConnect VPN using
certificate authentication. Ensure this test works outside of Workspace ONE UEM, as until
this works properly, Workspace ONE UEM is not able to configure a device to connect to
AnyConnect VPN with a certificate.
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Cisco IPSec VPN

Configure Workspace ONE UEM so that managed Apple and select Android devices can connect
to an enterprise network through Cisco IPsec using a certificate for authentication.

Certificate authentication is handled from the point where the user's device enrolls into
Workspace ONE UEM to when the user has VPN access to the protected enterprise network.

1

After the device enrolls, Workspace ONE UEM sends the device a profile that contains the
user's identity certificate and Cisco IPSec VPN configuration settings.

When the device uses VPN, the device sends the identity certificate to ASA's VPN endpoint
for authentication.

ASA verifies that the device identity certificate came from the same CA as its own identity
certificate and both were signed with the CA's certificate.

Optionally, if CRL Checking is enabled, the ASA regularly receives, parses, and caches the
CA's CRL to validate the device identity certificate has not been revoked.

ASA grants the device VPN access. The device can now securely access internal enterprise
resources.
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Workspace ONE UEM

Root CA Revocation List

< ---

Cisco ASA

Y

AU U

Mobiles Devices

Enterprise Network with VPN Access

Prerequisites

m  Use an external CA server. The CA must be an external Enterprise CA as opposed to a
standalone CA. A standalone CAs doe not allow for the configuration and customization of
templates.

m  For IPSec, you must have a Cisco Adaptive Security Appliance (ASA) connected to your
network.

Procedure

1 Disable the local CA on the ASA firewall to ensure that certificates are authenticated against
the external CA.

a Loginto the Cisco Adaptive Security Device Manager (ASDM) to configure your ASA
firewall.

b Navigate to Configuration > Remote Access VPN > Certificate Management > Local
Certificate Authority > CA Server.

c Select Disable.

Configuration > Remote Access VPN > Certificate Management > Local Certificate Authority > CA Server
Configure the Local Certificate Authority. To make configuration changes after it has been configured for the first time, disable the Local Certificate Authority.

™) Enablé @ Disable

d Select OK.
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2 Configure IPsec VPN.

a

Create a CSR on the ASA firewall and send it to the external CA. This is because the

ASA needs an Identity Certificate signed by the external CA. For assistance, follow Cisco’s

instructions for Generating a CSR on the ASA firewall.

After you have completed all the steps, a CER file (for example, cert_client_id.cer)
downloads to your local machine that was obtained from the external CA.

Download the certificate from the external CA and install it on the ASA firewall to
authenticate that the external CA is a trusted source.

Follow Cisco’s instructions on how to install the external CA’s certificate.

Configure the IKE policies, tunnel properties and policies, group policies, available VPN
client IP addresses (pool), user accounts and group assignments, and associate these
configurations to create an IPSec profile used by the VPN clients.

Visit the Cisco website for instructions on creating a remote access connection profile
and tunnel group on the ASA for IPSec VPN clients. Complete the steps necessary

to configure the external CA and ASA firewall to create a trust using certificates and
configure a remote access connection profile and tunnel group so that IPSec VPN
certificate authentication can be used by your VPN clients to gain access into your
enterprise network.
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63



Certificate Authority Integrations

3 Integrate Workspace ONE UEM with the external CA so that Workspace ONE UEM can
request and deploy Identity Certificates. Configure the CA and the request template in the
Workspace ONE UEM console.

a Configure the CA.

1 Log in to the Workspace ONE UEM console as a user with Workspace ONE UEM
Administrator privileges, at minimum.

2 Navigate to Devices > Certificates > Certificate Authorities.

3 Select Add and complete the settings.

Setting Description
Authority Type Microsoft ADCS
Protocol ADCS

If you select SCEP, then there are different text
boxes and selections available not covered by this
documentation.

Server Hostname Enter the host name of the CA server.

Authority Name Enter the actual CA name.
This value is the name of the CA to which the AD CS
endpoint is connected. This value can be found by
launching the Certification Authority application on
the CA server.

Authentication Select Service Account so the device user enters
credentials.
User name This value is the user name of the AD CS

Admin Account which has sufficient access to
allow Workspace ONE UEM to request and issue
certificates.

Password This value is the password of the AD CS
Admin Account which has sufficient access to
allow Workspace ONE UEM to request and issue
certificates.

Additional Options None
4 Select Save.
b Configure the request template.

Enter information about the Identity Certificate template that Workspace ONE UEM
deploys to devices for VPN certificate authentication.

1 Navigate to Devices > Certificates > Certificate Authorities and select the Request
Template tab.

2 Select Add.

3 Complete the certificate template information.
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Setting

Certificate Authority

Subject Name

Private Key Length

Private Key Type

SAN Type

Automatic Certificate Renewal

Enable Certificate Revocation

Publish Private Key

4 Select Save.

Description

Select the certificate authority that was just created
from the certificate authority drop-down menu.

Enter the Subject Name or Distinguished Name (DN)
for the template.

The text entered in this text box is the Subject of
the certificate, which a network administrator can
use to determine who or what device received the
certificate.

A typical entry in this text box is
CN=WorkspaceONEUEM. {EnrollmentUser} oOr
CN={DeviceUid} where the {} entries are
Workspace ONE UEM lookup values.

This value is typically 2048 but must match the
certificate template used by the external CA.

Select the types that match the certificate template
used by the external CA.

Include one or more Subject Alternate Names with
the template. This value is used for extra unique
certificate identification.

Usually, this value needs to match the certificate
template on the server. Use the drop-down menu to
select the SAN Type and enter the subject alternate
name in the corresponding data entry text box.
Each text box supports lookup values.

Has certificates using this template automatically
renewed before their expiration date. If enabled,
specify the Auto Renewal Period in days and make
sure the assignment type is set to Auto.

Has certificates automatically revoked when
applicable devices are unenrolled or deleted, or if
the applicable profile is removed.

Select to publish the private key to the specified
Web service endpoint (directory services or custom
Web service).

4 Deploy a device profile from Workspace ONE UEM console with IPSec VPN and Certificate

payloads to devices.

This device profile deploys an ldentity Certificate and IPSec VPN settings to configure all

assigned devices.

a Navigate to Devices > Profiles > List View from the Workspace ONE UEM console main

menu.

b Select Add.

c Select the applicable device platform to open the Add a New Profile screen.
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d Configure the General settings for the profile. The General settings determine how the
profile is deployed and who receives it and other overall settings.

e Select Credentials from the profile options at left and then select Configure.
f  Select Defined Certificate Authority from the Credential Source drop-down menu.

g Select the external CA created previously from the Certificate Authority drop-down
menu.

h Select the certificate template created previously from the Certificate Template drop-
down menu.

i Select VPN from the profile options at left and then select Configure.

Credentials profile settings must be configured before the VPN profile settings because
the VPN configuration refers to the credential that was just configure. Also, some of the
configuration settings described here are not applicable to all device platforms.

j  Configure the following VPN profile settings.

Setting Description

Connection Type IPSec (Cisco)

Connection Name Enter a name that helps identify this specific VPN.

Server Enter the URL that users connect to for establishing their VPN
connection.

Account If your VPN has been configured to apply user credentials in addition to a

certificate for authentication, then specify an account to pass to the VPN
endpoint. To pass Workspace ONE UEM User Account names to the VPN
endpoint, use the {EnrolimentUser} lookup value.

Machine Authentication Certificate

Identity Certificate Select the credential configured for the certificate.
Include User PIN Ensure this is not selected. Unselect this option.
Enable VPN On Demand Ensure this is not selected. Unselect this option.

k Select Save or Save & Publish to push the profile to a device.

What to do next

You can confirm that the VPN certificate is operational by pushing a profile to the device and
testing whether or not the device is able to connect and sync to the configured ASA firewall.

If the device is not connecting and shows a message that the certificate cannot be authenticated
or the account cannot connect to the ASA firewall, then there is a problem in the configuration.

m  Make sure that a certificate is being issued by the external CA to the device by checking the
following information.

m  Go to the external CA’s server, launch the certification authority application, and browse
to the “issued certificates” section.
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m If the certificate is being issued, make sure that it is in the Profile payload and on the device.

Find the last certificate that was issued and it should have a subject that matches the one

created in the certificate template section earlier in this documentation.

If there is no certificate then there is an issue with the external CA, client access server
(e.g., ADCS), or with the Workspace ONE UEM connection to the client access server.

Check that the permissions of the client access server (e.g., ADCS) Admin Account are
applied correctly to the external CA and the template on the external CA.

Check that the account information is entered correctly in the Workspace ONE UEM
configuration.

Navigate to Devices > Profiles > List View. In the Device Profiles screen for the user’s
device, select Actions and then, select </ > View XML to view the profile XML. There is
certificate information that appears as a large section of text in the payload.

On the device, go to the profiles list, select details and see if the certificate is present.

m If the certificate is on the device and contains the correct information, then the problem is
most likely with the security settings on the ASA firewall.

Confirm that the address of the VPN endpoint is correct in the Workspace ONE UEM profile
and that all the security settings have been adjusted for allowing certificate authentication on
the firewall.

m A very good test to run is to manually configure a single device to connect to IPSec VPN
using certificate authentication. This should work outside of Workspace ONE UEM and until
this works properly, Workspace ONE UEM will not be able to configure a device to connect
to IPSec VPN with a certificate.
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SCEP

Workspace ONE UEM supports SCEP (Simple Certificate Enrollment Protocol) for iOS and macOS

devices. The integration includes the use of key pairs and the submission of the certificate
signing request (CSR) that results in a signed certificate from the SCEP endpoint to devices.

If you're looking to leverage certificates as part of your mobile deployment, SCEP allows you to
securely deploy certificate enrollment requests to iOS devices, even when Workspace ONE UEM
does not natively support your PKI infrastructure of choice.

Workspace ONE UEM provisions the device with the parameters to generate the key pair and
submit the CSR to the SCEP endpoint. The SCEP endpoint returns a signed certificate back to the
mobile device. The device manages the certificate and its private key. The benefit to SCEP is that

the private key never leaves the mobile device.

Device

generates
the key pair

Prerequisites

m  Workspace ONE UEM 9.5 or later

m  iOS 5.0 or later
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s macOS 10.9 or later

m  CA or SCEP endpoint must support SCEP as per the Internet Engineering Task Force's Simple
Certificate Enrollment Protocol draft document.

m  SCEP endpoint must be accessible from the device in order for the certificate enroliment to
finish.

m  The exception to this requirement is when you use the Enable Proxy item in the
Certificate Authority - Add/Edit page for non-generic SCEP protocol use.

Note Renewal and revoke are not supported.

Procedure

1 Configure the SCEP CA in the Workspace ONE UEM console.
a Navigate to Devices > Certificates > Certificate Authorities, and select Add.
b Select Generic SCEP from the Authority Type drop-down.

c Enter the information pertaining to your SCEP Endpoint.

Settings Description

Name The friendly name of your certificate authority in Workspace ONE UEM.

Description An optional field that you can use to give details about this defined-CA
and its uses.

Authority Type The type of certificate authority being defined in Workspace ONE UEM.

SCEP Provider The type of SCEP provider Workspace ONE UEM is integrating with.
Basic is the only option supported currently. (This field cannot be
changed.)

SCEP URL The URL the device uses during certificate enroliment.

Challenge Type Allows the admin to choose between static challenge and no challenge.

Static Challenge If static challenge is selected, this is the necessary challenge the device

must have in order to get its CSR signed by the CA.

d Select Save.
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2 Configure the request template in Workspace ONE UEM console.

a

d

Navigate to Devices > Certificates > Certificate Authorities. Select the Request
Templates tab. Select Add.

Enter the following information pertaining to your request template.

Settings Description

Name The friendly name given to the request template defined in Workspace
ONE UEM.

Description An optional field you can use to describe the details, usages, etc. of the

request template.
Certificate Authority The certificate authority you defined previously.

Subject Name The subject given to device when it generates its key pair. Use the
lookup value button to the left of the field for dynamic values.

Private Key Length The length of the key pair to be generated.

Private Key Type This tells the device what the private key is to be used for.

For SAN Type, select Add to include one or more Subject Alternate Names with the
template.

This is used for additional unique certificate identification. In most cases, this needs to
match the certificate template on the server. Use the drop-down menu to select the SAN
Type and enter the subject alternate name in the corresponding data entry field. Each
field supports lookup values. Email Address, User Principal Name, and DNS Name are
supported by SCEP templates by default, and Workspace ONE UEM recommends that
you use them.

Select Save.

3 Create a SCEP profile in the Workspace ONE UEM console.

Define a certificate authority, then configure a Credentials payload alongside your EAS, Wi-Fi
or VPN payload. Each of these payloads has settings for associating the certificate authority
defined in the Credentials payload.

a

b

Navigate to Devices > Profiles > List View > Add and select iOS from the platform list.
Configure General profile settings as appropriate.

Select either an EAS, Wi-Fi or VPN payload to configure. Fill out the necessary
information, depending on the payload you selected.

Select the SCEP payload and select your SCEP Certificate Authority and Certificate
Template from the drop-down lists. Navigate back to the previous payload for EAS, Wi-Fi
or VPN.
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e Specify the Identity Certificate in the payload.

EAS - Select the Payload Certificate under Login Information.

Wi-Fi - Select a compatible Security Type (WEP Enterprise, WPA/WPA2 Enterprise or
Any (Enterprise)) and select the Identity Certificate under Authentication.

VPN - Select a compatible Connection Type (for example, CISCO AnyConnect, F5
SSL) and select Certificate from the User Authentication drop-down. Select the
Identity Certificate.

f Select Save and Publish when you are done configuring any remaining settings.
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EOBO with AD CS via DCOM

If you have a strong security policy for certificates and you want to use Microsoft's Certificate
Enroll On Behalf of Others (EOBO) function, integrate an Enroliment Agent Signing Certificate

with Workspace ONE UEM. This process uses Active Directory Certificate Services (AD CS) by
the Distributed Component Object Model (DCOM) remote protocol for integration.

By default, only domain administrators are granted permission to request a certificate on behalf
of another user. However, you can grant a user or computer account other than a domain
administrator permission to become an enroliment agent. To be an enroliment agent, the user or
the computer account registers for an Enrollment Agent certificate.

Note For integration with Workspace ONE UEM, the user is a computer account.

After an agent has an Enrollment Agent certificate, that agent registers for a smart card
certificate and generates a smart card on behalf of anyone in the organization. The smart card
user can log in to the network and impersonate the real user. Because of the powerful capability
of the Enrolliment Agent certificate, it is best that your organization maintains strong security
policies for these certificates.

For Workspace ONE UEM to use a certificate in a profile used to authenticate a user, set up an
enterprise certificate authority (CA) in the domain in an on-premises environment. Additionally,
you must join the CA to the same domain as VMware AirWatch Cloud Connector to successfully
manage certificates within Workspace ONE UEM. There are several methods for Workspace ONE
UEM to retrieve a certificate from the CA.

m On-Premises - Components are Internal with no VMware AirWatch Cloud Connector - In an
on-premises environment, all Workspace ONE UEM application servers are internal and the
VMware AirWatch Cloud Connector is not installed.

_________________________________________________________

Internet Internal

(e

Workspace ONE UEM Internal CA
console/Device Services

_________________________________________________________

VMware, Inc. 72



Certificate Authority Integrations

m On-Premises - Devices Services in a DMZ with no VMware AirWatch Cloud Connector - In an
on-premises environment, Devices Services is located in a DMZ and the CA and Workspace
ONE UEM servers are internal. The VMware AirWatch Cloud Connector is not installed.

___________________________________

Internal

1

1

I

<% (ol o I

1

— — !
1

1

1

Internet

Internal CA Workspace ONE

UEM console

___________________________________

m On-Premises — Components are Internal with VMware AirWatch Cloud Connector - In an on-
premises environment, Devices Services, Workspace ONE UEM server, the CA, and VMware
AirWatch Cloud Connector are internal.

___________________________________________

Device Services Internal CA

Workspace ONE
UEM console

m On Premises - Devices Services in a DMZ with VMware AirWatch Cloud Connector - In an
on-premises environment, Devices Services is located in the DMZ and Workspace ONE UEM
server, CA, and VMware AirWatch Cloud Connector are internal.

________________________________

>

m
Il ::0
gt

—
FACACAE]

Internet X : DMz : X Internal
o — l ACC
EAcacaca >
~—

Internal CA

Workspace ONE
UEM console

________________________________

m  SaaS - Components in the Cloud with VMware AirWatch Cloud Connector - In a SaaS
environment, Devices Services, Workspace ONE UEM server, and the CA are in the cloud.
The VMware AirWatch Cloud Connector and an internal CA are internal and must be in the
same domain.
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Internet DMz

Internal

Device Services T T

I=0=E

OB

Internal CA

Workspace
ONE UEM console

Prerequisites

Use an on-premises Workspace ONE UEM environment.

Note There is one scenario where a SaaS Workspace ONE UEM environment is supported.

The certificate authority used in certificate integration must be a member of the same domain
as the Workspace ONE UEM application server to install the Enterprise CA.

Use a service account with administrative access to the certificate authority server.

Use Windows Server 2008 R2 SP1, Windows Server 2012, Windows Server 2012 R2, or
Windows Server 2016.

The Workspace ONE UEM console server and the VMware AirWatch Cloud Connector
server (if you are using it), must communicate to the Microsoft Certificate Authority over
all configured DCOM ports.

Note If using VMware AirWatch Cloud Connector, the VMware AirWatch Cloud Connector
server must comply with the hardware sizing requirements mentioned in the Workspace ONE
UEM Recommended Architecture. Refer to the guidelines described for the Admin Console
server.

You can configure the port range to be any number of non-standard ports depending on
your DCOM implementation. However, the listed ports are utilized by default.

m  Port 135: Microsoft DCOM Service Control Manager.
m  Ports 1025 - 5000: Default ports DCOM processes.

m  Ports 49152 - 65535: Dynamic Ports.
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Procedure

1 Set up the restricted enroliment agent signing certificate on the CA server.

a Enable LDAP referrels.

Active Directory Certificate Services (AD CS) Certificate Authority (CA) requires enabling
LDAP referrals so that Workspace ONE UEM can request certificates on behalf of some
other service account user.

1

2

3

Stop certificate services by running the following command, net stop certsvec.

Enable LDAP Referrals, certutil -setreg policy\EditFlags

+EDITF ENABLELDAPREFERRALS.

[&+ Administrator: Command Prompt

MHicrosoft Windows [Uersion 6.1.76811
Copyright <c> 2009 Hicrosoft Corporation. All rights reserved.

C=~UsersssucSCEP>certutil —setreg policysEditFlags +EDITF_ENABLELDAPREFERRALS _

Start certificate services by running the following command, net start certsve.

b Create a Restricted Enroliment Agent Certificate so you can generate a Restricted
Enrollment Agent Signer Certificate.

1
2
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Open the Certificate Authority (CA).
Expand the CA Name, Right click Certificate Templates, and select Manage.

Right click the Enrollment Agent (Computer) template and select Duplicate Template.
Name it per your preference.

Select your Windows Server version.
On the Request Handling tab, select Allow Private Key to be Exported.

On the Subject Name tab, make sure Build from this Active Directory Information is
activated and Subject Name format is set to Fully distinguished name.

On the Security tab, give the enroliment agent servers Read and Enroll permissions.
Click OK.

Navigate back to the CA, right click Certificate Templates, select New, and select
Certificate Template to Issue.
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File  Action Wiew Help

ation Authority {Local)]

G| = | H HH

__ﬂj Certification Authority {Local)

[ame

| Descripkion |

= ﬂ::] airwatch-ATLO1DENCSZ21-CA
| Revoked Certificates
| Issued Certificates
_| Pending Requests
_| Failed Requests

Manage

H:I] airwatch-4TLO1DEMCS21-CA

Certification Autharity

Certificate Template to [ssue

Refresh

Help

|Creates a new ikem in this containgr.

10 Select the duplicate copy of the template created in the previous step.

&__certsrv - [Certification Authority {(Local)ail ,Certificate Templates]
File Action Wiew Help
&= 7| o=
Cerbification mst o oot I~ T. T o T A|
_gjuj aitwatch: [l Enable Certificate Templates
- Revg Select one Certificate Template to enable on this Certification Autharity.
. Issue ate: I & cerlificate template that was recently created does not appear on this list, pou may need to wait unkil
| Pend  information about thiz template has been replicated to all domain controllers.
“| Failes 2l of the certificate templates in the organization may not be available to your CA,
= Certi Far mare information, sees Certificate Template Concepts.
Hame | Intended Purpoge il
E Confighdar Client Distribution Point Certificate  Clent Authentication
j Confighdar Web Server Certificate Server Authentication
:! Copy of ATLD_CAD3_User Encrypting File System, Secure Email, Client Authentication
Ci of E hrallmed i it J
)| Copy of R4S and 145 Server Server Authentication, Client Authentication
]| Copy of User Client &uthentication, Secure Email. Encrppting File System
E Cross Certification suthority <Al
E Directory Email Replication Directory Service Email Replication
& Dorming Test Server Authentication
ﬁl DraminaClismt Server Authentication [ _l;l
4 3
ak. I Cancel |
E‘ Code Signing Code Signing
] web Server Server Authentication
& subordinate Certification Authority <All= =
1 Click OK.
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c Generate the Restricted Enrollment Agent Signer Certificate on any server that can
connect to the Certificate Authority.

1 Login with a local admin account on the server when requesting the Enrollment
Agent certificate on the ACC/DS/CN server.

2 Open Microsoft Management Console, (MMC).

3 Click File and select Add/Remove Snap in.

= Consolel - [Console Root] _[ofx

w Action  Wiew  Favorites  Window  Help | - ﬂlil
é Rlew Chrhet
—  Open... ChrHO | -
~  Save Ctrl+s [ Actions
Save As... There are no ikems to show in this view,
A ki, .. ChrHM IMare Actions »

1 C:iwindowsisystem3z2)certsry
2 C:\Windows\, ..\ Serverfanager
3 C\Windows\Syskem3Zycertbmpl
4 CiiUsers),..\DesktophConsolel

Exit

|Enah|es wou to 5dd snap-ins ta or remave them From the snap-in console.

Select Certificates.
Select Computer Account.
Select Local Computer and select Finish.

Click OK.

0o N o o b

Expand Certificates (Local Computer), double-click Personal, right click Certificates,
select All Tasks, and select Request New Certificate.

9 Click Next.

10 Select Active Directory Enrollment Policy and select Next.

7= Consolel - [Console Root' Certificates (Local Computer)'PersonalCertificates]

e Enrollment

———————— ] Certificate Enrollment
] Console Root tions

= 5 Certificates {Local Computer)

~ Personal Select Certificate Enrollment Policy —

=
| Cettificates Mare Actions »
| Trusted Root Certification Certificate enrollmant policy enables enrollment for certificates based on predefined certificate templates, Certificate
__ Enterprise Trust enrollment palicy may already be configured For you,
~ Intermediats Certification
| Trusted Publishers Configured by your administrator

1 Unbrusted Certificates

| Third-Party Rook Certifica
“| Trusted People Configured by you Add Hew
] Cperations Manager

| Remote Desktop
 Certfficate Enrolment Rec
| Smart Card Trusted Raoks
| Trusted Devices

R EE

Learn mare about gertificate enrollment policy.

o |

4 | | K3 ] o

Personal store contains 22 certificates. [
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11 Check the duplicate template created in earlier steps and select Enroll.

Consolel - [Console Root' Certificates (Local Computer)'Personal'Certificates] o =] B3
File —Action View Favorites twindos Heln |_|_|- 2| x|
T [ ol icate Enroliment _|O
Y EEIEINEE)
~ 5] Certificate Enrollment
~| Console Roat tions
= Certificates {Local Computer) W
B [ Personal Request Certificates
| Certificates More Actians »
~| Trusted Reat Certification You can request the following bypes of certificates, Select the certificates you wark to request, and then click Enroll.
| Enkerprise Trust
| Intermediate Certification T T &
| Trusted Publishers . _
| Untrusted Certificates [~ Ch Exchange 1) STATUS: Available Details (%) J
| Third-Party Root Certifica ﬂ More information is required ko envoll For this certificate. Click here to configure settings.
| Trusted People
| Cperations Manager [ CEP Encryption L) STATUS: Avallable Detals (&)
_| Remote Desktop . - . o . . N
= Certificate Enrollment Rec ﬂ Mare infarmation is required to enrall For this certificate. Click here to configure settings.
| Smart Card Trusted Roots
| Trusted Devices [~ Computer 1) STATUS: Avallable Details ()
[W Copy of Enroliment Agent {Computer) j‘JSTATUS: Available Details (%) J
-
™ Show all templates
Learn more about certificates
Cancel
4 | I ] ] 21

12 Once completed, select Finish.

d Configure the certificate to make the private, if needed, and public keys using the

network service.

1 Right click the restricted enrollment agent signer certificate and select All Tasks

followed by Manage Private Keys.

2 Click Add.

3 Type Network Service and select Check Names. Once added, select OK twice.

Q Select Users, Computers, Service Accounts, or Groups ﬂ

Select this object type:

| Expiration Date

| Intended Pur[:l I Actions

[ IUsers, Groupsz, of Built-in security principals Object Types.

From thiz location:

IAir\Au"atch DEY Locations...

Enter the object names to select [examples)

MNETWORK SERVICE Check Mames

Advanced... | Cancel
p

cure Certificate Authori..,
st Roat CA

st Root CA
LOIDEYCSZ0-CA
LOIDEYCSZ1-CA
LO1DEYCS20-CA
LD-CADG-CA
LD-CADZ-CA
L01DEYCSZ21-CA
LO1DEYCS20-CA
LO1DEYCSZ21-CA

airweatch-aT

m];
ot

Special permissions

click Advanced

(1] | Cancel | Apply |

| | Kl

LO1DEYCSZ1-CA

alrwatch-ATLOIDEYCSZ21-CA
airwakch-ATLD1DEYCS21-CA
airwatch-ATLOIDEWCS21-CA
For special permissions or advanced settings, e | sirwakch-ATLOIDEYCS21-CA

o alrwakch-ATLOIDEYWCS21-CA
A Device Services Child Certificate
Leamn about sccess contiol and permissions A Device Services Child Certificate
A Device Services Child Certificate
airwakch-ATLD1DEYCS21-CA
TR TTAr e o AgeTTe ceroreate B2.., YMware YCM Agent Certificate B250...

2{2042017
1j23z022
1j13f2022
5f9f2019

6124/2014
Sfafz019

8(26/2015
12212015
7lz7j2007
3(7(2015

9f20/2017
11112007
111207
1j12f2017
1j2712017
1j27fz017
1j1212017
9f14/2034
Bl5(2033

/1312033
7(z7j2017
3(2312025

Server futhel
<All>

<Allx

<All>

Client Authen
<Al

Client Authen
Client Authen
Certificate Re
Client Authen
Certificate Re
Certificate Re
Certificate Re
Certificate Re
Certificate Re
Certificate Re
Certificate Re
Server Authel
Server futhel
Server Authel
Certificate Re
<All>

Cettificates

More Actions

More Actions 4

Mg

Another option to using the network service is adding the service account to manage the
private keys. This option requires that the AirwWatch Cloud Connector service logs in as

the service account.
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e Depending on the need to install certificates on multiple servers, either export the public
key or both the public and private keys.

If the certificate needs to be installed on multiple Device Services servers or VMware
AirWatch Cloud Connector servers, export the public and the private key.

When exporting the certificate to install on additional AirWatch Cloud Connector
servers, the subject name is the name of the server the certificate was requested
from (for example, requested from ACC1). Even though the subject name does not
match the other servers you are importing the certificate to (for example, importing to
ACC2 and ACC3), this disparity does not cause issues because the private key is also
imported along with the certificate.

1 Right click the issued certificate, select All Tasks followed by Export.
2 Click Next.

3 Select Yes, export the private key and select Next. Select Include all certificates
in the certification path if possible as well as Export all extended properties. Click
Next.

4 Set a password and select Next.
5 Select a folder in which to save the exported certificate.
6 Click Finish.

If the certificate is installed on a single Device Services server or VMware AirWatch
Cloud Connector server, export only the public key.

1 Right click the issued certificate, select All Tasks followed by Export.
2 Select No, do not export the private key, select Next.

3 Select DER encoded binary X.509 (.CER), select Next.

4 Select a destination for the exported certificate and select Next.

5

Click Finish.

f If you have other DS servers or VMware AirWatch Cloud Connector (ACC) servers, you
must import the certificate that was exported in previous steps. Skip this section if you
have no other DS or ACC servers.

1

2
3
4
5
6
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Open Microsoft Management Console (MMC).
Click File and select Add/Remove Snap in.
Select Certificates.

Select Computer Account and select Next.
Select Local Computer and select Finish.

Click OK.
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7 Expand Certificates (Local Computer) and select Personal. Right click Certificates,
select All Tasks and select Import....

8 Select the PFX file exported in previous steps and select Next.

9 Enter the password created for this file in previous steps, make sure Include all
extended properties is checked and select Next.

10 Ensure Place all certificate in the following store is set to Personal and select Next.

11 Click Finish.

2 Create a custom user template if you do not want to use the default Microsoft Certificate
template to issue certificates to the end user.

If using the default Microsoft Certificate template, consider using the template for client
authentication certificates.

a

On the CA server, under the Certificate Authority Name, right click Certificate Templates
and select Manage.

Right click a default template that is closest to your needs and select Duplicate Template.
Select your Windows Server and select OK.
Enter the Template display name and select Apply.

Select the Issuance Requirements tab and select This number of authorized signatures.
Under the Application policy drop-down field, select Certificate Request Agent and
select Apply.

On the Subject Name tab, select Build from Active Directory Information. Configure
the name format as Fully Distinguished Name along with including the Email and User
Principal Name.

If you do not configure the subject name, the subject is blank and the certificate request
fails.

On the Security tab, give the service account Read, Enroll, and Auto Enroll permissions.

Right click Certificate Templates under the CA name, select New, and select Certificate
Template to Issue.

Select the template that was just created and select OK.

3 SaaS environments can configure the VMware AirWatch Cloud Connector to deploy
Enrollment On Behalf Of (EOBO) with ADCS on Microsoft's Distributed Component Object
Model (DCOM) substrate.

If your Workspace ONE UEM deployment is strictly on-premises, you do not need to perform

this step.

a Onthe VMware AirWatch Cloud Connector server, run services.msc.
b Stop the Cloud Connector service.

¢ Right-click the Cloud Connector service.
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d Select Properties.
e Select the Log On tab.

f Under Log on as:, select Local System account and enable the check box Allow Service
to Interact with Desktop.

g Click OK to save settings and close the Properties page.

4 Connect Workspace ONE UEM to the certificate authority and upload your public key to the
console.

a Inthe Workspace ONE UEM console, navigate to Groups & Settings > All Settings >
System > Enterprise Integration > Certificate Authorities > Certificate Authorities tab
and select Add.

b Complete required text boxes and make the listed configurations.

Option Description
Authority Type Select Microsoft ADCS.
User name Enter the username and its corresponding password

that has administrative access to the certificate
authority server.

Additional Options Select Restricted Enrollment Agent.

¢ Upload the public key file (.cer) you exported when you set up the Restricted Enroliment
Agent.

d Select Save.

5 Configure the request template in Workspace ONE UEM so that services in the console,
like wifi, email, and VPN, can request secure communication with the configured certificate
authority.

a Inthe Workspace ONE UEM console, navigate to Groups & Settings > All Settings >
System > Enterprise Integration > Certificate Authorities > Request Templates tab and
select Add.

b Select the certificate authority you created previously.
This step sets up the available options in the Certificate Template - Add/Edit window.

c Set the Issuing Template to either the default user template or the custom user template
you configured earlier.

d Set the Requester Name to the lookup values {EmailDomain}\{EnrollmentUser} for best
results.

Select user-specific lookup values. Device-specific lookup values are not supported.
e Click Save.

You can stop here in the process unless you need to establish permissions on the VMware
AirWatch Cloud Connector.
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6 In some cases, steps used to configure the VMware AirWatch Cloud Connector may not be
sufficient to establish the proper permissions required to log in to the server. Troubleshoot
the permissions using a suggested method.

a Create a service account with full permissions.

A service account runs the VMware AirWatch Cloud Connector service. Current service
account permissions are subject to change if the permission levels can be successfully

lowered.

1 Add permissions for members of the following groups in Active Directory.
s Domain Users
m  Enterprise Admins
m  Remote Desktop Users

For example, the screenshot displays the permissions for the service account

‘caadmin’.
caadmin Properties
[
| Remote control | Remote Desktop Services Profile I COM+
General I Address I Account I Profile | Telephones | Organization
Member Of | Digkin | Environment I Sessions
Member of:
Mame Active Directony Domain Services Folder
Domain Users 2N 2CATemplate local /Users

Enterprize Admins 201 2CATemplate local/Users

Remote Desltop Users  2012CATemplate local/Builtin

< mn [+]
Primary group: Domain Users
T There is no need to change Primary group unless
Set Primary Group you have Macintosh clients or POS¥-compliant
applications.
[ ok [ caned || ooy [ Heb |

2 Configure permission on the certificate authority (CA) server.

m  Member of Local Administrator Group

For example, the screenshot displays Local Administrator Group permissions on
the CA Server.
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2012_DevCA_CertAuthority

. General

@( Administrators

Administrators have complete and unrestricted access
to the computer/domain

Description:

Members:

€ 2012CATEMFLATE \caadmin

& 2012CATEMPLATE \causer

%2{]1 2CATEMPLATE \Domain Admins
A Administrator

Changes to a user's group membership
| Add | | Remove | are not effective until the next time the
user logs on.

ok G [ ow | [ ]

m  Full permissions on the Certification Authority

For example, the screen below displays the full compliment of available
permissions for 'caadmin’.

Extensions I Storage | Certificate Managers
General | Policy Module | Exit Module
Enrollment Agerts | Auditing | Recovery Agents | Security

Group or user names:
%Mhenticated Users
caadmin (caadmin@2012CATemplate local)
& CA User (causer@2012CATemplate local)
% Domain Admins (2012CATEMPLATE Domain Admins)
% Enterprise Admins (2012CATEMPLATE"\Enterprise Admins)
%ﬁdministmtors (201 2CACA Administrators)

| Add... || Remove |

Pemmissions for caadmin Alow

Read

lssue and Manage Certificates
Manage CA

Request Certficates

b Use alternate VMware AirWatch Cloud Connector configuration.

1

2
3

VMware, Inc.

On the VMware AirWatch Cloud Connector server, run services.msc.
Locate and stop the Cloud Connector service.

Right-click the Cloud Connector service.
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4  Select Properties.
5 Select the Log On tab.

6 Under Log on as:, select This account and Browse for the service account you
created.

7 Enter and confirm the password.

AirWateh Cloud Connector Properties (Local Computen) I

| General | Log On | Recovery I Dependencies |

Log on as:

() Local System account
[T] Mlow service to interact with desktop

(®) This account: |caadmin@2{]12ﬁATemplate.loc| | Browse..
Password: |............... |
Corfim password: |............... |

[ ok ][ Camcel ][ sty |

8 Launch the Microsoft Management Console (mmc.exe) and open the personal
certificate store of the local computer.

Ensure you are logged in with an account that has admin permissions for both the
VMware AirWatch Cloud Connector server and the domain, otherwise you may not
be able to access MMC and also add a domain user to manager the private key.

9 Select the Restricted Enroliment Agent.

10 In MMC, right-click the Restricted Enroliment Certificate you added and select All
Tasks and then Manage Private Keys.

11 Add the service account and set read permissions.
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: !Ir PermlssmnsforAW Clc—ﬂd Connector —Shell_-

Security

I:3I‘0I.I|:J Or User names:
£, 5YSTEM

3 caadmin (caadmin @201 2CATemplate local)

%ﬁdminishators (SERYERZ2012R2" Administrators)
Ho5-1-55-0-12419257

| Add... | | Remove |
Pemissions for caadmin Allowe Dlerny
Full contral O O
Read [l
Special permissions O O

For special pemmissions or advanced settings,
click Advanced.

[ ok || cancel || fppy |

12 Click OK to save settings and close the Properties page.

13 Add the service account to both the VMware AirWatch Cloud Connector and the
Secure Channel Certificates.

m  Both these certificates are issued by the Device Services Child Certificate.

m  They are issued to AW Cloud Connector - VMware Enterprise Systems
Connector and AW Cloud Connector - [OG Namel].

14 From services.msc, manually start the Cloud Connector service.
What to do next
If you see one of these error messages, review some troubleshooting tips.
m The system cannot find the file specified. 0x80070002 (WIN32: 2)

The REA signing certificate might not be present on the console/DS server’s certificate
store. You might have added it using your SSO AD user. These AD user-uploaded MMC
certificates remain specific to that instance since they are not Network Admin users.

Therefore, airwatchdev\svcscep (the network admin) cannot access the private key of REA

certificate uploaded using awsso\shwethan.

When adding an REA signing certificate to MMC, make sure you log in as the network
admin (airwatchdev\svcscep). Then add the signing certificate to the certificate store and

give proper network service access to it so that other network admin users can also access it.

When you provide Service Account credentials on the CA configuration page in the

Workspace ONE UEM console, the console/DS server performs a remote call to the server

hostname using these service account credentials.
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m Object reference not set to an instance of an object

The CA server received the certificate request, but the policy module denied the request. The
denial happens either because the LDAP forest referrals are not set (Step 1 of CA server), or
because the user domain used is not correct or not associated with the CA server.

For Issued certificates on the CA server, only requests from the Airwatchdev domain are
processed. AWSSO domain requests are rejected (atlO1devcs21 CA is synced only with
Airwatchdev AD, not with AWSSO). Therefore, we changed the directory mapping on the
LGs to Airwatchdev and users from this domain for enrolling devices. The profile lands on the
device with the correct client certificate for REA.

VMware, Inc. 86



Symantec MPKI

Workspace ONE UEM is flexible with PKI integration by being able to request certificates from
either internal or external certificate authorities (CA). Integrate with Symantec MPKI services to
issue certificates for your Workspace ONE UEM MDM solution.

In order for Workspace ONE UEM to communicate with Symantec as a Registration Authority
(RA), you must first establish an account with Symantec. After your Symantec account is active,
you can generate an RA certificate and store it on the RA server.

Workspace ONE UEM can then be configured to use the certificate to communicate with the
Symantec MPKI CA. Once communication is successfully established, you can define which
certificate Workspace ONE UEM will deploy to the device.

Prerequisites

m  Symantec version 8.0 or later

m A Symantec MPKI account

m  Workspace ONE UEM version 9.5 or later

. When using PKI protocol, verify the Symantec certificate profile(s) under Primary certificate
options.

Ensure Enrollment Method is set to PKI Web Services and Authentication method is set to
3rd party application. This gives Workspace ONE UEM the ability to deploy certificate profiles
through APIs.

m  When using SCEP protocol, verification that the Symantec certificate profile(s), under Primary
certificate options, within Authentication method, has Enroliment Code selected. This gives
the SCEP server the ability to deploy certificate profiles through APIs.
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Procedure

1 In the Symantec PKIl portal, generate a Registration Authority (RA) certificate. After Symantec
creates the certificate, it is stored on the server, which can be any server you choose.

a Generate a new RSA key pair.

Command: openssl req -new -newkey rsa:2048 -nodes -out AirWatch.csr
—-keyout AirWatch.key -subj

/C=US/ST=Georgia/L=Atlanta/0=R&D/0U=R&D/CN=AirWatch
b Login to the Symantec PKI portal.
c Click on Tasks (gear icon). Click on Get a RA Certificate.

v B - ) g v Pagew Safely - Took - (€

(& symantec™ PKI Manager

Symantec™ PKI Manager

Logged in to: WorldTone Cellular

Alerts Users and certificates Account status
Manage users

Account activity

Siatuz: OK

Last updated: Aug 20, 2012 7:09 PM

Refresh

Days to expiration of administrator certificate for WerldTene Cellular Manage cerlificates

Days to expiration of RA certificate named REGISTRATION AUTHORITY 13262/ JREe Rt S Next service renewal: Sep 9, 2014
Manage authorized user lists

=]

There is no recent activity for these functions

[

PKI Client 2.5 includes important feature and security updates, including enhang Optional account setup:

users will receive these updates automatically. Referto Managed PKIvE 5 Reled Reporting = @ use directory service
View recent reports

Schedule a report

User seat activity
View audit trail

Your account
Manage account and sub-
accounts

Manage adminisirators
Seat usage

Manage CAs

Cerificates

Manage PKI Enterprise Galeways Seat pool Used Out of
Get an RA cerlificate & 5
User 44 500
" Fen'lz Mar "1z =
Device 0 500

— Certificates revoked
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d Paste the CSR into the field, submit, and download a new certificate.

. i
Get RA certificate: Enter CSR Download certificate

Get an RA certificate

If you are setting up PEI Enterprise Gataway or PKI Web Sarvices, you must install an RA ceddificates to sscurs

cormmunications with Symantec

If you are not setting up these servicss, or have slready gotten your RA cedificats, you do not nesd to complets this

prooess.

Enter Certificate Signing Request {CSR)

Ak your server sdministretor to generste 8 TSR for your RA cetificats. Your administretor must generste the C5R
according to the instructions in the installstion guide for your service.

You can scoess the resources page by clidking on the O icon on the dashbosrd.

*Paste your C5R:

-]

=

mponant Senvics Reguirements: I pou disCOVET OF MEVE rE50n 1D Delleve Tt TETe s Deen 3 compromiss of your private ey, you must Immedlzizly rewsks e cerieEt: or
Nty SymEntec™ 0 0o 50, Simitarly, e Ivormation winin jour ceriificzis or your arganization nams nes changsd, plesss nOt Symantec. MO TE! SmEnEe ™ retaing
e rigiht 10 revoie youUr CEMFICEte 22 2y time winout natics If (1) you %21 %2 perionm your obligations under e iemms of your sen/ice agreement; or (1) In Symamiss's solke
CIECTEION. You MENE ENGE0EC 1N S0INTIEE WAKY SyMETIECTY ORIETMINgS Ens NEMTUI W0 NE EEEME

lﬂanoelJlCnntimJ

* Reguired information

e Convert the .p7b format certificate into .pem.

Command: openssl pkcs7 -print certs -in certificate.p7b -out

certificate.pem

f  Create a pkcs12 with the private key and pem.

openssl pkcsl2 -export -out certificate.pfx -inkey AirWatch.key -in

certificate.pem
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2 Configure CA and request template in Workspace ONE UEM.

a Configure the CA.

1

Navigate to Devices > Certificates > Certificate Authorities > Certificate Authorities
tab.

Click Add complete the menu items.

Option Description
Authority Type Symantec
Server URL Enter https://pki-ws.symauth.com/pki-ws. This

allows Workspace ONE UEM to have sufficient
access to request and issue certificates.

The URL is the same for all customers.
Protocol Select either the PKI or SCEPradio button.

SCEP Endpoint URL (SCEP Protocol) Enter the URL for the SCEP End Point in the data
entry field that appears. This allows your SCEP
server to have sufficient access to request and issue
certificates

Certificate Select the Upload button and select the RA
certificate (PFX file) you generated earlier.

Enter the password Symantec provided previously in the Certificate Password field.

The password you need in this step was created when you completed and exported
the CSR process.

Select Save.

Click Test Connection when complete to verify the test is successful. An error
message appears indicating the problem if the connection fails.

b Configure the request template.

Define which certificate deploys to devices by setting up a certificate template in
Workspace ONE UEM.

1
2
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Navigate to Devices > Certificates > Certificate Authorities.
Select the Request Templates tab.

Click Add and complete the menu items.

Option Description

Certificate Authority Select the Symantec CA you created.

Profile Name Select the Symantec profile OID

Automatic Certificate Renewal Select the this checkbox if Workspace ONE UEM is

going to automatically request the certificate to be
renewed by Symantec when it expires.
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Option

Enable Certificate Revocation

Key Type

Mandatory Fields

4 Click Save.

Description

If you select this option, enter the number of days
prior to expiration before Workspace ONE UEM
automatically requests Symantec to reissue the
certificate in the Auto Renewal Period (days) field.
This requires the certificate profile on Symantec to
have Duplicate Certificates enabled.

Select the this checkbox if Workspace ONE UEM
should automatically remove the certificate if the
device is unenrolled, if the applicable profile

is removed, or if the device is deleted from
Workspace ONE UEM.

If you do not select this checkbox, when you delete
a profile or a device the SCEP certificate is removed
from the device but it is not automatically revoked
from the CA.

Configuration occurs in the Symantec PKI Manager.
This indicates whether the public-private key pair
is generated by Workspace ONE UEM or by
Symantec. Workspace ONE UEM loads this setting
from Symantec based on the selected OID and
uses this value to determine the type of certificate
request to send. Absolutely no configuration in
Workspace ONE UEM is needed by the customer.

Enter Lookup Values that complement those fields
in the Symantec profile. These fields can change
depending on which Symantec profile you choose
since the information within the Symantec profile
may be different.

3 Configure Workspace ONE UEM profiles (payloads) for either PKI or SCEP.

If in configuring the CA, you chose PKI then you only need to configure a Credentials profile,
but if you chose SCEP, you only need to configure a SCEP profile. Once either of these
profiles is created, you can create additional payloads that the Symantec certificate can use,
such as Exchange ActiveSync (EAS), VPN, or Wi-Fi services.

a

b

Navigate to Devices > Profiles > List View.

Click Add.

Select the applicable platform for the device type.

Specify General profile parameters.

Select Credentials from the payload options and select Configure.

Select Defined Certificate Authority from the Credential Source drop-down menu.

Select the external Symantec CA you created previously in Configuring CA from the

Certificate Authority drop-down menu.
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h Select the certificate template for Symantec you created previously in Configuring
Certificate Template from the Certificate Template drop-down menu.

i Select SCEP from the payload area on the left rather than configuring Credentials.
j  Select Defined Certificate Authority from the Credential Source drop-down menu.

k Select the external Symantec CA you created for using SCEP previously in Configuring CA
from the Certificate Authority drop-down menu.

| Select the certificate template for Symantec you created for using SCEP previously in
Configuring Certificate Template from the Certificate Template drop-down menu.

At this point, saving and publishing the profile would deploy a certificate to the device.
However, if you plan on using the certificate on the device for Wi-Fi, VPN, or Email
purposes, then you should also configure the respective payload in the same profile to
leverage the certificate being deployed.

What to do next
Review some tips and troubleshooting steps for the integration.
m  Verify ability to perform certificate authentication without Workspace ONE UEM.

Remove Workspace ONE UEM from the configuration and manually configure a device to
connect to your network server using certificate authentication. This should work outside of
Workspace ONE UEM and until this works properly, Workspace ONE UEM will not be able to
configure a device to connect with a certificate.

m  Verify ability to perform certificate authentication with Workspace ONE UEM.

You can confirm that the certificate is usable by pushing a profile to the device and testing
whether or not the device is able to connect and sync to the configured EAS, VPN, or Wi-Fi
access-point. If the device is not connecting and shows a message that the certificate cannot
be authenticated or the account cannot connect then there is a problem in the configuration.
Below are some helpful troubleshooting checks.

m |f SSL TLS errors are received while creating a template.
m  This error can occur when you attempt two tasks.

m Create a Workspace ONE UEM certificate template byselecting the Retrieve Profiles
button or

m  Retrieve a certificate from the Workspace ONE UEM console from the SecureAuth
certificate authority.

m  The troubleshooting technique that usually resolves this problem is adding the required
server certificate chain in the console servers trusted root key store.

m If the Workspace ONE UEM certificate profile fails to install on the device.
m  Inform Workspace ONE UEM Professional Services of the error and request they:

m  Turn On Verbose Mode to capture additional data.
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m  Retrieve web console log.
m Workspace ONE UEM analyzes the log and works with customer to resolve the problem.
m If the certificate is not populated in the View XML option of the profile.

= Confirm that lookup values configured on the Symantec certificate profile match the look
up values in the Workspace ONE UEM console’s request template.

m  Confirm that lookup values in Workspace ONE UEM request template are actually
populated in the user information being pulled from AD.

m  Confirm you are pointing to the right profile in Symantec.
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Workspace ONE UEM is flexible with PKI integration by being able to request certificates from
either internal or external certificate authorities (CA). Integrate with Enterprise Java Beans
Certificate Authority (EJBCA) services to issue certificates for yourWorkspace ONE UEM MDM
solution.

In order for Workspace ONE UEM to communicate with Enterprise Java Beans Certificate
Authority (EJBCA) for certificate distribution, you must have an EJBCA instance configured and
ready to issue certificates. You can then configure Workspace ONE UEM to communicate with
EJBCA using certificate based authentication. Once communication is successfully established,
you can define how to deploy certificates to devices. Below are some of the examples of how
EJBCA and Workspace ONE UEM can be configured.

m  Scenario 1: Workspace ONE UEM SaaS with EJBCA installed on-premises.

Decive Workspace ONE Internal Network
UEM SaaS
1

<—0—-—> —@—> —— Airwatch Cloud
4_9_.__(_._9_5 Connector

Workspace ONE $ ?

UEM MDM Server

EJBCA

PKI by PrimeKey

a Device enrolls with Workspace ONE UEM.

b Workspace ONE UEM requests certificate from EJBCA endpoint (optionally through the
AirWatch Cloud Connector).

¢ EJBCA endpoint delivers the certificate to Workspace ONE UEM (optionally through the
AirWatch Cloud Connector).

d Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or
WiFi profile.

If your EJBCA endpoint is public-facing, then it must be protected by a public SSL certificate.

If you are using AirWatch Cloud Connector, then it needs to be configured to trust the root
certificate installed on your EJBCA appliance.

m  Scenario 2: Workspace ONE UEM and EJBCA both installed on-premises.
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Decive Internal Network

<—0—-—> ——@0——>C—) Airwatch Cloud
(_e_.__ (_e_% Connector

' Workspace ONE $ ?
UEM MDM Server
I=0=0
EJBCA

PKI by PrimeKey

a Device enrolls with Workspace ONE UEM.

b Workspace ONE UEM requests certificate from EJBCA endpoint (optionally through the
AirWatch Cloud Connector).

c EJBCA endpoint delivers the certificate to Workspace ONE UEM (optionally through the
AirWatch Cloud Connector).

d Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or
WiFi profile.

If your EJBCA endpoint is public-facing, then it must be protected by a public SSL certificate.

If you are using AirWatch Cloud Connector, then it needs to be configured to trust the root
certificate installed on your EJBCA appliance. See Configuring AirWatch Cloud Connector to
trust EJBCA for more information.

Prerequisites
m  An EJBCA instance that is configured for certificate deployment.
s Workspace ONE UEM console version 9.5 or later.

m |f your EJBCA appliance is public-facing, it must be protected with a Public SSL Certificate. If

you are using VMware AirWatch Cloud Connector for enterprise integration, then it needs to

be configured to trust the root certificate installed on your EJBCA appliance.

Procedure

1 Generate an EJBCA certificate.
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2 Configure the CA and the request template in the Workspace ONE UEM console.

a Configure the CA.

1
2

Navigate to Devices > Certificates > Certificate Authorities.

Click Add and complete the menu items.

Option
Authority Type

Server URL

Certificate

Click Save.

Description
EJBCA

Enter the URL of your EJBCA instance.

This is the web endpoint that Workspace ONE
UEMuses to submit requests and issue certificates.

Select to Upload the certificate from the location on
your PC to which it has been saved.

Click Test Connection when complete to verify the test is successful. An error
message appears indicating the problem if the connection fails.

b Configure the request template.

Define which certificate deploys to devices by setting up a certificate template in
Workspace ONE UEM. Use the following to set up a template.

1
2
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Navigate to Devices > Certificates > Certificate Authorities.

Select the Request Templates tab.

Click Add and complete the menu items.

Option
Certificate Authority

End Entity Profiles

Certificate Profiles
Available CA

Subject Name

Automatic Certificate Renewal

Enable Certificate Revocation

Description
EJBCA

Define those parts of the DN that require
registration.

Define the actual certificate profile/template.
Enter the CA that issues the certificates.

Select a lookup value that defines the identity
bound to the certificate.

Select this checkbox if Workspace ONE UEM is
going to automatically request the certificate to be
renewed by EJBCA when it expires.

If you select this option, enter the number of

days prior to expiration before Workspace ONE
UEM automatically requests EJBCA to reissue the
certificate in the Auto Renewal Period (days) field.
This requires the certificate profile on EJBCA to
have the Duplicated Certificates setting enabled.

Select the this checkbox if you wantWorkspace
ONE UEM to be able to revoke certificates.
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4 Click Save.

3 Configure Workspace ONE UEM profiles (payloads). Once either of these profiles is created,
you can create additional payloads that the EJBCA certificate can use, such as Exchange
ActiveSync (EAS), VPN, or Wi-Fi services.

a Navigate to Devices > Profiles > List View.

b Click Add.

c Select the applicable platform for the device type.

d Specify all General profile parameters.

e Select Credentials from the payload options and select Configure.

f  Select Defined Certificate Authority from the Credential Source drop-down menu.
g Select the external EJBCA certificate you created previously.

h Select the request template for EJBCA you created previously.

Saving and publishing the profile would deploy a certificate to the device. If you plan on using
the certificate on the device for Wi-Fi, VPN, or email purposes, you should also configure the
respective payload in the same profile to leverage the certificate being deployed.

4 (Optional) If you are using AirWatch Cloud Connector and the EJBCA appliance is not public-
facing, then you need to ensure the AirWatch Cloud Connector configuration trusts the
appliance.

a Open the EJBCA console certificate and view the Certificate Path tab.

1 If multiple certificates are listed, they will need to be separated and added to the
appropriate stores.

2 The remaining steps address adding the root certificate to the Trust Root Store.
b Open MMC by searching for it using Windows Search and launching the mmc.exe file.
¢ Navigate to File > Add/Remove Snap-in. The Add or Remove Snap-ins screen displays.
d Select the Certificates snap-in in the left pane and select Add.
e Select Computer account as Snap-in source. Select Next.
f  Select Local computer and then select Finish.
g Select OK.
h Expand the newly added Certificates tree.
i Expand the Trusted Root Certification Authorities folder.
j  Right-click the Certificates folder here and select All Tasks > Import.

k Proceed through the Certificate Import Wizard. You will be prompted to Browse and
select the file of the root certificate used to generate the EJBCA Console certificate.
Select Next.
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|  Select Place all certs in the following store and then select Next.
m Click Finish.

n Select all other intermediate and child certificates to add them to their associated stores
within the Certificates tree.

What to do next

Review some tips and troubleshooting steps for the integration.

Verify ability to perform certificate authentication without Workspace ONE UEM.

Remove Workspace ONE UEM from the configuration and manually configure a device to
connect to your network server using certificate authentication. This should work outside of
Workspace ONE UEM and until this works properly, Workspace ONE UEM will not be able to
configure a device to connect with a certificate.

Verify ability to perform certificate authentication with Workspace ONE UEM.

You can confirm that the certificate is usable by pushing a profile to the device and testing
whether or not the device is able to connect and sync to the configured EAS, VPN, or Wi-Fi
access-point. If the device is not connecting and shows a message that the certificate cannot
be authenticated or the account cannot connect then there is a problem in the configuration.
Below are some helpful troubleshooting checks.

If SSL TLS errors are received while creating a template.
m  This error can occur when you attempt two tasks.

m Create a Workspace ONE UEM certificate template byselecting the Retrieve Profiles
button or

m  Retrieve a certificate from the Workspace ONE UEM console from the SecureAuth
certificate authority.

m  The troubleshooting technique that usually resolves this problem is adding the required
server certificate chain in the console servers trusted root key store.

If the Workspace ONE UEM certificate profile fails to install on the device.
m  Inform Workspace ONE UEM Professional Services of the error and request they:
m  Turn on Verbose Mode to capture additional data.
m Retrieve web console log.
m Workspace ONE UEM analyzes the log and works with customer to resolve the problem.
If the certificate is not populated in the View XML option of the profile.

= Confirm that lookup values configured on the EJBCA certificate profile match the look up
values in the Workspace ONE UEM console request emplate.

m  Confirm that lookup values in Workspace ONE UEM request template are actually
populated in the user information being pulled from AD.
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= Confirm you are pointing to the right profile in EJBCA.
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SecureAuth

Workspace ONE UEM is flexible with PKI integration by being able to request certificates from
either internal or external certificate authorities (CA). Integrate with SecureAuth services to issue
certificates for your Workspace ONE UEM MDM solution.

In order for Workspace ONE UEM to communicate with SecureAuth for certificate distribution,
you must have a SecureAuth instance configured and ready to issue certificates.

You can then configure Workspace ONE UEM to communicate with SecureAuth using basic
authentication. Once communication is successfully established, you can define how to deploy
certificates to devices. Below are some of the examples of how SecureAuth and Workspace ONE
UEM can be deployed.

m Workspace ONE UEM with SecureAuth Installed On-Premises

Workspace ONE UEM SaaS Internal Network

SECUREAUTH

—
—
— )

AirWatch Cloud

) a Connector (Optional)

a Device enrolls with Workspace ONE UEM.

b Workspace ONE UEM requests a certificate from the SecureAuth endpoint (optionally
thorugh the Airwatch Cloud Connector).
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c The SecureAuth endpoint delivers the certificate to Workspace ONE UEM (optionally
thorugh the Airwatch Cloud Connector).

d Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or
Wi-Fi profile.

Note If your SecureAuth endpoint is public-facing, then it must be protected by a public
SSL certificate. If you are using the AirWatch Cloud Connector, configure it to trust the
root certificate installed on your SecureAuth appliance.

m Workspace ONE UEM SaaS and SecureAuth SaaS

Workspace ONE UEM SaaS SecureAuth SaaS

°
) J J

< > > GE—
—
< —

SECUREAUTH

a Device enrolls with Workspace ONE UEM.
b Workspace ONE UEM requests a certificate from the SecureAuth endpoint.
c The SecureAuth endpoint delivers the certificate to Workspace ONE UEM.

d Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or
Wi-Fi profile.

m Workspace ONE UEM and SecureAuth Both Installed On-Premises
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Internal Network

SECUREAUTH

c—

Workspace ONE UEM MDM Server —o
c—)

AirWatch Cloud

e Connector (Optional)

Y e N an
[ ]
) J

a Device enrolls with Workspace ONE UEM.

b Workspace ONE UEM requests a certificate from the SecureAuth endpoint (optionally
thorugh the AirWatch Cloud Connector).

Cc The SecureAuth endpoint delivers the certificate to Workspace ONE UEM (optionally
thorugh the AirWatch Cloud Connector).

d Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or
Wi-Fi profile.

Note If your SecureAuth endpoint is public-facing, then it must be protected by a public
SSL certificate. If you are using the AirWatch Cloud Connector, configure it to trust the
root certificate installed on your SecureAuth appliance.

Prerequisites

m A SecureAuth instance that is configured for certificate deployment.

m Workspace ONE UEM console version 9.6 or later.

m |f your SecureAuth appliance is public-facing, it must be protected with a Public SSL
Certificate. If you are using VMware AirWatch Cloud Connector for enterprise integration,
then AirWatch Cloud Connector needs to be configured to trust the root certificate installed
on your SecureAuth appliance.

Procedure

1 Generate a SecureAuth MPKI RA certificate.
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2 Configure the CA and the request template in the Workspace ONE UEM console.

a Configure the CA.

1

Navigate to Devices > Certificates > Certificate Authorities > Certificate Authorities

tab.

Click Add and complete the menu items.

Option
Authority Type

Server URL

Company GUID

User name

Password

Click Save.

Description
SecureAuth

Enter https://<SecureAuth FQDN>/SecureAuthX/
webservice/certificateissuerws.svc, where
<SecureAuth FODN> is the URL of your SecureAuth
instance and the “X” in “SecureAuthX” is the realm
instance number that is configured for certificates.
This is the web endpoint that Workspace ONE UEM
will use to submit requests and issue certificates.

Enter the value that you can find in the SecureAuth
portal. Look in the License Info section.

Enter name for your SecureAuth instance. Look in
the FBA WebService section of the SecureAuth
portal.

Enter value for your SecureAuth instance. Look in
the FBA WebService section of the SecureAuth
portal.

Click Test Connection when complete to verify the test is successful. An error
message appears indicating the problem if the connection fails.

b Configure the request template.

1
2
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Navigate to Devices > Certificates > Certificate Authorities.

Select the Request Templates tab.

Click Add and complete the menu items.

Option
Certificate Authority
Subject Name

Key Pair Generation Location

Description
SecureAuth
The identity bound to the certificate.

Select either Workspace ONE UEM or SecureAuth.

This is where the key pair is generated - either on
the SecureAuth side or on the Workspace ONE UEM
side.
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Option Description

B SecureAuth - Generates the certificate and the
private key and returns it back to Workspace
ONE UEM with its root certificate. The root
certificate and user certificate are combined into
a single certificate and sent to the device to
install.

m  Workspace ONE UEM - Configure the Certificate
Validity Period, which is the length of time the
certificate is valid for in days. You can use
the value 365. Also, configure the Private Key
Length, which is how secure you want the keys.
Use 2048 as the key length.

Private Key Type Select if the certificate is used for signing and
encryption operations or both.

Automatic Certificate Renewal Select the this checkbox if Workspace ONE UEM is
going to automatically request the certificate to be
renewed by SecureAuth when it expires.

If you select this option, enter the number of days
prior to expiration before Workspace ONE UEM
automatically requests SecureAuth to reissue the
certificate in the Auto Renewal Period (days) field.
This requires the certificate profile on SecureAuth to
have the Duplicated Certificates setting enabled.

Enable Certificate Revocation Select the this checkbox if you want Workspace
ONE UEM to be able to revoke certificates.

4  Click Save.
3 Configure Workspace ONE UEM profiles (payloads) for either PKI or SCEP.

If in Retrieving Certificate from SecureAuth certificate authority, you chose PKI then you
only need to configure a Credentials profile. Once either of these profiles are created, you
can create additional payloads that the SecureAuth certificate can use, such as Exchange
ActiveSync (EAS), VPN, or Wi-Fi services.

a Navigate to Devices > Profiles > List View.

b Click Add.

c Select the applicable platform for the device type.

d Specify all General profile parameters.

e Select Credentials from the payload options and select Configure.

f  Select Defined Certificate Authority from the Credential Source drop-down menu.
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g Select the external SecureAuth CA you created previously from the Certificate Authority
drop-down menu.

h Select the certificate template for SecureAuth you created previously from the Certificate
Template drop-down menu.

Saving and Publishing the profile would deploy a certificate to the device. However, if
you plan on using the certificate on the device for Wi-Fi, VPN, or email purposes, then
you should also configure the respective payload in the same profile to leverage the
certificate being deployed.

4 (Optional) If you are using AirWatch Cloud Connector and the SecureAuth appliance is not
public-facing, configure AirWatch Cloud Connector to trust the SecureAuth appliance.

a Open MMC by searching for it using Windows Search and launching the mmc.exe file.
b Navigate to File > Add/Remove Snhap-in.
The Add or Remove Snhap-ins screen displays.
c Select the Certificates snap-in in the left pane and select Add.
d Select Computer account as Snap in source. Select Next.
e Select Local computer. Select Finish.
f  Select OK.
g Expand the newly added Certificates tree.
h Expand the Trusted Root Certification Authorities folder.
i Right-click the Certificates folder here and select All Tasks > Import.

j  Proceed through the Certificate Import Wizard. As prompted, browse and select the file
of the root certificate used to generate the SecureAuth SSL certificate. Select Next.

k Select Place all certs in the following store. Select Next.

| Click Finish.

What to do next
Review some tips and troubleshooting steps for the integration.
m  Verify ability to perform certificate authentication without Workspace ONE UEM.

Remove Workspace ONE UEM from the configuration and manually configure a device to
connect to your network server using certificate authentication. This should work outside of
Workspace ONE UEM and until this works properly, Workspace ONE UEM will not be able to
configure a device to connect with a certificate.

m  Verify ability to perform certificate authentication with Workspace ONE UEM.
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You can confirm that the certificate is usable by pushing a profile to the device and testing
whether or not the device is able to connect and sync to the configured EAS, VPN, or Wi-Fi
access-point. If the device is not connecting and shows a message that the certificate cannot
be authenticated or the account cannot connect then there is a problem in the configuration.
Below are some helpful troubleshooting checks.

m |If SSL TLS errors are received while creating a template.
m  This error can occur when you attempt two tasks.

m Create a Workspace ONE UEM certificate template byselecting the Retrieve Profiles
button or

m  Retrieve a certificate from the Workspace ONE UEM console from the SecureAuth
certificate authority.

m  The troubleshooting technique that usually resolves this problem is adding the required
server certificate chain in the console servers trusted root key store.

m If the Workspace ONE UEM Certificate Profile fails to install on the device.
m  Inform Workspace ONE UEM Professional Services of the error and request they:
m  Turn On Verbose Mode to capture additional data.
m Retrieve web console log.
m  Workspace ONE UEM analyzes the log and works with customer to resolve the problem.
m If the certificate is not populated in the View XML option of the profile.

m  Confirm that lookup values configured on the SecureAuth certificate profile match the
look up values in the Workspace ONE UEM console’s Request Template.

= Confirm that lookup values in Workspace ONE UEM Request Template are actually
populated in the user information being pulled from AD.

m  Confirm you are pointing to the right profile in SecureAuth.
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Workspace ONE UEM is flexible with PKI integration by being able to request certificates from
either internal or external certificate authorities (CA). Integrate with GlobalSign PKI services to
issue certificates for your Workspace ONE UEM MDM solution.

In order for Workspace ONE UEM to communicate with GlobalSign for certificate distribution,
you must have a GlobalSign instance configured and ready to issue certificates. You can then
configure Workspace ONE UEM to communicate with GlobalSign using basic authentication.

Once communication is successfully established, you can define how to deploy certificates to
devices. Below is an example of how GlobalSign and Workspace ONE UEM can be deployed.

1 The device enrolls with Workspace ONE UEM.

2 Workspace ONE UEM requests a certificate from the GlobalSign endpoint.

3 The GlobalSign endpoint delivers the certificate to Workspace ONE UEM.
4  Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or Wi-Fi
profile.
Frmmmemem-em-;e--;;e--;;e---eees-meee-mmmmm e mmmm e —m e ————————
Device Workspace ONE UEM SaaS GlobalSign SaaS

' ammn
[ ]
—r \d N\t

Prerequisites
m A GlobalSign instance that is configured for certificate deployment.

m Workspace ONE UEM console version 9.5 or later.
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m A service account with authentication permissions.

Procedure

1 Generate the GlobalSign certificate.

2 Configure the GlobalSign certificate authority in Workspace ONE UEM console.

a

b

Navigate to Devices > Certificates > Certificate Authorities.
Click Add.
Select GlobalSign from the Authority Type drop-down menu.

Enter a unique name and description that identifies the GlobalSign certificate authority in
the Certificate Authority and Description fields.

In the Server URL field enter the URL of your GlobalSign instance.

This is the web endpoint that Workspace ONE UEM will use to submit requests and issue
certificates.

Enter the Username and Password fields belonging to the service account with
authentication permissions mentioned in System Requirements above.

Click Save.

Click Test Connection when complete to verify the test is successful. An error message
appears indicating the problem if the connection fails.

Click Save.
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3 Set up the request template for GlobalSign in Workspace ONE UEM console.

C

Navigate to Devices > Certificates > Certificate Authorities.

Select the Request Templates tab and select Add to complete the menu items.

Option

Certificate Authority
Profile ID

Product Code
Validity Period

SAN Type

Automatic Certificate Renewal

Enable Certificate Revocation

Select Save.

Description

GlobalSign

Enter the GlobalSign profile identity bound to the certificate.
Enter the code for the certificate and the license.

Enter how long the certificate is valid.

Select Add to include one or more Subject Alternate Names with the
template.

This entry is used for additional unique certificate identification. In most
cases, this needs to match the certificate template on the server. Use the
drop-down menu to select the SAN Type and enter the subject alternate
name in the corresponding data entry field.

Each field supports lookup values. Email Address, User Principal Name,
and DNS Name are supported by GlobalSign templates by default.

Select the checkbox if Workspace ONE UEM is going to automatically
request the certificate to be renewed by GlobalSign when it expires.

If you select this option, enter the number of days prior to expiration
before Workspace ONE UEM automatically requests GlobalSign to
reissue the certificate in the Auto Renewal Period (days) field. This
requires the certificate profile on GlobalSign to have the Duplicated
Certificates setting enabled.

Select the checkbox if you want Workspace ONE UEM to be able to
revoke certificates.

4 Configure a Workspace ONE UEM Credentials profile (payloads) to deploy to devices.

This profile connects the GlobalSign certificate authority configured in the console to devices
with this Credentials profile (payload).

a

b

Navigate to Devices > Profiles > List View.

Click Add.

Select the applicable platform for the device type.

Specify General profile parameters.

Select Credentials from the payload options and select Configure.

Select Defined Certificate Authority from the Credential Source drop-down menu.
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g Select the external GlobalSign CA you created from the Certificate Authority drop-down
menu.

h Select the request template for GlobalSign you createdfrom the Certificate Template
drop-down menu.

Saving and publishing the profile would deploy a certificate to the device. However, if
you plan on using the certificate on the device for Wi-Fi, VPN, or email purposes, then
you should also configure the respective payload in the same profile to leverage the
certificate being deployed.

What to do next

Review some tips and troubleshooting steps for the integration.

Verify ability to perform certificate authentication without Workspace ONE UEM.

Remove Workspace ONE UEM from the configuration and manually configure a device to
connect to your network server using certificate authentication. This should work outside of
Workspace ONE UEM and until this works properly, Workspace ONE UEM will not be able to
configure a device to connect with a certificate.

Verify ability to perform certificate authentication with Workspace ONE UEM.

You can confirm that the certificate is usable by pushing a profile to the device and testing
whether or not the device is able to connect and sync to the configured EAS, VPN, or Wi-Fi
access-point. If the device is not connecting and shows a message that the certificate cannot
be authenticated or the account cannot connect then there is a problem in the configuration.
Below are some helpful troubleshooting checks.

If SSL TLS errors are received while creating a template.
m  This error can occur when you attempt two tasks.

m  Create a Workspace ONE UEM certificate template byselecting the Retrieve Profiles
button or

m  Retrieve a certificate from the Workspace ONE UEM console from the SecureAuth
certificate authority.

m  The troubleshooting technique that usually resolves this problem is adding the required
server certificate chain in the console servers trusted root key store.

If the Workspace ONE UEM Certificate Profile fails to install on the device.

m  Inform Workspace ONE UEM Professional Services of the error and request they:
m  Turn On Verbose Mode to capture additional data.
m Retrieve web console log.

m Workspace ONE UEM analyzes the log and works with customer to resolve the problem.
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m If the certificate is not populated in the View XML option of the profile.

= Confirm that lookup values configured on the GlobalSign certificate profile match the look
up values in the Workspace ONE UEM console’s Request Template.

= Confirm that lookup values in Workspace ONE UEM Request Template are actually
populated in the user information being pulled from AD.

m  Confirm you are pointing to the right profile in GlobalSign.
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JCCH Gléas

Workspace ONE UEM can request certificates from either internal or external certificate
authorities (CA). Integrate with JCCH Gléas services to issue certificates for your Workspace
ONE UEM EMM solution.

In order for Workspace ONE UEM to communicate with JCCH for certificate distribution,

you must have a JCCH instance configured and ready to issue certificates. You can then
configure Workspace ONE UEM to communicate with JCCH using basic authentication. Once
communication is successfully established, you can define how to deploy certificates to devices.
Below are some of the examples of how JCCH and Workspace ONE UEM can be deployed.

m Workspace ONE UEM SaaS and JCCH Gléas is insalled on-premises.

Device Internal Network

K X
1 1
1 1
1 1

1
: : JCCH Gléas
I . —
- | —o
: ! —o
I 9 I
I 9 I

AirWatch Cloud

D‘_‘_’ ( ° ) a_ Connector (Optional)

a The device enrolls with Workspace ONE UEM.

b Workspace ONE UEM requests a certificate from the JCCH Gléas endpoint (optionally
through the AirWatch Cloud Connector).

¢ The JCCH Gléas endpoint delivers the certificate to Workspace ONE UEM (optionally
through the AirWatch Cloud Connector).
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d Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or
Wi-Fi profile.

Note If your JCCH Gléas endpoint is public-facing, then you must protect it with a public
SSL certificate. If you use the AirWatch Cloud Connector, then configure it to trust the root
certificate installed on your JCCH Gléas appliance.

m  Workspace ONE UEM and JCCH Gléas are both insalled on-premises.

Internal Network

1

1

1

1

]

1 JCCH Gléas
1

) —)
! Workspace ONE UEM Saa$ c—
. —/)
1

1

' 9

1

AirWatch Cloud

D{—‘—) ( 3| e_ Connector (Optional)

alll

a The device enrolls with Workspace ONE UEM.

b Workspace ONE UEM requests a certificate from the JCCH Gléas endpoint (optionally
through the Airwatch Cloud Connector).

c The JCCH Gléas endpoint delivers the certificate to Workspace ONE UEM (optionally
through the Airwatch Cloud Connector).

d Workspace ONE UEM delivers the certificate to the device as part of an EAS, VPN, or
Wi-Fi profile.

Note If your JCCH Gléas endpoint is public-facing, then you must protect it with a public
SSL certificate. If you use the AirWatch Cloud Connector, then configure it to trust the root
certificate installed on your JCCH Gléas appliance.

Prerequisites

m A JCCH instance that is configured for certificate deployment.

m Workspace ONE UEM console version 9.5 or later.

m If your JCCH appliance is public-facing, it must be protected with a Public SSL Certificate. If
you are using VMware AirWatch Cloud Connector (ACC) for enterprise integration, then ACC
needs to be configured to trust the root certificate installed on your JCCH appliance.

Procedure

1 Generate a JCCH Gléas certificate.
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2 Configure JCCH Gléas as a certificate authority in Workspace ONE UEM console.

a

b

Navigate to Devices > Certificates > Certificate Authorities.
Click Add.
Select JCCH Gléas from the Authority Type drop-down menu.

Enter a unique name and description that identifies the JCCH certificate authority in the
Certificate Authority and Description fields.

In the Server URL field enter the URL of your JCCH instance.

This is the web endpoint that Workspace ONE UEM will use to submit requests and issue
certificates.

Select the Upload button in the Client Certificate field and upload the new certificate
from the location on your PC to which it has been saved.

Click Save.

Click Test Connection when complete to verify the test is successful. An error message
appears indicating the problem if the connection fails.

3 Define which certificate deploys to devices by setting up a request template in the
Workspace ONE UEM console.

a

b

C

Navigate to Devices > Certificates > Certificate Authorities.

Select the Request Templates tab, select Add, and complete the menu items.

Option Description
Certificate Authority JCCH
Profile ID Enter the identification that corresponds to the profile identity bound to

the certificate.

Product Code Enter the code bound to the certificate.
Validity Period Enter the time period the certificate is valid.
Automatic Certificate Renewal Select this checkbox if Workspace ONE UEM is going to automatically

request the certificate to be renewed by JCCH when it expires.

If you select this option, enter the number of days prior to expiration
before Workspace ONE UEM automatically requests JCCH to reissue the
certificate in the Auto Renewal Period (days) field. This requires the
certificate profile on JCCH to have the Duplicated Certificates setting
enabled.

Enable Certificate Revocation Select this checkbox if you want Workspace ONE UEM to be able to
revoke certificates.

Click Save.
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4 Configure Workspace ONE UEM profiles (payloads). Once Crendential profile is created,
you can create additional payloads that the JCCH certificate can use, such as Exchange
ActiveSync (EAS), VPN, or Wi-Fi services.

a Navigate to Devices > Profiles > List View.

b Click Add.

c Select the applicable platform for the device type.

d Specify General profile parameters.

e Select Credentials from the payload options.

f  Click Configure.

g Select Defined Certificate Authority from the Credential Source drop-down menu.

h Select the external JCCH CA you created from the Certificate Authority drop-down
menu.

i Select the request template for JCCH you created from the Certificate Template drop-
down menu.

Saving and publishing the profile would deploy a certificate to the device. However, if
you plan on using the certificate on the device for Wi-Fi, VPN, or email purposes, then
you should also configure the respective payload in the same profile to leverage the
certificate being deployed.

5 (Optional) If you are using AirWatch Cloud Connector and the JCCH appliance is not public-
facing, then you need to ensure the AirWatch Cloud Connector configuration trusts the
appliance.

a Open the JCCH console certificate and view the Certificate Path tab.

1 If multiple certificates are listed, they will need to be separated and added to the
appropriate stores.

2 The remaining steps address adding the root certificate to the Trust Root Store.
b Open MMC by searching for it using Windows Search and launching the mmc.exe file.
¢ Navigate to File > Add/Remove Snap-in. The Add or Remove Snap-ins screen displays.
d Select the Certificates snap-in in the left pane and select Add.
e Select Computer account as Snap-in source. Select Next.
f  Select Local computer and then select Finish.
g Select OK.
h Expand the newly added Certificates tree.
i Expand the Trusted Root Certification Authorities folder.

j  Right-click the Certificates folder here and select All Tasks > Import.
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k Proceed through the Certificate Import Wizard. You will be prompted to Browse and
select the file of the root certificate used to generate the EJBCA Console certificate.
Select Next.

|  Select Place all certs in the following store and then select Next.
m Click Finish.

n Select all other intermediate and child certificates to add them to their associated stores
within the Certificates tree.

What to do next
Review some tips and troubleshooting steps for the integration.
m  Verify ability to perform certificate authentication without Workspace ONE UEM.

Remove Workspace ONE UEM from the configuration and manually configure a device to
connect to your network server using certificate authentication. This should work outside of
Workspace ONE UEM and until this works properly, Workspace ONE UEM will not be able to
configure a device to connect with a certificate.

m  Verify ability to perform certificate authentication with Workspace ONE UEM.

You can confirm that the certificate is usable by pushing a profile to the device and testing
whether or not the device is able to connect and sync to the configured EAS, VPN, or Wi-Fi
access-point. If the device is not connecting and shows a message that the certificate cannot
be authenticated or the account cannot connect then there is a problem in the configuration.
Below are some helpful troubleshooting checks.

m |If SSL TLS errors are received while creating a template.
m  This error can occur when you attempt two tasks.

m Create a Workspace ONE UEM certificate template byselecting the Retrieve Profiles
button or

m  Retrieve a certificate from the Workspace ONE UEM console from the SecureAuth
certificate authority.

m  The troubleshooting technique that usually resolves this problem is adding the required
server certificate chain in the console servers trusted root key store.

m If the Workspace ONE UEM certificate profile fails to install on the device.
= Inform Workspace ONE UEM Professional Services of the error and request they:
m  Turn on Verbose Mode to capture additional data.
m  Retrieve web console log.

m  Workspace ONE UEM analyzes the log and works with customer to resolve the problem.
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m If the certificate is not populated in the View XML option of the profile.

m  Confirm that lookup values configured on the JCCH certificate profile match the look up
values in the Workspace ONE UEM console request emplate.

m  Confirm that lookup values in Workspace ONE UEM request template are actually
populated in the user information being pulled from AD.

m  Confirm you are pointing to the right profile in JCCH.

VMware, Inc.
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Entrust IdentityGuard

Workspace ONE UEM can request certificates from various certificate authorities, one is Entrust
IdentityGuard. To use Entrust IdentityGuardas as a certificate authority, ensure to use the
supported version of Workspace ONE UEM console, have access to an Entrust IndentityGuard
instance, and set up Entrust IdentityGuard for mobile enroliment.

You can use Entrust IdentityGuard as a third-party certificate authority for Workspace ONE UEM
in a SaaS environment. Communication flows between Workspace ONE UEM, Entrust, and mobile
devices.

Email Traffic
A
Workspace ONE UEM Traffic
A
‘ HTTPS(443)
Kerberos
— HTTPS(443) I I I Delegation
—> |
— Q 0% = =p==
— HTTPS(443) LL_—LJ  wWorkspace ONE UEM Mail Services
Workspace ONE Internet Firewall Reserve Proxy/
UEM SaaS Secure Email
HTTPS(443) Gateway
Entrust

Prerequisites

m Open port 19443 from the Workspace ONE UEM console to your Entrust server.

Note SaaS deployments can contact VMware Support Services to check that 19443 is open.

m If you use the AirWatch Cloud Connector, go to the advanced settings, and disable the
Entrust PKI.

m  Use supported Entrust API versions V8 and V9.

m  Use Workspace ONE UEM console version 9.5 or later.
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= VMware AirWatch Cloud Connector is required if the Entrust IdentityGuard instance is
installed behind a firewall.

= An Entrust IdentityGuard instance needs to be available.

m  Configure Entrust IdentityGuard for mobile enroliment.

Procedure

1 Set up Entrust IdentityGuard for mobile enroliment with Workspace ONE UEM. This task
creates an Entrust Managed certificate authority (CA) and issues the instance of Entrust with
a digital ID.

Perform this task with help from your Entrust IdentityGuard representative. If you are using
Entrust Managed Services PKI, your representative gives you several values you need for
configuring Entrust as a CA in Workspace ONE UEM console.

m  URL to enter as the Server URL of the CA.
m  Credentials for the Server URL.

m A digital ID configuration to enter while completing the certificate template.

a Configure an Entrust Managed CA in Entrust IdentityGuard.

Adding a Managed CA allows Entrust IdentityGuard to communicate with your Security
Manager CA.

b Configure a Digital ID Configuration in Entrust IdentityGuard.

A Digital ID Configuration is a template that Entrust IdentityGuard uses to issue digital IDs.
c Configure the Entrust IdentityGuard digital ID policies.
d Mirror the password rules set in Security Manager and Entrust IdentityGuard.

If the password rules do not match, errors can occur when issuing digital IDs.

e Add an Entrust IdentityGuard administrator that your Workspace ONE UEM MDM uses to
issue digital IDs.

2 Configure Entrust IdentityGuard as a certificate authority (CA) in the Workspace ONE UEM
console.

Configuration sets communication between the systems using values from your Entrust
IdentityGuard managed certificate authority.

a Navigate to Devices > Certificates > Certificate Authorities and in the System Settings
page that displays, select the Certificate Authorities tab.

b Select the Add button.
The Certificate Authority - Add / Edit page displays.
c Enter in the Name field a unigue name that identifies the Entrust certificate authority.

d Select the Authority Type drop-down and select Entrust.
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For Protocol, select either the PKI or SCEP radio button.

Enter in the Server URL field the URL of the Administration Services MDM Web Service or
the Entrust IdentityGuard Administration Service.

If you are using Entrust Managed Services PKI, your Entrust IdenityGuard representative
gave you this URL when you configured Entrust for mobile enrollment. should have been
provided to you by an Entrust representative.

An example of the URL is https://mobile.example.com:19443/mdmws/services/
AdminServiceVs8.

In the Username and Password settings, enter the user name of the Administration
Services or Entrust IdentityGuard administrator you created while configuring Entrust.

If you are using Entrust Managed Services PKI, this username and corresponding
password should have been provided to you by an Entrust representative.

When complete, select the Test Connection button and verify that the test is successful.

If the connection failed, an error displays. This error could be the result of a certificate not
being installed on the Workspace ONE UEM server or the URL not being correct. In the
example error, the Server URL was not correct.

Conmection Failed: There was no endpoint listening an hps: ptor-pki-ws, bbtest net policySemnvice that could accopt the message, This is often caused

by an incoiiect addigss of SOAP action. See InneiException, il present, foi moie details.

Select Save.

3 Define which certificate Workspace ONE UEM console deploys to devices by setting up a
certificate template for Entrust IdentityGuard.

a

On the Certificate Authorities system settings page (Groups & Settings > Configurations
> Certificate Authorities), select the Request Templates tab.

Select the Add button to add a new Certificate Template.
The Certificate Template Add/Edit window displays.

Select on the Certificate Authority drop-down and select the Entrust CA you configured
earlier.

Enter in the Name and Description fields the name you want to give the Entrust
certificate template.

For Managed CA, select the name of the Entrust CA.

Click on the Profile Name drop-down and select the name of the Digital ID Configuration
that you created while configuring Entrust.

If you are using Entrust Managed Services PKI, this Digital ID Configuration should have
been provided to you by an Entrust representative.
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g Configure Subject Alternative Name (SAN) attributes as required.

These are used for additional unique identification of the device and need to match the
Digital ID configuration.

h If Workspace ONE UEM automatically requests the certificate to be reviewed by
Entrust when it expires, check the Automatic Certificate Renewal check box and make
sure the assignment type is set to Auto. Set the number of days prior to expiration
beforeWorkspace ONE UEM auotmatically requests Entrust to reissue the certificate in
Auto Renewal Period (days) field.

i If certificates must be revoked, either manually or when they are removed from the
device, select Enable Certificate Revocation.

j  Complete the Mandatory Fields that are used to form the common name of the
distinguished name within the certificate.

These fields can change depending on which Entrust profile you choose since the
information within the profile may be different.

The fields you see on the left side correspond to the data source fields you declared on
the Entrust side. The values on the right are the Workspace ONE UEM variables. Enter
Lookup Values in each of the fields that complement those fields in the Entrust profile.
Make sure the lookup values you use match those used in the Digital ID configuration.

If you are using Entrust Managed Services PKI, this information should have been
provided to you by an Entrust representative.

k Click Save.

What to do next

To fix a (40) error that occurrs in your integration of Entrust IdentityGuard and Workspace ONE
UEM, delete old profiles and update the values for two parameters.

If you see the error (40) Error
AirWatch.CloudConnector.CertificateService.CertificateService.TestConnection,

take the following steps to fix the error.
m  Clean up stale profiles.
m Increase the size of MaxRecievedMessageSize t0 2147483647.

m  Increase the size of MaxBufferSize t0 2147483647.
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