What's in the Release Notes

VMware Workspace ONE Intelligent Hub for macOS Release Notes describe the new features and enhancements in each release. This page contains a summary of the new capabilities, issues that have been resolved, and known issues that have been reported in each version.

Workspace ONE Intelligent Hub 24.01.1 - April 2024

New Features

This release of macOS Intelligent Hub is primarily focused on bug fixes and performance improvements.

Minimum Requirements

Following are the minimum requirements:

  • macOS version 10.16 or later is required to install Intelligent Hub version 24.01.1.

    • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

    • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

    • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Note: As of 23.10 macOS 10.15 is no longer supported. See KB here.  

  • Hub Services require Workspace ONE UEM 1904+.

  • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

  • hubCLI profiles require Workspace ONE UEM 1910+.

  • hubCLI sensors require Workspace ONE UEM 2010+.

  • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

  • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

  • Intelligent Hub 24.01.1 is backward compatible with existing features on older servers.

  • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • macOS Intelligent Hub 24.01.1 will be seeded in Workspace ONE UEM version 2310. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2310, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

  • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: 24.01.1 will be seeded in UEM 2310, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-7704: App installation failure due to corrupt package.

  • HUBM-8080: Applications installed by macOS Hub are getting removed from the device.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 24.01 - January 2024

New Features

  • Third Party Integrations: Upgrade Firebase, Alamofire, MSAL, EULA

  • EULA updates - A new version of the VMware General Terms has been added.

  • The following Hub Health attributes are added:

    • Time of last Hub-targeted WS1 command

    • Is Hub on latest seeded version?

    • Version of Workflow Engine installed

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.16 or later is required to install Intelligent Hub version 24.01.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

      • Note: As of 23.10 macOS 10.15 is no longer supported. See KB here.  

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 24.01 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • Download Instructions

    • macOS Intelligent Hub 24.01 will be seeded in Workspace ONE UEM version 2310. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2310, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v24.01 will be seeded in UEM 2310, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-7764: Multiple location permission prompts from macOS Hub on Sonoma.

  • HUBM-7566 : Weblink Icons are not getting modified on App Catalog.

  • HUBM-7414: Application gets upgraded to the latest version but console still shows the previous version installed.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.10 - December 2023

New Features

This release of the macOS Intelligent Hub includes the following new features:

  • We've made updates to Hub Health feature. This helps in providing visibility into the overall health and status of each managed device.

  • Improvement to Logs

    • We have removed unnecessary log entries that are huge and and very long sequence.

  • We've dropped the support for macOS 10.15 in Intelligent Hub.

  • Third-party integrations

    • We've upgraded the versions of Sparkle and JWTDecode.

  • We've upgraded Python to version 3.11.6 along with openssl and sqlite.

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 11.0 Big Sur is required to install Intelligent Hub version 23.10.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

      • Note: As of 23.10 macOS 10.15 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed.

    • Intelligent Hub 23.10 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • macOS Intelligent Hub 23.10 will be seeded in Workspace ONE UEM version 2310. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2310, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v23.10 will be seeded in UEM 2310, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-7356: Internal application not being removed when removing tag on Mac if device offline.

  • HUBM-7523: Hub not sending profile response to WorkflowEngine.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.09 - October 2023

New Features

This release of the macOS Intelligent Hub includes the following new features:

  • We have enabled Hub Health remediation

HubHealth now checks for the health of the Hub at regular intervals. If the hubd is in the deadlock state, as a healing process it relaunches the hubd process to resolve the deadlock state and the Hub moves to the normal state.

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 23.09.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 23.09 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • macOS Intelligent Hub 23.09 will be seeded in Workspace ONE UEM version 2310. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2310, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note:

    v23.09 will be seeded in UEM 2310, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-7412: Dispatch thread soft limit is reached for hubd when multiple native profiles activation is triggered.

  • HUBM-7296: Workflow engine not completing download leading to workflow issues CN447.

  • HUBM-7308: macOS Custom Attribute profiles failing to install or being removed.

  • HUBM-7139: Sensors on macOS are not assigned to all computers that are in the assignment groups.

  • HUBM-6809: macOS Hub app being removed from Applications.

  • HUBM-7259: It takes 1 min to show group ip input box after customer provide ds wso.qilinit.com in macOS hub app.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.07.1 - September 2023

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes.

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 23.07.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 23.07 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • macOS Intelligent Hub 23.07.1 will be seeded in Workspace ONE UEM version 2305. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2305, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note:

    v23.07.1 will be seeded in UEM 2305, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-6976: Hub loops privacy and data collection screens on macOS 14 Sonoma.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.07 - August 2023

New Features

This release of macOS Intelligent Hub includes the following new features:

  • We have introduced Hub Health monitoring that provides a detailed report of device health making it easier for the administrators to manage devices, troubleshoot and fix problems faster.

  • You can now reset the Hub App without rebooting the system.

    • Recover from the deadlock state.

    • Self healing of Hub app is done periodically when secure channel communication is broken .

  • We have upgraded the KeychainAccess to 4.2.2 or above.

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 23.07.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. The 21.04 macOS Intelligent Hub release automates Workflow Engine deployment and management, eliminating manual steps by detecting, downloading, and installing the latest version from UEM Console.

    • Intelligent Hub 23.07 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • macOS Intelligent Hub 23.07 will be seeded in Workspace ONE UEM version 2305. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2305, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v23.07 will be seeded in UEM 2305, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-7232: HUB sensors misreported Error - No Error

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.06 - July 2023

New Features

This release of macOS Intelligent Hub includes the following new features:

  • We have enabled Google Conditional Access for macOS Hub

  • Hub Health Monitor added to binary

  • macOS Hub now supports redirect URI for Microsoft SSO Extension profile

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 23.06.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 23.06 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • macOS Intelligent Hub 23.06 will be seeded in Workspace ONE UEM version 2305. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2305, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v23.04 will be seeded in UEM 2305, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-6956 : Handle missing scheme for Fileserver during product execution

  • HUBM-6973: Customer flow testing

  • HUBM-6862: [Workflow] macOS Workflow with application installation step gets stuck at InProgress

  • HUBM-6993: Error while fetching compliance

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.04.1 - May 2023

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes.

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.14 or later is required to install Intelligent Hub version 23.04.1.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 23.04.1 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ . For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • How to Download Workspace ONE Hub 23.04.1 for macOS

    • macOS Intelligent Hub 23.04.1 will be seeded in Workspace ONE UEM version 2305. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2305, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v23.04 will be seeded in UEM 2305, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-6841: macOS Intelligent Hub Version 23.04 generating HMAC Errors in the Device troubleshooting Logs and "Device Registration Error" notifications are observed on device

    For more information, refer to the KB article here.

Known Issues

  • We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.04 - April 2023

New Features

This release of macOS Intelligent Hub includes the following new features:

  • Native For You tab on macOS initial enablement

  • Third party integrations: Update Alamofire and Firebase

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 23.04.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed.

    • Intelligent Hub 23.04 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

How to Download Workspace ONE Hub 23.04 for macOS

  • macOS Intelligent Hub 23.04 will be seeded in Workspace ONE UEM version 2305. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2305, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2305,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v23.04 will be seeded in UEM 2305, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-6729: [Firebase][Crash] Close is clicked on the AWrecoveryKeyVC prompt

  • HUBM-6677: Application displayed in catalog when "DisplayInCatalog" is disabled

  • HUBM-6582: macOS Sensor with User Switch trigger is not getting executed on device

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 23.03 - March 2023

New Features

This release of macOS Intelligent Hub includes the following new features:

  • Support for Native People tab on macOS

  • Support for headless mac mini or unattended user effort

  • Third-party updates for Munki and Alamofire

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 23.03.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 23.03 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

Download Instructions

  • How to Download Workspace ONE Hub 23.03 for macOS

    • macOS Intelligent Hub 23.03 will be seeded in Workspace ONE UEM version 2304. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2304, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2304,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v23.03 will be seeded in UEM 2304, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-5439: Hub Auto Update not working for headless Macs

Known Issues

  • HUBM-6526: End-of-Support for Mobile Flows

Workspace ONE Intelligent Hub 23.01 - January 2023

New Features

This release of macOS Intelligent Hub includes the following new features:

  • DSM sync schedule

A new key MacOsDsmSyncInterval is available in the agent settings to customize the sync interval. When the value is changed in the UEM database, it will get updated to all the devices and they start following the new sync schedule. 

  • User Bookmarks Support

Bookmarks or web links will be displayed in the Favorites tab. They are editable, sortable, and persistent. 

  • Dark Mode Support has been added to Hub

End user can easily toggle from light to dark mode which now supports custom branding.

  • macOS On-Demand Workflow support has been added to show the completion status of on-demand workflows.

Requires 2302+ Workflow Engine - See minimum requirements below. 

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 23.01.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • Scripts and Freestyle Orchestrator require Workflow Engine 20.10+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 23.01 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

Download Instructions

  • How to Download Workspace ONE Hub 23.01 for macOS

    • macOS Intelligent Hub 23.01 will be seeded in Workspace ONE UEM version 2302. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2302, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2302,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v23.01 will be seeded in UEM 2302, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-6335: Console UI misreporting app install status on Device details view Apps Dashboard.

  • HUBM-6326 : UEM Managed Application Counts Are Inaccurate.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 22.12 - December 2022

New Features

This release of macOS Intelligent Hub includes the following new features:

  • hubCLI support for managed software updates via MDM commands

  • 3rd party package updates - Python, MSAL, Firebase, SwiftProtobuf etc.

Minimum Requirements

  • Following are the minimum requirements:

    • macOS version 10.15 or later is required to install Intelligent Hub version 22.12.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Hub Services require Workspace ONE UEM 1904+.

    • Seeded Notifications and System Extension payload for App & Process restrictions requires Workspace ONE UEM 2105+.

    • hubCLI profiles require Workspace ONE UEM 1910+.

    • hubCLI sensors require Workspace ONE UEM 2010+.

    • hubCLI support for managed software updates via MDM commands requires Workspace ONE UEM 2210+.

    • Scripts and Freestyle Orchestrator require Workflow Engine 20.10+ to be installed. This is available in the Resource Portal.

    • Intelligent Hub 22.12 is backward compatible with existing features on older servers.

    • Privacy Preferences payloads require Workspace ONE UEM 1907+ for macOS version 10.14+ For more information on Privacy Preferences, see My Workspace ONE.

    • On-Demand Workflow Completion, Scripts, and Freestyle Orchestrator require Workflow Engine 2302.1+ to be installed. This is available in the Resource Portal.

Download Instructions

  • How to Download Workspace ONE Hub 22.12 for macOS

    • macOS Intelligent Hub 22.12 will be seeded in Workspace ONE UEM version 2212. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2207, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2209,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v22.12 will be seeded in UEM 2212, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-6200: Accept/Decline button missing for Terms of use for MacOS applications

  • HUBM-6155: HUB Support Tab - Installed profiles misreported failed with error.

  • HUBM-6181: "Apps and Process Restrictions for macOS" are not enforced right after reboot for a peroid of time

  • HUBM-6128: Favorites not displaying on macOS Ventura Dock

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 22.10 - October 2022

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes.

Minimum Requirements

  • macOS version 10.15 or later is required to install Intelligent Hub version 22.10.

    • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

    • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

    • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

  • Workspace ONE UEM 1904 or later for the support of Hub Services features.

  • Workspace ONE UEM 1907 or later for macOS version 10.14 or later Privacy Preferences (or use the appropriate Privacy Preferences payload). For more information on Privacy Preferences, see My Workspace ONE.

  • Workspace ONE UEM 2105 or later for seeded Notifications and System Extension payload for App & Process restrictions introduced in 21.04

  • Workspace ONE UEM 1910 or later for the support of hubcli profiles feature introduced in 19.10.

  • Workspace ONE UEM 2010 or higher for support for hubcli sensors feature introduced in 20.10.

  • Workflow Engine 20.10+ for macOS must also be installed to support Scripts and Freestyle Orchestrator. Available in the Resource Portal.

  • Intelligent Hub 22.10 is backward compatible with existing features on older servers.

Download Instructions

  • How to Download Workspace ONE Hub 22.10 for macOS

    • macOS Intelligent Hub 22.10 will be seeded in Workspace ONE UEM version 2210. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2207, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2209,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v22.10 will be seeded in UEM 2210, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-6000: Passcode Change pop-up screen on macOS device never appears again once the user selects ignore, even though if the user is not setting any password.

  •  HUBM-6014: Translation strings of all buttons in the enrollment workflow is not loaded.

  • HUBM-6061: Console UI misreporting app install status on Device details view Apps Dashboard.

Known Issues

  • HUBM-4781:Workspace ONE Access support for Token Authentication on macOS Hub.

  • HUBM-6007: Upgrade Python package to 3.10.7

Workspace ONE Intelligent Hub 22.08.1 - September 2022

New Features

This release of macOS Intelligent Hub includes the following new features:

  • End User License Agreement has been upgraded to new VMware General Terms.

Minimum Requirements

  • Following are minimum requirements:

    • macOS version 10.15.1 or later is required to install Intelligent Hub version 22.08.1.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09, macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08, macOS 10.14 is no longer supported. See KB here.

    • Workspace ONE UEM 1904 or later for the support of Hub Services features.

    • Workspace ONE UEM 1907 or later for macOS version 10.14 or later Privacy Preferences (or use the appropriate Privacy Preferences payload). For more information on Privacy Preferences, see My Workspace ONE.

    • Workspace ONE UEM 2105 or later for seeded Notifications and System Extension payload for App & Process restrictions introduced in 21.04

    • Workspace ONE UEM 1910 or later for the support of hubcli profiles feature introduced in 19.10.

    • Workspace ONE UEM 2010 or higher for support for hubcli sensors feature introduced in 20.10.

    • Workflow Engine 20.10+ for macOS must also be installed to support Scripts and Freestyle Orchestrator. Available in the Resource Portal.

    • Intelligent Hub 22.08.1 is backward compatible for existing features on older servers.

Download Instructions

  • How to Download Workspace ONE Hub 22.08.1 for macOS

    • macOS Intelligent Hub 22.08 will be seeded in Workspace ONE UEM version 2209. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2207, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2209, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v22.08 will be seeded in UEM 2209, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-5849: Freestyle Orchestrator Sensor does not trigger Application Upgrade/Install.

  • HUBM-5861: macOS 13 Ventura (beta5)- Weblink-apps are damaged.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 22.08 - August 2022

New Features

This release of macOS Intelligent Hub includes the following new features:

  • New option added to uninstall managed applications from App Catalog (supported from UEM Console 21.11 and Hub Services 22.07)

  • As of 22.08 for macOS 10.14 is no longer supported

  • General enhancements:

    • Optimization of App list sample

    • Improvements have been made to HUB sensors error reporting

    • Munki upgraded to 5.7.2, MSAL to 1.2.2, and Python to 3.10.6

    • Product download from Relay Server improvements

    • Native App Catalog UI Improvements

Minimum Requirements

  • Following are the minimum requirements:

    Minimum Requirements

    • macOS version 10.15.1 or later is required to install Intelligent Hub version 22.08.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here.

      • Note: As of 21.09 macOS 10.13 is no longer supported. See KB here.

      • Note: As of 22.08 macOS 10.14 is no longer supported. See KB here.

    • Workspace ONE UEM 1904 or later for the support of Hub Services features.

    • Workspace ONE UEM 1907 or later for macOS version 10.14 or later Privacy Preferences (or use the appropriate Privacy Preferences payload). For more information on Privacy Preferences, see My Workspace ONE.

    • Workspace ONE UEM 2105 or later for seeded Notifications and System Extension payload for App & Process restrictions introduced in 21.04

    • Workspace ONE UEM 1910 or later for the support of hubcli profiles feature introduced in 19.10.

    • Workspace ONE UEM 2010 or higher for support for hubcli sensors feature introduced in 20.10.

    • Workflow Engine 20.10+ for macOS must also be installed to support Scripts and Freestyle Orchestrator. Available in the Resource Portal.

    • Intelligent Hub 22.08 is backward compatible for existing features on older servers.

Download Instructions

  • How to Download Workspace ONE Hub 22.08 for macOS

    • macOS Intelligent Hub 22.08 will be seeded in Workspace ONE UEM version 2207. If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2207, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2207,then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

      Note: v22.08 will be seeded in UEM 2207, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Premise customers to update. 

Resolved Issues

  • HUBM-5746: HUB sensors misreported Error - No Error

  • HUBM-5710: Unable to download products from Relay Server

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 22.07 - July 2022

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes. The new feature for this release includes:

Workspace ONE Intelligent Hub now supports software updates in macOS Monterey for all devices by redirecting to the Software Update Preference pane.

Minimum Requirements

  • Following are the Minimum Requirements:

    • macOS version 10.14 or later is required to install Intelligent Hub version 22.07.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here

      • Note: As of 21.09, macOS 10.13 is no longer supported. See KB here

      • Note: With 22.08, macOS 10.14 is no longer supported.

    • Workspace ONE UEM 1904 or later for the support of Hub Services features.

    • Workspace ONE UEM 1907 or later for macOS version 10.14 or later Privacy Preferences (or use the appropriate Privacy Preferences payload). For more information on Privacy Preferences, see My Workspace ONE.

    • Workspace ONE UEM 2105 or later for seeded Notifications and System Extension payload for App & Process restrictions introduced in 21.04.

    • Workspace ONE UEM 1910 or higher for the support of hubcli profiles feature introduced in 19.10.

    • Workspace ONE UEM 2010 or higher for support for hubcli sensors feature introduced in 20.10.

    • Workflow Engine 20.10 and later for macOS must also be installed to support Scripts and Freestyle Orchestrator. The latest version is available in the Resource Portal

    • The Intelligent Hub 22.07 is backward compatible for existing features on older servers.

Download Instructions

  • How to Download Intelligent Hub 22.07  for macOS

    • macOS Intelligent Hub 22.07 will be seeded in Workspace ONE UEM version 2206.

    • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2206, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2206, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v22.07 will be seeded in UEM 2206, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Resolved Issues

  • HUBM-5501: Icon for apps does not immediately appear in macOS Hub

  • HUBM-5514: Fix Archive Related Deprecation Warnings in Hub UI and hubd.

Known Issues

We haven’t identified any notable known issues in this release. If you are facing any problems, feel free to reach out to our support team.

Workspace ONE Intelligent Hub 22.05.1 - June 2022

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes.

Minimum Requirements

  • Minimum Requirements for this release includes:

    • macOS Intelligent Hub 22.05.1 will be seeded in Workspace ONE UEM version 2204.5.

    • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2204.5, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2204.5, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v22.05.1 will be seeded in UEM 2204.5, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Download Instructions

  • How to Download Intelligent Hub 22.05.1 for macOS

    • macOS Intelligent Hub 22.05.1 will be seeded in Workspace ONE UEM version 2204.5.

    • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2204.5, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2204.5, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v22.05.1 will be seeded in UEM 2204.5, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Resolved Issues

  • HUBM-5601: 22.05 and 22.04 are not updating after seeding

Known Issues

  • HUBM-5175: macOS Monterey is not updating to the latest version after clicking on "Install now" triggered by s/w update profile

Workspace ONE Intelligent Hub 22.05- June 2022

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes. The new feature for this release includes:

Troubleshooting enhancements

Workspace ONE Hub now provides logged-in Username to the DEEM agent.

Minimum Requirements

  • Minimum Requirements for this release includes:

    • macOS Intelligent Hub 22.05 will be seeded in Workspace ONE UEM version 2205

    • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2205, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2205, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v22.05 will be seeded in UEM 2205, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Download Instructions

  • How to Download Intelligent Hub 22.05 for macOS

    • macOS Intelligent Hub 22.05 will be seeded in Workspace ONE UEM version 2205

    • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2205, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings.

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2205, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com.

    Note: v22.05 will be seeded in UEM 2205, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Resolved Issues

  • HUBM-5447: Intelligent Hub process seems to cause ManagedClient memory leak

  • HUBM-5354: When certain macOS sensors throw an error on a device, the sensor value gets reported with incorrect data

  • HUBM-5331: Some of the link is not parsed in onboarding window

  • HUBM-5332: Intelligent Hub in Dutch language is reporting Compliance as "Network Policy"

  • HUBM-5207: [Apps Tab] Category pills animation glitch on first load

Known Issues

  • HUBM-5175: macOS Monterey is not updating to the latest version after clicking on "Install now" triggered by s/w update profile

Workspace ONE Intelligent Hub 22.04- May 2022

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes. The new feature for this release includes:

Troubleshooting Enhancements

Workspace ONE Hub now provides logged-in Username to the DEEM agent.

Minimum Requirements

  • Minimum Requirements for this release includes:

Download Instructions

  • How to Download Intelligent Hub 22.04 for macOS

    • macOS Intelligent Hub 22.04 will be seeded in Workspace ONE UEM version 2204.

    • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2204, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings. 

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2204, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com

      • Note: v22.04 will be seeded in the UEM 2204, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Resolved Issues

  • HUBM-5354: When certain macOS sensors throw an error on a device, the sensor value gets reported with incorrect data

  • HUBM-5331: Some of the link is not parsed in onboarding window

  • HUBM-5332: Intelligent Hub in Dutch language is reporting Compliance as "Network Policy"

  • HUBM-5207: [Apps Tab] Category pills animation glitch on first load

Known Issues

  • HUBM-5175: macOS Monterey is not updating to the latest version after clicking on "Install now" triggered by s/w update profile

Workspace ONE Intelligent Hub 22.03- April 2022

New Features

This release of macOS Intelligent Hub is primarily focused on backend improvements and bug fixes. The new feature for this release includes:

Troubleshooting Enhancements 

On initiating log collection from Workspace ONE Intelligent Hub, DEEM logs will be collected and uploaded to UEM as a separate attachment.

Minimum Requirements

  • Minimum Requirements for this release includes:

    • macOS version 10.14 or later is required to install Intelligent Hub version 22.03.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here. As of 21.09, macOS 10.13 is no longer supported. See KB here

    • Workspace ONE UEM 1904 or later for the support of Hub Services features.

    • Workspace ONE UEM 1907 or later for macOS version 10.14 or later Privacy Preferences (or use the appropriate Privacy Preferences payload). For more information on Privacy Preferences, see My Workspace ONE.

    • Workspace ONE UEM 2105 or later for seeded Notifications and System Extension payload for App & Process restrictions introduced in 21.04.

    • Workspace ONE UEM 1910 or higher for the support of hubcli profiles feature introduced in 19.10.

    • Workspace ONE UEM 2010 or higher for support for hubcli sensors feature introduced in 20.10.

    • Workflow Engine 20.10 and later for macOS must also be installed to support Scripts and Freestyle Orchestrator. The latest version is available in the Resource Portal

    • The Intelligent Hub 22.03 is backward compatible for existing features on older servers.

Download Instructions

How to Download Intelligent Hub 22.03  for macOS

  • macOS Intelligent Hub 22.03 will be seeded in Workspace ONE UEM version 2203.

  • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2203, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

    • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings. 

  • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2203, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com

    • Note: v22.03 will be seeded in the UEM 2203, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Resolved Issues

  • HUBM-5296: Avatar image not showing up

  • HUBM-5291: Cannot Re-enroll Mac after Enterprise Wipe

  • HUBM-5164: Intelligent Hub Favorites on mac does not exit when adding an app as a favorite

  • HUBM-5258: Log Upload failing, when deem logs not present

  • HUBM-4841: Mac Hub Timeout Issue Migrating from Mosyle to WS1

  • HUBM-4953: Internal app not getting installed on Hub v21.07+

  • HUBM-5298: Freestyle Orchestrator conditions not working for mac workflow

Known Issues

  • HUBM-5175: macOS Monterey is not updating to the latest version after clicking on "Install now" triggered by s/w update profile

Workspace ONE Intelligent Hub 22.01- January 2022

New Features

This release of macOS Intelligent Hub is primarily focused on improvements and bug fixes. The new features for this release include:

Hub Services Improvements 

  • Intelligent Hub Services templates are now refreshed on application restart. 

  • Allows toggle of Hub Services within UEM console (UEM 20.08 and later).

Improvements to Workflow Step Status

With every change, now the workflow step status is updated on Workspace ONE UEM.

Support for DEEM Log Collection

Admins can now collect DEEM logs along with the Hub.

Minimum Requirements

  • Minimum Requirements for this release includes:

    • macOS version 10.14 or later is required to install Intelligent Hub version 22.01.

      • Note: As of 20.06, macOS 10.12 is no longer supported. See KB here. As of 21.09, macOS 10.13 is no longer supported. See KB here

    • Workspace ONE UEM 1904 or later for the support of Hub Services features.

    • Workspace ONE UEM 1907 or later for macOS version 10.14 or later Privacy Preferences (or use the appropriate Privacy Preferences payload). For more information on Privacy Preferences, see My Workspace ONE.

    • Workspace ONE UEM 2105 or later for seeded Notifications and System Extension payload for App & Process restrictions introduced in 21.04.

    • Workspace ONE UEM 1910 or higher for the support of hubcli profiles feature introduced in 19.10.

    • Workspace ONE UEM 2010 or higher for support for hubcli sensors feature introduced in 20.10.

    • Workflow Engine 20.10 and later for macOS must also be installed to support Scripts and Freestyle Orchestrator. The latest version is available in the Resource Portal

    • The Intelligent Hub 22.01 is backward compatible for existing features on older servers.

Download Instructions

  • How to Download Intelligent Hub 22.01 for macOS

    • macOS Intelligent Hub 22.01 will be seeded in Workspace ONE UEM version 2201.

    • If your device has a previous version of the Workspace ONE Intelligent Hub installed and enrolled to Workspace ONE UEM 2201, then the application seamlessly updates over the existing Intelligent Hub application version without disrupting the functionality.

      • Automatic Updates must be enabled (default) in the UEM Console at Settings > Devices & Users > Apple > Apple macOS > Intelligent Hub Settings. 

    • If your devices do not have a previous version of the Workspace ONE Intelligent Hub installed or enrolled to Workspace ONE UEM 2201, then direct end-users to download the Workspace ONE Intelligent Hub from GetWSONE.com

      • Note: v22.01 will be seeded in the UEM 2201, which will be rolled out to Shared and Latest Mode SaaS automatically and require Dedicated SaaS and On-Prem customers to update. 

Resolved Issues

  • HUBM-5072: Customer name not properly filled in Privacy

  • HUBM-4559: On Catalog Activity monitor, Chrome app icons not shown even if the apps is in installation completed bucket.

  • HUBM-5085: The "timeout" value from Script definition created in UEM, is not getting honored in Hub.

  • HUBM-4987: macOS Battery showing 0% when on ac power in console.

Known Issues

  • HUBM-4953: Internal app not getting installed on Hub v21.07+

  • HUBM-4841: Mac Hub Timeout Issue Migrating from Mosyle to WS1

Documentation

  • Find the FAQs about Workspace ONE Intelligent Hub App here.

  • Find the release notes for Digital Employee Experience Management (DEEM) here.

Support Contact Information

To receive support, either submit a ticket through the My Workspace ONE portal or call your local support line.

You can also check out the Knowledge Base (KB) Article How to access VMware Workspace ONE Support for a description of the multiple methods available for you to contact Workspace ONE Support to address issues regarding your product.

check-circle-line exclamation-circle-line close-line
Scroll to top icon