Use this information to troubleshoot some of the common errors that can occur with the Okta and Workspace ONE Access SCIM integration.

  • Error: “ERRORS REPORTED BY REMOTE SERVER: REQUIRED USER ATTRIBUTES:[DISTINGUISHEDNAME] ARE MISSING.”

    Solution: distinguishedName is set as a required attribute in Workspace ONE Access. Deselect the Required check box in the Workspace ONE Access Identity & Access Management > Setup > User Attributes page.

  • Error: “ERRORS REPORTED BY REMOTE SERVER: USER CREATION IS NOT SUPPORTED FOR SPECIFIED DIRECTORY ID.”

    Solution: You are attempting to create a user in a directory that is not of type Other. Verify that when you completed the prerequisites you did not use a domain that is used by another directory. It is possible that the domain was used for Just-in-Time (JIT) users. If so, you must create another directory of type Other with a unique domain.

  • Error: “ERRORS REPORTED BY REMOTE SERVER: USER DOMAIN NAME SPECIFIED FOR THE USER RESOURCE DOESN'T BELONG TO THE DIRECTORY.”

    Solution: The domain you configured in the attribute mapping in Okta does not match the domain for the directory created in Workspace ONE Access. Ensure that they match.

  • Error: AUTOMATIC PROVISIONING OF USER <USERNAME> TO APP VMWARE WORKSPACE ONE FAILED: MATCHING USER NOT FOUND.

    Solution: The Create Users and Deactivate Users settings are not enabled in the Provisioning tab of the VMware Workspace ONE app. Go to the Provisioning tab, click Edit, and select the Enable check box for Create Users and Deactivate Users.