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Using VMware Workstation Player for
Linux
Using VMware Workstation Player for Linux describes how to use VMware Workstation Player™ to
create, configure, and manage virtual machines on a Linux host.

Intended Audience
This information is intended for anyone who wants to install, upgrade, or use VMware Workstation Player
on a Linux host.
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Introduction and System
Requirements

1

Workstation Player is a desktop application that lets you create, configure, and run virtual machines. You
can also use Workstation Player to download and run virtual appliances.
Host computers that run Workstation Player must meet specific hardware and software requirements.
Virtual machines that run in Workstation Player support specific devices and provide certain features.
This chapter includes the following topics:
n

Host System Requirements for Workstation Player

n

Virtual Machine Features and Specifications

Host System Requirements for Workstation Player
The physical computer on which you install Workstation Player is called the host system and its operating
system is called the host operating system. To run Workstation Player, the host system and the host
operating system must meet specific hardware and software requirements.

Processor Requirements for Host Systems
You must install Workstation Player on a host system that meets certain processor requirements.

Supported Processors
The following host systems are supported.
n

n

Systems using processors launched in 2011 or later except for systems using the following
processors.
n

Intel Atom processors based on the 2011 Bonnell micro-architecture. For example, Atom Z670/
Z650 and Atom N570.

n

Intel Atom processors based on the 2012 Saltwell micro-architecture. For example, Atom Atom
S1200, Atom D2700/D2500, and Atom N2800/N2600.

n

AMD processors based on the Llano and Bobcat micro-architectures.

Systems using the following processors.
n

Intel processors based on the 2010 Westmere micro-architecture. For example, Xeon 5600, Xeon
3600, Core i7-970, Core i7-980, and Core i7-990.

VMware, Inc.
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Processor Requirements for 64-Bit Guest Operating Systems
For supported processors to run 64-bit guest operating systems, the host system must use one of the
following processors.
n

An AMD CPU with AMD-V support

n

An Intel CPU with VT-x support

If you have an Intel CPU that has VT-x support, you must verify that VT-x support is enabled in the host
system BIOS. The BIOS settings that must be enabled for VT-x support vary depending on the system
vendor. See the VMware knowledge base article at http://kb.vmware.com/kb/1003944 for information
about how to determine if VT-x support is enabled.
When you install a 64-bit operating system, Workstation Player performs checks to make sure the host
system has a supported processor. You cannot install a 64-bit operating system if the host system does
not meet the processor requirements.

Supported Host Operating Systems
You can install Workstation Player on Windows and Linux host operating systems.
To see a list of the supported host operating systems, search the online VMware Compatibility Guide on
the VMware Web site.
Workstation Player is not listed, but the information for Workstation Pro is applicable to Workstation
Player. Operating systems that are not listed are not supported for use in a virtual machine.

Memory Requirements for Host Systems
The host system must have enough memory to run the host operating system, the guest operating
systems that run inside the virtual machines on the host system, and the applications that run in the host
and guest operating systems.
The minimum memory required on the host system is 2 GB. 4 GB and above is recommended.
To support Windows 7 Aero graphics in a virtual machine, at least 3 GB of host system memory is
required. 1 GB of memory is allocated to the guest operating system and 256 MB is allocated to graphics
memory.
See your guest operating system and application documentation for more information on memory
requirements.

Display Requirements for Host Systems
The host system must have a 16-bit or 32-bit display adapter. Use the latest graphics driver
recommended for the host system.

VMware, Inc.
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To support Windows 7 Aero graphics, the host system should have either an NVIDIA GeForce 8800GT or
later or an ATI Radeon HD 2600 or later graphics processor.
Important 3D benchmarks, such as 3DMark '06, might not render correctly or at all when running
Windows Vista or Windows 7 virtual machines on some graphics hardware.

Disk Drive Requirements for Host Systems
Host systems must meet certain disk drive requirements. Guest operating systems can reside on physical
disk partitions or in virtual disk files.
Table 1-1. Disk Drive Requirements for Host Systems
Drive Type

Requirements

Hard disk

n

IDE, SATA, SCSI and NVMe hard drives are supported.

n

At least 1 GB free disk space is recommended for each guest operating system and
the application software used with it. If you use a default setup, the actual disk space
needs are approximately the same as those for installing and running the guest
operating system and applications on a physical computer.

n

For installation, approximately 200 MB free disk space is required on Linux and 250
MB free disk space is required on Windows. You can delete the installer after the
installation is complete to reclaim disk space.

n

IDE, SATA, and SCSI optical drives are supported.

n

CD-ROM and DVD drives are supported.

n

ISO disk image files are supported.

Optical CD-ROM and DVD

Floppy

Virtual machines can connect to disk drives on the host computer. Floppy disk image
files are also supported.

Solid-State Drives
If your host machine has a physical solid-state drive (SSD), the host informs guest operating systems
they are running on an SSD.
This allows the guest operating systems to optimize behavior. How the virtual machines recognize SSD
and use this information depends on the guest operating system and the disk type of the virtual disk
(SCSI, SATA, IDE, or NVMe).
n

On Windows 8, Windows 10, Ubuntu, and Red Hat Enterprise Linux virtual machines, all drive types
can report their virtual disks as SSD drives.
Note
n

NVMe virtual hard disks are natively supported for Windows 8.1 and later.

n

To create a new a virtual machine with a Windows 7 or Windows 2008 R2 guest operating system
using NVMe as the virtual hard disk, apply the appropriate Windows hot fix. See https://
support.microsoft.com/en-us/kb/2990941.

n

Several Linux operating systems support NVMe while others do not. Check with the operating
system vendor.
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n

On Windows 7 virtual machines, only IDE and SATA virtual disks can report their virtual disks as SSD.
SCSI virtual disks only report as SSD when used as a system drive in a virtual machine, or as a
mechanical drive when used as a data drive inside a virtual machine.

Use the virtual machine operating system to verify your virtual machine is using SSD as its virtual disk.

Local Area Networking Requirements for Host Systems
You can use any Ethernet controller that the host operating system supports.
Non-Ethernet networks are supported by using built-in network address translation (NAT) or by using a
combination of host-only networking and routing software on the host operating system.

Virtual Machine Features and Specifications
Workstation Player virtual machines support specific devices and provide certain features.

Supported Guest Operating Systems
A guest operating system can be Windows, Linux, and other commonly used operating systems.
For the most recent list of guest operating systems that VMware products support, see the VMware
Compatibility Guide site: http://www.vmware.com/resources/compatibility/search.php.
Workstation Player is not listed, but the information for Workstation Pro is applicable to Workstation
Player. Operating systems that are not listed are not supported for use in a virtual machine.
For instructions about how to install the most common guest operating systems, see the VMware Guest
Operating System Installation Guide: http://partnerweb.vmware.com/GOSIG/home.html.

Virtual Machine Processor Support
Virtual machines support certain processor features.
n

The same as the processor on the host computer.

n

One virtual processor on a host system that has one or more logical processors.

n

Up to 16 virtual processors (sixteen-way virtual symmetric multiprocessing, or Virtual SMP) on a host
system that has at least 2 logical processors.
Note Workstation Player considers multiprocessor hosts that have 2 or more physical CPUs, singleprocessor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading
enabled, to have two logical processors.

Virtual Machine Memory Allocation
The total amount of memory that you can assign to all virtual machines running on a single host system is
limited only by the amount of RAM on the host.
The maximum amount of memory for each virtual machine is 64GB.

VMware, Inc.
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Compatible Virtual Machines
Workstation Player can run virtual machines that other VMware products create.
VMware virtual
machines

VMware, Inc.

Workstation Player runs virtual machines that were created by using
Workstation 4 and later, GSX Server 3.x, VMware Server, and ESX Server
2.5 and later. Workstation 4 virtual machines run in legacy mode. You must
use another VMware product to upgrade virtual machines created in
versions earlier than Workstation 4 before you can run them in Workstation
Player.
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Installing and Using Workstation
Player

2

Installing Workstation Player typically involves running a standard GUI wizard.
This chapter includes the following topics:
n

Install Workstation Player on a Linux Host

n

Start Workstation Player

n

Use the Workstation Player Window

n

Transferring Files and Text

n

Download a Virtual Appliance in Workstation Player

n

Remove a Virtual Machine from the Library in Workstation Player

n

Uninstall Workstation Player

Install Workstation Player on a Linux Host
You run the Linux bundle installer to install Workstation Player on a Linux host system. By default,
Workstation Player is installed silently, and the installation progress is displayed in the terminal. When
Workstation Player is launched for the first time, a dialog box asks you to accept the EULAs and configure
necessary settings. At the same time, pure console installation is also supported. You can run the installer
with the --console option to install and configure Workstation Player in the terminal, without the first-time
dialog box appearing during the first launch.
Prerequisites
n

Verify that the host system meets the host system requirements. See Host System Requirements for
Workstation Player.

n

Obtain the Workstation Player software.

n

Familiarize yourself with the Linux command-line installation options. See Linux Command Line
Installation Options .

n

Verify that you have root access on the host system.

VMware, Inc.
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Procedure

1

Log in to the Linux host system with the user name that you plan to use when you run Workstation
Player.

2

Become root.
For example: su root
The command that you use depends on your Linux distribution and configuration.

3

Change directories to the directory that contains the Workstation Player installer file.

4

Run the appropriate Workstation Player installer file for the host system.
For example: sh VMware-Player-e.x.p-xxxx-xxxx.architecture.bundle --[option]
xxxx-xxxx is the version and build numbers, architecture is i386 or x86_64, and option is a command
line option.

5

Accept the license agreement.
If you are using the --console option or installing Workstation Player on a host system that does not
support the GUI wizard, press Enter to scroll through and read the license agreement or type q to skip
to the [yes/no] prompt.

6

Follow the prompts to finish the installation.

What to do next

After Workstation Player is installed, you can exit from the root account. You do not need to be root to run
Workstation Player.

Linux Command Line Installation Options
You can use command line installation options to install Workstation Player on a Linux host system.
To use the installation options, you must be logged in as root. Exit from the root account after the
installation is finished.
Table 2-1. Linux Command Line Installation Options
Option

Description

--console

Enables you to use the terminal for installation.

--custom

Use this option to customize the locations of the installation directories.

--deferred-gtk

Installs the product silently and configures the product on first launch.

--ignore-errors or -I

Allows the installation to continue even if there is an error in one of the installer
scripts. Because the section that has an error does not complete, the component
might not be properly configured

--regular

Shows installation questions that have not been answered before or are required.
This is the default option.

--required

Shows the license agreement only and then proceeds to install Workstation
Player.

VMware, Inc.
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Table 2-1. Linux Command Line Installation Options (continued)
Option

Description

--set-setting vmware-installer
installShortcuts yes | no

Adds shortcuts when Workstation Player is installed. The default is yes.

--set-setting vmware-installer libdir
lib_path

--set-setting vmware-installer
prefix /usr/local

The libdir parameter instructs the installer where to place product-specific data
files, such as libraries and internal icons. The installer places product files in
$libdir/vmware and $libdirvmware-installer. The default is /usr/lib.
Installs executable files you run directly (ex: vmware, vmplayer, vmwarenetworks, etc.) here. Remainder of the product distributed under libdir-derived
paths. The default is /usr .

--set-setting vmware-player
serialNumber xxxxx-xxxxx-xxxxx-xxxxxxxxxx

Lets you enter the license key when Workstation Player is installed. Enter the
license key with hyphens, for example, xxxxx-xxxxx-xxxxx-xxxxx-xxxxx.

--set-setting vmware-player-app
simplifiedUI yes|no

Turn on or off certain UI features of Workstation Player. The default is no.

--set-setting vmware-player-app
softwareUpdateEnabled yes|no

Enables automatic upgrades for Workstation Player when a new build becomes
available.

--set-setting vmware-player-app
softwareUpdateURL https://url/

Specifies a custom URL for managing software updates (separate from
vmware.com).

--set-setting vmware-player-app
supportURL https://url/

Set a support URL or email alias specifically for your users to contact with
product issues through the Help menu.

Start Workstation Player
When you start Workstation Player, the Workstation Player window opens.
You start Workstation Player from the command line. On some Linux distributions, including Red Hat
Enterprise Linux 5.1, you can also start Workstation Player from the System Tools menu under
Applications.
Procedure
u

Type the vmplayer command.
Option

Description

/usr/bin is in your default path

vmplayer &

/usr/bin is not in your default path

/usr/bin/vmplayer &

Use the Workstation Player Window
You interact with Workstation Player and virtual machines through the Workstation Player window. The
best way to learn how to use Workstation Player is to use it. The Workstation Player window is designed
to be intuitive and easy to use.

VMware, Inc.
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Procedure
u

Use the icons on the Home tab to create a new virtual machine, open an existing virtual machine,
download a virtual appliance, or view the Workstation Player help system.

u

Select a powered-off virtual machine in the library see the summary view.
The summary view shows a summary of configuration information and the virtual machine state. You
can start the virtual machine and edit virtual machine settings from the summary view.

u

Select a powered-off virtual machine in the library and click Play virtual machine to start the virtual
machine and see the console view.
The console view is like the monitor display of a physical computer.

u

Select a virtual machine in the library and use the Virtual Machine menu on the menu bar to perform
all virtual machine operations for the selected virtual machine.

u

When a virtual machine is powered on, use the icons on the status bar to perform actions on virtual
devices such as hard disks, CD/DVD drives, floppy drives, and network adapters.
You can click or right-click on a removable device icon to connect or disconnect the device or edit its
settings.

u

Use the About VMware Player window to access information about your installation of Workstation
Player, including license key information.
Click Help > About VMware Workstation Player.
n

If you have an individual license for Workstation Player, the key is displayed in the License
Information section in the Type field. It is labeled Individual and is followed by your license key.

n

If you have a version of Workstation Player licensed for multiple users, the Type field displays
Volume and your license key is not displayed.

n

If you did not enter a license for Workstation Player, the Type field displays Not applicable and a
license key is not displayed.

n

If you have an evaluation license key for Workstation Player, the Type field displays Not
applicable. The date the evaluation license key expires is also displayed.

Transferring Files and Text
You can use the drag-and-drop and copy and paste features, shared folders, and mapped drives to
transfer text and files between the host system and virtual machines.

Using the Drag-and-Drop Feature
You can use the drag-and-drop feature to move files and directories, email attachments, plain text,
formatted text, and images between the host system and virtual machines.
You can drag files or directories between the following locations.
n

File managers, such as Windows Explorer, on the host system and virtual machines.
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n

A file manager to an application that supports drag-and-drop.

n

Applications, such as zip file managers, which support drag-and-drop extraction of individual files.

n

Different virtual machines.

When you drag a file or folder between the host and a virtual machine, Workstation Player copies the file
or folder to the location where you drop it. For example, if you drop a file on the desktop icon of a word
processor, the word processor opens a copy of the original file. The original file does not include changes
that you make to the copy.
Initially, the application opens a copy of the file that is stored in the temp directory. On Windows, the temp
directory is specified in the %TEMP% environment variable. On Linux and Solaris, the temp directory
is /tmp/VMwareDnD. Save the file in a different directory to protect changes that you make.

Drag-and-Drop Requirements and Restrictions
The drag-and-drop feature has certain requirements and restrictions.
n

You must install VMware Tools in a virtual machine to use the drag-and-drop feature.

n

The drag-and-drop feature requires Linux hosts and guests to run X Windows and Solaris 10 guests
to run an Xorg X server and JDS/Gnome.

n

You can drag images between applications on Windows hosts and applications on Windows guests
only. Dragging images is not supported for Linux hosts or guests.

n

You can drag files and directories, email attachments, plain text, and formatted text between Linux
and Windows hosts and Linux, Windows, and Solaris 10 guests only.

n

Dragging email attachments is restricted to images or files smaller than 4 MB.

n

Dragging plain text and formatted text (including the formatting) is restricted to amounts less than 4
MB.

n

Dragging text is restricted to text in languages that can be represented by Unicode characters.

n

Workstation Player uses the PNG format to encode images that are dragged. Dragging images is
restricted to images smaller than 4 MB after conversion to PNG format.

Using the Copy and Paste Feature
You can cut, copy, and paste text between virtual machines and between applications running in virtual
machines.
You can also cut, copy, and paste images, plain text, formatted text, and email attachments between
applications running on the host system and applications running in virtual machines.

Copy and Paste Requirements and Restrictions
The copy and paste feature has certain requirements and restrictions.
n

You must install VMware Tools in a virtual machine to use the copy and paste feature.
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n

The copy and paste feature works with Linux and Windows hosts and Linux, Windows, and Solaris 10
guests only.

n

The copy and paste feature requires Linux hosts and guests to run X Windows and Solaris 10 guests
to run an Xorg X server and JDS/Gnome.

n

Copying and pasting email attachments is restricted to images or files smaller than 4 MB.

n

Copying and pasting plain text and formatted text (including the formatting) is restricted to amounts
less than 4MB.

n

Copying and pasting text is restricted to text in languages that can be represented by Unicode
characters.

n

Workstation Player uses the PNG format to encode images that are copied and pasted. Copying and
pasting images is restricted to images smaller than 4 MB after conversion to PNG format.

n

You cannot copy and paste files between virtual machines.

Download a Virtual Appliance in Workstation Player
You can download a virtual appliance in Workstation Player. A virtual appliance is a prebuilt,
preconfigured, and ready-to-run software application that is packaged with the operating system in a
virtual machine.
Procedure
u

Select File > Download a Virtual Appliance.

A Web browser opens to the Virtual Appliance Marketplace page on the VMware Web site. You can
browse to and download virtual appliances from this page.

Remove a Virtual Machine from the Library in Workstation
Player
When you open a virtual machine in Workstation Player, it is added to the virtual machine library. You can
remove a virtual machine that you are not using from the library.
Removing a virtual machine from the library does not delete the virtual machine or any of its files from the
host file system. The virtual machine is removed only from the library. If you open the virtual machine
again, the virtual machine is added back to the library.
Prerequisites

Power off the virtual machine.
Procedure
u

Select the virtual machine, right-click, and select Remove VM from the Library.

The virtual machine is removed from the library without any confirmation.
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Uninstall Workstation Player
You must uninstall the previous version of Workstation Player before you can install the latest version.
Procedure
u

Open a terminal and type the command vmware-installer -u vmware-player.
The uninstall program lets you specify whether to preserve your configuration files.
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3

Workstation Player preference settings are global configuration settings that apply to Workstation Player
and the virtual machines that you run in Workstation Player.
To change Workstation Player preference settings, select Player > File > Preferences.
This chapter includes the following topics:
n

Configuring Close Behavior Preference Settings

n

Configuring Software Updates Settings

n

Join or Leave the Customer Experience Improvement Program

Configuring Close Behavior Preference Settings
Close behavior preference settings control what Workstation Player does with virtual machines when you
close them.
To configure close behavior preference settings, select File > Preferences.
Table 3-1. Close Behavior Preference Settings
Setting

Description

Suspend the virtual machine

The virtual machine is suspended when you close it. The next
time you start Workstation Player, the virtual machine resumes
operation from the point at which it was suspended.

Power off the virtual machine

The virtual machines is powered off when you close it. The next
time you start Workstation Player, the virtual machine is in a
powered off state.

Leave the virtual machine running

The virtual machine remains running in the background when
you close it. The next time you start Workstation Player, the
virtual machine is in a powered on state.

Confirm before closing a virtual machine

Workstation Player prompts you for confirmation when you close
a virtual machine.

Return to the VM Library after closing a virtual machine

Workstation Player returns the virtual machines to the library
after you close it. You can open another virtual machine or edit
virtual machine settings.
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Configuring Software Updates Settings
Software updates settings control when Workstation Player downloads software updates to the host
system and whether it uses a proxy server to connect to the VMware Update Server.
To configure software updates settings, select Edit > Preferences > Updates.
Table 3-2. Software Update Preference Settings
Setting

Description

Check for product updates on startup

Check for new versions of the application and installed components when
you start Workstation Player. This setting is selected by default.

Check for new software components as needed

Check for a new version of a component when a component, such as
VMware Tools, is required. When this setting is selected, Workstation
Player verifies if a new version is available to download and install.

Download All Components Now

Manually download all of the available software components to the host
system. Click this button if you are planning to use a virtual machine at a
later time when you do not have access to the Internet.

Connection Settings

Click this button to configure a proxy server to connect to the VMware
Update Server.

Configuring Connection Settings for a Proxy Server
You can configure connection settings to use a proxy server to connect to the VMware Update Server.
To configure proxy connection settings, select Edit > Preferences > Updates and click Connection
Settings.
Table 3-3. Connection Settings
Setting

Description

No proxy

Do not use a proxy server.

Windows proxy settings

(Windows hosts only) Workstation Player uses the host proxy settings from the Connections
tab in the Internet Options control panel to access the VMware Update Server.
Click Internet Options to set the guest connection options.

System proxy settings

(Linux hosts only) Workstation Player uses the host proxy settings to access the VMware
Update Server.

Manual proxy settings

Select an HTTP or SOCKS proxy, specify the proxy server address, and designate a port
number to access the VMware Update Server.

Username and Password

The username and password to use for proxy server authentication. On Linux hosts, if either
the Username or Password text box is blank, Workstation Player uses the username and
password set in the gnome settings.

You must restart Workstation Player for proxy setting changes to take effect.

Understanding the Automatic Software Update Process
When you enable automatic software updates, you are always aware of the latest releases from VMware.
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By keeping your software up-to-date, you can take advantage of new product features and performance
improvements, ensure that your system includes the latest patches, and obtain timely support for new
guest operating systems. You can enable the automatic software update feature when you install
Workstation Player or by configuring Workstation Player preference settings. You can disable the feature
at any time.
To determine if software updates are available, the VMware software updates feature securely sends the
following anonymous information to VMware.
n

A universal unique identifier (UUID), which it uses to identify each individual system

n

The product name, the product version, and the build number

n

Your host operating system name, version, and the locale setting

The VMware software updates feature does not collect any personal data, such as your name, address,
telephone number, or mail address. Your product license key and MAC address are not sent to VMware,
and VMware does not store your IP address with the data that it receives from you.
VMware might use the information it receives from the software update feature for product planning
purposes. VMware limits access to your data and uses industry-standard controls to protect your
information, including physical access controls, Internet firewalls, intrusion detection, and network
monitoring.
The information collected by the VMware software updates feature is handled in accordance with VMware
Privacy Policy.

Join or Leave the Customer Experience Improvement
Program
The VMware Customer Experience Improvement Program (CEIP) provides information to VMware.
VMware uses the information to improve its products and services, to fix problems, and to advise you on
how best to deploy and use VMware products.
Workstation Player participates in the VMware CEIP. Information about the data collected through CEIP
and how VMware uses it are in the Trust & Assurance Center at http://www.vmware.com/trustvmware/
ceip.html.
The CEIP appears the first time you start Workstation Player after you install the product. You must then
make a selection. You can change your selection any time afterwards.
Procedure

1

Start Workstation Player.

2

Select Player > File > Preferences.
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3

Join or leave the CEIP depending on the participation preference currently selected.
Option

Description

Join

Select Join the VMware Customer Experience Improvement Program.

Leave

Unselect Join the VMware Customer Experience Improvement Program.
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Creating Virtual Machines in
Workstation Player

4

You use the New Virtual Machine wizard to create virtual machines. The New Virtual Machine wizard
guides you through the steps for setting up a new virtual machine, helping you set options and
parameters.
To start the New Virtual Machine wizard, select Player > File > New Virtual Machine, or click Create a
New Virtual Machine on the welcome page.
This chapter includes the following topics:
n

Understanding Virtual Machines

n

Preparing to Create a Virtual Machine

n

Create a Virtual Machine

n

Use Easy Install to Install a Guest Operating System

n

Install a Guest Operating System Manually

n

Importing Virtual Machines

Understanding Virtual Machines
A virtual machine is a software computer that, like a physical machine, runs an operating system and
applications. A virtual machine uses the physical resources of the physical machine on which it runs,
which is called the host system. Virtual machines have virtual devices that provide the same functionality
as physical hardware, but with the additional benefits of portability, manageability, and security.
A virtual machine has an operating system and virtual resources that you manage in much the same way
that you manage a physical computer. For example, you install an operating system in a virtual machine
in the same way that you install an operating system on a physical computer. You must have a CD-ROM,
DVD, or ISO image that contains the installation files from an operating system vendor.

Preparing to Create a Virtual Machine
When you create a virtual machine, you specify or accept defaults for a few basic virtual machine
settings.
n

How you want to install the guest operating system.
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n

A name for the virtual machine and a location for the virtual machine files.

n

The size of the virtual disk and whether to split the disk into multiple virtual disk files.

n

Whether to customize hardware settings, including memory allocation, number of virtual processors,
and network connection type.

Selecting a Guest Operating System
The New Virtual Machine prompts you to select the source media for the operating system that will run
inside the virtual machine. You can specify an installer disc inserted in a physical drive, an ISO image file,
or you can instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard
disk.
If you select an installer disc or an ISO image file and the operating system supports Easy Install, the
guest operating system installation is automated and VMware Tools is installed. If the installer disc or ISO
image file contains a product key number and is already set up to perform an unattended installation, the
only benefit of using Easy Install is the automatic installation of VMware Tools.
If you instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk, the
wizard prompts you to specify an operating system and version and you must install the guest operating
system manually after the virtual machine is created. Workstation Player uses this information to set the
appropriate default values, name files associated with the virtual machine, adjust performance settings,
and work around special behaviors and bugs in the guest operating system. If the operating system you
plan to install is not listed in the wizard, select Other for both the operating system and version.
If you are installing an operating system that supports Easy Install but you do not want to use Easy Install,
you can instruct the wizard to create a virtual machine that has a blank disk and install the guest
operating system manually.

Supported Guest Operating Systems
A guest operating system can be Windows, Linux, and other commonly used operating systems.
For the most recent list of guest operating systems that VMware products support, see the VMware
Compatibility Guide site: http://www.vmware.com/resources/compatibility/search.php.
Workstation Player is not listed, but the information for Workstation Pro is applicable to Workstation
Player. Operating systems that are not listed are not supported for use in a virtual machine.
For instructions about how to install the most common guest operating systems, see the VMware Guest
Operating System Installation Guide: http://partnerweb.vmware.com/GOSIG/home.html.

Providing Easy Install Information
When the New Virtual Wizard detects an operating system that supports Easy Install, the wizard prompts
you for information about the guest operating system. After the virtual machine is created, the guest
operating system installation is automated and VMware Tools is installed.
For Windows guest operating systems, you must provide the following Easy Install information.
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Table 4-1. Easy Install Information for Windows Guests
Easy Install Prompt

Description

Windows product key

(Optional) Type a product key unless the installation media contains a volume license
product key. If you provide a product key here, you are not prompted to provide a
product key when you install the guest operating system.

Version of Windows to install

Select the Windows operating system edition to install.

Full name

The name to use to register the guest operating system. Do not use the name
Administrator or Guest. If you use one of these names, you must enter a different name
when you install the guest operating system.

Password

(Optional) The password to use for an account with Administrator permissions on
Windows operating systems other than Windows 2000. On Windows 2000, this is the
password for the Administrator account. On Windows XP Home, an Administrator
account without a password is created and you are automatically logged in to the guest
operating system.

Log on automatically (requires a
password)

(Optional) Save your login credentials and bypass the login dialog box when you power
on the virtual machine. You must enter a name and password to use this feature.

For Linux guest operating systems, you must provide the following Easy Install information.
Table 4-2. Easy Install Information for Linux Guests
Prompt

Description

Full name

The name to use to register the guest operating system, if registration is required.
Workstation Player uses the first name to create the host name for the virtual machine.

User name

Your user name. You can use lowercase letters, numbers, and dashes, but avoid using
user names that begin with a dash. Do not use the name root. Some operating
systems set up sudo access for this user and other operating systems require this user
to use su to obtain root privileges.

Password

The password for the User name and the root user.

See Use Easy Install to Install a Guest Operating System .

Specifying the Virtual Machine Name and File Location
The New Virtual Machine wizard prompts you for a virtual machine name and a directory for the virtual
machine files.
The name of the default directory for virtual machine files is derived from the name of the guest operating
system, for example, Microsoft Windows 10 x64.
For standard virtual machines, the default directory for virtual machine files is located in the virtual
machine directory. For best performance, do not place the virtual machines directory on a network drive. If
other users need to access the virtual machine, consider placing the virtual machine files in a location that
is accessible to those users.
For shared virtual machines, the default directory for virtual machine files is located in the shared virtual
machines directory. Shared virtual machine files must reside in the shared virtual machines directory.
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Virtual Machines Directory
Workstation Player stores standard virtual machines in the virtual machines directory.
The default location of the virtual machines directory depends on the host operating system.
Table 4-3. Default Virtual Machines Directory
Host Operating System

Default Location

Windows Server 2008 R2

C:\Documents and Settings\username\My Documents\My
Virtual Machines

Windows Server 2012 R2

username is the name of the currently logged-in user.
Windows 7

C:\Users\ username \Documents\Virtual Machines

Windows 8

username is the name of the currently logged in user.

Windows 10
Linux

homedir/vmware
homedir is the home directory of the currently logged in logged
in user.

Specifying Disk Capacity for a Virtual Machine
If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration,
the wizard prompts you to set the size of the virtual disk and specify whether to split the disk into multiple
virtual disk (.vmdk) files.
A virtual disk is made up of one or more virtual disk files. Virtual disk files store the contents of the virtual
machine hard disk drive. Almost all of the file content is virtual machine data. A small portion of the file is
allotted to virtual machine overhead. If the virtual machine is connected directly to a physical disk, the
virtual disk file stores information about the partitions that the virtual machine is allowed to access.
You can set a size between 0.001 GB and 8 TB for a virtual disk file. You can also select whether to store
a virtual disk as a single file or split it into multiple files.
Select Split virtual disk into multiple files if the virtual disk is stored on a file system that has a file size
limitation. When you split a virtual disk less than 950 GB, a series of 2-GB virtual disk files are created.
When you split a virtual disk greater than 950 GB, two virtual disk files are created. The maximum size of
the first virtual disk file is 1.9 TB and the second virtual disk file stores the rest of the data.
Disk space is not preallocated for the disk. The actual files that the virtual disk uses start small and
expand to their maximum size as needed. The main advantage of this approach is the smaller file size.
Smaller files require less disk space and are easier to move to a new location.
After you create a virtual machine, you can edit virtual disk settings and add additional virtual disks.

Disk Size Compatibility
The size of a virtual disk is limited to 8 TB. However, your hardware version, bus type, and controller type
also impact the size of your virtual disks.
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Workstation Hardware Version

Bus Type

Controller Type

Maximum Disk Size

10, 11, 12, 14

IDE

ATAPI

8192 GB (8TB)

10, 11, 12, 14

SCSI

BusLogic

2040 GB (2TB)

10, 11, 12, 14

SCSI

LSI Logic

8192 GB (8TB)

10, 11, 12, 14

SCSI

LSI Logic SAS

8192 GB (8TB)

10, 11, 12, 14

SATA

AHCI

8192 GB (8TB)

14

NVMe

NVMe

8192 GB (8TB)

9, 8, 7, 6.5

All

All

2040 GB (2TB)

6.0, 5

All

All

950 GB

To discover your SCSI controller type, open the virtual machine .vmx file. The value of the setting
scsi0.virtualDev determines your SCSI controller type.
Value

SCSI Controller Type

Blank or not present

BusLogic

lsilogic

LSI Logic

lsisas1068

LSI Logic SAS

Customizing Virtual Machine Hardware
You can click Customize Hardware on the last page of the New Virtual Machine wizard to customize
the virtual machine hardware.
You can change the default hardware settings, including memory allocation, number of virtual CPUs,
CD/DVD and floppy drive settings, and the network connection type.

Worksheet for Creating a Typical Virtual Machine
You can print this worksheet and write the values to specify when you create a typical virtual machine.
Table 4-4. Worksheet: Typical Virtual Machine
Option

Write Your Value Here

Guest operating system source
Guest operating system type for manual installation
Easy Install information for Windows guests
n

Product key

n

Operating system version

n

Full name

n

Password

n

Credentials for automatic login

Easy Install information for Linux guests
n

Full name

n

User name

n

Password
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Table 4-4. Worksheet: Typical Virtual Machine (continued)
Option

Write Your Value Here

Virtual machine name
Virtual machine location
Disk capacity

Create a Virtual Machine
You create a virtual machine in Workstation Player by running the New Virtual Machine wizard.
Prerequisites
n

Verify that you have the information the New Virtual Machine wizard requires to create a virtual
machine. See Preparing to Create a Virtual Machine.

n

Verify that the guest operating system you plan to install is supported. See the online VMware
Compatibility Guide, which is available on the VMware Web site.

n

See the VMware Guest Operating System Installation Guide for information about the guest operating
system you plan to install.

n

If you are installing the guest operating system from an installer disc, insert the installer disc in the
CD-ROM drive in the host system.

n

If you are installing the guest operating system from an ISO image file, verify that the ISO image file is
in a directory that is accessible to the host system.

Procedure

1

Select File > Create a New Virtual Machine.

2

Select the source of the guest operating system.

3

4

Option

Description

Use a physical disc

Select the physical drive where you inserted the installation disc.

Use an ISO image

Type or browse to the location of the ISO image file.

Install the guest operating system
later

Create a virtual machine that has a blank disk. You must install the guest operating
system manually after the virtual machine is created.

Specify information about the guest operating system.
Option

Description

You are using Easy Install

Type the Easy Install information for the guest operating system.

You are not using Easy Install

Select the guest operating system type and version. If the guest operating system
is not listed, select Other.

Type a virtual machine name and type or browse to the directory for the virtual machine files.
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5

Select the virtual disk size and specify whether the disk should be split into multiple files.

6

(Optional) Click Customize Hardware to change the default hardware settings.
You can also modify virtual hardware settings after you create the virtual machine.

7

(Optional) Select Power on this virtual machine after creation to power on the virtual machine after
it is created.
This option is not available if you are installing the guest operating system manually.

8

Click Finish to create the virtual machine.

If you are using Easy Install, guest operating system installation begins when the virtual machine powers
on. The guest operating system installation is automated and typically runs without requiring any input
from you. After the guest operating system is installed, Easy Install installs VMware Tools.
If you are not using Easy Install, the virtual machine appears in the library.
What to do next

If you used Easy Install and the virtual machine did not power on when the installation finished, power on
the virtual machine to start the guest operating system installation. See Use Easy Install to Install a Guest
Operating System .
If you did not use Easy Install, install the guest operating system manually. See Install a Guest Operating
System Manually .

Use Easy Install to Install a Guest Operating System
When you use Easy Install, you usually do not need to provide information during guest operating system
installation.
If you did not provide all of the Easy Install information in the New Virtual Machine wizard, you might be
prompted for a product key, username, or password.
Also, if the guest operating system installation consists of multiple discs or ISO image files, the installer
might prompt you for the next disk.
Procedure
u

If the installer prompts you for a product key, username, or password, click in the virtual machine
window and type the required information.
Mouse and keyboard input are captured by the virtual machine.

u

If you are using physical discs and the installer prompts you for the next disk, use the CD-ROM or
DVD drive on the host system.
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u

If you are using multiple ISO image files and the installer prompts you for the next disk, select the
next ISO image file.
Option

Description

Windows host

Click Change Disk and browse to the next ISO image file.

Linux host

a

Select Virtual Machine > Removable Devices > CD/DVD > Settings and
browse to the next ISO image file.

b

Select Connected.

c

Click Save.

Install a Guest Operating System Manually
Installing a guest operating system in a virtual machine is similar to installing an operating system on a
physical computer. If you do not use Easy Install when you create a virtual machine in the New Virtual
Machine wizard, you must install the guest operating system manually.
You can install a guest operating system from an installer disc or ISO image file. You can also use a PXE
server to install the guest operating system over a network connection. If the host configuration does not
permit the virtual machine to boot from an installer disc, you can create an ISO image file from the
installer disc.
Prerequisites
n

Verify that the operating system is supported. See the online VMware Compatibility Guide on the
VMware Web site.

n

See the VMware Guest Operating System Installation Guide for information on the guest operating
system that you are installing.

Procedure

1

2

If you are installing the guest operating system from an installer disc, configure the virtual machine to
use a physical CD-ROM or DVD drive and configure the drive to connect at power on.
a

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

b

On the Hardware tab, select CD/DVD drive.

c

Select Connect at power on.

d

Select Use physical drive and select a the drive.

e

Click OK to save your changes.

If you are installing the guest operating system from an ISO image file, configure the CD/DVD drive in
the virtual machine to point to the ISO image file and configure the drive to connect at power on.
a

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

b

On the Hardware tab, select CD/DVD drive.

c

Select Connect at power on.
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d

Select Use ISO image file and browse to the location of the ISO image file.

e

Click OK to save your changes.

3

If you are installing the guest operating system from an installer disc, insert the disc in the CD-ROM
or DVD drive.

4

Power on the virtual machine.

5

Follow the installation instructions provided by the operating system vendor.

6

If the operating system consists of multiple installer discs and you are prompted to insert the next
disc, insert the next disc in the physical drive.

7

If the operating system consists of multiple ISO image files, select the image file for the next CD.

8

a

Select Virtual Machine > Removable Devices > CD/DVD > Disconnect and disconnect from
the current ISO image file..

b

Select Virtual Machine > Removable Devices > CD/DVD > Settings and select the next ISO
image file.

c

Select Connected and click OK.

Use the standard tools in the operating system to configure its settings.

What to do next

Install VMware Tools. You should install VMware Tools before you activate the license for the operating
system. See Installing VMware Tools.

Importing Virtual Machines
You can import virtual machines in other formats into Workstation Player.

Import an Open Virtualization Format Virtual Machine
You can import an Open Virtualization Format (OVF) virtual machine and run it in Workstation Player.
Workstation Player converts the virtual machine from OVF format to VMware runtime (.vmx) format. You
can import both .ovf and .ova files.
OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual
machines. For example, you can import OVF virtual machines exported from VMware Fusion™ or Oracle
VM VirtualBox into Workstation Player. You can import OVF 1.x files only.
You can also use the standalone OVF Tool to convert an OVF virtual machine to VMware runtime format.
The standalone version of the OVF Tool is installed in the Workstation Player installation directory under
OVFTool. See the OVF Tool User Guide on the VMware Web site for information on using the OVF Tool.
Procedure

1

In Workstation Player, select File > Open a Virtual Machine.

2

Browse to the .ovf or .ova file and click Open.
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3

Type a name for the virtual machine, type or browse to the directory for the virtual machine files, and
click Import.
Workstation Player performs OVF specification conformance and virtual hardware compliance
checks. A status bar indicates the progress of the import process.

4

If the import fails, click Retry to try again, or click Cancel to cancel the import.
If you retry the import, Workstation Player relaxes the OVF specification conformance and virtual
hardware compliance checks and you might not be able to use the virtual machine in Workstation
Player.

After Workstation Player successfully imports the OVF virtual machine, the virtual machine appears in the
virtual machine library.

Import a VMware vCenter Server Appliance
You can import a VMware vCenter® Server Appliance™ and run it in Workstation Player. You can import
both .ovf and .ova files.
Procedure

1

In Workstation Player, select File > Open a Virtual Machine.

2

Browse to the vCenter Server Appliance .ovf or .ova file and click Open.

3

Select the license agreement check box and click Next.

4

Continue through the wizard, responding to prompts and clicking through to the next dialog box.

5

If the import fails, click Retry to try again, or click Cancel to cancel the import.
If you retry the import, Workstation Player relaxes the OVF specification conformance and virtual
hardware compliance checks and you might not be able to use the virtual machine in Workstation
Player.

After Workstation Player successfully imports the vCenter Server Appliance as a virtual machine, the
virtual machine appears in the virtual machine library. Workstation Player then powers on the virtual
machine and applies the vCenter Server Appliance configuration.
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5

Installing VMware Tools is part of the process of creating a new virtual machine. Upgrading VMware Tools
is part of the process of keeping virtual machines up to current standards.
For the best performance and latest updates, install or upgrade VMware Tools to match the version of
Workstation Player that you are using. Other compatibility options are also available.
For more information about using VMware Tools, see Installing and Configuring VMware Tools at http://
www.vmware.com/pdf/vmware-tools-installation-configuration.pdf.
This chapter includes the following topics:
n

Installing VMware Tools

n

Upgrading VMware Tools

n

Configure Software Update Preferences

n

Configure VMware Tools Updates for a Specific Virtual Machine

n

Manually Installing and Upgrading VMware Tools

n

Starting the VMware User Process Manually If You Do Not Use a Session Manager

n

Uninstalling VMware Tools

Installing VMware Tools
Installing VMware Tools is part of the process of creating a new virtual machine, and upgrading VMware
Tools is part of the process of keeping your virtual machine up to current standards. Although your guest
operating systems can run without VMware Tools, many VMware features are not available until you
install VMware Tools. When you install VMware Tools, the utilities in the suite enhance the performance of
the guest operating system in your virtual machine and improve the management of your virtual
machines.
For information about creating virtual machines, see the documentation for the applicable VMware
product.
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The installers for VMware Tools are ISO image files. The CD-ROM in your guest operating system detects
the ISO image file. Each type of guest operating system, including Windows, Linux, and Mac OS X, has
an ISO image file. When you select the command to install or upgrade VMware Tools, the virtual
machine’s first virtual CD-ROM disk drive temporarily connects to the VMware Tools ISO file for your
guest operating system.
You can use the Windows Easy Install or Linux Easy Install feature to install VMware Tools as soon as the
operating system is finished installing.
The most recent versions of the ISO files are stored on a VMware Web site. When you select the
command to install or upgrade VMware Tools, the VMware product determines whether it has
downloaded the most recent version of the ISO file for the specific operating system. If the latest version
has not been downloaded or if no VMware Tools ISO file for that operating system has ever been
downloaded, you are prompted to download the file.
n

VMware Tools installer from windows.iso automatically detects the windows version. It does not
proceed with the installation on guest operating systems earlier than Windows Vista.

n

VMware Tools installer from winPreVista.iso does not proceed with the installation on Windows
Vista and later.

n

VMware Tools installer from linux.iso does not proceed with installation on Linux guest operating
system versions earlier than RHEL5, SLES 11, Ubuntu 10.04, and other Linux distributions with
glibc version earlier than 2.5.

n

VMware Tools installer from darwinPre15.iso does not proceed with installation on MAC OS X
guest operating systems versions 10.11 or later.

n

VMware Tools installer from darwin.iso does not proceed with installation on MAC OS X guest
operating systems versions earlier than 10.11.

The installation procedure varies, depending on the operating system. For information about installing or
upgrading VMware Tools on your guest operating systems, see the topic about upgrading virtual
machines in the Virtual Machine Administration Guide. For general instructions about installing VMware
Tools, see the VMware Knowledge base article http://kb.vmware.com/kb/1014294.

Upgrading VMware Tools
You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install
newer versions of VMware Tools.
The guest operating system checks the version of VMware Tools when you power on a virtual machine.
The status bar of your virtual machine displays a message when a new version is available.
For vSphere virtual machines,
A newer version of Tools is available for this VM

is displayed when the installed version of VMware Tools is out of date.
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In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this
notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution
icon when a VMware Tools upgrade is available.
To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware
Tools the first time. Upgrading VMware Tools means installing a new version.
For Windows and Linux guest operating systems, you can configure the virtual machine to automatically
upgrade VMware Tools. Although the version check is performed when you power on the virtual machine,
on Windows guest operating systems, the automatic upgrade occurs when you power off or restart the
virtual machine. The status bar displays the message Installing VMware Tools ... when an
upgrade is in progress. The procedure is mentioned below.
Note Upgrading VMware Tools on Windows guest operation systems automatically installs the WDDM
graphics drivers. The WDDM graphics driver allows the sleep mode available in guest OS power settings
to adjust the sleep options. For example, you can use the sleep mode setting Change when the
computer sleeps to configure your guest OS to automatically go to sleep mode after a certain time or
prevent your guest OS from automatically switching to sleep mode after being idle for some time.
Some features in a particular release of a VMware product might depend on installing or upgrading to the
version of VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not
always necessary. Newer versions of VMware Tools are compatible with several host versions. To avoid
unnecessary upgrades, evaluate whether the added features and capabilities are necessary for your
environment.

Configure Software Update Preferences
You can configure Workstation Player to automatically download software updates, including new
versions of VMware Tools. When you select automatic software updates, Workstation Player always
includes the latest support for guest operating systems and virtual machines always have the latest
version of VMware Tools.
Procedure

1

Select File > Preferences.
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2

Select when Workstation Player checks for software updates.
You can select one, both, or neither option. If you deselect all of the software update options,
automatic software updates are disabled.

3

Option

Description

Check for product updates on startup

Checks for new versions of Workstation Player available to download and install
when you start Workstation Player. This option is enabled by default. If you do not
select this option, your system does not get the latest product updates.

Check for software components as
needed

When a software component is required, for example, when you install VMware
Tools, Workstation Player checks for a new version of the component.

Download All Components Now

Immediately download all of the available software components to the host system.
This option is useful if you are planning to use the virtual machine at a later time
when you do not have access to the Internet.

If you use a proxy server to connect to the VMware Update Server, click Connection Settings to
configure the proxy settings.
Option

Description

No proxy

Select this option if you do not use a proxy server. This is the default setting.

System proxy settings

Workstation Player uses the host proxy settings to access the VMware Update
Server.

Manual proxy settings

a

Select HTTP or SOCKS, specify the proxy server address and designate a port
number to access the VMware Update Sever.

b

Type a username and password to use for proxy authentication.

If you leave either the Username or the Password text box blank, Workstation
Player does not use either value (Windows hosts) or it uses the username and
password set in the gnome settings (Linux hosts).

4

Click OK to save your changes.

Configure VMware Tools Updates for a Specific Virtual
Machine
You can configure virtual machines that have Windows or Linux guest operating systems to update
VMware Tools automatically. For other guest operating systems, you must manually update VMware
Tools.
Automatic VMware Tools updates are supported for versions of VMware Tools included in Workstation 5.5
and later virtual machines only. Automatic updates are not supported for versions of VMware Tools
included in virtual machines created with VMware Server 1.x.
Important If you update VMware Tools in a Windows virtual machine that was created with Workstation
4 or 5.x, some new components are not installed. To install the new components, you must uninstall the
old version of VMware Tools and install the new version of VMware Tools.
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Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select VMware Tools.

3

Select a VMware Tools update setting.

4

Option

Description

Update manually (do nothing)

You must update VMware Tools manually. The virtual machine status bar indicates
when a new version of VMware Tools is available.

Update automatically

VMware Tools is updated automatically. The virtual machine status bar indicates
when an update is in progress. If you are logged in to a Windows guest, a restart
prompt appears after the update is complete. If you are not logged in, the operating
system restarts without prompting. An auto-update check is performed as part of
the boot sequence when you power on the virtual machine. If the virtual machine
was suspended and you resume it or restore it to a snapshot during the boot
sequence before this check, the automatic update occurs as planned. If you
resume the virtual machine or restore it to a snapshot after the check, the
automatic update does not occur.

Use application default (currently
update manually)

Use the default VMware Tools update behavior. The default behavior is set in
Workstation Player preferences.

Click OK to save your changes.

Manually Installing and Upgrading VMware Tools
You can manually install or upgrade VMware Tools on Windows, Linux, NetWare, Solaris, and FreeBSD
virtual machines.
If you are installing VMware Tools in a number of Windows virtual machines, you can automate its
installation by using the VMware Tools setup.exe at a command prompt in the guest operating system.
See Installing and Configuring VMware Tools at http://www.vmware.com/pdf/vmware-tools-installationconfiguration.pdffor more information.

Manually Installing VMware Tools on a Windows Virtual Machine
Guest operating system Windows 2000 and earlier, Windows XP, Windows Server 2003, Windows Vista,
and later support VMware Tools.
Prerequisites
n

Power on the virtual machine.

n

Verify that the guest operating system is running.

n

If you connected the virtual machine’s virtual CD/DVD drive to an ISO image file when you installed
the operating system, change the setting so that the virtual CD/DVD drive is configured to autodetect
a physical drive.
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The autodetect setting enables the virtual machine's first virtual CD/DVD drive to detect and connect
to the VMware Tools ISO file for a VMware Tools installation. This ISO file is detected as a physical
CD by your guest operating system. Use the virtual machine settings editor to set the CD/DVD drive
to autodetect a physical drive.
n

Log in as an administrator unless you are using an older Windows operating system. Any user can
install VMware Tools in a Windows 95, Windows 98, or Windows ME guest operating system. For
operating systems later than these, you must log in as an administrator.

n

The AppDefense component is not installed by default. You must perform a custom installation and
include that component.

Procedure

1

On the host, from the Workstation Player menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2

If you are installing VMware Tools for the first time, click OK on the Install VMware Tools information
page.
If autorun is enabled for the CD-ROM drive on the guest operating system, the VMware Tools
installation wizard starts.
If autorun is not enabled, to manually launch the wizard, click Start > Run and enter D:\setup.exe,
where D: is your first virtual CD-ROM drive. Use D:\setup64.exe for 64-bit Windows guest
operating system.

3

Follow the on-screen prompts.

4

If the New Hardware wizard appears, follow the prompts and accept the defaults.
Note If you are installing a beta or RC version of VMware Tools and you see a warning that a
package or driver is not signed, click Install Anyway to complete the installation.

5

When prompted, reboot the virtual machine.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Installing VMware Tools on a Linux Virtual Machine
It is recommended that you use Open VM Tools in Linux virtual machines.
For more information about Linux distributions supported by Open VM Tools, see https://github.com/
vmware/open-vm-tools/blob/master/README.md and the VMware Compatibility Guide at https://
www.vmware.com/resources/compatibility/search.php.
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VMware Tar Tool for Linux virtual machine is feature-frozen at version 10.3.10, so the tar tools (linux.iso)
included in Workstation Player is 10.3.10 and will not be updated. Due to this change, the Install/Update/
Reinstall VMware Tools menu is disabled for the following Linux virtual machines:
n

Modern Linux distributions not officially supported by tar tools.
n

Red Hat Enterprise Linux 8 and later releases.

n

CentOS 8 and later releases.

n

Oracle Linux 8 and later releases.

n

SUSE Linux Enterprise 15 and later releases.

n

Linux kernel version is 4.0 or later, and the version of the installed Open VM Tools is 10.0.0 or later.

n

Linux kernel version is 3.10 or later, and the version of the installed Open VM Tools is 10.3.0 or later.

For the Linux virtual machines that have Open VM Tools installed but are not in the scope mentioned in
the preceding bullet, Install/Update/Reinstall VMware Tools menu is enabled, so that you can install
bundled tar tools on top of Open VM Tools to get Shared Folder (HGFS) feature support.
For old Linux virtual machines not supported by Open VM Tools, perform the following steps to install tar
tools.
Prerequisites
n

Power on the virtual machine.

n

Verify that the guest operating system is running.

n

Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating
system.

Procedure

1

On the host, from the Workstation Player menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2

In the virtual machine, open a terminal window.

3

Run the mount command with no arguments to determine whether your Linux distribution
automatically mounted the VMware Tools virtual CD-ROM image.
If the CD-ROM device is mounted, the CD-ROM device and its mount point are listed in a manner
similar to the following output:
/dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)
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4

If the VMware Tools virtual CD-ROM image is not mounted, mount the CD-ROM drive.
a

If a mount point directory does not already exist, create it.
mkdir /mnt/cdrom

Some Linux distributions use different mount point names. For example, on some distributions
the mount point is /media/VMware Tools rather than /mnt/cdrom. Modify the command to
reflect the conventions that your distribution uses.
b

Mount the CD-ROM drive.
mount /dev/cdrom /mnt/cdrom

Some Linux distributions use different device names or organize the /dev directory differently. If
your CD-ROM drive is not /dev/cdrom or if the mount point for a CD-ROM is not /mnt/cdrom,
modify the command to reflect the conventions that your distribution uses.
5

Change to a working directory, for example, /tmp.
cd /tmp

6

(Optional) Delete any previous vmware-tools-distrib directory before you install VMware Tools.
The location of this directory depends on where you placed it during the previous installation. Often
this directory is placed in /tmp/vmware-tools-distrib.

7

List the contents of the mount point directory and note the file name of the VMware Tools tar installer.
ls mount-point

8

Uncompress the installer.
tar zxpf /mnt/cdrom/VMwareTools-x.x.x-yyyy.tar.gz

The value x.x.x is the product version number, and yyyy is the build number of the product release.
9

If necessary, unmount the CD-ROM image.
umount /dev/cdrom

If your Linux distribution automatically mounted the CD-ROM, you do not need to unmount the image.
10 Run the installer and configure VMware Tools as a root user
cd vmware-tools-distrib
sudo ./vmware-install.pl

Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.
If you attempt to install a tar installation over an RPM installation, or the reverse, the installer detects
the previous installation and must convert the installer database format before continuing.
Note For newer Linux distributions, users are prompted to choose the integrated open-vm-tools.
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11 Follow the prompts to accept the default values, if appropriate for your configuration.
12 Follow the instructions at the end of the script.
Depending on the features you use, these instructions can include restarting the X session, restarting
networking, logging in again, and starting the VMware User process. You can alternatively reboot the
guest operating system to accomplish all these tasks.
What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Installing VMware Tools on a NetWare Virtual Machine
For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.
Prerequisites
n

Power on the virtual machine.

n

Verify that the guest operating system is running.

n

Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating
system.

Note VMware Tools 10.1.0 does not support the NetWare operating system.
Procedure

1

On the host, from the Workstation Player menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2

Load the CD-ROM driver so that the virtual CD-ROM device mounts the ISO image as a volume.
Operating System

Command

NetWare 6.5

LOAD CDDVD

NetWare 6.0 or NetWare 5.1

LOAD CD9660.NSS

NetWare 4.2 (not available in vSphere)

load cdrom

When the installation finishes, the message VMware Tools for NetWare are now running
appears in the Logger Screen for NetWare 6.5 and NetWare 6.0 guest operating systems and in the
Console Screen for NetWare 4.2 and 5.1 operating systems.
3

If the VMware Tools virtual disc (netware.iso) is attached to the virtual machine, right-click the CDROM icon in the status bar of the console window and select Disconnect.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
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Manually Installing VMware Tools on a Solaris Virtual Machine
For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.
Prerequisites
n

Power on the virtual machine.

n

Verify that the guest operating system is running.

n

Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating
system.

Procedure

1

On the host, from the Workstation Player menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2

In the virtual machine, log in to the guest operating system as root and open a terminal window.

3

If the Solaris volume manager does not mount the CD-ROM under /cdrom/vmwaretools, restart the
volume manager.
/etc/init.d/volmgt stop
/etc/init.d/volmgt start

4

Change to a working directory, for example, /tmp.
cd /tmp

5

Extract VMware Tools.
gunzip -c /cdrom/vmwaretools/vmware-solaris-tools.tar.gz | tar xf -

6

Run the installer and configure VMware Tools.
cd vmware-tools-distrib
./vmware-install.pl

Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.
7

Follow the prompts to accept the default values, if appropriate for your configuration.

8

Follow the instructions at the end of the script.
Depending on the features you use, these instructions can include restarting the X session, restarting
networking, logging in again, and starting the VMware User process. You can alternatively reboot the
guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
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Manually Installing VMware Tools on a FreeBSD Virtual Machine
For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line.
Prerequisites
n

Power on the virtual machine.

n

Verify that the guest operating system is running.

n

Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating
system.

Procedure

1

On the host, from the Workstation Player menu bar, select Virtual Machine > Install VMware Tools.
If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2

In the virtual machine, log in to the guest operating system as root and open a terminal window.

3

If the distribution does not automatically mount CD-ROMs, mount the VMware Tools virtual CD-ROM
image.
For example, type mount /cdrom.

4

Change to a working directory, for example, /tmp.
cd /tmp

5

Untar the VMware Tools .tar.gz file.
tar zxpf /cdrom/vmware-freebsd-tools.tar.gz

6

If the distribution does not use automounting, unmount the VMware Tools virtual CD-ROM image.
umount /cdrom

7

Run the installer and configure VMware Tools.
cd vmware-tools-distrib
./vmware-install.pl

Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.
8

Follow the prompts to accept the default values, if appropriate for your configuration.

9

Follow the instructions at the end of the script.
Depending on the features you use, these instructions can include restarting the X session, restarting
networking, logging in again, and starting the VMware User process. You can alternatively reboot the
guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
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Starting the VMware User Process Manually If You Do Not
Use a Session Manager
VMware Tools in Linux, Solaris, and FreeBSD guest operating systems uses the VMware user process.
This program implements the fit-guest-to-window and other features.
Normally, this process starts after you configure VMware Tools, log out of the desktop environment, and
log back in. You can invoke the VMware user process by running the vmtoolsd -n vmusr command. The
startup script that you need to modify depends on your system. You must start the process manually in
the following environments:
n

If you run an X session without a session manager. For example, if you use startx to start a desktop
session and do not use xdm, kdm, or gdm.

n

If you are using an older version of GNOME without gdm or xdm.

n

If you are using a session manager or environment that does not support the Desktop Application
Autostart Specification, available from http://standards.freedesktop.org.

n

If you upgrade VMware Tools.

Procedure
u

Start the VMware User process.
Option

Action

Start the VMware User process when
you start an X session.

or .xinitrc file.

Start the process after a VMware
Tools software upgrade, or if certain
features are not working.

Add vmtoolsd -n vmusr to the appropriate X startup script, such as the .xsession

Open a terminal window and type the vmtoolsd -n vmusr command.

Uninstalling VMware Tools
If the upgrade process of VMware Tools is incomplete, you can uninstall and then reinstall the VMware
Tools.
Prerequisites
n

Power on the virtual machine.

n

Log in to the guest operating system.
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Procedure
u

Select a method to uninstall VMware Tools.
Operating System

Action

Windows 7, 8, 8.1, or Windows 10

In the guest operating system, select Programs > Uninstall a program.

Windows Vista and Windows Server
2008

In the guest operating system, select Programs and Features > Uninstall a
program.

Windows XP and earlier

In the guest operating system, select Add/Remove Programs.

Linux

Log in as root and enter vmware-uninstall-tools.pl in a terminal window.

Mac OS X, OS X, or macOS

Use the Uninstall VMware Tools application, found in /Library/Application
Support/VMware Tools.

What to do next

Reinstall VMware Tools.
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6

You can use Workstation Player to start and stop virtual machines on the host system.
When you start a virtual machine, the guest operating system starts and you can interact with the virtual
machine. You can power off, reset, and suspend virtual machines.
This chapter includes the following topics:
n

Start a Virtual Machine in Workstation Player

n

Start an Encrypted Virtual Machine in Workstation Player

n

Download a Virtual Appliance in Workstation Player

n

Power Off a Virtual Machine in Workstation Player

n

Remove a Virtual Machine from the Library in Workstation Player

n

Use Ctrl+Alt+Delete to Shut Down a Guest

n

Suspend and Resume a Virtual Machine in Workstation Player

n

Reset a Virtual Machine in Workstation Player

n

Enable Autologon in a Windows Virtual Machine

n

Set Workstation Player Preferences for Virtual Machine Closing Behavior

Start a Virtual Machine in Workstation Player
You can start a virtual machine from the Workstation Player window.
Prerequisites

Verify that the virtual machine files are accessible to the host system.
Procedure

1

If the virtual machine does not appear in the library, select File > Open a Virtual Machine.

2

Browse to and select the virtual machine configuration (.vmx) file, and click Open.
The virtual machine appears in the library.

3

Select the virtual machine in the library and select Virtual Machine > Power > Play Virtual Machine.
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4

Click anywhere inside the virtual machine console to give the virtual machine control of the mouse
and keyboard on the host system.

5

Log in to the guest operating system.

Start an Encrypted Virtual Machine in Workstation Player
An encrypted virtual machine is a virtual machine that has been secured from unauthorized use. A lock
icon appears next to an encrypted virtual machine in the virtual machine library.
Note You cannot create encrypted virtual machines in Workstation Player. You can only create
encrypted virtual machines using VMware Workstation 7.x and later or VMware Fusion 7.x and later.
Prerequisites

Obtain the encryption password for the virtual machine.
Procedure

1

Select the virtual machine in the library and select Virtual Machine > Power > Play Virtual Machine.

2

Type the encryption password.

3

Click Continue to start the virtual machine.

Download a Virtual Appliance in Workstation Player
You can download a virtual appliance in Workstation Player. A virtual appliance is a prebuilt,
preconfigured, and ready-to-run software application that is packaged with the operating system in a
virtual machine.
Procedure
u

Select File > Download a Virtual Appliance.

A Web browser opens to the Virtual Appliance Marketplace page on the VMware Web site. You can
browse to and download virtual appliances from this page.

Power Off a Virtual Machine in Workstation Player
As with physical computers, you should shut down a guest operating system before you power off a
virtual machine.
Procedure
u

To shut down the guest operating system, shut down the operating system as you would if you were
using a physical machine.
When the guest operating system shuts down, the virtual machine is powered off and Workstation
Player exits.
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u

To power off a virtual machine without shutting down the guest operating system, select Virtual
Machine > Power > Power Off.
If soft power operations are configured for the virtual machine in Workstation Player, Power Off
Guest appears in the menu instead of Power Off.

Remove a Virtual Machine from the Library in Workstation
Player
When you open a virtual machine in Workstation Player, it is added to the virtual machine library. You can
remove a virtual machine that you are not using from the library.
Removing a virtual machine from the library does not delete the virtual machine or any of its files from the
host file system. The virtual machine is removed only from the library. If you open the virtual machine
again, the virtual machine is added back to the library.
Prerequisites

Power off the virtual machine.
Procedure
u

Select the virtual machine, right-click, and select Remove VM from the Library.

The virtual machine is removed from the library without any confirmation.

Use Ctrl+Alt+Delete to Shut Down a Guest
You can use the Ctrl+Alt+Delete key sequence to shut down or log off of a guest operating system.
Prerequisites

Power on the virtual machine.
Procedure
u

Select the virtual machine and select Virtual Machine > Send Ctrl+Alt+Delete.
This option is the same as pressing Ctrl+Alt+Delete on your keyboard. On Windows hosts, this
command might be received by both the host operating system and the virtual machine, even when
Workstation Player has control of input.

u

If the command is received by both the host operating system and the virtual machine, press Ctrl+Alt
+Ins on the keyboard.
The command is received solely by the virtual machine and shuts down or logs out of the guest
operating system.
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Suspend and Resume a Virtual Machine in Workstation
Player
Suspending a virtual machine saves its current state. When you resume the virtual machine, applications
that were running before the virtual machine was suspended resume in their running state and their
content is unchanged.
How quickly the suspend and resume operations perform depends on how much data changed after you
started the virtual machine. The first suspend typically takes longer than subsequent suspend operations.
Procedure
u

To suspend a virtual machine, select Virtual Machine > Power > Suspend and click Yes to confirm.
If soft power operations are configured for the virtual machine in Workstation Player, Suspend Guest
appears in the menu instead of Suspend.
Workstation Player returns the virtual machine to the library in the Suspended state.

u

To resume a suspended virtual machine, select the virtual machine and select Virtual Machine >
Power > Play Virtual Machine.

u

To set the Workstation Player preferences to suspend the virtual machine when you close the virtual
machine window, select Player > File > Preferences and then select Suspend the virtual machine.

Reset a Virtual Machine in Workstation Player
You can reset a virtual machine in Workstation Player. Resetting a virtual machine causes it to abruptly
power off and restart.
Prerequisites
n

Power on the virtual machine.

n

Verify that the virtual machine is in a safe state. Resetting a virtual machine can damage data. When
possible, shut down the virtual machine with its operating system.

Procedure
u

Select Virtual Machine > Power > Reset.
If soft power operations are configured for the virtual machine in Workstation, Reset Guest appears
in the menu instead of Reset.

Enable Autologon in a Windows Virtual Machine
With Autologon, you can save your login credentials and bypass the login dialog box when you power on
a Windows virtual machine. The guest operating system securely stores the password.
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Use the Autologon feature if you restart the guest operating system frequently and want to avoid entering
your login credentials. You can also use the Autologon feature to grant users access to the guest
operating system without sharing your password.
Prerequisites
n

Verify that the guest operating system is Windows 2000 or later.

n

Verify that you have an existing user account to enable Autologon. The account must be a local
machine account, not a domain account.

n

Verify that the latest version of VMware Tools is running in the guest operating system.

n

Power on the virtual machine.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select Autologon.

3

Click Enable, type your login credentials, and click OK.
If you type an incorrect or expired password, you must type your login credentials when you power on
the virtual machine.

4

Click OK to save your changes.
When you enable Autologon or change your login credentials, the Autologon settings are saved
immediately. Clicking Cancel in the Virtual Machine Settings dialog box does not affect the changes
applied to the Autologon settings.

Set Workstation Player Preferences for Virtual Machine
Closing Behavior
You can configure how virtual machines behave when you close them.
Procedure

1

Select File > Preferences.

2

Select how Workstation Player behaves when you close a virtual machine.
You can select one, both, or neither option.
Option

Description

Confirm before closing a virtual
machine

Confirm whether you intend to exit Workstation Player or click Cancel to continue
using Workstation Player

Return to the VM Library after closing
a virtual machine

Workstation Player either suspends or powers off the virtual machine and returns it
to the virtual machine library. From the library, you can either open another virtual
machine or edit the virtual machine settings.
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3

4

Select whether Workstation Player suspends or powers off a virtual machine when you close it.
Option

Description

Suspend the virtual machine

Workstation Player suspends the virtual machine. The next time you start
Workstation Player, the virtual machine resumes operation from the point where it
was suspended.

Power off the virtual machine

Workstation Player powers off the virtual machine. The next time you start
Workstation Player, the virtual machine starts from a powered-off state and the
guest operating system starts.

Click OK to save your changes.
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7

You can change the way Workstation Player displays virtual machines and virtual machine applications.
You can use full screen mode to make the virtual machine display fill the screen and use multiple
monitors.
This chapter includes the following topics:
n

Configure Display Settings for a Virtual Machine

n

Use Full Screen Mode in Workstation Player

n

Use Multiple Monitors for One Virtual Machine

Configure Display Settings for a Virtual Machine
You can specify monitor resolution settings, configure multiple monitors, and select accelerated graphics
capabilities for a virtual machine. You can use the multiple-monitor feature when the virtual machine is in
full screen mode.
For Windows guests, to use DirectX 9 accelerated graphics, the guest operating system must be
Windows XP or later. To use DirectX 10 accelerated graphics, the guest operating system must be
Windows Vista or later. To use DirectX 10.1 accelerated graphics, the guest operating system must be
Windows 7 or later.
Prerequisites
n

Verify that the latest version of VMware Tools is installed in the guest operating system.

n

Verify that the guest operating system in the virtual machine is Windows XP or later, or Linux.

n

If you plan to use DirectX 9, DirectX 10, or DirectX 10.1 accelerated graphics, prepare the host
system. See Prepare the Host System to Use 3D Accelerated Graphics.

n

If you are using Windows 8.1 (Update 2) or Windows 10, Workstation Player detects the DPI on each
monitor and scales the virtual machine to match the DPI on the host.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Display.
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3

(Optional) To run applications that use DirectX 9, DirectX 10, or DirectX 10.1 accelerated graphics,
select Accelerate 3D graphics.

4

Specify whether host settings determine the number of monitors.

5

Option

Description

Use host setting for monitors

When you select this setting, the SVGA driver uses a maximum bounding box
width of 7680 and a maximum bounding box height of 4320. The virtual machine
uses the number of monitors on the host system. The guest monitors cannot
exceed the maximum bounding box that the SVGA driver uses, 7680x4320. You
should select this setting in most cases.

Specify monitor settings

Set the number of monitors that the virtual machine will see, regardless of the
number of monitors on the host system. This setting is useful if you use a
multimonitor host system and you need to test in a virtual machine that has only
one monitor. It is also useful if you are developing a multimonitor application in a
virtual machine and the host system has only one monitor. After you power on the
virtual machine, the guest operating system sees the number of monitors that you
specified. Select a resolution from the list or type a setting that has the format width
x height, where width and height are the number of pixels.

(Optional) Select the maximum amount of guest memory that can be used for graphics memory using
the drop-down menu. The default value of video memory varies by guest OS.
Guest OS

Default

Windows 7 and later

1 GB

Windows XP and earlier

512 MB

Linux

768 MB

Note If you manually edited the .vmx file to change the memory size for the virtual machine, the
value you entered in the .vmx file is displayed, labeled Custom.
6

Click OK to save your changes.

Use Full Screen Mode in Workstation Player
In full screen mode, the virtual machine display fills the screen, so that you cannot see the borders of the
Workstation Player window.
Prerequisites
n

Power on the virtual machine.

n

Verify that the guest operating system display mode is larger than the host system display mode. If
the guest operating system display mode is smaller than the host system display mode, you might not
be able to enter full screen mode. If you cannot enter full screen mode, add the line
mks.maxRefreshRate=1000 to the virtual machine configuration (.vmx) file.

n

Verify that the latest version of VMware Tools is installed in the guest operating system.
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n

If you are running the virtual machine in full screen mode on a laptop, configure the guest operating
system to report battery information. See Report Battery Information in the Guest.

Procedure
u

To enter full screen mode, select the virtual machine and select Virtual Machine > Enter Full
Screen.

u

To hide the full screen toolbar and menus while you are using full screen mode, click the push pin
icon and move the pointer off of the toolbar.
This action unpins the toolbar. The toolbar slides up to the top of the monitor and disappears. To
display the toolbar again, point to the top of the screen until the toolbar appears.

u

To exit full screen mode and return to windowed mode, select Virtual Machine > Exit Full Screen
from the full screen toolbar.

Report Battery Information in the Guest
If you run a virtual machine on a laptop in full screen mode, configure the option to report battery
information in the guest so that you can determine when the battery is running low.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select Power.

3

Select Report battery information to guest.

4

Click OK to save your changes.

Use Multiple Monitors for One Virtual Machine
If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors.
You can use the multiple-monitor feature when the virtual machine is in full screen mode.
Note You do not need to use the Windows display properties settings in a Windows guest operating
system to configure multiple monitors.
Prerequisites
n

Verify that the virtual machine is a Workstation 6.x or later virtual machine.

n

Verify that the latest version of VMware Tools is installed in the guest operating system.

n

Verify that the Windows or Linux guest operating system is supported.
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Procedure

1

Select the virtual machine and select View > Autosize > Autofit Guest to verify that the virtual
machine can resize correctly.

2

Power on the virtual machine and select View > Full Screen.

3

On the full screen toolbar, click the Cycle Multiple Monitors button.
On a Windows host, you can mouse over a button on the toolbar to see its name. The guest
operating system desktop extends to the additional monitor or monitors.

4

(Optional) Click the Cycle Multiple Monitors button again if the host system has more than two
monitors and you want the virtual machine to use all of the monitors.
The order in which the virtual machine uses the monitors depends on the order in which the monitors
were added to the host operating system. If you continue to click the button, you return to fewer
monitors.

Limitations for Multiple Monitors
The use of more than two monitors with a virtual machine has certain limitations.
n

If you attempt to use more than two monitors with a virtual machine, your virtual machine must
support more than two monitors for this feature to function.

n

More than two monitors is supported on Windows and Linux host and guest operating systems.

n

Windows XP guests support more than three monitors. However, only three monitors can be in use
by a Windows XP guest at one time. If more than three monitors are connected to a Windows XP
guest, use the Cycle multiple monitors button to cycle through the monitors to the configuration you
want to use.
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8

You can connect and disconnect removable devices in a virtual machine. You can also print from a virtual
machine to any printer available to the host computer without having to install additional drivers in the
virtual machine.
This chapter includes the following topics:
n

Use a Removable Device in a Virtual Machine

n

Connecting USB Devices to Virtual Machines

n

Enabling a Virtual Machine to Print to Host Printers

n

Using Smart Cards in Virtual Machines

Use a Removable Device in a Virtual Machine
You can connect and disconnect removable devices in a virtual machine. You can also change the
settings for a removable device by modifying virtual machine settings.
Prerequisites
n

Power on the virtual machine.

n

If you are connecting or disconnecting a USB device, familiarize yourself with the way Workstation
Player handles USB devices. See Connecting USB Devices to Virtual Machines.

Procedure
u

To connect a removable device, select the virtual machine, select Virtual Machine > Removable
Devices, select the device, and select Connect.
If the device is connected to the host system through a USB hub, the virtual machine sees only the
USB device, not the hub.
A check mark appears next to the name of the device when the device is connected to the virtual
machine and a device icon appears on the virtual machine taskbar.

u

To change the settings for a removable device, select Virtual Machine > Removable Devices, select
the device, and select Settings.
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u

To disconnect a removable device, select the virtual machine, select Virtual Machine > Removable
Devices, select the device, and select Disconnect.
You can also disconnect the device by clicking or right-clicking the device icon on the virtual machine
taskbar. Using the taskbar icon is especially useful if you run the virtual machine in full screen mode.

Connecting USB Devices to Virtual Machines
When a virtual machine is running, its window is the active window. If you plug a USB device into the host
system, the device connects to the virtual machine instead of the host by default. If a USB device
connected to the host system does not connect to a virtual machine at power on, you must manually
connect the device to the virtual machine.
When you connect a USB device to a virtual machine, Workstation Player retains the connection to the
affected port on the host system. You can suspend or power off the virtual machine, or unplug the device.
When you plug in the device again or resume the virtual machine, Workstation Player reconnects the
device. Workstation Player retains the connection by writing an autoconnect entry to the virtual machine
configuration (.vmx) file.
If Workstation Player cannot reconnect to the device, for example, because you disconnected the device,
the device is removed and Workstation Player displays a message to indicate that it cannot connect to the
device. If the device is still available, you can connect to it manually. To connect a USB device to the
virtual machine manually, select Virtual Machine > Removable Devices > Device Name > Connect
(Disconnect from host).
Follow the device manufacturer's procedures for unplugging the device from the host computer when you
physically unplug the device, move the device from the host system to a virtual machine, or move the
device from a virtual machine to the host computer. Following these procedures is especially important for
data storage devices, such as zip drives. If you move a data storage device too soon after saving a file
and the operating system did not actually write the data to the disk, you can lose data.

Disable Automatic Connection of USB Devices
You can disable the autoconnect feature if you do not want USB devices to connect to a virtual machine
when you power it on.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select USB Controller.

3

Deselect Automatically connect new USB devices to disable automatic connection of USB
devices.

4

Click OK to save your changes.
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Connect USB HIDs to a Virtual Machine
To connect USB human interface devices (HIDs) to a virtual machine, you must configure the virtual
machine to show all USB input devices in the Removable Devices menu.
By default, USB HIDs, such as USB 1.1 and 2.0 mouse and keyboard devices, do not appear in the
Removable Devices menu in a virtual machine, even though they are plugged in to USB ports on the
host system.
An HID that is connected to a virtual machine is not available to the host system.
Prerequisites
n

Power off the virtual machine.

n

If you are using a KVM switch for a mouse or keyboard, disable automatic connection of USB
devices. See Disable Automatic Connection of USB Devices.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select USB Controller.

3

Select Show all USB input devices.
This option allows users to use special USB HIDs inside the virtual machine.

4

Click OK to save your changes.

5

Power on the virtual machine.
HIDs appear in the Removable Devices menu.

Install a PDA Driver and Synchronize With a Virtual Machine
To install a PDA driver in a virtual machine, you must synchronize the PDA with the virtual machine.
Procedure

1

Connect the PDA to the host system and synchronize it with the host system.
The PDA driver should begin installing in the virtual machine.

2

Allow the virtual machine to install the PDA driver.

3

If connection warning messages appear, dismiss them.

4

If the PDA disconnects from the host system before the virtual machine can synchronize with it,
synchronize the PDA with the host system again.
The total time required to load the VMware USB device driver in the host system and install the PDA
driver in the virtual machine might exceed the device connection timeout value. A second
synchronization attempt usually succeeds.
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Troubleshooting USB Device Control Sharing
Only the host system or the virtual machine can have control of a particular USB device at any one time.
Device control operates differently, depending on whether the host system is a Linux or a Windows
computer.
When you connect a device to a virtual machine, it is disconnected from the host system or from the
virtual machine that previously had control of the device. When you disconnect a device from a virtual
machine, it is returned to the host system.
Under some circumstances, if a USB storage device is in use on the host system, for example, one or
more files stored on the device are open on the host, an error appears in the virtual machine when you try
to connect to the device. You must let the host system complete its operation or close any application
connected to the device on the host system and connect to the device in the virtual machine again.

Troubleshoot USB Device Control Issues on a Linux Host
You have problems connecting or disconnecting USB devices on a Linux host system.
Problem

You are prompted to disconnect the driver on the host system when you connect a USB device to the
virtual machine or disconnecting the device fails.
Cause

On Linux host systems, guest operating systems can use devices that are not claimed by a host
operating system driver. A related issue sometimes affects devices that rely on automatic connection,
such as PDAs. Occasionally, even if you successfully use autoconnection to connect the device to the
virtual machine, you might experience problems with the connection to the device.
Solution

1

If you have problems with autoconnection, perform these steps.
a

Select the virtual machine and select Virtual Machine > Removable Devices to disconnect and
reconnect the device.

b

If the problem persists, unplug the device and plug it in again.

c

If a warning message indicates that the device is in use, disable the device in the hotplug
configuration files in the /etc/hotplug directory.
The documentation for the Linux distribution contains information on editing these configuration
files.
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2

If disconnection fails, either disable the driver or unload the driver manually.
Option

Description

Disable the driver

If the driver was automatically loaded by hotplug, disable it in the hotplug
configuration files in the /etc/hotplug directory. See the documentation for your
Linux distribution for information on editing these configuration files.

Unload the driver manually

Become root (su -) and use the rmmod command.

Enabling a Virtual Machine to Print to Host Printers
VMware Virtual Printer is a technology that allows you to print from a virtual machine to any printer
available to the host machine without having to install additional drivers in the virtual machine. When you
enable VMware Virtual Printer, Workstation Player configures a virtual serial port to communicate with the
host printers.
Starting with version 15 of Workstation Player, the version of VMware Tools downloaded from the
VMware software update server no longer delivers VMware Virtual Printer functionality. You must install
the VMware Virtual Printer application separately in the guest operating system to make the printers on
the host visible in the virtual machine.
Before you install VMware Virtual Printer on a virtual machine, you must add a virtual printer device to the
virtual machine.

Add a Virtual Printer to a Virtual Machine
To enable a virtual machine to print to any printer available to the host machine, you need to add a virtual
printer device to the virtual machine, if one is not already present. When you add a virtual printer to the
virtual machine, Workstation Player configures a virtual serial port with the virtual machine to
communicate with the host printers.
Prerequisites
n

The virtual machine must be powered on or off. You cannot add a printer to a virtual machine in a
powered on or suspended state.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Add.

3

In the Add Hardware wizard, select Printer and Finish.
The default device setting is to connect the virtual machine printer when the virtual machine is
powered on.

What to do next

Install the VMware Virtual Printer application in the virtual machine. See Install VMware Virtual Printer
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Install VMware Virtual Printer
To allow a supported virtual machine to print to any printer available to the host machine, install the
VMware Virtual Printer application on the virtual machine.
The VMware Virtual Printer application is packaged as an image that you can mount in the CD/DVD drive
of the guest operating system for installation.
The following guest operating systems support VMware Virtual Printer.
n

Windows 7 and later

n

Debian-based and RPM-based Linux distributions

Prerequisites

To install VMware Virtual Printer application in the guest operating system, perform the following
prerequisites.
n

Upgrade to or install VMware Tools 10.3.x or later, if not already installed. See Chapter 5 Installing
and Upgrading VMware Tools

n

Add a virtual printer device to the virtual machine, if one is not present already. See Add a Virtual
Printer to a Virtual Machine .

n

Add a CD/DVD drive to the virtual machine, if one is not present already installed. See Add a DVD or
CD-ROM Drive to a Virtual Machine

Procedure

1

Power on the virtual machine.

2

To mount the VMware Virtual Printer application in the CD/DVD drive of the guest, select Virtual
Machine > Install Virtual Printer.

3

Install VMware Virtual Printer using the method appropriate for the guest.
n

Windows Guest
n

n

Double-click the Virtual-Printer-version-build.exe file and complete the VMware Virtual
Printer Setup Wizard as guided.

Linux Guest
On Linux guests, install VMware Virtual Printer on the virtual machine using a .deb or .rpm
installer package.
The .deb packages are for Debian-based Linux distributions, such as Debian and Ubuntu, and
are in the top directory in the CD/DVD drive.
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The .rpm packages are for RPM-based Linux distributions, such as Red Hat, SUSE, and Fedora,
and are divided into folders on the CD/DVD drive. Each folder is specific to a Linux-distribution
type and bitness combination. The .x86_64.rpm package is for 64-bit Linux guests.
The .i386.rpm package is for 32-bit Linux guests.
a

Open a terminal window and change directories to the CD/DVD drive for a .deb package or
continue to a specific folder for a .rpm package.

b

c

Run the appropriate command for the guest.
DEB package command for 64-bit guests

sudo dpkg -i thinprint_version-revision_amd64.deb

DEB package command for 32-bit guests

sudo dpkg -i thinprint_version-revision_i386.deb

RPM package command for 64-bit guests

Rpm -ivh thinprint_version-revision.x86_64.rpm

RPM package command for 32-bit guests

Rpm -ivh thinprint_version-revision.i386.rpm

To verify that VMware Virtual Printer installed successfully, run the appropriate commands. If
the Thinprint service is listed as active, VMware Virtual Printer is installed and running.
DEB package commands for 32-bit and 64-bit guests

Command to check the status of VMware Virtual Printer.
service thinprint status

Command to list the installed package.
dpkg -l thinprint

RPM package commands for 32-bit and 64-bit guests

Command to check the status of VMware Virtual Printer.
service thinprint status

Command for information about the installed package.
rpm -q --info thinprint

The host printers appear on the printer list in the guest.
What to do next
n

In the guest, print a test page to a printer you just configured to confirm that VMware Virtual Printer
works as expected.

n

When you upgrade Workstation Player in the future, to ensure that a guest has the latest version of
VMware Virtual Printer, uninstall and reinstall VMware Virtual Printer. See Uninstall VMware Virtual
Printer

Uninstall VMware Virtual Printer
When you upgrade Workstation Player, to confirm that the latest version of VMware Virtual Printer is
installed on a guest operating system, you can uninstall and reinstall VMware Virtual Printer.
Procedure
u

Use the appropriate uninstallation method based on the operating system of the guest.
n

Windows guest
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Use the Windows uninstall feature to uninstall the VMware Virtual Printer application. For
example, for Windows 10, perform the following steps.

n

a

Select Start > Windows System > Control Panel.

b

Click Uninstall a program.

c

Select VMware Virtual Printer.

d

Click Uninstall.

Debian-based Linux guest, such as Debian and Ubuntu
In a terminal window, run either of the following commands.

n

n

sudo apt-get purge thinprint

n

sudo dpkg -P thinprint

RPM-based Linux guest, such as Red Hat, SUSE, and Fedora
In a terminal window, run the following command.
n

rpm -e thinprint

The VMware Virtual Printer is no longer installed on the guest.
What to do next

Install VMware Virtual Printer again. See Install VMware Virtual Printer.

Using Smart Cards in Virtual Machines
Virtual machines can connect to smart card readers that interface to serial ports, parallel ports, USB
ports, PCMCIA slots, and PCI slots. A virtual machine considers a smart card reader to be a type of USB
device.
A smart card is a plastic card that has an embedded computer chip. Many government agencies and
large enterprises use smart cards to send secure communication, digitally sign documents, and
authenticate users who access their computer networks. Users plug a smart card reader into their
computer and insert their smart card in the reader. They are then prompted for their PIN to log in.
You can select a smart card reader from the Removable Devices menu in a virtual machine. A smart
card can be shared between virtual machines, or between the host system and one or more virtual
machines. Sharing is enabled by default.
When you plug a smart card reader into the host system, the reader appears as two separate USB
devices in Workstation Player. This is because you can use smart cards in one of two mutually exclusive
modes.
Shared mode
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and Windows 7 guest operating systems, the generic smart card reader
device name appears under the Windows Device Manager list. The smart
card reader can be shared among applications on the host system and
among applications in different guest operating systems.
USB passthrough mode

The smart card reader device is available as smart_card_reader_model in
the Removable Devices menu. In USB passthrough mode, a single virtual
machine directly controls the physical smart card reader. A USB
passthrough smart card reader cannot be used by applications on the host
system or by applications in other virtual machines. You should use USB
passthrough mode only if connection in shared mode does not work well for
your scenario. You might need to install the driver provided by the
manufacturer to use USB passthrough mode.

You can use smart cards with Windows operating systems and most Linux distributions. VMware provides
full smart card support for Windows virtual machines running on Linux hosts. Using smart cards in Linux
typically requires third-party software to effectively authenticate to a domain or enable secure
communications.
Note Although smart cards should work with common Linux browsers, email applications, and directory
services, these products have not been tested or certified by VMware.

Use a Smart Card in a Virtual Machine
You can configure a virtual machine to use the smart card reader on the host system.
Prerequisites
n

On a Linux host, verify that the libpcsclite library is installed and that the pcscd daemon is
running.

n

Verify that the virtual machine has a USB controller. A USB controller is required, regardless of
whether the smart card reader is a USB device. A USB controller is added by default when you create
a virtual machine.

n

Connect the smart card reader to the host system.

n

Start the virtual machine

Procedure
u

To connect the smart card reader to the virtual machine, select the virtual machine and select Virtual
Machine > Removable Devices > Shared <smart_card_reader_model> > Connect.
If the smart card reader is a USB device, two items appear for it in the menu. Both items use the
model name of the reader, but one item name begins with Virtual.

u

To disconnect the smart card reader from the virtual machine, select Virtual Machine > Removable
Devices > Shared <smart_card_reader_model> > Disconnect.
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u

To remove the smart card from the virtual machine, select Virtual Machine > Removable Devices >
Shared <smart_card_reader_model> > Remove Smart Card.
The smart card is removed from the virtual machine, but it remains connected on the host system. If
the smart card is physically removed from the smart card reader, this option is disabled.

u

To insert the smart card to the virtual machine, select Virtual Machine > Removable Devices >
Shared <smart_card_reader_model> > Insert Smart Card.
If the smart card is physically inserted in the smart card reader, the smart card is also inserted in the
virtual machine.

Disable Smart Card Sharing
By default, you can share a smart card between virtual machines or between the host system and one or
more virtual machines. You might want to disable smart card sharing if you are using a PCMCIA smart
card reader, deploying virtual machines for enterprise use and do not want to support drivers for various
smart card readers, or the host system has drivers but the virtual machines do not.
The setting that controls smart card sharing is located in the Workstation Player global configuration file.
Procedure

1

2

Find the global configuration file on the host system.
Operating System

Location

Linux hosts

/etc/vmware/config

If the global configuration file does not yet exist on the host system, select File > Preferences and
change at least one Workstation Player preference setting.
Workstation Player creates the global configuration file when you change Workstation Player
preference settings.

3

Open the global configuration file in a text editor and set the usb.ccid.useSharedMode property to
FALSE.
For example: usb.ccid.useSharedMode = "FALSE"

4

Save and close the global configuration file.

5

Set permissions on the global configuration file so that other users cannot change it.

Switch to a Virtual Smart Card Reader on a Linux Host
Because of the way smart card reader functionality is implemented on Linux hosts, you must exit
Workstation Player and restart the pcscd daemon on the host system before you can switch from the nonvirtual smart card reader to the virtual smart card reader.
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Procedure

1

Select the virtual machine, select Virtual Machine > Removable Devices, select the smart card
reader, and select Disconnect.

2

Power off the virtual machine and exit Workstation Player.

3

Physically disconnect the smart card reader from the host system.

4

Restart the pcscd daemon on the host system.

5

Physically connect the smart card reader to the host system.

6

Start Workstation Player and start the virtual machine.

7

Select the virtual machine, select Virtual Machine > Removable Devices, select the smart card
reader, and select Connect.
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9

You can set up shared folders for a virtual machine. Shared folders provide an easy way to share files
among virtual machines and between virtual machines and the host system.
The directories that you add as shared folders can be located on the host system, or they can be located
on network directories that are accessible from the host system. Access to shared folders is governed by
permission settings on the host system. For example, if you are running Workstation Player as a user
named User, the virtual machine can read and write files in the shared folder only if User has permission
to read and write the files.
To use shared folders, the guest operating system must have the current version of VMware Tools and
must support shared folders.
Important Shared folders expose your files to programs in the virtual machine and might put your data
at risk. Only enable shared folders if you trust the virtual machine with your data.
This chapter includes the following topics:
n

Using Shared Folders

n

Enable a Shared Folder for a Virtual Machine

n

View Shared Folders in a Windows Guest

n

Mounting Shared Folders in a Linux Guest

n

Change Shared Folder Properties

n

Change the Folders That a Virtual Machine Can Share

n

Disable Folder Sharing for a Virtual Machine

n

Mapping a Virtual Disk to the Host System
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Using Shared Folders
You can use shared folders to share files among virtual machines and between virtual machines and the
host system. The directories that you add as shared folders can be on the host system, or they can be
network directories that are accessible from the host computer.
Important You cannot open a file in a shared folder from more than one application at a time. For
example, do not open the same file in an application on the host operating system and in another
application in the guest operating system. If one of the applications writes to the file, data might be
corrupted.

Guest Operating Systems That Support Shared Folders
To use shared folders, a virtual machine must have a supported guest operating system.
The following guest operating systems support shared folders.
n

Windows Server 2003 R2

n

Windows Server 2008 R2

n

Windows Server 2012 R2

n

Windows Server 2016

n

Windows Vista

n

Windows 7

n

Windows 8

n

Windows 10

n

Linux with a kernel version of 2.6 or later

n

Solaris x86 10

n

Solaris x86 10 Update 1 and later

Using Permissions to Restrict Access to Shared Files in a Linux
Guest
You can use permissions to restrict access to the files in a shared folder on a Linux guest operating
system.
On a Linux host, if you create files that you want to share with a Linux guest operating system, the file
permissions shown on the guest operating system are the same as the permissions on the host system.
You can use the fmask and dmask commands to mask permissions bits for files and directories.
If you create files on a Windows host system that you want to share with a Linux guest operating system,
read-only files are displayed as having read and execute permission for everyone and other files are
shown as fully writable by everyone.
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If you use a Linux guest operating system to create files for which you want to restrict permissions, use
the mount program with the following options in the guest operating system.
n

uid

n

gid

n

fmask

n

dmask

n

ro (read only)

n

rw (read-write)

rw is the default.

If you are using a virtual machine that was created with the Windows version of Workstation Player, or a
previous release of the Linux version of Workstation Player, you can change the owner permissions only.

Enable a Shared Folder for a Virtual Machine
You can enable folder sharing for a specific virtual machine. To set up a folder for sharing between virtual
machines, you must configure each virtual machine to use the same directory on the host system or
network share.
Prerequisites
n

Verify that the virtual machines use a guest operating system that supports shared folders. See Guest
Operating Systems That Support Shared Folders.

n

Verify that the latest version of VMware Tools is installed in the guest operating system.

n

Verify that permission settings on the host system allow access to files in the shared folders. For
example, if you are running Workstation Player as a user named User, the virtual machine can read
and write files in the shared folder only if User has permission to read and write them.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select Shared Folders.

3

Select a folder sharing option.
Option

Description

Always enabled

Keep folder sharing enabled, even when the virtual machine is shut down,
suspended, or powered off.

Enabled until next power off or
suspend

Enable folder sharing temporarily, until you power off, suspend, or shut down the
virtual machine. If you restart the virtual machine, shared folders remain enabled.
This setting is available only when the virtual machine is powered on.
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4

(Optional) To map a drive to the Shared Folders directory, select Map as a network drive in
Windows guests.
This directory contains all of the shared folders that you enable. Workstation Player selects the drive
letter.

5

Click Add to add a shared folder.
On Linux hosts, the Shared Folder Properties dialog box opens.

6

Browse to, or type, the path on the host system to the directory to share.
If you specify a directory on a network share, such as D:\share, Workstation Player always attempts
to use that path. If the directory is later connected to the host on a different drive letter, Workstation
Player cannot locate the shared folder.

7

Specify the name of the shared folder as it should appear inside the virtual machine and click Next.
Characters that the guest operating system considers illegal in a share name appear differently when
viewed inside the guest. For example, if you use an asterisk in a share name, you see %002A instead
of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal
value.

8

9

Select shared folder attributes.
Option

Description

Enable this share

Enable the shared folder. Deselect this option to disable a shared folder without
deleting it from the virtual machine configuration.

Read-only

Make the shared folder read-only. When this property is selected, the virtual
machine can view and copy files from the shared folder, but it cannot add, change,
or remove files. Access to files in the shared folder is also governed by permission
settings on the host computer.

Click Finish to add the shared folder.
The shared folder appears in the Folders list. The check box next to folder name indicates that the
folder is being shared. You can deselect this check box to disable sharing for the folder.

10 Click OK to save your changes.
What to do next

View the shared folder. On Linux guests, shared folders appear under /mnt/hgfs. On Solaris guests,
shared folders appear under /hgfs. To view shared folders on a Windows guest, see View Shared
Folders in a Windows Guest.

View Shared Folders in a Windows Guest
In a Windows guest operating system, you can view shared folders by using desktop icons.
Note If the guest operating system has VMware Tools from Workstation 4.0, shared folders appear as
folders on a designated drive letter.
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Procedure
u

Depending on the Windows operating system version, look for VMware Shared Folders in My
Network Places, Network Neighborhood, or Network.

u

If you mapped the shared folder as a network drive, open My Computer and look for Shared
Folders on 'vmware-host' under Network Drives.

u

To view a specific shared folder, go directly to the folder by using the UNC path \\vmware-host
\Shared Folders\shared_folder_name.

Mounting Shared Folders in a Linux Guest
After you enable a shared folder, you can mount one or more directories or subdirectories in the shared
folder to any location in the file system in addition to the default location of /mnt/hgfs.
Depending on the kernel version of the Linux guest operating system, VMware Tools uses different
components to provide shared-folder functionality. In Linux kernels prior to version 4.0, the VMware Tools
services script loads a driver that performs the mount. Linux kernels 4.0 and later use a FUSE file system
component.
You can use different mount commands to mount all shares, one share, or a subdirectory within a share
to any location in the file system. The commands also vary depending on the Linux-kernel version of the
guest.
Table 9-1. Mount Command Syntax
Linux Kernel Prior to 4.0

Linux Kernel 4.0 and Later

Description

mount -t vmhgfs .host:/ /home/user1/

/usr/bin/vmhgfs-fuse .host:/ /home/

shares

user1/shares -o subtype=vmhgfs-

Mounts all shares to /home/
user1/shares

fuse,allow_other
mount -t vmhgfs .host:/foo /tmp/foo

/usr/bin/vmhgfs-fuse .host:/
foo /tmp/foo -o subtype=vmhgfs-

Mounts the share named foo
to /tmp/foo

fuse,allow_other
mount -t vmhgfs .host:/foo/

/usr/bin/vmhgfs-fuse .host:/foo/

bar /var/lib/bar

bar /var/lib/bar -o subtype=vmhgfs-

Mounts the subdirectory bar within
the share foo to /var/lib/bar

fuse,allow_other

For Linux kernel prior to version 4.0, you can use VMware-specific options in addition to the standard
mount syntax. Enter the command /sbin/mount.vmhgfs -h to list the options.
For Linux kernel version 4.0 or later, enter the command /usr/bin/vmhgfs-fuse -h to list the available
options.
Note The mount can fail if shared folders are disabled or if the share does not exist. You are not
prompted to run the VMware Tools vmware-config-tools.pl configuration program again.

Change Shared Folder Properties
After you create a shared folder, you can change the folder name, the host path, and other attributes.
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Prerequisites

Create a shared folder. See Enable a Shared Folder for a Virtual Machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select Shared Folders.

3

Select the shared folder in the folders list and click Properties.

4

To change the name of the shared folder as it appears inside the virtual machine, type the new name
in the Name text box.
Characters that the guest operating system considers illegal in a share name appear differently when
viewed inside the guest. For example, if you use an asterisk in a share name, you see %002A instead
of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal
value.

5

To change the host path for the shared folder, browse to or type the new path in the Host path text
box.
If you specify a directory on a network share, such as D:\share, Workstation Player always attempts
to use that path. If the directory is later connected to the host on a different drive letter, Workstation
Player cannot locate the shared folder.

6

7

To change an attribute for the shared folder, select or deselect the attribute.
Option

Description

Enabled

Enable the shared folder. Deselect this option to disable a shared folder without
deleting it from the virtual machine configuration.

Read-only

Make the shared folder read-only. When this property is selected, the virtual
machine can view and copy files from the shared folder, but it cannot add, change,
or remove files. Access to files in the shared folder is also governed by permission
settings on the host computer.

Click OK to save your changes.

Change the Folders That a Virtual Machine Can Share
You can change the folders that a specific virtual machine is allowed to share.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select Shared Folders.

3

In the folders list, select the check boxes next to the folders to share and deselect the check boxes
next to the folders to disable.

4

Click OK to save your changes.
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Disable Folder Sharing for a Virtual Machine
You can disable folder sharing for a specific virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select Shared Folders.

3

Select Disabled to disable folder sharing.

4

Click OK to save your changes.

Mapping a Virtual Disk to the Host System
Instead of using shared folders or copying data between a virtual machine and the host system, you can
map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a
separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a
virtual machine.

Map or Mount a Virtual Disk to a Drive on the Host System
When you map a virtual disk and its associated volume to a drive on the host system, you can connect to
the virtual disk without opening a virtual machine.
After you map the virtual disk to a drive on the host system, you cannot power on any virtual machine that
uses the disk until you disconnect the disk from the host system.
Important If you mount a virtual disk that has a snapshot and then write to the disk, you can irreparably
damage a snapshot or linked clone created from the virtual machine. Note that Workstation Player does
not support taking snapshots or deleting them.
Mapping a virtual disk to a host system is not supported in the standalone version of Workstation Player.
Virtual disk mapping is supported in the Workstation Player version included with Workstation Pro.
Prerequisites
n

Power off all virtual machines that use the virtual disk.

n

Verify that the virtual disk (.vmdk) files on the virtual disk are not compressed and do not have readonly permissions.

n

Verify that the virtual disk is unencrypted. You cannot map or mount encrypted disks.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Hard Disk, click Utilities, and select Map.
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3

On a Linux host, select the Mount in read-only mode check box in the Mount Disk dialog box.
This setting prevents you from accidentally writing data to a virtual disk that might be the parent of a
snapshot or linked clone. Writing to such a disk might make the snapshot or linked clone unusable.

4

Browse to a virtual disk (.vmdk) file, select it, and click Open.

5

Select the volume to map or mount and select an unused drive letter on the host system.

6

Click OK or Mount.
The drive appears on the host system. You can read from or write to files on the mapped virtual disk
on the host system.

Disconnect a Virtual Disk from the Host System
To use a virtual disk from a virtual machine after it has been mapped or mounted on the host system, you
must disconnect it from the host system.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Hard Disk, click Utilities, and select Disconnect.

You can now power on any virtual machine that uses this disk.
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Virtual Machines

10

You can change virtual machine options, configure video and sound card settings, and move virtual
machines to another host system or to a different location on the same host system.
This chapter includes the following topics:
n

Change the Name of a Virtual Machine

n

Change the Guest Operating System for a Virtual Machine

n

Change the Working Directory for a Virtual Machine

n

Change the Virtual Machine Directory for a Virtual Machine

n

Change the Memory Allocation for a Virtual Machine

n

Configuring Video and Sound

n

Moving Virtual Machines

n

Configure a Virtual Machine as a VNC Server

n

Delete a Virtual Machine

n

View the Message Log for a Virtual Machine

n

Install New Software in a Virtual Machine

Change the Name of a Virtual Machine
When you run a virtual machine, its name appears in the title bar. Workstation Player uses the original
name of the virtual machine to name the directory where the virtual machine files are stored.
Changing the name of a virtual machine does not change the name of the virtual machine directory or
rename the virtual machine files on the host system.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select General.

3

Type the new name.

4

Click OK to save your changes.
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What to do next

When you restart the virtual machine the new name appears in the library.

Change the Guest Operating System for a Virtual Machine
If you upgrade the guest operating system that is installed in a virtual machine, or if you specify the wrong
operating system version when you create the virtual machine, you must change the guest operating
system type that is configured for the virtual machine.
When you change the operating system type, the virtual machine configuration (.vmx) file changes. The
guest operating system itself does not change. To upgrade the guest operating system, obtain the
appropriate software from the operating system vendor.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select General.

3

Select the new operating system and version.

4

Click OK to save your changes.

Change the Working Directory for a Virtual Machine
By default, the working directory and the virtual machine directory are the same. You might want to
change the working directory to improve performance. For example, to create a paging file on a fast disk
that has a lot of disk space but leave the virtual disk and configuration file on a different disk, you can
change the working directory so that it is located on the fast disk.
The working directory is where Workstation Player stores suspended state (.vmss), snapshot (.vmsn),
virtual machine paging (.vmem), and redo log files for a virtual machine.
Changing the working directory does not change the directory where the virtual machine configuration
(.vmx) file or the log files are stored.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Options tab, select General.

3

Type or browse to the location of the new working directory.

4

Click OK to save your changes.

VMware, Inc.

79

Using VMware Workstation Player for Linux

Change the Virtual Machine Directory for a Virtual
Machine
The virtual machine directory is where Workstation Player stores virtual machine files, including the virtual
machine configuration (.vmx) file. By default, the virtual machine directory and the working directory are
the same.
Prerequisites

Power off the virtual machine.
Procedure

1

In the host file system, rename the directory where the .vmx file is stored.

2

Select File > Open a Virtual Machine.

3

Browse to the new location of the .vmx file and click Open.

Change the Memory Allocation for a Virtual Machine
You can adjust the amount of memory that is allocated to a virtual machine.
On 64-bit hosts, the maximum amount of memory for each virtual machine is 32GB. On 32-bit hosts, the
maximum amount of memory for each virtual machine is 8GB. The total amount of memory that you can
assign to all virtual machines running on a single host system is limited only by the amount of RAM on the
host system.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Memory.
The Memory panel includes information to help you select the appropriate amount of memory for the
virtual machine. The high end of the range is determined by the amount of memory that is allocated to
all running virtual machines.

3

Align the slider with the corresponding icon to change the amount of memory.
The color-coded icons indicate the maximum recommended memory, the recommended memory, and
the guest operating system minimum memory amounts.

4

Click OK to save your changes.

5

Power on the virtual machine to implement the changes.
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Configuring Video and Sound
For best color and graphics display, coordinate host and guest operating system color settings.
Workstation Player supports games and applications that use DirectX 9 and DirectX 10 accelerated
graphics, but you must perform some 3D preparation tasks on the host and guest operating systems.
Workstation Player usually installs the necessary drivers for sound support, but you must manually install
a driver on some of the oldest and newest guest operating systems.
n

Setting Screen Color Depth
The number of screen colors available in the guest operating system depends on the screen color
setting of the host operating system.

n

Using Accelerated 3D Graphics
You must perform certain preparation tasks on the host system and on virtual machines to use
accelerated 3D graphics.

n

Configuring Sound
Workstation Player provides a sound device compatible with the Sound Blaster AudioPCI and
supports sound in Windows and Linux guest operating systems. The Workstation Player sound
device is enabled by default.

Setting Screen Color Depth
The number of screen colors available in the guest operating system depends on the screen color setting
of the host operating system.
Virtual machines support the following screen colors.
n

16-color (VGA) mode

n

8-bit pseudocolor

n

16 bits per pixel (16 significant bits per pixel)

n

32 bits per pixel (24 significant bits per pixel)

If the host operating system is in 15-bit color mode, the guest operating system color setting controls offer
15-bit mode in place of 16-bit mode. If the host operating system is in 24-bit color mode, the guest
operating system color setting controls offer 24-bit mode in place of 32-bit mode.
If you run a guest operating system set for a greater number of colors than the host operating system, the
colors in the guest operating system might not be correct or the guest operating system might not be able
to use a graphical interface. If these problems occur, you can either increase the number of colors in the
host operating system or decrease the number of colors in the guest operating system.
To change color settings on the host operating system, power off all virtual machines and close
Workstation Player and then follow standard procedures for changing color settings.
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How you change color settings in a guest operating system depends on the type of guest operating
system. In a Windows guest, the Display Properties control panel offers only those settings that are
supported. In a Linux or FreeBSD guest, you must change the color depth before you start the X server,
or you must restart the X server after making the changes.
For best performance, use the same number of colors in the host and guest operating systems.

Using Accelerated 3D Graphics
You must perform certain preparation tasks on the host system and on virtual machines to use
accelerated 3D graphics.
Support for applications that use DirectX 9 accelerated graphics applies only to Windows XP, Windows
Vista, and Windows 7 guests on hosts running Windows 7 or later, or Linux. OpenGL applications run in
software emulation mode.
Support for applications that use DirectX 10 accelerated graphics applies only to Windows 10.

Prepare the Host System to Use 3D Accelerated Graphics
You must perform certain preparation tasks on the Windows or Linux host system to use 3D accelerated
graphics in a virtual machine.
Prerequisites
n

Verify that the host has a video card that supports accelerated OpenGL 2.0 if you are using DirectX 9,
or OpenGL 3.3 if you are using DirectX 10 or DirectX 10.1.
The VMware guest operating system OpenGL driver for Windows and Linux supports the OpenGL
3.3 core profile only. The OpenGL3.3 compatibility profile is not supported.

Procedure

1

Upgrade the video drivers on the host system to the latest versions.
ATI Graphics drivers are available from the AMD Web site. NVIDIA drivers are available from the
NVIDIA Web site. Intel drivers are available from the Intel Web site.

2

Run commands to test the host for compatibility.
a

Verify that direct rendering is enabled.
glxinfo | grep direct

b

Verify that 3D applications work.
glxgears

Prepare a Virtual Machine to Use Accelerated 3D Graphics
You must perform certain preliminary tasks to use accelerated 3D graphics on a virtual machine.
The accelerated 3D graphics feature is enabled by default on Player 3.x and later virtual machines.
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Prerequisites
n

Prepare the host system to use accelerated 3D graphics. See Prepare the Host System to Use 3D
Accelerated Graphics.

n

If using DirectX 9, verify that the guest operating system is Windows XP or later. DirectX 9 is
supported on virtual machines running hardware version 11 or earlier.

n

If using DirectX 10, verify that the guest operating system is Windows 7 or later. DirectX 10 is
supported on virtual machines running hardware version 12 or later.

n

If using DirectX 10.1, verify that the guest operating system is Windows 7 or later. DirectX 10.1 is
supported on virtual machines running hardware version 16 or later.

n

Verify that the latest version of VMware Tools is installed in the guest operating system.

n

Power off the virtual machine. The virtual machine must not be suspended.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Display.

3

Select Accelerate 3D graphics.

4

Configure the virtual machine to use only one monitor.

5

Click OK to save your changes.

6

Power on the virtual machine and install the required DirectX EndRuntime version.
This download is available from the Microsoft Download Center.

7

Install and run your 3D applications.

Configuring Sound
Workstation Player provides a sound device compatible with the Sound Blaster AudioPCI and supports
sound in Windows and Linux guest operating systems. The Workstation Player sound device is enabled
by default.
Sound support includes pulse code modulation (PCM) output and input. For example, you can play .wav
files, MP3 audio, and Real Media audio. MIDI output from Windows guests is supported through the
Windows software synthesizer. MIDI input is not supported, and no MIDI support is available for Linux
guests.
Windows and most recent Linux distributions detect the sound device and install appropriate drivers for it.
A sound driver is installed when you install VMware Tools in a 64-bit Windows Vista or Windows 7 guest
operating system. For 32-bit Windows Vista, Windows 7, Windows 2003 Server, and Windows Server
2008 guests, you must use Windows Update to install a 32-bit driver.
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Configure Sound Card Settings
The VMware virtual sound device is compatible with a Creative Technology Sound Blaster Audio API. The
sound device supports sound in Windows and Linux guest operating systems.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Sound Card.

3

Configure one or more sound card settings.

4

Option

Description

Connected

Connects or disconnects the sound device while the virtual machine is running. You
can also use the Devices menu and select the drive to connect or disconnect.

Connect at power on

Automatically connects the sound device to the virtual machine when you power on
the virtual machine.

Use default host sound card

The virtual machine uses the default sound card in the host system.

Use physical sound card

Selects which sound card to use if you have more than one physical sound card on
the system.

Enable echo cancellation

Enables echo cancellation for the sound card.

Click OK to save your changes.

Moving Virtual Machines
You can move a virtual machine that was created in Workstation Player to a different host system or to a
different location on the same host system and connect to a virtual machine by using a VNC client.
n

Move a Virtual Machine to a New Location or New Host
You can move a virtual machine that is created in Workstation Player to a different host system or to
a different location on the same host system. You can move a virtual machine to a host system that
has a different operating system.

n

Configure a Virtual Machine for Compatibility
When you create a virtual machine that you intend to distribute to other users, you should configure
the virtual machine for maximum compatibility with all expected host systems. Users might be limited
in their ability to make changes in a virtual machine so that it is compatible with their host systems.

n

Using the Virtual Machine UUID
Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you
initially power on the virtual machine.
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Move a Virtual Machine to a New Location or New Host
You can move a virtual machine that is created in Workstation Player to a different host system or to a
different location on the same host system. You can move a virtual machine to a host system that has a
different operating system.
Moving a virtual machine typically involves moving the files that make up the virtual machine. The
pathnames for all files associated with a Workstation Player virtual machine are relative to the virtual
machine directory.
When you move a virtual machine, Workstation Player generates a new MAC address for the virtual
network adapter. Workstation Player also generates a new MAC address when you rename a directory in
the path to the virtual machine configuration (.vmx) file.
Prerequisites
n

Familiarize yourself with how Workstation Player generates UUIDs for moved virtual machines. See
Using the Virtual Machine UUID.

n

If you are moving the virtual machine to a different host system, familiarize yourself with the
limitations of moving a virtual machine to a new host. See Limitations of Moving a Virtual Machine to
a Different Host.

n

If you configured the working directory to reside in a different location on the host system, move files
from the working directory into the virtual machine directory and change the working directory to this
location.

n

Verify that virtual machine devices and any associated files point to locations that you can access
from the new location.

n

Verify that all virtual machine files are stored in the virtual machine directory. Some files might reside
outside of the virtual machine directory.

Procedure

1

Shut down the guest operating system and power off the virtual machine.

2

Copy the virtual machine files to the new location.

3

Verify that you copied all of the virtual machine files to the new location.

4

Open the virtual machine in Workstation Player

5

Option

Description

If you moved the virtual machine to a
different location on the same host
system

Remove the virtual machine from the library, select File > Open a Virtual
Machine, and browse to the .vmx file in its new location.

If you moved the virtual machine to a
different host system

Start Workstation Player on the new host system, select File > Open a Virtual
Machine, and browse to the .vmx file.

When you are certain that the virtual machine in the new location works correctly, delete the virtual
machine files from the original location.
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Limitations of Moving a Virtual Machine to a Different Host
You should be aware of certain limitations before you move a virtual machine to a different host system.
n

The guest operating system might not work correctly if you move a virtual machine to a host system
that has significantly different hardware, for example, if you move a virtual machine from a
multiprocessor host to a uniprocessor host.

n

Player 3.x and later virtual machines support up to eight-way virtual symmetric multiprocessing (SMP)
on multiprocessor host systems. Player 6.x and later virtual machines support up to sixteen-way
multiprocessing on multiprocessor host systems. You can assign up to 8 or 16 virtual processors to
virtual machines running on host systems that have at least two logical processors. If you attempt to
assign two processors to a virtual machine that is running on a uniprocessor host system, a warning
message appears. You can disregard this message and assign two processors to the virtual machine,
but you must move it to a host that has at least two logical processors before you can power it on.

Configure a Virtual Machine for Compatibility
When you create a virtual machine that you intend to distribute to other users, you should configure the
virtual machine for maximum compatibility with all expected host systems. Users might be limited in their
ability to make changes in a virtual machine so that it is compatible with their host systems.
Procedure
u

Install VMware Tools in the virtual machine.
VMware Tools significantly improves the user’s experience working with the virtual machine.

u

Determine which virtual devices are actually required, and do not include any that are not needed or
useful for the software you are distributing with the virtual machine.
Generic SCSI devices are typically not appropriate.

u

To connect a physical device to a virtual device, use the Auto detect options when you configure the
virtual machine.
The Auto detect options allow the virtual machine to adapt to the user’s system, and they work
whether the host operating system is Windows or Linux. Users who have no physical device receive a
warning message.

u

To connect a CD-ROM or floppy to an image file that you ship with the virtual machine, make sure the
image file is in the same directory as the virtual machine.
A relative path, rather than an absolute path, is used.

u

For both a physical CD-ROM and an image, provide two virtual CD-ROM devices in the virtual
machine.

u

Choose a reasonable amount of memory to allocate to the virtual machine.
For example, if the host system does not have enough physical memory to support the memory
allocation, the user cannot power on the virtual machine.
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u

Choose a reasonable screen resolution for the guest.
A user is likely to find it easier to increase the resolution manually than to deal with a display that
exceeds the user’s physical screen size.

Using the Virtual Machine UUID
Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you initially
power on the virtual machine.
You can use the UUID of a virtual machine for system management in the same way that you use the
UUID of a physical computer. The UUID is stored in the SMBIOS system information descriptor, and you
can access it by using standard SMBIOS scanning software, including SiSoftware Sandra or IBM
smbios2.
If you do not move or copy the virtual machine to another location, the UUID remains constant. When you
power on a virtual machine that was moved or copied to a new location, you are prompted to specify
whether you moved or copied the virtual machine. If you indicate that you copied the virtual machine, the
virtual machine receives a new UUID.
Suspending and resuming a virtual machine does not trigger the process that generates a UUID. The
UUID in use at the time the virtual machine was suspended remains in use when the virtual machine is
resumed, even if it was copied or moved. You are not prompted to specify whether you moved or copied
the virtual machine until the next time you reboot the virtual machine.

Configure a Virtual Machine to Keep the Same UUID
You can configure a virtual machine to always keep the same UUID, even when it is moved or copied.
When a virtual machine is set to always keep the same UUID, you are not prompted when a virtual
machine is moved or copied.
Prerequisites

Power off the virtual machine.
Procedure

1

Open the virtual machine configuration (.vmx) file in a text editor.

2

Add the uuid.action property and set it to keep.
For example: uuid.action = "keep"

Configure a Virtual Machine as a VNC Server
You can use Workstation Player to configure a virtual machine to act as a Virtual Network Computing
(VNC) server so that users on other computers can use a VNC client to connect to the virtual machine.
You do not need to install specialized VNC software in a virtual machine to set it up as a VNC server.
Note You cannot configure a shared or remote virtual machine as a VNC server.
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Procedure

1

Select the virtual machine and select VM > Settings.

2

On the Options tab, select VNC Connections and select Enable VNC.

3

(Optional) To allow VNC clients to connect to multiple virtual machines on the same host system,
specify a unique port number for each virtual machine.
Use should use a port number in the range from 5901 to 6001. Other applications use certain port
numbers, and some port numbers are privileged. For example, the VMware Management Interface
uses ports 8333 and 8222 and VMware Workstation Server uses port 443. On Linux, only the root
user can listen to ports up to port number 1024.

4

(Optional) Set a password for connecting to the virtual machine from a VNC client.
The password can be up to eight characters long. Because it is not encrypted when the VNC client
sends it, do not use a password that you use for other systems.

5

(Optional) Click View VNC Connections to see a list of the VNC clients that are remotely connected
to the virtual machine and find out how long they have been connected.

6

Click OK to save your changes.

What to do next

If you do not VNC clients use to use the US101 keyboard map (U.S. English) when they connect to the
virtual machine, specify a different language. See Specify a Language Keyboard Map for VNC Clients.

Specify a Language Keyboard Map for VNC Clients
If you set a virtual machine to act as a VNC server, you can specify which language to use for the
keyboard that VNC clients use. By default, the US101 keyboard map (U.S. English) is used.
Prerequisites
n

Verify that the virtual machine is set to act as a VNC server.

n

Determine the language code to use. See Language Codes.

Procedure

1

In a text editor, open the virtual machine configuration file (.vmx) file for the virtual machine and add
the RemoteDisplay.vnc.enabled and RemoteDisplay.vnc.port properties.
a

Set RemoteDisplay.vnc.enabled to TRUE.

b

Set RemoteDisplay.vnc.port to the port number to use.

For example:
RemoteDisplay.vnc.enabled = "TRUE"
RemoteDisplay.vnc.port = "portnumber"
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2

Determine the location of the keymap file to use.
Default keymap files are included in the Workstation Player installation directory.

Host System

Keymap File Location

Windows 7, Windows 8, and Windows 10 hosts

C:\ProgramData\VMware\vnckeymap

Linux host

/usr/lib/vmware/vnckeymap

3

In the virtual machine configuration (.vmx) file, add a property to specify the location of the keymap
file.
Option

Description

To use the default keymap file
included in the Workstation Player
installation directory

Add RemoteDisplay.vnc.keyMap = "xx", where xx is the code for the language

To use a keyboard map file in another
location

4

to use, such as jp for Japanese.

Add RemoteDisplay.vnc.keyMapFile = "filepath", where filepath is the
absolute file path.

Start the virtual machine and connect to it from a VNC client.

Language Codes
When you specify a language keyboard map for VNC clients, you must specify a language code.
Table 10-1. Language Codes
Code

Language

de

German

de-ch

German (Switzerland)

es

Spanish

fi

Finnish

fr

French

fr-be

French (Belgium)

fr-ch

French (Switzerland)

is

Icelandic

it

Italian

jp

Japanese

nl-be

Dutch (Belgium)

no

Norwegian

pt

Polish

uk

UK English

us

US English
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Use a VNC Client to Connect to a Virtual Machine
You can use a VNC client to connect to a running virtual machine. Because VNC software is crossplatform, you can use virtual machines running on different types of computers.
Workstation Player does not need to be running to use VNC to connect to a virtual machine. Only the
virtual machine needs to be running, and it can be running in the background.
When you use a VNC client to connect to a virtual machine, some features do not work or are not
available.
n

You cannot take or revert to snapshots.

n

You cannot power on, power off, suspend, or resume the virtual machine. You can shut down the
guest operating system. Shutting down might power off the virtual machine.

n

You cannot copy and paste text between the host system and the guest operating system.

n

You cannot change virtual machine settings.

n

Remote display does not work well if you are also using the 3D feature.

Prerequisites
n

Configure the virtual machine as a VNC server. See Configure a Virtual Machine as a VNC Server.

n

Determine the machine name or IP address of the host system on which the virtual machine is
running and, if required, the VNC port number and password.

Procedure

1

Install a VNC client on your computer.
Open-source versions of VNC are freely and publicly available. You can use any VNC client, but not a
Java viewer in a browser.

2

Start the VNC client on your computer.

3

Verify that the client is set for hextile encoding.
For example, if you use RealVNC Viewer, select Hextile under the Preferred Encoding option.

4

Set the VNC client to use all colors.
For example, if you use RealVNC Viewer, select Full (all available colours) under the Colour Level
option.

5

When prompted for the VNC server name, type the name or IP address and the port number of the
host system where the virtual machine is running.
For example: machine_name:port_number

6

Type a password if one is required.
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View VNC Connections for a Virtual Machine
When a virtual is configured to act as a VNC server, you can view a list of the VNC clients that are
remotely connected to the virtual machine and find out how long they have been connected.
Prerequisites

Configure the virtual machine to act as a VNC server. See Configure a Virtual Machine as a VNC Server.
Procedure
u

Select the virtual machine and select VM > Manage > VNC Connections.

Delete a Virtual Machine
You can delete a virtual machine and all of its files from the host file system.
Important Deleting a virtual machine is irreversible.
Prerequisites

Power off the virtual machine.
Procedure

1

Right-click the virtual machine in the library and select Delete VM from Disk.

2

Click Yes to delete the virtual machine.

The virtual machine and all of its files are removed from the host file system.

View the Message Log for a Virtual Machine
You can view the message log to review information about a particular virtual machine. Messages include
warning information about the virtual machine.
Procedure

1

Power on the virtual machine.

2

Select Help > Message Log.

3

Select a message in the message log to a see a detailed description of the message.

Install New Software in a Virtual Machine
Installing new software in a virtual machine is similar to installing new software on a physical computer.
Only a few additional steps are required.
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Prerequisites
n

Verify that VMware Tools is installed in the guest operating system. Installing VMware Tools before
installing the software minimizes the likelihood that you will have to reactivate the software if the
virtual machine configuration changes.

n

Verify that the virtual machine has access to the CD-ROM drive, ISO image file, or floppy drive where
the installation software is located.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Memory, set the final memory size for the virtual machine, and click
OK.
Some applications use a product activation feature that creates a key based on the virtual hardware
in the virtual machine where it is installed. Changes in the configuration of the virtual machine might
require you to reactivate the software. Setting the memory size minimizes the number of significant
changes.

3

Install the new software according to the manufacturer’s instructions.

Disable Acceleration if a Program Does Not Run
When you install or run software inside a virtual machine, Workstation Player might appear to stop
responding. This problem typically occurs early in the program's execution. In many cases, you can get
past the problem by temporarily disabling acceleration in the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Processors.

3

Select Disable acceleration for binary translation to disable acceleration.

4

Click OK to save your changes.

What to do next

After you pass the point where the program encountered problems, re-enable acceleration. Because
disabling acceleration slows down virtual machine performance, you should use it only for getting past the
problem with running the program
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Devices

11

You can use Workstation Player to add devices to virtual machines, including DVD and CD-ROM drives,
floppy drives, USB controllers, virtual and physical hard disks, parallel and serial ports, generic SCSI
devices, and processors. You can also modify settings for existing devices.
This chapter includes the following topics:
n

Configuring DVD, CD-ROM, and Floppy Drives

n

Configuring a USB Controller

n

Configuring and Maintaining Virtual Hard Disks

n

Configuring Virtual Ports

n

Configuring Generic SCSI Devices

n

Configuring Sixteen-Way Virtual Symmetric Multiprocessing

n

Configuring Keyboard Features

n

Modify Hardware Settings for a Virtual Machine

Configuring DVD, CD-ROM, and Floppy Drives
You can add up to four IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (four controllers
with 30 devices per controller) to a virtual machine. Any of these devices can be connected to a physical
or virtual CD-ROM or DVD device. CD-ROM and DVD devices cannot be connected to an NVMe
controller.
A virtual machine can read data from a DVD disc. Workstation Player does not support playing DVD
movies in a virtual machine. If you use a DVD player application that does not require video overlay
support in the video card, you might be able to play a movie.

Add a DVD or CD-ROM Drive to a Virtual Machine
You can add one or more DVD or CD-ROM drives to a virtual machine. You can connect the virtual DVD
or CD-ROM drive to a physical drive or an ISO image file.
You can configure the virtual DVD or CD-ROM drive as an IDE, SCSI, or SATA device, regardless of the
type of physical drive that you connect it to. For example, if the host has an IDE CD-ROM drive, you can
set up the virtual machine drive as either SCSI or IDE and connect it to the host drive.
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Do not configure legacy emulation mode unless you experience problems with normal mode. See
Configure Legacy Emulation Mode for a DVD or CD-ROM Drive for more information.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the Add Hardware wizard, select DVD/CD Drive.

4

Click Finish to add the drive to the virtual machine.

5

(Optional) To change which SCSI, IDE, or SATA device identifier to use for the drive, select the drive
and click Advanced.

6

Click OK to save your changes.

Add a Floppy Drive to a Virtual Machine
You can configure a virtual floppy drive to connect to a physical floppy drive or an existing or blank floppy
image file. You can add up to two floppy drives to a virtual machine.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the Add Hardware wizard, select Floppy Drive.

4

Click Finish to add the drive to the virtual machine.

5

Select the floppy media type.
Option

Description

Use a physical floppy drive

The virtual machine uses a physical floppy drive.

Use a floppy image

The drive connects to an floppy image (.flp) file.

Create a blank floppy image

The drive connects to a blank floppy image (.flp) file that you create.

6

If you selected the physical floppy drive media type, select a specific floppy drive or select Auto
detect to allow Workstation Player to auto-detect the drive to use.

7

If you selected the floppy image or blank floppy image media type, type the name or browse to the
location of a floppy image (.flp) file.

8

To connect the drive or floppy image file to the virtual machine when the virtual machine powers on,
select Connect at power on.

9

Click OK to save your changes.
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Configure Legacy Emulation Mode for a DVD or CD-ROM Drive
Use legacy emulation mode to work around direct communication problems between a guest operating
system and a DVD or CD-ROM drive.
In legacy emulation mode, you can read only from data discs in the DVD or CD-ROM drive. Legacy
emulation mode does not provide the other capabilities of normal mode. In normal mode, the guest
operating system communicates directly with the CD-ROM or DVD drive. This direct communication
enables you to read multisession CDs, perform digital audio extraction, view videos, and use CD and
DVD writers to burn discs.
If you run more than one virtual machine at a time, and if their CD-ROM drives are in legacy emulation
mode, you must start the virtual machines with their CD-ROM drives disconnected. By disconnecting the
CD-ROM drives in the virtual machines, you prevent multiple virtual machines from being connected to
the CD-ROM drive at the same time.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select the drive and click Advanced.

3

Select Legacy emulation and click OK.
On Linux hosts that have IDE drives, the default setting depends on whether the ide-scsi module is
loaded in the kernel. The ide-scsi module must be loaded, or you must use a physical SCSI drive,
to connect directly to the DVD or CD-ROM drive.

4

Click OK to save your changes.

Configuring a USB Controller
A virtual machine must have a USB controller to use USB devices and smart card readers. To use a
smart card reader, a virtual machine must have a USB controller regardless of whether the smart card
reader is actually a USB device.
Workstation Player provides a USB controller to support the following types of USB devices.
n

USB 1.1 UHCI (Universal Host Controller Interface) is supported for all virtual machine hardware
versions.

n

USB 2.0 EHCI (Enhanced Host Controller Interface) controllers are supported if the virtual machine
hardware is compatible with Workstation 6 and later virtual machines.

n

USB 3.0 xHCI (Extensible Host Controller Interface) support is available for Linux guests running
kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be
compatible with Workstation 8 or later virtual machines.

For USB 2.0 or 3.0 support, you must select USB 2.0 or 3.0 compatibility by configuring virtual machine
settings for the USB controller. USB 2.0 and 3.0 devices are high-speed devices that include the latest
models of USB flash drives, USB hard drives, iPods, and iPhone.
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If you select USB 2.0 compatibility, when a USB 2.0 device connects to a USB port on the host system,
the device connects to the EHCI controller and operates in USB 2.0 mode. A USB 1.1 device connects to
the UHCI controller and operates in USB 1.1 mode. If you enable USB 3.0, the xHCI controller can
support all USB devices, including USB 1.1, 2.0, and 3.0 devices.
Although the host operating system must support USB, you do not need to install device-specific drivers
for USB devices in the host operating system to use those devices only in the virtual machine. Linux
kernels earlier than 2.2.17 do not support USB.
VMware has tested a variety of USB devices. If the guest operating system has the appropriate drivers,
you can use many different USB devices, including PDAs, Smart phones, printers, storage devices,
scanners, MP3 players, digital cameras, memory card readers, and isochronous transfer devices, such as
webcams, speakers, and microphones.
You can connect USB human interface devices (HIDs), such as the keyboard and mouse, to a virtual
machine by enabling the Show all USB input devices option. If you do not select this option, these
devices do not appear in the Removable Devices menu and are not available to connect to the virtual
machine, even though they are plugged in to USB ports on the host system.
See Connect USB HIDs to a Virtual Machine for information on connecting HIDs.

Add a USB Controller to a Virtual Machine
A USB controller is required to use a USB device in a virtual machine. You can add one USB controller to
a virtual machine.
When you create a virtual machine in Workstation Player, a USB controller is added by default. If you
remove the USB controller, you can add it back.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the New Hardware wizard, select USB Controller.

4

Click Finish to add the USB controller.

5

Configure the USB connection settings.
You can select multiple settings.
Option

Description

USB Compatibility

Selecting USB 2.0 or 3.0 enables support for isochronous USB devices, including Web
cams, speakers, and microphones.

Automatically connect new
USB devices

Connect new USB devices to the virtual machine. If this setting is not selected, new USB
devices are connected only to the host system.

VMware, Inc.

96

Using VMware Workstation Player for Linux

Option

Description

Show all USB input devices

Human interface devices (HIDs), such as USB 1.1 and 2.0 mouse and keyboard devices,
appear in the Removable Devices menu. Icons for HIDs appear in the status bar. An HID
that is connected to the guest operating system is not available to the host system. The
virtual machine must be powered off when you change this setting.

Share Bluetooth devices
with the virtual machine

Enable support for Bluetooth devices.

Enable Support for Isochronous USB Devices
Modems and certain streaming data devices, such as speakers and webcams, do not work properly in a
virtual machine unless you enable support for isochronous USB devices.
Prerequisites
n

Verify that the guest operating system supports USB 2.0 devices or 3.0 devices.

n

On a Windows XP guest operating system, verify that the latest service pack is installed. If you use
Windows XP with no service packs, the driver for the EHCI controller cannot be loaded.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select USB Controller.

3

From the USB Compatibility list, select USB 2.0 or USB 3.0.

4

Option

Description

USB 2.0

Available if the virtual machine hardware is compatible with Workstation 6 and later
virtual machines.

USB 3.0

Available for Linux guests running kernel version 2.6.35 or later and for Windows 8
guests. The virtual machine hardware must be compatible with Workstation 8 and
later virtual machines.

Click OK to save your changes.

Configuring and Maintaining Virtual Hard Disks
You can use Workstation Player to configure virtual hard disk storage for virtual machines.
A virtual disk is a file or set of files that appears as a physical disk drive to a guest operating system. The
files can be on the host system or on a remote computer. When you configure a virtual machine to use a
virtual disk, you can install a new operating system onto the virtual disk without repartitioning a physical
disk or rebooting the host.
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The New Virtual Machine wizard creates a virtual machine that has one disk drive. You can modify
virtual machine settings to add more disk drives to a virtual machine, remove disk drives from a virtual
machine, and change certain settings for the existing disk drives.
n

Configuring a Virtual Hard Disk
You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can
set up a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI
Logic or BusLogic SCSI adapter. You can also set up a virtual hard disk as an NVMe disk for any
guest system that includes NVMe drivers. You determine which SCSI adapter to use when you
create a virtual machine.

n

Compact a Virtual Hard Disk
Compacting a virtual hard disk can reclaim unused space in the virtual disk. Modern disks and
operating systems are much more efficient at managing disk space than in the recent past.
Therefore, do not expect the compacting procedure to return large amounts of disk space to the host
drive.

n

Expand a Virtual Hard Disk
You can add storage space to a virtual machine by expanding its virtual hard disk.

n

Defragment a Virtual Hard Disk
Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks
rearranges files, programs, and unused space on the virtual hard disk so that programs run faster
and files open more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.

n

Remove a Virtual Hard Disk from a Virtual Machine
Removing a virtual hard disk disconnects it from a virtual machine. It does not delete files from the
host file system.

n

Using Lock Files to Prevent Consistency Problems on Virtual Hard Disks
A running virtual machine creates lock files to prevent consistency problems on virtual hard disks.
Without locks, multiple virtual machines might read and write to the disk, causing data corruption.

n

Moving a Virtual Hard Disk to a New Location
A key advantage of virtual hard disks is their portability. Because the virtual hard disks are stored as
files on the host system or a remote computer, you can move them easily to a new location on the
same computer or to a different computer.

Configuring a Virtual Hard Disk
You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can set up
a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or
BusLogic SCSI adapter. You can also set up a virtual hard disk as an NVMe disk for any guest system
that includes NVMe drivers. You determine which SCSI adapter to use when you create a virtual machine.
The files that make up an IDE, SATA, SCSI, or NVMe virtual hard disk can be stored on a hard disk of any
type. They can also be stored on other types of fast-access storage media.
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To use SCSI hard disks in a 32-bit Windows XP virtual machine, you must download a special SCSI driver
from the VMware Web site. Follow the instructions on the Web site to use the driver with a fresh
installation of Windows XP.

Growing and Allocating Virtual Disk Storage Space
Most virtual hard disks can be up to 8TB. SCSI disks on the BusLogic controller are limited to 2TB.
Depending on the size of the virtual hard disk and the host operating system, Workstation Player creates
one or more files to hold each virtual disk.
Virtual hard disk files include information such as the operating system, program files, and data files.
Virtual disk files have a .vmdk extension.
By default, the actual files that the virtual hard disk uses start small and grow to their maximum size as
needed. The main advantage of this approach is the smaller file size. Smaller files require less storage
space and are easier to move to a new location, but it takes slightly longer to write data to a disk
configured in this way.
You can also configure virtual hard disks so that all of the disk space is allocated when the virtual disk is
created. This approach provides enhanced performance and is useful if you are running performancesensitive applications in the virtual machine.
Regardless of whether you allocate all disk space in advance, you can configure the virtual hard disk to
split into multiple files on the host disk. The split is not visible to the virtual machine, but is necessary if
you move the virtual machine or its disks to a file system that does not support files larger than 4GB, such
as a USB thumb drive formatted with the FAT32 file system.

Add a New Virtual Hard Disk to a Virtual Machine
To increase storage space, you can add a new virtual hard disk to a virtual machine. Workstation Player
supports up to four IDE devices, 60 SCSI devices, 120 SATA devices, and 60 NVMe virtual disks.
Virtual hard disks are stored as files on the host computer or on a network file server. A virtual IDE drive
or SCSI drive can be stored on a physical IDE drive or on a physical SCSI drive.
As an alternative to adding a new virtual hard disk, you can expand the existing virtual hard disk. See
Expand a Virtual Hard Disk.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the New Hardware wizard, select Hard Disk.

4

Select Create a new virtual disk.
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5

6

Select the disk type.
Option

Description

IDE

Create an IDE device. You can add up to four IDE devices to a virtual machine.

SCSI

Create a SCSI device. You can add up to 60 SCSI devices to a virtual machine.

SATA

Create a SATA device. You can add up to 120 SATA devices, four controllers, and
30 devices per controller.

NVMe

Create an NVMe device. You can add up to 60 NVMe devices, four controllers, and
15 devices per controller.

Set the capacity for the new virtual hard disk.
You can set a size between 0.001 GB and 8 TB for a virtual disk.

7

Specify how to allocate the disk space.
Option

Description

Allocate all disk space now

Allocating all of the disk space when you create the virtual hard disk can enhance
performance, but it requires all of the physical disk space to be available now. If
you do not select this setting, the virtual disk starts small and grows as you add
data to it.

Store virtual disk as a single file

Select this option if the virtual disk is stored on a file system that does not have a
file size limitation.

Split virtual disk into multiple files

Select this option if the virtual disk is stored on a file system that has a file size
limitation. When you split a virtual disk less than 950 GB, a series of 2 GB virtual
disk files are created. When you split a virtual disk greater than 950 GB, two virtual
disk files are created. The maximum size of the first virtual disk file is 1.9 TB and
the second virtual disk file stores the rest of the data.

8

Accept the default filename and location, or browse to and select a different location.

9

Click Finish to add the new virtual hard disk.
The wizard creates the new virtual hard disk. The disk appears to the guest operating system as a
new, blank hard disk.

10 Click OK to save your changes.
11 Use the guest operating system tools (such as the Windows Disk Management tool or the fdisk
command in Linux) to partition and format the new drive.

Add an Existing Virtual Hard Disk to a Virtual Machine
You can reconnect an existing virtual hard disk that was removed from a virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the Add Hardware wizard, select Hard Disk.
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4

Select Use an existing virtual disk.

5

Specify the path name and filename for the existing disk file.

6

Click Finish to add the existing virtual hard disk.

7

Click OK to save your changes.

Compact a Virtual Hard Disk
Compacting a virtual hard disk can reclaim unused space in the virtual disk. Modern disks and operating
systems are much more efficient at managing disk space than in the recent past. Therefore, do not expect
the compacting procedure to return large amounts of disk space to the host drive.
Prerequisites
n

Power off the virtual machine.

n

Verify that the virtual disk is not mapped or mounted. You cannot compact a virtual disk while it is
mapped or mounted.

n

Verify that the disk space is not preallocated for the virtual hard disk. If the disk space was
preallocated, you cannot compact the disk.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select the virtual hard disk to compact.

3

Select Utilities > Compact.

4

Click OK after the disk compacting process is complete.

Expand a Virtual Hard Disk
You can add storage space to a virtual machine by expanding its virtual hard disk.
When you expand a virtual hard disk, the added space is not immediately available to the virtual machine.
To make the added space available, you must use a disk management tool to increase the size of the
existing partition on the virtual hard disk to match the expanded size.
The disk management tool that you use depends on the virtual machine guest operating system. Many
operating systems, including Windows Vista, Windows 7, and Windows 8 and some versions of Linux,
provide built-in disk management tools that can resize partitions. Third-party disk management tools are
also available, such as EASEUS Partition Master, Acronis Disk Director, and the open-source tool
GParted.
When you expand the size of a virtual hard disk, the sizes of partitions and file systems are not affected.
As an alternative to expanding a virtual hard disk, you can add a new virtual hard disk to the virtual
machine. See Add a New Virtual Hard Disk to a Virtual Machine.
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Prerequisites
n

Power off the virtual machine.

n

Verify that the virtual disk is not mapped or mounted. You cannot expand a virtual disk while it is
mapped or mounted.

n

Verify that the virtual machine has no snapshots.
Note Workstation Player does not support taking snapshots or deleting them.

n

Verify that the virtual machine is not a linked clone or the parent of a linked clone.
You can determine whether a virtual machine is a linked clone by the virtual machine name string on
the summary page. If the string includes "Clone of: virtual machine name", the virtual machine is a
linked clone. If the string includes "Snapshot: Snapshot for virtual machine name", the virtual machine
is a parent of a linked clone.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select the virtual hard disk to expand.

3

Select Utilities > Expand.

4

Set the new maximum size for the virtual disk.
You can set a size between 0.001 GB and 8192 GB for a virtual disk.

5

Select Expand.

6

Click OK after the disk expansion process is complete.

What to do next

Use a disk management tool to increase the disk partition size to match the expanded virtual disk size.

Defragment a Virtual Hard Disk
Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges
files, programs, and unused space on the virtual hard disk so that programs run faster and files open
more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.
Defragmenting disks can take considerable time.
Prerequisites
n

Verify that there is adequate free working space on the host system. For example, if the virtual hard
disk is contained in a single file, there must be free space equal to the size of the virtual disk file.
Other virtual hard disk configurations require less free space.

n

Verify that the virtual disk is not mapped or mounted. You cannot defragment a virtual disk while it is
mapped or mounted.

VMware, Inc.

102

Using VMware Workstation Player for Linux

Procedure

1

Run a disk defragmentation utility in the guest operating system.

2

If disk space is not preallocated for the virtual hard disk, use the Workstation Player defragmentation
tool to defragment it.

3

a

Power off the virtual machine.

b

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

c

On the Hardware tab, select Hard Disk.

d

Select Utilities > Defragment.

e

When the defragmentation process is finished, click OK.

Run a disk defragmentation utility on the host system.

Remove a Virtual Hard Disk from a Virtual Machine
Removing a virtual hard disk disconnects it from a virtual machine. It does not delete files from the host
file system.
After you remove a virtual hard disk from a virtual machine, you can map or mount the disk to the host
system and copy data from the guest operating system to the host without powering on the virtual
machine or starting Workstation Player. You can also add the disk to another virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select the virtual hard disk and click Remove.

3

Click OK to save your changes.

Using Lock Files to Prevent Consistency Problems on Virtual Hard
Disks
A running virtual machine creates lock files to prevent consistency problems on virtual hard disks. Without
locks, multiple virtual machines might read and write to the disk, causing data corruption.
Lock files have a .lck suffix and are created in subdirectories in the same directory as the virtual disk
(.vmdk) files. A locking subdirectory and lock file are created for .vmdk files, .vmx files, and .vmem files.
A unified locking method is used on all host operating systems so that files shared between them are fully
protected. For example, if one user on a Linux host tries to power on a virtual machine that is already
powered on by another user with a Windows host, the lock files prevent the second user from powering
on the virtual machine.
When a virtual machine powers off, it removes the locking subdirectories and the lock files. If the virtual
machine cannot remove these locking controls, one or more stale lock files might remain. For example, if
the host system fails before the virtual machine removes its locking controls, stale lock files remain.
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When the virtual machine restarts, it scans any locking subdirectories for stale lock files and, when
possible, removes them. A lock file is considered stale if the lock file was created on the same host
system that is now running the virtual machine and the process that created the lock is no longer running.
If either of these conditions is not true, a dialog box warns you that the virtual machine cannot be
powered on. You can delete the locking directories and their lock files manually.
Locks also protect physical disk partitions. Because the host operating system is not aware of this locking
convention, it does not recognize the lock. For this reason, you should install the physical disk for a virtual
machine on the same physical disk as the host operating system.

Moving a Virtual Hard Disk to a New Location
A key advantage of virtual hard disks is their portability. Because the virtual hard disks are stored as files
on the host system or a remote computer, you can move them easily to a new location on the same
computer or to a different computer.
For example, you can use Workstation Player on a Windows host system to create virtual hard disks,
move the disks to a Linux computer, and use the disks with Workstation Player on a Linux host system.

Configuring Virtual Ports
You can add virtual parallel (LPT) ports and virtual serial (COM) ports to a virtual machine. A Workstation
Player virtual machine can use up to three parallel ports and up to four virtual serial ports.
n

Add a Virtual Parallel Port to a Virtual Machine
You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports
can output to parallel ports or to files on the host system.

n

Configure a Virtual Parallel Port on a Linux 2.6.x Kernel Host
Linux 2.6.x kernels that support parallel ports use the modprobe modulename and modprobe
parport_pc modules. Workstation Player requires that the parallel port PC-style hardware option
(CONFIG_PARPORT_PC) is built and loaded as a kernel module.

n

Configure Permissions for a Parallel Port Device on a Linux Host
Some Linux distributions do not grant a virtual machine access to the lp and parport devices by
default. If this is the case on your Linux host system, you must add the VMware user to the group
that has permission to access those devices.

n

Troubleshoot ECR Errors for Parallel Ports
A parallel port on the host system does not have an Extended Control Register (ECR).

n

Add a Virtual Serial Port to a Virtual Machine
You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to
physical serial ports, files, or named pipes.

n

Change the Input Speed of a Serial Connection
You can increase the speed of a serial connection over a pipe to a virtual machine.
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Add a Virtual Parallel Port to a Virtual Machine
You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports can
output to parallel ports or to files on the host system.
Parallel ports are used for a variety of devices, including printers, scanners, dongles, and disk drives.
Although these devices can connect to the host system, only printers can reliably connect to virtual
machines by using parallel ports.
Workstation Player provides only partial emulation of PS/2 hardware. Interrupts that a device connected
to a physical port requests are not passed to the virtual machine. The guest operating system cannot use
direct memory access (DMA) to move data to or from the port. For this reason, not all devices that attach
to a parallel port work correctly. Do not use virtual parallel ports to connect parallel port storage devices or
other types of parallel port devices to a virtual machine.
Prerequisites
n

If you are using a Linux host system that has a 2.6.x kernel, verify that the parallel port PC-style
hardware option (CONFIG_PARPORT_PC) is built and loaded as a kernel module. See Configure a Virtual
Parallel Port on a Linux 2.6.x Kernel Host.

n

If you are using a Linux host system that does not grant virtual machines access to the lp and
parport devices by default, add the VMware user to the group that has permission to access those
devices. See Configure Permissions for a Parallel Port Device on a Linux Host.

n

Power off the virtual machine.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the New Hardware wizard, select Parallel Port.

4

Click Finish to add the virtual parallel port to the virtual machine.

5

Select where the virtual parallel port sends output.

6

Option

Description

Use a physical parallel port

Select a parallel port on the host system.

Use output file

Send output from the virtual parallel port to a file on the host system. Either locate
an existing output file or browse to a directory and type a filename to create a new
output file.

To connect the virtual parallel port to the virtual machine when the virtual machine powers on, select
Connect at power on.

When a parallel port is configured for a virtual machine, most guest operating systems detect the port at
installation time and install the required drivers. Some operating systems, including Linux, detect the ports
at boot time.
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Configure a Virtual Parallel Port on a Linux 2.6.x Kernel Host
Linux 2.6.x kernels that support parallel ports use the modprobe modulename and modprobe
parport_pc modules. Workstation Player requires that the parallel port PC-style hardware option
(CONFIG_PARPORT_PC) is built and loaded as a kernel module.
Linux kernels in the 2.6.x series use a special arbitrator for access to the parallel port hardware. If the
host system is using the parallel port, the virtual machine cannot use it. If a virtual machine is using the
parallel port, the host and any users accessing the host are denied access to the device. You must use
the Removable Devices menu to disconnect the parallel port from the virtual machine to access the
device from the host system.
Procedure

1

To determine whether the modprobe modulename and modprobe parport_pc modules are installed
and loaded on the host system, run the lsmod command as the root user.
You can also see a list of modules in the /proc/modules file.
Note In Linux 2.6.x, loading parport_pc does not load all modules.

2

If necessary, load the parallel port modules.
For example: modprobe parport_pc && modprobe ppdev
This command inserts the modules that are required for a parallel port.

3

If the lp module is loaded, run the rmmod command as root to remove it.
For example: rmmod lp
The virtual machine cannot use the parallel port correctly if the lp module is loaded.

4

Comment out the line that refers to the lp module in the /etc/modules.conf or /etc/
conf.modules file.
The name of the configuration file depends on the Linux distribution.
When the line is commented out, the configuration file no longer starts the lp module when you reboot
the host system.

5

To make sure that the proper modules for the parallel port are loaded at boot time, add the following
line to the /etc/modules.conf or /etc/conf.modules file.
alias parport_lowlevel parport_pc

Configure Permissions for a Parallel Port Device on a Linux Host
Some Linux distributions do not grant a virtual machine access to the lp and parport devices by default.
If this is the case on your Linux host system, you must add the VMware user to the group that has
permission to access those devices.
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Procedure

1

On the Linux host system, use the ls command to determine the owner and group for the device.
For example: ls –la /dev/parport0
The third and fourth columns of the output show the owner and group, respectively. In most cases,
the owner of the device is root and the associated group is lp.

2

To add the user to the device group, become root and open the /etc/group file in a text editor.

3

On the line that defines the lp group, add the Workstation Player username.
For example: lp::7:daemon,lp,player_username

The changes take effect the next time the user logs in to the host system.

Troubleshoot ECR Errors for Parallel Ports
A parallel port on the host system does not have an Extended Control Register (ECR).
Problem

When you power on a virtual machine after adding a parallel port, an error messages states that the
parallel port on the host system does not have an ECR.
Cause

This problem can occur when the hardware supports ECR, but ECR has been disabled in the BIOS.
Solution

1

Reboot the host system.

2

Early in the boot process, press and hold down the Delete key to enter the BIOS configuration editor.

3

Find the parallel port field and enable Extended Capability Port (ECP) mode or a combination of
modes that includes ECP.
Most modern computers support ECP mode.

Add a Virtual Serial Port to a Virtual Machine
You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to physical
serial ports, files, or named pipes.
You might want to add a virtual serial port to a virtual machine to make devices such as modems and
printers available to the virtual machine. You can also use virtual ports to send debugging data from a
virtual machine to the host system or to another virtual machine.
Note The virtual printer feature configures a serial port to make host printers available to the guest. You
do not need to install additional drivers in the virtual machine.
Prerequisites

Power off the virtual machine.
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Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the Add Hardware wizard, select Serial Port.

4

Click Finish to add the virtual serial port to the virtual machine.

5

Select where the virtual serial port sends output.

6

Option

Description

Use a physical parallel port

Send output to a physical serial port on the host system.

Use output file

Send output to a file on the host system. Either locate an existing output file or
browse to a directory and type a filename to create a new output file.

Output to named pipe

Set up a direct connection between two virtual machines, or a connection between
a virtual machine and an application on the host system.

If you selected Output to named pipe, configure the named pipe.
a

Type /tmp/socket or another UNIX socket name in the first text box.
The pipe name must be the same on both the server and the client.

b

To send debugging information to an application on the host system, select This end is the
server from the first drop-down menu and select The other end is an application from the
second drop-down menu.

c

To send debugging information to another virtual machine, select This end is the server from the
first drop-down menu and The other end is a virtual machine from the second drop-down
menu.

7

To connect the port to the virtual machine when the virtual machine powers on, select Connect at
power on.

8

(Optional) On the Hardware tab, select the new serial port, select Yield CPU on poll, and click OK.
This option is useful if you are using debugging tools that communicate over a serial connection. If
the serial port in the guest operating system is being used in polled mode rather than interrupt mode,
you might notice performance issues. This option forces the virtual machine to yield processor time if
the only task it is trying to do is poll the virtual serial port.

What to do next

If you set up a connection between two virtual machines, the first virtual machine is set up as the server.
Repeat this procedure for the second virtual machine, but set it up as the client by selecting This end is
the client when you configure the named pipe.

Change the Input Speed of a Serial Connection
You can increase the speed of a serial connection over a pipe to a virtual machine.
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In principle, the output speed, which is the speed at which the virtual machine sends data through the
virtual serial port, is unlimited. In practice, the output speed depends on how fast the application at the
other end of the pipe reads inbound data.
Prerequisites
n

Use the guest operating system to configure the serial port for the highest setting supported by the
application that you are running in the virtual machine.

n

Power off the virtual machine and exit Workstation Player.

Procedure

1

In a text editor, add the following line to the virtual machine configuration (.vmx) file.
serialport_number.pipe.charTimePercent = "time"
port_number is the number of the serial port, starting from 0. The first serial port is serial0. time is a
positive integer that specifies the time taken to transmit a character, expressed as a percentage of the
default speed set for the serial port in the guest operating system. For example, a setting of 200
forces the port to take twice as long for each character, or send data at half the default speed. A
setting of 50 forces the port to take only half as long for each character, or send data at twice the
default speed.

2

Assuming that the serial port speed is set appropriately in the guest operating system, experiment
with this setting by starting with a value of 100 and gradually decreasing it until you find the highest
speed at which the connection works reliably.

Configuring Generic SCSI Devices
The generic SCSI feature gives the guest operating system direct access to SCSI devices that are
connected to the host system, including scanners, tape drives, and other data storage devices. A virtual
machine can use the generic SCSI driver to run any SCSI device that is supported by the guest operating
system.
To use SCSI devices in a virtual machine running on a Windows host system, you must run Workstation
Player as a user who has administrator access.
On Linux host systems, you must have read and write permissions on a given generic SCSI device to use
that device in a virtual machine, even if the device is a read-only device, such as a CD-ROM drive. These
devices typically default to root-only permissions. A Linux administrator can create a group that has read
and write access to these devices and add the appropriate users to that group.
Although generic SCSI is device independent, it can be sensitive to the guest operating system, device
class, and specific SCSI hardware.
n

Add a Generic SCSI Device to a Virtual Machine
You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual
machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI
devices to a virtual machine.
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n

Avoiding Concurrent Access Problems for SCSI Devices on Linux Hosts
Workstation Player makes sure that multiple programs do not use the same /dev/sg entry at the
same time, but it cannot always ensure that multiple programs do not use the /dev/sg entry and the
traditional /dev entry at the same time.

n

Troubleshoot Problems Detecting Generic SCSI Devices
When you add a generic SCSI device to a virtual machine, the device does not appear in the list of
available SCSI devices.

Add a Generic SCSI Device to a Virtual Machine
You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual
machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI
devices to a virtual machine.
Prerequisites
n

On a Linux host system, log in as a user who has read and write permissions for the SCSI device.
Also, verify that version 2.1.36 or later of the SCSI Generic driver (sg.o) is installed. This version of
the SCSI Generic driver is included with Linux kernel 2.2.14 and later.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

In the Add Hardware wizard, select Generic SCSI Device.

4

Click Finish to add the device.

5

Select the physical SCSI device to map to the virtual SCSI device.
When you type the path to the SCSI device on a Linux host, do not enter /dev/st0 or /dev/sr0.

6

To connect the device when the virtual machine powers on, select Connect at power on.

7

On the Hardware tab, select the SCSI device identifier to use for the device from the Virtual device
node drop-down menu and click OK.
For example, if you select SCSI 0:2, the guest operating system sees the drive as ID 2 on controller
0.

Avoiding Concurrent Access Problems for SCSI Devices on Linux
Hosts
Workstation Player makes sure that multiple programs do not use the same /dev/sg entry at the same
time, but it cannot always ensure that multiple programs do not use the /dev/sg entry and the
traditional /dev entry at the same time.
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The SCSI generic driver sets up a mapping in /dev for each SCSI device. Each entry starts with sg, for
the SCSI generic driver, followed by a number. For example, /dev/sg0 is the first generic SCSI device.
Each entry corresponds to a SCSI device in the order specified in /proc/scsi/scsi, from the lowest
device ID on the lowest adapter to the highest device ID on the lowest adapter, and so on to the highest
device ID on the highest adapter.
Some Linux devices, such as tape drives, disk drives, and CD-ROM drives, already have a
designated /dev entry (st, sd, and sr, respectively). When the SCSI generic driver is installed, Linux
identifies these devices with corresponding sg entries in /dev, in addition to their traditional entries.
To avoid concurrent access problems, do not specify /dev/st0 or /dev/sr0 when you specify which
SCSI device to use in a virtual machine.
Important Do not attempt to use the same generic SCSI device in both the host system and guest
operating system. Unexpected behavior and data loss or corruption might occur.

Troubleshoot Problems Detecting Generic SCSI Devices
When you add a generic SCSI device to a virtual machine, the device does not appear in the list of
available SCSI devices.
Problem

The SCSI device does not appear in the list of available SCSI devices after you add it to a virtual
machine.
Cause

A driver for that device is not installed on the host system, a driver on the host system prevents the
device from being detected, or the virtual machine uses a device for which there are no drivers available
to the host operating system.
Solution

1

Determine the SCSI bus number that the device uses on the host system.
The SCSI bus is assigned a number by the host operating system after all IDE buses are assigned
numbers. For example, if you have two IDE buses, they are numbered 0 and 1. The first SCSI bus is
assigned bus number 2. You can use a third-party tool, such as winobj, to determine the SCSI bus
number.

2

Determine the target ID that the device uses in the virtual machine and on the host system.
This ID is usually set by some jumpers or switches on the device.

3

Determine whether the device driver for the device is installed on the host system.
If the device driver is not installed, install it and see if the device appears. To avoid a device-in-use
conflict between the host and guest, you might not want to install the driver on the host system.
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4

If an original SCSI device driver is already installed on the host system, disable it.
Some Windows operating systems do not process the send command from the adapter if the device
driver owns the device.

5

Power off the virtual machine and open the virtual machine configuration (.vmx) file in a text editor.

6

Add or change the following line in the virtual machine configuration (.vmx) file.
scsiZ:Y.fileName = "deviceName"
Z is the SCSI bus number the device uses in the virtual machine. For deviceName, use scsiX:Y,
where X is the SCSI bus number that the device uses on the host system and Y is the target ID that
the device uses in both the virtual machine and on the host system.
For example, if the problematic device is a CD-ROM drive, the existing entry is
scsi0:4.fileName = "CdRom0" and the device on the host system is located on bus 2 with target
ID 4, change the line to scsi0:4.fileName = "scsi2:4".

7

If the virtual machine does not contain any SCSI devices, to add a generic SCSI device to a new
virtual SCSI adapter, or to use an existing SCSI device as a generic SCSI device, add the following
line to the virtual machine configuration (.vmx) file.
scsiZ:Y.deviceType = "scsi-passthru"

8

If the virtual machine does not contain any SCSI devices, or to add a generic SCSI device to a new
virtual SCSI adapter, add the following lines to the virtual machine configuration (.vmx) file.
scsiZ:Y.present = "true"
scsiZ.present = "true"

Configuring Sixteen-Way Virtual Symmetric
Multiprocessing
With virtual symmetric multiprocessing (SMP), you can assign processors and cores per processor to a
virtual machine on any host system that has at least two logical processors.
Workstation Player considers multiprocessor hosts that have two or more physical CPUs, singleprocessor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading
enabled, to have two logical processors.
Note On hyperthreaded uniprocessor hosts, performance of virtual machines that have virtual SMP
might be below normal. Even on multiprocessor hosts, performance is affected if you overcommit by
running multiple workloads that require more total CPU resources than are physically available.
You can power on and run multiple dual-processor virtual machines concurrently. The number of
processors for a given virtual machine appears in the summary view of the virtual machine.

Configure Sixteen-Way Virtual Symmetric Multiprocessing
You can configure sixteen-way virtual symmetric multiprocessing (SMP) for an existing virtual machine.
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Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Processors.

3

Change the Number of processors setting to 16.

4

Click OK to save your changes.

Use a Virtual Machine That Has More Than Sixteen Virtual
Processors
If Workstation Player is running on a multiprocessor host system, you can open a virtual machine that has
more than 16 virtual processors assigned to it. You must change the number of processors before
powering on the virtual machine.
You can see the number of processors in the virtual machine summary view or by viewing the virtual
machine hardware settings.
Prerequisites

Power off the virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Processors.
Note that Number of processors is set to Other (x), where x is the number of processors originally
assigned to it. Workstation Player preserves this original configuration setting for the number of
processors, even though eight is the maximum number of processors supported.

3

Change the Number of processors setting to 1, 2, 4, 8, or 16.
After you commit a change to this setting, the original setting for the number of processors is
discarded and no longer appears as an option.

4

Click OK to save your changes.

Configuring Keyboard Features
You can change key combinations for hot-key sequences in Workstation Player and the language for the
keyboard that VNC clients use. You can also configure platform-specific keyboard features for Windows
and Linux host systems.
n

Use Ctrl+Alt in a Key Combination
Because Ctrl+Alt tells Workstation Player to release mouse and keyboard input, hot-key
combinations that include Ctrl+Alt are not passed to the guest operating system. You must use the
Space key if the key combination includes Ctrl+Alt.
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n

Configure Keyboard Mapping for a Remote X Server
Although the keyboard works correctly with a local X server, it might not work correctly when you run
the same virtual machine with a remote X server.

n

Change How a Specific Key Is Mapped
If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that
makes a modification to the map. To change how a specific key is mapped, you add the appropriate
property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

n

Configure How Keysyms Are Mapped
When key code mapping cannot be used or is disabled, Workstation Player maps keysyms to v-scan
codes. If a language-specific keyboard does not appear to be supported by Workstation Player, you
might need to set a property that tells Workstation Player which keysym table to use.

n

V-Scan Code Table
You specify v-scan codes when you change how keys or keysyms are mapped.

Use Ctrl+Alt in a Key Combination
Because Ctrl+Alt tells Workstation Player to release mouse and keyboard input, hot-key combinations
that include Ctrl+Alt are not passed to the guest operating system. You must use the Space key if the key
combination includes Ctrl+Alt.
Procedure

1

Press Ctrl+Alt+spacebar.

2

Release the spacebar without releasing Ctrl and Alt.

3

Press the third key of the key combination to send to the guest operating system.

Configure Keyboard Mapping for a Remote X Server
Although the keyboard works correctly with a local X server, it might not work correctly when you run the
same virtual machine with a remote X server.
For local X servers, Workstation Player maps X key codes to PC scan codes to correctly identify a key.
Because it cannot tell whether a remote X server is running on a PC or on some other kind of computer,
Workstation Player uses this key code map only for local X servers. You can set a property to tell
Workstation Player to use key code mapping. See Understanding X-Key Codes and Keysyms for more
information.
To configure a keyboard mapping for a remote X server, you add the appropriate property to the virtual
machine configuration (.vmx) file or to ~/.vmware/config.
Prerequisites
n

Verify that the remote X server is an XFree86 server running on a PC.
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n

Power off the virtual machine and exit Workstation Player.

Note If the keyboard does not work correctly on an XFree86 server running locally, report the problem to
VMware technical support.
Procedure
u

If you use an XFree86-based server that Workstation Player does not recognize as an XFree86
server, add the xkeymap.usekeycodeMap property and set it to TRUE.
This property tells Workstation Player to always use key code mapping regardless of server type.
For example: xkeymap.usekeycodeMap = "TRUE"

u

If Workstation Player does not recognize the remote server as an XFree86 server, add the
xkeymap.usekeycodeMapIfXFree86 property and set it to TRUE.
This property tells Workstation Player to use key code mapping if you are using an XFree86 server,
even if it is remote.
For example: usekeycodeMapIfXFree86 = "TRUE"

Understanding X-Key Codes and Keysyms
Pressing a key on a PC keyboard generates a PC scan code based roughly on the position of the key.
For example, the Z key on a German keyboard generates the same code as the Y key on an English
keyboard because they are in the same position on the keyboard. Most keys have one-byte scan codes,
but some keys have two-byte scan codes with prefix 0xe0.
Internally, Workstation Player uses a simplified version of the PC scan code that is a single nine-bit
numeric value, called a v-scan code. A v-scan code is written as a three-digit hexadecimal number. The
first digit is 0 or 1. For example, the Ctrl key on the left side of the keyboard has a one-byte scan code
(0x1d) and its v-scan code is 0x01d. The Ctrl key scan code on the right side of the keyboard is two bytes
(0xe0, 0x1d) and its v-scan code is 0x11d.
An XFree86 server on a PC has a one-to-one mapping from X key codes to PC scan codes, or v-scan
codes, which is what Workstation Player uses. When Workstation Player is hosted on an XFree86 server
and runs a local virtual machine, it uses the built-in mapping from X key codes to v-scan codes. This
mapping is keyboard independent and should be correct for most languages. In other cases (not an
XFree86 server or not a local server), Workstation Player must map keysyms to v-scan codes by using a
set of keyboard-specific tables.
An X server uses a two-level encoding of keys, which includes the X key code and the keysym. An X key
code is a one-byte value. The assignment of key codes to keys depends on the X server implementation
and the physical keyboard. As a result, an X application normally cannot use key codes directly. Instead,
the key codes are mapped into keysyms that have names like space, escape, x and 2. You can use an X
application to control the mapping by using the function XChangeKeyboardMapping() or by the program
xmodmap. To explore keyboard mappings, you can use the xev command, which shows the key codes
and keysyms for keys typed into its window.
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A key code corresponds roughly to a physical key, while a keysym corresponds to the symbol on the key
top. For example, with an XFree86 server running on a PC, the Z key on the German keyboard has the
same key code as the Y key on an English keyboard. The German Z keysym, however, is the same as
the English Z keysym, and different from the English Y keysym.

Change How a Specific Key Is Mapped
If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that
makes a modification to the map. To change how a specific key is mapped, you add the appropriate
property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.
Prerequisites
n

Verify that the X server is an XFree86 server running on a PC. If the X server is remote, configure it to
use key code mapping. See Configure Keyboard Mapping for a Remote X Server.

n

Determine the X key code and the corresponding v-scan code for the key. To find the X key code for a
key, run xev or xmodmap -pk. See V-Scan Code Table for most v-scan codes.

n

Power off the virtual machine and exit Workstation Player.

Procedure

1

Open .vmx or ~/.vmware/config in a text editor.

2

Add the xkeymap.keycode.code property and set it to the v-scan code.
code must be a decimal number and the v-scan code must be a C-syntax hexadecimal number, such
as 0x001.
In this example, the properties swap left Ctrl and Caps Lock.
xkeymap.keycode.64 = "0x01d # X Caps_Lock -> VM left ctrl"
xkeymap.keycode.37 = "0x03a # X Control_L -> VM caps lock"

Configure How Keysyms Are Mapped
When key code mapping cannot be used or is disabled, Workstation Player maps keysyms to v-scan
codes. If a language-specific keyboard does not appear to be supported by Workstation Player, you might
need to set a property that tells Workstation Player which keysym table to use.
Workstation Player determines which table to use by examining the current X keymap. However, its
decision-making process can sometimes fail. In addition, each mapping is fixed and might not be
completely correct for any given keyboard and X key code-to-keysym mapping. For example, if a user
uses xmodmap to swap Ctrl and Caps Lock by, the keys are swapped in the virtual machine when using a
remote server (keysym mapping), but are unswapped when using a local server (key code mapping). To
correct this situation, you must remap the keys in Workstation Player.
To configure how keysyms are mapped, you add one or more properties to the virtual machine
configuration (.vmx) file or to ~/.vmware/config.
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Prerequisites
n

To change the mapping of a few keys, determine the keysym name for each key. To find a keysym
name, use the xev or xmodmap -pk command. The X header file /usr/include/X11/keysymdef.h
also has a complete list of keysyms. The name of a keysym is the same as its C constant, but without
the XK_ prefix.

n

To use a different keysym table, determine which mapping table to use. The tables are located in the
xkeymap directory in the Workstation Player installation directory, which is usually /usr/lib/vmware.
The table you must use depends on the keyboard layout. The normal distribution includes tables for
PC keyboards for the United States and a number of European countries and languages. For most of
these, both the 101-key (or 102-key) and the 104-key (or 105-key) variants are available.
If none of the mapping tables is completely correct, find one that works best, copy it to a new location,
and change the individual keysym mappings.

n

Familiarize yourself with the v-scan codes. See V-Scan Code Table.

n

Power off the virtual machine and exit Workstation Player.

Procedure
u

To disable X key code mapping to map keysyms rather than key codes to v-scan codes, add the
xkeymap.nokeycodeMap property and set it to TRUE.
For example: xkeymap.nokeycodeMap = "TRUE"

u

If Workstation Player has a table in the xkeymap directory for your keyboard but cannot detect it, add
the xkeymap.language property and set it to one of the tables in the xkeymap directory.
For example: xkeymap.language = "keyboard_type"
If the failure to detect the keyboard means that the table is not completely correct for you, you might
need to create a modified table and use the xkeymap.fileName property instead.

u

To use a different keysym mapping table that is not in the xkeymap directory, add the
xkeymap.fileName property and set it to the path to the table.
For example: xkeymap.fileName = "file_path"
The table must list a keysym for each key by using the form sym="v-scan_code", where the sym
value is an X keysym name and v-scan_code is a C-syntax hexadecimal number, for example, 0x001.
Use a new line for each keysym.
Note Because compiling a complete keysym mapping is difficult, you should usually edit an existing
table and make small changes.

u

To change the keysym mapping of a few keys, type the xkeymap.keysym property for each key, on
separate lines.
For example: xkeymap.keysym.sym = "v-scan_code"
The value of sym must be an X keysym name and v-scan_code is a C-syntax hexadecimal number,
for example, 0x001.
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V-Scan Code Table
You specify v-scan codes when you change how keys or keysyms are mapped.
Following are the v-scan codes for the 104-key U.S. keyboard.
Table 11-1. V-Scan Codes for the 104-Key U.S. Keyboard
Symbol

Shifted Symbol

Location

Esc

V-Scan Code
0x001

1

!

0x002

2

@

0x003

3

#

0x004

4

$

0x005

5

%

0x006

6

^

0x007

7

&

0x008

8

*

0x009

9

(

0x00a

0

)

0x00b

-

_

0x00c

=

+

0x00d

Backspace

0x00e

Tab

0x00f

Q

0x010

W

0x011

E

0x012

R

0x013

T

0x014

Y

0x015

U

0x016

I

0x017

O

0x018

P

0x019

[

{

0x01a

]

}

0x01b

Enter
Ctrl
A
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Table 11-1. V-Scan Codes for the 104-Key U.S. Keyboard (continued)
Symbol

Shifted Symbol

Location

V-Scan Code

S

0x01f

D

0x020

F

0x021

G

0x022

H

0x023

J

0x024

K

0x025

L

0x026

;

0x027

'

0x028

`

0x029

Shift
\

left
|

0x02a
0x02b

Z

0x02c

X

0x02d

C

0x02e

V

0x02f

B

0x030

N

0x031

M

0x032

,

<

0x033

.

>

0x034

/

?

0x035

Shift

right

0x036

*

numeric pad

0x037

Alt

left

0x038

Space bar

0x039

Caps Lock

0x03a

F1

0x03b

F2

0x03c

F3

0x03d

F4

0x03e

F5

0x03f

F6

0x040
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Table 11-1. V-Scan Codes for the 104-Key U.S. Keyboard (continued)
Symbol

Shifted Symbol

Location

V-Scan Code

F7

0x041

F8

0x042

F9

0x043

F10

0x044

Num Lock

numeric pad

Scroll Lock

0x045
0x046

Home

7

numeric pad

0x047

Up arrow

8

numeric pad

0x048

PgUp

9

numeric pad

0x049

numeric pad

0x04a

numeric pad

0x04b

numeric pad

0x04c

numeric pad

0x04d

numeric pad

0x04e

Left arrow

4

5
Right arrow

6

+
End

1

numeric pad

0x04f

Down arrow

2

numeric pad

0x050

PgDn

3

numeric pad

0x051

Ins

0

numeric pad

0x052

numeric pad

0x053

Del
F11

0x057

F12

0x058

Break

Pause

0x100

Enter

numeric pad

0x11c

Ctrl

right

0x11d

/

numeric pad

0x135

SysRq

Print Scrn

0x137

Alt

right

0x138

Home

function pad

0x147

Up arrow

function pad

0x148

Page Up

function pad

0x149

Left arrow

function pad

0x14b

Right arrow

function pad

0x14d

End

function pad

0x14f

Down arrow

function pad

0x150
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Table 11-1. V-Scan Codes for the 104-Key U.S. Keyboard (continued)
Symbol

Shifted Symbol

Location

V-Scan Code

Page Down

function pad

0x151

Insert

function pad

0x152

Delete

function pad

0x153

Windows

left

0x15b

Windows

right

0x15c

Menu

0x15d

The 84-key keyboard has a Sys Req key on the numeric pad. Its v-scan code is 0x054.
Keyboards outside the U.S. usually have an extra key (often < > or < > |) next to the left Shift key. The vscan code for this key is 0x056.

Modify Hardware Settings for a Virtual Machine
You can modify memory, processor, virtual and physical hard disk, CD-ROM and DVD drive, floppy drive,
virtual network adapter, USB controller, sound card, serial port, generic SCSI device, printer, and display
settings for a virtual machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

Click the Hardware tab.

3

Select the hardware setting to modify.

4

Click Help for information about how to modify the hardware setting.
You must power off a virtual machine before you change certain hardware settings.
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Connections

12

Workstation Player provides bridged networking, network address translation (NAT), and host-only
networking to configure a virtual machine for virtual networking. The software that you need for all
networking configurations is installed on the host system when you install Workstation Player
This chapter includes the following topics:
n

Understanding Virtual Networking Components

n

Understanding Common Networking Configurations

n

Configuring Bridged Networking

n

Configuring Network Address Translation

n

Configuring Host-Only Networking

n

Changing a Networking Configuration

n

Enable Jumbo Frames

Understanding Virtual Networking Components
The virtual networking components in Workstation Player include virtual switches, virtual network
adapters, the virtual DHCP server, and the NAT device.

Virtual Switches
Like a physical switch, a virtual switch connects networking components together. Virtual switches, which
are also referred to as virtual networks, are named VMnet0, VMnet1, VMnet2, and so on. A few virtual
switches are mapped to specific networks by default.
Table 12-1. Default Virtual Network Switches
Network Type

Switch Name

Bridged

VMnet0

NAT

VMnet8

Host-only

VMnet1
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Workstation Player creates virtual switches as needed, up to 20 virtual switches on a Windows host
system and up to 255 virtual switches on a Linux host system. You can connect an unlimited number of
virtual network devices to a virtual switch on a Windows host system and up to 32 virtual network devices
to a virtual switch on a Linux host system.
Note On Linux host systems, the virtual switch names are in all lowercase letters, for example, vmnet0.

Virtual Network Adapters
When you use the New Virtual Machine wizard to create a new virtual machine, the wizard creates a
virtual network adapter for the virtual machine. The virtual network adapter appears in the guest operating
system as an AMD PCNET PCI adapter, Intel Pro/1000 MT Server Adapter, or Intel 82574L Gigabit
Network Connection. In Windows Vista, Windows 7, and Windows 8 guest operating systems, the adapter
is an Intel Pro/1000 MT Server Adapter. In Windows 8.1 and Windows10 guest operation systems, the
adapter is an Intel 82574L Gigabit Network Connection.
Player 3.x and later virtual machines can have up to 10 virtual network adapters.

Virtual DHCP Server
The virtual Dynamic Host Configuration Protocol (DHCP) server provides IP addresses to virtual
machines in configurations that are not bridged to an external network. For example, the virtual DHCP
server assigns IP addresses to virtual machines in host-only and NAT configurations.

NAT Device
In a NAT configuration, the NAT device passes network data between one or more virtual machines and
the external network, identifies incoming data packets intended for each virtual machine, and sends them
to the correct destination.

Understanding Common Networking Configurations
You can configure bridged networking, NAT, and host-only networking for virtual machines. You can also
use the virtual networking components to create sophisticated custom virtual networks.
Creating custom networks is available only on virtual machines that are created in Workstation Player.
Although you cannot configure custom networking in Workstation Player, you can run a virtual machine
that has custom networking in Workstation Player.

Bridged Networking
Bridged networking connects a virtual machine to a network by using the network adapter on the host
system. If the host system is on a network, bridged networking is often the easiest way to give the virtual
machine access to that network.
When you install Workstation Player on a Windows or Linux host system, a bridged network (VMnet0) is
set up for you. See Configuring Bridged Networking.
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NAT Networking
With NAT, a virtual machine does not have its own IP address on the external network. Instead, a
separate private network is set up on the host system. In the default configuration, a virtual machine gets
an address on this private network from the virtual DHCP server. The virtual machine and the host system
share a single network identity that is not visible on the external network.
When you install Workstation Player on a Windows or Linux host system, a NAT network (VMnet8) is set
up for you. When you use the New Virtual Machine wizard to create a new virtual machine and select
the typical configuration type, the wizard configures the virtual machine to use the default NAT network.
You can have only one NAT network. See Configuring Network Address Translation.

Host-Only Networking
Host-only networking creates a network that is completely contained within the host computer. Host-only
networking provides a network connection between the virtual machine and the host system by using a
virtual network adapter that is visible on the host operating system.
When you install Workstation Player on a Windows or Linux host system, a host-only network (VMnet1) is
set up for you. See Configuring Host-Only Networking.

Configuring Bridged Networking
When you install Workstation Player on a Windows or Linux host system, a bridged network (VMnet0) is
set up for you. Bridged networking connects a virtual machine to a network by using the network adapter
on the host system. If the host system is on a network, bridged networking is often the easiest way to give
the virtual machine access to that network.
With bridged networking, the virtual network adapter in the virtual machine connects to a physical network
adapter in the host system. The host network adapter enables the virtual machine to connect to the LAN
that the host system uses. Bridged networking works with both wired and wireless host network adapters.
Bridged networking configures the virtual machine as a unique identity on the network, separate from and
unrelated to the host system. The virtual machine is a full participant in the network. It has access to other
machines on the network, and other machines on the network can contact it as if it were a physical
computer on the network.
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Figure 12-1. Bridged Networking Configuration
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You can view and change the settings for bridged networking on the host system, determine which
network adapters to use for bridged networking, and map specific host network adapters to specific virtual
switches.

Assigning IP Addresses in a Bridged Networking Environment
A virtual machine must have its own identity on a bridged network. For example, on a TCP/IP network,
the virtual machine needs its own IP address. Your network administrator can tell you whether IP
addresses are available for virtual machines and which networking settings to use in the guest operating
system.
Typically, the guest operating system can acquire an IP address and other network details from a DHCP
server, but you might need to set the IP address and other details manually in the guest operating
system.
Users who boot multiple operating systems often assign the same address to all systems because they
assume that only one operating system will be running at a time. If the host system is set up to boot
multiple operating systems, and you run one or more operating systems in virtual machines, you must
configure each operating system to have a unique network address.

Configure Bridged Networking for an Existing Virtual Machine
You can configure bridged networking for an existing virtual machine.
To configure bridged networking for a new virtual machine, select Customize Hardware when you run
the New Virtual Machine wizard.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Network Adapter.

3

Select Bridged: Connected directly to the physical network.
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4

If you use the virtual machine on a laptop or other mobile device, select Replicate physical network
connection state.
This setting causes the IP address to be renewed when you move from one wired or wireless network
to another.

5

Click OK to save your changes.

Configuring Network Address Translation
When you install Workstation Player on a Windows or Linux host system, a NAT network (VMnet8) is set
up for you. When you use the New Virtual Machine wizard to create a typical virtual machine, the wizard
configures the virtual machine to use the default NAT network.
With NAT, a virtual machine does not have its own IP address on the external network. Instead, a
separate private network is set up on the host system. In the default configuration, virtual machines get
an address on this private network from the virtual DHCP server.
Figure 12-2. NAT Configuration
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NAT
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The virtual machine and the host system share a single network identity that is not visible on the external
network. NAT works by translating the IP addresses of virtual machines in the private network to the IP
address of the host system. When a virtual machine sends a request to access a network resource, it
appears to the network resource as if the request is coming from the host system.
The host system has a virtual network adapter on the NAT network. This adapter enables the host system
and virtual machines to communicate with each other. The NAT device passes network data between one
or more virtual machines and the external network, identifies incoming data packets intended for each
virtual machine, and sends them to the correct destination.

Configuring Host-Only Networking
When you install Workstation Player on a Windows or Linux host system, a host-only network (VMnet1) is
set up for you. Host-only networking is useful if you need to set up an isolated virtual network. In a hostonly network, the virtual machine and the host virtual network adapter are connected to a private Ethernet
network. The network is completely contained within the host system.
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The network connection between the virtual machine and the host system is provided by a virtual network
adapter that is visible on the host operating system. The virtual DHCP server provides IP addresses on
the host-only network.
Figure 12-3. Host-Only Networking Configuration
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In the default configuration, a virtual machine in a host-only network cannot connect to the Internet. If you
install the proper routing or proxy software on the host system, you can establish a connection between
the host virtual network adapter and a physical network adapter on the host system to connect the virtual
machine to a Token Ring or other non-Ethernet network.
On a Windows host computer, you can use host-only networking in combination with the Internet
Connection Sharing feature in Windows to allow a virtual machine to use the dial-up networking adapter
or other connection to the Internet on the host system. See Microsoft documentation for information on
configuring Internet Connection Sharing.

Configure Host-Only Networking for an Existing Virtual Machine
You can configure host-only networking for an existing virtual machine. You can connect a virtual network
adapter to the default host-only network (VMnet1) or to a custom host-only network. If a virtual machine
has two virtual network adapters, you can connect it to two host-only networks.
To configure host-only networking for a new virtual machine, select Customize Hardware when you run
the New Virtual Machine wizard.
Prerequisites

To connect the virtual machine to two host-only networks, add a second virtual network adapter to the
virtual machine. See Add a Virtual Network Adapter to a Virtual Machine.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab select a virtual network adapter.
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3

Select the host-only network.
Option

Action

Use the default host-only network
(VMnet1)

Select Host-only: A private network shared with the host.

Use a custom host-only network

Select Custom and select the custom host-only network from the drop-down
menu.

4

To connect the virtual machine to a second host-only network, select another virtual network adapter
and select the second host-only network.

5

Click OK to save your changes.

What to do next

Assign IP addresses to the virtual network adapters. To see the IP address that a host-only network is
using, use the ipconfig command on the Linux host.

Changing a Networking Configuration
You can determine the type of network that a virtual machine is using, add virtual network adapters to a
virtual machine, and change the configuration of existing virtual network adapters.

Find the Network Type of a Virtual Machine
Unless you configure a custom network connection, a virtual machine uses a bridged, NAT, or host-only
network connection. When you use the New Virtual Machine wizard to create a virtual machine, the new
virtual machine defaults to using the NAT network type.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Network Adapter.

Add a Virtual Network Adapter to a Virtual Machine
You can add up to 10 virtual network adapters to a virtual machine.
Prerequisites

Familiarize yourself with the network configuration types. See Understanding Common Networking
Configurations.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, click Add.

3

To add the virtual network adapter to the virtual machine, select Network Adapter and click Finish.
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4

Select the virtual network adapter type.
Option

Description

Bridged

The virtual machine is connected to the network by using the network adapter on
the host system. The virtual machine has a unique identity on the network,
separate from and unrelated to the host system.

NAT

The virtual machine and the host system share a single network identity that is not
visible on the external network. When the virtual machine sends a request to
access a network resource, it appears to the network resource as if the request is
coming from the host system.

Host-only

The virtual machine and the host virtual network adapter are connected to a private
Ethernet network. The network is completely contained within the host system.

5

(Optional) Select the Connect at power on checkbox.

6

Click Finish to add the virtual network adapter to the virtual machine.

7

Click OK to save your changes.

8

Verify that the guest operating system is configured to use an appropriate IP address on the new
network.
a

If the virtual machine is using DHCP, release and renew the lease.

b

If the IP address is set statically, verify that the guest operating system has an address on the
correct virtual network.

Modify an Existing Virtual Network Adapter for a Virtual Machine
You can change the settings of a virtual network adapter that is currently used by a virtual machine.
Prerequisites

Familiarize yourself with the network configuration types. See Understanding Common Networking
Configurations.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select the virtual network adapter.

3

Select the virtual network adapter type.
Option

Description

Bridged

The virtual machine is connected to the network by using the network adapter on
the host system. The virtual machine has a unique identity on the network,
separate from and unrelated to the host system.

NAT

The virtual machine and the host system share a single network identity that is not
visible on the external network. When the virtual machine sends a request to
access a network resource, it appears to the network resource as if the request is
coming from the host system.
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Option

Description

Host-only

The virtual machine and the host virtual network adapter are connected to a private
Ethernet network. The network is completely contained within the host system.

Custom

Select a custom network from the drop-down menu. Although VMnet0, VMnet1,
and VMnet8 might be available in this list, these networks are usually used for
bridged, host-only, and NAT networks.

LAN segment

Select a LAN segment from the drop-down menu. A LAN segment is a private
network that is shared by other virtual machines.

4

Click OK to save your changes.

5

Verify that the guest operating system is configured to use an appropriate IP address on the new
network.
a

If the virtual machine is using DHCP, release and renew the lease.

b

If the IP address is set statically, verify that the guest operating system has an address on the
correct virtual network.

Enable Jumbo Frames
With Workstation Player, you can enable jumbo frames for VMware virtual networks.
Jumbo frames let you send larger frames out onto the physical network or between virtual machines on
the same host.

Enable Jumbo Frames on Linux Host
With Workstation Player, you can enable jumbo frames for VMware virtual networks using the Virtual
Network Editor on Linux.
Procedure

1

To launch the Virtual Network Editor, run the vmware-netcfg command in the terminal or click Edit
> Virtual Network Editor from the UI.
Note The Edit > Virtual Network Editor option is only available in Workstation Pro.

2

Enter the super user password, and click Authenticate.

3

To configure jumbo frames, enter a value between 68 bytes and 9194 bytes in the MTU text box and
click Save.

Jumbo frame is enabled.
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Configuring Virtual Machine
Option Settings

13

Virtual machine options settings control characteristics of individual virtual machines, such as how files
are transferred between the host and guest operating system and what happens to a guest operating
system when you exit Workstation Player. Some virtual machine options override similar Workstation
Player preference settings.
To configure virtual machine option settings for a selected virtual machine, select Virtual Machine >
Virtual Machine Settings and click the Options tab.
This chapter includes the following topics:
n

Configuring General Option Settings for a Virtual Machine

n

Configuring Power Options for a Virtual Machine

n

Configuring VMware Tools Options for a Virtual Machine

n

Configuring Autologin for a Virtual Machine

Configuring General Option Settings for a Virtual Machine
General option settings include the virtual machine name, the guest operating system type and version,
and the location of the directory where virtual machine files are stored.
To configure general option settings for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Options tab, and select General.
n

Changing a Virtual Machine Name
You can change the name of a virtual machine. Changing the name of the virtual machine does not
change the name of this directory, nor does it rename the virtual machine files on the host.
Workstation Player uses the original name of the virtual machine to create the directory where virtual
machine files are stored.

n

Changing the Guest Operating System
You can change the guest operating system or operating system version for a virtual machine. You
might want to change the guest operating system for a virtual machine when you upgrade the guest
operating system or if you specified the wrong operating system version when you created the
virtual machine.
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n

Changing the Virtual Machine Working Directory
You can change the working directory for a virtual machine. The working directory is where
Workstation Player stores suspended state (.vmss), snapshot (.vmsn), and virtual machine paging
(.vmem) files. By default, the working directory is where the virtual machine files are stored.

Changing a Virtual Machine Name
You can change the name of a virtual machine. Changing the name of the virtual machine does not
change the name of this directory, nor does it rename the virtual machine files on the host. Workstation
Player uses the original name of the virtual machine to create the directory where virtual machine files are
stored.
To specify a new name for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Options tab, and select General.

Changing the Guest Operating System
You can change the guest operating system or operating system version for a virtual machine. You might
want to change the guest operating system for a virtual machine when you upgrade the guest operating
system or if you specified the wrong operating system version when you created the virtual machine.
To select a new guest operating system or operating system version for a selected virtual machine, select
Virtual Machine > Virtual Machine Settings, click the Options tab, and select General.
When you change the operating system type, the virtual machine configuration file is changed but the
guest operating system is not changed. To change the guest operating system, you must obtain the
operating system software and upgrade the guest operating system.
The virtual machine must be powered off when you change these settings.

Changing the Virtual Machine Working Directory
You can change the working directory for a virtual machine. The working directory is where Workstation
Player stores suspended state (.vmss), snapshot (.vmsn), and virtual machine paging (.vmem) files. By
default, the working directory is where the virtual machine files are stored.
To specify a new working directory for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Options tab, and select General.
You might want to change the working directory in the following situations.
n

To run a virtual machine that is stored on a network share or iPod, which might slow performance,
you can change the working directory to your local hard disk.

n

To create a paging file on a fast disk with a lot of disk space but leave the virtual disk and
configuration file on a different disk, you can change the working directory so that it is located on the
fast disk.

Changing the working directory does not change the directory where Workstation Player stores the virtual
machine configuration (.vmx) file and log files.
The virtual machine must be powered off when you change this setting.
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Configuring Power Options for a Virtual Machine
Power options control how a virtual machine behaves after it is powered off, closed, or suspended.
To configure power options for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Options tab, and select Power.
Table 13-1. Power Options
Option

Description

Enter full screen mode after powering on

The virtual machine window enters full screen mode after it is powered on.

Report battery information to guest

Battery information is reported to the guest operating system. If you run the virtual
machine on a laptop in full screen mode, this option enables you to determine
when the battery is running low. This option is available only for Workstation 6.x
and later virtual machines.

Configuring VMware Tools Options for a Virtual Machine
You can configure how VMware Tools is updated on a virtual machine. You can also configure whether
the clock on the guest operating system is synchronized with the clock on the host.

VMware Tools Update Options
The virtual machine VMware Tools update options override the Workstation Player preferences for
automatically updating VMware Tools on Linux and Windows guest operating systems.
To configure VMware Tools updates for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Options tab, and select VMware Tools.
Note Automatic updates are not supported for versions of VMware Tools included in virtual machines
created with older versions of VMware products, such as Workstation 5.5 and earlier or VMware Server
1.x.
Table 13-2. VMware Tools Update Options
Option

Description

Update manually (do nothing)

You must update VMware Tools manually. A message appears on the
status bar of the guest operating system when a new version of
VMware Tools is available.

Update automatically

VMware Tools is updated automatically when a new version is
available. The status bar indicates when an update is in progress.

Use application default (currently update automatically)

Use the default VMware Tools update behavior.

To install a VMware Tools update, use the same procedure that you used for installing VMware Tools the
first time.
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Time Synchronization
If you turn on the VMware Tools time synchronization feature, VMware Tools checks once every minute to
determine whether the clocks on the guest and host operating systems still match. If not, the clock on the
guest operating system is synchronized to match the clock on the host.
Native time synchronization software, such as Network Time Protocol (NTP) for Linux and the Mac OS X,
or Microsoft Windows Time Service (Win32Time) for Windows, is typically more accurate than VMware
Tools periodic time synchronization and is therefore preferred.

Configuring Autologin for a Virtual Machine
You can configure the Autologin feature for virtual machines that have a Windows 2000 or later guest
operating system. To use Autologin, the virtual machine must be powered on, you must have an existing
user account on the local machine, and the latest version of VMware Tools must be installed.
To configure Autologin for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Options tab, and select Autologin.
When you enable Autologin, you must type your login credentials. If you type an incorrect or expired
password, you must type your login credentials when you power on the virtual machine. To change your
login credentials, select Change User.
Note When you enable Autologin or change your login credentials, Autologin settings are saved
immediately. If you click Cancel in the Virtual Machine Settings dialog box, the changes applied to the
Autologin settings are not affected.

VMware, Inc.

134

Configuring Virtual Machine
Hardware Settings

14

You can use virtual machine hardware settings to add, remove, and modify virtual devices for a virtual
machine.
To configure hardware settings for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings and click the Hardware tab. When you select a device in the left pane, the configuration options
for that device appear in the right pane.
This chapter includes the following topics:
n

Adding Hardware to a Virtual Machine

n

Removing Hardware from a Virtual Machine

n

Adjusting Virtual Machine Memory

n

Configuring Virtual Machine Processor Settings

n

Configuring and Maintaining Virtual Hard Disks

n

Configuring CD-ROM and DVD Drive Settings

n

Configuring Floppy Drive Settings

n

Configuring Virtual Network Adapter Settings

n

Configuring USB Controller Settings

n

Configuring Sound Card Settings

n

Configuring Parallel Port Settings

n

Configuring Serial Port Settings

n

Configuring Generic SCSI Device Settings

n

Configuring Printer Settings

n

Configuring Display Settings

n

Installing a Guest Operating System on a Physical Disk or Unused Partition

Adding Hardware to a Virtual Machine
You can use virtual machine hardware settings to add hardware to an existing virtual machine.
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To add hardware to a selected virtual machine, select Virtual Machine > Virtual Machine Settings, click
the Hardware tab, and click Add.
Note You cannot add hardware to a virtual machine while it is in a suspended state.
The Add Hardware wizard prompts you to select the type of device that you want to add and to specify
device-specific configuration settings. You can modify many of the configuration settings after the device
is created by changing virtual machine hardware settings.
You can add the following types of devices to a virtual machine.
Virtual hard disks

A virtual hard disk is a set of files that appears as a physical disk drive to
the guest operating system. You can configure a virtual hard disk as an
IDE, SCSI, SATA, or NVMe device. You can add up to 4 IDE devices, up to
60 SCSI devices, up to 120 SATA devices (4 controllers and 30 devices per
controller), and up to 60 NVMe devices (4 controllers and 15 devices per
controller) to a virtual machine. You can also give a virtual machine direct
access to a physical disk.

CD-ROM and DVD
drives

You can configure a virtual CD-ROM or DVD drive as an IDE, SCSI, or
SATA device. You can add up to 4 IDE devices, up to 60 SCSI devices, and
up to 120 SATA devices (4 controllers and 30 devices per controller). You
can connect virtual CD-ROM and DVD drives to a physical drive on the
host system or to an ISO image file.

Floppy drives

You can add up to two floppy drives. A virtual floppy drive can connect to a
physical drive on the host system, to an existing floppy image file, or to a
blank floppy image file.

Network adapters

You can add up to 10 virtual network adapters to a virtual machine.

USB controller

You can add one USB controller to a virtual machine. A virtual machine
must have a USB controller to use USB devices or smart card readers. For
smart card readers, a virtual machine must have a USB controller
regardless of whether the smart card reader is actually a USB device.

Sound card

If the host system is configured for sound and has a sound card installed,
you can enable sound for virtual machines.

Parallel (LPT) ports

You can attach up to three bidirectional parallel ports to a virtual machine.
Virtual parallel ports can output to parallel ports or to files on the host
operating system.

Serial (COM) ports

You can add up to four serials ports to a virtual machine. Virtual serial ports
can output to physical serial ports, files on the host operating system, or
named pipes.

Printers

You can print from a virtual machine to any printer available to the host
system without installing additional drivers in the virtual machine.
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Workstation Player uses ThinPrint technology to replicate the host machine
printer mapping in the virtual machine. When you enable the virtual
machine printer, Workstation Player configures a virtual serial port to
communicate with the host printers.
Generic SCSI devices

You can add up to 60 SCSI devices to a virtual machine. A generic SCSI
device gives the guest operating system direct access to a SCSI device
connected to the host system. Generic SCSI devices can include scanners,
tape drives, CD-ROM drives, and DVD drives.

Removing Hardware from a Virtual Machine
You can remove certain types of hardware from a virtual machine.
To remove hardware from a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Hardware tab, and click Remove.
Note You cannot remove hardware from a virtual machine while it is in suspended state.
You can remove the following types of devices from a virtual machine.
n

Virtual hard disks

n

CD-ROM and DVD drives

n

Floppy drives

n

Virtual network adapters

n

USB controllers

n

Sound cards

n

Printers

n

Generic SCSI devices

You cannot remove the Memory, Processors, and Display device types.
You must power off a virtual machine before you remove a virtual network adapter, sound card, parallel
port, serial port, or generic SCSI device. You must also power off Workstation 5 virtual machines before
you remove a USB controller.

Adjusting Virtual Machine Memory
You can adjust the amount of memory that is allocated to a virtual machine. You must power off a virtual
machine before you change its memory allocation setting.
To adjust the memory allocation for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Hardware tab, and click Memory.
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The Memory panel includes information to help you select the appropriate amount of memory for the
virtual machine. The high end of the range is determined by the amount of memory that is allocated to all
running virtual machines. If you allow virtual machine memory to be swapped, this value changes to
reflect the specified amount of swapping.
The color-coded icons on the Memory panel indicate the maximum recommended memory, the
recommended memory, and the guest operating system recommended minimum memory amounts. To
adjust the memory, move the slider along the range of values, or type a value in the Memory for this
virtual machine text box.
Note Allocating more than the maximum memory to a virtual machine might cause memory swapping. It
can also negatively affect host system performance, including the ability to run Workstation Player.

Configuring Virtual Machine Processor Settings
You can configure processor settings for a virtual machine, including the number of processors, the
number of cores per processor, and the preferred execution mode for the virtualization engine.
To configure processor settings for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Hardware tab, and select Processors.
Table 14-1. Processor Settings
Setting

Description

Number of cores per processor

Select the number of cores per processor.
Workstation Player supports up to 16-way virtual Symmetric Multiprocessing
(SMP) for guest operating systems running on multiprocessor host machines.
You can assign processors and cores per processor to a virtual machine on any
host machine that has at least two logical processors.

Virtualize Intel VT-x/EPT or AMD-V/RVI

Workstation Player forces the virtual machine execution mode to VT-x/EPT or
AMD-RVI. Physical Address Extension (PAE) mode must be enabled to use
virtualized AMD-V/RVI.
If the execution mode is not supported by the host system, virtualized VT-x/EPT
or AMD/RVI is not available. If you migrate the virtual machine to another
VMware product, virtualized VT-x/EPT or AMD-V/RVI might not be available.

Virtualize CPU performance counters

Turn on this feature if you plan to use performance monitoring applications such
as VTune or OProfile to optimize or debug software that runs inside the virtual
machine.
This feature is available only if the virtual machine compatibility is Workstation 9
or later.

Configuring and Maintaining Virtual Hard Disks
You can configure virtual hard disk node and mode settings. You can also use command in the Utilities
menu to perform common disk maintenance tasks, such as defragmenting, compacting, and expanding a
disk.
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To perform actions on a virtual hard disk for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Hardware tab, and select the virtual hard disk.
n

Defragmenting Virtual Hard Disks
Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks
rearranges files, programs, and unused space on the virtual disk so that programs run faster and
files open more quickly. Defragmenting does not reclaim unused space on a virtual disk.

n

Expanding Virtual Hard Disks
Expanding a virtual hard disk adds storage space to the virtual machine.

n

Compacting Virtual Hard Disks
Compacting a virtual hard disk can reclaim unused space in the virtual disk. Modern disks and
operating systems are much more efficient at managing disk space than in the recent past.
Therefore, do not expect the compacting procedure to return large amounts of disk space to the host
drive.

n

Mapping a Virtual Disk to the Host System
Instead of using shared folders or copying data between a virtual machine and the host system, you
can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system
as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going
into a virtual machine.

n

Changing Virtual Hard Disk Node and Mode Settings
You can change virtual hard disk node and mode settings.

Defragmenting Virtual Hard Disks
Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges
files, programs, and unused space on the virtual disk so that programs run faster and files open more
quickly. Defragmenting does not reclaim unused space on a virtual disk.
There must be adequate free working space on the host system to defragment a virtual hard disk. If the
disk is contained in a single file, for example, you need free space equal to the size of the disk file. Other
virtual hard disk configurations require less free space. You cannot defragment a virtual hard disk while it
is mapped or mounted.
To defragment a virtual hard disk for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Hardware tab, select the virtual hard disk, and select Defragment from the
Utilities menu.
Note Defragmenting a virtual hard disk can take several minutes.

Expanding Virtual Hard Disks
Expanding a virtual hard disk adds storage space to the virtual machine.
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When you expand a virtual hard disk, the added space is not immediately available to the virtual machine.
To make the added space available, you must use a disk management tool to increase the size of the
existing partition on the virtual hard disk to match the expanded size.
The disk management tool that you use depends on the virtual machine guest operating system. Many
operating systems, including Windows 7 and later, and many versions of Linux, provide built-in disk
management tools that can resize partitions. Third-party disk management tools are also available, such
as Symantec/Norton PartitionMagic, EASEUS Partition Master, Acronis Disk Director, and the opensource tool GParted.
When you expand the size of a virtual hard disk, partition and file-system size are not affected.
To expand a virtual hard disk for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, select the virtual hard disk, and select Expand from the Utilities menu.
Note As an alternative to expanding a virtual hard disk, you can add a new virtual hard disk to the virtual
machine.

Compacting Virtual Hard Disks
Compacting a virtual hard disk can reclaim unused space in the virtual disk. Modern disks and operating
systems are much more efficient at managing disk space than in the recent past. Therefore, do not expect
the compacting procedure to return large amounts of disk space to the host drive.
You cannot compact a virtual hard disk if disk space is preallocated or if the virtual hard disk is mapped or
mounted.
To compact a virtual hard disk for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Hardware tab, select the virtual hard disk, and select Compact from the Utilities
menu.

Mapping a Virtual Disk to the Host System
Instead of using shared folders or copying data between a virtual machine and the host system, you can
map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a
separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a
virtual machine.

Map or Mount a Virtual Disk to a Drive on the Host System
When you map a virtual disk and its associated volume to a drive on the host system, you can connect to
the virtual disk without opening a virtual machine.
After you map the virtual disk to a drive on the host system, you cannot power on any virtual machine that
uses the disk until you disconnect the disk from the host system.
Important If you mount a virtual disk that has a snapshot and then write to the disk, you can irreparably
damage a snapshot or linked clone created from the virtual machine. Note that Workstation Player does
not support taking snapshots or deleting them.
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Mapping a virtual disk to a host system is not supported in the standalone version of Workstation Player.
Virtual disk mapping is supported in the Workstation Player version included with Workstation Pro.
Prerequisites
n

Power off all virtual machines that use the virtual disk.

n

Verify that the virtual disk (.vmdk) files on the virtual disk are not compressed and do not have readonly permissions.

n

Verify that the virtual disk is unencrypted. You cannot map or mount encrypted disks.

Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Hard Disk, click Utilities, and select Map.

3

On a Linux host, select the Mount in read-only mode check box in the Mount Disk dialog box.
This setting prevents you from accidentally writing data to a virtual disk that might be the parent of a
snapshot or linked clone. Writing to such a disk might make the snapshot or linked clone unusable.

4

Browse to a virtual disk (.vmdk) file, select it, and click Open.

5

Select the volume to map or mount and select an unused drive letter on the host system.

6

Click OK or Mount.
The drive appears on the host system. You can read from or write to files on the mapped virtual disk
on the host system.

Disconnect a Virtual Disk from the Host System
To use a virtual disk from a virtual machine after it has been mapped or mounted on the host system, you
must disconnect it from the host system.
Procedure

1

Select the virtual machine and select Virtual Machine > Virtual Machine Settings.

2

On the Hardware tab, select Hard Disk, click Utilities, and select Disconnect.

You can now power on any virtual machine that uses this disk.

Changing Virtual Hard Disk Node and Mode Settings
You can change virtual hard disk node and mode settings.
To change the node and mode settings for a virtual hard disk on a selected virtual machine, select Virtual
Machine > Virtual Machine Settings, click the Hardware tab, select the virtual hard disk, and click
Advanced. By default, changes are immediately written to the disk.
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Table 14-2. Virtual Hard Disk Node and Mode Settings
Setting

Description

Virtual device node

Select the SCSI, IDE, SATA, or NVMe device identifier to use for the drive. For example, if
you select SCSI 0:2, the guest operating system detects the drive as ID 2 on controller 0. You
determine whether the virtual disk is seen as a SCSI, IDE, SATA, or NVMe device at the time
that you create it.

Configuring CD-ROM and DVD Drive Settings
You can configure CD-ROM and DVD drive settings, including the virtual device node and legacy
emulation modes.
To configure CD-ROM and DVD drive settings for a selected virtual machine, select Virtual Machine >
Virtual Machine Settings, click the Hardware tab, and select the drive.
n

Configuring CD-ROM and DVD Drive Status and Connection Settings
Device status and connection settings control when a CD-ROM or DVD drive is connected to a
virtual machine, whether to use a specific drive or allow Workstation Player to detect a drive, and
whether to use an ISO image file instead of a physical drive.

n

Changing Virtual Device Node and Legacy Emulation Settings
You can use the advanced settings to change the virtual device node and legacy emulation settings
for a CD-ROM or DVD drive. You must power off the virtual machine before you change these
settings.

Configuring CD-ROM and DVD Drive Status and Connection
Settings
Device status and connection settings control when a CD-ROM or DVD drive is connected to a virtual
machine, whether to use a specific drive or allow Workstation Player to detect a drive, and whether to use
an ISO image file instead of a physical drive.
To configure device status and connection settings for a selected virtual machine, select Virtual Machine
> Virtual Machine Settings, click the Hardware tab, and select the drive.
Table 14-3. Device Status and Connection Settings
Setting

Description

Connected

Connect the drive or ISO image file while the virtual machine is running.

Connect at power on

Connect the drive or ISO image path when you power on the virtual machine.

Use physical drive

Select a specific drive or select Auto detect to allow Workstation Player to detect a
drive to use.

Use ISO image file

Specify or select an ISO image file for the virtual machine to use.
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To disable or enable access to a CD-ROM or DVD drive while a virtual machine is running, select the
virtual machine, select Virtual Machine > Removable Devices > CD/DVD, and select Disconnect or
Connect.

Changing Virtual Device Node and Legacy Emulation Settings
You can use the advanced settings to change the virtual device node and legacy emulation settings for a
CD-ROM or DVD drive. You must power off the virtual machine before you change these settings.
To configure virtual device and legacy emulation settings for a selected virtual machine, select Virtual
Machine > Virtual Machine Settings, click the Hardware tab, select the drive, and click Advanced.
Use the settings to select which SCSI, IDE, SATA, or NVMe device identifier to use for the drive. For
example, if you select SCSI 0:2, the guest operating system detects the drive as ID 2 on controller 0. You
can select the IDE, SCSI, SATA, or NVMe node options regardless of the physical device type. For
example, if the physical drive is an IDE device, you can select a SCSI node. In this case, the virtual
machine detects the drive as a SCSI device.
If you select the Legacy emulation setting, the virtual hardware works as it did in an earlier release of
Workstation Player. By default, Workstation Player attempts to make the advanced features of your drive
available, but sometimes this setting might cause the drive to not work with the virtual machine. Selecting
the Legacy emulation setting reverts Workstation Player to the previous emulation mode for the drive.
Legacy emulation is helpful for troubleshooting purposes.

Configuring Floppy Drive Settings
You can configure when a floppy drive is connected to a virtual machine, whether to use a specific drive
or allow Workstation Player to detect a drive, and whether to use an disk drive image file instead of a
physical drive.
To configure floppy drive settings for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Hardware tab, and select the floppy drive.
Table 14-4. Floppy Drive Settings
Setting

Description

Connected

Connect the drive or floppy image file while the virtual machine is running.

Connect at power on

Connect the floppy drive when you power on the virtual machine.

Use a physical drive

Select a specific floppy drive or select Auto detect to allow Workstation Player to detect
a drive to use.

Use a floppy image file

Create or browse to a floppy image (.img or .flp) file. Select Read only to prevent
changes from being made to the file.

To disable or enable access to a floppy drive while a virtual machine is running, select the virtual
machine, select Virtual Machine > Removable Devices > Floppy, and select Disconnect or Connect.
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Configuring Virtual Network Adapter Settings
You can configure when a virtual network adapter is connected to a virtual machine and the type of
network connection that the adapter provides.
To configure virtual network adapter settings for a selected virtual machine, select Virtual Machine >
Virtual Machine Settings, click the Hardware tab, and select the virtual network adapter.
n

Configuring Virtual Network Adapter Device Status Settings
Device status settings control when a virtual network adapter is connected to a virtual machine.

n

Configuring Bridged Networking
When you configure bridged networking, the virtual machine uses physical network adapters on the
host system to connect a network.

n

Configuring Network Address Translation
When you configure Network Address Translation (NAT), the virtual machine shares the IP address
and MAC address of the host system.

n

Configuring Host-Only Networking
When you configure host-only networking, Workstation Player creates a virtual private network
(VPN) connection between the virtual machine and the host system.

n

Configuring LAN Segments
When you select a LAN segment, the virtual machine uses a private network that can be shared with
other virtual machines. LAN segments are useful for multitier testing, network performance analysis,
and situations where virtual machine isolation are important.

n

Configuring Virtual Network Adapter Advanced Settings
You can use the advanced virtual network adapter settings to limit the bandwidth, specify the
acceptable packet loss percentage, and create network latency for incoming and outgoing data
transfers for a virtual machine.

Configuring Virtual Network Adapter Device Status Settings
Device status settings control when a virtual network adapter is connected to a virtual machine.
To configure virtual network adapter device status settings for a selected virtual machine, select Virtual
Machine > Virtual Machine Settings, click the Hardware tab, and select the virtual network adapter.
Table 14-5. Device Status Settings
Setting

Description

Connected

Connect the virtual network adapter while the virtual machine is running.

Connect at power on

Connect the virtual network adapter when you power on the virtual machine.
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Configuring Bridged Networking
When you configure bridged networking, the virtual machine uses physical network adapters on the host
system to connect a network.
If the host system is on a network, bridged networking is often the easiest way to give a virtual machine
access to that network.
With bridged networking, the virtual machine appears as an additional computer on the same physical
Ethernet network as the host system. The virtual machine can transparently use the services available on
the network, including file servers, printers, and gateways. Physical hosts and other virtual machines
configured with bridged networking can also use the resources of the virtual machine.
When you use bridged networking, the virtual machine must have its own identity on the network. For
example, on a TCP/IP network, the virtual machine must have its own IP address. Virtual machines
typically acquire an IP address and other network details from a DHCP server. In some configurations,
you might need to set the IP address and other details manually.
Users who boot multiple operating systems often assign the same address to all systems because they
assume that only one operating system will be running at the same time. If the host system is set up to
boot multiple operating systems and you run one or more of them in virtual machines, configure each
operating system with a unique network address.
When the Replicate physical connection state option is selected, the IP address is automatically
renewed when you move from one wired or wireless network to another. This setting is useful for virtual
machines than run on laptops or other mobile devices.

Changing Automatic Bridging Settings
When automatic bridging mode is configured, you can restrict the physical network adapters that a virtual
switch bridges to.
To change automatic bridging settings, select Player > Virtual Machine Settings > Network Adapter >
Configure Adapters, select the host network adapter(s) to automatically bridge, and click OK.
By default, a virtual switch bridges to all active network adapters on the host system when it is configured
for automatic bridging. The choice of which adapter to use is arbitrary.
To prevent a virtual switch from bridging to a particular physical network adapter, deselect the check box
for that host network adapter.

Configuring Network Address Translation
When you configure Network Address Translation (NAT), the virtual machine shares the IP address and
MAC address of the host system.
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The virtual machine and the host system share the a single identity that is not visible outside the network.
The virtual machine does not have its own IP address. Instead, a separate private network is set up on
the host system and the virtual machine obtains an address on that network from the VMware virtual
DHCP server. The VMware NAT device passes network data between one or more virtual machines and
the external network. The VMware NAT device identifies incoming data packets that are intended for each
virtual machine and sends them to the correct destination.
With NAT, a virtual machine can use many standard protocols to connect to other machines on the
external network. For example, you can use HTTP to browse Web sites, FTP to transfer files, and Telnet
to log in to other systems. You can also connect to a TCP/IP network by using a Token Ring adapter on
the host system.
In the default configuration, systems on the external network cannot initiate connections to the virtual
machine. For example, the default configuration does not let you use the virtual machine as a Web server
to send Web pages to systems on the external network. This limitation protects the guest operating
system from being compromised before you can install security software.
By default, NAT is used when you use the New Virtual Machine wizard to create a virtual machine.
The virtual machine uses NAT to connect to the Internet or other TCP/IP network by using the networking
connection on the host system. NAT works with Ethernet, DSL, and phone modems. A separate private
network is set up on the host system. The virtual machine obtains an address on that network from the
VMware virtual DHCP server.

Configuring Host-Only Networking
When you configure host-only networking, Workstation Player creates a virtual private network (VPN)
connection between the virtual machine and the host system.
A VPN is typically not visible outside the host system. Multiple virtual machines configured with host-only
networking on the same host system are on the same network. The VMware DHCP server provides
addresses on the network.
If you install the proper routing or proxy software on the host system, you can establish a connection
between the host virtual network adapter and a physical network adapter on the host system. With this
configuration, you can connect the virtual machine to a Token Ring or other non-Ethernet network.

Configuring LAN Segments
When you select a LAN segment, the virtual machine uses a private network that can be shared with
other virtual machines. LAN segments are useful for multitier testing, network performance analysis, and
situations where virtual machine isolation are important.
If you add an existing virtual machine to a LAN segment, the virtual machine might be configured to
expect an IP address from a DHCP server. Unlike host-only and NAT networking, Workstation Player
does not provide a DHCP server for LAN segments. You must manually configure IP addressing for
virtual machines on a LAN segment. You can either configure a DHCP server on the LAN segment to
allocate IP addresses, or you can configure a fixed IP address for each virtual machine on the LAN
segment.

VMware, Inc.

146

Using VMware Workstation Player for Linux

You can click LAN Segments to create new LAN segments or delete and rename existing LAN
segments. Deleting a LAN segment disconnects all virtual network adapters that are configured for that
LAN segment. When you delete a LAN segment, you must manually configure its disconnected virtual
network adapter to reconnect the virtual machine to the network.

Configuring Virtual Network Adapter Advanced Settings
You can use the advanced virtual network adapter settings to limit the bandwidth, specify the acceptable
packet loss percentage, and create network latency for incoming and outgoing data transfers for a virtual
machine.
The advanced virtual network adapter settings allow you to simulate a network environment that differs
from your own.
To configure advanced virtual network adapter settings for a selected virtual machine, select Virtual
Machine > Virtual Machine Settings, click the Hardware tab, select the virtual network adapter, and
click Advanced.
Table 14-6. Virtual Network Adapter Advanced Settings
Setting

Description

Bandwidth and Kbps

To limit incoming or outgoing data transfers to the data transfer rate for a specific
network connection type, select the network connection type from the Bandwidth dropdown menu. The value in the Kbps text box changes to the data transfer rate, in
kilobits per second, of the network connection type that you select. For example, if you
select Leased Line T1 (1.544 Mbps), the value in the Kbps text box changes to 1544.
To limit incoming or outgoing data transfers to a specific data transfer rate, select
Custom and type the data transfer rate in kilobits per second in the Kbps text box.
The default bandwidth setting for both incoming and outgoing data transfers is
Unlimited.

Packet Loss (%)

The acceptable packet loss percentage for incoming or outgoing data transfers. The
default setting is 0.0%.

Latency (ms)

To simulate network latency for incoming and outgoing data transfers, set the number
of milliseconds (ms) of latency. The latency range is 0 to 2,000 ms.
Note Expect actual network latency to be up to 10 ms above the number you set. For
example, if you set latency at 200 ms, expect the actual latency to be between 200 to
210 ms.

MAC Address

To assign a new MAC address to the network adapter, either type a new address in this
text box or click Generate to have Workstation Player generate a new address.

Configuring USB Controller Settings
You can configure whether a USB controller supports isochronous USB and Bluetooth devices, when to
connect new USB devices to the host system, and whether human interface devices (HIDs) appear in the
Removable Devices menu.
To configure USB controller settings for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Hardware tab, and click USB Controller.
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Table 14-7. USB Controller Settings
Setting

Description

USB Compatibility

Selecting USB 2.0 or 3.0 enables support for isochronous USB devices,
including Web cams, speakers, and microphones.

Automatically connect new USB devices

Connect new USB devices to the virtual machine. If this setting is not
selected, new USB devices are connected only to the host system.

Show all USB input devices

Human interface devices (HIDs), such as USB 1.1 and 2.0 mouse and
keyboard devices, appear in the Removable Devices menu. Icons for
HIDs appear in the status bar. An HID that is connected to the guest
operating system is not available to the host system. The virtual machine
must be powered off when you change this setting.

Share Bluetooth devices with the virtual machine

Enable support for Bluetooth devices.

To connect or disconnect USB devices while a virtual machine is running, select the virtual machine and
select Virtual Machine > Removable Devices. With the two-port USB controller, you can connect to both
USB 1.1 and USB 2.0 devices.
Important Before you unplug a USB device or select a removable device to disconnect a USB device
from a virtual machine, follow the device manufacturer's procedures for safely unplugging the device from
a physical computer.

Configuring Sound Card Settings
You can configure when a sound card is connected to a virtual machine. You can also configure whether
a virtual machine uses a specific sound card or the default sound card in the host system.
To configure sound card settings for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Hardware tab, and click Sound Card.
Table 14-8. Sound Card Settings
Setting

Description

Connected

Connect the sound device while the virtual machine is running.

Connect at power on

Connect the sound device when you power on the virtual machine.

Use default host sound card

Make the virtual machine use the default sound card in the host system.

Specify host sound card

(Windows hosts only) Select a specific host sound card for the virtual machine to use.

Use physical sound card

(Linux hosts only) Select a specific host sound card to for the virtual machine to use.

Enable Echo Cancellation

Enable echo cancellation for the sound card.

Configuring Parallel Port Settings
You can configure when a parallel port is connected to a virtual machine and whether to send output to a
physical port or to a file on the host system.
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To configure parallel port settings for a selected virtual machine, select Virtual Machine > Virtual
Machine Settings, click the Hardware tab, and select the parallel port.
Table 14-9. Parallel Port Settings
Setting

Description

Connected

Connect the port while the virtual machine is running.

Connect at power on

Connect the port when you power on the virtual machine.
If the guest operating system cannot access the parallel port device when you
power on the virtual machine, deselect this setting. You can use the
Removable Devices menu to enable access to the parallel port after the
virtual machine is powered on.

Use a physical parallel port

Select a host parallel port for the virtual machine to use.

Use output file

Send output from the virtual parallel port to a file on the host system. Either
locate an existing output file or browse to a directory and type a filename to
create a new output file.

Configuring Serial Port Settings
You can configure when a serial port is connected to a virtual machine. You can also configure whether to
send output to a physical port or to a file on the host system, set up a direct connection between two
virtual machines, and specify whether the guest operating system uses the port in polled mode.
To configure serial port settings for a selected virtual machine, select the virtual machine, select Virtual
Machine > Virtual Machine Settings, click the Hardware tab, and select the serial port.
Table 14-10. Serial Port Settings
Setting

Description

Connected

Connect the port while the virtual machine is running.

Connect at power on

Connect the port when you power on the virtual machine.

Use a physical serial port

Select a host serial port.

Use output file

Send output from the virtual serial port to a file on the host system. Either
locate an existing output file or navigate to the desired directory and type a
filename for the file to create.
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Table 14-10. Serial Port Settings (continued)
Setting

Description

Use named pipe or Use socket (named pipe)

Set up a direct connection between two virtual machines or a connection
between a virtual machine and an application on the host system.
(Linux hosts) Enter /tmp/socket or another UNIX socket name in the first
field. The pipe name must be the same on both the server and the client.

Yield CPU on poll

The guest operating system uses the port in polled mode rather than
interrupt mode. It yields processor time if its only task is to poll the virtual
serial port.
If the guest operating system uses the serial port in interrupt mode, do not
select this setting.
Note This setting is useful for developers who are using debugging tools
that communicate over a serial connection. Selecting this setting can
improve performance when the guest operating system uses the serial port
in polled mode.

Configuring Generic SCSI Device Settings
You can configure when a generic SCSI device is connected to a virtual machine, specify the physical
SCSI device to connect to on the host system, and select the SCSI identifier to use for the drive.
To configure generic SCSI device settings for a selected virtual machine, select Virtual Machine >
Virtual Machine Settings, click the Hardware tab, and select the generic SCSI device.
Table 14-11. Generic SCSI Device Settings
Setting

Description

Connected

Connect the device while the virtual machine is running.

Connect at power on

Connect the device when you power on the virtual machine.

Specify the physical SCSI device to connect to

Select a host SCSI device.
(Windows hosts) Select a device. The menu shows the SCSI devices
that are available on the host system.
(Linux hosts) Type the name of the /dev/sg entry for the device to
install in the virtual machine. For example, if the device is named sga,
type /dev/sga.

Virtual device node

Select the SCSI device identifier to use for the drive. For example, if
you select SCSI 0:2, the guest operating system sees the drive as ID
2 on controller 0.
The virtual machine must be powered off when you change this
setting.

Note For specific Windows guest operating systems, you might need to perform additional configuration
steps to use a generic SCSI device.
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Configuring Printer Settings
You can configure when a printer is connected to a virtual machine.
To configure printer settings for a selected virtual machine, select Virtual Machine > Virtual Machine
Settings, click the Hardware tab, and select Printer.
Table 14-12. Printer Settings
Setting

Description

Connected

Connect the printer while the virtual machine is running.

Connect at power on

Connect the printer when you power on the virtual machine.

Configuring Display Settings
You can specify monitor resolution settings, configure multiple monitors, and select accelerated graphics
capabilities for a virtual machine.
To configure display settings for a virtual machine, select the virtual machine, select Virtual Machine >
Virtual Machine Settings, click the Hardware tab, and select Display.
Table 14-13. Display Settings
Setting

Description

Accelerate 3D graphics

Select this setting if you run applications that use DirectX 9 or DirectX 10
accelerated graphics. Accelerated graphics capabilities apply to Windows XP or
later guests on hosts running Windows or Linux.
The virtual machine must be a Player 3.x or later virtual machine and must have
the latest VMware Tools installed.

Use host setting for monitors

When you select this setting, the SVGA driver uses two monitors, a maximum
bounding box width of 3840, and a maximum bounding box height of 1920. The
virtual machine is configured to have a minimum of two 1920x1200 monitors, in
a side-by-side topology, in both normal and rotated orientations. If the host
system has more than two monitors, the virtual machine uses the number of
monitors on the host system instead. If the host system's bounding box is wider
or taller than the defaults, the virtual machine uses the larger size. You should
select this setting in most cases.

Specify monitor settings

Set the number of monitors that the virtual machine will see, regardless of the
number of monitors on the host system. This setting is useful if you use a
multimonitor host system and you need to test in a virtual machine that has only
one monitor. It is also useful if you are developing a multimonitor application in a
virtual machine and the host system has only one monitor. After you power on
the virtual machine, the guest operating system sees the number of monitors
that you specified. Select a resolution from the list or type a setting that has the
format width x height, where width and height are the number of pixels.

Graphics memory

Select the maximum amount of guest memory that can be used for graphics
memory using the drop down menu. The default value of video memory varies
by guest OS.
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Installing a Guest Operating System on a Physical Disk or
Unused Partition
You can install a guest operating system directly on a physical disk or unused partition on the host
system.
A physical disk directly accesses an existing local disk or partition. You can use physical disks to run one
or more guest operating systems from existing disk partitions.
Workstation Player supports physical disks up to 2 TB capacity. Booting from an operating system already
set up on an existing SCSI disk or partition is not supported.
Running an operating system natively on the host system and switching to running it inside a virtual
machine is similar to pulling the hard drive out of one computer and installing it in a second computer that
has a different motherboard and hardware. The steps you take depend on the guest operating system in
the virtual machine. In most cases, a guest operating system that is installed on a physical disk or unused
partition cannot boot outside of the virtual machine, even though the data is available to the host system.
See the Dual-Boot Computers and Virtual Machines technical note on the VMware Web site for
information about using an operating system that can also boot outside of a virtual machine.
After you configure a virtual machine to use one or more partitions on a physical disk, do not modify the
partition tables by running fdisk or a similar utility in the guest operating system. If you use fdisk or a
similar utility on the host operating system to modify the partition table of the physical disk, you must
recreate the virtual machine physical disk. All files that were on the physical disk are lost when you modify
the partition table.
Important You cannot use a physical disk to share files between the host system and a guest operating
system. Making the same partition visible to both the host system and a guest operating system can
cause data corruption. Instead, use shared folder to share files between the host system and a guest
operating system.
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VMware Workstation Player REST API allow you to interact programmatically with the core VMware
hypervisor and virtual machines.

Overview of Workstation Player REST API
You can send standard GET, PUT, POST, and DELETE requests through HTTP and HTTPS to control
configuration and deployment options. For example, you can use VMware Workstation Player REST API
to perform power operations. You can perform network-related operations, such as to create and update
virtual NIC configurations and to retrieve IP addresses from the virtual machine. You can also configure
shared folders. Response payloads are delivered in JSON format.

Workstation Player REST API Considerations
Keep the following considerations in mind when using the Workstation Player REST API.
n

The Workstation Player REST API service depends on the vmrest process.

n

The vmrest service runs as the user who starts it. For example, the sudo vmrest command runs as
the root user.

This chapter includes the following topics:
n

Use the VMware Workstation Player REST API

Use the VMware Workstation Player REST API
You can access the VMware Workstation Player REST API from a local machine or a remote machine.
Note To view the Workstation Player API online, search VMware API Explorer for the appropriate
version of the Workstation Player API.
Procedure

1

Install Workstation Player on the host machine.
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2

Before you start the REST API service the first time, set up your credentials.
a

In a terminal window, run the vmrest -C command.

b

Enter a user name and password as prompted.
You do not need to set up credentials when you start the REST API on subsequent occasions.
The user name and password are saved to the ~/.vmrestcfg file.

3

Configure the REST API service for HTTP and HTTPS access.
You can configure the REST API service to provide HTTP access locally and HTTPS access both
locally and remotely.
n

Provide HTTP service.
a

In a terminal window, run the vmrest command.
The command returns the IP address and port number from which you can access the HTTP
service. The default IP address is 127.0.0.1:8697.

n

b

Open a web browser and go to http://address-returned-by-vmrest-command.

c

Click Authorize in the top-right corner of the Workstation Player API Explorer page.

d

Enter the user name and password you configured in Step 2.

Provide HTTPS service.
To enable remote access to Workstation Player REST API, you must configure the REST API
service to provide HTTPS service. In this situation, when you use the vmrest command to start
the REST API service, you must use the -c and -k options together to specify the certificate and
private key.
a

In a terminal window, run a command to generate a certificate and a private key.
The example command that follows, generates a self-signed OpenSSL-based certificate and
a private key.
openssl req -x509 -newkey rsa:4096 -keyout playerapi-key.pem -out playerapicert.pem -days 365 -nodes

b

To start the Workstation Player REST API service, run the command that follows. Replace the
placeholders with the full path to the certificate file, full path to the private key file, and the IP
address from which you want to serve the REST API.
vmrest -c certificate-file -k private-key-file -i ip-address

The command returns the IP address and port number from which you can access the
HTTPS service.
c

On a remote machine, open a web browser and go to https://address-returned-by-vmrestcommand.

d

Click Authorize in the top-right corner of the Workstation Player API Explorer page.

e

Enter the user name and password you configured in Step 2.
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