Using VMware Workstation Player for Windows

Workstation 12 Player
VMware Workstation Player 12.0
VMware Workstation Player 12.1

This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.
You can find the most up-to-date technical documentation on the VMware Web site at:
http://www.vmware.com/support/
The VMware Web site also provides the latest product updates.
If you have comments about this documentation, submit your feedback to:
docfeedback@vmware.com
Starting and Stopping Virtual Machines in Workstation Player 53

- Start a Virtual Machine in Workstation Player 53
- Start an Encrypted Virtual Machine in Workstation Player 54
- Download a Virtual Appliance in Workstation Player 54
- Power Off a Virtual Machine in Workstation Player 54
- Remove a Virtual Machine from the Library in Workstation Player 55
- Use Ctrl+Alt+Delete to Shut Down a Guest 55
- Suspend and Resume a Virtual Machine in Workstation Player 55
- Reset a Virtual Machine in Workstation Player 56
- Enable Autologon in a Windows Virtual Machine 56
- Set Workstation Player Preferences for Virtual Machine Closing Behavior 57

Changing the Virtual Machine Display 59

- Configure Display Settings for a Virtual Machine 59
- Use Full Screen Mode in Workstation Player 60
- Use Unity Mode 61
- Use Multiple Monitors for One Virtual Machine in Workstation Player 63

Using Removable Devices and Printers in Virtual Machines 65

- Use a Removable Device in a Virtual Machine 65
- Connecting USB Devices to Virtual Machines 66
- Add a Host Printer to a Virtual Machine 68
- Using Smart Cards in Virtual Machines 68

Setting Up Shared Folders for a Virtual Machine 71

- Using Shared Folders 71
- Enable a Shared Folder for a Virtual Machine 73
- View Shared Folders in a Windows Guest 74
- Mounting Shared Folders in a Linux Guest 74
- Change Shared Folder Properties 75
- Change the Folders That a Virtual Machine Can Share 75
- Disable Folder Sharing for a Virtual Machine 76
- Mapping a Virtual Disk to the Host System 76

Configuring and Managing Virtual Machines 79

- Change the Name of a Virtual Machine 79
- Change the Guest Operating System for a Virtual Machine 80
- Change the Working Directory for a Virtual Machine 80
- Change the Virtual Machine Directory for a Virtual Machine 80
- Change the Memory Allocation for a Virtual Machine 81
- Configuring Video and Sound 81
- Moving Virtual Machines 84
- Delete a Virtual Machine 87
- View the Message Log for a Virtual Machine 87
- Using the VIX API 87
- Install New Software in a Virtual Machine 88
12 Configuring and Managing Devices 89
   Configuring DVD, CD-ROM, and Floppy Drives 89
   Configuring a USB Controller 91
   Configuring and Maintaining Virtual Hard Disks 93
   Configuring Virtual Ports 98
   Configuring Generic SCSI Devices 101
   Configuring Sixteen-Way Virtual Symmetric Multiprocessing 103
   Configuring Keyboard Features 104
   Modify Hardware Settings for a Virtual Machine 112

13 Configuring Network Connections 113
   Understanding Virtual Networking Components 113
   Understanding Common Networking Configurations 114
   Configuring Bridged Networking 115
   Configuring Network Address Translation 116
   Configuring Host-Only Networking 116
   Changing a Networking Configuration 118

14 Configuring Virtual Machine Option Settings 121
   Configuring General Option Settings for a Virtual Machine 121
   Configuring Power Options for a Virtual Machine 123
   Configuring VMware Tools Options for a Virtual Machine 123
   Configuring Unity Mode for a Virtual Machine 124
   Configuring Autologin for a Virtual Machine 125

15 Configuring Virtual Machine Hardware Settings 127
   Adding Hardware to a Virtual Machine 127
   Removing Hardware from a Virtual Machine 129
   Adjusting Virtual Machine Memory 129
   Configuring Virtual Machine Processor Settings 129
   Configuring and Maintaining Virtual Hard Disks 130
   Configuring CD-ROM and DVD Drive Settings 133
   Configuring Floppy Drive Settings 134
   Configuring Virtual Network Adapter Settings 135
   Configuring USB Controller Settings 138
   Configuring Sound Card Settings 139
   Configuring Parallel Port Settings 139
   Configuring Serial Port Settings 139
   Configuring Generic SCSI Device Settings 140
   Configuring Printer Settings 141
   Configuring Display Settings 141
   Installing a Guest Operating System on a Physical Disk or Unused Partition 142

Index 143
Updated Information

Using VMware Workstation Player for Windows is updated with each release of the product or when necessary. This table provides the update history of Using VMware Workstation Player for Windows.
<table>
<thead>
<tr>
<th>Revision</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EN-001871-02</td>
<td>• Updated “Virtual Machine Processor Support,” on page 16 to reflect the supported functionality.</td>
</tr>
<tr>
<td></td>
<td>• Corrected the procedure in “Import a Windows XP Mode Virtual Machine,” on page 38 to reflect the supported functionality.</td>
</tr>
<tr>
<td></td>
<td>• Corrected “Add a New Virtual Hard Disk to a Virtual Machine,” on page 94 to remove functionality not supported in Workstation Player.</td>
</tr>
<tr>
<td></td>
<td>• Updated “Run an Unattended Workstation Player Installation on a Windows Host,” on page 20 to reflect the supported functionality.</td>
</tr>
<tr>
<td></td>
<td>• Updated “Installation Properties,” on page 21 to remove parameters no longer supported.</td>
</tr>
<tr>
<td></td>
<td>• Removed “REMOVE Property Values.”</td>
</tr>
<tr>
<td></td>
<td>• Updated “Connecting USB Devices to Virtual Machines,” on page 66 to add a statement for how to manually connect a USB device to a virtual machine.</td>
</tr>
<tr>
<td></td>
<td>• Updated “Add a Host Printer to a Virtual Machine,” on page 68 to add a prerequisite that the virtual machine must be powered on or off before adding a printer.</td>
</tr>
<tr>
<td></td>
<td>• Updated the global configuration file location in “Disable Smart Card Sharing,” on page 70.</td>
</tr>
<tr>
<td></td>
<td>• Added a note in “Map or Mount a Virtual Disk to a Drive on the Host System,” on page 76 that this functionality is not supported in the standalone version of Workstation Player. A note was also added that Workstation Player does not support taking or deleting snapshots.</td>
</tr>
<tr>
<td></td>
<td>• Corrected “Compact a Virtual Hard Disk,” on page 96 to remove functionality not supported in Workstation Player.</td>
</tr>
<tr>
<td></td>
<td>• Updated “Limitations of Moving a Virtual Machine to a Different Host,” on page 85 to reflect the supported functionality.</td>
</tr>
<tr>
<td></td>
<td>• Updated “Expand a Virtual Hard Disk,” on page 96 to provide information on how to determine whether a virtual machine is a linked clone or the parent of a linked clone. A note was also added that Workstation Player does not support taking or deleting snapshots.</td>
</tr>
<tr>
<td></td>
<td>• Changed “Configuring Eight-Way Symmetric Multiprocessing” to “Configuring Sixteen-Way Virtual Symmetric Multiprocessing,” on page 103 to reflect the supported functionality.</td>
</tr>
<tr>
<td></td>
<td>• Changed “Configure Eight-way Symmetric Multiprocessing” to “Configure Sixteen-Way Virtual Symmetric Multiprocessing,” on page 103 to reflect the supported functionality.</td>
</tr>
<tr>
<td></td>
<td>• Changed &quot;Use a Virtual Machine That Has More Than Eight Virtual Processors&quot; to “Use a Virtual Machine That Has More Than Sixteen Virtual Processors,” on page 104 to reflect the supported functionality.</td>
</tr>
<tr>
<td></td>
<td>• Updated “Add a Virtual Network Adapter to a Virtual Machine,” on page 118 to reflect the options available in the product.</td>
</tr>
<tr>
<td>Revision</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>■ Added a note to “Removing Hardware from a Virtual Machine,” on page 129 stating that you cannot remove hardware from a virtual machine while it is in suspended state.</td>
</tr>
<tr>
<td>EN-001871-01</td>
<td>■ Removed references to deprecated guest operating systems in the document.</td>
</tr>
<tr>
<td></td>
<td>■ Removed procedures for Linux hosts in the document.</td>
</tr>
<tr>
<td></td>
<td>■ Removed the following sections because the functionality was removed in a previous release:</td>
</tr>
<tr>
<td></td>
<td>■ &quot;Stream a Virtual Machine from a Web Server &quot;</td>
</tr>
<tr>
<td></td>
<td>■ &quot;Make a Virtual Machine Available for Streaming &quot;</td>
</tr>
<tr>
<td></td>
<td>■ Removed requirement in “Processor Requirements for Host Systems,” on page 13 for &quot;LAHF/SAHF support in long mode”. This requirement applies only to older 64-bit CPUs produced before 2006.</td>
</tr>
<tr>
<td></td>
<td>■ Updated “Prepare the Host System to Use 3D Accelerated Graphics,” on page 82 to add a statement clarifying OpenGL3.3 support.</td>
</tr>
<tr>
<td></td>
<td>■ Updated “Guest Operating Systems That Support Shared Folders,” on page 72 for supported guest operating systems.</td>
</tr>
<tr>
<td>EN-001871-00</td>
<td>Initial release.</td>
</tr>
</tbody>
</table>
Using VMware Workstation Player for Windows

Using VMware Workstation Player for Windows describes how to use VMware Workstation Player™ to create, configure, and manage virtual machines on a Windows host.

Intended Audience

This information is intended for anyone who wants to install, upgrade, or use Workstation Player on a Windows host.
Workstation Player is a desktop application that lets you create, configure, and run virtual machines. You can also use Workstation Player to download and run virtual appliances.

Host computers that run Workstation Player must meet specific hardware and software requirements. Virtual machines that run in Workstation Player support specific devices and provide certain features.

This chapter includes the following topics:

- “Host System Requirements for Workstation Player,” on page 13
- “Virtual Machine Features and Specifications,” on page 16

Host System Requirements for Workstation Player

The physical computer on which you install Workstation Player is called the host system and its operating system is called the host operating system. To run Workstation Player, the host system and the host operating system must meet specific hardware and software requirements.

Processor Requirements for Host Systems

You must install Workstation Player on a host system that meets certain processor requirements.

Supported Processors

The host system must have a 64-bit x86 CPU with 1.3 GHz or faster core speed. Multiprocessor systems are supported.

When you install Workstation Player, the installer performs checks to make sure the host system has a supported processor. You cannot install Workstation Player if the host system does not meet the processor requirements.

Processor Requirements for 64-Bit Guest Operating Systems

The operating system that runs inside a virtual machine is called the guest operating system. To run 64-bit guest operating systems, the host system must have one of the following processors.

- An AMD CPU that has segment-limit support in long mode
- An Intel CPU that has VT-x support

If you have an Intel CPU that has VT-x support, you must verify that VT-x support is enabled in the host system BIOS. The BIOS settings that must be enabled for VT-x support vary depending on the system vendor. See the VMware knowledge base article at [http://kb.vmware.com/kb/1003944](http://kb.vmware.com/kb/1003944) for information about how to determine if VT-x support is enabled.
When you install a 64-bit operating system, Workstation Player performs checks to make sure the host system has a supported processor. You cannot install a 64-bit operating system if the host system does not meet the processor requirements.

**Processor Requirements for Windows 7 Aero Graphics**

To support Windows 7 Aero graphics, the host system should have either an Intel Dual Core 2.2 GHz or later CPU or an AMD Athlon 4200+ or later CPU.

**Supported Host Operating Systems**

You can install Workstation Player on Windows and Linux host operating systems.

To see a list of the supported host operating systems, search the online VMware Compatibility Guide on the VMware Web site.

Workstation Player is not listed, but the information for Workstation Pro is applicable to Workstation Player. Operating systems that are not listed are not supported for use in a virtual machine.

**Memory Requirements for Host Systems**

The host system must have enough memory to run the host operating system, the guest operating systems that run inside the virtual machines on the host system, and the applications that run in the host and guest operating systems.

The minimum memory required on the host system is 1 GB. 2 GB and above is recommended.

To support Windows 7 Aero graphics in a virtual machine, at least 3 GB of host system memory is required. 1 GB of memory is allocated to the guest operating system and 256 MB is allocated to graphics memory.

See your guest operating system and application documentation for more information on memory requirements.

**Display Requirements for Host Systems**

The host system must have a 16-bit or 32-bit display adapter. Use the latest graphics driver recommended for the host system.

To support Windows 7 Aero graphics, the host system should have either an NVIDIA GeForce 8800GT or later or an ATI Radeon HD 2600 or later graphics processor.

**IMPORTANT** 3D benchmarks, such as 3DMark ’06, might not render correctly or at all when running Windows Vista or Windows 7 virtual machines on some graphics hardware.
Disk Drive Requirements for Host Systems

Host systems must meet certain disk drive requirements. Guest operating systems can reside on physical disk partitions or in virtual disk files.

Table 2-1. Disk Drive Requirements for Host Systems

<table>
<thead>
<tr>
<th>Drive Type</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hard disk</td>
<td>- IDE, SATA, and SCSI hard drives are supported.</td>
</tr>
<tr>
<td></td>
<td>- At least 1 GB free disk space is recommended for each guest operating system and the application software used with it. If you use a default setup, the actual disk space needs are approximately the same as those for installing and running the guest operating system and applications on a physical computer.</td>
</tr>
<tr>
<td></td>
<td>- For installation, approximately 200 MB free disk space is required on Linux and 250 MB free disk space is required on Windows. You can delete the installer after the installation is complete to reclaim disk space.</td>
</tr>
<tr>
<td>Optical CD-ROM and DVD</td>
<td>- IDE, SATA, and SCSI optical drives are supported.</td>
</tr>
<tr>
<td></td>
<td>- CD-ROM and DVD drives are supported.</td>
</tr>
<tr>
<td></td>
<td>- ISO disk image files are supported.</td>
</tr>
<tr>
<td>Floppy</td>
<td>Virtual machines can connect to disk drives on the host computer. Floppy disk image files are also supported.</td>
</tr>
</tbody>
</table>

Solid-State Drives

If your host machine has a physical solid-state drive (SSD), the host informs guest operating systems they are running on an SSD.

This allows the guest operating systems to optimize behavior. How the virtual machines recognize SSD and use this information depends on the guest operating system and the disk type of the virtual disk (SCSI, SATA, or IDE).

- On Windows 8, Windows 10, Ubuntu, and Red Hat Enterprise Linux virtual machines, all drive types can report their virtual disks as SSD drives.
- On Windows 7 virtual machines, only IDE and SATA virtual disks can report their virtual disks as SSD. SCSI virtual disks only report as SSD when used as a system drive in a virtual machine, or as a mechanical drive when used as a data drive inside a virtual machine.
- On Mac virtual machines, only SATA virtual disks are reported as SSD. IDE and SCSI virtual disks are reported as mechanical drives.

Use the virtual machine operating system to verify your virtual machine is using SSD as its virtual disk.

Local Area Networking Requirements for Host Systems

You can use any Ethernet controller that the host operating system supports.

Non-Ethernet networks are supported by using built-in network address translation (NAT) or by using a combination of host-only networking and routing software on the host operating system.
Virtual Machine Features and Specifications

Workstation Player virtual machines support specific devices and provide certain features.

Supported Guest Operating Systems

A guest operating system can be Windows, Linux, and other commonly used operating systems.

For the most recent list of guest operating systems that VMware products support, see the VMware Compatibility Guide site: http://www.vmware.com/resources/compatibility/search.php.

Workstation Player is not listed, but the information for Workstation Pro is applicable to Workstation Player. Operating systems that are not listed are not supported for use in a virtual machine.

For instructions about how to install the most common guest operating systems, see the VMware Guest Operating System Installation Guide: http://partnerweb.vmware.com/GOSIG/home.html.

Virtual Machine Processor Support

Virtual machines support certain processor features.

- The same as the processor on the host computer.
- One virtual processor on a host system that has one or more logical processors.
- Up to 16 virtual processors (sixteen-way virtual symmetric multiprocessing, or Virtual SMP) on a host system that has at least 2 logical processors.

**Note** Workstation Player considers multiprocessor hosts that have 2 or more physical CPUs, single-processor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading enabled, to have two logical processors.

Virtual Machine Memory Allocation

The total amount of memory that you can assign to all virtual machines running on a single host system is limited only by the amount of RAM on the host.

On 64-bit hosts, the maximum amount of memory for each virtual machine is 64GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. Workstation Player prevents powering on virtual machines that are configured to use more than 8GB of memory on 32-bit hosts. Memory management limitations on 32-bit operating systems cause virtual machine memory to overcommit, which severely affects system performance.

Compatible Virtual Machines and System Images

Workstation Player can run virtual machines and system images that other VMware products create and some non-VMware products.

- **VMware virtual machines**: Workstation Player runs virtual machines that were created by using Workstation 4 and later, GSX Server 3.x, VMware Server, and ESX Server 2.5 and later. Workstation 4 virtual machines run in legacy mode. You must use another VMware product to upgrade virtual machines created in versions earlier than Workstation 4 before you can run them in Workstation Player.

- **Microsoft Virtual PC and Virtual Server virtual machines**: On Windows hosts, Workstation Player can run Microsoft Virtual PC and Virtual Server virtual machines. When you open a Virtual PC virtual machine in Workstation Player, Workstation Player creates a configuration file that is VMware product compatible and that has a .vmx file extension.
Workstation Player preserves the original Virtual PC configuration file and gives the file a .vmc file extension. You can save the VMware product-compatible virtual machine without changing the original Virtual PC configuration file.

On Windows hosts, Workstation Player can run system images that were created by using Symantec Backup Exec System Recovery, formerly Symantec LiveState Recovery. When you open a Backup Exec System Recovery system image in Workstation Player, Workstation Player creates a configuration file that is VMware product compatible and that has a .vmx extension. Workstation Player preserves the original Backup Exec System Recovery system image file and gives the file a .sv2i file extension.
Installing and Using Workstation Player

Installing Workstation Player typically involves running a standard GUI wizard.

This chapter includes the following topics:

- “Install Workstation Player on a Windows Host,” on page 19
- “Start Workstation Player,” on page 21
- “Use the Workstation Player Window,” on page 22
- “Transferring Files and Text,” on page 22
- “Download a Virtual Appliance in Workstation Player,” on page 24
- “Remove a Virtual Machine from the Library in Workstation Player,” on page 24
- “Email Address Collection in Workstation Player,” on page 24
- “Uninstall Workstation Player,” on page 24

Install Workstation Player on a Windows Host

You install Workstation Player on a Windows machine by running the installation wizard.

Prerequisites

- Verify that your Windows machine meets the host system requirements. See “Host System Requirements for Workstation Player,” on page 13.
- Download the Workstation Player installer file to your Windows machine. You can obtain the Workstation Player installer file from the VMware Web site.
- If you are installing the purchased version of Workstation Player, verify that you have a license key.

You can use Workstation Player free of charge for non-commercial use. When you use Workstation Player for the first time, you can enter your email address and use it free of charge, or you can enter your purchased license key to use Workstation Player and have access to additional features.

Procedure

1. On your Windows machine, double-click the Workstation Player installer file. The installer filename is similar to VMware-player-xxxx-xxxx.exe, where xxxx-xxxx is the version and build numbers.

2. Follow the prompts to finish the installation.
3  (Optional) To activate Workstation Player features, start Workstation Player and enter your license key.
   a  Double-click the Workstation Player icon or select Start > All Programs VMware Player to start Workstation Player.
   b  Select Enter a license key to allow commercial use.
   c  Type your license key and click Continue.

Run an Unattended Workstation Player Installation on a Windows Host

You can use the unattended installation feature of the Microsoft Windows Installer (MSI) to install Workstation Player on Windows host systems without having to respond to wizard prompts. This feature is convenient in a large enterprise.

Prerequisites

- Verify that the host system meets the host system requirements.
- Obtain the Workstation Player software and license key.
- Verify that the host computer has version 2.0 or later of the MSI runtime engine. This version of the installer is available in versions of Windows beginning with Windows XP and is available from Microsoft. For more information, see the Microsoft Web site.
- Familiarize yourself with the installation properties. See “Installation Properties,” on page 21.

Procedure

1  Log in to the host system as the Administrator user or as a user who is a member of the local Administrators group.

   If you log in to the host system as the Administrator user or as a user who is a member of the local Administrators group.

2  Extract the administrative installation image from the setup file.

   The setup filename is similar to VMware=player-xxxx-xxxx.exe where xxxx-xxxx is the version and build number.

   For example, if you enter setup.exe/? , the flag displays a windows message box with the command line usage for the installer.

3  Enter the installation command on one line.

   The following example installs Workstation Player:

   VMware-player-x.x.x-xxxxxx.exe /s /v/qn EULAS_AGREED=1 SERIALNUMBER="xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

   You can use the optional INSTALLDIR property to specify a file path for the installation that is different from the default location.

   **Note** The double quotes around the file path are important. All the MSI arguments are passed with the /v option. The outer quotes group the MSI arguments and the double quotes put a quote in that argument.

   You can also run an unattended Workstation Player uninstallation on a Windows host. The following example uninstalls Workstation Player and removes the license from the host.

   VMware-player-x.x.x-xxxxxx.exe /s /v"/qn REMOVE=ALL"
Installation Properties

When you perform an unattended installation of Workstation Player, you can customize the installation by specifying installation properties in the installation command.

To specify an installation property in the installation command, use the format `property="value"`. A value of 1 means true and a value of 0 means false.

Table 3-1. Installation Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOSOFTWAREUPDATE</td>
<td>Enables automatic upgrades for Workstation Player or Workstation Player when a new build becomes available.</td>
<td>1</td>
</tr>
<tr>
<td>DATACOLLECTION</td>
<td>Sends user experience information to VMware.</td>
<td>1</td>
</tr>
<tr>
<td>DESKTOP_SHORTCUT</td>
<td>Adds a shortcut on the desktop when Workstation Player is installed.</td>
<td>1</td>
</tr>
<tr>
<td>ENABLE_VIRTUAL_PRINTING</td>
<td>Enables support for ThinPrint virtual printing on the Windows host after installing.</td>
<td>0</td>
</tr>
<tr>
<td>EULAS_AGREED</td>
<td>Allows you to silently accept the product EULAs. Set to 1 to complete the installation or upgrade.</td>
<td>0</td>
</tr>
<tr>
<td>INSTALLDIR</td>
<td>Install Workstation Player in a directory that is different from the default Workstation Player location.</td>
<td>C:\Program Files (86)\VMware\VMware Player</td>
</tr>
<tr>
<td>KEEP_LICENSE</td>
<td>Specifies whether to keep or remove license keys when Workstation Player is uninstalled.</td>
<td>1</td>
</tr>
<tr>
<td>KEEP_SETTINGFILES</td>
<td>Specifies whether to keep or remove settings files when Workstation Player is uninstalled.</td>
<td>1</td>
</tr>
<tr>
<td>SERIALNUMBER</td>
<td>Lets you enter the license key when Workstation Player is installed. Enter the license key with hyphens, for example, &quot;xxxxx-xxxxx-xxxxx-xxxxx-xxxxx&quot;.</td>
<td>1</td>
</tr>
<tr>
<td>SIMPLIFIEDUI</td>
<td>Turn on or off certain UI features of Workstation Player.</td>
<td>0</td>
</tr>
<tr>
<td>SOFTWAREUPDATEURL</td>
<td>Specifies a custom URL for managing software updates (separate from vmware.com).</td>
<td></td>
</tr>
<tr>
<td>STARTMENU_SHORTCUT</td>
<td>Adds a Start menu item when Workstation Player is installed.</td>
<td>1</td>
</tr>
<tr>
<td>SUPPORTURL</td>
<td>Set a support URL or email alias specifically for your users to contact with product issues through the Workstation Player or Workstation Player Help menu.</td>
<td></td>
</tr>
</tbody>
</table>

Start Workstation Player

When you start Workstation Player, the Workstation Player window opens.

You might have a desktop shortcut, a quick launch shortcut, or a combination of these options in addition to a Start menu item.

Procedure

- Select Start > Programs > VMware Player.
Use the Workstation Player Window

You interact with Workstation Player and virtual machines through the Workstation Player window. The best way to learn how to use Workstation Player is to use it. The Workstation Player window is designed to be intuitive and easy to use.

Procedure

- Use the icons on the Home tab to create a new virtual machine, open an existing virtual machine, download a virtual appliance, or view the Workstation Player help system.
- Select a powered-off virtual machine in the library see the summary view.
  
  The summary view shows a summary of configuration information and the virtual machine state. You can start the virtual machine and edit virtual machine settings from the summary view.
- Select a powered-off virtual machine in the library and click Play virtual machine to start the virtual machine and see the console view.
  
  The console view is like the monitor display of a physical computer.
- Select a virtual machine in the library and use the Virtual Machine menu on the menu bar to perform all virtual machine operations for the selected virtual machine.
- When a virtual machine is powered on, use the icons on the status bar to perform actions on virtual devices such as hard disks, CD/DVD drives, floppy drives, and network adapters.
  You can click or right-click on a removable device icon to connect or disconnect the device or edit its settings.
- Use the About VMware Player window to access information about your installation of Workstation Player, including license key information.

  Click Player > Help > About VMware Workstation 12 Player.

  - If you have an individual license for Workstation Player, the key is displayed in the License Information section in the Type field. It is labeled Individual and is followed by your license key.
  - If you have a version of Workstation Player licensed for multiple users, the Type field displays Volume and your license key is not displayed.
  - If you did not enter a license for Workstation Player, the Type field displays Not applicable and a license key is not displayed.
  - If you have an evaluation license key for Workstation Player, the Type field displays Not applicable. The date the evaluation license key expires is also displayed.

  **Note**: The evaluation key does not activate Horizon FLEX features.

Transferring Files and Text

You can use the drag-and-drop and copy and paste features, shared folders, and mapped drives to transfer text and files between the host system and virtual machines.

Using the Drag-and-Drop Feature

You can use the drag-and-drop feature to move files and directories, email attachments, plain text, formatted text, and images between the host system and virtual machines.

You can drag files or directories between the following locations.

- File managers, such as Windows Explorer, on the host system and virtual machines.
A file manager to an application that supports drag-and-drop.

Applications, such as zip file managers, which support drag-and-drop extraction of individual files.

Different virtual machines.

Dragging email attachments is especially useful in Unity mode.

When you drag a file or folder between the host and a virtual machine, Workstation Player copies the file or folder to the location where you drop it. For example, if you drop a file on the desktop icon of a word processor, the word processor opens a copy of the original file. The original file does not include changes that you make to the copy.

Initially, the application opens a copy of the file that is stored in the temp directory. On Windows, the temp directory is specified in the %TEMP% environment variable. On Linux and Solaris, the temp directory is /tmp/VMwareDnD. Save the file in a different directory to protect changes that you make.

**Drag-and-Drop Requirements and Restrictions**

The drag-and-drop feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the drag-and-drop feature.
- The drag-and-drop feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- You can drag images between applications on Windows hosts and applications on Windows guests only. Dragging images is not supported for Linux hosts or guests.
- You can drag files and directories, email attachments, plain text, and formatted text between Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- Dragging email attachments is restricted to images or files smaller than 4 MB.
- Dragging plain text and formatted text (including the formatting) is restricted to amounts less than 4 MB.
- Dragging text is restricted to text in languages that can be represented by Unicode characters.
- Workstation Player uses the PNG format to encode images that are dragged. Dragging images is restricted to images smaller than 4 MB after conversion to PNG format.

**Using the Copy and Paste Feature**

You can cut, copy, and paste text between virtual machines and between applications running in virtual machines.

You can also cut, copy, and paste images, plain text, formatted text, and email attachments between applications running on the host system and applications running in virtual machines.

Copying and pasting email attachments is especially useful in Unity mode. Use the normal hot keys or menu choices to cut or copy and paste.

**Copy and Paste Requirements and Restrictions**

The copy and paste feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the copy and paste feature.
- The copy and paste feature works with Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- The copy and paste feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- Copying and pasting email attachments is restricted to images or files smaller than 4 MB.
- Copying and pasting plain text and formatted text (including the formatting) is restricted to amounts less than 4MB.
- Copying and pasting text is restricted to text in languages that can be represented by Unicode characters.
- Workstation Player uses the PNG format to encode images that are copied and pasted. Copying and pasting images is restricted to images smaller than 4 MB after conversion to PNG format.
- You cannot copy and paste files between virtual machines.

**Download a Virtual Appliance in Workstation Player**

You can download a virtual appliance in Workstation Player. A virtual appliance is a prebuilt, preconfigured, and ready-to-run software application that is packaged with the operating system in a virtual machine.

**Procedure**

- Select Player > File > Download a Virtual Appliance.

A Web browser opens to the Virtual Appliance Marketplace page on the VMware Web site. You can browse to and download virtual appliances from this page.

**Remove a Virtual Machine from the Library in Workstation Player**

When you open a virtual machine in Workstation Player, it is added to the virtual machine library. You can remove a virtual machine that you are not using from the library.

Removing a virtual machine from the library does not delete the virtual machine or any of its files from the host file system. The virtual machine is removed only from the library. If you open the virtual machine again, the virtual machine is added back to the library.

**Prerequisites**

Power off the virtual machine.

**Procedure**

- Select the virtual machine, right-click, and select Remove VM from the Library.

The virtual machine is removed from the library without any confirmation.

**Email Address Collection in Workstation Player**

The trial version of Workstation Player prompts you for your email address when you use it for the first time.

You can use Workstation Player free of charge for non-commercial use. When you use Workstation Player for the first time, you can enter your email address and use it free of charge, or you can enter your purchased license key to use Workstation Player and have access to additional features.

**Uninstall Workstation Player**

You must uninstall the previous version of Workstation Player before you can install the latest version.

**Procedure**

- Use the Windows uninstall feature.

  For example, on Windows 7, select Start > Control Panel > Programs > Programs and Features > Uninstall a program.
Changing Workstation Player Preference Settings

Workstation Player preference settings are global configuration settings that apply to Workstation Player and the virtual machines that you run in Workstation Player.

To change Workstation Player preference settings, select Player > File > Preferences.

This chapter includes the following topics:

- “Configuring Close Behavior Preference Settings,” on page 25
- “Configuring Virtual Printers on Windows Hosts,” on page 26
- “Configuring Software Updates Settings,” on page 26
- “Sending System Data and Usage Statistics to VMware,” on page 27

Configuring Close Behavior Preference Settings

Close behavior preference settings control what Workstation Player does with virtual machines when you close them.

To configure close behavior preference settings, select File > Preferences.

Table 4-1. Close Behavior Preference Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suspend the virtual machine</td>
<td>The virtual machine is suspended when you close it. The next time you start Workstation Player, the virtual machine resumes operation from the point at which it was suspended.</td>
</tr>
<tr>
<td>Power off the virtual machine</td>
<td>The virtual machines is powered off when you close it. The next time you start Workstation Player, the virtual machine is in a powered off state.</td>
</tr>
<tr>
<td>Leave the virtual machine running</td>
<td>The virtual machine remains running in the background when you close it. The next time you start Workstation Player, the virtual machine is in a powered on state.</td>
</tr>
<tr>
<td>Confirm before closing a virtual machine</td>
<td>Workstation Player prompts you for confirmation when you close a virtual machine.</td>
</tr>
<tr>
<td>Return to the VM Library after closing a virtual machine</td>
<td>Workstation Player returns the virtual machines to the library after you close it. You can open another virtual machine or edit virtual machine settings.</td>
</tr>
</tbody>
</table>
Configuring Virtual Printers on Windows Hosts

On Windows hosts, you can configure Workstation Player to support virtual printing on all printers configured on the host.

Virtual printing is disabled by default on Windows hosts. To enable or disable virtual printing on a Windows host system, select **Player > File > Preferences > Devices**. Select the **Enable virtual printers** checkbox to enable virtual printers. VMware Tools must be installed on the virtual machine to enable printing. You must have administrator privileges to enable or disable virtual printers.

The Workstation Player printer feature uses ThinPrint technology to replicate the host system printer mapping in the virtual machine. When you enable the virtual machine printer, Workstation Player configures a virtual serial port to communicate with the host printers.

See “Add a Host Printer to a Virtual Machine,” on page 68

Configuring Software Updates Settings

Software updates settings control when Workstation Player downloads software updates to the host system and whether it uses a proxy server to connect to the VMware Update Server.

To configure software updates settings, select **Player > File > Preferences**.

Table 4-2. Software Update Preference Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check for product updates on startup</td>
<td>Check for new versions of the application and installed components when you start Workstation Player. This setting is selected by default.</td>
</tr>
<tr>
<td>Check for new software components as needed</td>
<td>Check for a new version of a component when a component, such as VMware Tools, is required. When this setting is selected, Workstation Player verifies if a new version is available to download and install.</td>
</tr>
<tr>
<td>Download All Components Now</td>
<td>Manually download all of the available software components to the host system. Click this button if you are planning to use a virtual machine at a later time when you do not have access to the Internet.</td>
</tr>
<tr>
<td>Connection Settings</td>
<td>Click this button to configure a proxy server to connect to the VMware Update Server.</td>
</tr>
</tbody>
</table>

Configuring Connection Settings for a Proxy Server

You can configure connection settings to use a proxy server to connect to the VMware Update Server.

To configure proxy connection settings, select **Player > File > Preferences** and click **Connection Settings**.

Table 4-3. Connection Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No proxy</td>
<td>Do not use a proxy server.</td>
</tr>
<tr>
<td>Windows proxy settings</td>
<td>(Windows hosts only) Workstation Player uses the host proxy settings from the Connections tab in the Internet Options control panel to access the VMware Update Server. Click <strong>Internet Options</strong> to set the guest connection options.</td>
</tr>
<tr>
<td>System proxy settings</td>
<td>(Linux hosts only) Workstation Player uses the host proxy settings to access the VMware Update Server.</td>
</tr>
</tbody>
</table>
Table 4-3. Connection Settings (Continued)

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual proxy settings</td>
<td>Select an HTTP or SOCKS proxy, specify the proxy server address, and designate a port number to access the VMware Update Server.</td>
</tr>
<tr>
<td>Username and Password</td>
<td>The username and password to use for proxy server authentication. On Linux hosts, if either the Username or Password text box is blank, Workstation Player uses the username and password set in the gnome settings.</td>
</tr>
</tbody>
</table>

You must restart Workstation Player for proxy setting changes to take effect.

Understanding the Automatic Software Update Process

When you enable automatic software updates, you are always aware of the latest releases from VMware.

By keeping your software up-to-date, you can take advantage of new product features and performance improvements, ensure that your system includes the latest patches, and obtain timely support for new guest operating systems. You can enable the automatic software update feature when you install Workstation Player or by configuring Workstation Player preference settings. You can disable the feature at any time.

To determine if software updates are available, the VMware software updates feature securely sends the following anonymous information to VMware.

- A universal unique identifier (UUID), which it uses to identify each individual system
- The product name, the product version, and the build number
- Your host operating system name, version, and the locale setting

The VMware software updates feature does not collect any personal data, such as your name, address, telephone number, or mail address. Your product license key and MAC address are not sent to VMware, and VMware does not store your IP address with the data that it receives from you.

VMware might use the information it receives from the software update feature for product planning purposes. VMware limits access to your data and uses industry-standard controls to protect your information, including physical access controls, Internet firewalls, intrusion detection, and network monitoring.

The information collected by the VMware software updates feature is handled in accordance with VMware Privacy Policy.

Sending System Data and Usage Statistics to VMware

The User experience improvement program setting controls whether you participate in the VMware User Experience Improvement Program.

To participate in or opt out of the program, select or deselect the Help improve VMware Player check box.

When you participate in the program, Workstation Player sends anonymous system data and usage statistics to VMware. Workstation Player creates log files for the collected data and stores the data on the host computer.
### Table 4-4. User Experience Improvement Program Log Files

<table>
<thead>
<tr>
<th>Filename</th>
<th>Host Operating System</th>
<th>Log File Location</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>playerUploadedData.log</td>
<td>Windows Server 2008 R2, Windows 7, Windows 8, Windows 10</td>
<td>\Users\user\AppData\Local\VMware</td>
<td>The most recent data uploaded to the VMware server.</td>
</tr>
<tr>
<td>playerUploadedData.log</td>
<td>Linux</td>
<td>~/.vmware</td>
<td>The most recent data uploaded to the VMware server.</td>
</tr>
</tbody>
</table>

**Note**  The data collection process does not affect the performance of your computer.

### Participating in the User Experience Improvement Program

When you participate in the VMware User Experience Improvement Program, your computer sends anonymous information to VMware. Participation in the program is voluntary and you can opt out at any time.

### Types of Data Collected

The data collected by the VMware User Experience Improvement Program might include product data, product usage information, product performance information, and system configuration information.

Product data typically includes information such as the product name, version, build number, and configuration settings. This information helps VMware compare data from identical installations and determine popular configurations.

Product usage information might include menu items selected, toolbar buttons pressed, virtual machines run, and virtual machine configuration settings. This information helps VMware identify usage patterns, such as the most popular features, how many virtual machines users create, how many virtual machines are run concurrently, which operating systems are the most popular, and what virtual machine settings are typically selected.

Product performance data might include errors that occur and measurements, such as virtual machine suspend and resume times, uptime, or application startup time.

System configuration information might include the operating system that your computer is currently running, how many processors are in your computer and the processor models, how much memory is installed, how many network connections are available, the video cards and video drivers that are installed, and screen resolutions for display devices. This information helps VMware identify the system configurations that best match customer environments during testing and to plan future development based on hardware industry trends and the adoption of new technologies.

Not all of the available information is collected from every system every time data is sent to VMware. Some information is included only from select installations and certain information, such as error messages, is collected only when it is generated.

VMware uses a universal unique identifier (UUID) to identify information from different machines.

### When the Data Is Transmitted to VMware

Data is typically collected on your system and transmitted to VMware when you start Workstation Player. If your computer does not have access to the Internet, the information is collected and sent to VMware the next time you start Workstation Player. Data might also be sent to VMware at other times, such as during a check for software updates. Data is encrypted and transmitted over a secure SSL connection so that it cannot be read by other Internet users.
Workstation Player stores all of the information that it sends to VMware on your system in clear text. The files are located in the same directory as your log files and are named `productnameUploadedData.log`.

**Privacy Protection**

VMware does not collect any personal data, such as your name, address, telephone number, or mail address. Your product license key and MAC address are not sent to VMware, and VMware does not store your IP address with the data that it receives from you.

VMware limits access to your data and uses industry-standard controls to protect your information, including physical access controls, Internet firewalls, intrusion detection, and network monitoring. The information collected by the VMware User Experience Improvement Program is handled in accordance with VMware Privacy Policy.

**Note**  The User Improvement Program is not Spyware. Spyware collects information or acts on your computer without your full knowledge or consent.

**Opting Out of the Program**

You can join or end participation in the VMware User Experience Improvement Program at any time by changing Workstation Player preference settings.

See “Sending System Data and Usage Statistics to VMware,” on page 27 for more information.
Creating Virtual Machines in Workstation Player

You use the New Virtual Machine wizard to create virtual machines. The New Virtual Machine wizard guides you through the steps for setting up a new virtual machine, helping you set options and parameters.

To start the New Virtual Machine wizard, select Player > File > New Virtual Machine, or click Create a New Virtual Machine on the welcome page.

This chapter includes the following topics:

- “Understanding Virtual Machines,” on page 31
- “Preparing to Create a Virtual Machine,” on page 31
- “Create a Virtual Machine,” on page 35
- “Use Easy Install to Install a Guest Operating System,” on page 36
- “Install a Guest Operating System Manually,” on page 37
- “Importing Virtual Machines,” on page 38

Understanding Virtual Machines

A virtual machine is a software computer that, like a physical machine, runs an operating system and applications. A virtual machine uses the physical resources of the physical machine on which it runs, which is called the host system. Virtual machines have virtual devices that provide the same functionality as physical hardware, but with the additional benefits of portability, manageability, and security.

A virtual machine has an operating system and virtual resources that you manage in much the same way that you manage a physical computer. For example, you install an operating system in a virtual machine in the same way that you install an operating system on a physical computer. You must have a CD-ROM, DVD, or ISO image that contains the installation files from an operating system vendor.

Preparing to Create a Virtual Machine

When you create a virtual machine, you specify or accept defaults for a few basic virtual machine settings.

- How you want to install the guest operating system.
- A name for the virtual machine and a location for the virtual machine files.
- The size of the virtual disk and whether to split the disk into multiple virtual disk files.
- Whether to customize hardware settings, including memory allocation, number of virtual processors, and network connection type.
Selecting a Guest Operating System

The New Virtual Machine prompts you to select the source media for the operating system that will run inside the virtual machine. You can specify an installer disc inserted in a physical drive, an ISO image file, or you can instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk.

If you select an installer disc or an ISO image file and the operating system supports Easy Install, the guest operating system installation is automated and VMware Tools is installed. If the installer disc or ISO image file contains a product key number and is already set up to perform an unattended installation, the only benefit of using Easy Install is the automatic installation of VMware Tools.

If you instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk, the wizard prompts you to specify an operating system and version and you must install the guest operating system manually after the virtual machine is created. Workstation Player uses this information to set the appropriate default values, name files associated with the virtual machine, adjust performance settings, and work around special behaviors and bugs in the guest operating system. If the operating system you plan to install is not listed in the wizard, select Other for both the operating system and version.

If you are installing an operating system that supports Easy Install but you do not want to use Easy Install, you can instruct the wizard to create a virtual machine that has a blank disk and install the guest operating system manually.

Supported Guest Operating Systems

A guest operating system can be Windows, Linux, and other commonly used operating systems.

For the most recent list of guest operating systems that VMware products support, see the VMware Compatibility Guide site: http://www.vmware.com/resources/compatibility/search.php.

Workstation Player is not listed, but the information for Workstation Pro is applicable to Workstation Player. Operating systems that are not listed are not supported for use in a virtual machine.

For instructions about how to install the most common guest operating systems, see the VMware Guest Operating System Installation Guide: http://partnerweb.vmware.com/GOSIG/home.html.

Providing Easy Install Information

When the New Virtual Wizard detects an operating system that supports Easy Install, the wizard prompts you for information about the guest operating system. After the virtual machine is created, the guest operating system installation is automated and VMware Tools is installed.

For Windows guest operating systems, you must provide the following Easy Install information.

<table>
<thead>
<tr>
<th>Easy Install Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows product key</td>
<td>(Optional) Type a product key unless the installation media contains a volume license product key. If you provide a product key here, you are not prompted to provide a product key when you install the guest operating system.</td>
</tr>
<tr>
<td>Version of Windows to install</td>
<td>Select the Windows operating system edition to install.</td>
</tr>
<tr>
<td>Full name</td>
<td>The name to use to register the guest operating system. Do not use the name Administrator or Guest. If you use one of these names, you must enter a different name when you install the guest operating system.</td>
</tr>
</tbody>
</table>
Table 5-1. Easy Install Information for Windows Guests (Continued)

<table>
<thead>
<tr>
<th>Easy Install Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Password</strong></td>
<td>(Optional) The password to use for an account with Administrator permissions on Windows operating systems other than Windows 2000. On Windows 2000, this is the password for the Administrator account. On Windows XP Home, an Administrator account without a password is created and you are automatically logged in to the guest operating system.</td>
</tr>
<tr>
<td><strong>Log on automatically (requires a password)</strong></td>
<td>(Optional) Save your login credentials and bypass the login dialog box when you power on the virtual machine. You must enter a name and password to use this feature.</td>
</tr>
</tbody>
</table>

For Linux guest operating systems, you must provide the following Easy Install information.

Table 5-2. Easy Install Information for Linux Guests

<table>
<thead>
<tr>
<th>Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Full name</strong></td>
<td>The name to use to register the guest operating system, if registration is required. Workstation Player uses the first name to create the host name for the virtual machine.</td>
</tr>
<tr>
<td><strong>User name</strong></td>
<td>Your user name. You can use lowercase letters, numbers, and dashes, but avoid using user names that begin with a dash. Do not use the name root. Some operating systems set up sudo access for this user and other operating systems require this user to use <code>su</code> to obtain root privileges.</td>
</tr>
<tr>
<td><strong>Password</strong></td>
<td>The password for the <strong>User name</strong> and the root user.</td>
</tr>
</tbody>
</table>

See “Use Easy Install to Install a Guest Operating System,” on page 36.

**Specifying the Virtual Machine Name and File Location**

The New Virtual Machine wizard prompts you for a virtual machine name and a directory for the virtual machine files.

The name of the default directory for virtual machine files is derived from the name of the guest operating system, for example, Microsoft Windows 10 x64.

For standard virtual machines, the default directory for virtual machine files is located in the virtual machine directory. For best performance, do not place the virtual machines directory on a network drive. If other users need to access the virtual machine, consider placing the virtual machine files in a location that is accessible to those users.

For shared virtual machines, the default directory for virtual machine files is located in the shared virtual machines directory. Shared virtual machine files must reside in the shared virtual machines directory.

**Virtual Machines Directory**

Workstation Player stores standard virtual machines in the virtual machines directory.

The default location of the virtual machines directory depends on the host operating system.
### Table 5-3. Default Virtual Machines Directory

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>Default Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2</td>
<td>C:\Documents and Settings\username\My Documents\My Virtual Machines</td>
</tr>
<tr>
<td>Windows Server 2012 R2</td>
<td>username is the name of the currently logged-in user.</td>
</tr>
<tr>
<td>Windows 7</td>
<td>C:\Users\username \Documents\Virtual Machines</td>
</tr>
<tr>
<td>Windows 8</td>
<td>username is the name of the currently logged in user.</td>
</tr>
<tr>
<td>Windows 10</td>
<td>homedir/vmware</td>
</tr>
<tr>
<td>Linux</td>
<td>homedir is the home directory of the currently logged in user.</td>
</tr>
</tbody>
</table>

### Specifying Disk Capacity for a Virtual Machine

If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to set the size of the virtual disk and specify whether to split the disk into multiple virtual disk (.vmdk) files.

A virtual disk is made up of one or more virtual disk files. Virtual disk files store the contents of the virtual machine hard disk drive. Almost all of the file content is virtual machine data. A small portion of the file is allotted to virtual machine overhead. If the virtual machine is connected directly to a physical disk, the virtual disk file stores information about the partitions that the virtual machine is allowed to access.

You can set a size between 0.001 GB and 8 TB for a virtual disk file. You can also select whether to store a virtual disk as a single file or split it into multiple files.

Select **Split virtual disk into multiple files** if the virtual disk is stored on a file system that has a file size limitation. When you split a virtual disk less than 950 GB, a series of 2-GB virtual disk files are created. When you split a virtual disk greater than 950 GB, two virtual disk files are created. The maximum size of the first virtual disk file is 1.9 TB and the second virtual disk file stores the rest of the data.

Disk space is not preallocated for the disk. The actual files that the virtual disk uses start small and expand to their maximum size as needed. The main advantage of this approach is the smaller file size. Smaller files require less disk space and are easier to move to a new location.

After you create a virtual machine, you can edit virtual disk settings and add additional virtual disks.

### Disk Size Compatibility

The size of a virtual disk is limited to 8 TBs. However, your hardware version, bus type, and controller type also impact the size of your virtual disks.

<table>
<thead>
<tr>
<th>Workstation Hardware Version</th>
<th>Bus Type</th>
<th>Controller Type</th>
<th>Maximum Disk Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>10, 11, 12</td>
<td>IDE</td>
<td>ATAPI</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SCSI</td>
<td>BusLogic</td>
<td>2040 GB (2TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SCSI</td>
<td>LSI Logic</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SCSI</td>
<td>LSI Logic SAS</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SATA</td>
<td>AHCI</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>9, 8, 7, 6, 5</td>
<td>All</td>
<td>All</td>
<td>2040 GB (2TB)</td>
</tr>
<tr>
<td>6.0, 5</td>
<td>All</td>
<td>All</td>
<td>950 GB</td>
</tr>
</tbody>
</table>

To discover your controller type, open the virtual machine .vmx file. The value of the setting s3ci0.virtual1dev determines your controller type.
### Value

<table>
<thead>
<tr>
<th>Value</th>
<th>Controller Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank or not present</td>
<td>BusLogic</td>
</tr>
<tr>
<td>Isilogo</td>
<td>LSI Logic</td>
</tr>
<tr>
<td>Isisas1068</td>
<td>LSI Logic SAS</td>
</tr>
</tbody>
</table>

#### Customizing Virtual Machine Hardware

You can click **Customize Hardware** on the last page of the New Virtual Machine wizard to customize the virtual machine hardware.

You can change the default hardware settings, including memory allocation, number of virtual CPUs, CD/DVD and floppy drive settings, and the network connection type.

#### Worksheet for Creating a Typical Virtual Machine

You can print this worksheet and write the values to specify when you create a typical virtual machine.

<table>
<thead>
<tr>
<th>Table 5-4. Worksheet: Typical Virtual Machine</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
</tr>
<tr>
<td>Guest operating system source</td>
</tr>
<tr>
<td>Guest operating system type for manual installation</td>
</tr>
<tr>
<td>Easy Install information for Windows guests</td>
</tr>
<tr>
<td>■ Product key</td>
</tr>
<tr>
<td>■ Operating system version</td>
</tr>
<tr>
<td>■ Full name</td>
</tr>
<tr>
<td>■ Password</td>
</tr>
<tr>
<td>■ Credentials for automatic login</td>
</tr>
<tr>
<td>Easy Install information for Linux guests</td>
</tr>
<tr>
<td>■ Full name</td>
</tr>
<tr>
<td>■ User name</td>
</tr>
<tr>
<td>■ Password</td>
</tr>
<tr>
<td>Virtual machine name</td>
</tr>
<tr>
<td>Virtual machine location</td>
</tr>
<tr>
<td>Disk capacity</td>
</tr>
</tbody>
</table>

#### Create a Virtual Machine

You create a virtual machine in Workstation Player by running the New Virtual Machine wizard.

#### Prerequisites

- Verify that you have the information the New Virtual Machine wizard requires to create a virtual machine. See “Preparing to Create a Virtual Machine,” on page 31.
- Verify that the guest operating system you plan to install is supported. See the online VMware Compatibility Guide, which is available on the VMware Web site.
- See the VMware Guest Operating System Installation Guide for information about the guest operating system you plan to install.
- If you are installing the guest operating system from an installer disc, insert the installer disc in the CD-ROM drive in the host system.
If you are installing the guest operating system from an ISO image file, verify that the ISO image file is in a directory that is accessible to the host system.

**Procedure**

2. Select the source of the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical disc</td>
<td>Select the physical drive where you inserted the installation disc.</td>
</tr>
<tr>
<td>Use an ISO image</td>
<td>Type or browse to the location of the ISO image file.</td>
</tr>
<tr>
<td>Install the guest operating system later</td>
<td>Create a virtual machine that has a blank disk. You must install the guest operating system manually after the virtual machine is created.</td>
</tr>
</tbody>
</table>

3. Specify information about the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are using Easy Install</td>
<td>Type the Easy Install information for the guest operating system.</td>
</tr>
<tr>
<td>You are not using Easy Install</td>
<td>Select the guest operating system type and version. If the guest operating system is not listed, select Other.</td>
</tr>
</tbody>
</table>

4. Type a virtual machine name and type or browse to the directory for the virtual machine files.

5. Select the virtual disk size and specify whether the disk should be split into multiple files.

6. (Optional) Click Customize Hardware to change the default hardware settings.

   You can also modify virtual hardware settings after you create the virtual machine.

7. (Optional) Select Power on this virtual machine after creation to power on the virtual machine after it is created.

   This option is not available if you are installing the guest operating system manually.

8. Click Finish to create the virtual machine.

   If you are using Easy Install, guest operating system installation begins when the virtual machine powers on. The guest operating system installation is automated and typically runs without requiring any input from you. After the guest operating system is installed, Easy Install installs VMware Tools.

   If you are not using Easy Install, the virtual machine appears in the library.

**What to do next**

If you used Easy Install and the virtual machine did not power on when the installation finished, power on the virtual machine to start the guest operating system installation. See “Use Easy Install to Install a Guest Operating System,” on page 36.

If you did not use Easy Install, install the guest operating system manually. See “Install a Guest Operating System Manually,” on page 37.

**Use Easy Install to Install a Guest Operating System**

When you use Easy Install, you usually do not need to provide information during guest operating system installation.

If you did not provide all of the Easy Install information in the New Virtual Machine wizard, you might be prompted for a product key, username, or password.

Also, if the guest operating system installation consists of multiple discs or ISO image files, the installer might prompt you for the next disk.
Procedure
- If the installer prompts you for a product key, username, or password, click in the virtual machine window and type the required information.
  
  Mouse and keyboard input are captured by the virtual machine.

- If you are using physical discs and the installer prompts you for the next disk, use the CD-ROM or DVD drive on the host system.

- If you are using multiple ISO image files and the installer prompts you for the next disk, select the next ISO image file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Click Change Disk and browse to the next ISO image file.</td>
</tr>
<tr>
<td>Linux host</td>
<td>a Select Virtual Machine &gt; Removable Devices &gt; CD/DVD &gt; Settings and browse to the next ISO image file.</td>
</tr>
<tr>
<td></td>
<td>b Select Connected.</td>
</tr>
<tr>
<td></td>
<td>c Click Save.</td>
</tr>
</tbody>
</table>

Install a Guest Operating System Manually

Installing a guest operating system in a virtual machine is similar to installing an operating system on a physical computer. If you do not use Easy Install when you create a virtual machine in the New Virtual Machine wizard, you must install the guest operating system manually.

You can install a guest operating system from an installer disc or ISO image file. You can also use a PXE server to install the guest operating system over a network connection. If the host configuration does not permit the virtual machine to boot from an installer disc, you can create an ISO image file from the installer disc.

Prerequisites
- Verify that the operating system is supported. See the online VMware Compatibility Guide on the VMware Web site.

- See the VMware Guest Operating System Installation Guide for information on the guest operating system that you are installing.

Procedure
1. If you are installing the guest operating system from an installer disc, configure the virtual machine to use a physical CD-ROM or DVD drive and configure the drive to connect at power on.
   - a Select the virtual machine and select Player > Manage > Virtual Machine Settings.
   - b On the Hardware tab, select CD/DVD drive.
   - c Select Connect at power on.
   - d Select Use physical drive and select a the drive.
   - e Click OK to save your changes.

2. If you are installing the guest operating system from an ISO image file, configure the CD/DVD drive in the virtual machine to point to the ISO image file and configure the drive to connect at power on.
   - a Select the virtual machine and select Player > Manage > Virtual Machine Settings.
   - b On the Hardware tab, select CD/DVD drive.
   - c Select Connect at power on.
d  Select **Use ISO image file** and browse to the location of the ISO image file.

e  Click **OK** to save your changes.

3  If you are installing the guest operating system from an installer disc, insert the disc in the CD-ROM or DVD drive.

4  Power on the virtual machine.

5  Follow the installation instructions provided by the operating system vendor.

6  If the operating system consists of multiple installer discs and you are prompted to insert the next disc, insert the next disc in the physical drive.

7  If the operating system consists of multiple ISO image files, select the image file for the next CD.

   a  Select **Player > Removable Devices > CD/DVD > Disconnect** and disconnect from the current ISO image file.

   b  Select **Player > Removable Devices > CD/DVD > Settings** and select the next ISO image file.

   c  Select **Connected** and click **OK**.

8  Use the standard tools in the operating system to configure its settings.

**What to do next**

Install VMware Tools. You should install VMware Tools before you activate the license for the operating system. See “Installing VMware Tools,” on page 41.

**Importing Virtual Machines**

You can import virtual machines in other formats into Workstation Player.

**Import a Windows XP Mode Virtual Machine**

You can import a Windows XP Mode virtual machine and run it in Workstation Player. When you import a Windows XP Mode virtual machine, Workstation Player creates a new virtual machine in VMware runtime (.vmx) format.

You can power on only one Windows XP Mode virtual machine at a time in Workstation Player. If you move a Windows XP Mode virtual machine to another host system, it becomes a new virtual machine and you must activate it.

---

**Note**  Changes made to the original Windows XP Mode virtual machine through Virtual PC do not affect the virtual machine imported in Workstation Player.

**Prerequisites**

- Verify that the Windows 7 Professional, Enterprise, or Ultimate edition operating system is running on the host system. Importing Windows XP Mode virtual machines is not supported on Linux host systems or on host systems that are running other versions of Windows.

- Download and install the Windows XP Mode virtual machine on the host system.

**Procedure**

1  Select **File > Open** and browse to the virtual machine configuration (.vmc) file.

   If you have never virtualized a physical machine or imported a third-party virtual machine in Workstation Player, you need to download and install VMware vCenter Converter Standalone. After the VMware vCenter Converter Standalone installation is finished, you must restart the import.
2 Type a name for the new virtual machine, type or browse to the directory for the virtual machine files, and click **Import**.

Workstation Player begins importing the Windows XP Mode virtual machine.

After Workstation Player successfully imports the Windows XP Mode virtual machine, a new virtual machine appears in the virtual machine library.

**Import an Open Virtualization Format Virtual Machine**

You can import an Open Virtualization Format (OVF) virtual machine and run it in Workstation Player. Workstation Player converts the virtual machine from OVF format to VMware runtime (.vmx) format. You can import both .ovf and .ova files.

OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual machines. For example, you can import OVF virtual machines exported from VMware Fusion™ or Oracle VM VirtualBox into Workstation Player. You can import OVF 1.0 and later files only.

You can also use the standalone OVF Tool to convert an OVF virtual machine to VMware runtime format. The standalone version of the OVF Tool is installed in the Workstation Player installation directory under OVFTool. See the [OVF Tool User Guide](https://www.vmware.com/support) on the VMware Web site for information on using the OVF Tool.

**Procedure**

1 In Workstation Player, select **Player > File > Open**.
2 Browse to the .ovf or .ova file and click **Open**.
3 Type a name for the virtual machine, type or browse to the directory for the virtual machine files, and click **Import**.

Workstation Player performs OVF specification conformance and virtual hardware compliance checks. A status bar indicates the progress of the import process.

4 If the import fails, click **Retry** to try again, or click **Cancel** to cancel the import.

If you retry the import, Workstation Player relaxes the OVF specification conformance and virtual hardware compliance checks and you might not be able to use the virtual machine in Workstation Player.

After Workstation Player successfully imports the OVF virtual machine, the virtual machine appears in the virtual machine library.

**Import a Windows Virtual PC Virtual Machine**

You can import a Windows Virtual PC virtual machine and run it in Workstation Player. Workstation Player converts the virtual machine from Virtual PC (.vmc) format to VMware runtime (.vmx) format. This feature is supported only on Windows host systems.

**Prerequisites**

Download and install the Virtual PC virtual machine on the Windows host system.

**Procedure**

1 Select **Player > File > Open**.

If you have never virtualized a physical machine or imported a third-party virtual machine in Workstation Player, you need to download and install VMware vCenter Converter Standalone. After the VMware vCenter Converter Standalone installation is finished, you must restart the import.

2 Browse to the .vmc file and click **Open**.
3 Type a name for the virtual machine, type or browse to the directory for the virtual machine files, and click **Import**.

After Workstation Player successfully imports the Virtual PC virtual machine, the virtual machine appears in the virtual machine library.
Installing VMware Tools is part of the process of creating a new virtual machine. Upgrading VMware Tools is part of the process of keeping virtual machines up to current standards.

For the best performance and latest updates, install or upgrade VMware Tools to match the version of Workstation Player that you are using. Other compatibility options are also available.


This chapter includes the following topics:

- "Installing VMware Tools," on page 41
- "Upgrading VMware Tools," on page 42
- "Configure Software Update Preferences," on page 43
- "Configure VMware Tools Updates for a Specific Virtual Machine," on page 44
- "Manually Installing and Upgrading VMware Tools," on page 44
- "Start the VMware User Process Manually If You Do Not Use a Session Manager," on page 50
- "Uninstalling VMware Tools," on page 50

**Installing VMware Tools**

Although your guest operating systems can run without VMware Tools, many VMware features are not available until you install VMware Tools. When you install VMware Tools, the utilities in the tools suite enhances the performance of your virtual machine's guest operating system and improves the management of your virtual machines.

Installing VMware Tools is part of the process of creating new virtual machines, and upgrading VMware Tools is part of the process of keeping your virtual machine up to current standards. For information about creating virtual machines, see the Virtual Machine Administration Guide.

The installers for VMware Tools are ISO image files. An ISO image file looks like a CD-ROM to your guest operating system. Each type of guest operating system, including Windows, Linux, Solaris, FreeBSD, and NetWare, has an ISO image file. When you select the command to install or upgrade VMware Tools, the virtual machine's first virtual CD-ROM disk drive temporarily connects to the VMware Tools ISO file for your guest operating system.

You can use the Windows Easy Install or Linux Easy Install feature to install VMware Tools as soon as the operating system is finished installing.
The most recent versions of the ISO files are stored on a VMware Web site. When you select the command to install or upgrade VMware Tools, the VMware product determines whether it has downloaded the most recent version of the ISO file for the specific operating system. If the latest version has not been downloaded or if no VMware Tools ISO file for that operating system has ever been downloaded, you are prompted to download the file.

- For information about installing or upgrading VMware Tools in Windows virtual machines, see “Manually Install or Upgrade VMware Tools in a Windows Virtual Machine,” on page 44 and Automate VMware Tools Installation for Multiple Windows Virtual Machines.

- For information about installing or upgrading VMware Tools in Linux virtual machines, see “Manually Install or Upgrade VMware Tools in a Linux Virtual Machine,” on page 45.

- For information about installing or upgrading VMware Tools in Solaris virtual machines, see “Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine,” on page 48.

- For information about installing or upgrading VMware Tools in NetWare virtual machines, see “Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine,” on page 47.

- For information about installing or upgrading VMware Tools in FreeBSD virtual machines, see “Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine,” on page 49.

#### Upgrading VMware Tools

You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

The guest operating system checks the version of VMware Tools when you power on a virtual machine. The status bar of your virtual machine displays a message when a new version is available.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon when a VMware Tools upgrade is available.

To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware Tools the first time. Upgrading VMware Tools means installing a new version.

For Windows and Linux guest operating systems, you can configure the virtual machine to automatically upgrade VMware Tools. Although the version check is performed when you power on the virtual machine, on Windows guest operating systems, the automatic upgrade occurs when you power off or restart the virtual machine. The status bar displays the message Installing VMware Tools ... when an upgrade is in progress.

**IMPORTANT** After you upgrade VMware Tools on Linux guest operating systems, new network modules are available but are not used until you either restart the guest operating system or stop networking, unload and reload the VMware networking kernel modules, and restart networking. This behavior means that even if VMware Tools is set to automatically upgrade, you must restart or reload network modules to make new features available.

This strategy avoids network interruptions and allows you to install VMware Tools over SSH.

Upgrading VMware Tools on Windows guest operation systems automatically installs the WDDM graphics drivers. The WDDM graphics driver makes the sleep mode available in guest OS power settings to adjust the sleep options. For example, you can use the sleep mode setting **Change when the computer sleeps** to configure your guest OS to automatically go to sleep mode after a certain time or prevent your guest OS from automatically switching to sleep mode after being idle for some time.
Some features in a particular release of a VMware product might depend on installing or upgrading to the version of VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not always necessary. Newer versions of VMware Tools are compatible with several host versions. To avoid unnecessary upgrades, evaluate whether the added features and capabilities are necessary for your environment.

**Configure Software Update Preferences**

You can configure Workstation Player to automatically download software updates, including new versions of VMware Tools. When you select automatic software updates, Workstation Player always includes the latest support for guest operating systems and virtual machines always have the latest version of VMware Tools.

**Procedure**

1. Select **Player > File > Preferences**.

2. Select when Workstation Player checks for software updates.

   - You can select one, both, or neither option. If you deselect all of the software update options, automatic software updates are disabled.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check for product updates on startup</td>
<td>Checks for new versions of Workstation Player available to download and install when you start Workstation Player. This option is enabled by default. If you do not select this option, your system does not get the latest product updates.</td>
</tr>
<tr>
<td>Check for software components as needed</td>
<td>When a software component is required, for example, when you install VMware Tools, Workstation Player checks for a new version of the component.</td>
</tr>
<tr>
<td>Download All Components Now</td>
<td>Immediately download all of the available software components to the host system. This option is useful if you are planning to use the virtual machine at a later time when you do not have access to the Internet.</td>
</tr>
</tbody>
</table>

3. If you use a proxy server to connect to the VMware Update Server, click **Connection Settings** to configure the proxy settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No proxy</td>
<td>Select this option if you do not use a proxy server. This is the default setting.</td>
</tr>
<tr>
<td>Windows proxy settings</td>
<td>Workstation Player uses the host proxy settings from the Connections tab in the Internet Options control panel to access the VMware Update Server.</td>
</tr>
<tr>
<td></td>
<td>a Click <strong>Internet Options</strong> to set the guest connection options.</td>
</tr>
<tr>
<td></td>
<td>b Type a user name and password to use for proxy server authentication. If you leave either the Username or the Password text box blank, Workstation Player does not use either value.</td>
</tr>
<tr>
<td>Manual proxy settings</td>
<td>a Select HTTP or SOCKS, specify the proxy server address and designate a port number to access the VMware Update Server.</td>
</tr>
<tr>
<td></td>
<td>b Type a username and password to use for proxy authentication. If you leave either the Username or the Password text box blank, Workstation Player does not use either value (Windows hosts) or it uses the username and password set in the gnome settings (Linux hosts).</td>
</tr>
</tbody>
</table>

4. Click **OK** to save your changes.
Configure VMware Tools Updates for a Specific Virtual Machine

You can configure virtual machines that have Windows or Linux guest operating systems to update VMware Tools automatically. For other guest operating systems, you must manually update VMware Tools.

Automatic VMware Tools updates are supported for versions of VMware Tools included in Workstation 5.5 and later virtual machines only. Automatic updates are not supported for versions of VMware Tools included in virtual machines created with VMware Server 1.x.

**IMPORTANT** If you update VMware Tools in a Windows virtual machine that was created with Workstation 4 or 5.x, some new components are not installed. To install the new components, you must uninstall the old version of VMware Tools and install the new version of VMware Tools.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **VMware Tools**.
3. Select a VMware Tools update setting.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update manually (do nothing)</td>
<td>You must update VMware Tools manually. The virtual machine status bar indicates when a new version of VMware Tools is available.</td>
</tr>
<tr>
<td>Update automatically</td>
<td>VMware Tools is updated automatically. The virtual machine status bar indicates when an update is in progress. If you are logged in to a Windows guest, a restart prompt appears after the update is complete. If you are not logged in, the operating system restarts without prompting. An auto-update check is performed as part of the boot sequence when you power on the virtual machine. If the virtual machine was suspended and you resume it or restore it to a snapshot during the boot sequence before this check, the automatic update occurs as planned. If you resume the virtual machine or restore it to a snapshot after the check, the automatic update does not occur.</td>
</tr>
<tr>
<td>Use application default (currently update manually)</td>
<td>Use the default VMware Tools update behavior. The default behavior is set in Workstation Player preferences.</td>
</tr>
</tbody>
</table>

4. Click **OK** to save your changes.

**Manually Installing and Upgrading VMware Tools**

You can manually install or upgrade VMware Tools on Windows, Linux, NetWare, Solaris, and FreeBSD virtual machines.

If you are installing VMware Tools in a number of Windows virtual machines, you can automate its installation by using the VMware Tools setup.exe at a command prompt in the guest operating system. See *Installing and Configuring VMware Tools* at [http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf](http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf) for more information.

**Manually Install or Upgrade VMware Tools in a Windows Virtual Machine**

All supported Windows guest operating systems support VMware Tools.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.
Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- If you connected the virtual machine’s virtual CD/DVD drive to an ISO image file when you installed the operating system, change the setting so that the virtual CD/DVD drive is configured to autodetect a physical drive.

The autodetect setting enables the virtual machine’s first virtual CD/DVD drive to detect and connect to the VMware Tools ISO file for a VMware Tools installation. This ISO file looks like a physical CD to your guest operating system. Use the virtual machine settings editor to set the CD/DVD drive to autodetect a physical drive.

- Log in as an administrator unless you are using an older Windows operating system. Any user can install VMware Tools in a Windows 95, Windows 98, or Windows ME guest operating system. For operating systems newer than these, you must log in as an administrator.

Procedure

1. On the host, from the Workstation Player menu bar, select **Player > Manage > Install VMware Tools**.

   If an earlier version of VMware Tools is installed, the menu item is **Update VMware Tools**.

2. If you are installing VMware Tools for the first time, click **OK** on the Install VMware Tools information page.

   If autorun is enabled for the CD-ROM drive in the guest operating system, the VMware Tools installation wizard starts.

3. If autorun is not enabled, to manually launch the wizard, click **Start > Run** and enter `D:\setup.exe`, where `D:` is your first virtual CD-ROM drive. Use `D:\setup64.exe` for 64-bit Windows guest operating system.

4. Follow the on-screen instructions.

5. If the New Hardware wizard appears, follow the prompts and accept the defaults.

6. If you are installing a beta or RC version of VMware Tools and you see a warning that a package or driver is not signed, click **Install Anyway** to complete the installation.

7. When prompted, reboot the virtual machine.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

**Manually Install or Upgrade VMware Tools in a Linux Virtual Machine**

For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.
Procedure

1. On the host, from the Workstation Player menu bar, select Player > Manage > Install VMware Tools.
   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2. In the virtual machine, log in to the guest operating system as root and open a terminal window.

3. Run the `mount` command with no arguments to determine whether your Linux distribution automatically mounted the VMware Tools virtual CD-ROM image.
   If the CD-ROM device is mounted, the CD-ROM device and its mount point are listed as something like this:
   ```
   /dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)
   ```

4. If the VMware Tools virtual CD-ROM image is not mounted, mount the CD-ROM drive.
   a. If a mount point directory does not already exist, create it.
      ```
      mkdir /mnt/cdrom
      ```
      Some Linux distributions use different mount point names. For example, on some distributions the mount point is `/media/VMware Tools` rather than `/mnt/cdrom`. Modify the command to reflect the conventions that your distribution uses.
   b. Mount the CD-ROM drive.
      ```
      mount /dev/cdrom /mnt/cdrom
      ```
      Some Linux distributions use different device names or organize the `/dev` directory differently. If your CD-ROM drive is not `/dev/cdrom` or if the mount point for a CD-ROM is not `/mnt/cdrom`, modify the command to reflect the conventions that your distribution uses.

5. Change to a working directory, for example, `/tmp`.
   ```
   cd /tmp
   ```

6. Delete any previous `vmware-tools-distrib` directory before you install VMware Tools.
   The location of this directory depends on where you placed it during the previous installation. Often this directory is placed in `/tmp/vmware-tools-distrib`.

7. List the contents of the mount point directory and note the filename of the VMware Tools tar installer.
   ```
   ls mount-point
   ```

8. Uncompress the installer.
   ```
   tar zxpf /mnt/cdrom/VMwareTools-x.x.x-yyyy.tar.gz
   ```
   The value `x.x.x` is the product version number, and `yyyy` is the build number of the product release.
   If you attempt to install a tar installation over an RPM installation, or the reverse, the installer detects the previous installation and must convert the installer database format before continuing.

9. If necessary, unmount the CD-ROM image.
   ```
   umount /dev/cdrom
   ```
   If your Linux distribution automatically mounted the CD-ROM, you do not need to unmount the image.

10. Run the installer and configure VMware Tools.
    ```
        cd vmware-tools-distrib
        ./vmware-install.pl
    ```
    Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.
11 Follow the prompts to accept the default values, if appropriate for your configuration.

12 Follow the instructions at the end of the script.

Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine

For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

Procedure

1 On the host, from the Workstation Player menu bar, select Player > Manage > Install VMware Tools.

If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2 Load the CD-ROM driver so that the virtual CD-ROM device mounts the ISO image as a volume.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>NetWare 6.5</td>
<td>LOAD CDVD</td>
</tr>
<tr>
<td>NetWare 6.0 or NetWare 5.1</td>
<td>LOAD CD9660.NSS</td>
</tr>
<tr>
<td>NetWare 4.2 (not available in vSphere)</td>
<td>load cdrom</td>
</tr>
</tbody>
</table>

When the installation finishes, the message VMware Tools for NetWare are now running appears in the Logger Screen for NetWare 6.5 and NetWare 6.0 guest operating systems and in the Console Screen for NetWare 4.2 and 5.1 operating systems.

3 If the VMware Tools virtual disc (netware.iso) is attached to the virtual machine, right-click the CD-ROM icon in the status bar of the console window and select Disconnect to disconnect it.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine

For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

Procedure

1. On the host, from the Workstation Player menu bar, select Player > Manage > Install VMware Tools. If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
2. In the virtual machine, log in to the guest operating system as root and open a terminal window.
3. If the Solaris volume manager does not mount the CD-ROM under /cdrom/vmwaretools, restart the volume manager.
   
   ```
   /etc/init.d/volmgt stop
   /etc/init.d/volmgt start
   ```
4. Change to a working directory, for example, /tmp.
   
   ```
   cd /tmp
   ```
5. Extract VMware Tools.
   
   ```
   gunzip -c /cdrom/vmwaretools/vmware-solaris-tools.tar.gz | tar xf -
   ```
6. Run the installer and configure VMware Tools.
   
   ```
   cd vmware-tools-distrib
   ./vmware-install.pl
   ```
   Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.
7. Follow the prompts to accept the default values, if appropriate for your configuration.
8. Follow the instructions at the end of the script.
   
   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine

For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line. Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine's guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.

Prerequisites
- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

Procedure
1. On the host, from the Workstation Player menu bar, select Player > Manage > Install VMware Tools. If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
2. In the virtual machine, log in to the guest operating system as root and open a terminal window.
3. If the distribution does not automatically mount CD-ROMs, mount the VMware Tools virtual CD-ROM image.
   For example, type `mount /cdrom`.
4. Change to a working directory, for example, `/tmp`.
   ```
   cd /tmp
   ```
5. Untar the VMware Tools tar file.
   ```
   tar zxf /cdrom/vmware-freebsd-tools.tar.gz
   ```
6. If the distribution does not use automounting, unmount the VMware Tools virtual CD-ROM image.
   ```
   umount /cdrom
   ```
7. Run the installer and configure VMware Tools.
   ```
   cd vmware-tools-distrib
   ./vmware-install.pl
   ```
   Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.
8. Follow the prompts to accept the default values, if appropriate for your configuration.
9. Follow the instructions at the end of the script.
   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next
If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
Start the VMware User Process Manually If You Do Not Use a Session Manager

VMware Tools in Linux, Solaris, and FreeBSD guest operating systems uses the VMware User process executable file. This program implements the fit-guest-to-window feature and Unity mode, among other features.

Normally, this process starts after you configure VMware Tools, log out of the desktop environment, and log back in. The `vmware-user` program is located in the directory in which you selected to install binary programs, which defaults to `/usr/bin`. The startup script that you need to modify depends on your system. You must start the process manually in the following environments:

- If you run an X session without a session manager. For example, if you use `startx` to start a desktop session and do not use `xdm`, `kdm`, or `gdm`.
- If you are using an older version of GNOME without `gdm` or `xdm`.
- If you are using a session manager or environment that does not support the Desktop Application Autostart Specification, available from [http://standards.freedesktop.org](http://standards.freedesktop.org).
- If you upgrade VMware Tools.

Procedure

- **Start the VMware User process.**

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start the VMware User process when you start an X session.</td>
<td>Add <code>vmware-user</code> to the appropriate X startup script, such as the <code>.xsession</code> or <code>.xinitrc</code> file.</td>
</tr>
<tr>
<td>Start the process after a VMware Tools software upgrade, or if certain features are not working.</td>
<td>Open a terminal window and type the <code>vmware-user</code> command.</td>
</tr>
</tbody>
</table>

Uninstalling VMware Tools

If the upgrade process of VMware Tools is incomplete, you can uninstall and then reinstall the VMware Tools.

**Prerequisites**

- Power on the virtual machine.
- Log in to the guest operating system.

**Procedure**

- **Select a method to uninstall VMware Tools.**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, 8, 8.1, or Windows 10</td>
<td>In the guest operating system, select <code>Programs &gt; Uninstall a program</code>.</td>
</tr>
<tr>
<td>Windows Vista and Windows Server 2008</td>
<td>In the guest operating system, select <code>Programs and Features &gt; Uninstall a program</code>.</td>
</tr>
<tr>
<td>Windows XP and earlier</td>
<td>In the guest operating system, select <code>Add/Remove Programs</code>.</td>
</tr>
<tr>
<td>Linux</td>
<td>Log in as root and enter <code>vmware-uninstall-tools.pl</code> in a terminal window.</td>
</tr>
<tr>
<td>Mac OS X Server</td>
<td>Use the <code>Uninstall VMware Tools</code> application, found in <code>/Library/Application Support/VMware Tools</code>.</td>
</tr>
</tbody>
</table>
What to do next

Reinstall VMware Tools.
Starting and Stopping Virtual Machines in Workstation Player

You can use Workstation Player to start and stop virtual machines on the host system. When you start a virtual machine, the guest operating system starts and you can interact with the virtual machine. You can power off, reset, and suspend virtual machines.

This chapter includes the following topics:

- “Start a Virtual Machine in Workstation Player,” on page 53
- “Start an Encrypted Virtual Machine in Workstation Player,” on page 54
- “Download a Virtual Appliance in Workstation Player,” on page 54
- “Power Off a Virtual Machine in Workstation Player,” on page 54
- “Remove a Virtual Machine from the Library in Workstation Player,” on page 55
- “Use Ctrl+Alt+Delete to Shut Down a Guest,” on page 55
- “Suspend and Resume a Virtual Machine in Workstation Player,” on page 55
- “Reset a Virtual Machine in Workstation Player,” on page 56
- “Enable Autologon in a Windows Virtual Machine,” on page 56
- “Set Workstation Player Preferences for Virtual Machine Closing Behavior,” on page 57

Start a Virtual Machine in Workstation Player

You can start a virtual machine from the Workstation Player window.

Prerequisites

Verify that the virtual machine files are accessible to the host system.

Procedure

1. If the virtual machine does not appear in the library, select Player > File > Open.
2. Browse to and select the virtual machine configuration (.vmx) file, and click Open.
   The virtual machine appears in the library.
3. Select the virtual machine in the library and select Player > Power > Power On.
4. Click anywhere inside the virtual machine console to give the virtual machine control of the mouse and keyboard on the host system.
5. Log in to the guest operating system.
Start an Encrypted Virtual Machine in Workstation Player

An encrypted virtual machine is a virtual machine that has been secured from unauthorized use. A lock icon appears next to an encrypted virtual machine in the virtual machine library.

For information about using Workstation Player to open a Horizon FLEX virtual machine, see the VMware Horizon FLEX Client User Guide.

**Note** You cannot create encrypted virtual machines in Workstation Player. You can create encrypted virtual machines by using only VMware Workstation 7.x or VMware Fusion 7.x and later.

**Prerequisites**

Obtain the encryption password for the virtual machine.

**Procedure**

1. Select the virtual machine in the library and select **Player > Power > Power On**.
2. Type the encryption password.
3. Click **Continue** to start the virtual machine.

Download a Virtual Appliance in Workstation Player

You can download a virtual appliance in Workstation Player. A virtual appliance is a prebuilt, preconfigured, and ready-to-run software application that is packaged with the operating system in a virtual machine.

**Procedure**

- Select **Player > File > Download a Virtual Appliance**.

A Web browser opens to the Virtual Appliance Marketplace page on the VMware Web site. You can browse to and download virtual appliances from this page.

Power Off a Virtual Machine in Workstation Player

As with physical computers, you should shut down a guest operating system before you power off a virtual machine.

**Procedure**

- To shut down the guest operating system, shut down the operating system as you would if you were using a physical machine.

  When the guest operating system shuts down, the virtual machine is powered off and Workstation Player exits.

- To power off a virtual machine without shutting down the guest operating system, select **Player > Power > Power Off**.

  If soft power operations are configured for the virtual machine when the virtual machine is first created, **Power Off Guest** appears in the menu instead of **Power Off**.
Remove a Virtual Machine from the Library in Workstation Player

When you open a virtual machine in Workstation Player, it is added to the virtual machine library. You can remove a virtual machine that you are not using from the library.

Removing a virtual machine from the library does not delete the virtual machine or any of its files from the host file system. The virtual machine is removed only from the library. If you open the virtual machine again, the virtual machine is added back to the library.

**Prerequisites**

Power off the virtual machine.

**Procedure**

- Select the virtual machine, right-click, and select **Remove VM from the Library**.

The virtual machine is removed from the library without any confirmation.

Use Ctrl+Alt+Delete to Shut Down a Guest

You can use the Ctrl+Alt+Delete key sequence to shut down or log off of a guest operating system.

**Prerequisites**

Power on the virtual machine.

**Procedure**

- Select the virtual machine and select **Player > Send Ctrl+Alt+Delete**.

  This option is the same as pressing Ctrl+Alt+Delete on your keyboard. On Windows hosts, using the physical keyboard to press Ctrl+Alt+Delete might send the command to the host operating system and the virtual machine, even when Workstation Player has control of input.

- If the command is received by both the host operating system and the virtual machine, press Ctrl+Alt+Ins on the keyboard.

  The command is received solely by the virtual machine and shuts down or logs out of the guest operating system.

Suspend and Resume a Virtual Machine in Workstation Player

Suspending a virtual machine saves its current state. When you resume the virtual machine, applications that were running before the virtual machine was suspended resume in their running state and their content is unchanged.

How quickly the suspend and resume operations perform depends on how much data changed after you started the virtual machine. The first suspend typically takes longer than subsequent suspend operations.

**Procedure**

- To suspend a virtual machine, select **Player > Power > Suspend** and click **Yes** to confirm.

  If soft power operations are configured for the virtual machine when the virtual machine is first created, **Suspend Guest** appears in the menu instead of **Suspend**.

  Workstation Player returns the virtual machine to the library in the Suspended state.

- To resume a suspended virtual machine, select the virtual machine and select **Player > Power > Power On**.
To set the Workstation Player preferences to suspend the virtual machine when you close the virtual machine window, select **Player > File > Preferences** and then select **Suspend the virtual machine**.

**Reset a Virtual Machine in Workstation Player**

You can reset a virtual machine in Workstation Player. Resetting a virtual machine causes it to abruptly power off and restart.

**Prerequisites**

- Power on the virtual machine.
- Verify that the virtual machine is in a safe state. Resetting a virtual machine can damage data. When possible, shut down the virtual machine with its operating system.

**Procedure**

- Select **Player > Power > Reset**.

  If soft power operations are configured for the virtual machine in Workstation Player, **Reset Guest** appears in the menu instead of **Reset**.

**Enable Autologon in a Windows Virtual Machine**

With Autologon, you can save your login credentials and bypass the login dialog box when you power on a Windows virtual machine. The guest operating system securely stores the password.

Use the Autologon feature if you restart the guest operating system frequently and want to avoid entering your login credentials. You can also use the Autologon feature to grant users access to the guest operating system without sharing your password.

**Prerequisites**

- Verify that the guest operating system is Windows 2000 or later.
- Verify that you have an existing user account to enable Autologon. The account must be a local machine account, not a domain account.
- Verify that the latest version of VMware Tools is running in the guest operating system.
- Power on the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Autologon**.
3. Click **Enable**, type your login credentials, and click **OK**.

   If you type an incorrect or expired password, you must type your login credentials when you power on the virtual machine.

4. Click **OK** to save your changes.

When you enable Autologon or change your login credentials, the Autologon settings are saved immediately. Clicking **Cancel** in the Virtual Machine Settings dialog box does not affect the changes applied to the Autologon settings.
Set Workstation Player Preferences for Virtual Machine Closing Behavior

You can configure how virtual machines behave when you close them.

Procedure

1 Select Player > File > Preferences.

2 Select how Workstation Player behaves when you close a virtual machine.

You can select one, both, or neither option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confirm before closing a virtual machine</td>
<td>Confirm whether you intend to exit Workstation Player or click Cancel to continue using Workstation Player</td>
</tr>
<tr>
<td>Return to the VM Library after closing a virtual machine</td>
<td>Workstation Player either suspends or powers off the virtual machine and returns it to the virtual machine library. From the library, you can either open another virtual machine or edit the virtual machine settings.</td>
</tr>
</tbody>
</table>

3 Select whether Workstation Player suspends or powers off a virtual machine when you close it.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suspend the virtual machine</td>
<td>Workstation Player suspends the virtual machine. The next time you start Workstation Player, the virtual machine resumes operation from the point where it was suspended.</td>
</tr>
<tr>
<td>Power off the virtual machine</td>
<td>Workstation Player powers off the virtual machine. The next time you start Workstation Player, the virtual machine starts from a powered-off state and the guest operating system starts.</td>
</tr>
</tbody>
</table>

4 Click OK to save your changes.
Changing the Virtual Machine Display

You can change the way Workstation Player displays virtual machines and virtual machine applications. You can use full screen mode to make the virtual machine display fill the screen and use multiple monitors. You can also use Unity mode to display applications directly on the host system desktop.

This chapter includes the following topics:

- “Configure Display Settings for a Virtual Machine,” on page 59
- “Use Full Screen Mode in Workstation Player,” on page 60
- “Use Unity Mode,” on page 61
- “Use Multiple Monitors for One Virtual Machine in Workstation Player,” on page 63

Configure Display Settings for a Virtual Machine

You can specify monitor resolution settings, configure multiple monitors, and select accelerated graphics capabilities for a virtual machine. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

For Windows guests, to use DirectX 9 accelerated graphics, the guest operating system must be Windows XP or later. To use DirectX 10 accelerated graphics, the guest operating system must be Windows Vista or later.

Prerequisites

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system in the virtual machine is Windows XP or higher, or Linux.
- If you plan to use DirectX 9 or DirectX 10 accelerated graphics, prepare the host system. See “Prepare the Host System to Use 3D Accelerated Graphics,” on page 82.
- If you are using Windows 8.1 (Update 2) or Windows 10, Workstation Player detects the DPI on each monitor and scales the virtual machine to match the DPI on the host.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Display.
3. (Optional) To run applications that use DirectX 9 or DirectX 10 accelerated graphics, select Accelerate 3D graphics.
4 Specify whether host settings determine the number of monitors.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use host setting for monitors</td>
<td>When you select this setting, the SVGA driver uses two monitors, a maximum bounding box width of 3840, and a maximum bounding box height of 1920. The virtual machine is configured to have a minimum of two 1920x1200 monitors, in a side-by-side topology, in both normal and rotated orientations. If the host system has more than two monitors, the virtual machine uses the number of monitors on the host system instead. If the host system's bounding box is wider or taller than the defaults, the virtual machine uses the larger size. You should select this setting in most cases.</td>
</tr>
<tr>
<td>Specify monitor settings</td>
<td>Set the number of monitors that the virtual machine will see, regardless of the number of monitors on the host system. This setting is useful if you use a multimonitor host system and you need to test in a virtual machine that has only one monitor. It is also useful if you are developing a multimonitor application in a virtual machine and the host system has only one monitor. After you power on the virtual machine, the guest operating system sees the number of monitors that you specified. Select a resolution from the list or type a setting that has the format width x height, where width and height are the number of pixels.</td>
</tr>
</tbody>
</table>

5 (Optional) Select the maximum amount of guest memory that can be used for graphics memory using the drop down menu. The default value of video memory varies by guest OS.

<table>
<thead>
<tr>
<th>Guest OS</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7 and later</td>
<td>1 GB</td>
</tr>
<tr>
<td>Windows XP and earlier</td>
<td>512 MB</td>
</tr>
<tr>
<td>Linux</td>
<td>768 MB</td>
</tr>
</tbody>
</table>

**Note** If you manually edited the .vmx file to change the memory size for the virtual machine, the value you entered in the .vmx file is displayed, labeled Custom.

6 To enable display scaling for the virtual machine, select the **Automatically adjust user interface size in the virtual machine** check box.

7 Click OK to save your changes.

## Use Full Screen Mode in Workstation Player

In full screen mode, the virtual machine display fills the screen, so that you cannot see the borders of the Workstation Player window.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system display mode is larger than the host system display mode. If the guest operating system display mode is smaller than the host system display mode, you might not be able to enter full screen mode. If you cannot enter full screen mode, add the line mks_maxRefreshRate=1000 to the virtual machine configuration (.vmx) file.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- If you are running the virtual machine in full screen mode on a laptop, configure the guest operating system to report battery information. See “Report Battery Information in the Guest,” on page 61.

**Procedure**

- To enter full screen mode, select the virtual machine and select Player > Full Screen.
To hide the full screen toolbar and menus while you are using full screen mode, click the push pin icon and move the pointer off of the toolbar. This action unpins the toolbar. The toolbar slides up to the top of the monitor and disappears. To display the toolbar again, point to the top of the screen until the toolbar appears.

To exit full screen mode and return to windowed mode, select **Player > Full Screen** from the full screen toolbar. The check mark next to **Full Screen** is removed.

**Report Battery Information in the Guest**

If you run a virtual machine on a laptop in full screen mode, configure the option to report battery information in the guest so that you can determine when the battery is running low.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Power**.
3. Select **Report battery information to guest**.
4. Click **OK** to save your changes.

**Use Unity Mode**

You can switch virtual machines that have Windows XP or later guest operating systems to Unity mode to display applications directly on the host system desktop.

In Unity mode, virtual machine applications appear on the host system desktop, you can use the virtual machine **Start** or **Applications** menu from the host system, and the virtual machine console view is hidden. Items for open virtual machine applications appear on the host system taskbar in the same way as open host applications.

On host system and virtual machine applications that are displayed in Unity mode, you can use keyboard shortcuts to copy, cut, and paste images, plain text, formatted text, and email attachments between applications. You can also drag and drop and copy and paste files between the host system and the guest operating system.

If you save a file or attempt to open a file from an application in Unity mode, the file system you see is the file system inside the virtual machine. You cannot open a file from the host operating system or save a file to the host operating system.

For some guest operating systems, application windows in Unity mode can appear only on the monitor that is set as the primary display when you have multiple monitors. If the host and guest operating systems are Windows XP or later, the application windows can appear on additional monitors.

Unity mode is not available in full screen mode on Windows.

**Prerequisites**

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system is Windows XP or later.
- Power on the virtual machine.
- If you are entering Unity mode, open applications in the virtual machine to use in Unity mode.
Procedure

- To enter Unity mode, select Player > Unity.

  The console view in the Workstation Player window is hidden, and open applications appear in application windows on the host system desktop. A check mark appears next to Unity in the menu.

- To display the virtual machine Start menu on a Windows host system, point to the Start menu on a Windows host system.

- To navigate between multiple Start or Applications menus when multiple virtual machines are in Unity mode, press the arrow keys, Tab, or Shift+Tab to cycle through the virtual machine menus and press Enter and the spacebar to select a virtual machine.

- To exit Unity mode, display the Workstation Player window and click Exit Unity in the virtual machine console view.

Set Preferences for Unity Mode

You can set preferences for Unity mode to control whether the virtual machine Start or Applications menu is available from the host system desktop. You can also select the border color that appears around applications that run in Unity mode when they appear on the host system desktop.

When you use the virtual machine Start or Applications menu from the host system desktop, you can start applications in the virtual machine that are not open in Unity mode. If you do not enable this feature, you must exit Unity mode to display the virtual machine Start or Applications menu in the console view.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options, select Unity.
3. Select a Unity window decoration option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show borders</td>
<td>Set a window border that identifies the application as belonging to the virtual machine rather than to the host computer.</td>
</tr>
<tr>
<td>Show badges</td>
<td>Display a logo in the title bar.</td>
</tr>
<tr>
<td>Use a custom color in window borders</td>
<td>Use a custom color in window borders to help distinguish between the application windows that belong to various virtual machines. For example, you can set the applications for one virtual machine to have a blue border and set the applications for another virtual machine to have a yellow border. On Windows hosts, click Choose color to use the color chooser.</td>
</tr>
</tbody>
</table>

4. To control whether the virtual machine Start or Application menu available on the host system desktop, select or deselect Enable applications menu.
5. Click OK to save your changes.

Create Virtual Machine Application Shortcuts on the Host in Unity Mode

You can create a shortcut for a virtual machine application on the host system in Unity mode.

You open the application in the same way that you open an application on the host system. You can open a virtual machine application shortcut from the host system even when the virtual machine is powered off or suspended.

Prerequisites

- Verify that the virtual machine is configured to display the virtual machine Start or Application menu on the host system desktop. See “Set Preferences for Unity Mode,” on page 62.
Verify that the latest version of VMware Tools is running in the guest operating system.

Power on the virtual machine.

**Procedure**

1. To enter Unity mode, select **Player > Unity**.
   
   The console view in the Workstation Player window is hidden, and open applications appear in application windows on the host system desktop. A check mark appears next to **Unity** in the menu.

2. Point to the **Start** button to display the virtual machine **Start** menu on the host system desktop, click the **Start** menu, and select the application.

3. Right-click the application and select **Create Shortcut on Desktop**, or drag the application to the host system.

**Use Multiple Monitors for One Virtual Machine in Workstation Player**

If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

**Prerequisites**

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system is Windows XP, Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, or Linux.
- On the host system, verify that the left-most monitor is not placed lower than any other monitor in the display topology. When you enter full screen mode, the monitor that contains the window cannot be lower than another monitor.

**Procedure**

1. Power on the virtual machine and click the maximize button.

2. On the full screen toolbar, click the **Cycle multiple monitors** button.

   On a Windows host, you can mouse over a button on the toolbar to see its name.

   If your virtual machine supports more than two monitors, use the **Cycle multiple monitors** button to select a configuration with more than two monitors. The monitor in which the virtual machine entered full screen mode is marked with an asterisk.

   The guest operating system desktop extends to the additional monitor or monitors.

3. If the host system has more than two monitors and you want the virtual machine to use all of the monitors, click the **Cycle multiple monitors** button again.

   The order in which the monitors are used depends on the order in which the monitors were added to the host operating system. If you continue to click the button, you return to fewer monitors.

**Limitations for Multiple Monitors**

The use of more than two monitors with a virtual machine has certain limitations.

- If you attempt to use more than two monitors with a virtual machine, your virtual machine must support more than two monitors for this feature to function.
- More than two monitors is supported on Windows and Linux host and guest operating systems.
Windows XP guests support more than three monitors. However, only three monitors can be in use by a Windows XP guest at one time. If more than three monitors are connected to a Windows XP guest, use the Cycle multiple monitors button to cycle through the monitors to the configuration you want to use.
Using Removable Devices and Printers in Virtual Machines

You can connect and disconnect removable devices in a virtual machine. You can also print from a virtual machine to any printer available to the host computer without having to install additional drivers in the virtual machine.

This chapter includes the following topics:
- “Use a Removable Device in a Virtual Machine,” on page 65
- “Connecting USB Devices to Virtual Machines,” on page 66
- “Add a Host Printer to a Virtual Machine,” on page 68
- “Using Smart Cards in Virtual Machines,” on page 68

Use a Removable Device in a Virtual Machine

You can connect and disconnect removable devices in a virtual machine. You can also change the settings for a removable device by modifying virtual machine settings.

Prerequisites
- Power on the virtual machine.
- If you are connecting or disconnecting a USB device, familiarize yourself with the way Workstation Player handles USB devices. See “Connecting USB Devices to Virtual Machines,” on page 66.

Procedure
- To connect a removable device, select the virtual machine, select Player > Removable Devices, select the device, and select Connect.
  
  If the device is connected to the host system through a USB hub, the virtual machine sees only the USB device, not the hub.
  
  A check mark appears next to the name of the device when the device is connected to the virtual machine and a device icon appears on the virtual machine taskbar.
  
- To change the settings for a removable device, select Player > Removable Devices, select the device, and select Settings.
  
- To disconnect a removable device, select the virtual machine, select Player > Removable Devices, select the device, and select Disconnect.

  You can also disconnect the device by clicking or right-clicking the device icon on the virtual machine taskbar. Using the taskbar icon is especially useful if you run the virtual machine in full screen mode.
Connecting USB Devices to Virtual Machines

When a virtual machine is running, its window is the active window. If you plug a USB device into the host system, the device connects to the virtual machine instead of the host by default. If a USB device connected to the host system does not connect to a virtual machine at power on, you must manually connect the device to the virtual machine.

When you connect a USB device to a virtual machine, Workstation Player retains the connection to the affected port on the host system. You can suspend or power off the virtual machine, or unplug the device. When you plug in the device again or resume the virtual machine, Workstation Player reconnects the device. Workstation Player retains the connection by writing an autocconnect entry to the virtual machine configuration (.vmx) file.

If Workstation Player cannot reconnect to the device, for example, because you disconnected the device, the device is removed and Workstation Player displays a message to indicate that it cannot connect to the device. You can connect to the device manually if it is still available. To manually connect a USB device to the virtual machine, select VM > Removable Devices > Device Name > Connect (Disconnect from host).

Follow the device manufacturer’s procedures for unplugging the device from the host computer when you physically unplug the device, move the device from host system to a virtual machine, move the device between virtual machines, or move the device from a virtual machine to the host computer. Following these procedures is especially important for data storage devices, such as zip drives. If you move a data storage device too soon after saving a file and the operating system did not actually write the data to the disk, you can lose data.

Installing USB Drivers on Windows Hosts

When a particular USB device is connected to a virtual machine for the first time, the host detects it as a new device named VMware USB Device and installs the appropriate VMware driver.

The Windows operating system prompts you to run the Microsoft Windows Found New Hardware wizard. Select the default action to install the software automatically. After the software is installed, the guest operating system detects the USB device and searches for a suitable driver.

Disable Automatic Connection of USB Devices

You can disable the autoconnect feature if you do not want USB devices to connect to a virtual machine when you power it on.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select USB Controller.
3. Deselect Automatically connect new USB devices to disable automatic connection of USB devices.
4. Click OK to save your changes.
Connect USB HIDs to a Virtual Machine

To connect USB human interface devices (HIDs) to a virtual machine, you must configure the virtual machine to show all USB input devices in the **Removable Devices** menu.

By default, USB HIDs, such as USB 1.1 and 2.0 mouse and keyboard devices, do not appear in the **Removable Devices** menu in a virtual machine, even though they are plugged in to USB ports on the host system.

An HID that is connected to a virtual machine is not available to the host system.

**Prerequisites**
- Power off the virtual machine.
- If you are using a KVM switch for a mouse or keyboard, disable automatic connection of USB devices. See “Disable Automatic Connection of USB Devices,” on page 66.

**Procedure**
1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select **USB Controller**.
3. Select **Show all USB input devices**.
   - This option allows users to use special USB HIDs inside the virtual machine.
4. Click **OK** to save your changes.
5. Power on the virtual machine.
   - HIDs appear in the **Removable Devices** menu.

Install a PDA Driver and Synchronize With a Virtual Machine

To install a PDA driver in a virtual machine, you must synchronize the PDA with the virtual machine.

**Procedure**
1. Connect the PDA to the host system and synchronize it with the host system.
   - The PDA driver should begin installing in the virtual machine.
2. Allow the virtual machine to install the PDA driver.
3. If connection warning messages appear, dismiss them.
4. If the PDA disconnects from the host system before the virtual machine can synchronize with it, synchronize the PDA with the host system again.
   - The total time required to load the VMware USB device driver in the host system and install the PDA driver in the virtual machine might exceed the device connection timeout value. A second synchronization attempt usually succeeds.

Troubleshooting USB Device Control Sharing

Only the host system or the virtual machine can have control of a particular USB device at any one time. Device control operates differently, depending on whether the host system is a Linux or a Windows computer.

When you connect a device to a virtual machine, it is disconnected from the host system or from the virtual machine that previously had control of the device. When you disconnect a device from a virtual machine, it is returned to the host system.
Under some circumstances, if a USB storage device is in use on the host system, for example, one or more files stored on the device are open on the host, an error appears in the virtual machine when you try to connect to the device. You must let the host system complete its operation or close any application connected to the device on the host system and connect to the device in the virtual machine again.

**Add a Host Printer to a Virtual Machine**

You can print from a virtual machine to any printer available to the host computer without having to install additional drivers in the virtual machine.

The Workstation Player printer feature uses ThinPrint technology to replicate the host system printer mapping in the virtual machine. When you enable the virtual machine printer, Workstation Player configures a virtual serial port to communicate with the host printers.

**Prerequisites**

- Support for virtual printers is disabled by default. To enable virtual printer support, see “Configuring Virtual Printers on Windows Hosts,” on page 26.
- The virtual machine must be powered on or off. You cannot add a printer to a virtual machine in suspended state.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Add.
3. In the Add Hardware wizard, select Printer and Finish.

   The default device setting is to connect the virtual machine printer when the virtual machine is powered on.

**What to do next**

In a Print window, when you attempt to select a printer in Windows 7 virtual machines, you might see only the default printer, even though other printers are available. To see the other printers, right-click the default printer and point to Printer properties.

**Using Smart Cards in Virtual Machines**

Virtual machines can connect to smart card readers that interface to serial ports, parallel ports, USB ports, PCMCIA slots, and PCI slots. A virtual machine considers a smart card reader to be a type of USB device.

A smart card is a plastic card that has an embedded computer chip. Many government agencies and large enterprises use smart cards to send secure communication, digitally sign documents, and authenticate users who access their computer networks. Users plug a smart card reader into their computer and insert their smart card in the reader. They are then prompted for their PIN to log in.

You can select a smart card reader from the Removable Devices menu in a virtual machine. A smart card can be shared between virtual machines, or between the host system and one or more virtual machines. Sharing is enabled by default.

When you plug a smart card reader into the host system, the reader appears as two separate USB devices in Workstation Player. This is because you can use smart cards in one of two mutually exclusive modes.

**Shared mode**

(Recommended) The smart card reader device is available as Shared smart_card_reader_model in the Removable Devices menu. In Windows XP guest operating systems, the shared reader appears as USB Smart Card Reader after it is connected to the virtual machine. In Windows Vista and
Windows 7 guest operating systems, the generic smart card reader device name appears under the Windows Device Manager list. The smart card reader can be shared among applications on the host system and among applications in different guest operating systems.

**USB passthrough mode**

The smart card reader device is available as `smart_card_reader_model` in the Removable Devices menu. In USB passthrough mode, a single virtual machine directly controls the physical smart card reader. A USB passthrough smart card reader cannot be used by applications on the host system or by applications in other virtual machines. You should use USB passthrough mode only if connection in shared mode does not work well for your scenario. You might need to install the driver provided by the manufacturer to use USB passthrough mode.

You can use smart cards with Windows operating systems and most Linux distributions. VMware provides full smart card support for Windows virtual machines running on Linux hosts. Using smart cards in Linux typically requires third-party software to effectively authenticate to a domain or enable secure communications.

**Note** Although smart cards should work with common Linux browsers, email applications, and directory services, these products have not been tested or certified by VMware.

### Use a Smart Card in a Virtual Machine

You can configure a virtual machine to use the smart card reader on the host system.

**Prerequisites**

- On a Windows host, start the `SCardSvr.exe` service.
- Verify that the virtual machine has a USB controller. A USB controller is required, regardless of whether the smart card reader is a USB device. A USB controller is added by default when you create a virtual machine.
- Connect the smart card reader to the host system.
- Start the virtual machine

**Procedure**

- To connect the smart card reader to the virtual machine, select the virtual machine and select **Player > Removable Devices > Shared <smart_card_reader_model> > Connect**.
  
  If the smart card reader is a USB device, two items appear for it in the menu. Both items use the model name of the reader, but one item name begins with Virtual.

- To disconnect the smart card reader from the virtual machine, select **Player > Removable Devices > Shared <smart_card_reader_model> > Disconnect**.

- To remove the smart card from the virtual machine, select **Player > Removable Devices > Shared <smart_card_reader_model> > Remove Smart Card**.

  The smart card is removed from the virtual machine, but it remains connected on the host system. If the smart card is physically removed from the smart card reader, this option is disabled.

- To insert the smart card to the virtual machine, select **Player > Removable Devices > Shared <smart_card_reader_model> > Insert Smart Card**.

  If the smart card is physically inserted in the smart card reader, the smart card is also inserted in the virtual machine.
Disable Smart Card Sharing

By default, you can share a smart card between virtual machines or between the host system and one or more virtual machines. You might want to disable smart card sharing if you are using a PCMCIA smart card reader, deploying virtual machines for enterprise use and do not want to support drivers for various smart card readers, or the host system has drivers but the virtual machines do not.

The setting that controls smart card sharing is located in the Workstation Player global configuration file.

Procedure

1. Find the global configuration file on the host system.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Location</th>
</tr>
</thead>
</table>
| Windows Server 2008 R2, Windows Server 2012 R2, Windows 8, Windows 10 hosts | Workstation 12.0: %PROGRAMDATA%\VMware\VMware Player\config.ini  
Workstation 12.1 and later:  
%PROGRAMDATA%\VMware\VMware Workstation\config.ini |

2. If the global configuration file does not yet exist on the host system, select Player > File > Preferences and change at least one Workstation Player preference setting. Workstation Player creates the global configuration file when you change Workstation Player preference settings.

3. Open the global configuration file in a text editor and set the usb.ccid.useSharedMode property to FALSE.

   For example: usb.ccid.useSharedMode = "FALSE"

4. Save and close the global configuration file.

5. Set permissions on the global configuration file so that other users cannot change it.
You can set up shared folders for a virtual machine. Shared folders provide an easy way to share files among virtual machines and between virtual machines and the host system.

The directories that you add as shared folders can be located on the host system, or they can be located on network directories that are accessible from the host system. Access to shared folders is governed by permission settings on the host system. For example, if you are running Workstation Player as a user named User, the virtual machine can read and write files in the shared folder only if User has permission to read and write the files.

To use shared folders, the guest operating system must have the current version of VMware Tools and must support shared folders.

**Important** Shared folders expose your files to programs in the virtual machine and might put your data at risk. Only enable shared folders if you trust the virtual machine with your data.

This chapter includes the following topics:

- “Using Shared Folders,” on page 71
- “Enable a Shared Folder for a Virtual Machine,” on page 73
- “View Shared Folders in a Windows Guest,” on page 74
- “Mounting Shared Folders in a Linux Guest,” on page 74
- “Change Shared Folder Properties,” on page 75
- “Change the Folders That a Virtual Machine Can Share,” on page 75
- “Disable Folder Sharing for a Virtual Machine,” on page 76
- “Mapping a Virtual Disk to the Host System,” on page 76

**Using Shared Folders**

You can use shared folders to share files among virtual machines and between virtual machines and the host system. The directories that you add as shared folders can be on the host system, or they can be network directories that are accessible from the host computer.

**Important** You cannot open a file in a shared folder from more than one application at a time. For example, do not open the same file in an application on the host operating system and in another application in the guest operating system. If one of the applications writes to the file, data might be corrupted.
Guest Operating Systems That Support Shared Folders

To use shared folders, a virtual machine must have a supported guest operating system.

The following guest operating systems support shared folders.

- Windows Server 2003 R2
- Windows Server 2008 R2
- Windows Server 2012 R2
- Windows Vista
- Windows 7
- Windows 8
- Windows 10
- Linux with a kernel version of 2.6 or later
- Solaris x86 10
- Solaris x86 10 Update 1 and later

Using Permissions to Restrict Access to Shared Files in a Linux Guest

You can use permissions to restrict access to the files in a shared folder on a Linux guest operating system.

On a Linux host, if you create files that you want to share with a Linux guest operating system, the file permissions shown on the guest operating system are the same as the permissions on the host system. You can use the fmask and dmask commands to mask permissions bits for files and directories.

If you create files on a Windows host system that you want to share with a Linux guest operating system, read-only files are displayed as having read and execute permission for everyone and other files are shown as fully writable by everyone.

If you use a Linux guest operating system to create files for which you want to restrict permissions, use the mount program with the following options in the guest operating system.

- uid
- gid
- fmask
- dmask
- ro (read only)
- rw (read-write)

rw is the default.

If you are using a virtual machine that was created with the Windows version of Workstation Player, or a previous release of the Linux version of Workstation Player, you can change the owner permissions only.
Enable a Shared Folder for a Virtual Machine

You can enable folder sharing for a specific virtual machine. To set up a folder for sharing between virtual machines, you must configure each virtual machine to use the same directory on the host system or network share.

Prerequisites

- Verify that the virtual machines use a guest operating system that supports shared folders. See “Guest Operating Systems That Support Shared Folders,” on page 72.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that permission settings on the host system allow access to files in the shared folders. For example, if you are running Workstation Player as a user named User, the virtual machine can read and write files in the shared folder only if User has permission to read and write them.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select Shared Folders.
3. Select a folder sharing option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always enabled</td>
<td>Keep folder sharing enabled, even when the virtual machine is shut down, suspended, or powered off.</td>
</tr>
<tr>
<td>Enabled until next power off or suspend</td>
<td>Enable folder sharing temporarily, until you power off, suspend, or shut down the virtual machine. If you restart the virtual machine, shared folders remain enabled. This setting is available only when the virtual machine is powered on.</td>
</tr>
</tbody>
</table>

4. (Optional) To map a drive to the Shared Folders directory, select Map as a network drive in Windows guests.

   This directory contains all of the shared folders that you enable. Workstation Player selects the drive letter.

5. Click Add to add a shared folder.

   On Windows hosts, the Add Shared Folder wizard starts.

6. Type the path on the host system to the directory to share.

   If you specify a directory on a network share, such as D:\share, Workstation Player always attempts to use that path. If the directory is later connected to the host on a different drive letter, Workstation Player cannot locate the shared folder.

7. Specify the name of the shared folder as it should appear inside the virtual machine.

   Characters that the guest operating system considers illegal in a share name appear differently when viewed inside the guest. For example, if you use an asterisk in a share name, you see %002A instead of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal value.
8 Select shared folder attributes.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable this share</td>
<td>Enable the shared folder. Deselect this option to disable a shared folder without deleting it from the virtual machine configuration.</td>
</tr>
<tr>
<td>Read-only</td>
<td>Make the shared folder read-only. When this property is selected, the virtual machine can view and copy files from the shared folder, but it cannot add, change, or remove files. Access to files in the shared folder is also governed by permission settings on the host computer.</td>
</tr>
</tbody>
</table>

9 Click **Finish** to add the shared folder.

The shared folder appears in the Folders list. The check box next to folder name indicates that the folder is being shared. You can deselect this check box to disable sharing for the folder.

10 Click **OK** to save your changes.

**What to do next**


**View Shared Folders in a Windows Guest**

In a Windows guest operating system, you can view shared folders by using desktop icons.

**Note** If the guest operating system has VMware Tools from Workstation 4.0, shared folders appear as folders on a designated drive letter.

**Procedure**

- Depending on the Windows operating system version, look for **VMware Shared Folders** in **My Network Places**, **Network Neighborhood**, or **Network**.
- If you mapped the shared folder as a network drive, open **My Computer** and look for **Shared Folders on 'vmware-host'** under **Network Drives**.
- To view a specific shared folder, go directly to the folder by using the UNC path `\vmware-host\Shared Folders\shared_folder_name`.

**Mounting Shared Folders in a Linux Guest**

After you have enabled a shared folder, you can mount one or more directories or subdirectories in the shared folder to any location in the file system in addition to the default location of `/mnt/hgfs`.

Use the `mount` command to mount all shares, one share, or a subdirectory within a share to any location in the file system.

**Table 10-1. Mount Command Syntax**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>mount -t vmhgfs .host:/ /home/user1/shares</code></td>
<td>Mounts all shares to <code>/home/user1/shares</code></td>
</tr>
<tr>
<td><code>mount -t vmhgfs .host:/foo /tmp/foo</code></td>
<td>Mounts the share named foo to <code>/tmp/foo</code></td>
</tr>
<tr>
<td><code>mount -t vmhgfs .host:/foo/bar /var/lib/bar</code></td>
<td>Mounts the subdirectory bar within the share foo to <code>/var/lib/bar</code></td>
</tr>
</tbody>
</table>

You can use VMware-specific options in addition to the standard `mount` syntax. For usage information for the host-guest file system options, type the command `/sbin/mount.vmhgfs --h`. 
When you install VMware Tools, an entry is made to `etc/fstab` to specify the location of shared folders. You can edit this file to change or add entries. For example, to auto-mount at startup, edit `/etc/fstab` and add the line:

```
.host:/mnt/hgfs vmhgfs defaults 0 0
```

The VMware Tools services script loads a driver that performs the mount. If the mount fails, a message appears regarding mounting HGFS shares.

**Note** The mount can fail if shared folders are disabled or if the share does not exist. You are not prompted to run the VMware Tools `vmware-config-tools.pl` configuration program again.

### Change Shared Folder Properties

After you create a shared folder, you can change the folder name, the host path, and other attributes.

**Prerequisites**

Create a shared folder. See “Enable a Shared Folder for a Virtual Machine,” on page 73.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Shared Folders**.
3. Select the shared folder in the folders list and click **Properties**.
4. To change the name of the shared folder as it appears inside the virtual machine, type the new name in the **Name** text box.
   
   Characters that the guest operating system considers illegal in a share name appear differently when viewed inside the guest. For example, if you use an asterisk in a share name, you see `%002A instead of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal value.

5. To change the host path for the shared folder, browse to or type the new path in the **Host path** text box.
   
   If you specify a directory on a network share, such as `D:\share`, Workstation Player always attempts to use that path. If the directory is later connected to the host on a different drive letter, Workstation Player cannot locate the shared folder.

6. To change an attribute for the shared folder, select or deselect the attribute.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Enabled</strong></td>
<td>Enable the shared folder. Deselect this option to disable a shared folder without deleting it from the virtual machine configuration.</td>
</tr>
<tr>
<td><strong>Read-only</strong></td>
<td>Make the shared folder read-only. When this property is selected, the virtual machine can view and copy files from the shared folder, but it cannot add, change, or remove files. Access to files in the shared folder is also governed by permission settings on the host computer.</td>
</tr>
</tbody>
</table>

7. Click **OK** to save your changes.

### Change the Folders That a Virtual Machine Can Share

You can change the folders that a specific virtual machine is allowed to share.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Shared Folders**.
3 In the folders list, select the check boxes next to the folders to share and deselect the check boxes next to
the folders to disable.
4 Click OK to save your changes.

**Disable Folder Sharing for a Virtual Machine**

You can disable folder sharing for a specific virtual machine.

**Procedure**

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2 On the Options tab, select Shared Folders.
3 Select Disabled to disable folder sharing.
4 Click OK to save your changes.

**Mapping a Virtual Disk to the Host System**

Instead of using shared folders or copying data between a virtual machine and the host system, you can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a virtual machine.

**Map or Mount a Virtual Disk to a Drive on the Host System**

When you map a virtual disk and its associated volume to a drive on the host system, you can connect to the virtual disk without opening a virtual machine.

After you map the virtual disk to a drive on the host system, you cannot power on any virtual machine that uses the disk until you disconnect the disk from the host system.

**Important** If you mount a virtual disk that has a snapshot and then write to the disk, you can irreparably damage a snapshot or linked clone created from the virtual machine. Note that Workstation Player does not support taking snapshots or deleting them.

Mapping a virtual disk to a host system is not supported in the standalone version of Workstation Player. Virtual disk mapping is supported in the Workstation Player version included with Workstation Pro.

**Prerequisites**

- Power off all virtual machines that use the virtual disk.
- Verify that the virtual disk (.vmdk) files on the virtual disk are not compressed and do not have read-only permissions.
- On a Windows host, verify that the volume is formatted with FAT (12/16/32) or NTFS. Only FAT (12/16/32) and NTFS formatting is supported. If the virtual disk has mixed partitions, for example, one partition is formatted with a Linux operating system and another partition is formatted with a Windows operating system, you can map the Windows partition only.
- Verify that the virtual disk is unencrypted. You cannot map or mount encrypted disks.

**Procedure**

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2 On the Hardware tab, select Hard Disk, click Utilities, and select Map.
On a Windows host, leave the check box **Open file in read-only mode** selected in the Map Virtual Disk dialog box. This setting prevents you from accidentally writing data to a virtual disk that might be the parent of a snapshot or linked clone. Writing to such a disk might make the snapshot or linked clone unusable.

Browse to a virtual disk (.vmdk) file, select it, and click **Open**.

Select the volume to map or mount and select an unused drive letter on the host system.

(Optional) On a Windows host, if you do not want the drive to open in Windows Explorer after it is mapped, deselect the **Open drive in Windows Explorer after mapping** check box.

Click **OK** or **Mount**.

The drive appears on the host system. You can read from or write to files on the mapped virtual disk on the host system.

**Disconnect a Virtual Disk from the Host System**

To use a virtual disk from a virtual machine after it has been mapped or mounted on the host system, you must disconnect it from the host system.

On Windows hosts, you must use Workstation Player to disconnect the drive from the host system. The mapped drive letter does not appear in the list of network drives when you use the Windows **Disconnect Network Drive** command.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select **Hard Disk**, click **Utilities**, and select **Disconnect**.

You can now power on any virtual machine that uses this disk.
You can change virtual machine options, configure video and sound card settings, and move virtual machines to another host system or to a different location on the same host system.

This chapter includes the following topics:

- “Change the Name of a Virtual Machine,” on page 79
- “Change the Guest Operating System for a Virtual Machine,” on page 80
- “Change the Working Directory for a Virtual Machine,” on page 80
- “Change the Memory Allocation for a Virtual Machine,” on page 81
- “Configuring Video and Sound,” on page 81
- “Moving Virtual Machines,” on page 84
- “Delete a Virtual Machine,” on page 87
- “View the Message Log for a Virtual Machine,” on page 87
- “Using the VIX API,” on page 87
- “Install New Software in a Virtual Machine,” on page 88

**Change the Name of a Virtual Machine**

When you run a virtual machine, its name appears in the title bar. Workstation Player uses the original name of the virtual machine to name the directory where the virtual machine files are stored.

Changing the name of a virtual machine does not change the name of the virtual machine directory or rename the virtual machine files on the host system.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.

2. On the Options tab, select General.

3. Type the new name.

4. Click OK to save your changes.

**What to do next**

When you restart the virtual machine the new name appears in the library.
Change the Guest Operating System for a Virtual Machine

If you upgrade the guest operating system that is installed in a virtual machine, or if you specify the wrong operating system version when you create the virtual machine, you must change the guest operating system type that is configured for the virtual machine.

When you change the operating system type, the virtual machine configuration (.vmx) file changes. The guest operating system itself does not change. To upgrade the guest operating system, obtain the appropriate software from the operating system vendor.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **General**.
3. Select the new operating system and version.
4. Click **OK** to save your changes.

Change the Working Directory for a Virtual Machine

By default, the working directory and the virtual machine directory are the same. You might want to change the working directory to improve performance. For example, to create a paging file on a fast disk that has a lot of disk space but leave the virtual disk and configuration file on a different disk, you can change the working directory so that it is located on the fast disk.

The working directory is where Workstation Player stores suspended state (.vmss), snapshot (.vmsn), virtual machine paging (.vmem), and redo log files for a virtual machine.

Changing the working directory does not change the directory where the virtual machine configuration (.vmx) file or the log files are stored.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **General**.
3. Type or browse to the location of the new working directory.
4. Click **OK** to save your changes.

Change the Virtual Machine Directory for a Virtual Machine

The virtual machine directory is where Workstation Player stores virtual machine files, including the virtual machine configuration (.vmx) file. By default, the virtual machine directory and the working directory are the same.

**Prerequisites**

Power off the virtual machine.
Procedure
1. In the host file system, rename the directory where the .vmx file is stored.
2. Select File > Open a Virtual Machine.
3. Browse to the new location of the .vmx file and click Open.

Change the Memory Allocation for a Virtual Machine

You can adjust the amount of memory that is allocated to a virtual machine.

On 64-bit hosts, the maximum amount of memory for each virtual machine is 32GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. The total amount of memory that you can assign to all virtual machines running on a single host system is limited only by the amount of RAM on the host system.

Prerequisites
Power off the virtual machine.

Procedure
1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Memory.
   The Memory panel includes information to help you select the appropriate amount of memory for the virtual machine. The high end of the range is determined by the amount of memory that is allocated to all running virtual machines.
3. Align the slider with the corresponding icon to change the amount of memory.
   The color-coded icons indicate the maximum recommended memory, the recommended memory, and the guest operating system minimum memory amounts.
4. Click OK to save your changes.
5. Power on the virtual machine to implement the changes.

Configuring Video and Sound

For best color and graphics display, coordinate host and guest operating system color settings. Workstation Player supports games and applications that use DirectX 9 and DirectX 10 accelerated graphics, but you must perform some 3D preparation tasks on the host and guest operating systems.

Workstation Player usually installs the necessary drivers for sound support, but you must manually install a driver on some of the oldest and newest guest operating systems.

- Setting Screen Color Depth on page 82
  The number of screen colors available in the guest operating system depends on the screen color setting of the host operating system.
- Using Accelerated 3D Graphics on page 82
  You must perform certain preparation tasks on the host system and on virtual machines to use accelerated 3D graphics.
- Configuring Sound on page 83
  Workstation Player provides a sound device compatible with the Sound Blaster AudioPCI and supports sound in Windows and Linux guest operating systems. The Workstation Player sound device is enabled by default.
Setting Screen Color Depth

The number of screen colors available in the guest operating system depends on the screen color setting of the host operating system.

Virtual machines support the following screen colors.

- 16-color (VGA) mode
- 8-bit pseudocolor
- 16 bits per pixel (16 significant bits per pixel)
- 32 bits per pixel (24 significant bits per pixel)

If the host operating system is in 15-bit color mode, the guest operating system color setting controls offer 15-bit mode in place of 16-bit mode. If the host operating system is in 24-bit color mode, the guest operating system color setting controls offer 24-bit mode in place of 32-bit mode.

If you run a guest operating system set for a greater number of colors than the host operating system, the colors in the guest operating system might not be correct or the guest operating system might not be able to use a graphical interface. If these problems occur, you can either increase the number of colors in the host operating system or decrease the number of colors in the guest operating system.

To change color settings on the host operating system, power off all virtual machines and close Workstation Player and then follow standard procedures for changing color settings.

How you change color settings in a guest operating system depends on the type of guest operating system. In a Windows guest, the Display Properties control panel offers only those settings that are supported. In a Linux or FreeBSD guest, you must change the color depth before you start the X server, or you must restart the X server after making the changes.

For best performance, use the same number of colors in the host and guest operating systems.

Using Accelerated 3D Graphics

You must perform certain preparation tasks on the host system and on virtual machines to use accelerated 3D graphics.

Support for applications that use DirectX 9 accelerated graphics applies only to Windows XP, Windows Vista, and Windows 7 guests on hosts running Windows 7 or later, or Linux. OpenGL applications run in software emulation mode.

Support for applications that use DirectX 10 accelerated graphics applies only to Windows 10.

Prepare the Host System to Use 3D Accelerated Graphics

You must perform certain preparation tasks on the Windows or Linux host system to use 3D accelerated graphics in a virtual machine.

Prerequisites

- Verify that the host has a video card that supports DirectX 9 or DirectX 10 and the latest DirectX Runtime required for the DirectX version being used.

  The VMware guest operating system OpenGL driver for Windows and Linux supports the OpenGL 3.3 core profile only. The OpenGL3.3 compatibility profile is not supported.
Procedure
1 Upgrade the video drivers on the host system to the latest versions.
   ATI Graphics drivers are available from the AMD Web site. NVIDIA drivers are available from the NVIDIA Web site.
2 Move the Hardware Acceleration slider to the Full position.

Option | Description
--- | ---
Windows 7, Windows 8, and Windows 10 | Right-click the desktop and select Personalize > Screen resolution > Advanced Settings > Troubleshoot > Change settings.

Prepare a Virtual Machine to Use Accelerated 3D Graphics
You must perform certain preliminary tasks to use accelerated 3D graphics on a virtual machine.

The accelerated 3D graphics feature is enabled by default on Player 3.x and later virtual machines.

Prerequisites
- Prepare the host system to use accelerated 3D graphics. See “Prepare the Host System to Use 3D Accelerated Graphics,” on page 82.
- If using DirectX 9, verify that the guest operating system is Windows XP or later. DirectX 9 is supported on virtual machines running hardware version 11 or earlier.
- If using DirectX 10, verify that the guest operating system is Windows 7 or later. DirectX 10 is supported on virtual machines running hardware version 12 or later.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Power off the virtual machine. The virtual machine must not be suspended.

Procedure
1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2 On the Hardware tab, select Display.
3 Select Accelerate 3D graphics.
4 Configure the virtual machine to use only one monitor.
5 Click OK to save your changes.
6 Power on the virtual machine and install the required DirectX EndRuntime version.
   This download is available from the Microsoft Download Center.
7 Install and run your 3D applications.

Configuring Sound
Workstation Player provides a sound device compatible with the Sound Blaster AudioPCI and supports sound in Windows and Linux guest operating systems. The Workstation Player sound device is enabled by default.

Sound support includes pulse code modulation (PCM) output and input. For example, you can play .wav files, MP3 audio, and Real Media audio. MIDI output from Windows guests is supported through the Windows software synthesizer. MIDI input is not supported, and no MIDI support is available for Linux guests.

Windows and most recent Linux distributions detect the sound device and install appropriate drivers for it.

**Configure Sound Card Settings**

The VMware virtual sound device is compatible with a Creative Technology Sound Blaster Audio API. The sound device supports sound in Windows and Linux guest operating systems.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Sound Card.
3. Configure one or more sound card settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connects or disconnects the sound device while the virtual machine is running. You can also use the Devices menu and select the drive to connect or disconnect.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Automatically connects the sound device to the virtual machine when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use default host sound card</td>
<td>The virtual machine uses the default sound card in the host system.</td>
</tr>
<tr>
<td>Specify host sound card</td>
<td>Selects which sound card to use if you have more than one physical sound card on the host system.</td>
</tr>
<tr>
<td>Enable echo cancellation</td>
<td>Enables echo cancellation for the sound card.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.

**Moving Virtual Machines**

You can move a virtual machine that was created in Workstation Player to a different host system or to a different location on the same host system and connect to a virtual machine by using a VNC client.

- **Move a Virtual Machine to a New Location or New Host** on page 84
  You can move a virtual machine that is created in Workstation Player to a different host system or to a different location on the same host system. You can move a virtual machine to a host system that has a different operating system.

- **Configure a Virtual Machine for Compatibility** on page 86
  When you create a virtual machine that you intend to distribute to other users, you should configure the virtual machine for maximum compatibility with all expected host systems. Users might be limited in their ability to make changes in a virtual machine so that it is compatible with their host systems.

- **Using the Virtual Machine UUID** on page 86
  Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you initially power on the virtual machine.

**Move a Virtual Machine to a New Location or New Host**

You can move a virtual machine that is created in Workstation Player to a different host system or to a different location on the same host system. You can move a virtual machine to a host system that has a different operating system.

Moving a virtual machine typically involves moving the files that make up the virtual machine. The pathnames for all files associated with a Workstation Player virtual machine are relative to the virtual machine directory.
When you move a virtual machine, Workstation Player generates a new MAC address for the virtual network adapter. Workstation Player also generates a new MAC address when you rename a directory in the path to the virtual machine configuration (.vmx) file.

Prerequisites

- Familiarize yourself with how Workstation Player generates UUIDs for moved virtual machines. See “Using the Virtual Machine UUID,” on page 86.
- If you are moving the virtual machine to a different host system, familiarize yourself with the limitations of moving a virtual machine to a new host. See “Limitations of Moving a Virtual Machine to a Different Host,” on page 85.
- If you configured the working directory to reside in a different location on the host system, move files from the working directory into the virtual machine directory and change the working directory to this location.
- Verify that virtual machine devices and any associated files point to locations that you can access from the new location.
- Verify that all virtual machine files are stored in the virtual machine directory. Some files might reside outside of the virtual machine directory.

Procedure

1. Shut down the guest operating system and power off the virtual machine.
2. Copy the virtual machine files to the new location.
3. Verify that you copied all of the virtual machine files to the new location.
4. Open the virtual machine in Workstation Player

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you moved the virtual machine to a different location on the same host system</td>
<td>Remove the virtual machine from the library, select File &gt; Open a Virtual Machine, and browse to the .vmx file in its new location.</td>
</tr>
<tr>
<td>If you moved the virtual machine to a different host system</td>
<td>Start Workstation Player on the new host system, select File &gt; Open a Virtual Machine, and browse to the .vmx file.</td>
</tr>
</tbody>
</table>

5. When you are certain that the virtual machine in the new location works correctly, delete the virtual machine files from the original location.

Limitations of Moving a Virtual Machine to a Different Host

You should be aware of certain limitations before you move a virtual machine to a different host system.

- The guest operating system might not work correctly if you move a virtual machine to a host system that has significantly different hardware, for example, if you move a virtual machine from a 64-bit host to a 32-bit host or from a multiprocessor host to a uniprocessor host.
- Player 3.x and later virtual machines support up to eight-way virtual symmetric multiprocessing (SMP) on multiprocessor host systems. Player 6.x and later virtual machines support up to sixteen-way multiprocessing on multiprocessor host systems. You can assign up to 8 or 16 virtual processors to virtual machines running on host systems that have at least two logical processors. If you attempt to assign two processors to a virtual machine that is running on a uniprocessor host system, a warning message appears. You can disregard this message and assign two processors to the virtual machine, but you must move it to a host that has at least two logical processors before you can power it on.
- You can move a virtual machine from a 32-bit host to a 64-bit host. You cannot move a virtual machine from a 64-bit host to a 32-bit host unless the 32-bit host has a supported 64-bit processor.
Configure a Virtual Machine for Compatibility

When you create a virtual machine that you intend to distribute to other users, you should configure the virtual machine for maximum compatibility with all expected host systems. Users might be limited in their ability to make changes in a virtual machine so that it is compatible with their host systems.

Procedure

- Install VMware Tools in the virtual machine.
  VMware Tools significantly improves the user’s experience working with the virtual machine.
- Determine which virtual devices are actually required, and do not include any that are not needed or useful for the software you are distributing with the virtual machine.
  Generic SCSI devices are typically not appropriate.
- To connect a physical device to a virtual device, use the Auto detect options when you configure the virtual machine.
  The Auto detect options allow the virtual machine to adapt to the user’s system, and they work whether the host operating system is Windows or Linux. Users who have no physical device receive a warning message.
- To connect a CD-ROM or floppy to an image file that you ship with the virtual machine, make sure the image file is in the same directory as the virtual machine.
  A relative path, rather than an absolute path, is used.
- For both a physical CD-ROM and an image, provide two virtual CD-ROM devices in the virtual machine.
- Choose a reasonable amount of memory to allocate to the virtual machine.
  For example, if the host system does not have enough physical memory to support the memory allocation, the user cannot power on the virtual machine.
- Choose a reasonable screen resolution for the guest.
  A user is likely to find it easier to increase the resolution manually than to deal with a display that exceeds the user’s physical screen size.

Using the Virtual Machine UUID

Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you initially power on the virtual machine.

You can use the UUID of a virtual machine for system management in the same way that you use the UUID of a physical computer. The UUID is stored in the SMBIOS system information descriptor, and you can access it by using standard SMBIOS scanning software, including SiSoftware Sandra or IBM smbios2.

If you do not move or copy the virtual machine to another location, the UUID remains constant. When you power on a virtual machine that was moved or copied to a new location, you are prompted to specify whether you moved or copied the virtual machine. If you indicate that you copied the virtual machine, the virtual machine receives a new UUID.

Suspending and resuming a virtual machine does not trigger the process that generates a UUID. The UUID in use at the time the virtual machine was suspended remains in use when the virtual machine is resumed, even if it was copied or moved. You are not prompted to specify whether you moved or copied the virtual machine until the next time you reboot the virtual machine.
Configure a Virtual Machine to Keep the Same UUID

You can configure a virtual machine to always keep the same UUID, even when it is moved or copied. When a virtual machine is set to always keep the same UUID, you are not prompted when a virtual machine is moved or copied.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Open the virtual machine configuration (.vmx) file in a text editor.
2. Add the `uuid.action` property and set it to `keep`.
   
   For example: `uuid.action = "keep"

Delete a Virtual Machine

You can delete a virtual machine and all of its files from the host file system.

**IMPORTANT** Deleting a virtual machine is irreversible.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Right-click the virtual machine in the library and select **Delete VM from Disk**.
2. Click **Yes** to delete the virtual machine.

The virtual machine and all of its files are removed from the host file system.

View the Message Log for a Virtual Machine

You can view the message log to review information about a particular virtual machine. Messages include warning information about the virtual machine.

**Procedure**

1. Power on the virtual machine.
2. Select **Player > Manage > Message Log**.
3. Select a message in the message log to see a detailed description of the message.

Using the VIX API

Application developers can use the VMware VIX API to write programs to automate virtual machine operations.

The API is high level, easy to use, and practical for script writers and application programmers. With API functions, you can register, power virtual machines on and off, and run programs in guest operating systems. Additional language bindings are available for Perl, COM, and shell scripts such as `vmrun`.

See the VMware VIX API Release Notes.
Install New Software in a Virtual Machine

Installing new software in a virtual machine is similar to installing new software on a physical computer. Only a few additional steps are required.

Prerequisites

- Verify that VMware Tools is installed in the guest operating system. Installing VMware Tools before installing the software minimizes the likelihood that you will have to reactivate the software if the virtual machine configuration changes.
- Verify that the virtual machine has access to the CD-ROM drive, ISO image file, or floppy drive where the installation software is located.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Memory, set the final memory size for the virtual machine, and click OK.
   
   Some applications use a product activation feature that creates a key based on the virtual hardware in the virtual machine where it is installed. Changes in the configuration of the virtual machine might require you to reactivate the software. Setting the memory size minimizes the number of significant changes.
3. Install the new software according to the manufacturer’s instructions.

Disable Acceleration if a Program Does Not Run

When you install or run software inside a virtual machine, Workstation Player might appear to stop responding. This problem typically occurs early in the program’s execution. In many cases, you can get past the problem by temporarily disabling acceleration in the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Processors.
3. Select Disable acceleration for binary translation to disable acceleration.
4. Click OK to save your changes.

What to do next

After you pass the point where the program encountered problems, re-enable acceleration. Because disabling acceleration slows down virtual machine performance, you should use it only for getting past the problem with running the program.
You can use Workstation Player to add devices to virtual machines, including DVD and CD-ROM drives, floppy drives, USB controllers, virtual and physical hard disks, parallel and serial ports, generic SCSI devices, and processors. You can also modify settings for existing devices.

This chapter includes the following topics:

- “Configuring DVD, CD-ROM, and Floppy Drives,” on page 89
- “Configuring a USB Controller,” on page 91
- “Configuring and Maintaining Virtual Hard Disks,” on page 93
- “Configuring Virtual Ports,” on page 98
- “Configuring Generic SCSI Devices,” on page 101
- “Configuring Sixteen-Way Virtual Symmetric Multiprocessing,” on page 103
- “Configuring Keyboard Features,” on page 104
- “Modify Hardware Settings for a Virtual Machine,” on page 112

**Configuring DVD, CD-ROM, and Floppy Drives**

You can add up to 4 IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (4 controllers with 30 devices per controller) to a virtual machine. Any of these devices can be a virtual or physical hard disk or DVD or CD-ROM drive. By default, a floppy drive is not connected when a virtual machine powers on.

A virtual machine can read data from a DVD disc. Workstation Player does not support playing DVD movies in a virtual machine. You might be able to play a movie if you use a DVD player application that does not require video overlay support in the video card.

**Add a DVD or CD-ROM Drive to a Virtual Machine**

You can add one or more DVD or CD-ROM drives to a virtual machine. You can connect the virtual DVD or CD-ROM drive to a physical drive or an ISO image file.

You can configure the virtual DVD or CD-ROM drive as an IDE or a SCSI device, regardless of the type of physical drive that you connect it to. For example, if the host has an IDE CD-ROM drive, you can set up the virtual machine drive as either SCSI or IDE and connect it to the host drive.

Do not configure legacy emulation mode unless you experience problems with normal mode. See “Configure Legacy Emulation Mode for a DVD or CD-ROM Drive,” on page 91 for more information.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings.**
2 On the **Hardware** tab, click **Add**.

3 In the Add Hardware wizard, select **DVD/CD Drive**.

4 Select a physical drive or ISO image file to connect to the drive.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use physical drive</td>
<td>The virtual machine uses a physical drive.</td>
</tr>
<tr>
<td>Use ISO image</td>
<td>The drive connects to an ISO image file.</td>
</tr>
</tbody>
</table>

5 Configure the physical drive or ISO image file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical drive</td>
<td>Select a specific drive, or select <strong>Auto detect</strong> to allow Workstation Player to auto-detect the drive to use.</td>
</tr>
<tr>
<td>ISO image file</td>
<td>Type the path or browse to the location of the ISO image file.</td>
</tr>
</tbody>
</table>

6 To connect the drive or ISO image file to the virtual machine when the virtual machine powers on, select **Connect at power on**.

7 Click **Finish** to add the drive to the virtual machine.

8 (Optional) To change which SCSI or IDE device identifier to use for the drive, select the drive and click **Advanced**.

9 Click **OK** to save your changes.

### Add a Floppy Drive to a Virtual Machine

You can configure a virtual floppy drive to connect to a physical floppy drive or an existing or blank floppy image file. You can add up to two floppy drives to a virtual machine.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1 Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.

2 On the **Hardware** tab, click **Add**.

3 In the Add Hardware wizard, select **Floppy Drive**.

4 Select the floppy media type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical floppy drive</td>
<td>The virtual machine uses a physical floppy drive.</td>
</tr>
<tr>
<td>Use a floppy image</td>
<td>The drive connects to an floppy image (.flp) file.</td>
</tr>
<tr>
<td>Create a blank floppy image</td>
<td>The drive connects to a blank floppy image (.flp) file that you create.</td>
</tr>
</tbody>
</table>

5 If you selected the physical floppy drive media type, select a specific floppy drive or select **Auto detect** to allow Workstation Player to auto-detect the drive to use.

6 If you selected the floppy image or blank floppy image media type, type the name or browse to the location of a floppy image (.flp) file.

7 To connect the drive or floppy image file to the virtual machine when the virtual machine powers on, select **Connect at power on**.
8. Click **Finish** to add the drive to the virtual machine.
9. Click **OK** to save your changes.

**Configure Legacy Emulation Mode for a DVD or CD-ROM Drive**

Use legacy emulation mode to work around direct communication problems between a guest operating system and a DVD or CD-ROM drive.

In legacy emulation mode, you can read only from data discs in the DVD or CD-ROM drive. Legacy emulation mode does not provide the other capabilities of normal mode. In normal mode, the guest operating system communicates directly with the CD-ROM or DVD drive. This direct communication enables you to read multisession CDs, perform digital audio extraction, view videos, and use CD and DVD writers to burn discs.

If you run more than one virtual machine at a time, and if their CD-ROM drives are in legacy emulation mode, you must start the virtual machines with their CD-ROM drives disconnected. By disconnecting the CD-ROM drives in the virtual machines, you prevent multiple virtual machines from being connected to the CD-ROM drive at the same time.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select the drive and click **Advanced**.
3. Select **Legacy emulation** and click **OK**.
   
   On Windows hosts, this option is deselected by default.
4. Click **OK** to save your changes.

**Configuring a USB Controller**

A virtual machine must have a USB controller to use USB devices and smart card readers. To use a smart card reader, a virtual machine must have a USB controller regardless of whether the smart card reader is actually a USB device.

Workstation Player provides a USB controller to support the following types of USB devices.

- USB 1.1 UHCI (Universal Host Controller Interface) is supported for all virtual machine hardware versions.
- USB 2.0 EHCI (Enhanced Host Controller Interface) controllers are supported if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.
- USB 3.0 xHCI (Extensible Host Controller Interface) support is available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 or later virtual machines.

For USB 2.0 or 3.0 support, you must select USB 2.0 or 3.0 compatibility by configuring virtual machine settings for the USB controller. USB 2.0 and 3.0 devices are high-speed devices that include the latest models of USB flash drives, USB hard drives, iPods, and iPhone.

If you select USB 2.0 compatibility, when a USB 2.0 device connects to a USB port on the host system, the device connects to the EHCI controller and operates in USB 2.0 mode. A USB 1.1 device connects to the UHCI controller and operates in USB 1.1 mode. If you enable USB 3.0, the xHCI controller can support all USB devices, including USB 1.1, 2.0, and 3.0 devices.

Although the host operating system must support USB, you do not need to install device-specific drivers for USB devices in the host operating system to use those devices only in the virtual machine. Linux kernels earlier than 2.2.17 do not support USB.
VMware has tested a variety of USB devices. If the guest operating system has the appropriate drivers, you can use many different USB devices, including PDAs, Smart phones, printers, storage devices, scanners, MP3 players, digital cameras, memory card readers, and isochronous transfer devices, such as webcams, speakers, and microphones.

You can connect USB human interface devices (HIDs), such as the keyboard and mouse, to a virtual machine by enabling the **Show all USB input devices** option. If you do not select this option, these devices do not appear in the **Removable Devices** menu and are not available to connect to the virtual machine, even though they are plugged in to USB ports on the host system.

See “Connect USB HIDs to a Virtual Machine,” on page 67 for information on connecting HIDs.

### Add a USB Controller to a Virtual Machine

A USB controller is required to use a smart card in a virtual machine, regardless of whether the smart card reader is a USB device. You can add one USB controller to a virtual machine.

When you create a virtual machine in Workstation Player, a USB controller is added by default. If you remove the USB controller, you can add it back.

**Preprerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the New Hardware wizard, select USB Controller.
4. Configure the USB connection settings.
   You can select multiple settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB Compatibility</td>
<td>Selecting USB 2.0 or 3.0 enables support for isochronous USB devices, including Web cams, speakers, and microphones.</td>
</tr>
<tr>
<td>Automatically connect new USB devices</td>
<td>Connect new USB devices to the virtual machine. If this setting is not selected, new USB devices are connected only to the host system.</td>
</tr>
<tr>
<td>Show all USB input devices</td>
<td>Human interface devices (HIDs), such as USB 1.1 and 2.0 mouse and keyboard devices, appear in the Removable Devices menu. Icons for HIDs appear in the status bar. An HID that is connected to the guest operating system is not available to the host system. The virtual machine must be powered off when you change this setting.</td>
</tr>
<tr>
<td>Share Bluetooth devices with the virtual machine</td>
<td>Enable support for Bluetooth devices.</td>
</tr>
</tbody>
</table>

5. Click Finish to add the USB controller.

### Enable Support for Isochronous USB Devices

Modems and certain streaming data devices, such as speakers and webcams, do not work properly in a virtual machine unless you enable support for isochronous USB devices.

**Preprerequisites**

- Verify that the guest operating system supports USB 2.0 devices or 3.0 devices.
- On a Windows XP guest operating system, verify that the latest service pack is installed. If you use Windows XP with no service packs, the driver for the EHCI controller cannot be loaded.
Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select USB Controller.
3. From the USB Compatibility list, select USB 2.0 or USB 3.0.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB 2.0</td>
<td>Available if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.</td>
</tr>
<tr>
<td>USB 3.0</td>
<td>Available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 and later virtual machines.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.

Configuring and Maintaining Virtual Hard Disks

You can use Workstation Player to configure virtual hard disk storage for virtual machines.

A virtual disk is a file or set of files that appears as a physical disk drive to a guest operating system. The files can be on the host system or on a remote computer. When you configure a virtual machine to use a virtual disk, you can install a new operating system onto the virtual disk without repartitioning a physical disk or rebooting the host.

The New Virtual Machine wizard creates a virtual machine that has one disk drive. You can modify virtual machine settings to add more disk drives to a virtual machine, remove disk drives from a virtual machine, and change certain settings for the existing disk drives.

- **Configuring a Virtual Hard Disk** on page 94
  You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can also set up a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or BusLogic SCSI adapter. You determine which SCSI adapter to use when you create a virtual machine.

- **Compact a Virtual Hard Disk** on page 96
  Compacting a virtual hard disk reclaims unused space in the virtual disk. If a disk has empty space, this process reduces the amount of space the virtual disk occupies on the host drive.

- **Expand a Virtual Hard Disk** on page 96
  You can add storage space to a virtual machine by expanding its virtual hard disk.

- **Defragment a Virtual Hard Disk** on page 97
  Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual hard disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.

- **Remove a Virtual Hard Disk from a Virtual Machine** on page 97
  Removing a virtual hard disk disconnects it from a virtual machine. It does not delete files from the host file system.

- **Using Lock Files to Prevent Consistency Problems on Virtual Hard Disks** on page 98
  A running virtual machine creates lock files to prevent consistency problems on virtual hard disks. Without locks, multiple virtual machines might read and write to the disk, causing data corruption.
Moving a Virtual Hard Disk to a New Location on page 98

A key advantage of virtual hard disks is their portability. Because the virtual hard disks are stored as files on the host system or a remote computer, you can move them easily to a new location on the same computer or to a different computer.

Configuring a Virtual Hard Disk

You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can also set up a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or BusLogic SCSI adapter. You determine which SCSI adapter to use when you create a virtual machine.

The files that make up an IDE, SATA, or SCSI virtual hard disk can be stored on an IDE hard disk, SATA hard disk, or on a SCSI hard disk. They can also be stored on other types of fast-access storage media.

To use SCSI hard disks in a 32-bit Windows XP virtual machine, you must download a special SCSI driver from the VMware Web site. Follow the instructions on the Web site to use the driver with a fresh installation of Windows XP.

Growing and Allocating Virtual Disk Storage Space

IDE and SCSI virtual hard disks can be up to 8TB. Depending on the size of the virtual hard disk and the host operating system, Workstation Player creates one or more files to hold each virtual disk.

Virtual hard disk files include information such as the operating system, program files, and data files. Virtual disk files have a .vmdk extension.

By default, the actual files that the virtual hard disk uses start small and grow to their maximum size as needed. The main advantage of this approach is the smaller file size. Smaller files require less storage space and are easier to move to a new location, but it takes longer to write data to a disk configured in this way.

You can also configure virtual hard disks so that all of the disk space is allocated when the virtual disk is created. This approach provides enhanced performance and is useful if you are running performance-sensitive applications in the virtual machine.

Regardless of whether you allocate all disk space in advance, you can configure the virtual hard disk to use a set of files limited to 2GB per file. Use this option if you plan to move the virtual hard disk to a file system that does not support files larger than 2GB.

Add a New Virtual Hard Disk to a Virtual Machine

To increase storage space, you can add a new virtual hard disk to a virtual machine. You can add up to four IDE devices and up to 60 SCSI devices. Any of these devices can be a virtual or physical hard disk or DVD or CD-ROM drive.

Virtual hard disks are stored as files on the host computer or on a network file server. A virtual IDE drive or SCSI drive can be stored on a physical IDE drive or on a physical SCSI drive.

As an alternative to adding a new virtual hard disk, you can expand the existing virtual hard disk. See “Expand a Virtual Hard Disk,” on page 96.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the New Hardware wizard, select Hard Disk.
4. Select Create a new virtual disk.
5 Select the disk type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDE</td>
<td>Create an IDE device. You can add up to four IDE devices to a virtual machine.</td>
</tr>
<tr>
<td>SCSI</td>
<td>Create a SCSI device. You can add up to 60 SCSI devices to a virtual machine.</td>
</tr>
<tr>
<td>SATA</td>
<td>Create a SATA device. You can add up to 120 SATA devices: four controllers and 30 devices per controller.</td>
</tr>
</tbody>
</table>

6 Set the capacity for the new virtual hard disk.

You can set a size between 0.001 GB and 8 TB for a virtual disk.

7 Specify how to allocate the disk space.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocate all disk space now</td>
<td>Allocating all of the disk space when you create the virtual hard disk can enhance performance, but it requires all of the physical disk space to be available now. If you do not select this setting, the virtual disk starts small and grows as you add data to it.</td>
</tr>
<tr>
<td>Store virtual disk as a single file</td>
<td>Select this option if the virtual disk is stored on a file system that does not have a file size limitation.</td>
</tr>
<tr>
<td>Split virtual disk into multiple files</td>
<td>Select this option if the virtual disk is stored on a file system that has a file size limitation. When you split a virtual disk less than 950 GB, a series of 2 GB virtual disk files are created. When you split a virtual disk greater than 950 GB, two virtual disk files are created. The maximum size of the first virtual disk file is 1.9 TB and the second virtual disk file stores the rest of the data.</td>
</tr>
</tbody>
</table>

8 Accept the default filename and location, or browse to and select a different location.

9 Click Finish to add the new virtual hard disk.

The wizard creates the new virtual hard disk. The disk appears to the guest operating system as a new, blank hard disk.

10 Click OK to save your changes.

11 Use the guest operating system tools (such as the Windows Management tool or the fdisk command in Linux) to partition and format the new drive.

### Add an Existing Virtual Hard Disk to a Virtual Machine

You can reconnect an existing virtual hard disk that was removed from a virtual machine.

**Procedure**

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.

2 On the Hardware tab, click Add.

3 In the Add Hardware wizard, select Hard Disk.

4 Select Use an existing virtual disk.

5 Specify the path name and filename for the existing disk file.

6 Click Finish to add the existing virtual hard disk.

7 Click OK to save your changes.
Compact a Virtual Hard Disk

Compacting a virtual hard disk reclaims unused space in the virtual disk. If a disk has empty space, this process reduces the amount of space the virtual disk occupies on the host drive.

Prerequisites

- Power off the virtual machine.
- Verify that the virtual disk is not mapped or mounted. You cannot compact a virtual disk while it is mapped or mounted.
- Verify that the disk space is not preallocated for the virtual hard disk. If the disk space was preallocated, you cannot compact the disk.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select the virtual hard disk to compact.
3. Select Utilities > Compact.
4. Click OK after the disk compacting process is complete.

Expand a Virtual Hard Disk

You can add storage space to a virtual machine by expanding its virtual hard disk.

When you expand a virtual hard disk, the added space is not immediately available to the virtual machine. To make the added space available, you must use a disk management tool to increase the size of the existing partition on the virtual hard disk to match the expanded size.

The disk management tool that you use depends on the virtual machine guest operating system. Many operating systems, including Windows Vista, Windows 7, and Windows 8 and some versions of Linux, provide built-in disk management tools that can resize partitions. Third-party disk management tools are also available, such as EASEUS Partition Master, Acronis Disk Director, and the open-source tool GParted.

When you expand the size of a virtual hard disk, the sizes of partitions and file systems are not affected.

As an alternative to expanding a virtual hard disk, you can add a new virtual hard disk to the virtual machine. See “Add a New Virtual Hard Disk to a Virtual Machine,” on page 94.

Prerequisites

- Power off the virtual machine.
- Verify that the virtual disk is not mapped or mounted. You cannot expand a virtual disk while it is mapped or mounted.
- Verify that the virtual machine has no snapshots.

Note Workstation Player does not support taking snapshots or deleting them.

- Verify that the virtual machine is not a linked clone or the parent of a linked clone.

You can determine whether a virtual machine is a linked clone by the virtual machine name string on the summary page. If the string includes "Clone of: virtual machine name", the virtual machine is a linked clone. If the string includes "Snapshot: Snapshot for virtual machine name", the virtual machine is a parent of a linked clone.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
On the Hardware tab, select the virtual hard disk to expand.

Select Utilities > Expand.

Set the new maximum size for the virtual disk.

You can set a size between 0.001 GB and 8192 GB for a virtual disk.

Select Expand.

Click OK after the disk expansion process is complete.

What to do next
Use a disk management tool to increase the disk partition size to match the expanded virtual disk size.

Defragment a Virtual Hard Disk

Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual hard disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.

Defragmenting disks can take considerable time.

Prerequisites
- Verify that there is adequate free working space on the host system. For example, if the virtual hard disk is contained in a single file, there must be free space equal to the size of the virtual disk file. Other virtual hard disk configurations require less free space.
- Verify that the virtual disk is not mapped or mounted. You cannot defragment a virtual disk while it is mapped or mounted.

Procedure
1. Run a disk defragmentation utility in the guest operating system.
2. If disk space is not preallocated for the virtual hard disk, use the Workstation Player defragmentation tool to defragment it.
   a. Power off the virtual machine.
   b. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
   c. On the Hardware tab, select Hard Disk.
   d. Select Utilities > Defragment.
   e. When the defragmentation process is finished, click OK.
3. Run a disk defragmentation utility on the host system.

Remove a Virtual Hard Disk from a Virtual Machine

Removing a virtual hard disk disconnects it from a virtual machine. It does not delete files from the host file system.

After you remove a virtual hard disk from a virtual machine, you can map or mount the disk to the host system and copy data from the guest operating system to the host without powering on the virtual machine or starting Workstation Player. You can also add the disk to another virtual machine.

Procedure
1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select the virtual hard disk and click Remove.
Using VMware Workstation Player for Windows

3 Click **OK** to save your changes.

**Using Lock Files to Prevent Consistency Problems on Virtual Hard Disks**

A running virtual machine creates lock files to prevent consistency problems on virtual hard disks. Without locks, multiple virtual machines might read and write to the disk, causing data corruption.

Lock files have a `.lck` suffix and are created in subdirectories in the same directory as the virtual disk (.vmdk) files. A locking subdirectory and lock file are created for .vmdk files, .vmx files, and .vmem files.

A unified locking method is used on all host operating systems so that files shared between them are fully protected. For example, if one user on a Linux host tries to power on a virtual machine that is already powered on by another user with a Windows host, the lock files prevent the second user from powering on the virtual machine.

When a virtual machine powers off, it removes the locking subdirectories and the lock files. If the virtual machine cannot remove these locking controls, one or more stale lock files might remain. For example, if the host system fails before the virtual machine removes its locking controls, stale lock files remain.

When the virtual machine restarts, it scans any locking subdirectories for stale lock files and, when possible, removes them. A lock file is considered stale if the lock file was created on the same host system that is now running the virtual machine and the process that created the lock is no longer running. If either of these conditions is not true, a dialog box warns you that the virtual machine cannot be powered on. You can delete the locking directories and their lock files manually.

Locks also protect physical disk partitions. Because the host operating system is not aware of this locking convention, it does not recognize the lock. For this reason, you should install the physical disk for a virtual machine on the same physical disk as the host operating system.

**Moving a Virtual Hard Disk to a New Location**

A key advantage of virtual hard disks is their portability. Because the virtual hard disks are stored as files on the host system or a remote computer, you can move them easily to a new location on the same computer or to a different computer.

For example, you can use Workstation Player on a Windows host system to create virtual hard disks, move the disks to a Linux computer, and use the disks with Workstation Player on a Linux host system.

**Configuring Virtual Ports**

You can add virtual parallel (LPT) ports and virtual serial (COM) ports to a virtual machine. A Workstation Player virtual machine can use up to three parallel ports and up to four virtual serial ports.

- **Add a Virtual Parallel Port to a Virtual Machine** on page 99
  You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host system.

- **Troubleshoot ECR Errors for Parallel Ports** on page 99
  A parallel port on the host system does not have an Extended Control Register (ECR).

- **Add a Virtual Serial Port to a Virtual Machine** on page 100
  You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to physical serial ports, files, or named pipes.

- **Change the Input Speed of a Serial Connection** on page 101
  You can increase the speed of a serial connection over a pipe to a virtual machine.
Add a Virtual Parallel Port to a Virtual Machine

You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host system.

Parallel ports are used for a variety of devices, including printers, scanners, dongles, and disk drives. Although these devices can connect to the host system, only printers can reliably connect to virtual machines by using parallel ports.

Workstation Player provides only partial emulation of PS/2 hardware. Interrupts that a device connected to a physical port requests are not passed to the virtual machine. The guest operating system cannot use direct memory access (DMA) to move data to or from the port. For this reason, not all devices that attach to a parallel port work correctly. Do not use virtual parallel ports to connect parallel port storage devices or other types of parallel port devices to a virtual machine.

Prerequisites

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the New Hardware wizard, select Parallel Port.
4. Select where the virtual parallel port sends output.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical parallel port</td>
<td>Select a parallel port on the host system.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output from the virtual parallel port to a file on the host system. Either locate an existing output file or browse to a directory and type a filename to create a new output file.</td>
</tr>
</tbody>
</table>

5. To connect the virtual parallel port to the virtual machine when the virtual machine powers on, select Connect at power on.
6. Click Finish to add the virtual parallel port to the virtual machine.

When a parallel port is configured for a virtual machine, most guest operating systems detect the port at installation time and install the required drivers. Some operating systems, including Linux, detect the ports at boot time.

Troubleshoot ECR Errors for Parallel Ports

A parallel port on the host system does not have an Extended Control Register (ECR).

Problem

When you power on a virtual machine after adding a parallel port, an error messages states that the parallel port on the host system does not have an ECR.

Cause

This problem can occur when the hardware supports ECR, but ECR has been disabled in the BIOS.

Solution

1. Reboot the host system.
2. Early in the boot process, press and hold down the Delete key to enter the BIOS configuration editor.
Find the parallel port field and enable Extended Capability Port (ECP) mode or a combination of modes that includes ECP. Most modern computers support ECP mode.

**Add a Virtual Serial Port to a Virtual Machine**

You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to physical serial ports, files, or named pipes. You might want to add a virtual serial port to a virtual machine to make devices such as modems and printers available to the virtual machine. You can also use virtual ports to send debugging data from a virtual machine to the host system or to another virtual machine.

**Note** The virtual printer feature configures a serial port to make host printers available to the guest. You do not need to install additional drivers in the virtual machine.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the Hardware tab, click **Add**.
3. In the Add Hardware wizard, select **Serial Port**.
4. Select where the virtual serial port sends output.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical parallel port</td>
<td>Send output to a physical serial port on the host system.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output to a file on the host system. Either locate an existing output file or browse to a directory and type a filename to create a new output file.</td>
</tr>
<tr>
<td>Output to named pipe</td>
<td>Set up a direct connection between two virtual machines, or a connection between a virtual machine and an application on the host system.</td>
</tr>
</tbody>
</table>

5. If you selected **Output to named pipe**, configure the named pipe.
   a. Use the default pipe name, or type another pipe name.
      The pipe name must begin with `\\\pipe\` and must be the same on both the server and the client.
      For example: `\\\pipe\namedpipe`
   b. To send debugging information to an application on the host system, select **This end is the server** from the first drop-down menu and select **The other end is an application** from the second drop-down menu.
   c. To send debugging information to another virtual machine, select **This end is the server** from the first drop-down menu and **The other end is a virtual machine** from the second drop-down menu.
6. To connect the port to the virtual machine when the virtual machine powers on, select **Connect at power on**.
7. Click **Finish** to add the virtual serial port to the virtual machine.
8 (Optional) On the Hardware tab, select the new serial port, select Yield CPU on poll, and click OK.

This option is useful if you are using debugging tools that communicate over a serial connection. If the serial port in the guest operating system is being used in polled mode rather than interrupt mode, you might notice performance issues. This option forces the virtual machine to yield processor time if the only task it is trying to do is poll the virtual serial port.

What to do next

If you set up a connection between two virtual machines, the first virtual machine is set up as the server. Repeat this procedure for the second virtual machine, but set it up as the client by selecting This end is the client when you configure the named pipe.

Change the Input Speed of a Serial Connection

You can increase the speed of a serial connection over a pipe to a virtual machine.

In principle, the output speed, which is the speed at which the virtual machine sends data through the virtual serial port, is unlimited. In practice, the output speed depends on how fast the application at the other end of the pipe reads inbound data.

Prerequisites

- Use the guest operating system to configure the serial port for the highest setting supported by the application that you are running in the virtual machine.
- Power off the virtual machine and exit Workstation Player.

Procedure

1. In a text editor, add the following line to the virtual machine configuration (.vmx) file.
   
   ```
   serial_port_number.pipe.charTimePercent = "time"
   ```

   `port_number` is the number of the serial port, starting from 0. The first serial port is serial0. `time` is a positive integer that specifies the time taken to transmit a character, expressed as a percentage of the default speed set for the serial port in the guest operating system. For example, a setting of 200 forces the port to take twice as long for each character, or send data at half the default speed. A setting of 50 forces the port to take only half as long for each character, or send data at twice the default speed.

2. Assuming that the serial port speed is set appropriately in the guest operating system, experiment with this setting by starting with a value of 100 and gradually decreasing it until you find the highest speed at which the connection works reliably.

Configuring Generic SCSI Devices

The generic SCSI feature gives the guest operating system direct access to SCSI devices that are connected to the host system, including scanners, tape drives, and other data storage devices. A virtual machine can use the generic SCSI driver to run any SCSI device that is supported by the guest operating system.

To use SCSI devices in a virtual machine running on a Windows host system, you must run Workstation Player as a user who has administrator access.

Although generic SCSI is device independent, it can be sensitive to the guest operating system, device class, and specific SCSI hardware.

- Add a Generic SCSI Device to a Virtual Machine on page 102
  
  You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI devices to a virtual machine.
Troubleshoot Problems Detecting Generic SCSI Devices on page 102

When you add a generic SCSI device to a virtual machine, the device does not appear in the list of available SCSI devices.

Add a Generic SCSI Device to a Virtual Machine

You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI devices to a virtual machine.

Prerequisites

- On a Windows host system, run Workstation Player as a user who has administrator access.
- On a 32-bit Windows XP virtual machine, install the special SCSI driver that VMware provides. You can download the driver from the VMware Web site.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select Generic SCSI Device.
4. Select the physical SCSI device to map to the virtual SCSI device.
5. To connect the device when the virtual machine powers on, select Connect at power on.
6. Click Finish to add the device.
7. On the Hardware tab, select the SCSI device identifier to use for the device from the Virtual device node drop-down menu and click OK.

For example, if you select SCSI 0:2, the guest operating system sees the drive as ID 2 on controller 0.

Troubleshoot Problems Detecting Generic SCSI Devices

When you add a generic SCSI device to a virtual machine, the device does not appear in the list of available SCSI devices.

Problem

The SCSI device does not appear in the list of available SCSI devices after you add it to a virtual machine.

Cause

A driver for that device is not installed on the host system, a driver on the host system prevents the device from being detected, or the virtual machine uses a device for which there are no drivers available to the host operating system.

Solution

1. Determine the SCSI bus number that the device uses on the host system.

   The SCSI bus is assigned a number by the host operating system after all IDE buses are assigned numbers. For example, if you have two IDE buses, they are numbered 0 and 1. The first SCSI bus is assigned bus number 2. You can use a third-party tool, such as winobj, to determine the SCSI bus number.

2. Determine the target ID that the device uses in the virtual machine and on the host system.

   This ID is usually set by some jumpers or switches on the device.
3. Determine whether the device driver for the device is installed on the host system. If the device driver is not installed, install it and see if the device appears. To avoid a device-in-use conflict between the host and guest, you might not want to install the driver on the host system.

4. If an original SCSI device driver is already installed on the host system, disable it. Some Windows operating systems do not process the send command from the adapter if the device driver owns the device.

5. Power off the virtual machine and open the virtual machine configuration (.vmx) file in a text editor.

6. Add or change the following line in the virtual machine configuration (.vmx) file.

   ```
   scsiZ:Y.fileName = "deviceName"
   ```

   Z is the SCSI bus number the device uses in the virtual machine. For deviceName, use scsiX:Y, where X is the SCSI bus number that the device uses on the host system and Y is the target ID that the device uses in both the virtual machine and on the host system.

   For example, if the problematic device is a CD-ROM drive, the existing entry is `scsi0:4.fileName = "CdRom0"` and the device on the host system is located on bus 2 with target ID 4, change the line to `scsi0:4.fileName = "scsi2:4"`.

7. If the virtual machine does not contain any SCSI devices, to add a generic SCSI device to a new virtual SCSI adapter, or to use an existing SCSI device as a generic SCSI device, add the following line to the virtual machine configuration (.vmx) file.

   ```
   scsiZ:Y.deviceType = "scsi-passthru"
   ```

8. If the virtual machine does not contain any SCSI devices, or to add a generic SCSI device to a new virtual SCSI adapter, add the following lines to the virtual machine configuration (.vmx) file.

   ```
   scsiZ:Y.present = "true"
   scsiZ.present = "true"
   ```

### Configuring Sixteen-Way Virtual Symmetric Multiprocessing

With virtual symmetric multiprocessing (SMP), you can assign processors and cores per processor to a virtual machine on any host system that has at least two logical processors.

Workstation Player considers multiprocessor hosts that have two or more physical CPUs, single-processor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading enabled, to have two logical processors.

**Note** On hyperthreaded uniprocessor hosts, performance of virtual machines that have virtual SMP might be below normal. Even on multiprocessor hosts, performance is affected if you overcommit by running multiple workloads that require more total CPU resources than are physically available.

You can power on and run multiple dual-processor virtual machines concurrently. The number of processors for a given virtual machine appears in the summary view of the virtual machine.

### Configure Sixteen-Way Virtual Symmetric Multiprocessing

You can configure sixteen-way virtual symmetric multiprocessing (SMP) for an existing virtual machine.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Processors.
3. Change the Number of processors setting to 16.
4 Click **OK** to save your changes.

**Use a Virtual Machine That Has More Than Sixteen Virtual Processors**

If Workstation Player is running on a multiprocessor host system, you can open a virtual machine that has more than 16 virtual processors assigned to it. You must change the number of processors before powering on the virtual machine.

You can see the number of processors in the virtual machine summary view or by viewing the virtual machine hardware settings.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select **Processors**.
   
   Note that **Number of processors** is set to **Other (x)**, where x is the number of processors originally assigned to it. Workstation Player preserves this original configuration setting for the number of processors, even though eight is the maximum number of processors supported.
3. Change the **Number of processors** setting to 1, 2, 4, 8, or 16.
   
   After you commit a change to this setting, the original setting for the number of processors is discarded and no longer appears as an option.
4. Click **OK** to save your changes.

**Configuring Keyboard Features**

You can change key combinations for hot-key sequences in Workstation Player and the language for the keyboard that VNC clients use. You can also configure platform-specific keyboard features for Windows and Linux host systems.

- **Use the Enhanced Virtual Keyboard Feature in a Virtual Machine** on page 105
  
  The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

- **Use Ctrl+Alt in a Key Combination** on page 106
  
  Because Ctrl+Alt tells Workstation Player to release mouse and keyboard input, hot-key combinations that include Ctrl+Alt are not passed to the guest operating system. You must use the Space key if the key combination includes Ctrl+Alt.

- **Configure Keyboard Mapping for a Remote X Server** on page 106
  
  Although the keyboard works correctly with a local X server, it might not work correctly when you run the same virtual machine with a remote X server.

- **Change How a Specific Key Is Mapped** on page 107
  
  If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that makes a modification to the map. To change how a specific key is mapped, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

- **Configure How Keysyms Are Mapped** on page 108
  
  When key code mapping cannot be used or is disabled, Workstation Player maps keysyms to v-scan codes. If a language-specific keyboard does not appear to be supported by Workstation Player, you might need to set a property that tells Workstation Player which keysym table to use.
You specify v-scan codes when you change how keys or keysyms are mapped.

**Use the Enhanced Virtual Keyboard Feature in a Virtual Machine**

The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

Because it processes raw keyboard input as soon as possible, the enhanced virtual keyboard feature also offers security improvements by bypassing Windows keystroke processing and any malware that is not already at a lower layer. When you use the enhanced virtual keyboard feature, only the guest operating system acts when you press Ctrl+Alt+Delete.

**Prerequisites**

- If you recently installed or upgraded Workstation Player, but did not restart the host system, restart the host system.
- Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **General**.
3. Select an option from the **Enhanced virtual keyboard** drop-down menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off</td>
<td>The virtual machine does not use the enhanced virtual keyboard feature.</td>
</tr>
<tr>
<td></td>
<td>This is the default value.</td>
</tr>
<tr>
<td><strong>Use if available</strong> (recommended)</td>
<td>The virtual machine uses the enhanced virtual keyboard feature, but only if the enhanced keyboard driver is installed on the host system.</td>
</tr>
<tr>
<td><strong>Required</strong></td>
<td>The virtual machine must use the enhanced virtual keyboard feature. If you select this option and the enhanced keyboard driver is not installed on the host system, Workstation Player returns an error message.</td>
</tr>
</tbody>
</table>

4. Click **OK** to save your changes.

**Install the Enhanced Keyboard Driver on a Windows Host**

To use the enhanced virtual keyboard feature in a virtual machine, you must install the enhanced keyboard driver on the Windows host system. If you did not install the enhanced keyboard driver when you initially installed or upgraded Workstation Player, you can install it by running the Workstation Player installer in program maintenance mode.

**Prerequisites**

Verify that you have administrative privileges on the host system.

**Procedure**

1. Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   
   If you log in to a domain, the domain account must also be a local administrator.
2. Double-click the `VMware-player-xxxx-xxxxxxx.exe` file, where `xxxx-xxxxxxx` is the version and build numbers.
3. Select **Modify/Change**.
4 Select **Enhanced Keyboard Utility**.

5 Follow the prompts to finish the installation.

**What to do next**

Enable the enhanced virtual keyboard feature for the virtual machine. See “Use the Enhanced Virtual Keyboard Feature in a Virtual Machine,” on page 105.

---

**Use Ctrl+Alt in a Key Combination**

Because Ctrl+Alt tells Workstation Player to release mouse and keyboard input, hot-key combinations that include Ctrl+Alt are not passed to the guest operating system. You must use the Space key if the key combination includes Ctrl+Alt.

**Procedure**

1. Press Ctrl+Alt+spacebar.
2. Release the spacebar without releasing Ctrl and Alt.
3. Press the third key of the key combination to send to the guest operating system.

---

**Configure Keyboard Mapping for a Remote X Server**

Although the keyboard works correctly with a local X server, it might not work correctly when you run the same virtual machine with a remote X server.

For local X servers, Workstation Player maps X key codes to PC scan codes to correctly identify a key. Because it cannot tell whether a remote X server is running on a PC or on some other kind of computer, Workstation Player uses this key code map only for local X servers. You can set a property to tell Workstation Player to use key code mapping. See “Understanding X-Key Codes and Keysyms,” on page 107 for more information.

To configure a keyboard mapping for a remote X server, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

**Prerequisites**

- Verify that the remote X server is an XFree86 server running on a PC.
- Power off the virtual machine and exit Workstation Player.

**Note** If the keyboard does not work correctly on an XFree86 server running locally, report the problem to VMware technical support.

**Procedure**

- If you use an XFree86-based server that Workstation Player does not recognize as an XFree86 server, add the xkeymap.usekeycodeMap property and set it to TRUE.
  
  This property tells Workstation Player to always use key code mapping regardless of server type.
  
  For example: **xkeymap.usekeycodeMap = "TRUE"**

- If Workstation Player does not recognize the remote server as an XFree86 server, add the xkeymap.usekeycodeMapIfXFree86 property and set it to TRUE.
  
  This property tells Workstation Player to use key code mapping if you are using an XFree86 server, even if it is remote.
  
  For example: **usekeycodeMapIfXFree86 = "TRUE"**
Understanding X-Key Codes and Keysyms

Pressing a key on a PC keyboard generates a PC scan code based roughly on the position of the key. For example, the Z key on a German keyboard generates the same code as the Y key on an English keyboard because they are in the same position on the keyboard. Most keys have one-byte scan codes, but some keys have two-byte scan codes with prefix 0xe0.

Internally, Workstation Player uses a simplified version of the PC scan code that is a single nine-bit numeric value, called a v-scan code. A v-scan code is written as a three-digit hexadecimal number. The first digit is 0 or 1. For example, the Ctrl key on the left side of the keyboard has a one-byte scan code (0x1d) and its v-scan code is 0x01d. The Ctrl key scan code on the right side of the keyboard is two bytes (0xe0, 0x1d) and its v-scan code is 0x11d.

An XFree86 server on a PC has a one-to-one mapping from X key codes to PC scan codes, or v-scan codes, which is what Workstation Player uses. When Workstation Player is hosted on an XFree86 server and runs a local virtual machine, it uses the built-in mapping from X key codes to v-scan codes. This mapping is keyboard independent and should be correct for most languages. In other cases (not an XFree86 server or not a local server), Workstation Player must map keysyms to v-scan codes by using a set of keyboard-specific tables.

An X server uses a two-level encoding of keys, which includes the X key code and the keysym. An X key code is a one-byte value. The assignment of key codes to keys depends on the X server implementation and the physical keyboard. As a result, an X application normally cannot use key codes directly. Instead, the key codes are mapped into keysyms that have names like space, escape, x and 2. You can use an X application to control the mapping by using the function XChangeKeyboardMapping() or by the program xmodmap. To explore keyboard mappings, you can use the xev command, which shows the key codes and keysyms for keys typed into its window.

A key code corresponds roughly to a physical key, while a keysym corresponds to the symbol on the key top. For example, with an XFree86 server running on a PC, the Z key on the German keyboard has the same key code as the Y key on an English keyboard. The German Z keysym, however, is the same as the English Z keysym, and different from the English Y keysym.

Change How a Specific Key Is Mapped

If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that makes a modification to the map. To change how a specific key is mapped, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

Prerequisites

- Verify that the X server is an XFree86 server running on a PC. If the X server is remote, configure it to use key code mapping. See “Configure Keyboard Mapping for a Remote X Server,” on page 106.
- Determine the X key code and the corresponding v-scan code for the key. To find the X key code for a key, run xev or xmodmap -pk. See “V-Scan Code Table,” on page 109 for most v-scan codes.
- Power off the virtual machine and exit Workstation Player.

Procedure

1. Open .vmx or ~/.vmware/config in a text editor.
2 Add the `xkeymap.keycode` property and set it to the v-scan code.

   `code` must be a decimal number and the v-scan code must be a C-syntax hexadecimal number, such as `0x001`.

In this example, the properties swap left Ctrl and Caps Lock.

   `xkeymap.keycode.64 = "0x01d # X Caps_Lock -> VM left ctrl"
   xkeymap.keycode.37 = "0x03a # X Control_L -> VM caps lock"

**Configure How Keysyms Are Mapped**

When key code mapping cannot be used or is disabled, Workstation Player maps keysyms to v-scan codes. If a language-specific keyboard does not appear to be supported by Workstation Player, you might need to set a property that tells Workstation Player which keysym table to use.

Workstation Player determines which table to use by examining the current X keymap. However, its decision-making process can sometimes fail. In addition, each mapping is fixed and might not be completely correct for any given keyboard and X key code-to-keysym mapping. For example, if a user uses `xmodmap` to swap Ctrl and Caps Lock by, the keys are swapped in the virtual machine when using a remote server (keysym mapping), but are unswapped when using a local server (key code mapping). To correct this situation, you must remap the keys in Workstation Player.

To configure how keysyms are mapped, you add one or more properties to the virtual machine configuration (.vmx) file or to `~/.vmware/config`.

**Prerequisites**

- To change the mapping of a few keys, determine the keysym name for each key. To find a keysym name, use the `xev` or `xmodmap -pk` command. The X header file `/usr/include/X11/keysymdef.h` also has a complete list of keysyms. The name of a keysym is the same as its C constant, but without the XK_ prefix.

- To use a different keysym table, determine which mapping table to use. The tables are located in the `xkeymap` directory in the Workstation Player installation directory, which is usually `/usr/lib/vmware`. The table you must use depends on the keyboard layout. The normal distribution includes tables for PC keyboards for the United States and a number of European countries and languages. For most of these, both the 101-key (or 102-key) and the 104-key (or 105-key) variants are available.

  If none of the mapping tables is completely correct, find one that works best, copy it to a new location, and change the individual keysym mappings.

- Familiarize yourself with the v-scan codes. See “V-Scan Code Table,” on page 109.

- Power off the virtual machine and exit Workstation Player.

**Procedure**

- To disable X key code mapping to map keysyms rather than key codes to v-scan codes, add the `xkeymap.nokeycodeMap` property and set it to TRUE.

  For example: `xkeymap.nokeycodeMap = "TRUE"

- If Workstation Player has a table in the `xkeymap` directory for your keyboard but cannot detect it, add the `xkeymap.language` property and set it to one of the tables in the `xkeymap` directory.

  For example: `xkeymap.language = "keyboard_type"

  If the failure to detect the keyboard means that the table is not completely correct for you, you might need to create a modified table and use the `xkeymap.fileName` property instead.
To use a different keysym mapping table that is not in the xkeymap directory, add the xkeymap.fileName property and set it to the path to the table.

For example: `xkeymap.fileName = "file_path"`

The table must list a keysym for each key by using the form `sym="v-scan_code"`, where the `sym` value is an X keysym name and `v-scan_code` is a C-syntax hexadecimal number, for example, 0x001. Use a new line for each keysym.

**NOTE** Because compiling a complete keysym mapping is difficult, you should usually edit an existing table and make small changes.

To change the keysym mapping of a few keys, type the xkeymap.keysym property for each key, on separate lines.

For example: `xkeymap.keysym.sym = "v-scan_code"`

The value of `sym` must be an X keysym name and `v-scan_code` is a C-syntax hexadecimal number, for example, 0x001.

### V-Scan Code Table

You specify v-scan codes when you change how keys or keysyms are mapped.

Following are the v-scan codes for the 104-key U.S. keyboard.

**Table 12.1.** V-Scan Codes for the 104-Key U.S. Keyboard

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Esc</td>
<td></td>
<td></td>
<td>0x001</td>
</tr>
<tr>
<td>1</td>
<td>!</td>
<td></td>
<td>0x002</td>
</tr>
<tr>
<td>2</td>
<td>@</td>
<td></td>
<td>0x003</td>
</tr>
<tr>
<td>3</td>
<td>#</td>
<td></td>
<td>0x004</td>
</tr>
<tr>
<td>4</td>
<td>$</td>
<td></td>
<td>0x005</td>
</tr>
<tr>
<td>5</td>
<td>%</td>
<td></td>
<td>0x006</td>
</tr>
<tr>
<td>6</td>
<td>^</td>
<td></td>
<td>0x007</td>
</tr>
<tr>
<td>7</td>
<td>&amp;</td>
<td></td>
<td>0x008</td>
</tr>
<tr>
<td>8</td>
<td>*</td>
<td></td>
<td>0x009</td>
</tr>
<tr>
<td>9</td>
<td>(</td>
<td></td>
<td>0x00a</td>
</tr>
<tr>
<td>0</td>
<td>)</td>
<td></td>
<td>0x00b</td>
</tr>
<tr>
<td>-</td>
<td>_</td>
<td></td>
<td>0x00c</td>
</tr>
<tr>
<td>=</td>
<td>+</td>
<td></td>
<td>0x00d</td>
</tr>
<tr>
<td>Backspace</td>
<td></td>
<td></td>
<td>0x00e</td>
</tr>
<tr>
<td>Tab</td>
<td></td>
<td></td>
<td>0x00f</td>
</tr>
<tr>
<td>Q</td>
<td></td>
<td></td>
<td>0x010</td>
</tr>
<tr>
<td>W</td>
<td></td>
<td></td>
<td>0x011</td>
</tr>
<tr>
<td>E</td>
<td></td>
<td></td>
<td>0x012</td>
</tr>
<tr>
<td>R</td>
<td></td>
<td></td>
<td>0x013</td>
</tr>
<tr>
<td>T</td>
<td></td>
<td></td>
<td>0x014</td>
</tr>
<tr>
<td>Y</td>
<td></td>
<td></td>
<td>0x015</td>
</tr>
<tr>
<td>U</td>
<td></td>
<td></td>
<td>0x016</td>
</tr>
</tbody>
</table>
### Table 12-1. V-Scan Codes for the 104-Key U.S. Keyboard (Continued)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td></td>
<td></td>
<td>0x017</td>
</tr>
<tr>
<td>O</td>
<td></td>
<td></td>
<td>0x018</td>
</tr>
<tr>
<td>P</td>
<td></td>
<td></td>
<td>0x019</td>
</tr>
<tr>
<td>[</td>
<td></td>
<td></td>
<td>0x01a</td>
</tr>
<tr>
<td>]</td>
<td></td>
<td></td>
<td>0x01b</td>
</tr>
<tr>
<td>Enter</td>
<td></td>
<td></td>
<td>0x01c</td>
</tr>
<tr>
<td>Ctrl</td>
<td>left</td>
<td></td>
<td>0x01d</td>
</tr>
<tr>
<td>A</td>
<td></td>
<td></td>
<td>0x01e</td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
<td>0x01f</td>
</tr>
<tr>
<td>D</td>
<td></td>
<td></td>
<td>0x020</td>
</tr>
<tr>
<td>F</td>
<td></td>
<td></td>
<td>0x021</td>
</tr>
<tr>
<td>G</td>
<td></td>
<td></td>
<td>0x022</td>
</tr>
<tr>
<td>H</td>
<td></td>
<td></td>
<td>0x023</td>
</tr>
<tr>
<td>J</td>
<td></td>
<td></td>
<td>0x024</td>
</tr>
<tr>
<td>K</td>
<td></td>
<td></td>
<td>0x025</td>
</tr>
<tr>
<td>L</td>
<td></td>
<td></td>
<td>0x026</td>
</tr>
<tr>
<td>;</td>
<td></td>
<td></td>
<td>0x027</td>
</tr>
<tr>
<td>'</td>
<td></td>
<td></td>
<td>0x028</td>
</tr>
<tr>
<td>\</td>
<td>left</td>
<td></td>
<td>0x029</td>
</tr>
<tr>
<td>Shift</td>
<td>left</td>
<td></td>
<td>0x02a</td>
</tr>
<tr>
<td>\</td>
<td></td>
<td></td>
<td>0x02b</td>
</tr>
<tr>
<td>Z</td>
<td></td>
<td></td>
<td>0x02c</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>0x02d</td>
</tr>
<tr>
<td>C</td>
<td></td>
<td></td>
<td>0x02e</td>
</tr>
<tr>
<td>V</td>
<td></td>
<td></td>
<td>0x02f</td>
</tr>
<tr>
<td>B</td>
<td></td>
<td></td>
<td>0x030</td>
</tr>
<tr>
<td>N</td>
<td></td>
<td></td>
<td>0x031</td>
</tr>
<tr>
<td>M</td>
<td></td>
<td></td>
<td>0x032</td>
</tr>
<tr>
<td>.</td>
<td></td>
<td></td>
<td>0x033</td>
</tr>
<tr>
<td>.</td>
<td></td>
<td></td>
<td>0x034</td>
</tr>
<tr>
<td>/</td>
<td></td>
<td></td>
<td>0x035</td>
</tr>
<tr>
<td>Shift</td>
<td>right</td>
<td></td>
<td>0x036</td>
</tr>
<tr>
<td>*</td>
<td>numeric pad</td>
<td></td>
<td>0x037</td>
</tr>
<tr>
<td>Alt</td>
<td>left</td>
<td></td>
<td>0x038</td>
</tr>
<tr>
<td>Space bar</td>
<td></td>
<td></td>
<td>0x039</td>
</tr>
<tr>
<td>Caps Lock</td>
<td></td>
<td></td>
<td>0x03a</td>
</tr>
<tr>
<td>F1</td>
<td></td>
<td></td>
<td>0x03b</td>
</tr>
<tr>
<td>F2</td>
<td></td>
<td></td>
<td>0x03c</td>
</tr>
<tr>
<td>F3</td>
<td></td>
<td></td>
<td>0x03d</td>
</tr>
<tr>
<td>Symbol</td>
<td>Shifted Symbol</td>
<td>Location</td>
<td>V-Scan Code</td>
</tr>
<tr>
<td>----------</td>
<td>----------------</td>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>F4</td>
<td></td>
<td></td>
<td>0x03e</td>
</tr>
<tr>
<td>F5</td>
<td></td>
<td></td>
<td>0x03f</td>
</tr>
<tr>
<td>F6</td>
<td></td>
<td></td>
<td>0x040</td>
</tr>
<tr>
<td>F7</td>
<td></td>
<td></td>
<td>0x041</td>
</tr>
<tr>
<td>F8</td>
<td></td>
<td></td>
<td>0x042</td>
</tr>
<tr>
<td>F9</td>
<td></td>
<td></td>
<td>0x043</td>
</tr>
<tr>
<td>F10</td>
<td></td>
<td></td>
<td>0x044</td>
</tr>
<tr>
<td>Num Lock</td>
<td>numeric pad</td>
<td></td>
<td>0x045</td>
</tr>
<tr>
<td>Scroll Lock</td>
<td></td>
<td></td>
<td>0x046</td>
</tr>
<tr>
<td>Home</td>
<td>7</td>
<td>numeric pad</td>
<td>0x047</td>
</tr>
<tr>
<td>Up arrow</td>
<td>8</td>
<td>numeric pad</td>
<td>0x048</td>
</tr>
<tr>
<td>PgUp</td>
<td>9</td>
<td>numeric pad</td>
<td>0x049</td>
</tr>
<tr>
<td>-</td>
<td></td>
<td>numeric pad</td>
<td>0x04a</td>
</tr>
<tr>
<td>Left arrow</td>
<td>4</td>
<td>numeric pad</td>
<td>0x04b</td>
</tr>
<tr>
<td>5</td>
<td>numeric pad</td>
<td></td>
<td>0x04c</td>
</tr>
<tr>
<td>Right arrow</td>
<td>6</td>
<td>numeric pad</td>
<td>0x04d</td>
</tr>
<tr>
<td>+</td>
<td></td>
<td>numeric pad</td>
<td>0x04e</td>
</tr>
<tr>
<td>End</td>
<td>1</td>
<td>numeric pad</td>
<td>0x04f</td>
</tr>
<tr>
<td>Down arrow</td>
<td>2</td>
<td>numeric pad</td>
<td>0x050</td>
</tr>
<tr>
<td>PgDn</td>
<td>3</td>
<td>numeric pad</td>
<td>0x051</td>
</tr>
<tr>
<td>Ins</td>
<td>0</td>
<td>numeric pad</td>
<td>0x052</td>
</tr>
<tr>
<td>Del</td>
<td>numeric pad</td>
<td></td>
<td>0x053</td>
</tr>
<tr>
<td>F11</td>
<td></td>
<td></td>
<td>0x057</td>
</tr>
<tr>
<td>F12</td>
<td></td>
<td></td>
<td>0x058</td>
</tr>
<tr>
<td>Break</td>
<td>Pause</td>
<td></td>
<td>0x100</td>
</tr>
<tr>
<td>Enter</td>
<td></td>
<td>numeric pad</td>
<td>0x111c</td>
</tr>
<tr>
<td>Ctrl</td>
<td>right</td>
<td></td>
<td>0x11d</td>
</tr>
<tr>
<td>/</td>
<td></td>
<td>numeric pad</td>
<td>0x135</td>
</tr>
<tr>
<td>SysRq</td>
<td>Print Scrn</td>
<td></td>
<td>0x137</td>
</tr>
<tr>
<td>Alt</td>
<td></td>
<td>right</td>
<td>0x138</td>
</tr>
<tr>
<td>Home</td>
<td></td>
<td>function pad</td>
<td>0x147</td>
</tr>
<tr>
<td>Up arrow</td>
<td></td>
<td>function pad</td>
<td>0x148</td>
</tr>
<tr>
<td>Page Up</td>
<td></td>
<td>function pad</td>
<td>0x149</td>
</tr>
<tr>
<td>Left arrow</td>
<td></td>
<td>function pad</td>
<td>0x14b</td>
</tr>
<tr>
<td>Right arrow</td>
<td></td>
<td>function pad</td>
<td>0x14d</td>
</tr>
<tr>
<td>End</td>
<td></td>
<td>function pad</td>
<td>0x14f</td>
</tr>
<tr>
<td>Down arrow</td>
<td></td>
<td>function pad</td>
<td>0x150</td>
</tr>
<tr>
<td>Page Down</td>
<td></td>
<td>function pad</td>
<td>0x151</td>
</tr>
<tr>
<td>Insert</td>
<td></td>
<td>function pad</td>
<td>0x152</td>
</tr>
</tbody>
</table>
Table 12-1. V-Scan Codes for the 104-Key U.S. Keyboard (Continued)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>function pad</td>
<td></td>
<td>0x153</td>
</tr>
<tr>
<td>Windows</td>
<td>left</td>
<td></td>
<td>0x15b</td>
</tr>
<tr>
<td>Windows</td>
<td>right</td>
<td></td>
<td>0x15c</td>
</tr>
<tr>
<td>Menu</td>
<td></td>
<td></td>
<td>0x15d</td>
</tr>
</tbody>
</table>

The 84-key keyboard has a Sys Req key on the numeric pad. Its v-scan code is 0x054.

Keyboards outside the U.S. usually have an extra key (often < > or < > |) next to the left Shift key. The v-scan code for this key is 0x056.

Modify Hardware Settings for a Virtual Machine

You can modify memory, processor, virtual and physical hard disk, CD-ROM and DVD drive, floppy drive, virtual network adapter, USB controller, sound card, serial port, generic SCSI device, printer, and display settings for a virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. Click the Hardware tab.
3. Select the hardware setting to modify.
4. Click Help for information about how to modify the hardware setting.

You must power off a virtual machine before you change certain hardware settings.
Configuring Network Connections

Workstation Player provides bridged networking, network address translation (NAT), and host-only networking to configure a virtual machine for virtual networking. The software that you need for all networking configurations is installed on the host system when you install Workstation Player.

This chapter includes the following topics:

- “Understanding Virtual Networking Components,” on page 113
- “Understanding Common Networking Configurations,” on page 114
- “Configuring Bridged Networking,” on page 115
- “Configuring Network Address Translation,” on page 116
- “Configuring Host-Only Networking,” on page 116
- “Changing a Networking Configuration,” on page 118

Understanding Virtual Networking Components

The virtual networking components in Workstation Player include virtual switches, virtual network adapters, the virtual DHCP server, and the NAT device.

Virtual Switches

Like a physical switch, a virtual switch connects networking components together. Virtual switches, which are also referred to as virtual networks, are named VMnet0, VMnet1, VMnet2, and so on. A few virtual switches are mapped to specific networks by default.

<table>
<thead>
<tr>
<th>Network Type</th>
<th>Switch Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bridged</td>
<td>VMnet0</td>
</tr>
<tr>
<td>NAT</td>
<td>VMnet8</td>
</tr>
<tr>
<td>Host-only</td>
<td>VMnet1</td>
</tr>
</tbody>
</table>

Workstation Player creates virtual switches as needed, up to 20 virtual switches on a Windows host system and up to 255 virtual switches on a Linux host system. You can connect an unlimited number of virtual network devices to a virtual switch on a Windows host system and up to 32 virtual network devices to a virtual switch on a Linux host system.

**Note** On Linux host systems, the virtual switch names are in all lowercase letters, for example, vmnet0.
Virtual Network Adapters

When you use the New Virtual Machine wizard to create a new virtual machine, the wizard creates a virtual network adapter for the virtual machine. The virtual network adapter appears in the guest operating system as an AMD PCNET PCI adapter or Intel Pro/1000 MT Server Adapter. In Windows Vista, Windows 7, and Windows 8 guest operating systems, it is an Intel Pro/1000 MT Server Adapter.

Player 3.x and later virtual machines can have up to 10 virtual network adapters.

Virtual DHCP Server

The virtual Dynamic Host Configuration Protocol (DHCP) server provides IP addresses to virtual machines in configurations that are not bridged to an external network. For example, the virtual DHCP server assigns IP addresses to virtual machines in host-only and NAT configurations.

NAT Device

In a NAT configuration, the NAT device passes network data between one or more virtual machines and the external network, identifies incoming data packets intended for each virtual machine, and sends them to the correct destination.

Understanding Common Networking Configurations

You can configure bridged networking, NAT, and host-only networking for virtual machines. You can also use the virtual networking components to create sophisticated custom virtual networks.

Creating custom networks is available only on virtual machines that are created in Workstation Player. Although you cannot configure custom networking in Workstation Player, you can run a virtual machine that has custom networking in Workstation Player.

Bridged Networking

Bridged networking connects a virtual machine to a network by using the network adapter on the host system. If the host system is on a network, bridged networking is often the easiest way to give the virtual machine access to that network.

When you install Workstation Player on a Windows or Linux host system, a bridged network (VMnet0) is set up for you. See “Configuring Bridged Networking,” on page 115.

NAT Networking

With NAT, a virtual machine does not have its own IP address on the external network. Instead, a separate private network is set up on the host system. In the default configuration, a virtual machine gets an address on this private network from the virtual DHCP server. The virtual machine and the host system share a single network identity that is not visible on the external network.

When you install Workstation Player on a Windows or Linux host system, a NAT network (VMnet8) is set up for you. When you use the New Virtual Machine wizard to create a new virtual machine and select the typical configuration type, the wizard configures the virtual machine to use the default NAT network.

You can have only one NAT network. See “Configuring Network Address Translation,” on page 116.

Host-Only Networking

Host-only networking creates a network that is completely contained within the host computer. Host-only networking provides a network connection between the virtual machine and the host system by using a virtual network adapter that is visible on the host operating system.
When you install Workstation Player on a Windows or Linux host system, a host-only network (VMnet1) is set up for you. See “Configuring Host-Only Networking,” on page 116.

**Configuring Bridged Networking**

When you install Workstation Player on a Windows or Linux host system, a bridged network (VMnet0) is set up for you. Bridged networking connects a virtual machine to a network by using the network adapter on the host system. If the host system is on a network, bridged networking is often the easiest way to give the virtual machine access to that network.

With bridged networking, the virtual network adapter in the virtual machine connects to a physical network adapter in the host system. The host network adapter enables the virtual machine to connect to the LAN that the host system uses. Bridged networking works with both wired and wireless host network adapters.

Bridged networking configures the virtual machine as a unique identity on the network, separate from and unrelated to the host system. The virtual machine is a full participant in the network. It has access to other machines on the network, and other machines on the network can contact it as if it were a physical computer on the network.

**Figure 13-1. Bridged Networking Configuration**

You can view and change the settings for bridged networking on the host system, determine which network adapters to use for bridged networking, and map specific host network adapters to specific virtual switches.

**Assigning IP Addresses in a Bridged Networking Environment**

A virtual machine must have its own identity on a bridged network. For example, on a TCP/IP network, the virtual machine needs its own IP address. Your network administrator can tell you whether IP addresses are available for virtual machines and which networking settings to use in the guest operating system.

Typically, the guest operating system can acquire an IP address and other network details from a DHCP server, but you might need to set the IP address and other details manually in the guest operating system.

Users who boot multiple operating systems often assign the same address to all systems because they assume that only one operating system will be running at a time. If the host system is set up to boot multiple operating systems, and you run one or more operating systems in virtual machines, you must configure each operating system to have a unique network address.

**Configure Bridged Networking for an Existing Virtual Machine**

You can configure bridged networking for an existing virtual machine.

To configure bridged networking for a new virtual machine, select **Customize Hardware** when you run the New Virtual Machine wizard.
Procedure

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select **Network Adapter**.
3. Select **Bridged: Connected directly to the physical network**.
4. If you use the virtual machine on a laptop or other mobile device, select **Replicate physical network connection state**.
   This setting causes the IP address to be renewed when you move from one wired or wireless network to another.
5. Click **OK** to save your changes.

Configuring Network Address Translation

When you install Workstation Player on a Windows or Linux host system, a NAT network (VMnet8) is set up for you. When you use the New Virtual Machine wizard to create a typical virtual machine, the wizard configures the virtual machine to use the default NAT network.

With NAT, a virtual machine does not have its own IP address on the external network. Instead, a separate private network is set up on the host system. In the default configuration, virtual machines get an address on this private network from the virtual DHCP server.

**Figure 13-2.** NAT Configuration

The virtual machine and the host system share a single network identity that is not visible on the external network. NAT works by translating the IP addresses of virtual machines in the private network to the IP address of the host system. When a virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.

The host system has a virtual network adapter on the NAT network. This adapter enables the host system and virtual machines to communicate with each other. The NAT device passes network data between one or more virtual machines and the external network, identifies incoming data packets intended for each virtual machine, and sends them to the correct destination.

Configuring Host-Only Networking

When you install Workstation Player on a Windows or Linux host system, a host-only network (VMnet1) is set up for you. Host-only networking is useful if you need to set up an isolated virtual network. In a host-only network, the virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.

The network connection between the virtual machine and the host system is provided by a virtual network adapter that is visible on the host operating system. The virtual DHCP server provides IP addresses on the host-only network.
In the default configuration, a virtual machine in a host-only network cannot connect to the Internet. If you install the proper routing or proxy software on the host system, you can establish a connection between the host virtual network adapter and a physical network adapter on the host system to connect the virtual machine to a Token Ring or other non-Ethernet network.

On a Windows host computer, you can use host-only networking in combination with the Internet Connection Sharing feature in Windows to allow a virtual machine to use the dial-up networking adapter or other connection to the Internet on the host system. See Microsoft documentation for information on configuring Internet Connection Sharing.

**Configure Host-Only Networking for an Existing Virtual Machine**

You can configure host-only networking for an existing virtual machine. You can connect a virtual network adapter to the default host-only network (VMnet1) or to a custom host-only network. If a virtual machine has two virtual network adapters, you can connect it to two host-only networks.

To configure host-only networking for a new virtual machine, select **Customize Hardware** when you run the New Virtual Machine wizard.

**Prerequisites**

To connect the virtual machine to two host-only networks, add a second virtual network adapter to the virtual machine. See “Add a Virtual Network Adapter to a Virtual Machine,” on page 118.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings.**
2. On the **Hardware** tab select a virtual network adapter.
3. Select the host-only network.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use the default host-only network</strong> (VMnet1)</td>
<td>Select <strong>Host-only: A private network shared with the host.</strong></td>
</tr>
<tr>
<td><strong>Use a custom host-only network</strong></td>
<td>Select <strong>Custom</strong> and select the custom host-only network from the drop-down menu.</td>
</tr>
</tbody>
</table>

4. To connect the virtual machine to a second host-only network, select another virtual network adapter and select the second host-only network.
5. Click **OK** to save your changes.
What to do next

Assign IP addresses to the virtual network adapters. To see the IP address that a host-only network is using, use the `ipconfig /all` command on the Windows host.

Changing a Networking Configuration

You can determine the type of network that a virtual machine is using, add virtual network adapters to a virtual machine, and change the configuration of existing virtual network adapters.

Find the Network Type of a Virtual Machine

Unless you configure a custom network connection, a virtual machine uses a bridged, NAT, or host-only network connection. When you use the New Virtual Machine wizard to create a virtual machine, the new virtual machine defaults to using the NAT network type.

Procedure

1. Select the virtual machine and select `Player > Manage > Virtual Machine Settings`.
2. On the `Hardware` tab, select `Network Adapter`.

Add a Virtual Network Adapter to a Virtual Machine

You can add up to 10 virtual network adapters to a virtual machine.

Prerequisites

Familiarize yourself with the network configuration types. See “Understanding Common Networking Configurations,” on page 114.

Procedure

1. Select the virtual machine and select `Player > Manage > Virtual Machine Settings`.
2. On the `Hardware` tab, click `Add`.
3. Select `Network Adapter` and click `Next`.
4. Select the virtual network adapter type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bridged</td>
<td>The virtual machine is connected to the network by using the network adapter on the host system. The virtual machine has a unique identity on the network, separate from and unrelated to the host system.</td>
</tr>
<tr>
<td>NAT</td>
<td>The virtual machine and the host system share a single network identity that is not visible on the external network. When the virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.</td>
</tr>
<tr>
<td>Host-only</td>
<td>The virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.</td>
</tr>
</tbody>
</table>

5. (Optional) Select the `Connect at power on` checkbox.
6. Click `Finish` to add the virtual network adapter to the virtual machine.
7. Click `OK` to save your changes.
Verify that the guest operating system is configured to use an appropriate IP address on the new network.

- If the virtual machine is using DHCP, release and renew the lease.
- If the IP address is set statically, verify that the guest operating system has an address on the correct virtual network.

**Modify an Existing Virtual Network Adapter for a Virtual Machine**

You can change the settings of a virtual network adapter that is currently used by a virtual machine.

**Prerequisites**

Familiarize yourself with the network configuration types. See “Understanding Common Networking Configurations,” on page 114.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select the virtual network adapter.
3. Select the virtual network adapter type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bridged</strong></td>
<td>The virtual machine is connected to the network by using the network adapter on the host system. The virtual machine has a unique identity on the network, separate from and unrelated to the host system.</td>
</tr>
<tr>
<td><strong>NAT</strong></td>
<td>The virtual machine and the host system share a single network identity that is not visible on the external network. When the virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.</td>
</tr>
<tr>
<td><strong>Host-only</strong></td>
<td>The virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.</td>
</tr>
<tr>
<td><strong>Custom</strong></td>
<td>Select a custom network from the drop-down menu. Although VMnet0, VMnet1, and VMnet8 might be available in this list, these networks are usually used for bridged, host-only, and NAT networks.</td>
</tr>
<tr>
<td><strong>LAN segment</strong></td>
<td>Select a LAN segment from the drop-down menu. A LAN segment is a private network that is shared by other virtual machines.</td>
</tr>
</tbody>
</table>

4. Click **OK** to save your changes.
5. Verify that the guest operating system is configured to use an appropriate IP address on the new network.

- If the virtual machine is using DHCP, release and renew the lease.
- If the IP address is set statically, verify that the guest operating system has an address on the correct virtual network.
Configuring Virtual Machine Option Settings

Virtual machine options settings control characteristics of individual virtual machines, such as how files are transferred between the host and guest operating system and what happens to a guest operating system when you exit Workstation Player. Some virtual machine options override similar Workstation Player preference settings.

To configure virtual machine option settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings and click the Options tab.

This chapter includes the following topics:

- “Configuring General Option Settings for a Virtual Machine,” on page 121
- “Configuring Power Options for a Virtual Machine,” on page 123
- “Configuring VMware Tools Options for a Virtual Machine,” on page 123
- “Configuring Unity Mode for a Virtual Machine,” on page 124
- “Configuring Autologin for a Virtual Machine,” on page 125

Configuring General Option Settings for a Virtual Machine

General option settings include the virtual machine name, the guest operating system type and version, and the location of the directory where virtual machine files are stored.

To configure general option settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select General.

- Changing a Virtual Machine Name on page 122
  You can change the name of a virtual machine. Changing the name of the virtual machine does not change the name of this directory, nor does it rename the virtual machine files on the host.
  Workstation Player uses the original name of the virtual machine to create the directory where virtual machine files are stored.

- Changing the Guest Operating System on page 122
  You can change the guest operating system or operating system version for a virtual machine. You might want to change the guest operating system for a virtual machine when you upgrade the guest operating system or if you specified the wrong operating system version when you created the virtual machine.

- Changing the Virtual Machine Working Directory on page 122
  You can change the working directory for a virtual machine. The working directory is where Workstation Player stores suspended state (.vmss), snapshot (.vmsn), and virtual machine paging (.vmem) files. By default, the working directory is where the virtual machine files are stored.
Use the Enhanced Virtual Keyboard Feature in a Virtual Machine on page 122

The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

Changing a Virtual Machine Name

You can change the name of a virtual machine. Changing the name of the virtual machine does not change the name of this directory, nor does it rename the virtual machine files on the host. Workstation Player uses the original name of the virtual machine to create the directory where virtual machine files are stored.

To specify a new name for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select General.

Changing the Guest Operating System

You can change the guest operating system or operating system version for a virtual machine. You might want to change the guest operating system for a virtual machine when you upgrade the guest operating system or if you specified the wrong operating system version when you created the virtual machine.

To select a new guest operating system or operating system version for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select General.

When you change the operating system type, the virtual machine configuration file is changed but the guest operating system is not changed. To change the guest operating system, you must obtain the operating system software and upgrade the guest operating system.

The virtual machine must be powered off when you change these settings.

Changing the Virtual Machine Working Directory

You can change the working directory for a virtual machine. The working directory is where Workstation Player stores suspended state (.vmss), snapshot (.vmsn), and virtual machine paging (.vmem) files. By default, the working directory is where the virtual machine files are stored.

To specify a new working directory for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select General.

You might want to change the working directory in the following situations.

- To run a virtual machine that is stored on a network share or iPod, which might slow performance, you can change the working directory to your local hard disk.
- To create a paging file on a fast disk with a lot of disk space but leave the virtual disk and configuration file on a different disk, you can change the working directory so that it is located on the fast disk.

Changing the working directory does not change the directory where Workstation Player stores the virtual machine configuration (.vmx) file and log files.

The virtual machine must be powered off when you change this setting.

Use the Enhanced Virtual Keyboard Feature in a Virtual Machine

The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

Because it processes raw keyboard input as soon as possible, the enhanced virtual keyboard feature also offers security improvements by bypassing Windows keystroke processing and any malware that is not already at a lower layer. When you use the enhanced virtual keyboard feature, only the guest operating system acts when you press Ctrl+Alt/Delete.
Prerequisites

- If you recently installed or upgraded Workstation Player, but did not restart the host system, restart the host system.
- Power off the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select General.
3. Select an option from the Enhanced virtual keyboard drop-down menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off</td>
<td>The virtual machine does not use the enhanced virtual keyboard feature. This is the default value.</td>
</tr>
<tr>
<td>Use if available (recommended)</td>
<td>The virtual machine uses the enhanced virtual keyboard feature, but only if the enhanced virtual keyboard driver is installed on the host system.</td>
</tr>
<tr>
<td>Required</td>
<td>The virtual machine must use the enhanced virtual keyboard feature. If you select this option and the enhanced keyboard driver is not installed on the host system, Workstation Player returns an error message.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.

Configuring Power Options for a Virtual Machine

Power options control how a virtual machine behaves after it is powered off, closed, or suspended.

To configure power options for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select Power.

Table 14-1. Power Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter full screen mode after powering on</td>
<td>The virtual machine window enters full screen mode after it is powered on.</td>
</tr>
<tr>
<td>Report battery information to guest</td>
<td>Battery information is reported to the guest operating system. If you run the virtual machine on a laptop in full screen mode, this option enables you to determine when the battery is running low. This option is available only for Workstation 6.x and later virtual machines.</td>
</tr>
</tbody>
</table>

Configuring VMware Tools Options for a Virtual Machine

You can configure how VMware Tools is updated on a virtual machine. You can also configure whether the clock on the guest operating system is synchronised with the clock on the host.

VMware Tools Update Options

The virtual machine VMware Tools update options override the Workstation Player preferences for automatically updating VMware Tools on Linux and Windows guest operating systems.

To configure VMware Tools updates for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select VMware Tools.

Note: Automatic updates are not supported for versions of VMware Tools included in virtual machines created with older versions of VMware products, such as Workstation 5.5 and earlier or VMware Server 1.x.
Table 14-2. VMware Tools Update Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update manually (do nothing)</td>
<td>You must update VMware Tools manually. A message appears on the status bar of the guest operating system when a new version of VMware Tools is available.</td>
</tr>
<tr>
<td>Update automatically</td>
<td>VMware Tools is updated automatically when a new version is available. The status bar indicates when an update is in progress.</td>
</tr>
<tr>
<td>Use application default (currently update automatically)</td>
<td>Use the default VMware Tools update behavior.</td>
</tr>
</tbody>
</table>

To install a VMware Tools update, use the same procedure that you used for installing VMware Tools the first time.

**Time Synchronization**

If you turn on the VMware Tools time synchronization feature, VMware Tools checks once every minute to determine whether the clocks on the guest and host operating systems still match. If not, the clock on the guest operating system is synchronized to match the clock on the host.

Native time synchronization software, such as Network Time Protocol (NTP) for Linux and the Mac OS X, or Microsoft Windows Time Service (Win32Time) for Windows, is typically more accurate than VMware Tools periodic time synchronization and is therefore preferred.

**Configuring Unity Mode for a Virtual Machine**

In virtual machines that have Windows XP or later guest operating systems, you can switch to Unity mode to display applications directly on the host system desktop. Open applications in Unity mode appear on the taskbar in the same way as open host system applications.

To configure Unity mode settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select Unity.

Table 14-3. Unity Mode Options

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show borders</td>
<td>Set a window border that identifies the application as belonging to the virtual machine rather than to the host computer.</td>
</tr>
<tr>
<td>Show badges</td>
<td>Display a logo in the title bar.</td>
</tr>
<tr>
<td>Use a custom color in window borders</td>
<td>Use a custom color in window borders to help distinguish between the application windows that belong to various virtual machines. For example, you can set the applications for one virtual machine to have a blue border and set the applications for another virtual machine to have a yellow border. On Windows hosts, click Choose color to use the color chooser.</td>
</tr>
<tr>
<td>Enable applications menu</td>
<td>The virtual machine Start or Applications menu appears on the host system desktop. When you can access the virtual machine Start or Applications menu from the host machine desktop, you can start applications in the virtual machine that are not open in Unity mode. If you do not enable this setting, you must exit Unity mode to display the virtual machine Start or Applications menu in the console view.</td>
</tr>
</tbody>
</table>
Configuring Autologin for a Virtual Machine

You can configure the Autologin feature for virtual machines that have a Windows 2000 or later guest operating system. To use Autologin, the virtual machine must be powered on, you must have an existing user account on the local machine, and the latest version of VMware Tools must be installed.

To configure Autologin for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Options tab, and select Autologin.

When you enable Autologin, you must type your login credentials. If you type an incorrect or expired password, you must type your login credentials when you power on the virtual machine. To change your login credentials, select Change User.

**Note** When you enable Autologin or change your login credentials, Autologin settings are saved immediately. If you click Cancel in the Virtual Machine Settings dialog box, the changes applied to the Autologin settings are not affected.
Configuring Virtual Machine

Hardware Settings

You can use virtual machine hardware settings to add, remove, and modify virtual devices for a virtual machine.

To configure hardware settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings and click the Hardware tab. When you select a device in the left pane, the configuration options for that device appear in the right pane.

This chapter includes the following topics:

- “Adding Hardware to a Virtual Machine,” on page 127
- “Removing Hardware from a Virtual Machine,” on page 129
- “Adjusting Virtual Machine Memory,” on page 129
- “Configuring Virtual Machine Processor Settings,” on page 129
- “Configuring and Maintaining Virtual Hard Disks,” on page 130
- “Configuring CD-ROM and DVD Drive Settings,” on page 133
- “Configuring Floppy Drive Settings,” on page 134
- “Configuring Virtual Network Adapter Settings,” on page 135
- “Configuring USB Controller Settings,” on page 138
- “Configuring Sound Card Settings,” on page 139
- “Configuring Parallel Port Settings,” on page 139
- “Configuring Serial Port Settings,” on page 139
- “Configuring Generic SCSI Device Settings,” on page 140
- “Configuring Printer Settings,” on page 141
- “Configuring Display Settings,” on page 141
- “Installing a Guest Operating System on a Physical Disk or Unused Partition,” on page 142

Adding Hardware to a Virtual Machine

You can use virtual machine hardware settings to add hardware to an existing virtual machine.

To add hardware to a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and click Add.

**NOTE** You cannot add hardware to a virtual machine while it is in suspended state.
The Add Hardware wizard prompts you to select the type of device that you want to add and to specify device-specific configuration settings. You can modify many of the configuration settings after the device is created by changing virtual machine hardware settings.

You can add the following types of devices to a virtual machine.

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual hard disks</td>
<td>A virtual hard disk is a set of files that appears as a physical disk drive to the guest operating system. You can configure a virtual hard disk as an IDE, SCSI, or SATA device. You can add up to 4 IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (4 controllers and 30 devices per controller) to a virtual machine. You can also give a virtual machine direct access to a physical disk.</td>
</tr>
<tr>
<td>CD-ROM and DVD drives</td>
<td>You can configure a virtual CD-ROM or DVD drive as an IDE, SCSI, or SATA device. You can add up to 4 IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (4 controllers and 30 devices per controller) to a virtual machine. You can connect virtual CD-ROM and DVD drives to a physical drive on the host system or to an ISO image file.</td>
</tr>
<tr>
<td>Floppy drives</td>
<td>You can add up to two floppy drives. A virtual floppy drive can connect to a physical drive on the host system, to an existing floppy image file, or to a blank floppy image file.</td>
</tr>
<tr>
<td>Network adapters</td>
<td>You can add up to 10 virtual network adapters to a virtual machine.</td>
</tr>
<tr>
<td>USB controller</td>
<td>You can add one USB controller to a virtual machine. A virtual machine must have a USB controller to use USB devices or smart card readers. For smart card readers, a virtual machine must have a USB controller regardless of whether the smart card reader is actually a USB device.</td>
</tr>
<tr>
<td>Sound card</td>
<td>If the host system is configured for sound and has a sound card installed, you can enable sound for virtual machines.</td>
</tr>
<tr>
<td>Parallel (LPT) ports</td>
<td>You can attach up to three bidirectional parallel ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host operating system.</td>
</tr>
<tr>
<td>Serial (COM) ports</td>
<td>You can add up to four serials ports to a virtual machine. Virtual serial ports can output to physical serial ports, files on the host operating system, or named pipes.</td>
</tr>
<tr>
<td>Printers</td>
<td>You can print from a virtual machine to any printer available to the host system without installing additional drivers in the virtual machine. Workstation Player uses ThinPrint technology to replicate the host machine printer mapping in the virtual machine. When you enable the virtual machine printer, Workstation Player configures a virtual serial port to communicate with the host printers.</td>
</tr>
<tr>
<td>Generic SCSI devices</td>
<td>You can add up to 60 SCSI devices to a virtual machine. A generic SCSI device gives the guest operating system direct access to a SCSI device connected to the host system. Generic SCSI devices can include scanners, tape drives, CD-ROM drives, and DVD drives.</td>
</tr>
</tbody>
</table>
Removing Hardware from a Virtual Machine

You can remove certain types of hardware from a virtual machine.

To remove hardware from a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and click Remove.

**Note** You cannot remove hardware from a virtual machine while it is in suspended state.

You can remove the following types of devices from a virtual machine:

- Virtual hard disks
- CD-ROM and DVD drives
- Floppy drives
- Virtual network adapters
- USB controllers
- Sound cards
- Printers
- Generic SCSI devices

You cannot remove the Memory, Processors, and Display device types.

You must power off a virtual machine before you remove a virtual network adapter, sound card, parallel port, serial port, or generic SCSI device. You must also power off Workstation 5 virtual machines before you remove a USB controller.

Adjusting Virtual Machine Memory

You can adjust the amount of memory that is allocated to a virtual machine. You must power off a virtual machine before you change its memory allocation setting.

To adjust the memory allocation for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and click Memory.

The Memory panel includes information to help you select the appropriate amount of memory for the virtual machine. The high end of the range is determined by the amount of memory that is allocated to all running virtual machines. If you allow virtual machine memory to be swapped, this value changes to reflect the specified amount of swapping.

The color-coded icons on the Memory panel indicate the maximum recommended memory, the recommended memory, and the guest operating system recommended minimum memory amounts. To adjust the memory, move the slider along the range of values, or type a value in the Memory for this virtual machine text box.

**Note** Allocating more than the maximum memory to a virtual machine might cause memory swapping. It can also negatively affect host system performance, including the ability to run Workstation Player.

Configuring Virtual Machine Processor Settings

You can configure processor settings for a virtual machine, including the number of processors, the number of cores per processor, and the preferred execution mode for the virtualization engine.

To configure processor settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select Processors.
Table 15-1. Processor Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of cores per processor</td>
<td>Select the number of cores per processor. Workstation Player supports up to 16-way virtual Symmetric Multiprocessing (SMP) for guest operating systems running on multiprocessor host machines. You can assign processors and cores per processor to a virtual machine on any host machine that has at least two logical processors.</td>
</tr>
<tr>
<td>Preferred mode</td>
<td>Select the preferred execution mode for the virtualization engine. You usually do not need to change virtualization engine settings.</td>
</tr>
<tr>
<td>Automatic</td>
<td>Workstation Player chooses the execution mode based on the guest operating system and the host CPU.</td>
</tr>
<tr>
<td>Binary translation</td>
<td>Workstation Player uses a mix of directly executing guest code and binary translation to run the guest operating system. Guest memory mapping is performed by using shadow page tables.</td>
</tr>
<tr>
<td>Intel VT-x or AMD-V</td>
<td>Workstation Player uses hardware extensions to run and isolate guest code. Guest memory mapping is performed by using shadow page tables.</td>
</tr>
<tr>
<td>Intel VT-x/EPT or AMD-V/RVI</td>
<td>Workstation Player forces the virtual machine execution mode to VT-x/EPT or AMD-RVI. Physical Address Extension (PAE) mode must be enabled to use virtualized AMD-V/RVI.</td>
</tr>
<tr>
<td>Disable acceleration for binary translation</td>
<td>In rare instances, you might find that Workstation Player appears to freeze when you install or run software inside a virtual machine. This problem typically occurs early in the execution of the program. In many cases, you can prevent the problem by temporarily disabling acceleration in the virtual machine. After the program passes the point at which the problems occur, deselect this setting.</td>
</tr>
<tr>
<td>Virtualize CPU performance counters</td>
<td>Turn on this feature if you plan to use performance monitoring applications such as VTune or OProfile to optimize or debug software that runs inside the virtual machine. This feature is available only if the virtual machine compatibility is Workstation 9 or later.</td>
</tr>
</tbody>
</table>

Configuring and Maintaining Virtual Hard Disks

You can configure virtual hard disk node and mode settings. You can also use command in the Utilities menu to perform common disk maintenance tasks, such as defragmenting, compacting, and expanding a disk.

To perform actions on a virtual hard disk for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select the virtual hard disk.
Defragmenting Virtual Hard Disks
Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual disk.

Expanding Virtual Hard Disks
Expanding a virtual hard disk adds storage space to the virtual machine.

Compacting Virtual Hard Disks
Compacting a virtual hard disk reclaims unused space in the disk. If a disk has empty space, this process reduces the amount of space the virtual hard disk occupies on the host drive. You must power off a virtual machine before you compact its virtual hard disk.

Mapping a Virtual Disk to the Host System
Instead of using shared folders or copying data between a virtual machine and the host system, you can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a virtual machine.

Changing Virtual Hard Disk Node and Mode Settings
You can change virtual hard disk node and mode settings.

Defragmenting Virtual Hard Disks
Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual disk.

There must be adequate free working space on the host system to defragment a virtual hard disk. If the disk is contained in a single file, for example, you need free space equal to the size of the disk file. Other virtual hard disk configurations require less free space. You cannot defragment a virtual hard disk while it is mapped or mounted.

To defragment a virtual hard disk for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, select the virtual hard disk, and select Defragment from the Utilities menu.

Note: Defragmenting a virtual hard disk can take several minutes.

Expanding Virtual Hard Disks
Expanding a virtual hard disk adds storage space to the virtual machine.

When you expand a virtual hard disk, the added space is not immediately available to the virtual machine. To make the added space available, you must use a disk management tool to increase the size of the existing partition on the virtual hard disk to match the expanded size.

The disk management tool that you use depends on the virtual machine guest operating system. Many operating systems, including Windows Vista, Windows 7, and some versions of Linux, provide built-in disk management tools that can resize partitions. Third-party disk management tools are also available, such as Symantec/Norton PartitionMagic, EASEUS Partition Master, Acronis Disk Director, and the open-source tool GParted.

When you expand the size of a virtual hard disk, the sizes of partitions and file systems are not affected.
To expand a virtual hard disk for a selected virtual machine, select Player > Manage > Virtual Machine Settings, select the virtual hard disk, and select Expand from the Utilities menu.

**NOTE** As an alternative to expanding a virtual hard disk, you can add a new virtual hard disk to the virtual machine.

### Compacting Virtual Hard Disks

Compacting a virtual hard disk reclaims unused space in the disk. If a disk has empty space, this process reduces the amount of space the virtual hard disk occupies on the host drive. You must power off a virtual machine before you compact its virtual hard disk.

You cannot compact a virtual hard disk if disk space is preallocated or if the virtual hard disk is mapped or mounted.

To compact a virtual hard disk for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, select the virtual hard disk, and select Compact from the Utilities menu.

### Mapping a Virtual Disk to the Host System

Instead of using shared folders or copying data between a virtual machine and the host system, you can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a virtual machine.

### Map or Mount a Virtual Disk to a Drive on the Host System

When you map a virtual disk and its associated volume to a drive on the host system, you can connect to the virtual disk without opening a virtual machine.

After you map the virtual disk to a drive on the host system, you cannot power on any virtual machine that uses the disk until you disconnect the disk from the host system.

**IMPORTANT** If you mount a virtual disk that has a snapshot and then write to the disk, you can irreparably damage a snapshot or linked clone created from the virtual machine. Note that Workstation Player does not support taking snapshots or deleting them.

Mapping a virtual disk to a host system is not supported in the standalone version of Workstation Player. Virtual disk mapping is supported in the Workstation Player version included with Workstation Pro.

### Prerequisites

- Power off all virtual machines that use the virtual disk.
- Verify that the virtual disk (.vmdk) files on the virtual disk are not compressed and do not have read-only permissions.
- On a Windows host, verify that the volume is formatted with FAT (12/16/32) or NTFS. Only FAT (12/16/32) and NTFS formatting is supported. If the virtual disk has mixed partitions, for example, one partition is formatted with a Linux operating system and another partition is formatted with a Windows operating system, you can map the Windows partition only.
- Verify that the virtual disk is unencrypted. You cannot map or mount encrypted disks.

### Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Hard Disk, click Utilities, and select Map.
3 On a Windows host, leave the check box **Open file in read-only mode** selected in the Map Virtual Disk dialog box.

This setting prevents you from accidentally writing data to a virtual disk that might be the parent of a snapshot or linked clone. Writing to such a disk might make the snapshot or linked clone unusable.

4 Browse to a virtual disk (.vmdk) file, select it, and click **Open**.

5 Select the volume to map or mount and select an unused drive letter on the host system.

6 (Optional) On a Windows host, if you do not want the drive to open in Windows Explorer after it is mapped, deselect the **Open drive in Windows Explorer after mapping** check box.

7 Click **OK** or **Mount**.

The drive appears on the host system. You can read from or write to files on the mapped virtual disk on the host system.

**Disconnect a Virtual Disk from the Host System**

To use a virtual disk from a virtual machine after it has been mapped or mounted on the host system, you must disconnect it from the host system.

On Windows hosts, you must use Workstation Player to disconnect the drive from the host system. The mapped drive letter does not appear in the list of network drives when you use the Windows **Disconnect Network Drive** command.

**Procedure**

1 Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.

2 On the **Hardware** tab, select **Hard Disk**, click **Utilities**, and select **Disconnect**.

You can now power on any virtual machine that uses this disk.

**Changing Virtual Hard Disk Node and Mode Settings**

You can change virtual hard disk node and mode settings.

To change the node and mode settings for a virtual hard disk on a selected virtual machine, select **Player > Manage > Virtual Machine Settings**, click the **Hardware** tab, select the virtual hard disk, and click **Advanced**. By default, changes are immediately written to the disk.

**Table 15-2. Virtual Hard Disk Node and Mode Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual device node</td>
<td>Select the SCSI, IDE, or SATA device identifier to use for the drive. For example, if you select SCSI 0:2, the guest operating system detects the drive as ID 2 on controller 0. You determine whether the virtual disk is seen as a SCSI, IDE, or SATA device at the time that you create it.</td>
</tr>
</tbody>
</table>

**Configuring CD-ROM and DVD Drive Settings**

You can configure CD-ROM and DVD drive settings, including the virtual device node and legacy emulation modes.

To configure CD-ROM and DVD drive settings for a selected virtual machine, select **Player > Manage > Virtual Machine Settings**, click the **Hardware** tab, and select the drive.
• Configuring CD-ROM and DVD Drive Status and Connection Settings on page 134
  Device status and connection settings control when a CD-ROM or DVD drive is connected to a virtual
  machine, whether to use a specific drive or allow Workstation Player to detect a drive, and whether to
  use an ISO image file instead of a physical drive.

• Changing Virtual Device Node and Legacy Emulation Settings on page 134
  You can use the advanced settings to change the virtual device node and legacy emulation settings for
  a CD-ROM or DVD drive. You must power off the virtual machine before you change these settings.

Configuring CD-ROM and DVD Drive Status and Connection Settings

Device status and connection settings control when a CD-ROM or DVD drive is connected to a virtual
machine, whether to use a specific drive or allow Workstation Player to detect a drive, and whether to
use an ISO image file instead of a physical drive.

To configure device status and connection settings for a selected virtual machine, select Player > Manage >
Virtual Machine Settings, click the Hardware tab, and select the drive.

Table 15-3. Device Status and Connection Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the drive or ISO image file while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the drive or ISO image path when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use physical drive</td>
<td>Select a specific drive or select Auto detect to allow Workstation Player to detect a drive to use.</td>
</tr>
<tr>
<td>Use ISO image file</td>
<td>Specify or select an ISO image file for the virtual machine to use.</td>
</tr>
</tbody>
</table>

To disable or enable access to a CD-ROM or DVD drive while a virtual machine is running, select the virtual
machine, select Player > Removable Devices > CD/DVD, and select Disconnect or Connect.

Changing Virtual Device Node and Legacy Emulation Settings

You can use the advanced settings to change the virtual device node and legacy emulation settings for a CD-
ROM or DVD drive. You must power off the virtual machine before you change these settings.

To configure virtual device and legacy emulation settings for a selected virtual machine, select Player >
Manage > Virtual Machine Settings, click the Hardware tab, select the drive, and click Advanced.

Use the settings to select which SCSI, IDE, or SATA device identifier to use for the drive. For example, if you
select SCSI 0:2, the guest operating system detects the drive as ID 2 on controller 0. You can select the IDE,
SCSI, or SATA node options regardless of the physical device type. For example, if the physical drive is an
IDE device, you can select a SCSI node. In this case, the virtual machine detects the drive as a SCSI device.

If you select the Legacy emulation setting, the virtual hardware works as it did in an earlier release of
Workstation Player. By default, Workstation Player attempts to make the advanced features of your drive
available, but sometimes this setting might cause the drive to not work with the virtual machine. Selecting
the Legacy emulation setting reverts Workstation Player to the previous emulation mode for the drive.
Legacy emulation is helpful for troubleshooting purposes.

Configuring Floppy Drive Settings

You can configure when a floppy drive is connected to a virtual machine, whether to use a specific drive or
allow Workstation Player to detect a drive, and whether to use an disk drive image file instead of a physical
drive.

To configure floppy drive settings for a selected virtual machine, select Player > Manage > Virtual Machine
Settings, click the Hardware tab, and select the floppy drive.
Table 15-4. Floppy Drive Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the drive or floppy image file while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the floppy drive when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use a physical drive</td>
<td>Select a specific floppy drive or select Auto detect to allow Workstation Player to detect a drive to use.</td>
</tr>
<tr>
<td>Use a floppy image file</td>
<td>Create or browse to a floppy image (.img or .flp) file. Select Read only to prevent changes from being made to the file.</td>
</tr>
</tbody>
</table>

To disable or enable access to a floppy drive while a virtual machine is running, select Player > Removable Devices > Floppy, and select Disconnect or Connect.

**Configuring Virtual Network Adapter Settings**

You can configure when a virtual network adapter is connected to a virtual machine and the type of network connection that the adapter provides.

To configure virtual network adapter settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select the virtual network adapter.

- Configuring Virtual Network Adapter Device Status Settings on page 135
  Device status settings control when a virtual network adapter is connected to a virtual machine.

- Configuring Bridged Networking on page 136
  When you configure bridged networking, the virtual machine uses physical network adapters on the host system to connect a network.

- Configuring Network Address Translation on page 136
  When you configure Network Address Translation (NAT), the virtual machine shares the IP address and MAC address of the host system.

- Configuring Host-Only Networking on page 137
  When you configure host-only networking, Workstation Player creates a virtual private network (VPN) connection between the virtual machine and the host system.

- Configuring LAN Segments on page 137
  When you select a LAN segment, the virtual machine uses a private network that can be shared with other virtual machines. LAN segments are useful for multitier testing, network performance analysis, and situations where virtual machine isolation are important.

- Configuring Virtual Network Adapter Advanced Settings on page 137
  You can use the advanced virtual network adapter settings to limit the bandwidth and specify the acceptable packet loss percentage for incoming and outgoing data transfers.

**Configuring Virtual Network Adapter Device Status Settings**

Device status settings control when a virtual network adapter is connected to a virtual machine.

To configure virtual network adapter device status settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select the virtual network adapter.
### Table 15-5. Device Status Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the virtual network adapter while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the virtual network adapter when you power on the virtual machine.</td>
</tr>
</tbody>
</table>

### Configuring Bridged Networking

When you configure bridged networking, the virtual machine uses physical network adapters on the host system to connect a network.

If the host system is on a network, bridged networking is often the easiest way to give a virtual machine access to that network.

With bridged networking, the virtual machine appears as an additional computer on the same physical Ethernet network as the host system. The virtual machine can transparently use the services available on the network, including file servers, printers, and gateways. Physical hosts and other virtual machines configured with bridged networking can also use the resources of the virtual machine.

When you use bridged networking, the virtual machine must have its own identity on the network. For example, on a TCP/IP network, the virtual machine must have its own IP address. Virtual machines typically acquire an IP address and other network details from a DHCP server. In some configurations, you might need to set the IP address and other details manually.

Users who boot multiple operating systems often assign the same address to all systems because they assume that only one operating system will be running at the same time. If the host system is set up to boot multiple operating systems and you run one or more of them in virtual machines, configure each operating system with a unique network address.

When the Replicate physical connection state option is selected, the IP address is automatically renewed when you move from one wired or wireless network to another. This setting is useful for virtual machines than run on laptops or other mobile devices.

### Changing Automatic Bridging Settings

When automatic bridging mode is configured, you can restrict the physical network adapters that a virtual switch bridges to.

To change automatic bridging settings, select Player > Virtual Machine Settings > Network Adapter > Configure Adapters, select the host network adapter(s) to automatically bridge, and click OK.

By default, a virtual switch bridges to all active network adapters on the host system when it is configured for automatic bridging. The choice of which adapter to use is arbitrary.

To prevent a virtual switch from bridging to a particular physical network adapter, deselect the check box for that host network adapter.

### Configuring Network Address Translation

When you configure Network Address Translation (NAT), the virtual machine shares the IP address and MAC address of the host system.

The virtual machine and the host system share the a single identity that is not visible outside the network. The virtual machine does not have its own IP address. Instead, a separate private network is set up on the host system and the virtual machine obtains an address on that network from the VMware virtual DHCP server. The VMware NAT device passes network data between one or more virtual machines and the external network. The VMware NAT device identifies incoming data packets that are intended for each virtual machine and sends them to the correct destination.
With NAT, a virtual machine can use many standard protocols to connect to other machines on the external network. For example, you can use HTTP to browse Web sites, FTP to transfer files, and Telnet to log in to other systems. You can also connect to a TCP/IP network by using a Token Ring adapter on the host system.

In the default configuration, systems on the external network cannot initiate connections to the virtual machine. For example, the default configuration does not let you use the virtual machine as a Web server to send Web pages to systems on the external network. This limitation protects the guest operating system from being compromised before you can install security software.

By default, NAT is used when you use the New Virtual Machine wizard to create a virtual machine.

The virtual machine uses NAT to connect to the Internet or other TCP/IP network by using the networking connection on the host system. NAT works with Ethernet, DSL, and phone modems. A separate private network is set up on the host system. The virtual machine obtains an address on that network from the VMware virtual DHCP server.

**Configuring Host-Only Networking**

When you configure host-only networking, Workstation Player creates a virtual private network (VPN) connection between the virtual machine and the host system.

A VPN is typically not visible outside the host system. Multiple virtual machines configured with host-only networking on the same host system are on the same network. The VMware DHCP server provides addresses on the network.

If you install the proper routing or proxy software on the host system, you can establish a connection between the host virtual network adapter and a physical network adapter on the host system. With this configuration, you can connect the virtual machine to a Token Ring or other non-Ethernet network.

On Windows host systems, you can use host-only networking in combination with the Internet Connection Sharing feature in Windows. With this combination, the virtual machine can use the dial-up networking adapter on the host system or another connection to the Internet. See the Windows documentation for more information on Internet Connection Sharing.

**Configuring LAN Segments**

When you select a LAN segment, the virtual machine uses a private network that can be shared with other virtual machines. LAN segments are useful for multitier testing, network performance analysis, and situations where virtual machine isolation are important.

If you add an existing virtual machine to a LAN segment, the virtual machine might be configured to expect an IP address from a DHCP server. Unlike host-only and NAT networking, Workstation Player does not provide a DHCP server for LAN segments. You must manually configure IP addressing for virtual machines on a LAN segment. You can either configure a DHCP server on the LAN segment to allocate IP addresses, or you can configure a fixed IP address for each virtual machine on the LAN segment.

You can click **LAN Segments** to create new LAN segments or delete and rename existing LAN segments. Deleting a LAN segment disconnects all virtual network adapters that are configured for that LAN segment. When you delete a LAN segment, you must manually configure its disconnected virtual network adapter to reconnect the virtual machine to the network.

**Configuring Virtual Network Adapter Advanced Settings**

You can use the advanced virtual network adapter settings to limit the bandwidth and specify the acceptable packet loss percentage for incoming and outgoing data transfers.

To configure advanced virtual network adapter settings for a selected virtual machine, select **Player > Manage > Virtual Machine Settings**, click the **Hardware** tab, select the virtual network adapter, and click **Advanced**.
Table 15-6. Virtual Network Adapter Advanced Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bandwidth and Kbps</td>
<td>To limit incoming or outgoing data transfers to the data transfer rate for a specific network connection type, select the network connection type from the Bandwidth drop-down menu. The value in the Kbps text box changes to the data transfer rate, in kilobits per second, of the network connection type that you select. For example, if you select Leased Line T1 (1.544 Mbps), the value in the Kbps text box changes to 1544. To limit incoming or outgoing data transfers to a specific data transfer rate, select Custom and type the data transfer rate in kilobits per second in the Kbps text box. The default bandwidth setting for both incoming and outgoing data transfers is Unlimited.</td>
</tr>
<tr>
<td>Packet Loss (%)</td>
<td>The acceptable packet loss percentage for incoming or outgoing data transfers. The default setting is 0.0%.</td>
</tr>
<tr>
<td>MAC Address</td>
<td>To assign a new MAC address to the network adapter, either type a new address in this text box or click Generate to have Workstation Player generate a new address.</td>
</tr>
</tbody>
</table>

Configuring USB Controller Settings

You can configure whether a USB controller supports isochronous USB and Bluetooth devices, when to connect new USB devices to the host system, and whether human interface devices (HIDs) appear in the Removable Devices menu.

To configure USB controller settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and click USB Controller.

Table 15-7. USB Controller Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB Compatibility</td>
<td>Selecting USB 2.0 or 3.0 enables support for isochronous USB devices, including Web cams, speakers, and microphones.</td>
</tr>
<tr>
<td>Automatically connect new USB devices</td>
<td>Connect new USB devices to the virtual machine. If this setting is not selected, new USB devices are connected only to the host system.</td>
</tr>
<tr>
<td>Show all USB input devices</td>
<td>Human interface devices (HIDs), such as USB 1.1 and 2.0 mouse and keyboard devices, appear in the Removable Devices menu. Icons for HIDs appear in the status bar. An HID that is connected to the guest operating system is not available to the host system. The virtual machine must be powered off when you change this setting.</td>
</tr>
<tr>
<td>Share Bluetooth devices with the virtual machine</td>
<td>Enable support for Bluetooth devices.</td>
</tr>
</tbody>
</table>

To connect or disconnect USB devices while a virtual machine is running, select the virtual machine and select Player > Removable Devices. With the two-port USB controller, you can connect to both USB 1.1 and USB 2.0 devices.

**IMPORTANT** Before you unplug a USB device or select a removable device to disconnect a USB device from a virtual machine, follow the device manufacturer’s procedures for safely unplugging the device from a physical computer.
Configuring Sound Card Settings

You can configure when a sound card is connected to a virtual machine. You can also configure whether a virtual machine uses a specific sound card or the default sound card in the host system.

To configure sound card settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and click Sound Card.

Table 15-8. Sound Card Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the sound device while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the sound device when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use default host sound card</td>
<td>Make the virtual machine use the default sound card in the host system.</td>
</tr>
<tr>
<td>Specify host sound card</td>
<td>(Windows hosts only) Select a specific host sound card for the virtual machine to use.</td>
</tr>
<tr>
<td>Use physical sound card</td>
<td>(Linux hosts only) Select a specific host sound card to for the virtual machine to use.</td>
</tr>
<tr>
<td>Enable Echo Cancellation</td>
<td>Enable echo cancellation for the sound card.</td>
</tr>
</tbody>
</table>

Configuring Parallel Port Settings

You can configure when a parallel port is connected to a virtual machine and whether to send output to a physical port or to a file on the host system.

To configure parallel port settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select the parallel port.

Table 15-9. Parallel Port Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the port while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the port when you power on the virtual machine.</td>
</tr>
<tr>
<td></td>
<td>If the guest operating system cannot access the parallel port device when you power on the virtual machine, deselected this setting. You can use the Removable Devices menu to enable access to the parallel port after the virtual machine is powered on.</td>
</tr>
<tr>
<td>Use a physical parallel port</td>
<td>Select a host parallel port for the virtual machine to use.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output from the virtual parallel port to a file on the host system.</td>
</tr>
<tr>
<td></td>
<td>Either locate an existing output file or browse to a directory and type a filename to create a new output file.</td>
</tr>
</tbody>
</table>

Configuring Serial Port Settings

You can configure when a serial port is connected to a virtual machine. You can also configure whether to send output to a physical port or to a file on the host system, set up a direct connection between two virtual machines, and specify whether the guest operating system uses the port in polled mode.

To configure serial port settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select the serial port.
### Serial Port Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the port while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the port when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use a physical serial port</td>
<td>Select a host serial port.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output from the virtual serial port to a file on the host system.</td>
</tr>
<tr>
<td>Use named pipe or Use socket (named pipe)</td>
<td>Set up a direct connection between two virtual machines or a connection between a virtual machine and an application on the host system. (Windows hosts) Use the default pipe name, or enter another pipe name. The pipe name must begin with <code>\., \pipe\</code> and must be the same on both the server and the client. For example: <code>\., \pipe\ namedpipe</code></td>
</tr>
<tr>
<td>Yield CPU on poll</td>
<td>The guest operating system uses the port in polled mode rather than interrupt mode. It yields processor time if its only task is to poll the virtual serial port. If the guest operating system uses the serial port in interrupt mode, do not select this setting. <strong>Note</strong> This setting is useful for developers who are using debugging tools that communicate over a serial connection. Selecting this setting can improve performance when the guest operating system uses the serial port in polled mode.</td>
</tr>
</tbody>
</table>

### Configuring Generic SCSI Device Settings

You can configure when a generic SCSI device is connected to a virtual machine, specify the physical SCSI device to connect to on the host system, and select the SCSI identifier to use for the drive.

To configure generic SCSI device settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select the generic SCSI device.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the device while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the device when you power on the virtual machine.</td>
</tr>
<tr>
<td>Specify the physical SCSI device to connect to</td>
<td>Select a host SCSI device. (Windows hosts) Select a device. The menu shows the SCSI devices that are available on the host system. (Linux hosts) Type the name of the <code>/dev/sd</code> entry for the device to install in the virtual machine. For example, if the device is named <code>sda</code>, type <code>/dev/sda</code>.</td>
</tr>
<tr>
<td>Virtual device node</td>
<td>Select the SCSI device identifier to use for the drive. For example, if you select SCSI 0:2, the guest operating system sees the drive as ID 2 on controller 0. The virtual machine must be powered off when you change this setting. <strong>Note</strong> For specific Windows guest operating systems, you might need to perform additional configuration steps to use a generic SCSI device.</td>
</tr>
</tbody>
</table>

**Note** For specific Windows guest operating systems, you might need to perform additional configuration steps to use a generic SCSI device.
Configuring Printer Settings

You can configure when a printer is connected to a virtual machine.

To configure printer settings for a selected virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select Printer.

Table 15-12. Printer Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the printer while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the printer when you power on the virtual machine.</td>
</tr>
</tbody>
</table>

Configuring Display Settings

You can specify monitor resolution settings, configure multiple monitors, and select accelerated graphics capabilities for a virtual machine.

To configure display settings for a virtual machine, select the virtual machine, select Player > Manage > Virtual Machine Settings, click the Hardware tab, and select Display.

Table 15-13. Display Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accelerate 3D graphics</td>
<td>Select this setting if you run applications that use DirectX 9 or DirectX 10 accelerated graphics. Accelerated graphics capabilities apply to Windows XP or later guests on hosts running Windows or Linux. The virtual machine must be a Player 3.x or later virtual machine and must have the latest VMware Tools installed.</td>
</tr>
<tr>
<td>Use host setting for monitors</td>
<td>When you select this setting, the SVGA driver uses two monitors, a maximum bounding box width of 3840, and a maximum bounding box height of 1920. The virtual machine is configured to have a minimum of two 1920x1200 monitors, in a side-by-side topology, in both normal and rotated orientations. If the host system has more than two monitors, the virtual machine uses the number of monitors on the host system instead. If the host system’s bounding box is wider or taller than the defaults, the virtual machine uses the larger size. You should select this setting in most cases.</td>
</tr>
<tr>
<td>Specify monitor settings</td>
<td>Set the number of monitors that the virtual machine will see, regardless of the number of monitors on the host system. This setting is useful if you use a multimonitor host system and you need to test in a virtual machine that has only one monitor. It is also useful if you are developing a multimonitor application in a virtual machine and the host system has only one monitor. After you power on the virtual machine, the guest operating system sees the number of monitors that you specified. Select a resolution from the list or type a setting that has the format width x height, where width and height are the number of pixels.</td>
</tr>
<tr>
<td>Graphics memory</td>
<td>Select the maximum amount of guest memory that can be used for graphics memory using the drop down menu. The default value of video memory varies by guest OS.</td>
</tr>
<tr>
<td>Display Scaling</td>
<td>Enables display scaling for the virtual machine display. The user interface is automatically adjusted when the display changes.</td>
</tr>
</tbody>
</table>
Installing a Guest Operating System on a Physical Disk or Unused Partition

You can install a guest operating system directly on a physical disk or unused partition on the host system. A physical disk directly accesses an existing local disk or partition. You can use physical disks to run one or more guest operating systems from existing disk partitions.

Workstation Player supports physical disks up to 2 TB capacity. Booting from an operating system already set up on an existing SCSI disk or partition is not supported.

Running an operating system natively on the host system and switching to running it inside a virtual machine is similar to pulling the hard drive out of one computer and installing it in a second computer that has a different motherboard and hardware. The steps you take depend on the guest operating system in the virtual machine. In most cases, a guest operating system that is installed on a physical disk or unused partition cannot boot outside of the virtual machine, even though the data is available to the host system. See the Dual-Boot Computers and Virtual Machines technical note on the VMware Web site for information about using an operating system that can also boot outside of a virtual machine.

After you configure a virtual machine to use one or more partitions on a physical disk, do not modify the partition tables by running fdisk or a similar utility in the guest operating system. If you use fdisk or a similar utility on the host operating system to modify the partition table of the physical disk, you must recreate the virtual machine physical disk. All files that were on the physical disk are lost when you modify the partition table.

**IMPORTANT** You cannot use a physical disk to share files between the host system and a guest operating system. Making the same partition visible to both the host system and a guest operating system can cause data corruption. Instead, use shared folder to share files between the host system and a guest operating system.
### Index

**A**
- accelerated 3D graphics
  - preparing a virtual machine 83
  - preparing the host system 82
  - using 82
- acceleration, disabling 88
- application shortcuts, creating in Unity mode 62
- Autologin 125
- Autologon, configuring 56
- automatic bridging settings 136

**B**
- bandwidth 137
- battery information 61
- bridged networking
  - assigning IP addresses 115
  - configuring 115

**C**
- CD-ROM drives
  - adding 89
  - configuring 89
  - configuring legacy emulation mode 91
  - configuring legacy emulation mode 91
- close behavior, configuring 57
- close behavior preference settings 25
- compatible virtual machines and system images 16
- configuring virtual machines 79
- copy and paste feature
  - restrictions 23
  - using 22
- copy virtual machine 84
- CPUs, host requirements 13
- Ctrl+Alt, using in a key combination 106
- Ctrl+Alt+Delete 55
- Ctrl+Alt+Ins 55

**D**
- deleting virtual machines 87
- devices, configuring and managing 89
- disk drives, host requirements 15
- disk node and mode settings 133
- display settings, configuring 59
- displays
  - changing 59
- changing settings 141
- host requirements 14
- drag-and-drop feature
  - restrictions 23
  - using 22
- DVD drives
  - adding 89
  - configuring 89
  - configuring legacy emulation mode 91

**E**
- Easy Install, responding to prompts 32, 36
- ECR errors, troubleshooting 99
- email collection 24
- encrypted virtual machines 54
- enhanced virtual keyboard, installing the driver 105

**F**
- floppy drives
  - adding 90
  - configuring 89
- FreeBSD guest operating system, VMware Tools installation or upgrade (tar installer) 49
- full screen mode 60

**G**
- general option settings 121
- generic SCSI devices
  - adding 102
  - configuring 101
  - troubleshooting detection problems 102
- glossary 11
- guest operating systems
  - changing 80, 122
  - installing manually 37
  - selecting 32
  - supported 16, 32

**H**
- hardware
  - adding to virtual machines 127
  - customizing 35
  - removing from virtual machines 129
- hardware settings, modifying 112
- host-only networks, configuring 116, 117
- host-only networking 137
human interface devices, connecting 67

I
IDE drives, host requirements 15
importing virtual machines 38
installation properties 21
installing 19
installing VMware Tools
FreeBSD (tar installer) 49
Linux (tar installer) 45
Microsoft Windows 44
NetWare (tar installer) 47
process overview 41
Solaris (tar installer) 48
installing Workstation Player
unattended installation on Windows host 20
Windows host 19
intended audience 11

K
key code mappings, configuring 108
key mappings, changing 107
keyboard features, configuring 104
keysyms
defined 107
mapping 108

L
LAN segments 137
license key 24
Linux guest, VMware Tools installation or upgrade (tar installer) 45
local area networking, host requirements 15
lock files 98

M
managing virtual machines 79
mapped drives 76, 132
maximum virtual disk size 34
memory
host requirements 14
virtual machine allocation 16
memory allocation, changing 81
memory settings 129
message log, viewing 87
Microsoft Windows guest operating system, VMware Tools installation or upgrade 44
monitor settings 141
monitors, using multiple 63
moving a virtual machines 84
moving virtual machines, considerations 85
multiple monitors 63
multiple monitors for one virtual machine 63
naming virtual machines 122
NAT, configuring 116, 136
NetWare guest operating system, VMware Tools installation or upgrade (tar installer) 47
network type of a virtual machine, finding 118
networking components, understanding 113
networking configurations
changing 118
common 114
New Virtual Machine wizard 31, 35

O
operating systems, host supported 14
optical drives supported in host 15
OVA format virtual machines 39
OVF format virtual machines 39

P
packet loss 137
parallel ports, configuring 98, 99
PDAs, installing drivers 67
physical disks 142
power options, configuring 123
printers
changing settings 141
using host printers in a virtual machine 65, 68
processors
configuring 129
host requirements 13
supported in virtual machines 16
using a virtual machine that has more than sixteen 104

R
RAM, host requirements 14
removable devices 65
removing virtual machines 24, 55
repairing VMware Tools installations 50
resetting a virtual machine 56

S
SATA drives 15
screen colors, setting for virtual machines 82
SCSI drives, host requirements 15
serial ports
changing the input speed 101
configuring 98, 100
shared folders
adding 71
changing 75
changing properties 75
configuring 73
disabling 76
mounting 74
supported guest operating systems 72
using 71
using permissions to restrict access 72
viewing in Windows 74
silent installation, Windows host 20
smart cards
disabling sharing 70
using in virtual machines 68, 69
software updates
automatic 27
configuring 26
configuring a proxy server 26
software update preferences, configuring 43
Solaris guest operating system, VMware Tools
installation or upgrade (tar installer) 48
solid-state drives 15
sound, configuring 81, 83, 84
sound cards 139
SSD 15
starting virtual machines 53
stopping virtual machines 53
suspending virtual machines 55
system data 27
system requirements, host system 13
T
tar installer 45
time synchronization 123
transferring files and text 22
U
unattended installation, installation properties 21
uninstalling, Windows host 24
uninstalling VMware Tools 50
Unity mode, setting preferences 62
Unity mode features 61
Unity mode options 124
updated information 7
upgrading VMware Tools
FreeBSD (tar installer) 49
Linux (tar installer) 45
Microsoft Windows 44
NetWare (tar installer) 47
process overview 42
Solaris (tar installer) 48
usage statistics 27
USB controller
adding 92
configuring 91
USB devices
connecting 66
disabling autoconnect 66
enabling high-speed support for USB 2.0 or 3.0 92
installing drivers 66
understanding device control sharing 67
USB controller settings 138
User Experience Improvement Program 28
UUIDs
configuring 87
using 86
V
v-scan codes 109
video, configuring 81
virtual disks
allocating disk space 34
changing settings 130
compacting 132
defragmenting 131
disconnecting from the host 77, 133
expanding 131
mapping and mounting 76, 132
SSD 15
virtual machines
changing names 79
configuring for compatibility 86
creating 31
deleting 87
installing software 88
moving 84
shutting down 54
specifications 16
starting 53
understanding 31
virtual networks, configuring 113
virtual appliances 24, 54
virtual disk
bus type 34
controller type 34
maximum size 34
optimize behavior 15
virtual disk capacity 34
virtual hard disks
adding 94, 95
compacting 96
configuring 93
defragmenting 97
expanding 96
growing and allocating storage space 94
moving 98
removing 97
setting up as IDE or SCSI 94
virtual machine directory, changing 80
virtual machine files, specifying in the New Virtual Machine wizard 33
virtual machine options 121
virtual machines directory 33
virtual network adapter, changing 119
virtual network adapters  
    adding 118  
    configuring 135  
    connection settings 135
virtual printing 26
virtual symmetric multiprocessing, configuring 103
VIX API 87
VMnet  
    virtual network 113  
    virtual switch 113
VMware Tools  
    configuring updates for virtual machines 123  
    installing 44  
    updating on a specific virtual machine 44  
    using 41
VMware Tools installation  
    FreeBSD (tar installer) 49  
    Linux (tar installer) 45  
    Microsoft Windows 44  
    NetWare (tar installer) 47  
    process 41  
    Solaris (tar installer) 48
VMware Tools upgrade  
    FreeBSD (tar installer) 49  
    Linux (tar installer) 45  
    Microsoft Windows 44  
    NetWare (tar installer) 47  
    process 42  
    Solaris (tar installer) 48
vmware-user, starting manually 50

W
Windows Virtual PC virtual machines 39  
Windows XP Mode virtual machine, importing 38
working directory, changing 80
working directory for virtual machine files 122
worksheet, typical virtual machine 35
Workstation Player, start 21
Workstation Player window 22
Workstation Player email collection 24
Workstation Player preference settings 25

X
X server and keyboard mapping 106
x-key codes, defined 107
xFree86 and keyboard mapping 106