Using VMware Workstation Pro

Workstation 12 Pro
VMware Workstation Pro 12.0
VMware Workstation Pro 12.1

This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.

EN-001870-02
You can find the most up-to-date technical documentation on the VMware Web site at:
http://www.vmware.com/support/
The VMware Web site also provides the latest product updates.
If you have comments about this documentation, submit your feedback to:
docfeedback@vmware.com
# Contents

Using VMware Workstation Pro  7

1  Updated Information  9

2  Introduction and System Requirements  13
   Host System Requirements for Workstation Pro  13
   Virtual Machine Features and Specifications  16

3  Installing and Using Workstation Pro  21
   Obtaining the Workstation Pro Software and License Key  21
   Installing Workstation Pro with Other VMware Products  22
   Reinstalling Workstation Pro When Upgrading a Windows Host Operating System  22
   Installing the Integrated Virtual Debuggers for Eclipse  23
   Installing Workstation Pro  23
   Upgrading Workstation Pro  28
   Uninstalling Workstation Pro  33
   Start Workstation Pro  34
   Using the Workstation Pro Window  34
   Using the Workstation Pro Online Help  38

4  Creating Virtual Machines  39
   Understanding Virtual Machines  39
   Preparing to Create a New Virtual Machine  40
   Create a New Virtual Machine on the Local Host  50
   Cloning Virtual Machines  54
   Virtualize a Physical Machine  57
   Importing Virtual Machines  59
   Installing and Upgrading VMware Tools  60
   Virtual Machine Files  71

5  Using Virtual Machines  73
   Starting Virtual Machines  73
   Stopping Virtual Machines  76
   Transferring Files and Text  80
   Add a Host Printer to a Virtual Machine  89
   Using Removable Devices in Virtual Machines  90
   Changing the Virtual Machine Display  96
   Using Folders to Manage Virtual Machines  102
   Taking Snapshots of Virtual Machines  105
   Install New Software in a Virtual Machine  111
   Take a Screenshot of a Virtual Machine  112
## 6 Configuring and Managing Virtual Machines
- Configure Power Options and Power Control Settings
- Set Workstation Pro Display Preferences
- Configure Display Settings for a Virtual Machine
- Set Preferences for Unity Mode
- Setting Screen Color Depth
- Using Advanced Linux Sound Architecture
- Encrypting and Restricting Virtual Machines
- Moving Virtual Machines
- Configure a Virtual Machine as a VNC Server
- Change the Hardware Compatibility of a Virtual Machine
- Clean Up a Virtual Hard Disk on Windows Hosts
- Export a Virtual Machine to OVF Format
- Writing and Debugging Applications That Run In Virtual Machines

## 7 VMware Workstation Server Log Files

## 8 Configuring and Managing Devices
- Configuring DVD, CD-ROM, and Floppy Drives
- Configuring a USB Controller
- Configuring and Maintaining Virtual Hard Disks
- Adding a Physical Disk to a Virtual Machine
- Configuring Virtual Ports
- Configuring Generic SCSI Devices
- Configuring Sixteen-Way Virtual Symmetric Multiprocessing
- Configuring Keyboard Features
- Modify Hardware Settings for a Virtual Machine

## 9 Configuring Network Connections
- Understanding Virtual Networking Components
- Understanding Common Networking Configurations
- Changing the Default Networking Configuration
- Configuring Bridged Networking
- Configuring Network Address Translation
- Configuring Host-Only Networking
- Assigning IP Addresses in Host-Only Networks and NAT Configurations
- Configuring LAN Segments
- Configuring Samba for Workstation Pro
- Using Virtual Network Adapters in Promiscuous Mode on Linux Hosts
- Maintaining and Changing MAC Addresses for Virtual Machines
- Sample Custom Networking Configuration

## 10 Using Remote Connections and Sharing Virtual Machines
- Understanding VMware Workstation Server
- Connect to a Remote Server
- Disconnect from a Remote Server
Creating and Managing Shared Virtual Machines  216
Uploading Virtual Machines to Remote Servers  219
Download a Virtual Machine from a Remote Server  221
Create a Virtual Machine on a Remote Host  222
Configure Shared and Remote Virtual Machines to Start with the Host  223
Using Roles to Assign Privileges  224
Using Permissions to Restrict Users  227

11 Changing Workstation Pro Preference Settings  231
   Configuring Workspace Preference Settings  231
   Configuring Input Preference Settings  234
   Changing Hot-Key Combinations  236
   Configuring Workstation Pro Display Preference Settings  236
   Configuring Software Update Preference Settings  238
   Sending System Data and Usage Statistics to VMware  240
   Changing Shared Virtual Machine Preference Settings  241
   Configuring Workstation Pro Memory Preference Settings  242
   Configuring Workstation Pro Priority Preference Settings  243
   Configuring Device Settings for Windows Hosts  244

12 Configuring Virtual Machine Option Settings  247
   Configuring General Option Settings for a Virtual Machine  247
   Configuring Power Settings for a Virtual Machine  249
   Configuring Snapshot Options for a Virtual Machine  250
   Configuring AutoProtect Options for a Virtual Machine  251
   Configuring Guest Isolation Options for a Virtual Machine  252
   Configuring Tablet Sensor Input Options for a Virtual Machine  252
   Configuring VMware Tools Options for a Virtual Machine  253
   Configuring a Virtual Machine as a VNC Server  254
   Configuring Unity Mode for a Virtual Machine  254
   Configuring Appliance Details for a Virtual Machine  255
   Configuring Autologin for a Virtual Machine  255
   Configuring Advanced Options for a Virtual Machine  256

13 Configuring Virtual Machine Hardware Settings  259
   Adding Hardware to a Virtual Machine  259
   Removing Hardware from a Virtual Machine  261
   Adjusting Virtual Machine Memory  261
   Configuring Virtual Machine Processor Settings  261
   Configuring and Maintaining Virtual Hard Disks  262
   Configuring CD-ROM and DVD Drive Settings  264
   Configuring Floppy Drive Settings  266
   Configuring Virtual Network Adapter Settings  266
   Configuring USB Controller Settings  270
   Configuring Sound Card Settings  271
   Configuring Parallel Port Settings  271
   Configuring Serial Port Settings  271
   Configuring Generic SCSI Device Settings  272
14 Using the Virtual Network Editor 275
   Add a Bridged Virtual Network 276
   Add a Host-Only Virtual Network 277
   Change Automatic Bridging Settings 278
   Change NAT Settings 278
   Change DHCP Settings on a Windows Host 280

15 Running the Support Script 281
   Register and Create a Support Request 281
   Run the Support Script from Workstation Pro 282
   Run the Support Script from a Windows Command Prompt 282
   Run the Support Script from a Linux Terminal Window 283

16 Using the vmware Command 285
   Run the vmware Command 285
   Incorporate Workstation Pro Startup Options in a Windows Shortcut 286

Index 287
Using VMware Workstation Pro

*Using VMware Workstation Pro* describes how to use VMware Workstation Pro™ to create, configure, and manage virtual machines.

**Intended Audience**

This information is intended for anyone who wants to install, upgrade, or use Workstation Pro. The information is written for experienced Windows or Linux system administrators who are familiar with virtual machine technology and datacenter operations.
Using VMware Workstation Pro is updated with each release of the product or when necessary. This table provides the update history of Using VMware Workstation Pro.
<table>
<thead>
<tr>
<th>Revision</th>
<th>Description</th>
</tr>
</thead>
</table>
| EN-001870-02     | - Updated “Supported Guest Operating Systems,” on page 16 to add a link to the VMware Compatibility Guide site.  
                   - Updated “Virtual Machine Processor Support,” on page 16 to reflect the supported functionality.  
                   - Updated “Install Workstation Pro on a Windows Host,” on page 23 to remove a procedure step no longer supported.  
                   - Updated “Run an Unattended Workstation Pro Installation on a Windows Host,” on page 24 to reflect the supported functionality.  
                   - Updated “Installation Properties,” on page 25 to remove parameters no longer supported.  
                   - Removed “REMOVE Property Values.”  
                   - Updated “Install Workstation Pro on a Linux Host,” on page 26 to add a statement to use your regular user name, not root, to log in when Workstation Pro starts.  
                   - Updated the option examples in “Linux Command Line Installation Options,” on page 27.  
                   - Updated “Upgrade Workstation Pro on a Windows Host,” on page 29 to remove a procedure step no longer supported.  
                   - Moved the location of “Worksheet for Creating a Virtual Machine,” on page 40.  
                   - Added “Selecting the Firmware Type,” on page 43.  
                   - Updated “Virtualize a Physical Machine,” on page 57 to add a note stating that you can use vCenter Converter Standalone to virtualize a Linux physical machine.  
                   - Corrected the procedure in “Import a Windows XP Mode Virtual Machine,” on page 59 to reflect the supported functionality.  
                   - Updated “Add a Host Printer to a Virtual Machine,” on page 89 to add a prerequisite that the virtual machine must be powered on or off before adding a printer.  
                   - Updated “Connecting USB Devices to Virtual Machines,” on page 90 to add a statement for how to manually connect a USB device to a virtual machine.  
                   - Updated the global configuration file location in “Disable Smart Card Sharing,” on page 95.  
                   - Corrected the procedure in “Use Multiple Monitors for One Virtual Machine,” on page 99 to reflect the supported functionality.  
                   - Added the Combine tabs with toolbar in full screen option to “Set Workstation Pro Display Preferences,” on page 117.  
                   - Updated “Move a Virtual Machine to a New Location or Host,” on page 128 to clarify what virtual machine files must be moved.  
                   - Updated “Limitations of Moving a Virtual Machine to a Different Host,” on page 129 to reflect the supported functionality.  
                   - Updated step 12 in “Add a New Virtual Hard Disk to a Virtual Machine,” on page 149 to add examples of guest operating system tools used to partition and format the new drive.  
                   - Updated “Expand a Virtual Hard Disk,” on page 151 to provide information on how to determine whether a virtual machine is a linked clone or the parent of a linked clone. |
<table>
<thead>
<tr>
<th>Revision</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Changed &quot;Configuring</td>
<td>Changed &quot;Configuring Eight-Way Symmetric Multiprocessing&quot; to &quot;Configuring Sixteen-Way Virtual</td>
</tr>
<tr>
<td>&quot;Configuring Eight-Way</td>
<td>Symmetric Multiprocessing,&quot; on page 163 to reflect the supported functionality.</td>
</tr>
<tr>
<td>&quot;Configuring Sixteen-</td>
<td>Changed &quot;Configure Eight-way Symmetric Multiprocessing&quot; to &quot;Configure Sixteen-Way Virtual</td>
</tr>
<tr>
<td>Way Virtual Symmetric</td>
<td>Symmetric Multiprocessing,&quot; on page 163 to reflect the supported functionality.</td>
</tr>
<tr>
<td>Multiprocessing&quot; to</td>
<td>Changed &quot;Use a Virtual Machine That Has More Than Eight Virtual Processors&quot; to &quot;Use a Virtual</td>
</tr>
<tr>
<td>&quot;Use a Virtual Machine</td>
<td>Machine That Has More Than Sixteen Virtual Processors,&quot; on page 164 to reflect the supported</td>
</tr>
<tr>
<td>That Has More Than</td>
<td>functionality.</td>
</tr>
<tr>
<td>Eight Virtual Processors</td>
<td>Updated &quot;Add a Virtual Network Adapter to a Virtual Machine,&quot; on page 178 to reflect the</td>
</tr>
<tr>
<td></td>
<td>options available in the product.</td>
</tr>
<tr>
<td></td>
<td>Added a statement to “Configuring Workstation Pro Display Preference Settings,” on page 236 that</td>
</tr>
<tr>
<td></td>
<td>&quot;If you are using Windows 8.1 (Update 2) or Windows 10, Workstation Pro detects the DPI on each</td>
</tr>
<tr>
<td></td>
<td>monitor and scales the virtual machine to machine the DPI on the host.</td>
</tr>
<tr>
<td></td>
<td>Added a note to “Removing Hardware from a Virtual Machine,” on page 261 stating that you cannot</td>
</tr>
<tr>
<td></td>
<td>remove hardware from a virtual machine while it is in suspended state.</td>
</tr>
<tr>
<td></td>
<td>Removed references to deprecated guest operating systems in the document.</td>
</tr>
<tr>
<td></td>
<td>Added support for Windows Server 2012 R2 as a host.</td>
</tr>
<tr>
<td></td>
<td>Removed requirement in “Processor Requirements for Host Systems,” on page 13 for &quot;LAHF/SAHF</td>
</tr>
<tr>
<td></td>
<td>support in long mode&quot;. This requirement applies only to older 64-bit CPUs produced before 2006.</td>
</tr>
<tr>
<td></td>
<td>Updated “Virtual Machine Graphics and Keyboard Support,” on page 16 to add a statement clarifying</td>
</tr>
<tr>
<td></td>
<td>OpenGL3.3 support.</td>
</tr>
<tr>
<td></td>
<td>Updated “Installation Properties,” on page 25 to fix the example for the SERIALNUMBER property.</td>
</tr>
<tr>
<td></td>
<td>Added “Enable EFI Support,” on page 76.</td>
</tr>
<tr>
<td></td>
<td>Updated “Guest Operating Systems That Support Shared Folders,” on page 83 to reflect supported</td>
</tr>
<tr>
<td></td>
<td>guest operating systems.</td>
</tr>
<tr>
<td></td>
<td>Updated “Configure Display Settings for a Virtual Machine,” on page 118 to add the Display</td>
</tr>
<tr>
<td></td>
<td>Scaling option.</td>
</tr>
<tr>
<td></td>
<td>Updated “Prepare the Host System to Use 3D Accelerated Graphics,” on page 119 to add a statement</td>
</tr>
<tr>
<td></td>
<td>clarifying OpenGL3.3 support.</td>
</tr>
<tr>
<td></td>
<td>Updated the existing section “Changing NAT Settings on a Windows Host” to “Change NAT Settings,”</td>
</tr>
<tr>
<td></td>
<td>on page 186 to add support for NAT on Linux hosts.</td>
</tr>
<tr>
<td></td>
<td>Removed a note in “Upload a Virtual Machine to VMware vCloud Air,” on page 221 stating that only</td>
</tr>
<tr>
<td></td>
<td>Windows virtual machines can be uploaded to VMware vCloud Air.</td>
</tr>
<tr>
<td>EN-001870-01</td>
<td></td>
</tr>
<tr>
<td>Revision</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>Updated “Configuring Snapshot Options for a Virtual Machine,” on page 250 to add the Take a new Snapshot option. This option was removed in Workstation Pro 12.0 and restored in Workstation Pro 12.0.1.</td>
</tr>
<tr>
<td></td>
<td>Corrected an error in “Configuring AutoProtect Options for a Virtual Machine,” on page 251. The statement in the previous version, “AutoProtect snapshots are not taken in Workstation Pro, even if AutoProtect is enabled for the virtual machine in Workstation Pro,” is incorrect. The statement should read “AutoProtect snapshots are not taken in Workstation Player, even if AutoProtect is enabled for the virtual machine in Workstation Pro”</td>
</tr>
<tr>
<td></td>
<td>Updated “Gathering Debugging Information,” on page 256 to add the Gather verbose USB debugging information option.</td>
</tr>
<tr>
<td></td>
<td>Renamed the “Configuring Memory Page Trimming and Template Mode” section to “Configuring Advanced Settings for a Virtual Machine,” on page 257 and added the Boot from EFI Instead of BIOS option.</td>
</tr>
<tr>
<td></td>
<td>Updated “Change Automatic Bridging Settings,” on page 278 to add support for NAT on Linux hosts. Support for this feature was added in Workstation Pro 12.0.</td>
</tr>
<tr>
<td></td>
<td>Updated the “Changing DHCP Settings on a Windows Host” section to “Change DHCP Settings on a Windows Host,” on page 280.</td>
</tr>
</tbody>
</table>

EN-001870-00 Initial release.
Introduction and System Requirements

Host computers that run Workstation Pro must meet specific hardware and software requirements. Virtual machines that run in Workstation Pro support specific devices and provide certain features.

This chapter includes the following topics:

- “Host System Requirements for Workstation Pro,” on page 13
- “Virtual Machine Features and Specifications,” on page 16

Host System Requirements for Workstation Pro

The physical computer on which you install Workstation Pro is called the host system and its operating system is called the host operating system. To run Workstation Pro, the host system and the host operating system must meet specific hardware and software requirements.

Processor Requirements for Host Systems

You must install Workstation Pro on a host system that meets certain processor requirements.

Supported Processors

The host system must have a 64-bit x86 CPU with 1.3 GHz or faster core speed. Multiprocessor systems are supported.

When you install Workstation Pro, the installer performs checks to make sure the host system has a supported processor. You cannot install Workstation Pro if the host system does not meet the processor requirements.

Processor Requirements for 64-Bit Guest Operating Systems

The operating system that runs inside a virtual machine is called the guest operating system. To run 64-bit guest operating systems, the host system must have one of the following processors.

- An AMD CPU that has segment-limit support in long mode
- An Intel CPU that has VT-x support

If you have an Intel CPU that has VT-x support, you must verify that VT-x support is enabled in the host system BIOS. The BIOS settings that must be enabled for VT-x support vary depending on the system vendor. See the VMware knowledge base article at http://kb.vmware.com/kb/1003944 for information about how to determine if VT-x support is enabled.

When you install a 64-bit operating system, Workstation Pro performs checks to make sure the host system has a supported processor. You cannot install a 64-bit operating system if the host system does not meet the processor requirements.
Processor Requirements for Windows 7 Aero Graphics

To support Windows 7 Aero graphics, the host system should have either an Intel Dual Core 2.2 GHz or later CPU or an AMD Athlon 4200+ or later CPU.

Supported Host Operating Systems

You can install Workstation Pro on Windows and Linux host operating systems.

To see a list of the supported host operating systems, search the online VMware Compatibility Guide on the VMware Web site.

Memory Requirements for Host Systems

The host system must have enough memory to run the host operating system, the guest operating systems that run inside the virtual machines on the host system, and the applications that run in the host and guest operating systems.

The minimum memory required on the host system is 1 GB. 2 GB and above is recommended.

To support Windows 7 Aero graphics in a virtual machine, at least 3 GB of host system memory is required. 1 GB of memory is allocated to the guest operating system and 256 MB is allocated to graphics memory.

See your guest operating system and application documentation for more information on memory requirements.

Display Requirements for Host Systems

The host system must have a 16-bit or 32-bit display adapter. Use the latest graphics driver recommended for the host system.

To support Windows 7 Aero graphics, the host system should have either an NVIDIA GeForce 8800GT or later or an ATI Radeon HD 2600 or later graphics processor.

**IMPORTANT** 3D benchmarks, such as 3DMark ’06, might not render correctly or at all when running Windows Vista or Windows 7 virtual machines on some graphics hardware.
**Disk Drive Requirements for Host Systems**

Host systems must meet certain disk drive requirements. Guest operating systems can reside on physical disk partitions or in virtual disk files.

**Table 2-1. Disk Drive Requirements for Host Systems**

<table>
<thead>
<tr>
<th>Drive Type</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hard disk</td>
<td></td>
</tr>
</tbody>
</table>
|                       | - IDE, SATA, and SCSI hard drives are supported.  
|                       | - At least 1 GB free disk space is recommended for each guest operating system and the application software used with it. If you use a default setup, the actual disk space needs are approximately the same as those for installing and running the guest operating system and applications on a physical computer.  
|                       | - For basic installation, 1.5 GB free disk space is required on Windows and Linux. You can delete the installer after the installation is complete to reclaim disk space.  
| Optical CD-ROM and DVD|  
|                       | - IDE, SATA, and SCSI optical drives are supported.  
|                       | - CD-ROM and DVD drives are supported.  
|                       | - ISO disk image files are supported.  
| Floppy                | Virtual machines can connect to disk drives on the host computer. Floppy disk image files are also supported.  

**Solid-State Drives**

If your host machine has a physical solid-state drive (SSD), the host informs guest operating systems they are running on an SSD.

This allows the guest operating systems to optimize behavior. How the virtual machines recognize SSD and use this information depends on the guest operating system and the disk type of the virtual disk (SCSI, SATA, or IDE).

- On Windows 8, Windows 10, Ubuntu, and Red Hat Enterprise Linux virtual machines, all drive types can report their virtual disks as SSD drives.
- On Windows 7 virtual machines, only IDE and SATA virtual disks can report their virtual disks as SSD. SCSI virtual disks only report as SSD when used as a system drive in a virtual machine, or as a mechanical drive when used as a data drive inside a virtual machine.
- On Mac virtual machines, only SATA virtual disks are reported as SSD. IDE and SCSI virtual disks are reported as mechanical drives.

Use the virtual machine operating system to verify your virtual machine is using SSD as its virtual disk.

**Local Area Networking Requirements for Host Systems**

You can use any Ethernet controller that the host operating system supports.

Non-Ethernet networks are supported by using built-in network address translation (NAT) or by using a combination of host-only networking and routing software on the host operating system.

**ALSA Requirements**

To use ALSA in a virtual machine, the host system must meet certain requirements.

- The ALSA library version on the host system must be version 1.0.16 or later.
- The sound card on the host system must support ALSA. The ALSA project Web site maintains a current listing of sound cards and chipsets that support ALSA.
The sound device on the host system must not be muted.

The current user must have the appropriate permissions to use the sound device.

Virtual Machine Features and Specifications

Workstation Pro virtual machines support specific devices and provide certain features.

Supported Guest Operating Systems

A guest operating system can be Windows, Linux, and other commonly used operating systems.

For the most recent list of guest operating systems that VMware products support, see the VMware Compatibility Guide site: http://www.vmware.com/resources/compatibility/search.php.

For instructions about how to install the most common guest operating systems, see the VMware Guest Operating System Installation Guide: http://partnerweb.vmware.com/GOSIG/home.html.

Virtual Machine Processor Support

Virtual machines support certain processor features.

- The same as the processor on the host computer.
- One virtual processor on a host system that has one or more logical processors.
- Up to 16 virtual processors (sixteen-way virtual symmetric multiprocessing, or Virtual SMP) on a host system that has at least 2 logical processors.

Note: Workstation Pro considers multiprocessor hosts that have 2 or more physical CPUs, single-processor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading enabled, to have two logical processors.

Virtual Machine Chip Set and BIOS Support

Virtual machines support certain virtual machine chip set and BIOS features.

- Intel 440BX-based motherboard
- NS338 SIO chip set
- 82093AA I/O Advanced Programmable Controller (I/O APIC)
- Phoenix BIOS 4.0 Release 6 with VESA BIOS

Virtual Machine Memory Allocation

The total amount of memory that you can assign to all virtual machines running on a single host system is limited only by the amount of RAM on the host.

On 64-bit hosts, the maximum amount of memory for each virtual machine is 64GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. Workstation Pro prevents powering on virtual machines that are configured to use more than 8GB of memory on 32-bit hosts. Memory management limitations on 32-bit operating systems cause virtual machine memory to overcommit, which severely affects system performance.

Virtual Machine Graphics and Keyboard Support

Virtual machines support certain graphics features.

- VGA and SVGA are supported.
- 104-key Windows 95/98 enhanced keyboards are supported.
- To use the GL_EXT_texture_compression_s3tc and GL_S3_s3tc Open Graphics Library (OpenGL) extensions in a Windows XP or Windows 7 or later guest operating system, you must install Microsoft DirectX End-User Runtime in the guest operating system. OpenGL is an API that is used to define 2D and 3D computer graphics. You can download Microsoft DirectX End-User Runtime from the Microsoft Download Center Web site.

The VMware guest operating system OpenGL driver for Windows and Linux supports the OpenGL 3.3 core profile only. The OpenGL3.3 compatibility profile is not supported.

**Virtual Machine IDE Drive Support**

Virtual machines support certain IDE drives and features.
- Up to four devices, including disk, CD-ROM, and DVD drives, are supported.
- DVD drives can be used to read data DVD discs only.
- DVD video is not supported.
- Hard disks can be virtual disks or physical disks.
- IDE virtual disks can be up to 8TB.
- CD-ROM drives can be physical devices or ISO image files.

**Virtual Machine SCSI Device Support**

Virtual machines support certain SCSI devices and features.
- Up to 60 devices are supported.
- SCSI virtual disks can be up to 8TB.
- Hard disks can be virtual disks or physical disks.
- With Generic SCSI support, you can use devices in a virtual machine without installing drivers in the host operating system. Generic SCSI support works with scanners, CD-ROM drives, DVD drives, tape drives, and other SCSI devices.
- The LSI Logic LSI53C10xx Ultra320 SCSI I/O controller is supported.

**Virtual Machine Floppy Drive Support**

Virtual machines can have floppy drives.
- Up to two 2.88MB floppy devices are supported.
- Floppy drives can be physical drives or floppy image files.

**Virtual Machine Serial and Parallel Port Support**

Virtual machines support serial (COM) and parallel (LPT) ports.
- Up to four serial (COM) ports are supported. Output can be sent to serial ports, Windows or Linux files, or named pipes.
- Up to three bidirectional parallel (LPT) ports. Output can be sent to parallel ports or host operating system files.
Virtual Machine USB Port Support

Virtual machines can have USB ports and can support certain USB devices.

- USB 1.1 UHCI (Universal Host Controller Interface) is supported for all virtual machine hardware versions.
- USB 2.0 EHCI (Enhanced Host Controller Interface) controllers are supported if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.
- USB 3.0 xHCI (Extensible Host Controller Interface) support is available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 and later virtual machines.
- Support for USB 2.0 and 3.0 requires that you configure virtual machine settings to enable USB 2.0 and 3.0 support and that you have compatible guest operating systems and virtual machine hardware versions.
- Most USB devices are supported, including USB printers, scanners, PDAs, hard disk drives, memory card readers, and digital cameras. Streaming devices, such as webcams, speakers, and microphones, are also supported.

Virtual Machine Mouse and Drawing Tablet Support

Virtual machines support certain types of mice and drawing tablets.

- PS/2 and USB mouse types are supported.
- Serial tablets are supported.
- USB tablets are supported.

Virtual Machine Ethernet Card Support

Virtual machines support certain types of Ethernet cards.

- Up to 10 virtual Ethernet cards are supported.
- The AMD PCnet-PCI II Ethernet Adapter is supported. For 64-bit guests, the Intel Pro/1000 MT Server Adapter is also supported.

Virtual Machine Networking Support

Virtual machines support certain Ethernet switches and networking protocols.

- Up to 10 virtual Ethernet switches are supported on Windows host operating systems. Up to 255 virtual Ethernet switches are supported on Linux host operating systems.
- Three switches are configured by default for bridged, host-only, and NAT networking.
- Most Ethernet-based protocols are supported, including TCP/IP, NetBEUI, Microsoft Networking, Samba, Novell NetWare, and Network File System (NFS).
- Built-in NAT networking supports client software that uses TCP/IP, FTP, DNS, HTTP, and Telnet. VPN is supported for PPTP over NAT.

Virtual Machine Sound Support

Workstation Pro provides a sound device that is compatible with the Sound Blaster AudioPCI and Intel High-Definition Audio Specification. The Workstation Pro sound device is enabled by default.

Workstation Pro supports sound in all supported Windows and Linux guest operating systems.
Sound support includes pulse code modulation (PCM) output and input. You can play .wav files, MP3 audio, and Real Media audio. MIDI output from Windows guest operating systems is supported by the Windows software synthesizer. MIDI input is not supported, and no MIDI support is available for Linux guest operating systems.

Windows XP, Windows Vista, Windows 7 and most recent Linux distributions detect the sound device and install appropriate drivers for it.


For Workstation 8.x and later virtual machines, the High-Definition Audio (HD Audio) device is presented by default for both 64-bit and 32-bit Windows Vista and Windows 7 guest operating systems and their server counterparts. Windows provides a driver for HD Audio that is not part of VMware Tools.

On Linux host systems, Workstation 7.x and later supports Advanced Linux Sound Architecture (ALSA). Earlier versions of Workstation use the Open Sound System (OSS) interface for sound playback and recording in virtual machines running on Linux host systems. Unlike OSS, ALSA does not require exclusive access to the sound device. The host system and multiple virtual machines can play sound at the same time.
You can install Workstation Pro on a Linux or Windows host system. Installing or upgrading Workstation Pro typically involves running a standard GUI wizard.

This chapter includes the following topics:

- “Obtaining the Workstation Pro Software and License Key,” on page 21
- “Installing Workstation Pro with Other VMware Products,” on page 22
- “Reinstalling Workstation Pro When Upgrading a Windows Host Operating System,” on page 22
- “Installing the Integrated Virtual Debuggers for Eclipse,” on page 23
- “Installing Workstation Pro,” on page 23
- “Upgrading Workstation Pro,” on page 28
- “Uninstalling Workstation Pro,” on page 33
- “Start Workstation Pro,” on page 34
- “Using the Workstation Pro Window,” on page 34
- “Using the Workstation Pro Online Help,” on page 38

### Obtaining the Workstation Pro Software and License Key

The Workstation Pro installation software is in the file that you downloaded and the license key is sent to you in email.

The installation files for both host platforms are included in the packaged distribution. You can use the license key on both the Windows and Linux versions of Workstation Pro. You need one license for each host system.

If you do not enter the Workstation Pro license key during installation, you can specify the license key later, in Workstation Pro, select **Help > Enter License Key** and enter the license key on the Workstation Activation dialog box. You can also purchase a license key and view the status of an evaluation license from the Workstation Activation dialog box.

See the VMware Web site for information on obtaining an evaluation license.

**Note** If you have an invalid license, Workstation Pro prompts you to enter a license key each time you attempt to power on a virtual machine.
Once you have installed Workstation Pro, you can find your license key in the About VMware Workstation Pro window. Click Help > About VMware Workstation Pro.

- If you have an individual license for Workstation Pro, the key is displayed in the License Information section under Type. It is labeled Individual and followed by your license key.
- If you have a version of Workstation Pro licensed for multiple users, the Type field displays Volume and your license key is not displayed.
- If you did not enter a license for Workstation Pro, the Type field displays Not applicable and a license key is not displayed.
- If you have an evaluation license key for Workstation Pro, the Type field displays Not applicable. The date the evaluation license key expires is also displayed.

**Trial Version Expiration Date Warnings**

When you use the trial version of VMware Workstation Pro, a notice appears on the home page advising you of the trial license expiration date.

To purchase a license key click, click Get a license key. If you have a license key, click Enter a license key. You can also go to the Help menu and click Enter a license key.

**Installing Workstation Pro with Other VMware Products**

The only VMware products that can share a host system with Workstation Pro are VMware vSphere Client and VMware vCenter Converter Standalone. You cannot install Workstation Pro on a host system that has any other VMware virtualization products installed.

If the host system has another VMware virtualization product installed, you must uninstall that product before you install Workstation Pro.

**Reinstalling Workstation Pro When Upgrading a Windows Host Operating System**

Before you upgrade the operating system on a Microsoft Windows host, VMware recommends that you uninstall VMware Workstation Pro.

The way Workstation Pro is installed and configured depends partly on the version of Windows used. As a best practice, to ensure that Workstation Pro is properly configured for a new operating system, you must remove the Workstation Pro application before you perform the operating system upgrade. Uninstalling Workstation Pro guarantees that legacy components that apply only to older versions of Windows are not left behind.

For example, if you do not uninstall Workstation Pro before upgrading the Windows operating system, some virtual network adapters might not function properly after the operating system upgrade. Before you uninstall Workstation Pro, open the virtual network editor and note the settings used. You must configure these settings again after you reinstall Workstation Pro.

When you uninstall Workstation Pro, you need only uninstall the Workstation Pro application, not the virtual machines that you have created. When the operating system upgrade is complete, reinstall Workstation Pro or, if you are also upgrading Workstation Pro, install the new version of Workstation Pro.
Installing the Integrated Virtual Debuggers for Eclipse

If you plan to use the Integrated Virtual Debugger for Eclipse, you should install it on the host system before you install Workstation Pro.

If you must install the Integrated Virtual Debugger for Eclipse after you install Workstation Pro, run the Workstation Pro installer again and select Modify/Change to install the associated Workstation Pro plug-ins.

See the Integrated Virtual Debugger for Eclipse Developer’s Guide for host system requirements and supported operating systems. This guide is available on the VMware Web site.

Installing Workstation Pro

You can install Workstation Pro on a Windows host system by running the installation wizard or by using the unattended installation feature of the Microsoft Windows Installer (MSI). The MSI unattended installation feature is useful if you are installing Workstation Pro on several Windows hosts and do not want to respond to wizard prompts. You install Workstation Pro on a Linux host system by running the Workstation Pro bundle installer.

- **Install Workstation Pro on a Windows Host** on page 23
  You run the Windows setup program and installation wizard to install Workstation Pro on a Windows host system.

- **Run an Unattended Workstation Pro Installation on a Windows Host** on page 24
  You can use the unattended installation feature of the Microsoft Windows Installer (MSI) to install Workstation Pro on Windows host systems without having to respond to wizard prompts. This feature is convenient in a large enterprise.

- **Install Workstation Pro on a Linux Host** on page 26
  You run the Linux bundle installer to install Workstation Pro on a Linux host system. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the --console option to install Workstation Pro in a terminal window.

Install Workstation Pro on a Windows Host

You run the Windows setup program and installation wizard to install Workstation Pro on a Windows host system.

Remote connections and virtual machine sharing are enabled by default when you install Workstation Pro. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation Pro can access remotely.

**Prerequisites**

- Verify that the host system meets the host system requirements. See “Host System Requirements for Workstation Pro,” on page 13.

- Verify that you have administrative privileges on the host system.

- Verify that no incompatible VMware products are installed on the host system. See “Installing Workstation Pro with Other VMware Products,” on page 22.

- Obtain the Workstation Pro software and license key. See “Obtaining the Workstation Pro Software and License Key,” on page 21.
If you plan to use the Integrated Virtual Debugger for Eclipse, install it on the host system. See “Installing the Integrated Virtual Debuggers for Eclipse,” on page 23.

Procedure

1. Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   If you log in to a domain, the domain account must also be a local administrator.

2. Double-click the `VMware-workstation-xxxx-xxxxxxx.exe` file, where `xxxx-xxxxxxx` is the version and build numbers.

3. Follow the prompts to finish the installation.
   Depending on your configuration, you might need to restart the host system to finish the installation.

After Workstation Pro is installed, the VMware Workstation Server service starts on the host system. The VMware Workstation Server service starts whenever you restart the host system.

Run an Unattended Workstation Pro Installation on a Windows Host

You can use the unattended installation feature of the Microsoft Windows Installer (MSI) to install Workstation Pro on Windows host systems without having to respond to wizard prompts. This feature is convenient in a large enterprise.

Prerequisites

- Verify that the host system meets the host system requirements. See “Host System Requirements for Workstation Pro,” on page 13.
- Verify that no incompatible VMware products are installed on the host system. See “Installing Workstation Pro with Other VMware Products,” on page 22.
- Obtain the Workstation Pro software and license key. See “Obtaining the Workstation Pro Software and License Key,” on page 21.
- If you plan to use the Integrated Virtual Debugger for Eclipse, install it on the host system. See “Installing the Integrated Virtual Debuggers for Eclipse,” on page 23.
- Verify that the host computer has version 2.0 or later of the MSI runtime engine. This version of the installer is available in versions of Windows beginning with Windows XP and is available from Microsoft. For more information, see the Microsoft Web site.
- Familiarize yourself with the installation properties. See “Installation Properties,” on page 25.

Procedure

1. Log in to the host system as the Administrator user or as a user who is a member of the local Administrators group.
   If you log in to the domain, the domain account must also be a local administrator.

2. Extract the administrative installation image from the setup file.
   The setup filename is similar to `VMware-workstation-xxxx-xxxx.exe` where `xxxx-xxxx` is the version and build number.
   For example, if you enter `setup.exe/?`, the flag displays a windows message box with the command line usage for the installer.
3 Enter the installation command on one line.

The following example installs Workstation Pro:

```
VMware-workstation-full-x.x.x-xxxxxx.exe /s /v/qn EULAS_AGREED=1 SERIALNUMBER=“xxxxx-xxxxx-xxxxx-xxxxx-xxxxx” AUTOSOFTWAREUPDATE=1
```

You can use the optional INSTALLDIR property to specify a file path for the installation that is different from the default location.

**Note** The double quotes around the file path are important. All the MSI arguments are passed with the /v option. The outer quotes group the MSI arguments and the double quotes put a quote in that argument.

You can also run an unattended uninstallation of Workstation Pro on a Windows host. The following example uninstalls Workstation Pro and removes the license from the host.

```
VMware-workstation-full-x.x.x-xxxxxx.exe /s /v”/qn REMOVE=ALL”
```

### Installation Properties

When you perform an unattended installation of Workstation Pro, you can customize the installation by specifying installation properties in the installation command.

To specify an installation property in the installation command, use the format `property=“value”`. A value of 1 means true and a value of 0 means false.

**Table 3-1. Installation Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOSOFTWAREUPDATE</td>
<td>Enables automatic upgrades for Workstation Pro or Workstation Player when a new build becomes available.</td>
<td>1</td>
</tr>
<tr>
<td>DATACOLLECTION</td>
<td>Sends user experience information to VMware.</td>
<td>1</td>
</tr>
<tr>
<td>DESKTOP_SHORTCUT</td>
<td>Adds a shortcut on the desktop when Workstation Pro is installed.</td>
<td>1</td>
</tr>
<tr>
<td>ENABLE_VIRTUAL_PRINTING</td>
<td>Enables support for ThinPrint virtual printing on the Windows host after installing.</td>
<td>0</td>
</tr>
<tr>
<td>EULAS_AGREED</td>
<td>Allows you to silently accept the product EULAs. Set to 1 to complete the installation or upgrade.</td>
<td>0</td>
</tr>
<tr>
<td>INSTALLDIR</td>
<td>Install Workstation Pro in a directory that is different from the default Workstation Pro location.</td>
<td>C:\Program Files (86)\VMware\VMware Workstation</td>
</tr>
<tr>
<td>KEEP_LICENSE</td>
<td>Specifies whether to keep or remove license keys when Workstation Pro is uninstalled.</td>
<td>1</td>
</tr>
<tr>
<td>KEEP_SETTINGFILES</td>
<td>Specifies whether to keep or remove settings files when Workstation Pro is uninstalled.</td>
<td>1</td>
</tr>
<tr>
<td>SERIALNUMBER</td>
<td>Lets you enter the license key when Workstation Pro is installed. Enter the license key with hyphens, for example, ”xxxxx-xxxxx-xxxxx-xxxxx-xxxxx”.</td>
<td>1</td>
</tr>
<tr>
<td>SOFTWAREUPDATEURL</td>
<td>Specifies a custom URL for managing software updates (separate from vmware.com).</td>
<td></td>
</tr>
<tr>
<td>STARTMENU_SHORTCUT</td>
<td>Adds a Start menu item when Workstation Pro is installed.</td>
<td>1</td>
</tr>
<tr>
<td>SUPPORTURL</td>
<td>Set a support URL or email alias specifically for your users to contact with product issues through the Workstation Pro or Workstation Pro Help menu.</td>
<td></td>
</tr>
</tbody>
</table>
Install Workstation Pro on a Linux Host

You run the Linux bundle installer to install Workstation Pro on a Linux host system. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the \(--\text{console}\) option to install Workstation Pro in a terminal window.

Remote connections and virtual machine sharing are enabled by default when you install Workstation Pro. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation Pro can access remotely.

Shared virtual machines are stored in the shared virtual machines directory, where VMware Workstation Server (\texttt{vmware-workstation-server}) manages them. Remote users connect to VMware Workstation Server through HTTPS port 443 on the host system.

To change the shared virtual machines directory or select a different port during the installation process, you must specify the \(--\text{custom}\) option. You can also change the shared virtual machines directory, select a different port, and disable remote connections and virtual machine sharing after Workstation Pro is installed by modifying the Shared VMs Workstation Pro preference setting.

Prerequisites

- Verify that the host system meets the host system requirements. See “Host System Requirements for Workstation Pro,” on page 13.
- Verify that no incompatible VMware products are installed on the host system. See “Installing Workstation Pro with Other VMware Products,” on page 22.
- Obtain the Workstation Pro software and license key. See “Obtaining the Workstation Pro Software and License Key,” on page 21.
- If you plan to use the Integrated Virtual Debugger for Eclipse, install it on the host system. See “Installing the Integrated Virtual Debuggers for Eclipse,” on page 23.
- Compile the real-time clock function into the Linux kernel.
- Verify that the parallel port PC-style hardware option (\texttt{CONFIG\_PARPORT\_PC}) is built and loaded as a kernel module and that it is set to \texttt{m} when the kernel is compiled.
- Familiarize yourself with the Linux command-line installation options. You must use the \(--\text{custom}\) option to specify certain configuration settings. See “Linux Command Line Installation Options,” on page 27.
- Verify that you have root access on the host system.

Procedure

1. Log in to the host system with the user name that you plan to use when you run Workstation Pro.
2. Become root.
   For example: \texttt{su root}
   The command that you use depends on your Linux distribution and configuration.
3. Change directories to the directory that contains the Workstation Pro installer file.
4. Run the appropriate Workstation Pro installer for the host system.
   For example: \texttt{sh VMware-Workstation-xxxx-xxxxxxx.architecture.bundle [--option]}
   \texttt{xxxx-xxxxxxx} is the version and build numbers, \texttt{architecture} is i386 or x86\_64, and \texttt{option} is a command line option.
5 Accept the Open Virtualization Format (OVF) Tool license agreement.

If you are using the --console option or installing Workstation Pro on a host system that does not support the GUI wizard, press Enter to scroll through and read the license agreement or type q to skip to the [yes/no] prompt.

6 Follow the prompts to finish the installation.

After Workstation Pro is installed, vmware-workstation-server starts on the host system. When Workstation Pro starts, log in using your regular user name, not root. vmware-workstation-server starts whenever you restart the host system.

**Linux Command Line Installation Options**

You can use command line installation options to install Workstation Pro on a Linux host system.

To use the installation options, you must be logged in as root. Exit from the root account after the installation is finished.

**Table 3-2. Linux Command Line Installation Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>--console</td>
<td>Enables you to use the terminal for installation.</td>
</tr>
<tr>
<td>--custom</td>
<td>Use this option to customize the following installation settings.</td>
</tr>
<tr>
<td></td>
<td>- The locations of the installation directories.</td>
</tr>
<tr>
<td></td>
<td>- The user who will initially connect to VMware Workstation Server. This user can create and manage shared virtual machines.</td>
</tr>
<tr>
<td></td>
<td>- The location of the shared virtual machines directory.</td>
</tr>
<tr>
<td></td>
<td>- The HTTPS port that VMware Workstation Server uses on the host system.</td>
</tr>
<tr>
<td>--gtk</td>
<td>Opens the GUI-based VMware installer, which is the default option.</td>
</tr>
<tr>
<td>--ignore-errors or -I</td>
<td>Allows the installation to continue even if there is an error in one of the installer scripts. Because the section that has an error does not complete, the component might not be properly configured</td>
</tr>
<tr>
<td>--regular</td>
<td>Shows installation questions that have not been answered before or are required. This is the default option.</td>
</tr>
<tr>
<td>--required</td>
<td>Shows the license agreement only and then proceeds to install Workstation Pro.</td>
</tr>
<tr>
<td>--set-setting vmware-installer</td>
<td>Adds shortcuts when Workstation Pro is installed. The default is yes.</td>
</tr>
<tr>
<td>installShortcuts yes</td>
<td>no</td>
</tr>
<tr>
<td>--set-setting vmware-installer libdir lib_path</td>
<td>The libdir parameter instructs the installer where to place product-specific data files, such as libraries and internal icons. The installer places product files in $libdir/vmware and $libdir/vmware-installer. The default is /usr/lib.</td>
</tr>
<tr>
<td>--set-setting vmware-installer</td>
<td>Installs executable files you run directly (ex: vmware, vmplayer, vmware-networks, etc.) here. Remainder of the product distributed under libdir-derived paths. The default is /usr.</td>
</tr>
<tr>
<td>prefix /usr/local</td>
<td></td>
</tr>
<tr>
<td>--set-setting vmware-workstation</td>
<td>Lets you enter the license key when Workstation Pro or Workstation Player is installed. Enter the license key with hyphens, for example, xxxxx-xxxxx-xxxxx-xxxxx-xxxxx.</td>
</tr>
<tr>
<td>serialNumber xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</td>
<td></td>
</tr>
<tr>
<td>--set-setting vmware-player</td>
<td>Turn on or off certain UI features of Workstation Player. The default is no.</td>
</tr>
<tr>
<td>serialNumber xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</td>
<td></td>
</tr>
<tr>
<td>--set-setting vmware-player-app</td>
<td>Enables automatic upgrades for Workstation Pro or Workstation Player when a new build becomes available.</td>
</tr>
<tr>
<td>simplifiedUI yes</td>
<td>no</td>
</tr>
<tr>
<td>--set-setting vmware-workstation-app softwareUpdateEnabled yes</td>
<td>no</td>
</tr>
<tr>
<td>softwareUpdateEnabled yes</td>
<td>no</td>
</tr>
</tbody>
</table>
### Table 3-2. Linux Command Line Installation Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>--set-setting vmware-workstation-app softwareUpdateURL https://url/</code></td>
<td>Specifies a custom URL for managing software updates (separate from vmware.com).</td>
</tr>
<tr>
<td><code>--set-setting vmware-player-app softwareUpdateURL https://url/</code></td>
<td></td>
</tr>
<tr>
<td><code>--set-setting vmware-workstation-app supportURL https://url/</code></td>
<td>Set a support URL or email alias specifically for your users to contact with product issues through the Help menu.</td>
</tr>
<tr>
<td><code>--set-setting vmware-player-app supportURL https://url/</code></td>
<td></td>
</tr>
</tbody>
</table>

### Upgrading Workstation Pro

You can upgrade from a previous version of Workstation to the current version of Workstation Pro by running the Workstation Pro installation program.

When you upgrade Workstation Pro, the installation program removes the previous version of Workstation Pro before it installs the new version.

To use the latest features, virtual machines that were created in the previous versions of Workstation must be upgraded to the current version of Workstation Pro.

- **Prepare for an Upgrade** on page 28
  - You must perform certain steps before you upgrade Workstation Pro.

- **Upgrade Workstation Pro on a Windows Host** on page 29
  - You can upgrade to the current version of Workstation Pro on a Windows host system by running the Workstation Pro setup program and installation wizard for Windows.

- **Upgrade Workstation Pro on a Linux Host** on page 30
  - You can upgrade to the current version of Workstation Pro on a Linux host system by running the Linux bundle installer for Workstation Pro. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the `--console` option to upgrade Workstation Pro in a terminal window.

- **Change the Hardware Compatibility of a Virtual Machine** on page 31
  - You can change the hardware compatibility of a virtual machine. All virtual machines have a hardware version. The hardware version indicates which virtual hardware features that the virtual machine supports, such as BIOS or EFI, number of virtual slots, maximum number of CPUs, maximum memory configuration, and other hardware characteristics.

### Prepare for an Upgrade

You must perform certain steps before you upgrade Workstation Pro.

**Procedure**

- Verify that all virtual machines are Workstation 7.x, 8, 9, 10 or 11 virtual machines.
  - Direct upgrades from Workstation 2 and 3 virtual machines are not supported.

- Review the system requirements for the new version of Workstation Pro.

- If a virtual machine was created with a version of Workstation earlier than Workstation 5.5 and it has a snapshot, delete the snapshot.
If you are upgrading from Workstation 4, 5.x, 6.x, or 7.x, and the previous version of Workstation used bridged settings to map virtual networks to specific physical or virtual adapters, record those settings. You must recreate these mappings after you upgrade Workstation Pro.

- Power off all running virtual machines in Workstation Pro.
- If any virtual machines are suspended, resume them and power them off in Workstation Pro.
- If any virtual machines are running in the background, start them in Workstation Pro and power them off.
- Back up all virtual machines by making backup copies of the files in the virtual machine directories and storing them in different directories. The files that you back up should include .vmdk or .dsk files, .vmx or .cfg files, and .nvram files. Depending on the upgrade path, you might not be able to run virtual machines under both the current version of Workstation Pro and the previous version.

If you are upgrading Workstation 6.x on Windows XP to the current version of Workstation Pro on Windows Vista or Windows 7, verify that Service Pack 2 is installed and then upgrade the host operating system to Windows Vista or Windows 7.

If you are upgrading Workstation 5.x on Windows Vista to the current version of Workstation Pro on Windows Vista, select Programs > Programs and Features > Uninstall a program in the Windows control panel to manually uninstall Workstation 5.x.

If you are upgrading Workstation 5.x on Windows XP to the current version of Workstation Pro on Windows Vista or Windows 7, select Add or Remove Programs in the Windows control panel to manually uninstall Workstation 5.x.

During an upgrade from Windows XP to Windows Vista or Windows 7, the location of virtual machines might change. The Windows Vista and Windows 7 upgrade use the registry to map the virtual machines to a new location. Before the upgrade, the default virtual machine location on Windows XP is C:\Documents and Settings\username\My Documents\My Virtual Machines. After the upgrade, the default virtual machine location on Windows Vista and Windows 7 is C:\Users\username\Documents\Virtual Machines\guest0Sname.

Upgrade Workstation Pro on a Windows Host

You can upgrade to the current version of Workstation Pro on a Windows host system by running the Workstation Pro setup program and installation wizard for Windows. Remote connections and virtual machine sharing are enabled by default when you upgrade Workstation Pro. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation Pro can access remotely.

Prerequisites

- Verify that the host system meets the host system requirements. See “Host System Requirements for Workstation Pro,” on page 13.
- Verify that you have a license key.
- Verify that you have administrative privileges on the host system.
- Prepare for the upgrade. See “Prepare for an Upgrade,” on page 28.
Procedure

1. Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   
   If you log in to a domain, the domain account must also be a local administrator.

2. Double-click the `VMware-workstation-xxxx-xxxxxxx.exe` file, where `xxxx-xxxxxxx` is the version and build numbers.

3. Click Uninstall to uninstall the previous version of Workstation Pro.

4. After the host system restarts, log in as the Administrator user or as a user who is a member of the local Administrators group.
   
   If you log in to a domain, the domain account must also be a local administrator.

5. Follow the prompts to finish the upgrade.
   
   Depending on your configuration, you might need to restart the host system to finish the installation.

After Workstation Pro is upgraded and you restart the host system, the VMware Workstation Server service starts. The VMware Workstation Server service starts whenever you restart the host system.

What to do next

To use the latest features, upgrade existing virtual machines to the new version of Workstation Pro. See “Change the Hardware Compatibility of a Virtual Machine,” on page 31.

If you used bridged settings to map virtual networks to specific physical or virtual adapters in the previous version of Workstation Pro, recreate the mappings. If you created teams in the previous version of Workstation, convert the teams to use them in the new version of Workstation Pro.

Upgrade Workstation Pro on a Linux Host

You can upgrade to the current version of Workstation Pro on a Linux host system by running the Linux bundle installer for Workstation Pro. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the `--console` option to upgrade Workstation Pro in a terminal window.

Remote connections and virtual machine sharing are enabled by default when you upgrade Workstation Pro. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation Pro can access remotely.

Shared virtual machines are stored in the shared virtual machines directory, where VMware Workstation Server (`vmware-workstation-server`) manages them. Remote users connect to VMware Workstation Server through HTTPS port 443 on the host system.

To change the shared virtual machines directory or select a different port during the upgrade process, you must specify the `--custom` option. You can also change the shared virtual machines directory, select a different port, and disable remote connections and virtual machine sharing after Workstation Pro is upgraded by modifying the Shared VMs Workstation Pro preference setting.

Prerequisites

- Verify that the host system meets the host system requirements. See “Host System Requirements for Workstation Pro,” on page 13.
- Verify that you have a license key.
- Prepare for the upgrade. See “Prepare for an Upgrade,” on page 28.
Familiarize yourself with the Linux command-line installation options. You must use the \texttt{--custom} option to specify certain configuration settings. See “Linux Command Line Installation Options,” on page 27.

Verify that you have root access to the host system.

**Procedure**

1. Log in to the host system with the user name that you plan to use when you run Workstation Pro.
2. Become root.
   
   For example: \texttt{su root}
   
   The command that you use depends on your Linux distribution and configuration.
3. Change directories to the directory that contains the Workstation Pro installer file.
4. Run the appropriate Workstation Pro installer for the host system.
   
   For example: \texttt{sh VMware-Workstation-xxxx-xxxxxxx.architecture.bundle \texttt{[\texttt{--option}]}}
   
   \texttt{xxxx-xxxxxxx} is the version and build numbers, \texttt{architecture} is i386 or x86_64, and \texttt{option} is a command line option.
5. Accept the Open Virtualization Format (OVF) Tool license agreement.
   
   If you are using the \texttt{--console} option or installing Workstation Pro on a host system that does not support the GUI wizard, press Enter to scroll through and read the license agreement or type \texttt{q} to skip to the \texttt{[yes/no]} prompt.
6. Follow the prompts to finish the installation.

After Workstation Pro is upgraded, \texttt{vmware-workstation-server} starts on the host system. \texttt{vmware-workstation-server} starts whenever you restart the host system.

**What to do next**

To use the latest features, upgrade existing virtual machines to the new version of Workstation Pro. See “Change the Hardware Compatibility of a Virtual Machine,” on page 31.

If you used bridged settings to map virtual networks to specific physical or virtual adapters in the previous version of Workstation Pro, recreate the mappings. If you created teams in the previous version of Workstation, convert the teams to use them in the new version of Workstation Pro.

**Change the Hardware Compatibility of a Virtual Machine**

You can change the hardware compatibility of a virtual machine. All virtual machines have a hardware version. The hardware version indicates which virtual hardware features that the virtual machine supports, such as BIOS or EFI, number of virtual slots, maximum number of CPUs, maximum memory configuration, and other hardware characteristics.

When you upgrade Workstation Pro, you must change the hardware compatibility of virtual machines that were created in previous versions of Workstation Pro so that they can use the new features in the new version of Workstation Pro. You can run older versions of virtual machines in the new version of Workstation Pro, but you will not have the benefits of the new features.

If you want a virtual machine to remain compatible with other VMware products that you are using, you might not want to change the hardware compatibility to the latest Workstation Pro version.

\textbf{Note} If you decide not to change the hardware compatibility of a virtual machine, you should consider upgrading to the latest version of VMware Tools to obtain the latest VMware Tools features.
Prerequisites

Familiarize yourself with the considerations and limitations of changing the hardware compatibility of a virtual machine. See “Considerations for Changing the Hardware Compatibility of a Virtual Machine,” on page 32.

Procedure

1. Make backup copies of the virtual disk (.vmdk) files.
2. If you are upgrading from a Workstation 5.x virtual machine, or downgrading to a Workstation 5.x virtual machine, make a note of the NIC settings in the guest operating system.
   
   If you specified a static IP address for the virtual machine, that setting might be changed to automatic assignment by DHCP after the upgrade.

3. Shut down the guest operating system and power off the virtual machine.

4. Select the virtual machine and select VM > Manage > Change Hardware Compatibility.

5. Follow the prompts in the wizard to change the hardware compatibility of the virtual machine.

   When you select a hardware compatibility setting, a list of the VMware products that are compatible with that setting appears. For example, if you select Workstation 4, 5, or 6, a list of Workstation 6.5 and later features that are not supported for that Workstation version also appears.

   **NOTE** Using Workstation 10, you can change the hardware compatibility of a shared or remote virtual machine. However, you cannot down grade a previously created virtual machine.

6. Power on the virtual machine.

   If you upgrade a virtual machine that contains a Windows 98 operating system to a Workstation 6.5 or later virtual machine, you must install a PCI-PCI bridge driver when you power on the virtual machine.

   **NOTE** Because Workstation 6.5 and later versions have 32 more PCI-PCI bridges than Workstation 6, you might need to respond to the prompt 32 or 33 times.

7. If the NIC settings in the guest operating system have changed, use the NIC settings that you recorded to change them back to their original settings.

8. If the virtual machine does not have the latest version of VMware Tools installed, update VMware Tools.

   You should update VMware Tools to the version included with the latest version of Workstation Pro, even if you upgraded the virtual machine to an earlier version of Workstation Pro. Do not remove the older version of VMware Tools before installing the new version.

   **NOTE** If you are upgrading a virtual machine that runs from a physical disk, you can safely ignore this message: Unable to upgrade drive_name. One of the supplied parameters is invalid.

Considerations for Changing the Hardware Compatibility of a Virtual Machine

Before you change the hardware compatibility of a virtual machine, you should be aware of certain considerations and limitations.

- For Workstation 5.x, 6, 6.5, 7.x, and later virtual machines, you can change the version of the original virtual machine or create a full clone so that the original virtual machine remains unaltered.

- If you upgrade a Workstation 5.x virtual machine that is compatible with ESX Server to Workstation 6, 6.5, 7.x, or later, you cannot use the Change Hardware Compatibility wizard to later downgrade the virtual machine to an ESX-compatible virtual machine.
When you upgrade a Windows XP, Windows Server 2003, Windows Vista, Windows 7, or Windows 8 virtual machine, the Microsoft product activation feature might require you to reactivate the guest operating system.

Using Workstation 9 or earlier, you cannot change the hardware compatibility of a shared or remote virtual machine.

Using Workstation 10 and later, you can change the hardware compatibility of a shared or remote virtual machine. However, you cannot downgrade a previously created virtual machine.

Uninstalling Workstation Pro

You uninstall Workstation Pro on a Windows host by using the Windows setup program. On a Linux host, you uninstall Workstation Pro by running the bundle installer.

**IMPORTANT** If you uninstall Workstation Pro and do not save the configuration, then when you reinstall Workstation Pro, shared virtual machines will no longer appear in the Shared VMs list in the virtual machine library. To display virtual machines in the list again, you will need to share them again.

Uninstall Workstation Pro from a Windows Host

You can run the Windows setup program to uninstall Workstation Pro from a Windows host system.

**Procedure**

1. Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   
   If you log in to the domain, the domain account must also be a local administrator.

2. Double-click the `VMware-workstation-xxxx-xxxxxxx.exe` file, where `xxxx-xxxxxxx` is the version and build numbers.

3. Click **Next** on the Welcome screen and then click **Remove**.

4. (Optional) To save product license and Workstation Pro configuration information, select the appropriate check boxes.

5. Click **Next** to begin uninstalling Workstation Pro.

Uninstall Workstation Pro from a Linux Host

You must run a command to uninstall Workstation Pro from a Linux host.

**Prerequisites**

Verify that you have root access to the host system.

**Procedure**

1. Log in to the Linux host system with the user name that you use when you run Workstation Pro.

2. Become root.
   
   For example: `su root`

   The command that you use depends on your Linux distribution and configuration.

3. In a terminal window, type `vmware-installer -u vmware-workstation`

4. Click **Next** to begin uninstalling Workstation Pro.
Start Workstation Pro

How you start Workstation Pro depends on the host system platform and the options that you selected during Workstation Pro installation.

On Windows host systems, you might have a desktop shortcut, a quick launch shortcut, or a combination of these options in addition to a Start menu item.

On Linux host systems, you start Workstation Pro from the command line. On some Linux distributions, including Red Hat Enterprise Linux 5.1, you can also start Workstation Pro from the System Tools menu under Applications.

Procedure

- To start Workstation Pro on a Windows host system, select Start > Programs > VMware > VMware Workstation.
- To start Workstation Pro on a Linux host system, type the vmware command in a terminal window.

<table>
<thead>
<tr>
<th>Option</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>/usr/bin is in your default path</td>
<td>vmware &amp;</td>
</tr>
<tr>
<td>/usr/bin is not in your default path</td>
<td>/usr/bin/vmware &amp;</td>
</tr>
</tbody>
</table>

The first time you start Workstation Pro, Workstation Pro prompts you to accept the End User License Agreement. After you start Workstation Pro, the Workstation Pro window opens.

Using the Workstation Pro Window

A virtual machine is like a separate computer that runs in a window on the host system. Workstation Pro displays more than the screen of another computer. From the Workstation Pro window, you can interact with and run virtual machines. You can also switch easily from one virtual machine to another.

The best way to learn how to use Workstation Pro is to use it. The Workstation Pro window is designed to be intuitive and easy to use.

- **Use Virtual Machines in the Workstation Pro Window** on page 35
  You interact with virtual machines through the Workstation Pro window.

- **Use the Virtual Machine Library** on page 35
  The virtual machine library appears on the left side of the Workstation Pro window. You use the library to view and select virtual machines, folders, and remote hosts in Workstation Pro. The library appears by default.

- **Use the Thumbnail Bar** on page 36
  The thumbnail bar appears along the bottom of the Workstation Pro window.

- **Use the Status Bar** on page 36
  The status bar appears at the bottom of the Workstation Pro window. You can use the icons on the status bar to see Workstation Pro messages and perform actions on devices such as hard disks, CD/DVD drives, floppy drives, and network adapters. The status bar appears by default.

- **Use Workstation Pro Tabs** on page 37
  Workstation Pro creates a tab in the right pane of the Workstation Pro window when you select an item in the library. Tabs appear by default.
Customize the Workstation Pro Window on page 37
You can customize the appearance of the Workstation Pro window by selecting items from the View menu.

Default Hot-Key Combinations on page 38
You can use keyboard shortcuts to interact with Workstation Pro and with virtual machines. Most of the available keyboard shortcuts for Workstation Pro are listed next to their associated commands in Workstation Pro menus.

Use Virtual Machines in the Workstation Pro Window
You interact with virtual machines through the Workstation Pro window.

Procedure

- Use the icons on the Home tab to create a new virtual machine, open an existing virtual machine, connect to a remote server, or view the Workstation Pro help system.
- Select a powered-off virtual machine in the library or click its tab to see the summary view for that virtual machine.
  The summary view shows a summary of configuration information and the virtual machine state. You can power on the virtual machine and edit virtual machine settings from the summary view.
- Select an active virtual machine in the library or click its tab to see the console view.
  The console view is like the monitor display of a physical computer. You can click the console view button on the toolbar to switch between the console and summary views.
- Select a virtual machine in the library and use the VM menu on the menu bar at the top of the Workstation Pro window to perform all virtual machine operations for the selected virtual machine.
  You can use the VM menu when a virtual machine is powered on or off. If an operation is not supported for the virtual machine in its current state, the menu item is not available.
- Select a virtual machine in the library and use the buttons on the toolbar at the top of the Workstation Pro window to perform common virtual machine operations and change the display for the selected virtual machine.
  You can use the buttons on the toolbar to take and manage snapshots, enter full screen and Unity mode, cycle multiple monitors, and switch between the console and summary views.
- When a virtual machine is powered on, use the icons on the status bar at the bottom of the Workstation Pro window to see Workstation Pro messages and perform actions on virtual devices such as hard disks, CD/DVD drives, floppy drives, and network adapters.
  You can click or right-click on a removable device icon to connect or disconnect the device or edit its settings, and you can click the Message log icon to view the message log. Messages include warning information about the virtual machine. If the icon is dimmed, all messages have already been read.
- Select items in the library or use tabs to quickly switch between virtual machines, folders, and remote hosts.

Use the Virtual Machine Library
The virtual machine library appears on the left side of the Workstation Pro window. You use the library to view and select virtual machines, folders, and remote hosts in Workstation Pro. The library appears by default.

Prerequisites
If the library is not visible, select View > Customize > Library.
Procedure

- Right-click a virtual machine, folder, or remote host in the library to view the item's context menu and perform common operations.

- To find a specific virtual machine in the library, type its name, part of its description, or the name of the guest operating system in the search box.

  For example, to find all of the virtual machines that have a Windows 8 guest operating system, type Windows 8. You can also search for folders and remote hosts.

- To mark a virtual machine or folder as a favorite in the library, right-click it and select Mark as Favorite or click the star icon.

- Use the library drop-down menu to show only powered on virtual machines or favorite items.

  By default, the library shows all items.

- To remove an item from the library, right-click it and select Remove.

Use the Thumbnail Bar

The thumbnail bar appears along the bottom of the Workstation Pro window.

For active virtual machines, Workstation Pro updates the thumbnail in real time to show the actual content of the virtual machine. When a virtual machine is suspended, the thumbnail is a screenshot of the virtual machine at the time that it was suspended.

Prerequisites

If the thumbnail bar is not visible, select View > Customize > Thumbnail Bar.

Procedure

- Click a thumbnail to show the summary or console view for a virtual machine.

- Click thumbnails to quickly switch between virtual machines.

- To change the order of the thumbnails, change the order of the virtual machine tabs.

  Thumbnails appear in the same order as the virtual machine tabs. To move a virtual machine tab, drag and drop it to a new location.

- To change the virtual machines that appear in the thumbnail bar, select Open Virtual Machines or Folder View Virtual Machines from the thumbnail bar drop-down menu.

  The drop-down menu is a down-arrow on the thumbnail bar.

Use the Status Bar

The status bar appears at the bottom of the Workstation Pro window. You can use the icons on the status bar to see Workstation Pro messages and perform actions on devices such as hard disks, CD/DVD drives, floppy drives, and network adapters. The status bar appears by default.

Procedure

- Mouse over an icon on the status bar to see its name.

- Click or right-click on a removable device icon to connect or disconnect the device or edit its settings.

- Click the message log icon to view the message log.

  Messages include warning information about the virtual machine. If the icon is dimmed, all messages have already been read.
Use Workstation Pro Tabs

Workstation Pro creates a tab in the right pane of the Workstation Pro window when you select an item in the library. Tabs appear by default.

Procedure

- Use the links on the Home tab to create a virtual machine, open a virtual machine, connect to a remote server, virtualize a physical machine, use the virtual network editor, customize Workstation Pro preferences, download software updates, and view the help system.
- Use the virtual machine tabs to view virtual machine configuration information, modify virtual machine hardware and option settings, and create or modify the virtual machine description.
- Use the Shared VMs tab to see information about all of the shared virtual machines on the host system.
- Use the tab for a remote host to see information about the remote host, including CPU, memory, and disk usage, and the virtual machines and virtual machine tasks running on the remote host.
- Select File > Close Tab to close a tab.

Customize the Workstation Pro Window

You can customize the appearance of the Workstation Pro window by selecting items from the View menu.

Procedure

1. Select View > Customize and select a Workstation Pro window view.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library</td>
<td>The virtual machine library appears in the left side of the window. You can use the library to view and select virtual machines, folders, and remote hosts in Workstation Pro. The library appears by default.</td>
</tr>
<tr>
<td>Thumbnail Bar</td>
<td>A thumbnail bar appears at the bottom of the window. Depending on the thumbnail bar option that is selected, the thumbnail bar shows all open virtual machines or the virtual machines in the selected folder.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>A toolbar appears at the top of the window. You can use the icons on the toolbar to start and stop virtual machines, take snapshots, change the display, and perform other common tasks. The toolbar appears by default.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>A status bar appears at the bottom of the window when a virtual machine is selected. You can use the icons on the status bar to see Workstation Pro messages and perform actions on virtual machine devices such as hard disks, CD/DVD drives, floppy drives, and network adapters. The status bar appears by default.</td>
</tr>
<tr>
<td>Tabs</td>
<td>Workstation Pro creates a tab in the right pane when you select an item in the library. Tabs appear by default.</td>
</tr>
</tbody>
</table>

2. To specify which virtual machines appear in the thumbnail bar, select View > Customize > Thumbnail Bar Options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Virtual Machines</td>
<td>The thumbnail bar shows thumbnails for all open virtual machines.</td>
</tr>
<tr>
<td>Folder View Virtual Machines</td>
<td>The thumbnail bar shows thumbnails for virtual machines in the selected folder.</td>
</tr>
</tbody>
</table>
Default Hot-Key Combinations

You can use keyboard shortcuts to interact with Workstation Pro and with virtual machines. Most of the available keyboard shortcuts for Workstation Pro are listed next to their associated commands in Workstation Pro menus.

Table 3-3. Default Hot-Key Combinations

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+G</td>
<td>Grab input from the keyboard and mouse.</td>
</tr>
<tr>
<td>Ctrl+Alt</td>
<td>Release the mouse cursor.</td>
</tr>
<tr>
<td>Ctrl+Alt+Insert</td>
<td>Shut down or, depending on the guest operating system, log out of the guest operating system. This command is received solely by the virtual machine.</td>
</tr>
<tr>
<td>Ctrl+Alt+Delete</td>
<td>Shut down or, depending on the operating system, log out of the guest operating system. On a Windows host, if you do not use the enhanced virtual keyboard feature, both the host operating system and the virtual machine receive this command, even when Workstation Pro has control of input. Cancel the ending of the host operating system session and return to the virtual machine to log out or shut down or perform administrative tasks.</td>
</tr>
<tr>
<td>Ctrl+Alt+Enter</td>
<td>Enter full screen mode.</td>
</tr>
<tr>
<td>Ctrl+Alt+spacebar</td>
<td>Send any command to the virtual machine so that Workstation Pro does not process it. Hold down Ctrl+Alt as you press and release the spacebar, and continue to hold the Ctrl+Alt keys down as you press the next key in the combination.</td>
</tr>
<tr>
<td>Ctrl+Tab</td>
<td>(Windows hosts only) Switch among tabs.</td>
</tr>
<tr>
<td>Ctrl+Shift+Tab</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Alt+right arrow</td>
<td>In full screen mode, switch to the next powered-on virtual machine.</td>
</tr>
<tr>
<td>Ctrl+Alt+left arrow</td>
<td>In full screen mode, switch to the previous powered-on virtual machine.</td>
</tr>
<tr>
<td>Ctrl+Shift+U</td>
<td>In Unity mode, give access to the virtual machine Start or Applications menu. You can change the Unity hot-key combination by modifying Unity preference settings.</td>
</tr>
</tbody>
</table>

You can change the default hot-key combinations by modifying Workstation Pro for common virtual machine operations to Ctrl+Shift, you press Ctrl+Shift instead of Ctrl+Alt to release control from the current virtual machine.

Using the Workstation Pro Online Help

The Workstation Pro online help contains information about Workstation Pro settings and common tasks. Use the online help when you need to quickly find information about Workstation Pro preferences, virtual hardware settings, and virtual machine options.

For example, if you are configuring a virtual machine and you need information about a specific hardware setting, click Help on the dialog box that contains the setting. The Help window opens and a context-sensitive help topic appears in the right pane. To see the entire help system, select Help > Help Topics (Windows host) or Help > Contents (Linux host).
Creating Virtual Machines

You can create a new virtual machine in Workstation Pro by using the New Virtual Machine wizard, clone an existing Workstation Pro virtual machine or virtual machine template, import third-party and Open Virtualization Format (OVF) virtual machines, and create a virtual machine from a physical machine.

You can also create shared virtual machines, which can be used by remote users, and virtual machines that run on remote hosts. See Chapter 10, “Using Remote Connections and Sharing Virtual Machines,” on page 211.

This chapter includes the following topics:

- “Understanding Virtual Machines,” on page 39
- “Preparing to Create a New Virtual Machine,” on page 40
- “Create a New Virtual Machine on the Local Host,” on page 50
- “Cloning Virtual Machines,” on page 54
- “Virtualize a Physical Machine,” on page 57
- “Importing Virtual Machines,” on page 59
- “Installing and Upgrading VMware Tools,” on page 60
- “Virtual Machine Files,” on page 71

Understanding Virtual Machines

A virtual machine is a software computer that, like a physical machine, runs an operating system and applications. A virtual machine uses the physical resources of the physical machine on which it runs, which is called the host system. Virtual machines have virtual devices that provide the same functionality as physical hardware, but with the additional benefits of portability, manageability, and security.

A virtual machine has an operating system and virtual resources that you manage in much the same way that you manage a physical computer. For example, you install an operating system in a virtual machine in the same way that you install an operating system on a physical computer. You must have a CD-ROM, DVD, or ISO image that contains the installation files from an operating system vendor.
Preparing to Create a New Virtual Machine

You use the New Virtual Machine wizard to create a new virtual machine in Workstation Pro. The wizard prompts you to make decisions about many aspects of the virtual machine. You should make these decisions before you start the New Virtual Machine wizard.

Worksheet for Creating a Virtual Machine

You can print this worksheet and write down the values to specify when you run the New Virtual Machine wizard.

<table>
<thead>
<tr>
<th>Table 4-1. Worksheet: Creating a Virtual Machine</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
</tr>
<tr>
<td>Hardware compatibility setting</td>
</tr>
<tr>
<td>Guest operating system source</td>
</tr>
<tr>
<td>Guest operating system type (for manual installation)</td>
</tr>
<tr>
<td>Easy Install information for Windows guests</td>
</tr>
<tr>
<td>- Product key</td>
</tr>
<tr>
<td>- Operating system version</td>
</tr>
<tr>
<td>- Full name</td>
</tr>
<tr>
<td>- Password</td>
</tr>
<tr>
<td>- Credentials for automatic login</td>
</tr>
<tr>
<td>Easy Install information for Linux guests</td>
</tr>
<tr>
<td>- Full name</td>
</tr>
<tr>
<td>- User name</td>
</tr>
<tr>
<td>- Password</td>
</tr>
<tr>
<td>Virtual machine name</td>
</tr>
<tr>
<td>Virtual machine location</td>
</tr>
<tr>
<td>Number of processors</td>
</tr>
<tr>
<td>Memory allocation</td>
</tr>
<tr>
<td>Network connection type</td>
</tr>
<tr>
<td>I/O controller type</td>
</tr>
<tr>
<td>Hard disk</td>
</tr>
<tr>
<td>Virtual hard disk type</td>
</tr>
<tr>
<td>Disk capacity</td>
</tr>
<tr>
<td>Virtual disk file name and location</td>
</tr>
</tbody>
</table>

Selecting a Virtual Machine Configuration

When you start the New Virtual Machine wizard, the wizard prompts you to select a typical or custom configuration.

**Typical Configuration**

If you select a typical configuration, you must specify or accept defaults for a few basic virtual machine settings.

- How you want to install the guest operating system.
- A name for the virtual machine and a location for the virtual machine files.
The size of the virtual disk and whether to split the disk into multiple virtual disk files.

Whether to customize specific hardware settings, including memory allocation, number of virtual processors, and network connection type.

**Custom Configuration**

You must select a custom configuration if you need to perform any of the following hardware customizations.

- Create a virtual machine that has a different Workstation Pro version than the default hardware compatibility setting.
- Select the I/O controller type for the SCSI controller.
- Select the virtual disk device type.
- Configure a physical disk or an existing virtual disk instead of create a new virtual disk.
- Allocate all virtual disk space rather than let disk space gradually grow to the maximum disk size.

**Selecting the Virtual Machine Hardware Compatibility Setting**

All virtual machines have a hardware version. The hardware version indicates which virtual hardware features that the virtual machine supports, such as BIOS or EFI, number of virtual slots, maximum number of CPUs, maximum memory configuration, and other hardware characteristics. The virtual machine hardware compatibility setting determines the hardware features of the virtual machine.

If you select a typical configuration, the wizard uses the default hardware compatibility setting configured in the Workstation Pro preferences. By default, the default hardware compatibility setting is the installed Workstation Pro version.

If you select a custom configuration, the New Virtual Machine wizard prompts you to select a hardware compatibility setting for the virtual machine. When you select a hardware compatibility setting, a list of the VMware products and versions that are compatible with your selection appears. Limitations and features that are not available for your selection are also listed. If a feature compatibility check box is available for your selection, you can select that check box to see a list of the additional limitations.

To deploy virtual machines to run on a different VMware product, you might need to select a hardware compatibility setting that is compatible with that product.

**Selecting a Guest Operating System**

The New Virtual Machine prompts you to select the source media for the operating system that will run inside the virtual machine. You can specify an installer disc inserted in a physical drive, an ISO image file, or you can instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk.

If you select an installer disc or an ISO image file and the operating system supports Easy Install, the guest operating system installation is automated and VMware Tools is installed. If the installer disc or ISO image file contains a product key number and is already set up to perform an unattended installation, the only benefit of using Easy Install is the automatic installation of VMware Tools.

**Note** For remote virtual machines, you must specify whether the physical drive or ISO image file is located on the local host or remote host before you select the installer disc or ISO image file.

If you instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk, the wizard prompts you to specify an operating system and version and you must install the guest operating system manually after the virtual machine is created. Workstation Pro uses this information to set the appropriate default values, name files associated with the virtual machine, adjust performance settings, and work around special behaviors and bugs in the guest operating system. If the operating system you plan to install is not listed in the wizard, select Other for both the operating system and version.
If you are installing an operating system that supports Easy Install but you do not want to use Easy Install, you can instruct the wizard to create a virtual machine that has a blank disk and install the guest operating system manually.

**Providing Easy Install Information**

When the New Virtual Wizard detects an operating system that supports Easy Install, the wizard prompts you for information about the guest operating system. After the virtual machine is created, the guest operating system installation is automated and VMware Tools is installed.

For Windows guest operating systems, you must provide the following Easy Install information.

**Table 4-2. Easy Install Information for Windows Guests**

<table>
<thead>
<tr>
<th>Easy Install Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows product key</td>
<td>(Optional) Type a product key unless the installation media contains a volume license product key. If you provide a product key here, you are not prompted to provide a product key when you install the guest operating system.</td>
</tr>
<tr>
<td>Version of Windows to install</td>
<td>Select the Windows operating system edition to install.</td>
</tr>
<tr>
<td>Full name</td>
<td>The name to use to register the guest operating system. Do not use the name Administrator or Guest. If you use one of these names, you must enter a different name when you install the guest operating system.</td>
</tr>
<tr>
<td>Password</td>
<td>(Optional) The password to use for an account with Administrator permissions on Windows operating systems other than Windows 2000. On Windows 2000, this is the password for the Administrator account. On Windows XP Home, an Administrator account without a password is created and you are automatically logged in to the guest operating system.</td>
</tr>
<tr>
<td>Log on automatically (requires a password)</td>
<td>(Optional) Save your login credentials and bypass the login dialog box when you power on the virtual machine. You must enter a name and password to use this feature.</td>
</tr>
</tbody>
</table>

For Linux guest operating systems, you must provide the following Easy Install information.

**Table 4-3. Easy Install Information for Linux Guests**

<table>
<thead>
<tr>
<th>Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full name</td>
<td>The name to use to register the guest operating system, if registration is required. Workstation Pro uses the first name to create the host name for the virtual machine.</td>
</tr>
<tr>
<td>User name</td>
<td>Your user name. You can use lowercase letters, numbers, and dashes, but avoid using user names that begin with a dash. Do not use the name root. Some operating systems set up sudo access for this user and other operating systems require this user to use su to obtain root privileges.</td>
</tr>
<tr>
<td>Password</td>
<td>The password for the User name and the root user.</td>
</tr>
</tbody>
</table>

See “Use Easy Install to Install a Guest Operating System,” on page 51.

**Specifying the Virtual Machine Name and File Location**

The New Virtual Machine wizard prompts you for a virtual machine name and a directory for the virtual machine files.

The name of the default directory for virtual machine files is derived from the name of the guest operating system, for example, Microsoft Windows 10 x64.
For standard virtual machines, the default directory for virtual machine files is located in the virtual machine directory. For best performance, do not place the virtual machines directory on a network drive. If other users need to access the virtual machine, consider placing the virtual machine files in a location that is accessible to those users.

For shared virtual machines, the default directory for virtual machine files is located in the shared virtual machines directory. Shared virtual machine files must reside in the shared virtual machines directory.

**Virtual Machines Directory**

Workstation Pro stores standard virtual machines in the virtual machines directory.

The default location of the virtual machines directory depends on the host operating system.

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>Default Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2</td>
<td>C:\Documents and Settings\username\My Documents\My Virtual Machines</td>
</tr>
<tr>
<td>Windows 7</td>
<td>C:\Users\username\Documents\Virtual Machines</td>
</tr>
<tr>
<td>Windows 8</td>
<td>username is the name of the currently logged-in user.</td>
</tr>
<tr>
<td>Windows 10</td>
<td>username is the name of the currently logged-in user.</td>
</tr>
<tr>
<td>Linux</td>
<td>homedir/vmware homedir is the home directory of the currently logged-in user.</td>
</tr>
</tbody>
</table>

**Shared Virtual Machines Directory**

Workstation Pro stores shared virtual machines in the shared virtual machines directory, where VMware Workstation Server manages them.

The default location of the shared virtual machines directory depends on the host operating system.

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>Default Shared Virtual Machines Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2</td>
<td>C:\Documents and Settings\All Users\Documents\Shared Virtual Machines</td>
</tr>
<tr>
<td>Windows 7</td>
<td>C:\Users\Public\Documents\Shared Virtual Machines</td>
</tr>
<tr>
<td>Windows 8</td>
<td></td>
</tr>
<tr>
<td>Windows 10</td>
<td></td>
</tr>
<tr>
<td>Linux</td>
<td>/var/lib/vmware/Shared VMs</td>
</tr>
</tbody>
</table>

**Selecting the Firmware Type**

Depending on the guest operating system, when you use a custom configuration, the New Virtual Machine wizard prompts you to select the firmware type the virtual machine uses when it boots.

This option is only available in the New Virtual Machine wizard when selecting Windows 7 and later 64-bit guest operating systems.
Table 4-6. Firmware Type Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BIOS</td>
<td>The virtual machine firmware uses BIOS when booting.</td>
</tr>
<tr>
<td>EFI</td>
<td>The virtual machine uses EFI when booting. See “Enable EFI Support,” on page 76.</td>
</tr>
</tbody>
</table>

See also “Configuring Advanced Settings for a Virtual Machine,” on page 257.

Selecting the Number of Processors for a Virtual Machine

When you select a custom configuration, the New Virtual Machine wizard prompts you to specify the number of processors for the virtual machine.

Specifying multiple virtual processors is supported only on host machines that have at least two logical processors. Single-processor hosts that have hyperthreading enabled or dual-core CPUs are considered to have two logical processors. Multiprocessor hosts that have two CPUs are considered to have at least two logical processors, regardless of whether they are dual-core or have hyperthreading enabled.

For Windows virtual machines running mostly office and Internet productivity applications, using multiple virtual processors is not beneficial, so the default single virtual processor is ideal. For server workloads and data-intensive computing applications, adding extra virtual processors may provide an increase in application performance.

<table>
<thead>
<tr>
<th>Application</th>
<th>Recommended number of processors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desktop applications</td>
<td>1 processor</td>
</tr>
<tr>
<td>Server operating systems</td>
<td>2 processors</td>
</tr>
<tr>
<td>Video encoding, modeling, and scientific</td>
<td>4 processors</td>
</tr>
</tbody>
</table>

In some circumstances, adding additional processors can decrease the overall performance of the virtual machine and your computer. This can occur if the operating system or application is not using the processors efficiently. In this case, reducing the number of processors is recommended.

Assigning all processors on your computer to the virtual machine results in extremely poor performance. The host operating system must continue to perform background tasks even if no applications are running. If you assign all processors to a virtual machine, this prevents important tasks from being completed.

Allocating Memory for a Virtual Machine

When you select a custom configuration, the New Virtual Machine wizard prompts you to specify the default settings for memory allocation.

Color-coded icons correspond to the maximum recommended memory, recommended memory, and guest operating system recommended minimum memory values. To adjust the memory allocated to the virtual machine, move the slider along the range of values. The high end of the range is determined by the amount of memory allocated to all running virtual machines. If you allow virtual machine memory to be swapped, this value changes to reflect the specified amount of swapping.

On 64-bit hosts, the maximum amount of memory for each virtual machine is 64GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. You cannot power on virtual machines that are configured to use more than 8GB of memory on 32-bit hosts. Memory management limitations on 32-bit operating systems cause virtual machine memory to overcommit, which severely affects system performance.
The total amount of memory that you can assign to all virtual machines running on a single host machine is limited only by the amount of RAM on the host machine.

You can change the amount of memory available to all virtual machines by modifying Workstation Pro memory settings.

**Selecting the Network Connection Type for a Virtual Machine**

When you select a custom configuration, the New Virtual Machine wizard prompts you to configure the network connection type for the virtual machine.

If you are creating a remote virtual machine, you must select either a custom network or no network connection.

**Table 4-7. Network Connection Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use bridged networking</td>
<td>Configure a bridged network connection for the virtual machine. With bridged networking, the virtual machine has direct access to an external Ethernet network. The virtual machine must have its own IP address on the external network. If your host system is on a network and you have a separate IP address for your virtual machine (or can get an IP address from a DHCP server), select this setting. Other computers on the network can then communicate directly with the virtual machine.</td>
</tr>
<tr>
<td>Use network address translation (NAT)</td>
<td>Configure a NAT connection for the virtual machine. With NAT, the virtual machine and the host system share a single network identity that is not visible outside the network. Select NAT if you do not have a separate IP address for the virtual machine, but you want to be able to connect to the Internet.</td>
</tr>
<tr>
<td>Use host-only networking</td>
<td>Configure a host-only network connection for the virtual machine. Host-only networking provides a network connection between the virtual machine and the host system, using a virtual network adapter that is visible to the host operating system. With host-only networking, the virtual machine can communicate only with the host system and other virtual machines in the host-only network. Select host-only networking to set up an isolated virtual network.</td>
</tr>
<tr>
<td>Do not use a network connection</td>
<td>Do not configure a network connection for the virtual machine.</td>
</tr>
<tr>
<td>Custom (Windows host) or Named Network (Linux host)</td>
<td>(Remote virtual machine only) Select a specific virtual network.</td>
</tr>
</tbody>
</table>

See Chapter 9, “Configuring Network Connections,” on page 175 for information about virtual switches, virtual network adapters, the virtual DHCP server, and the NAT device.

**Selecting the I/O Controller Type for a Virtual Machine**

When you select a custom configuration, the New Virtual Machine wizard prompts you to select the I/O controller type for the virtual machine.

Workstation Pro installs an IDE controller and a SCSI controller in the virtual machine. SATA controllers are supported for some guest operating systems. The IDE controller is always ATAPI. For the SCSI controller, you can choose BusLogic, LSI Logic, or LSI Logic SAS. If you are creating a remote virtual machine on an ESX host, you can also select a VMware Paravirtual SCSI (PVSCSI) adapter.

BusLogic and LSI Logic adapters have parallel interfaces. The LSI Logic SAS adapter has a serial interface. The LSI Logic adapter has improved performance and works better with generic SCSI devices. The LSI Logic adapter is also supported by ESX Server 2.0 and later.
PVSCSI adapters are high-performance storage adapters that can provide greater throughput and lower CPU utilization. They are best suited for environments where hardware or applications drive a very high amount of I/O throughput, such as SAN environments. PVSCSI adapters are not suited for DAS environments.

**Note**  The choice of SCSI controller does not affect whether the virtual disk can be an IDE, SCSI, or SATA disk.

Some guest operating systems, such as Windows XP, do not include a driver for the LSI Logic or LSI Logic SAS adapter. You must download the driver from the LSI Logic Web site. Drivers for a Mylex (BusLogic) compatible host bus adapter are not obvious on the LSI Logic Web site. Search the support area for the numeric string in the model number, for example, search for 958 for BT/KT-958 drivers.

See the *VMware Guest Operating System Installation Guide* for driver support information. For guest operating system support information and known issues, as well as SATA support, see the online Compatibility Guide on the VMware Web site.

## Selecting a Hard Disk for a Virtual Machine

When you select a custom configuration, the New Virtual Machine wizard prompts you to configure a hard disk for the virtual machine.

Virtual hard disks are the best choice for most virtual machines because they are easy to set up and can be moved to new locations on the same host system or to different host systems. In a typical configuration, Workstation Pro creates a new virtual hard disk for the virtual machine.

In some cases, you might want to select an existing virtual hard disk or give the virtual machine access to a physical hard disk or unused partition on the host system.

- **Selecting the Virtual Hard Disk Type for a Virtual Machine** on page 47
  
  If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to select the virtual hard disk type for the virtual machine.

- **Selecting the Disk Mode** on page 47
  
  When you select a custom configuration on a Linux host, you can use the New Virtual Machine wizard to configure normal or independent mode for a disk.

- **Prepare to Use a Physical Disk or Unused Partition** on page 47
  
  You must perform certain tasks before you configure a virtual machine to use a physical disk or unused partition on the host system.

- **Specifying Disk Capacity for a Virtual Machine** on page 48
  
  If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to set the size of the virtual disk and specify whether to split the disk into multiple virtual disk (.vmdk) files.

- **Specifying the Name and Location of Virtual Disk Files** on page 49
  
  During a custom configuration, if you instruct the New Virtual Machine wizard to create a new virtual disk, use an existing virtual disk, or use a physical disk, the wizard prompts you for the name and location of a virtual disk (.vmdk) file.
Selecting the Virtual Hard Disk Type for a Virtual Machine

If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to select the virtual hard disk type for the virtual machine.

You can set up a virtual disk as an IDE disk for any guest operating system. You can set up a virtual disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or BusLogic SCSI controller available in the virtual machine. You can set up a virtual disk as SATA for some guest operating systems.

You can change virtual disk node and mode settings after a virtual machine is created.

Selecting the Disk Mode

When you select a custom configuration on a Linux host, you can use the New Virtual Machine wizard to configure normal or independent mode for a disk.

In normal mode, disks are included in snapshots that you take of the virtual machine. If you do not want data on the disk to be recorded when you take a snapshot of the virtual machine, configure the disk to be independent.

If you configure a disk to be independent, you can further specify whether changes you make to the disk are to persist or be discarded when you power off the virtual machine or restore a snapshot.

You can also exclude virtual disks from snapshots by modifying virtual machine settings.

Prepare to Use a Physical Disk or Unused Partition

You must perform certain tasks before you configure a virtual machine to use a physical disk or unused partition on the host system.

You must perform these tasks before you run the New Virtual Machine wizard to add a physical disk to a new virtual machine, and before you add a physical disk to an existing virtual machine.

Procedure

1. If a partition is mounted by the host or in use by another virtual machine, unmount it.

   The virtual machine and guest operating system access a physical disk partition while the host continues to run its operating system. Corruption is possible if you allow the virtual machine to modify a partition that is simultaneously mounted on the host operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| **The partition is mapped to a Windows Server 2008 R2 or Windows Server 2012 R2 host** | a. Select Start > Settings > Control Panel > Administrative Tools > Computer Management > Storage > Disk Management.  
b. Select a partition and select Action > All Tasks > Change Drive Letter and Paths.  
c. Click Remove. |
| **The partition is mapped to a Windows 7, Windows 8, or Windows 10 host** | a. Select Start > Control Panel.  
b. In the menu bar, click the arrow next to Control Panel.  
c. From the drop-down menu, select All Control Panel Items > Administrative Tools > Computer Management > Storage > Disk Management (Local).  
d. Right-click a partition and choose Change Drive Letter and Paths.  
e. Click Remove and OK. |
2 Check the guest operating system documentation regarding the type of partition on which the guest operating system can be installed.

On Windows 7 hosts, you cannot use the system partition, or the physical disk that contains it, in a virtual machine. Other operating systems, such as Linux, can be installed on a primary or an extended partition on any part of the drive.

3 If the physical partition or disk contains data that you need in the future, back up the data.

4 If you use a Windows host IDE disk in a physical disk configuration, verify that it is not configured as the slave on the secondary IDE channel if the master on that channel is a CD-ROM drive.

5 On a Linux host, set the device group membership or device ownership appropriately.
   a Verify that the master physical disk device or devices are readable and writable by the user who runs Workstation Pro.
      Physical devices, such as /dev/hda (IDE physical disk) and /dev/sdb (SCSI physical disk), belong to group-id disk on most distributions. If this is the case, you can add Workstation Pro users to the disk group. Another option is to change the owner of the device. Consider all the security issues involved in this option.
   b Grant Workstation Pro users access to all /dev/hd[a-bcd] physical devices that contain operating systems or boot managers.
      When permissions are set correctly, the physical disk configuration files in Workstation Pro control access. This reliability provides boot managers access to configuration files and other files they might need to boot operating systems. For example, LILO needs to read /boot on a Linux partition to boot a non-Linux operating system that might be on another drive.

### Specifying Disk Capacity for a Virtual Machine

If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to set the size of the virtual disk and specify whether to split the disk into multiple virtual disk (.vmdk) files.

A virtual disk is made up of one or more virtual disk files. Virtual disk files store the contents of the virtual machine hard disk drive. Almost all of the file content is virtual machine data. A small portion of the file is allotted to virtual machine overhead. If the virtual machine is connected directly to a physical disk, the virtual disk file stores information about the partitions that the virtual machine is allowed to access.

You can set a size between 0.001 GB and 8 TB for a virtual disk file. You can also select whether to store a virtual disk as a single file or split it into multiple files.

Select **Split virtual disk into multiple files** if the virtual disk is stored on a file system that has a file size limitation. When you split a virtual disk less than 950 GB, a series of 2-GB virtual disk files are created. When you split a virtual disk greater than 950 GB, two virtual disk files are created. The maximum size of the first virtual disk file is 1.9 TB and the second virtual disk file stores the rest of the data.

For custom configurations, you can select **Allocate all disk space now** to allocate all disk space immediately rather than allow the disk space to gradually grow to the maximum amount. Allocating all the disk space immediately might provide better performance, but it is a time-consuming operation that requires as much physical disk space as you specify for the virtual disk. If you allocate all the disk space immediately, you cannot use the shrink disk feature.

After you create a virtual machine, you can edit virtual disk settings and add additional virtual disks.
Disk Size Compatibility

The size of a virtual disk is limited to 8 TBs. However, your hardware version, bus type, and controller type also impact the size of your virtual disks.

<table>
<thead>
<tr>
<th>Workstation Hardware Version</th>
<th>Bus Type</th>
<th>Controller Type</th>
<th>Maximum Disk Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>10, 11, 12</td>
<td>IDE</td>
<td>ATAPI</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SCSI</td>
<td>BusLogic</td>
<td>2040 GB (2TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SCSI</td>
<td>LSI Logic</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SCSI</td>
<td>LSI Logic SAS</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>10, 11, 12</td>
<td>SATA</td>
<td>AHCI</td>
<td>8192 GB (8TB)</td>
</tr>
<tr>
<td>9, 8, 7, 6.5</td>
<td>All</td>
<td>All</td>
<td>2040 GB (2TB)</td>
</tr>
<tr>
<td>6.0, 5</td>
<td>All</td>
<td>All</td>
<td>950 GB</td>
</tr>
</tbody>
</table>

To discover your controller type, open the virtual machine .vmx file. The value of the setting scsi0.virtualDev determines your controller type.

<table>
<thead>
<tr>
<th>Value</th>
<th>Controller Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank or not present</td>
<td>BusLogic</td>
</tr>
<tr>
<td>lsilogic</td>
<td>LSI Logic</td>
</tr>
<tr>
<td>lsisas1068</td>
<td>LSI Logic SAS</td>
</tr>
</tbody>
</table>

Specifying the Name and Location of Virtual Disk Files

During a custom configuration, if you instruct the New Virtual Machine wizard to create a new virtual disk, use an existing virtual disk, or use a physical disk, the wizard prompts you for the name and location of a virtual disk (.vmdk) file.

Table 4-8. Required Information for Each Disk Type

<table>
<thead>
<tr>
<th>Type of Disk</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New virtual disk</td>
<td>If you specified that all disk space should be stored in a single file, Workstation Pro uses the filename that you provide to create one 40GB disk file. If you specified that disk space should be stored in multiple files, Workstation Pro generates subsequent filenames by using the filename that you provide. If you specified that files can increase in size, subsequent filenames include an s in the file number, for example, Windows 7-s001.vmdk. If you specified that all disk space should be allocated when the virtual disk is created, subsequent filenames include an f in the file number, for example, Windows 7-f001.vmdk.</td>
</tr>
<tr>
<td>Existing virtual disk</td>
<td>You select the name and location of an existing virtual disk file.</td>
</tr>
<tr>
<td>Physical disk</td>
<td>After the wizard prompts you to select a physical device and specify whether to use the entire disk or individual partitions, you must specify a virtual disk file. Workstation Pro uses this virtual disk file to store partition access configuration information for the physical disk.</td>
</tr>
</tbody>
</table>

**Note** Earlier VMware products use the .dsk extension for virtual disk files.
Customizing Virtual Machine Hardware

You can click Customize Hardware on the last page of the New Virtual Machine wizard to customize the virtual machine hardware.

You can change the default hardware settings, including memory allocation, number of virtual CPUs, CD/DVD and floppy drive settings, and the network connection type.

Create a New Virtual Machine on the Local Host

You create a new virtual machine on the local host system by running the New Virtual Machine wizard.

You can also use the New Virtual Machine wizard to create shared virtual machines, which can be used by remote users, and remote virtual machines, which run on remote hosts. See Chapter 10, “Using Remote Connections and Sharing Virtual Machines,” on page 211.

Prerequisites

- Verify that you have the information the New Virtual Machine wizard requires to create a virtual machine. See “Preparing to Create a New Virtual Machine,” on page 40.
- Verify that the guest operating system you plan to install is supported. See the online VMware Compatibility Guide on the VMware Web site.
- See the VMware Guest Operating System Installation Guide for information about the guest operating system that you plan to install.
- If you are installing the guest operating system from an installer disc, insert the installer disc in the CD-ROM drive in the host system.
- If you are installing the guest operating system from an ISO image file, verify that the ISO image file is in a directory that is accessible to the host system.
- If the virtual machine will use a physical disk or unused partition on the host system, perform the appropriate preparation tasks. See “Prepare to Use a Physical Disk or Unused Partition,” on page 47.

Procedure


   + Windows host
     - If the host is not connected to a remote server, select File > New Virtual Machine.
     - If the host is connected to a remote server, select File > New Virtual Machine > On this Computer.

   + Linux host
     - Select File > New Virtual Machine.

2. Select the configuration type.

   + Typical
     - The wizard prompts you to specify or accept defaults for basic virtual machine settings. The typical configuration type is appropriate in most instances.

   + Custom
     - You must select the custom configuration type to make a different virtual machine version than the default hardware compatibility setting, specify the I/O adapter type for SCSI adapters, specify whether to create an IDE, SCSI, or SATA virtual disk, use a physical disk instead of a virtual disk, use an existing virtual disk, or allocate all virtual disk space rather than let disk space gradually grow to the maximum disk size.
3 If you selected the **Custom** option, select a hardware compatibility setting.

The hardware compatibility setting determines the hardware features of the virtual machine.

4 Select the source of the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical disc</td>
<td>Select the physical drive where you inserted the installation disc.</td>
</tr>
<tr>
<td>Use an ISO image</td>
<td>Type or browse to the location of the ISO image file for the guest operating system.</td>
</tr>
<tr>
<td>Install the guest operating system later</td>
<td>Create a virtual machine that has a blank disk. You must install the guest operating system manually after you create the virtual machine.</td>
</tr>
</tbody>
</table>

5 Specify information about the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are using Easy Install</td>
<td>Type the Easy Install information for the guest operating system.</td>
</tr>
<tr>
<td>You are not using Easy Install</td>
<td>Select the guest operating system type and version. If the guest operating system is not listed, select Other.</td>
</tr>
</tbody>
</table>

6 Type a virtual machine name and type or browse to the directory for the virtual machine files.

7 Follow the prompts to configure the virtual machine.

   If you selected a typical configuration, the wizard prompts you to configure the virtual disk size and specify whether the disk should be split into multiple files. If you selected a custom configuration, the wizard prompts you to configure the virtual machine processors, memory allocation, networking configuration, I/O controller types, virtual disk type and mode, and virtual disk.

8 (Optional) Click **Customize Hardware** to customize the hardware configuration.

   You can also modify virtual hardware settings after you create the virtual machine.

9 (Optional) Select **Power on this virtual machine after creation** to power on the virtual machine after you create it.

   This option is not available if you are installing the guest operating system manually.

10 Click **Finish** to create the virtual machine.

If you are using Easy Install, guest operating system installation begins when the virtual machine powers on. The guest operating system installation is automated and typically runs without requiring any input from you. After the guest operating system is installed, Easy Install installs VMware Tools.

If you are not using Easy Install, the virtual machine appears in the library.

**What to do next**

If you used Easy Install and the virtual machine did not power on when you finished the New Virtual Machine wizard, power on the virtual machine to start the guest operating system installation. See “Use Easy Install to Install a Guest Operating System,” on page 51.

If you did not use Easy Install, install the guest operating system manually. See “Install a Guest Operating System Manually,” on page 52.

**Use Easy Install to Install a Guest Operating System**

When you use Easy Install, you usually do not need to provide information during guest operating system installation.

If you did not provide all of the Easy Install information in the New Virtual Machine wizard, you might be prompted for a product key, user name, or password.
Also, if the guest operating system installation consists of multiple discs or ISO image files, the installer might prompt you for the next disk.

**Procedure**

- If the installer prompts you for a product key, user name, or password, click in the virtual machine window and type the required information.

  Mouse and keyboard input are captured by the virtual machine.

- If you are using physical discs and the installer prompts you for the next disk, use the CD-ROM or DVD drive on the host system.

- If you are using multiple ISO image files and the installer prompts you for the next disk, select the next ISO image file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Click Change Disk and browse to the next ISO image file.</td>
</tr>
<tr>
<td>Linux host</td>
<td>a Select VM &gt; Removable Devices &gt; CD/DVD &gt; Settings and browse to the next ISO image file.</td>
</tr>
<tr>
<td></td>
<td>b Select Connected.</td>
</tr>
<tr>
<td></td>
<td>c Click Save.</td>
</tr>
</tbody>
</table>

**Install a Guest Operating System Manually**

Installing a guest operating system in a virtual machine is similar to installing an operating system on a physical computer. If you do not use Easy Install when you create a virtual machine in the New Virtual Machine wizard, you must install the guest operating system manually.

You can install a guest operating system from an installer disc or ISO image file. You can also use a PXE server to install the guest operating system over a network connection. If the host configuration does not permit the virtual machine to boot from an installer disc, you can create an ISO image file from the installer disc.

**Prerequisites**

- Verify that the operating system is supported. See the online VMware Compatibility Guide on the VMware Web site.

- See the VMware Guest Operating System Installation Guide for information on the guest operating system that you are installing.

**Procedure**

1. If you are installing the guest operating system from an installer disc, configure the virtual machine to use a physical CD-ROM or DVD drive and configure the drive to connect at power on.

   a Select the virtual machine and select VM > Settings.

   b On the Hardware tab, select CD/DVD drive.

   c Select Connect at power on.

   d (Remote virtual machine only) Select the location of the CD-ROM or DVD drive.

   e Select Use physical drive and select a the drive.

   f Click OK to save your changes.
2. If you are installing the guest operating system from an ISO image file, configure the CD/DVD drive in the virtual machine to point to the ISO image file and configure the drive to connect at power on.
   a. Select the virtual machine and select VM > Settings.
   b. On the Hardware tab, select CD/DVD drive.
   c. Select Connect at power on.
   d. (Remote virtual machine only) Select the location of the ISO image file.
   e. Select Use ISO image file and browse to the location of the ISO image file.
   f. Click OK to save your changes.

3. If you are installing the guest operating system from an installer disc, insert the disc in the CD-ROM or DVD drive.

4. Power on the virtual machine.

5. Follow the installation instructions provided by the operating system vendor.

6. If the operating system consists of multiple installer discs and you are prompted to insert the next disc, insert the next disc in the physical drive.

7. If the operating system consists of multiple ISO image files, select the image file for the next CD.
   a. Select VM > Removable Devices > CD/DVD > Disconnect and disconnect from the current ISO image file.
   b. Select VM > Removable Devices > CD/DVD > Settings and select the next ISO image file.
   c. Select Connected and click OK.

8. Use the standard tools in the operating system to configure its settings.

**What to do next**

Install VMware Tools. You should install VMware Tools before you activate the license for the operating system. See “Installing VMware Tools,” on page 61.

### Installing a Guest Operating System on a Physical Disk or Unused Partition

You can install a guest operating system directly on a physical disk or unused partition on the host system.

A physical disk directly accesses an existing local disk or partition. You can use physical disks to run one or more guest operating systems from existing disk partitions.

Workstation Pro supports physical disks up to 2 TB capacity. Booting from an operating system already set up on an existing SCSI disk or partition is not supported.

Running an operating system natively on the host system and switching to running it inside a virtual machine is similar to pulling the hard drive out of one computer and installing it in a second computer that has a different motherboard and hardware. The steps you take depend on the guest operating system in the virtual machine. In most cases, a guest operating system that is installed on a physical disk or unused partition cannot boot outside of the virtual machine, even though the data is available to the host system. See the Dual-Boot Computers and Virtual Machines technical note on the VMware Web site for information about using an operating system that can also boot outside of a virtual machine.
After you configure a virtual machine to use one or more partitions on a physical disk, do not modify the partition tables by running `fdisk` or a similar utility in the guest operating system. If you use `fdisk` or a similar utility on the host operating system to modify the partition table of the physical disk, you must recreate the virtual machine physical disk. All files that were on the physical disk are lost when you modify the partition table.

**Important** You cannot use a physical disk to share files between the host system and a guest operating system. Making the same partition visible to both the host system and a guest operating system can cause data corruption. Instead, use shared folder to share files between the host system and a guest operating system.

### Create a Virtual Machine Shortcut

You can use a shortcut to select a virtual machine from your desktop.

**Prerequisites**

A virtual machine must be present in the Workstation Pro Virtual Machine Library.

This feature is available on Windows host systems only.

**Procedure**

1. Select a virtual machine from the virtual machine library.
2. Drag the virtual machine to the host desktop or to a folder.

A shortcut is created for the virtual machine.

You can select the virtual machine by double-clicking the shortcut.

### Cloning Virtual Machines

Installing a guest operating system and applications can be time consuming. With clones, you can make many copies of a virtual machine from a single installation and configuration process. Cloning a virtual machine is faster and easier than copying it.

Clones are useful when you must deploy many identical virtual machines to a group. For example, an MIS department can clone a virtual machine that has a suite of preconfigured office applications for each employee. You can also configure a virtual machine that has a complete development environment and then clone it repeatedly as a baseline configuration for software testing.

The existing virtual machine is called the parent virtual machine. When the cloning operation is complete, the clone becomes a separate virtual machine.

Changes made to a clone do not affect the parent virtual machine, and changes made to the parent virtual machine do not appear in a clone. The MAC address and UUID for a clone are different from the parent virtual machine.

- **Using Linked Clones** on page 55
  A linked clone is a copy of a virtual machine that shares virtual disks with the parent virtual machine in an ongoing manner.

- **Using Full Clones** on page 55
  A full clone is a complete and independent copy of a virtual machine. It shares nothing with the parent virtual machine after the cloning operation. Ongoing operation of a full clone is entirely separate from the parent virtual machine.
Using Linked Clones

A linked clone is a copy of a virtual machine that shares virtual disks with the parent virtual machine in an ongoing manner.

Because a linked clone is made from a snapshot of the parent, disk space is conserved and multiple virtual machines can use the same software installation. All files available on the parent at the moment you take the snapshot continue to remain available to the linked clone.

Ongoing changes to the virtual disk of the parent do not affect the linked clone, and changes to the disk of the linked clone do not affect the parent. A linked clone must have access to the parent. Without access to the parent, you cannot use a linked clone.

Because linked clones are created swiftly, you can create a unique virtual machine for each task. You can also share a virtual machine with other users by storing the virtual machine on your local network where other users can quickly make a linked clone. For example, a support team can reproduce a bug in a virtual machine, and an engineer can quickly make a linked clone of that virtual machine to work on the bug.

You can make a linked clone from a linked clone, but the performance of the linked clone degrades. If you make a full clone from a linked clone, the full clone is an independent virtual machine that does not require access to the linked clone or its parent. You should make a linked clone of the parent virtual machine, if possible.

**IMPORTANT** You cannot delete a linked clone snapshot without destroying the linked clone. You can safely delete the snapshot only if you also delete the clone that depends on it.

Using Full Clones

A full clone is a complete and independent copy of a virtual machine. It shares nothing with the parent virtual machine after the cloning operation. Ongoing operation of a full clone is entirely separate from the parent virtual machine.

Because a full clone does not share virtual disks with the parent virtual machine, full clones generally perform better than linked clones. Full clones take longer to create than linked clones. Creating a full clone can take several minutes if the files involved are large.

Because a full clone duplicates only the state of the virtual machine at the instant of the cloning operation, it does not have access to snapshots of the parent virtual machine.

Enable Template Mode for a Parent Virtual Machine of Linked Clones

To prevent the parent virtual machine for a linked clone from being deleted, you can designate the parent as a template. When template mode is enabled, the virtual machine, and snapshots of the virtual machine, cannot be deleted.

**NOTE** You cannot enable template mode for a shared or remote virtual machine.
**Prerequisites**

If the parent does not have at least one snapshot, create a snapshot. See “Taking Snapshots of Virtual Machines,” on page 105.

**Procedure**

1. Select the virtual machine to use as a parent of the linked clone and select **VM > Settings**.
2. On the **Options** tab, select **Advanced**.
3. Select **Enable Template mode (to be used for cloning)** and click **OK**.

**Clone a Virtual Machine**

The Clone Virtual Machine wizard guides you through the process of cloning a virtual machine. You do not need to locate and manually copy the parent virtual machine files.

**Prerequisites**

- Familiarize yourself with the different types of clones. See “Using Full Clones,” on page 55 and “Using Linked Clones,” on page 55.
- Run a defragmentation utility in the guest operating system to defragment the drives on the parent virtual machine.
- If the parent virtual machine is a Workstation 4.x and Workstation 4.x-compatible virtual machine, upgrade it to Workstation 5.x or later.
- If you are creating a linked clone, enable template mode for the parent virtual machine. See “Enable Template Mode for a Parent Virtual Machine of Linked Clones,” on page 55.
- Power off the parent virtual machine.

**Procedure**

1. Select the parent virtual machine and select **VM > Manage > Clone**.
2. Select the state of the parent from which you want to create a clone.
   - You can create a clone from the current state of the parent virtual machine or from an existing snapshot.
   - If you select the current state, Workstation Pro creates a snapshot of the parent virtual machine before cloning it.
   - **Note**: You cannot clone from the current state if template mode is enabled for the parent virtual machine.
3. Specify whether to create a linked clone or a full clone.
4. Type a name and a location for the cloned virtual machine.
5. Click **Finish** to create the clone and **Close** to exit the wizard.
   - A full clone can take several minutes to create, depending on the size of the virtual disk that is being duplicated.
6. If the parent virtual machine uses a static IP address, change the static IP address of the clone before the clone connects to the network to prevent IP address conflicts.
   - Although the wizard creates a new MAC address and UUID for the clone, other configuration information, such as the virtual machine name and static IP address configuration, is identical to that of the parent virtual machine.

The summary view for a linked clone shows the path to the virtual machine configuration (.vmx) file of the parent virtual machine.
Virtualize a Physical Machine

You can create a virtual machine from a Windows physical machine in Workstation Pro. When you virtualize a physical machine, you capture all of the applications, documents, and settings on the physical machine in a new virtual machine. Workstation Pro must be running on a Windows host system to use this feature.

Prerequisites

- Verify that the physical machine that you want to virtualize is running Windows. You cannot create a virtual machine from a non-Windows physical machine in Workstation Pro.

  **Note** You can create a virtual machine from a Linux physical machine using vCenter Converter Standalone. For more information, see the vCenter Converter Standalone documentation.

- Verify that you have administrative access on the physical machine that you want to virtualize and on the Workstation Pro host system.

- Verify that the Workstation Pro host system has network access to the physical machine that you want to virtualize.

- Verify that on the Workstation Pro host system you have disabled User Account Control (UAC). For instructions, see “Prepare a Windows Physical Machine for Virtualization,” on page 58.

- Turn off firewall applications running on the physical machine that you want to virtualize.

- Prepare the physical machine for virtualization. See “Prepare a Windows Physical Machine for Virtualization,” on page 58.

Procedure

1. Power on the physical machine that you want to virtualize.


   If you have never virtualized a physical machine or imported a third-party virtual machine in Workstation Pro, you need to download and install VMware vCenter Converter Standalone. After the VMware vCenter Converter Standalone installation is finished, you must restart the virtualization wizard.

3. Type the hostname or IP address, user name, and password for the physical machine that you want to virtualize.

   You must use the Administrator account or a user account that is a member of the local Administrators group.

4. Type a name for the new virtual machine and specify a location on the host system in which to store the virtual machine files.

5. Type the user name and password for your user account on the host system.

6. Click **Finish** to create a virtual machine from the physical machine.

   The amount of time required to create the virtual machine depends on the size of the hard disk on the physical machine.

VMware Tools installation begins the first time you power on the new virtual machine.
Prepare a Windows Physical Machine for Virtualization

To avoid problems related to permissions and network access, you must perform certain steps to prepare a Windows physical machine before you run the Virtualize a Physical Machine wizard.

Procedure

- Disable User Account Control (UAC) on the Windows physical machine.
  - On Windows Vista, open the User Accounts control panel, select Turn User Account Control On or Off, and deselect Use User Account Control (UAC) to help protect your computer.
  - On Windows 7 or later, open the Change User Account Control Settings control panel and drag the slider to Never notify.

Troubleshoot Windows Authentication Problems During Physical Machine Virtualization

User authentication fails when the Virtualize a Physical Machine wizard attempts to connect a Windows physical machine.

Problem

After you provide user credentials for the physical machine, the Virtualize a Physical Machine wizard reports that your user credentials are incorrect or you have insufficient permissions to connect to the physical machine.

Cause

Simple file sharing or User Account Control (UAC) is enabled on the physical machine.

Solution

Perform the steps in “Prepare a Windows Physical Machine for Virtualization,” on page 58 and rerun the Virtualize a Physical Machine wizard.

Troubleshoot Windows Activation Problems

A virtual machine that you create from a physical machine prompts you to activate Windows when you use it in Workstation Pro.

Problem

After you create a virtual machine from a Windows Vista or Windows 7 physical machine, or from a physical PC that came with Windows preinstalled, you were required to reactivate Windows in the virtual machine.

Cause

When you create a virtual machine from a Windows Vista or Windows 7 physical machine, the operating system detects that the computer hardware has changed. When you make a significant hardware change, Microsoft requires you to activate Windows again.

The OEM versions of Windows that are preinstalled on some new computers are customized for those computers. OEM licenses of Windows are not transferrable.

Solution

Any virtual machine that was created from a physical machine that had its Windows license key successfully activated needs to be reactivated when you run it in Workstation Pro.
The activation process in Windows Vista and Windows 7 is different from the Windows XP activation process. In Windows 7, retail activation keys are good for only one use. If you enter the same activation key in Workstation Pro that you used previously, you cannot successfully activate the virtual machine.

The activation wizard tells you that the activation key was already used and prompts you to call the Microsoft activation hotline to get a second key. If you did not previously call the hotline for the same license key, you should receive a new activation key. Your call is not transferred to an operator unless you call repeatedly for the same key.

See the Microsoft Web site for more information about why reactivation is necessary.

Importing Virtual Machines

You can import virtual machines in other formats into Workstation Pro.

Import a Windows XP Mode Virtual Machine

You can import a Windows XP Mode virtual machine and run it in Workstation Pro. When you import a Windows XP Mode virtual machine, Workstation Pro creates a new virtual machine in VMware runtime (.vmx) format.

You can power on only one Windows XP Mode virtual machine at a time in Workstation Pro. If you move a Windows XP Mode virtual machine to another host system, it becomes a new virtual machine and you must activate it.

Note Changes made to the original Windows XP Mode virtual machine through Virtual PC do not affect the virtual machine imported in Workstation Pro.

Prerequisites

- Verify that the Windows 7 Professional, Enterprise, or Ultimate edition operating system is running on the host system. Importing Windows XP Mode virtual machines is not supported on Linux host systems or on host systems that are running other versions of Windows.
- Download and install the Windows XP Mode virtual machine on the host system.

Procedure

1. Select File > Open and browse to the virtual machine configuration (.vmc) file.
   If you have never virtualized a physical machine or imported a third-party virtual machine in Workstation Pro, you need to download and install VMware vCenter Converter Standalone. After the VMware vCenter Converter Standalone installation is finished, you must restart the import.

2. Type a name for the new virtual machine, type or browse to the directory for the virtual machine files, and click Import.
   Workstation Pro begins importing the Windows XP Mode virtual machine.

   After Workstation Pro successfully imports the Windows XP Mode virtual machine, a new virtual machine appears in the virtual machine library.

Import an Open Virtualization Format Virtual Machine

You can import an Open Virtualization Format (OVF) virtual machine and run it in Workstation Pro. Workstation Pro converts the virtual machine from OVF format to VMware runtime (.vmx) format. You can import both .ovf and .ova files.

OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual machines. For example, you can import OVF virtual machines exported from VMware Fusion™ or Oracle VM VirtualBox into Workstation Pro. You can import OVF 1.0 and later files only.
You can also use the standalone OVF Tool to convert an OVF virtual machine to VMware runtime format. The standalone version of the OVF Tool is installed in the Workstation Pro installation directory under OVFTool. See the OVF Tool User Guide on the VMware Web site for information on using the OVF Tool.

**Procedure**

1. In Workstation Pro, select **File > Open**.
2. Browse to the .ovf or .ova file and click **Open**.
3. Type a name for the virtual machine, type or browse to the directory for the virtual machine files, and click **Import**.

   Workstation Pro performs OVF specification conformance and virtual hardware compliance checks. A status bar indicates the progress of the import process.

4. If the import fails, click **Retry** to try again, or click **Cancel** to cancel the import.

   If you retry the import, Workstation Pro relaxes the OVF specification conformance and virtual hardware compliance checks and you might not be able to use the virtual machine in Workstation Pro.

After Workstation Pro successfully imports the OVF virtual machine, the virtual machine appears in the virtual machine library.

**Import a Windows Virtual PC Virtual Machine**

You can import a Windows Virtual PC virtual machine and run it in Workstation Pro. Workstation Pro converts the virtual machine from Virtual PC (.vmc) format to VMware runtime (.vmx) format. This feature is supported only on Windows host systems.

**Prerequisites**

Download and install the Virtual PC virtual machine on the Windows host system.

**Procedure**

1. In Workstation Pro, select **File > Open**.

   If you have never imported a third-party virtual machine or virtualized a physical machine in Workstation Pro, Workstation Pro installs VMware vCenter Converter Standalone. After the installation is finished, you must restart the import.

2. Browse to the .vmc file and click **Open**.

3. Type a name for the virtual machine, type or browse to the directory for the virtual machine files, and click **Import**.

After Workstation Pro successfully imports the Virtual PC virtual machine, the virtual machine appears in the virtual machine library.

**Installing and Upgrading VMware Tools**

Installing VMware Tools is part of the process of creating a new virtual machine. Upgrading VMware Tools is part of the process of keeping virtual machines up to current standards.

For the best performance and latest updates, install or upgrade VMware Tools to match the version of Workstation Pro that you are using. Other compatibility options are also available.

Installing VMware Tools on page 61
Although your guest operating systems can run without VMware Tools, many VMware features are not available until you install VMware Tools. When you install VMware Tools, the utilities in the tools suite enhances the performance of your virtual machine's guest operating system and improves the management of your virtual machines.

Upgrading VMware Tools on page 62
You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

Configure Automatic Software Updates on page 63
You can configure Workstation Pro to automatically download software updates, including new versions of VMware Tools. When automatic software updates are enabled, Workstation Pro always includes the latest support for guest operating systems and virtual machines always have the latest version of VMware Tools.

Configure VMware Tools Updates for a Specific Virtual Machine on page 64
You can configure virtual machines that have Windows or Linux guest operating systems to update VMware Tools automatically. For other guest operating systems, you must manually update VMware Tools.

Manually Installing and Upgrading VMware Tools on page 65
You can manually install or upgrade VMware Tools on Windows, Linux, NetWare, Solaris, and FreeBSD virtual machines.

Start the VMware User Process Manually If You Do Not Use a Session Manager on page 70
VMware Tools in Linux, Solaris, and FreeBSD guest operating systems uses the VMware User process executable file. This program implements the fit-guest-to-window feature and Unity mode, among other features.

Uninstalling VMware Tools on page 71
If the upgrade process of VMware Tools is incomplete, you can uninstall and then reinstall the VMware Tools.

Installing VMware Tools
Although your guest operating systems can run without VMware Tools, many VMware features are not available until you install VMware Tools. When you install VMware Tools, the utilities in the tools suite enhances the performance of your virtual machine's guest operating system and improves the management of your virtual machines.

Installing VMware Tools is part of the process of creating new virtual machines, and upgrading VMware Tools is part of the process of keeping your virtual machine up to current standards. For information about creating virtual machines, see the Virtual Machine Administration Guide.

The installers for VMware Tools are ISO image files. An ISO image file looks like a CD-ROM to your guest operating system. Each type of guest operating system, including Windows, Linux, Solaris, FreeBSD, and NetWare, has an ISO image file. When you select the command to install or upgrade VMware Tools, the virtual machine's first virtual CD-ROM disk drive temporarily connects to the VMware Tools ISO file for your guest operating system.

You can use the Windows Easy Install or Linux Easy Install feature to install VMware Tools as soon as the operating system is finished installing.
The most recent versions of the ISO files are stored on a VMware Web site. When you select the command to install or upgrade VMware Tools, the VMware product determines whether it has downloaded the most recent version of the ISO file for the specific operating system. If the latest version has not been downloaded or if no VMware Tools ISO file for that operating system has ever been downloaded, you are prompted to download the file.

- For information about installing or upgrading VMware Tools in Windows virtual machines, see “Manually Install or Upgrade VMware Tools in a Windows Virtual Machine,” on page 65 and Automate VMware Tools Installation for Multiple Windows Virtual Machines.
- For information about installing or upgrading VMware Tools in Linux virtual machines, see “Manually Install or Upgrade VMware Tools in a Linux Virtual Machine,” on page 66.
- For information about installing or upgrading VMware Tools in Solaris virtual machines, see “Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine,” on page 68.
- For information about installing or upgrading VMware Tools in NetWare virtual machines, see “Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine,” on page 68.
- For information about installing or upgrading VMware Tools in FreeBSD virtual machines, see “Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine,” on page 69.

Upgrading VMware Tools

You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

The guest operating system checks the version of VMware Tools when you power on a virtual machine. The status bar of your virtual machine displays a message when a new version is available.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon when a VMware Tools upgrade is available.

To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware Tools the first time. Upgrading VMware Tools means installing a new version.

For Windows and Linux guest operating systems, you can configure the virtual machine to automatically upgrade VMware Tools. Although the version check is performed when you power on the virtual machine, on Windows guest operating systems, the automatic upgrade occurs when you power off or restart the virtual machine. The status bar displays the message Installing VMware Tools ... when an upgrade is in progress.

**IMPORTANT** After you upgrade VMware Tools on Linux guest operating systems, new network modules are available but are not used until you either restart the guest operating system or stop networking, unload and reload the VMware networking kernel modules, and restart networking. This behavior means that even if VMware Tools is set to automatically upgrade, you must restart or reload network modules to make new features available.

This strategy avoids network interruptions and allows you to install VMware Tools over SSH.

Upgrading VMware Tools on Windows guest operating systems automatically installs the WDDM graphics drivers. The WDDM graphics driver makes the sleep mode available in guest OS power settings to adjust the sleep options. For example, you can use the sleep mode setting **Change when the computer sleeps** to configure your guest OS to automatically go to sleep mode after a certain time or prevent your guest OS from automatically switching to sleep mode after being idle for some time.
Some features in a particular release of a VMware product might depend on installing or upgrading to the version of VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not always necessary. Newer versions of VMware Tools are compatible with several host versions. To avoid unnecessary upgrades, evaluate whether the added features and capabilities are necessary for your environment.

**Configure Automatic Software Updates**

You can configure Workstation Pro to automatically download software updates, including new versions of VMware Tools. When automatic software updates are enabled, Workstation Pro always includes the latest support for guest operating systems and virtual machines always have the latest version of VMware Tools.

**Prerequisites**

- On a Linux host, become root. On Linux systems, non-root users are not allowed to modify the preference setting for VMware Tools updates.
- Verify that the host system is connected to the Internet.

**Procedure**

1. Select **Edit > Preferences** and select **Updates**.
2. Select a software update download option.

   If you deselect all of the software update options, automatic software updates are disabled.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check for product updates on startup</td>
<td>When Workstation Pro starts, it checks for new versions of the application and installed software components.</td>
</tr>
<tr>
<td>Check for software components as needed</td>
<td>When a software component is needed, for example, when you install or upgrade VMware Tools on a virtual machine, Workstation Pro checks for a new version of the component.</td>
</tr>
<tr>
<td>Download All Components Now</td>
<td>Click this button to download all software updates immediately. This option is useful if you are planning to use a virtual machine at a later time when you do not have access to the Internet.</td>
</tr>
</tbody>
</table>

3. If you use a proxy server to connect to the Internet, click **Connection Settings** and select a proxy setting.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No proxy</td>
<td>Select this option if you do not use a proxy server. This is the default setting.</td>
</tr>
<tr>
<td>Windows proxy settings</td>
<td>(Windows hosts only) Workstation Pro uses the host proxy settings from the Connections tab in the Internet Options control panel to access the VMware Update Server. Click <strong>Internet Options</strong> to set the guest connection options. Type a user name and password to use for proxy server authentication. If you leave either the <strong>Username</strong> or <strong>Password</strong> text box blank, Workstation Pro does not use either value.</td>
</tr>
<tr>
<td>Manual proxy settings</td>
<td>Select an HTTP or SOCKS proxy, specify the proxy server address and designate a port number to access the VMware Update Server. Type a user name and password to use for proxy server authentication. If you leave either the <strong>Username</strong> or <strong>Password</strong> text box blank, Workstation Pro does not use either value (Windows hosts) or it uses the user name and password set in the gnome settings (Linux hosts).</td>
</tr>
</tbody>
</table>
4 To update VMware Tools when you power on a virtual machine or shut down the guest operating system, select **Automatically update VMware Tools on a virtual machine**.

You can override this setting for a specific virtual machine by modifying virtual machine settings.

When you power on a virtual machine, you are prompted to download VMware Tools if a new version is available.

5 Click **OK** to save your changes.

**What to do next**

To override the VMware Tools update setting for a specific virtual machine, edit the virtual machine settings. See “Configure VMware Tools Updates for a Specific Virtual Machine,” on page 64.

**Configure VMware Tools Updates for a Specific Virtual Machine**

You can configure virtual machines that have Windows or Linux guest operating systems to update VMware Tools automatically. For other guest operating systems, you must manually update VMware Tools.

Automatic VMware Tools updates are supported for versions of VMware Tools included in Workstation 5.5 and later virtual machines only. Automatic updates are not supported for versions of VMware Tools included in virtual machines created with VMware Server 1.x.

**IMPORTANT** If you update VMware Tools in a Windows virtual machine that was created with Workstation 4 or 5.x, some new components are not installed. To install the new components, you must uninstall the old version of VMware Tools and install the new version of VMware Tools.

**Procedure**

1 Select the virtual machine and select **VM > Settings**.

2 On the **Options** tab, select **VMware Tools**.

3 Select a VMware Tools update setting.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Update manually (do nothing)</strong></td>
<td>You must update VMware Tools manually. The virtual machine status bar indicates when a new version of VMware Tools is available.</td>
</tr>
<tr>
<td><strong>Update automatically</strong></td>
<td>VMware Tools is updated automatically. The virtual machine status bar indicates when an update is in progress. If you are logged in to a Windows guest, a restart prompt appears after the update is complete. If you are not logged in, the operating system restarts without prompting. An auto-update check is performed as part of the boot sequence when you power on the virtual machine. If the virtual machine was suspended and you resume it or restore it to a snapshot during the boot sequence before this check, the automatic update occurs as planned. If you resume the virtual machine or restore it to a snapshot after the check, the automatic update does not occur.</td>
</tr>
<tr>
<td><strong>Use application default (currently update manually)</strong></td>
<td>Use the default VMware Tools update behavior. The default behavior is set in Workstation Pro preferences.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>You cannot configure this option for a shared or remote virtual machine.</td>
</tr>
</tbody>
</table>

4 Click **OK** to save your changes.
Manually Installing and Upgrading VMware Tools

You can manually install or upgrade VMware Tools on Windows, Linux, NetWare, Solaris, and FreeBSD virtual machines.

If you are installing VMware Tools in a number of Windows virtual machines, you can automate its installation by using the VMware Tools setup.exe at a command prompt in the guest operating system. See Installing and Configuring VMware Tools at http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf for more information.

- Manually Install or Upgrade VMware Tools in a Windows Virtual Machine on page 65
  All supported Windows guest operating systems support VMware Tools.

- Manually Install or Upgrade VMware Tools in a Linux Virtual Machine on page 66
  For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.

- Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine on page 68
  For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.

- Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine on page 68
  For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.

- Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine on page 69
  For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line.

Manually Install or Upgrade VMware Tools in a Windows Virtual Machine

All supported Windows guest operating systems support VMware Tools.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.

For Windows 2000 and later, VMware Tools installs a virtual machine upgrade helper tool. This tool restores the network configuration if you upgrade the virtual machine compatibility from ESX/ESXi 3.5 to ESX/ESXi 4.0 and later or from Workstation 5.5 to Workstation 6.0 and later.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- If you connected the virtual machine’s virtual CD/DVD drive to an ISO image file when you installed the operating system, change the setting so that the virtual CD/DVD drive is configured to autodetect a physical drive.

The autodetect setting enables the virtual machine’s first virtual CD/DVD drive to detect and connect to the VMware Tools ISO file for a VMware Tools installation. This ISO file looks like a physical CD to your guest operating system. Use the virtual machine settings editor to set the CD/DVD drive to autodetect a physical drive.
Log in as an administrator unless you are using an older Windows operating system. Any user can install VMware Tools in a Windows 95, Windows 98, or Windows ME guest operating system. For operating systems newer than these, you must log in as an administrator.

**Procedure**

1. On the host, from the Workstation Pro menu bar, select **VM > Install VMware Tools**.
   
   If an earlier version of VMware Tools is installed, the menu item is **Update VMware Tools**.

2. If you are installing VMware Tools for the first time, click **OK** on the Install VMware Tools information page.

   If autorun is enabled for the CD-ROM drive in the guest operating system, the VMware Tools installation wizard starts.

3. If autorun is not enabled, to manually launch the wizard, click **Start > Run** and enter `D:\setup.exe`, where `D:` is your first virtual CD-ROM drive. Use `D:\setup64.exe` for 64-bit Windows guest operating system.

4. Follow the on-screen instructions.

5. If the New Hardware wizard appears, follow the prompts and accept the defaults.

6. If you are installing a beta or RC version of VMware Tools and you see a warning that a package or driver is not signed, click **Install Anyway** to complete the installation.

7. When prompted, reboot the virtual machine.

**What to do next**

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

**Manually Install or Upgrade VMware Tools in a Linux Virtual Machine**

For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

**Procedure**

1. On the host, from the Workstation Pro menu bar, select **VM > Install VMware Tools**.

   If an earlier version of VMware Tools is installed, the menu item is **Update VMware Tools**.

2. In the virtual machine, log in to the guest operating system as root and open a terminal window.

3. Run the `mount` command with no arguments to determine whether your Linux distribution automatically mounted the VMware Tools virtual CD-ROM image.

   If the CD-ROM device is mounted, the CD-ROM device and its mount point are listed as something like this:

   ```
   /dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)
   ```
4 If the VMware Tools virtual CD-ROM image is not mounted, mount the CD-ROM drive.

   a If a mount point directory does not already exist, create it.
      
      `mkdir /mnt/cdrom`
      
      Some Linux distributions use different mount point names. For example, on some distributions the mount point is `/media/VMware Tools` rather than `/mnt/cdrom`. Modify the command to reflect the conventions that your distribution uses.

   b Mount the CD-ROM drive.
      
      `mount /dev/cdrom /mnt/cdrom`
      
      Some Linux distributions use different device names or organize the `/dev` directory differently. If your CD-ROM drive is not `/dev/cdrom` or if the mount point for a CD-ROM is not `/mnt/cdrom`, modify the command to reflect the conventions that your distribution uses.

5 Change to a working directory, for example, `/tmp`.

   `cd /tmp`

6 Delete any previous `vmware-tools-distrib` directory before you install VMware Tools.

   The location of this directory depends on where you placed it during the previous installation. Often this directory is placed in `/tmp/vmware-tools-distrib`.

7 List the contents of the mount point directory and note the filename of the VMware Tools tar installer.

   `ls mount-point`

8 Uncompress the installer.

   `tar zxpf /mnt/cdrom/VMwareTools-x.x.x-yyyy.tar.gz`

   The value `x.x.x` is the product version number, and `yyyy` is the build number of the product release.

   If you attempt to install a tar installation over an RPM installation, or the reverse, the installer detects the previous installation and must convert the installer database format before continuing.

9 If necessary, unmount the CD-ROM image.

   `umount /dev/cdrom`

   If your Linux distribution automatically mounted the CD-ROM, you do not need to unmount the image.

10 Run the installer and configure VMware Tools.

   `cd vmware-tools-distrib`
   
   `.vmware-install.pl`

   Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.

11 Follow the prompts to accept the default values, if appropriate for your configuration.

12 Follow the instructions at the end of the script.

   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

**What to do next**

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
**Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine**

For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

**Procedure**

1. On the host, from the Workstation Pro menu bar, select VM > Install VMware Tools.
   
   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2. Load the CD-ROM driver so that the virtual CD-ROM device mounts the ISO image as a volume.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>NetWare 6.5</td>
<td>LOAD CDDVD</td>
</tr>
<tr>
<td>NetWare 6.0 or NetWare 5.1</td>
<td>LOAD CD9660.NSS</td>
</tr>
<tr>
<td>NetWare 4.2 (not available in vSphere)</td>
<td>load cdrom</td>
</tr>
</tbody>
</table>

   When the installation finishes, the message VMware Tools for NetWare are now running appears in the Logger Screen for NetWare 6.5 and NetWare 6.0 guest operating systems and in the Console Screen for NetWare 4.2 and 5.1 operating systems.

3. If the VMware Tools virtual disc (netware.iso) is attached to the virtual machine, right-click the CD-ROM icon in the status bar of the console window and select Disconnect to disconnect it.

**What to do next**

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

**Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine**

For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.
Procedure

1. On the host, from the Workstation Pro menu bar, select VM > Install VMware Tools.
   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2. In the virtual machine, log in to the guest operating system as root and open a terminal window.

3. If the Solaris volume manager does not mount the CD-ROM under /cdrom/vmwaretools, restart the volume manager.
   ```
   /etc/init.d/volmgt stop
   /etc/init.d/volmgt start
   ```

4. Change to a working directory, for example, /tmp.
   ```
   cd /tmp
   ```

5. Extract VMware Tools.
   ```
   gunzip -c /cdrom/vmwaretools/vmware-solaris-tools.tar.gz | tar xf -
   ```

6. Run the installer and configure VMware Tools.
   ```
   cd vmware-tools-distrib
   ./vmware-install.pl
   ```
   Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.

7. Follow the prompts to accept the default values, if appropriate for your configuration.

8. Follow the instructions at the end of the script.
   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine

For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility and avoid downtime in your environment.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

Procedure

1. On the host, from the Workstation Pro menu bar, select VM > Install VMware Tools.
   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2. In the virtual machine, log in to the guest operating system as root and open a terminal window.
3 If the distribution does not automatically mount CD-ROMs, mount the VMware Tools virtual CD-ROM image.
   For example, type `mount /cdrom`.

4 Change to a working directory, for example, `/tmp`.
   `cd /tmp`

5 Untar the VMware Tools tar file.
   `tar xzpf /cdrom/vmware-freebsd-tools.tar.gz`

6 If the distribution does not use automounting, unmount the VMware Tools virtual CD-ROM image.
   `umount /cdrom`

7 Run the installer and configure VMware Tools.
   `cd vmware-tools-distrib`
   `./vmware-install.pl`
   Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.

8 Follow the prompts to accept the default values, if appropriate for your configuration.

9 Follow the instructions at the end of the script.
   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

**What to do next**
If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

## Start the VMware User Process Manually If You Do Not Use a Session Manager

VMware Tools in Linux, Solaris, and FreeBSD guest operating systems uses the VMware User process executable file. This program implements the fit-guest-to-window feature and Unity mode, among other features.

Normally, this process starts after you configure VMware Tools, log out of the desktop environment, and log back in. The `vmware-user` program is located in the directory in which you selected to install binary programs, which defaults to `/usr/bin`. The startup script that you need to modify depends on your system. You must start the process manually in the following environments:

- If you run an X session without a session manager. For example, if you use `startx` to start a desktop session and do not use `xdm`, `kdm`, or `gdm`.
- If you are using an older version of GNOME without `gdm` or `xdm`.
- If you are using a session manager or environment that does not support the Desktop Application Autostart Specification, available from [http://standards.freedesktop.org](http://standards.freedesktop.org).
- If you upgrade VMware Tools.
Procedure

- Start the VMware User process.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start the VMware User process when you start an X session.</td>
<td>Add <code>vmware-user</code> to the appropriate X startup script, such as the <code>.xsession</code> or <code>.xinitrc</code> file.</td>
</tr>
<tr>
<td>Start the process after a VMware Tools software upgrade, or if certain features are not working.</td>
<td>Open a terminal window and type the <code>vmware-user</code> command.</td>
</tr>
</tbody>
</table>

Uninstalling VMware Tools

If the upgrade process of VMware Tools is incomplete, you can uninstall and then reinstall the VMware Tools.

Prerequisites

- Power on the virtual machine.
- Log in to the guest operating system.

Procedure

- Select a method to uninstall VMware Tools.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, 8, 8.1, or Windows 10</td>
<td>In the guest operating system, select Programs &gt; Uninstall a program.</td>
</tr>
<tr>
<td>Windows Vista and Windows Server 2008</td>
<td>In the guest operating system, select Programs and Features &gt; Uninstall a program.</td>
</tr>
<tr>
<td>Windows XP and earlier</td>
<td>In the guest operating system, select Add/Remove Programs.</td>
</tr>
<tr>
<td>Linux</td>
<td>Log in as root and enter <code>vmware-uninstall-tools.pl</code> in a terminal window.</td>
</tr>
<tr>
<td>Mac OS X Server</td>
<td>Use the Uninstall VMware Tools application, found in <code>/Library/Application Support/VMware Tools</code>.</td>
</tr>
</tbody>
</table>

What to do next

Reinstall VMware Tools.

Virtual Machine Files

When you create a virtual machine, Workstation Pro creates a set of files for that specific virtual machine. Virtual machine files are stored in either the virtual machines directory or the working directory. Both directories are typically on the host system.

Table 4-9. Virtual Machine Files

<table>
<thead>
<tr>
<th>Extension</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.vmx</td>
<td><code>vmname.vmx</code></td>
<td>The primary configuration file, which stores virtual machine settings. If you created the virtual machine with an earlier version of Workstation Pro on a Linux host, this file might have a <code>.cfg</code> extension.</td>
</tr>
<tr>
<td>.log</td>
<td><code>vmname.log</code> or <code>vmware.log</code></td>
<td>The main log file. If you need to troubleshoot a problem, refer to this file. This file is stored in the same directory as the <code>.vmx</code> file.</td>
</tr>
</tbody>
</table>
### Table 4-9. Virtual Machine Files (Continued)

<table>
<thead>
<tr>
<th>Extension</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.nvram</td>
<td>vmname.nvram or nvram</td>
<td>The NVRAM file, which stores the state of the virtual machine BIOS. This file is stored in the same directory as the .vmx file.</td>
</tr>
<tr>
<td>.vmdk</td>
<td>vmname.vmdk</td>
<td>Virtual disk files, which store the contents of the virtual machine hard disk drive. These files are stored in the same directory as the .vmx file. A virtual disk is made up of one or more virtual disk files. The virtual machine settings show the name of the first file in the set. This file contains pointers to the other files in the set. If you specify that all disk space should be allocated when the virtual disk is created, these files start at the maximum size and do not grow. Almost all of the file content is virtual machine data. A small portion of the file is allotted to virtual machine overhead. If the virtual machine is connected directly to a physical disk, the virtual disk file stores information about the partitions that the virtual machine is allowed to access. Note: Earlier VMware products use the .dsk extension for virtual disk files.</td>
</tr>
<tr>
<td></td>
<td>vmname-s###.vmdk</td>
<td>If you specified that the files can increase, filenames include an s in the file number, for example, Windows 7-s001.vmdk.</td>
</tr>
<tr>
<td></td>
<td>vmname-f###.vmdk</td>
<td>If all disk space was allocated when the disk was created, filenames include an f, for example, Windows 7-f001.vmdk.</td>
</tr>
<tr>
<td></td>
<td>vmname-disk-###.vmdk</td>
<td>If the virtual machine has one or more snapshots, some files are redo log files. These files store changes made to a virtual disk while the virtual machine is running. The ### indicates a unique suffix that Workstation Pro adds to avoid duplicate file names.</td>
</tr>
<tr>
<td>.vmem</td>
<td>uuid.vmem</td>
<td>The virtual machine paging file, which backs up the guest main memory on the host file system. This file exists only when the virtual machine is running or if the virtual machine fails. It is stored in the working directory.</td>
</tr>
<tr>
<td></td>
<td>snapshot_name_number.vmem</td>
<td>Each snapshot of a virtual machine that is powered on has an associated .vmem file, which contains the guest operating system main memory, saved as part of the snapshot.</td>
</tr>
<tr>
<td>.vmsd</td>
<td>vmname.vmsd</td>
<td>A centralized file for storing information and metadata about snapshots. It is stored in the working directory.</td>
</tr>
<tr>
<td>.vmsn</td>
<td>vmname.Snapshot.vmsn</td>
<td>The snapshot state file, which stores the running state of a virtual machine at the time you take that snapshot. It is stored in the working directory.</td>
</tr>
<tr>
<td></td>
<td>vmname.Snapshot###.vmsn</td>
<td>The file that stores the state of a snapshot.</td>
</tr>
<tr>
<td>.vmss</td>
<td>vmname.vmss</td>
<td>The suspended state file, which stores the state of a suspended virtual machine. It is stored in the working directory. Some earlier VMware products used the .std extension for suspended state files.</td>
</tr>
</tbody>
</table>

Other files, such as lock files, might also be present in the virtual machines directory. Some files are present only while a virtual machine is running.
Using Virtual Machines

When you use virtual machines in Workstation Pro, you can transfer files and text between virtual machines and the host system, print to host printers, connect removable devices, and change display settings. You can use folders to manage multiple virtual machines, take snapshots to preserve virtual machine states, and create screenshots and movies of virtual machines.

You can also use Workstation Pro to interact with remote virtual machines. See Chapter 10, “Using Remote Connections and Sharing Virtual Machines,” on page 211 for more information.

This chapter includes the following topics:

- “Starting Virtual Machines,” on page 73
- “Stopping Virtual Machines,” on page 76
- “Transferring Files and Text,” on page 80
- “Add a Host Printer to a Virtual Machine,” on page 89
- “Using Removable Devices in Virtual Machines,” on page 90
- “Changing the Virtual Machine Display,” on page 96
- “Using Folders to Manage Virtual Machines,” on page 102
- “Taking Snapshots of Virtual Machines,” on page 105
- “Install New Software in a Virtual Machine,” on page 111
- “Take a Screenshot of a Virtual Machine,” on page 112
- “Delete a Virtual Machine,” on page 113

Starting Virtual Machines

When you start a virtual machine, the guest operating system starts and you can interact with the virtual machine. You can use Workstation Pro to start virtual machines on the host system and on remote servers.

To start a virtual machine from the command line, use the vmware command. See Chapter 16, “Using the vmware Command,” on page 285.

- **Start a Virtual Machine** on page 74
  You can start a virtual machine from the VM menu or from the toolbar. When you use the VM menu, you can select a soft or hard power option or start the virtual machine in BIOS setup mode.

- **Start a Virtual Machine That Is Running in the Background** on page 75
  You can start a virtual machine that is running in the background when Workstation Pro is not started.
- **Enable Autologon in a Windows Virtual Machine** on page 75
  
  With Autologon, you can save your login credentials and bypass the login dialog box when you power on a Windows virtual machine. The guest operating system securely stores the password.

- **Enable EFI Support** on page 76
  
  Extensible Firmware Interface (EFI) is replacing BIOS as a technology that newer computers and operating systems use to boot computers. EFI is sometimes referred to as Unified Extensible Firmware Interface (UEFI).

**Start a Virtual Machine**

You can start a virtual machine from the **VM** menu or from the toolbar. When you use the **VM** menu, you can select a soft or hard power option or start the virtual machine in BIOS setup mode.

When virtual machines are in a folder, you can perform batch power operations. See “Using Folders to Manage Virtual Machines,” on page 102.

You can use the AutoStart feature to configure shared and remote virtual machines to start when the host system starts. See “Configure Shared and Remote Virtual Machines to Start with the Host,” on page 223.

**Prerequisites**

- If the virtual machine is on the local host, select **File > Open** and browse to the virtual machine configuration (.vmx) file.

- If the virtual machine is on a remote host, connect to the remote server. See “Connect to a Remote Server,” on page 214.

**Procedure**

- To select a power option when you start the virtual machine, select the virtual machine and select **VM > Power**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Power On</strong></td>
<td>(Hard option) Workstation Pro starts the virtual machine.</td>
</tr>
<tr>
<td><strong>Start Up Guest</strong></td>
<td>(Soft option) Workstation Pro starts the virtual machine and VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script renews the IP address of the virtual machine. On a Linux, FreeBSD, or Solaris guest, the script starts networking for the virtual machine.</td>
</tr>
<tr>
<td><strong>Power On to firmware</strong></td>
<td>Workstation Pro starts the virtual machine in BIOS setup mode.</td>
</tr>
</tbody>
</table>

- To start the virtual machine from the toolbar, select the virtual machine and click the start button.

  The start power control setting that is configured for the virtual machine determines whether Workstation Pro performs a hard or soft power on operation. The configured behavior appears in a tooltip when you mouse over the button.

**What to do next**

Click anywhere inside the virtual machine console to give the virtual machine control of the mouse and keyboard on the host system.
Start a Virtual Machine That Is Running in the Background

You can start a virtual machine that is running in the background when Workstation Pro is not started.

Prerequisites

Set the virtual machine to run in the background. See “Closing Virtual Machines and Exiting Workstation Pro,” on page 77.

Procedure

1. On the host system, click the virtual machine status icon that is located in the notification area of the taskbar.
   A list of the virtual machines that are running in the background appears in a tooltip. The list contains the virtual machines that belong to the currently logged in user.
2. Select a virtual machine from the list in the tooltip.
   Workstation Pro starts and displays the console view of the virtual machine.

Enable Autologon in a Windows Virtual Machine

With Autologon, you can save your login credentials and bypass the login dialog box when you power on a Windows virtual machine. The guest operating system securely stores the password.

Use the Autologon feature if you restart the guest operating system frequently and want to avoid entering your login credentials. You can also use the Autologon feature to grant users access to the guest operating system without sharing your password.

Prerequisites

- Verify that the guest operating system is Windows 2000 or later.
- Verify that you have an existing user account to enable Autologon. The account must be a local machine account, not a domain account.
- Verify that the latest version of VMware Tools is running in the guest operating system.
- Power on the virtual machine.

Procedure

1. Select the virtual machine, select VM > Settings.
2. On the Options tab, select Autologon.
3. Click Enable, type your login credentials, and click OK.
   If you type an incorrect or expired password, you must type your login credentials when you power on the virtual machine.
4. Click OK to save your changes.

When you enable Autologon or change your login credentials, the Autologon settings are saved immediately. Clicking Cancel in the Virtual Machine Settings dialog box does not affect the changes applied to the Autologon settings.
Enable EFI Support

Extensible Firmware Interface (EFI) is replacing BIOS as a technology that newer computers and operating systems use to boot computers. EFI is sometimes referred to as Unified Extensible Firmware Interface (UEFI).

You can choose to boot a virtual machine by using the EFI firmware option or select BIOS in the New Virtual Machine wizard when you use a custom configuration.

You can specify the EFI firmware option when you create a remote virtual machine in shared virtual machine mode.

Prerequisites

Verify that the following conditions are met:

- The guest operating system to be installed on the virtual machine supports EFI firmware.
- The virtual machine uses hardware version 8 or later.
- The software to boot the system is installed.

Procedure

1. In the Workstation Pro interface, select VM > Settings.
2. Click the Options tab and click Advanced.
3. Select the Boot with EFI instead of BIOS check box.
4. Click OK.

Stopping Virtual Machines

You can use Workstation Pro to stop virtual machines on the host system and on remote servers. You can shut down, pause, and suspend virtual machines. You can also close virtual machines and continue running them in the background.

- Shut Down a Virtual Machine on page 77
  You can shut down a virtual machine from the VM menu or from the toolbar. When you use the VM menu, you can select a hard or soft power option.

- Closing Virtual Machines and Exiting Workstation Pro on page 77
  You can close a virtual machine that is running on the local host system without powering it off. By default, Workstation Pro prompts you to select an action when you close a powered-on virtual machine and when you exit Workstation Pro while virtual machines are running on the local host system.

- Pause and Unpause a Virtual Machine on page 78
  You can pause a virtual machine multiple times for a few seconds, or up to several minutes. The pause feature is useful when a virtual machine is engaged in an lengthy, processor-intensive activity that prevents you from using the host system to do a more immediate task.

- Suspend and Resume a Virtual Machine on page 79
  Use the suspend and resume feature to save the current state of a virtual machine. When you resume the virtual machine, the applications that were running before the suspension will resume their running state with their content unchanged.
Shut Down a Virtual Machine

You can shut down a virtual machine from the VM menu or from the toolbar. When you use the VM menu, you can select a hard or soft power option.

You are not required to power off a virtual machine that is running on the local host system before you exit Workstation Pro. You can exit Workstation Pro and leave the virtual machine running in the background. See “Closing Virtual Machines and Exiting Workstation Pro,” on page 77.

When virtual machines are in a folder, you can perform batch power operations. See “Using Folders to Manage Virtual Machines,” on page 102.

Procedure

- To select a power option when you shut down the virtual machine, select the virtual machine and select VM > Power.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Off</td>
<td>(Hard option) Workstation Pro powers off the virtual machine abruptly with no consideration for work in progress.</td>
</tr>
<tr>
<td>Shut Down Guest</td>
<td>(Soft option) Workstation Pro sends a shut down signal to the guest operating system. An operating system that recognizes the signal shuts down gracefully. Not all guest operating systems respond to a shutdown signal from Workstation Pro. If the guest operating system does not respond to the signal, shut down from the guest operating system as you would a physical machine.</td>
</tr>
</tbody>
</table>

- To shut down the virtual machine from the toolbar, select the virtual machine and click the stop button. The stop power control setting that is configured for the virtual machine determines whether Workstation Pro performs a hard or soft power off operation. The configured behavior appears in a tooltip when you mouse over the button.

- To shut down a virtual machine that is suspended, select the virtual machine and click VM > Power > Power Off.

Closing Virtual Machines and Exiting Workstation Pro

You can close a virtual machine that is running on the local host system without powering it off. By default, Workstation Pro prompts you to select an action when you close a powered-on virtual machine and when you exit Workstation Pro while virtual machines are running on the local host system.

**Note** When you close a remote virtual machine, the virtual machine tab closes. If the virtual machine is powered on, it continues to run on the remote host.

**Table 5-1. Close and Exit Actions**

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run in Background</td>
<td>Continue to run the virtual machine in the background. You can interact with the virtual machine through VNC or some other service. By default, a virtual machine status icon appears in the notification area of the taskbar on the host system. When you mouse over this icon, a tooltip shows the number of virtual machines running in the background that belong to the currently logged in user.</td>
</tr>
<tr>
<td>Suspend</td>
<td>Suspend the virtual machine and save its current state.</td>
</tr>
<tr>
<td>Power Off</td>
<td>Power off the virtual machine. By default, Workstation Pro powers off the virtual machine abruptly. The effect is the same as using the power button on a physical machine.</td>
</tr>
</tbody>
</table>
You can configure Workstation Pro preference settings so that virtual machines always run in the background and you are not prompted to select an action. You can also configure virtual machine option settings to control power off behavior.

**Configure Virtual Machines to Always Run in the Background**

You can configure Workstation Pro preference settings so that virtual machines always run in the background and you are not prompted to select an action when you close powered-on virtual machines.

**Procedure**

1. Select Edit > Preferences.
2. Select Workspace and select Keep VMs running after Workstation closes.
3. Click OK to save your changes.

**Pause and Unpause a Virtual Machine**

You can pause a virtual machine multiple times for a few seconds, or up to several minutes. The pause feature is useful when a virtual machine is engaged in an lengthy, processor-intensive activity that prevents you from using the host system to do a more immediate task.

**Note** You cannot pause a remote virtual machine.

**Prerequisites**

Familiarize yourself with the restrictions and limitations of the pause feature. See “Pause Feature Restrictions and Limitations,” on page 78.

**Procedure**

- To pause a virtual machine, select the virtual machine and select VM > Pause.
  
  The virtual machine display dims and a play button appears over the display. Paused virtual machines that are configured to display on more than one monitor have a play button on each monitor.

- To pause all of the powered-on virtual machines without interacting with the Workstation Pro user interface, right-click the virtual machine status icon located in the notification area on the task bar of the host computer and select Pause All Virtual Machines.

- To unpause a virtual machine, click the play button on the virtual machine display or deselect VM > Pause.

**Pause Feature Restrictions and Limitations**

The pause feature has certain restrictions and limitations.

- You cannot switch to Unity mode when a virtual machine is paused.

- When paused, a virtual machine does not send or receive network packets. If a virtual machine is paused for more than a few minutes, some network connections might be interrupted.

- If you take a snapshot when the virtual machine is paused, the virtual machine is not paused when you restore that snapshot. Similarly, if you suspend a virtual machine while it is paused, it is not paused when you resume the virtual machine.

- If you initiate soft power operations when a virtual machine is paused, those operations do not take effect until the virtual machine is unpause.

- While a virtual machine is paused, LEDs and devices remain enabled, but device connection changes do not take effect until the virtual machine is unpause.

- You cannot pause a remote virtual machine.
Suspend and Resume a Virtual Machine

Use the suspend and resume feature to save the current state of a virtual machine. When you resume the virtual machine, the applications that were running before the suspension will resume their running state with their content unchanged.

How quickly the suspend operation performs depends on the how much data changed after you started the virtual machine. The first suspend operation usually takes longer than subsequent suspend operations. When you suspend a virtual machine, Workstation Pro creates a virtual machine suspended state (.vmss or .vmem) file set in the working directory. How quickly the resume operation performs depends on how active the virtual machine is. The more active the virtual machine is, the longer it will take to resume. It also depends on whether the virtual machine suspended state (.vmss or .vmem) file set is already in the physical memory of the host system. If it is, the virtual machine will resume much faster.

After you resume a virtual machine and do more work, you cannot return to the state that the virtual machine was in when you suspended it. To return to the same state repeatedly, you must take a snapshot.

When virtual machines are in a folder, you can perform batch power operations. See “Using Folders to Manage Virtual Machines,” on page 102.

Procedure

- To select a suspend option when you suspend a virtual machine, select the virtual machine and select VM > Power.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suspend</td>
<td>(Hard option) Workstation Pro suspends the virtual machine and leaves it connected to the network.</td>
</tr>
<tr>
<td>Suspend Guest</td>
<td>(Soft option) Workstation Pro suspends the virtual machine and disconnects it from the network. VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script releases the IP address of the virtual machine. On Linux, FreeBSD, and Solaris guests, the script stops networking for the virtual machine.</td>
</tr>
</tbody>
</table>

- To suspend a virtual machine from the toolbar, select the virtual machine and click the suspend button.

  The suspend power control setting that is configured for the virtual machine determines whether Workstation Pro performs a hard or soft suspend operation. The configured behavior appears in a tooltip when you mouse over the button.

- To select a resume option when you resume a suspended virtual machine, select the virtual machine and select VM > Power.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resume</td>
<td>(Hard option) Workstation Pro resumes the virtual machine from the suspended state.</td>
</tr>
<tr>
<td>Resume Guest</td>
<td>(Soft option) Workstation Pro resumes the virtual machine from the suspended state and reconnects it to the network.</td>
</tr>
</tbody>
</table>

- To resume a virtual machine from the toolbar, select the virtual machine and click the resume button.

  The suspend power control setting that is configured for the virtual machine determines whether Workstation Pro performs a hard or soft resume operation. The configured behavior appears in a tooltip when you mouse over the button.

- To power off a suspended virtual machine, select the virtual machine and click VM > Power > Power Off.
Using the Guest ACPI S1 Sleep Feature on Windows Hosts

On Windows hosts, Workstation Pro provides experimental support for guest operating system ACPI S1 sleep. Not all guest operating systems support this feature. Common guest operating system interfaces for entering standby mode are supported.

By default, ACPI S1 sleep is implemented in Workstation Pro as suspend. You can use the Workstation Pro Resume button to wake the guest operating system.

You can implement ACPI S1 sleep as power-on suspend. The guest operating system is not fully powered down. This feature can be useful for test and development scenarios. You can wake the virtual machine through keyboard input, mouse input, or by programming the CMOS external timer.

Transferring Files and Text

You can use the drag-and-drop feature, the copy and paste feature, shared folders, and mapped drives to transfer files and text between the host system and virtual machines and between virtual machines.

- **Using the Drag-and-Drop Feature** on page 80
  
  You can use the drag-and-drop feature to move files and directories, email attachments, plain text, formatted text, and images between the host system and virtual machines.

- **Using the Copy and Paste Feature** on page 81
  
  You can cut, copy, and paste text between virtual machines and between applications running in virtual machines.

- **Using Shared Folders** on page 82
  
  You can use shared folders to share files among virtual machines and between virtual machines and the host system. The directories that you add as shared folders can be on the host system, or they can be network directories that are accessible from the host computer.

- **Mapping a Virtual Disk to the Host System** on page 88
  
  Instead of using shared folders or copying data between a virtual machine and the host system, you can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a virtual machine.

Using the Drag-and-Drop Feature

You can use the drag-and-drop feature to move files and directories, email attachments, plain text, formatted text, and images between the host system and virtual machines.

You can drag files or directories between the following locations.

- File managers, such as Windows Explorer, on the host system and virtual machines.
- A file manager to an application that supports drag-and-drop.
- Applications, such as zip file managers, which support drag-and-drop extraction of individual files.
- Different virtual machines.

When you drag a file or folder between the host and a virtual machine, Workstation Pro copies the file or folder to the location where you drop it. For example, if you drop a file on the desktop icon of a word processor, the word processor opens a copy of the original file. The original file does not include changes that you make to the copy.

Initially, the application opens a copy of the file that is stored in the temp directory. On Windows, the temp directory is specified in the %TEMP% environment variable. On Linux and Solaris, the temp directory is /tmp/VmwareDnD. Save the file in a different directory to protect changes that you make.
Drag-and-Drop Requirements and Restrictions
The drag-and-drop feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the drag-and-drop feature.
- The drag-and-drop feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- You can drag images between applications on Windows hosts and applications on Windows guests only. Dragging images is not supported for Linux hosts or guests.
- You can drag files and directories, email attachments, plain text, and formatted text between Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- Dragging email attachments is restricted to images or files smaller than 4 MB.
- Dragging plain text and formatted text (including the formatting) is restricted to amounts less than 4 MB.
- Dragging text is restricted to text in languages that can be represented by Unicode characters.
- Workstation Pro uses the PNG format to encode images that are dragged. Dragging images is restricted to images smaller than 4 MB after conversion to PNG format.

Disable the Drag-and-Drop Feature
The drag-and-drop feature is enabled by default when you create a virtual machine in Workstation Pro. To prevent dragging and dropping between a virtual machine and the host system, disable the drag-and-drop feature.

**NOTE** You cannot enable or disable the drag-and-drop feature for a shared or remote virtual machine.

**Procedure**
1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **Guest Isolation**.
3. Deselect **Enable drag and drop**.
4. Click **OK** to save your changes.

Using the Copy and Paste Feature
You can cut, copy, and paste text between virtual machines and between applications running in virtual machines.

You can also cut, copy, and paste images, plain text, formatted text, and email attachments between applications running on the host system and applications running in virtual machines.

Copy and Paste Requirements and Restrictions
The copy and paste feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the copy and paste feature.
- The copy and paste feature works with Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- The copy and paste feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- Copying and pasting email attachments is restricted to images or files smaller than 4 MB.
Copying and pasting plain text and formatted text (including the formatting) is restricted to amounts less than 4 MB.

Copying and pasting text is restricted to text in languages that can be represented by Unicode characters.

Workstation Pro uses the PNG format to encode images that are copied and pasted. Copying and pasting images is restricted to images smaller than 4 MB after conversion to PNG format.

You cannot copy and paste files between virtual machines.

**Disable the Copy and Paste Feature**

The copy and paste feature is enabled by default when you create a virtual machine in Workstation Pro. To prevent copying and pasting between a virtual machine and the host system, disable the copy and paste feature.

**NOTE** You cannot enable or disable the copy and paste feature for a shared or remote virtual machine.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **Guest Isolation**.
3. Deselect **Enable copy and paste**.
4. Click **OK** to save your changes.

**Using Shared Folders**

You can use shared folders to share files among virtual machines and between virtual machines and the host system. The directories that you add as shared folders can be on the host system, or they can be network directories that are accessible from the host computer.

**IMPORTANT** You cannot open a file in a shared folder from more than one application at a time. For example, do not open the same file in an application on the host operating system and in another application in the guest operating system. If one of the applications writes to the file, data might be corrupted.

- **Guest Operating Systems That Support Shared Folders** on page 83
  
  To use shared folders, a virtual machine must have a supported guest operating system.

- **Enable a Shared Folder for a Virtual Machine** on page 83
  
  You can enable folder sharing for a specific virtual machine. To set up a folder for sharing between virtual machines, you must configure each virtual machine to use the same directory on the host system or network share.

- **Enable Shared Folders for Virtual Machines Created By Other Users** on page 85
  
  If a shared folder is not created by the user who powers on the virtual machine, it is disabled by default. This is a security precaution.

- **View Shared Folders in a Windows Guest** on page 85
  
  In a Windows guest operating system, you can view shared folders by using desktop icons.

- **Mounting Shared Folders in a Linux Guest** on page 85
  
  After you have enabled a shared folder, you can mount one or more directories or subdirectories in the shared folder to any location in the file system in addition to the default location of /mnt/hgfs.
Change Shared Folder Properties on page 87
After you create a shared folder, you can change the folder name, the host path, and other attributes.

Change the Folders That a Virtual Machine Can Share on page 87
You can change the folders that a specific virtual machine is allowed to share.

Disable Folder Sharing for a Virtual Machine on page 87
You can disable folder sharing for a specific virtual machine.

Guest Operating Systems That Support Shared Folders
To use shared folders, a virtual machine must have a supported guest operating system. The following guest operating systems support shared folders.

- Windows Server 2003 R2
- Windows Server 2008 R2
- Windows Server 2012 R2
- Windows Vista
- Windows 7
- Windows 8
- Windows 10
- Linux with a kernel version of 2.6 or later
- Solaris x86 10
- Solaris x86 10 Update 1 and later

Enable a Shared Folder for a Virtual Machine
You can enable folder sharing for a specific virtual machine. To set up a folder for sharing between virtual machines, you must configure each virtual machine to use the same directory on the host system or network share.

**Note** You cannot enable a shared folder for a shared or remote virtual machine.

Prerequisites
- Verify that the virtual machines use a guest operating system that supports shared folders. See “Guest Operating Systems That Support Shared Folders,” on page 83.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that permission settings on the host system allow access to files in the shared folders. For example, if you are running Workstation Pro as a user named User, the virtual machine can read and write files in the shared folder only if User has permission to read and write them.

Procedure
1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **Shared Folders**.
3 Select a folder sharing option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always enabled</td>
<td>Keep folder sharing enabled, even when the virtual machine is shut down, suspended, or powered off.</td>
</tr>
<tr>
<td>Enabled until next power off or suspend</td>
<td>Enable folder sharing temporarily, until you power off, suspend, or shut down the virtual machine. If you restart the virtual machine, shared folders remain enabled. This setting is available only when the virtual machine is powered on.</td>
</tr>
</tbody>
</table>

4 (Optional) To map a drive to the Shared Folders directory, select Map as a network drive in Windows guests.

This directory contains all of the shared folders that you enable. Workstation Pro selects the drive letter.

5 Click Add to add a shared folder.

On Windows hosts, the Add Shared Folder wizard starts. On Linux hosts, the Shared Folder Properties dialog box opens.

6 Type the path on the host system to the directory to share.

If you specify a directory on a network share, such as D:\share, Workstation Pro always attempts to use that path. If the directory is later connected to the host on a different drive letter, Workstation Pro cannot locate the shared folder.

7 Specify the name of the shared folder as it should appear inside the virtual machine.

Characters that the guest operating system considers illegal in a share name appear differently when viewed inside the guest. For example, if you use an asterisk in a share name, you see %002A instead of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal value.

8 Select shared folder attributes.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable this share</td>
<td>Enable the shared folder. Deselect this option to disable a shared folder without deleting it from the virtual machine configuration.</td>
</tr>
<tr>
<td>Read-only</td>
<td>Make the shared folder read-only. When this property is selected, the virtual machine can view and copy files from the shared folder, but it cannot add, change, or remove files. Access to files in the shared folder is also governed by permission settings on the host computer.</td>
</tr>
</tbody>
</table>

9 Click Finish to add the shared folder.

The shared folder appears in the Folders list. The check box next to folder name indicates that the folder is being shared. You can deselect this check box to disable sharing for the folder.

10 Click OK to save your changes.

What to do next

Enable Shared Folders for Virtual Machines Created By Other Users

If a shared folder is not created by the user who powers on the virtual machine, it is disabled by default. This is a security precaution.

Folder sharing is also disabled by default for Workstation 5.x virtual machines, regardless of who creates the folder.

**Important** Enabling shared folders on all virtual machines can pose a security risk because a shared folder might enable existing programs inside the virtual machine to access the host file system without your knowledge.

### Procedure

1. Select **Edit > Preferences**.
2. Select **Workspace** and select **Enable all shared folders by default**.

   This setting applies to shared folders on all virtual machines that are created by other users.

### View Shared Folders in a Windows Guest

In a Windows guest operating system, you can view shared folders by using desktop icons.

**Note** If the guest operating system has VMware Tools from Workstation 4.0, shared folders appear as folders on a designated drive letter.

### Procedure

- Depending on the Windows operating system version, look for **VMware Shared Folders** in **My Network Places**, **Network Neighborhood**, or **Network**.
- If you mapped the shared folder as a network drive, open **My Computer** and look for **Shared Folders on 'vmware-host'** under **Network Drives**.
- To view a specific shared folder, go directly to the folder by using the UNC path `\\vmware-host\Shared Folders\shared_folder_name`.

### Mounting Shared Folders in a Linux Guest

After you have enabled a shared folder, you can mount one or more directories or subdirectories in the shared folder to any location in the file system in addition to the default location of `/mnt/hgfs`.

Use the `mount` command to mount all shares, one share, or a subdirectory within a share to any location in the file system.

**Table 5-2. Mount Command Syntax**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>mount -t vmhgfs .host:/ /home/user1/shares</code></td>
<td>Mounts all shares to <code>/home/user1/shares</code></td>
</tr>
<tr>
<td><code>mount -t vmhgfs .host:/foo /tmp/foo</code></td>
<td>Mounts the share named <code>foo</code> to <code>/tmp/foo</code></td>
</tr>
<tr>
<td><code>mount -t vmhgfs .host:/foo/bar /var/lib/bar</code></td>
<td>Mounts the subdirectory <code>bar</code> within the share <code>foo</code> to <code>/var/lib/bar</code></td>
</tr>
</tbody>
</table>

You can use VMware-specific options in addition to the standard `mount` syntax. For usage information for the host-guest file system options, type the command `/sbin/mount.vmhgfs -h`. 
When you install VMware Tools, an entry is made to `etc/fstab` to specify the location of shared folders. You can edit this file to change or add entries. For example, to auto-mount at startup, edit `/etc/fstab` and add the line:

```
:host:/ /mnt/hgfs vmhgfs defaults 0 0
```

The VMware Tools services script loads a driver that performs the mount. If the mount fails, a message appears regarding mounting HGFS shares.

**Note** The mount can fail if shared folders are disabled or if the share does not exist. You are not prompted to run the VMware Tools `vmware-config-tools.pl` configuration program again.

### Optimizing Read and Write Access to Shared Files on Linux

Host-guest file sharing is integrated with the guest page cache. Files in shared folders are cached for reading and can be written to asynchronously.

Files that are being actively written to from the guest do not experience read caching benefits. To improve performance, you can use the `mount` command time-to-live (`ttl`) option to specify the interval that the host-guest file system (hgfs) driver uses for validating file attributes.

For example, to validate attributes every 3 seconds instead of every 1 second, which is the default, use the following command.

```
mount -o ttl=3 -t vmhgfs .host:/sharemountpoint
```

**Note** Lengthening the interval involves some risk. If a process in the host modifies file attributes, the guest operating system might not get the modifications as quickly and the file can become corrupted.

### Using Permissions to Restrict Access to Shared Files in a Linux Guest

You can use permissions to restrict access to the files in a shared folder on a Linux guest operating system.

On a Linux host, if you create files that you want to share with a Linux guest operating system, the file permissions shown on the guest operating system are the same as the permissions on the host system. You can use the `fmask` and `dmask` commands to mask permissions bits for files and directories.

If you create files on a Windows host system that you want to share with a Linux guest operating system, read-only files are displayed as having read and execute permission for everyone and other files are shown as fully writable by everyone.

If you use a Linux guest operating system to create files for which you want to restrict permissions, use the `mount` program with the following options in the guest operating system.

- `uid`
- `gid`
- `fmask`
- `dmask`
- `ro` (read only)
- `rw` (read-write)

`rw` is the default.

If you are using a virtual machine that was created with the Windows version of Workstation Pro, or a previous release of the Linux version of Workstation Pro, you can change the owner permissions only.
Change Shared Folder Properties
After you create a shared folder, you can change the folder name, the host path, and other attributes.

Prerequisites
Create a shared folder. See “Enable a Shared Folder for a Virtual Machine,” on page 83.

Procedure
1 Select the virtual machine and select VM > Settings.
2 On the Options tab, select Shared Folders.
3 Select the shared folder in the folders list and click Properties.
4 To change the name of the shared folder as it appears inside the virtual machine, type the new name in the Name text box.
   Characters that the guest operating system considers illegal in a share name appear differently when viewed inside the guest. For example, if you use an asterisk in a share name, you see %002A instead of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal value.
5 To change the host path for the shared folder, browse to or type the new path in the Host path text box.
   If you specify a directory on a network share, such as D:\share, Workstation Pro always attempts to use that path. If the directory is later connected to the host on a different drive letter, Workstation Pro cannot locate the shared folder.
6 To change an attribute for the shared folder, select or deselect the attribute.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>Enable the shared folder. Deselect this option to disable a shared folder without deleting it from the virtual machine configuration.</td>
</tr>
<tr>
<td>Read-only</td>
<td>Make the shared folder read-only. When this property is selected, the virtual machine can view and copy files from the shared folder, but it cannot add, change, or remove files. Access to files in the shared folder is also governed by permission settings on the host computer.</td>
</tr>
</tbody>
</table>

7 Click OK to save your changes.

Change the Folders That a Virtual Machine Can Share
You can change the folders that a specific virtual machine is allowed to share.

Procedure
1 Select the virtual machine and select VM > Settings.
2 On the Options tab, select Shared Folders.
3 In the folders list, select the check boxes next to the folders to share and deselect the check boxes next to the folders to disable.
4 Click OK to save your changes.

Disable Folder Sharing for a Virtual Machine
You can disable folder sharing for a specific virtual machine.

Procedure
1 Select the virtual machine and select VM > Settings.
2 On the **Options** tab, select **Shared Folders**.
3 Select **Disabled** to disable folder sharing.
4 Click **OK** to save your changes.

### Mapping a Virtual Disk to the Host System

Instead of using shared folders or copying data between a virtual machine and the host system, you can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a virtual machine.

### Map or Mount a Virtual Disk to a Drive on the Host System

When you map a virtual disk and its associated volume to a drive on the host system, you can connect to the virtual disk without opening a virtual machine.

After you map the virtual disk to a drive on the host system, you cannot power on any virtual machine that uses the disk until you disconnect the disk from the host system.

**Note**  You cannot map a virtual hard disk for a shared or remote virtual machine.

**Important**  If you mount a virtual disk that has a snapshot and then write to the disk, you can irreparably damage a snapshot or linked clone created from the virtual machine.

### Prerequisites

- Power off all virtual machines that use the virtual disk.
- Verify that the virtual disk (.vmdk) files on the virtual disk are not compressed and do not have read-only permissions.
- Verify that the virtual disk is unencrypted. You cannot map or mount encrypted disks.

### Procedure

1 Mount the virtual disk to a drive on the host system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>Select File &gt; Map Virtual Disks.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>Select File &gt; Mount Virtual Disks.</td>
</tr>
</tbody>
</table>

2 Map or mount the virtual disk.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>In the Map or Disconnect Virtual Disks dialog box, click <strong>Map</strong>.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>In the Mount or Unmount Virtual Disks dialog box, click <strong>Mount Disk</strong>.</td>
</tr>
</tbody>
</table>

3 (Optional) You can also map a virtual disk from Windows Explorer.
   a Open Explorer and browse to the .vmdk file you want to map.
   b Right-click the .vmdk file and select **Map Virtual Disk**.

   The menu also allows you to map the first volume of the .vmdk file to a drive immediately. If you select that option, no further configurations are needed.

4 Browse to a virtual disk (.vmdk) file, select it, and click **Open**.
5 Select the volume to map or mount and select an unused drive letter on the host system.
Click OK or Mount.

The drive appears on the host system. You can read from or write to files on the mapped virtual disk on the host system.

(Optional) View the mapped or mounted drive.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>Select File &gt; Map Virtual Disks. A list of mapped drives displays.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>Select File &gt; Mount Virtual Disks. A list of mounted drives displays.</td>
</tr>
</tbody>
</table>

**Disconnect a Virtual Disk from the Host System**

To use a virtual disk from a virtual machine after it has been mapped or mounted on the host system, you must disconnect it from the host system.

**Procedure**

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select Hard Disk, click Utilities, and select Disconnect.

You can now power on any virtual machine that uses this disk.

**Add a Host Printer to a Virtual Machine**

You can print from a virtual machine to any printer available to the host computer without having to install additional drivers in the virtual machine.

The Workstation Pro printer feature uses ThinPrint technology to replicate the host system printer mapping in the virtual machine. When you enable the virtual machine printer, Workstation Pro configures a virtual serial port to communicate with the host printers.

**Note** You cannot add a printer to a shared or remote virtual machine.

**Prerequisites**

- Support for virtual printers is disabled by default. To enable virtual printer support, see "Configuring Virtual Printers on Windows Hosts," on page 245.
- The virtual machine must be powered on or off. You cannot add a printer to a virtual machine in suspended state.

**Procedure**

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select Add.
3. In the Add Hardware wizard, select Printer and Finish.

The default device setting is to connect the virtual machine printer when the virtual machine is powered on.

**What to do next**

In a Print window, when you attempt to select a printer in Windows 7 virtual machines, you might see only the default printer, even though other printers are available. To see the other printers, right-click the default printer and point to Printer properties.
Using Removable Devices in Virtual Machines

You can use removable devices such as floppy drives, DVD and CD-ROM drives, USB devices, and smart card readers in virtual machines.

Some devices cannot be used by the host system and a guest operating system, or by multiple guest operating systems, simultaneously.

For example, if the host system is using a floppy drive, you must connect the floppy drive to the virtual machine before you can use it in the virtual machine. To use the floppy drive on the host again, you must disconnect it from the virtual machine. By default, a floppy drive is not connected when a virtual machine powers on.

Use a Removable Device in a Virtual Machine

You can connect and disconnect removable devices in a virtual machine. You can also change the settings for a removable device by modifying virtual machine settings.

Prerequisites

- Power on the virtual machine.
- If you are connecting or disconnecting a USB device, familiarize yourself with the way Workstation Pro handles USB devices. See “Connecting USB Devices to Virtual Machines,” on page 90.

Procedure

- To connect a removable device, select the virtual machine, select VM > Removable Devices, select the device, and select Connect.
  
  If the device is connected to the host system through a USB hub, the virtual machine sees only the USB device, not the hub.

  A check mark appears next to the name of the device when the device is connected to the virtual machine and a device icon appears on the virtual machine taskbar.

- To change the settings for a removable device, select VM > Removable Devices, select the device, and select Settings.

- To disconnect a removable device, select the virtual machine, select VM > Removable Devices, select the device, and select Disconnect.
  
  You can also disconnect the device by clicking or right-clicking the device icon on the virtual machine taskbar. Using the taskbar icon is especially useful if you run the virtual machine in full screen mode.

Connecting USB Devices to Virtual Machines

When a virtual machine is running, its window is the active window. If you plug a USB device into the host system, the device connects to the virtual machine instead of the host by default. If a USB device connected to the host system does not connect to a virtual machine at power on, you must manually connect the device to the virtual machine.

When you connect a USB device to a virtual machine, Workstation Pro retains the connection to the affected port on the host system. You can suspend or power off the virtual machine, or unplug the device. When you plug in the device again or resume the virtual machine, Workstation Pro reconnects the device.

Workstation Pro retains the connection by writing an autoconnect entry to the virtual machine configuration (.vmx) file.
If Workstation Pro cannot reconnect to the device, for example, because you disconnected the device, the device is removed and Workstation Pro displays a message to indicate that it cannot connect to the device. You can connect to the device manually if it is still available. To manually connect a USB device to the virtual machine, select VM > Removable Devices > Device Name > Connect (Disconnect from host).

Follow the device manufacturer's procedures for unplugging the device from the host computer when you physically unplug the device, move the device from host system to a virtual machine, move the device between virtual machines, or move the device from a virtual machine to the host computer. Following these procedures is especially important for data storage devices, such as zip drives. If you move a data storage device too soon after saving a file and the operating system did not actually write the data to the disk, you can lose data.

- **Installing USB Drivers on Windows Hosts** on page 91
  When a particular USB device is connected to a virtual machine for the first time, the host detects it as a new device named VMware USB Device and installs the appropriate VMware driver.

- **Disable Automatic Connection of USB Devices** on page 91
  You can disable the autoconnect feature if you do not want USB devices to connect to a virtual machine when you power it on.

- **Mount the USB File System on a Linux Host** on page 92
  On Linux hosts, Workstation Pro uses the USB device file system to connect to USB devices. If the USB device file system is not located in /proc/bus/usb, you must mount the USB file system to that location.

- **Connect USB HIDs to a Virtual Machine** on page 92
  To connect USB human interface devices (HIDs) to a virtual machine, you must configure the virtual machine to show all USB input devices in the Removable Devices menu.

- **Install a PDA Driver and Synchronize With a Virtual Machine** on page 92
  To install a PDA driver in a virtual machine, you must synchronize the PDA with the virtual machine.

**Installing USB Drivers on Windows Hosts**

When a particular USB device is connected to a virtual machine for the first time, the host detects it as a new device named VMware USB Device and installs the appropriate VMware driver.

The Windows operating system prompts you to run the Microsoft Windows Found New Hardware wizard. Select the default action to install the software automatically. After the software is installed, the guest operating system detects the USB device and searches for a suitable driver.

**Disable Automatic Connection of USB Devices**

You can disable the autoconnect feature if you do not want USB devices to connect to a virtual machine when you power it on.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select USB Controller.
3. Deselect **Automatically connect new USB devices** to disable automatic connection of USB devices.
4. Click **OK** to save your changes.
Mount the USB File System on a Linux Host

On Linux hosts, Workstation Pro uses the USB device file system to connect to USB devices. If the USB device file system is not located in `/proc/bus/usb`, you must mount the USB file system to that location.

**Important** Do not attempt to add a USB drive device node directory, for example, `/dev/sda`, to the virtual machine as a hard disk.

**Prerequisites**
Verify that you have root access to the host system.

**Procedure**
1. As root, mount the USB file system.
   ```bash
   mount -t usbfs none /proc/bus/usb
   ```
2. Connect the USB device to the host system.

Connect USB HIDs to a Virtual Machine

To connect USB human interface devices (HIDs) to a virtual machine, you must configure the virtual machine to show all USB input devices in the `Removable Devices` menu.

By default, USB HIDs, such as USB 1.1 and 2.0 mouse and keyboard devices, do not appear in the `Removable Devices` menu in a virtual machine, even though they are plugged in to USB ports on the host system.

An HID that is connected to a virtual machine is not available to the host system.

**Note** You cannot configure a shared or remote virtual machine to show all USB input devices.

**Prerequisites**
- Power off the virtual machine.
- If you are using a KVM switch for a mouse or keyboard, disable automatic connection of USB devices.

**Procedure**
1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select USB Controller.
3. Select Show all USB input devices.
   - This option allows users to use special USB HIDs inside the virtual machine.
4. Click OK to save your changes.
5. Power on the virtual machine.
   - HID s appear in the Removable Devices menu.

Install a PDA Driver and Synchronize With a Virtual Machine

To install a PDA driver in a virtual machine, you must synchronize the PDA with the virtual machine.

**Procedure**
1. Connect the PDA to the host system and synchronize it with the host system.
   - The PDA driver should begin installing in the virtual machine.
2 Allow the virtual machine to install the PDA driver.

3 If connection warning messages appear, dismiss them.

4 If the PDA disconnects from the host system before the virtual machine can synchronize with it, synchronize the PDA with the host system again.

The total time required to load the VMware USB device driver in the host system and install the PDA driver in the virtual machine might exceed the device connection timeout value. A second synchronization attempt usually succeeds.

**Troubleshooting USB Device Control Sharing**

Only the host system or the virtual machine can have control of a particular USB device at any one time. Device control operates differently, depending on whether the host system is a Linux or a Windows computer.

When you connect a device to a virtual machine, it is disconnected from the host system or from the virtual machine that previously had control of the device. When you disconnect a device from a virtual machine, it is returned to the host system.

Under some circumstances, if a USB storage device is in use on the host system, for example, one or more files stored on the device are open on the host, an error appears in the virtual machine when you try to connect to the device. You must let the host system complete its operation or close any application connected to the device on the host system and connect to the device in the virtual machine again.

**Troubleshoot USB Device Control Issues on a Linux Host**

You have problems connecting or disconnecting USB devices on a Linux host system.

**Problem**

You are prompted to disconnect the driver on the host system when you connect a USB device to the virtual machine or disconnecting the device fails.

**Cause**

On Linux host systems, guest operating systems can use devices that are not claimed by a host operating system driver. A related issue sometimes affects devices that rely on automatic connection, such as PDAs. Occasionally, even if you successfully use autoconnection to connect the device to the virtual machine, you might experience problems with the connection to the device.

**Solution**

1 If you have problems with autoconnection, perform these steps.

   a Select the virtual machine and select **VM > Removable Devices** to disconnect and reconnect the device.

   b If the problem persists, unplug the device and plug it in again.

   c If a warning message indicates that the device is in use, disable the device in the `hotplug` configuration files in the `/etc/hotplug` directory.

      The documentation for the Linux distribution contains information on editing these configuration files.
2. If disconnection fails, either disable the driver or unload the driver manually.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable the driver</td>
<td>If the driver was automatically loaded by hotplug, disable it in the hotplug configuration files. See the documentation for your Linux distribution for information on editing these configuration files.</td>
</tr>
<tr>
<td>Unload the driver manually</td>
<td>Become root (su -) and use the rmmod command.</td>
</tr>
</tbody>
</table>

**Using Smart Cards in Virtual Machines**

Virtual machines can connect to smart card readers that interface to serial ports, parallel ports, USB ports, PCMCIA slots, and PCI slots. A virtual machine considers a smart card reader to be a type of USB device.

A smart card is a plastic card that has an embedded computer chip. Many government agencies and large enterprises use smart cards to send secure communication, digitally sign documents, and authenticate users who access their computer networks. Users plug a smart card reader into their computer and insert their smart card in the reader. They are then prompted for their PIN to log in.

You can select a smart card reader from the **Removable Devices** menu in a virtual machine. A smart card can be shared between virtual machines, or between the host system and one or more virtual machines. Sharing is enabled by default.

When you plug a smart card reader into the host system, the reader appears as two separate USB devices in Workstation Pro. This is because you can use smart cards in one of two mutually exclusive modes.

**Shared mode**

(Recommended) The smart card reader device is available as **Shared smart_card_reader_model** in the **Removable Devices** menu. In Windows XP guest operating systems, the shared reader appears as **USB Smart Card Reader** after it is connected to the virtual machine. In Windows Vista and Windows 7 guest operating systems, the generic smart card reader device name appears under the Windows Device Manager list. The smart card reader can be shared among applications on the host system and among applications in different guest operating systems.

**USB passthrough mode**

The smart card reader device is available as **smart_card_reader_model** in the **Removable Devices** menu. In USB passthrough mode, a single virtual machine directly controls the physical smart card reader. A USB passthrough smart card reader cannot be used by applications on the host system or by applications in other virtual machines. You should use USB passthrough mode only if connection in shared mode does not work well for your scenario. You might need to install the driver provided by the manufacturer to use USB passthrough mode.

You can use smart cards with Windows operating systems and most Linux distributions. VMware provides full smart card support for Windows virtual machines running on Linux hosts. Using smart cards in Linux typically requires third-party software to effectively authenticate to a domain or enable secure communications.

**Note** Although smart cards should work with common Linux browsers, email applications, and directory services, these products have not been tested or certified by VMware.
Use a Smart Card in a Virtual Machine

You can configure a virtual machine to use the smart card reader on the host system.

Prerequisites

- Verify that the virtual machine has a USB controller. A USB controller is required, regardless of whether the smart card reader is a USB device. A USB controller is added by default when you create a virtual machine.
- Connect the smart card reader to the host system.
- Start the virtual machine

Procedure

- To connect the smart card reader to the virtual machine, select the virtual machine and select VM > Removable Devices > Shared <smart_card_reader_model> > Connect.
  
  If the smart card reader is a USB device, two items appear for it in the menu. Both items use the model name of the reader, but one item name begins with Shared.
- To disconnect the smart card reader from the virtual machine, select VM > Removable Devices > Shared <smart_card_reader_model> > Disconnect.
- To remove the smart card from the virtual machine, select VM > Removable Devices > Shared <smart_card_reader_model> > Remove Smart Card.
  
  The smart card is removed from the virtual machine, but it remains connected on the host system. If the smart card is physically removed from the smart card reader, this option is disabled.
- To insert the smart card to the virtual machine, select VM > Removable Devices > Shared <smart_card_reader_model> > Insert Smart Card.
  
  If the smart card is physically inserted in the smart card reader, the smart card is also inserted in the virtual machine.

Disable Smart Card Sharing

By default, you can share a smart card between virtual machines or between the host system and one or more virtual machines. You might want to disable smart card sharing if you are using a PCMCIA smart card reader, deploying virtual machines for enterprise use and do not want to support drivers for various smart card readers, or the host system has drivers but the virtual machines do not.

The setting that controls smart card sharing is located in the Workstation Pro global configuration file.

Procedure

1. Find the global configuration file on the host system.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, Windows 8, Windows 10 hosts</td>
<td>%PROGRAMDATA%\VMware\VMware Workstation\config.ini</td>
</tr>
<tr>
<td>Linux hosts</td>
<td>/etc/vmware/config</td>
</tr>
</tbody>
</table>

2. If the global configuration file does not yet exist on the host system, select Edit > Preferences and change at least one Workstation Pro preference setting.

   Workstation Pro creates the global configuration file when you change Workstation Pro preference settings.
3 Open the global configuration file in a text editor and set the `usb.ccid.useSharedMode` property to `FALSE`. For example: `usb.ccid.useSharedMode = "FALSE"

4 Save and close the global configuration file.

5 Set permissions on the global configuration file so that other users cannot change it.

### Switch to a Virtual Smart Card Reader on a Linux Host

Because of the way smart card reader functionality is implemented on Linux hosts, you must exit Workstation Pro and restart the `pcscd` daemon on the host system before you can switch from the non-virtual smart card reader to the virtual smart card reader.

**Procedure**

1 Select the virtual machine, select **VM > Removable Devices**, select the smart card reader, and select **Disconnect**.

2 Power off the virtual machine and exit Workstation Pro.

3 Physically disconnect the smart card reader from the host system.

4 Restart the `pcscd` daemon on the host system.

5 Physically connect the smart card reader to the host system.

6 Start Workstation Pro and start the virtual machine.

7 Select the virtual machine, select **VM > Removable Devices**, select the smart card reader, and select **Connect**.

### Changing the Virtual Machine Display

You can change the way Workstation Pro displays virtual machines and virtual machine applications. You can use full screen mode to make the virtual machine display fill the screen and use multiple monitors.

You can also match the Workstation Pro console with the guest operating system display size.

- **Use Full Screen Mode** on page 97
  
  In full screen mode, the virtual machine display fills the screen and you cannot see the borders of the Workstation Pro window.

- **Use Exclusive Mode** on page 98
  
  Like full screen mode, exclusive mode causes the Workstation Pro virtual machine display to fill the screen. You might want to use exclusive mode to run graphics-intensive applications, such as games, in full screen mode.

- **Use Unity Mode** on page 98
  
  You can switch virtual machines that have Windows XP or later guest operating systems to Unity mode to display applications directly on the host system desktop.

- **Use Multiple Monitors for One Virtual Machine** on page 99
  
  If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

- **Use Multiple Monitors for Multiple Virtual Machines** on page 100
  
  If the host system has multiple monitors, you can run a different virtual machine on each monitor.

- **Fit the Workstation Pro Console to the Guest Operating System Display** on page 100
  
  You can control the size of the virtual machine display and match the Workstation Pro console with the display size of the guest operating system for an active virtual machine.
Use Full Screen Mode

In full screen mode, the virtual machine display fills the screen and you cannot see the borders of the Workstation Pro window.

You can configure the guest operating system to report battery information. This feature is useful when you run a virtual machine in full screen mode on a laptop. See “Report Battery Information in the Guest,” on page 97.

Prerequisites

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system display mode is larger than the host system display mode. If the guest operating system display mode is smaller than the host system display mode, you might not be able to enter full screen mode. If you cannot enter full screen mode, add the line mks.maxRefreshRate=1000 to the virtual machine configuration (.vmx) file.
- Power on the virtual machine.
- If you have multiple monitors, move the Workstation Pro window onto the monitor to use for full screen mode.

Procedure

- To enter full screen mode, select the virtual machine and select View > Full Screen.
- Press Ctrl+Alt+right arrow to switch to the next powered-on virtual machine and Ctrl+Alt+left arrow to switch to the previous powered-on virtual machine.
- When in full screen mode, you can also use the tabs on the full screen toolbar to switch between powered-on virtual machines.
- To hide the full screen toolbar while you are using full screen mode, click the push pin icon on the full screen toolbar and move the mouse pointer off of the toolbar.
  - The toolbar is unpinned and slides up to the top of the monitor and disappears.
- To show the full screen toolbar after it has been hidden, point to the top of the screen until the toolbar appears and click the push pin icon.
- To exit full screen mode, on the full screen toolbar select View > Full Screen, and deselect Full Screen.

Report Battery Information in the Guest

If you run a virtual machine on a laptop in full screen mode, configure the option to report battery information in the guest so that you can determine when the battery is running low.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Options tab, select Power.
3. Select Report battery information to guest.
4. Click OK to save your changes.
Use Exclusive Mode

Like full screen mode, exclusive mode causes the Workstation Pro virtual machine display to fill the screen. You might want to use exclusive mode to run graphics-intensive applications, such as games, in full screen mode.

Exclusive mode has certain advantages and limitations.

- The full screen toolbar is not engaged when you move the mouse to the top of the screen. To configure virtual machine settings, you must exit exclusive mode.
- When input is grabbed by the virtual machine, only the ungrab shortcut is respected. You can change the ungrab shortcut to reduce the chance of unintentionally pressing it.
- On a Windows host, exclusive mode does not use multiple monitors.

Prerequisites

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Power on the virtual machine.
- If you have multiple monitors, move the Workstation Pro window onto the monitor to use for exclusive mode.
- Enter full screen mode. See “Use Full Screen Mode,” on page 97.

Procedure

1. Enter full screen mode.
2. Select View > Exclusive Mode from the full screen toolbar.

What to do next

To exit exclusive mode, press Ctrl+Alt.

On a Windows or Linux host, pressing Ctrl+Alt returns you to full screen mode.

Use Unity Mode

You can switch virtual machines that have Windows XP or later guest operating systems to Unity mode to display applications directly on the host system desktop.

In Unity mode, virtual machine applications appear on the host system desktop, you can use the virtual machine Start or Applications menu from the host system, and the virtual machine console view is hidden. Items for open virtual machine applications appear on the host system taskbar in the same way as open host applications.

On host system and virtual machine applications that are displayed in Unity mode, you can use keyboard shortcuts to copy, cut, and paste images, plain text, formatted text, and email attachments between applications. You can also drag and drop and copy and paste files between the host system and the guest operating system.

If you save a file or attempt to open a file from an application in Unity mode, the file system you see is the file system inside the virtual machine. You cannot open a file from the host operating system or save a file to the host operating system.

For some guest operating systems, application windows in Unity mode can appear only on the monitor that is set as the primary display when you have multiple monitors. If the host and guest operating systems are Windows XP or later, the application windows can appear on additional monitors.
Unity mode is not available in full screen mode on Windows.

**Note** You cannot use Unity mode with a remote virtual machine.

**Prerequisites**
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system is Windows XP or later.
- Power on the virtual machine.
- If you are entering Unity mode, open applications in the virtual machine to use in Unity mode.

**Procedure**
- To enter Unity mode, select the virtual machine and select View > Unity.
  
  The console view in the Workstation Pro window is hidden, and open applications appear in application windows on the host system desktop. A check mark appears next to Unity in the View menu.
- To navigate between multiple Start or Applications menus when multiple virtual machines are in Unity mode, press the arrow keys, Tab, or Shift+Tab to cycle through the virtual machine menus and press Enter and the spacebar to select a virtual machine.
- To exit Unity mode, select View > Unity and deselect Unity.

**Use Multiple Monitors for One Virtual Machine**

If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

**Note** You do not need to use the Windows display properties settings in a Windows guest operating system to configure multiple monitors.

**Prerequisites**
- Verify that the virtual machine is a Workstation 6.x or later virtual machine.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the Windows or Linux guest operating system is supported.

**Procedure**
1. Select the virtual machine and select View > Autosize > Autofit Guest to verify that the virtual machine can resize correctly.
2. Power on the virtual machine and select View > Full Screen.
3. On the full screen toolbar, click the Cycle Multiple Monitors button.
   
   On a Windows host, you can mouse over a button on the toolbar to see its name. The guest operating system desktop extends to the additional monitor or monitors.
4. (Optional) Click the Cycle Multiple Monitors button again if the host system has more than two monitors and you want the virtual machine to use all of the monitors.

   The order in which the virtual machine uses the monitors depends on the order in which the monitors were added to the host operating system. If you continue to click the button, you return to fewer monitors.
Limitations for Multiple Monitors

The use of more than two monitors with a virtual machine has certain limitations.

- If you attempt to use more than two monitors with a virtual machine, your virtual machine must support more than two monitors for this feature to function.
- More than two monitors is supported on Windows and Linux host and guest operating systems.
- Windows XP guests support more than three monitors. However, only three monitors can be in use by a Windows XP guest at one time. If more than three monitors are connected to a Windows XP guest, use the Cycle multiple monitors button to cycle through the monitors to the configuration you want to use.

Use Multiple Monitors for Multiple Virtual Machines

If the host system has multiple monitors, you can run a different virtual machine on each monitor.

Prerequisites

Verify that the latest version of VMware Tools is installed in the guest operating system.

Procedure

1. Open a second Workstation Pro window.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a new window from Workstation Pro</td>
<td>Select File &gt; New Window. On Linux hosts, the windows operate in a single Workstation Pro process.</td>
</tr>
<tr>
<td>(Linux hosts only) Run a separate Workstation Pro process in a different X server</td>
<td>Use the <code>vmware</code> command with the <code>-W</code> flag, for example, <code>vmware -W &amp;</code>.</td>
</tr>
</tbody>
</table>

2. Start one or more virtual machines in each Workstation Pro window.

3. Drag each Workstation Pro window to the monitor on which you want to use it.
   
   If a virtual machine is running in one Workstation Pro window and you want to run that virtual machine in another Workstation Pro window, you must close the virtual machine in the first window before you attempt to open it in the other window.

4. To switch mouse and keyboard input from the virtual machine on the first monitor to the virtual machine on the second monitor, move the pointer from one screen to the other screen and click inside the second monitor.

Fit the Workstation Pro Console to the Guest Operating System Display

You can control the size of the virtual machine display and match the Workstation Pro console with the display size of the guest operating system for an active virtual machine.

The fit options are redundant if the corresponding Autofit option is active because the console and the guest operating system display are the same size.

Prerequisites

- For a Linux virtual machine, familiarize yourself with the considerations for resizing displays. See “Considerations for Resizing Displays in Linux Virtual Machines,” on page 101.
- For a Solaris virtual machine, familiarize yourself with the considerations for resizing displays. See “Considerations for Resizing Displays in Solaris Virtual Machines,” on page 101.
Procedure

To configure a display size option, select View > Autosize and select an Autofit option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autofit Guest</td>
<td>The virtual machine resizes the guest display resolution to match the size of the Workstation Pro console.</td>
</tr>
<tr>
<td>Stretch Guest</td>
<td>The virtual machine changes the guest display to fit the full screen. The guest display resolution is not changed.</td>
</tr>
<tr>
<td>Center Guest</td>
<td>The virtual machine centers the guest display in the full screen. The guest display resolution is not changed.</td>
</tr>
<tr>
<td>Autofit Window</td>
<td>The Workstation Pro console maintains the size of the virtual machine display resolution. If the guest operating system changes its resolution, the Workstation Pro console resizes to match the new resolution.</td>
</tr>
</tbody>
</table>

To configure a fit option, select View and select a fit option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit Window Now</td>
<td>The Workstation Pro console changes to match the current display size of the guest operating system.</td>
</tr>
<tr>
<td>Fit Guest Now</td>
<td>The guest operating system display size changes to match the current Workstation Pro console.</td>
</tr>
</tbody>
</table>

Considerations for Resizing Displays in Linux Virtual Machines

Certain considerations apply to resizing displays in Linux virtual machines.

- If you have virtual machines that were suspended under a version of VMware Tools earlier than version 5.5, display resizing does not work until the virtual machines are powered off and powered on again. Rebooting the guest operating system is not sufficient.
- To use the resizing options, you must update VMware Tools to the latest version in the guest operating system.
- You cannot use the Autofit Guest and Fit Guest Now options unless VMware Tools is running in the guest operating system.
- The resizing restrictions that the X11 Windows system imposes on physical host systems also apply to guest operating systems.
  - You cannot resize to a mode that is not defined. The VMware Tools configuration script can add a large number of mode lines, but you cannot resize in 1-pixel increments as you can in Windows. VMware Tools adds modelines in 100-pixel increments. This means that you cannot resize a guest larger than the largest mode defined in the X11 configuration file. If you attempt to resize larger than that mode, a black border appears and the guest operating system size stops increasing.
  - The X server always starts up in the largest defined resolution. The XDM/KDM/GDM login screen always appears at the largest size. Because Gnome and KDE allow you to specify your preferred resolution, you can reduce the guest display size after you log in.

Considerations for Resizing Displays in Solaris Virtual Machines

Certain considerations apply to resizing displays in Solaris virtual machines.

- To use the display resizing options, you must update VMware Tools to the latest version in the guest operating system.
- You cannot use the Autofit Guest and Fit Guest Now options unless VMware Tools is running in the guest operating system.
Solaris 10 guests must be running an Xorg X server and JDS/Gnome.

**Working with Nonstandard Resolutions**

A guest operating system and its applications might react unexpectedly when the Workstation Pro console size is not a standard VESA resolution.

For example, you can use **Autofit Guest** and **Fit Guest Now** to set the guest operating system screen resolution smaller than 640×480, but some installers do not run at resolutions smaller than 640×480. Programs might refuse to run. Error messages might include phrases such as **VGA Required to Install** or **You must have VGA to install**.

If the host computer screen resolution is high enough, you can enlarge the window and select **Fit Guest Now**. If the host computer screen resolution does not allow you to enlarge the Workstation Pro console sufficiently, you can manually set the guest operating system's screen resolution to 640×480 or larger.

**Using Folders to Manage Virtual Machines**

You can use folders to organize and manage multiple virtual machines in the library. When virtual machines are in a folder, you can manage them on the folder tab and perform batch power operations.

- **Add a Virtual Machine to a Folder** on page 103
  
  When you add a virtual machine to a folder, it remains an independent entity, but you can also perform batch power operations. For example you can power on, suspend, and resume each virtual machine in a folder separately, or you can power on, suspend, and resume all of the virtual machines in a folder at the same time.

- **Remove a Virtual Machine from a Folder** on page 103
  
  You can remove a virtual machine from a folder or move it to a different folder or subfolder.

- **Manage Virtual Machines in a Folder** on page 103
  
  When virtual machines are in a folder, you can manage them as a unit. For example, you can select multiple virtual machines on the folder tab and perform power operations on several virtual machines at the same time.

- **Change the Power On Delay** on page 104
  
  By default, when you power on several virtual machines in a folder, Workstation Pro delays 10 seconds before powering on the next virtual machine. The power on delay avoids overloading the CPU on the host system when you power on multiple virtual machines. You can change the default power on delay setting by modifying a Workstation Pro preference.

- **Convert a Team** on page 104
  
  If you created a team in an earlier version, you must convert the team before you can use the virtual machines in the current version of Workstation Pro.
Add a Virtual Machine to a Folder

When you add a virtual machine to a folder, it remains an independent entity, but you can also perform batch power operations. For example you can power on, suspend, and resume each virtual machine in a folder separately, or you can power on, suspend, and resume all of the virtual machines in a folder at the same time.

Procedure

1. If the folder does not already exist, create it.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a folder at the top level of the library</td>
<td>Right-click My Computer, select New Folder, and type a name for the folder. The folder appears under My Computer in the library.</td>
</tr>
<tr>
<td>Create a subfolder</td>
<td>Right-click the folder, select New Folder, and type a name for the folder. The new folder appears under the folder in the library.</td>
</tr>
</tbody>
</table>

You can create an unlimited number of folders or subfolders.

2. To add a virtual machine to a folder, select the virtual machine in the library and drag it to the folder.

The virtual machine appears under the folder in the library. You can add an unlimited number of virtual machines to a folder.

Remove a Virtual Machine from a Folder

You can remove a virtual machine from a folder or move it to a different folder or subfolder.

Procedure

- To remove a virtual machine from a folder, select the virtual machine in the library and drag it to My Computer.

  The virtual machine appears under My Computer in the library.

- To move a virtual machine to a different folder or subfolder, select the virtual machine in the library and drag it to the folder or subfolder.

  The virtual machine appears under the folder or subfolder in the library.

Manage Virtual Machines in a Folder

When virtual machines are in a folder, you can manage them as a unit. For example, you can select multiple virtual machines on the folder tab and perform power operations on several virtual machines at the same time.

When you power on several virtual machines at the same time, Workstation Pro delays 10 seconds before powering on the next virtual machine by default. Workstation Pro performs power operations on virtual machines in the order in which they appear on the folder tab.

You can change the default power on delay setting by modifying a Workstation Pro preference. See “Change the Power On Delay,” on page 104.

Procedure

- To perform a power operation on several virtual machines at the same time, use Ctrl-Click to select the virtual machines on the folder tab and select the power operation from the toolbar or from the VM menu.

  All of the virtual machines that you select must be in the same power state.
To perform a power operation on all of the virtual machines at the same time, select the folder in the library and select the power operation from the toolbar or from the VM menu. All of the virtual machines in the folder must be in the same power state.

To display thumbnails for virtual machines on the folder tab, select a thumbnail size from the drop-down menu on the folder tab. When a virtual machine is powered on, Workstation Pro updates the thumbnail in real time to show the actual content of the virtual machine. When a virtual machine is suspended, the thumbnail shows a screenshot of the virtual machine at the time that it was suspended.

To display virtual machine names on the folder tab, select Details from the drop-down menu on the folder tab.

To open the tab for a virtual machine, double-click the virtual machine on the folder tab.

**Change the Power On Delay**

By default, when you power on several virtual machines in a folder, Workstation Pro delays 10 seconds before powering on the next virtual machine. The power on delay avoids overloading the CPU on the host system when you power on multiple virtual machines. You can change the default power on delay setting by modifying a Workstation Pro preference.

**Procedure**

1. Select Edit > Preferences and select Workspace.
2. Select the number of seconds for the delay from the Seconds between powering on multiple VMs drop-down menu.
3. Click OK to save your changes.

**Convert a Team**

If you created a team in an earlier version, you must convert the team before you can use the virtual machines in the current version of Workstation Pro.

**Procedure**

1. Open the team in Workstation Pro or browse to the location of the virtual machine team configuration (.vmtm) file and drag it to the library. A dialog box appears that prompts you to convert the team.
2. Click Convert Team to convert the team.

After the team is converted, the .vmtm file is deleted and the virtual machines are added to a new folder in the library.

After you convert a team, the virtual machines keep their packet loss and bandwidth settings. LAN segment information appears in the network adapter settings for each virtual machine, where you can modify it.
Taking Snapshots of Virtual Machines

Taking a snapshot of a virtual machine saves its current state and enables you to return to the same state repeatedly. When you take a snapshot, Workstation Pro captures the entire state of the virtual machine. You can use the snapshot manager to review and act on the snapshots for an active virtual machine.

- **Using Snapshots to Preserve Virtual Machine States** on page 106
  A snapshot includes the contents of the virtual machine memory, virtual machine settings, and the state of all the virtual disks. When you revert to a snapshot, you return the memory, settings, and virtual disks of the virtual machine to the state they were in when you took the snapshot.

- **Using the Snapshot Manager** on page 106
  You can review all snapshots for a virtual machine and act on them directly in the snapshot manager.

- **Take a Snapshot of a Virtual Machine** on page 107
  When you take a snapshot, you preserve the state of a virtual machine at a specific moment in time and the virtual machine continues to run. Taking a snapshot enables you to return to the same state repeatedly. You can take a snapshot while a virtual machine is powered on, powered off, or suspended.

- **Revert to a Snapshot** on page 108
  You can restore a virtual machine to a previous state by reverting to a snapshot.

- **Take or Revert to a Snapshot at Power Off** on page 108
  You can configure a virtual machine to revert to a snapshot or take a new snapshot when you power off the virtual machine. This feature is useful if you need to discard changes when a virtual machine is powered off.

- **Enable AutoProtect Snapshots** on page 108
  The AutoProtect feature preserves the state of a virtual machine by taking snapshots at regular intervals that you specify. This process is in addition to manual snapshots, which you can take at any time.

- **Enable Background Snapshots** on page 109
  When you enable background snapshots, you can continue working while Workstation Pro preserves the state of a virtual machine. A progress indicator for the background snapshot appears in a corner of the Workstation Pro window.

- **Exclude a Virtual Disk from Snapshots** on page 109
  You can configure snapshots so that Workstation Pro preserves states only for certain virtual disks.

- **Delete a Snapshot** on page 110
  When you delete a snapshot, you delete the state of the virtual machine that you preserved and you cannot return to that state again. Deleting a snapshot does not affect the current state of the virtual machine.

- **Troubleshooting Snapshot Problems** on page 110
  You can use a variety of procedures for diagnosing and fixing problems with snapshots.
Using Snapshots to Preserve Virtual Machine States

A snapshot includes the contents of the virtual machine memory, virtual machine settings, and the state of all the virtual disks. When you revert to a snapshot, you return the memory, settings, and virtual disks of the virtual machine to the state they were in when you took the snapshot.

You might want to take snapshots in a linear process if you plan to make changes in a virtual machine. For example, you can take a snapshot, continue to use the virtual machine from that point, take another snapshot at a later point, and so on. You can revert to the snapshot of a previous known working state of the project if the changes do not work as expected.

For local virtual machines, you can take more than 100 snapshots for each linear process. For shared and remote virtual machines, you can take a maximum of 31 snapshots for each linear process.

If you are testing software, you might want to save multiple snapshots as branches from a single baseline in a process tree. For example, you can take a snapshot before installing different versions of an application to make sure that each installation begins from an identical baseline.

Figure 5-1. Snapshots as Restoration Points in a Process Tree

Multiple snapshots have a parent-child relationship. The parent snapshot of a virtual machine is the snapshot on which the current state is based. After you take a snapshot, that stored state is the parent snapshot of the virtual machine. If you revert to an earlier snapshot, the earlier snapshot becomes the parent snapshot of the virtual machine.

In a linear process, each snapshot has one parent and one child, except for the last snapshot, which has no children. In a process tree, each snapshot has one parent, one snapshot can have more than one child, and many snapshots have no children.

Using the Snapshot Manager

You can review all snapshots for a virtual machine and act on them directly in the snapshot manager.

You must use the snapshot manager to perform the following tasks.

- Show AutoProtect snapshots in the Snapshot menu.
- Prevent an AutoProtect snapshot from being deleted.
Rename a snapshot or change its description.

Delete a snapshot.

All other snapshot actions are available as menu items in the Snapshot menu under the VM menu.

When you open the snapshot manager for a virtual machine, the snapshot tree appears. The snapshot tree shows all of the snapshots for the virtual machine and the relationships between the snapshots.

The You Are Here icon in the snapshot tree shows the current state of the virtual machine. The other icons that appear in the snapshot tree represent AutoProtect snapshots, snapshots of powered-on virtual machines, snapshots of powered-off virtual machines, and snapshots that are used to create linked clones.

The snapshot manager is available as a menu item in the Snapshot menu under the VM menu.

Take a Snapshot of a Virtual Machine

When you take a snapshot, you preserve the state of a virtual machine at a specific moment in time and the virtual machine continues to run. Taking a snapshot enables you to return to the same state repeatedly. You can take a snapshot while a virtual machine is powered on, powered off, or suspended.

Avoid taking snapshots when applications in the virtual machine are communicating with other computers, especially in production environments. For example, if you take a snapshot while the virtual machine is downloading a file from a server on the network, the virtual machine continues downloading the file after you take the snapshot. If you revert to the snapshot, communications between the virtual machine and the server are confused and the file transfer fails.

**Note**  Workstation 4 virtual machines do not support multiple snapshots. You must upgrade the virtual machine to Workstation 7.x or later to take multiple snapshots.

Prerequisites

- Verify that the virtual is not configured to use a physical disk. You cannot take a snapshot of a virtual machine that uses a physical disk.
- To have the virtual machine revert to suspend, power on, or power off when you start it, be sure it is in that state before you take the snapshot. When you revert to a snapshot, you return the memory, settings, and virtual disks of the virtual machine to the state they were in when you took the snapshot.
- Complete any suspend operations.
- Verify that the virtual machine is not communicating with another computer.
- For better performance, defragment the guest operating system drives.
- If the virtual machine has multiple disks in different disk modes, power off the virtual machine. For example, if a configuration requires you to use an independent disk, you must power off the virtual machine before you take a snapshot.
- If the virtual machine was created with Workstation 4, delete any existing snapshots or upgrade the virtual machine to Workstation 5.x or later.

Procedure

1. Select the virtual machine and select VM > Snapshot > Take Snapshot.
2. Type a unique name for the snapshot.
3. (Optional) Type a description for the snapshot.
   - The description is useful for recording notes about the virtual machine state captured in the snapshot.
4. Click OK to take the snapshot.
Revert to a Snapshot
You can restore a virtual machine to a previous state by reverting to a snapshot.

If you take a snapshot of a virtual machine and add any kind of disk, reverting to the snapshot removes the disk from the virtual machine. If associated disk (.vmdk) files are not used by another snapshot, the disk files are deleted.

**IMPORTANT** If you add an independent disk to a virtual machine and take a snapshot, reverting to the snapshot does not affect the state of the independent disk.

**Procedure**
- To revert to the parent snapshot, select the virtual machine and select **VM > Snapshot > Revert to Snapshot**.
- To revert to any snapshot, select the virtual machine, select **VM > Snapshot**, select the snapshot, and click **Go To**.

Take or Revert to a Snapshot at Power Off
You can configure a virtual machine to revert to a snapshot or take a new snapshot when you power off the virtual machine. This feature is useful if you need to discard changes when a virtual machine is powered off.

**Procedure**
1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **Snapshots**.
3. Select a power off option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Just power off</td>
<td>Powers off the virtual machine without making any changes to snapshots.</td>
</tr>
<tr>
<td>Revert to snapshot</td>
<td>Reverts to the parent snapshot of the current state of the virtual machine.</td>
</tr>
<tr>
<td>Ask me</td>
<td>Prompts you to power off, revert, or take a snapshot when the virtual machine is powered off.</td>
</tr>
</tbody>
</table>

4. Click **OK** to save your changes.

Enable AutoProtect Snapshots
The AutoProtect feature preserves the state of a virtual machine by taking snapshots at regular intervals that you specify. This process is in addition to manual snapshots, which you can take at any time.

When AutoProtect snapshots are enabled for a virtual machine, Workstation Pro shows an estimate of the minimum amount of disk space taken by AutoProtect snapshots on the Virtual Machine Settings window. This minimum is affected by the memory settings for the virtual machine. The more virtual machine memory a virtual machine has, the more disk space is available for AutoProtect snapshots.

The AutoProtect feature has certain restrictions.
- Because AutoProtect takes snapshots only while a virtual machine is powered on, AutoProtect snapshots cannot be cloned. You can clone a virtual machine only if it is powered off.
- AutoProtect snapshots are not taken in Workstation Player, even if AutoProtect is enabled for the virtual machine in Workstation Pro.
- You cannot configure the AutoProtect feature for a shared or remote virtual machine.
Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **AutoProtect** and select **Enable AutoProtect**.
3. Select the interval between snapshots.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Half-Hourly</td>
<td>Snapshots are taken every half hour.</td>
</tr>
<tr>
<td>Hourly</td>
<td>Snapshots are taken every hour.</td>
</tr>
<tr>
<td>Daily</td>
<td>Snapshots are taken daily.</td>
</tr>
</tbody>
</table>

The interval is measured only when the virtual machine is powered on. For example, if you set AutoProtect to take snapshots hourly and then power off the virtual machine five minutes later, the next AutoProtect snapshot takes place 55 minutes after you power on the virtual machine again, regardless of the length of time the virtual machine was powered off.

Workstation Pro saves only one snapshot per tier, even if a snapshot matches more than one tier.

4. Select the maximum number of AutoProtect snapshots to retain.

After the maximum number of AutoProtect snapshots is reached, Workstation Pro deletes the oldest AutoProtect snapshot each time a new AutoProtect snapshot is taken. This setting does not affect the number of manual snapshots that you can take and keep.

5. Select **OK** to save your changes.

Enable Background Snapshots

When you enable background snapshots, you can continue working while Workstation Pro preserves the state of a virtual machine. A progress indicator for the background snapshot appears in a corner of the Workstation Pro window.

**IMPORTANT** Enabling background snapshots for a host with slow hard disks can adversely affect performance. If you experience significant performance problems when taking or restoring snapshots, disable background snapshots.

Prerequisites

On a Linux host, run Workstation Pro as the root user. Only root users are allowed to change background snapshot settings.

Procedure

1. Select **Edit > Preferences**.
2. On the **Priority** tab, select **Take snapshots in the background**.
3. Click **OK** to save your changes.
4. Restart the virtual machines.

Virtual machines must be powered off and then powered on, rather than restarted, for background snapshot changes to take effect.

Exclude a Virtual Disk from Snapshots

You can configure snapshots so that Workstation Pro preserves states only for certain virtual disks.

In certain configurations, you might want to revert some disks to a snapshot while other disks retain all changes. For example, you might want a snapshot to preserve a disk with the operating system and applications, but always keep the changes to a disk with documents.
Prerequisites

- Power off the virtual machine.
- Delete existing snapshots.

Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select the drive to exclude and click **Advanced**.
3. Select **Independent** and select the disk mode.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Persistent</strong></td>
<td>Changes are immediately and permanently written to the disk. Disks in persistent mode behave like conventional disks on a physical computer.</td>
</tr>
<tr>
<td><strong>Nonpersistent</strong></td>
<td>Changes to the disk are discarded when you power off or restore a snapshot. In nonpersistent mode, a virtual disk is in the same state every time you restart the virtual machine. Changes to the disk are written to and read from a redo log file that is deleted when you power off or reset the virtual machine.</td>
</tr>
</tbody>
</table>

Delete a Snapshot

When you delete a snapshot, you delete the state of the virtual machine that you preserved and you can never return to that state again. Deleting a snapshot does not affect the current state of the virtual machine.

If a snapshot is used to create a clone, the snapshot becomes locked. If you delete a locked snapshot, the clones created from the snapshot no longer operate.

You cannot delete a snapshot if the associated virtual machine is designated as a template for cloning.

Procedure

1. Select the virtual machine and select **VM > Snapshot > Snapshot Manager**.
2. If you are deleting an AutoProtect snapshot, select **Show AutoProtect snapshots**.
3. Select the snapshot.
4. Select an option to delete the snapshot.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Delete a single snapshot</strong></td>
<td>Click Delete.</td>
</tr>
<tr>
<td><strong>Delete the snapshot and all of its children</strong></td>
<td>Right-click and select <strong>Delete Snapshot and Children</strong>.</td>
</tr>
<tr>
<td><strong>Delete all snapshots</strong></td>
<td>Right-click, select <strong>Select All</strong>, and click <strong>Delete</strong>.</td>
</tr>
</tbody>
</table>

5. Click **Close** to close the snapshot manager.

Troubleshooting Snapshot Problems

You can use a variety of procedures for diagnosing and fixing problems with snapshots.

Guest Operating System Has Startup Problems

The guest operating system experiences problems during startup.

Problem

The guest operating system does not start up properly.
Cause
Keeping more than 99 snapshots for each branch in a process tree can cause startup problems.

Solution
Delete some snapshots or create a full clone of the virtual machine.

Take Snapshot Option Is Disabled
The Snapshot Manager Take Snapshot option is disabled.

Problem
You cannot select the Take Snapshot option in the Snapshot Manager.

Cause
The virtual machine might have multiple disks in different disk modes.

Solution
If your configuration requires an independent disk, you must power off the virtual machine before you take a snapshot.

Performance Is Slow When You Take a Snapshot
Significant performance problems occur when you take or restore snapshots.

Problem
Performance is slow when you take or restore snapshots.

Cause
The host operating system has a slow hard disk.

Solution
Upgrade the hard disk or disable background snapshots to improve performance. See “Enable Background Snapshots,” on page 109 for information on background snapshots.

Install New Software in a Virtual Machine
Installing new software in a virtual machine is similar to installing new software on a physical computer. Only a few additional steps are required.

Prerequisites
- Verify that VMware Tools is installed in the guest operating system. Installing VMware Tools before installing the software minimizes the likelihood that you will have to reactivate the software if the virtual machine configuration changes.
- Verify that the virtual machine has access to the CD-ROM drive, ISO image file, or floppy drive where the installation software is located.

Procedure
1. Select the virtual machine and select VM > Settings.
2 On the Hardware tab, select Memory, set the final memory size for the virtual machine, and click OK. Some applications use a product activation feature that creates a key based on the virtual hardware in the virtual machine where it is installed. Changes in the configuration of the virtual machine might require you to reactivate the software. Setting the memory size minimizes the number of significant changes.

3 Install the new software according to the manufacturer’s instructions.

Disable Acceleration if a Program Does Not Run

When you install or run software inside a virtual machine, Workstation Pro might appear to stop responding. This problem typically occurs early in the program’s execution. In many cases, you can get past the problem by temporarily disabling acceleration in the virtual machine.

Procedure

1 Select the virtual machine and select VM > Settings.
2 On the Hardware tab, select Processors.
3 Select Disable acceleration for binary translation to disable acceleration.
4 Click OK to save your changes.

What to do next

After you pass the point where the program encountered problems, re-enable acceleration. Because disabling acceleration slows down virtual machine performance, you should use it only for getting past the problem with running the program.

Take a Screenshot of a Virtual Machine

You can take a screenshot of a virtual machine and save it to the clipboard, to a file, or to both a file and the clipboard.

When you take a screenshot of a virtual machine, the image is saved as a portable network graphics (.png) file by default. On Windows hosts, you can also save the screenshot as a bitmap (.bmp) file.

On Linux hosts, saving a screenshot to the clipboard is supported only on systems running Gnome 2.12 or later.

Procedure

1 Select Edit > Preferences.
2 Select Workspace and select a save screenshots option.

You can select both options to save screenshots to both a file and the clipboard.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clipboard</td>
<td>Save the screenshot to the clipboard.</td>
</tr>
<tr>
<td>File</td>
<td>Save screenshots to a file. You can select:</td>
</tr>
<tr>
<td></td>
<td>- Always ask for location</td>
</tr>
<tr>
<td></td>
<td>- Save to Desktop</td>
</tr>
<tr>
<td></td>
<td>- Browse for custom location</td>
</tr>
</tbody>
</table>

By default, Workstation Pro saves screenshots to .png files on the Desktop of the host computer. If you save the file to the desktop, the filename is generated from the virtual machine name and the time at which the screenshot is taken.

To save screenshots to .bmp files on Windows hosts, select Always ask for location and specify the file type when you save the screenshot.
3  Click OK to save your changes.
4  To take the screenshot, select the virtual machine, select VM > Capture Screen.

Delete a Virtual Machine

You can delete a virtual machine and all of its files from the host file system.

**Important**  Do not delete a virtual machine if it was used to make a linked clone and you want to continue to use the linked clone. A linked clone stops working if it cannot find the virtual disk files for the parent virtual machine.

**Prerequisites**

Power off the virtual machine.

**Procedure**

- Select the virtual machine and select VM > Manage > Delete from Disk.
You can configure virtual machine power, display, video, and sound card settings, encrypt a virtual machine to secure it from unauthorized use, and restrict the Workstation Pro user interface to limit virtual machine operations.

You can also move a virtual machine to another host system or to a different location on the same host system, configure a virtual machine as a VNC server, change the hardware compatibility of a virtual machine, and export a virtual machine to Open Virtualization Format (OVF).

This chapter includes the following topics:

- “Configure Power Options and Power Control Settings,” on page 115
- “Set Workstation Pro Display Preferences,” on page 117
- “Configure Display Settings for a Virtual Machine,” on page 118
- “Set Preferences for Unity Mode,” on page 121
- “Setting Screen Color Depth,” on page 121
- “Using Advanced Linux Sound Architecture,” on page 122
- “Encrypting and Restricting Virtual Machines,” on page 123
- “Moving Virtual Machines,” on page 127
- “Configure a Virtual Machine as a VNC Server,” on page 132
- “Change the Hardware Compatibility of a Virtual Machine,” on page 135
- “Clean Up a Virtual Hard Disk on Windows Hosts,” on page 137
- “Export a Virtual Machine to OVF Format,” on page 137
- “Writing and Debugging Applications That Run In Virtual Machines,” on page 138

Configure Power Options and Power Control Settings

You can configure how a virtual machine behaves when it is powered on, powered off, and closed. You can also configure the behavior of the power controls and specify which power options appear in the context menu when you right-click the virtual machine in the library.

You can configure a soft or hard setting for each power control. A soft setting sends a request to the guest operating system, which the guest operating system can ignore or, in the case of a deadlocked guest, it might not be able to handle. A guest operating system cannot ignore a hard power control. Hard power control settings are configured by default.
Power control settings affect the behavior of the stop, suspend, start, and reset buttons. The behavior you select for a power control appears in a tooltip when you mouse over the button. Power control settings also determine which power options appear in the context menu. For example, if you select the hard setting for the start control, Power On appears in the context menu when you right-click the virtual machine in the library. If you select the soft setting, Start Up Guest appears instead.

Not all guest operating systems respond to a shutdown or restart signal. If the guest operating system does not respond to the signal, shut down or restart from within the guest operating system.

You can pass X toolkit options when you power on a virtual machine for a Linux guest operating system. See Chapter 16, “Using the vmware Command,” on page 285 for more information.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Options tab, select Power.
3. Select a power option.

**Note** You cannot configure these options for a shared or remote virtual machine.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter full screen mode after powering on</td>
<td>The virtual machine window enters full screen mode after it is powered on.</td>
</tr>
<tr>
<td>Close after powering off or suspending</td>
<td>The virtual machine tab closes after it is powered off or suspended.</td>
</tr>
<tr>
<td>Report battery information to guest</td>
<td>Battery information is reported to the guest operating system. If you run the virtual machine on a laptop in full screen mode, this option enables you to determine when the battery is running low. This option is available only for Workstation 6.x and later virtual machines.</td>
</tr>
</tbody>
</table>

4. Select a setting for the power off control.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Off</td>
<td>(Hard option) Workstation Pro powers off the virtual machine abruptly with no consideration for work in progress.</td>
</tr>
<tr>
<td>Shut Down Guest</td>
<td>(Soft option) Workstation Pro sends a shut down signal to the guest operating system. An operating system that recognizes the signal shuts down gracefully. Not all guest operating systems respond to a shutdown signal from Workstation Pro. If the guest operating system does not respond to the signal, shut down from the guest operating system as you would a physical machine.</td>
</tr>
</tbody>
</table>

5. Select a setting for the suspend control.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suspend</td>
<td>(Hard option) Workstation Pro suspends the virtual machine and leaves it connected to the network.</td>
</tr>
<tr>
<td>Suspend Guest</td>
<td>(Soft option) Workstation Pro suspends the virtual machine and disconnects it from the network. VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script releases the IP address of the virtual machine. On Linux, FreeBSD, and Solaris guests, the script stops networking for the virtual machine.</td>
</tr>
</tbody>
</table>
6  Select a setting for the start control.

**Note** You cannot configure start control settings for a shared or remote virtual machine.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power On</td>
<td>(Hard option) Workstation Pro starts the virtual machine.</td>
</tr>
<tr>
<td>Start Up Guest</td>
<td>(Soft option) Workstation Pro starts the virtual machine and VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script renews the IP address of the virtual machine. On a Linux, FreeBSD, or Solaris guest, the script starts networking for the virtual machine.</td>
</tr>
</tbody>
</table>

7  Select a setting for the reset control.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reset</td>
<td>(Hard option) Workstation Pro resets the virtual machine abruptly with no consideration for work in progress.</td>
</tr>
<tr>
<td>Restart Guest</td>
<td>(Soft option) Workstation Pro shuts down and restarts the guest operating system gracefully. VMware Tools runs scripts before the virtual machine shuts down and when the virtual machine starts up.</td>
</tr>
</tbody>
</table>

8  Click **OK** to save your changes.

### Set Workstation Pro Display Preferences

You can configure Workstation Pro display preferences to control how the display settings of all virtual machines adjust to fit the Workstation Pro window. These adjustments occur when you resize the Workstation Pro window or when you change the display settings in the guest operating system.

**Prerequisites**

Verify that the latest version of VMware Tools is installed in all guest operating systems.

**Procedure**

1  Select **Edit > Preferences** and select **Display**.

   If you are using Windows 8.1 (Update 2) or Windows 10, Workstation Pro detects the DPI on each monitor and scales the virtual machine to match the DPI on the host.

2  Configure the Autofit options.

   You can select one option, both options, or no options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autofit window</td>
<td>Resize the application window to match the virtual machine display settings when the virtual machine display settings are changed.</td>
</tr>
<tr>
<td>Autofit guest</td>
<td>Change the virtual machine settings to match the application window when the application window is resized.</td>
</tr>
</tbody>
</table>
3 Select a full screen option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autofit guest (change guest resolution)</td>
<td>Virtual machine resolution settings change to match the display settings of</td>
</tr>
<tr>
<td></td>
<td>the host system when you are in full screen mode.</td>
</tr>
<tr>
<td>Stretch guest (no resolution change)</td>
<td>Virtual machine resolution settings are retained, but the display still</td>
</tr>
<tr>
<td></td>
<td>changes to fill the full screen. Select this setting if you need to retain</td>
</tr>
<tr>
<td></td>
<td>low-resolution settings, for example, when playing older computer games that</td>
</tr>
<tr>
<td></td>
<td>run only at low resolutions.</td>
</tr>
<tr>
<td>Center guest (no resolution change)</td>
<td>The host system and virtual machines retain their own display settings</td>
</tr>
<tr>
<td></td>
<td>when you are in full screen mode.</td>
</tr>
</tbody>
</table>

4 Select menu and toolbar options.

You can select one or more options, or no options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a single button for power controls</td>
<td>(Windows hosts only) When this setting is selected, the start, stop,</td>
</tr>
<tr>
<td></td>
<td>suspend, and reset power controls appear on the toolbar as a single button</td>
</tr>
<tr>
<td></td>
<td>with a drop-down menu. When this setting is deselected, each power control</td>
</tr>
<tr>
<td></td>
<td>has a separate button on the toolbar.</td>
</tr>
<tr>
<td>Combine toolbar with menu bar in windowed</td>
<td>Show the Workstation Pro menus and toolbar on a single bar when Workstation</td>
</tr>
<tr>
<td>mode</td>
<td>Pro is in windowed mode.</td>
</tr>
<tr>
<td>Combine tabs with toolbar in full screen</td>
<td>Show the tabs and toolbar in a single bar when Workstation Pro is in full</td>
</tr>
<tr>
<td></td>
<td>screen mode.</td>
</tr>
<tr>
<td>Show toolbar edge when unpinned in full</td>
<td>Show the edge of the full screen toolbar. When this setting is deselected,</td>
</tr>
<tr>
<td>screen</td>
<td>the edge of the full screen toolbar is not visible. The full screen toolbar</td>
</tr>
<tr>
<td></td>
<td>appears for a few seconds when you place your cursor near the top of the</td>
</tr>
<tr>
<td></td>
<td>screen.</td>
</tr>
</tbody>
</table>

5 Click OK to save your changes.

## Configure Display Settings for a Virtual Machine

You can specify monitor resolution settings, configure multiple monitors, and select accelerated graphics capabilities for a virtual machine. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

For Windows guests, to use DirectX 9 accelerated graphics, the guest operating system must be Windows XP or later. To use DirectX 10 accelerated graphics, the guest operating system must be Windows Vista or later.

### Prerequisites

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system in the virtual machine is Windows XP or higher, or Linux.
- If you plan to use DirectX 9 or DirectX 10 accelerated graphics, prepare the host system. See “Prepare the Host System to Use 3D Accelerated Graphics,” on page 119.
- If you are using Windows 8.1 (Update 2) or Windows 10, Workstation Pro detects the DPI on each monitor and scales the virtual machine to match the DPI on the host.

### Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select Display.
3 (Optional) To run applications that use DirectX 9 or DirectX 10 accelerated graphics, select Accelerate 3D graphics.

4 Specify whether host settings determine the number of monitors.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use host setting for monitors</td>
<td>When you select this setting, the SVGA driver uses two monitors, a maximum bounding box width of 3840, and a maximum bounding box height of 1920. The virtual machine is configured to have a minimum of two 1920x1200 monitors, in a side-by-side topology, in both normal and rotated orientations. If the host system has more than two monitors, the virtual machine uses the number of monitors on the host system instead. If the host system's bounding box is wider or taller than the defaults, the virtual machine uses the larger size. You should select this setting in most cases.</td>
</tr>
<tr>
<td>Specify monitor settings</td>
<td>Set the number of monitors that the virtual machine will see, regardless of the number of monitors on the host system. This setting is useful if you use a multimonitor host system and you need to test in a virtual machine that has only one monitor. It is also useful if you are developing a multimonitor application in a virtual machine and the host system has only one monitor. After you power on the virtual machine, the guest operating system sees the number of monitors that you specified. Select a resolution from the list or type a setting that has the format width x height, where width and height are the number of pixels. <strong>Note</strong> You cannot configure the resolution setting for a remote virtual machine.</td>
</tr>
</tbody>
</table>

5 (Optional) Select the maximum amount of guest memory that can be used for graphics memory using the drop down menu. The default value of video memory varies by guest OS.

<table>
<thead>
<tr>
<th>Guest OS</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7 and later</td>
<td>1 GB</td>
</tr>
<tr>
<td>Windows XP and earlier</td>
<td>512 MB</td>
</tr>
<tr>
<td>Linux</td>
<td>768 MB</td>
</tr>
</tbody>
</table>

**Note** If you manually edited the .vmx file to change the memory size for the virtual machine, the value you entered in the .vmx file is displayed, labeled *Custom*.

6 To enable display scaling for the virtual machine, select the **Automatically adjust user interface size in the virtual machine** check box.

7 Click **OK** to save your changes.

**Prepare the Host System to Use 3D Accelerated Graphics**

You must perform certain preparation tasks on the Windows or Linux host system to use 3D accelerated graphics in a virtual machine.

**Prerequisites**

- On a Windows host, verify that the host has a video card that supports DirectX 9 or DirectX 10 and the latest DirectX Runtime required for the DirectX version being used.
- On a Linux host, verify that the host has a video card that supports accelerated OpenGL 2.0 if you are using DirectX 9, or OpenGL 3.3 if you are using DirectX 10.

The VMware guest operating system OpenGL driver for Windows and Linux supports the OpenGL 3.3 core profile only. The OpenGL3.3 compatibility profile is not supported.
Procedure

1. Upgrade the video drivers on the host system to the latest versions.
   ATI Graphics drivers are available from the AMD Web site. NVIDIA drivers are available from the NVIDIA Web site.

2. If you have a Windows host system, move the **Hardware Acceleration** slider to the **Full** position.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows 8, and</td>
<td>Right-click the desktop and select <strong>Personalize &gt; Screen resolution &gt;</strong></td>
</tr>
<tr>
<td>Windows 10</td>
<td><strong>Advanced Settings &gt; Troubleshoot &gt; Change settings.</strong></td>
</tr>
</tbody>
</table>

3. If you have a Linux host system, run commands to test the host for compatibility.
   a. Verify that direct rendering is enabled.
      
      ```bash
      glxinfo | grep direct
      ```
   b. Verify that 3D applications work.
      
      ```bash
      glxgears
      ```

Prepare a Virtual Machine to Use Accelerated 3D Graphics

You must perform certain preliminary tasks to use accelerated 3D graphics on a virtual machine. The accelerated 3D graphics feature is enabled by default on Workstation 6.x and later virtual machines.

**Prerequisites**

- Prepare the host system to use accelerated 3D graphics. [See “Prepare the Host System to Use 3D Accelerated Graphics,” on page 119.](#)
- If using DirectX 9, verify that the guest operating system is Windows XP or later. DirectX 9 is supported on virtual machines running hardware version 11 or earlier.
- If using DirectX 10, verify that the guest operating system is Windows 7 or later. DirectX 10 is supported on virtual machines running hardware version 12 or later.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Power off the virtual machine. The virtual machine must not be suspended.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select **Display**.
3. Select **Accelerate 3D graphics**.
4. Configure the virtual machine to use only one monitor.
5. Click **OK** to save your changes.
6. Power on the virtual machine and install the required DirectX EndRuntime version.
   - This download is available from the Microsoft Download Center.
7. Install and run your 3D applications.
Set Preferences for Unity Mode

You can set preferences for Unity mode to control whether that the virtual machine Start or Applications menu is available from the host system desktop. You can also select the border color that appears around applications that run in Unity mode when they appear on the host system desktop.

When you use the virtual machine Start or Applications menu from the host system desktop, you can start applications in the virtual machine that are not open in Unity mode. If you do not enable this feature, you must exit Unity mode to display the virtual machine Start or Applications menu in the console view.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Options, select Unity.
3. Select a Unity window decoration option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show borders</td>
<td>Set a window border that identifies the application as belonging to the virtual machine rather than to the host computer.</td>
</tr>
<tr>
<td>Show badges</td>
<td>Display a logo in the title bar.</td>
</tr>
<tr>
<td>Use a custom color in window borders</td>
<td>Use a custom color in window borders to help distinguish between the application windows that belong to various virtual machines. For example, you can set the applications for one virtual machine to have a blue border and set the applications for another virtual machine to have a yellow border. On Windows hosts, click Choose color to use the color chooser.</td>
</tr>
</tbody>
</table>

4. To control whether the virtual machine Start or Application menu available on the host system desktop, select or deselect Enable applications menu.
5. Click OK to save your changes.
6. (Optional) To minimize the Workstation Pro window when you enter Unity mode, edit the Workstation Pro Unity preference setting.
   Workstation Pro preference settings apply to all virtual machines.
   a. Select Edit > Preferences and select Unity.
   b. Select Minimize Workstation when entering Unity.
   c. Click OK to save your changes.

Setting Screen Color Depth

The number of screen colors available in the guest operating system depends on the screen color setting of the host operating system.

Virtual machines support the following screen colors.

- 16-color (VGA) mode
- 8-bit pseudocolor
- 16 bits per pixel (16 significant bits per pixel)
- 32 bits per pixel (24 significant bits per pixel)

If the host operating system is in 15-bit color mode, the guest operating system color setting controls offer 15-bit mode in place of 16-bit mode. If the host operating system is in 24-bit color mode, the guest operating system color setting controls offer 24-bit mode in place of 32-bit mode.
If you run a guest operating system set for a greater number of colors than the host operating system, the colors in the guest operating system might not be correct or the guest operating system might not be able to use a graphical interface. If these problems occur, you can either increase the number of colors in the host operating system or decrease the number of colors in the guest operating system.

To change color settings on the host operating system, power off all virtual machines and close Workstation Pro and then follow standard procedures for changing color settings.

How you change color settings in a guest operating system depends on the type of guest operating system. In a Windows guest, the Display Properties control panel offers only those settings that are supported. In a Linux or FreeBSD guest, you must change the color depth before you start the X server, or you must restart the X server after making the changes.

For best performance, use the same number of colors in the host and guest operating systems.

**Using Advanced Linux Sound Architecture**

Workstation 7.x and later versions support Advanced Linux Sound Architecture (ALSA). You might need to perform certain preparation tasks before you can use ALSA in a virtual machine.

To use ALSA, the host system must meet certain requirements.

- The ALSA library version on the host system must be version 1.0.16 or later.
- The sound card on the host system must support ALSA. The ALSA project Web site maintains a current listing of sound cards and chipsets that support ALSA.
- The ALSA sound card on the host system must not be muted.
- The current user must have the appropriate permissions to use the ALSA sound card.

**Override the ALSA Library Version Requirement for a Virtual Machine**

If the host system has an earlier version of the ALSA library, you can override the requirement for version 1.0.16.

If the host system does not meet ALSA requirements, or for some other reason cannot use ALSA, Workstation uses the OSS API for sound playback and recording. Depending on the sound card in the host system, the sound quality might not be as good when an older version of the ALSA library is used.

You should upgrade the host system to use the latest sound drivers and libraries.

**Procedure**

1. Open the virtual machine configuration (.vmx) file in a text editor.
2. Add the `sound.skipAlsaVersionCheck` property and set it to `TRUE`.
   
   For example: `sound.skipAlsaVersionCheck = "TRUE"

**Obtain ALSA Sound Card Information**

You can type commands at the command prompt on a Linux host system to obtain information about the ALSA sound card and determine whether the current user has the appropriate permissions to access it.

**Prerequisites**

Obtain the documentation for the `alsamixer` program. The documentation is available on the Internet.
Procedure

- Use the `alsamixer` program to determine whether the current user has the appropriate permissions to access the ALSA sound card.
  
  If the user does not have the appropriate permissions, an error similar to `alsamixer: function snd_ctl_open failed for default: No such device.` appears.

- If a user does not have the appropriate permissions to access the ALSA sound card, give the user read, write, and execute permissions to the directory that contains the ALSA sound card.

  The ALSA sound card is usually located in `/dev/snd/`. This location can vary depending on the Linux distribution.

- To list the name and type of sound chipset on the host system, type the command `lspci | grep -I audio`.

- To list the sound cards on the host system, type the command `cat /proc/asound/cards`.

- If the ALSA sound card is muted, use the `alsamixer` program to unmute it.

Configure a Virtual Machine to Use an ALSA Sound Card

You can configure a virtual machine to use an ALSA sound card by modifying virtual machine settings.

Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select **Sound Card**.
3. Select **Connected** and **Connect at power on**.
4. Select **Specify host sound card** and select the ALSA sound card.
5. If the ALSA sound card does not appear in the list, use the `alsa-utils` package to list the ALSA sound cards on the host system and select **Specify host sound card** again.
   
   For example: `aplay -L`
6. Click **OK** to save your changes.

Encrypting and Restricting Virtual Machines

Encrypting a virtual machine secures it from unauthorized use. To decrypt a virtual machine, users must enter the correct encryption password. Restricting a virtual machine prevents users from changing configuration settings unless they first enter the correct restrictions password. You can also set other restriction policies.

When you encrypt a virtual machine, Workstation Pro prompts you for a password. After the virtual machine is encrypted, you must enter this password to open the virtual machine or to remove encryption from it. Workstation Pro displays the encrypted virtual machine with a lock icon until you enter the password to open the virtual machine.

If you also enable restrictions, users are prevented from modifying the virtual machine. For example, you can enable restrictions to prevent users from removing virtual devices, changing the memory allocation, modifying removable devices, changing the network connection type, and changing the virtual hardware compatibility. A password prompt appears whenever anyone performs any of the following actions on the virtual machine:

- Clicks **Edit virtual machine settings** or **Upgrade Virtual Machine** on the virtual machine summary tab
- Double-clicks a virtual device in the **Devices** list on the virtual machine summary tab
Selects the virtual machine and selects VM > Settings or VM > Manage > Change Hardware Compatibility from the menu bar

Clicks or right-clicks on a removable device icon to edit its settings

Uses a Removable Devices > device_name menu to edit the settings for a device

Besides restricting users from changing USB device settings, you can also optionally set a policy that prevents users from connecting USB devices to the guest operating system. If you set the policy to allow connecting USB devices, users are not prompted to enter the restrictions password to use the devices.

An optional policy includes a setting that forces users to change the encryption password if they move or copy the virtual machine. For example, a teacher might provide a copy of the virtual machine to all students in the class and set this restriction so that all students must create their own encryption password.

Another optional policy includes setting an expiration date for a virtual machine. For example, an administrator can create a virtual machine for a temporary employee and set the virtual machine to expire when the temporary employee leaves the company.

**IMPORTANT** Make sure you record the encryption password and the restrictions password. Workstation Pro does not provide a way to retrieve these passwords if you lose them.

Encryption applies to all snapshots in a virtual machine. If you restore a snapshot in an encrypted virtual machine, the virtual machine remains encrypted whether or not it was encrypted when the snapshot was taken. If you change the password for an encrypted virtual machine, the new password applies to any snapshot you restore, regardless of the password in effect when the snapshot was taken.

- Virtual Machine Encryption Limitations on page 124
  The encryption feature has certain limitations.

- Encrypt and Restrict a Virtual Machine on page 125
  You can encrypt a virtual machine to secure it from unauthorized use. You can also enable restrictions to prevent users from changing configuration settings.

- Remove Encryption From a Virtual Machine on page 126
  You can remove encryption from a virtual machine.

- Change the Password for an Encrypted Virtual Machine on page 127
  You can change the password for an encrypted virtual machine. Changing the password does not re-encrypt the virtual machine.

**Virtual Machine Encryption Limitations**

The encryption feature has certain limitations.

- You must power off a virtual machine before you add or remove encryption or change the encryption password.

- The encryption feature supports virtual machines that have virtual hardware version 5.x or later only.

- You cannot create a linked clone from an encrypted virtual machine.

- If more than one unencrypted virtual machine shares the same virtual disk and you encrypt one of the virtual machines, the virtual disk becomes unusable for the unencrypted virtual machine.

- You cannot encrypt a shared or remote virtual machine.

- You cannot upload an encrypted virtual machine to a remote server.

- You cannot share an encrypted virtual machine.
Encrypt and Restrict a Virtual Machine

You can encrypt a virtual machine to secure it from unauthorized use. You can also enable restrictions to prevent users from changing configuration settings.

Depending on the size of the virtual machine, the encryption process can take several minutes or several hours.

**Prerequisites**

- Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select VM > Settings.
2. On the Options tab, select Access Control.
3. Click Encrypt.
4. Click Encrypt, type an encryption password, and click Encrypt.

The encryption password is required to gain access to the virtual machine. It does not prevent the user from changing the virtual machine configuration. Turn on restrictions and enter a password to prevent the user from changing the virtual machine configuration.

**IMPORTANT** Record the encryption password you use. If you forget the password, Workstation Pro does not provide a way to retrieve it.

Workstation Pro begins encrypting the virtual machine. After the encryption process is complete, you can optionally set a restrictions password.

5. (Optional) To enable restrictions, select the Enable restrictions check box and configure restrictions options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrictions password</td>
<td>Set the restrictions password. The restrictions password prevents users of the virtual machine from changing the virtual machine configuration. <strong>IMPORTANT</strong> Record the restrictions password you use. If you forget the password, Workstation Pro does not provide a way to retrieve it.</td>
</tr>
<tr>
<td>Restrictions type</td>
<td>Select a restriction type.</td>
</tr>
<tr>
<td></td>
<td><strong>Fixed</strong> - Enables you to set specific restrictions for the individual virtual machine.</td>
</tr>
<tr>
<td></td>
<td><strong>Managed</strong> - Enables restrictions for the virtual machine to be managed by a Horizon FLEX Policy Server. If you select this option, you must provide the server address of a Horizon FLEX server in the Management server text box. Do not select this option unless you have a Horizon FLEX installation.</td>
</tr>
<tr>
<td>Require the user to change the encryption password when this virtual machine is moved or copied</td>
<td>(Optional) Select this check box to require the user to change the encryption password for the virtual machine if the virtual machine is moved or copied.</td>
</tr>
<tr>
<td>Allow USB devices to be connected to this virtual machine</td>
<td>(Optional) Select this check box to allow USB device connections in the virtual machine.</td>
</tr>
</tbody>
</table>
**Option** | **Action**  
--- | ---  
**Expire the virtual machine after** | (Optional) If you selected the **Fixed** restriction type, set a date and time for the virtual machine to expire. Click the down arrow to select an expiration date. Click in the time field and enter the expiration time. To enter an alert message, perform these steps:  
  a. Click **Advanced**.  
  b. Enter text to be displayed when the virtual machine expires.  
  c. (Optional) Select the check box to show a message when the virtual machine is about to expire and enter message text.  
  d. (Optional) Set the number of days before expiration that the message is displayed.  
  e. Click **OK**.  

**Management server** | (Optional) If you selected the **Managed** restriction type, type the URL of the Horizon FLEX server on which you intend to host the virtual machine with Horizon FLEX.  

**Check server** | (Optional) If you selected the **Managed** restriction type, click this button to verify the Horizon FLEX server URL.  

**Manage certificates** | (Optional) If you selected the **Managed** restriction type, click this button and then click **Add** to navigate to the location of each certificate file to add. If you add certificates to the virtual machine, the Horizon FLEX Client uses the certificates in the virtual machine and does not use the certificates on the host. To control certificates for all virtual machines from the Horizon FLEX Policy Server, leave the Manage Certificates box blank.  

---  

6. Click **OK** in the Virtual Machine Settings dialog box.  

**Restricted Virtual Machine Expiration**  
When you enable restrictions for an encrypted virtual machine, how and when the virtual machine expires depends on whether you configure the Fixed or Managed restrictions type.  

**Fixed Virtual Machine Expiration**  
If you select the Fixed restriction type for an encrypted virtual machine, the expiration date and time are fixed, for example, December 12, 2012, at 11:00 am in local time. The time and date are in Universal Time Coordinated (UTC) format.  

When an encrypted virtual machine with an expiration date is powered on, the virtual machine verifies the time and compares it to the expiration date. While running, the virtual machine periodically checks the time and stores all successful timestamps as the last trusted time stamp. If the last trusted timestamp exceeds the date set for the virtual machine expiration, a warning message appears and the virtual machine is suspended.  

After a virtual machine has expired, you can delete or extend its expiration date. You must provide the restrictions password to change the expiration date.  

**Managed Virtual Machine Expiration**  
If you select the Managed restriction type for an encrypted virtual machine, a Horizon FLEX Policy Server manages the virtual machine expiration date and time. For more information, see the *VMware Horizon FLEX Administration Guide*.  

**Remove Encryption From a Virtual Machine**  
You can remove encryption from a virtual machine.  

**Prerequisites**  
- Power off the virtual machine.
■ Remove any sensitive information from the virtual machine.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **Encryption**.
3. Deselect the **Enable restrictions** check box, if it is selected.
   
   You cannot remove encryption from a virtual machine while restrictions are enabled.
4. Click **Remove Encryption**.
5. Type the encryption password.
6. Click **Remove Encryption**.

**Change the Password for an Encrypted Virtual Machine**

You can change the password for an encrypted virtual machine. Changing the password does not re-encrypt the virtual machine.

When you use this feature to change the password, the master key used to decrypt the virtual machine is not changed, and the virtual machine is not re-encrypted. For security reasons, instead of changing the password by using this procedure, you might choose to remove encryption and then encrypt the virtual machine again with a different password.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **Encryption**.
3. Select **Change Password**.
4. Type the current password and the new password.

**IMPORTANT** Make sure that you record the password. If you forget the password, Workstation Pro does not provide a way to retrieve it.

**Moving Virtual Machines**

You can move a virtual machine that was created in Workstation Pro to a different host system or to a different location on the same host system. You can also use a virtual machine that was created in Workstation Pro in Workstation Player.

■ **Move a Virtual Machine to a New Location or Host** on page 128

You can move a virtual machine that was created in Workstation Pro to a different host system or to a different location on the same host system. You can also move a virtual machine to a host system that has a different operating system.

■ **Open a Virtual Machine in VMware Workstation Player** on page 129

VMware® Workstation Player opens and plays virtual machines created in other VMware products. On Windows hosts, Workstation Player can also open and play Microsoft Virtual PC and Virtual Server virtual machines and Symantec LiveState Recovery and system images.
Configure a Virtual Machine for Compatibility on page 130

When you create a virtual machine that you intend to distribute to other users, you should configure the virtual machine for maximum compatibility with all expected host systems. Users might be limited in their ability to make changes in a virtual machine so that it is compatible with their host systems.

Using the Virtual Machine UUID on page 131

Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you initially power on the virtual machine.

Move a Virtual Machine to a New Location or Host

You can move a virtual machine that was created in Workstation Pro to a different host system or to a different location on the same host system. You can also move a virtual machine to a host system that has a different operating system.

Moving a virtual machine typically involves moving all of the files that make up the virtual machine. All files in the virtual machine’s original directory when the virtual machine was created must be moved. The path names for all files associated with a Workstation Pro virtual machine are relative to the virtual machine directory. If you stored any files in directories other than the virtual machine directory, be sure to move them into a directory of the same name and same position relative to the location of the virtual machine.

When you move a virtual machine to a different host system or to a different location on the same host system, Workstation Pro generates a new MAC address for the virtual network adapter. Workstation Pro also generates a new MAC address when you rename a directory in the path to the virtual machine configuration file.

Prerequisites

- If you are moving the virtual machine to a different host system, familiarize yourself with the limitations of moving a virtual machine to a new host. see “Limitations of Moving a Virtual Machine to a Different Host,” on page 129.
- If you are moving a linked clone or a parent virtual machine, verify that the clone can access the parent virtual machine. See “Moving Linked Clones,” on page 129 for more information.
- Make backup copies of the files in the virtual machine directory for the virtual machine that you are moving.

Procedure

1. Verify that all virtual machine files are stored in the virtual machines directory. Some files might reside outside of the virtual machines directory.
2. Shut down the guest operating system and power off the virtual machine.
3. Copy the virtual machine files to the new location.
4. If you moved the virtual machine to a different location on the same host system, remove the virtual machine from the library, select File > Open, and browse to the virtual machine configuration (.vmx) file in its new location.
5. If you moved the virtual machine to a different host system, start Workstation Pro on the new host system, select File > Open and browse to the virtual machine configuration (.vmx) file.
6. When you are certain that the virtual machine works correctly in its new location, delete the virtual machine files from its original location.
If the virtual machine does not work correctly, verify that you copied all of the virtual machine files to the new location.

You can examine virtual machine device settings to determine whether any associated files point to locations that cannot be accessed from the new location.

**Limitations of Moving a Virtual Machine to a Different Host**

You should be aware of certain limitations before you move a virtual machine to a different host system.

- The guest operating system might not work correctly if you move a virtual machine to a host system that has significantly different hardware, for example, if you move a virtual machine from a 64-bit host to a 32-bit host or from a multiprocessor host to a uniprocessor host.
- Workstation 7.x and later virtual machines support up to eight-way virtual symmetric multiprocessing (SMP) on multiprocessor host systems. Workstation 10.x and later virtual machines support up to sixteen-way multiprocessing on multiprocessor host systems. You can assign up to 8 or 16 virtual processors to virtual machines running on host systems that have at least two logical processors. If you attempt to assign two processors to a virtual machine that is running on a uniprocessor host system, a warning message appears. You can disregard this message and assign two processors to the virtual machine, but you must move it to a host that has at least two logical processors before you can power it on.
- You can move a virtual machine from a 32-bit host to a 64-bit host. You cannot move a virtual machine from a 64-bit host to a 32-bit host unless the 32-bit host has a supported 64-bit processor.

**Moving Linked Clones**

If you move a linked clone, or if you move its parent virtual machine, make sure that the clone can access the parent virtual machine.

You cannot power on a linked clone if Workstation Pro cannot locate the original virtual machine.

For example, if you put a linked clone on a laptop and the parent remains on another machine, you can use the clone only when the laptop connects to the network or drive where the parent is stored.

To use a cloned virtual machine on a disconnected laptop, you must use a full clone, or you must move the parent virtual machine to the laptop.

**Open a Virtual Machine in VMware Workstation Player**

VMware® Workstation Player opens and plays virtual machines created in other VMware products. On Windows hosts, Workstation Player can also open and play Microsoft Virtual PC and Virtual Server virtual machines and Symantec LiveState Recovery and system images.

Workstation Player is included with VMware Workstation Pro. When you install Workstation Pro, the Workstation Player application file is stored with the Workstation Pro program files. On Windows hosts, the file is called `vmplayer.exe`. On Linux hosts, the file is called `vmplayer`.

**Note** You can download the standalone version of Workstation Player for free from the VMware Web site.

**Prerequisites**

Verify that the virtual machine is compatible with Workstation Player. See “Configure a Virtual Machine for Compatibility,” on page 130.
Procedure

1. Start Workstation Player.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>From the GUI on a Windows host</td>
<td>Select Start &gt; Programs &gt; VMware &gt; VMware Player.</td>
</tr>
<tr>
<td>From the command line on a Windows host</td>
<td>Type <code>path\vmplayer.exe</code>, where <code>path</code> is the path to the application file.</td>
</tr>
<tr>
<td>From a Linux X session</td>
<td>Select VMware Player from the corresponding program menu, such as the System Tools menu.</td>
</tr>
<tr>
<td>From the command line on a Linux host</td>
<td>Type <code>vmplayer &amp;</code>.</td>
</tr>
</tbody>
</table>

2. Select File > Open a Virtual Machine and browse to the virtual machine configuration (.vmx) file.


Configure a Virtual Machine for Compatibility

When you create a virtual machine that you intend to distribute to other users, you should configure the virtual machine for maximum compatibility with all expected host systems. Users might be limited in their ability to make changes in a virtual machine so that it is compatible with their host systems.

Procedure

- Install VMware Tools in the virtual machine.
  VMware Tools significantly improves the user’s experience working with the virtual machine.

- Determine which virtual devices are actually required, and do not include any that are not needed or useful for the software you are distributing with the virtual machine.
  Generic SCSI devices are typically not appropriate.

- To connect a physical device to a virtual device, use the Auto detect options when you configure the virtual machine.
  The Auto detect options allow the virtual machine to adapt to the user’s system, and they work whether the host operating system is Windows or Linux. Users who have no physical device receive a warning message.

- To connect a CD-ROM or floppy to an image file that you ship with the virtual machine, make sure the image file is in the same directory as the virtual machine.
  A relative path, rather than an absolute path, is used.

- For both a physical CD-ROM and an image, provide two virtual CD-ROM devices in the virtual machine.
  For example, Workstation Pro does not provide an option to switch a single CD-ROM device between a physical CD-ROM and an image, and the user cannot switch between them if you plan to ship multiple images.

- Choose a reasonable amount of memory to allocate to the virtual machine.
  For example, if the host system does not have enough physical memory to support the memory allocation, the user cannot power on the virtual machine.

- Choose a reasonable screen resolution for the guest.
  A user is likely to find it easier to increase the resolution manually than to deal with a display that exceeds the user’s physical screen size.
To ensure that CD-ROMs work properly in virtual machines that you intend to distribute and play on Workstation Pro, configure CD-ROM devices in legacy mode.

Some host operating systems do not support CD-ROMs in non-legacy mode.

When you configure a snapshot option for the virtual machine, select Just power off or Revert to snapshot.

The Revert to snapshot option is useful if you want to distribute a demo virtual machine that resets itself to a clean state when it is powered off. Workstation Pro does not allow taking snapshots.

Using the Virtual Machine UUID

Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you initially power on the virtual machine.

You can use the UUID of a virtual machine for system management in the same way that you use the UUID of a physical computer. The UUID is stored in the SMBIOS system information descriptor, and you can access it by using standard SMBIOS scanning software, including SiSoftware Sandra or IBM smbios2.

If you do not move or copy the virtual machine to another location, the UUID remains constant. When you power on a virtual machine that was moved or copied to a new location, you are prompted to specify whether you moved or copied the virtual machine. If you indicate that you copied the virtual machine, the virtual machine receives a new UUID.

Suspending and resuming a virtual machine does not trigger the process that generates a UUID. The UUID in use at the time the virtual machine was suspended remains in use when the virtual machine is resumed, even if it was copied or moved. You are not prompted to specify whether you moved or copied the virtual machine until the next time you reboot the virtual machine.

Configure a Virtual Machine to Always Receive a New UUID

You can configure a virtual machine to always receive a new UUID when it is copied or moved so that you are not prompted when you move or copy the virtual machine.

Prerequisites

Power off the virtual machine.

Procedure

1. Open the virtual machine configuration (.vmx) file in a text editor.
2. Add the uuid.action property to the .vmx file and set it to create.

   For example: `uuid.action = "create"

Configure a Virtual Machine to Keep the Same UUID

You can configure a virtual machine to always keep the same UUID, even when it is moved or copied. When a virtual machine is set to always keep the same UUID, you are not prompted when a virtual machine is moved or copied.

Prerequisites

Power off the virtual machine.

Procedure

1. Open the virtual machine configuration (.vmx) file in a text editor.
2. Add the uuid.action property and set it to keep.

   For example: `uuid.action = "keep"
Override the Generated UUID for a Virtual Machine

You can override the generated UUID and assign a specific UUID to a virtual machine.

Prerequisites

Power off the virtual machine.

Procedure

1. Open the virtual machine configuration (.vmx) file in a text editor.
2. Search for the line that contains uuid.bios.
   
   The format of the line is uuid.bios = "uuid_value". The UUID is a 128-bit integer. The 16 bytes are separated by spaces, except for a dash between the eighth and ninth hexadecimal pairs.

   For example: uuid.bios = "00 11 22 33 44 55 66 77-88 99 aa bb cc dd ee ff"
3. Replace the existing UUID value with the specific UUID value.
4. Power on the virtual machine.

The virtual machine uses new UUID is used when it reboots.

Configure a Virtual Machine as a VNC Server

You can use Workstation Pro to configure a virtual machine to act as a Virtual Network Computing (VNC) server so that users on other computers can use a VNC client to connect to the virtual machine. You do not need to install specialized VNC software in a virtual machine to set it up as a VNC server.

**NOTE** You cannot configure a shared or remote virtual machine as a VNC server.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Options tab, select VNC Connections and select Enable VNC.
3. (Optional) To allow VNC clients to connect to multiple virtual machines on the same host system, specify a unique port number for each virtual machine.
   
   Use should use a port number in the range from 5901 to 6001. Other applications use certain port numbers, and some port numbers are privileged. For example, the VMware Management Interface uses ports 8333 and 8222 and VMware Workstation Server uses port 443. On Linux, only the root user can listen to ports up to port number 1024.
4. (Optional) Set a password for connecting to the virtual machine from a VNC client.
   
   The password can be up to eight characters long. Because it is not encrypted when the VNC client sends it, do not use a password that you use for other systems.
5. (Optional) Click View VNC Connections to see a list of the VNC clients that are remotely connected to the virtual machine and find out how long they have been connected.
6. Click OK to save your changes.

What to do next

If you do not VNC clients use to use the US101 keyboard map (U.S. English) when they connect to the virtual machine, specify a different language. See “Specify a Language Keyboard Map for VNC Clients,” on page 133.
Specify a Language Keyboard Map for VNC Clients

If you set a virtual machine to act as a VNC server, you can specify which language to use for the keyboard that VNC clients use. By default, the US101 keyboard map (U.S. English) is used.

Prerequisites

- Verify that the virtual machine is set to act as a VNC server.
- Determine the language code to use. See “Language Codes,” on page 133.

Procedure

1. In a text editor, open the virtual machine configuration (.vmx) file for the virtual machine and add the RemoteDisplay.vnc.enabled and RemoteDisplay.vnc.port properties.
   a. Set RemoteDisplay.vnc.enabled to TRUE.
   b. Set RemoteDisplay.vnc.port to the port number to use.
   For example:
   RemoteDisplay.vnc.enabled = "TRUE"
   RemoteDisplay.vnc.port = "portnumber"

2. Determine the location of the keymap file to use.
   Default keymap files are included in the Workstation Pro installation directory.

<table>
<thead>
<tr>
<th>Host System</th>
<th>Keymap File Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, Windows 8, and Windows 10 hosts</td>
<td>C:\ProgramData\VMware\vnckeymap</td>
</tr>
<tr>
<td>Linux host</td>
<td>/usr/lib/vmware/vnckeymap</td>
</tr>
</tbody>
</table>

3. In the virtual machine configuration (.vmx) file, add a property to specify the location of the keymap file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>To use the default keymap file included in the Workstation Pro installation directory</td>
<td>Add RemoteDisplay.vnc.keyMap = &quot;xx&quot;, where xx is the code for the language to use, such as jp for Japanese.</td>
</tr>
<tr>
<td>To use a keyboard map file in another location</td>
<td>Add RemoteDisplay.vnc.keyMapFile = &quot;filepath&quot;, where filepath is the absolute file path.</td>
</tr>
</tbody>
</table>

4. Start the virtual machine and connect to it from a VNC client.

Language Codes

When you specify a language keyboard map for VNC clients, you must specify a language code.

<table>
<thead>
<tr>
<th>Code</th>
<th>Language</th>
</tr>
</thead>
<tbody>
<tr>
<td>de</td>
<td>German</td>
</tr>
<tr>
<td>de-ch</td>
<td>German (Switzerland)</td>
</tr>
<tr>
<td>es</td>
<td>Spanish</td>
</tr>
<tr>
<td>fi</td>
<td>Finnish</td>
</tr>
<tr>
<td>fr</td>
<td>French</td>
</tr>
<tr>
<td>fr-be</td>
<td>French (Belgium)</td>
</tr>
</tbody>
</table>
Table 6-1. Language Codes (Continued)

<table>
<thead>
<tr>
<th>Code</th>
<th>Language</th>
</tr>
</thead>
<tbody>
<tr>
<td>fr-ch</td>
<td>French (Switzerland)</td>
</tr>
<tr>
<td>is</td>
<td>Icelandic</td>
</tr>
<tr>
<td>it</td>
<td>Italian</td>
</tr>
<tr>
<td>jp</td>
<td>Japanese</td>
</tr>
<tr>
<td>nl-be</td>
<td>Dutch (Belgium)</td>
</tr>
<tr>
<td>no</td>
<td>Norwegian</td>
</tr>
<tr>
<td>pt</td>
<td>Polish</td>
</tr>
<tr>
<td>uk</td>
<td>UK English</td>
</tr>
<tr>
<td>us</td>
<td>US English</td>
</tr>
</tbody>
</table>

Use a VNC Client to Connect to a Virtual Machine

You can use a VNC client to connect to a running virtual machine. Because VNC software is cross-platform, you can use virtual machines running on different types of computers.

Workstation Pro does not need to be running to use VNC to connect to a virtual machine. Only the virtual machine needs to be running, and it can be running in the background.

When you use a VNC client to connect to a virtual machine, some features do not work or are not available.

- You cannot take or revert to snapshots.
- You cannot power on, power off, suspend, or resume the virtual machine. You can shut down the guest operating system. Shutting down might power off the virtual machine.
- You cannot copy and paste text between the host system and the guest operating system.
- You cannot change virtual machine settings.
- Remote display does not work well if you are also using the 3D feature.

Prerequisites

- Configure the virtual machine as a VNC server. See “Configure a Virtual Machine as a VNC Server,” on page 132.
- Determine the machine name or IP address of the host system on which the virtual machine is running and, if required, the VNC port number and password.

Procedure

1. Install a VNC client on your computer.
   Open-source versions of VNC are freely and publicly available. You can use any VNC client, but not a Java viewer in a browser.
2. Start the VNC client on your computer.
3. Verify that the client is set for hextile encoding.
   For example, if you use RealVNC Viewer, select Hextile under the Preferred Encoding option.
4. Set the VNC client to use all colors.
   For example, if you use RealVNC Viewer, select Full (all available colours) under the Colour Level option.
5 When prompted for the VNC server name, type the name or IP address and the port number of the host system where the virtual machine is running.

For example: `machine_name:port_number`

6 Type a password if one is required.

**View VNC Connections for a Virtual Machine**

When a virtual is configured to act as a VNC server, you can view a list of the VNC clients that are remotely connected to the virtual machine and find out how long they have been connected.

**Prerequisites**

Configure the virtual machine to act as a VNC server. See “Configure a Virtual Machine as a VNC Server,” on page 132.

**Procedure**

- Select the virtual machine and select **VM > Manage > VNC Connections**.

**Change the Hardware Compatibility of a Virtual Machine**

You can change the hardware compatibility of a virtual machine. All virtual machines have a hardware version. The hardware version indicates which virtual hardware features that the virtual machine supports, such as BIOS or EFI, number of virtual slots, maximum number of CPUs, maximum memory configuration, and other hardware characteristics.

When you upgrade Workstation Pro, you must change the hardware compatibility of virtual machines that were created in previous versions of Workstation Pro so that they can use the new features in the new version of Workstation Pro. You can run older versions of virtual machines in the new version of Workstation Pro, but you will not have the benefits of the new features.

If you want a virtual machine to remain compatible with other VMware products that you are using, you might not want to change the hardware compatibility to the latest Workstation Pro version.

**Note** If you decide not to change the hardware compatibility of a virtual machine, you should consider upgrading to the latest version of VMware Tools to obtain the latest VMware Tools features.

**Prerequisites**

Familiarize yourself with the considerations and limitations of changing the hardware compatibility of a virtual machine. See “Considerations for Changing the Hardware Compatibility of a Virtual Machine,” on page 32.

**Procedure**

1 Make backup copies of the virtual disk (.vmdk) files.

2 If you are upgrading from a Workstation 5.x virtual machine, or downgrading to a Workstation 5.x virtual machine, make a note of the NIC settings in the guest operating system.

   If you specified a static IP address for the virtual machine, that setting might be changed to automatic assignment by DHCP after the upgrade.

3 Shut down the guest operating system and power off the virtual machine.

4 Select the virtual machine and select **VM > Manage > Change Hardware Compatibility**.
5 Follow the prompts in the wizard to change the hardware compatibility of the virtual machine.

When you select a hardware compatibility setting, a list of the VMware products that are compatible with that setting appears. For example, if you select Workstation 4, 5, or 6, a list of Workstation 6.5 and later features that are not supported for that Workstation version also appears.

**Note** Using Workstation 10, you can change the hardware compatibility of a shared or remote virtual machine. However, you cannot downgrade a previously created virtual machine.

6 Power on the virtual machine.

If you upgrade a virtual machine that contains a Windows 98 operating system to a Workstation 6.5 or later virtual machine, you must install a PCI-PCI bridge driver when you power on the virtual machine.

**Note** Because Workstation 6.5 and later versions have 32 more PCI-PCI bridges than Workstation 6, you might need to respond to the prompt 32 or 33 times.

7 If the NIC settings in the guest operating system have changed, use the NIC settings that you recorded to change them back to their original settings.

8 If the virtual machine does not have the latest version of VMware Tools installed, update VMware Tools.

You should update VMware Tools to the version included with the latest version of Workstation Pro, even if you upgraded the virtual machine to an earlier version of Workstation Pro. Do not remove the older version of VMware Tools before installing the new version.

**Note** If you are upgrading a virtual machine that runs from a physical disk, you can safely ignore this message: Unable to upgrade drive_name. One of the supplied parameters is invalid.

---

### Considerations for Changing the Hardware Compatibility of a Virtual Machine

Before you change the hardware compatibility of a virtual machine, you should be aware of certain considerations and limitations.

- For Workstation 5.x, 6, 6.5, 7.x, and later virtual machines, you can change the version of the original virtual machine or create a full clone so that the original virtual machine remains unaltered.

- If you upgrade a Workstation 5.x virtual machine that is compatible with ESX Server to Workstation 6, 6.5, 7.x, or later, you cannot use the Change Hardware Compatibility wizard to later downgrade the virtual machine to an ESX-compatible virtual machine.

- When you upgrade a Windows XP, Windows Server 2003, Windows Vista, Windows 7, or Windows 8 virtual machine, the Microsoft product activation feature might require you to reactivate the guest operating system.

- Using Workstation 9 or earlier, you cannot change the hardware compatibility of a shared or remote virtual machine.

- Using Workstation 10 and later, you can change the hardware compatibility of a shared or remote virtual machine. However, you cannot downgrade a previously created virtual machine.
Clean Up a Virtual Hard Disk on Windows Hosts

When you delete files from your virtual machine, the disk space occupied by those files is not immediately returned to your host system. If a virtual disk has such empty space, you can use the **Clean up disks** command to return that space to the hard drive on a Microsoft Windows host.

The **Clean up disks** command is similar to the **Compact** command in the Workstation Pro virtual machine settings and the **shrink** command provided by VMware Tools. The **Clean up disks** command has these advantages:

- You can use the **Clean up disks** command with virtual machines that have snapshots or are linked clones or parents of a linked clone.
- The **Clean up disks** command reclaims more disk space than the **Compact** command.
- The **Clean up disks** command reclaims disk space from the current state of the virtual machine, from any powered-off snapshots, and from any powered-on snapshots where the guest operating system is Windows XP or later and you have installed a version of VMware Tools that is compatible with Workstation 8 or later.
- Unlike the **Defragment** command and the **shrink** command provided by VMware Tools, the **Clean up disks** command does not require any extra disk space on the host. The **Clean up disks** command operates directly on the virtual disk (.vmdk) files.

**Note** This command is not available for shared or remote virtual machines.

**Prerequisites**

- Verify that you are using a Windows host and that the guest operating system uses NTFS. (NTFS is standard in Windows XP or later operating systems.) This feature works on all NTFS hard disks but reclaims more disk space if the operating system is Windows XP or later.
- Shut down or power off the virtual machine. You cannot use this command while the virtual machine is powered on or suspended.

**Procedure**

1. Select the virtual machine in the library.
2. From the menu bar, select **VM > Manage > Clean Up Disks**.
   Workstation Pro calculates how much space can be reclaimed, and either the **Clean Up Now** button becomes available or a message appears, explaining why the command is unavailable.
3. Click **Clean Up Now** to start the process.
   A dialog box reports the progress of the clean-up process.

**Export a Virtual Machine to OVF Format**

You can export a virtual machine from Workstation Pro to OVF format.

OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual machines. OVF format provides a complete specification of the virtual machine, including the full list of required virtual disks and the required virtual hardware configuration, including CPU, memory, networking, and storage. An administrator can quickly provision an OVF-formatted virtual machine with little or no intervention.
You can also use the standalone OVF Tool to convert a virtual machine that is in VMware runtime format to an OVF virtual machine. The standalone version of the OVF Tool is installed in the Workstation Pro installation directory under OVFTool. See the OVF Tool User Guide on the VMware Web site for information about using the OVF Tool.

**Prerequisites**

- Verify that the virtual machine is not encrypted. You cannot export an encrypted virtual machine to OVF format.
- Verify that the virtual machine is powered off.

**Procedure**

1. Select the virtual machine and select `File > Export to OVF`.
2. Type a name for the OVF file and specify a directory in which to save it.
3. Click `Save` to start the OVF export process.

The export process can take several minutes. A status bar indicates the progress of the export process.

**Writing and Debugging Applications That Run In Virtual Machines**

Application developers can use APIs, SDKs, and IDEs to write and debug applications that run in virtual machines.

**VIX API**
You can use the VIX API to write programs that automate virtual machine operations. The API is easy to use and useful for both script writers and application programmers. Functions enable you to power virtual machines on and off, register them, and run programs to manipulate files in the guest operating systems. Additional language bindings are available for Perl, COM, and shell scripts (for example, `vmrun`).

**VMCI Sockets Interface**
VMCI Sockets is a network sockets API for the Virtual Machine Communication Interface. It provides a fast means of communication between a host and its guest virtual machines. This API is well-suited for client-server applications. See the VMCI Sockets Programming Guide.

**Integrated Virtual Debuggers for Eclipse**
The integrated development environment (IDE) plug-ins provide a configurable interface between virtual machines and Eclipse. They let you test, run, and debug programs in virtual machines. See the Integrated Virtual Debugger for Eclipse Developer’s Guide.

**Debugging Over a Virtual Serial Port**
You can use virtual machines to debug kernel code on one system without the need for two physical computers, a modem, or a serial cable. You can use Debugging Tools for Windows (WinDbg) or Kernel Debugger (KD) to debug kernel code in a virtual machine over a virtual serial port.

You can Download Debugging Tools for Windows from the Windows Hardware Developer Central (WHDC) Web site.

**Debug an Application in a Virtual Machine from a Windows Host**
You can debug an application in a virtual machine from a Windows host system over a virtual serial port.

**Prerequisites**

- Verify that Debugging Tools for Windows is installed on the host system and that it supports debugging over a pipe. It must be version 5.0.18.0 or later.
Verify that a serial port is configured for the virtual machine. See “Configuring Virtual Ports,” on page 156.

**Procedure**

1. Configure the named pipe on the target virtual machine and select **This end is the server**.
2. Power on the virtual machine.
3. Select the virtual machine, select **VM > Removable Devices**, and verify that the serial port is connected.
4. If the serial port is not reported as `\\\pipe\namedpipe`, select the virtual serial port and click **Connect**.
5. On the host system, type the debugger command.
   
   For example: `debugger -k com:port=\\\pipe\namedpipe,pipe`
   
   The `debugger` value is **WinDbg** or **KD**.
6. Press Enter to start debugging.

**Debug an Application in a Virtual Machine from Another Virtual Machine**

You can use the WinDbg or KD debugger to debug an application in a virtual machine from another virtual machine over a serial port.

**Prerequisites**

- Download and install WinDbg or KD in the Windows guest operating system that you plan to use as the debugger virtual machine.
- Verify that a serial port is configured for the virtual machine. See “Configuring Virtual Ports,” on page 156.

**Procedure**

1. Power on both virtual machines.
2. Select the virtual machine and select **VM > Removable Devices** to verify that the serial port is connected.
3. If the serial port is not connected, select the virtual serial port and click **Connect**.
4. In the debugger virtual machine, start debugging by using WinDbg or KD.
VMware Workstation Server saves messages in log files. Refer to these log files if you need to audit or troubleshoot a problem with remote access or remote authorization.

**Table 7-1. Workstation Server Log Files**

<table>
<thead>
<tr>
<th>Host System</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, Windows 8, and Windows 10 hosts</td>
<td>C:\ProgramData\VMware\hostd\hostd-n.log</td>
</tr>
<tr>
<td>Linux hosts</td>
<td>/var/log/vmware/hostd-n.log</td>
</tr>
</tbody>
</table>

On Linux hosts, security-related information, such as authorization attempts, is sent to the system messages log.
You can use Workstation Pro to add devices to virtual machines, including DVD and CD-ROM drives, floppy drives, USB controllers, virtual and physical hard disks, parallel and serial ports, generic SCSI devices, and processors. You can also modify settings for existing devices.

This chapter includes the following topics:

- “Configuring DVD, CD-ROM, and Floppy Drives,” on page 143
- “Configuring a USB Controller,” on page 145
- “Configuring and Maintaining Virtual Hard Disks,” on page 147
- “Adding a Physical Disk to a Virtual Machine,” on page 154
- “Configuring Virtual Ports,” on page 156
- “Configuring Generic SCSI Devices,” on page 161
- “Configuring Sixteen-Way Virtual Symmetric Multiprocessing,” on page 163
- “Configuring Keyboard Features,” on page 164
- “Modify Hardware Settings for a Virtual Machine,” on page 173

### Configuring DVD, CD-ROM, and Floppy Drives

You can add up to 4 IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (4 controllers with 30 devices per controller) to a virtual machine. Any of these devices can be a virtual or physical hard disk or DVD or CD-ROM drive. By default, a floppy drive is not connected when a virtual machine powers on.

A virtual machine can read data from a DVD disc. Workstation Pro does not support playing DVD movies in a virtual machine. You might be able to play a movie if you use a DVD player application that does not require video overlay support in the video card.

### Add a DVD or CD-ROM Drive to a Virtual Machine

You can add one or more DVD or CD-ROM drives to a virtual machine. You can connect the virtual DVD or CD-ROM drive to a physical drive or an ISO image file.

You can configure the virtual DVD or CD-ROM drive as an IDE or a SCSI device, regardless of the type of physical drive that you connect it to. For example, if the host has an IDE CD-ROM drive, you can set up the virtual machine drive as either SCSI or IDE and connect it to the host drive.

Do not configure legacy emulation mode unless you experience problems with normal mode. See “Configure Legacy Emulation Mode for a DVD or CD-ROM Drive,” on page 145 for more information.
Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select DVD/CD Drive.
4. Select a physical drive or ISO image file to connect to the drive.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use physical drive</td>
<td>The virtual machine uses a physical drive.</td>
</tr>
<tr>
<td>Use ISO image</td>
<td>The drive connects to an ISO image file.</td>
</tr>
</tbody>
</table>

5. Configure the physical drive or ISO image file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical drive</td>
<td>Select a specific drive, or select Auto detect to allow Workstation Pro to auto-detect the drive to use.</td>
</tr>
<tr>
<td>ISO image file</td>
<td>Type the path or browse to the location of the ISO image file.</td>
</tr>
</tbody>
</table>

6. To connect the drive or ISO image file to the virtual machine when the virtual machine powers on, select Connect at power on.
7. Click Finish to add the drive to the virtual machine.
   The drive initially appears as an IDE drive to the guest operating system.
8. (Optional) To change which SCSI or IDE device identifier to use for the drive, select the drive and click Advanced.
9. Click OK to save your changes.

Add a Floppy Drive to a Virtual Machine

You can configure a virtual floppy drive to connect to a physical floppy drive or an existing or blank floppy image file. You can add up to two floppy drives to a virtual machine.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select Floppy Drive.
4. Select the floppy media type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical floppy drive</td>
<td>The virtual machine uses a physical floppy drive.</td>
</tr>
<tr>
<td>Use a floppy image</td>
<td>The drive connects to an floppy image (.flp) file.</td>
</tr>
<tr>
<td>Create a blank floppy image</td>
<td>The drive connects to a blank floppy image (.flp) file that you create.</td>
</tr>
</tbody>
</table>

5. If you selected the physical floppy drive media type, select a specific floppy drive or select Auto detect to allow Workstation Pro to auto-detect the drive to use.
6 If you selected the floppy image or blank floppy image media type, type the name or browse to the location of a floppy image (.flp) file.

7 To connect the drive or floppy image file to the virtual machine when the virtual machine powers on, select **Connect at power on**.

8 Click **Finish** to add the drive to the virtual machine.

9 Click **OK** to save your changes.

10 If you added a second floppy drive to the virtual machine, enable the drive in the virtual machine BIOS.
   a Select the virtual machine and select **VM > Power > Power On to BIOS**.
   b Select **Legacy Diskette B** and use the plus (+) and minus (-) keys on the numerical keypad to select the type of floppy drive to use.
   c Press F10 to save the settings.

### Configure Legacy Emulation Mode for a DVD or CD-ROM Drive

Use legacy emulation mode to work around direct communication problems between a guest operating system and a DVD or CD-ROM drive.

In legacy emulation mode, you can read only from data discs in the DVD or CD-ROM drive. Legacy emulation mode does not provide the other capabilities of normal mode. In normal mode, the guest operating system communicates directly with the CD-ROM or DVD drive. This direct communication enables you to read multisession CDs, perform digital audio extraction, view videos, and use CD and DVD writers to burn discs.

If you run more than one virtual machine at a time, and if their CD-ROM drives are in legacy emulation mode, you must start the virtual machines with their CD-ROM drives disconnected. By disconnecting the CD-ROM drives in the virtual machines, you prevent multiple virtual machines from being connected to the CD-ROM drive at the same time.

**Procedure**

1 Select the virtual machine and select **VM > Settings**.
2 On the **Hardware** tab, select the drive and click **Advanced**.
3 Select **Legacy emulation** and click **OK**.
   On Windows hosts, this option is deselected by default. On Linux hosts that have IDE drives, the default setting depends on whether the `ide-scsi` module is loaded in the kernel. The `ide-scsi` module must be loaded, or you must use a physical SCSI drive, to connect directly to the DVD or CD-ROM drive.
4 Click **OK** to save your changes.

### Configuring a USB Controller

A virtual machine must have a USB controller to use USB devices and smart card readers. To use a smart card reader, a virtual machine must have a USB controller regardless of whether the smart card reader is actually a USB device.

Workstation Pro provides a USB controller to support the following types of USB devices:

- USB 1.1 UHCI (Universal Host Controller Interface) is supported for all virtual machine hardware versions.
- USB 2.0 EHCI (Enhanced Host Controller Interface) controllers are supported if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.
USB 3.0 xHCI (Extensible Host Controller Interface) support is available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 or later virtual machines.

For USB 2.0 or 3.0 support, you must select USB 2.0 or 3.0 compatibility by configuring virtual machine settings for the USB controller. USB 2.0 and 3.0 devices are high-speed devices that include the latest models of USB flash drives, USB hard drives, iPods, and iPhone.

If you select USB 2.0 compatibility, when a USB 2.0 device connects to a USB port on the host system, the device connects to the EHCI controller and operates in USB 2.0 mode. A USB 1.1 device connects to the UHCI controller and operates in USB 1.1 mode. If you enable USB 3.0, the xHCI controller can support all USB devices, including USB 1.1, 2.0, and 3.0 devices.

Although the host operating system must support USB, you do not need to install device-specific drivers for USB devices in the host operating system to use those devices only in the virtual machine. Linux kernels earlier than 2.2.17 do not support USB.

VMware has tested a variety of USB devices. If the guest operating system has the appropriate drivers, you can use many different USB devices, including PDAs, Smart phones, printers, storage devices, scanners, MP3 players, digital cameras, memory card readers, and isochronous transfer devices, such as webcams, speakers, and microphones.

You can connect USB human interface devices (HIDs), such as the keyboard and mouse, to a virtual machine by enabling the Show all USB input devices option. If you do not select this option, these devices do not appear in the Removable Devices menu and are not available to connect to the virtual machine, even though they are plugged in to USB ports on the host system.

See “Connect USB HIDs to a Virtual Machine,” on page 92 for information on connecting HIDs.

Add a USB Controller to a Virtual Machine

A USB controller is required to use a smart card in a virtual machine, regardless of whether the smart card reader is a USB device. You can add one USB controller to a virtual machine.

When you create a virtual machine in Workstation Pro, a USB controller is added by default. If you remove the USB controller, you can add it back.

**Note** Shared and remote virtual machines are created without a USB controller by default. You can add a USB controller manually after you finish creating a shared or remote virtual machine.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, click Add.
3. In the New Hardware wizard, select USB Controller.
4 Configure the USB connection settings.
You can select multiple settings.

**Note** You typically cannot configure USB connection settings for a shared or remote virtual machine.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>USB Compatibility</strong></td>
<td>Selecting USB 2.0 or 3.0 enables support for isochronous USB devices, including Web cams, speakers, and microphones.</td>
</tr>
<tr>
<td><strong>Automatically connect new USB devices</strong></td>
<td>Connect new USB devices to the virtual machine. If this setting is not selected, new USB devices are connected only to the host system.</td>
</tr>
<tr>
<td><strong>Show all USB input devices</strong></td>
<td>Human interface devices (HIDs), such as USB 1.1 and 2.0 mouse and keyboard devices, appear in the Removable Devices menu. Icons for HIDs appear in the status bar. An HID that is connected to the guest operating system is not available to the host system. The virtual machine must be powered off when you change this setting.</td>
</tr>
<tr>
<td><strong>Share Bluetooth devices with the virtual machine</strong></td>
<td>Enable support for Bluetooth devices.</td>
</tr>
</tbody>
</table>

5 Click **Finish** to add the USB controller.

**Enable Support for Isochronous USB Devices**

Modems and certain streaming data devices, such as speakers and webcams, do not work properly in a virtual machine unless you enable support for isochronous USB devices.

**Prerequisites**

- Verify that the guest operating system supports USB 2.0 devices or 3.0 devices.
- On a Windows XP guest operating system, verify that the latest service pack is installed. If you use Windows XP with no service packs, the driver for the EHCI controller cannot be loaded.

**Procedure**

1 Select the virtual machine and select **VM > Settings**.
2 On the **Hardware** tab, select **USB Controller**.
3 From the **USB Compatibility** list, select **USB 2.0** or **USB 3.0**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>USB 2.0</strong></td>
<td>Available if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.</td>
</tr>
<tr>
<td><strong>USB 3.0</strong></td>
<td>Available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 and later virtual machines.</td>
</tr>
</tbody>
</table>

4 Click **OK** to save your changes.

**Configuring and Maintaining Virtual Hard Disks**

You can use Workstation Pro to configure virtual hard disk storage for virtual machines.

A virtual disk is a file or set of files that appears as a physical disk drive to a guest operating system. The files can be on the host system or on a remote computer. When you configure a virtual machine to use a virtual disk, you can install a new operating system onto the virtual disk without repartitioning a physical disk or rebooting the host.
The New Virtual Machine wizard creates a virtual machine that has one disk drive. You can modify virtual machine settings to add more disk drives to a virtual machine, remove disk drives from a virtual machine, and change certain settings for the existing disk drives.

- **Configuring a Virtual Hard Disk** on page 148
  You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can also set up a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or BusLogic SCSI adapter. You determine which SCSI adapter to use when you create a virtual machine.

- **Compact a Virtual Hard Disk** on page 151
  Compacting a virtual hard disk reclaiming unused space in the virtual disk. If a disk has empty space, this process reduces the amount of space the virtual disk occupies on the host drive.

- **Expand a Virtual Hard Disk** on page 151
  You can add storage space to a virtual machine by expanding its virtual hard disk.

- **Defragment a Virtual Hard Disk** on page 152
  Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual hard disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.

- **Remove a Virtual Hard Disk from a Virtual Machine** on page 152
  Removing a virtual hard disk disconnects it from a virtual machine. It does not delete files from the host file system.

- **Using Virtual Disk Manager** on page 153
  Virtual Disk Manager (vmware-vdiskmanager.exe) is a Workstation Pro utility that you can use to create, manage, and modify virtual disk files from the command line or in scripts.

- **Using Legacy Virtual Disks** on page 153
  You can use the current version of Workstation Pro in a mixed environment with virtual machines that were created with earlier versions or with other VMware products.

- **Using Lock Files to Prevent Consistency Problems on Virtual Hard Disks** on page 153
  A running virtual machine creates lock files to prevent consistency problems on virtual hard disks. Without locks, multiple virtual machines might read and write to the disk, causing data corruption.

- **Moving a Virtual Hard Disk to a New Location** on page 154
  A key advantage of virtual hard disks is their portability. Because the virtual hard disks are stored as files on the host system or a remote computer, you can move them easily to a new location on the same computer or to a different computer.

### Configuring a Virtual Hard Disk

You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can also set up a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or BusLogic SCSI adapter. You determine which SCSI adapter to use when you create a virtual machine.

The files that make up an IDE, SATA, or SCSI virtual hard disk can be stored on an IDE hard disk, SATA hard disk, or on a SCSI hard disk. They can also be stored on other types of fast-access storage media.

To use SCSI hard disks in a 32-bit Windows XP virtual machine, you must download a special SCSI driver from the VMware Web site. Follow the instructions on the Web site to use the driver with a fresh installation of Windows XP.
Growing and Allocating Virtual Disk Storage Space

IDE and SCSI virtual hard disks can be up to 8TB. Depending on the size of the virtual hard disk and the host operating system, Workstation Pro creates one or more files to hold each virtual disk.

Virtual hard disk files include information such as the operating system, program files, and data files. Virtual disk files have a .vmdk extension.

By default, the actual files that the virtual hard disk uses start small and grow to their maximum size as needed. The main advantage of this approach is the smaller file size. Smaller files require less storage space and are easier to move to a new location, but it takes longer to write data to a disk configured in this way.

You can also configure virtual hard disks so that all of the disk space is allocated when the virtual disk is created. This approach provides enhanced performance and is useful if you are running performance-sensitive applications in the virtual machine.

Regardless of whether you allocate all disk space in advance, you can configure the virtual hard disk to use a set of files limited to 2GB per file. Use this option if you plan to move the virtual hard disk to a file system that does not support files larger than 2GB.

Add a New Virtual Hard Disk to a Virtual Machine

To increase storage space, you can add a new virtual hard disk to a virtual machine. You can add up to four IDE devices and up to 60 SCSI devices. Any of these devices can be a virtual or physical hard disk or DVD or CD-ROM drive.

Virtual hard disks are stored as files on the host computer or on a network file server. A virtual IDE drive or SCSI drive can be stored on a physical IDE drive or on a physical SCSI drive.

As an alternative to adding a new virtual hard disk, you can expand the existing virtual hard disk. See “Expand a Virtual Hard Disk,” on page 151.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, click Add.
3. In the New Hardware wizard, select Hard Disk.
4. Select Create a new virtual disk.
5. Select the disk type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDE</td>
<td>Create an IDE device. You can add up to four IDE devices to a virtual machine.</td>
</tr>
<tr>
<td>SCSI</td>
<td>Create a SCSI device. You can add up to 60 SCSI devices to a virtual machine.</td>
</tr>
<tr>
<td>SATA</td>
<td>Create a SATA device. You can add up to 120 SATA devices: four controllers and 30 devices per controller.</td>
</tr>
</tbody>
</table>
(Optional) To exclude the disk from snapshots, select Independent for the mode and select a persistence option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Persistent</td>
<td>Disks in persistent mode behave like conventional disks on a physical computer. All data written to a disk in persistent mode is written permanently to the disk.</td>
</tr>
<tr>
<td>Nonpersistent</td>
<td>Changes to disks in nonpersistent mode are discarded when you power off or reset the virtual machine. With nonpersistent mode, you always restart the virtual machine with a virtual disk in the same state. Changes to the disk are written to and read from a redo log file that is deleted when you power off or reset the virtual machine.</td>
</tr>
</tbody>
</table>

7 Set the capacity for the new virtual hard disk.

You can set a size between 0.001 GB and 8 TB for a virtual disk.

8 Specify how to allocate the disk space.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocate all disk space now</td>
<td>Allocating all of the disk space when you create the virtual hard disk can enhance performance, but it requires all of the physical disk space to be available now. If you do not select this setting, the virtual disk starts small and grows as you add data to it.</td>
</tr>
<tr>
<td>Store virtual disk as a single file</td>
<td>Select this option if the virtual disk is stored on a file system that does not have a file size limitation.</td>
</tr>
<tr>
<td>Split virtual disk into multiple files</td>
<td>Select this option if the virtual disk is stored on a file system that has a file size limitation. When you split a virtual disk less than 950 GB, a series of 2 GB virtual disk files are created. When you split a virtual disk greater than 950 GB, two virtual disk files are created. The maximum size of the first virtual disk file is 1.9 TB and the second virtual disk file stores the rest of the data.</td>
</tr>
</tbody>
</table>

9 Accept the default filename and location, or browse to and select a different location.

10 Click Finish to add the new virtual hard disk.

The wizard creates the new virtual hard disk. The disk appears to the guest operating system as a new, blank hard disk.

11 Click OK to save your changes.

12 Use the guest operating system tools (such as the Windows Management tool or the fdisk command in Linux) to partition and format the new drive.

**Add an Existing Virtual Hard Disk to a Virtual Machine**

You can reconnect an existing virtual hard disk that was removed from a virtual machine.

**Procedure**

1 Select the virtual machine and select VM > Settings.
2 On the Hardware tab, click Add.
3 In the Add Hardware wizard, select Hard Disk.
4 Select Use an existing virtual disk.
5 Specify the path name and filename for the existing disk file.
6 Click Finish to add the existing virtual hard disk.
7 Click OK to save your changes.
Compact a Virtual Hard Disk

Compacting a virtual hard disk reclaims unused space in the virtual disk. If a disk has empty space, this process reduces the amount of space the virtual disk occupies on the host drive.

**Prerequisites**

- Power off the virtual machine.
- Verify that the virtual disk is not mapped or mounted. You cannot compact a virtual disk while it is mapped or mounted.
- Verify that the disk space is not preallocated for the virtual hard disk. If the disk space was preallocated, you cannot compact the disk.
- If the virtual hard disk is an independent disk, verify that it is in persistent mode.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select the virtual hard disk to compact.
3. Select **Utilities > Compact**.
4. Click **OK** after the disk compacting process is complete.

Expand a Virtual Hard Disk

You can add storage space to a virtual machine by expanding its virtual hard disk.

When you expand a virtual hard disk, the added space is not immediately available to the virtual machine. To make the added space available, you must use a disk management tool to increase the size of the existing partition on the virtual hard disk to match the expanded size.

The disk management tool that you use depends on the virtual machine guest operating system. Many operating systems, including Windows Vista, Windows 7, and Windows 8 and some versions of Linux, provide built-in disk management tools that can resize partitions. Third-party disk management tools are also available, such as EASEUS Partition Master, Acronis Disk Director, and the open-source tool GParted.

When you expand the size of a virtual hard disk, the sizes of partitions and file systems are not affected.

As an alternative to expanding a virtual hard disk, you can add a new virtual hard disk to the virtual machine. See “Add a New Virtual Hard Disk to a Virtual Machine,” on page 149.

**Prerequisites**

- Power off the virtual machine.
- Verify that the virtual disk is not mapped or mounted. You cannot expand a virtual disk while it is mapped or mounted.
- Verify that the virtual machine has no snapshots.
- Verify that the virtual machine is not a linked clone or the parent of a linked clone.

You can determine whether a virtual machine is a linked clone by the virtual machine name string on the summary page. If the string includes "Clone of: virtual machine name", the virtual machine is a linked clone. If the string includes "Snapshot: Snapshot for virtual machine name", the virtual machine is a parent of a linked clone.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
On the Hardware tab, select the virtual hard disk to expand.

Select Utilities > Expand.

Set the new maximum size for the virtual disk.

You can set a size between 0.001 GB and 8192 GB for a virtual disk.

Select Expand.

Click OK after the disk expansion process is complete.

What to do next

Use a disk management tool to increase the disk partition size to match the expanded virtual disk size.

Defragment a Virtual Hard Disk

Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual hard disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.

Defragmenting disks can take considerable time.

Prerequisites

- Verify that there is adequate free working space on the host system. For example, if the virtual hard disk is contained in a single file, there must be free space equal to the size of the virtual disk file. Other virtual hard disk configurations require less free space.
- Verify that the virtual disk is not mapped or mounted. You cannot defragment a virtual disk while it is mapped or mounted.

Procedure

1. Run a disk defragmentation utility in the guest operating system.
2. If disk space is not preallocated for the virtual hard disk, use the Workstation Pro defragmentation tool to defragment it.
   a. Power off the virtual machine.
   b. Select the virtual machine and select VM > Settings.
   c. On the Hardware tab, select Hard Disk.
   d. Select Utilities > Defragment.
   e. When the defragmentation process is finished, click OK.
3. Run a disk defragmentation utility on the host system.

Remove a Virtual Hard Disk from a Virtual Machine

Removing a virtual hard disk disconnects it from a virtual machine. It does not delete files from the host file system.

After you remove a virtual hard disk from a virtual machine, you can map or mount the disk to the host system and copy data from the guest operating system to the host without powering on the virtual machine or starting Workstation Pro. You can also add the disk to another virtual machine.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select the virtual hard disk and click Remove.
Click **OK** to save your changes.

**Using Virtual Disk Manager**

Virtual Disk Manager (vmware-vdiskmanager.exe) is a Workstation Pro utility that you can use to create, manage, and modify virtual disk files from the command line or in scripts.

Virtual Disk Manager is included in the VMware Workstation program files directory when Workstation Pro is installed. With Virtual Disk Manager, you can enlarge a virtual disk so that its maximum capacity is larger than it was when you created it. This feature is useful if you need more disk space in a given virtual machine, but do not want to add another virtual disk or use ghosting software to transfer the data on a virtual disk to a larger virtual disk.

You can also use Virtual Disk Manager to change how disk space is allocated for a virtual hard disk. You can preallocate all the disk space in advance or configure the disk to grow as more disk space is needed. If you allocate all the disk space but later need to reclaim some hard disk space on the host system, you can convert the preallocated virtual disk into a growable disk. The new virtual disk is still large enough to contain all the data in the original virtual hard disk. You can also change whether the virtual hard disk is stored in a single file or split into 2GB files.

**Using Legacy Virtual Disks**

You can use the current version of Workstation Pro in a mixed environment with virtual machines that were created with earlier versions or with other VMware products.

Although you can use the current version of Workstation Pro to power on virtual machines that were created with older versions or other VMware products, many new features of Workstation Pro are not available in older virtual machines.

If you decide not to upgrade a virtual machine, you should still upgrade VMware Tools to the latest version in the guest operating system. Do not remove the older version of VMware Tools before installing the new version.

You can also use the current version of Workstation to create a version 5.x and later virtual machine.

If you have a Workstation 2, 3, or 4 virtual machine that you want to use with the current version of Workstation, upgrade the virtual machine to at least Workstation version 5 before you attempt to power it on.

**Using Lock Files to Prevent Consistency Problems on Virtual Hard Disks**

A running virtual machine creates lock files to prevent consistency problems on virtual hard disks. Without locks, multiple virtual machines might read and write to the disk, causing data corruption.

Lock files have a .lck suffix and are created in subdirectories in the same directory as the virtual disk (.vmdk) files. A locking subdirectory and lock file are created for .vmdk files, .vmx files, and .vmem files.

A unified locking method is used on all host operating systems so that files shared between them are fully protected. For example, if one user on a Linux host tries to power on a virtual machine that is already powered on by another user with a Windows host, the lock files prevent the second user from powering on the virtual machine.

When a virtual machine powers off, it removes the locking subdirectories and the lock files. If the virtual machine cannot remove these locking controls, one or more stale lock files might remain. For example, if the host system fails before the virtual machine removes its locking controls, stale lock files remain.

When the virtual machine restarts, it scans any locking subdirectories for stale lock files and, when possible, removes them. A lock file is considered stale if the lock file was created on the same host system that is now running the virtual machine and the process that created the lock is no longer running. If either of these conditions is not true, a dialog box warns you that the virtual machine cannot be powered on. You can delete the locking directories and their lock files manually.
Locks also protect physical disk partitions. Because the host operating system is not aware of this locking convention, it does not recognize the lock. For this reason, you should install the physical disk for a virtual machine on the same physical disk as the host operating system.

**Moving a Virtual Hard Disk to a New Location**

A key advantage of virtual hard disks is their portability. Because the virtual hard disks are stored as files on the host system or a remote computer, you can move them easily to a new location on the same computer or to a different computer.

For example, you can use Workstation Pro on a Windows host system to create virtual hard disks, move the disks to a Linux computer, and use the disks with Workstation Pro on a Linux host system.

**Adding a Physical Disk to a Virtual Machine**

In some circumstances, you might need to give a virtual machine direct access to a physical disk or unused partition on the host computer.

A physical disk directly accesses an existing local disk or partition. You can use physical disks to run one or more guest operating systems from existing disk partitions.

Workstation Pro supports physical disks up to 2TB capacity. Booting from an operating system already set up on an existing SCSI disk or partition is not supported.

Running an operating system natively on the host computer and switching to running it inside a virtual machine is similar to pulling the hard drive out of one computer and installing it in a second computer that has a different motherboard and hardware. The steps you take depend on the guest operating system in the virtual machine. In most cases, a guest operating system that is installed on a physical disk or unused partition cannot boot outside of the virtual machine, even though the data is available to the host system. See the *Dual-Boot Computers and Virtual Machines* technical note on the VMware Web site for information about using an operating system that can also boot outside of a virtual machine.

After you configure a virtual machine to use one or more partitions on a physical disk, do not modify the partition tables by running `fdisk` or a similar utility in the guest operating system. If you use `fdisk` or a similar utility on the host operating system to modify the partition table of the physical disk, you must recreate the virtual machine physical disk. All files that were on the physical disk are lost when you modify the partition table.

**Important** You cannot use a physical disk to share files between the host computer and a guest operating system. Making the same partition visible to both the host computer and a guest operating system can cause data corruption. Instead, use shared folder to share files between the host computer and a guest operating system.

**Prepare to Use a Physical Disk or Unused Partition**

You must perform certain tasks before you configure a virtual machine to use a physical disk or unused partition on the host system.

You must perform these tasks before you run the New Virtual Machine wizard to add a physical disk to a new virtual machine, and before you add a physical disk to an existing virtual machine.
Procedure

1. If a partition is mounted by the host or in use by another virtual machine, unmount it.

The virtual machine and guest operating system access a physical disk partition while the host continues to run its operating system. Corruption is possible if you allow the virtual machine to modify a partition that is simultaneously mounted on the host operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| The partition is mapped to a Windows Server 2008 R2 or Windows Server 2012 R2 host | a. Select Start > Settings > Control Panel > Administrative Tools > Computer Management > Storage > Disk Management.  
b. Select a partition and select Action > All Tasks > Change Drive Letter and Paths.  
c. Click Remove. |
| The partition is mapped to a Windows 7, Windows 8, or Windows 10 host | a. Select Start > Control Panel.  
b. In the menu bar, click the arrow next to Control Panel.  
c. From the drop-down menu, select All Control Panel Items > Administrative Tools > Computer Management > Storage > Disk Management (Local).  
d. Right-click a partition and choose Change Drive Letter and Paths.  
e. Click Remove and OK. |

2. Check the guest operating system documentation regarding the type of partition on which the guest operating system can be installed.

On Windows 7 hosts, you cannot use the system partition, or the physical disk that contains it, in a virtual machine. Other operating systems, such as Linux, can be installed on a primary or an extended partition on any part of the drive.

3. If the physical partition or disk contains data that you need in the future, back up the data.

4. If you use a Windows host IDE disk in a physical disk configuration, verify that it is not configured as the slave on the secondary IDE channel if the master on that channel is a CD-ROM drive.

5. On a Linux host, set the device group membership or device ownership appropriately.

   a. Verify that the master physical disk device or devices are readable and writable by the user who runs Workstation Pro.

   Physical devices, such as /dev/hda (IDE physical disk) and /dev/sdb (SCSI physical disk), belong to group-id disk on most distributions. If this is the case, you can add Workstation Pro users to the disk group. Another option is to change the owner of the device. Consider all the security issues involved in this option.

   b. Grant Workstation Pro users access to all /dev/hd[a-cd] physical devices that contain operating systems or boot managers.

   When permissions are set correctly, the physical disk configuration files in Workstation Pro control access. This reliability provides boot managers access to configuration files and other files they might need to boot operating systems. For example, LILO needs to read /boot on a Linux partition to boot a non-Linux operating system that might be on another drive.

Add a Physical Disk to an Existing Virtual Machine

You can add a physical disk to an existing virtual machine by modifying virtual machine hardware settings.

To add a physical disk to a new virtual machine, run the New Virtual Machine wizard and select the Custom option. See “Create a New Virtual Machine on the Local Host,” on page 50.

**Note** You cannot add a physical disk to a shared or remote virtual machine.
Prerequisites

- Perform the appropriate preparation tasks. See “Prepare to Use a Physical Disk or Unused Partition,” on page 47.
- Power off the virtual machine.

Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, click **Add**.
3. Select **Hard Disk**.
4. Select **Use a physical disk**.
5. If a warning message appears, click **OK**.
6. Select the physical hard disk to use from the drop-down menu.
7. Select whether to use the entire disk or individual partitions.
8. If you selected individual partitions, select the partitions.
   The virtual machine can access only the partitions that you select. The guest operating system might be able to detect other partitions, but you cannot mount, access, or format those partitions.
9. Accept the default filename and location for the virtual disk (.vmdk) file, or browse to a different location.
10. Click **Finish** to add the physical disk to the virtual machine.
11. Use the tools in the guest operating system to format any partitions on the physical disk that are not formatted for the guest operating system.

Configuring Virtual Ports

You can add virtual parallel (LPT) ports and virtual serial (COM) ports to a virtual machine. A Workstation Pro virtual machine can use up to three parallel ports and up to four virtual serial ports.

- **Add a Virtual Parallel Port to a Virtual Machine** on page 157
  You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host system.

- **Configure a Virtual Parallel Port on a Linux 2.6.x Kernel Host** on page 157
  Linux 2.6.x kernels that support parallel ports use the `modprobe modulename` and `modprobe parport_pc` modules. Workstation Pro requires that the parallel port PC-style hardware option (`CONFIG_PARPORT_PC`) is built and loaded as a kernel module.

- **Configure Permissions for a Parallel Port Device on a Linux Host** on page 158
  Some Linux distributions do not grant a virtual machine access to the `lp` and `parport` devices by default. If this is the case on your Linux host system, you must add the VMware user to the group that has permission to access those devices.

- **Troubleshoot ECR Errors for Parallel Ports** on page 158
  A parallel port on the host system does not have an Extended Control Register (ECR).

- **Add a Virtual Serial Port to a Virtual Machine** on page 159
  You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to physical serial ports, files, or named pipes.

- **Change the Input Speed of a Serial Connection** on page 160
  You can increase the speed of a serial connection over a pipe to a virtual machine.
Add a Virtual Parallel Port to a Virtual Machine

You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host system.

Parallel ports are used for a variety of devices, including printers, scanners, dongles, and disk drives. Although these devices can connect to the host system, only printers can reliably connect to virtual machines by using parallel ports.

Workstation Pro provides only partial emulation of PS/2 hardware. Interrupts that a device connected to a physical port requests are not passed to the virtual machine. The guest operating system cannot use direct memory access (DMA) to move data to or from the port. For this reason, not all devices that attach to a parallel port work correctly. Do not use virtual parallel ports to connect parallel port storage devices or other types of parallel port devices to a virtual machine.

Prerequisites

Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, click **Add**.
3. In the New Hardware wizard, select **Parallel Port**.
4. Select where the virtual parallel port sends output.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical parallel port</td>
<td>Select a parallel port on the host system.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output from the virtual parallel port to a file on the host system. Either locate an existing output file or browse to a directory and type a filename to create a new output file.</td>
</tr>
</tbody>
</table>

5. To connect the virtual parallel port to the virtual machine when the virtual machine powers on, select **Connect at power on**.
6. Click **Finish** to add the virtual parallel port to the virtual machine.

When a parallel port is configured for a virtual machine, most guest operating systems detect the port at installation time and install the required drivers. Some operating systems, including Linux, detect the ports at boot time.

Configure a Virtual Parallel Port on a Linux 2.6.x Kernel Host

Linux 2.6.x kernels that support parallel ports use the `modprobe modulename` and `modprobe parport_pc` modules. Workstation Pro requires that the parallel port PC-style hardware option (`CONFIG_PARPORT_PC`) is built and loaded as a kernel module.

Linux kernels in the 2.6.x series use a special arbitrator for access to the parallel port hardware. If the host system is using the parallel port, the virtual machine cannot use it. If a virtual machine is using the parallel port, the host and any users accessing the host are denied access to the device. You must use the **Removable Devices** menu to disconnect the parallel port from the virtual machine to access the device from the host system.
Procedure

1. To determine whether the `modprobe modulename` and `modprobe parport_pc` modules are installed and loaded on the host system, run the `lsmod` command as the root user.

   You can also see a list of modules in the `/proc/modules` file.

   Note: In Linux 2.6.x, loading `parport_pc` does not load all modules.

2. If necessary, load the parallel port modules.

   For example: `modprobe parport_pc && modprobe ppdev`

   This command inserts the modules that are required for a parallel port.

3. If the `lp` module is loaded, run the `rmmod` command as root to remove it.

   For example: `rmmod lp`

   The virtual machine cannot use the parallel port correctly if the `lp` module is loaded.

4. Comment out the line that refers to the `lp` module in the `/etc/modules.conf` or `/etc/conf.modules` file.

   The name of the configuration file depends on the Linux distribution.

   When the line is commented out, the configuration file no longer starts the `lp` module when you reboot the host system.

5. To make sure that the proper modules for the parallel port are loaded at boot time, add the following line to the `/etc/modules.conf` or `/etc/conf.modules` file.

   `alias parport_lowlevel parport_pc`

Configure Permissions for a Parallel Port Device on a Linux Host

Some Linux distributions do not grant a virtual machine access to the `lp` and `parport` devices by default. If this is the case on your Linux host system, you must add the VMware user to the group that has permission to access those devices.

Procedure

1. On the Linux host system, use the `ls` command to determine the owner and group for the device.

   For example: `ls -l /dev/parport0`

   The third and fourth columns of the output show the owner and group, respectively. In most cases, the owner of the device is root and the associated group is `lp`.

2. To add the user to the device group, become root and open the `/etc/group` file in a text editor.

3. On the line that defines the `lp` group, add the Workstation Pro username.

   For example: `lp:7:daemon,lp,workstation_username`

   The changes take effect the next time the user logs in to the host system.

Troubleshoot ECR Errors for Parallel Ports

A parallel port on the host system does not have an Extended Control Register (ECR).

Problem

When you power on a virtual machine after adding a parallel port, an error message states that the parallel port on the host system does not have an ECR.
Cause
This problem can occur when the hardware supports ECR, but ECR has been disabled in the BIOS.

Solution
1. Reboot the host system.
2. Early in the boot process, press and hold down the Delete key to enter the BIOS configuration editor.
3. Find the parallel port field and enable Extended Capability Port (ECP) mode or a combination of modes that includes ECP.
   Most modern computers support ECP mode.

Add a Virtual Serial Port to a Virtual Machine
You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to physical serial ports, files, or named pipes.

You might want to add a virtual serial port to a virtual machine to make devices such as modems and printers available to the virtual machine. You can also use virtual ports to send debugging data from a virtual machine to the host system or to another virtual machine.

**Note** The virtual printer feature configures a serial port to make host printers available to the guest. You do not need to install additional drivers in the virtual machine.

Prerequisites
Power off the virtual machine.

Procedure
1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select Serial Port.
4. Select where the virtual serial port sends output.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical parallel port</td>
<td>Send output to a physical serial port on the host system.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output to a file on the host system. Either locate an existing output file or browse to a directory and type a filename to create a new output file.</td>
</tr>
<tr>
<td>Output to named pipe</td>
<td>Set up a direct connection between two virtual machines, or a connection between a virtual machine and an application on the host system.</td>
</tr>
</tbody>
</table>

5. If you selected **Output to named pipe**, configure the named pipe.
   a. (Windows host) Use the default pipe name, or type another pipe name.
      The pipe name must begin with `\pipe` and must be the same on both the server and the client.
      For example: `\pipe\namedpipe`
   b. (Linux host) Type `/tmp/socket` or another UNIX socket name in the first text box.
      The pipe name must be the same on both the server and the client.
To send debugging information to an application on the host system, select **This end is the server** from the first drop-down menu and select **The other end is an application** from the second drop-down menu.

d To send debugging information to another virtual machine, select **This end is the server** from the first drop-down menu and **The other end is a virtual machine** from the second drop-down menu.

6 To connect the port to the virtual machine when the virtual machine powers on, select **Connect at power on**.

7 Click **Finish** to add the virtual serial port to the virtual machine.

8 (Optional) On the **Hardware** tab, select the new serial port, select **Yield CPU on poll**, and click **OK**. This option is useful if you are using debugging tools that communicate over a serial connection. If the serial port in the guest operating system is being used in polled mode rather than interrupt mode, you might notice performance issues. This option forces the virtual machine to yield processor time if the only task it is trying to do is poll the virtual serial port.

**What to do next**

If you set up a connection between two virtual machines, the first virtual machine is set up as the server. Repeat this procedure for the second virtual machine, but set it up as the client by selecting **This end is the client** when you configure the named pipe.

### Change the Input Speed of a Serial Connection

You can increase the speed of a serial connection over a pipe to a virtual machine.

In principle, the output speed, which is the speed at which the virtual machine sends data through the virtual serial port, is unlimited. In practice, the output speed depends on how fast the application at the other end of the pipe reads inbound data.

**Prerequisites**

- Use the guest operating system to configure the serial port for the highest setting supported by the application that you are running in the virtual machine.
- Power off the virtual machine and exit Workstation Pro.

**Procedure**

1. In a text editor, add the following line to the virtual machine configuration (.vmx) file.

   ```
   serial_port_number.pipe.charTimePercent = "time"
   ```

   *port_number* is the number of the serial port, starting from 0. The first serial port is serial0. *time* is a positive integer that specifies the time taken to transmit a character, expressed as a percentage of the default speed set for the serial port in the guest operating system. For example, a setting of 200 forces the port to take twice as long for each character, or send data at half the default speed. A setting of 50 forces the port to take only half as long for each character, or send data at twice the default speed.

2. Assuming that the serial port speed is set appropriately in the guest operating system, experiment with this setting by starting with a value of 100 and gradually decreasing it until you find the highest speed at which the connection works reliably.
Configuring Generic SCSI Devices

The generic SCSI feature gives the guest operating system direct access to SCSI devices that are connected to the host system, including scanners, tape drives, and other data storage devices. A virtual machine can use the generic SCSI driver to run any SCSI device that is supported by the guest operating system.

To use SCSI devices in a virtual machine running on a Windows host system, you must run Workstation Pro as a user who has administrator access.

Although generic SCSI is device independent, it can be sensitive to the guest operating system, device class, and specific SCSI hardware.

- **Add a Generic SCSI Device to a Virtual Machine** on page 161
  You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI devices to a virtual machine.

- **Avoiding Concurrent Access Problems for SCSI Devices on Linux Hosts** on page 162
  Workstation Pro makes sure that multiple programs do not use the same /dev/sg entry at the same time, but it cannot always ensure that multiple programs do not use the /dev/sg entry and the traditional /dev entry at the same time.

- **Troubleshoot Problems Detecting Generic SCSI Devices** on page 162
  When you add a generic SCSI device to a virtual machine, the device does not appear in the list of available SCSI devices.

Add a Generic SCSI Device to a Virtual Machine

You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI devices to a virtual machine.

**Note** You cannot add a generic SCSI device to a shared or remote virtual machine.

**Prerequisites**

**Procedure**

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select Generic SCSI Device.
4. Select the physical SCSI device to map to the virtual SCSI device.
   - When you type the path to the SCSI device on a Linux host, do not enter /dev/st0 or /dev/sr0.
5. To connect the device when the virtual machine powers on, select Connect at power on.
6. Click Finish to add the device.
7. On the Hardware tab, select the SCSI device identifier to use for the device from the Virtual device node drop-down menu and click OK.
   - For example, if you select SCSI 0:2, the guest operating system sees the drive as ID 2 on controller 0.
Avoiding Concurrent Access Problems for SCSI Devices on Linux Hosts

Workstation Pro makes sure that multiple programs do not use the same /dev/sg entry at the same time, but it cannot always ensure that multiple programs do not use the /dev/sg entry and the traditional /dev entry at the same time.

The SCSI generic driver sets up a mapping in /dev for each SCSI device. Each entry starts with sg, for the SCSI generic driver, followed by a number. For example, /dev/sg0 is the first generic SCSI device. Each entry corresponds to a SCSI device in the order specified in /proc/scsi/scsi, from the lowest device ID on the lowest adapter to the highest device ID on the lowest adapter, and so on to the highest device ID on the highest adapter.

Some Linux devices, such as tape drives, disk drives, and CD-ROM drives, already have a designated /dev entry (st, sd, and sr, respectively). When the SCSI generic driver is installed, Linux identifies these devices with corresponding sg entries in /dev, in addition to their traditional entries.

To avoid concurrent access problems, do not specify /dev/st0 or /dev/sr0 when you specify which SCSI device to use in a virtual machine.

**IMPORTANT** Do not attempt to use the same generic SCSI device in both the host system and guest operating system. Unexpected behavior and data loss or corruption might occur.

Troubleshoot Problems Detecting Generic SCSI Devices

When you add a generic SCSI device to a virtual machine, the device does not appear in the list of available SCSI devices.

**Problem**

The SCSI device does not appear in the list of available SCSI devices after you add it to a virtual machine.

**Cause**

A driver for that device is not installed on the host system, a driver on the host system prevents the device from being detected, or the virtual machine uses a device for which there are no drivers available to the host operating system.

**Solution**

1. Determine the SCSI bus number that the device uses on the host system.

   The SCSI bus is assigned a number by the host operating system after all IDE buses are assigned numbers. For example, if you have two IDE buses, they are numbered 0 and 1. The first SCSI bus is assigned bus number 2. You can use a third-party tool, such as winobj, to determine the SCSI bus number.

2. Determine the target ID that the device uses in the virtual machine and on the host system.

   This ID is usually set by some jumpers or switches on the device.

3. Determine whether the device driver for the device is installed on the host system.

   If the device driver is not installed, install it and see if the device appears. To avoid a device-in-use conflict between the host and guest, you might not want to install the driver on the host system.

4. If an original SCSI device driver is already installed on the host system, disable it.

   Some Windows operating systems do not process the send command from the adapter if the device driver owns the device.

5. Power off the virtual machine and open the virtual machine configuration (.vmx) file in a text editor.
Add or change the following line in the virtual machine configuration (.vmx) file.

```
scsiZ:Y.fileName = "deviceName"
```

Z is the SCSI bus number the device uses in the virtual machine. For deviceName, use scsiX:Y, where X is the SCSI bus number that the device uses on the host system and Y is the target ID that the device uses in both the virtual machine and on the host system.

For example, if the problematic device is a CD-ROM drive, the existing entry is

```
scsi0:4.fileName = "CdRom0"
```

and the device on the host system is located on bus 2 with target ID 4, change the line to

```
scsi0:4.fileName = "scsi2:4"
```

If the virtual machine does not contain any SCSI devices, to add a generic SCSI device to a new virtual SCSI adapter, or to use an existing SCSI device as a generic SCSI device, add the following line to the virtual machine configuration (.vmx) file.

```
scsiZ:Y.deviceType = "scsi-passthru"
```

If the virtual machine does not contain any SCSI devices, or to add a generic SCSI device to a new virtual SCSI adapter, add the following lines to the virtual machine configuration (.vmx) file.

```
scsiZ:Y.present = "true"
scsiZ.present = "true"
```

### Configuring Sixteen-Way Virtual Symmetric Multiprocessing

With virtual symmetric multiprocessing (SMP), you can assign processors and cores per processor to a virtual machine on any host system that has at least two logical processors.

Workstation Pro considers multiprocessor hosts that have two or more physical CPUs, single-processor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading enabled, to have two logical processors.

**Note** On hyperthreaded uniprocessor hosts, performance of virtual machines that have virtual SMP might be below normal. Even on multiprocessor hosts, performance is affected if you overcommit by running multiple workloads that require more total CPU resources than are physically available.

You can power on and run multiple dual-processor virtual machines concurrently. The number of processors for a given virtual machine appears in the summary view of the virtual machine.

### Configure Sixteen-Way Virtual Symmetric Multiprocessing

You can configure sixteen-way virtual symmetric multiprocessing (SMP) for an existing virtual machine.

**Note** For a new virtual machine, you can specify the number of processors when you select the custom configuration option in the New Virtual Machine wizard.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select **Processors**.
3. Change the **Number of processors** setting to 16.
4. Click **OK** to save your changes.
Use a Virtual Machine That Has More Than Sixteen Virtual Processors

If Workstation Pro is running on a multiprocessor host system, you can open a virtual machine that has more than 16 virtual processors assigned to it. You must change the number of processors before powering on the virtual machine.

You can see the number of processors in the virtual machine summary view or by viewing the virtual machine hardware settings.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select Processors.
   
   Note that Number of processors is set to Other (x), where x is the number of processors originally assigned to it. Workstation Pro preserves this original configuration setting for the number of processors, even though eight is the maximum number of processors supported.

3. Change the Number of processors setting to 1, 2, 4, 8, or 16.
   
   After you commit a change to this setting, the original setting for the number of processors is discarded and no longer appears as an option.

4. Click OK to save your changes.

Configuring Keyboard Features

You can change key combinations for hot-key sequences in Workstation Pro and the language for the keyboard that VNC clients use. You can also configure platform-specific keyboard features for Windows and Linux host systems.

- Use the Enhanced Virtual Keyboard Feature in a Virtual Machine on page 165
  
  The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

- Change Hot-Key Combinations for Common Operations on page 166
  
  You can change the hot-key combinations that you use to perform common virtual machine operations.

- Change Hot-Key Combinations for Unity Mode on page 167
  
  You can change the hot-key combination that you use to access the Start and Applications menus in Unity mode.

- Configure Keyboard Mapping for a Remote X Server on page 167
  
  Although the keyboard works correctly with a local X server, it might not work correctly when you run the same virtual machine with a remote X server.

- Change How a Specific Key Is Mapped on page 168
  
  If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that makes a modification to the map. To change how a specific key is mapped, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.
Configure How Keysyms Are Mapped on page 169

When key code mapping cannot be used or is disabled, Workstation Pro maps keysyms to v-scan codes. If a language-specific keyboard does not appear to be supported by Workstation Pro, you might need to set a property that tells Workstation Pro which keysym table to use.

V-Scan Code Table on page 170

You specify v-scan codes when you change how keys or keysyms are mapped.

Use the Enhanced Virtual Keyboard Feature in a Virtual Machine

The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

Because it processes raw keyboard input as soon as possible, the enhanced virtual keyboard feature also offers security improvements by bypassing Windows keystroke processing and any malware that is not already at a lower layer. When you use the enhanced virtual keyboard feature, only the guest operating system acts when you press Ctrl+Alt+Delete.

**NOTE** You cannot configure the enhanced virtual keyboard setting for a shared or remote virtual machine.

Prerequisites

- Power off the virtual machine.
- If you did not install the Enhanced Keyboard Utility feature when you initially installed or upgraded Workstation Pro, install it by running the Workstation Pro installer in program maintenance mode. See “Install the Enhanced Keyboard Driver on a Windows Host,” on page 165.

Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **General**.
3. Select an option from the **Enhanced virtual keyboard** drop-down menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off</td>
<td>The virtual machine does not use the enhanced virtual keyboard feature. This is the default value.</td>
</tr>
<tr>
<td>Use if available (recommended)</td>
<td>The virtual machine uses the enhanced virtual keyboard feature, but only if the enhanced virtual keyboard driver is installed on the host system.</td>
</tr>
<tr>
<td>Required</td>
<td>The virtual machine must use the enhanced virtual keyboard feature. If you select this option and the enhanced keyboard driver is not installed on the host system, Workstation Pro returns an error message.</td>
</tr>
</tbody>
</table>

4. Click **OK** to save your changes.

Install the Enhanced Keyboard Driver on a Windows Host

To use the enhanced virtual keyboard feature in a virtual machine, you must install the enhanced keyboard driver on the Windows host system. If you did not install the enhanced keyboard driver when you initially installed or upgraded Workstation Pro, you can install it by running the Workstation Pro installer in program maintenance mode.

Prerequisites

Verify that you have administrative privileges on the host system.
Procedure
1 Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   If you log in to a domain, the domain account must also be a local administrator.
2 Double-click the VMware-workstation-xxxx-xxxxxxx.exe file, where xxxx-xxxxxxx is the version and build numbers.
3 Select Modify/Change.
4 Select Enhanced Keyboard Utility.
5 Follow the prompts to finish the installation.

What to do next
Enable the enhanced virtual keyboard feature for the virtual machine. See “Use the Enhanced Virtual Keyboard Feature in a Virtual Machine,” on page 165.

Change Hot-Key Combinations for Common Operations
You can change the hot-key combinations that you use to perform common virtual machine operations.
Configuring hot keys is useful to prevent key combinations such as Ctrl+Alt+Del from being intercepted by Workstation Pro instead of being sent to the guest operating system. You can use hot-key sequences to switch between virtual machines, enter or exit from full screen mode, release input, send Ctrl+Alt+Del only to virtual machines, and send commands only to virtual machines.

Prerequisites
Familiarize yourself with the default hot-key combinations. See “Default Hot-Key Combinations,” on page 38.

Procedure
1 Select Edit > Preferences > Hot Keys.
2 To change the hot-key combinations for common virtual machine operations, click one or more hot key buttons on the dialog box.
   For example, to use Ctrl+Shift to release control from the current virtual machine, click the Ctrl and Shift buttons.
   The text under the hot key buttons describes the new hot key combinations.
3 Click OK to save your changes.

Use Ctrl+Alt in a Key Combination
Because Ctrl+Alt tells Workstation Pro to release mouse and keyboard input, hot-key combinations that include Ctrl+Alt are not passed to the guest operating system. You must use the Space key if the key combination includes Ctrl+Alt.

Procedure
1 Press Ctrl+Alt+spacebar.
2 Release the spacebar without releasing Ctrl and Alt.
3 Press the third key of the key combination to send to the guest operating system.
Change Hot-Key Combinations for Unity Mode

You can change the hot-key combination that you use to access the Start and Applications menus in Unity mode.

Procedure

1. Select Edit > Preferences > Unity.
2. Type a new hot-key combination in the Hot Key text box.
3. To minimize the Workstation Pro when you enter Unity mode, select Minimize Workstation when entering Unity.
   Do not select this setting if you plan to run virtual machines in Unity mode and simultaneously run other virtual machines that are accessible only in the Workstation Pro window.
4. Click OK to save your changes.

Configure Keyboard Mapping for a Remote X Server

Although the keyboard works correctly with a local X server, it might not work correctly when you run the same virtual machine with a remote X server.

For local X servers, Workstation Pro maps X key codes to PC scan codes to correctly identify a key. Because it cannot tell whether a remote X server is running on a PC or on some other kind of computer, Workstation Pro uses this key code map only for local X servers. You can set a property to tell Workstation Pro to use key code mapping. See “Understanding X-Key Codes and Keysyms,” on page 168 for more information.

To configure a keyboard mapping for a remote X server, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

Prerequisites

- Verify that the remote X server is an XFree86 server running on a PC.
- Power off the virtual machine and exit Workstation Pro.

**Note** If the keyboard does not work correctly on an XFree86 server running locally, report the problem to VMware technical support.

Procedure

- If you use an XFree86-based server that Workstation Pro does not recognize as an XFree86 server, add the xkeymap.usekeycodeMap property and set it to TRUE.
  This property tells Workstation Pro to always use key code mapping regardless of server type.
  For example: xkeymap.usekeycodeMap = "TRUE"

- If Workstation Pro does not recognize the remote server as an XFree86 server, add the xkeymap.usekeycodeMapIfXFree86 property and set it to TRUE.
  This property tells Workstation Pro to use key code mapping if you are using an XFree86 server, even if it is remote.
  For example: usekeycodeMapIfXFree86 = "TRUE"
Understanding X-Key Codes and Keysyms

Pressing a key on a PC keyboard generates a PC scan code based roughly on the position of the key. For example, the Z key on a German keyboard generates the same code as the Y key on an English keyboard because they are in the same position on the keyboard. Most keys have one-byte scan codes, but some keys have two-byte scan codes with prefix 0xe0.

Internally, Workstation Pro uses a simplified version of the PC scan code that is a single nine-bit numeric value, called a v-scan code. A v-scan code is written as a three-digit hexadecimal number. The first digit is 0 or 1. For example, the Ctrl key on the left side of the keyboard has a one-byte scan code (0x1d) and its v-scan code is 0x01d. The Ctrl key scan code on the right side of the keyboard is two bytes (0xe0, 0x1d) and its v-scan code is 0x11d.

An XFree86 server on a PC has a one-to-one mapping from X key codes to PC scan codes, or v-scan codes, which is what Workstation Pro uses. When Workstation Pro is hosted on an XFree86 server and runs a local virtual machine, it uses the built-in mapping from X key codes to v-scan codes. This mapping is keyboard independent and should be correct for most languages. In other cases (not an XFree86 server or not a local server), Workstation Pro must map keysyms to v-scan codes by using a set of keyboard-specific tables.

An X server uses a two-level encoding of keys, which includes the X key code and the keysym. An X key code is a one-byte value. The assignment of key codes to keys depends on the X server implementation and the physical keyboard. As a result, an X application normally cannot use key codes directly. Instead, the key codes are mapped into keysyms that have names like space, escape, x and 2. You can use an X application to control the mapping by using the function XChangeKeyboardMapping() or by the program xmodmap. To explore keyboard mappings, you can use the xev command, which shows the key codes and keysyms for keys typed into its window.

A key code corresponds roughly to a physical key, while a keysym corresponds to the symbol on the key top. For example, with an XFree86 server running on a PC, the Z key on the German keyboard has the same key code as the Y key on an English keyboard. The German Z keysym, however, is the same as the English Z keysym, and different from the English Y keysym.

Change How a Specific Key Is Mapped

If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that makes a modification to the map. To change how a specific key is mapped, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

Prerequisites

- Verify that the X server is an XFree86 server running on a PC. If the X server is remote, configure it to use key code mapping. See “Configure Keyboard Mapping for a Remote X Server,” on page 167.
- Determine the X key code and the corresponding v-scan code for the key. To find the X key code for a key, run xev or xmodmap -pk. See “V-Scan Code Table,” on page 170 for most v-scan codes.
- Power off the virtual machine and exit Workstation Pro.

Procedure

1. Open .vmx or ~/.vmware/config in a text editor.
2. Add the xkeymap.keycode.code property and set it to the v-scan code.
   
   code must be a decimal number and the v-scan code must be a C-syntax hexadecimal number, such as 0x001.
   
   In this example, the properties swap left Ctrl and Caps Lock.

   xkeymap.keycode.64 = "0x01d # X Caps_Lock -> VM left ctrl"
   xkeymap.keycode.37 = "0x03a # X Control_L -> VM caps lock"
Configure How Keysyms Are Mapped

When key code mapping cannot be used or is disabled, Workstation Pro maps keysyms to v-scan codes. If a language-specific keyboard does not appear to be supported by Workstation Pro, you might need to set a property that tells Workstation Pro which keysym table to use.

Workstation Pro determines which table to use by examining the current X keymap. However, its decision-making process can sometimes fail. In addition, each mapping is fixed and might not be completely correct for any given keyboard and X key code-to-keysym mapping. For example, if a user uses xmodmap to swap Ctrl and Caps Lock by, the keys are swapped in the virtual machine when using a remote server (keysym mapping), but are unswapped when using a local server (key code mapping). To correct this situation, you must remap the keys in Workstation Pro.

To configure how keysyms are mapped, you add one or more properties to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

Prerequisites

- To change the mapping of a few keys, determine the keysym name for each key. To find a keysym name, use the xev or xmodmap -pk command. The X header file /usr/include/X11/keysymdef.h also has a complete list of keysyms. The name of a keysym is the same as its C constant, but without the XK_ prefix.
- To use a different keysym table, determine which mapping table to use. The tables are located in the xkeymap directory in the Workstation Pro installation directory, which is usually /usr/lib/vmware. The file you must use depends on the keyboard layout. The normal distribution includes tables for PC keyboards for the United States and a number of European countries and languages. For most of these, both the 101-key (or 102-key) and the 104-key (or 105-key) variants are available.

If none of the mapping tables is completely correct, find one that works best, copy it to a new location, and change the individual keysym mappings.
- Familiarize yourself with the v-scan codes. See “V-Scan Code Table,” on page 170.
- Power off the virtual machine and exit Workstation Pro.

Procedure

- To disable X key code mapping to map keysyms rather than key codes to v-scan codes, add the xkeymap.nokeycodeMap property and set it to TRUE.
  
  For example: xkeymap.nokeycodeMap = "TRUE"

- If Workstation Pro has a table in the xkeymap directory for your keyboard but cannot detect it, add the xkeymap.language property and set it to one of the tables in the xkeymap directory.
  
  For example: xkeymap.language = "keyboard_type"

  If the failure to detect the keyboard means that the table is not completely correct for you, you might need to create a modified table and use the xkeymap.fileName property instead.

- To use a different keysym mapping table that is not in the xkeymap directory, add the xkeymap.fileName property and set it to the path to the table.
  
  For example: xkeymap.fileName = "file_path"

  The table must list a keysym for each key by using the form sym="v-scan_code", where the sym value is an X keysym name and v-scan_code is a C-syntax hexadecimal number, for example, 0x001. Use a new line for each keysym.

  **Note** Because compiling a complete keysym mapping is difficult, you should usually edit an existing table and make small changes.
To change the keysym mapping of a few keys, type the xkeymap.keysym property for each key, on separate lines.

For example: `xkeymap.keysym.sym = "v-scan_code"

The value of `sym` must be an X keysym name and `v-scan_code` is a C-syntax hexadecimal number, for example, 0x001.

V-Scan Code Table

You specify v-scan codes when you change how keys or keysyms are mapped.

Following are the v-scan codes for the 104-key U.S. keyboard.

**Table 8-1. V-Scan Codes for the 104-Key U.S. Keyboard**

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Esc</td>
<td></td>
<td></td>
<td>0x001</td>
</tr>
<tr>
<td>1</td>
<td>!</td>
<td></td>
<td>0x002</td>
</tr>
<tr>
<td>2</td>
<td>@</td>
<td></td>
<td>0x003</td>
</tr>
<tr>
<td>3</td>
<td>#</td>
<td></td>
<td>0x004</td>
</tr>
<tr>
<td>4</td>
<td>$</td>
<td></td>
<td>0x005</td>
</tr>
<tr>
<td>5</td>
<td>%</td>
<td></td>
<td>0x006</td>
</tr>
<tr>
<td>6</td>
<td>^</td>
<td></td>
<td>0x007</td>
</tr>
<tr>
<td>7</td>
<td>&amp;</td>
<td></td>
<td>0x008</td>
</tr>
<tr>
<td>8</td>
<td>*</td>
<td></td>
<td>0x009</td>
</tr>
<tr>
<td>9</td>
<td>(</td>
<td></td>
<td>0x00a</td>
</tr>
<tr>
<td>0</td>
<td>)</td>
<td></td>
<td>0x00b</td>
</tr>
<tr>
<td>-</td>
<td></td>
<td></td>
<td>0x00c</td>
</tr>
<tr>
<td>=</td>
<td>+</td>
<td></td>
<td>0x00d</td>
</tr>
<tr>
<td>Backspace</td>
<td></td>
<td></td>
<td>0x00e</td>
</tr>
<tr>
<td>Tab</td>
<td></td>
<td></td>
<td>0x00f</td>
</tr>
<tr>
<td>Q</td>
<td></td>
<td></td>
<td>0x010</td>
</tr>
<tr>
<td>W</td>
<td></td>
<td></td>
<td>0x011</td>
</tr>
<tr>
<td>E</td>
<td></td>
<td></td>
<td>0x012</td>
</tr>
<tr>
<td>R</td>
<td></td>
<td></td>
<td>0x013</td>
</tr>
<tr>
<td>T</td>
<td></td>
<td></td>
<td>0x014</td>
</tr>
<tr>
<td>Y</td>
<td></td>
<td></td>
<td>0x015</td>
</tr>
<tr>
<td>U</td>
<td></td>
<td></td>
<td>0x016</td>
</tr>
<tr>
<td>I</td>
<td></td>
<td></td>
<td>0x017</td>
</tr>
<tr>
<td>O</td>
<td></td>
<td></td>
<td>0x018</td>
</tr>
<tr>
<td>P</td>
<td></td>
<td></td>
<td>0x019</td>
</tr>
<tr>
<td>[</td>
<td>]</td>
<td></td>
<td>0x01a</td>
</tr>
<tr>
<td>]</td>
<td></td>
<td></td>
<td>0x01b</td>
</tr>
<tr>
<td>Enter</td>
<td></td>
<td></td>
<td>0x01c</td>
</tr>
<tr>
<td>Ctrl</td>
<td>left</td>
<td></td>
<td>0x01d</td>
</tr>
<tr>
<td>A</td>
<td></td>
<td></td>
<td>0x01e</td>
</tr>
<tr>
<td>Symbol</td>
<td>Shifted Symbol</td>
<td>Location</td>
<td>V-Scan Code</td>
</tr>
<tr>
<td>--------</td>
<td>----------------</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
<td>0x01f</td>
</tr>
<tr>
<td>D</td>
<td></td>
<td></td>
<td>0x020</td>
</tr>
<tr>
<td>F</td>
<td></td>
<td></td>
<td>0x021</td>
</tr>
<tr>
<td>G</td>
<td></td>
<td></td>
<td>0x022</td>
</tr>
<tr>
<td>H</td>
<td></td>
<td></td>
<td>0x023</td>
</tr>
<tr>
<td>J</td>
<td></td>
<td></td>
<td>0x024</td>
</tr>
<tr>
<td>K</td>
<td></td>
<td></td>
<td>0x025</td>
</tr>
<tr>
<td>L</td>
<td></td>
<td></td>
<td>0x026</td>
</tr>
<tr>
<td>;</td>
<td></td>
<td></td>
<td>0x027</td>
</tr>
<tr>
<td>'</td>
<td></td>
<td></td>
<td>0x028</td>
</tr>
<tr>
<td>`</td>
<td></td>
<td></td>
<td>0x029</td>
</tr>
<tr>
<td>Shift</td>
<td>left</td>
<td></td>
<td>0x02a</td>
</tr>
<tr>
<td>\</td>
<td></td>
<td></td>
<td>0x02b</td>
</tr>
<tr>
<td>Z</td>
<td></td>
<td></td>
<td>0x02c</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>0x02d</td>
</tr>
<tr>
<td>C</td>
<td></td>
<td></td>
<td>0x02e</td>
</tr>
<tr>
<td>V</td>
<td></td>
<td></td>
<td>0x02f</td>
</tr>
<tr>
<td>B</td>
<td></td>
<td></td>
<td>0x030</td>
</tr>
<tr>
<td>N</td>
<td></td>
<td></td>
<td>0x031</td>
</tr>
<tr>
<td>M</td>
<td></td>
<td></td>
<td>0x032</td>
</tr>
<tr>
<td>,</td>
<td></td>
<td></td>
<td>0x033</td>
</tr>
<tr>
<td>.</td>
<td></td>
<td></td>
<td>0x034</td>
</tr>
<tr>
<td>/</td>
<td></td>
<td></td>
<td>0x035</td>
</tr>
<tr>
<td>Shift</td>
<td>right</td>
<td></td>
<td>0x036</td>
</tr>
<tr>
<td>*</td>
<td>numeric pad</td>
<td></td>
<td>0x037</td>
</tr>
<tr>
<td>Alt</td>
<td>left</td>
<td></td>
<td>0x038</td>
</tr>
<tr>
<td>Space bar</td>
<td></td>
<td></td>
<td>0x039</td>
</tr>
<tr>
<td>Caps Lock</td>
<td></td>
<td></td>
<td>0x03a</td>
</tr>
<tr>
<td>F1</td>
<td></td>
<td></td>
<td>0x03b</td>
</tr>
<tr>
<td>F2</td>
<td></td>
<td></td>
<td>0x03c</td>
</tr>
<tr>
<td>F3</td>
<td></td>
<td></td>
<td>0x03d</td>
</tr>
<tr>
<td>F4</td>
<td></td>
<td></td>
<td>0x03e</td>
</tr>
<tr>
<td>F5</td>
<td></td>
<td></td>
<td>0x03f</td>
</tr>
<tr>
<td>F6</td>
<td></td>
<td></td>
<td>0x040</td>
</tr>
<tr>
<td>F7</td>
<td></td>
<td></td>
<td>0x041</td>
</tr>
<tr>
<td>F8</td>
<td></td>
<td></td>
<td>0x042</td>
</tr>
<tr>
<td>F9</td>
<td></td>
<td></td>
<td>0x043</td>
</tr>
<tr>
<td>F10</td>
<td></td>
<td></td>
<td>0x044</td>
</tr>
<tr>
<td>Num Lock</td>
<td>numeric pad</td>
<td></td>
<td>0x045</td>
</tr>
</tbody>
</table>
Table 8-1. V-Scan Codes for the 104-Key U.S. Keyboard (Continued)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll Lock</td>
<td></td>
<td>numeric pad</td>
<td>0x046</td>
</tr>
<tr>
<td>Home</td>
<td>7</td>
<td>numeric pad</td>
<td>0x047</td>
</tr>
<tr>
<td>Up arrow</td>
<td>8</td>
<td>numeric pad</td>
<td>0x048</td>
</tr>
<tr>
<td>PgUp</td>
<td>9</td>
<td>numeric pad</td>
<td>0x049</td>
</tr>
<tr>
<td>-</td>
<td></td>
<td>numeric pad</td>
<td>0x04a</td>
</tr>
<tr>
<td>Left arrow</td>
<td>4</td>
<td>numeric pad</td>
<td>0x04b</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>numeric pad</td>
<td>0x04c</td>
</tr>
<tr>
<td>Right arrow</td>
<td>6</td>
<td>numeric pad</td>
<td>0x04d</td>
</tr>
<tr>
<td>+</td>
<td></td>
<td>numeric pad</td>
<td>0x04e</td>
</tr>
<tr>
<td>End</td>
<td>1</td>
<td>numeric pad</td>
<td>0x04f</td>
</tr>
<tr>
<td>Down arrow</td>
<td>2</td>
<td>numeric pad</td>
<td>0x050</td>
</tr>
<tr>
<td>PgDn</td>
<td>3</td>
<td>numeric pad</td>
<td>0x051</td>
</tr>
<tr>
<td>Ins</td>
<td>0</td>
<td>numeric pad</td>
<td>0x052</td>
</tr>
<tr>
<td>Del</td>
<td></td>
<td>numeric pad</td>
<td>0x053</td>
</tr>
<tr>
<td>F11</td>
<td></td>
<td>numeric pad</td>
<td>0x057</td>
</tr>
<tr>
<td>F12</td>
<td></td>
<td>numeric pad</td>
<td>0x058</td>
</tr>
<tr>
<td>Break</td>
<td>Pause</td>
<td>numeric pad</td>
<td>0x100</td>
</tr>
<tr>
<td>Enter</td>
<td></td>
<td>numeric pad</td>
<td>0x11c</td>
</tr>
<tr>
<td>Ctrl</td>
<td>right</td>
<td>numeric pad</td>
<td>0x11d</td>
</tr>
<tr>
<td>/</td>
<td></td>
<td>numeric pad</td>
<td>0x135</td>
</tr>
<tr>
<td>SysRq</td>
<td>Print Scrn</td>
<td>numeric pad</td>
<td>0x137</td>
</tr>
<tr>
<td>Alt</td>
<td>right</td>
<td>numeric pad</td>
<td>0x138</td>
</tr>
<tr>
<td>Home</td>
<td></td>
<td>function pad</td>
<td>0x147</td>
</tr>
<tr>
<td>Up arrow</td>
<td></td>
<td>function pad</td>
<td>0x148</td>
</tr>
<tr>
<td>Page Up</td>
<td></td>
<td>function pad</td>
<td>0x149</td>
</tr>
<tr>
<td>Left arrow</td>
<td></td>
<td>function pad</td>
<td>0x14b</td>
</tr>
<tr>
<td>Right arrow</td>
<td></td>
<td>function pad</td>
<td>0x14d</td>
</tr>
<tr>
<td>End</td>
<td></td>
<td>function pad</td>
<td>0x14f</td>
</tr>
<tr>
<td>Down arrow</td>
<td></td>
<td>function pad</td>
<td>0x150</td>
</tr>
<tr>
<td>Page Down</td>
<td></td>
<td>function pad</td>
<td>0x151</td>
</tr>
<tr>
<td>Insert</td>
<td></td>
<td>function pad</td>
<td>0x152</td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td>function pad</td>
<td>0x153</td>
</tr>
<tr>
<td>Windows</td>
<td>left</td>
<td>numeric pad</td>
<td>0x15b</td>
</tr>
<tr>
<td>Windows</td>
<td>right</td>
<td>numeric pad</td>
<td>0x15c</td>
</tr>
<tr>
<td>Menu</td>
<td></td>
<td>numeric pad</td>
<td>0x15d</td>
</tr>
</tbody>
</table>

The 84-key keyboard has a Sys Req key on the numeric pad. Its v-scan code is 0x054.

Keyboards outside the U.S. usually have an extra key (often < > or < > |) next to the left Shift key. The v-scan code for this key is 0x056.
Modify Hardware Settings for a Virtual Machine

You can modify memory, processor, virtual and physical hard disk, CD-ROM and DVD drive, floppy drive, virtual network adapter, USB controller, sound card, serial port, generic SCSI device, printer, and display settings for a virtual machine.

Procedure

1. Select the virtual machine, select VM > Settings.
2. Click the Hardware tab.
3. Select the hardware setting to modify.
4. Click Help for information about how to modify the hardware setting.

You must power off a virtual machine before you change certain hardware settings.
Workstation Pro provides bridged networking, network address translation (NAT), host-only networking, and custom networking options to configure a virtual machine for virtual networking. The software needed for all networking configurations is installed on the host system when you install Workstation Pro.

This chapter includes the following topics:

- “Understanding Virtual Networking Components,” on page 175
- “Understanding Common Networking Configurations,” on page 176
- “Changing the Default Networking Configuration,” on page 177
- “Configuring Bridged Networking,” on page 181
- “Configuring Network Address Translation,” on page 184
- “Configuring Host-Only Networking,” on page 193
- “Assigning IP Addresses in Host-Only Networks and NAT Configurations,” on page 199
- “Configuring LAN Segments,” on page 203
- “Configuring Samba for Workstation Pro,” on page 204
- “Using Virtual Network Adapters in Promiscuous Mode on Linux Hosts,” on page 205
- “Maintaining and Changing MAC Addresses for Virtual Machines,” on page 206
- “Sample Custom Networking Configuration,” on page 207

Understanding Virtual Networking Components

The virtual networking components in Workstation Pro include virtual switches, virtual network adapters, the virtual DHCP server, and the NAT device.

Virtual Switches

Like a physical switch, a virtual switch connects networking components together. Virtual switches, which are also referred to as virtual networks, are named VMnet0, VMnet1, VMnet2, and so on. A few virtual switches are mapped to specific networks by default.
### Table 9-1. Default Virtual Network Switches

<table>
<thead>
<tr>
<th>Network Type</th>
<th>Switch Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bridged</td>
<td>VMnet0</td>
</tr>
<tr>
<td>NAT</td>
<td>VMnet8</td>
</tr>
<tr>
<td>Host-only</td>
<td>VMnet1</td>
</tr>
</tbody>
</table>

Workstation Pro creates virtual switches as needed, up to 20 virtual switches on a Windows host system and up to 255 virtual switches on a Linux host system. You can connect an unlimited number of virtual network devices to a virtual switch on a Windows host system and up to 32 virtual network devices to a virtual switch on a Linux host system.

**Note** On Linux host systems, the virtual switch names are in all lowercase letters, for example, vmnet0.

### Virtual Network Adapters

When you use the New Virtual Machine wizard to create a new virtual machine, the wizard creates a virtual network adapter for the virtual machine. The virtual network adapter appears in the guest operating system as an AMD PCNET PCI adapter or Intel Pro/1000 MT Server Adapter. In Windows Vista, Windows 7, and Windows 8 guest operating systems, it is an Intel Pro/1000 MT Server Adapter.

Workstation 6.0 and later virtual machines can have up to 10 virtual network adapters. Workstation 5.x virtual machines are limited to three virtual network adapters.

### Virtual DHCP Server

The virtual Dynamic Host Configuration Protocol (DHCP) server provides IP addresses to virtual machines in configurations that are not bridged to an external network. For example, the virtual DHCP server assigns IP addresses to virtual machines in host-only and NAT configurations.

### NAT Device

In a NAT configuration, the NAT device passes network data between one or more virtual machines and the external network, identifies incoming data packets intended for each virtual machine, and sends them to the correct destination.

### Understanding Common Networking Configurations

You can configure bridged networking, NAT, and host-only networking for virtual machines. You can also use the virtual networking components to create sophisticated custom virtual networks.

### Bridged Networking

Bridged networking connects a virtual machine to a network by using the network adapter on the host system. If the host system is on a network, bridged networking is often the easiest way to give the virtual machine access to that network.

When you install Workstation Pro on a Windows or Linux host system, a bridged network (VMnet0) is set up for you. See “Configuring Bridged Networking” on page 181.

### NAT Networking

With NAT, a virtual machine does not have its own IP address on the external network. Instead, a separate private network is set up on the host system. In the default configuration, a virtual machine gets an address on this private network from the virtual DHCP server. The virtual machine and the host system share a single network identity that is not visible on the external network.
When you install Workstation Pro on a Windows or Linux host system, a NAT network (VMnet8) is set up for you. When you use the New Virtual Machine wizard to create a new virtual machine and select the typical configuration type, the wizard configures the virtual machine to use the default NAT network.

You can have only one NAT network. See “Configuring Network Address Translation,” on page 184.

Host-Only Networking

Host-only networking creates a network that is completely contained within the host computer. Host-only networking provides a network connection between the virtual machine and the host system by using a virtual network adapter that is visible on the host operating system.

When you install Workstation Pro on a Windows or Linux host system, a host-only network (VMnet1) is set up for you. See “Configuring Host-Only Networking,” on page 193.

Custom Networking Configurations

With the Workstation Pro virtual networking components, you can create sophisticated virtual networks. The virtual networks can be connected to one or more external networks, or they can run entirely on the host system. You can use the virtual network editor to configure multiple network cards in the host system and create multiple virtual networks. “Sample Custom Networking Configuration,” on page 207.

Changing the Default Networking Configuration

When you choose the standard network options in the New Virtual Machine wizard, the wizard sets up the networking configuration for the virtual machine.

In a typical configuration, the New Virtual Machine wizard sets up NAT for the virtual machine. You must select the custom configuration option to configure bridged networking or host-only networking. The wizard connects the virtual machine to the appropriate virtual network.

You can change the networking configuration for a virtual machine by modifying virtual machine settings. For example, you can use virtual machine settings to add virtual network adapters and change existing virtual network adapters for a particular virtual machine.

You use the virtual network editor to change key networking settings, add and remove virtual networks, and create custom virtual networking configurations. The changes you make in the virtual network editor affect all virtual machines running on the host system.

**Important**: If you click **Restore Default** in the virtual network editor to restore network settings, all changes that you made to network settings after you installed Workstation Pro are permanently lost. Do not restore the default network settings when a virtual machine is powered on as this might cause serious damage to bridged networking.

- **Add a Virtual Network Adapter to a Virtual Machine** on page 178
  You can add up to 10 virtual network adapters to a virtual machine.

- **Modify an Existing Virtual Network Adapter for a Virtual Machine** on page 178
  You can change the settings of a virtual network adapter that is currently used by a virtual machine.

- **Disconnect a Host Virtual Network Adapter** on page 179
  When you install Workstation Pro, two virtual network adapters, VMware Network Adapter VMnet1 and VMware Network Adapter VMnet8, are added to the configuration of the host operating system. You might want to disconnect one or both of these virtual network adapters to improve performance on the host system.

- **Configure Bandwidth and Packet Loss Settings for a Virtual Machine** on page 180
  You can use advanced virtual network adapter settings to limit the bandwidth and specify the acceptable packet loss percentage for incoming and outgoing data transfers for a virtual machine.
Add a Virtual Network Adapter to a Virtual Machine

You can add up to 10 virtual network adapters to a virtual machine.

**Note**  Workstation 5.x virtual machines are limited to three virtual network adapters.

**Prerequisites**

Familiarize yourself with the network configuration types. See “Understanding Common Networking Configurations,” on page 176.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, click **Add**.
3. Select **Network Adapter** and click **Next**.
4. Select the virtual network adapter type.
   
   You cannot select a custom network or LAN segment for a shared virtual machine. For a remote virtual machine, you must select a custom network.

   **Option** | **Description**
   --- | ---
   Bridged | The virtual machine is connected to the network by using the network adapter on the host system. The virtual machine has a unique identity on the network, separate from and unrelated to the host system.
   **NAT** | The virtual machine and the host system share a single network identity that is not visible on the external network. When the virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.
   **Host-only** | The virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.
   **Custom** | Select a custom network from the drop-down menu. Although VMnet0, VMnet1, and VMnet8 might be available in the list, these networks are usually used for bridged, host-only, and NAT networks.

5. (Optional) Select the **Connect at power on** checkbox.
6. Click **Finish** to add the virtual network adapter to the virtual machine.
7. Click **OK** to save your changes.
8. Verify that the guest operating system is configured to use an appropriate IP address on the new network.
   a. If the virtual machine is using DHCP, release and renew the lease.
   b. If the IP address is set statically, verify that the guest operating system has an address on the correct virtual network.

Modify an Existing Virtual Network Adapter for a Virtual Machine

You can change the settings of a virtual network adapter that is currently used by a virtual machine.

**Prerequisites**

Familiarize yourself with the network configuration types. See “Understanding Common Networking Configurations,” on page 176.
Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select the virtual network adapter.
3. Select the virtual network adapter type.

You cannot select a custom network or LAN segment for a shared virtual machine. For a remote virtual machine, you must select a custom network.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bridged</td>
<td>The virtual machine is connected to the network by using the network adapter on the host system. The virtual machine has a unique identity on the network, separate from and unrelated to the host system.</td>
</tr>
<tr>
<td>NAT</td>
<td>The virtual machine and the host system share a single network identity that is not visible on the external network. When the virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.</td>
</tr>
<tr>
<td>Host-only</td>
<td>The virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.</td>
</tr>
<tr>
<td>Custom</td>
<td>Select a custom network from the drop-down menu. Although VMnet0, VMnet1, and VMnet8 might be available in this list, these networks are usually used for bridged, host-only, and NAT networks.</td>
</tr>
<tr>
<td>LAN segment</td>
<td>Select a LAN segment from the drop-down menu. A LAN segment is a private network that is shared by other virtual machines.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.
5. Verify that the guest operating system is configured to use an appropriate IP address on the new network.
   a. If the virtual machine is using DHCP, release and renew the lease.
   b. If the IP address is set statically, verify that the guest operating system has an address on the correct virtual network.

Disconnect a Host Virtual Network Adapter

When you install Workstation Pro, two virtual network adapters, VMware Network Adapter VMnet1 and VMware Network Adapter VMnet8, are added to the configuration of the host operating system. You might want to disconnect one or both of these virtual network adapters to improve performance on the host system.

Because broadcast packets must go to these adapters, the presence of virtual network adapters has a slight performance cost. On Windows networks, browsing the network might be slower than usual. In some cases, these adapters interact with the host computer networking configuration in undesirable ways.

You can reconnect a host virtual network adapter after you disconnect it.

Prerequisites

- Determine whether you are going to use the host virtual network adapter. The host system uses VMware Network Adapter VMnet1 to connect to the host-only network and it uses VMware Network Adapter VMnet8 to connect to the NAT network.
- On a Windows host, log in as an Administrator user. Only an Administrator user can change network settings in the virtual network editor.
- On a Linux host, log in as root. You must enter the root password to use the virtual network editor.
**Procedure**

1. Start the virtual network editor on the host system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Select Edit &gt; Virtual Network Editor.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Select Applications &gt; System Tools &gt; Virtual Network Editor. The menu path might be different for your version of Linux. You can also start the network editor from the command line by using the <code>vmware-netcfg</code> command.</td>
</tr>
</tbody>
</table>

2. Select the virtual network.

3. Deselect *Connect a host virtual adapter to this network* to disconnect the host virtual network adapter from the virtual network.

4. Click **OK** to save your changes.

**Configure Bandwidth and Packet Loss Settings for a Virtual Machine**

You can use advanced virtual network adapter settings to limit the bandwidth and specify the acceptable packet loss percentage for incoming and outgoing data transfers for a virtual machine.

**NOTE** You cannot configure advanced virtual network adapter settings for a shared or remote virtual machine.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.

2. On the **Hardware** tab, select the virtual network adapter and click **Advanced**.

3. Select a bandwidth setting.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Limit incoming or outgoing data transfers to the data transfer rate for a specific network connection type</td>
<td>Select the network connection type from the <strong>Bandwidth</strong> drop-down menu. The value in the <strong>Kbps</strong> text box changes to the data transfer rate, in kilobits per second, of the network connection type that you select. For example, if you select <em>Leased Line T1 (1.544 Mbps)</em>, the value in the <strong>Kbps</strong> text box changes to 1544.</td>
</tr>
</tbody>
</table>

| Limit incoming or outgoing data transfers to a specific data transfer rate | Select **Custom** and type the data transfer rate, in kilobits per second, in the **Kbps** text box. |

4. Type the acceptable packet loss percentage for incoming and outgoing data transfers in the **Packet Loss (%)** text box.

   The default setting is 0.0%.

5. Click **OK** to save your changes.
Configuring Bridged Networking

When you install Workstation Pro on a Windows or Linux host system, a bridged network (VMnet0) is set up for you. Bridged networking connects a virtual machine to a network by using the network adapter on the host system. If the host system is on a network, bridged networking is often the easiest way to give the virtual machine access to that network.

With bridged networking, the virtual network adapter in the virtual machine connects to a physical network adapter in the host system. The host network adapter enables the virtual machine to connect to the LAN that the host system uses. Bridged networking works with both wired and wireless host network adapters.

Bridged networking configures the virtual machine as a unique identity on the network, separate from and unrelated to the host system. The virtual machine is a full participant in the network. It has access to other machines on the network, and other machines on the network can contact it as if it were a physical computer on the network.

Figure 9-1. Bridged Networking Configuration

You can view and change the settings for bridged networking on the host system, determine which network adapters to use for bridged networking, and map specific host network adapters to specific virtual switches.

- Assigning IP Addresses in a Bridged Networking Environment on page 182
  A virtual machine must have its own identity on a bridged network. For example, on a TCP/IP network, the virtual machine needs its own IP address. Your network administrator can tell you whether IP addresses are available for virtual machines and which networking settings to use in the guest operating system.

- Add a Bridged Network on page 182
  When you install Workstation Pro on a Windows or Linux host system, a bridged network (VMnet0) is set up for you. If you install Workstation Pro on a host system that has multiple network adapters, you can configure multiple bridged networks.

- Configure Bridged Networking for an Existing Virtual Machine on page 182
  You can configure bridged networking for an existing virtual machine.

- Change VMnet0 Bridged Networking Settings on page 183
  By default, VMnet0 is set to use auto-bridging mode and is configured to bridge to all active network adapters on the host system. You can use the virtual network editor to change VMnet0 to bridge to one specific host network adapter, or restrict the host network adapters that VMnet0 auto-bridges to. The changes you make affect all virtual machines that use bridged networking on the host system.
Assigning IP Addresses in a Bridged Networking Environment

A virtual machine must have its own identity on a bridged network. For example, on a TCP/IP network, the virtual machine needs its own IP address. Your network administrator can tell you whether IP addresses are available for virtual machines and which networking settings to use in the guest operating system.

Typically, the guest operating system can acquire an IP address and other network details from a DHCP server, but you might need to set the IP address and other details manually in the guest operating system.

Users who boot multiple operating systems often assign the same address to all systems because they assume that only one operating system will be running at a time. If the host system is set up to boot multiple operating systems, and you run one or more operating systems in virtual machines, you must configure each operating system to have a unique network address.

Add a Bridged Network

When you install Workstation Pro on a Windows or Linux host system, a bridged network (VMnet0) is set up for you. If you install Workstation Pro on a host system that has multiple network adapters, you can configure multiple bridged networks.

For example, if the host system has two network adapters connected to two different networks, you might want virtual machines on the host system to bridge to both network adapters so that they can access either or both physical networks.

Prerequisites

- Verify that a network adapter is available on the host system to bridge to. If VMnet0 is bridging to all of the available host network adapters (the default setting), you can modify it to make an adapter available. See “Change VMnet0 Bridged Networking Settings,” on page 183.
- On a Windows host, log in as an Administrator user. Only an Administrator user can change network settings in the virtual network editor.
- On a Linux host, log in as root. You must enter the root password to access the virtual network editor.

Procedure

1. Select Edit > Virtual Network Editor.
2. Click Add Network and select a network to add.
   You can create a custom bridged network on VMnet2 to VMnet7. On Windows hosts, you can also use VMnet9. On Linux hosts, you can also use vmnet10 through vmnet255.
3. Select the new network and select Bridged (connect VMs directly to the external network).
4. Select a host network adapter to bridge to from the Bridged to drop-down menu.
5. Click OK to save your changes.

Configure Bridged Networking for an Existing Virtual Machine

You can configure bridged networking for an existing virtual machine.

To configure bridged networking for a new virtual machine, select Customize Hardware when you run the New Virtual Machine wizard.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select Network Adapter.
3 Select Bridged: Connected directly to the physical network.

4 If you use the virtual machine on a laptop or other mobile device, select Replicate physical network connection state.
   This setting causes the IP address to be renewed when you move from one wired or wireless network to another.

5 Click OK to save your changes.

Change VMnet0 Bridged Networking Settings

By default, VMnet0 is set to use auto-bridging mode and is configured to bridge to all active network adapters on the host system. You can use the virtual network editor to change VMnet0 to bridge to one specific host network adapter, or restrict the host network adapters that VMnet0 auto-bridges to. The changes you make affect all virtual machines that use bridged networking on the host system.

For example, you might want to change VMnet0 to bridge to a specific host network adapter, or to auto-bridge to as subset of the available host network adapters, to make a host network adapter available to create a second bridged network.

**IMPORTANT** If you reassign a host network adapter to a different virtual network, any virtual machine that is using the original network loses its network connectivity through that network and you must change the setting for each affected virtual machine network adapter individually. This restriction can be especially problematic if the host system has only one physical network adapter and you reassign it to a virtual network other than VMnet0. Even though the virtual network appears to be bridged to an automatically chosen adapter, the only adapter it can use was assigned to a different virtual network.

**Prerequisites**

- On a Windows host, log in as an Administrator user. Only an Administrator user can change network settings in the virtual network editor.
- On a Linux host, log in as root. You must enter the root password to use the virtual network editor.

**Procedure**

1 Select Edit > Virtual Network Editor.
2 Select VMnet0.
3 Change the host network adapters that VMnet0 bridges to.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prevent VMnet0 from automatically bridging to a particular host network adapter</td>
<td>a Click Automatic Settings.  b Deselect the check box for the host network adapter.  c Click OK.</td>
</tr>
<tr>
<td>Disable automatic bridging and bridge VMnet0 to a specific host network adapter</td>
<td>Select the host network adapter from the Bridge to drop-down menu.</td>
</tr>
</tbody>
</table>

4 Click OK to save your changes.
Configuring Network Address Translation

When you install Workstation Pro on a Windows or Linux host system, a NAT network (VMnet8) is set up for you. When you use the New Virtual Machine wizard to create a typical virtual machine, the wizard configures the virtual machine to use the default NAT network.

With NAT, a virtual machine does not have its own IP address on the external network. Instead, a separate private network is set up on the host system. In the default configuration, virtual machines get an address on this private network from the virtual DHCP server.

Figure 9-2. NAT Configuration

The virtual machine and the host system share a single network identity that is not visible on the external network. NAT works by translating the IP addresses of virtual machines in the private network to the IP address of the host system. When a virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.

The host system has a virtual network adapter on the NAT network. This adapter enables the host system and virtual machines to communicate with each other. The NAT device passes network data between one or more virtual machines and the external network, identifies incoming data packets intended for each virtual machine, and sends them to the correct destination.

- Features and Limitations of NAT Configurations on page 185
  NAT is useful when the number of IP addresses is limited or the host system is connected to the network through a non-Ethernet adapter.

- Change NAT Settings on page 186
  You can change the gateway IP address, configure port forwarding, and configure advanced networking settings for NAT networks.

- Editing the NAT Configuration File on page 188
  If you are an advanced user, you can edit the NAT configuration file to modify NAT settings.

- Using NAT with NetLogon on page 191
  If you use NAT networking in a Windows virtual machine running on a Windows host system, you can use NetLogon to log in to a Windows domain from the virtual machine and access file shares that the WINS server knows.

- Specifying Connections from Source Ports Below 1024 on page 192
  If a virtual machine that uses NAT attempts to connect to a server that requires the client to use a source port below 1024, the NAT device must forward the request from a port below 1024. For security reasons, some servers accept connections only from source ports below 1024.
Features and Limitations of NAT Configurations

NAT is useful when the number of IP addresses is limited or the host system is connected to the network through a non-Ethernet adapter.

With NAT, a virtual machine can use many standard TCP/IP protocols to connect to other machines on the external network. For example, you can use HTTP to browse Web sites, FTP to transfer files, and Telnet to log in to other computers. You also can connect to a TCP/IP network by using a Token Ring adapter on the host system. NAT works with Ethernet, DSL, and phone modems.

In the default NAT configuration, computers on the external network cannot initiate connections to the virtual machine. For example, you cannot use the virtual machine as a Web server to send Web pages to computers on the external network. This feature protects the guest operating system from being compromised before you have a chance to install security software.

NAT configurations have the following additional features and limitations.

- NAT causes some performance loss. Because NAT requires that every packet sent to and received from a virtual machine must be in the NAT network, an unavoidable performance penalty occurs.
- NAT is not perfectly transparent. NAT does not usually allow connections to be initiated from outside the network, although you can manually configure the NAT device to set up server connections. The practical result is that some TCP and UDP protocols that require a connection be initiated from the server machine do not work automatically and some might not work at all.
- NAT provides some firewall protection. A standard NAT configuration provides basic-level firewall protection because the NAT device can initiate connections from the private NAT network, but devices on the external network usually cannot initiate connections to the private NAT network.

Understanding DHCP in a NAT Configuration

In a NAT configuration, virtual machines running on the network with the NAT device can send DHCP requests to dynamically obtain their IP addresses.

In the default configuration, the virtual DHCP server dynamically allocates IP addresses in the range of net.128 through net.254, where net is the network number assigned to the NAT network. Workstation Pro always uses a Class C address for NAT networks. IP addresses net.3 through net.127 can be used for static IP addresses. IP address net.1 is reserved for the host virtual network adapter and net.2 is reserved for the NAT device.

In addition to the IP address, the virtual DHCP server on the NAT network sends out configuration information that enables the virtual machine to operate. This information includes the default gateway and the DNS server. In the DHCP response, the NAT device instructs the virtual machine to use the IP address net.2 as the default gateway and DNS server. This routing causes all IP packets destined for the external network and DNS requests to be forwarded to the NAT device.

Understanding the NAT Device

The NAT device is connected to the VMnet8 virtual switch. Virtual machines connected to the NAT network also use the VMnet8 virtual switch.

The NAT device waits for packets coming from virtual machines on the VMnet8 virtual network. When a packet arrives, the NAT device translates the address of the virtual machine to the address of the host system before forwarding the packet to the external network.

When data arrives from the external network for the virtual machine on the private network, the NAT device receives the data, replaces the network address with the address of the virtual machine, and forwards the data to the virtual machine on the virtual network. This translation occurs automatically and requires minimal configuration on the guest operating system and the host system.
The NAT device is a DNS proxy and forwards DNS requests from the virtual machines to a DNS server that the host system knows. Responses return to the NAT device, which then forwards them to the virtual machines.

If they get their configuration information from the virtual DHCP server, the virtual machines on the NAT network use the NAT device as the DNS server. The virtual machines in the private NAT network are not accessible through DNS. To have the virtual machines running on the NAT network access each other by DNS names, you must set up a private DNS server connected to the NAT network and configure the virtual machines to use the DNS server.

**Accessing External Networks from a NAT Network**

For most client applications, including Web browsers, Telnet, passive-mode FTP, and downloaded streaming video, a virtual machine on a NAT network can use any protocol using TCP or UDP if the virtual machine initiates the network connection. Additional protocol support is built into the NAT device to allow FTP and ICMP echo (ping) to work transparently through the NAT device.

On the external network, a virtual machine on the NAT network appears to be the host system because its network traffic uses the host system IP address. The virtual machine can send and receive data by using TCP/IP to any machine that is accessible from the host system.

Before any communication can occur, the NAT device must set up a map between the virtual machine address on the private NAT network and the host network address on the external network. When a virtual machine initiates a network connection with another network resource, this map is created automatically. The operation is transparent to the user of the virtual machine on the NAT network.

Network connections that are initiated from outside the NAT network to a virtual machine on the NAT network are not transparent. When a machine on the external network attempts to initiate a connection with a virtual machine on the NAT network, it cannot reach the virtual machine because the NAT device does not forward the request. You can configure port forwarding manually on the NAT device so that network traffic destined for a certain port can still be forwarded automatically to a virtual machine on the NAT network.

File sharing of the type used by Windows operating systems and Samba is possible among computers on the NAT network, including virtual machines and the host system. If you use WINS servers on your network, a virtual machine that uses NAT networking can access shared files and folders on the host system that the WINS server knows if those shared files and folders are in the same workgroup or domain.

**Change NAT Settings**

You can change the gateway IP address, configure port forwarding, and configure advanced networking settings for NAT networks.

**Prerequisites**

- Determine whether you are going to use the host virtual network adapter. The host system uses VMware Network Adapter VMnet1 to connect to the host-only network and it uses VMware Network Adapter VMnet8 to connect to the NAT network.
- On a Windows host, log in as an Administrator user. Only an Administrator user can change network settings in the virtual network editor.
- On a Linux host, log in as root. You must enter the root password to use the virtual network editor.
## Procedure

1. Start the virtual network editor on the host system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Select Edit &gt; Virtual Network Editor.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Select Applications &gt; System Tools &gt; Virtual Network Editor. The menu path might be different for your version of Linux. You can also start the network editor from the command line by using the <code>vmware-netcfg</code> command.</td>
</tr>
</tbody>
</table>

2. Select the NAT network, and click **NAT Settings**.

By default, the NAT device is connected to the VMnet8 virtual switch. You can have only one NAT virtual network.

**Table 9-2. NAT Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gateway IP</td>
<td>The gateway IP address for the selected network.</td>
</tr>
<tr>
<td><strong>Port Forwarding</strong></td>
<td>Add a port for port forwarding. With port forwarding, incoming TCP or UDP requests are sent to a specific virtual machine on the virtual network that is served by the NAT device.</td>
</tr>
<tr>
<td><strong>Host port</strong></td>
<td>The number of the incoming TCP or UDP port. For example, incoming HTTP requests are usually on port 80.</td>
</tr>
<tr>
<td><strong>Virtual machine IP address</strong></td>
<td>The IP address of the virtual machine to which you want to forward the incoming requests.</td>
</tr>
<tr>
<td><strong>Virtual machine port</strong></td>
<td>The port number to use for requests on the specified virtual machine. It may be the standard port, such as 80 for HTTP, or a nonstandard port if software running in the virtual machine is configured to accept requests on a nonstandard port.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>(Optional) You can use this text box to identify the forwarded service, for example, HTTP.</td>
</tr>
<tr>
<td>Allow active FTP</td>
<td>Allow only passive mode FTP over the NAT device.</td>
</tr>
<tr>
<td>Allow any Organizationally Unique Identifier</td>
<td>Select this setting if you change the organizationally unique identifier (OUI) portion of the MAC address for the virtual machine and subsequently cannot use NAT with the virtual machine.</td>
</tr>
<tr>
<td>UDP timeout (in seconds)</td>
<td>Select the number of minutes to keep the UDP mapping for the NAT.</td>
</tr>
<tr>
<td>Config port</td>
<td>Select the port to use to access status information about NAT. Important: Change this value only under the direction of VMware technical support.</td>
</tr>
<tr>
<td>Enable IPv6</td>
<td>Enable NAT to use an IPv6 address.</td>
</tr>
<tr>
<td>IPv6 Prefix</td>
<td>If IPv6 is enabled, enter the IPv6 prefix that the NAT device uses.</td>
</tr>
</tbody>
</table>
### Table 9-2. NAT Settings (Continued)

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DNS Settings</td>
<td>(Windows hosts only) Configure the DNS servers for the virtual NAT device to use.</td>
</tr>
<tr>
<td>Auto detect available DNS servers</td>
<td>Select this option to detect the available DNS servers. To add a DNS server to the list, deselect this check box and enter the IP address of the preferred and alternate DNS servers in the Preferred DNS server text boxes.</td>
</tr>
<tr>
<td>Policy</td>
<td>If you have multiple DNS servers, select the strategy for choosing which server to send a request to. Order sends one DNS request at a time in order of the name. Rotate sends one DNS request at a time and rotates through the DNS servers. Burst sends to three servers and waits for the first server to respond.</td>
</tr>
<tr>
<td>Timeout (sec)</td>
<td>Select the number of seconds to keep trying if the NAT device cannot connect to the DNS server.</td>
</tr>
<tr>
<td>Retries</td>
<td>Select the number of retries.</td>
</tr>
</tbody>
</table>

**NetBios Settings** (Windows hosts only) Select NBNS (NetBIOS Name Service) and NBDS (NetBIOS Datagram Service) timeouts and retry settings.

### Editing the NAT Configuration File

If you are an advanced user, you can edit the NAT configuration file to modify NAT settings.

The location of the NAT configuration file depends on the host operating system.

### Table 9-3. NAT Configuration File Location

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>NAT Configuration File Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, Windows 8 or Windows 10</td>
<td>C:\ProgramData\VMware\vmnetnat.conf</td>
</tr>
<tr>
<td>Linux</td>
<td>/etc/vmware/vmnet8/nat/nat.conf</td>
</tr>
</tbody>
</table>

The NAT configuration file is divided into sections, and each section configures a part of the NAT device. Text surrounded by square brackets, such as `[dns]`, marks the beginning of a section. Each section contains one or more configuration parameters. The configuration parameters take the form `ip = 192.168.27.1/24`.

On a Windows host system, you can change the NAT configuration by using the virtual network editor. You do not need to edit the NAT configuration file. On a Linux host system, you must edit the NAT configuration file to modify the NAT configuration.

**IMPORTANT** Make a backup copy of the NAT configuration file. If you edit the NAT configuration file and then use the virtual network editor, your edits might be lost.

### NAT Configuration File Sections

The NAT configuration file is divided into sections. The parameters in each section configure a part of the NAT device.

**[host] Section**

The [host] section includes parameters to configure the NAT connection.
### Table 9-4. [host] Section Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ip</td>
<td>The IP address that the NAT device should use. It can be followed by a slash and the number of bits in the subnet.</td>
</tr>
<tr>
<td>netmask</td>
<td>The subnet mask to use for the NAT network. DHCP addresses are allocated from this range of addresses.</td>
</tr>
<tr>
<td>configport</td>
<td>A port that can be used to access status information about the NAT device.</td>
</tr>
<tr>
<td>device</td>
<td>The VMnet device to use. Windows devices are of the form <code>vmnetx</code> where <code>x</code> is the number of the VMnet. Linux devices are of the form <code>/dev/vmnetx</code>.</td>
</tr>
<tr>
<td>activeFTP</td>
<td>Flag to indicate if active FTP is to be allowed. Active FTP allows incoming connections to be opened by the remote FTP server. Turning this off means that only passive mode FTP works. Set this flag to 0 to turn it off.</td>
</tr>
</tbody>
</table>

### [udp] Section

The [udp] section contains the `timeout` parameter, which specifies the number of seconds to keep the UDP mapping for the NAT network.

### [dns] Section

The [dns] section is for Windows hosts only. Linux hosts do not use this section.

### Table 9-5. [dns] Section Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>policy</td>
<td>Policy to use for DNS forwarding.</td>
</tr>
<tr>
<td>order</td>
<td>Sends one DNS request at a time in the order of the name servers.</td>
</tr>
<tr>
<td>rotate</td>
<td>Sends one DNS request at a time and rotate through the DNS servers.</td>
</tr>
<tr>
<td>burst</td>
<td>Sends to three servers and wait for the first one to respond.</td>
</tr>
<tr>
<td>timeout</td>
<td>Time in seconds before retrying a DNS request.</td>
</tr>
<tr>
<td>retries</td>
<td>Number of retries before the NAT device stops trying to respond to a DNS request.</td>
</tr>
<tr>
<td>autodetect</td>
<td>Flag to indicate whether the NAT device should detect the DNS servers available to the host.</td>
</tr>
<tr>
<td>nameserver1</td>
<td>IP address of a DNS server to use.</td>
</tr>
<tr>
<td>nameserver2</td>
<td>IP address of a DNS server to use.</td>
</tr>
<tr>
<td>nameserver3</td>
<td>IP address of a DNS server to use.</td>
</tr>
</tbody>
</table>

If autodetect is on and some name servers are specified, the DNS servers specified in `nameserver1`, `nameserver2`, and `nameserver3` are added before the list of detected DNS servers.

### [netbios] Section

The [netbios] section applies to Windows hosts only. Linux hosts do not use this section.

### Table 9-6. [netbios] Section Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>nbnsTimeout = 2</td>
<td>Timeout, in seconds, for NBNS queries.</td>
</tr>
<tr>
<td>nbnsRetries = 3</td>
<td>Number of retries for each NBNS query.</td>
</tr>
<tr>
<td>nbdsTimeout = 3</td>
<td>Timeout, in seconds, for NBDS queries.</td>
</tr>
</tbody>
</table>
[incomingtcp] Section

The [incomingtcp] section configures TCP port forwarding for NAT. You can assign a port number to an IP address and port number on a virtual machine.

This example creates a map from port 8887 on the host to the IP address 192.168.27.128 and port 21.

8887 = 192.168.27.128:21

When this map is set and an external machine connects to the host at port 8887, the network packets are forwarded to port 21 (the standard port for FTP) on the virtual machine that has IP address 192.168.27.128.

[incomingudp] Section

The [incomingudp] section configures UDP port forwarding for NAT. You can assign a port number to an IP address and port number on a virtual machine.

This example creates a map from port 6000 on the host to the IP address 192.168.27.128 and port 6001.

6000 = 192.168.27.128:6001

When this map is set and an external machine connects to the host at port 6000, the network packets are forwarded to port 6001 on the virtual machine that has IP address 192.168.27.128.

Sample Linux nat.conf File

This is an example of a NAT configuration file on a Linux host system.

```bash
# Linux NAT configuration file
[host]
# NAT gateway address
ip = 192.168.237.2/24
hostMAC = 00:50:56:C0:00:08
# enable configuration; disabled by default for security reasons
#configport = 33445
# vmnet device if not specified on command line
device = vmnet8
# Allow PORT/EPRT FTP commands (they need incoming TCP stream...)
activeFTP = 1
# Allows the source to have any OUI. Turn this one if you change the OUI
# in the MAC address of your virtual machines.
#allowAnyOUI = 1
[udp]
# Timeout in seconds, 0 = no timeout, default = 60; real value might
# be up to 100% longer
timeout = 30
[dns]
# This section applies only to Windows.
#
# Policy to use for DNS forwarding. Accepted values include order,
# rotate, burst.
#
# order: send one DNS request at a time in order of the name servers
# rotate: send one DNS request at a time, rotate through the DNS servers
# burst: send to three servers and wait for the first one to respond
policy = order;
# Timeout in seconds before retrying DNS request.
timeout = 2
# Retries before giving up on DNS request
retries = 3
```
# Automatically detect the DNS servers
autodetect = 1
# List of DNS servers to use. Up to three may be specified
#nameserver1 = 208.23.14.2
#nameserver2 = 63.93.12.3
#nameserver3 = 208.23.14.4

[netbios]
# This section applies only to Windows.
# Timeout for NBNS queries.
nbnsTimeout = 2
# Number of retries for each NBNS query.
nbnsRetries = 3
# Timeout for NBDS queries.
nbdsTimeout = 3

[incomingtcp]
# Use these with care – anyone can enter into your virtual machine through these...
# FTP (both active and passive FTP is always enabled)
# ftp localhost 8887
#8887 = 192.168.27.128:21
# WEB (make sure that if you are using named webhosting, names point to your host, not to guest... And if you are forwarding port other than 80 make sure that your server copes with mismatched port number in Host: header)
# lynx http://localhost:8888
#8888 = 192.168.27.128:80
# SSH
# ssh -p 8889 root@localhost
#8889 = 192.168.27.128:22

[incomingudp]
# UDP port forwarding example
#6000 = 192.168.27.128:6000

Using NAT with NetLogon

If you use NAT networking in a Windows virtual machine running on a Windows host system, you can use NetLogon to log in to a Windows domain from the virtual machine and access file shares that the WINS server knows.

To use NetLogon, you need to set up the virtual machine to use NetLogon. The setup process is similar to the way you set up a physical computer on one LAN that is using a domain controller on another LAN.

To log in to a Windows domain outside the virtual NAT network, the virtual machine needs access to a WINS server for that domain. If the WINS server that the DHCP server uses on the NAT network is already set up on the host system, you can connect the virtual machine to it. To connect from the virtual machine to a WINS server that is not set up on the host system, you must manually configure the IP address of the WINS server.

After the virtual machine has an IP address for a WINS server, you can use NetLogon in the virtual machine to log in to a domain and access shares in that domain. Your access is limited to shares of virtual machines that are on the same NAT network or are bridged on the same domain.

For example, if the WINS server covers a domain with a domain controller, you can access that domain controller from the virtual machine and add the virtual machine to the domain. You need the Administrator user ID and password for the domain controller.
Use NAT to Connect to an Existing WINS Server on the Host

If the WINS server that the DHCP server uses on the NAT network is already set up on the host system, you can connect the virtual machine to it.

You can use this procedure for Windows guest operating systems. The steps might be different, depending on the Windows operating system type.

Procedure

1. In the Windows virtual machine, right-click My Network Places and select Properties.
2. Right-click the virtual network adapter and click Properties.
3. In the Properties dialog box, select Internet Protocol (TCP/IPv4) and click Properties.
4. In the TCP/IP Properties dialog box, click Advanced.
5. On the WINS tab, under the NetBIOS setting, select Default: Use NetBIOS setting from DHCP Server.
6. Click OK twice and click Close.

Configure the IP Address of a WINS Server Manually

To connect from a virtual machine to a WINS server that is not set up on the host system, you must manually configure the IP address of the WINS server.

You can use this procedure for Windows 2000, XP, 2003 Server, and 9x guest operating systems. The steps might be different, depending on the Windows operating system type. Repeat this procedure for each WINS server that you want to connect to from the virtual machine.

Procedure

1. In the Windows virtual machine, right-click My Network Places and select Properties.
2. In the Network Connections window, right-click the virtual network adapter and choose Properties.
3. In the Properties dialog box, select Internet Protocol (TCP/IPv4) and click Properties.
4. In the TCP/IP Properties dialog box, click Advanced.
5. On the WINS tab, click Add.
6. In the TCP/IP WINS Server dialog box, type the IP address for the WINS server in the WINS server text box and click Add.
   The IP address of the WINS server appears in the WINS addresses list on the WINS tab.
7. Click OK twice and click Close.

Specifying Connections from Source Ports Below 1024

If a virtual machine that uses NAT attempts to connect to a server that requires the client to use a source port below 1024, the NAT device must forward the request from a port below 1024. For security reasons, some servers accept connections only from source ports below 1024.

The parameters that control virtual machine source and destination ports are in the [privilegedUDP] and [privilegedTCP] sections in the NAT configuration file. You might need to add settings or modify settings in either or both of these sections, depending on the kind of connection you need to make. You can set two parameters, each of which appears on a separate line.
### Table 9-7. Parameters that Map Virtual Machine Source and Destination Ports

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>autodetect</td>
<td>Determines whether the NAT device attempts to map virtual machine source ports below 1024 to NAT source ports below 1024. A setting of 1 means true. A setting of 0 means false. On a Windows host, the default is 1 (true). On a Linux host, the default is 0 (false).</td>
</tr>
<tr>
<td>port</td>
<td>Specifies a destination port, where ( n ) is the port on the server that accepts the connection from the client. When a virtual machine connects to the specified port on any server, the NAT device attempts to make the connection from a source port below 1024. You can include one or more port settings in the <code>[privilegedUDP]</code> or <code>[privilegedTCP]</code> section or in both sections, as required for the connections you need to make. Enter each port setting on a separate line.</td>
</tr>
</tbody>
</table>

See “Editing the NAT Configuration File,” on page 188 for more information.

### Configuring Host-Only Networking

When you install Workstation Pro on a Windows or Linux host system, a host-only network (VMnet1) is set up for you. Host-only networking is useful if you need to set up an isolated virtual network. In a host-only network, the virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.

The network connection between the virtual machine and the host system is provided by a virtual network adapter that is visible on the host operating system. The virtual DHCP server provides IP addresses on the host-only network.

![Figure 9-3. Host-Only Networking Configuration](image)

In the default configuration, a virtual machine in a host-only network cannot connect to the Internet. If you install the proper routing or proxy software on the host system, you can establish a connection between the host virtual network adapter and a physical network adapter on the host system to connect the virtual machine to a Token Ring or other non-Ethernet network.

On a Windows host computer, you can use host-only networking in combination with the Internet Connection Sharing feature in Windows to allow a virtual machine to use the dial-up networking adapter or other connection to the Internet on the host system. See Microsoft documentation for information on configuring Internet Connection Sharing.

- **Add a Host-Only Network** on page 194

  When you install Workstation Pro on a Windows or Linux host system, a host-only network (VMnet1) is set up for you. You might want to configure multiple host-only networks to manage network traffic between virtual machines in specific ways.
You can configure host-only networking for an existing virtual machine. You can connect a virtual network adapter to the default host-only network (VMnet1) or to a custom host-only network. If a virtual machine has two virtual network adapters, you can connect it to two host-only networks.

If you are setting up a complex test network that uses virtual machines, you might want to have two independent host-only networks with a router between them.

Each host-only network should be confined to the host system on which it is set up. Packets that virtual machines send on this network should not leak out to a physical network attached to the host system. Packet leakage can occur only if a machine actively forwards packets.

A host-only network has a network interface associated with it (vmnet1) that is marked up when the host operating system is booted. Routing server processes that operate on the host operating system automatically discover the host-only network and propagate information on how to reach the network, unless you explicitly configure them not to do so.

The virtual DHCP server in Workstation Pro cannot update a DNS server by using a Dynamic Domain Name Service (DDNS). For this reason, you should use DHCP to supply IP addresses as well as other information, such as the identity of a host running a name server and the nearest router or gateway.

Add a Host-Only Network

When you install Workstation Pro on a Windows or Linux host system, a host-only network (VMnet1) is set up for you. You might want to configure multiple host-only networks to manage network traffic between virtual machines in specific ways.

For example, you can set up multiple host-only networks on the same host system to test routing between two virtual networks or test a virtual machine that has multiple network interface cards without using any physical network adapters. You might also want to have two virtual machines connected to one host-only network and other virtual machines connected to another host-only network to isolate the network traffic on each network.

On a Windows host, log in as an Administrator user. Only an Administrator user can change network settings in the virtual network editor.

On a Linux host, log in as root. You must enter the root password to use the virtual network editor.

1 Select Edit > Virtual Network Editor.
2 Click Add Network and select a network to add, for example, VMnet2.
   You can create a custom host-only network on VMnet2 to VMnet7. On Windows hosts, you can also use VMnet9. On Linux hosts, you can also use vmnet10 through vmnet255.
   The new network is configured as a host-only network by default.
3 Click OK to save your changes.

After the host-only networks are set up on a Linux host system, at least four network interfaces appear: eth0, lo, vmnet1, and vmnet2. These four interfaces should have different IP addresses on separate subnets.
Configure Host-Only Networking for an Existing Virtual Machine

You can configure host-only networking for an existing virtual machine. You can connect a virtual network adapter to the default host-only network (VMnet1) or to a custom host-only network. If a virtual machine has two virtual network adapters, you can connect it to two host-only networks.

To configure host-only networking for a new virtual machine, select Customize Hardware when you run the New Virtual Machine wizard.

Prerequisites

To connect the virtual machine to two host-only networks, add a second virtual network adapter to the virtual machine. See “Add a Virtual Network Adapter to a Virtual Machine,” on page 178.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab select a virtual network adapter.
3. Select the host-only network.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the default host-only network (VMnet1)</td>
<td>Select Host-only: A private network shared with the host.</td>
</tr>
<tr>
<td>Use a custom host-only network</td>
<td>Select Custom and select the custom host-only network from the dropdown menu.</td>
</tr>
</tbody>
</table>

4. To connect the virtual machine to a second host-only network, select another virtual network adapter and select the second host-only network.
5. Click OK to save your changes.

What to do next

Assign IP addresses to the virtual network adapters. To see the IP address that a host-only network is using, use the `ipconfig /all` command on a Windows host or the `ipconfig` command on a Linux host.

Set Up Routing Between Two Host-Only Networks

If you are setting up a complex test network that uses virtual machines, you might want to have two independent host-only networks with a router between them.

You can run the router software on the host system or on its own virtual machine. In both cases, you need two host-only networks.

In a simple configuration, you configure one virtual machine on each of the host-only networks. For more complex configurations, you can add more virtual machines and host-only networks.

Prerequisites

Create a second host-only network. On Windows and Linux host systems, the first host-only network (VMnet1) is set up for you when you install Workstation Pro. See “Add a Host-Only Network,” on page 194.
Procedure

1. Set up the connection to the first host-only network.
   a. Select the virtual machine and select **VM > Settings**.
   b. On the **Hardware** tab, select **Network Adapter**.
   c. Select **Host-only** to connect to the default host-only network (VMnet1).

2. Set up the connection to the second host-only network.
   a. Select the virtual machine and select **VM > Settings**.
   b. On the **Hardware** tab, select **Network Adapter**.
   c. Select **Custom** and select the custom host-only network from the drop-down menu.

3. (Optional) To run the router software on a virtual machine, set up a third virtual machine that has connections to the two host-only networks.
   a. Select the virtual machine and select **VM > Settings**.
   b. On the **Hardware** tab, select **Network Adapter**.
   c. Select **Host-only**.
   The adapter is connected to the default host-only interface (VMnet1).
   d. Select the second network adapter, select **Custom**, and select the custom host-only network from the drop-down menu.

4. Stop the VMware DHCP Server service.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>Use the services.msc command to open the Services Console and stop the VMware DHCP Service.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>Use the killall -TERM vmnet-dhcpd command to stop the vmnet-dhcpd service.</td>
</tr>
</tbody>
</table>

5. Install the router software on the host system or in the third virtual machine, depending on the approach you are using.

6. Configure networking in the first two virtual machines to use addresses on the appropriate host-only network.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>Use the ipconfig /all command to determine which IP addresses each host-only network is using.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>Use the ifconfig command to determine which IP addresses each host-only network is using.</td>
</tr>
</tbody>
</table>
Assign IP addresses.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>The router software is on the host system</td>
<td>Assign default router addresses based on the addresses of the host-only adapters on the host computer. In the first virtual machine, the default router address should be the IP address for the host-only adapter connected to VMnet1. In the second virtual machine, the default router address should be the IP address for the host-only adapter connected to VMnet2.</td>
</tr>
<tr>
<td>The router software is in a third virtual machine</td>
<td>Set the default router addresses in the first two virtual machines based on the addresses that the third virtual machine. In the first virtual machine, the default router address should be the IP address for the network adapter connected to VMnet1 in third virtual machine. In the second virtual machine, the default router address should be the IP address for the network adapter connected to VMnet2 in third virtual machine.</td>
</tr>
</tbody>
</table>

Ping the router machine from the first and second virtual machines.

If the router software is set up correctly, you can communicate between the first and second virtual machines.

Avoiding IP Packet Leakage in Host-Only Networks

Each host-only network should be confined to the host system on which it is set up. Packets that virtual machines send on this network should not leak out to a physical network attached to the host system. Packet leakage can occur only if a machine actively forwards packets.

If you use dial-up networking support in a virtual machine and packet forwarding is enabled, host-only network traffic might leak out through the dial-up connection. To prevent the leakage, disable packet forwarding in the guest operating system.

If the host system has multiple network adapters, it might be intentionally configured to use IP forwarding. If that is the case, you do not want to disable forwarding. To avoid packet leakage, you must enable a packet filtering facility and specify that packets from the host-only network should not be sent outside the host system. See the operating system documentation for information on configuring packet filtering.

Disable Packet Forwarding on a Windows Host

Systems that use server versions of Windows operating systems can forward IP packets that are not addressed to them. These systems, and Windows Vista and Windows 7 and later systems, have IP packet forwarding disabled by default.

If packets are leaking from a host-only network on a Windows host system, check whether packet forwarding is enabled on the host system. If packet forwarding is enabled, you must disable it.

Procedure

◆ On a Windows Vista or Windows 7 or later host, stop the Routing and Remote Access service.
  
  a Type `services.msc` to open the Services Console.
  
  b Select `Routing and Remote Access` and click `Stop`.

Disable Packet Forwarding on a Linux Host

If packets are leaking from a host-only network on a Linux host system, packet forwarding might be mistakenly enabled on the host system. If packet forwarding is enabled, you must disable it.

How you disable packet forwarding depends on your Linux distribution. For example, you might be able to use a control panel, specify a setting at the time you compile your kernel, or enter a specification when you boot your system. See the operating system documentation for more information.
Procedure

- As root, write a 0 (zero) to the special file /proc/sys/net/ipv4/ip_forward.

```bash
echo "0" > /proc/sys/net/ipv4/ip_forward
```

Controlling Routing Information for Host-Only Networks on Linux

A host-only network has a network interface associated with it (vmnet1) that is marked up when the host operating system is booted. Routing server processes that operate on the host operating system automatically discover the host-only network and propagate information on how to reach the network, unless you explicitly configure them not to do so.

If you are running the routed or gated daemon only to receive routing information, the simplest solution is to run the routing configuration with the –q option so that the host-only network receives, but does not supply, routing information.

If you are running routing services to supply routing information, configure the services so that they do not advertise routes to the host-only network. The routed daemon version that is included with many Linux distributions does not support specifying that an interface should not be advertised. See the routed(8) manual page for your system for more information.

If you are using the gated daemon, you must explicitly exclude the vmnet1 interface from any protocol activity. If you need to run virtual machines on a host-only network on a multihomed system where gated is used and you experience problems, contact VMware technical support.

Using DHCP and DDNS with Host-Only Networking on Linux

The virtual DHCP server in Workstation Pro cannot update a DNS server by using a Dynamic Domain Name Service (DDNS). For this reason, you should use DHCP to supply IP addresses as well as other information, such as the identity of a host running a name server and the nearest router or gateway.

To use names to communicate with other virtual machines, you must either edit the DHCP configuration file for vmnet1 (/etc/vmware/vmnet1/dhcpd/dhcpd.conf), or use IP addresses that are statically bound to a host name. Editing the DHCP server configuration file requires information that is best obtained directly from the DHCP server documentation. See the dhcpd(8) and dhcpd.conf(8) manual pages.

**Note** The edits made inside the read-only section of the DHCP configuration file are lost the next time you run the virtual network editor.

Troubleshooting DHCPD Problems on a Linux Host

If a DHCP server (dhcppd) utility was running on the Linux host system before you installed Workstation Pro, it might have noticed that an additional network interface, vmnet1, was marked up and available for use when host-only networking was configured.

Some dhcppd implementations abort if their configuration files do not include a subnet specification for the interface. This can happen even if dhcppd is not supposed to respond to messages that arrive through the interface.

The best solution is to add a line to the dhcppd configuration file in the format

```bash
subnet net.0 netmask 255.255.255.0 {}
```

The net value is the network number assigned to the host-only network, for example, 192.168.0. This line in the configuration file informs dhcppd about the host-only network and tells it explicitly not to respond to any dhcppd requests arriving from that network.

An alternative solution is to explicitly state the set of network interfaces for dhcppd to monitor each time you start the program. For example, if the host system has one Ethernet interface (eth0), list the interface on the command line each time you start dhcppd.

```bash
dhcppd eth0
```
This solution prevents dhcpd from searching for all available network interfaces.

If these solutions do not work for your DHCP server program, it might be an older version of the program and you can try upgrading to more current version. DHCP server programs are available from the Internet Systems Consortium (ISC) Web site.

**Assigning IP Addresses in Host-Only Networks and NAT Configurations**

The host system and all virtual machines configured for host-only networking are connected to the network through a virtual switch. Typically, all the parties on this network use the TCP/IP protocol suite, although other communication protocols can be used.

A NAT configuration also sets up a private network, which must be a TCP/IP network. The virtual machines configured for NAT are connected to that network through a virtual switch. A host virtual network adapter connects the host system to the private network used for NAT. Each virtual machine and the host system must be assigned addresses on the private network.

When host-only networking is enabled at the time Workstation Pro is installed, the subnet IP address for the virtual network is automatically selected as an unused private subnet IP address. A NAT configuration also uses an unused private network automatically selected when you install Workstation Pro. The subnet number associated with a virtual network is shown in the virtual network editor.

IP addresses are typically assigned by using the virtual DHCP server included with Workstation Pro. IP addresses can also be assigned statically from a pool of addresses that the virtual DHCP server does not assign. Using DHCP to assign IP addresses is simpler and more automatic than statically assigning them. Most Windows operating systems are preconfigured to use DHCP at boot time, so Windows virtual machines can connect to the network the first time they are booted, without additional configuration.

If you want virtual machines to communicate with each other by using names instead of IP addresses, you must set up a naming convention, a name server on the private network, or both. In this case, it might be simpler to use static IP addresses.

In general, if you have virtual machines that you intend to use frequently or for extended periods of time, it is more convenient to assign static IP addresses or configure the virtual DHCP server to always assign the same IP address to each of these virtual machines. For temporary virtual machines, let the virtual DHCP allocate IP addresses.

**NOTE** The virtual DHCP server does not service virtual or physical machines residing on bridged networks.

- **Change DHCP Settings for a Host-Only or NAT Network on a Windows Host** on page 200
  You can use the virtual network editor to change DHCP settings for a host-only or NAT network on a Windows host system.

- **Change the Subnet Settings for a Host-Only or NAT Network on a Windows Host** on page 200
  You can use the virtual network editor to change the subnet IP address and subnet mask for a host-only or NAT network on a Windows host system.

- **Change the Subnet IP Address for a Host-Only or NAT Network on a Linux Host** on page 201
  You can use the virtual network editor to change the subnet IP address for a host-only or NAT network on a Linux host system.

- **DHCP Conventions for Assigning IP Addresses in Host-Only and NAT Networks** on page 202
  For each host-only or NAT network, the virtual DHCP server allocates available IP addresses by using certain conventions. Workstation Pro always uses a Class C address for host-only and NAT networks.
Change DHCP Settings for a Host-Only or NAT Network on a Windows Host

You can use the virtual network editor to change DHCP settings for a host-only or NAT network on a Windows host system.

**Prerequisites**

- Verify that you have administrative privileges on the host system.
- Familiarize yourself with the DHCP conventions for assigning IP addresses. See “DHCP Conventions for Assigning IP Addresses in Host-Only and NAT Networks,” on page 202.

**Procedure**

1. Log in to the host system as an Administrator user.
   
   Only an Administrator user can change network settings in the virtual network editor.

2. Select **Edit > Virtual Network Editor**.

3. Select the host-only or NAT network.

4. To use the virtual DHCP server to assign IP addresses to virtual machines on the network, select **Use local DHCP service to distribute IP addresses to VMs**.

5. To change additional DHCP settings, click **DHCP Settings**.
   
   You can change the range of IP addresses that the virtual DHCP server provides on the selected network and the duration of DHCP licenses that the DHCP server provides to clients on the virtual network.

6. Click **OK** to save your changes.

---

Change the Subnet Settings for a Host-Only or NAT Network on a Windows Host

You can use the virtual network editor to change the subnet IP address and subnet mask for a host-only or NAT network on a Windows host system.

The default subnet mask is 255.255.255.0, which is a Class C address. Typically, you should modify only the third number in the IP address, for example, x in 192.168.x.0 or 198.16.x.0. In general, do not change the subnet mask. Certain virtual network services might not work as well with a customized subnet mask.

When you modify the subnet mask, Workstation Pro updates the IP address settings for other components, including DHCP, NAT, and the host virtual network adapter, if the default settings were never changed. Settings that are automatically updated include the DHCP lease range and DHCP server address, the NAT gateway address, and the host network adapter IP address.

If you change any of these settings from their default values, Workstation Pro does not update that setting automatically if the value is within the valid range. If the value exceeds the valid range, Workstation Pro resets the settings based on the subnet range. Workstation Pro presumes that a custom setting should not be modified, even if you later change the setting back to its default value.

**Prerequisites**

- Verify that you have administrative privileges on the host system.
- Familiarize yourself with the DHCP conventions for assigning IP addresses. See “DHCP Conventions for Assigning IP Addresses in Host-Only and NAT Networks,” on page 202.
Procedure

1. Log in to the host system as an Administrator user.
   Only an Administrator user can change network settings in the virtual network editor on a Windows host system.

2. Select Edit > Virtual Network Editor.

3. Select the host-only or NAT network.

4. To change the subnet IP address, type a new value in the Subnet IP text box.
   The address should specify a valid network address that is suitable for use with the subnet mask.

5. To change the subnet mask, type a new value in the Subnet mask text box.

6. Click OK to save your changes.

Change the Subnet IP Address for a Host-Only or NAT Network on a Linux Host

You can use the virtual network editor to change the subnet IP address for a host-only or NAT network on a Linux host system.

You can also use the virtual network editor to specify that a local DHCP service distributes IP addresses to virtual machines. To change DHCP settings further, you must edit the DHCP server configuration file (dhcpd.conf). See “Editing the DHCP Server Configuration File,” on page 201.

Prerequisites

- Verify that you have root access on the host system.
- Familiarize yourself with the DHCP conventions for assigning IP addresses. See “DHCP Conventions for Assigning IP Addresses in Host-Only and NAT Networks,” on page 202.

Procedure

1. Log in to the Linux host system as root.
   You must enter the root password to use the virtual network editor on a Linux host system.

2. Select Applications > System Tools > Virtual Network Editor to start the virtual network editor.
   The menu path might be different for your version of Linux. You can also start the network editor from the command line by using the vmware-netcfg command.

3. Select the virtual network.

4. Change the subnet IP address.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an unused subnet IP address</td>
<td>Leave the Subnet IP text box empty.</td>
</tr>
<tr>
<td>Configure a specific subnet IP address</td>
<td>Type the subnet IP address that you want to use in the Subnet IP text box.</td>
</tr>
</tbody>
</table>

5. To have the virtual DHCP server distribute IP addresses to virtual machines on the network, select Use local DHCP service to distribute IP addresses to VMs.

6. Click Save to save your changes.

Editing the DHCP Server Configuration File

If you are an advanced user, you can edit the DHCP server configuration file to modify DHCP settings.

The location of the DHCP server configuration file depends on the operating system type.
Table 9-8. DHCP Configuration File Location

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>DHCP Server Configuration File Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, Windows 8, or Windows 10</td>
<td>C:\ProgramData\VMware\vmnetdhcp.conf</td>
</tr>
<tr>
<td>Linux</td>
<td>For the default host-only network: /etc/vmware/vmnet1/dhcp/dhcp.conf</td>
</tr>
<tr>
<td></td>
<td>For the NAT network: /etc/vmware/vmnet8/dhcp/dhcp.conf</td>
</tr>
</tbody>
</table>

On a Windows host system, you can change DHCP settings by using the virtual network editor. You do not need to edit the DHCP server configuration file.

On a Linux host system, you can use the virtual network editor to specify that a local DHCP service distributes IP addresses to virtual machines on the network. To change DHCP settings further, you must edit the DHCP server configuration file. Editing the DHCP server configuration file requires information that is best obtained directly from the DHCP server documentation. See the `dhcpd(8)` and `dhcpd.conf(8)` manual pages.

**Note** Changes made to the read-only section of the DHCP configuration file are lost the next time you run the virtual network editor.

**DHCP Conventions for Assigning IP Addresses in Host-Only and NAT Networks**

For each host-only or NAT network, the virtual DHCP server allocates available IP addresses by using certain conventions. Workstation Pro always uses a Class C address for host-only and NAT networks.

The `net` value is the network number assigned to the host-only or NAT network.

Table 9-9. IP Address Use on a Host-Only Network

<table>
<thead>
<tr>
<th>Range</th>
<th>Address Use</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>net.1</td>
<td>Host machine</td>
<td>192.168.0.1</td>
</tr>
<tr>
<td>net.2–net.127</td>
<td>Static addresses</td>
<td>192.168.0.2–192.168.0.127</td>
</tr>
<tr>
<td>net.128–net.253</td>
<td>DHCP-assigned</td>
<td>192.168.0.128–192.168.0.253</td>
</tr>
<tr>
<td>net.254</td>
<td>DHCP server</td>
<td>192.168.0.254</td>
</tr>
<tr>
<td>net.255</td>
<td>Broadcasting</td>
<td>192.168.0.255</td>
</tr>
</tbody>
</table>

Table 9-10. IP Address Use on a NAT Network

<table>
<thead>
<tr>
<th>Range</th>
<th>Address Use</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>net.1</td>
<td>Host machine</td>
<td>192.168.0.1</td>
</tr>
<tr>
<td>net.2</td>
<td>NAT device</td>
<td>192.168.0.2</td>
</tr>
<tr>
<td>net.3–net.127</td>
<td>Static addresses</td>
<td>192.168.0.3–192.168.0.127</td>
</tr>
<tr>
<td>net.128–net.253</td>
<td>DHCP-assigned</td>
<td>192.168.0.128–192.168.0.253</td>
</tr>
<tr>
<td>net.254</td>
<td>DHCP server</td>
<td>192.168.0.254</td>
</tr>
<tr>
<td>net.255</td>
<td>Broadcasting</td>
<td>192.168.0.255</td>
</tr>
</tbody>
</table>
Configuring LAN Segments

A LAN segment is a private network that is shared by other virtual machines. A LAN segment can be useful for multtier testing, network performance analysis, and situations where virtual machine isolation are important.

Create a LAN Segment for a Virtual Machine

You create a LAN segment by configuring virtual machine network settings. When you convert a team that was created in an earlier version of Workstation Pro, the LAN segment configuration is retained for each virtual machine. You do not need to recreate the LAN segment.

Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select **Network Adapter**.
3. Click **LAN Segments**.
4. Click **Add**, type a name for the LAN segment, and click **OK**.
5. Click **OK** to save your changes.

What to do next

Configure the virtual machine to use the LAN segment. See “Configure a Virtual Machine to Use a LAN Segment,” on page 203.

Configure a Virtual Machine to Use a LAN Segment

You can configure an existing virtual machine to use a LAN segment, and you can change the LAN segment that a virtual machine is currently using.

In this release of Workstation Pro, bandwidth and packet loss settings are associated with individual virtual machines rather than LAN segments. See “Configure Bandwidth and Packet Loss Settings for a Virtual Machine,” on page 180.

Prerequisites

- If the LAN segment does not already exist, create it. See “Create a LAN Segment for a Virtual Machine,” on page 203.
- To configure a virtual machine to use multiple LAN segments, you must configure the virtual machine to have multiple network adapters. See “Add a Virtual Network Adapter to a Virtual Machine,” on page 178.

Procedure

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select **Network Adapter**.
3. Select **LAN segment** and select the LAN segment from the drop-down menu.
4. Click **OK** to save your changes.
What to do next

When you add an existing virtual machine to a LAN segment, the virtual machine might be configured to expect an IP address from a DHCP server. Unlike host-only and NAT networking, Workstation Pro does not provide a DHCP server for LAN segments. You must manually configure IP addressing for virtual machines on a LAN segment. You can either configure a DHCP server on the LAN segment to allocate IP addresses, or you can configure a fixed IP address for each virtual machine on the LAN segment.

Delete a LAN Segment

Deleting a LAN segment disconnects all virtual network adapters that are configured for that LAN segment. When you delete a LAN segment, you must manually configure its disconnected virtual network adapter to reconnect the virtual machine to a network.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select Network Adapter.
3. Click LAN Segments, select the LAN segment, click Remove, and click OK.
4. Either select another LAN segment or change the network connection type for the virtual machine.
5. Click OK to save your changes.

What to do next

If you deleted a LAN segment that is being used by other virtual machines, select another LAN segment or change the network connection type for those virtual machines. See “Modify an Existing Virtual Network Adapter for a Virtual Machine,” on page 178.

Configuring Samba for Workstation Pro

If you have Samba on a Linux host system, you can configure it so that it works with Workstation Pro.

You must modify the Samba configuration so that it includes the IP subnet that the vmnet1 virtual network adapter uses. You can determine which subnet vmnet1 uses by using the command /sbin/ifconfig vmnet1.

You must also make sure the Samba password file includes entries for all users of the virtual machine who will access the host file system. The user names and passwords in the Samba password file must match those used for logging on to the guest operating system.

Add Users to the Samba Password File

You can add user names and passwords to the Samba password file at any time from a terminal window on the Linux host system. The Samba password file must include entries for all users of the virtual machine who will access the host file system.

Procedure

1. Log in to the root account.
2. Run the Samba password command with the user name to add to the password file.
   
   For example: smbpasswd -a user_name

3. Follow the instructions on the screen.
4. Log out of the root account.
Use a Samba Server for Bridged or Host-Only Networking

You can use a Samba server for bridged or host-only networking.

Procedure

1. Open the Samba configuration file (/etc/samba/smb.conf) in a text editor.
2. Add the interfaces parameter and set it to VMnet interface.
   
   You can define the interface parameter so that the Samba server serves multiple interfaces. This example tells the Samba server to monitor and use both the eth0 and vmnet1 interfaces, which are the networks that bridged and host-only networking use.
   
   For example: `interface = eth0 vmnet1`
3. Restart Samba.

Use Samba Without Network Access

You can make Samba inaccessible from the physical network interface.

Procedure

1. Open the Samba configuration file (/etc/samba/smb.conf) in a text editor.
2. Add the interfaces parameter and set it to `vmnet*`.
   
   For example: `interfaces = vmnet*`
3. Restart Samba.

Using Virtual Network Adapters in Promiscuous Mode on Linux Hosts

Workstation Pro does not allow the virtual network adapter to go into promiscuous mode unless the user running Workstation Pro has permission to make that setting. This restriction follows the standard Linux practice that only the root user can put a network interface into promiscuous mode.

When you install and configure Workstation Pro, you must run the installation as the root user. Because Workstation Pro creates the vmnet devices with root ownership and root group ownership, only the root user has read and write permissions to the devices.

To set a virtual machine network adapter to promiscuous mode, you must launch Workstation Pro as the root user because you must have read and write access to the vmnet device. For example, if you use bridged networking, you must have access to /dev/vmnet0.

To grant selected users read and write access to the vmnet device, you can create a new group, add the appropriate users to the group, and grant that group read and write access to the appropriate device. You must make these changes on the host operating system as the root user.

In this example, `newgroup` is the group that should be able to set vmnet0 to promiscuous mode.

```
chgrp newgroup /dev/vmnet0
chmod g+rw /dev/vmnet0
```

In the next example, all users are able to set vmnet0 to promiscuous mode.

```
chmod a+rw /dev/vmnet0
```
Maintaining and Changing MAC Addresses for Virtual Machines

When a virtual machine is powered on, Workstation Pro assigns each of its virtual network adapters an Ethernet media access control (MAC) address. A MAC address is the unique address assigned to each Ethernet network device.

A virtual machine is assigned the same MAC address every time it is powered unless the virtual machine configuration (.vmx) file is moved or changes are made to certain settings in the configuration file.

Moving the file to a different host system, or even moving it to a different location on the same host system, changes the MAC address.

The MAC address changes if you remove or change any of these options in the virtual machine configuration (.vmx) file.

- ethernet[n].generatedAddress
- ethernet[n].addressType
- ethernet[n].generatedAddressOffset
- uuid.location uuid.bios
- ethernet[n].present

In these options, [n] is the number of the virtual network adapter. If you never edit the configuration file by hand and do not remove the virtual network adapter, these settings remain unchanged.

Workstation Pro cannot guarantee to automatically assign unique MAC addresses for virtual machines that run on multiple host systems.

**Note** To preserve the MAC address for a virtual network adapter, you must be careful not to remove the adapter. If you remove the adapter but later recreate it, the adapter might receive a different MAC address.

Change the MAC Address for a Virtual Machine

You can use advanced virtual network adapter settings to assign a new MAC address to a virtual machine.

**Note** You cannot configure advanced virtual network adapter settings for a shared or remote virtual machine.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select the virtual network adapter and click **Advanced**.
3. Type a new MAC address in the **MAC Address** text box, or click **Generate** to have Workstation Pro generate a new address.
4. Click **OK** to save your changes.

Manually Assign a MAC Address to a Virtual Machine

You can manually assign a MAC address to a virtual machine.

You might want to assign a MAC address to guarantee that the same address is assigned to a virtual machine every time it powers on, even it is moved, or to be sure that a unique MAC address is provided for each virtual machine in a networked environment.
Procedure

1. Use a text editor to remove the following options from the virtual machine configuration (.vmx) file.
   - ethernet[n].generatedAddress
   - ethernet[n].addressType
   - ethernet[n].generatedAddressOffset

   In these options, \([n]\) is the number of the virtual network adapter.

2. Add the `ethernet[n].address` option to the .vmx file above the UUID lines in the file and set it to the MAC address.

   For example: `ethernet[n].address = 00:50:56:XX:YY:ZZ`

   In this line, the fourth pair of numbers, XX, must be a valid hexadecimal number between 00h and 3Fh, and YY and ZZ must be valid hexadecimal numbers between 00h and FFh. You must use this format. Workstation Pro virtual machines do not support arbitrary MAC addresses.

   A value for XX:YY:ZZ that is unique among your hard-coded addresses avoids conflicts between the automatically assigned MAC addresses and the manually assigned addresses.

Sample Custom Networking Configuration

There are many ways to combine devices on a virtual network. This example shows server connections through multiple firewalls.

You can combine devices on a virtual network in many ways. In this example, a Web server connects through a firewall to an external network and an administrator’s computer connects to the Web server through a second firewall.

Figure 9-4. Custom Configuration with Two Firewalls
Create the Sample Custom Networking Configuration

You can create the sample custom networking configuration.

Prerequisites

- Familiarize yourself with how to create virtual machines and configure network devices in the host and guest operating systems.
- Familiarize yourself with the diagram of the sample networking configuration. See Figure 9-4.

Procedure

1. Use the New Virtual Machine wizard to create four virtual machines.
   a. Create the first virtual machine with bridged networking so that it can connect to an external network by using the host network adapter.
   b. Create the other three virtual machines without networking.

2. Configure network settings for the first virtual machine.
   a. Open the first virtual machine, but do not power it on.
   b. Edit the virtual machine settings to add a second virtual network adapter.
   c. Connect the second network adapter to VMnet2.

3. Configure network settings for the second virtual machine.
   a. Open the virtual machine, but do not power it on.
   b. Edit the virtual machine settings to add a virtual network adapter.
   c. Connect the network adapter to VMnet2.

4. Configure network settings for the third virtual machine.
   a. Open the virtual machine, but do not power it on.
   b. Edit the virtual machine settings to add a virtual network adapter.
   c. Connect the network adapter to VMnet2.
   d. Edit the virtual machine settings to add a second virtual network adapter.
   e. Connect the second network adapter to VMnet3.

5. Configure network settings for the fourth virtual machine.
   a. Open the virtual machine, but do not power it on.
   b. Edit the virtual machine settings to add a virtual network adapter.
   c. Connect the network adapter to VMnet3.

6. Determine the network addresses that are used for VMnet2 and VMnet3.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Use the ipconfig /all command.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Use the ifconfig command.</td>
</tr>
</tbody>
</table>

7. Power on each virtual machine and install the appropriate guest operating system.

8. Use the virtual network editor to configure VMnet2 to use the virtual DHCP service to distribute IP address to virtual machines.
9 Configure the networking in each guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual machine 1</td>
<td>For the bridged network adapter in virtual machine 1, use the networking settings needed for a connection to the external network. If the virtual machine receives its IP address from a DHCP server on the external network, the default settings should work. For the second network adapter in virtual machine 1, manually assign an IP address in the range you are using with VMnet2.</td>
</tr>
<tr>
<td>Virtual machine 2</td>
<td>Assign an IP address in the range you are using with VMnet2.</td>
</tr>
<tr>
<td>Virtual machine 3</td>
<td>Network adapters are connected to VMnet2 and VMnet3. Assign an IP address in the virtual network’s range it is connected to.</td>
</tr>
<tr>
<td>Virtual machine 4</td>
<td>Assign an IP address in the range you are using with VMnet3.</td>
</tr>
</tbody>
</table>

10 Install the necessary application software in each virtual machine.
Using Remote Connections and Sharing Virtual Machines

A shared virtual machine is a virtual machine on the host system that remote Workstation Pro users can access as a remote virtual machine. Up to 100 remote users can connect to a single shared virtual machine at the same time.

You can configure Workstation Pro so that users on remote Workstation Pro hosts can interact with your local host and use the shared virtual machines that are running on it. You can also connect to remote hosts and run remote virtual machines. You control who can access host systems and shared virtual machines by setting permissions.

This chapter includes the following topics:

- “Understanding VMware Workstation Server,” on page 211
- “Connect to a Remote Server,” on page 214
- “Disconnect from a Remote Server,” on page 216
- “Creating and Managing Shared Virtual Machines,” on page 216
- “Uploading Virtual Machines to Remote Servers,” on page 219
- “Download a Virtual Machine from a Remote Server,” on page 221
- “Create a Virtual Machine on a Remote Host,” on page 222
- “Configure Shared and Remote Virtual Machines to Start with the Host,” on page 223
- “Using Roles to Assign Privileges,” on page 224
- “Using Permissions to Restrict Users,” on page 227

Understanding VMware Workstation Server

VMware Workstation Server is a service that runs on the Workstation Pro host system. Remote Workstation Pro users connect to VMware Workstation Server when they run shared virtual machines on the host system.

On a Windows host, VMware Workstation Server is the VMware Workstation Server service. On a Linux host, it is vmware-workstation-server.

When you install Workstation Pro, virtual machine sharing and remote access are enabled by default and VMware Workstation Server starts when the host system starts. When Workstation Pro starts, it connects to VMware Workstation Server by using the credentials of the currently logged in user.

Remote Workstation Pro users connect to VMware Workstation Server through HTTPS port 443 on the host system. You can change the VMware Workstation Server port when you install Workstation Pro and after Workstation Pro is installed by modifying the Shared VMs Workstation Pro preference.
Shared virtual machines appear under the **Shared VMs** item in the virtual machine library. If virtual machine sharing is disabled, or if the current user does not have permissions to connect to VMware Workstation Server, the **Shared VMs** item is inactive.

If you click the **Shared VMs** item when virtual machine sharing is disabled, Workstation Pro returns a message that explains how to enable virtual machine sharing. If the **Shared VMs** item is inactive because the current user does not have the proper permissions, a login dialog box appears and you can log in as a user who can connect to VMware Workstation Server.

**Configure Virtual Machine Sharing and Remote Access**

You can enable or disable virtual machine sharing and remote access, change the HTTPS port that VMware Workstation Server uses on the host system, and change the shared virtual machines directory.

When you enable virtual machine sharing and remote access, Workstation Pro starts VMware Workstation Server and configures the service to start with the host system.

When you disable virtual machine sharing and remote access, Workstation Pro disables virtual machine sharing and stops VMware Workstation Server. You cannot create shared virtual machines and remote users cannot connect to the host system.

You must disable virtual machine sharing and remote access before you can change the HTTPS port that VMware Workstation Server uses.

**Prerequisites**

- On a Linux host, verify that you have root access.
- On a Windows host, verify that you have administrative privileges.
- If you plan to change the shared virtual machines directory, stop sharing virtual machines on the host system. You cannot change the shared virtual machines directory if there are shared virtual machines on the host system. See “Stop Sharing a Virtual Machine,” on page 219.

**Procedure**

1. Select **Edit > Preferences > Shared VMs**.

2. To enable or disable virtual machine sharing and remote access, click **Enable Sharing** or **Disable Sharing** (Windows host), or select or deselect **Enable virtual machine sharing and remote access** (Linux host).

3. To change the HTTPS port that VMware Workstation Server uses on the host system, select a different port from the drop-down menu.

   **Note** If you change the port to a non-default value, remote users must specify the port number when they connect to the host system, for example, `host:port`.

4. To change the shared virtual machines directory, type or browse to the location of the new shared virtual machines directory (Windows host), or type the new directory in the text box and click **Apply** (Linux host).

5. Click **OK** to save your changes.
Replace the Default Certificate for VMware Workstation Server

VMware Workstation Server generates a self-signed certificate. This certificate is sufficient for encryption, but it does not provide identity verification. For increased security, you should replace the default certificate with a certificate that is signed by a commercial Certificate Authority (CA).

Prerequisites

Obtain a signed certificate. Obtaining a signed certificate involves creating a certificate signing request (CSR) and sending it to a CA in accordance with the CA’s enrollment process. After conducting some checks on your company, the CA signs your request, encrypts it with a private key, and sends you a validated certificate. See the instructions provided by the CA for more information.

Procedure

1. On the host system, replace the default certificate text in the VMware SSL certificate file with the certificate text that you obtained from the CA.

   The location of the certificate file depends on the host operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Certificate File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, Windows 8, and Windows 10 hosts</td>
<td>C:\ProgramData\VMware\SSL\rui.crt</td>
</tr>
<tr>
<td>Linux hosts</td>
<td>/etc/vmware/ssl/rui.crt</td>
</tr>
</tbody>
</table>

   Note: You can access the SSL directory only from an elevated command prompt.

2. On the host system, replace the default private key text in the VMware SSL key file with the private key text that you obtained from the CA.

   The location of the key file depends on the host operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Certificate File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, Windows 8, and Windows 10 hosts</td>
<td>C:\ProgramData\VMware\SSL\rui.key</td>
</tr>
<tr>
<td>Linux hosts</td>
<td>/etc/vmware/ssl/rui.key</td>
</tr>
</tbody>
</table>

   Note: You can access the SSL directory only from an elevated command prompt.

3. Restart the host system.

   The VMware Workstation Server service restarts and begins using the new certificate.

Shared Virtual Machines Directory

Workstation Pro stores shared virtual machines in the shared virtual machines directory, where VMware Workstation Server manages them.

The default location of the shared virtual machines directory depends on the host operating system.

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>Default Shared Virtual Machines Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2</td>
<td>C:\Documents and Settings\All Users\Documents\Shared Virtual Machines</td>
</tr>
<tr>
<td>Windows 7, Windows 8, Windows 10</td>
<td>C:\Users\Public\Documents\Shared Virtual Machines</td>
</tr>
<tr>
<td>Linux</td>
<td>/var/lib/vmware/Shared VMs</td>
</tr>
</tbody>
</table>

Chapter 10 Using Remote Connections and Sharing Virtual Machines   VMware, Inc.  213
VMware Workstation Server Log Files

VMware Workstation Server saves messages in log files. Refer to these log files if you need to audit or troubleshoot a problem with remote access or remote authorization.

Table 10-2. Workstation Server Log Files

<table>
<thead>
<tr>
<th>Host System</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2008 R2, Windows Server 2012 R2, Windows 7, Windows 8, and Windows 10 hosts</td>
<td>C:\ProgramData\VMware\hostd\hostd-n.log</td>
</tr>
<tr>
<td>Linux hosts</td>
<td>/var/log/vmware/hostd-n.log</td>
</tr>
</tbody>
</table>

On Linux hosts, security-related information, such as authorization attempts, is sent to the system messages log.

Connect to a Remote Server

You can use Workstation Pro to connect to a remote server that is running Workstation Pro, ESX, ESXi, or vCenter Server.

When you connect to a remote server for the first time, Workstation Pro asks you whether to save your login information. You can configure Workstation Pro to never ask you to save login information for a remote server. See “Disable the Prompt to Save Remote Login Information,” on page 215.

Prerequisites

Verify that the remote server is running Workstation 8.x or later, or ESX, ESXi, or vCenter Server 4.1 or later.

Procedure

1. Select File > Connect to Server.
2. Type the host name or IP address, your user name and password, and click Connect.

   If the VMware Workstation Server service running on the remote server is not using the default port, you must specify the port number, for example, remotehost:444. The VMware Workstation Server service uses port 443 by default.

3. (Optional) If Workstation Pro asks you whether to save your login information, select an option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remember</td>
<td>Workstation Pro saves your login information so that you do not need to provide it the next time you log in to the server.</td>
</tr>
<tr>
<td>Never for this Host</td>
<td>Workstation Pro saves the server name to an exceptions list and does not prompt you to save your login information for this server again.</td>
</tr>
<tr>
<td>Not Now</td>
<td>Workstation Pro does not save your login information, but it prompts you to save your login information the next time you connect to this server.</td>
</tr>
</tbody>
</table>

After you are connected to the remote server, the remote host and remote virtual machines appear in the library.

What to do next

Interact with the remote host and remote virtual machines.
Interacting with Remote Hosts and Virtual Machines

After you connect to a remote server, the remote host and remote virtual machines appear in the library. If the remote server is running vCenter Server, datacenters and folders appear in the library.

To interact with a remote host, you select it in the library. The tasks that you can perform on a remote host appear on the tab for the remote host. For example, you might be able to restart, shut down, or suspend the remote host and create virtual machines.

To interact with a remote virtual machine, you select it in the library. You interact with remote virtual machines in the same way that you interact with local virtual machines, but some features and devices are not supported. Features that you cannot use with remote virtual machines include Unity mode, shared folders, AutoProtect snapshots, drag-and-drop, and copy and paste.

Your permissions determine the actions that you can perform on remote hosts and remote virtual machines. When a feature is not supported, or when you do not have permission to use it, the associated menu item is unavailable.

Disable the Prompt to Save Remote Login Information

You can disable the prompt to save remote login information for a specific remote server or for all remote servers.

Procedure

- Disable the prompt to save login information for a specific remote server.
  a Log in to the remote server for the first time.
  b Select Never for this Host.
  Workstation Pro saves the name of the remote server to an exceptions list. You must type login information the next time you connect to the remote server.

- Disable the prompt to save login information for all remote servers.
  a Select Edit > Preference > Workspace.
  b Deselect Offer to save login information for remote hosts.
  c Click OK to save your changes.
  You must type login information every time you connect to a remote server.

Remove Saved Login and Exception Information for Remote Servers

You can remove the login information that Workstation Pro saves for a remote server. You might need to remove saved login information if the user name or password changes for a remote server. You can also remove a remote server from the exceptions list.

Workstation Pro adds a remote server to the exceptions list when you select Never for this Host the first time you log in to the remote server. If you subsequently want Workstation Pro to prompt you to save login information for that remote server, you must remove the remote server from the exceptions list.
Procedure

1. Select **Edit > Preferences**, select **Workspace**, and click **Show Saved Login Information**.

   The **Saved Passwords** tab shows the saved user names. The remote servers for which Workstation Pro does not prompt you to save login information appear on the **Exceptions** tab.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove saved login information for a specific remote server</td>
<td>On the <strong>Saved Passwords</strong> tab, select the remote server and click <strong>Remove</strong>. You must type login information the next time you connect to that remote server.</td>
</tr>
<tr>
<td>Remove all saved login information</td>
<td>On the <strong>Saved Passwords</strong> tab, click <strong>Remove All</strong>. You must type login information the next time you connect to any remote server.</td>
</tr>
<tr>
<td>Remove a remote server from the exceptions list</td>
<td>On the <strong>Exceptions</strong> tab, select the remote server and click <strong>Remove</strong>. Workstation Pro prompts you to save login information the next time you connect to the remote server.</td>
</tr>
<tr>
<td>Remove all remote servers from the exceptions list</td>
<td>On the <strong>Exceptions</strong> tab, click <strong>Remove All</strong> (Windows host) or <strong>Clear</strong> (Linux host). Workstation Pro prompts you to save login information the next time you connect to any remote server.</td>
</tr>
</tbody>
</table>

2. Click **Close** to close the dialog box and click **OK** to save your changes.

Disconnect from a Remote Server

When you disconnect from a remote server, the remote virtual machines no longer appear in the library.

**Procedure**

- On a Windows host, right-click the remote host in the library and select **Disconnect**.
- On a Linux host, select the remote host in the library and click **Disconnect From This Server** on the tab for the remote host.

Creating and Managing Shared Virtual Machines

A shared virtual machine is a virtual machine on the host system that remote Workstation Pro users can access as a remote virtual machine. You can create a new shared virtual machine, convert a standard virtual machine to a shared virtual machine, or create a shared virtual machine clone of a standard virtual machine.

You can configure specific shared virtual machines to start when the host system starts, and you can view status and task information for shared virtual machines.

Workstation Pro stores shared virtual machines in the shared virtual machines directory, where VMware Workstation Server manages them. Shared virtual machines appear in the virtual machine library under the **Shared VMs** item.

- **Convert or Clone a Standard Virtual Machine to a Shared Virtual Machine** on page 217
  
  You can convert a standard virtual machine to a shared virtual machine or create a shared virtual machine by creating a clone of a standard virtual machine. Workstation Pro stores shared virtual machines in the shared virtual machines directory.

- **Create a New Shared Virtual Machine** on page 217
  
  You can create a new shared virtual machine in Workstation Pro by using the New Virtual Machine wizard. Creating a shared virtual machine is similar to creating a standard virtual machine.

- **Stop Sharing a Virtual Machine** on page 219
  
  When you stop sharing a virtual machine, Workstation Pro changes the shared virtual machine to a standard virtual machine.
View the Status of Shared and Remote Virtual Machines on page 219
You can view power status and task information for shared virtual machines, and you can view the power status of remote virtual machines. Tasks are operations that can affect the use of a virtual machine, such as power state changes and changes to virtual machine settings.

Convert or Clone a Standard Virtual Machine to a Shared Virtual Machine
You can convert a standard virtual machine to a shared virtual machine or create a shared virtual machine by creating a clone of a standard virtual machine. Workstation Pro stores shared virtual machines in the shared virtual machines directory.

Prerequisites
- Verify that the virtual machine is not encrypted.
- Verify that the virtual machine is not configured to use a physical disk.
- Power off the virtual machine.

Procedure
1. Select the virtual machine and select VM > Manage > Share, or drag the virtual machine to the Shared VMs item.
2. Type a name for the shared virtual machine.
3. Select how to create the shared virtual machine.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the virtual machine</td>
<td>Convert the standard virtual machine to a shared virtual machine. Workstation Pro moves the virtual machine files to the shared virtual machines directory. If you decide to prevent remote access to virtual machine at a later time, you can change the virtual machine back to a standard virtual machine.</td>
</tr>
<tr>
<td>Make a full clone of the virtual machine</td>
<td>Create a shared virtual machine by cloning the virtual machine. Workstation Pro creates the clone in the shared virtual machines directory. The clone is a complete and independent copy of the virtual machine and additional disk space is required to store it.</td>
</tr>
</tbody>
</table>
4. Click Finish to share the virtual machine and click Close to exit the wizard.

A clone can take several minutes to create, depending on the size of the virtual disk that is being duplicated.

If you converted a standard virtual machine to a shared virtual machine, the virtual machine appears under the Shared VMs item in the library. If you cloned a standard virtual machine, the clone appears under the Shared VMs item and the original virtual machine remains under My Computer.

What to do next
If the virtual machine uses a static IP address, change it after cloning a standard virtual machine to a shared virtual machine.

Create a New Shared Virtual Machine
You can create a new shared virtual machine in Workstation Pro by using the New Virtual Machine wizard. Creating a shared virtual machine is similar to creating a standard virtual machine.

Prerequisites
- Verify that you have the information the New Virtual Machine wizard requires to create a virtual machine. See “Preparing to Create a New Virtual Machine,” on page 40.
Verify that the guest operating system you plan to install is supported. See the VMware Compatibility Guide on the VMware Web site for a list of the supported guest operating systems.

See the VMware Guest Operating System Installation Guide for information about the guest operating system that you plan to install.

If you are installing the guest operating system from an installer disc, insert the installer disc in the CD-ROM drive in the host system.

If you are installing the guest operating system from an ISO image file, verify that the ISO image file is in a directory that is accessible to the host system.

Procedure

1. In the library, select Shared VMs.
2. On the Shared VMs tab, click Create a New Virtual Machine.
3. On the Welcome screen, select the configuration type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical</td>
<td>The wizard prompts you to specify or accept defaults for basic virtual machine settings. The typical configuration type is appropriate in most instances. After specifying an operating system version and virtual machine name and location, the wizard prompts you to configure only the virtual disk size and whether the disk should be split into multiple files. If you choose a custom setup, the wizard includes additional prompts for such things as processors, memory, and networking.</td>
</tr>
<tr>
<td>Custom</td>
<td>You must select the custom configuration type to make a different virtual machine version than the default hardware compatibility setting, specify the I/O adapter type for SCSI adapters, specify whether to create an IDE, SCSI, or SATA virtual disk, use an existing virtual disk, or allocate all virtual disk space rather than let disk space gradually grow to the maximum disk size.</td>
</tr>
</tbody>
</table>

4. If you selected a custom configuration, select the hardware compatibility setting for the virtual machine. The hardware compatibility setting determines the hardware features of the virtual machine.
5. Follow the prompts to select a guest operating system and name and configure the virtual machine.
   Use the following guidelines:
   - The Easy Install feature is not available for installing operating systems in shared or remote virtual machines.
   - If you choose to install the operating system later, the virtual machine is created with a blank disk.
6. (Optional) Click Customize Hardware to customize the hardware configuration.
   You can also modify virtual hardware settings after you create the virtual machine.
7. (Optional) Select Power on this virtual machine after creation to power on the virtual machine after you create it.
   This option is not available if you are installing the guest operating system manually.
8. Click Finish to create the virtual machine.

If you are using Easy Install, guest operating system installation begins when the virtual machine powers on. The guest operating system installation is automated and typically runs without requiring any input from you. After the guest operating system is installed, Easy Install installs VMware Tools.

Newly created shared virtual machines appear in the library under the Shared VMs item.
What to do next

If you used Easy Install and the virtual machine did not power on when you finished the New Virtual Machine wizard, power on the virtual machine to start the guest operating system installation. See “Use Easy Install to Install a Guest Operating System,” on page 51.

If you did not use Easy Install, install the guest operating system manually. See “Install a Guest Operating System Manually,” on page 52.

Stop Sharing a Virtual Machine

When you stop sharing a virtual machine, Workstation Pro changes the shared virtual machine to a standard virtual machine.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the shared virtual machine and select VM > Manage > Stop Sharing, or drag the virtual machine from under the Shared VMs item and drop it on My Computer.
2. Type or browse to the new location for the virtual machine.
3. Click Finish to stop sharing the virtual machine and click Close to exit the wizard.

The virtual machine no longer appears on the Shared VMs tab.

View the Status of Shared and Remote Virtual Machines

You can view power status and task information for shared virtual machines, and you can view the power status of remote virtual machines. Tasks are operations that can affect the use of a virtual machine, such as power state changes and changes to virtual machine settings.

Prerequisites

To view the power status of remote virtual machines, connect to the remote server. See “Connect to a Remote Server,” on page 214.

Procedure

- To view power status and task information for shared virtual machines, select Shared VMs and select the list view on the Shared VMs tab.
  
  Power status and task information appears on the Shared VMs tab for each shared virtual machine.

- To view the power status of remote virtual machines, select the remote host and select the list view on the tab for the remote host.

  The power status of each virtual machine on the remote host appears on the tab.

Uploading Virtual Machines to Remote Servers

You can upload virtual machines created with Workstation Pro to remote servers running other VMware products.

You can upload virtual machines to remote servers running VMware ESXi or VMware vCenter Server, or to VMware vCloud Air OnDemand.

- Upload a Virtual Machine to a Remote Server on page 220

  When you upload a virtual machine to a remote server, Workstation Pro copies the virtual machine to the remote host and datastore that you select. The original virtual machine remains on the host system.
Upload a Virtual Machine to VMware vCloud Air on page 221

When you upload a virtual machine to VMware® vCloud® Air™, Workstation Pro copies the virtual machine to the VMware vCloud Air server and the virtual data center that you select. The original virtual machine remains on the host system.

Upload a Virtual Machine to a Remote Server

When you upload a virtual machine to a remote server, Workstation Pro copies the virtual machine to the remote host and datastore that you select. The original virtual machine remains on the host system.

Prerequisites

- Verify that the remote server is running VMware Workstation Pro, VMware ESXi or VMware vCenter Server.
- Verify that the virtual machine is not encrypted. You cannot upload an encrypted virtual machine.
- Verify that the remote host supports the hardware version of the virtual machine. If the remote host does not support the hardware version, the upload wizard returns an error message.
- Open the virtual machine in Workstation Pro.
- If the virtual machine is powered on or suspended, power it off.

Procedure

1. Select the virtual machine and select **VM > Manage > Upload**.

   **Note** You can also start the upload process by dragging and dropping the virtual machine to the remote host in the library.

2. Select the destination remote server.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>The remote server appears in the list</td>
<td>Select the remote server in the list.</td>
</tr>
<tr>
<td>The remote server does not appear in the list</td>
<td>Select <strong>New Server Connection</strong> and log in to the remote server.</td>
</tr>
</tbody>
</table>

   Workstation Pro verifies the connection to the remote server.

3. If the remote server is running vCenter Server, select a destination location.

4. (Optional) Type a new name for the virtual machine on the remote host.

5. Select a remote host and datastore to store the uploaded virtual machine.
   - If the remote server is running vCenter Server, multiple hosts and datastores might be available.

6. Click **Finish** to upload the virtual machine to the remote server.

   A status bar indicates the progress of the upload process. How long it takes to upload a virtual machine depends on the size of the virtual disk and the network connection speed.

After the virtual machine is uploaded to the remote server, it appears in the inventory for the remote host in the library.
Upload a Virtual Machine to VMware vCloud Air

When you upload a virtual machine to VMware vCloud Air, Workstation Pro copies the virtual machine to the VMware vCloud Air server and the virtual data center that you select. The original virtual machine remains on the host system.

Prerequisites
- Verify that the virtual machine is not encrypted. You cannot upload an encrypted virtual machine.
- Verify that the remote host supports the hardware version of the virtual machine. If the remote host does not support the hardware version, you receive an error message.
- Verify that the virtual machine is turned off.
- Verify that you have login credentials for VMware vCloud Air.

For more information about VMware vCloud Air, see the vCloud Air - Virtual Private Cloud OnDemand User’s Guide.

Procedure
1. Select a virtual machine to upload to VMware vCloud Air.
2. Select VM > Manage > Upload.
3. Select VMware vCloud Air and click Next.
4. Enter your user name and password for the server and click Next.
5. Type a new name for the virtual machine.
6. Select a virtual data center to store the uploaded virtual machine.
7. Click Finish to upload the virtual machine to the virtual data center.

Download a Virtual Machine from a Remote Server

When you download a virtual machine from a remote server, Workstation Pro copies the virtual machine from the remote host and datastore. The original virtual machine remains on the host system, and a copy is created on the Workstation Pro host in the location you specify.

This feature is available for virtual machines on remote servers. It is not available for shared virtual machines or standard virtual machines on Workstation Pro hosts.

Prerequisites
- Connect to the remote server that hosts the virtual machine you want to download. See “Connect to a Remote Server,” on page 214.
- Verify that the remote server is running ESX, ESXi, or vCenter Server 4.1 or later.
- If the virtual machine is powered on or suspended, power it off.

Procedure
1. Select the virtual machine on the remote server and select VM > Manage > Download.

   Note: You can also start the download process by dragging the virtual machine from the remote host into the My Computer portion of the Workstation Pro library or into any sub-folder of My Computer in the library.

2. In the Download Virtual Machine dialog box that appears, type a name for the virtual machine, type or browse to the directory for the virtual machine files, and click Download.
Create a Virtual Machine on a Remote Host

When you are connected to a remote server, you can create a remote virtual machine. Creating a remote virtual machine is similar to creating a virtual machine on the local host, but Easy install is not supported and you must install the guest operating system manually.

When you select a typical configuration, the New Virtual Machine wizard uses the default hardware version configured in the Workstation Pro preferences, unless the remote host does not support that version. If the remote host does not support the default hardware version, the wizard uses the latest hardware version that is supported on the remote host.

Prerequisites

- Connect to the remote server. See “Connect to a Remote Server,” on page 214.
- Verify that you have permission to create a virtual machine on the remote host.
- Verify that you have the information the New Virtual Machine wizard requires to create a virtual machine. See “Preparing to Create a New Virtual Machine,” on page 40.

Procedure


<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Select File &gt; New Virtual Machine and select the remote host from the menu, or click New Virtual Machine on the tab for the remote host.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Click Create a New Virtual Machine on the tab for the remote host.</td>
</tr>
</tbody>
</table>

2. On the Welcome screen, select the configuration type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical</td>
<td>The wizard prompts you to specify or accept defaults for basic virtual machine settings. The typical configuration type is appropriate in most instances. After specifying an operating system version and virtual machine name and location, the wizard prompts you to configure only the virtual disk size and whether the disk should be split into multiple files. If you choose a custom setup, the wizard includes additional prompts for such things as processors, memory, and networking.</td>
</tr>
<tr>
<td>Custom</td>
<td>You must select the custom configuration type to make a different virtual machine version than the default hardware compatibility setting, specify the I/O adapter type for SCSI adapters, specify whether to create an IDE, SCSI, or SATA virtual disk, use an existing virtual disk, or allocate all virtual disk space rather than let disk space gradually grow to the maximum disk size.</td>
</tr>
</tbody>
</table>

3. If the remote server running is ESX or ESXi and it has multiple datastores, select a datastore to store the virtual machine.

4. If the remote server is running vCenter Server, select an inventory location, a remote host, and a datastore to store the virtual machine.

   The inventory location can be a datacenter or a folder within a datacenter. You must select a datastore only if the remote host has multiple datastores.

5. If you selected a custom configuration, select the hardware compatibility setting for the virtual machine.

   The hardware compatibility setting determines the hardware features of the virtual machine.
6 Select the guest operating system type and version, or select Other if the guest operating system is not listed.

7 Type a name for the virtual machine.

8 Follow the prompts to select a guest operating system and name and configure the virtual machine.

   Use the following guidelines:
   - The Easy Install feature is not available for installing operating systems in shared or remote virtual machines.
   - If you choose to install the operating system later, the virtual machine is created with a blank disk.

9 Click Finish to create the virtual machine.

The virtual machine appears in the library under the remote host.

**What to do next**

Install the guest operating system manually. See “Install a Guest Operating System Manually,” on page 52.

**Configure Shared and Remote Virtual Machines to Start with the Host**

You can use the AutoStart feature to configure shared virtual machines to start when the local host system starts. You can also configure remote virtual machines to start when the remote host system starts.

You cannot configure AutoStart if the remote server is running vCenter Server. You cannot use the AutoStart feature to configure virtual machines to start in a preferred sequence. You can use the VMware vSphere Client to configure more advanced features, including startup order. See the vSphere virtual machine administration documentation.

**Prerequisites**

- If you are configuring AutoStart for remote virtual machines, connect to the remote server. See “Connect to a Remote Server,” on page 214.

- Verify that you have the Administrator role or a custom role that contains the Host.Configuration.Virtual machine autostart configuration privilege.

**Procedure**

1 Select the location of the virtual machines.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>The virtual machines are on the local host</td>
<td>a In the library, select Shared VMs.</td>
</tr>
<tr>
<td></td>
<td>b On the Shared VMs tab, click Manage Autostart VMs.</td>
</tr>
<tr>
<td>The virtual machines are on a remote host</td>
<td>a In the library, select the remote host.</td>
</tr>
<tr>
<td></td>
<td>b On the tab for the remote host, Manage Autostart VMs.</td>
</tr>
</tbody>
</table>

2 Select the virtual machines to start with the host system.

3 If you selected multiple virtual machines, select the number of seconds to delay between starting the virtual machines.

4 Click Save to save your changes.
Using Roles to Assign Privileges

A role is a predefined set of privileges. Privileges define individual rights that a user requires to perform actions and read properties. Workstation Pro includes a default set of system roles. You can also create your own roles.

A single user might have different roles for different objects. For example, if you have two shared virtual machines, virtual machine A and virtual machine B, you might assign a particular user the Administrator role on virtual machine A and the Read Only permission on virtual machine B.

- **Default System Roles** on page 224
  Workstation Pro provides a set of default system roles. You can use the default system roles to assign permissions, or you can use them as a model to create your own roles.

- **Create a Role** on page 225
  If the default system roles do not meet your needs, you can combine selected privileges to create your own roles.

- **Edit a Role** on page 225
  You can change the name of a role. You can add or remove the privileges in a role. You cannot edit the default system roles.

- **Clone a Role** on page 226
  You can make a copy of an existing role by cloning it. When you clone a role, the new role is not applied to users, groups, or objects. You must assign the role to users or groups and objects.

- **Remove a Role** on page 227
  When you remove a role, Workstation Pro removes the definition from the list of roles.

Default System Roles

Workstation Pro provides a set of default system roles. You can use the default system roles to assign permissions, or you can use them as a model to create your own roles.

The default system roles are permanent. You cannot edit the privileges associated with these roles.

Table 10-3. Default System Roles

<table>
<thead>
<tr>
<th>Role</th>
<th>User Capabilities</th>
</tr>
</thead>
</table>
| **Administrator** | ■ Has all privileges for all objects.  
                                 ■ Can add, remove, and set access rights and privileges on all objects.  
                                 Default role for members of the Administrators group on Windows hosts and the root user on Linux hosts. |
| **No Access** | ■ Cannot view or change the associated object.  
                                 ■ Tabs associated with the object appear without content.  
                                 Except for users in the Administrators group on Windows hosts and the root user on Linux hosts, this is the default role for all users. |
| **Read Only** | ■ Can view the object state and details about the object.  
                                 ■ Cannot perform any actions through the menus and toolbars. |
| **VM Creator** | Can create, use, configure, and delete virtual machines. |
| **VM User** | Can configure and use existing virtual machines. |
**Create a Role**

If the default system roles do not meet your needs, you can combine selected privileges to create your own roles.

Privileges define individual rights that a user requires to perform actions and read properties. The privileges that you can select when you create a role depend on whether the server is running Workstation Pro, ESX, ESXi, or vCenter Server.


**Prerequisites**

If you are creating a role on a remote host, connect to the remote server. See “Connect to a Remote Server,” on page 214.

**Procedure**

1. Open the Edit Roles dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Create a role on the local host | (Windows host) Right-click *Shared VMs* and select *Roles.*  
|                               | (Linux host) Right-click *Shared VMs* and select *Edit Roles.*               |
| Create a role on a remote host | (Windows host) Right-click the remote host and select *Roles.*              |
|                               | (Linux host) Right-click the remote host and select *Edit Roles.*           |

2. Click **Add**.

3. Type a name for the new role.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Replace the name of the role in the Roles list.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Type a new name in the <em>Name</em> text box.</td>
</tr>
</tbody>
</table>

4. From the privileges tree, select the privileges to include in the new role.

You can expand the tree to view the privileges in each category.

5. Click **OK** (Windows host) or **Save** (Linux host) to create the new role.

**Edit a Role**

You can change the name of a role. You can add or remove the privileges in a role. You cannot edit the default system roles.

When you change the privileges in a role, the changes are applied to any user or group that is assigned that role. When you change the name of a role, no changes occur to the role’s assignments.


**Prerequisites**

If you are editing a role on a remote host, connect to the remote server. See “Connect to a Remote Server,” on page 214.
Procedure

1 Open the Edit Roles dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit a role on the local host</td>
<td>(Windows host) Right-click Shared VMs and select Roles.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Right-click Shared VMs and select Edit Roles.</td>
</tr>
<tr>
<td>Edit a role on a remote host</td>
<td>(Windows host) Right-click the remote host and select Roles.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Right-click the remote host and select Edit Roles.</td>
</tr>
</tbody>
</table>

2 Select the role to edit.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the role name</td>
<td>(Windows host) Double-click the role in the Roles list and type a new name.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Type a new name in the Name text box.</td>
</tr>
<tr>
<td>Change the privileges in the role</td>
<td>Select or deselect privileges from the privileges tree. You can expand the</td>
</tr>
<tr>
<td></td>
<td>tree to view the privileges in each category.</td>
</tr>
</tbody>
</table>

3 Click OK (Windows host) or Save (Linux host) to save your changes.

Clone a Role

You can make a copy of an existing role by cloning it. When you clone a role, the new role is not applied to users, groups, or objects. You must assign the role to users or groups and objects.

You can change the privileges in a cloned role during the cloning process. See Defined Privileges in the Workstation Pro documentation center for descriptions of the available privileges. The Workstation Pro documentation center is available on the VMware Web site at https://www.vmware.com/support/pubs/ws_pubs.html.

Prerequisites

If you are cloning a role on a remote host, connect to the remote server. See “Connect to a Remote Server,” on page 214.

Procedure

1 Open the Edit Roles dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clone a role on the local host</td>
<td>(Windows host) Right-click Shared VMs and select Roles.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Right-click Shared VMs and select Edit Roles.</td>
</tr>
<tr>
<td>Clone a role on a remote host</td>
<td>(Windows host) Right-click the remote host and select Roles.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Right-click the remote host and select Edit Roles.</td>
</tr>
</tbody>
</table>

2 Select the role to clone and click Clone.

Workstation Pro adds a copy of the role to the list of roles.

3 Type a new name for the cloned role.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Replace the name of the role in the Roles list.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Type a new name in the Name text box.</td>
</tr>
</tbody>
</table>
4 (Optional) To change the privileges in the cloned role, select or deselect privileges from the privileges tree. You can expand the tree to view the privileges in each category.

5 Click OK (Windows host) or Save (Linux host) to create the new role.

Remove a Role
When you remove a role, Workstation Pro removes the definition from the list of roles.

**IMPORTANT** Make sure that you understand how users will be affected before you remove or replace role assignments.

**Prerequisites**
If you are removing a role on a remote host, connect to the remote server. See “Connect to a Remote Server,” on page 214.

**Procedure**
1 Open the Edit Roles dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove a role on the local host</td>
<td>(Windows host) Right-click Shared VMs and select Roles.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Right-click Shared VMs and select Edit Roles.</td>
</tr>
<tr>
<td>Remove a role on a remote host</td>
<td>(Windows host) Right-click the remote host and select Roles.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Right-click the remote host and select Edit Roles.</td>
</tr>
</tbody>
</table>

2 Select the role to remove and click Remove.
On a Windows host, Workstation Pro removes configured user or group and role pairings on the host. Users or groups that do not have other permissions assigned lose all privileges.

3 If the role is assigned to a user or group, select a reassignment option and click OK.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove the role from all affected users and groups</td>
<td>(Windows host) Select Remove role assignments.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Select Remove affected permissions.</td>
</tr>
<tr>
<td>Users or groups that do not have other permissions assigned lose all privileges.</td>
<td></td>
</tr>
<tr>
<td>Remove the role and assign another role to all affected users and groups</td>
<td>(Windows host) Select Reassign affected users to and select a role.</td>
</tr>
<tr>
<td></td>
<td>(Linux host) Select Reassign affected permissions to and select a role.</td>
</tr>
</tbody>
</table>

Using Permissions to Restrict Users
You can control which users can access remote hosts and shared virtual machines by creating permissions. To create a permission, you pair a user or group with a role and associate that pairing with an object. The role defines the actions that a user or group can perform, the user or group indicates who can perform the actions, and the object is the target of the actions.

A role is a predefined set of privileges. Privileges define individual rights that a user requires to perform actions and read properties. A single user can have different roles for different objects.
Users can inherit permissions through group membership and through the object hierarchy. When you assign permissions to a group, all of the users in the group inherit those permissions. If you define multiple group permissions on the same object and a user belongs to two or more of those groups, the user inherits all of the privileges assigned to the groups. If you define a permission for the user on the object, that permission takes precedence over all group permissions.

Add a Permission

To create a permission, you assign a user or group and a role to an object.

The available users and groups include local users and groups on the host system. For Workstation Pro, users and groups in the Windows domain that the host system belongs to are also included. For remote hosts that vCenter Server manages, users and groups in the Windows domain list that vCenter Server references are also included.

The object of a permission can be a shared or remote virtual machine, the Shared VMs item, or a remote host. For remote hosts that vCenter Server manages, you can also set permissions on datacenters and folders within datacenters.

When you add a permission, you can indicate whether the permission propagates down the object hierarchy. Propagation is not universally applied. Permissions that you define for a child object always override the permissions that propagate from parent objects.

**Note** You cannot use Workstation Pro to create, remove, or modify users and groups. To manage users and groups, use the mechanisms that the host operating system provides.

Prerequisites

- Verify that you know the default roles. See “Default System Roles,” on page 224.
- If you are setting a permission on a remote object, connect to the remote server. See “Connect to a Remote Server,” on page 214.

Procedure

1. Open the Permissions dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the object is a shared or remote virtual machine</td>
<td>Right-click the object and select Manage &gt; Permissions.</td>
</tr>
<tr>
<td>If the object is a remote host, datacenter, or folder</td>
<td>Right-click the object and select Permissions.</td>
</tr>
</tbody>
</table>

2. Click Add.

3. Select the location of the user or group from the Domain drop-down menu.

   - If you select (server), only local users and groups appear in the list.

4. Select the name of the user or group from the list.

5. Add the permission.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Click Add, select the user or group, select a role from the drop-down menu under Assigned Role, and click OK.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Select a role from the Role drop-down menu and click Add.</td>
</tr>
</tbody>
</table>
On a Linux host, the permission is added immediately. On a Windows host, the permission is not added until you click OK.

6 (Optional) If you do not want to propagate the permission to child objects, deselect the Propagate check box next to the new permission.

If the object is a shared or remote virtual machine and you deselected the Propagate check box, you must confirm that the user can have read-only access to the host. Users must have read-only access to the host on which a virtual machine is running to access the virtual machine through Workstation Pro.

The propagation setting takes effect immediately.

7 (Windows host only) Click OK to add the permission.

### Edit a Permission

You can change the role that is paired with a user or group. You can also change the propagation setting.

**Prerequisites**

- Verify that you know the default roles. See “Default System Roles,” on page 224.
- If you are editing a permission on a remote object, connect to the remote server. See “Connect to a Remote Server,” on page 214.

**Procedure**

1 Open the Permissions dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the object is a shared or remote virtual machine</td>
<td>Right-click the object and select Manage &gt; Permissions.</td>
</tr>
<tr>
<td>If the object is a remote host, datacenter, or folder</td>
<td>Right-click the object and select Permissions.</td>
</tr>
</tbody>
</table>

2 Select the permission.

3 Select a new role from the drop-down menu.

On a Windows host, the drop-down menu is under Assigned Role.

On a Linux host, the role is changed immediately. On a Windows host, the role is not changed until you click OK.

4 To change the propagation setting, select or deselect the Propagate check box.

The propagation setting change takes effect immediately.

5 (Windows host only) Click OK to save your changes.

### Remove a Permission

You can remove the user or group and role pair for a selected object. You cannot remove an inherited permission.

Removing a permission does not remove the user or group from the list of available users and groups, nor does it remove the role from the list of available roles.

**Prerequisites**

If you are removing a permission on a remote object, connect to the remote server. See “Connect to a Remote Server,” on page 214.
Procedure

1. Open the Permissions dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the object is a shared or remote virtual machine</td>
<td>Right-click the object and select Manage &gt; Permissions.</td>
</tr>
<tr>
<td>If the object is a remote host, datacenter, or folder</td>
<td>Right-click the object and select Permissions.</td>
</tr>
</tbody>
</table>

2. Select the permission and click Remove.

   On a Linux host, the permission is removed immediately. On a Windows host, the permission is not removed until you click OK.

3. (Windows host only) Click OK to remove the permission.
Changing Workstation Pro Preference Settings

Workstation Pro preference settings are global configuration settings that apply to Workstation Pro and the virtual machines that you run in Workstation Pro. You can override certain Workstation Pro preference settings for specific virtual machines.

To change Workstation Pro preference settings, select Edit > Preferences.

**IMPORTANT** The default settings for Workstation Pro preferences are correct for most cases. Do not change Workstation Pro preference settings unless you are an experienced user.

This chapter includes the following topics:

- "Configuring Workspace Preference Settings," on page 231
- "Configuring Input Preference Settings," on page 234
- "Changing Hot-Key Combinations," on page 236
- "Configuring Workstation Pro Display Preference Settings," on page 236
- "Configuring Software Update Preference Settings," on page 238
- "Sending System Data and Usage Statistics to VMware," on page 240
- "Changing Shared Virtual Machine Preference Settings," on page 241
- "Configuring Workstation Pro Memory Preference Settings," on page 242
- "Configuring Workstation Pro Priority Preference Settings," on page 243
- "Configuring Device Settings for Windows Hosts," on page 244

**Configuring Workspace Preference Settings**

You can use workspace preference settings to change the default hardware compatibility setting for newly created virtual machines, control how virtual machines behave when you exit Workstation Pro, and configure general workspace settings.

To configure workspace preference settings, select Edit > Preferences > Workspace.

- **Configuring the Default Locations for Virtual Machine Files and Screenshots** on page 232
  
  You can configure the default locations for virtual machine files and captured screenshots.

- **Configuring Virtual Machine Exit Behavior** on page 232
  
  You can configure how virtual machines behave when you exit Workstation Pro.
Enabling Shared Folders Created By Other Users on page 233

As a security precaution, a shared folder is disabled by default if it was not created by the user who powers on the virtual machine. Folder sharing is also disabled by default for Workstation 5.x virtual machines, regardless of who created the virtual machine.

Changing the Default Hardware Compatibility Setting on page 233

You can change the hardware compatibility setting that the New Virtual Machine wizard uses when it creates a typical virtual machine. The hardware compatibility setting determines the hardware features that are supported in the virtual machine.

Configuring Power On Delay and Aero Peek Thumbnail Settings on page 234

You can configure the number of seconds that Workstation Pro delays between powering on virtual machines when you perform a batch power operation. You can also specify whether to show Aero Peek thumbnails on open virtual machine tabs.

Changing the Remote Server Login Privacy Setting on page 234

You can change the setting to enable or disable a prompt to save your login information when connecting to a remote server.

Configuring the Default Locations for Virtual Machine Files and Screenshots

You can configure the default locations for virtual machine files and captured screenshots.

To configure the default locations for virtual machine files and screenshots, select Edit > Preferences > Workspace.

Table 11-1. Virtual Machine File and Screenshot Location Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default location for virtual machines</td>
<td>The default location for storing virtual machine files. This path appears in the Location text box in the New Virtual Machine wizard and the Clone Virtual Machine wizard. It applies to virtual machines that the currently logged in user creates.</td>
</tr>
<tr>
<td>Save screenshots to</td>
<td>Select whether to save virtual machine screenshots to the clipboard, to a file, or to both. When saving a screenshot to a file, you can have Workstation Pro:</td>
</tr>
<tr>
<td></td>
<td>■  Always ask for location</td>
</tr>
<tr>
<td></td>
<td>■  Save to desktop</td>
</tr>
<tr>
<td></td>
<td>■  Browse for custom location</td>
</tr>
<tr>
<td></td>
<td>By default, Workstation Pro saves screenshots to .png files on the Desktop of the host computer. To save screenshots to .bmp files on Windows hosts, select Always ask for location and specify the file type when you create the screenshot.</td>
</tr>
</tbody>
</table>

Configuring Virtual Machine Exit Behavior

You can configure how virtual machines behave when you exit Workstation Pro.

To configure virtual machine exit behavior, select Edit > Preferences > Workspace.
### Table 11-2. Virtual Machine Exit Behavior Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remember opened tabs between sessions</td>
<td>The virtual machine tabs that appear when you exit Workstation Pro appear the next time you start Workstation Pro. If a tab for a virtual machine appears in the Workstation Pro window, the virtual machine is considered open even if it is not powered on.</td>
</tr>
<tr>
<td>Keep VMs running after Workstation closes</td>
<td>Powered-on virtual machines remain running in the background when you close them or exit Workstation Pro. If you deselect this setting, Workstation Pro prompts you for the action to take each time you close a powered-on virtual machine or exit Workstation Pro. If a powered-on virtual machine continues running after you close it or exit Workstation Pro, you can interact with it through VNC or another service.</td>
</tr>
</tbody>
</table>
| Show tray icon                   | If you run virtual machines in the background, use this setting to select how the tray icon appears. The tray icon is represented by three overlapping squares in the notification area in the taskbar on the host system.  

**Always**  
The tray icon appears in the taskbar when no virtual machines are running, even if Workstation Pro is not running.  

**When a virtual machine is powered on**  
The tray icon appears in the taskbar only when a virtual machine is powered on.  

**Never**  
The tray icon does not appear in the taskbar when a virtual machine is running, even if you restart Workstation Pro. |

### Enabling Shared Folders Created By Other Users

As a security precaution, a shared folder is disabled by default if it was not created by the user who powers on the virtual machine. Folder sharing is also disabled by default for Workstation 5.x virtual machines, regardless of who created the virtual machine.

To enable shared folders that were created by other users, select **Edit > Preferences > Workstation** and select **Enable all shared folders by default**.

After this setting is enabled, you can specify which virtual machines can share folders and which folders can be shared.

**IMPORTANT** Enabling all shared folders can pose a security risk because a shared folder might enable existing programs inside the virtual machine to access the host file system without your knowledge.

### Changing the Default Hardware Compatibility Setting

You can change the hardware compatibility setting that the New Virtual Machine wizard uses when it creates a typical virtual machine. The hardware compatibility setting determines the hardware features that are supported in the virtual machine.

To change the default hardware compatibility setting, select **Edit > Preferences > Workspace**. The default hardware compatibility setting appears in the **Default hardware compatibility** menu.
By default, the default hardware compatibility setting is the Workstation Pro version that is installed on the host system.

If you plan to create virtual machines and deploy them in environments that use other VMware products, you might need to change the default hardware compatibility setting to an earlier Workstation version. Some products do not support all of the hardware features in the installed Workstation Pro version. If the virtual machine must be ESX server compatible, you can select the check box for ESX server compatibility on the Workspace preferences dialog box.

**Note** The check box for ESX server compatibility is not available when you create a virtual machine on a remote ESX host. Virtual machines created on remote ESX hosts are always ESX compatible.

See the [Virtual Machine Mobility Planning Guide](#) for information about virtual hardware versions. This guide lists compatibility problems to consider when you move virtual machines into different environments.

**Note** If you create a custom virtual machine in the New Virtual Machine wizard, you can override the default hardware compatibility setting.

### Configuring Power On Delay and Aero Peek Thumbnail Settings

You can configure the number of seconds that Workstation Pro delays between powering on virtual machines when you perform a batch power operation. You can also specify whether to show Aero Peek thumbnails on open virtual machine tabs.

To configure power on delay and thumbnail settings, select **Edit > Preferences > Workspace**.

<table>
<thead>
<tr>
<th>Table 11-3. Power On Delay and Thumbnail Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Setting</strong></td>
</tr>
<tr>
<td>Seconds between powering on multiple VMs</td>
</tr>
<tr>
<td>Show Aero Peek thumbnails for open tabs</td>
</tr>
</tbody>
</table>

### Changing the Remote Server Login Privacy Setting

You can change the setting to enable or disable a prompt to save your login information when connecting to a remote server.

By default, when you connect to a remote server you are prompted whether you want Workstation Pro to save your login and password information. You can disable this prompt from displaying by deselecting the **Offer to Save Login Information for Remote Hosts** checkbox. For more information, see “Connect to a Remote Server,” on page 214.

### Configuring Input Preference Settings

To direct input to a virtual machine, Workstation Pro captures input from the host system so that all keystrokes, mouse moves, and button clicks go to the virtual machine. You can use input preference settings to configure how Workstation Pro captures input from the host system.

To configure input preference settings, select **Edit > Preferences > Input**.
Configuring Keyboard and Mouse Settings

Keyboard and mouse settings control how virtual machines that run in Workstation Pro capture input from the keyboard and mouse.

To configure keyboard and mouse settings, select Edit > Preferences > Input.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grab keyboard and mouse input on mouse click</td>
<td>Virtual machines grab input the first time you click in the virtual machine window.</td>
</tr>
<tr>
<td>Grab keyboard and mouse input on key press</td>
<td>Virtual machines grab keyboard and mouse input the first time you press a key when the cursor is in the virtual machine window. When this setting is selected, you cannot use the normal application and system accelerator key sequences when the virtual machine display is active.</td>
</tr>
</tbody>
</table>

Troubleshooting Input Problems

You might occasionally encounter problems when virtual machines capture input from the keyboard and mouse on the host system.

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pressing Ctrl+Alt to release the mouse and keyboard causes a laptop to suspend.</td>
<td>By default, Workstation Pro uses Ctrl+Alt to release the mouse and keyboard. Some laptops use this same key combination to suspend the host machine. In these cases, try using Ctrl and Alt on the right side of the keyboard. Workstation Pro recognizes both sets of Ctrl and Alt keys, but laptops usually recognize only the keys on the left side of the keyboard for the suspend function.</td>
</tr>
<tr>
<td>After you press Ctrl+Alt to release the mouse and keyboard, the keyboard does not function properly within the host operating system.</td>
<td>Occasionally, Workstation Pro causes the host operating system to lose keyboard events, which in turn causes the host operating system to detect that keys are being pressed when they are not. If keys do not respond as expected after you exit Workstation Pro, they might be stuck in the host operating system. Press and release each of the modifier keys individually, including Ctrl, Shift, and Alt. If the keys still do not respond, press and release more special keys, including the Windows, Esc, and Caps Lock keys.</td>
</tr>
<tr>
<td>On Linux hosts, pressing Ctrl+Alt does not release the cursor.</td>
<td>The modifier keys might be mapped under X (in Linux) in unexpected ways. For example, the left Ctrl key might be mapped to Caps Lock, or an Alt key is generating special keystrokes. Run <code>xmodmap -- kim -- kp</code> and submit a support request to VMware technical support that includes the output.</td>
</tr>
</tbody>
</table>

Configuring Cursor Settings

Cursor settings control cursor behavior for the virtual machines that you run in Workstation Pro.

To configure cursor settings, select Edit > Preferences > Input.
Table 11-6. Cursor Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically grab and ungrab the mouse</td>
<td>Virtual machines release the cursor when you point outside of the virtual machine window. When this setting is selected, you can use the host system without first pressing a key combination. You might need to deselect this setting if you play computer games that pan or scroll when you move the pointer to the edge of the screen. VMware Tools must be installed in the virtual machine to use this feature.</td>
</tr>
<tr>
<td>Hide cursor on ungrab</td>
<td>The cursor does not appear in the virtual machine display after input is transferred back to the host system. If you have multiple virtual machines open at the same time, selecting this setting helps you track the active cursor. VMware Tools must be installed in the virtual machine to use this feature.</td>
</tr>
<tr>
<td>Optimize mouse for games</td>
<td>Select mouse behavior for computer games. In some computer games, you move the pointer to the edge of the screen to pan the scene or scroll. By optimizing the virtual mouse for games, you can achieve this effect in a virtual machine.</td>
</tr>
</tbody>
</table>

Automatically grab and ungrab the mouse
- **Automatic**: Workstation Pro determines when to optimize mouse motion. This is the default setting.
- **Always**: Mouse motion is always optimized for games.
- **Never**: Mouse motion is never optimized. When you play computer games in a virtual machine, the optimized mouse is usually not released from the virtual machine. Some applications, such as AutoCAD, are incorrectly identified as games. Select this setting if you use AutoCAD and find that the mouse cannot pass freely from the virtual machine to the host system or if pointer speed is different when you use AutoCAD.

Changing Hot-Key Combinations

Hot-keys, which are also called keyboard shortcuts, provide a quick way to perform common virtual machine operations. Hot-key settings are usually a combination of the Ctrl, Shift, Alt, and Windows keys.

- You can change the hot-key combinations that you use to perform common virtual machine operations. See “Change Hot-Key Combinations for Common Operations,” on page 166.
- You can change the hot-key combination that you use to access the Start and Applications menus in Unity mode. See “Change Hot-Key Combinations for Unity Mode,” on page 167.

Configuring Workstation Pro Display Preference Settings

Display adjustments occur when you resize the Workstation Pro window and when you change the display settings inside the guest operating system. You can use display preference settings to configure how Workstation Pro makes display adjustments.

To configure display preference settings, select Edit > Preferences > Display.

If you are using Windows 8.1 (Update 2) or Windows 10, Workstation Pro detects the DPI on each monitor and scales the virtual machine to match the DPI on the host.

- Configuring Autofit Settings on page 237
  Autofit settings control how the display of virtual machines adjusts to fit the Workstation Pro window.
Configuring Full Screen Settings on page 237

Full screen settings control how the host system and guest operating system display settings interact when you enter full screen mode. In full screen mode, the virtual machine display fills the screen and you cannot see the borders of the Workstation Pro window.

Configuring Menu and Toolbar Settings on page 237

Menu and toolbar settings control how the menus and toolbars appear when Workstation Pro is in full screen and windowed mode.

Configuring Autofit Settings

Autofit settings control how the display of virtual machines adjusts to fit the Workstation Pro window.

To configure autofit settings, select Edit > Preferences > Display.

Table 11-7. Autofit Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autofit window</td>
<td>Resize the application window to match the virtual machine display settings when the virtual machine display settings are changed.</td>
</tr>
<tr>
<td>Autofit guest</td>
<td>Change the virtual machine settings to match the application window when the application window is resized.</td>
</tr>
</tbody>
</table>

Configuring Full Screen Settings

Full screen settings control how the host system and guest operating system display settings interact when you enter full screen mode. In full screen mode, the virtual machine display fills the screen and you cannot see the borders of the Workstation Pro window.

To configure full screen settings, select Edit > Preferences > Display.

Table 11-8. Full Screen Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autofit guest</td>
<td>Change the virtual machine settings to match the application window when the application window is resized.</td>
</tr>
<tr>
<td>Stretch guest (no resolution change)</td>
<td>Virtual machine resolution settings are retained, but the display still changes to fill the full screen. Select this setting if you need to retain low-resolution settings, for example, when playing older computer games that run only at low resolutions.</td>
</tr>
<tr>
<td>Center guest (no resolution change)</td>
<td>The host system and virtual machines retain their own display settings when you are in full screen mode.</td>
</tr>
</tbody>
</table>

Configuring Menu and Toolbar Settings

Menu and toolbar settings control how the menus and toolbars appear when Workstation Pro is in full screen and windowed mode.

To configure menu and toolbar settings, select Edit > Preferences > Display.
### Table 11.9. Menu and Toolbar Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a single button for power controls</td>
<td>(Windows hosts only) When this setting is selected, the start, stop, suspend, and reset power controls appear on the toolbar as a single button with a drop-down menu. When this setting is deselected, each power control has a separate button on the toolbar.</td>
</tr>
<tr>
<td>Combine toolbar with menu bar in windowed mode</td>
<td>Show the Workstation Pro menus and toolbar on a single bar when Workstation Pro is in windowed mode.</td>
</tr>
<tr>
<td>Combine tabs with toolbar in full screen</td>
<td>Show the tabs and toolbar in a single bar when Workstation Pro is in full screen mode.</td>
</tr>
<tr>
<td>Show toolbar edge when unpinned in full screen</td>
<td>Show the edge of the full screen toolbar. When this setting is deselected, the edge of the full screen toolbar is not visible. The full screen toolbar appears for a few seconds when you place your cursor near the top of the screen.</td>
</tr>
</tbody>
</table>

### Configuring Software Update Preference Settings

You can use software update preference settings to configure when Workstation Pro checks for the availability of new versions of software components and VMware Tools updates. You can also configure a proxy server to connect to the VMware Update Server.

To configure software update preference settings, select Edit > Preferences > Updates.

- **Configuring Software Updates Settings** on page 238
  
  Software updates settings control when Workstation Pro downloads software updates to the host system and whether it uses a proxy server to connect to the VMware Update Server.

- **Configuring Connection Settings for a Proxy Server** on page 239
  
  You can configure connection settings to use a proxy server to connect to the VMware Update Server.

### Configuring Software Updates Settings

Software updates settings control when Workstation Pro downloads software updates to the host system and whether it uses a proxy server to connect to the VMware Update Server.

### Table 11.10. Software Update Preference Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check for product updates on startup</td>
<td>Check for new versions of the application and installed components when you start Workstation Pro. This setting is selected by default.</td>
</tr>
<tr>
<td>Check for new software components as needed</td>
<td>Check for a new version of a component when a component, such as VMware Tools, is required. When this setting is selected, Workstation Pro verifies if a new version is available to download and install.</td>
</tr>
<tr>
<td>Download All Components Now</td>
<td>Manually download all of the available software components to the host system. Click this button if you are planning to use a virtual machine at a later time when you do not have access to the Internet.</td>
</tr>
<tr>
<td>Connection Settings</td>
<td>Click this button to configure a proxy server to connect to the VMware Update Server.</td>
</tr>
<tr>
<td>Automatically update VMware Tools on virtual machine</td>
<td>Install the latest version of VMware Tools when you power on a virtual machine or shut down the guest operating system. You can override this setting for specific virtual machines.</td>
</tr>
</tbody>
</table>
Understanding the Automatic Software Update Process

When you enable automatic software updates, you are always aware of the latest releases from VMware.

By keeping your software up-to-date, you can take advantage of new product features and performance improvements, ensure that your system includes the latest patches, and obtain timely support for new guest operating systems. You can enable the automatic software update feature when you install Workstation Pro or by configuring Workstation Pro preference settings. You can disable the feature at any time.

To determine if software updates are available, the VMware software updates feature securely sends the following anonymous information to VMware.

- A universal unique identifier (UUID), which it uses to identify each individual system
- The product name, the product version, and the build number
- Your host operating system name, version, and the locale setting

The VMware software updates feature does not collect any personal data, such as your name, address, telephone number, or mail address. Your product license key and MAC address are not sent to VMware, and VMware does not store your IP address with the data that it receives from you.

VMware might use the information it receives from the software update feature for product planning purposes. VMware limits access to your data and uses industry-standard controls to protect your information, including physical access controls, Internet firewalls, intrusion detection, and network monitoring.

The information collected by the VMware software updates feature is handled in accordance with VMware Privacy Policy.

Configuring Connection Settings for a Proxy Server

You can configure connection settings to use a proxy server to connect to the VMware Update Server.

To configure proxy connection settings, select Edit > Preferences > Updates and click Connection Settings.

Table 11-11. Connection Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No proxy</td>
<td>Do not use a proxy server.</td>
</tr>
<tr>
<td>Windows proxy settings</td>
<td>(Windows hosts only) Workstation Pro uses the host proxy settings from the Connections tab in the Internet Options control panel to access the VMware Update Server. Click Internet Options to set the guest connection options.</td>
</tr>
<tr>
<td>System proxy settings</td>
<td>(Linux hosts only) Workstation Pro uses the host proxy settings to access the VMware Update Server.</td>
</tr>
<tr>
<td>Manual proxy settings</td>
<td>Select an HTTP or SOCKS proxy, specify the proxy server address, and designate a port number to access the VMware Update Server.</td>
</tr>
<tr>
<td>Username and Password</td>
<td>The username and password to use for proxy server authentication. On Windows hosts, if either the Username or Password text box is blank, Workstation Pro does not use either value. On Linux hosts, if either the Username or Password text box is blank, Workstation Pro uses the username and password set in the gnome settings.</td>
</tr>
</tbody>
</table>

You must restart Workstation Pro for proxy setting changes to take effect.
Sending System Data and Usage Statistics to VMware

You can use the Workstation Pro feedback preference setting to control whether you participate in or opt out of the VMware User Experience Improvement Program.

To configure the feedback preference setting, select Edit > Preferences > Feedback. The Help improve VMware Workstation setting controls whether you participate in the Customer Experience Improvement Program.

When you participate in the VMware User Experience Improvement Program, Workstation Pro collects and sends anonymous system data and usage statistics to VMware. Workstation Pro creates log files for the collected data and stores the data on the host system.

<table>
<thead>
<tr>
<th>Table 11-12. User Experience Improvement Program Log Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filename</td>
</tr>
<tr>
<td>workstationUploadedData.log</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

**Note** The data collection process does not affect the performance of your computer.

Participating in the User Experience Improvement Program

When you participate in the VMware User Experience Improvement Program, your computer sends anonymous information to VMware. Participation in the program is voluntary and you can opt out at any time.

Types of Data Collected

The data collected by the VMware User Experience Improvement Program might include product data, product usage information, product performance information, and system configuration information. Product data typically includes information such as the product name, version, build number, and configuration settings. This information helps VMware compare data from identical installations and determine popular configurations.

Product usage information might include menu items selected, toolbar buttons pressed, virtual machines run, and virtual machine configuration settings. This information helps VMware identify usage patterns, such as the most popular features, how many virtual machines users create, how many virtual machines are run concurrently, which operating systems are the most popular, and what virtual machine settings are typically selected.

Product performance data might include errors that occur and measurements, such as virtual machine suspend and resume times, uptime, or application startup time.
System configuration information might include the operating system that your computer is currently running, how many processors are in your computer and the processor models, how much memory is installed, how many network connections are available, the video cards and video drivers that are installed, and screen resolutions for display devices. This information helps VMware identify the system configurations that best match customer environments during testing and to plan future development based on hardware industry trends and the adoption of new technologies.

Not all of the available information is collected from every system every time data is sent to VMware. Some information is included only from select installations and certain information, such as error messages, is collected only when it is generated.

VMware uses a universal unique identifier (UUID) to identify information from different machines.

**When the Data Is Transmitted to VMware**

Data is typically collected on your system and transmitted to VMware when you start Workstation Pro. If your computer does not have access to the Internet, the information is collected and sent to VMware the next time you start Workstation Pro. Data might also be sent to VMware at other times, such as during a check for software updates. Data is encrypted and transmitted over a secure SSL connection so that it cannot be read by other Internet users.

Workstation Pro stores all of the information that it sends to VMware on your system in clear text. The files are located in the same directory as your log files and are named `productnameUploadedData.log`.

**Privacy Protection**

VMware does not collect any personal data, such as your name, address, telephone number, or mail address. Your product license key and MAC address are not sent to VMware, and VMware does not store your IP address with the data that it receives from you.

VMware limits access to your data and uses industry-standard controls to protect your information, including physical access controls, Internet firewalls, intrusion detection, and network monitoring. The information collected by the VMware User Experience Improvement Program is handled in accordance with VMware Privacy Policy.

---

*Note* The User Improvement Program is not Spyware. Spyware collects information or acts on your computer without your full knowledge or consent.

**Opting Out of the Program**

You can join or end participation in the VMware User Experience Improvement Program at any time by changing Workstation Pro preference settings.

See “Sending System Data and Usage Statistics to VMware,” on page 240 for more information.

**Changing Shared Virtual Machine Preference Settings**

You can enable or disable virtual machine sharing and remote access, modify the HTTPS port that VMware Workstation Server uses, and change the shared virtual machines directory.

To change shared virtual machine preference settings, select `Edit > Preferences > Shared VMs`.

To change these settings on a Windows host, you must have administrative privileges on the host system. On a Linux host, you must have root access on the host system.
### Table 11-13. Shared Virtual Machine Preference Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Enable Sharing or Disable Sharing** (Windows host)         | When you enable virtual machine sharing, Workstation Pro starts VMware Workstation Server on the host system. You can create shared virtual machines and remote users can connect to the host system.  
When you disable virtual machine sharing, Workstation Pro stops VMware Workstation Server on the host system. You cannot create shared virtual machines and remote users cannot connect to the host system.  
Virtual machine sharing is enabled by default. |
| **Enable virtual machine sharing and remote access** (Linux host) | The HTTPS port that VMware Workstation Server uses on the host system. The default HTTPS port is 443.  
On Windows hosts, you cannot change the HTTPS port unless remote access and virtual machine sharing are disabled.  
On Linux hosts, you cannot change the port number in the Preferences dialog box. You can change the port number only during installation, when running the Workstation Pro installation wizard.  
**Note** If the port number uses a non-default value, remote users must specify the port number when they connect to the host system, for example, host:port. |
| **HTTPS port**                                               | The directory where Workstation Pro stores shared virtual machines.  
You cannot change the shared virtual machines directory if there are shared virtual machines on the host. |

### Configuring Workstation Pro Memory Preference Settings

You can use memory preference settings to configure the amount of memory that Workstation Pro is allowed to reserve for all running virtual machines. You can also configure settings to control memory swapping.

To configure memory preference settings, select **Edit > Preferences > Memory**.

- **Configuring Reserved Memory** on page 242  
The reserved memory setting specifies the maximum amount of host RAM that Workstation Pro is allowed to reserve for all running virtual machines. Reserved memory is not allocated in advance.

- **Configuring Additional Memory Settings** on page 243  
The additional memory settings control how the memory manager on the host system swaps virtual machines out of physical RAM.

#### Configuring Reserved Memory

The reserved memory setting specifies the maximum amount of host RAM that Workstation Pro is allowed to reserve for all running virtual machines. Reserved memory is not allocated in advance.

To configure the reserved memory setting, select **Edit > Preferences > Memory** and move the **Reserved memory** slider to select the reserved memory amount.

If you set the reserved memory value too high, the CPU might thrash if you run other applications on the host. If you set the value too low, virtual machines might perform poorly, and you cannot run as many virtual machines at the same time.
On 64-bit hosts, the maximum amount of memory for each virtual machine is 64GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. Workstation Pro prevents powering on virtual machines that are configured to use more than 8GB of memory on 32-bit hosts. Memory management limitations on 32-bit operating systems cause virtual machine memory to overcommit, which severely affects system performance.

The total amount of memory that you can assign to all virtual machines running on a single host system is limited only by the amount of RAM on the host system.

**Configuring Additional Memory Settings**

The additional memory settings control how the memory manager on the host system swaps virtual machines out of physical RAM.

To configure additional memory settings, select Edit > Preferences > Memory.

<table>
<thead>
<tr>
<th>Table 11-14. Additional Memory Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Setting</strong></td>
</tr>
<tr>
<td>Fit all virtual machine memory into reserved host RAM</td>
</tr>
<tr>
<td>Allow some virtual machine memory to be swapped</td>
</tr>
<tr>
<td>Allow most virtual machine memory to be swapped</td>
</tr>
</tbody>
</table>

**Configuring Workstation Pro Priority Preference Settings**

You can use priority preference settings to enable or disable background snapshots. On Windows hosts, you can also use priority preference settings to configure process priorities.

To configure priority preference settings, select Edit > Preferences > Priority.

- **Configuring Process Priorities on Windows Hosts** on page 243
  
  The default process priority settings control the priority that the Windows process scheduler gives to the virtual machines that run on the host system. These settings affect the performance of both the host system and the virtual machines running on it.

- **Configuring Background Snapshots** on page 244
  
  Background snapshots settings control how Workstation Pro handles background snapshots.

**Configuring Process Priorities on Windows Hosts**

The default process priority settings control the priority that the Windows process scheduler gives to the virtual machines that run on the host system. These settings affect the performance of both the host system and the virtual machines running on it.

To configure default process priority settings, select Edit > Preferences > Priority.
Process priority settings apply to Windows hosts only. You can override these settings for specific virtual machines.

**Table 11-15. Default Process Priority Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input grabbed</td>
<td>Select the priority for virtual machines when their keyboard and mouse input is grabbed.</td>
</tr>
<tr>
<td>Input ungrabbed</td>
<td>Select the priority for virtual machines when their keyboard and mouse input is not grabbed.</td>
</tr>
</tbody>
</table>

The **Normal** setting means that the processes within virtual machines contend equally for resources with all other processes running on the host.

**Configuring Background Snapshots**

Background snapshots settings control how Workstation Pro handles background snapshots.

To configure background snapshot settings, select **Edit > Preferences > Priority**.

Taking a snapshot is not an instantaneous process. When background snapshots are enabled, you can continue to work while Workstation Pro completes the snapshot process in the background.

**Table 11-16. Snapshot Setting Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take snapshots in the background when possible</td>
<td>Enable background snapshots.</td>
</tr>
<tr>
<td>Restore snapshots in the background when possible</td>
<td>Enable the restoration of background snapshots.</td>
</tr>
</tbody>
</table>

Virtual machines must be powered off and then powered on, rather than restarted, for background snapshot changes to take effect.

**Configuring Device Settings for Windows Hosts**

You can use device settings to configure removable media and virtual printer settings for Windows hosts.

To configure device settings for Windows hosts, select **Edit > Preferences > Devices**.

**Configuring the Autorun Feature on Windows Hosts**

On Windows hosts, the Autorun feature causes CDs and DVDs to run automatically when you insert them in to the CD-ROM or DVD drive on the host system.

To enable or disable the Autorun feature on a Windows host system, select **Edit > Preferences > Devices**. You must be logged in as a member of the Administrators group to change this setting.

To run Autorun programs, some operating systems poll the CD-ROM drive every second or so to determine whether a disk is present. Polling can cause Workstation Pro to connect to the host CD-ROM or DVD drive, which can make the drive spin up while the virtual machine appears to pause. Because this behavior is undesirable, the Autorun feature is disabled by default in Workstation Pro.

**Note** You can use Windows Explorer to open a disk on the host system when the Autorun feature is disabled.
Configuring Virtual Printers on Windows Hosts

On Windows hosts, you can configure Workstation Pro to support virtual printing on all printers configured on the host.

Virtual printing is disabled by default on Windows hosts. To enable or disable virtual printing on a Windows host system, select Edit > Preferences > Devices. Select the Enable virtual printers check box to enable virtual printers. VMware Tools must be installed on the virtual machine to enable printing. You must have administrator privileges to enable or disable virtual printers.

The Workstation Pro printer feature uses ThinPrint technology to replicate the host system printer mapping in the virtual machine. When you enable the virtual machine printer, Workstation Pro configures a virtual serial port to communicate with the host printers.

**Note** If any virtual printers are powered on when the Enable virtual printers option is selected, the virtual machines must be rebooted, or suspended and then resumed, for the setting to take effect.

See “Add a Host Printer to a Virtual Machine,” on page 89
Virtual machine options settings control characteristics of individual virtual machines, such as how files are transferred between the host and guest operating system and what happens to a guest operating system when you exit Workstation Pro. Some virtual machine options override similar Workstation Pro preference settings.

To configure virtual machine option settings for a selected virtual machine, select VM > Settings and click the Options tab.

This chapter includes the following topics:
- “Configuring General Option Settings for a Virtual Machine,” on page 247
- “Configuring Power Settings for a Virtual Machine,” on page 249
- “Configuring Snapshot Options for a Virtual Machine,” on page 250
- “Configuring AutoProtect Options for a Virtual Machine,” on page 251
- “Configuring Guest Isolation Options for a Virtual Machine,” on page 252
- “Configuring Tablet Sensor Input Options for a Virtual Machine,” on page 252
- “Configuring VMware Tools Options for a Virtual Machine,” on page 253
- “Configuring a Virtual Machine as a VNC Server,” on page 254
- “Configuring Unity Mode for a Virtual Machine,” on page 254
- “Configuring Appliance Details for a Virtual Machine,” on page 255
- “Configuring Autologin for a Virtual Machine,” on page 255
- “Configuring Advanced Options for a Virtual Machine,” on page 256

## Configuring General Option Settings for a Virtual Machine

General option settings include the virtual machine name, the guest operating system type and version, and the location of the directory where virtual machine files are stored.

To configure general option settings for a selected virtual machine, select VM > Settings, click the Options tab, and select General.

- Changing a Virtual Machine Name on page 248

You can change the name of a virtual machine. Changing the name of the virtual machine does not change the name of this directory, nor does it rename the virtual machine files on the host. Workstation Pro uses the original name of the virtual machine to create the directory where virtual machine files are stored.
Changing the Guest Operating System on page 248
You can change the guest operating system or operating system version for a virtual machine. You might want to change the guest operating system for a virtual machine when you upgrade the guest operating system or if you specified the wrong operating system version when you created the virtual machine.

Changing the Virtual Machine Working Directory on page 248
You can change the working directory for a virtual machine. The working directory is where Workstation Pro stores suspended state (.vmss), snapshot (.vmsn), and virtual machine paging (.vmem) files. By default, the working directory is where the virtual machine files are stored.

Changing a Virtual Machine Name
You can change the name of a virtual machine. Changing the name of the virtual machine does not change the name of this directory, nor does it rename the virtual machine files on the host. Workstation Pro uses the original name of the virtual machine to create the directory where virtual machine files are stored.

To specify a new name for a selected virtual machine, select VM > Settings, click the Options tab, and select General.

Changing the Guest Operating System
You can change the guest operating system or operating system version for a virtual machine. You might want to change the guest operating system for a virtual machine when you upgrade the guest operating system or if you specified the wrong operating system version when you created the virtual machine.

To select a new guest operating system or operating system version for a selected virtual machine, select VM > Settings, click the Options tab, and select General.

When you change the operating system type, the virtual machine configuration file is changed but the guest operating system is not changed. To change the guest operating system, you must obtain the operating system software and upgrade the guest operating system.

The virtual machine must be powered off when you change these settings.

Changing the Virtual Machine Working Directory
You can change the working directory for a virtual machine. The working directory is where Workstation Pro stores suspended state (.vmss), snapshot (.vmsn), and virtual machine paging (.vmem) files. By default, the working directory is where the virtual machine files are stored.

**Note** You cannot change the working directory for a remote or a shared virtual machine.

To specify a new working directory for a selected virtual machine, select VM > Settings, click the Options tab, and select General.

You might want to change the working directory in the following situations:

- To organize all of your snapshots in a separate directory, you can create a directory in another location. If you plan to take many snapshots and use a large amount of disk space, place the working directory on a disk with a lot of space.

- To run a virtual machine that is stored on a network share or iPod, which might slow performance, you can change the working directory to your local hard disk. Then you can take a snapshot, power on the virtual machine, use it, and discard the snapshot when you are finished. The virtual machine then revert to its original state.

- To create a paging file on a fast disk with a lot of disk space but leave the virtual disk and configuration file on a different disk, you can change the working directory so that it is located on the fast disk.
Changing the working directory does not change the directory where Workstation Pro stores the virtual machine configuration (.vmx) file and log files.

The virtual machine must be powered off when you change this setting.

### Configuring Power Settings for a Virtual Machine

You can configure power options and power control settings for a virtual machine.

To change power options and settings for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Power**.

* Configuring Power Options for a Virtual Machine on page 249
  - Power options control how a virtual machine behaves after it is powered off, closed, or suspended.

* Configuring Power Controls for a Virtual Machine on page 249
  - Power control settings affect the behavior of the stop, suspend, start, and reset buttons for a virtual machine. The behavior that you select appears in a tooltip when you mouse over the associated button. Power control settings also determine which power options appear in the context menu when you right-click the virtual machine in the library.

### Configuring Power Options for a Virtual Machine

Power options control how a virtual machine behaves after it is powered off, closed, or suspended.

To configure power options for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Power**.

**Note** You cannot configure power options for a shared or remote virtual machine.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter full screen mode after powering on</td>
<td>The virtual machine window enters full screen mode after it is powered on.</td>
</tr>
<tr>
<td>Close after powering off or suspending</td>
<td>The virtual machine tab closes after it is powered off or suspended.</td>
</tr>
<tr>
<td>Report battery information to guest</td>
<td>Battery information is reported to the guest operating system. If you run the virtual machine on a laptop in full screen mode, this option enables you to determine when the battery is running low. This option is available only for Workstation 6.x and later virtual machines.</td>
</tr>
</tbody>
</table>

### Configuring Power Controls for a Virtual Machine

Power control settings affect the behavior of the stop, suspend, start, and reset buttons for a virtual machine. The behavior that you select appears in a tooltip when you mouse over the associated button. Power control settings also determine which power options appear in the context menu when you right-click the virtual machine in the library.

You can configure a soft or hard setting for each power control. A soft setting sends a request to the guest operating system, which it can ignore or, in the case of a deadlocked guest, it might not be able to handle. A guest operating system cannot ignore a hard power control. Hard power control settings are configured by default.

To change power controls for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Power**.
### Table 12-2. Power Controls

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Stop</strong></td>
<td><strong>Power Off</strong> (Hard option) Workstation Pro powers off the virtual machine abruptly with no consideration for work in progress.</td>
</tr>
<tr>
<td></td>
<td><strong>Shut Down Guest</strong> (Soft option) Workstation Pro sends a shut down signal to the guest operating system. An operating system that recognizes the signal shuts down gracefully. Not all guest operating systems respond to a shutdown signal from Workstation Pro. If the guest operating system does not respond to the signal, shut down from the guest operating system as you would a physical machine.</td>
</tr>
<tr>
<td><strong>Suspend</strong></td>
<td><strong>Suspend</strong> (Hard option) Workstation Pro suspends the virtual machine and leaves it connected to the network.</td>
</tr>
<tr>
<td></td>
<td><strong>Suspend Guest</strong> (Soft option) Workstation Pro suspends the virtual machine and disconnects it from the network. VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script releases the IP address of the virtual machine. On Linux, FreeBSD, and Solaris guests, the script stops networking for the virtual machine.</td>
</tr>
<tr>
<td><strong>Start</strong></td>
<td><strong>Power On</strong> (Hard option) Workstation Pro starts the virtual machine.</td>
</tr>
<tr>
<td></td>
<td><strong>Start Up Guest</strong> (Soft option) Workstation Pro starts the virtual machine and VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script renews the IP address of the virtual machine. On a Linux, FreeBSD, or Solaris guest, the script starts networking for the virtual machine.</td>
</tr>
</tbody>
</table>

**Note** You cannot configure this setting for a shared or remote virtual machine.

| **Reset**        | **Reset** (Hard option) Workstation Pro resets the virtual machine abruptly with no consideration for work in progress.                   |
|                  | **Restart Guest** (Soft option) Workstation Pro shuts down and restarts the guest operating system gracefully. VMware Tools runs scripts before the virtual machine shuts down and when the virtual machine starts up. |

### Configuring Snapshot Options for a Virtual Machine

When you take a snapshot, Workstation Pro preserves the state of a virtual machine so that you can return to the same state repeatedly. A snapshot captures the entire state of the virtual machine at the time you take the snapshot, including the contents of the virtual machine memory, the virtual machine settings, and the state of all virtual disks.

To configure snapshot options for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Snapshots**.

### Table 12-3. Snapshot Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Just power off</strong></td>
<td>Power off the virtual machine without making any changes to snapshots.</td>
</tr>
<tr>
<td><strong>Revert to snapshot</strong></td>
<td>Revert to the parent snapshot of the current state of the virtual machine. When you revert to a snapshot, you return the memory, settings, and virtual disks of the virtual machine to the state that they were in when you took the snapshot.</td>
</tr>
</tbody>
</table>
Table 12-3. Snapshot Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Take a new snapshot | Takes a snapshot of the virtual machine state after it is powered off. The snapshot appears in the Snapshot Manager. The name of the snapshot is the date and time that the virtual machine was powered off and the description is Automatic snapshot created when powering off.  
  **Note**: You cannot configure this option for a shared or remote virtual machine. |
| Ask me         | Prompts you to power off or take a snapshot when the virtual machine is powered off.                                                        |

Configuring AutoProtect Options for a Virtual Machine

The AutoProtect feature preserves the state of a virtual machine by taking snapshots at regular intervals. You can also take manual snapshots at any time.

The AutoProtect feature has certain restrictions.

- Because AutoProtect takes snapshots only while a virtual machine is powered on, you cannot clone AutoProtect snapshots. You can clone a virtual machine only if it is powered off.
- AutoProtect snapshots are not taken in Workstation Player, even if AutoProtect is enabled for the virtual machine in Workstation Pro.
- You cannot configure the AutoProtect feature for a shared or remote virtual machine.

To configure AutoProtect options for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Snapshots**.

Table 12-4. AutoProtect Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable AutoProtect</td>
<td>When you enable the AutoProtect feature, an estimate of the minimum of amount of disk space used appears in the Virtual Machine Settings window. The Memory setting for the virtual machine affects this minimum. The more virtual memory that a virtual machine has, the more disk space is available for AutoProtect snapshots.</td>
</tr>
<tr>
<td>AutoProtect interval</td>
<td>Select the interval of time between AutoProtect snapshots.</td>
</tr>
<tr>
<td>Half-Hourly</td>
<td>Snapshots are taken every half hour.</td>
</tr>
<tr>
<td>Hourly</td>
<td>Snapshots are taken every hour.</td>
</tr>
<tr>
<td>Daily</td>
<td>Snapshots are taken daily.</td>
</tr>
<tr>
<td>Maximum AutoProtect snapshots</td>
<td>Select the maximum number of snapshots to be retained. After the maximum number of AutoProtect snapshots is reached, Workstation Pro deletes the oldest AutoProtect snapshot each time a new AutoProtect snapshot is taken. Based on the settings that you enter, Workstation Pro retains a selection of AutoProtect snapshots over a range of time.</td>
</tr>
</tbody>
</table>
Configuring Guest Isolation Options for a Virtual Machine

With the guest isolation option, you can restrict file operations between the virtual machine and the host system, and between the virtual machine and other virtual machines.

To configure guest isolation options for a selected virtual machine, select VM > Settings, click the Options tab, and select Guest Isolation.

These restrictions apply:

- VMware Tools must be installed in the guest operating system to use guest isolation features.
- You cannot configure these options for a shared or remote virtual machine.

**Note** The drag-and-drop and copy-and-paste operations are enabled by default. You might want to disable these operations to prevent files from being accidentally transferred between the virtual machine and the host system.

<table>
<thead>
<tr>
<th>Table 12-5. Guest Isolation Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
</tr>
<tr>
<td>Enable drag and drop</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Enable copy and paste</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

For virtual machines running Windows 8 or later guest operating systems, you can configure the guest operating system to pass tablet sensor data to a tablet. See “Configuring Tablet Sensor Input Options for a Virtual Machine,” on page 252

Configuring Tablet Sensor Input Options for a Virtual Machine

You can configure a Windows 8 or later guest operating system to pass tablet sensor data to your host Windows 8 or later tablet. With this setting, you can use tablet applications inside your virtual machine.

**Prerequisites**

- Power off a Windows 8 or later virtual machine.

**Note** Tablet data is available only on guest operating systems and hosts running Windows 8 or later.

**Procedure**

1. Select the Windows 8 or later virtual machine and select VM > Settings > Options > Guest Isolation
2. Select the tablet sensor data to be shared with the Windows 8 or later host from the **Share sensor input** section.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orientation</td>
<td>Detects the orientation of the device. For example in landscape or portrait mode.</td>
</tr>
<tr>
<td>Motion</td>
<td>Detects changes in physical speed.</td>
</tr>
<tr>
<td>Ambient light</td>
<td>Checks the available light.</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Configuring VMware Tools Options for a Virtual Machine

You can configure how VMware Tools is updated on a virtual machine. You can also configure whether the clock on the guest operating system is synchronised with the clock on the host.

#### VMware Tools Update Options

The virtual machine VMware Tools update options override the Workstation Pro preferences for automatically updating VMware Tools on Linux and Windows guest operating systems.

To configure VMware Tools updates for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **VMware Tools**.

**Note** Automatic updates are not supported for versions of VMware Tools included in virtual machines created with older versions of VMware products, such as Workstation 5.5 and earlier or VMware Server 1.x.

**Table 12-6. VMware Tools Update Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update manually (do nothing)</td>
<td>You must update VMware Tools manually. A message appears on the status bar of the guest operating system when a new version of VMware Tools is available.</td>
</tr>
<tr>
<td>Update automatically</td>
<td>VMware Tools is updated automatically when a new version is available. The status bar indicates when an update is in progress.</td>
</tr>
<tr>
<td>Use application default (currently update automatically)</td>
<td>Use the default VMware Tools update behavior. <strong>Note</strong> You cannot configure this option for a shared or remote virtual machine.</td>
</tr>
</tbody>
</table>

To install a VMware Tools update, use the same procedure that you used for installing VMware Tools the first time.

#### Time Synchronization

If you turn on the VMware Tools time synchronization feature, VMware Tools checks once every minute to determine whether the clocks on the guest and host operating systems still match. If not, the clock on the guest operating system is synchronized to match the clock on the host.

Native time synchronization software, such as Network Time Protocol (NTP) for Linux and the Mac OS X, or Microsoft Windows Time Service (Win32Time) for Windows, is typically more accurate than VMware Tools periodic time synchronization and is therefore preferred.
Configuring a Virtual Machine as a VNC Server

You can configure a virtual machine so that VNC clients can access it remotely. You do not need to install specialized VNC software in the virtual machine.

To configure Virtual Network Computing (VNC) client access for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **VNC Connections**.

**Note** You cannot configure VNC client access for a shared or remote virtual machine.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable VNC</td>
<td>VNC clients can access the virtual machine.</td>
</tr>
<tr>
<td>Port</td>
<td>Select a unique port number for the virtual machine. A unique port number is</td>
</tr>
<tr>
<td></td>
<td>required to connect to multiple virtual machines on the same host. Use a port</td>
</tr>
<tr>
<td></td>
<td>number in the range 5901 to 6001. The default port is 5900.</td>
</tr>
<tr>
<td><strong>Important</strong></td>
<td>Make sure that you specify an available port number. The VMware Management</td>
</tr>
<tr>
<td></td>
<td>Interface uses ports 8333 and 8222. The VMware Workstation Server service</td>
</tr>
<tr>
<td></td>
<td>uses port 443 by default. On Linux, only the root user can listen to ports</td>
</tr>
<tr>
<td></td>
<td>up to port number 1024.</td>
</tr>
<tr>
<td>Password</td>
<td>The password to use to connect to the virtual machine from a VNC client. It</td>
</tr>
<tr>
<td></td>
<td>can be up to eight characters long. Because the password is not encrypted</td>
</tr>
<tr>
<td></td>
<td>when the VNC client sends it, do not use a password that you use for other</td>
</tr>
<tr>
<td></td>
<td>systems.</td>
</tr>
<tr>
<td>View VNC Connections</td>
<td>Click this button to see a list of the VNC clients that are connected to</td>
</tr>
<tr>
<td></td>
<td>the virtual machine.</td>
</tr>
</tbody>
</table>

Configuring Unity Mode for a Virtual Machine

In virtual machines that have Windows XP or later guest operating systems, you can switch to Unity mode to display applications directly on the host system desktop. Open applications in Unity mode appear on the taskbar in the same way as open host system applications.

To configure Unity mode settings for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Unity**.

**Note** You cannot configure Unity mode settings for a shared or remote virtual machine.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show borders</td>
<td>Set a window border that identifies the application as belonging to the</td>
</tr>
<tr>
<td></td>
<td>virtual machine rather than to the host computer.</td>
</tr>
<tr>
<td>Show badges</td>
<td>Display a logo in the title bar.</td>
</tr>
</tbody>
</table>
Table 12-8. Unity Mode Options (Continued)

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a custom color in window borders</td>
<td>Use a custom color in window borders to help distinguish between the application windows that belong to various virtual machines. For example, you can set the applications for one virtual machine to have a blue border and set the applications for another virtual machine to have a yellow border. On Windows hosts, click <strong>Choose color</strong> to use the color chooser.</td>
</tr>
<tr>
<td>Enable applications menu</td>
<td>The virtual machine <strong>Start</strong> or <strong>Applications</strong> menu appears on the host system desktop. When you can access the virtual machine <strong>Start</strong> or <strong>Applications</strong> menu from the host machine desktop, you can start applications in the virtual machine that are not open in Unity mode. If you do not enable this setting, you must exit Unity mode to display the virtual machine <strong>Start</strong> or <strong>Applications</strong> menu in the console view.</td>
</tr>
</tbody>
</table>

**Configuring Appliance Details for a Virtual Machine**

You can configure version and author information and enable an HTTP access port inside a virtual machine.

To configure appliance details for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Appliance Details**.

The virtual machine must be a Workstation 6.x or later virtual machine.

**NOTE** You cannot configure appliance details for a shared or remote virtual machine.

Table 12-9. Application Details Options

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version</td>
<td>(Optional) The virtual machine version, which appears in the upper right corner of the summary page.</td>
</tr>
<tr>
<td>Author</td>
<td>(Optional) The virtual machine author, which appears in the upper right corner of the summary page.</td>
</tr>
<tr>
<td>Access port inside virtual machine</td>
<td>The HTTP access port. When this check box is selected, the HTTP access port is enabled inside the virtual machine. You can also change the port number. The default HTTP port is 80.</td>
</tr>
</tbody>
</table>

**Configuring Autologin for a Virtual Machine**

You can configure the Autologin feature for virtual machines that have a Windows 2000 or later guest operating system. To use Autologin, the virtual machine must be powered on, you must have an existing user account on the local machine, and the latest version of VMware Tools must be installed.

To configure Autologin for a selected virtual machine, select **VM > Settings**, click the **Options** tab, and select **Autologin**.

**NOTE** You cannot configure the Autologin feature for a shared or remote virtual machine.

When you enable Autologin, you must type your login credentials. If you type an incorrect or expired password, you must type your login credentials when you power on the virtual machine. To change your login credentials, select **Change User**.

**NOTE** When you enable Autologin or change your login credentials, Autologin settings are saved immediately. If you click **Cancel** in the Virtual Machine Settings dialog box, the changes applied to the Autologin settings are not affected.
Configuring Advanced Options for a Virtual Machine

Advanced options include process priority settings, debugging settings, memory settings, and virtual machine file locations.

To configure advanced options for a selected virtual machine, select VM > Settings, click the Options tab, and select Advanced.

- Configuring Process Priorities for a Virtual Machine on page 256
  Process priority settings control the priority that the Windows process scheduler gives to the virtual machine. Process priority settings apply to Windows hosts only. The default settings are specified in Workstation Pro priority preference settings.

- Gathering Debugging Information on page 256
  When it runs in debugging mode, a virtual machine collects information that helps VMware technical support resolve problems.

- Configuring Advanced Settings for a Virtual Machine on page 257
  You can configure advanced settings for the selected virtual machine to disable memory page trimming, enable Template mode, and boot the virtual machine from EFI.

Configuring Process Priorities for a Virtual Machine

Process priority settings control the priority that the Windows process scheduler gives to the virtual machine. Process priority settings apply to Windows hosts only. The default settings are specified in Workstation Pro priority preference settings.

To configure process priority settings for a selected virtual machine, select VM > Settings, click the Options tab, and select Advanced.

**Note** You cannot configure process priority settings for a shared or remote virtual machine.

<table>
<thead>
<tr>
<th>Table 12-10. Process Priority Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
</tr>
<tr>
<td>Input grabbed</td>
</tr>
<tr>
<td>Input ungrabbed</td>
</tr>
</tbody>
</table>

The Normal setting specifies that processes in the virtual machine contend equally for resources with all other processes running on the host.

Gathering Debugging Information

When it runs in debugging mode, a virtual machine collects information that helps VMware technical support resolve problems.

To configure debugging mode for a selected virtual machine, select VM > Settings, click the Options tab, and select Advanced. The debugging level is set in the Gather debugging information drop-down menu.
Table 12-11. Debugging Levels

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Normal mode. No debugging information is gathered. When this mode is selected, the virtual machine runs faster than it does in the other modes. When the cause and remedy for the problem are found, return to normal mode by selecting None.</td>
</tr>
<tr>
<td>Full</td>
<td>Select this mode if the virtual machine crashes and you want to send the debugging logs to VMware technical support.</td>
</tr>
<tr>
<td>Statistics</td>
<td>Select this mode if the virtual machine runs very slowly under certain workloads. You can send the statistics file to VMware technical support.</td>
</tr>
</tbody>
</table>

If you select the Full option, you can select the Gather verbose USB debugging information check box for USB debugging purposes.

For local virtual machines, you can select Log virtual machine progress periodically to increase logging information for debugging and troubleshooting purposes. You cannot use this feature for remote or shared virtual machines. When this setting is selected, you do not need to edit a configuration file or restart the virtual machine to extract more detailed logging for VMware technical support.

Configuring Advanced Settings for a Virtual Machine

You can configure advanced settings for the selected virtual machine to disable memory page trimming, enable Template mode, and boot the virtual machine from EFI.

To configure additional advanced options for a selected virtual machine, select VM > Settings, click the Options tab, and select Advanced.

**Note** You cannot configure these options for a shared or remote virtual machine.

Table 12-12. Additional Advanced Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable memory page trimming</td>
<td>Workstation Pro uses a memory trimming technique to return unused virtual machine memory to the host machine for other uses. While trimming usually has little effect on performance and might be needed in low-memory situations, the I/O caused by memory trimming can sometimes interfere with disk-oriented workload performance in a guest.</td>
</tr>
<tr>
<td>Log virtual machine progress periodically</td>
<td>When enabled, Workstation Pro includes information about your virtual machine's virtual CPU state, instruction pointer, and code segment registers in the log file. This is useful for troubleshooting or optimizing the performance of your virtual machine.</td>
</tr>
<tr>
<td>Enable Template mode (to be used for cloning)</td>
<td>When you create a linked clone of a virtual machine, the clone depends on the parent virtual machine to function. If a linked clone cannot access the parent virtual machine or the snapshot on which the clone is based, the clone no longer operates. You can avoid this problem by designating the parent virtual machine of a linked clone as a template. You typically must have write access to a virtual machine to clone it. A virtual machine that is designated as a clone template can be cloned by users who do not have write access to the template virtual machine. To protect linked clones, you cannot delete a template virtual machine. You cannot delete snapshots of the template.</td>
</tr>
<tr>
<td>Boot with EFI instead of BIOS</td>
<td>When enabled, the virtual machine is booted from Extensible Firmware Interface (EFI) instead of BIOS. The guest operating system to be installed on the virtual machine must support EFI firmware. You can specify the EFI firmware option when you create a remote virtual machine in shared virtual machine mode.</td>
</tr>
</tbody>
</table>
Configuring Virtual Machine Hardware Settings

You can use virtual machine hardware settings to add, remove, and modify virtual devices for a virtual machine.

To configure hardware settings for a selected virtual machine, select VM > Settings and click the Hardware tab. When you select a device in the left pane, the configuration options for that device appear in the right pane.

This chapter includes the following topics:

- “Adding Hardware to a Virtual Machine,” on page 259
- “Removing Hardware from a Virtual Machine,” on page 261
- “Adjusting Virtual Machine Memory,” on page 261
- “Configuring Virtual Machine Processor Settings,” on page 261
- “Configuring and Maintaining Virtual Hard Disks,” on page 262
- “Configuring CD-ROM and DVD Drive Settings,” on page 264
- “Configuring Floppy Drive Settings,” on page 266
- “Configuring Virtual Network Adapter Settings,” on page 266
- “Configuring USB Controller Settings,” on page 270
- “Configuring Sound Card Settings,” on page 271
- “Configuring Parallel Port Settings,” on page 271
- “Configuring Serial Port Settings,” on page 271
- “Configuring Generic SCSI Device Settings,” on page 272
- “Configuring Printer Settings,” on page 273
- “Configuring Display Settings,” on page 273
- “Installing a Guest Operating System on a Physical Disk or Unused Partition,” on page 274

Adding Hardware to a Virtual Machine

You can use virtual machine hardware settings to add hardware to an existing virtual machine.

To add hardware to a selected virtual machine, select VM > Settings, click the Hardware tab, and click Add.

**NOTE** You cannot add hardware to a virtual machine while it is in suspended state.
The Add Hardware wizard prompts you to select the type of device that you want to add and to specify device-specific configuration settings. You can modify many of the configuration settings after the device is created by changing virtual machine hardware settings.

You can add the following types of devices to a virtual machine.

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Virtual hard disks</strong></td>
<td>A virtual hard disk is a set of files that appears as a physical disk drive to the guest operating system. You can configure a virtual hard disk as an IDE, SCSI, or SATA device. You can add up to 4 IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (4 controllers and 30 devices per controller) to a virtual machine. You can also give a virtual machine direct access to a physical disk.</td>
</tr>
<tr>
<td><strong>CD-ROM and DVD drives</strong></td>
<td>You can configure a virtual CD-ROM or DVD drive as an IDE, SCSI, or SATA device. You can add up to 4 IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (4 controllers and 30 devices per controller) to a virtual machine. You can connect virtual CD-ROM and DVD drives to a physical drive on the host system or to an ISO image file.</td>
</tr>
<tr>
<td><strong>Floppy drives</strong></td>
<td>You can add up to two floppy drives. A virtual floppy drive can connect to a physical drive on the host system, to an existing floppy image file, or to a blank floppy image file.</td>
</tr>
<tr>
<td><strong>Network adapters</strong></td>
<td>You can add up to 10 virtual network adapters to a virtual machine.</td>
</tr>
<tr>
<td><strong>USB controller</strong></td>
<td>You can add one USB controller to a virtual machine. A virtual machine must have a USB controller to use USB devices or smart card readers. For smart card readers, a virtual machine must have a USB controller regardless of whether the smart card reader is actually a USB device.</td>
</tr>
<tr>
<td><strong>Sound card</strong></td>
<td>If the host system is configured for sound and has a sound card installed, you can enable sound for virtual machines.</td>
</tr>
<tr>
<td><strong>Parallel (LPT) ports</strong></td>
<td>You can attach up to three bidirectional parallel ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host operating system.</td>
</tr>
<tr>
<td><strong>Serial (COM) ports</strong></td>
<td>You can add up to four serial ports to a virtual machine. Virtual serial ports can output to physical serial ports, files on the host operating system, or named pipes.</td>
</tr>
<tr>
<td><strong>Printers</strong></td>
<td>You can print from a virtual machine to any printer available to the host system without installing additional drivers in the virtual machine. Workstation Pro uses ThinPrint technology to replicate the host machine printer mapping in the virtual machine. When you enable the virtual machine printer, Workstation Pro configures a virtual serial port to communicate with the host printers.</td>
</tr>
<tr>
<td><strong>Generic SCSI devices</strong></td>
<td>You can add up to 60 SCSI devices to a virtual machine. A generic SCSI device gives the guest operating system direct access to a SCSI device connected to the host system. Generic SCSI devices can include scanners, tape drives, CD-ROM drives, and DVD drives.</td>
</tr>
</tbody>
</table>
Removing Hardware from a Virtual Machine

You can remove certain types of hardware from a virtual machine. To remove hardware from a selected virtual machine, select **VM > Settings**, click the **Hardware** tab, select the device, and click **Remove**.

**Note** You cannot remove hardware from a virtual machine while it is in suspended state.

You can remove the following types of devices from a virtual machine.

- Virtual hard disks
- CD-ROM and DVD drives
- Floppy drives
- Virtual network adapters
- USB controllers
- Sound cards
- Printers
- Generic SCSI devices

You cannot remove the Memory, Processors, and Display device types.

You must power off a virtual machine before you remove a virtual network adapter, sound card, parallel port, serial port, or generic SCSI device. You must also power off Workstation 5 virtual machines before you remove a USB controller.

Adjusting Virtual Machine Memory

You can adjust the amount of memory that is allocated to a virtual machine. You must power off a virtual machine before you change its memory allocation setting.

To adjust the memory allocation for a selected virtual machine, select **VM > Settings**, click the **Hardware** tab, and click **Memory**.

The Memory panel includes information to help you select the appropriate amount of memory for the virtual machine. The high end of the range is determined by the amount of memory that is allocated to all running virtual machines. If you allow virtual machine memory to be swapped, this value changes to reflect the specified amount of swapping.

The color-coded icons on the Memory panel indicate the maximum recommended memory, the recommended memory, and the guest operating system recommended minimum memory amounts. To adjust the memory, move the slider along the range of values, or type a value in the **Memory for this virtual machine** text box.

**Note** Allocating more than the maximum memory to a virtual machine might cause memory swapping. It can also negatively affect host system performance, including the ability to run Workstation Pro.

Configuring Virtual Machine Processor Settings

You can configure processor settings for a virtual machine, including the number of processors, the number of cores per processor, and the preferred execution mode for the virtualization engine.

To configure processor settings for a selected virtual machine, select **VM > Settings**, click the **Hardware** tab, and select **Processors**.
**Table 13-1. Processor Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of processors and Number of cores per processor</td>
<td>Select the number of processors and the number of cores per processor. Workstation Pro supports up to 16-way virtual Symmetric Multiprocessing (SMP) for guest operating systems running on multiprocessor host machines. You can assign processors and cores per processor to a virtual machine on any host machine that has at least two logical processors.</td>
</tr>
</tbody>
</table>

**Preferred mode**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic</td>
<td>Workstation Pro chooses the execution mode based on the guest operating system and the host CPU.</td>
</tr>
<tr>
<td>Binary translation</td>
<td>Workstation Pro uses a mix of directly executing guest code and binary translation to run the guest operating system. Guest memory mapping is performed by using shadow page tables.</td>
</tr>
<tr>
<td>Intel VT-x or AMD-V</td>
<td>Workstation Pro uses hardware extensions to run and isolate guest code. Guest memory mapping is performed by using shadow page tables.</td>
</tr>
<tr>
<td>Intel VT-x/EPT or AMD-V/RVI</td>
<td>Workstation Pro uses hardware extensions to run and isolate guest code. Guest memory mapping is performed by using hardware paging.</td>
</tr>
</tbody>
</table>

**Note:** You cannot configure this setting for a shared or remote virtual machine.

**Disable acceleration for binary translation**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In rare instances, you might find that Workstation Pro appears to freeze when you install or run software inside a virtual machine. This problem typically occurs early in the execution of the program. In many cases, you can prevent the problem by temporarily disabling acceleration in the virtual machine. After the program passes the point at which the problems occur, deselect this setting.</td>
<td></td>
</tr>
</tbody>
</table>

**Virtualize Intel VT-x/EPT or AMD-V/RVI**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workstation Pro forces the virtual machine execution mode to VT-x/EPT or AMD-V/RVI. Physical Address Extension (PAE) mode must be enabled to use virtualized AMD-V/RVI. If the execution mode is not supported by the host system, virtualized VT-x/EPT or AMD/RVI is not available. If you migrate the virtual machine to another VMware product, virtualized VT-x/EPT or AMD-V/RVI might not be available.</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** You cannot configure this setting for a shared or remote virtual machine.

**Virtualize CPU performance counters**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn on this feature if you plan to use performance monitoring applications such as VTune or OProfile to optimize or debug software that runs inside the virtual machine. This feature is available only if the virtual machine compatibility is Workstation 9 or later.</td>
<td></td>
</tr>
</tbody>
</table>

---

**Configuring and Maintaining Virtual Hard Disks**

You can configure virtual hard disk node and mode settings. You can also use command in the Utilities menu to perform common disk maintenance tasks, such as defragmenting, compacting, and expanding a disk.

To perform actions on a virtual hard disk for a selected virtual machine, select VM > Settings, click the Hardware tab, and select the virtual hard disk.
Defragmenting Virtual Hard Disks

Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual disk.

Expanding Virtual Hard Disks

Expanding a virtual hard disk adds storage space to the virtual machine.

Compacting Virtual Hard Disks

Compacting a virtual hard disk reclaims unused space in the disk. If a disk has empty space, this process reduces the amount of space the virtual hard disk occupies on the host drive. You must power off a virtual machine before you compact its virtual hard disk.

Changing Virtual Hard Disk Node and Mode Settings

You can change virtual hard disk node and mode settings.

Defragmenting Virtual Hard Disks

Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual disk.

There must be adequate free working space on the host system to defragment a virtual hard disk. If the disk is contained in a single file, for example, you need free space equal to the size of the disk file. Other virtual hard disk configurations require less free space. You cannot defragment a virtual hard disk while it is mapped or mounted.

To defragment a virtual hard disk for a selected virtual machine, select VM > Settings, click the Hardware tab, select the virtual hard disk, and select Defragment from the Utilities menu.

Note Defragmenting a virtual hard disk can take several minutes.

Expanding Virtual Hard Disks

Expanding a virtual hard disk adds storage space to the virtual machine.

When you expand a virtual hard disk, the added space is not immediately available to the virtual machine. To make the added space available, you must use a disk management tool to increase the size of the existing partition on the virtual hard disk to match the expanded size.

The disk management tool that you use depends on the virtual machine guest operating system. Many operating systems, including Windows Vista, Windows 7, and some versions of Linux, provide built-in disk management tools that can resize partitions. Third-party disk management tools are also available, such as Symantec/Norton PartitionMagic, EASEUS Partition Master, Acronis Disk Director, and the open-source tool GParted.

When you expand the size of a virtual hard disk, the sizes of partitions and file systems are not affected.

To expand a virtual hard disk for a selected virtual machine, select VM > Settings, click the Hardware tab, select the virtual hard disk, and select Expand from the Utilities menu.

Note As an alternative to expanding a virtual hard disk, you can add a new virtual hard disk to the virtual machine.
Compacting Virtual Hard Disks

Compacting a virtual hard disk reclaims unused space in the disk. If a disk has empty space, this process reduces the amount of space the virtual hard disk occupies on the host drive. You must power off a virtual machine before you compact its virtual hard disk.

You cannot compact a virtual hard disk if disk space is preallocated or if the virtual hard disk is mapped or mounted.

To compact a virtual hard disk for a selected virtual machine, select VM > Settings, click the Hardware tab, select the virtual hard disk, and select Compact from the Utilities menu.

Changing Virtual Hard Disk Node and Mode Settings

You can change virtual hard disk node and mode settings.

To change the node and mode settings for a virtual hard disk on a selected virtual machine, select VM > Settings, click the Hardware tab, select the virtual hard disk, and click Advanced. By default, changes are immediately written to the disk. The data on the disk is saved when you take a snapshot of the virtual machine.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual device node</td>
<td>Select the SCSI, IDE, or SATA device identifier to use for the drive. For example, if you select SCSI 0:2, the guest operating system detects the drive as ID 2 on controller 0. You determine whether the virtual disk is seen as a SCSI, IDE, or SATA device at the time that you create it.</td>
</tr>
<tr>
<td>Independent</td>
<td>For independent disks, records data on the disk when you take a snapshot of the virtual machine. If the Independent check box is unavailable, the virtual machine might have snapshots. After you delete the snapshots, the check box becomes available. You can further specify whether changes that you make to the disk should persist or be discarded when you power off or restore a snapshot.</td>
</tr>
</tbody>
</table>

Configuring CD-ROM and DVD Drive Settings

You can configure CD-ROM and DVD drive settings, including the virtual device node and legacy emulation modes.

To configure CD-ROM and DVD drive settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and select the drive.

- Configuring CD-ROM and DVD Drive Status and Connection Settings on page 265
  Device status and connection settings control when a CD-ROM or DVD drive is connected to a virtual machine, whether to use a specific drive or allow Workstation Pro to detect a drive, and whether to use an ISO image file instead of a physical drive.

- Changing Virtual Device Node and Legacy Emulation Settings on page 265
  You can use the advanced settings to change the virtual device node and legacy emulation settings for a CD-ROM or DVD drive. You must power off the virtual machine before you change these settings.
Configuring CD-ROM and DVD Drive Status and Connection Settings

Device status and connection settings control when a CD-ROM or DVD drive is connected to a virtual machine, whether to use a specific drive or allow Workstation Pro to detect a drive, and whether to use an ISO image file instead of a physical drive.

To configure device status and connection settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and select the drive.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the drive or ISO image file while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the drive or ISO image path when you power on the virtual machine.</td>
</tr>
<tr>
<td>Connection</td>
<td>Select the location of the physical drive or ISO image file.</td>
</tr>
<tr>
<td>Remote Server</td>
<td>(Remote virtual machine only) The physical drive or ISO image file is located on the remote host.</td>
</tr>
<tr>
<td>Local Client</td>
<td>(Remote virtual machine only) The physical drive or ISO image file is located on the local host.</td>
</tr>
<tr>
<td>Local (Across Sessions)</td>
<td>(Shared virtual machine only) The physical drive or ISO image file can be used across multiple sessions.</td>
</tr>
<tr>
<td>Local (Single Session)</td>
<td>(Shared virtual machine only) The physical drive or ISO image file can be used only in this session.</td>
</tr>
<tr>
<td>Use physical drive</td>
<td>Select a specific drive or select Auto detect to allow Workstation Pro to detect a drive to use.</td>
</tr>
<tr>
<td>Use ISO image file</td>
<td>Specify or select an ISO image file for the virtual machine to use.</td>
</tr>
</tbody>
</table>

To disable or enable access to a CD-ROM or DVD drive while a virtual machine is running, select the virtual machine, select VM > Removable Devices > CD/DVD, and select Disconnect or Connect.

Changing Virtual Device Node and Legacy Emulation Settings

You can use the advanced settings to change the virtual device node and legacy emulation settings for a CD-ROM or DVD drive. You must power off the virtual machine before you change these settings.

To configure virtual device and legacy emulation settings for a selected virtual machine, select VM > Settings, click the Hardware tab, select the drive, and click Advanced.

Use the settings to select which SCSI, IDE, or SATA device identifier to use for the drive. For example, if you select SCSI 0:2, the guest operating system detects the drive as ID 2 on controller 0. You can select the IDE, SCSI, or SATA node options regardless of the physical device type. For example, if the physical drive is an IDE device, you can select a SCSI node. In this case, the virtual machine detects the drive as a SCSI device.

If you select the Legacy emulation setting, the virtual hardware works as it did in an earlier release of Workstation Pro. By default, Workstation Pro attempts to make the advanced features of your drive available, but sometimes this setting might cause the drive to not work with the virtual machine. Selecting the Legacy emulation setting reverts Workstation Pro to the previous emulation mode for the drive. Legacy emulation is helpful for troubleshooting purposes.
Configuring Floppy Drive Settings

You can configure when a floppy drive is connected to a virtual machine, whether to use a specific drive or allow Workstation Pro to detect a drive, and whether to use an disk drive image file instead of a physical drive.

To configure floppy drive settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and select the floppy drive.

**Table 13-4. Floppy Drive Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the drive or floppy image file while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the floppy drive when you power on the virtual machine.</td>
</tr>
<tr>
<td>Location</td>
<td>Select the location of the physical drive or floppy image file.</td>
</tr>
<tr>
<td></td>
<td><strong>Remote Server</strong>              (Remote virtual machine only) The physical drive or floppy image file is located on the remote host.</td>
</tr>
<tr>
<td></td>
<td><strong>Local Client</strong>               (Remote virtual machine only) The physical drive or floppy image file is located on the local host.</td>
</tr>
<tr>
<td></td>
<td><strong>Local (Across Sessions)</strong>    (Shared virtual machine only) The physical drive or floppy image file can be used across multiple sessions.</td>
</tr>
<tr>
<td></td>
<td><strong>Local (Single Session)</strong>     (Shared virtual machine only) The physical drive or floppy image file can be used only in this session.</td>
</tr>
<tr>
<td>Use a physical drive</td>
<td>Select a specific floppy drive or select Auto detect to allow Workstation Pro to detect a drive to use.</td>
</tr>
<tr>
<td>Use a floppy image file</td>
<td>Create or browse to a floppy image (.img or .flp) file. Select Read only to prevent changes from being made to the file.</td>
</tr>
</tbody>
</table>

To disable or enable access to a floppy drive while a virtual machine is running, select the virtual machine, select VM > Removable Devices > Floppy, and select Disconnect or Connect.

Configuring Virtual Network Adapter Settings

You can configure when a virtual network adapter is connected to a virtual machine and the type of network connection that the adapter provides.

The type of network configuration that you can select depends on whether the virtual machine is a local, shared, or remote virtual machine.

To configure virtual network adapter settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and select the virtual network adapter.

- **Configuring Virtual Network Adapter Device Status Settings** on page 267
  Device status settings control when a virtual network adapter is connected to a virtual machine.

- **Configuring a Network Connection** on page 267
  You can configure the type of network connection that a virtual network adapter provides.

- **Configuring Virtual Network Adapter Advanced Settings** on page 269
  You can use the advanced virtual network adapter settings to limit the bandwidth and specify the acceptable packet loss percentage for incoming and outgoing data transfers.
Configuring Virtual Network Adapter Device Status Settings

Device status settings control when a virtual network adapter is connected to a virtual machine.

To configure virtual network adapter device status settings for a selected virtual machine, select \texttt{VM > Settings}, click the \texttt{Hardware} tab, and select the virtual network adapter.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the virtual network adapter while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the virtual network adapter when you power on the virtual machine.</td>
</tr>
</tbody>
</table>

Configuring a Network Connection

You can configure the type of network connection that a virtual network adapter provides.

For a local virtual machine, you can configure bridged, NAT, or host-only networking, or you can select a custom network or LAN segment. For a shared virtual machine, you can select bridged, NAT, or host-only networking from a drop-down menu. For a remote virtual machine, you must select a custom network.

To configure a network connection for a selected virtual machine, select \texttt{VM > Settings}, click the \texttt{Hardware} tab, and select the virtual network adapter.

- Configuring Bridged Networking on page 267
  When you configure bridged networking, the virtual machine uses physical network adapters on the host system to connect a network.

- Configuring Network Address Translation on page 268
  When you configure Network Address Translation (NAT), the virtual machine shares the IP address and MAC address of the host system.

- Configuring Host-Only Networking on page 268
  When you configure host-only networking, Workstation Pro creates a virtual private network (VPN) connection between the virtual machine and the host system.

- Configuring a Custom Network Configuration on page 269
  A custom network is a network that you create by using the virtual network editor. You can select a custom network when you modify the network connection setting for a local virtual machine. For a remote virtual machine, you must select a custom network. You cannot select a custom network for a shared virtual machine.

- Configuring LAN Segments on page 269
  When you select a LAN segment, the virtual machine uses a private network that can be shared with other virtual machines. LAN segments are useful for multitier testing, network performance analysis, and situations where virtual machine isolation are important.

Configuring Bridged Networking

When you configure bridged networking, the virtual machine uses physical network adapters on the host system to connect a network.

If the host system is on a network, bridged networking is often the easiest way to give a virtual machine access to that network.
With bridged networking, the virtual machine appears as an additional computer on the same physical Ethernet network as the host system. The virtual machine can transparently use the services available on the network, including file servers, printers, and gateways. Physical hosts and other virtual machines configured with bridged networking can also use the resources of the virtual machine.

When you use bridged networking, the virtual machine must have its own identity on the network. For example, on a TCP/IP network, the virtual machine must have its own IP address. Virtual machines typically acquire an IP address and other network details from a DHCP server. In some configurations, you might need to set the IP address and other details manually.

Users who boot multiple operating systems often assign the same address to all systems because they assume that only one operating system will be running at the same time. If the host system is set up to boot multiple operating systems and you run one or more of them in virtual machines, configure each operating system with a unique network address.

When the Replicate physical connection state option is selected, the IP address is automatically renewed when you move from one wired or wireless network to another. This setting is useful for virtual machines than run on laptops or other mobile devices.

Configuring Network Address Translation

When you configure Network Address Translation (NAT), the virtual machine shares the IP address and MAC address of the host system.

The virtual machine and the host system share the a single identity that is not visible outside the network. The virtual machine does not have its own IP address. Instead, a separate private network is set up on the host system and the virtual machine obtains an address on that network from the VMware virtual DHCP server. The VMware NAT device passes network data between one or more virtual machines and the external network. The VMware NAT device identifies incoming data packets that are intended for each virtual machine and sends them to the correct destination.

With NAT, a virtual machine can use many standard protocols to connect to other machines on the external network. For example, you can use HTTP to browse Web sites, FTP to transfer files, and Telnet to log in to other systems. You can also connect to a TCP/IP network by using a Token Ring adapter on the host system.

In the default configuration, systems on the external network cannot initiate connections to the virtual machine. For example, the default configuration does not let you use the virtual machine as a Web server to send Web pages to systems on the external network. This limitation protects the guest operating system from being compromised before you can install security software.

By default, NAT is used when you use the New Virtual Machine wizard to create a virtual machine.

The virtual machine uses NAT to connect to the Internet or other TCP/IP network by using the networking connection on the host system. NAT works with Ethernet, DSL, and phone modems. A separate private network is set up on the host system. The virtual machine obtains an address on that network from the VMware virtual DHCP server.

Configuring Host-Only Networking

When you configure host-only networking, Workstation Pro creates a virtual private network (VPN) connection between the virtual machine and the host system.

A VPN is typically not visible outside the host system. Multiple virtual machines configured with host-only networking on the same host system are on the same network. The VMware DHCP server provides addresses on the network.

If you install the proper routing or proxy software on the host system, you can establish a connection between the host virtual network adapter and a physical network adapter on the host system. With this configuration, you can connect the virtual machine to a Token Ring or other non-Ethernet network.
Configuring a Custom Network Configuration

A custom network is a network that you create by using the virtual network editor. You can select a custom network when you modify the network connection setting for a local virtual machine. For a remote virtual machine, you must select a custom network. You cannot select a custom network for a shared virtual machine.

A custom network can be connected to one or more external networks, or it can run entirely on the host system. You can use the virtual network editor to access multiple network cards in the host system and create multiple virtual networks.

For more information, see Chapter 14, “Using the Virtual Network Editor,” on page 275.

 Configuring LAN Segments

When you select a LAN segment, the virtual machine uses a private network that can be shared with other virtual machines. LAN segments are useful for multilayer testing, network performance analysis, and situations where virtual machine isolation are important.

You cannot configure a LAN segment for a shared or remote virtual machine.

If you add an existing virtual machine to a LAN segment, the virtual machine might be configured to expect an IP address from a DHCP server. Unlike host-only and NAT networking, Workstation Pro does not provide a DHCP server for LAN segments. You must manually configure IP addressing for virtual machines on a LAN segment. You can either configure a DHCP server on the LAN segment to allocate IP addresses, or you can configure a fixed IP address for each virtual machine on the LAN segment.

If you convert a team that was created in an earlier version of Workstation Pro, the LAN segment that was configured for the team appears in the LAN segment drop-down menu for each virtual machine.

You can click LAN Segments to create new LAN segments or delete and rename existing LAN segments. Deleting a LAN segment disconnects all virtual network adapters that are configured for that LAN segment. When you delete a LAN segment, you must manually configure its disconnected virtual network adapter to reconnect the virtual machine to the network.

Configuring Virtual Network Adapter Advanced Settings

You can use the advanced virtual network adapter settings to limit the bandwidth and specify the acceptable packet loss percentage for incoming and outgoing data transfers.

To configure advanced virtual network adapter settings for a selected virtual machine, select VM > Settings, click the Hardware tab, select the virtual network adapter, and click Advanced.

**Note** You cannot configure advanced virtual network adapter settings for a shared or remote virtual machine.
Table 13-6. Virtual Network Adapter Advanced Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bandwidth and Kbps</strong></td>
<td>To limit incoming or outgoing data transfers to the data transfer rate for a specific network connection type, select the network connection type from the Bandwidth drop-down menu. The value in the Kbps text box changes to the data transfer rate, in kilobits per second, of the network connection type that you select. For example, if you select Leased Line T1 (1.544 Mbps), the value in the Kbps text box changes to 1544. To limit incoming or outgoing data transfers to a specific data transfer rate, select Custom and type the data transfer rate in kilobits per second in the Kbps text box. The default bandwidth setting for both incoming and outgoing data transfers is Unlimited.</td>
</tr>
<tr>
<td><strong>Packet Loss (%)</strong></td>
<td>The acceptable packet loss percentage for incoming or outgoing data transfers. The default setting is 0.0%.</td>
</tr>
<tr>
<td><strong>MAC Address</strong></td>
<td>To assign a new MAC address to the network adapter, either type a new address in this text box or click Generate to have Workstation Pro generate a new address.</td>
</tr>
</tbody>
</table>

Configuring USB Controller Settings

You can configure whether a USB controller supports isochronous USB and Bluetooth devices, when to connect new USB devices to the host system, and whether human interface devices (HIDs) appear in the Removable Devices menu.

**NOTE** You typically cannot configure USB controller settings for a shared or remote virtual machine.

To configure USB controller settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and click USB Controller.

Table 13-7. USB Controller Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>USB Compatibility</strong></td>
<td>Selecting USB 2.0 or 3.0 enables support for isochronous USB devices, including Web cams, speakers, and microphones.</td>
</tr>
<tr>
<td><strong>Automatically connect new USB devices</strong></td>
<td>Connect new USB devices to the virtual machine. If this setting is not selected, new USB devices are connected only to the host system.</td>
</tr>
<tr>
<td><strong>Show all USB input devices</strong></td>
<td>Human interface devices (HIDs), such as USB 1.1 and 2.0 mouse and keyboard devices, appear in the Removable Devices menu. Icons for HIDs appear in the status bar. An HID that is connected to the guest operating system is not available to the host system. The virtual machine must be powered off when you change this setting.</td>
</tr>
<tr>
<td><strong>Share Bluetooth devices with the virtual machine</strong></td>
<td>Enable support for Bluetooth devices.</td>
</tr>
</tbody>
</table>

To connect or disconnect USB devices while a virtual machine is running, select the virtual machine and select VM > Removable Devices. With the two-port USB controller, you can connect to both USB 1.1 and USB 2.0 devices.

**IMPORTANT** Before you unplug a USB device or select a removable device to disconnect a USB device from a virtual machine, follow the device manufacturer’s procedures for safely unplugging the device from a physical computer.
Configuring Sound Card Settings

You can configure when a sound card is connected to a virtual machine. You can also configure whether a virtual machine uses a specific sound card or the default sound card in the host system.

To configure sound card settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and click Sound Card.

**Table 13-8. Sound Card Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the sound device while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the sound device when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use default host sound card</td>
<td>Make the virtual machine use the default sound card in the host system.</td>
</tr>
<tr>
<td>Specify host sound card</td>
<td>(Windows hosts only) Select a specific host sound card for the virtual machine to use.</td>
</tr>
<tr>
<td>Use physical sound card</td>
<td>(Linux hosts only) Select a specific host sound card to for the virtual machine to use.</td>
</tr>
<tr>
<td>Enable Echo Cancellation</td>
<td>Enable echo cancellation for the sound card.</td>
</tr>
</tbody>
</table>

**Note** You cannot change sound card settings for a remote virtual machine.

Configuring Parallel Port Settings

You can configure when a parallel port is connected to a virtual machine and whether to send output to a physical port or to a file on the host system.

To configure parallel port settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and select the parallel port.

**Table 13-9. Parallel Port Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the port while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the port when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use a physical parallel port</td>
<td>Select a host parallel port for the virtual machine to use.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output from the virtual parallel port to a file on the host system.</td>
</tr>
</tbody>
</table>

**Either locate an existing output file or browse to a directory and type a filename to create a new output file.**

Configuring Serial Port Settings

You can configure when a serial port is connected to a virtual machine. You can also configure whether to send output to a physical port or to a file on the host system, set up a direct connection between two virtual machines, and specify whether the guest operating system uses the port in polled mode.

To configure serial port settings for a selected virtual machine, select the virtual machine, select VM > Settings, click the Hardware tab, and select the serial port.
Table 13-10. Serial Port Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the port while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the port when you power on the virtual machine.</td>
</tr>
<tr>
<td>Use a physical serial port</td>
<td>Select a host serial port.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output from the virtual serial port to a file on the host system.</td>
</tr>
<tr>
<td>Use named pipe or Use socket</td>
<td>Set up a direct connection between two virtual machines or a connection</td>
</tr>
<tr>
<td></td>
<td>between a virtual machine and an application on the host system.</td>
</tr>
<tr>
<td>Yield CPU on poll</td>
<td>The guest operating system uses the port in polled mode rather than</td>
</tr>
<tr>
<td></td>
<td>interrupt mode. It yields processor time if its only task is to poll the</td>
</tr>
<tr>
<td></td>
<td>virtual serial port.</td>
</tr>
<tr>
<td></td>
<td>Note This setting is useful for developers who are using debugging tools</td>
</tr>
<tr>
<td></td>
<td>that communicate over a serial connection. Selecting this setting can</td>
</tr>
<tr>
<td></td>
<td>improve performance when the guest operating system uses the serial port in</td>
</tr>
<tr>
<td></td>
<td>polled mode.</td>
</tr>
</tbody>
</table>

Table 13-11. Generic SCSI Device Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the device while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the device when you power on the virtual machine.</td>
</tr>
<tr>
<td>Specify the physical SCSI</td>
<td>Select a host SCSI device.</td>
</tr>
<tr>
<td>device to connect to</td>
<td>(Windows hosts) Select a device. The menu shows the SCSI devices that are</td>
</tr>
<tr>
<td></td>
<td>available on the host system.</td>
</tr>
<tr>
<td></td>
<td>(Linux hosts) Type the name of the /dev/sg entry for the device to install</td>
</tr>
<tr>
<td></td>
<td>in the virtual machine. For example, if the device is named sga, type /dev/</td>
</tr>
<tr>
<td></td>
<td>sga.</td>
</tr>
<tr>
<td>Virtual device node</td>
<td>Select the SCSI device identifier to use for the drive. For example, if you</td>
</tr>
<tr>
<td></td>
<td>select SCSI 0:2, the guest operating system sees the drive as ID 2 on</td>
</tr>
<tr>
<td></td>
<td>controller 0.</td>
</tr>
<tr>
<td></td>
<td>The virtual machine must be powered off when you change this setting.</td>
</tr>
</tbody>
</table>

Note: For specific Windows guest operating systems, you might need to perform additional configuration steps to use a generic SCSI device.
Configuring Printer Settings

You can configure when a printer is connected to a virtual machine.

To configure printer settings for a selected virtual machine, select VM > Settings, click the Hardware tab, and select Printer.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connect the printer while the virtual machine is running.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Connect the printer when you power on the virtual machine.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accelerate 3D graphics</td>
<td>Select this setting if you run applications that use DirectX 9 or DirectX 10 accelerated graphics. Accelerated graphics capabilities apply to Windows XP or later guests on hosts running Windows or Linux. The virtual machine must be a Workstation 6.x or later virtual machine and must have VMware Tools installed from Workstation 7.x or later.</td>
</tr>
<tr>
<td>Use host setting for monitors</td>
<td>When you select this setting, the SVGA driver uses two monitors, a maximum bounding box width of 3840, and a maximum bounding box height of 1920. The virtual machine is configured to have a minimum of two 1920x1200 monitors, in a side-by-side topology, in both normal and rotated orientations. If the host system has more than two monitors, the virtual machine uses the number of monitors on the host system instead. If the host system’s bounding box is wider or taller than the defaults, the virtual machine uses the larger size. You should select this setting in most cases.</td>
</tr>
<tr>
<td>Specify monitor settings</td>
<td>Set the number of monitors that the virtual machine will see, regardless of the number of monitors on the host system. This setting is useful if you use a multimonitor host system and you need to test in a virtual machine that has only one monitor. It is also useful if you are developing a multimonitor application in a virtual machine and the host system has only one monitor. After you power on the virtual machine, the guest operating system sees the number of monitors that you specified. Select a resolution from the list or type a setting that has the format width x height, where width and height are the number of pixels. <strong>Note</strong> You cannot configure the resolution setting for a shared or remote virtual machine.</td>
</tr>
<tr>
<td>Graphics memory</td>
<td>Select the maximum amount of guest memory that can be used for graphics memory using the drop down menu. The default value of video memory varies by guest OS.</td>
</tr>
<tr>
<td>Display Scaling</td>
<td>Enables display scaling for the virtual machine display. The user interface is automatically adjusted when the display changes.</td>
</tr>
</tbody>
</table>
Installing a Guest Operating System on a Physical Disk or Unused Partition

You can install a guest operating system directly on a physical disk or unused partition on the host system. A physical disk directly accesses an existing local disk or partition. You can use physical disks to run one or more guest operating systems from existing disk partitions.

Workstation Pro supports physical disks up to 2 TB capacity. Booting from an operating system already set up on an existing SCSI disk or partition is not supported.

Running an operating system natively on the host system and switching to running it inside a virtual machine is similar to pulling the hard drive out of one computer and installing it in a second computer that has a different motherboard and hardware. The steps you take depend on the guest operating system in the virtual machine. In most cases, a guest operating system that is installed on a physical disk or unused partition cannot boot outside of the virtual machine, even though the data is available to the host system. See the Dual-Boot Computers and Virtual Machines technical note on the VMware Web site for information about using an operating system that can also boot outside of a virtual machine.

After you configure a virtual machine to use one or more partitions on a physical disk, do not modify the partition tables by running `fdisk` or a similar utility in the guest operating system. If you use `fdisk` or a similar utility on the host operating system to modify the partition table of the physical disk, you must recreate the virtual machine physical disk. All files that were on the physical disk are lost when you modify the partition table.

**Important** You cannot use a physical disk to share files between the host system and a guest operating system. Making the same partition visible to both the host system and a guest operating system can cause data corruption. Instead, use shared folder to share files between the host system and a guest operating system.
You can use the virtual network editor to view and change key networking settings, add and remove virtual networks, and create custom virtual networking configurations. The changes that you make in the virtual network editor affect all virtual machines running on the host system.

On a Windows host, any user can view network settings, but only Administrator users can change them. On a Linux host, you must enter the root password to access the virtual network editor.

On Windows hosts, select Edit > Virtual Network Editor to start the virtual network editor in Workstation Pro. You can also select Start > Programs > VMware > Virtual Network Editor to start the virtual network editor from the host operating system.

On Linux hosts, select Applications > System Tools > Virtual Network Editor to start the virtual network editor. The menu path might be different for your version of Linux. You can also start the network editor from the command line by using the `vmware-netcfg` command.

**IMPORTANT** When you click Restore Default to restore the default network settings, all changes that you made to network settings after you installed Workstation Pro are permanently lost. Do not restore the default network settings when a virtual machine is powered on as this might cause serious damage to the bridged networking.

This chapter includes the following topics:

- “Add a Bridged Virtual Network,” on page 276
- “Add a Host-Only Virtual Network,” on page 277
- “Change Automatic Bridging Settings,” on page 278
- “Change NAT Settings,” on page 278
- “Change DHCP Settings on a Windows Host,” on page 280
Add a Bridged Virtual Network

If you installed Workstation Pro on a host system that has multiple network adapters, you can configure multiple bridged networks.

By default, virtual switch VMnet0 is mapped to a bridged network. You can create a custom bridged network on virtual switches VMnet2 to VMnet7. On Windows, you can also use VMnet19. On Linux, you can also use vmnet10 through vmnet255.

**IMPORTANT** If you reassign a physical network adapter to a different virtual network, any virtual machine that used the original network is no longer bridged to the external network through that virtual network and you must change the setting for each affected virtual machine network adapter individually. This restriction can be especially problematic if the host system has only one physical network adapter and you reassign it to a virtual network other than VMnet0. Even though the virtual network appears to bridge to an automatically chosen adapter, the only adapter it can use was assigned to a different virtual network.

**Prerequisites**

- Familiarize yourself with bridged networking. See “Configuring Bridged Networking,” on page 267 for more information.
- Verify that a physical network adapter is available on the host system. By default, the VMnet0 virtual switch is set to use automatic bridging mode and bridges to all active physical network adapters on the host system. You can make a physical network adapter available by restricting the physical network adapters that are bridged to VMnet0. See “Change Automatic Bridging Settings,” on page 278 for more information.

**Procedure**

1. Select Edit > Virtual Network Editor.
2. Click Add Network.
3. Select a virtual switch.
   Workstation Pro assigns a subnet IP address to the virtual network adapter.
4. Select the new virtual network from the list and select **Bridged (connect VMs directly to the external network)**.
5. From the Bridged to menu, select a physical adapter on the host system to bridge to.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatic</strong></td>
<td>Workstation Pro automatically bridges the virtual network to all active physical network adapters on the host system. The choice of which adapter to use is arbitrary.</td>
</tr>
<tr>
<td><strong>physical_adapter</strong></td>
<td>Bridge to a specific physical network adapter on the host system.</td>
</tr>
</tbody>
</table>

6. (Optional) If you selected automatic bridging mode and you want to place restrictions on the physical adapters that the virtual network adapter bridges to, click **Automatic Settings** and deselect one or more physical adapters.
7. Click **OK** to save your changes.
Add a Host-Only Virtual Network

You can use the virtual network editor to set up multiple host-only virtual networks.

On Windows and Linux host systems, the first host-only network is set up automatically when you install Workstation Pro. You might want to set up multiple host-only networks on the same computer in the following situations.

- To have two virtual machines connected to one host-only network, and other virtual machines connected to another host-only network to isolate the network traffic on each network.
- To test routing between two virtual networks.
- To test a virtual machine that has multiple network interface cards, without using any physical network adapters.

Prerequisites
Familiarize yourself with host-only networking. See “Configuring Host-Only Networking,” on page 268 for more information.

Procedure
1. Select Edit > Virtual Network Editor.
2. Click Add Network.
3. Select a virtual switch.
   - On Windows and Linux hosts, the VMnet1 virtual switch is mapped to a host-only network by default. Workstation Pro assigns a subnet IP address to the virtual network.
4. Select the new virtual network from the list and select Host-only (connect VMs internally on a private network).
5. (Optional) To connect a physical network on the host system to the network, select Connect a host virtual adapter to this network.
6. (Optional) To use a local DHCP service to distribute IP addresses to virtual machines on the network, select Use local DHCP service to distribute IP addresses to VMs.
7. (Optional) (Windows hosts only) To customize DHCP settings if the network uses a local DHCP service, click DHCP Settings.
8. (Optional) To change the subnet IP address or subnet mask, modify the addresses in the Subnet IP and Subnet mask text boxes.
9. Click OK to save your changes.
Change Automatic Bridging Settings

When automatic bridging mode is configured, you can restrict the physical network adapters that a virtual switch bridges to.

Procedure

1. Start the virtual network editor on the host system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Select Edit &gt; Virtual Network Editor.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Select Applications &gt; System Tools &gt; Virtual Network Editor. The menu path might be different for your version of Linux. You can also start the network editor from the command line by using the <code>vmware-netcfg</code> command.</td>
</tr>
</tbody>
</table>

2. Select the bridged network, and click **Automatic Settings**.

   By default, a virtual switch bridges to all active network adapters on the host system when it is configured for automatic bridging. The choice of which adapter to use is arbitrary.

   To prevent a virtual switch from bridging to a particular physical network adapter, deselect the check box for that host network adapter.

Change NAT Settings

You can change the gateway IP address, configure port forwarding, and configure advanced networking settings for NAT networks.

Prerequisites

- Determine whether you are going to use the host virtual network adapter. The host system uses VMware Network Adapter VMnet1 to connect to the host-only network and it uses VMware Network Adapter VMnet8 to connect to the NAT network.

- On a Windows host, log in as an Administrator user. Only an Administrator user can change network settings in the virtual network editor.

- On a Linux host, log in as root. You must enter the root password to use the virtual network editor.

Procedure

1. Start the virtual network editor on the host system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Select Edit &gt; Virtual Network Editor.</td>
</tr>
<tr>
<td>Linux host</td>
<td>Select Applications &gt; System Tools &gt; Virtual Network Editor. The menu path might be different for your version of Linux. You can also start the network editor from the command line by using the <code>vmware-netcfg</code> command.</td>
</tr>
</tbody>
</table>

2. Select the NAT network, and click **NAT Settings**.

   By default, the NAT device is connected to the VMnet8 virtual switch. You can have only one NAT virtual network.
<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gateway IP</td>
<td>The gateway IP address for the selected network.</td>
</tr>
<tr>
<td>Port Forwarding</td>
<td>Add a port for port forwarding. With port forwarding, incoming TCP or UDP requests are sent to a specific virtual machine on the virtual network that is served by the NAT device.</td>
</tr>
<tr>
<td><strong>Host port</strong></td>
<td>The number of the incoming TCP or UDP port. For example, incoming HTTP requests are usually on port 80.</td>
</tr>
<tr>
<td><strong>Virtual machine IP address</strong></td>
<td>The IP address of the virtual machine to which you want to forward the incoming requests.</td>
</tr>
<tr>
<td><strong>Virtual machine port</strong></td>
<td>The port number to use for requests on the specified virtual machine. It may be the standard port, such as 80 for HTTP, or a nonstandard port if software running in the virtual machine is configured to accept requests on a nonstandard port.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>(Optional) You can use this text box to identify the forwarded service, for example, HTTP.</td>
</tr>
<tr>
<td>Allow active FTP</td>
<td>Allow only passive mode FTP over the NAT device.</td>
</tr>
<tr>
<td>Allow any Organizationally Unique Identifier</td>
<td>Select this setting if you change the organizationally unique identifier (OUI) portion of the MAC address for the virtual machine and subsequently cannot use NAT with the virtual machine.</td>
</tr>
<tr>
<td>UDP timeout (in seconds)</td>
<td>Select the number of minutes to keep the UDP mapping for the NAT.</td>
</tr>
<tr>
<td>Config port</td>
<td>Select the port to use to access status information about NAT.</td>
</tr>
<tr>
<td><strong>IMPORTANT</strong></td>
<td>Change this value only under the direction of VMware technical support.</td>
</tr>
<tr>
<td>Enable IPv6</td>
<td>Enable NAT to use an IPv6 address.</td>
</tr>
<tr>
<td>IPv6 Prefix</td>
<td>If IPv6 is enabled, enter the IPv6 prefix that the NAT device uses.</td>
</tr>
<tr>
<td>DNS Settings</td>
<td>(Windows hosts only) Configure the DNS servers for the virtual NAT device to use.</td>
</tr>
<tr>
<td><strong>Auto detect available DNS servers</strong></td>
<td>Select this option to detect the available DNS servers. To add a DNS server to the list, deselect this check box and enter the IP address of the preferred and alternate DNS servers in the Preferred DNS server text boxes.</td>
</tr>
<tr>
<td><strong>Policy</strong></td>
<td>If you have multiple DNS servers, select the strategy for choosing which server to send a request to. <strong>Order</strong> sends one DNS request at a time in order of the name. <strong>Rotate</strong> sends one DNS request at a time and rotates through the DNS servers. <strong>Burst</strong> sends to three servers and waits for the first server to respond.</td>
</tr>
<tr>
<td><strong>Timeout (sec)</strong></td>
<td>Select the number of seconds to keep trying if the NAT device cannot connect to the DNS server.</td>
</tr>
<tr>
<td><strong>Retries</strong></td>
<td>Select the number of retries.</td>
</tr>
<tr>
<td>NetBios Settings</td>
<td>(Windows hosts only) Select NBNS (NetBIOS Name Service) and NBDS (NetBIOS Datagram Service) timeouts and retry settings.</td>
</tr>
</tbody>
</table>
Change DHCP Settings on a Windows Host

On a Windows host, you can change the range of IP addresses and the duration of DHCP licenses for NAT and host-only networks that use a DHCP service to distribute IP addresses.

Procedure

1. Select **Edit > Virtual Network Editor**.
2. Select the NAT or host-only network, and click **DHCP Settings**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start IP address and End IP address</td>
<td>The range of IP addresses that the virtual DHCP service provides on the selected virtual network.</td>
</tr>
<tr>
<td>Default lease time and Max lease time</td>
<td>Select the duration of the DHCP leases that the DHCP service provides to clients on the virtual network.</td>
</tr>
</tbody>
</table>
Running the Support Script

VMware technical support might ask you to run the support script to gather information from the host system or virtual machines running on the host system. For example, if a virtual machine exits abnormally or fails, you can run the support script to collect the appropriate log files and system information. You can run the support script from Workstation Pro, from a Windows command prompt, or from a Linux terminal window.

**Note** The support script collects local data only. It does not collect data for remote hosts or for virtual machines running on remote hosts.

To collect diagnostic information for VMware Tools, you must edit the tools.conf file. See the VMware knowledge base article at http://kb.vmware.com/kb/1010744 for more information.

This chapter includes the following topics:

- “Register and Create a Support Request,” on page 281
- “Run the Support Script from Workstation Pro,” on page 282
- “Run the Support Script from a Windows Command Prompt,” on page 282
- “Run the Support Script from a Linux Terminal Window,” on page 283

**Register and Create a Support Request**

To report problems to VMware support, you create a support request.

**Prerequisites**

Locate your Workstation Pro license key. The license key is sent to you in an email message when you register.

**Procedure**

1. If you do not have a VMware account, select Help > Enter License Key > Register and follow the instructions on the Web site.

2. Select Help > Support > Submit Support Request to create a support request.
Run the Support Script from Workstation Pro

You can run the support script from Workstation Pro to collect support data from the local host system or from the local host system and selected virtual machines running on the local host system.

On a Linux host, the script displays messages that indicate that it cannot collect some information because you are not logged in as root. If VMware technical support needs this information, a support representative will ask you to run the script from a terminal window as root. See “Run the Support Script from a Linux Terminal Window,” on page 283.

Prerequisites

- Create a support request. See “Register and Create a Support Request,” on page 281.
- Increase the level of logging. See “Gathering Debugging Information,” on page 256.
- If you plan to collect support data from specific virtual machines, verify that the latest version of VMware Tools is installed and power on the virtual machines.

Procedure

1. On the host system, select Help > Support > Collect Support Data in Workstation Pro.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>To collect data from the host system and a virtual machine</td>
<td>Select the virtual machine and click Collect. You can select multiple virtual machines.</td>
</tr>
<tr>
<td>To collect data only from the host system</td>
<td>Deselect all virtual machines and click Collect.</td>
</tr>
</tbody>
</table>

   On a Windows host, the support script creates a .ZIP file of the collected data and displays the file in an open Windows Explorer window. Choose a directory location for the .ZIP file. On a Linux host, the support script creates a compressed .TGZ file in your home directory.

2. Add the .ZIP or .TGZ file to your support request.

Run the Support Script from a Windows Command Prompt

On a Windows host system, you can run the support script from the Windows command prompt to collect support data from the local host system.

Prerequisites

- Create a support request. See “Register and Create a Support Request,” on page 281
- Increase the level of logging. See “Gathering Debugging Information,” on page 256.

Procedure

1. Open a command prompt on the Windows host system and change to the VMware Workstation directory.
   
   For example: `cd C:\Program Files\VMware\VMware Workstation`

2. Run the support script.
   
   `cscript vm-support.vbs`
   
   The script displays the name of the directory where it stores its output.

3. Use a file compression utility to compress the script output directory.

4. Include the zip file of the script output directory with your support request.
Chapter 15 Running the Support Script

5 If you are reporting a problem that occurred during Workstation Pro installation, include the installation log file (VMInst.log) with your support request.

The installation log file is located in the Temp directory. On a Windows host, the default location is C:\Documents and Settings\username\Local Settings\temp.

Run the Support Script from a Linux Terminal Window

On a Linux host system, you can run the support script from a Linux terminal window to collect support data from the local host system.

If you do not run the support script as root, the script displays messages that indicate that it cannot collect some information. If the VMware support team needs this information, a support representative will ask you to run the script as root.

Prerequisites

- Create a support request. See “Register and Create a Support Request,” on page 281
- Increase the level of logging. See “Gathering Debugging Information,” on page 256.

Procedure

1 On the Linux host system, open a terminal window and run the support script as root or as the user who is running the virtual machine.

   vm-support

   The script creates a compressed .TGZ file in the user’s home directory.

2 Include the .TGZ file with your support request.

3 If you are reporting a problem that occurred during Workstation Pro installation, include the installation log file with your support request.
Using the `vmware` Command

You can use the `vmware` command to run Workstation Pro from the command line on a Linux or Windows host system.

This chapter includes the following topics:
- “Run the `vmware` Command,” on page 285
- “Incorporate Workstation Pro Startup Options in a Windows Shortcut,” on page 286

Run the `vmware` Command

You can run the `vmware` command on a Linux or Windows host system. You can type the command in a Linux terminal window or at the Windows command prompt. You can also create scripts to run multiple commands.

Prerequisites

Familiarize yourself with the `vmware` command options. See “`vmware` Command Options,” on page 285.

Procedure

- To run the `vmware` command on a Linux host system, use the following syntax.

  ```bash
  /usr/bin/vmware [-n] [-x] [-t] [-q] [-s variable_name = value] [-v] [path_to_vm.vmx] [http[s]://path_to_vm.vmx] [X toolkit options]
  ```

- To run the `vmware` command on a Windows host system, use the following syntax.

  ```bash
  C:\Program Files\VMware\VMware Workstation\vmware.exe [-n] [-x] [-t] [-q] [-s variable_name = value] [-v] [path_to_vm.vmx] [http[s]://path_to_vm.vmx]
  ```

`vmware` Command Options

When you run the `vmware` command, you can specify certain options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-n</code></td>
<td>Opens a new Workstation Pro window.</td>
</tr>
<tr>
<td><code>-t</code></td>
<td>Opens a virtual machine in a new tab in the existing Workstation Pro window.</td>
</tr>
<tr>
<td><code>-x</code></td>
<td>Powers on the virtual machine when Workstation Pro starts. This option is equivalent to clicking <strong>Power On</strong> in the Workstation Pro toolbar.</td>
</tr>
<tr>
<td><code>-X</code></td>
<td>Powers on the virtual machine and switches the Workstation Pro window to full screen mode.</td>
</tr>
</tbody>
</table>
### Table 16-1. vmware Command Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-q</td>
<td>Closes the virtual machine tab when the virtual machine powers off. If no other virtual machine is open, it also exits Workstation Pro. This option is useful when the guest operating system can power off the virtual machine.</td>
</tr>
<tr>
<td>-s</td>
<td>Sets the specified variable to the specified value. You can specify at the command line any variable names and values that are valid in the configuration file.</td>
</tr>
<tr>
<td>-v</td>
<td>Displays the product name, version, and build number.</td>
</tr>
<tr>
<td>path_to_vm.vmx</td>
<td>Launches a virtual machine by using the specified virtual machine configuration (.vmx) file.</td>
</tr>
</tbody>
</table>

On Linux hosts, you can pass X toolkit options as arguments, such as `--display` and `--geometry`. Some options, such as the size and title of the Workstation Pro window, cannot be overridden.

### Incorporate Workstation Pro Startup Options in a Windows Shortcut

The most convenient way to use `vmware` command options is to incorporate them into the command that a Windows shortcut generates.

**Prerequisites**

Familiarize yourself with the `vmware` command options. See “vmware Command Options,” on page 285.

**Procedure**

1. Right-click the Workstation Pro shortcut and select **Properties**.
2. In the **Target** text box, add any options to use after the `vmware.exe` command and enclose the entire command string in quotation marks.

   For example:

   ```
   "C:\Program Files\VMware\VMware Workstation\vmware.exe -X \\
   C:\Documents and Settings\username\My Documents\My Virtual Machines\Windows Me\Windows Me.vmx"
   ```
Index

A
accelerated 3D graphics
  preparing a virtual machine 120
  preparing the host system 119
acceleration, disabling 122
ACPI S1 sleep feature 80
Administrator default role 224
Advanced Linux Sound Architecture 15
advanced options 256
Aero Peek thumbnails 234
ALSA
  configuring virtual machines 123
  giving a user permission 122
  overriding the library version 122
  using 122
appliance view 255
autofit settings 237
Autologin 255
Autologon, configuring 75
automatic bridging settings 278
AutoProtect snapshots, enabling 108
AutoProtect feature 251
Autorun feature 251
A

B
background settings, configuring 78
bandwidth, configuring 180
batch power operations 103, 234
battery information 97
BIOS, virtual machine support 16
boot from EFI 257
bridged networking
  assigning IP addresses 182
  configuring 181–183
C
CD-ROM drives
  adding 143
  configuring 143
  configuring legacy emulation mode 145
changing settings 186, 278
chip sets, virtual machine support 16
cleaning up virtual disks 137
clones
  creating 54, 56
  full 55
  linked 55
closing virtual machines 77
copy and paste feature
  disabling 82
  restrictions 81
  using 81
CPU, host requirements 13
creating virtual machines 39
Creative Labs Sound Blaster 18
Ctrl+Alt, using in a key combination 166
cursor settings 235
custom configuration, virtual machine 40
custom networking 269
D
DDNS 198
deleting, virtual machines 113
device settings 244
devices, configuring and managing 143
DHCP
  changing settings 200
  DHCPD 198
  editing the configuration file 201
DHCP server, NAT 185
DHCP settings 280
disk drives
  cleaning up 137
  host requirements 15
  virtual machine support 17
disk modes, configuring 47
disk node and mode settings 264
disk types 47
display settings, configuring 118
display preferences 236
displays
  changing 96
  changing settings 273
  configuring preference settings 117
host requirements 14
resizing 100
download components 63
downloading virtual machines 221
drag-and-drop feature
  disabling 81
  restrictions 81
  using 80
drawing tablets, virtual machine support 18
DVD drives
  adding 143
  configuring 143
  configuring legacy emulation mode 145

easy install, responding to prompts 42, 51
Eclipse, installing 23
ECR errors, troubleshooting 158
EFI support 43, 76
encryption
  changing the password 127
  limitations 124
  removing 126
  virtual machine 123, 125
enhanced virtual keyboard, installing the driver 165
Ethernet cards, virtual machine support 18
exclusive mode 98
exit behavior 232
expiration date, timestamp 126
exporting OVF files 137

files, virtual machine 71
floppy drives
  adding 144
  configuring 143
  virtual machine support 17
folders
  creating 103
  managing virtual machines 102
  removing virtual machines 103
FreeBSD guest operating system, VMware Tools installation or upgrade (tar installer) 69
full screen mode 97
full screen settings 237

G
general option settings 247
generic SCSI devices
  adding 161
  avoiding concurrent access problems on Linux 162
  configuring 161
troubleshooting detection problems 162
glossary 7
graphics, virtual machine support 16
guest isolation 252
guest operating systems
  changing 248
  installing manually 52
  selecting 41
  supported 16

H
hard disk, cleanup 137
hard power controls 115
hardware
  adding to virtual machines 259
  customizing 50
  removing from virtual machines 261
  hardware compatibility, changing 32, 136
  hardware compatibility setting
    selecting in the New Virtual Machine wizard 41
  setting 233
  hardware settings, modifying 173
  HD Audio 18
  host-only networks
    adding 182, 194
    avoiding packet leakage 197
    configuring 193, 195
  host-only networking 268, 277
  hot keys
    changing combinations 166, 236
    changing for Unity mode 167
    default combinations 38
  human interface devices, connecting 92

I
I/O controller types 45
IDE 45
IDE drives
  host requirements 15
  virtual machine support 17
importing virtual machines 59
Input preferences 234
input problems 235
install components 63
installation properties 25
installation restrictions 22
installing VMware Tools
  FreeBSD (tar installer) 69
  Linux (tar installer) 69
  Microsoft Windows 65
  NetWare (tar installer) 68
index

process overview 61
Solaris (tar installer) 68
installing Workstation Pro
Linux host 26
unattended installation on Windows host 24
Windows host 23
Intel High-Definition Audio 18
intended audience 7
IP addresses, assigning 199, 202

K
key code mappings, configuring 169
key mappings, changing 168
keyboard features, configuring 164
keyboard settings 235
keyboard shortcuts 166, 236
keysyms
defined 168
mapping 169

L
LAN segments
configuring 203
configuring virtual machines to use 203
creating 203
deleting 204
language codes 133
license key, obtaining 21
linked clones, moving 129
Linux guest, VMware Tools installation or upgrade (tar installer) 66
local area networking, host requirements 15
lock files 153

M
MAC addresses
assigning manually 206
changing 206
mapped drives 88
maximum virtual disk size 49
memory
host requirements 14
virtual machine allocation 16
memory allocation 44
memory preference settings 242
memory settings 243, 261
memory trimming 257
menu settings 237
Microsoft Windows guest operating system, VMware Tools installation or upgrade 65
monitor settings 273
monitors, using multiple 99, 100
mouse settings 235
mouse types, virtual machine support 18
moving virtual machines
considerations 129
new location or host 128

N
naming virtual machines 248
NAT
configuration file sections 188
configuring 184, 268
editing the configuration file 188
external access 186
features and limitations 185
sample Linux configuration file 190
specifying connections from ports below 1024 192
using NetLogon 191, 192
NAT device, understanding 185
NetLogon 191
NetWare guest operating system, VMware Tools installation or upgrade (tar installer) 68
network
changing the configuration 177
virtual network editor 179
network configuration example 207, 208
network connection types 45, 267
networking components, understanding 175
networking configurations, common 176
New Virtual Machine wizard 50, 252
No Access default role 224

O
online help, using 38
operating systems
host supported 14
OS upgrades on Windows hosts 22
optical drives supported in host 15
OVA format virtual machines 59
OVF files, exporting virtual machines 137
OVF format virtual machines 59

P
packet forwarding, disabling 197
packet leakage, host-only networks 197
packet loss 269
packet loss percentage, configuring 180
parallel ports
configuring 156, 157
configuring device permissions 158
configuring on Linux 2.6.x kernels hosts 157
virtual machine support 17
passwords for encrypting and restricting virtual machines 123, 125
pause feature restrictions 78
pausing virtual machines 78
PDAs, installing drivers 92
permissions
adding 228
changing 229
removing 229
understanding 227
physical machines
preparing for virtualization 58
virtualizing 57
physical disks
adding to an existing virtual machine 155
preparing to use 47, 154
using in a virtual machine 154
power controls 249
power off behavior, configuring 115
power on delay 104, 234
power options
changing 249
configuring 249
powering off virtual machines 77
preference settings 231
printers
changing settings 273
using host printers in a virtual machine 89
priority preferences 243
process priorities 243, 256
processors
configuring 261
host requirements 13
specifying number 44
supported in virtual machines 16
using a virtual machine that has more than sixteen 164
promiscuous mode 205

R
RAM, host requirements 14
Read Only default role 224
remote access
configuring 211, 212
enabling 241
remote servers
connecting 214
disabling the prompt to save login information 215
disconnecting 216
downloading virtual machines from 221
removing saved login information 215
remote hosts, saving login information 234
removable devices, using in virtual machines 90
repairing VMware Tools installations 70
reserved memory 242
resizing
Linux guests 101
Solaris guests 101
restricted virtual machine, expiration date 126
restriction password 126
restrictions password 123, 125
resuming virtual machines 79
roles
changing 225
cloning 226
creating 225
default 224
removing 227
using to assign privileges 224
routing
between host-only networks 195
controlling on host-only networks 198
S
Samba
adding user passwords 204
configuring 204
on both bridged and host-only networks 205
SATA 45
SATA drives 15
screen colors, setting for virtual machines 121
screen resolutions, working with nonstandard 102
screenshots, creating for virtual machines 112
SCSI 45
SCSI devices, virtual machine support 17
SCSI drives, host requirements 15
serial ports
changing the input speed 160
configuring 156, 159
using to debug applications 138, 139
virtual machine support 17
shared files, optimizing read and write access 86
shared folders
changing 87
changing properties 87
configuring 83
created by other users 85
disabling 87
enabling all folders by default 233
mounting 85
supported guest operating systems 83
using 82
using permissions to restrict access 86
viewing in Windows 85
shared virtual machines
configuring 216
configuring autostart 223
installing drivers 91
mounting on a Linux host 92
troubleshooting connection issues 93
understanding device control sharing 93
USB controller settings 270
USB ports, virtual machine support 18
User Experience Improvement Program 240
UUIDs
clones 54
configuring 131, 132
using 131
V
v-scan codes 170
vCPU
best use 44
specifying number 44
virtual disks
allocating disk space 48
changing settings 262
cleaning up 137
compacting 264
configuring in the New Virtual Machine wizard 46
defragmenting 263
disconnecting from the host 89
expanding 263
mapping and mounting 88
SSD 15
virtual machine, expiration date 126
virtual machines
changing hardware compatibility 31, 135
configuring 115
configuring for compatibility 130
configuring power off behavior 115
deleting 113
downloading from a remote server 221
installing software 111
managing 115
moving 127
specifications 16
understanding 39
uploading to remote servers 219, 220
uploading to VMware vCloud Air 221
using 73
using the New Virtual Machine Wizard 40
virtual disk
bus type 49
controller type 49
maximum size 49
optimize behavior 15
virtual disk capacity 49
virtual disk files 49
Virtual Disk Manager 153
virtual hard disks
adding 149, 150
cleaning up 137
compacting 151
configuring 147
defragmenting 152
expanding 151
growing and allocating storage space 149
moving 154
removing 152
setting up as IDE or SCSI 148
using legacy 153
virtual machine library 35
virtual machine files
changing the default location 232
specifying in the New Virtual Machine wizard 42
virtual machine options 247
virtual machine shortcut 54
virtual machines directory 43
virtual network adapter, changing 178
virtual network adapters
adding 178
configuring 266
connection settings 267
virtual network editor 275
virtual networking
configuring 175
virtual machine support 18
virtual printing 245
virtual symmetric multiprocessing, configuring 163
virtualizing physical machines 57
Visual Studio, installing 23
VIX API 138
VM, expiration date 126
VM Creator default role 224
VM User default role 224
VMCI Sockets interface 138
VMnet
virtual network 175
virtual switch 175
vmware command
incorporating into a Windows shortcut 286
options 285
running 285
using 285
VMware Tools
configuring updates for virtual machines 253
installing 65
updating on a specific virtual machine 64
using 60
VMware account registration 281
VMware Tools installation
  FreeBSD (tar installer) 69
  Linux (tar installer) 66
  Microsoft Windows 65
  NetWare (tar installer) 68
  process 61
  Solaris (tar installer) 68
VMware Tools upgrade
  FreeBSD (tar installer) 69
  Linux (tar installer) 66
  Microsoft Windows 65
  NetWare (tar installer) 68
  process 62
  Solaris (tar installer) 68
VMware Workstation Server, understanding 211
VMware Workstation Player, using virtual machines 129
vmware-user, starting manually 70
VNC client, connecting to a virtual machine 134
VNC client access 254
VNC connections, viewing 135
VNC server
  configuring a virtual machine 132
  specifying a language keyboard map 133
W
Windows activation problems 58
Windows authentication problems 58
Windows operating system upgrades 22
Windows Virtual PC virtual machines 60
Windows XP Mode virtual machine, importing 59
working directory for virtual machine files 248
worksheet, typical virtual machine 40
Workspace preferences 231
Workstation Pro tabs 37
Workstation Pro window
  customizing the view 37
  performing virtual machine operations 35
  using 34
Workstation Server, log files 141, 214
X
X server and keyboard mapping 167
x-key codes, defined 168
xFree86 and keyboard mapping 167