To upgrade from version 3.0, you must use the command-line interface of each of the appliances. You can also upgrade from version 3.x by using the command-line interface.