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About vRealize Network Insight Installation
Guide

The vRealize Network Insight Installation Guide is intended for administrators or specialists responsible for
installing vRealize Network Insight.

Intended Audience

This information is intended for administrators or specialists responsible for installing
vRealize Network Insight. The information is written for experienced virtual machine administrators who
are familiar with enterprise management applications and datacenter operations.

VMware Technical Publications Glossary

VMware Technical Publications provides a glossary of terms that might be unfamiliar to you. For definitions
of terms as they are used in VMware technical documentation, go to
http://www.vmware.com/support/pubs.
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Preparing for Installation

Before you install vRealize Network Insight, prepare the deployment environment to meet the system
requirements.

This chapter includes the following topics:

m  “System Requirements,” on page 7

m  “Supported Products and Versions,” on page 9

m  “Prerequisites,” on page 10

System Requirements

Ensure that the system meets the minimum hardware configurations to install vRealize Network Insight.

Minimum resource requirements
m  vRealize Network Insight Platform OVA
m 800 GB - HDD, Thin provisioned
®  Medium Brick Requirement
m 8 cores - Reservation 4096 Mhz
m 32 GB RAM - Reservation - 16GB

m  Large Brick Requirement

m 12 cores - Reservation 6144 Mhz
m 48 GB RAM - Reservation - 24GB

m  vRealize Network Insight Proxy OVA
® 150 GB - HDD, Thin provisioned

m  Medium Brick Requirement

m 4 cores - Reservation 2048 Mhz
m 10 GB RAM - Reservation - 5GB

m  Large Brick Requirement

B 6 cores - Reservation 3072 Mhz

m 12 GB RAM - Reservation - 6GB
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Software Requirements

Google Chrome or Mozilla Firefox Web browser

Privileges required for Data Sources

m  Privileges required to configure and use IPFIX
m  vCenter Server Credentials with privileges:
m  Distributed Switch: Modify
m  dvPort group: Modify
m  The predefined roles in the vCenter server must have the following privileges:
®  System.Anonymous
m  System.Read
m  System.View
m  global.settings
m  Privileges required for NSX Manager Data Provider
m  NSX Manager Data Provider requires the Enterprise role.
m  If Central CLI is enabled, then the system admin credentials are required for NSX Manager Data
Provider.
m  User privileges required on Cisco switches for metrics collection
m  vRealize Network Insight is capable of collecting metric data via SNMP as well as configuration via
SSH from Cisco Switches. Cisco Switches UCS platform requires the use of both SSH and API for
collection.
Table 1-1.
Type of data User Privileges
Configuration Data Read-Only
Metric Data SNMP read-only
SNMPv2 read-only SNMP community
SNMPv3 read-only
NorTtE
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Chapter 1 Preparing for Installation

Supported Products and Versions

vRealize Network Insight support several products and versions.

Environment Version/Model Description
VMware vSphere m  vSphere 5.5 (up to U3) Data provider connects to
m  vSphere 6.0 (up to U2) VMware vCenter over HTTPS to
®  vSphere 6.5 fetch virtual environment
P . . information.
For IPFIX, VMware ESXi version needed:
m 5.5 Update 2 (Build 2068190) and above
m 6.0 Update 1b (Build 3380124) and above
m  VMware VDS 5.5 and above
Note vmtools should be installed on all the
Virtual Machines in the data center to identify
the VM to VM path.
VMware NSX m 63 (upto6.3.1) The data provider connects:
B 6.2 (upto6.2.6) B VMware NSX Manager over
m 6.1 (upto6.1.7) HTTPS
B 60 ®  VMware NSX Controller
over SSH
m  VMware NSX Edge over SSH
or Central CLI depending on
customer preference

Cisco Nexus 5000, 7000, 9000, VSM N1000 The data provider connects Cisco
Nexus switches over SSH v2 and
SNMP.

Cisco UCS (Unified Computing Series B blade servers, Series C rack servers, The data provider connects to

System) Chassis, Fabric interconnect UCS Manager over HTTPS and
UCS Fabric Interconnect over
SSH to fetch information. It also
connects to the SNMP service on
UCS.

Cisco Catalyst switches 3000, 3750, 4500, 6000, 6500 The data provider Cisco Catalyst
switches connects to device over
SSH and SNMP.

Dell switches FORCE10 MXL 10, FORCE10 S6000, 54048, The data provider connects to

79100, S4810, PowerConnect 8024 Dell switches over SSH v2 and
SNMP.

Arista switches 7050TX, 7250QX The data provider connects to
Arista switches over SSH v2 and
SNMP.

Brocade Switches VDX 6740, VDX 6940 The data provider connects to
Brocade switches over SSH v2
and SNMP.

Juniper Switches EX3300 The data provider connects to
Juniper switches over SSH v2
and SNMP.

Palo Alto Networks Panorama 7.0.x, Panorama 7.1 The data provider connects to
Palo Alto Panorama appliance
HTTPS.

HP HP Virtual Connect Manager 4.41 The data provider connects to
HP Virtual Connect Manager
over SSH v2.
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Prerequisites
Certain prerequisites for installing vRealize Network Insight are as follows:

m  If the vRealize Network Insight platform is behind an Internet proxy, ensure that you whitelist the
following domain names and ports:

Table 1-2.

Service URL Port
Upgrade Service/Metric Service svc.ni.vmware.com 443
Support Tunnel Service support2.ni.vmware.com 443
Registration Service reg.ni.vmware.com 443
Log Service log.ni.vmware.com 443
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You can deploy vRealize Network Insight using vSphere Web client or vSphere Windows native client.

NotEe After you successfully deploy vRealize Network Insight Platform OVA, verify whether the given
static IP is set on vCenter Server.

This chapter includes the following topics:

m  “Installation Workflow,” on page 11

m  “Deploying vRealize Network Insight Platform OVA,” on page 12
m  “Activating the License,” on page 14

m  “Generating Shared Secret,” on page 14

B “Setting up vRealize Network Insight Proxy Virtual Appliance (OVA),” on page 14
m  “Deploy Additional Proxy to an Existing Setup,” on page 16

m  “Default Login Credentials,” on page 17

m “NSX Assessment Mode for Evaluation License,” on page 17

m  “Add vCenter Server,” on page 17

m  “Analyze Traffic Flows,” on page 18

m  “Generate a Report,” on page 18

m  “Adding Data Sources,” on page 18

Installation Workflow

To install vRealize Network Insight, you install the platform OVA, activate the license, generate shared
secret, and setup proxy OVA.

Note The terms Proxy and Collector are used interchangeably in the documentation.

VMware, Inc. 1
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Install Platform OVA
(Import in vCenter Server)

Open https://<Platform IP Address=
and activate license

Generate Shared Secret
and Setup Proxy OVA

Log into vRealize Network Insight
and add Data sources

Deploying vRealize Network Insight Platform OVA

You can import the vRealize Network Insight Platform OVA to your vCenter Server.

12

Deployment using vSphere Web Client

You can deploy vRealize Network Insight using vSphere Web Client.

Procedure

1
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Right-click on the Datacenter where you want to install the appliance and select Deploy OVF
Template.

Browse to select the source location of the appliance OVA.

Verify the OVF template details.

Read the End User License Agreement and click Accept.

Select the destination folder in which you want to create the VM and give a desired name to the VM.
Select the Deployment Configuration.

Select a Host/Cluster where you want to run the deployed template.

Select the Resource Pool in which you want to deploy this template.

Select the Datastore where you want to store the files.

Select Thin Provision as the Virtual Disk format.

VMware, Inc.
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Select the Network that the deployed VM will use.

Selected network should allow the appliance to reach out to the Internet for support and upgrade.
Customize the template as mentioned below:

a  IPv4 Address: First reserved static IP address

b Netmask: Subnet mask for the above static IP

¢ Gateway: Default gateway of your network

d  DNS Server List: DNS servers of your environment

e  (Optional) DNS Server List: DNS servers of your environment

f  Domain Search List: Determines which domain to be appended for dns lookups.

g (Optional) NTP Server List: Enter the list of NTP servers and ensure that NTP Server can be
reached from the VM. The services will fail to start if NTP time is out of sync.

h  (Optional) Web Proxy IP/FQDN and Web Proxy Port: For accessing the Internet using a proxy

i (Optional) Syslog server IP : Syslog server IP [Optional]: IP address of the syslog server where you
want to send the syslog messages

j  Uncheck the Log Push Enable checkbox if you do not want to send diagnostic and troubleshooting
data to VMware.

Review the details and select the Power on after deployment checkbox, then click Finish.

Deployment using vSphere Windows Native Client

You can deploy vRealize Network Insight using vSphere Windows native client.

Procedure

1
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Click File > Deploy OVF Template.

Browse to select the source location of the OVA.

Click Next and Verify OVF template details.

Ensure that the desired folder is selected and give a name to the VM.
Select the Deployment Configuration.

Select a Host/Cluster where you want to run the deployed template.
Select the Resource Pool in which you want to deploy this template.
Select the Datastore where you want to store the files.

Select Thin Provision as the Virtual Disk format.

Map the Network from OVA to your inventory

Customize the template as mentioned below:

a  IPv4 Address: First reserved static IP address

b Netmask: Subnet mask for the above static IP

¢ Gateway: Default gateway of your network

d DNS Server List: DNS servers of your environment

e (Optional) DNS Server List: DNS servers of your environment

f  Domain Search List: Determines which domain to be appended for dns lookups.
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g (Optional) NTP Server List: Enter the list of NTP servers and ensure that the NTP Server can be
reached from the VM. The services will fail to start if NTP time is out of sync.

h  (Optional) HTTP Proxy IP/FQDN and HTTP Proxy Port: For accessing the Internet using a proxy

i (Optional) Syslog server IP : IP address of the syslog server where you want to send the syslog
messages

j  Uncheck the Log Push Enable checkbox if you do not want to send diagnostic and troubleshooting
data to VMware.

k  Select the Health Telemetry Enable checkbox to improve the product by sending anonymous data
about product performance.

12 Review the details and select the Power on after deployment checkbox, then click Finish.

Generating the Support Tunnel Certificate
Perform this step only if you are offline or have restricted access to Internet.

To generate the support tunnel certificate:

1  Log on to the console user CLI and run the offline-registration command.

2 The CLI generates a token. After you supply this token to VMware Support, an entry is created in the
registration server and a certificate is given to you.

3 Install this certificate by using the offline-registration command.

Activating the License

Before the deployment, activate and install the vRealize Network Insight virtual appliance.

After installing the vRealize Network Insight Platform OVA, open https://<vRealize Network Insight Platform
IP address> in the Chrome Web browser.

Procedure
1  Enter the license key received in the welcome email.

2 For UI admin (admin@local) user name, set the password. If you are a support user or a CLI user, refer
“Default Login Credentials,” on page 17for the password.

3 Click Activate.

4 Add the vRealize Network Insight Collector after activating the license.

Generating Shared Secret

You can generate and import the vRealize Network Insight proxy virtual appliance.

Generate a shared secret and import the vRealize Network Insight proxy virtual appliance:

Procedure
1  Generate a shared secret after activating the license on the Setup Proxy Virtual Appliance page.
2 Copy the shared secret.

You will require this during the deployment of vRealize Network Insight Proxy OVA.

Setting up vRealize Network Insight Proxy Virtual Appliance (OVA)
You can set up vRealize Network Insight proxy virtual appliance by importing OVA to your vCenter server.

Follow the steps below to import the vRealize Network InsightProxy OVA to your vCenter Server

14 VMware, Inc.
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Deployment using vSphere Web Client

You can import the vRealize Network Insight Proxy OVA using vSphere Web Client.

Procedure

1
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Right-click on the Datacenter where you want to install the appliance and select Deploy OVF Template.
Browse to select the source location of the appliance OVA.

Verify the OVF template details.

Read the End User License Agreement and click Accept.

Select the destination folder in which you want to create the VM and give a desired name to the VM.
Select the Deployment Configuration.

Select a Host/Cluster where you want to run the deployed template.

Select the Resource Pool in which you want to deploy this template.

Select the Datastore where you want to store the files.

Select Thin Provision as the Virtual Disk format.

Select the Network that the deployed VM will use.

Customize the template as mentioned below:

a  Shared Secret for vRealize Network Insight Proxy: The shared secret generated on the
onboarding page

b  IPv4 Address: Second reserved static IP address

¢ Netmask: Subnet mask for the above static IP

d Gateway: Default gateway of your network

e  DNS Server List: DNS servers of your environment

f  (Optional) Domain Search List : Determines which domain to be appended for dns lookups

g  NTP Server List: Enter the list of NTP servers and ensure that the NTP Server can be reached from
the VM. The services will fail to start if NTP time is out of sync.

h  (Optional) Web Proxy IP/FQDNand Web Proxy Port: For accessing the Internet using a proxy

i (Optional) Syslog server IP : IP address of the syslog server where you want to send the syslog
messages

j  Uncheck the Log Push Enable checkbox if you do not want to send diagnostic and troubleshooting

data to VMware.

k  Select the Health Telemetry Enable checkbox, to improve the product by sending anonymous data
about product performance.

Review the details and select the Power on after deployment checkbox then click Finish.

Deployment using vSphere Windows Native Client

You can import the vRealize Network Insight Proxy OVA using vSphere Windows native client.

Procedure
1  Click File > Deploy OVF Template.
2 Browse to select the source location of OVA.
VMware, Inc. 15
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Verify the OVF template details.

Read the End-User License Agreement and click Accept.

Ensure the desired folder is selected and give a name to the VM.
Select the Deployment Configuration.

Select a Host/Cluster where you want to run the deployed template.
Select the Resource Pool in which you want to deploy this template.
Select the Datastore where you want to store the files.

Select Thin Provision as the Virtual Disk format.

Select the Network that the deployed VM will use.

Map the network from OVA to your inventory.

Customize the template as mentioned below:

a  Shared Secret for vRealize Network Insight Proxy: The shared secret generated on the
onboarding page

b  IPv4 Address: Second reserved static IP address

¢ Netmask: Subnet mask for the above static IP

d Gateway: Default gateway of your network

e  DNS Server List: DNS servers of your environment

f  (Optional) Domain Search List : Determines which domain to be appended for dns lookups

g  NTP Server List: Enter the list of NTP servers and ensure that the NTP Server can be reached from
the VM. The services will fail to start if NTP time is out of sync.

h  (Optional) HTTP Proxy IP/FQDN and HTTP Proxy Port: For accessing the Internet using a proxy

i (Optional) Syslog server IP : IP address of the syslog server where you want to send the syslog
messages

j  Uncheck the Log Push Enable checkbox if you do not want to send diagnostic and troubleshooting

data to VMware.

k  Select the Health Telemetry Enable checkbox, to improve the product by sending anonymous data
about product performance.

Review the details and select the Power on after deployment checkbox then click Finish.

Note After the vRealize Network Insight Proxy OVA is deployed and running, you must verify
whether the given static IP is set on vCenter Server.

Click Finish, once Proxy Detected! message is displayed on the onboarding page. It will redirect to the
Login Page.

Deploy Additional Proxy to an Existing Setup

You can add additional vRealize Network Insight proxy to an existing setup.

Procedure

1 Log into the vRealize Network Insight UI. Navigate to Settings > Install and Support.
2 Click Add Proxy VM.

3 Copy the shared secret from the dialog that is displayed.

16
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Chapter 2 Installing vRealize Network Insight

4  Follow the steps in section “Setting up vRealize Network Insight Proxy Virtual Appliance (OVA),” on
page 14 in step 3.

Default Login Credentials

vRealize Network Insight has three types of users. The login credentials for these users are as follows:

Note Use Google Chrome to log in to vRealize Network Insight.

Table 2-1.

Types of Users Username Password

Admin UI admin@local Set this password in Activate
License screen during
installation

SSH User support arklnc0113ctOr

CLI User consoleuser arklncOns013

Procedure

1 Open https://<vRealize Network Insight Platform IP address>.

2 Log in to the product UI with the corresponding username and password.

NSX Assessment Mode for Evaluation License
vRealize Network Insight starts in the NSX assessment mode when you use the evaluation license.

You can add a data source to vRealize Network Insight, analyze traffic flow, and generate reports.

Note To switch to the Full Product mode, click Switch to Full Product Evaluation located in the bottom
right corner.

Add vCenter Server
You can add vCenter Servers as data source to vRealize Network Insight.
Multiple vCenter Servers can be added to vRealize Network Insight to start monitoring data.
Procedure
1 Click Add vCenter.

2 Click Add new source and customize the options.

Option Action

Source Type Select the vCenter Server system from the drop-down menu.

IP Address/FQDN Enter the IP address or fully qualified domain name of the vCenter Server.
Username Enter the user name, with the following privileges:

m  Distributed Switch: Modify
m  dvPort group: Modify

Password Enter the password for vRealize Network Insight software to access the
vCenter Server system.

3 Click Validate.

4  Add advanced data collection sources to your vCenter Server system.

VMware, Inc. 17
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5 (Optional) Click Submit to add the vCenter Server system. The vCenter Server systems appear on the
homepage.

Analyze Traffic Flows

You can use vRealize Network Insight to analyze flows in your datacenter.

Prerequisites

At least two hours of data collection must occur before starting the flow analysis.

Procedure

1  Specify the scope of the analysis. For example, if you are interested in flows of all virtual machines in a
Cluster, select Cluster from the dropdown menu. You can alternately select all virtual machines
connected to a VLAN or VXLAN.

2 Select the entity name for which you want to analyze the flows.

3 Select the duration and click Analyze.

Generate a Report

You can generate a report of the flow assessment.

Prerequisites

Analyze traffic flows in the datacenter. For comprehensive reports, collect 24 hours of data before the
analysis.

Procedure
1 Inthe EVAL NSX Assessment Mode, click Generate Report in the Analyze Flows page.

2 Inthe Non EVAL Mode, on the Microsegmentation page, click Traffic Distribution > More Options >
Assesment Report.

Adding Data Sources

18

After you log in, add the various data sources to vRealize Network Insight for the software to monitor your
data center.

The product will start showing the data from your environment after two hours of data collection.

Procedure

1  Select Profile > Settings.

Click the Add new source button.
Select the Source Type.

Enter the required details and click Submit to add the Data source.

(62 B O N S

Repeat the above steps to add all the required data sources from your environment.
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