vRealize Network Insight supports several products and versions.

Data Source Version/Model Connection Protocol Permissions/Privileges
Amazon Web Services (Enterprise License Only) Not Applicable HTTPS See the Add Datasources section in the User Guide.
Arista switches 7050TX, 7250QX, 7050QX-32S, 7280SE-72 SSH, SNMP See the Add Datasources section in the User Guide.
Azure Subscription Not Applicable HTTPS See the Add Datasources section in the User Guide.
Brocade Switches VDX 6740, VDX 6940, MLX, MLXe SSH, SNMP See the Add Datasources section in the User Guide.
Check Point Firewall Check Point R80, R80.10, R80.20, R80.30 HTTPS, SSH See the Add Datasources section in the User Guide.
Cisco ACI 3.2 HTTPS (to APIC controller)

SNMP (to APIC controller and ACI switches)

See the Add Datasources section in the User Guide.
Cisco ASA X Series with OS 9.4 SSH, SNMP See the Add Datasources section in the User Guide.
Cisco Catalyst 3000, 3750, 4500, 6000, 6500 SSH, SNMP See the Add Datasources section in the User Guide.
Cisco Nexus 3000, 5000, 6000, 7000, 9000 SSH, SNMP Read only user

Read only SNMP user

Cisco UCS (Unified Computing System) Series B blade servers, Series C rack servers, Chassis, Fabric interconnect UCS Manager: HTTPS

UCS Fabric: SSH, SNMP

Read only user

Read only SNMP user

Dell switches FORCE10 MXL 10, FORCE10 S6000, S4048, Z9100, S4810, PowerConnect 8024, Dell OS10 SSH, SNMP Read only user

Read only SNMP user

Fortinet FortiManager 6.0.1 HTTPS The user must have:
  • at least the Restricted User role with access to all ADOMs and policy packages.
  • the rpc-permit read access enabled from Command Line Interface (CLI).
F5 BIG - IP 12.1.2 and later HTTPS, SSH, SNMP The user must have at least the guest role. Also, TMSH must be enabled and must have access to all partitions. F5 BIG-IP supports both routing and load balancing.
HP HP Virtual Connect Manager 4.41, HP OneView 3.0 HP OneView 3.0: HTTPS

HP Virtual Connect Manager 4.41: SSH

Read only user
Huawei Cloud Engine 6800, 7800, 8800 SSH, SNMP Read only user

Read only SNMP user

Infoblox Infoblox NIOS version 8.0, 8.1, 8.2 HTTPS Read only user with API Interface access
Read-only permissions for DNS object types as follows:
  • Permission Type - DNS
  • Resource - A Records, DNS Zones, DNS Views
Juniper Switches EX3300, QFX 51xx Series (JunOS v12 & v15, without QFabric) Netconf, SSH, SNMP Read only user

Read only SNMP user

Kubernetes
  • 1.12 on NSX-T 2.3.1
  • 1.12 on NSX-T 2.3.2
  • 1.13 on NSX-T 2.3.2
HTTPS User must have cluster admin role with read permissions.
OpenShift 3.1.1 HTTPS See the Add Datasources section in the User Guide.
Palo Alto Networks Panorama 7.0.x, 7.1, 8.x, 9.0 HTTPS User must have admin role with XML API access. For details, see the Palo Alto Networks section in the vRealize Network Insight User Guide.
ServiceNow London HTTPS User must have admin role
VMware SD-WAN VeloCloud Orchestrator and Edge Version 3.3.1 and later HTTPS User must have Account Role with any of the following permission:
  • Superuser
  • Standard Admin
  • Customer Support
VMC on AWS - vCenter M8 and later
Note: Only NSX-T based VMware Cloud on AWS SDDCs are supported.
HTTPS User must have the following permission:
  • Cloud Administrator: To add data source and enable IPFIX.
VMC on AWS - NSX Manager M8 and later
Note: Only NSX-T based VMware Cloud on AWS SDDCs are supported.
HTTPS User must have any of the following permission:
  • Org Member.Administrator: To add data source and enable IPFIX.
  • Org Member.Administrator.NSX Cloud Admin: To add data source and enable IPFIX.
  • Org Member.VMware Cloud on AWS (all role): To add data source and enable IPFIX.
  • Org Member.NSX Cloud Auditor: To add data source.
VMware Identity Manager 3.3 and later HTTPS User must have admin role.
VMware PKS Supported Versions

User must have cluster admin role permissions - pks.clusters.admin.
VMware NSX Manager (VMware NSX-V) Supported Versions SSH, HTTPS See the Edge Data Collection section in the vRealize Network Insight User Guide.
VMware NSX-T Manager 2.4.

For additional supported version, see Supported Versions

HTTPS Read only user
VMware vRealize Log Insight Supported Versions HTTPS API user with permissions to install, configure, and manage the content pack
VMware vSphere Supported Versions
For IPFIX, VMware ESXi version needed:
  • 5.5 Update 2 (Build 2068190) and above
  • 6.0 Update 1b (Build 3380124) and above
  • VMware VDS 5.5 and above
Note: VMware tools should be installed on all the VMs in the data center to identify the VM to VM path.
HTTPS Read only user

Privileges required to configure and use IPFIX

vCenter Server Credentials with privileges:

Distributed Switch: Modify

dvPort group: Modify

The predefined roles in the vCenter server must have the following privileges assigned at root level that need to be propagated to the children roles:

System.Anonymous

System.Read

System.View

global.settings

Note:
  • The supported operating systems for Cisco ASA, ACI, Catalyst, and Nexus devices is iOS/NX-OS; and for Cisco UCS is UCSM version.
  • The supported operation system for Arista is Arista EOS.