Before installing and configuring the management pack, ensure your system meets the following requirements:

vRealize Operations Requirements Kubernetes Requirements
Version(s)

vRealize Operations 7.x or 8.x

(Advanced or Enterprise editions)

Kubernetes API, version 1.9 - 1.13

Connection

Kubernetes Hostname

Default Ports for Kubernetes Host:

  • Non-SSL: 8080
  • SSL: 443

Default Ports for Kubelet API:

  • Non-SSL: 10255
  • SSL: 10250
Credentials

Kubernetes Bearer Token

Note: To create a least-privileged user (LPU) for the management pack and obtain the Bearer Token required for RBAC, see: Creating a Least-Privileged User (Kubernetes).