VMware Cloud Native Storage (CNS) solution is delivered on vSphere version 6.7 Update 3 and above. The vSphere Container Storage Plug-in interacts with the CNS and connects only to vSphere 6.7 Update 3 and above. When you upgrade an older version of vSphere to 6.7 Update 3 or above, ensure to upgrade the individual ESXi hosts that are part of the cluster to 6.7 Update 3 or above.

Ensure that the vSphere versions and ESXi versions match.