Installing VMware Tools is part of the process of creating a new virtual machine, and upgrading VMware Tools is part of the process of keeping your virtual machine up to current standards.

Some new features in a particular release of a VMware product might depend on installing or upgrading to the new version of VMware Tools included in that release. Other compatibility options are also available.

  • The version of VMware Tools included in vSphere 5.0 is supported on vSphere 4.x and 5.0 virtual machines. That is, you can also use this new version of VMware Tools in virtual machines on ESX/ESXi 4.x hosts.

  • Virtual machines in a vSphere 5.0 environment support the versions of VMware Tools included in vSphere 4.0-5.0. That is, you are not strictly required to upgrade VMware Tools if VMware Tools was installed from an ESX/ESXi 4.x host.