Hosts might contain third-party software, such as Cisco Nexus 1000V VEMs or EMC PowerPath modules. When you upgrade an ESXi 5.x host to ESXi 6.0, all supported custom VIBs are migrated, regardless of whether the VIBs are included in the installer ISO.

If the host or the installer ISO image contains a VIB that creates a conflict and prevents the upgrade, an error message identifies the VIB that created the conflict.

To discover potential problems with third-party software before an upgrade operation, scan the hosts against an upgrade baseline and review the scan messages in the Update Manager Compliance view. See Host Upgrade Scan Messages in Update Manager and Host Upgrade Scan Messages When Cisco Nexus 1000V Is Present.

For information about upgrading with third-party customization, see the vSphere Upgrade documentation. For information about using vSphere ESXi Image Builder to make a custom ISO, see the vSphere Installation and Setup documentation.