A host can have custom vSphere installation bundles (VIBs) installed, for example, for third-party drivers or management agents. When you upgrade an ESXi 5.x host to ESXi 6.0, all supported custom VIBs are migrated, regardless of whether the VIBs are included in the installer ISO.

If the host or the installer ISO image contains a VIB that creates a conflict and prevents the upgrade, an error message identifies the VIB that created the conflict. To upgrade the host, take one of the following actions:

  • Remove the VIB that created the conflict from the host and retry the upgrade. If you are using vSphere Update Manager, select the option to remove third-party software modules during the remediation process. For more information, see the Installing and Administering VMware vSphere Update Manager documentation. You can also remove the VIB that created the conflict from the host by using esxcli commands. For more information, see Remove VIBs from a Host.

  • Use the vSphere ESXi Image Builder CLI to create a custom installer ISO image that resolves the conflict. For more information about vSphere ESXi Image Builder CLI installation and usage, see the vSphere Installation and Setup documentation.