Verify that the vSphere components in your environment meet the software version requirements for using Virtual SAN.

To use the full set of Virtual SAN capabilities, the ESXi hosts that participate in Virtual SAN clusters must be version 6.0 or later. During the Virtual SAN upgrade from version 5.5 to version 6.0, you can keep the on-disk format version 1.0, but you cannot use many of the new features. Virtual SAN 6.0 and later software supports all on-disk formats.