You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

The guest operating system checks the version of VMware Tools when you power on a virtual machine. The status bar of the virtual machine displays a message when a new version is available. The displayed version also is the version of the ESXi the VMware Tools is bundled with.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon when a VMware Tools upgrade is available.

To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware Tools the first time. Upgrading VMware Tools means installing a new version.

For Windows and Linux guest operating systems, you can configure the virtual machine to automatically upgrade VMware Tools. Although the version check is performed when you power on the virtual machine, on Windows guest operating systems, the automatic upgrade occurs when you power off or restart the virtual machine. The status bar displays the message Installing VMware Tools ... when an upgrade is in progress.

Important:

When you upgrade VMware Tools on Linux guest operating systems, new network modules are available but are not used until you either restart the guest operating system or stop networking, unload and reload the VMware networking kernel modules, and restart networking. This behavior means that even if VMware Tools is set to automatically upgrade, you must restart or reload network modules to make new features available.

This strategy avoids network interruptions and allows you to install VMware Tools over SSH.

For vSphere virtual machines, you can use one of the following processes to upgrade multiple virtual machines at the same time.

You can use one of the following processes to upgrade multiple virtual machines at the same time.

  • Log in to vCenter Server, select a host or cluster, and on the Virtual Machines tab specify the virtual machines on which to perform a VMware Tools upgrade.

  • Use Update Manager to perform an orchestrated upgrade of virtual machines at the folder or datacenter level.

Some features in a particular release of a VMware product might depend on installing or upgrading to the version of VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not always necessary, however, VMware highly recommends that you upgrade to the most updated version of the VMware Tools. Newer versions of VMware Tools are compatible with several ESXi host versions. To avoid unnecessary upgrades, evaluate whether the added features and capabilities are necessary for your environment. See Hardware Features Available with Virtual Machine Compatibility Settings. However, VMware highly recommends installing and using the latest version of VMware Tools.

Some features in a particular release of a VMware product might depend on installing or upgrading to the version of VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not always necessary. Newer versions of VMware Tools are compatible with several host versions. To avoid unnecessary upgrades, evaluate whether the added features and capabilities are necessary for your environment.

Table 1. Virtual Machine Compatibility Options

Compatibility

Description

ESXi 6.0 and later

This virtual machine (hardware version 11) is compatible with ESXi 6.0 and later.

ESXi 5.5 and later

This virtual machine (hardware version 10) is compatible with ESXi 5.5 and later.

ESXi 5.1 and later

This virtual machine (hardware version 9) is compatible with ESXi 5.1 and later.

ESXi 5.0 and later

This virtual machine (hardware version 8) is compatible with ESXi 5.0 and 5.1.

ESX/ESXi 4.x and later

This virtual machine (hardware version 7) is compatible with ESX/ ESXi 4.x, ESXi 5.0, and ESXi 5.1.

ESX/ESXi 3.5 and later

This virtual machine (hardware version 4) is compatible with ESX/ESX 3.5. ESX/ESX 4.x, and ESXi 5.1. It is also compatible with VMware Server 1.0 and later. You cannot create a virtual machine with ESX/ESXi 3.5 compatibility on ESXi 5.0.

For more information, see the documentation for your specific VMware product.