After you perform a scan, the compliance state of the attached baseline might be displayed as incompatible because of updates that cannot be installed on the object.

Problem

The state of the attached baseline is incompatible because it contains updates that cannot be installed.

Cause

  • A VMware Tools Upgrade to Match Host baseline is attached to a virtual machine on which VMware Tools is not installed. The Upgrade Details window shows the actual reason for the Incompatible state.

  • A VMware Tools Upgrade to Match Host baseline is attached to a virtual machine with VMware Tools not managed by the VMware vSphere platform. The Upgrade Details window shows the actual reason for the Incompatible state.

Procedure

  • If VMware Tools is not installed on the virtual machine, install a version of VMware Tools and retry the scan operation.
  • If VMware Tools on the virtual machine is not managed by the VMware vSphere platform, you should detach the baseline and perform the upgrade manually. For more information about upgrading VMware Tools when it is packaged and distributed as OSPs, see VMware Tools Installation Guide for Operating System Specific Packages.