For VMware Tools, the Upgrade Details window provides information about both compliance state and status. The status indicates whether the current version of VMware Tools is installed or supported and whether upgrades are available.

Table 1. VMware Tools Status

VMware Tools Status

Description

Compliance State

VMware Tools version is compliant.

The VMware Tools version is recent and supported.

Remediation is not required.

Compliant

VMware Tools is installed, supported, and newer than the version available on the host.

VMware Tools is installed on a machine that is running on an earlier ESXi version.

Remediation is not required.

Compliant

VMware Tools is installed and supported, but a newer version is available on the host.

An earlier supported version of VMware Tools is installed on the virtual machine.

You can upgrade VMware Tools, but the existing earlier version is also supported.

Non-Compliant

VMware Tools is installed, but the installed version has a known issue and should be immediately upgraded.

A serious issue is present in the VMware Tools version that is installed on the machine.

You must remediate the virtual machine against a VMware Tools upgrade baseline.

Non-Compliant

VMware Tools is installed, but the version is too new to work correctly with this virtual machine.

The existing newer version might cause problems on the virtual machine.

You must remediate the virtual machine against a VMware Tools upgrade baseline, to downgrade to a supported version.

Non-Compliant

VMware Tools is installed, but the version is too old.

The VMware Tools version is no longer supported.

You must remediate the virtual machine against a VMware Tools upgrade baseline.

Non-Compliant

VMware Tools is not installed.

VMware Tools is not present on the virtual machine.

You must install VMware Tools by using the vSphere Web Client.

Incompatible

VMware Tools is not managed by vSphere.

VMware Tools is installed by using operating system specific packages that cannot be upgraded with Update Manager.

To upgrade VMware Tools by using Update Manager, you must install VMware Tools from the vSphere Web Client.

Incompatible

Status is empty.

The virtual machine has not been scanned.

Unknown