The vCenter Server Appliance installer contains JSON templates that are located in the vcsa-cli-installer/templates directory. In the upgrade subfolder, you can find the JSON templates with the minimum configuration parameters for all upgrade types.

For each upgrade type, there is one template for deploying the new appliance on an ESXi host and another template for deploying the new appliance on a vCenter Server instance.

Table 1. Upgrade JSON Templates Included in the vCenter Server Appliance Installer

Location

Template

Description

vcsa-cli-installer\templates\upgrade\vcsa5.5

embedded_vCSA_on_ESXi.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 5.5 with an embedded vCenter Single Sign-On to vCenter Server Appliance 6.5 with an embedded Platform Services Controller on an ESXi host.

embedded_vCSA_on_VC.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 5.5 with an embedded vCenter Single Sign-On to vCenter Server Appliance 6.5 with an embedded Platform Services Controller on a vCenter Server instance.

vCSA_on_ESXi.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 5.5 with an external vCenter Single Sign-On to vCenter Server Appliance 6.5 with an external Platform Services Controller on an ESXi host.

vCSA_on_VC.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 5.5 with an external vCenter Single Sign-On to vCenter Server Appliance 6.5 with an external Platform Services Controller on a vCenter Server instance.

vcsa-cli-installer\templates\upgrade\vcsa6.0

embedded_vCSA_on_ESXi.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 6.0 with an embedded Platform Services Controller to vCenter Server Appliance 6.5 with an embedded Platform Services Controller on an ESXi host.

embedded_vCSA_on_VC.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 6.0 with an embedded Platform Services Controller to vCenter Server Appliance 6.5 with an embedded Platform Services Controller on a vCenter Server instance.

PSC_on_ESXi.json

Contains the minimum configuration parameters that are required for upgrade of a Platform Services Controller appliance 6.0 to Platform Services Controller appliance 6.5 on an ESXi host.

PSC_on_VC.json

Contains the minimum configuration parameters that are required for upgrade of a Platform Services Controller appliance 6.0 to Platform Services Controller appliance 6.5 on a vCenter Server instance.

vCSA_on_ESXi.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 6.0 with an external Platform Services Controller to vCenter Server Appliance 6.5 with an external Platform Services Controller on an ESXi host.

vCSA_on_VC.json

Contains the minimum configuration parameters that are required for upgrade of a vCenter Server Appliance 6.0 with an external Platform Services Controller to vCenter Server Appliance 6.5 with an external Platform Services Controller on a vCenter Server instance.