Verify that the vSphere components in your environment meet the software version requirements for using vSAN.

To use the full set of vSAN capabilities, the ESXi hosts that participate in vSAN clusters must be version 6.5 or later. During the vSAN upgrade from previous versions, you can keep the current on-disk format version, but you cannot use many of the new features. vSAN 6.6 and later software supports all on-disk formats.