If your cluster contains stateful ESXi 6.5 hosts, you use the present workflow to resolve version compliance errors when upgrading vCenter Server with version 6.5 to version 6.7.

It is recommended to upgrade your host profiles to the same version as your vCenter Server.

Prerequisites

  • Your cluster contains ESXi 6.5 hosts only.

  • A host profile with version 6.5 is attached to the cluster.

  • Your vCenter Server is with version 6.5.

Procedure

  1. Upgrade your vCenter Server to version 6.7.

    There are no changes in the vCenter Server configurations.

  2. Upgrade all ESXi hosts in the cluster to version 6.7.

    Edit host customization and host profile edit operations are not available, see KB 2150534. Compliance check, attach host profile and remediate hosts operations are available.

  3. (Optional) Leave one ESXi host at version 6.5, to use your current host profiles version 6.5.
  4. Remediate the ESXi hosts against the host profile with version 6.5.

    Reboot is required for all remediated hosts.

  5. Reboot all ESXi hosts.
  6. (Optional) Skip the next steps, to use your current host profiles version 6.5.
  7. Extract a new host profile from an ESXi 6.7 host.

    There are some changed parameters for the host profile policy. For more information, see Answer File Field and Host Profile Extraction.

  8. Attach the host profile with version 6.7 to the cluster.

    The host customization data auto-populates.

    All host profile operations are available.