If your cluster contains stateful ESXi 5.5 and ESXi 6.0 hosts, you use the present workflow to resolve version compliance errors when upgrading vCenter Server with version 6.0 to version 6.7.

Prerequisites

  • Your cluster contains ESXi 5.5 and ESXi 6.0 hosts.

  • A host profile with version 5.5 is attached to the cluster.

  • Your vCenter Server is with version 6.0.

Procedure

  1. Upgrade all ESXi 5.5 hosts in the cluster to version 6.0.
  2. Remediate the upgraded hosts against the host profile with version 5.5.
  3. Extract a new host profile from one of the upgraded hosts in the cluster.

    There are some changed parameters for the host profile policy. For more information, see Answer File Field and Host Profile Extraction.

  4. Attach the host profile with version 6.0 to the cluster.
  5. Remediate the cluster against the host profile with version 6.0.
  6. Upgrade your vCenter Server to version 6.7.

    There are no changes in the vCenter Server configurations.

  7. Upgrade all ESXi hosts in the cluster to version 6.7.

    Edit host customization and host profile edit operations are not available, see KB 2150534. Compliance check, attach host profile and remediate hosts operations are available.

  8. Remediate the ESXi hosts in the cluster against the host profile with version 6.0.

    All host profile settings are applied.

  9. Extract a new host profile from an ESXi 6.7 host.

    There are some changed parameters for the host profile policy. For more information, see Answer File Field and Host Profile Extraction.

  10. Attach the host profile with version 6.7 to the cluster.

    The host customization data auto-populates.

    All host profile operations are available.