If your cluster contains stateless ESXi 6.5 hosts, you use the present workflow to resolve version compliance errors when upgrading vCenter Server with version 6.5 to version 6.7.

It is recommended to upgrade your host profiles to the same version as your vCenter Server.

Prerequisites

  • Your cluster contains ESXi 6.5 hosts only.

  • A host profile with version 6.5 is attached to the cluster.

  • Your vCenter Server is with version 6.5.

Procedure

  1. Upgrade your vCenter Server to version 6.7.

    There are no changes in the vCenter Server configurations.

  2. Create a new rule or edit the existing rule with an image profile version 6.7 and select the cluster.
  3. Remediate all ESXi hosts by clicking Remediate Host Associations.
  4. Reboot all the ESXi hosts in the cluster.

    Remediation and check compliance operations are available, but the host profile with version 6.5 cannot be edited.

    Note:

    Skip the next steps, to use your current host profile version 6.5.

    All the hosts are compliant with the host profile.

  5. (Optional) Extract a new host profile from an ESXi 6.7 host.

    There are some changed parameters for the host profile policy. For more information, see Answer File Field and Host Profile Extraction.

  6. (Optional) Attach the host profile with version 6.7 to the cluster.

    The host customization data auto-populates.

    All host profile operations are available.