Install UMDS if the machine on which Update Manager is installed does not have access to the Internet.

Prerequisites

  • Verify that the machine on which you install UMDS has Internet access, so that UMDS can download upgrades, patch metadata, and patch binaries.

  • Uninstall any 6.5 or earlier instance of UMDS if it is installed on the machine. If such a version of UMDS is already installed, the installation wizard displays an error message and the installation cannot proceed.

  • UMDS and Update Manager must be installed on different machines.

  • To ensure optimal performance, install UMDS on a system with requirements same as the ones for the Update Manager server listed in System Requirements.

  • Update Manager installation requires installation of the Microsoft .NET framework 4.7. Consider the following before proceeding with the installation.

    • Installing Microsoft .NET framework 4.7 is not supported on Microsoft Windows Server 2008 Service Pack 2 64-bit.

    • Installing Microsoft .NET framework 4.7 might require you to install some additional Windows updates. Relevant links to the Windows updates are provided during the Microsoft .NET framework 4.7.

    • Installing Microsoft .NET framework 4.7 might require you to reboot your host operating system.

    • If you plan to install Update Manager server on the same Windows machine where vCenter Server runs (typical installation), the vCenter Server service might temporarily disconnect if the a reboot is invoked on the system by the .NET Microsoft .NET framework 4.7 installation.

    • After installing or upgrading the Microsoft .NET framework 4.7, follow the prompts of the Update Manager server or the UMDS installation wizards.

Procedure

  1. Mount the ISO image of the vCenter Server installer to the Windows virtual machine or physical server on which you want to install the vSphere Update Manager Download Service (UMDS).
  2. In the mounted directory, double-click the autorun.exe file of the VMware vCenter Installer, and select vSphere Update Manager > Download Service.
  3. Select the option to install the Microsoft .NET framework 4.7.
    Note:

    If you do not select to install Microsoft .NET framework 4.7, the Update Manager Download Service installation will fail with an error message.

  4. On the VMware vCenter Installer, click Install.

    The VMware vCenter Installer wizard remains open, and a language selection dialog box opens.

  5. Select the language for the vSphere Update Manager Download Service installer, and click OK.
  6. (Optional) If the wizard prompts you, install the required items such as Windows Installer 4.5.

    This step is required only if Windows Installer 4.5 is not present on your machine and you must perform it the first time you install a vSphere 5.x product. After the system restarts, the installer starts again.

  7. Review the Welcome page and click Next.
  8. Read and accept the license agreement, and click Next.
  9. Accept the terms in the license agreement and click Next.
  10. Enter the Update Manager Download Service proxy settings and click Next.
  11. Select the Update Manager Download Service installation and patch download directories and click Next.

    If you do not want to use the default locations, you can click Change to browse to a different directory. You can select the patch store to be an existing download directory from a previous UMDS 6.0 or UMDS 6.5 installation and reuse the applicable downloaded updates in UMDS 6.7. After you associate an existing download directory with UMDS 6.7, you cannot use it with earlier UMDS versions.

  12. (Optional) In the warning message about the disk free space, click OK.
  13. Click Install to begin the installation.
  14. Click OK in the Warning message notifying you that .NET Framework 4.7 is not installed.

    The UMDS installer installs the prerequisite before the actual product installation.

  15. Click Finish.

Results

UMDS is installed.