Before you install the Update Manager server, review the installation prerequisites.

Update Manager Database Requirements

Update Manager requires an Oracle or SQL Server database. Update Manager can handle small-scale environments using the bundled Microsoft SQL Server 2012 Express. For environments with more than 5 hosts and 50 virtual machines, you must create either an Oracle or SQL Server database.

To see a list of database formats that are compatible with the Update Manager server and the UMDS, select the Solution/Database Interoperability option from the VMware Product Interoperability Matrixes at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

For large-scale environments, set up the database on a machine different than the machines on which the Update Manager server is installed and the vCenter Server database is located. For more information about setting up the Update Manager database, see Preparing the Update Manager Database.

  • Create a database and 64-bit DSN, unless you are using the bundled Microsoft SQL Server 2012 Express.
  • Make sure that if the Update Manager database is located on a remote machine, the database and the system DSN use SQL Server authentication.

    Update Manager does not support Windows authentication of the database when the database is located on a different machine because of local system account problems.

  • If you plan to use the bundled Microsoft SQL Server 2012 Express database, make sure that you install Microsoft Windows Installer version 4.5 (MSI 4.5) on your system.

  • Make sure that the database privileges meet the requirements listed in Required Database Privileges.
  • Create the 64-bit ODBC connection to a supported database server version by using a supported database client version.

    If you create an ODBC connection to a database server that is of an unsupported version, and your database client is of a supported version, a DSN for the unsupported database might be displayed in the drop-down menu of the Update Manager installation wizard.

vCenter Server Installation

  • Install vCenter Server.

    If prompted, you must restart the machine on which vCenter Server is installed. Otherwise, you might not be able to register Update Manager with vCenter Server, and the Update Manager installation might fail.

    For more information about installing vCenter Server, see vSphere Installation and Setup.

  • Gather the following networking information for the vCenter Server system.
    • User name and password for the vCenter Server system.

      During the Update Manager installation process, you must register the Update Manager server with the vCenter Server system. To register Update Manager with vCenter Server, you must provide the credentials of the vCenter Server user that has the Register extension privilege. For more information about managing users, groups, roles, and permissions, see vSphere Security.

    • Port numbers. In most cases, the default Web service port 80 is used.
    • IP address.

      If the IP address of the vCenter Server system or Update Manager changes, you can re-register the Update Manager server with the vCenter Server system. For more information about configuring the Update Manager server after installation, see Reconfiguring VMware vSphere Update Manager.

Update Manager System Requirements

  • Make sure that your system meets the requirements specified in System Requirements.
    Important: You can install the Update Manager 6.7 server component only on a 64-bit machine. Make sure the Windows system on which you are installing the Update Manager server is not an Active Directory domain controller.
  • Log in as a local Administrator or a domain user that is member of the Administrators group.
  • Update Manager installation requires installation of the Microsoft .NET framework 4.7. Consider the following before proceeding with the installation.
    • Installing Microsoft .NET framework 4.7 is not supported on Microsoft Windows Server 2008 Service Pack 2 64-bit.
    • Installing Microsoft .NET framework 4.7 might require you to install some additional Windows updates. Relevant links to the Windows updates are provided during the Microsoft .NET framework 4.7.
    • Installing Microsoft .NET framework 4.7 might require you to reboot your host operating system.
    • If you plan to install Update Manager server on the same Windows machine where vCenter Server runs (typical installation), the vCenter Server service might temporarily disconnect if the a reboot is invoked on the system by the .NET Microsoft .NET framework 4.7 installation.
    • After installing or upgrading the Microsoft .NET framework 4.7, follow the prompts of the Update Manager server or the UMDS installation wizards.
  • Check the compatibility and interoperability of the vCenter Server server with VMware Site Recovery Manager®. Use caution when connecting the Update Manager server to a vCenter Server instance to which the Site Recovery Manager server is also connected. Connecting the Update Manager server to the same vCenter Server instance as Site Recovery Manager might cause problems when you upgrade the Site Recovery Manager or the vCenter Server, or when you perform daily operations.