In some situations, you might have a problem with the vSphere Auto Deploy database. The most efficient recovery option is to replace the existing database file with the most recent backup.
Problem
When you use vSphere Auto Deploy to provision the
ESXi hosts in your environment, you might encounter a problem with the vSphere Auto Deploy database.
Important: This is a rare problem. Follow all other vSphere Auto Deploy troubleshooting strategies before you replace the current database file. Rules or associations that you created since the backup you choose are lost.
Cause
This problem happens only with hosts that are provisioned with vSphere Auto Deploy.
Solution
- Stop the vSphere Auto Deploy server service.
- Find the vSphere Auto Deploy log by going to the vSphere Auto Deploy page in the vSphere Web Client.
- Check the logs for the following message:
DatabaseError: database disk image is malformed.
If you see the message, replace the existing database with the most recent backup.
- Go to the vSphere Auto Deploy data directory.
Operating System |
File Location |
vCenter Server appliance |
/var/lib/rbd |
Microsoft Windows |
%VMWARE_DATA_DIR%\autodeploy\Data |
The directory contains a file named
db, and backup files named
db-
yyy-
mm-
dd.
- Rename the current db file.
VMware Support might ask for that file if you call for assistance.
- Rename the most recent backup to db.
- Restart the vSphere Auto Deploy server service.
- If the message still appears in the log, repeat the steps to use the next recent backup until vSphere Auto Deploy works without database errors.