Each PCI-e based storage I/O device in the HCL database has a unique identifier. This unique ID allows the vSAN HCL check to locate an NVMe device in the database.

Problem

PCI ID of some NVMe devices in the HCL database is not unique. The identifier fails the vSAN HCL check to locate the corresponding device in the database. vSAN health service cannot differentiate the devices and can generate false alarms.

Cause

There can be multiple NVMe devices in HCL having the same PCI ID. This results in vSAN health service unable to identify the NVMe device correctly.

Solution

  1. Navigate to the vSAN cluster.
  2. On the Configure tab, click vSAN and select Disk Management.
  3. Click EDIT UNIDENTIFIED NVME DEVICES. vSAN displays the list of unidentified NVMe devices.
  4. Select the device and then select an appropriate model from the drop-down.
    Note: In Monitor > vSAN > Skyline Health, verify that the vSAN HCL DB up-to-date health check is set to green. Select Not listed here option if you are unable to find the device model in the list.

    In Skyline Health, the status of the NVME device can be identified health check is set to green. However, the devices display the uncertified status in the NVMe device is VMware certified health check.

  5. Click Apply.