Adhere to the supported update paths for upgrading Workload Management components, including Supervisor Clusters and Tanzu Kubernetes clusters.

Follow the path set forth below to update Workload Management components.

Prerequisites

  • Familiarize yourself with the Workload Management update process. See About vSphere with Tanzu Cluster Updates.
  • Read the release notes. See vSphere with Tanzu Release Notes.
  • If you are using the initial release of Workload Management on vSphere 7.0, you must first perform a vSphere Namespaces update to the first release available post-GA so that the Tanzu Kubernetes cluster upgrade functionality is installed. Refer to the May 19, 2020 release in the release notes for more information.

Procedure

  1. Update vCenter Server to the vSphere version 7 U1 release. See Upgrading the vCenter Server Appliance in the vCenter Server documentation.
  2. Update Tanzu Kubernetes clusters as required based on the table below. See Update Tanzu Kubernetes Clusters.
    Current Version Update Requirements and Recommendations
    v1.16.8
    • Incompatible with vSphere 7.0 U1.
    • Incompatible with Antrea CNI.

    Must update to a version that is compatible with vSphere 7.0 U1 before you perform a vSphere Namespaces update to vSphere 7.0 U1.

    Should update to a version that is compatible with Antrea before you perform a vSphere Namespaces update to vSphere 7.0 U1 to avoid the error Antrea CNI not supported in current TKC version when provisioning a cluster.

    v1.16.12
    • Compatible with vSphere 7.0 U1.
    • Incompatible with Antrea CNI.

    Should update to a version that is compatible with Antrea before you perform a vSphere Namespaces update to vSphere 7.0 U1 to avoid the error Antrea CNI not supported in current TKC version when provisioning a cluster.

    v1.16.14
    • Compatible with vSphere 7.0 U1.
    • Compatible with Antrea CNI.

    Recommended 1.16 version before you perform a vSphere Namespaces update to vSphere 7.0 U1.

    v1.17.7
    • Compatible with vSphere 7.0 U1.
    • Incompatible with Antrea CNI.

    Should update to a version that is compatible with Antrea before you perform a vSphere Namespaces update to vSphere 7.0 U1 to avoid the error Antrea CNI not supported in current TKC version when provisioning a cluster.

    v1.17.8
    • Compatible with vSphere 7.0 U1.
    • Compatible with Antrea CNI.

    Minimum 1.17 version before you perform a vSphere Namespaces update to vSphere 7.0 U1.

    v1.17.11
    • Compatible with vSphere 7.0 U1.
    • Compatible with Antrea CNI.

    Recommended 1.17 version before you perform a vSphere Namespaces update to vSphere 7.0 U1.

    v1.18.5
    • Compatible with vSphere 7.0 U1.
    • Compatible with Antrea CNI.

    Newly available 1.18 version.

  3. Perform a vSphere Namespaces update. See Update the Supervisor Cluster by Performing a vSphere Namespaces Update.
  4. Update Tanzu Kubernetes clusters to 1.18 when the release becomes available in the Content Library. See Update Tanzu Kubernetes Clusters.