A plug-in unregistration command fails.

Problem

You use the plug-in registration tool to unregister a plug-in, but the tool reports a failure to unregister the plug-in.

Cause

The --key argument did not match the extension.key property of the registration record in the ExtensionManager.

Solution

  1. Use the --action unregisterPlugin argument with a key that matches the key you used to register the plug-in. If you no longer have access to the registration command you used, you can find the extension key value from the registration record in the ExtensionManager by using the following procedure.
    1. Connect a web browser to the Managed Object Browser (MOB) of the vCenter Server with which you attempted to register the plug-in.

      The MOB URL is https://vcenter_server_FQDN/mob.

    2. To view the ServiceContent data object click the content link.
    3. Click the ExtensionManager link to view the ExtensionManager managed object.
    4. In the extensionList values, search for the extension key that you used in your registration command.

      The more... link enables you to see more of the list of extension keys.

    5. Locate the extension.key property of the registration record for your plug-in.
  2. Retry the unregistration command, supplying a corrected --key argument.