The remote plug-in does not display in the vSphere Client user interface.
Problem
The plug-in does not appear in the object navigator, but it is listed in the vSphere Client under .
Cause
This problem can occur if the extension.thumbprint
is not valid. The plug-in registration command might have supplied an incorrect server thumbprint, which causes deployment to fail.
To verify the cause, use one of the following methods:
-
In the Management UI, find the plug-in in the list under . Next to the list entry, look for a signpost which contains an error message saying that the plug-in failed to download:
Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct.
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If you do not find the signpost, you can search for the sample name in the log file at /var/log/vmware/vsphere-ui/logs/vsphere-client-virgo.log to find an error message.
Solution
- Connect a web browser to the Managed Object Browser (MOB) of the vCenter Server with which you attempted to register the plug-in.
The MOB URL is https://vcenter_server_FQDN/mob.
- To view the ServiceContent data object click the content link.
- To view the ExtensionManager managed object click the ExtensionManager link.
- In the extensionList values, search for the extension key that you used to register the plug-in.
The more... link enables you to see more of the list of extension keys.
- Check that the
server.serverThumbprint
property is correct.
-
The thumbprint (fingerprint) should match the characters shown in the plug-in server certificate. To find the plug-in server thumbprint, see Get Thumbprint or Certificate of Remote Plug-in Server. Character pairs should be colon separated.
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Check for hidden characters.
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Pairs of digits must be separated by colon separators.
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You can register the plug-in using a SHA-256 fingerprint or a SHA-1 fingerprint. A best practice is to use SHA-256, which is more secure. SHA-1 is deprecated in favor of SHA-256.
If the thumbprint is correct, check the URL by using the topic Wrong Plug-in URL.
- If the thumbprint used in the registration command was incorrect, reregister the plug-in as follows:
- Unregister the plug-in.
- Repeat the plug-in registration step with the correct thumbprint.