The remote plug-in does not display in the vSphere Client user interface.

Problem

The plug-in does not appear in the object navigator, but it is listed in the vSphere Client under Admin > Client plugins.

Cause

This problem can occur if the extension.thumbprint is not valid. The plug-in registration command might have supplied an incorrect server thumbprint, which causes deployment to fail.

To verify the cause, use one of the following methods:

  • In the Management UI, find the plug-in in the list under Admin > Client plugins. Next to the list entry, look for a signpost which contains an error message saying that the plug-in failed to download:

    Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct.

  • If you do not find the signpost, you can search for the sample name in the log file at ​/var/log/vmware/vsphere-ui/logs/vsphere-client-virgo.log​​ to find an error message.​

Solution

  1. Connect a web browser to the Managed Object Browser (MOB) of the vCenter Server with which you attempted to register the plug-in.

    The MOB URL is https://vcenter_server_FQDN/mob.

  2. To view the ServiceContent data object click the content link.
  3. To view the ExtensionManager managed object click the ExtensionManager link.
  4. In the extensionList values, search for the extension key that you used to register the plug-in.

    The more... link enables you to see more of the list of extension keys.

  5. Check that the server.serverThumbprint property is correct.
    • The thumbprint (fingerprint) should match the characters shown in the plug-in server certificate. To find the plug-in server thumbprint, see Get Thumbprint or Certificate of Remote Plug-in Server. Character pairs should be colon separated.

    • Check for hidden characters.

    • Pairs of digits must be separated by colon separators.

    • You can register the plug-in using a SHA-256 fingerprint or a SHA-1 fingerprint. A best practice is to use SHA-256, which is more secure. SHA-1 is deprecated in favor of SHA-256.

    If the thumbprint is correct, check the URL by using the topic Wrong Plug-in URL.

  6. If the thumbprint used in the registration command was incorrect, reregister the plug-in as follows:
    1. Unregister the plug-in.

      You can use the registration tool in the SDK to unregistor a plug-in. For syntax information, see vSphere Client Plug-in Registration Tool.

    2. Repeat the plug-in registration step with the correct thumbprint.