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Tenant Administration

Tenant Administration explains how to perform administrative tasks for vRealize Automation. It describes
procedures for configuring tenants, setting up notifications, managing users, and managing the contents of
the catalog.
Note Not all features and capabilities of vRealize Automation are available in all editions. For a
comparison of feature sets in each edition, see https://www.vmware.com/products/vrealize-automation/.

Intended Audience
This information is intended for system administrators, tenant administrators, service architects, and
business group managers who need to configure and maintain the vRealize Automation environment.

VMware Technical Publications Glossary
VMware Technical Publications provides a glossary of terms that might be unfamiliar to you. For definitions
of terms as they are used in VMware technical documentation, go to
http://www.vmware.com/support/pubs.

Updated Information
This Tenant Administration guide for vRealize Automation is updated with each release of the product or
when necessary.
This table provides the update history of the Tenant Administration guide.
Revision

Description

001445-04

Added information about reconfiguration support for SCVMM machines. See “Reconfigure a Machine,” on
page 45 and “Action Menu Options for Virtual, Physical, and Cloud Machines,” on page 73.

001445-03

n
n
n

001445-02

n

n

Updated “Workflow States of Reconfigure Operations,” on page 50
Added information for managing user and group entitlements in “Manage User and Group
Entitlements,” on page 19
Updated the power actions information in “Schedule the Start,” on page 49
Added post-provisioning actions information. See Chapter 12, “Running Actions for Provisioned
Resources,” on page 73 and “Troubleshooting Missing Actions in the Resource Actions Menu,” on
page 76.
Added information about machines that are not available for reclamation. See “Send Reclamation
Requests,” on page 41.

001445-01

n

001445-00

Initial release.
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Included documentation for support for remote consoles for machines provisioned on vSphere. See
Chapter 10, “Configuring Remote Consoles for vSphere with Untrusted SSL Certificates,” on page 67.
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Using the Goal Navigator
The goal navigator guides you through high-level goals that you might want to accomplish in
vRealize Automation.
The goals you can achieve depend on your role. To complete each goal, you must complete a sequence of
steps that are presented on separate pages in the vRealize Automation console.
The goal navigator can answer the following questions:
n

Where do I start?

n

What are all the steps I need to complete to achieve a goal?

n

What are the prerequisites for completing a particular task?

n

Why do I need to do this step and how does this step help me achieve my goal?

The goal navigator is hidden by default. You can expand the goal navigator by clicking the icon on the left
side of the screen.
After you select a goal, you navigate between the pages needed to accomplish the goal by clicking each step.
The goal navigator does not validate that you completed a step, or force you to complete steps in a
particular order. The steps are listed in the recommended sequence. You can return to each goal as many
times as needed.
For each step, the goal navigator provides a description of the task you need to perform on the
corresponding page. The goal navigator does not provide detailed information such as how to complete the
forms on a page. You can hide the page information or move it to a more convenient position on the page. If
you hide the page information, you can display it again by clicking the information icon on the goal
navigator panel.
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Configure Branding for the
vRealize Automation Console

1

System administrators can change the appearance of the vRealize Automation console to meet site-specific
branding guidelines by changing the logo, the background color, and information in the header and footer.
System administrators control the default branding for tenants. Tenant administrators can use the default or
reconfigure branding for each tenant.
As you make changes, a preview of each change appears at the bottom of the form. The changes take effect
when they are saved.
Prerequisites
Log in to the vRealize Automation console as a system administrator or tenant administrator.
Procedure
1

Select Administration > Branding.

2

Clear the Use default check box.

3

Create a banner.
a

Click Choose File to upload a logo image.

b

Follow the prompts to finish creating the banner.

4

Click Next.

5

Type the copyright information in the Copyright notice text box and press Enter to preview your
selection.

6

(Optional) Type the URL to your privacy policy in the Privacy policy link text box and press Enter to
preview your selection.

7

(Optional) Type the URL to your contact page in the Contact link text box and press Enter to preview
your selection.

8

Click Update.
The console is updated with your changes.

VMware, Inc.
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Configuring Notifications

2

Tenant administrators can configure settings for sending notifications to users who subscribe to receive
communications from vRealize Automation.
This chapter includes the following topics:
n

“Configuring Notifications Overview,” on page 11

n

“Add a Tenant-Specific Outbound Email Server,” on page 12

n

“Add a Tenant-Specific Inbound Email Server,” on page 13

n

“Override a System Default Outbound Email Server,” on page 14

n

“Override a System Default Inbound Email Server,” on page 14

n

“Configure Notifications,” on page 15

n

“Subscribe to Notifications,” on page 16

n

“Revert to System Default Email Servers,” on page 16

Configuring Notifications Overview
Depending on your role, you can choose how to support notifications and whether you want to receive
them.
The following high-level overview describes the process for configuring notifications:
1

Configure an outbound email server to send notifications. See “Add a Tenant-Specific Outbound Email
Server,” on page 12. If your system administrator configured a default outbound server and you need
to configure your own, see “Override a System Default Outbound Email Server,” on page 14.

2

(Optional) Configure an inbound server so that users can complete tasks by responding to notifications.
See “Add a Tenant-Specific Inbound Email Server,” on page 13. If your system administrator
configured a default inbound server and you need to configure your own, see “Override a System
Default Inbound Email Server,” on page 14.

3

Select the vRealize Automation events to trigger user notifications. See “Configure Notifications,” on
page 15.

4

(Optional) Each user must subscribe to notifications before they can receive the notifications that you
configured. See “Subscribe to Notifications,” on page 16.

VMware, Inc.

11

Tenant Administration

Add a Tenant-Specific Outbound Email Server
Tenant administrators can add an outbound email server to send notifications for completing work items,
such as approvals.
Each tenant can have only one outbound email server. If your system administrator has already configured a
global outbound email server, see “Override a System Default Outbound Email Server,” on page 14.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator.

n

If the email server requires authentication, the specified user must be in an identity store and the
business group.

Procedure
1
2

Select Administration > Notifications > Email Servers.
Click the Add icon (

).

3

Select Email – Outbound.

4

Click OK.

5

Enter a name in the Name text box.

6

(Optional) Enter a description in the Description text box.

7

Type the name of the server in the Server Name text box.

8

Choose an encryption method.
n

Click Use SSL.

n

Click Use TLS.

n

Click None to send unencrypted communications.

9

Type the server port number in the Server Port text box.

10

(Optional) Select the Required check box if the server requires authentication.

11

a

Type a user name in the User Name text box.

b

Type a password in the Password text box.

Type the email address that vRealize Automation emails should appear to originate from in the Sender
Address text box.
This email address corresponds to the user name and password you supplied.

12

Choose whether vRealize Automation can accept self-signed certificates from the email server.
This option is available only if you enabled encryption.

12

n

Click Yes to accept self-signed certificates.

n

Click No to reject self-signed certificates.

13

Click Test Connection.

14

Click Add.
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Add a Tenant-Specific Inbound Email Server
Tenant administrators can add an inbound email server so that users can respond to notifications for
completing work items, such as approvals.
Each tenant can have only one inbound email server. If your system administrator already configured a
global inbound email server, see “Override a System Default Inbound Email Server,” on page 14.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator.

n

Verify that the specified user is in an identity store and in the business group.

Procedure
1
2

Select Administration > Notifications > Email Servers.
Click the Add icon (

).

3

Select Email - Inbound and click OK.

4

Configure the following inbound email server options.

5

Option

Action

Name

Enter a name for the inbound email server.

Description

Enter a description of the inbound email server.

Security

Select the Use SSL check box.

Protocol

Choose a server protocol.

Server Name

Enter the server name.

Server Port

Enter the server port number.

Type the folder name for emails in the Folder Name text box.
This option is required only if you choose IMAP server protocol.

6

Enter a user name in the User Name text box.

7

Enter a password in the Password text box.

8

Type the email address that vRealize Automation users can reply to in the Email Address text box.

9

(Optional) Select Delete From Server to delete from the server all processed emails that are retrieved by
the notification service.

10

Choose whether vRealize Automation can accept self-signed certificates from the email server.
This option is available only if you enabled encryption.
n

Click Yes to accept self-signed certificates.

n

Click No to reject self-signed certificates.

11

Click Test Connection.

12

Click Add.
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Override a System Default Outbound Email Server
If the system administrator configured a system default outbound email server, the tenant administrator can
override this global setting.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
Procedure
1

Select Administration > Notifications > Email Servers.

2

Select the Outbound email server.

3

Click Override Global.

4

Enter a name in the Name text box.

5

(Optional) Enter a description in the Description text box.

6

Type the name of the server in the Server Name text box.

7

Choose an encryption method.
n

Click Use SSL.

n

Click Use TLS.

n

Click None to send unencrypted communications.

8

Type the server port number in the Server Port text box.

9

(Optional) Select the Required check box if the server requires authentication.

10

a

Type a user name in the User Name text box.

b

Type a password in the Password text box.

Type the email address that vRealize Automation emails should appear to originate from in the Sender
Address text box.
This email address corresponds to the user name and password you supplied.

11

Choose whether vRealize Automation can accept self-signed certificates from the email server.
This option is available only if you enabled encryption.
n

Click Yes to accept self-signed certificates.

n

Click No to reject self-signed certificates.

12

Click Test Connection.

13

Click Add.

Override a System Default Inbound Email Server
If the system administrator has configured a system default inbound email server, tenant administrators can
override this global setting.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
Procedure
1

14

Select Administration > Notifications > Email Servers.
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2

Select the Inbound email server in the Email Servers table.

3

Click Override Global.

4

Enter the following inbound email server options.

5

Option

Action

Name

Enter the name of the inbound email server.

Description

Enter a description of the inbound email server.

Security

Select the SSL check box to use SSL for security.

Protocol

Choose a server protocol.

Server Name

Enter the server name.

Server Port

Enter the server port number.

Type the folder name for emails in the Folder Name text box.
This option is required only if you choose IMAP server protocol.

6

Enter a user name in the User Name text box.

7

Enter a password in the Password text box.

8

Type the email address that vRealize Automation users can reply to in the Email Address text box.

9

(Optional) Select Delete From Server to delete from the server all processed emails that are retrieved by
the notification service.

10

Choose whether vRealize Automation can accept self-signed certificates from the email server.
This option is available only if you enabled encryption.
n

Click Yes to accept self-signed certificates.

n

Click No to reject self-signed certificates.

11

Click Test Connection.

12

Click Add.

Configure Notifications
Each user determines whether to receive notifications, but tenant administrators determine which events
trigger notifications.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator.

n

Verify that a tenant administrator or system administrator configured an outbound email server. See
“Add a Tenant-Specific Outbound Email Server,” on page 12.

Procedure
1

Select Administration > Notifications > Scenarios.

2

Select one or more notifications.

3

Click Activate.

Users who subscribe to notifications in their preference settings now receive the notifications.

VMware, Inc.
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Subscribe to Notifications
If your administrators have configured notifications, you can subscribe to receive notifications from
vRealize Automation. Notification events can include the successful completion of a catalog request or a
required approval.
Prerequisites
Log in to the vRealize Automation console.
Procedure
1

Click Preferences.

2

Select the Enabled check box for the Email protocol in the Notifications table.

3

Click Apply.

4

Click Close.

Revert to System Default Email Servers
Tenant administrators who override system default servers can revert the settings back to the global settings.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
Procedure

16

1

Select Administration > Notifications > Email Servers.

2

Select the email server to revert.

3

Click Revert to Global.

4

Click Yes.

VMware, Inc.

3

Managing Users

Tenant administrators create and manage custom groups and grant and manage user access rights to the
vRealize Automation console.
This chapter includes the following topics:
n

“Add Identity Store,” on page 17

n

“Assign Roles to Identity Store Users or Groups,” on page 18

n

“Create a Custom Group,” on page 18

n

“Manage User and Group Entitlements,” on page 19

Add Identity Store
vRealize Automation uses identity stores to authenticate users. Each tenant is associated with at least one
identity store when it is created, but you can add new ones if necessary.
When you delete an identity store, this removes the roles assigned to users from this store, the roles
assigned to users from custom groups, and the information about which services are available to this user.
Entries for entitlements and business groups are not affected.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
Procedure
1
2

Select Administration > Identity Stores.
Click the Add icon (

).

3

Enter a name in the Name text box.

4

Select the type of the identity store from the Type drop-down menu.

5

Enter the following Identify Store configuration options.

VMware, Inc.

Option

Action

URL

Enter the URL for the identity store. For example,
ldap://10.141.64.166:875.

Domain

Enter the domain for the identity store.

(Optional) Domain Alias

Enter the domain alias.

Login User DN

Enter the login user Distinguished Name. For example,
cn=demoadmin,ou=demo,dc=dev,dc=mycompany,dc=com.

Password

Enter the password for the identity store login user.

17
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Option

Action

Group Search Base DN

Enter the group search base Distinguished Name. For example,
ou=demo,dc=dev,dc=mycompany,dc=com.

User Search Base DN

Enter the user search base Distinguished Name.

6

Click Test Connection.

7

Click Add.

What to do next
“Assign Roles to Identity Store Users or Groups,” on page 18.

Assign Roles to Identity Store Users or Groups
Tenant administrators grant users access rights by assigning roles to users or groups.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
Procedure
1

Select Administration > Users & Groups > Identity Store Users & Groups.

2

Enter a user or group name in the Search box and press Enter.
Do not use an at sign (@), backslash (\), or slash (/) in a name. You can optimize your search by typing
the entire user or group name in the form user@domain.

3

Click the name of the user or group to which you want to assign roles.

4

Select one or more roles from the Add Roles to this User list.
The Authorities Granted by Selected Roles list indicates the specific authorities you are granting.

5

(Optional) Click Next to view more information about the user or group.

6

Click Update.

Users who are currently logged in to the vRealize Automation console must log out and log back in to the
vRealize Automation console before they can navigate to the pages to which they have been granted access.
What to do next
Optionally, you can create your own custom groups from users and groups in your identity stores. See
“Create a Custom Group,” on page 18.

Create a Custom Group
Tenant administrators can create custom groups by combining other custom groups, identity store groups,
and individual identity store users.
You can assign roles to your custom group, but it is not necessary in all cases. For example, you can create a
custom group called Machine Specification Approvers, to use for all machine pre-approvals. You can also
create custom groups to map to your business groups so that you can manage all groups in one place. In
those cases, you do not need to assign roles.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
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Procedure
1
2
3

Select Administration > Users & Groups > Custom Groups.
Click the Add icon (

).

Enter a group name in the New Group Name text box.
Custom group names cannot contain the combination of a semicolon (;) followed by an equal sign (=).

4

(Optional) Enter a description in the New Group Description text box.

5

Select one or more roles from the Add Roles to this Group list.
The Authorities Granted by Selected Roles list indicates the specific authorities you are granting.

6

Click Next.

7

Add users and groups to create your custom group.
a

Enter a user or group name in the Search box and press Enter.
Do not use an at sign (@), backslash (\), or slash (/) in a name. You can optimize your search by
typing the entire user or group name in the form user@domain.

b
8

Select the user or group to add to your custom group.

Click Add.

Users who are currently logged in to the vRealize Automation console must log out and log back in to the
vRealize Automation console before they can navigate to the pages to which they have been granted access.

Manage User and Group Entitlements
You can use user and group directory name search parameters to control user and group entitlements.
If users or groups from other domains do not possess the expected system privileges, and do not appear on
the Administration > Users page or the Administration > Groups page, check the user and group search
base distinguished name parameters on the Identity Store Configuration page. Ensure that the distinguished
name search parameters are not so restrictive that the users and groups are excluded the desired domains.
Prerequisites
Log in to vRealize Automation as a tenant administrator.
Procedure
1

Select Administration > Identity Stores .

2

Select the appropriate identity store and then click the Edit button.

3

Edit the group base distinguished name search parameters in the Group search base DN field.
If users or groups do not possess adequate privileges, edit the search parameters to be less restrictive.

4

Edit the user base distinguished name search parameters in the User search base DN field.
If users or groups do not possess adequate privileges, edit the search parameters to be less restrictive.

5

Click Test Connection.

6

Click Update.

VMware, Inc.
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Managing the Service Catalog

4

A tenant administrator's tasks include creating services, configuring catalog items, adding entitlements, and
assigning approvals.
This chapter includes the following topics:
n

“Create a Service,” on page 21

n

“Add and Remove Catalog Items in a Service,” on page 22

n

“Configure a Catalog Item,” on page 23

n

“Approvals Overview,” on page 23

n

“Creating an Entitlement,” on page 28

n

“Prioritize Entitlements,” on page 32

Create a Service
You can create a service to organize catalog items into related offerings.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or service architect.
Procedure
1
2

Select Administration > Catalog Management > Services.
Click Add (

).

3

Enter a name and, optionally, a description.

4

(Optional) Click Browse to select an icon for the service and click Open.

5

(Optional) Select a status for the service from the Status drop-down menu.
Option

VMware, Inc.

Description

Inactive

Service is saved in a draft state and cannot be published to the catalog.

Active

Service can be published in the catalog.
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6

7

(Optional) Configure information to display to users of the service when they browse the catalog.
a

Select the availability of internal support services teams from the Hours drop-down menus.

b

Enter the name of the service owner in the Owner text box and press Enter.

a

Enter the name of the person or group of persons in charge of the service in the Support Team text
box and press Enter.

b

Select a time for scheduled maintenance from the Change Window drop-down menus.

Click Add.

What to do next
Associate your catalog item with a service.

Add and Remove Catalog Items in a Service
A tenant administrator, service architect, or business group manager can add and remove catalog items to
and from a service.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator, business group manager, or
service architect.

n

Verify that a service exists. If necessary, request one from a tenant administrator or service architect. See
“Create a Service,” on page 21.

n

Verify that one or more catalog items are published. See “Configure a Catalog Item,” on page 23.

Procedure
1

Select Administration > Catalog Management > Services.

2

Select the service to use when adding or removing catalog items.

3

Click Manage Catalog Items.

4

(Optional) Add a catalog item.
a
b

Click the Catalog Items

icon.

Select the check box for the catalog item to add to the service.
Repeat this step for any additional catalog items to add. Only catalog items not associated with a
service are available.

c
5

6

Click Add.

(Optional) Remove a catalog item.
a

Locate the catalog item to remove.

b

In the Actions column, click the down arrow and click Remove.

c

Click OK.

d

Repeat Step 5a through Step 5c to remove additional catalog items.

Click Close.

What to do next
Users cannot request your catalog item until you entitle them to the service or the item. See “Creating an
Entitlement,” on page 28.
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Configure a Catalog Item
Before users can request an item, you must configure the catalog item and associate it with a service.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator, business group manager, or
service architect.

n

Verify that you have at least one blueprint published as a catalog item. Depending on the type of
blueprints you are working with, see the appropriate guide for more information about publishing a
blueprint. For example, for a services blueprint see Advanced Service Design. For a virtual machine
blueprint, see IaaS Configuration for Virtual Platforms.

Procedure
1

Select Administration > Catalog Management > Catalog Items.

2

Select the catalog item to configure.

3

Click Configure.

4

(Optional) Enter a description in the Description text box.

5

(Optional) Click Browse to choose an icon for the catalog item.

6

Select the status of the catalog item from the Status drop-down menu.

7

Option

Description

Active

The catalog item appears in the service catalog and entitled users can
request it.

Inactive

The catalog item does not appear in the service catalog and users cannot
request it.

Select a service from the Service drop-down menu.
This action determines in which service catalog your item appears.

8

(Optional) Select the New and noteworthy check box.
The catalog item appears in the New & Noteworthy area on the Home page.

9

(Optional) Click the Entitlements tab to view the entitlements associated with this item and service.

10

Click Update.

What to do next
Users cannot request your catalog item until you entitle them to the service or the item. See “Creating an
Entitlement,” on page 28.

Approvals Overview
Any catalog request, whether it is for a new catalog item or to perform an action on a provisioned item, can
be subject to approval.
A tenant administrator or business group manager can associate an approval policy with any service,
catalog item, or action as part of entitling the items or actions to users.
A tenant administrator or an approval administrator can create approval policies. Each approval policy has
an approval policy type that determines to what requests that policy can apply. For example, you can apply
some policies only to new catalog item requests, or requests for a specific type of item. You can apply other
policies only to post-provisioning actions or to a specific action on provisioned items.

VMware, Inc.
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Each approval policy has at least one phase and each phase can have one or more levels.
An approval level represents a single step in a business process. For example, an approval policy can have
one level for manager approval, followed by a level for finance approval. An approval level can be
designated as always required or required based on certain conditions. The available conditions can vary
depending on the approval policy type. For example, an approval policy for virtual machine requests can be
conditional based on the number of CPUs in the machine request.
Each level specifies one or more approvers. If a level has multiple approvers, the policy can specify whether
all the approvers must approve the request to complete the level, or any one of the approvers can complete
the level. If any approver rejects the request, then the entire request is rejected.
For each approval level, you can specify attributes that an approver can edit when completing the approval.
For example, in an approval level for IT to review a machine request, they might be able to update the
requested CPU, memory, or storage specifications. The approvers must determine that the requested
specifications are not appropriate for the proposed use of the machine.
An approval phase is a sequence of approval levels associated with a particular stage in the request. The
approval policy type defines how many phases a policy has and which stage in a request triggers a
particular approval phase. For example, an approval policy can define the following phases:
n

A preprovisioning approval phase must be complete before provisioning a requested item

n

A postprovisioning phase occurs after the item is already provisioned but before it is released to the
owner

An approval policy in the Draft status can be edited but after it is activated, it becomes read-only. A policy
with an Inactive status is also read-only.

Create an Approval Policy
Tenant administrators and approval administrators can define approval policies and use them in
entitlements. You can set up the approval policies with multiple levels for pre- and post-approval events.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or approval administrator.
Procedure
1

Specify Approval Policy Information on page 24
When you create an approval policy, first define the approval policy type, name, description, and
status.

2

Create an Approval Level on page 25
When you create an approval policy, you can add pre- and post-approval levels.

3

Configure an Approval Form on page 26
You can configure an approval form to allow the approvers to change the values of system properties
for machine resource settings such as CPU, Lease, or Memory and custom properties before they
complete an approval request.

Specify Approval Policy Information
When you create an approval policy, first define the approval policy type, name, description, and status.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or approval administrator.
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Procedure
1
2

Select Administration > Approval Policies.
Click the Add icon (

).

3

Select an approval policy type from the Policy Type drop-down menu.

4

Click OK.

5

Enter a name and, optionally, a description.

6

Select the state of the policy from the Status drop-down menu.
Option

Description

Draft

Saves the approval policy in an editable state.

Active

Saves the approval policy in a read-only state that you can use in an
entitlement.

Inactive

Saves the approval policy in a read-only state that you cannot use in an
entitlement until you activate the policy.

What to do next
Create the pre- and post-approval levels.

Create an Approval Level
When you create an approval policy, you can add pre- and post-approval levels.
You can create multiple approval levels for an approval phase. See “Approvals Overview,” on page 23.
Prerequisites
“Specify Approval Policy Information,” on page 24.
Procedure
1

On the Pre Approval or Post Approval tab, click the Add icon (

2

Enter a name and, optionally, a description.

3

Select a manual approval requirement.

4
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Option

Description

Always Required

A manual approval is always required.

Required based on conditions

A manual approval is required based on the conditions you select from the
Clause drop-down menu.
You can create a clause to determine whether to include all, include any, or
exclude some of the manual approvers.

Select the approvers.
Option

Action

Specific Users and Groups

Enter a user or group name in the Search text box and press Enter.

Determine approvers from the
request

Select the approvers from the Value drop-down menu.
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5

Indicate who must approve the request or action.
Option

Description

Anyone can approve

Any one of the approvers can approve the request.

All must approve

Each of the approvers must approve the request.

6

Click Add.

7

Click Add again.

You can apply your approval policy to services, catalog items, and actions when you create an entitlement.

Configure an Approval Form
You can configure an approval form to allow the approvers to change the values of system properties for
machine resource settings such as CPU, Lease, or Memory and custom properties before they complete an
approval request.
Only system properties and custom properties that consumers can edit display their original values to
approvers on the approval form.
Custom properties you add to the approval form overwrite any other instances of that custom property for
example, in blueprints, build profiles or endpoints. If your approver decides not to enter a value for the
custom property, the value is not inherited from an existing implementation of the custom property.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or approval administrator.
Procedure
1

On the Pre Approval or Post Approval tab, select an existing approval policy in the draft state.

2

Click the Approval Form tab.

3

Select system properties you want the approver to configure during approval.

4

Add a custom property you want approvers to configure during a pre-provisioning approval phase.
Multiple custom properties can be selected and removed concurrently.
a
b

5

Click the Add icon (

).

Type the custom property value and click Add.

Click Add again.

Update an Approval Policy
To update an existing approval policy, the policy must be in the draft state. Active and inactive approval
policies are read-only. To update an active approval policy that is in use or an inactive approval policy, you
must create a copy of the original policy.
When you make the copy of the approval policy, the status of the new policy is in the draft state. You can
edit all of the attributes except the policy type.
You can create pre- and post-approval levels. For instructions about creating an approval level, see “Create
an Approval Level,” on page 25.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
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Procedure
1

Select Administration > Approval Policies.

2

Select the row of the approval policy to copy.

3

Click the Copy icon (

).

A copy of the approval policy is created.
4

Select the new approval policy to edit.

5

Enter a name in the Name text box.

6

(Optional) Enter a description in the Description text box.

7

Select the state of the policy from the Status drop-down menu.
Option

Description

Draft

Saves the approval policy in an editable state.

Active

Saves the approval policy in a read-only state that you can use in an
entitlement.

Inactive

Saves the approval policy in a read-only state that you cannot use in an
entitlement until you activate the policy.

8

Edit the pre- and post-approval levels.

9

Click Update.

10

Click View Linked Entitlements to view the entitlements linked to the old policy and update them to
use the new approval policy.
You cannot deactivate a policy if it is linked to an entitlement.

What to do next
Deactivate the old policy. See “Deactivate an Approval Policy,” on page 27.

Deactivate an Approval Policy
When an approval policy is out-of-date, you can deactivate the policy so that it is not available during
provisioning.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator.

n

Verify that there are no entitlements linked to the approval policy. See “Update an Approval Policy,” on
page 26.

Procedure
1

Select Administration > Approval Policies.

2

Select the row of the approval policy to deactivate.

3

Click the Edit icon (

).

4

Select Inactive from the Status drop-menu.

5

Click Update.

The approval policy is deactivated.
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Creating an Entitlement
As a tenant administrator or business group manager, you can create entitlements to manage user and
group access to services, catalog items, and resource actions in business groups, and to assign approval
policies to entitlements.
You specify the entitlement information first. This information includes the name and status of the
entitlement and the business group whose selected users and groups are entitled to request the services and
catalog items and perform the actions listed in the entitlement.
You then identify one or more services, catalog items, and resource actions that entitled users can request.
You can also assign approvals to the services, catalog items, and resource actions.

Specify Entitlement Information
When you create an entitlement, start by identifying the name of the entitlement, the business group, and
the users and groups in the business group who are entitled to use the specified items.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or business group manager.
Procedure
1
2

Select Administration > Catalog Management > Entitlements.
Click the Add icon (

).

3

Enter a name in the Name text box.

4

(Optional) Enter a description in the Description text box.

5

(Optional) Select an expiration date and time.
a

Click the calendar icon.

b

Select an expiration year, month, and day, as required.
The actual time of expiration is calculated from your local time.
You can use the double arrows to select an adjacent month, or use the drop-down boxes to select a
different month or year.

c

Click the up and down arrows to select a different time.
Clicking the circled x clears the date and time fields.

6

Select the status of the entitlement from the Status drop-down box.
The status can be Draft or Active. Users have access to items listed in the entitlement only when it is
active.

7

Select the business group for the entitlement from the Business Group drop-down menu.

8

Type a user or group name in the Users & Groups search box.
vRealize Automation displays a list of matching names, if any.

9

Select a name.
The name appears in the Users and Groups list.

10

28

Click Next.

VMware, Inc.

Chapter 4 Managing the Service Catalog

What to do next
For information about entitling users to services, catalog items, and resource actions, see “Creating an
Entitlement,” on page 28.

Add an Item to an Entitlement
You can identify the items in an entitlement in any sequence and combination. For example, you can
combine services and resource actions in the same entitlement, separate them into different entitlements,
specify only catalog items, and so on. You can assign approvals to the services, catalog items, and resource
actions as you add them to the entitlement.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or business group manager.
n

Entitle Users to Services on page 29
When you add a service to an entitlement, you allow the users and groups identified in the entitlement
to request catalog items associated with that service. You can also apply an approval to the service.

n

Entitle Users to Catalog Items on page 30
When you add a catalog item to an entitlement, you allow the business group members identified in
the entitlement to request that catalog item. You can also apply an approval to that catalog item.

n

Entitle Users to Resource Actions on page 31
When you add a resource action to an entitlement, you allow the business group members who are
identified in the entitlement to use the resource action with any item that supports that action. You can
also apply an approval to that resource action.

Entitle Users to Services
When you add a service to an entitlement, you allow the users and groups identified in the entitlement to
request catalog items associated with that service. You can also apply an approval to the service.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or business group manager.
Procedure
1

Select Administration > Catalog Management > Entitlements.

2

Create or edit an entitlement.
Option
Create an entitlement
Edit an entitlement

3

Click the Add icon (

Description
Click Add (

), enter a name, and click Next.

Click an entitlement name, and click Next.

) for Entitled Services.

The Add Services to Entitlement dialog box appears.
4

(Optional) Enter all or part of a service name in the Name search box.
vRealize Automation displays a list of matching names, if any.

5

Select the check boxes of the services to add to the entitlement.

6

(Optional) Select an approval policy from the Apply this Policy to selected Items drop-down menu.

7

Click OK.
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8

(Optional) Change the policy.
a

Point to the down arrow for the service.

b

Click Modify Policy.
The Modify Policy dialog box appears.

c
9
10

11

Select a policy from the Apply this Policy drop-down menu.

Click OK.
(Optional) Click an Add icon (
with this entitlement.

) to entitle users to more services, catalog items, or resource actions

Click Add or Update to save your changes and close the entitlement.
Add appears when you create an entitlement. Update appears when you edit an entitlement.

What to do next
For information about how to specify entitlement information, or how to entitle users to catalog items and
resource actions, see “Creating an Entitlement,” on page 28.

Entitle Users to Catalog Items
When you add a catalog item to an entitlement, you allow the business group members identified in the
entitlement to request that catalog item. You can also apply an approval to that catalog item.
When you add a catalog item and its service to the same entitlement, the approval for the catalog item
applies.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or business group manager.
Procedure
1

Select Administration > Catalog Management > Entitlements.

2

Create or edit an entitlement.
Option
Create an entitlement
Edit an entitlement

3

Click the Add icon (

Description
Click Add (

), enter a name, and click Next.

Click an entitlement name, and click Next.

) for Entitled Catalog Items.

The Add Catalog Items to Entitlement dialog box appears.
4

(Optional) Select the service in which to search in the Service drop-down menu.

5

(Optional) Select the type of catalog item to search for in the Type drop-down menu.

6

(Optional) Type all or part of a catalog item name in the Name search box.
vRealize Automation displays a list of matching names, if any.
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7

Select the check boxes of the catalog items to add to the entitlement.

8

(Optional) Select an approval policy from the Apply this Policy to Selected Items drop-down menu.

9

Click OK.
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10

(Optional) Change the policy.
a

Click the down arrow for the catalog item.

b

Click Modify Policy.
The Modify Policy dialog box appears.

c
11
12

13

Select a policy from the Apply this Policy drop-down menu.

Click OK.
(Optional) Click an Add icon (
with this entitlement.

) to entitle users to more services, catalog items, or resource actions

Click Add or Update.
Add appears when you create an entitlement. Update appears when you edit an entitlement.

What to do next
For information about how to specify entitlement information, or how to entitle users to services and
resource actions, see “Creating an Entitlement,” on page 28.

Entitle Users to Resource Actions
When you add a resource action to an entitlement, you allow the business group members who are
identified in the entitlement to use the resource action with any item that supports that action. You can also
apply an approval to that resource action.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or business group manager.
Procedure
1

Select Administration > Catalog Management > Entitlements.

2

Create or edit an entitlement.
Option
Create an entitlement
Edit an entitlement

3

Click the Add icon (

Description
Click Add (

), enter a name, and click Next.

Click an entitlement name, and click Next.

) for Entitled Actions.

The Add Resource Actions to Entitlement dialog box appears.
4

(Optional) Select the type of resource action in the Type drop-down menu.

5

(Optional) Type all or part of a resource action name in the Name search box.
vRealize Automation displays a list of matching names, if any.

6

Select the check boxes of the resource actions to add to the entitlement.

7

(Optional) Select an approval policy from the Apply this Policy to selected Items drop-down menu.

8

Click OK.
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9

(Optional) Change the policy.
a

Click the down arrow for the resource action.

b

Click Modify Policy.
The Modify Policy dialog box appears.

c
10
11

12

Select a policy from the Apply this Policy drop-down menu.

Click OK.
(Optional) Click an Add icon (
with this entitlement.

) to entitle users to more services, catalog items, or resource actions

Click Add or Update.
Add appears when you create an entitlement. Update appears when you edit an entitlement.

What to do next
For information about how to specify entitlement information, or how to entitle users to services and catalog
items, see “Creating an Entitlement,” on page 28.

Prioritize Entitlements
By prioritizing entitlements in a business group, you can determine the activation order of the approval
policies associated with the entitlements.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or business group manager.
Procedure

32

1

Select Administration > Catalog Management > Entitlements.

2

Click the Prioritize icon (

3

Select a business group from the Business Group drop-down list.

4

Drag an entitlement to a new location in the list to change its priority.

5

Select an update method.

).

Option

Description

Update

Saves your changes.

Update & Close

Saves your changes and closes the Prioritize Elements window.
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5

You can monitor virtual and physical resource use with the vRealize Automation console.
This chapter includes the following topics:
n

“Managing Resource Reports,” on page 33

n

“Resource Reports,” on page 35

n

“Chargeback Reports,” on page 35

n

“Chargeback Cost Calculation,” on page 36

n

“Managing Machine Leases,” on page 39

n

“Reclamation Overview,” on page 40

Managing Resource Reports
You can add real-time resource reports to your Home page to monitor virtual, physical, and cloud resource
usage, change their layout, and export their data to other applications.

Add Reports to the Home Page
You can add one or more IaaS reports to your Home page. These real-time reports list your most recent open
tasks, catalog requests, provisioned items, and provisioned machines broken down by user, blueprint,
compute resource, and business group. Two reports also display updated summaries of reclamation
savings.
Prerequisites
Log in to the vRealize Automation console.
Procedure
1
2

3

Navigate to the Home page.
Click the Edit
menu.

icon in the upper-right corner of the page and click Add Portlets in the drop-down

Click Add for each report to add to your Home page.
A disabled Add button indicates an already added report.

4
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What to do next
“Configure the Report Layout,” on page 34.

Configure the Report Layout
You can configure your Home page to display reports in one, two, three, or four columns. You can move a
report from one column to another.
Prerequisites
Log in to the vRealize Automation console.
Procedure
1
2

3

Navigate to the Home page.
Click the Edit icon (
down menu.

) in the upper-right corner of the page and click Change Layout in the drop-

Select a report layout.
Option

Description

1 Column

Lay out reports in one column.

2 Columns

Lay out reports in two columns of equal or unequal widths.

3 Columns

Lay out reports in three columns of equal or unequal widths.

4 Columns

Lay out reports in four equal columns.

4

Click Submit.

5

Point to the title bar of a report.
The cursor changes to a four-headed cursor.

6

Drag the report to its new location.
The width of the report changes to fit the new location.

Export Report Data
You can save IaaS reports located on your Home page to CSV files where you can customize the data.
Prerequisites
n

Log in to the vRealize Automation console.

n

“Add Reports to the Home Page,” on page 33.

Procedure
1

Navigate to the Home page.

2

Click Export as CSV in the report to save.
Some browsers save the file immediately. With Firefox, a dialog box appears with selections for opening
or saving the report with Microsoft Excel or another application.

3
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Resource Reports
Resource reports display data about machines and resources used and reclaimed according to owner,
compute resource, and group.
Name

Description

My Inbox

Displays a list of the most recent open tasks in your inbox. Click a row to view the detail
page of a task. Click More to open the complete list of inbox tasks.

My Open Requests

Displays a list of your most recent catalog requests. Click a row to view the detail page of a
request. Click More to open the complete list of requests.

My Recent Requests

Displays a list of your most recent catalog requests regardless of status. Click a row to view
the detail page of a request. Click More to open the complete list of requests.

My Items

Displays a list of your most recently provisioned items. Click a row to view the detail page
of an item. Click More to open the complete list of items.

My Group Requests

Displays a list of the most recent catalog requests for users in groups that you manage.
Click a row to view the detail page of a request. Click More to open the complete list of
requests.

My Groups Items

Displays a list of the most recently provisioned items for users in groups that you manage.
Click a row to view the detail page of an item. Click More to open the complete list of
items.

New & Noteworthy

Highlights catalog items that were recently made available in the catalog.

Calendar of Events

Displays a calendar view of important events for catalog items that you own, such as lease
expiration and machine destruction.

IaaS Capacity Usage by
Blueprint

Displays the number of machines provisioned from each blueprint and the total resources
that those machines used.

IaaS Capacity Usage by
Group

Displays the number of machines that users own in each business group and the total
resources that those machines use.

IaaS Capacity Usage by
Owner

Displays the number of machines that each user owns and the total resources that those
machines use.

IaaS Capacity Usage by
Compute Resource

Displays the number of machines provisioned on each compute resource and the total
resources that those machines use.

IaaS Reclamation Savings
by Owner

Displays a summary of cost savings because of reclaiming machines that each user owns.

IaaS Reclamation Savings
by Group

Displays a summary of cost savings because of reclaiming machines that users in each
business group own.

IaaS Chargeback by Group
by Allocated Resources

Displays the cumulative cost over time of provisioned machines that each business group
owns. See “Chargeback Reports,” on page 35.

My Trips

Displays a sample consumer report.

Chargeback Reports
Chargeback reports allow IaaS administrators, tenant administrators, and business group managers to track
the cumulative cost of provisioned machines over time.
Chargeback cost is calculated differently for each machine type. See “Chargeback Cost Calculation,” on
page 36.
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Table 5‑1. Chargeback Reports
Situation

Report

Role Restrictions

Monitor machine costs at the business
group level. By default, the report
shows the first 100 most expensive
machines. You can filter these reports
by business group and by machine
type, and run the report with different
time parameters. For example, you can
see the cost of all machines owned by
all business groups last year, or you
can view the cost of physical machines
owned by business group B last week.

Chargeback by Allocated
Resources by Group

Business group managers see reports only
for the business groups that they manage.
IaaS administrators and tenant
administrators see reports for all business
groups within the tenant.

Chargeback Cost Calculation
Machine costs are calculated differently depending on the machine type, but are typically based on a
combination of cost profiles and blueprint cost settings.
For more information about creating and applying cost profiles, see the IaaS Configuration documentation for
the relevant machine type.

Cost Calculation for Virtual Machines
Several factors can contribute to the calculation of cost for virtual machines.
The daily cost of a machine is based on the cost of the memory, CPU, and storage resources that it consumes,
and the blueprint cost.
Table 5‑2. Daily Cost Drivers
Cost Driver

Calculated Cost

Memory

Allocated memory (GB) multiplied by the daily memory cost per gigabyte specified in the
cost profile associated with the compute resource on which the machine is provisioned

CPUs

Number of allocated CPUs multiplied by the daily CPU cost specified in the cost profile
associated with the compute resource on which the machine is provisioned

Storage

Allocated storage (GB) multiplied by the storage cost per gigabyte specified in one of the
following places:
n The cost profile associated with the compute resource on which the machine is
provisioned
n The storage cost profile on the datastore on which the machine is provisioned
The cost specified in a storage cost profile for a specific datastore overrides the storage
cost specified in a cost profile on the compute resource.

Blueprint cost

The value for daily cost specified in the machine blueprint is added to the total cost of the
machine.
This value can represent a markup for using the machine in addition to the resources
consumed by the machine.

Lease cost is calculated as daily cost multiplied by the total number of days in the lease period, if applicable.
Cost-to-date is calculated as daily cost multiplied by the number of days a machine is provisioned.
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Cost Information for Cloud Machines
Cost profiles do not apply to cloud machines. The only factor in calculating cost for cloud machines is the
blueprint cost.
Lease cost is calculated as daily cost multiplied by the total number of days in the lease period, if applicable.
Cost-to-date is calculated as daily cost multiplied by the number of days a machine is provisioned.

Cost Calculation for Physical Machines
Several factors can contribute to the calculation of cost for physical machines.
The daily cost of a machine is based on the cost of the memory and CPU resources that it consumes, and the
blueprint cost.
Table 5‑3. Daily Cost Drivers
Cost Driver

Calculated Cost

Memory

Memory (GB) on the physical machine multiplied by the daily memory cost per gigabyte
specified in the cost profile associated with the machine

CPUs

Number of CPUs on the physical machine multiplied by the daily CPU cost specified in
the cost profile associated with the machine

Blueprint cost

The value for daily cost specified in the machine blueprint is added to the total cost of the
machine.
This value can represent a markup for using the machine in addition to the resources
consumed by the machine.

Storage cost specified in a cost profile is not taken into account for physical machines. If you assign a cost
profile that includes a value for storage cost to a physical machine, it is ignored. You can account for the cost
of using storage in the daily cost specified in the blueprint for the physical machine.
Lease cost is calculated as daily cost multiplied by the total number of days in the lease period, if applicable.
Cost-to-date is calculated as daily cost multiplied by the number of days a machine is provisioned.

Cost Calculation for vCloud Director
Several factors can contribute to the chargeback calculation of cost for vApps.
The cost of a vApp is based on the cost of memory and CPU that component machines consume, and the
costs specified in the vApp blueprint and vApp component blueprints. Storage cost is not taken into account
for component machines. If you assign a cost profile that includes a value for storage cost to a component
machine, it is ignored. You can account for the cost of using storage in the daily cost specified in the
blueprint for the component machine.
Table 5‑4. Daily Cost Drivers
Cost Driver

Calculated Cost

Memory

Allocated memory (GB) multiplied by the daily memory cost per gigabyte specified in the
cost profile associated with the virtual datacenter on which a component machine is
provisioned

CPUs

Number of allocated CPUs multiplied by the daily CPU cost specified in the cost profile
associated with the virtual datacenter on which a component machine is provisioned
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Table 5‑4. Daily Cost Drivers (Continued)
Cost Driver

Calculated Cost

Blueprint cost (vApp
component)

The value for daily cost specified in the vApp component blueprint is added to the total
cost of each component machine.
This value can represent a markup for using the machine in addition to the resources
consumed by the machine.

Blueprint cost (vApp)

The value for daily cost specified in the vApp blueprint is added to the total cost of the
vApp.
This value can represent a markup for using the vApp in addition to the costs of the
component machines.

Lease cost is calculated as daily cost multiplied by the total number of days in the lease period, if applicable.
Cost-to-date is calculated as daily cost multiplied by the number of days a vApp is provisioned.

Cost Calculation for Multi-Machine Services
Chargeback reports calculate and report the cost of a multi-machine and its component machines.
Chargeback cost for component machines is calculated differently depending on the type of machine.

Parent Machine
The cost of the parent multi-machine is determined by the cost specified in the multi-machine parent
blueprint.

Virtual Component Machines
The daily cost of a machine is based on the cost of the memory, CPU, and storage resources that it consumes,
and the blueprint cost.
Table 5‑5. Daily Cost Drivers
Cost Driver

Calculated Cost

Memory

Allocated memory (GB) multiplied by the daily memory cost per gigabyte specified in the
cost profile associated with the compute resource on which the machine is provisioned

CPUs

Number of allocated CPUs multiplied by the daily CPU cost specified in the cost profile
associated with the compute resource on which the machine is provisioned

Storage

Allocated storage (GB) multiplied by the storage cost per gigabyte specified in one of the
following places:
n The cost profile associated with the compute resource on which the machine is
provisioned
n The storage cost profile on the datastore on which the machine is provisioned
The cost specified in a storage cost profile for a specific datastore overrides the storage
cost specified in a cost profile on the compute resource.

Blueprint cost

The value for daily cost specified in the machine blueprint is added to the total cost of the
machine.
This value can represent a markup for using the machine in addition to the resources
consumed by the machine.

Lease cost is calculated as daily cost multiplied by the total number of days in the lease period, if applicable.
Cost-to-date is calculated as daily cost multiplied by the number of days a machine is provisioned.

Cloud Component Machines
The cost of a cloud machine is determined by the cost specified in the blueprint.
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Lease cost is calculated as daily cost multiplied by the total number of days in the lease period, if applicable.
Cost-to-date is calculated as daily cost multiplied by the number of days a machine is provisioned.

Physical Component Machines
The daily cost of a machine is based on the cost of the memory and CPU resources that it consumes, and the
blueprint cost.
Table 5‑6. Daily Cost Drivers
Cost Driver

Calculated Cost

Memory

Memory (GB) on the physical machine multiplied by the daily memory cost per gigabyte
specified in the cost profile associated with the machine

CPUs

Number of CPUs on the physical machine multiplied by the daily CPU cost specified in
the cost profile associated with the machine

Blueprint cost

The value for daily cost specified in the machine blueprint is added to the total cost of the
machine.
This value can represent a markup for using the machine in addition to the resources
consumed by the machine.

Storage cost specified in a cost profile is not taken into account for physical machines. If you assign a cost
profile that includes a value for storage cost to a physical machine, it is ignored. You can account for the cost
of using storage in the daily cost specified in the blueprint for the physical machine.
Lease cost is calculated as daily cost multiplied by the total number of days in the lease period, if applicable.

Managing Machine Leases
Tenant administrators or business group managers can use leases to place time limits on resource
consumption.
Tenant administrators or business group managers can optionally define a lease duration when creating a
blueprint.
n

If a blueprint does not specify a lease period, machines are provisioned from that blueprint with no
expiration date.

n

If a blueprint specifies a single value for lease duration, machines are provisioned from that blueprint
with the lease duration specified in the blueprint.

n

If a blueprint specifies a range of possible lease durations, a user can select the desired lease duration
when submitting the machine request. Machine requests can be subject to approval based on the
requested lease duration.

The lease duration can be changed after a machine is provisioned. A typical use case is for a machine owner
to extend the lease past its original expiration date. The following considerations apply to modifying the
lease on a provisioned machine:
n

Users must be entitled to the Change Lease action to modify a lease.

n

The new expiration date is not subject to the constraints on lease duration specified in the blueprint.

n

Tenant administrators or approval administrators can create approval policies of the type Service
Catalog - Resource Action Request (Change Lease). The policy can be configured so that approval is
always required for lease modifications, or approval can be conditional based on criteria such as the
new lease duration or the cost of the machine.

Tenant administrators can also request that a machine owner release a provisioned machine for reclamation,
which might result in a shortened lease period.
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Managing Leases for Multi-Machine Services
Leases are controlled at the multi-machine service level. Lease operations such as change, extend, and expire
are not available for individual component machines.
n

The lease period for a multi-machine service always overrides the lease on its component machines. A
component machine always has the same lease period as the multi-machine service.

n

When the expiration date for a multi-machine service changes, that change is applied to all its
component machines.

n

Component machines cannot expire earlier than the multi-machine service to which they belong.

n

When a multi-machine service expires, all its component machines expire at the same time. The multimachine service and its component machines are destroyed immediately when the lease expires.

Reclamation Overview
Tenant administrators can use metrics such as low CPU use, low memory use, or low hard disk use to
reclaim virtual machines in their tenant and help control resources.
You can use the basic metrics provided by vRealize Automation to sort and filter metrics information for all
of your machines, or you can configure a vRealize Operations Manager endpoint to provide metrics and
health badges for your vSphere virtual machines.
You can use the metrics to identify underused machines that might be candidates for reclamation. Select the
candidate machines and send a reclamation request to the owners of the machines. The machine owner has
a fixed period of time to respond to the request. If the machine is still in use, the owner can stop the
reclamation process and continue using the machine. If the machine is no longer needed, the owner can
release the machine for reclamation, in which case the machine lease is ended. If the owner does not respond
in a timely manner, a lease determined by the administrator is imposed. If the owner continues to take no
action, the machine is powered off on the new expiration date, the machine is reclaimed, and the resources
are freed.

Configure a Metrics Provider
You can configure vRealize Automation to use vRealize Operations Manager health and resource metrics for
vSphere virtual machines.
For more information about vRealize Operations Manager health badges and metrics, see the
vRealize Operations Manager documentation.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator.

n

Create a vRealize Operations Manager user account with view and resource metrics query privileges
for all vSphere servers that you integrate with vRealize Automation.

n

Create vRealize Operations Manager adapter instances for all vSphere servers you add as endpoints in
vRealize Automation. For information about creating adapter instances, see the
vRealize Operations Manager documentation.

Procedure
1

40

Select Administration > Tenant Machines > Metrics Provider Configuration.
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2

Select a metrics provider.
Option

Description

(Default) vRealize Automation
metrics provider

If you do not have a vRealize Operations Manager instance,
vRealize Automation provides basic machine metrics.

vRealize Operations Manager
endpoint

Provide connection information for the vRealize Operations Manager
instance you want to use as your metrics provider for vSphere virtual
machines.

3

Click Test Connection.

4

Click Save.

Tenant administrators can view health badges and health alerts on the item details pages for vSphere virtual
machines, and can view vRealize Operations Manager metrics and health badges when they filter by the
platform type vSphere on the reclamations page.
What to do next
“Send Reclamation Requests,” on page 41.

Send Reclamation Requests
A tenant administrator can send reclamation requests to virtual machine owners. A reclamation request
specifies a new lease length in days, the amount of time given for a machine owner’s response, and which
machines to target for reclamation.
Prerequisites
n

Log in to the vRealize Automation console as a tenant administrator.

n

(Optional) To see health badges or view metrics provided by vRealize Operations Manager, “Configure
a Metrics Provider,” on page 40.

Procedure
1
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Find virtual machines that match your search criteria.
You must select platform type vSphere to view metrics provided by vRealize Operations Manager.
a

Click the Advanced Search down arrow to open the search box.

b

Enter or select one or more search values.

c
3

Option

Action

Virtual Machine name contains

Enter one or more characters in the text box to find virtual machine
names that match.

Owner name contains

Enter a name in the text box to find owner names that match.

Business group names contains

Enter a name in the text box to find business group names that match.

Platform Type (required for
vRealize Operations Manager)

Select a platform type from the drop-down menu. Select vSphere to
view metrics provided by vRealize Operations Manager.

Power State

Select a power state value from the drop-down menu to find virtual
machines with a matching power state.

Expiration date between

Click the calendar icons and select start and end dates to find
expiration dates inside the range.

CPU usage

Select a value from the drop-down menu to find virtual machines with
High CPU use, above 80%, Low CPU use below 5%, or None, no value.
If you are querying vRealize Operations Manager metrics, you cannot
use this filter to query, and you cannot sort results by CPU usage.

Mem usage

Select a value from the drop-down menu to find virtual machines with
High Memory use, above 80%, Low Memory use, below 10%, or None,
no value.
If you are querying vRealize Operations Manager metrics, you cannot
use this filter to query, and you cannot sort results by memory usage.

Disk usage

Select a value from the drop-down menu to find virtual machines with
Low Hard Disk use, less than 2 KBs per second or None, no value.
If you are querying vRealize Operations Manager metrics, you cannot
use this filter to query, and you cannot sort results by disk usage.

Network usage

Select a value from the drop-down menu to find virtual machines with
Low Network use, less than 1 KB per second, or None, no value.
If you are querying vRealize Operations Manager metrics, you cannot
use this filter to query, and you cannot sort results by network usage.

Complex metric

Select a value from the drop-down menu to find virtual machines based
on complex metrics. For example, select idle to find machines that have
CPU, network, memory, and disk usage values all under 20%.
You cannot use this filter if you are querying
vRealize Operations Manager metrics.

Click the search icon (

).

From the current results page, select one or more virtual machines to reclaim.
For manageability, only machines selected on the current results page are reclaimed.

4

Click Reclaim Virtual Machine.
Virtual machines selected on the current results page are included in the request.
Note The Reclamation page can list machines that are not available for reclamation, such as machines
for which the lease has expired. If you specify a machine that is not available for reclamation, you
receive the following error:
Selection Error: Virtual machine name is not in valid state for reclamation.
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5

Enter the duration of the new lease in the New lease length (days) text box.
The minimum is 1 day, the maximum is 365 days, and the default is 7 days.

6

Enter how many days the machine owner has to respond to the reclamation request in the Wait before
forcing lease (days) text box.
At the end of that time, the machine gets a new lease with the new lease length. The minimum waiting
period is 1 day, the maximum is 365 days, and the default is 3 days.

7

Enter a reason for the request in the Reason for request text box.

8

Click Submit.

9

Click OK.

When you send a reclamation request, it appears in the Inbox of the owner of the virtual machine. If the
owner does not respond to the request in the required number of days, the virtual machine gets a new lease
of the specified length, unless its current lease is shorter. If the owner clicks Item in Use on the reclamation
request, the virtual machine's lease remains unchanged. If the owner clicks Release for Reclamation, the
virtual machine lease expires immediately.
What to do next
“Track Reclamation Requests,” on page 43.

Track Reclamation Requests
A tenant administrator can track the current state of reclamation requests and other details.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator.
Procedure
1

Select Administration > Tenant Machines > Reclamation Requests.

2

Find the virtual machines that match your search criteria.
a

Click the Advanced Search down arrow to open the search box.

b

Type or select one or more search values.

c
d
3
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Option

Action

Virtual Machine name contains:

Type one or more characters in the text box to find virtual machine
names that match.

Owner name contains:

Type one or more characters in the text box to find owner names that
match.

Request Reason contains:

Type one or more characters in the text box to find a request reason that
matches.

Request State:

Select a request state value from the drop-down menu to find virtual
machines with a matching request state.

Click the Search icon (

) or press Enter to start the search.

Click the Advanced Search up arrow to close the search box.

(Optional) Click Refresh Data to update the display of reclamation requests.
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6

Managing virtual machines requires different roles to perform some tasks. For example, only a fabric
administrator can change the reservation of a virtual machine, but a machine owner can create a snapshot of
a virtual machine.
This chapter includes the following topics:
n

“Reconfigure a Machine,” on page 45

n

“Change the Reservation of a Virtual Machine,” on page 50

n

“Create a Snapshot of Your Machine,” on page 51

Reconfigure a Machine
vSphere, vCloud Director, and SCVMM platforms support reconfiguration of existing machines to
accommodate changes in workload demand.
A business group manager, support user, or machine owner can perform the following tasks:
n

Reconfigure CPU or memory

n

(vSphere and vApp only) Reconfigure network and Storage

n

Change description

n

Add, edit, and delete properties

n

Reconfigure shutdown

Reconfiguration requests are subject to approval based on entitlements, policies, and specifications on the
machine blueprint. You cannot reconfigure any machines if you are not entitled to the Reconfigure
(Machine) actions, and you might not be able reconfigure a specific machine if the machine blueprint does
not allow reconfigure. If your machine is provisioned on SCVMM, you cannot reconfigure networks or
storage.
If you are entitled to the Cancel Reconfigure (Machine) and Execute Reconfigure (Machine) actions, you can
cancel a reconfiguration or retry a failed reconfiguration.
Prerequisites
n

Log in to the vRealize Automation console as a machine owner, support user, tenant administrator, or
business group manager.

n

The machine you want to reconfigure has the status On or Off with no active reconfigure status.

VMware, Inc.

45

Tenant Administration

Procedure
1

Start the Operation on page 46
You start the reconfigure operation by selecting a provisioned machine with an On or Off status.

2

Reconfigure CPUs and Memory on page 46
You can optionally change the number of CPUs or the amount of memory used by the provisioned
machine, within the limits set by the provisioning blueprint.

3

Reconfigure Storage on page 47
You can add, delete, or change the size of a storage volume on a provisioned virtual machine.

4

Add Custom Properties on page 47
Optionally, you can add custom properties to a volume.

5

Reconfigure Networks on page 48
You can add, remove, or edit a network adapter when you reconfigure a virtual machine.

6

Schedule the Start on page 49
You can start the reconfiguration immediately, or schedule it to start at a particular day and time. You
can also specify the power option for the machine before reconfiguring it.

Start the Operation
You start the reconfigure operation by selecting a provisioned machine with an On or Off status.
Prerequisites
n

Log in to the vRealize Automation console as a machine owner, support user, tenant administrator, or
business group manager.

n

The machine you want to reconfigure must have the status On or Off with no active reconfigure status.

Procedure
1

Select Items > Machines.

2

Select the row of the machine to reconfigure.

3

Select Reconfigure from the Actions drop-down menu.

What to do next
“Reconfigure CPUs and Memory,” on page 46.

Reconfigure CPUs and Memory
You can optionally change the number of CPUs or the amount of memory used by the provisioned machine,
within the limits set by the provisioning blueprint.
Prerequisites
“Start the Operation,” on page 46.
Procedure
1

(Optional) Type the number of CPUs in the # CPUs text box.
The allowable range appears next to the text box.

2

(Optional) Type the amount of memory in the Memory (MB) text box.
The allowable range appears next to the text box.
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What to do next
“Reconfigure Storage,” on page 47.

Reconfigure Storage
You can add, delete, or change the size of a storage volume on a provisioned virtual machine.
You cannot reconfigure storage for the IDE disk type.
Prerequisites
“Reconfigure CPUs and Memory,” on page 46.
Procedure
1

Click the Storage tab.
The allowable range for storage appears below the Storage volumes table.

2

(Optional) Add a volume.
a

Click New Volume.

b

Type the capacity in the Capacity (GB) text box.

c

(Optional) Select a storage reservation policy from the Storage reservation policy drop-down
menu.

d
3

Click the Save icon (

).

(Optional) Delete a volume.
a
b

Locate the volume.
Click the Delete icon (

).

An unselectable icon indicates an undeletable volume such as one from a linked clone.
4

(Optional) Increase the size of a volume.
You cannot reduce the size of existing volumes. Volume size is limited by the total amount of storage
specified in the blueprint, less the amount allocated to other volumes.
a
b
c
d

Locate the volume.
Click the Edit icon (

).

Type the new size in the Capacity (GB) text box.
Click the Save icon (

).

What to do next
“Add Custom Properties,” on page 47.

Add Custom Properties
Optionally, you can add custom properties to a volume.
You cannot use custom properties to enter values for volume disk number, capacity, label, or storage
reservation policy. You must enter these values in their required locations by adding or editing a volume in
the Storage volumes table.
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Prerequisites
“Reconfigure Storage,” on page 47.
Procedure
1

In the Custom Properties column of the Storage volumes table, click Edit for the volume receiving the
custom property.

2

Click New Property.

3

Enter the name of the custom property in the Name text box.

4

Enter the value for the custom property in the Value text box.

5

Select the Encrypted check box to encrypt the value.

6

Select the Prompt user check box to prompt users for the value when they request the machine.

What to do next
“Reconfigure Networks,” on page 48.

Reconfigure Networks
You can add, remove, or edit a network adapter when you reconfigure a virtual machine.
Prerequisites
“Add Custom Properties,” on page 47.
Procedure
1

Click the Network tab.

2

(Optional) Add a network adapter.
a

Click New Network Adapter.

b

Select a network from the Network Path drop-down menu.
All networks selected on the machine’s reservation are available.

c

Type a static IP address for the network in the Address text box.
The IP address must be unallocated in the network profile assigned in the reservation.

d
3

Click the Save icon (

).

(Optional) Remove a network adapter.
a
b

Locate the network adapter.
Click the Delete icon (

).

You cannot remove network adapter 0.
4

(Optional) Edit a network adapter.
a
b
c
d
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Locate the network adapter.
Click the Edit icon (

).

Select a network from the Network Path drop-down menu.
Click the Save icon (

).
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What to do next
“Schedule the Start,” on page 49.

Schedule the Start
You can start the reconfiguration immediately, or schedule it to start at a particular day and time. You can
also specify the power option for the machine before reconfiguring it.
Prerequisites
“Reconfigure Networks,” on page 48.
Procedure
1

Click the Execution tab.

2

(Optional) Select an option from the Execute request drop-down menu.
Option

Description

Immediate

Start reconfiguration as soon as possible after approval.

Scheduled

Start reconfiguration at the specified date and time. Type or select the date
and time in the text boxes that appear.

The scheduled time is the local time where the vRealize Automation Web server is located. If Execute
request is not available, reconfiguration starts immediately.
3

(Optional) Select a power action from the Power action drop-down menu.
Option

Description

Reboot if required

(Default) If required, reboot the machine before reconfiguring it.

Reboot

Reboot the machine before reconfiguring it, regardless of whether reboot is
required.

Do not reboot

Do not reboot the machine before reconfiguring it, even if reboot is
required.

The following conditions require that the machine be rebooted before reconfiguration:
n

CPU change where hot CPU is not supported or is disabled

n

Memory change where hot CPU is not supported or is disabled

n

Storage change where hot CPU is not supported or is disabled

n

Hardware reconfiguration

If the machine is in the shutdown state, it is not rebooted.
4

Click OK.

What to do next
You can monitor the progress of the reconfiguration by observing the workflow states displayed in the user
interface. See “Workflow States of Reconfigure Operations,” on page 50.
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Workflow States of Reconfigure Operations
When reconfiguration starts and as it progresses through the workflow, you can monitor the progress from
the Edit page.
Table 6‑1. Workflow States of Reconfigure Operations
State

Description

Reconfigure pending

The State Operation was created.

Scheduled

A scheduled workflow has been created for the Distributed Execution Manager (DEM).

Reconfiguring

The interface-specific workflow is being executed.

Reconfigure failed, waiting to
retry

The reconfigure failed, waiting for the owner to request a retry. If the machine owner is
entitled to the actions execute reconfigure or cancel reconfigure, the owner can retry or
cancel a reconfiguration.

ReconfigureFailed

The reconfigure failed, waiting for the RVG workflow to perform the next action.

ReconfigureSuccessful

The reconfigure was successful, waiting for the RVG workflow to perform the next
action.

Canceled

The user has canceled the reconfiguration. Machine owners who are entitled to the
cancel reconfigure action can cancel a reconfiguration.

Complete

The completion workflow sets this state after completing the cleanup, so that the RVG
workflow can proceed to clean up the state operations and approvals. A status of
complete indicates that the request from vRealize Automation is finished, but it does not
indicate that the machine reconfiguration completed successfully.

Change the Reservation of a Virtual Machine
A fabric administrator can change the reservation of a virtual machine. This ability is useful when a virtual
machine moves to a new storage path that is not available in its current reservation.
You can change the machine’s current compute resource. You can also move it to any reservation on that
compute resource, including one belonging to a different business group. You must be a business group
manager of the original and the target business groups to use this function.
Prerequisites
Log in to the vRealize Automation console as a fabric administrator.
Procedure

50

1

Select Infrastructure > Machines > Managed Machines.

2

Locate the virtual machine with the reservation to change.

3

Click Change Reservation in the drop-down menu.

4

Select values from the drop-down menus as required.

5

Click OK.
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Create a Snapshot of Your Machine
Depending on how your administrators have configured your environment, you might be able to create a
snapshot of your virtual machine. A snapshot is an image of a virtual machine at a specific time. It is a
space-efficient copy of the original VM image. Snapshots are an easy way to recover a system from damage,
data loss, or security threats. After you create a snapshot of your virtual machine, you can apply it and reset
your system back to the point where the snapshot was taken.
When you create a memory snapshot, the snapshot captures the state of the virtual machine power settings
and, optionally, the virtual machine's memory. When you capture the virtual machine's memory state, the
snapshot operation takes longer to complete. You might also see a momentary lapse in response over the
network.
Prerequisites
n

An existing virtual machine that is powered on, off, or suspended.

n

If your virtual machine is configured for one or more independent disks, power off the machine before
creating a snapshot. You cannot create a snapshot when it is powered on. For disk configuration
information, see Custom Properties V Table.

n

Snapshot Manager is enabled on your machine by a tenant administrator or business group manager.
For more information, see IaaS Configuration for Virtual Platforms.

Procedure
1

Select Items > Machines.

2

Locate the machine to snapshot.

3

In the Actions column, click the down arrow and click View Details.

4

Click the Snapshots tab.

5

Click the Add icon (

).

6

Enter a name and, optionally, a description.

7

Select Snapshot the machine's memory to capture the memory of the virtual machine.

8

Click OK.
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You can import or provision a physical machine, connect a managed physical machine to the management
interface of its endpoint, and join a hypervisor-provisioned physical machine to a vCenter Server cluster.
This chapter includes the following topics:
n

“Physical Machine Provisioning and Management,” on page 53

n

“Physical Endpoints,” on page 53

n

“Physical Reservations,” on page 54

n

“Configure Hardware Details,” on page 54

n

“Assign a Cost Profile to a Physical Machine,” on page 55

n

“Provision a Reserved Physical Machine,” on page 55

n

“Import a Physical Machine,” on page 56

n

“Connect a Physical Machine to an Endpoint,” on page 57

n

“Join a Hypervisor to a Cluster,” on page 58

Physical Machine Provisioning and Management
To provision and manage physical machines, vRealize Automation communicates directly with each
system’s management interface to run actions such as OS installation, rebooting, and reprovisioning.
By directly provisioning an operating system on a physical system using the hardware’s management
interface, machine requesters and administrators can standardize, customize, use, track, manage and
decommission physical machines in the same manner as virtual and cloud machines.
You can provision a virtual machine on a single virtualization compute resource and you can provision
cloud machines within a single cloud service account. One physical machine represents one hardware
system. But you provision, use, and manage virtual, cloud, and physical machines in much the same way.

Physical Endpoints
A physical endpoint represents one physical machine or a pool of multiple physical machines. To make a
physical machine available for provisioning, you must create an endpoint to represent it.
Information about each known physical machine, such as its installed memory and CPU count, is collected
regularly through its management interface. Physical machines do not belong to fabric groups. A fabric
administrator can manage any known physical machine and reserve it for any business group.
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Until a physical machine is provisioned, it is considered to be unprovisioned, even if it already has an
operating system. After it is provisioned with an operating system, or imported with its existing operating
system intact, a physical machine is under the same management and control as a virtual or cloud machine.
vRealize Automation communicates with physical machines through the following types of physical
endpoints, which represent the management interfaces through which it communicates.
n

Cisco UCS Manager

n

Dell iDRAC

n

HP iLO

iDRAC and iLO endpoints represent single standalone machines. Cisco UCS Manager endpoints represent
pools of multiple machines.

Physical Reservations
A physical reservation is a set of physical machines reserved for and available to a particular business group
for provisioning.
Any physical machine or blade represented by a physical endpoint is available to any fabric administrator to
include in a physical reservation, but each machine or blade can belong to only one reservation.
Unprovisioned physical machines or blades must be added to a physical reservation before they can be
provisioned or imported, and cannot be removed from a reservation until they are decommissioned and
become unprovisioned. Each physical reservation is for one business group only but a business group can
have any number of physical reservations containing any number of physical machines or blades.
A reservation can also define policies, priorities, and quotas that determine machine placement.

Configure Hardware Details
A fabric administrator can modify the data center, row, and rack details of a managed or reserved physical
machine.
Prerequisites
Log in to the vRealize Automation console as a fabric administrator.
Procedure
1

54

Navigate to a managed or reserved physical machine.
Machine Type

Location

Managed

Select Infrastructure > Machines > Managed Machines

Reserved

Select Infrastructure > Machines > Reserved Machines

2

Locate the physical machine to be configured.

3

Select Edit from the drop-down menu.

4

Click the Hardware tab.

5

Type values in the Data center, Row, and Rack text boxes, as required.

6

Click OK.
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Assign a Cost Profile to a Physical Machine
A fabric administrator can assign a cost profile to a managed or reserved physical machine.
Prerequisites
n

Log in to the vRealize Automation console as a fabric administrator.

n

Verify that you have a reserved or managed physical machine in vRealize Automation. The managed
physical machine must be powered off.

Procedure
1

Navigate to a managed or reserved physical machine.
Machine Type

Navigation

Managed

Infrastructure > Machines > Managed Machines

Reserved

Infrastructure > Machines > Reserved Machines

2

Locate the physical machine to be assigned the cost profile.

3

Click Edit in the drop-down menu.
A managed physical machine must have an Off status for Edit to appear in the drop-down menu.

4

Click the Hardware tab.

5

(Optional) Click New cost profile to create a cost profile.
The link opens the Cost Profiles page.

6

Select a cost profile from the Cost profile drop-down menu.
The memory and CPU costs of the machine appear.

7

Click OK.

What to do next
You must navigate back to the Managed Machines or Reserved Machines page to finish assigning the cost
profile.

Provision a Reserved Physical Machine
You provision a reserved physical machine by using a physical blueprint. The reservation for the machine
determines the business group, so only blueprints from that group appear.
When you use the Provision option, provisioning proceeds even if the CPU count or memory of the selected
machine does not match the specifications in the selected blueprint.
The Provision option does not appear for an unprovisioned Cisco USC physical machine with an associated
service profile, which indicates it has an existing operating system. To provision such a machine in
vRealize Automation, import then reprovision the machine with the same blueprint used for the import.
Caution When you use the Provision option to provision a physical machine with an existing operating
system, the operating system and all associated data are deleted.
None of these changes affects the machine itself, but change only the record of the machine, and in some
cases, the virtualization platform’s record of a virtual machine, in vRealize Automation. The correct property
value is restored and the record corrected with the next data collection.
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Prerequisites
n

Log in to the vRealize Automation console as a business group manager.

n

Verify that a fabric group exists that does not have compute resources or a physical endpoint for the
physical machine.

n

Verify that a business group exists.

n

Verify that a physical reservation exists and that it contains a physical machine.

n

Create a physical blueprint. The Properties tab in the blueprint must include the Image.ISO.Location
and Image.ISO.Name custom properties to identify the image to be deployed on the physical machine
during provisioning.

For more information about how to prepare for provisioning a physical machine, see IaaS Configuration for
Physical Machines.
Procedure
1

Select Infrastructure > Machines > Reserved Machines.

2

Locate the machine to provision.

3

Select Provision from the drop-down menu.

4

Select the blueprint to use when provisioning the machine.
Only blueprints in the associated business group appear.

5

Click the Request Information tab.

6

Type values in the Description, Owner, and Reason for request text boxes, as required.
Your user name appears in the Owner text box.

7

(Optional) Add custom properties.
If the physical blueprint does not include the Image.ISO.Location and Image.ISO.Name custom
properties to identify the image being deployed on the physical machine, you can enter them here.
a

Click the Properties tab.

b

Click New Property.

c

Type a custom property name in the Name text box.

d

Type the value of the custom property in the Value text box.

e
f
8

Click the Save icon (

).

Repeat Step 7a through Step 7e to add more custom properties.

Click OK.

Import a Physical Machine
A fabric administrator with business group manager privileges can import a reserved physical machine
while retaining its current operating system. The fabric administrator then becomes the machine's owner.
The Import option brings a reserved machine under vRealize Automation management while retaining its
current operating system. The Import option is not available for an unprovisioned Cisco UCS physical
machine with no associated service profile.
If a mismatch exists between the imported machine and the blueprint you select, for example a different
amount of memory or number of CPUs, the vRealize Automation record of the machine differs from its
actual specifications until the machine is decommissioned.
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Prerequisites
n

Log in to the vRealize Automation console as a fabric administrator and as a business group manager.

n

Create a machine prefix.

n

An IaaS administrator created a fabric group with no compute resources selected, and an endpoint for
the physical machine to be imported.

n

A tenant administrator created a business group.

n

Create a physical reservation and add a physical machine to it.

n

Create a physical blueprint.

For more information about how to prepare for importing a physical machine, see IaaS Configuration for
Physical Machines.
Procedure
1

Select Infrastructure > Machines > Reserved Machines.

2

Locate the reserved machine to import and select Import from its drop-down menu.

3

Select the blueprint to use when importing the machine.
Only blueprints in the associated business group are displayed.

4

Type the name for the imported machine in the Machine name text box.

5

(Optional) Type a comment in the Reason for request text box.

6

Click OK.

The machine is imported with you as owner and a status of Off.

Connect a Physical Machine to an Endpoint
A fabric administrator can connect to the management interface of a reserved or managed physical machine.
When you connect a physical machine to an endpoint and log into the management interface, you can
perform remote operations on the machine.
Prerequisites
n

Log in to the vRealize Automation console as a fabric administrator.

n

Verify that you have a reserved or managed physical machine in vRealize Automation.

Procedure
1

Select Infrastructure > Machines > Managed Machines.

2

Locate the physical machine to connect to the endpoint.

3

Click Connect to Endpoint in the drop-down menu.
The login page for the endpoint's management interface opens in a new browser window.

4
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Join a Hypervisor to a Cluster
A fabric administrator and business group manager can join a physical machine provisioned as a hypervisor
to an existing compute resource cluster in vCenter Server.
Prerequisites
n

Log in to the vRealize Automation console as a fabric administrator and as a business group manager.

n

A system administrator installed a vSphere agent as described in Installation and Configuration. The
agent must manage the vCenter Server instance where you plan to join the hypervisor to an existing
cluster.

n

An administrator created an ESXi or ESX reference machine for deployment on the physical machine
being provisioned. See IaaS Configuration for Physical Machines.

n

An IaaS administrator created a fabric group, a vSphere endpoint for the targeted vCenter Server
instance, and a physical endpoint for the physical machine.

n

A tenant administrator created a business group.

n

Create a physical reservation and add the physical machine to it.

n

A tenant administrator or business group manager created a physical blueprint for a hypervisor
physical machine. The Properties tab in the blueprint must include the Image.ISO.Location and
Image.ISO.Name custom properties to identify the image to be deployed on the physical machine
during provisioning.

n

Provision the physical machine as a hypervisor with the blueprint.

n

Connect the hypervisor provisioned physical machine to its endpoint. See “Connect a Physical Machine
to an Endpoint,” on page 57.

n

After logging on to the management interface of the machine, locate and record the IP address of the
machine for use in this procedure.

For more information about setting up and provisioning a physical machine, see IaaS Configuration for
Physical Machines.
Procedure
1

Select Infrastructure > Machines > Managed Machines.

2

Locate the hypervisor provisioned physical machine.

3

Select Join to Cluster in the drop-down menu.

4

Select an endpoint in the Endpoint drop-down menu.
This is the vSphere endpoint for the vCenter Server instance where the cluster exists.

5

Select the cluster from the Cluster drop-down menu.
This menu contains all clusters discovered in the vCenter Server instance by the most recent data
collection from the selected endpoint.

6

Type the user name for the ESXi or ESX instance deployed on the hypervisor provisioned machine in
the Host username text box.
The user account must allow vRealize Automation to add the machine to the vCenter Server instance.

7
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Type the password for the ESXi or ESX instance deployed on the hypervisor provisioned machine in the
Host password text box.
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8

Type the IP address of the hypervisor provisioned physical machine in the Host IP address text box.
This is the IP address you found with the management interface when you connected the hypervisor
provisioned physical machine to its endpoint.

9

If your site uses host profiles in ESX, select the Apply cluster host profile check box.

10

(Optional) Select the Leave compute resource in maintenance mode check box to add the host to the
cluster in maintenance mode without activating it.

11

Click OK.

The hypervisor appears as a host attached to the targeted cluster in the vCenter Server instance.
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Managing Multi-Machine Services

8

The machine owner or fabric administrator can view and manage multi-machine services and their
component machines.
After the multi-machine service is provisioned, the machine owner, or fabric administrator, can perform the
following machine actions:
n

Add components

n

Edit provisioned machines

n

Change lease information

n

Power off, reset, restart, and shut down

n

View details such as status, cost, type, expiration date, and business group name

Reprovisioning is not available at the multi-machine service level. You can reprovision individual
component machines.
This chapter includes the following topics:
n

“Add Component Machines to a Multi-Machine Service,” on page 61

n

“Edit Custom Properties,” on page 62

n

“Determining Multi-Machine Service Status,” on page 63

n

“Power Options for Multi-Machine Services,” on page 63

Add Component Machines to a Multi-Machine Service
You can add component machines to the multi-machine service in the maximum number of allowed
machines.
Prerequisites
Log in to the vRealize Automation console as a fabric administrator.
You can also log in as an entitled user who owns a multi-machine service.
Procedure
1

Select Items > Machines.
A list of provisioned machines appears, including machine information such as status and platform
type.
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2

3

Select Add Component from the Actions drop-down menu of a multi-machine item.
n

Selection options differ from those that are available when you request a new machine.

n

Components that are at their maximum capacity are disabled in the selection menu.

n

Components that are not at their maximum capacity are selectable but you can only add machines
up to the maximum specified capacity.

n

The property tab is not available to group managers.

Review the information in the summary table and click OK.

Edit Custom Properties
A machine owner or fabric administrator can add, change, or delete custom properties for a provisioned
machine.
Prerequisites
Log in to the vRealize Automation console as a tenant administrator or business group manager.
You can also log in as a machine owner.
Procedure
1

Select Items > Machines.
A list of provisioned machines appears, including machine information such as status and platform
type.

2

In the machine name row, click the down arrow in the Actions column.
n

For a multi-machine service, click View Details to view the details of the multi-machine service.

n

For a multi-machine service, click View Components to display the service's component machines.

Alternatively, click the machine name to display its Item Details page.
The Actions menu is also available from the machine's Item Details page. The Actions menu for
component machines is only available from the component machine's Item Details page.
3

Select Edit from the Actions drop-down menu.

4

Click the Properties tab.

5

(Optional) Add a new property.
a

Type a name for the property.

c

(Optional) Type a value for the property.

d

(Optional) Indicate whether the property is to be encrypted.

e

(Optional) Indicate whether a user should be prompted for additional information.
Click the Save icon (

).

(Optional) Edit an existing property.
a
b
c
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).

b

f
6

Click the New Property icon (

Click the Edit icon (

) next to the property to edit.

Make any necessary changes.
Click the Save icon (

).
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7

(Optional) Delete a property.
a

Click the Delete icon (

) next to the property to delete.

A confirmation prompt appears.
b
8

Click OK to remove the property.

When you are finished, click OK.

Determining Multi-Machine Service Status
A multi-machine service has a status of on or off, and is considered healthy if at least the minimum number
of machines for each component type are powered on.
The status of the multi-machine service is based on the power state of its component machines.
When the number of machines that are powered on for a component type is lower than the minimum, the
multi-machine service is considered unhealthy and its state is set to off.
Multi-machine service requests are reported as successful even if one or more of the component machine
requests fail. You can find details about the full or partial success of a multi-machine service request on the
Requests and Infrastructure tabs.

View Machine Status
A machine owner or fabric administrator can determine if a machine is powered on or off.
Procedure
1

Log in to the vRealize Automation console as a machine owner or fabric administrator.

2

Select Items > Machines.
A list of provisioned machines appears, including machine information such as status and platform
type.

Power Options for Multi-Machine Services
The multi-machine service menu provides several options for managing the power status of a multimachine service and all of its component machines.
Table 8‑1. Power Options for Multi-Machine Services
Menu Option

Description

Power On

Power on all component machines in the startup order specified on the multi-machine blueprint.

Power Off

Power off all component machines without shutting down the guest operating systems in the
shutdown order specified on the multi-machine blueprint.

Power Cycle

Power off all component machines in shutdown order, then power on all machines in the startup
order.

Reboot

Shut down all component machines, including guest operating systems, in shutdown order, then
power on all machines in the startup order.

Shut Down

Shut down the guest operating system and power off all component machines in the shutdown
order specified in the multi-machine blueprint.

If a multi-machine service has multiple machines of the same component type, all machines of that type are
powered on before machines of the next component type in the startup order and shutdown order.
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Component Machines

9

A machine owner can perform tasks on a provisioned vApp machine.
A fabric administrator or business group owner can change the owner of a component machine. This
updates the owner for all component machines in the vApp.
Leases are controlled at the parent level, which affects the component machines. Lease operations such as
change, extend, and expire are not available for individual component machines.
For more information about managing machines, see Tenant Administration.
This chapter includes the following topics:
n

“Determining vApp Status,” on page 65

n

“Connect Remotely to a Virtual Machine,” on page 65

Determining vApp Status
A machine owner or fabric administrator can determine if a machine is powered on or off.
A vApp has a status of on or off, and is considered healthy if its components are powered on. When one or
more component machines are powered off, the vApp is considered unhealthy and its status is set to off.
The vApp status is updated based on the power state of its component machines.
The vApp machine list displays the name, status, platform type, and description of each vApp. It also
displays their expiration and destruction dates. Additional columns can be displayed.

Connect Remotely to a Virtual Machine
A machine owner, tenant administrator, or business group manager can connect remotely to a virtual
machine from the vRealize Automation console.
Prerequisites
n

Log in to the vRealize Automation console as a machine owner, tenant administrator, or business
group manager.

n

Verify that the provisioned vApp machine and its vApp component machines are powered on.

Procedure
1

Select Items > Application Deployment.

2

Click Actions in the machine name row or select the machine and click Actions on its machine page.
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3

Select the remote connection method.
n

Select Connect Using RDP to connect by using RDP.

n

Select Connect to remote console to connect by using VMware Remote Console.

Respond to any prompts.

66

4

Click Connect and log in to the machine as directed.

5

When finished, log out and close the browser window.
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Configuring Remote Consoles for
vSphere with Untrusted SSL
Certificates

10

If your vRealize Automation deployment uses untrusted certificates, before you can use remote consoles
with VMRC, you must configure your client browser to trust the certificate, The steps to do this vary by
browser.
If vRealize Automation is configured with a trusted SSL certificate for your environment, then VMRC does
not require additional configuration on client browsers. When a vRealize Appliance certificate is replaced
and is a trusted certificate, there is no need to update certificate information for the Web browser client.
If you want to replace the certificate, see the topic on replacing a vRealize Appliance certificate in the System
Administration guide for vRealize Automation.
Remote connections using VMRC for machines provisioned on vSphere are secured by vRealize Appliance
certificates through a proxy console. VMRC requires WebSockets support in the browser and browsers must
trust the vRealize Appliance certificate. The certificate can be obtained by going to the root-level virtual
appliance at an address of the form https://vra-va.eng.mycompany.com/.
For information about support requirements for browsers and vSphere, see the VMware vRealize Support
Matrix.
This chapter includes the following topics:
n

“Configure Firefox to Trust a Certificate for vRealize Automation,” on page 67

n

“Configure Internet Explorer to Trust a Certificate for vRealize Automation,” on page 68

n

“Configure Chrome to Trust a Certificate for vRealize Appliance,” on page 69

Configure Firefox to Trust a Certificate for vRealize Automation
Untrusted vRealize Appliance certificates must be manually imported to client browsers to support VMware
Remote Console on clients provisioned on vSphere.
For information about supported versions of Firefox, see the VMware vRealize Support Matrix on the VMware
Web site.
Note If vRealize Automation is configured with a trusted SSL certificate for your environment, then
VMRC does not require additional configuration on client browsers.
Procedure
1

In a Firefox browser, log in to the vRealize Appliance.
A message appears saying that the certificate is not trusted.

2
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3

Click More Information and click the Security tab on the Page Info page..

4

Select a certificate from the Certificate Hierarchy pane.
Option

Action

Certificate Authority issued
certificates

Select the top-level vRealize Automation certificate.

Self-signed certificates

Select the vRealize Automation certificate.

5

Click Export.

6

Configure the certificate information in the Save Certificate To File dialog box.
a

Enter a certificate name in the Save As text box. The certificate name must end in .crt, .cert,
or .cer.

b

Select a location in which to save the file.

c

Select X.509 Certificate (PEM) as the format.

7

Click Save.

8

Click the Authorities tab in the Certificate Management dialog box.
Option

Action

Windows

Select Preference > Advanced > Certificates from the Firefox menu.

iOS

Select Preference > Advanced > Certificates from the Firefox menu and
click View Certificates.

9

Click the Authorities tab and click Import.

10

Select the certificate file you saved earlier and click Open in the dialog box.

11

Edit the trust settings.

12

Option

Action

self-signed certificates

Select This certificate can identify websites.

Certificates issued by a Certificate
Authority

Select Trust this CA to identify websites.

Click OK and restart the browser.

You can connect to the remote console without certificate errors.

Configure Internet Explorer to Trust a Certificate for
vRealize Automation
Untrusted vRealize Appliance certificates must be manually imported to client browsers to support VMware
Remote Console on clients provisioned on vSphere.
Note If vRealize Automation is configured with a trusted SSL certificate for your environment, then
VMRC does not require additional configuration on client browsers.
The steps in this procedure apply for self-signed certificates and certificates issued by a Certificate
Authority.
For information about supported versions of Internet Explorer, see the VMware vRealize Support Matrix on
the VMware Web site.
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Procedure
1

In an Internet Explorer browser, log in to the vRealize Appliance.

2

Click View Certificate on the certificate error message that appears in the browser address bar.

3

Click the General tab of the Certificate Information window..

4

Verify that the information about the certificate is correct and click Install Certificate.

5

Select Place all certificates in the following store in the Certificate Store dialog box.

6

Click Browse to locate the certificate store.

7

Select Trusted Root Certification Authority and click OK.

8

Click Next on the Certificate Store dialog box.

9

Click Yes in the Security Warning dialog box to install the certificate.

10

Restart the browser.

You can connect to the remote console without certificate errors.

Configure Chrome to Trust a Certificate for vRealize Appliance
Untrusted vRealize Appliance certificates must be manually imported to client browsers to support VMware
Remote Console on clients provisioned on vSphere.
For information about supported versions of Chrome, see the VMware vRealize Support Matrix on the
VMware Web site.
Note If vRealize Automation is configured with a trusted SSL certificate for your environment, then
VMRC does not require additional configuration on client browsers.
On Windows, Chrome and Internet Explorer use the same certificate store. This means that certificates that
are trusted by Internet Explorer are also trusted by Chrome. To establish trusted certificates for Chrome,
import them through Internet Explorer. For information about this procedure, see “Configure Internet
Explorer to Trust a Certificate for vRealize Automation,” on page 68.
When you complete the procedure, restart Chrome.
To permanently trust a certificate on the Macintosh operating system, download the certificate file and
install the certificate as trusted in your certificate management tool.
Procedure
1

In a Chrome browser, log in to the vRealize Appliance.

2

Click the icon in the address bar.

3

Click the certificate information link.

4

Save the certificate by dragging the certificate icon to the desktop.

5

Start the Keychain Access application.

6

Select File > Import Items.

7

On the Keychain Access screen, select the certificate file you saved earlier.
Set the value of Destination Key to System.

8

Click Open to import the certificate.

9

Restart the browser.
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Install the VMRC Plug-in for vApps on
vCloud Director

11

You can enable remote console capabilities through VMware Remote Console (VMRC) when you provision
machines with vApps for vCloud Director.
The first time you use this feature, you must install the VMRC plug-in on client browsers.
Procedure
1

Select Connect to Remote Console from the Actions menu on the Items tab of the vRealize Automation
console.
If the VMRC plug-in is not present or is disabled, you are prompted to download it.

2

Enable pop-ups if prompted.

3

When you see the following message, click the link for your operating system to download the
installation program.
VMRC Plug-in is not installed or is disabled by your browser.
To install, download and run the installation program for your
operating system: Windows, Linux 32-bit, or Linux 64-bit.

4

Close all browsers.

5

Select the installation program and right-click.

6

On Windows, select Run as Administrator and install the plug-in.

7

Reopen a browser.

8

Log in to vRealize Automation.

9

Select Allow user to activate remote console at the prompt.

VMRC functionality is available when you select Connect to Remote Console from the Actions Menu.
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Running Actions for Provisioned
Resources

12

Items that you provisioned using vRealize Automation might have actions that you can run on those items.
The configured actions that are available for a provisioned items appear in the Actions menu for the selected
resource on the Items tab.
The actions that are available for a provisioned resource depend on the type of resource, how the action was
configured and made available for provisioned items, and the operational state of the item.
If the item was provisioned using an IaaS machine blueprint, the list of available actions is determined by
what was selected on the Actions tab when the blueprint was created, and then by what is applicable based
on machine type or state.
If the item was provisioned using an Advanced Services blueprint, the resource actions must be created,
published, and entitled in the same service that is used to provision the item. The list of available actions is
determined by the item type and the current state of the item.
The available actions for an item that was provisioned as an IaaS machine might also include Advanced
Services resource actions if the actions are mapped to the item.
This chapter includes the following topics:
n

“Action Menu Options for Virtual, Physical, and Cloud Machines,” on page 73

n

“Action Menu Options for Container and Component Machines,” on page 74

n

“Troubleshooting Missing Actions in the Resource Actions Menu,” on page 76

Action Menu Options for Virtual, Physical, and Cloud Machines
You can perform actions on a provisioned machine relative to its status as a Virtual, Physical, or Cloud
machine.
The options you see on the Action menu for your provisioned machine include actions that were specified
on the machine's blueprint, and might include custom menu operations created by your service architects.
You only see options that your tenant administrator or business group manager entitled you to use.
For information about actions, see Foundations and Concepts. For information about creating resource actions
to provide users with custom menu operations, see Advanced Service Design.
Table 12‑1. Action Menu Options Available on the Machine Page from the Items Tab
Connect using RDP

Connect to the selected machine using
Microsoft Remote Desktop Protocol.

Connect using SSH

Connect to the selected machine using SSH.
This option requires that the Machine.SSH custom
property is included, and set to true, in the machine
blueprint's build profile or Properties page.
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Table 12‑1. Action Menu Options Available on the Machine Page from the Items Tab (Continued)
Connect to remote console

Connect to the selected machine using
VMware Remote Console.

Destroy

Destroy a machine.
Machines are destroyed when their lease expires.
This action is not available for physical machines.

Decommission

Decommission a physical machine.
Physical machines are decommissioned when their lease
expires.
This action is only available for physical machines.

Change Lease

Change the machine's lease duration period.

Expire

Terminate the machine's lease.

Reconfigure
(vSphere machines, SCVMM machines, and vApp
component machines only)

A business group manager, support user, or machine
owner can perform the following tasks:
n Reconfigure CPU or memory
n (vSphere and vApp only) Reconfigure network and
storage
n Change description
n Add, edit, and delete properties
n Reconfigure shutdown
Business group managers and support users can change
ownership of a machine.

Power On

Power on the machine.
if the machine was suspended, normal operation resumes
from the point at which the machine was suspended.

Power Off

Power off the machine without shutting down the guest
operating system.

Power Cycle

Power off the machine, then power it back on.

Reboot

Shut down the machine, then power it back on.

Shut Down

Shut down the guest operating system and power off the
machine.

Suspend

Pause the machine so that it cannot be used and does not
consume any system resources other than the storage it is
currently using.

Action Menu Options for Container and Component Machines
You can perform actions on a provisioned machine relative to its status as a container or a component
machine.
The options you see on the Action menu for your provisioned machine include actions that were specified
on the machine's blueprint, and might include custom menu operations created by your service architects.
You only see options that your tenant administrator or business group manager entitled you to use.
For information about actions, see Foundations and Concepts. For information about creating resource actions
to provide users with custom menu operations, see Advanced Service Design.
Performing an operation such as destroy, expire, or a power operation affects the vApp or Multi-Machine
service and its component machines.
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Table 12‑2. Action Menu Options Available by Displaying the Machine Page on the Items Tab
vApp or Multi-Machine Container
Machine

vApp or Multi-Machine Component
Machine

Connect using RDP

Connect to the selected machine
using
Microsoft Remote Desktop Protocol.

Connect to the selected machine using
Microsoft Remote Desktop Protocol.

Connect using SSH

Connect to the selected machine
using SSH.
This option requires that the
Machine.SSH custom property is
included, and set to true, in the
machine blueprint's build profile or
Properties page.

Connect to the selected machine using
SSH.
This option requires that the
Machine.SSH custom property is
included, and set to true, in the
machine blueprint's build profile or
Properties page.

Connect to remote console

Connect to the selected machine by
using VMware Remote Console or
WebMKS.

Connect to the selected machine by
using VMware Remote Console. or
WebMKS.

Destroy

Destroy a vApp and component
machines.
Machines are destroyed when their
lease expires.

Not available.

Change Lease

Change lease, in
vRealize Automation only.
The vApp in vCloud Director always
has an unlimited lease and is
unaffected.

Not available.

Expire

The vApp machine and its
component machines are destroyed.

Not available.

Reconfigure
(vSphere machines and vApp
component machines only)

A business group manager, support
user, or machine owner can perform
the following tasks on a vSphere
machine or vApp container machine:
n Change description
n Add, edit, and delete properties
Business group managers and
support users can also change the
owner of a machine.

A business group manager, support
user, or machine owner can perform
the following tasks on a vSphere
machine or vApp component machine:
n Change description
n Reconfigure CPU, memory,
network, and disk settings
n Add, edit, and delete properties
n Reconfigure shutdown
Business group managers and support
users can also change the owner of a
machine.

Power On

Power on the vApp and all its vApp
component machines in the startup
order specified in the vApp template.
if the machine was suspended,
normal operation resumes from the
point at which the machine was
suspended.

Power on the machine.
if the machine was suspended, normal
operation resumes from the point at
which the machine was suspended.

Power Off

Power off the vApp and all its vApp
component machines, without
shutting down the guest operating
system, in the shutdown order
specified in the vApp template.

Power off the machine without
shutting down the guest operating
system.

Power Cycle

Power off the vApp and all its vApp
component machines in shutdown
order, then power on the vApp and
all its vApp component machines in
the startup order.

Power off the machine, then power it
back on.

Menu Option
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Table 12‑2. Action Menu Options Available by Displaying the Machine Page on the Items Tab (Continued)
vApp or Multi-Machine Container
Machine

vApp or Multi-Machine Component
Machine

Reboot

Shut down the vApp and all its vApp
component machines in shutdown
order, then power on the vApp and
all its vApp component machines in
the startup order.

Shut down the machine, then power it
back on.

Shut Down

Shut down the guest operating
system and power off the vApp and
all its vApp component machines in
the shutdown order specified in the
vApp template.

Shut down the guest operating system
and power off the machine.

Suspend

Pause the machine so that it cannot
be used and does not consume any
system resources other than the
storage it is currently using.

Pause the machine so that it cannot be
used and does not consume any
system resources other than the
storage it is currently using.

Menu Option

Troubleshooting Missing Actions in the Resource Actions Menu
As a machine or resource owner, you do not see all entitled actions for a provisioned item.
Problem
In an environment where you know that an action was entitled for your user or business group, you expect
to see all actions when you select an item in your Items list.
Cause
The availability of actions depends on the type of provisioned resource, operational state of the resource,
and how it was configured and made available. The following list provides some reasons why you do not
see all configured actions.
n

The action is not applicable based on the current state of the provisioned resource. For example, Power
Off is available only when the machine is powered on.

n

The action is not applicable to the selected item type. If the item does not support the action, it does not
appear in the list. For example, the Take Snapshot action is not available for a physical machine, and the
Connect by Using RDP action is not available if the selected item is a Linux machine.

n

The action is applicable for the provisioned resource type, but the action is disabled in the
Infrastructure blueprint. If the action is disabled, it never appears as an available action for any of the
items that were provisioned using the blueprint.

n

The action is not entitled for the service. Only entitled actions, either as part of an Infrastructure
blueprint or as an Advanced Services resource action, can appear in the Actions menu.

n

The action is created as an Advanced Services resource action but was not entitled for the service. Only
entitled actions appear in the Actions menu.

n

The action might be limited based on the configured target criteria for Advanced Services resource
actions or resource mappings to provisioned IaaS machines.

Solution
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n

Verify that the action is applicable to the provisioned resource or the state of the resource.

n

Verify that the action is configured and entitled for the service that provisioned the resource.

VMware, Inc.

Index

A

D

actions
provisioned resources 73
troubleshooting 76
adding 22
approval form
configuring 26
custom property 26
system property 26
approval policies
copying 26
creating 24
deactivating 27
general information 24
post-approval level 25
pre-approval level 25
updating 26
approvals, overview 23

deleting, identity stores 17

B
blueprints, associating a service 23
branding, configuring 9

C
catalog items
adding in a service 22
associating a service 23
removing from a service 22
catalogs, managing 21
chargeback
calculations 36
reports 35
Chrome browser, configure for remote console
use 69
clusters, joining 58
cost, calculation 36–38
cost profiles
assigning 55
chargeback report calculations 36
chargeback reports 35
costs
calculation 37
during request and provisioning life cycle 37
custom properties
editing 62
reconfiguring virtual machines with 47
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E
email servers
adding inbound 13
adding outbound 12, 14
override global 14
reverting to default servers 16
emails, subscribing to notifications 16
endpoints, connecting a physical machine 57
endpoints, physical 53
entitlements
adding 28
adding a service 29
adding services 29
adding a catalog item 29
adding a resource action 29
adding an item 29
adding catalog items 30
adding resource actions 31
creating 28
prioritizing 32
users and groups 19

F
Firefox, configuring certificates 67

G
goal navigator, using 8
groups, creating custom groups 18

H
hardware details, editing 54

I
identity stores
adding 17
deleting 17
Internet Explorer, configure for remote console
use 68

L
leases
managing 40
See also machine leases
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R

machine cost, See cost
machine leases, managing 39
machines
editing hardware details 54
physical 53
requesting machine actions 73, 74
viewing status 63
virtual 45
Managed machines, viewing vApp status 65
Metrics providers, configuring vRealize
Operations Manager 40
multi-machine services
determining status 63
managing leases 40
managing machines 63
power options 63
viewing and editing provisioned machines 61
multi-machine services, adding component
machines 61

reclamation, overview 40
reclamation requests
sending 41
tracking 43
reconfigure
adding a network adapter 48
adding a storage volume 47
adding custom properties 47
changing system memory 46
changing the size of a storage volume 47
deleting a storage volume 47
editing a network adapter 48
monitoring the workflow 50
removing a network adapter 48
scheduling the start of 49
specifying number of CPUs 46
specifying the power option for 49
starting the operation 46
states of operation 50
ReconfigureVM Generic workflow 50
reports
adding 33
chargeback 35
chargeback calculation 36
configuring layout 34
exporting data 34
IaaS Capacity Usage by Blueprint 35
IaaS Capacity Usage by Compute
Resource 35
IaaS Capacity Usage by Group 35
IaaS Capacity Usage by Owner 35
IaaS Reclamation Savings by Group 35
IaaS Reclamation Savings by Owner 35
My Trips 35
resource 33, 35
reservations
changing virtual machine 50
physical 54
reserved machines, importing 56
resource actions, troubleshooting 76
resources, monitoring usage 33
resources actions, provisioned resources 73
roles
assigning to custom groups 18
assigning user roles 18
managing user roles 17

N
notifications
adding inbound email servers 13
adding outbound email servers 12, 14
configuring 11
configuring scenarios 15
enabling 15
overriding default inbound server 14
overriding default outbound server 14
reverting to default servers 16
subscribing 16

O
override global, email servers 14

P
physical endpoints 53
physical machines
assigning a cost profile 55
connecting endpoints 57
importing 56
managing 53
provisioning 53, 55
reservations 54
post-approval levels, creating 25
power option, multi-machine services 63
pre-approval levels, creating 25
provisioned machines, reconfiguring 46

S
service catalog items, removing 22
services
associating blueprints 23
associating catalog items 23
creating 21
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snapshot, virtual machines 51

T
troubleshooting, missing actions on the Items
tab 76

U
updated information 7
users
granting user access 18
managing 17
users and groups, managing entitlements 19

V
vApp virtual machines, connecting remotely
to 65
vApps
accessing vApp management tasks 65
viewing on/off status 65
virtual machines
changing reservations 50
reconfiguring 45
VMRC plug-in, installling 71
VMware Remote Console, connecting remotely
to a vApp machine 65
vRealize Operations Manager, configuring
metrics provider 40
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