Before you run the upgrade, review the following prerequisites.

System Configuration Requirements

Make sure the following system requirements are met before you begin an upgrade.

  • Verify that you are following a supported upgrade path. See Upgrading vRealize Automation for a list of supported upgrade paths.

  • Verify that all appliances and servers that are part of your deployment meet the system requirements for the version you are upgrading to. See the vRealize Automation Support Matrix athttps://www.vmware.com/support/pubs/vcac-pubs.html.

  • Consult the VMware Product Interoperability Matrix on the VMware Web site for information about compatibility with other VMware products.

  • Verify that the vRealize Automation you are upgrading from is in stable working condition. Correct any problems before upgrading.

  • If you are upgrading from vRealize Automation 6.2.x, record your vCloud Suite license key if you used it for the vRealize Automation installation you are upgrading from. Upon upgrade, existing license keys are removed from the database. You do not need to do this task if you are upgrading from vRealize Automation 7.x.

Hardware Configuration Requirements

Make sure the following hardware requirements are met before you begin an upgrade.

  • You must create a disk with at least 50 GB of space and 18 GB of RAM space before you download the upgrade. See Increase vCenter Server Hardware Resources for Upgrade.

    If the virtual machine is on vCloud Networking and Security, you might need to allocate more RAM space.

    If you have two disks in your vRealize Automation appliance, you must add a Disk 3 with 25 GB and a Disk 4 with 50 GB of space. The virtual appliance must have Disk 3 and Disk 4 for the upgrade process to succeed.

  • Your CPU must have four virtual sockets and one core. See Increase vCenter Server Hardware Resources for Upgrade.

  • Your primary IaaS Web site, Microsoft SQL database, and Model Manager node must have the Microsoft .NET Framework 4.5.2 version and at least 5 GB of free disk space.

  • Your primary IaaS Web site, Microsoft SQL database, and Model Manager node must have Java 8, update 91, 64 bit, jdk-8u91-windows-x64.exe, installed. After you install Java, you must set the environment variable, JAVA_HOME, to the new version on each server node.

  • You must have at least 5.3 GB of free disk space on the root partition of each vRealize Automation appliance to download and run the upgrade.

  • Check the /storage/log subfolder and remove any older archived ZIP files to clean up space.

General Prerequisites

Verify that the following prerequisites are finished before you begin an upgrade.

  • You have access to an Active Directory account with a username@domain format and permissions to bind to the directory.

    Note:

    Identity Provider from OpenLDAP is not migrated when you upgrade from vRealize Automation 6.2.x versions.

  • You have access to an account with a SAMaccountName format and sufficient privileges to join the system to the domain by creating a computer object dynamically or to merge into a pre-created object.

  • You have access to all databases and all load balancers impacted by or participating in the vRealize Automation upgrade.

  • You make the system unavailable to users while you perform the upgrade.

  • You disable any applications that query vRealize Automation.

  • Verify that Microsoft Distributed Transaction Coordinator (MSDTC) is enabled on all vRealize Automation and associated SQL servers. For instructions, see the VMware Knowledge Base article Various tasks fail after upgrading or migrating to VMware vCloud Automation Center (vCAC) 6.1.x (2089503) at http://kb.vmware.com/kb/2089503.

  • If your site uses an external vRealize Orchestrator appliance, and your deployment uses an external vRealize Orchestrator appliance that is connected to the Identity Appliance, upgrade vRealize Orchestrator before you upgrade vRealize Automation.

  • If you are upgrading a distributed environment configured with an embedded PostgreSQL database, examine the files in the pgdata directory on the master host before you upgrade the replica hosts. Navigate to the PostgreSQL data folder on the master host at /var/vmware/vpostgres/current/pgdata/. Close any opened files in the pgdata directory and remove any files with a .swp suffix.

  • If you installed a Common Components Catalog component, you must uninstall it before you upgrade. For information about how to uninstall, install, and upgrade Common Components Catalog components, see the Common Components Catalog Installation Guide.