You can install vRealize Automation for the first time, or you can upgrade or migrate your current environment to the latest version. To determine your supported upgrade or migration path, locate your current vCloud Automation Center or vRealize Automation version in the Choosing Your Upgrade or Migration Path table.

Note:

New vRealize Automation features introduce several enhancements along with the ability to upgrade or migrate to the new version. For recommendations and guidance before you begin the upgrade process, visit the vRealize Automation Upgrade Assistance Program web page at http://www.vmware.com/products/vrealize-automation/upgrade-center before you begin the upgrade process.

You can upgrade your current vRealize Automation environment using one of the following methods.

  • Upgrade. An in-place upgrade of your current vRealize Automation 6.2.x or 7.x environment. Upgrade is a multi-stage process in which you perform procedures in a particular order on the various components in your environment.

  • Migration. A side-by-side upgrade of your current vRealize Automation 6.2.x environment. Migration moves the data in your current vRealize Automation 6.2.x environment to a new 7.1 environment that mirrors your current environment. Migration does not change your current 6.2.x environment. You cannot use migration to upgrade a vRealize Automation 7 or 7.0.1 environment to 7.1. If your current environment is integrated with vCloud Director, vCloud Air or has physical endpoints, you must use migration to upgrade. Migration removes all unsupported endpoints and everything associated with them in the 7.1 environment.

Table 1. Choosing Your Upgrade or Migration Path

Your Currently Installed Version

How to upgrade or migrate to the latest vRealize Automation

None

If you have never installed vRealize Automation before, see Installing vRealize Automation.

vRealize Automation 7.0 or 7.0.1

See Upgrading from vRealize Automation 7.0 to 7.1.

vRealize Automation 6.2.1, 6.2.2, 6.2.3, or 6.2.4

See Upgrading from vRealize Automation 6.2 to 7.1.

See Migrating from vRealize Automation 6.2.x to 7.1

All other vCloud Automation Center or vRealize Automation versions

You must upgrade to vRealize Automation 6.2.1, 6.2.2, 6.2.3 or 6.2.4. For information about how to upgrade to a version of vRealize Automation supported for upgrade to 7.1, see https://www.vmware.com/support/pubs/vcac-pubs.html.