Your environment must meet some general requirements that support the installation of Distributed Execution Managers (DEMs).

  • Microsoft .NET Framework 4.5.2 is installed.

  • Microsoft PowerShell 2.0, 3.0, or 4.0. Some vRealize Automation upgrades or migrations might require you to install an older or newer PowerShell version, in addition to the one that you are currently running.

  • SecondaryLogOnService is running.

  • No firewalls between DEM host and the Windows server, or ports opened as described in vRealize Automation Port Requirements.

Servers that host DEM Worker instances might have additional requirements depending on the provisioning resources that they interact with.