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IaaS Integration for BMC BladeLogic

IaaS Integration for BMC BladeLogic provides information about integrating BMC BladeLogic
Configuration Manager with VMware vRealize ™ Automation.

This documentation provides information on how you can enable deployment of BMC BladeLogic
software jobs on machines provisioned by vRealize Automation.

Note   Not all features and capabilities of vRealize Automation are available in all editions. For a
comparison of feature sets in each edition, see https://www.vmware.com/products/vrealize-automation/.

Intended Audience
This information is intended for system administrators, tenant administrators, fabric administrators, and
business group managers of vRealize Automation. This content is written for experienced Windows or
Linux system administrators who are familiar with virtualization technology and the basic concepts
described in Foundations and Concepts.

VMware Technical Publications Glossary
VMware Technical Publications provides a glossary of terms that might be unfamiliar to you. For
definitions of terms as they are used in VMware technical documentation, go to 
http://www.vmware.com/support/pubs.
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Updated Information

This IaaS Integration for BMC BladeLogic is updated with each release of the product or when necessary.

This table provides the update history of the IaaS Integration for BMC BladeLogic.

Revision Description

001843-01 Miscellaneous minor changes.

001843-00 Initial release.
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BMC BladeLogic Configuration
Manager Overview 1
You can integrate BMC BladeLogic with vRealize Automation to enable deployment of BMC BladeLogic
software jobs on machines provisioned by vRealize Automation. Custom properties can be used to
specify whether these jobs can be selected by the requesting user on a per-machine basis or applied to
all machines provisioned from a particular blueprint.

The following is a high-level overview of the requirements for integrating BMC BladeLogic Configuration
Manager with vRealize Automation:

n A system administrator verifies that BMC BladeLogic Operations Manger 7.6.0.115 or BMC Server
Automation Console 8.2 is installed on the same host as your external provisioning integration (EPI)
agent.

n A system administrator sets the PowerShell execution policy to RemoteSigned. See Chapter 2 Set
the PowerShell Execution Policy to RemoteSigned.

n A system administrator installs at least one EPI agent. See Chapter 3 Install an EPI Agent for BMC
BladeLogic.

n A system administrator configures how software jobs are deployed. See Chapter 5 Integrate BMC
BladeLogic.

n A tenant administrator or a business group manager creates a blueprint that enables the deployment
of software jobs. See Chapter 6 Creating BMC BladeLogic Blueprints.
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Set the PowerShell Execution
Policy to RemoteSigned 2
You must set the PowerShell Execution Policy from Restricted to RemoteSigned or Unrestricted to allow
local PowerShell scripts to be run.

Prerequisites

n Log in as a Windows administrator.

n Verify that Microsoft PowerShell is installed on the installation host before agent installation. The
version required depends on the operating system of the installation host. See Microsoft Help and
Support.

n For more information about PowerShell Execution Policy, run help about_signing or help Set-
ExecutionPolicy at the PowerShell command prompt.

Procedure

1 Select Start > All Programs > Windows PowerShell version > Windows PowerShell.

2 For Remote Signed, run Set-ExecutionPolicy RemoteSigned.

3 For Unrestricted, run Set-ExecutionPolicy Unrestricted.

4 Verify that the command did not produce any errors.

5 Type Exit at the PowerShell command prompt.
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Install an EPI Agent for BMC
BladeLogic 3
A system administrator must install at least one vRealize Automation EPI agent to manage interaction
with BMC BladeLogic. The agent can be installed anywhere, but it must be able to communicate with
vRealize Automation and BMC BladeLogic Configuration Manager.

Prerequisites

n Verify that BMC BladeLogic Operations Manger 7.6.0.115 or BMC Server Automation Console 8.2 is
installed on the same host as your EPI agent.

If the EPI agent is installed before BMC Operations Manager, the agent service must be restarted
after BMC Operations Manager is installed.

n The agent must be installed on Windows Server 2008 SP1, Windows Server 2008 SP2 (32 or 64-bit),
Windows Server 2008 R2 system, or Windows 2012 with .NET 4.5.

n The credentials under which the agent runs must have administrative access to all BMC BladeLogic
hosts with which the agent interacts.

n Log in to the vRealize Automation console as a system administrator.

See Installing vRealize Automation 7.0 for complete information about installing vRealize Automation
agents.

Procedure

1 Select Component Selection on the Installation Type page.

2 Accept the root install location or click Change and select an installation path.

3 Click Next.

4 Log in with administrator privileges for the Windows services on the installation machine.

The service must run on the same installation machine.

5 Click Next.

6 Select EPIPowerShell from the Agent type list.
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7 Enter an identifier for this agent in the Agent name text box.

Maintain a record of the agent name, credentials, endpoint name, and platform instance for each
agent. You need this information to configure endpoints and to add hosts in the future.

Important   Do not duplicate agent names unless you are installing redundant, identically configured
agents for high availability.

Option Description

Redundant agent install Install redundant agents on different servers, but name and configure them
identically to provide high-availability.

Single agent install Select a unique name for this agent.
 

8 Configure a connection to the Manager Service component.

Option Description

If you are using a load balancer Enter the fully qualified domain name and port number of the load balancer for the
Manager Service component. For example,
manager-load-balancer.eng.mycompany.com:443. IP addresses are not
recognized.

With no load balancer Enter the fully qualified domain name and port number of the machine where you
installed the Manager Service component. For example,
manager_service.mycompany.com:443. IP addresses are not recognized.

 
The default port is 443.

9 Configure a connection to the Manager Website component.

Option Description

If you are using a load balancer Enter the fully qualified domain name and port number of the load balancer for the
Manager Website component. For example,
website-load-balancer.eng.mycompany.com:443. IP addresses are not
recognized.

With no load balancer Enter the fully qualified domain name and port number of the machine where you
installed the Manager Website component. For example,
website_component.mycompany.com:443. IP addresses are not recognized.

 
The default port is 443.

10 Click Test to verify connectivity to each host.

11 Select BMC in EPI Type.

12 Select the EPI type.

13 Enter the fully qualified domain name of the managed server in the EPI Server text box.

14 Click Add.

15 Click Next.

16 Click Install to begin the installation.

After several minutes a success message appears.

IaaS Integration for BMC BladeLogic

VMware, Inc.  9



17 Click Next.

18 Click Finish.

What to do next

Chapter 5 Integrate BMC BladeLogic

IaaS Integration for BMC BladeLogic
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Extend the Default Software
Installation Timeout 4
When you install the software for the integration product, the software might take longer to install than the
default 30-minute timeout. You can increase the default timeout to a value that allows the installation to
finish.

Procedure

1 Navigate to the Manager Service installation directory. Typically, this is %System-Drive%\Program
Files x86\VMware\vCAC\Server.

2 Create a backup of the ManagerService.exe.config file.

3 Open the ManagerService.exe.config file and locate the
workflowTimeoutConfigurationSection element and increase the value of the DefaultTimeout
attribute from 30 minutes to your desired limit.

4 Click Save and close the file.

5 Select Start > Administrative Tools > Services, and restart the vRealize Automation service.
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Integrate BMC BladeLogic 5
If a system from which BMC BladeLogic Configuration Manager deploys software is available on the
network and you have installed an EPI agent to interact with it, software can be deployed from it directly
to newly provisioned machines. The requesting user can select which software to deploy or the blueprint
can contain the specific jobs to be deployed on all machines provisioned from that blueprint.

Prerequisites

n Chapter 3 Install an EPI Agent for BMC BladeLogic.

n Log in to the vRealize Automation EPI/BMC Agent host as a system administrator.

n As the system administrator under which the EPI agent is running, log in to the BladeLogic console
to configure the authentication profile to be used and to accept any BladeLogic security certificates,
and then close the console. This prerequisite is required only once.

Procedure

1 Select Start > Administrative Tools > Services, and stop the vRealize Automation EPI/BMC Agent
service.

2 On the EPI agent installation host, which could be the same as the Manager Service host, change to
the EPI agent installation directory, typically %SystemDrive%\Program Files (x86)\VMware\vCAC
Agents\agent_name.

3 Edit every file in the Scripts\nsh folder in the EPI agent directory and under the parameter list
section of each .nsh file, update the values for the following variables. The description of each
variable appears above the variable definitions.

USERNAME_USER=BLAdmin

AUTH_TYPE=SRP

PASSWORD_USER=password

APP_SERVER_HOST=bladelogic.dynamicops.local

ROLE_NAME=BLAdmins
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4 Edit the agent configuration file, VRMAgent.exe.config, in the EPI agent installation directory and
replace CitrixProvisioningUnregister.ps1 with DecomMachine.ps1.

a Locate the following line.

<DynamicOps.Vrm.Agent.EpiPowerShell

  registerScript="CitrixProvisioningRegister. ps1"

  unregisterScript="CitrixProvisioningUnregister.ps1"/>

b Change the line to match the following line.

<DynamicOps.Vrm.Agent.EpiPowerShell

  registerScript="CitrixProvisioningRegister. ps1"

  unregisterScript="DecomMachine.ps1"/>

5 If you intend to provision by cloning with a static IP address assignment, you can enable BMC
BladeLogic registration of provisioned machines by IP address rather than by machine name.

a Edit the files InstallSoftware.ps1 and DecomMachine.ps1 in theScripts folder in the EPI
agent directory and change the line $byip=$false to $byip=$true. edit the files
InstallSoftware.ps1 and DecomMachine.ps1 in the Scripts folder in the EPI agent directory
and change the line $byip=$false to $byip=$true.

b If you enable registration by IP address by making the above change, you must provision by
using static IP address assignment, otherwise, BMC BladeLogic integration fails.

6 Select Start > Administrative Tools > Services to start the EPI/BMC agent service
(vRealize Automation Agent – agentname service).

7 Place all the BMC BladeLogic jobs you want available to be selected by machine requestors or
specified by blueprint architects under a single location within BMC BladeLogic Configuration
Manager, for example, /Utility.

8 Prepare a reference machine and convert it to a template for cloning.

a Install a BMC BladeLogic agent that points to the server on which BMC BladeLogic Configuration
Manager is running.

b Verify that you are able to connect to the agent on the guest and successfully execute jobs as
expected after provisioning.

Tenant administrators and business group managers can now integrate BMC BladeLogic into clone
blueprints. See Add BMC BladeLogic Integration to a Blueprint.

IaaS Integration for BMC BladeLogic
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Creating BMC BladeLogic
Blueprints 6
BMC BladeLogic integration is invoked by adding custom properties for any BMC BladeLogic software
jobs to be deployed on machines provisioned from a blueprint.

Obtain the following information so that tenant administrators and business group managers can include it
in their blueprints:

n The name of the template.

n The name of the customization specification.

n The amount of total storage specified for the template.

n For vCenter Server integrations, the vCenter Server guest operating system version with which
vCenter Server is to create the machine.

This chapter includes the following topics:
n Add BMC BladeLogic Integration to a Blueprint

n Custom Properties for BMC BladeLogic Configuration Manager Integration

Add BMC BladeLogic Integration to a Blueprint
To create a blueprint that enables the deployment of BMC BladeLogic Configuration Manager software
jobs on machines provisioned from it, a tenant administrator or a business group manager must create a
blueprint for provisioning by cloning that includes BMC BladeLogic custom properties.

n Obtain the following information from your fabric administrator:

n The name of the server that hosts BMC BladeLogic.

n The name of the default authentication profile on the BMC BladeLogic server.

n The BMC BladeLogic location of software jobs to be deployed. This must match the appropriate
value of Vrm.Software.IdNNNN.

Prerequisites

n Log in to the vRealize Automation console as a tenant administrator or business group manager.
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n Create a blueprint for cloning by using the template and customization specification provided to you
by your fabric administrator. See IaaS Configuration for Virtual Platforms.

Note   A fabric administrator can create a build profile by using the property set
BMCSoftWareProperties. This makes it easier for tenant administrators and business group
managers to correctly include this information in their blueprints.

n For a list of all required and common BMC BladeLogic custom properties, see Custom Properties for
BMC BladeLogic Configuration Manager Integration.

Procedure

1 Select Design > Blueprints.

2 Locate the clone blueprint that you want to integrate with BMC BladeLogic.

3 In the Actions column, click the down arrow and click Edit.

4 Click the Properties tab.

5 (Optional) Select one or more property groups.

Property groups contain multiple custom properties.

6 (Optional) Add any custom properties to your machine component.

a Click New Property.

b Enter the custom property in the Name text box.

c (Optional) Select the Encrypted check box to encrypt the custom property in the database.

d Enter the value of the custom property in the Value text box.

e (Optional) Select the Prompt user check box to require the user to provide a value when they
request a machine.

If you choose to prompt users for a value, any value you provide for the custom property is
presented to them as the default. If you do not provide a default, users cannot continue with the
machine request until they provide a value for the custom property.

f Click the Save icon ( ).

7 Click OK.

Your blueprint is saved.

What to do next

Publish your blueprint to make it available as a catalog item. See Chapter 7 Publish a Blueprint.

IaaS Integration for BMC BladeLogic
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Custom Properties for BMC BladeLogic Configuration
Manager Integration
vRealize Automation includes custom properties that you can use to provide additional controls for BMC
BladeLogic Configuration Manager integration.

Table 6‑1.  Custom Properties Required for BMC BladeLogic Configuration Manager
Integrations

Custom Property Description

VirtualMachine.EPI.Type Specifies the type of external provisioning infrastructure.

VirtualMachine.Admin.Owner Specifies the user name of the machine owner.

BMC.Software.Install Set to True to enable BMC BladeLogic Configuration Manager
integration.

EPI.Server.Name Specifies the name of the external provisioning infrastructure
server, for example, the name of the server hosting BMC
BladeLogic. If at least one general BMC EPI agent was installed
without specifying a BMC BladeLogic Configuration Manager
host, this value directs the request to the desired server.

If only dedicated BMC EPI agents for specific BMC BladeLogic
Configuration Manager hosts were installed, this value must
exactly match the server name configured for one of these
agents.

BMC.Service.Profile Specifies the name of the default authentication profile on the
BMC BladeLogic server.

BMC.Software.BatchLocation Specifies the location in BMC BladeLogic configuration where
software jobs are deployed. This value must match the
appropriate value of Vrm.Software.IdNNNN. For example, a
valid value could be /Application Deployment.

VMware.VirtualCenter.OperatingSystem Specifies the vCenter Server guest operating system version
(VirtualMachineGuestOsIdentifier) with which
vCenter Server creates the machine. This operating system
version must match the operating system version to be installed
on the provisioned machine. Administrators can create property
groups using one of several property sets, for example,
VMware[OS_Version]Properties, that are predefined to
include the correct VMware.VirtualCenter.OperatingSystem
values. This property is for virtual provisioning.

For related information, see the enumeration type
VirtualMachineGuestOsIdentifier in vSphere API/SDK
Documentation. For a list of currently accepted values, see the
vCenter Server documentation.

IaaS Integration for BMC BladeLogic
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Custom Properties To Make BMC BladeLogic Configuration
Manager Software Jobs Available
Configure BMC BladeLogic Configuration Manager jobs for vRealize Automation integrations. Make all
software jobs available to machine requesters to select from, or specify a software job to apply to all
machines provisioned from the blueprint.

Table 6‑2.  Custom Properties to Make Software Jobs Available

Custom Property Description

LoadSoftware Set to True to enable software install options.

Vrm.Software.IdNNNN Specifies a software job or policy to be applied to all machines
provisioned from the blueprint. Set the value to
job_type=job_path, where job_type is the numeral that
represents the BMC BladeLogic job type and job_path is the
location of the job in BMC BladeLogic, for example
4=/Utility/putty. NNNN is a number from 1000 to 1999. The
first property must start with 1000 and increment in numerical
order for each additional property.

1 — AuditJob
2 — BatchJob
3 — ComplianceJob
4 — DeployJob
5 — FileDeployJob
6 — NSHScriptJob
7 — PatchAnalysisJob
8 — SnapshotJob

Optional Custom Properties for BMC BladeLogic Configuration
Manager Integrations
You can also use optional custom properties that are commonly used with BMC BladeLogic Configuration
Manager blueprints.

Table 6‑3.  Optional Custom Properties for BMC BladeLogic Configuration Manager
Integrations

Property Definition

BMC.AddServer.Delay Specifies the number of seconds to wait before adding the
machine to BMC BladeLogic Configuration Manager. The default
is 30.

BMC.AddServer.Retry Specifies the number of seconds to wait before retrying if the
first attempt to add the machine to BMC BladeLogic
Configuration Manager is unsuccessful. The default is 100.

IaaS Integration for BMC BladeLogic
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Publish a Blueprint 7
You can publish a blueprint for use in machine provisioning and optionally for reuse in another blueprint.
To use the blueprint for requesting machine provisioning, you must entitle the blueprint after publishing it.
Blueprints that are consumed as components in other blueprints do not required entitlement.

Prerequisites

n n Log in to the vRealize Automation console as an infrastructure architect.

n Create a blueprint. See Checklist for Creating vRealize Automation Blueprints.

Procedure

1 Click the Design tab.

2 Click Blueprints.

3 Point to the blueprint to publish and click Publish.

4 Click OK.

The blueprint is published as a catalog item but you must first entitle it to make it available to users in the
service catalog.

What to do next

Add the blueprint to the catalog service and entitle users to request the catalog item for machine
provisioning as defined in the blueprint.
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